(__DBF)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Degree of margin | DegreeOfMarginItemInvLoc |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
@zPrompt=null | mr_Mark_FIFO |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Columns updated | RowUpdatedCols |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL
@zPrompt=null | Term |  |  |  | @DataType=NULL


(BTran2GLDefTargetColumn)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Receiving column | BTran2GLDefTargetColumn | ztString | 40 |  | varchar
Receiving column in table | BTran2GLDefTargetColumnDescr | ztString | 100 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: BTran2GLDefTargetColumn Receiving columns/target columns


(BTran2GLDefTargetTableCol)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Receiving column | BTran2GLDefTargetColumn | ztString | 40 |  | varchar
Receiving table | BTran2GLDefTargetTable | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


(CacheJvsSiteSetting)

Internal, alphanumeric designation for node, e.g. A for the program’s main node and AA, AC, etc, for underlying program nodes.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Priority | JvsSitePriority | ztInteger | 4 |  | int
JvsTypePriority | JvsTypePriority | ztInteger | 5 |  | int
Program node | Node | ztString | 35 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Program | pgm | ztString | 40 |  | nvarchar
Identity | SqlIdentity | ZtLong | 10 |  | int
Window context (site rep) | Wctxt | ztString | 40 |  | nvarchar


(CddJvsInternalLddlIDMasterPrefix)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
@zPrompt=null | JvsInternalLddlIdprefix | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


(ItemRevisionOverview)

Alphanumeric code for the item, BOM, fixed asset, or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Item Revision | ItemRevision | ZtLong | 3 |  | int
@zPrompt=null | ItemRevisionColor | ztString | 50 |  | varchar
No of changes | ItemRevisionNumber | ztInteger | 4 |  | smallint
Table | ItemRevisionTable | ztString | 50 |  | varchar
Type of change | ItemRevisionType | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


(Jeeves_Log_MultiRow_Update_Table)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Object name | ObjectName | ztString | 128 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
SQL sats | SqlStmt | ztString | 255 |  | varchar
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: Jeeves_Log_MultiRow_Update_Table Internal log, multi updates


(Jeeves_SHOWCONTIG)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Actual count | DB_ActualCount | ZtLong | 10 |  | int
Ideal number of extent | DB_BestCount | ZtLong | 10 |  | int
Index defrag done | DB_IndexDefrag_Done | ztBoolean |  |  | char
Index ID | DB_IndexId | ztInteger | 5 |  | smallint
Index name | DB_IndexName | ztString | 255 |  | varchar
Logical fragmentation % | DB_LogicalFragmentation | ZtDecimal73 | 8 | 3 | decimal
Pages | DB_Pages | ZtLong | 10 |  | int
Scan density % | DB_ScanDensity | ZtDecimal73 | 8 | 3 | decimal
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Object no. | ObjectId | ZtLong | 10 |  | int
Object name | ObjectName | ztString | 128 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SqlIdentity | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: Jeeves_SHOWCONTIG DBCC SHOWCONTIG


(JvsSite_Export_Log)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
JvsSite Export LogId | JvsSiteExportLogId | ZtLong | 10 |  | int
Unique ID | JvsSiteUniqueID | ztString | 40 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SQL statement | SQLStmtStr | ztBlob | 1 |  | nvarchar


(JvsSite_Import_Log_SimpBackup)

Sequence number of own nodes, columns, fields etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sequence no. | JvsSeqNo | ZtLong | 10 |  | int
JvsSite Import LogId | JvsSiteImportLogId | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SQL statement | SQLStmtStr | ztBlob | 1 |  | nvarchar
SQL statement | SQLStmtStr_stuff_1 | ztBlob | 1 |  | nvarchar


(JvsSIteLangImportDiff)

Language code.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Language | JvsSiteLangID |  |  |  | @DataType=NULL
Text | JvsSiteLangString |  |  |  | @DataType=NULL
Imported Text | JvsSiteLangStringImport |  |  |  | @DataType=NULL
TextID | JvsSiteTextID |  |  |  | @DataType=NULL


(JvsSIteLangImportDiffTarget)

Language code.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Language | JvsSiteLangID |  |  |  | @DataType=NULL
Text | JvsSiteLangString |  |  |  | @DataType=NULL
Imported Text | JvsSiteLangStringImport |  |  |  | @DataType=NULL
TextID | JvsSiteTextId |  |  |  | @DataType=NULL


(JvsSiteOutputProperty)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
@zPrompt=null | OutputDevId | ztInteger | 5 |  | int
@zPrompt=null | OutputNrOfCopies | ztInteger | 5 |  | int
@zPrompt=null | OutputPgm | ztString | 40 |  | nvarchar
@zPrompt=null | OutputProperties | ztString | 255 |  | nvarchar
@zPrompt=null | OutPutTemplate | ztString | 40 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Columns updated | RowUpdatedCols | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


(NetReqPegging)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
MRP Manufacturing order no | AoNrNE | Jeeves_MONo | 7 |  | bigint
MRP Pos | AoPosNE | ztInteger | 4 |  | smallint
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Req to date (int) | BestBehovDat | ztDate |  |  | datetime
Est disp date | BestBerLevDat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Identitetskolumn | ConnToSqlIdentity | ZtLong | 10 |  | int
Deliv from MRP MO Pos | DelivFromNetMOLine | ztInteger | 5 |  | smallint
Deliv from MRP MO | DelivFromNetMONo | Jeeves_MONo | 7 |  | bigint
Receive to MRP MO Pos | DelivToNetMOLine | ztInteger | 4 |  | smallint
Receive to MRP MO | DelivToNetMONo | Jeeves_MONo | 20 |  | bigint
Receive to MRP MO Op | DelivToNetOpNo | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Receive to MO | InlevTillAoNr | Jeeves_MONo | 7 |  | bigint
Receive to MO Pos | InlevTillAoPos | ztInteger | 4 |  | int
Receive to MO Op | InlevTillOpNr | ztInteger | 3 |  | smallint
Rcvd deliv f CO no. | InlevTillOrderNr | Jeeves_SONo | 20 |  | bigint
Rcvd deliv f order row no. | InlevTillOrdRadNr | ztInteger | 5 |  | int
Rcvd deliv f CO row BOM | InlevTillOrdRadNrStrPos | ztInteger | 5 |  | int
Rcvd deliv f backorder no. | InlevTillOrdRestNr | ztInteger | 5 |  | smallint
Customer | KundNr | ztCompanyNo | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Where | NE_Where | ztString | 255 |  | varchar
Dys btwen deliv and with | NoDaysStockDelivWithdrawal | ztInteger | 5 |  | smallint
Adjust deliv no of days | NRP_AdjDelivNoDays | ztInteger | 5 |  | smallint
Adjust no of days | NRP_AdjNoDays | ztInteger | 5 |  | smallint
Adjust to date | NRP_AdjToDte | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SqlIdentity | ZtLong | 10 |  | int
Requisition | StrDateTimeBIA | ztString | 28 |  | varchar
Deliv from MO | UttagFranAoNr | Jeeves_MONo | 7 |  | bigint
Deliv from MO Pos | UttagFranAoPos | ztInteger | 5 |  | int
ID number | X_IdNr | ZtLong | 10 |  | int
ID row | X_IdRad | ZtLong | 10 |  | int
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: NetReqPegging Pegging MRP


ABC codes (xabc)

Definition of the ABC codes the company applies and each code’s percentage.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
ABC code | ArtABC | ztchar | 1 |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Percentage | Procent | ZtDecimal73 | 7 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xabc ABC codes

    Program: xabcV ABC codes and item turnover


Acceptance status (RemStatus)

Acceptance status description.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Acceptance status | RemJrnlStatus | ztInteger | 2 |  | smallint
Acceptance status descr | RemJrnlStatusDescr | ztString | 80 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: RemStatus Acceptance status


Access levels (xaut)

User access levels. These levels are only used for information only.

The levels are defined in the program 'Access level' (xauth). Users are allocated an access level in the program 'System data person, own co.' (xsy2).

For information about Jeeves approval functions, see the Help for the field 'Group' in the above program (xsy2) and the chapter on approval under System administration.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Access level | authorizecode | ztString | 4 |  | varchar
Behörighetsbeskr | authorizedescr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xauth Access level


Account deposit types (xlki)

Definition of account deposit types used for outgoing payments to suppliers.

The following standard records exist. Do not alter/delete:

Pmt to acct (KontoIns) | Pmt to acct (KontoInsBeskr) | Description
0 | Normal giro BG/PG | Applies for NULL or 0.
1 | Account deposit BG/PG (no notification BG) | Account deposit via BG or bank giro deposit via PG. For more information, see the help section for the field Account with bank (bank account).
2 | Account deposit BG (with notification) | Deposit to account via BG via PG. (As 1 but fixed with notification.) For more information see the help section for the field Account with bank (bank account).
3 | Plus Giro payment BG | Plus Giro payment via BG

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Pmt to acct | KontoIns | ztInteger | 1 |  | smallint
Pmt to acct | KontoInsBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xlki Account deposit types


Account for databasemail (SysMail_Accounts)

The identifier of the profile used to send the message.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mail account descr. | DBM_account_description | ztString | 256 |  | varchar
Email account display | DBM_account_display | ztString | 256 |  | varchar
Email sender address | DBM_account_email_address | ztString | 256 |  | varchar
Account enable ssl | DBM_account_enable_ssl | ztInteger | 5 |  | smallint
Account id | DBM_account_id | ztInteger | 5 |  | smallint
Mail account name | DBM_account_name | ztString | 256 |  | varchar
Email reply address | DBM_account_replyto_address | ztString | 256 |  | varchar
Sequence number | DBM_account_sequence_number | ztInteger | 5 |  | smallint
Mail server name | DBM_account_server_name | ztString | 256 |  | varchar
Mail server port | DBM_account_server_port | ztInteger | 5 |  | smallint
Mail server user name | DBM_account_server_user_name | ztString | 256 |  | varchar
Email servertype | DBM_account_servertype | ztString | 256 |  | varchar
Account credentials | DBM_account_use_default_credentials | ztInteger | 5 |  | smallint
Mail profile id | DBM_profile_id | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: DbMailAccount Mail accounts for database mail


Account interval (BE_VAT_FT)

An interval of accounts used at VAT reporting.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
From account | KtoFrom | ztString | 8 |  | varchar
To account | KtoTom | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Reverse sign | RpOmvTkn | ztBoolean |  |  | char
Grid ID | VATGridid | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: BE_VAT_FT Account interval


Account segment 3 (kb)

Definition of the company's names for cost units (account segment 3) in the chart of accounts. The definition is copied between fiscal years.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
As of date | DatKbarFom | ztDate |  |  | datetime
End date | DatKbarTom | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Replaced by cost unit | ErsattsKostBar | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost unit | Kostbarbeskr | ztString | 30 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Control group project | PrjGrupp | ztString | 6 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: kb Cost unit


Account segment 3 VIEW (vkb)

View of the Kb table (Account segment 3).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost unit | Kostbarbeskr | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: vkb Cost unit (view)


Account segment 3 VIEW 2 (vkb1)

View of the Kb table (Account segment 3).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost unit | Kostbarbeskr | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint


Account segment 3 VIEW 3 (vkb2)

View of the Kb table (Account segment 3).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost unit | Kostbarbeskr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Account segment 4 (k4)

Definition of the company's names for account segment 4 in the chart of accounts. The definition is copied between fiscal years.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Replaced by account segment 4 | ErsattsK4 | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S4 | K4Beskr | ztString | 30 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Control group project | PrjGrupp | ztString | 6 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xK4 S4


Account segment 5 (k5)

Definition of the company's names for account segment 5 in the chart of accounts. The definition is copied between fiscal years.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Replaced by account segment 5 | ErsattsK5 | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S5 | K5Beskr | ztString | 30 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Control group project | PrjGrupp | ztString | 6 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xK5 S5


Account segment 6 (k6)

Definition of the company's names for account segment 6 in the chart of accounts. The definition is copied between fiscal years.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Replaced by account segment 6 | ErsattsK6 | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S6 | K6Beskr | ztString | 30 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Control group project | PrjGrupp | ztString | 6 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xK6 S6


Account segment 7 (k7)

Definition of the company's names for account segment 7 in the chart of accounts. The definition is copied between fiscal years.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
As of date | DatK7Fom | ztDate |  |  | datetime
End date | DatK7Tom | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Replaced by account segment 7 | ErsattsK7 | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S7 | K7Beskr | ztString | 30 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Control group project | PrjGrupp | ztString | 6 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax reduction method | VATMethodReduction | ztInteger | 5 |  | smallint
Display on web | WebAccountMark | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xK7 S7


Account segment 8 (k8)

This table contains the company's designations for account segment 8, if used.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
S8 | K8Beskr | ztString | 30 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char


Account segments 4 (view 2) (Vk41)

View of the K4 table (Account segment 4).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Replaced by account segment 4 | ErsattsK4 | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S4 | K4Beskr | ztString | 30 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char


Account segments 4 (view 3) (vk42)

View of the K4 table (Account segment 4).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Replaced by account segment 4 | ErsattsK4 | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S4 | K4Beskr | ztString | 30 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char


Account segments 4 (view) (vK4)

View of the K4 table (Account segment 4).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Replaced by account segment 4 | ErsattsK4 | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S4 | K4Beskr | ztString | 30 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: vk4 S4 (view)


Account segments 5 (view 2) (vk51)

View of the K5 table (Account segment 5).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Replaced by account segment 5 | ErsattsK5 | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S5 | K5Beskr | ztString | 30 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char


Account segments 5 (view 3) (vk52)

View of the K5 table (Account segment 5).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Replaced by account segment 5 | ErsattsK5 | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S5 | K5Beskr | ztString | 30 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char


Account segments 5 (view) (vK5)

View of the K5 table (Account segment 5).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Replaced by account segment 5 | ErsattsK5 | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S5 | K5Beskr | ztString | 30 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: vk5 S5 (view)


Account segments 6 (view 2) (vk61)

View of the K6 table (Account segment 6).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Replaced by account segment 6 | ErsattsK6 | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S6 | K6Beskr | ztString | 30 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char


Account segments 6 (view 3) (vk62)

View of the K6 table (Account segment 6).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Replaced by account segment 6 | ErsattsK6 | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S6 | K6Beskr | ztString | 30 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char


Account segments 6 (view) (vK6)

View of the K6 table (Account segment 6).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Replaced by account segment 6 | ErsattsK6 | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S6 | K6Beskr | ztString | 30 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: vk6 S6 (view)


Account segments 7 (view 2) (vk71)

View of the K7 table (Account segment 7).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
As of date | DatK7Fom | ztDate |  |  | datetime
End date | DatK7Tom | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Replaced by account segment 7 | ErsattsK7 | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S7 | K7Beskr | ztString | 30 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char


Account segments 7 (view 3) (vk72)

View of the K7 table (Account segment 7).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
As of date | DatK7Fom | ztDate |  |  | datetime
End date | DatK7Tom | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Replaced by account segment 7 | ErsattsK7 | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S7 | K7Beskr | ztString | 30 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char


Account segments 7 (view) (vK7)

View of the K7 table (Account segment 7).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
As of date | DatK7Fom | ztDate |  |  | datetime
End date | DatK7Tom | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Replaced by account segment 7 | ErsattsK7 | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S7 | K7Beskr | ztString | 30 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: vk7 S7 (view)


Account statement, invoices per currency (fhva)

An interim table, used when printing account statements to print one statement per customer and currency.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Amount BCU | amountBCU | ztMoney | 14 | 2 | money
Amount curr | amountFCU | ztMoney | 14 | 2 | money
Accounting date | bokfdat | ztDate |  |  | datetime
Invoice date | faktdat | ztDate |  |  | datetime
Due date | FaktFfDat | ztDate |  |  | datetime
Invoice no. | Faktnr | Jeeves_InvNo | 9 |  | bigint
Invoice type | FakturaTyp | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Payer, company ID | Kundbetalarenr | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Type | Rowtype2 | ztString | 50 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Identity | sqlIdentity | ZtLong | 10 |  | int
Currency | Valkod | ztString | 3 |  | varchar
Invoice amount, curr | Vb_Faktsum | ztMoney | 14 | 2 | money
Outst invc amt, curr | VbFaktRest | ztMoney | 14 | 2 | money
Paid amount, curr | VbInbBel | ztMoney | 14 | 2 | money
Voucher no. | vernr | Jeeves_VchrNo | 9 |  | bigint


Account translation (kot)

Translation table of account at auto posting and auto allocation in the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allocate to account | FordTillKto | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
Translation group | OversattnGrp | ztString | 8 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xKot Translate accounts


Accounting users (pr)

Personal details of own employees. There must be a record in this table for each person authorized to enter data in any of the accounting modules.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval chain time | AppChainTime | ztInteger | 5 |  | smallint
Arrival sign | ArrivalSign | ztBoolean |  |  | char
Approval chain | Attkedja | ztInteger | 5 |  | smallint
Department | avd | ztString | 30 |  | varchar
Contact details | ComNr | ztString | 200 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase limit | InkopLimit | ZtBaseCurrAmount | 18 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Journal closed | JfbsLocked | ztBoolean |  |  | char
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Calendar number | kalendernr | ztInteger | 2 |  | smallint
Est hourly cost | KalkKostManTim | ZtBaseCurrAmount | 14 | 2 | money
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Interim cost centre | KstInterimsBokning | ztString | 8 |  | varchar
Balance sheet CC | KstReskSaldo | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
E-mail account | mailboxname | ztString | 30 |  | varchar
Mail per day | MailPerDag | ztBoolean |  |  | char
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Password | Passord | ztString | 10 |  | varchar
Personnel category | Perskategori | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Reserve | PerssignMailReserv | ztString | 6 |  | varchar
Personal no. | PersSignNr | ztInteger | 3 |  | smallint
Project ID | Projcode | ztString | 10 |  | varchar
Fiscal year | redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Name | RespNamn | ztString | 50 |  | varchar
Resource group | Resursgrp | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sign all | Signeraalla | ztBoolean |  |  | char
Open locked voucher | UnlockClosedVer | ztBoolean |  |  | char
Voucher no. group | VerNrGrupp | ztString | 6 |  | varchar
E-mail | wEmailAddress | ztString | 100 |  | varchar

    This table is the main table in the following programs:

    Program: pr Accounting users

    Program: upr Accounting users, assignments


Accounts (view3) (vkotktc)

View over the account with currency balance.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar

    This table is the main table in the following programs:

    Program: Kodcag Account reconciliation, day per currency


Acct seg 3, customer order (orkb)

The cost units that can be entered manually on customer orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
As of date | DatKBarFom | ztDate |  |  | datetime
End date | DatKBarTom | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost unit | KostBar | ztString | 8 |  | varchar
Cost unit | KostBarBeskr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: orkb Acct seg 3 on order


Acct segment 4, customer order (ork4)

The account segments 4 that can be entered manually on customer orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S4 | K4Beskr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ork4 Segment 4 on order


Acct segment 5, customer order (ork5)

The account segments 5 that can be entered manually on customer orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S5 | K5 | ztString | 8 |  | varchar
S5 | K5Beskr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ork5 Segment 5 on order


Acct segment 6, customer order (ork6)

The account segments 6 that can be entered manually on customer orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S6 | K6 | ztString | 8 |  | varchar
S6 | K6Beskr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ork6 Segment 6 on order


Acct segment 7, customer order (ork7)

The account segments 6 that can be entered manually on customer orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S7 | K7 | ztString | 8 |  | varchar
S7 | K7Beskr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ork7 Segment 7 on order


Acct segments, currency revaluation (kxx)

Definition of accounts, and any other account segments, to be used for exchange rate revaluation of currencies.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | k4 | ztString | 8 |  | varchar
S5 | k5 | ztString | 8 |  | varchar
S6 | k6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar


Acct types, GL (xkot)

Internal definitions of the different account types that accounts in Jeeves can be split into.

The following standard records exist. Do not alter/delete:

Account type (KtoTyp) | Account type (KtoTypBeskr) | Description
0 | Income account |
90 | Update costs for project | Account type 90 is used when a posted amount should update the field for posted costs on a project. The posting must have the project specified. This is used in the function for percentage of completion accounting.
91 | Update revenues for project | Account type 91 works like account type 90, but updates the project's field for posted revenue. This is used in the function for percentage of completion accounting.
92 | Re invoicing/follow up assignments/projects | Account type 92 means that it is an external cost that is transferred to the posted project as an expense. This is used in manual vouchers, supplier invoices and in the function for percentage of completion accounting.
93 | Connect to service order | Creates a service order row.
100 | Customer receivable |
200 | Accounts payable | Account type 200 is used to check that the supplier invoice amount is posted against a debt account. If not, the invoice CANNOT be paid.
201 | Accounts payable, interim account | Account type 201 is used when a supplier invoice is preliminarily posted against an interim account. To finally post this type of invoice, the amount of the type 201 account must be zero.
203 | Auto. entry of fixed assets fr GL | Account type 203 is used to automatically create a fixed asset record when posting supplier invoices.
204 | Tax, clearing account | Account type 204 is used when preliminarily posting a supplier invoice with invoice type 1 (Advance invoice - debit). The tax amount is posted to the clearing account instead of the normal tax account. When the last partial payment of this type of invoice is made, the clearing account is counter-booked and the normal tax account is debited. Account type 204 is also used to enter tax amounts in a clearing account for customer invoices. The contra account (MotKtoNrAvrMoms) is entered on the clearing account in the account table (ko). Upon payment or partial payment of customer invoices, the clearing account is counter-booked and the contra account is credited. This process is used mainly in France.
205 | Bill of exchange account | Account type 205 is used to post incoming/outgoing payments with exchanges.
900 | Balance account |
901 | Check account |
1000 | Statistical account | Account type 1000 (statistical accounts) and higher can be used for accounts that do not refer to the normal General Ledger. These accounts are not included in checks to ensure that the debit and credit sums agree. NOTE! The statistical account is a new function that under development.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Account type | KtoTyp | ztInteger | 3 |  | smallint
Account type | KtoTypBeskr | ztString | 50 |  | varchar
Override Debit/Credit | OverrideDC | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xXkot Account types


Accumulated balances per employee (AttR_prvacc)

Holds balances per employee (and per salary type used as accumulator).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Balance | AttrBAlance | ztFloat | 15 | 2 | float
Balance Date | AttrBalanceDat | ztDate |  |  | datetime
Salary type | AttRSalaryType | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_prvacc Accumulated balances per employee


Acquisition method, item (xaas)

Table of the different acquisition methods used for items. This data controls if and how items are to be processed in the purchasing and manufacturing modules.

The following standard records exist. Do not alter/delete:

Acquisition method (Anskaffningssatt) | Acquisition method (AnskaffningssattBeskr) | Description
0 | Purchase to order point | Set for items that are normally purchased according to the order point. If an item has this acquisition method, the inventory balance (available) must be less than the order point to generate a requirement.
1 | Purchase to plan | Set for items that are normally purchased according to the safety stock. If an item has this acquisition method, requirement planning is done in respect of safety stock.
2 | Purchase to requirement | Set for items that are normally purchased according to a customer/manufacturing order. If an item has this acquisition method, the requirement is linked to a customer or manufacturing order.
10 | Manufacture to order point | Set for items that are normally manufactured according to the order point. If an item has this acquisition method, the inventory balance (available) must be less than the order point to generate a requirement.
11 | Manufacture to plan | Set for items that are normally manufactured according to the safety stock. If an item has this acquisition method, requirement planning is done in respect of safety stock.
12 | Manufacture to requirement | Set for items that are normally manufactured according to a customer order. If an item has this acquisition method, the requirement is linked to a customer order.
99 | z Non-delivery item | Used for fictitious items, services, and so on. Note that items with this acquisition method are excluded from detailed production costing. For fictitious items that are to be included in production costing you should instead set method 10-12, preferably 11.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Acq to order point | AnskaffningBestp | ztBoolean |  |  | char
Purchased | AnskaffningKop | ztBoolean |  |  | char
Acq to requirement | AnskaffningMotBehov | ztBoolean |  |  | char
Acq to plan | AnskaffningPlanering | ztBoolean |  |  | char
Acquisition method | Anskaffningssatt | ztInteger | 2 |  | smallint
Acquisition method | AnskaffningssattBeskr | ztString | 50 |  | varchar
Manufactured | AnskaffningTillv | ztBoolean |  |  | char
Auto breakdown within MO | AutoVidareNedbrInomTo | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xaas Acquisition method, item


Activity status (xeas)

Definition of existing status codes and descriptions in respect of activities in projects, as required.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Activity status | AktStatus | ztInteger | 5 |  | smallint
Activity status | AktStatusB | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xeas Activity status


Activity status (xwfs)

In this table, Jeeves Information Systems sets up the options that can occur in respect of activity status in the workflows in Workflow.

The following standard records exist. Do not alter/delete:

Activity status (ActivityStatus) | Activity status (ActivityStatusD)
10 | Created
20 | Waiting
30 | Started
40 | Paused
60 | Finished
70 | Suspended
90 | Start/Stop Activity Status
99 | Error

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Activity status | ActivityStatus | ztInteger | 3 |  | smallint
Activity status | ActivityStatusD | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xwfs Activity status


Activity status for claim flow (ClaimActivityStatus)

Definition of existing activity status for voucher flow.

Most statuses are fixed and must be present. Otherwise, status is defined according to need.

The following standard records exist. Do not alter/delete:

Activity status (ClaimActivityStatus) | Activity status (ClaimActivityStatusDescr)
98 | Rejected
99 | Closed

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Activity status | ClaimActivityStatus | ztInteger | 4 |  | smallint
Activity status | ClaimActivityStatusDescr | ztString | 80 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ClaimActivityStatus Activity status for claim flow


Activity types, special planning list (xo4x)

Table of the row types that may be found on the special item planning list.

The following standard records exist. Do not alter/delete:

Row type plan list (PlanLstRadTyp) | Row type plan list (PlanLstRadTypBeskr)
- | Batch record, do not use
A | Requisition, Purchase
B | Order/purchase
I | Rec. delivery, PO
IN | IN: Rec. delivery, PO
K | Customer orders
M | Material reservation, mfg
N | Material reservation, MRP
P | Forecast demand
R | Repair, service
S | Balance record, batch
T | Manufacturing order, receiving
U | Delivery, customer order
UT | OUT: Delivery, customer order
V | Manufacturing, NET REQ

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row type plan list | PlanLstRadTyp | ztString | 2 |  | varchar
Row type plan list | PlanLstRadTypBeskr | ztString | 50 |  | varchar
Sort order | PlanLstRadTypSort | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xo4x Row type, planning list special


ActivType (xwac)

In this table, Jeeves Information Systems sets up the types of activities that can occur in the workflows in Workflow.

The following standard records exist. Do not alter/delete:

Activity type (ActivityKind) | Activity type (ActivityKindD) | Description
0 | Start Activity | All flows begin with a start activity behind which there is a rule specifying what initiates the flow. The start activity is always performed automatically and never appears in the user's To do list. A flow can be started automatically by making a change in the database, insert, update or delete. When this is done, the flow begins when Jeeves Workflow executes the flow's start activity. It then moves on to the next activity in the flow. You can start a flow manually, for example if a customer makes a telephone order the recipient will be able to start the order receipt flow manually. This procedure is described in another chapter. In these cases the start activity is also performed automatically by Jeeves Workflow. Can only be combined with the following data resource types: - Trigger action - Dummy
1 | Update Jeeves | NOT USED!
10 | Join | A join activity does not represent a work task or processing, i.e. it is never executed and also never appears in any user's To do list. Join activities are created automatically and only exist for design technical reasons to show that the flow joins again here after a split. The data resource type is always Dummy.
11 | Split | A split means that the flow is divided into one or more alternative or parallel routes. The outgoing flow routes include logic for the route(s) in the flow that will be taken. The logic can either be controlled automatically by Jeeves Workflow or answered manually by the user (Accept/Reject). Example ------------- - You can ask whether it is OK to process a customer order. The user answers manually with the Accept (Yes) button or the Reject (No) button. - A condition can have been specified that all supplier invoices above a certain amount will undergo extra approval. Workflow checks the amount automatically. The above answer/check result decides which route(s) the customer order/supplier invoice will take to move on in the work flow. Can only be combined with the following data resource types: - Accept/Reject - Dummy
12 | Dummy | A dummy activity does not represent a work task or processing, i.e. it is never executed and also never appears in any user's To do list. Dummy activities exist for design technical reasons.
20 | Jeeves Document | An activity of this type means that a document which has been checked in to Jeeves PDM and is linked to a record in the database will display in the viewer. For example, this could be an invoice which will be approved where you are only interested in looking at the document, and not at an associated supplier invoice record in the database. Can only be combined with the following data resource types: - Jeeves document
30 | Subprocess | A subprocess activity involves skipping directly to the first activity in another related or underlying flow. If this is set up as a manual activity, it displays in the user's To-do list. Can only be combined with the following data resource types: - Dummy
40 | Run Exe.pgm | An activity of this type is linked to a specific external program. When you start the activity from the To do list, the program in which you will perform the activity launches automatically. The term 'WfExecute' in the program 'wpra' is used to define which .exe application will be used. You specify the name of entered Windows programs, e.g. Notepad.exe or Word.exe, otherwise you have to enter the whole path for the program specified. Can only be combined with the following data resource types: - Exe program
50 | Run Jeeves | An activity of this type is linked to a specific program in Jeeves. When you start the activity from the To do list, the program in which you will perform the activity launches automatically. Can only be combined with the following data resource types - Jeeves application - Macro/Record - Dummy
60 | Run SQL Script | An activity of the SQL script type is an automatic activity, i.e. it is performed by Jeeves Workflow and never appears in the user's To do list. Workflow executes one or more commands according to an SQL script which has been written in the activity's definition. Can only be combined with the following data resource types: - Run SQL-script - Send mail - Connect tables
70 | Report | An activity of this type is linked to a specific print program in Jeeves, either a report in Jeeves or an external print program. If this refers to a report in Jeeves, it must also be linked to a specific template. Reports can be started automatically or manually. Can only be combined with the following data resource types: - Run Jeeves report - Run Crystal Reports
90 | End Activity | All flows end with an end activity. The end activity is created and is always performed automatically by Jeeves Workflow and never appears in the user's To-do list.
100 | Approval | An activity of the Approval type represents a manual work task which involves approval of the activity in question or an ongoing activity in the flow. The Accept/Reject buttons are used to approve/reject the matter/activity. Approve normally means that Jeeves Workflow moves on to the next activity in the flow (this is decided by the rules). You can also allow the Accept/Reject choice to start a subflow. An approval activity displays in the relevant user's/resource group's To-do list. Can only be combined with the following data resource types: - Accept/Reject

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Activity type | ActivityKind | ztInteger | 5 |  | smallint
Activity type | ActivityKindD | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Layer | LagLayer | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xwac ActivType


Add on Assignments (vAddOn)

Add on Assignments.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Deducted invoice | AcDrawn | ztBoolean |  |  | char
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Days commitmt 1 | AtagandeGrad1 | ztInteger | 3 |  | smallint
Days commitmt 2 | AtagandeGrad2 | ztInteger | 3 |  | smallint
Days commitmt 3 | AtagandeGrad3 | ztInteger | 3 |  | smallint
Days commitmt 4 | AtagandeGrad4 | ztInteger | 3 |  | smallint
Automatically created | AutomatSkapad | ztBoolean |  |  | char
Posting template | AutoRegel | ztString | 4 |  | varchar
Agreement type | AvtalsKod | ztInteger | 3 |  | smallint
Payment terms | BetKod | ztString | 2 |  | varchar
Invoicing start date | CheckDagPerAvtal | ztBoolean |  |  | char
Sequence no. type | CompanyType | ztInteger | 4 |  | smallint
Detail posting | Detaljkontering | ztBoolean |  |  | char
District | DistrKod | ztString | 4 |  | varchar
Division code | DivisKod | ztString | 3 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Replaces QuoteNo | ErsattOffNr | ztString | 10 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Handling charge | ExpAvgKd | ztBoolean |  |  | char
Invoice to date | FaktTomDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Storage code | Forradskod | ztString | 17 |  | varchar
Freight charge code | FraktAvgKd | ztBoolean |  |  | char
Frozen up to commitment | FrystAtagande | ztInteger | 5 |  | smallint
Delivery note Y/N | FsKd | ztBoolean |  |  | char
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Valid to date | GiltigTomDatum | ztDate |  |  | datetime
Goods label row 1 | GodsMarke1 | ztString | 40 |  | varchar
Goods label row 2 | GodsMarke2 | ztString | 40 |  | varchar
Goods label row 3 | GodsMarke3 | ztString | 40 |  | varchar
Goods label row 4 | GodsMarke4 | ztString | 40 |  | varchar
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Est hourly cost | KalkKostManTim | ZtBaseCurrAmount | 14 | 2 | money
Campaign | KampNr | ZtLong | 4 |  | int
Block order | KodBlockOrder | ztBoolean |  |  | char
External text -> order | KodExtTextToOrder | ztBoolean |  |  | char
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit percentage | KreditProcent | ztFloat | 15 | 2 | float
Customer order date | KundBestDat | ztDate |  |  | datetime
Ordering dept | KundBestNamn | ztString | 36 |  | varchar
Customer order no. | KundBestNr | ztString | 30 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Invoicing address | KundFaktAdr | ztString | 36 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Customer reference | KundRef2 | ztString | 30 |  | varchar
Customer specific text | KundTextKod | ztString | 4 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Ship documents | LevHandlKod | ztBoolean |  |  | char
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Dispatch plan group | LevPlanGrupp | ztString | 35 |  | varchar
Update method | LevPlanUpdMetod | ztInteger | 1 |  | smallint
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Allocation template | MallFaktPeriod | ztInteger | 3 |  | smallint
Master project no. | MasterProjCode | ztString | 10 |  | varchar
Max date not invoiced | MaxEjFaktDat | ztDate |  |  | datetime
Min date not invoiced | MinEjFaktDat | ztDate |  |  | datetime
Min invoice amt | MinInvoiceAmount | ztMoney | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Recipient code | MottagarKod | ztString | 17 |  | varchar
Not credit invoice | NoCreditInvoice | ztBoolean |  |  | char
Quotation/agreement | OffBeskr | ztString | 40 |  | varchar
Quote/Agreemt date | OffertDat | ztDate |  |  | datetime
Quote row no. -> Order row no. | OffertRadNrToOrdRadNr | ztBoolean |  |  | char
Quote cost | OffKostnad | ZtBaseCurrAmount | 14 | 2 | money
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Offert/avtal nr | OffNrNum | ZtLong | 10 |  | int
Quote/assignment status | OffStatus | ztString | 1 |  | varchar
Quotation value, BCU | OffSum | ZtBaseCurrAmount | 14 | 2 | money
Margin | OffTB | ZtBaseCurrAmount | 14 | 2 | money
Quotation printed | OffUtskrDat | ztDateTime |  |  | datetime
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order date | OrdDatum | ztDate |  |  | datetime
Order text | OrdEditext | ztBlob | 1 |  | varchar
Order up to oblig. | OrderAtagande | ztInteger | 3 |  | smallint
Order cost | OrdKostnad | ZtBaseCurrAmount | 14 | 2 | money
Delivery addr, company | OrdLevAdr1 | ztString | 36 |  | varchar
Delivery address 1 | OrdLevAdr2 | ztString | 36 |  | varchar
Delivery address 2 | OrdLevAdr3 | ztString | 36 |  | varchar
Delivery address 3 | OrdLevAdr4 | ztString | 36 |  | varchar
Destination, district | OrdLevAdrBstOrt | ztString | 36 |  | varchar
Destination, country | OrdLevAdrLandsKod | ztString | 3 |  | varchar
Point of delivery, co. ID | ordlevplats1 | ztCompanyNo | 20 |  | varchar
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Order value | OrdSum | ZtBaseCurrAmount | 14 | 2 | money
Order type | OrdTyp | ztInteger | 3 |  | smallint
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Gate description | PortBeskrivning | ztString | 35 |  | varchar
Gate code | PortKod | ztString | 17 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Service price list | PrislistaT | ztInteger | 6 |  | smallint
Pricing method | PrisTyp | ztInteger | 3 |  | smallint
Percent of invoice | ProcentavFaktura | ztFloat | 7 | 2 | float
Project ID | ProjCode | ztString | 10 |  | varchar
Finished on | ProjEndDat | ztDate |  |  | datetime
Revised end date | Projrevenddat | ztDate |  |  | datetime
Revised start date | Projrevstartdat | ztDate |  |  | datetime
Project start date | ProjStartDat | ztDate |  |  | datetime
Business opportunity ID | prospektid | ZtLong | 10 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Collective invoicing ID | SamFaktOffNr | ztString | 30 |  | varchar
Collective invoicing | SamFaktUtskr | ztBoolean |  |  | char
Last invoice date | SerSenFakt | ztDate |  |  | datetime
End date invc period | SersSlutFakt | ztDate |  |  | datetime
Start date invc period | SerStartFakt | ztDate |  |  | datetime
Service agreement | ServiceAssignment | ztBoolean |  |  | char
Create purchase agreement | SkapaInkAvt | ztBoolean |  |  | char
Create forecast rows | SkapaPrognos | ztBoolean |  |  | char
Skrivskydd | SkrivUtskSk | ztBoolean |  |  | char
Block check | SparrAvtal | ztBoolean |  |  | char
Blocked | SparrAvtal_C | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Tiering code | StafflKodOffert | ztBoolean |  |  | char
Sum items on invoice | SumitemOnInvoice | ztBoolean |  |  | char
Price ceiling | TakPrisAvt | ZtBaseCurrAmount | 12 | 2 | money
Price ceiling expense | TakPrisEx | ZtBaseCurrAmount | 12 | 2 | money
Asgmt controls VAT/tax | TaxByAssignmentFlag | ztBoolean |  |  | char
Use cust discount | TillatKundRabatt | ztBoolean |  |  | char
Invoicing type | UFakttyp | ztInteger | 3 |  | smallint
Assignment class | Uppdragsklass | ztInteger | 5 |  | smallint
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Quotation value, curr | VbOffSum | ztMoney | 14 | 2 | money
Order amount, curr | VbOrdSum | ztMoney | 14 | 2 | money
Our reference | VRef | ztString | 30 |  | varchar
Publish on Web | webpublish | ztBoolean |  |  | char


Added fields to form/list/total (JvsSiteAddedFields)

Program/table for viewing and editing settings regarding fields that have been added to forms, lists and totals.

The program/table can be accessed through an embedded window in the program Setting dimensions/keys (jvssitenodewin) or from Jeeves' menu.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Term | JvsSiteColumnName | ztString | 40 |  | nvarchar
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Setting ID (orig) | JvsSiteNodeWinSettingsID_orig | ZtLong | 10 |  | int
Tab ID | JvsSiteTabID | ZtLong | 10 |  | int
Tab ID (orig) | JvsSiteTabID_orig | ZtLong | 10 |  | int
Table | JvsSiteTableName | ztString | 40 |  | nvarchar
Field ID | JvsSiteWindowFieldID | ZtLong | 11 |  | int
Field ID (orig) | JvsSiteWindowFieldID_orig | ZtLong | 11 |  | int
Window type | JvsSiteWindowType | ztString | 2 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteAddedFields Fields added to window


Added/modified objects (UsrDefModSQLObject)

User/ISV own modification of databas object containing SQL code.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Object name | DB_Object_Name | ztString | 128 |  | varchar
SQL code | DB_SQLCode | ztBlob | 1 |  | varchar
Documentation | Documentation | ztBlob | 1 |  | varchar
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Object type | ObjectType | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Development project | UsrDefDevProj | ztString | 10 |  | varchar
Type of mod (R/M/A) | UsrDefMod_type_SQLObject | ztString | 30 |  | varchar
Install sequence | UsrDefModSQLCodeInstallSequence | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: UsrDefModSQLObject Added/modified objects


Added/modified objects, history (UsrDefModSQLObject_CodeHistory)

History of own modifications of database objects.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Object name | DB_Object_Name | ztString | 128 |  | varchar
SQL code | DB_SQLCode | ztBlob | 1 |  | varchar
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Development project | UsrDefDevProj | ztString | 10 |  | varchar


Added/modified objects, history, original code (UsrDefModSQLObject_OrigCode)

User/ISV own modification of databas object containing SQL code.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Object name | DB_Object_Name | ztString | 128 |  | varchar
SQL code | DB_SQLCode | ztBlob | 1 |  | varchar
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Development project | UsrDefDevProj | ztString | 10 |  | varchar


Added/modified objects, log (UsrDefModSQLObject_log)

User/ISV own modification of databas object containing SQL code.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDbObject | ztString | 60 |  | nvarchar
Object name | DB_Object_Name | ztString | 128 |  | nvarchar
SQL code | DB_SQLCode | ztBlob | 1 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
SQL sats | SqlStmt | ztString | 255 |  | nvarchar

    This table is the main table in the following programs:

    Program: UsrDefModSQLObject_log Added/modified objects, log


Address label number series (adlt)

Definition of number series per dispatch method and address label type used for automatic address label numbering.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Address label type | AdressLappTyp | ztInteger | 2 |  | smallint
Bar code, start | BarCodeStart | ztString | 10 |  | varchar
Bar code, start/stop | BarCodeStartStop | ztString | 4 |  | varchar
Bar code, complete | BarCodeStop | ztString | 10 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight number series | FraktNrSerieKod | ztInteger | 2 |  | smallint
Freight series no. type | FraktNrSerieTyp | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Code EAN data element | KodEANDataElement | ztString | 10 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xadlt Address label, def. No. series


Adress label types, Sales (xadl)

A number of standard address label types are entered during installation. you cannot add your own address label types.

You link the address label types to dispatch methods in the program 'Dispatch methods, sales' (Xx2f). When you enter a customer order, an address label type is retrieved according to the definition for the dispatch method in question. You cannot print a different address label type for the order.

The number of address labels depends on the number of packages specified for the order.

The following standard records exist. Do not alter/delete:

Address label type (AdressLappTyp) | Address label type (AdressLappTypBeskr)
1 | Postal label
2 | Address label 151.4/double
3 | Address label 151.4/single
4 | Forwarder - package
5 | Forwarder - goods
6 | 6: ASG - STE Label

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Address label type | AdressLappTyp | ztInteger | 2 |  | smallint
Address label type | AdressLappTypBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Number series types | KodFraktNrSerieTyp | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xxadl Address label types, Sales


Advance, link to order/invoice (fskk)

Unique sequence number for relevant definition. The term is used by a number of functions, in some the number is entered manually and in others it is generated automatically. If the number is generated automatically, this can be done, for example, according to one of the conventions described below.

Example 1:
number of days since 940101
number of seconds since 00.00
process ID in the database
counter

Example 2:
today's date (8char) (YYYYMDD)
current time (8char) (HH:MM:SS)
current time milliseconds (:SSS)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no., advance | FaktNrForskott | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Adv amt incl tax, BCU | ForskottBelopp | ZtBaseCurrAmount | 14 | 2 | money
Ded advance amt, BCU | ForskottBeloppAvdr | ZtBaseCurrAmount | 14 | 2 | money
Remaining adv amt, BCU | ForskottBeloppRest | ZtBaseCurrAmount | 14 | 2 | money
Link type, advance | ForskottKopplTyp | ztInteger | 5 |  | smallint
Deduction order-lnkd adv | ForskottOrdKopplTyp | ztInteger | 2 |  | smallint
Exchange rate, advance | ForskottValKurs | ZtCurrencyRate | 15 | 7 | decimal
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Adv amt incl tax, curr | vb_ForskottBelopp | ztMoney | 14 | 2 | money
Ded advance amt, curr | vb_ForskottBeloppAvdr | ztMoney | 14 | 2 | money
Remaining adv amt, curr | vb_ForskottBeloppRest | ztMoney | 14 | 2 | money


Agreement row discount (sht8)

Table for storing discount percentages on service items depending on the reparation type.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quote/agreement no. | Offnr | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Discount % | Rabatt | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Reparation type | RepNr | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Agreement types (x1v)

Table of agreement types for projects, used to determine billing method.

The following standard records exist. Do not alter/delete:

Agreement type (AvtalsKod) | Agreement type (AvtalsBeskr) | Description
0 | Fixed price | Reported activities and expenses on assignments of this type will not normally be invoiced on open account. If you check the Check fixed price checkbox in the system data, the invoicing flag is automatically removed for fixed price projects.
1 | Open account | Assignments of this type cannot be invoiced periodically. Only invoicing of ongoing costs such as expenses, hours, etc., is permitted here.
2 | Periodically | Assignments of this type can be invoiced both on open account and periodically.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Agreement type | AvtalsBeskr | ztString | 50 |  | varchar
Agreement type | AvtalsKod | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xx1v Agreement types


Agreement, Time type and Salary type (AttR_agrtt)

Connects Agreement, Time type, Salary type and formula (which will be used for calculating salary).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Agreement ID | AttRAgreement | ztString | 6 |  | varchar
Formula | AttRFormula | ztString | 100 |  | varchar
Salary type | AttRSalaryType | ZtLong | 10 |  | int
Time type | AttRTimeType | ztString | 6 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_agrtt Agreement, Time type and Salary type


Agreement/service item (sht9)

Definition of service agreement details per service item with information on reparation time and any compensary discount for excess time.

You can enter further details on discounts in the agreement in the underlying table Agreement row discount (sht8).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quote/agreement no. | Offnr | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Compensation discount% | RabattKomp | ztFloat | 6 | 2 | float
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Repair time | TurnAround | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: sht9 Agreement/service item


Agreements (AttR_agr)

Describes all existing agreements.
Agreement is the highest level for setting up and managing different time types, salary types and types of compensation.

The same reason code or time type can be connected to different salary types/types of compensation, depending on the agreement with the employee.

Each employee is then linked to an agreement.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Agreement ID | AttRAgreement | ztString | 6 |  | varchar
Agreement description | AttRAgreementDescr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_agr Agreements


Alias for programs (JvsSitePgmAlias)

Definition of customer-specific short-names or aliases for programs in Jeeves. These can be used in the Run program function (Ctrl+Shift+F8).

Examples of use:
- To translate Jeeves' standard datanames for programs, which in some cases are in Swedish and therefore difficult for non-Swedish users.
- To abbreviate standard datanames, some of which are long and can therefore impair the quickness of the Run program option.
- To create an own code system for programs, such as:

po = Be, Purchase orders
so = Order1, Sales orders
rec = Beinlev, Receive deliveries
disp = Utpl/ohutpl, Dispatches

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Group | JvsSiteForGrp | ZtLong | 6 |  | int
Signature | JvsSiteForUser | ztString | 6 |  | nvarchar
Program name in Jeeves | JvsStdPgmName | ztString | 40 |  | nvarchar
Alias | JvsStdPgmNameAlias | ztString | 40 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIdentity | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: JvsSitePgmAlias Alias for programs


All companies (sy1All)

Numeric ID of the company. If a company ID is displayed in this field, the setting is only valid when working in that company.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company code | ForetagKodAll | ztInteger | 5 |  | smallint
Company name | FtgNamn | ztString | 36 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime


Allocation batches, prel budget (bfar)

Allocation batches per fiscal year and budget revision when preliminary budget records are allocated over the year's periods and converted to "normal" budget records.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Budget batch no. | BudgetOmg | ZtLong | 10 |  | int
Allocation curve | FordKurva | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | perssign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Revision | Revision | ztInteger | 3 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: bfar Allocation preliminary budget


Allocation quarterly->period (pfkp)

This table contains an allocation percentage to get from quarter to period.
The table is used, for example, when allocating a forecast for quarter level down to period level.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allocation percent | FordProc | ZtDecimal73 | 6 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quarter | Kvartal | ztInteger | 1 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Forecast version | PrognosVer | ZtLong | 4 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Pfkp Allocation quarterly->period


Allocation rules, posting templates (xx1)

Definition of allocation rules that can be linked to details in posting templates to determine how amounts will be retrieved.

The following standard records exist. Do not alter/delete:

Allocation rule (FordRegel) | Allocation rule (FordRegBeskr) | Description
0 | Pre-determined fixed | Means that allocation is performed based on a fixed amount specified in the field "Amount to allocate" in the template.
1 | Manual allocation | Means that the row amount is entered manually.
2 | Debit/credit difference | Means that the voucher's remaining difference is posted on the row. This can only be used on the last row of the template.
3 | Voucher amount | Means that allocation is performed based on the amount on the voucher header.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allocation rule | FordRegBeskr | ztString | 50 |  | varchar
Allocation rule | FordRegel | ztString | 3 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxx1 Allocation rules, posting templates


Allocation source (fdv)

Allocation source details.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Auto allocation rule | AutFordRegel | ztString | 10 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
From S4 | K4From | ztString | 8 |  | varchar
To S4 | K4Tom | ztString | 8 |  | varchar
From S5 | K5From | ztString | 8 |  | varchar
To S5 | K5Tom | ztString | 8 |  | varchar
From S6 | K6From | ztString | 8 |  | varchar
To S6 | K6Tom | ztString | 8 |  | varchar
From S7 | K7From | ztString | 8 |  | varchar
To S7 | K7Tom | ztString | 8 |  | varchar
Fr o m K8 | K8From | ztString | 8 |  | varchar
To S8 | K8Tom | ztString | 8 |  | varchar
From CU | KBarFrom | ztString | 8 |  | varchar
To S3 | KBarTom | ztString | 8 |  | varchar
From CC | KstFrom | ztString | 8 |  | varchar
To CC | KstTom | ztString | 8 |  | varchar
From account | KtoFrom | ztString | 8 |  | varchar
To account | KtoTom | ztString | 8 |  | varchar
Batch number | OmgangsNr | ztInteger | 3 |  | smallint
From project | ProjFrom | ztString | 10 |  | varchar
To project | ProjTom | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar


Allocation target (fdt)

Allocation target details.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Auto allocation rule | AutFordRegel | ztString | 10 |  | varchar
Allocation percent | FordProc | ZtDecimal73 | 6 | 2 | decimal
Allocate to S4 | FordTillK4 | ztString | 8 |  | varchar
Allocate to S5 | FordTillK5 | ztString | 8 |  | varchar
Allocate to S6 | FordTillK6 | ztString | 8 |  | varchar
Allocate to S7 | FordTillK7 | ztString | 8 |  | varchar
Fördelas till K8 | FordTillK8 | ztString | 8 |  | varchar
Allocate to S3 | FordTillKBar | ztString | 8 |  | varchar
Allocate to cost ctr | FordTillKst | ztString | 8 |  | varchar
Allocate to account | FordTillKto | ztString | 8 |  | varchar
Allocate to project | FordTillPrj | ztString | 10 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Constant | KonstantId | ztString | 15 |  | varchar
Batch number | OmgangsNr | ztInteger | 3 |  | smallint
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Columns updated | RowupdatedCols | ztString | 255 |  | varchar


Allocation template, details (pfmd)

Template details with data on with which periodicity an assignment shall be invoiced.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Allocation template | MallFaktPeriod | ztInteger | 3 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Last day of period | PeriodEnd | ztDate |  |  | datetime
First day of period. | PeriodStart | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: pfmd Period invoicing template


Allocation template, header (pfmh)

Definition of templates that contain the periods when different types of periodic invoicing of assignments will be done. The period intervals are stored in the underlying table (pfmd).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No of month | AntManad | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Allocation template | MallFaktPeriod | ztInteger | 3 |  | smallint
Allocation template | MallFaktPeriodBeskr | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: pfmh Allocation template, assignment


Alt supplier calc cost-% per Inventory loc (alcc)

Definition of cost percentages per Inventory location to be used when calculating standard/average cost price for a specific Alternative supplier for an Item (table al), when functionality for cost price per Inventory location is active in the system.
Percentages can be definied for the following costs:
- Delivery cost (HemtKostnProc)
- Freight cost (FraktKostnProc) If a record is entered for an Inventory location in this table, the percentages defined will have priority over any percentages defined on the Alternative supplier record (table al) itself.

Here it is also possible to define a Markup template or individually define values for any of the fields connected to the Markup template according to the following:
- Markup 1 %
- Markup 2 %
- Markup 3 %
- Markup 4 %
- Markup 5, amount

These fields are only considered if a value NOT NULL (empty) is entered in the field.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Markup 2 chain | ArtKalkChain2 | ztBoolean |  |  | char
Markup 4 chain | ArtKalkChain4 | ztBoolean |  |  | char
Markup 5, amount | ArtKalkPalBel5 | ZtBaseCurrAmount | 14 | 2 | money
Markup template | ArtKalkPalKod | ztString | 4 |  | varchar
Markup 1 % | ArtKalkProc1 | ztFloat | 6 | 2 | float
Markup 2 % | ArtKalkProc2 | ztFloat | 6 | 2 | float
Markup 3 % | ArtKalkProc3 | ztFloat | 6 | 2 | float
Markup 4 % | ArtKalkProc4 | ztFloat | 6 | 2 | float
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight cost % | FraktKostnProc | ZtDecimal73 | 7 | 2 | decimal
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Delivery cost % | HemtKostnProc | ZtDecimal73 | 7 | 2 | decimal
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Alcc Alt supplier calc cost-% per inventory loc


Alt units per item (xare)

If you have specified that the items' alternative units are to be defined per item, i.e. if the Alternative units field (KodAlternativEnhet) in the System data order, purchase, inventory program (Sy1Lager) is set to 2, you set up the different alternative units for each individual item in this program. You will then only be able to select the units you link to the item when entering inventory transactions, orders or purchase orders.

You can also specify whether the unit should be default for purchases or sales here.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Decimal places | AltEnhetAntDec | ztInteger | 2 |  | smallint
Purchase unit | AltEnhetInkop | ztBoolean |  |  | char
Purchase unit, standard | AltEnhetInkopStd | ztBoolean |  |  | char
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Conversion factor | AltEnhetOmrFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Sales unit | AltEnhetOrder | ztBoolean |  |  | char
Sales unit, standard | AltEnhetOrderStd | ztBoolean |  |  | char
Fixed conversion factor | AltEnhOmrAktiv | ztBoolean |  |  | char
Alt unit tolerance - % | AltEnhTolProcMinus | ZtDecimal73 | 8 | 3 | decimal
Alt unit tolerance + % | AltEnhTolProcPlus | ZtDecimal73 | 8 | 3 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Max qty joint pick | Samplock_Antal | ZtQty | 14 | 2 | decimal

    This table is the main table in the following programs:

    Program: xare Alternative units per item


Alt units per supplier/item (xale)

Table of alternative units per item and supplier.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Decimal places | AltEnhetAntDec | ztInteger | 2 |  | smallint
Purchase unit | AltEnhetInkop | ztBoolean |  |  | char
Purchase unit, standard | AltEnhetInkopStd | ztBoolean |  |  | char
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Sales unit | AltEnhetOrder | ztBoolean |  |  | char
Sales unit, standard | AltEnhetOrderStd | ztBoolean |  |  | char
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xale Alternative units per supplier/item


Alt units, language (xaeb)

Code for alternative unit according you own convention, e.g. 12P for 12-pack or 100K for Boxes with 100 units. You can use the function for sales and purchasing to handle alternative units to your own stock unit.

From version 11.0 there are two ways of using alternative units:

1) Fixed relationship between own stock unit and alternative unit:
When entering order and purchase order quantities in alternative units, these are automatically converted to your own stock unit. Example: An item is stocked per piece. It can be sold per piece, but can also be sold in the alternative units of 6 pack, 12 pack or 24 pack. If you use the alternative unit 6 pack when entering the item on an order or purchase order and specify a quantity of 3, the quantity is automatically converted to 18 in your own stock unit.

2) Varying relationship between own stock unit and alternative unit:
There is no automatic conversion to your own inventory stock unit. You enter order, purchase order and physical count quantities in both units. Jeeves checks that specified quantities are reasonable in relation to each other.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit description | AltEnhetBeskr | ztString | 50 |  | varchar
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint


Alternative items (arav)

In Jeeves, you can enter an unlimited number of alternative items for an item. Alternative items are used in the order routine to present possible alternatives for an item that at the time of the order does not have an available balance for the dispatch in question.

The alternative items can be prioritized.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Alternative item | ArtNrAltArt | ztString | 30 |  | varchar
Priority code | ArtNrAltArtPrior | ztInteger | 3 |  | smallint
EDI alternative | EdiAlternativ | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Valid to date | TomDatum | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: arav Alternative items


Alternative routings (opa)

Definition of applicable alternative routings for an item. Please refer to the program help for complete documentation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative routing | AltOpBeskr | ztString | 40 |  | varchar
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Alternative routing | AltRouting_Orig | ztInteger | 2 |  | smallint
Quantity to manufacture | AntalAttTillverka | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Copied from alternative routing | CopiedFromMOAltRouting | ztInteger | 2 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Main alternative routing | HuvudOperationsAlternativ | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Item Revision | ItemRevision | ZtLong | 3 |  | smallint
Copy from item revision | ItemRevision_CopyOfRevision | ZtLong | 3 |  | int
Item rev OK to use? | ItemRevOkToUse | ztBoolean |  |  | char
Note | KortNotering | ztString | 255 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Max qty to manufacture | MaxQty4OperationAlternative | ZtQty | 14 | 2 | decimal
Min qty to manufacture | MinQty4OperationAlternative | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: opa Alternative routings


Alternative suppliers (al)

Data on items per supplier. You can use the table in different ways:

You can store information about alternative suppliers of an item here.

You can enter and maintain the purchase prices drawn up with suppliers, linked if required to an agreement header (the agreement header is entered in a separate program), in which case you cite the purchase agreement by filling in the field for purchase agreement designation (term InkAvt). Agreement number 0 or blank means no agreement header. If you need to store more records relating to the same item and supplier, you must create a new purchase agreement header because a different agreement number is required for this.

If you have several records on the same item, you should specify which is the main record (main agreement), i.e. which should be used in the first instance. You do this by selecting the field ‘Main agreement’ (term ArtHuvudAvt) for the relevant record. Priority codes can be set to control which supplier is used as first choice, second choice, etc. if there is no primary supplier.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Qty on PO | AntalIBest | ZtQty | 14 | 2 | decimal
Number of decs (ext) | AntDecExtQty | ztInteger | 1 |  | smallint
Item description | ArtBeskr | ztString | 30 |  | varchar
Main agreement | ArtHuvudAvt | ztBoolean |  |  | char
Net purchase price | ArtInPris | ZtBaseCurrAmount | 14 | 2 | money
Purch price date | ArtInPrisDat | ztDate |  |  | datetime
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
New cost price from date | ArtKalkBerNyttDatum | ztDate |  |  | datetime
New cost price (refinement) | ArtKalkBerNyttForadling | ZtBaseCurrAmount | 14 | 2 | money
New cost price (mtrl) | ArtKalkBerNyttMtrl | ZtBaseCurrAmount | 14 | 2 | money
Markup 2 chain | ArtKalkChain2 | ztBoolean |  |  | char
Markup 4 chain | ArtKalkChain4 | ztBoolean |  |  | char
Markup 5, amount | ArtKalkPalBel5 | ZtBaseCurrAmount | 14 | 2 | money
Markup template | ArtKalkPalKod | ztString | 4 |  | varchar
Calc cost price | ArtKalkPris | ZtBaseCurrAmount | 14 | 2 | money
Markup 1 % | ArtKalkProc1 | ztFloat | 6 | 2 | float
Markup 2 % | ArtKalkProc2 | ztFloat | 6 | 2 | float
Markup 3 % | ArtKalkProc3 | ztFloat | 6 | 2 | float
Markup 4 % | ArtKalkProc4 | ztFloat | 6 | 2 | float
Item class | ArtKod | ztInteger | 3 |  | smallint
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Sellable item | ArtSaljBar | ztBoolean |  |  | char
Start cost/pc | ArtStyckStartKostnad | ZtCost | 16 | 6 | float
Manufacturer | ArtTillv | ztString | 30 |  | varchar
Days commitmt 2 | AtagandeGrad2 | ztInteger | 3 |  | smallint
Days commitmt 3 | AtagandeGrad3 | ztInteger | 3 |  | smallint
Days commitmt 4 | AtagandeGrad4 | ztInteger | 3 |  | smallint
Days commitmt 9 | AtagandeGrad9 | ztInteger | 3 |  | smallint
New to PO date | AvtTomBestDat_Nytt | ztDate |  |  | datetime
New to disp date | AvtTomLevDat_Nytt | ztDate |  |  | datetime
Order text | BestEditExt | ztBlob | 1 |  | varchar
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
Priority (copy from) | CopiedFromItmPOPriority | ztInteger | 2 |  | smallint
Days fixed suborder | DagarFastAvrop | ztInteger | 5 |  | smallint
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight cost % | FraktKostnProc | ZtDecimal73 | 7 | 2 | decimal
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Delivery cost % | HemtKostnProc | ZtDecimal73 | 7 | 2 | decimal
Order type ICT | ICTOrderType | ztInteger | 3 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Price conv factor | InkArtOmvFaktor | ztFloat | 14 | 4 | float
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Calc quantity | InkAvtBerAnt | ZtQty | 14 | 2 | decimal
Calculated qty, alt unit | InkAvtBerAntAltEnh | ZtQty | 14 | 2 | decimal
Ordered quantity | InkAvtBestAnt | ZtQty | 14 | 2 | decimal
PO agreement date | InkAvtDat | ztDate |  |  | datetime
Agreement to disp date | InkAvtTomDat | ztDate |  |  | datetime
Agreement to PO date | InkAvtTomDatBestH | ztDate |  |  | datetime
Purchase blocked | InkopsSparr | ztBoolean |  |  | char
Price unit factor | InkPrisPer | ZtDecimal73 | 8 | 3 | decimal
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Item Revision | ItemRevision | ZtLong | 3 |  | smallint
Copy from item revision | ItemRevision_CopyOfRevision | ZtLong | 3 |  | int
Item rev OK to use? | ItemRevOkToUse | ztBoolean |  |  | char
External text -> PO | KodExtTextToBest | ztBoolean |  |  | char
Inspection instruction | KontrollInstruktion | ztBlob | 1 |  | varchar
Customer | KundNr | ztCompanyNo | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Adm lead time | LedTidAdm | ztInteger | 3 |  | smallint
Lead time from suppl | LedTidEnlLev | ztInteger | 3 |  | smallint
Lead time extra demand | LedTidExtra1 | ztInteger | 3 |  | smallint
Surcharge, alloying | LegeringsTillaggId | ZtLong | 10 |  | int
Supplier item descr | LevsArtBeskr | ztString | 255 |  | varchar
Date/time updated | LnUpdatedDt_1 | ztDateTime |  |  | datetime
Date/time updated | LnUpdatedDt_2 | ztDateTime |  |  | datetime
Max qty per PO | MaxQtyPerPO | ZtQty | 14 | 2 | decimal
Min order qty | MinAntalBest | ZtQty | 14 | 2 | decimal
Min order qty (ext) | MinAntalBestExtQty | ZtQty | 14 | 2 | decimal
Minimum qty, alt unit | MinAntalBestExtQtyAltEnh | ZtQty | 14 | 2 | decimal
Pkg size purchase | Multipel | ZtQty | 14 | 2 | decimal
Package size | MultipelExtQty | ZtQty | 14 | 2 | decimal
New cost as of date | NewCostsFromDate | ztDate |  |  | datetime
No minimum qty check | NoMinQtyCheck | ztBoolean |  |  | char
Normal purchase qty | NormBestAntLager | ZtQty | 14 | 2 | decimal
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Quote/agreement row no | OffRadNr | ztInteger | 5 |  | int
OLE-1 | Ole1 | ztString | 255 |  | varchar
OLE-2 | Ole2 | ztString | 255 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Quantity PDM | pdmcount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Planeringsreserv (dgr) | PlanReservTid | ztInteger | 3 |  | smallint
Price list | PrisLista | ztInteger | 5 |  | smallint
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
New discount 1 % | Rabatt1Nytt | ztFloat | 6 | 2 | float
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
New discount 2 % | Rabatt2Nytt | ztFloat | 6 | 2 | float
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
New discount 3 % | Rabatt3Nytt | ztFloat | 6 | 2 | float
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Invtry unit->Purch unit | StockQty2SuppQty | ztFloat | 12 | 6 | float
Stock replenishment ICT | StockReplenishment | ztBoolean |  |  | char
Requisition | StrDateTimeBIA | ztString | 28 |  | varchar
Freight cost (amt/kg) | TransportKostnadsID | ZtLong | 10 |  | int
Transport days | TransportTid | ztInteger | 3 |  | smallint
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
B-Inpris, Brutto valuta | Vb_InPris_B | ztMoney | 14 | 2 | money
Gross purch price, curr | vb_inpris_Brutto | ztMoney | 14 | 2 | money
Net purchase price, curr | vb_inpris_Netto | ztMoney | 14 | 2 | money
Gross setup price, curr | Vb_InPris_Stall | ztMoney | 14 | 2 | money
New gross setup price, curr | Vb_InPris_Stall_Nytt | ztMoney | 14 | 2 | money
Gross start purch price, curr | Vb_InPris_Start | ztMoney | 14 | 2 | money
Gross purch prc, excl alloy | Vb_InPrisBas | ztMoney | 14 | 2 | money
New purch prc, excl alloy | Vb_InPrisBasNytt | ztMoney | 14 | 2 | money
Purchase price incl tax | Vb_InPrisInklMoms | ztMoney | 14 | 2 | money
New gross purch price, curr | Vb_InPrisNytt | ztMoney | 14 | 2 | money
Cost price, curr | vbKalkPris | ztMoney | 14 | 2 | money
Nytt kalk.pris valuta | vbKalkPrisNytt | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: al Alternative suppliers

    Program: al_OldItemRev Alternative suppliers

    Program: AlKalkPrisPerLgr Calculate cost prices/inventory loc, main agreements

    Program: AlKalkPrisPerLgrO Calculate cost prices/inventory loc, other agreements

    Program: AltLev Show supplier/item by price

    Program: ArtKalk Calculate cost prices

    Program: rAlKalkP Calculate cost prices


Alternative suppliers (revision diff) (al_ItemRevDiff)

Priority for suppliers/purchase agreements, where 0 is the highest and 99 is the lowest priority. The information is used, for example when creating requisitions, if there are several suppliers/purchase agreements for an item and a main agreement is not specified.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Main agreement | ArtHuvudAvt | ztBoolean |  |  | char
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Manufacturer | ArtTillv | ztString | 30 |  | varchar
Priority (copy from) | CopiedFromItmPOPriority | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Item Revision | ItemRevision | ZtLong | 3 |  | smallint
Copy from item revision | ItemRevision_CopyOfRevision | ZtLong | 3 |  | int
Item revision diff flag | ItemRevisionDiffFlag | ztString | 4 |  | nvarchar
Item rev OK to use? | ItemRevOkToUse | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Created by | RowCreatedBy | ztString | 30 |  | varchar


Alternative suppliers, RFQ (pal)

Table for preliminary purchase prices which can be entered manually on RFQs, imported via EDI, etc. Everything or a sub-quantity can then be transferred to “definitive” purchase prices/purchase agreements (table Al). This is done in connection with purchase order entry based on a quotation in the program ‘Purchase order from quotation’ (bepal) if you check the ‘Update agrmt price’ (bestinpris2avtal) box.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Qty on PO | AntalIBest | ZtQty | 14 | 2 | decimal
Number of decs (ext) | AntDecExtQty | ztInteger | 1 |  | smallint
Item description | ArtBeskr | ztString | 30 |  | varchar
Main agreement | ArtHuvudAvt | ztBoolean |  |  | char
Net purchase price | ArtInPris | ZtBaseCurrAmount | 14 | 2 | money
Purch price date | ArtInPrisDat | ztDate |  |  | datetime
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
New cost price from date | ArtKalkBerNyttDatum | ztDate |  |  | datetime
Markup 2 chain | ArtKalkChain2 | ztBoolean |  |  | char
Markup 4 chain | ArtKalkChain4 | ztBoolean |  |  | char
Markup 5, amount | ArtKalkPalBel5 | ZtBaseCurrAmount | 14 | 2 | money
Markup template | ArtKalkPalKod | ztString | 4 |  | varchar
Markup 1 % | ArtKalkProc1 | ztFloat | 6 | 2 | float
Markup 2 % | ArtKalkProc2 | ztFloat | 6 | 2 | float
Markup 3 % | ArtKalkProc3 | ztFloat | 6 | 2 | float
Markup 4 % | ArtKalkProc4 | ztFloat | 6 | 2 | float
Item class | ArtKod | ztInteger | 3 |  | smallint
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Start cost/pc | ArtStyckStartKostnad | ZtCost | 16 | 6 | float
Manufacturer | ArtTillv | ztString | 30 |  | varchar
New to PO date | AvtTomBestDat_Nytt | ztDate |  |  | datetime
New to disp date | AvtTomLevDat_Nytt | ztDate |  |  | datetime
Order text | BestEditExt | ztBlob | 1 |  | varchar
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Price conv factor | InkArtOmvFaktor | ztFloat | 14 | 4 | float
Calc quantity | InkAvtBerAnt | ZtQty | 14 | 2 | decimal
Calculated qty, alt unit | InkAvtBerAntAltEnh | ZtQty | 14 | 2 | decimal
Ordered quantity | InkAvtBestAnt | ZtQty | 14 | 2 | decimal
PO agreement date | InkAvtDat | ztDate |  |  | datetime
Agreement to disp date | InkAvtTomDat | ztDate |  |  | datetime
Agreement to PO date | InkAvtTomDatBestH | ztDate |  |  | datetime
Price unit factor | InkPrisPer | ZtDecimal73 | 8 | 3 | decimal
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
External text -> PO | KodExtTextToBest | ztBoolean |  |  | char
Inspection instruction | KontrollInstruktion | ztBlob | 1 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Adm lead time | LedTidAdm | ztInteger | 3 |  | smallint
Lead time from suppl | LedTidEnlLev | ztInteger | 3 |  | smallint
Lead time extra demand | LedTidExtra1 | ztInteger | 3 |  | smallint
Supplier item descr | LevsArtBeskr | ztString | 255 |  | varchar
Min order qty | MinAntalBest | ZtQty | 14 | 2 | decimal
Min order qty (ext) | MinAntalBestExtQty | ZtQty | 14 | 2 | decimal
Minimum qty, alt unit | MinAntalBestExtQtyAltEnh | ZtQty | 14 | 2 | decimal
Pkg size purchase | Multipel | ZtQty | 14 | 2 | decimal
Package size | MultipelExtQty | ZtQty | 14 | 2 | decimal
New cost as of date | NewCostsFromDate | ztDate |  |  | datetime
OLE-1 | Ole1 | ztString | 255 |  | varchar
OLE-2 | Ole2 | ztString | 255 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Purchase agreem designation | PInkAvt | ZtLong | 6 |  | int
Planeringsreserv (dgr) | PlanReservTid | ztInteger | 3 |  | smallint
Requisition (prel) | PrelAnmID | ZtLong | 10 |  | int
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Row | radpos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Invtry unit->Purch unit | StockQty2SuppQty | ztFloat | 12 | 6 | float
Date/time | StrDateTime | ztString | 28 |  | varchar
Requisition | StrDateTimeBIA | ztString | 28 |  | varchar
Transport days | TransportTid | ztInteger | 3 |  | smallint
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
B-Inpris, Brutto valuta | Vb_InPris_B | ztMoney | 14 | 2 | money
Gross purch price, curr | vb_inpris_Brutto | ztMoney | 14 | 2 | money
Net purchase price, curr | vb_inpris_Netto | ztMoney | 14 | 2 | money
Gross setup price, curr | Vb_InPris_Stall | ztMoney | 14 | 2 | money
New gross setup price, curr | Vb_InPris_Stall_Nytt | ztMoney | 14 | 2 | money
Gross start purch price, curr | Vb_InPris_Start | ztMoney | 14 | 2 | money
Purchase price incl tax | Vb_InPrisInklMoms | ztMoney | 14 | 2 | money
New gross purch price, curr | Vb_InPrisNytt | ztMoney | 14 | 2 | money
Cost price, curr | vbKalkPris | ztMoney | 14 | 2 | money
Nytt kalk.pris valuta | vbKalkPrisNytt | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: pal RFQ (item/supplier)


Alternative units (xae)

Definition of applicable alternative units in inventory, purchases and sales. These define if and how the unit is to be converted and which text is to be printed on external documents.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Decimal places | AltEnhetAntDec | ztInteger | 2 |  | smallint
Alternative unit description | AltEnhetBeskr | ztString | 50 |  | varchar
Purchase unit | AltEnhetInkop | ztBoolean |  |  | char
Purchase unit, standard | AltEnhetInkopStd | ztBoolean |  |  | char
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Multiply quantity | AltEnhetMultKod | ztBoolean |  |  | char
Conversion factor | AltEnhetOmrFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Sales unit | AltEnhetOrder | ztBoolean |  |  | char
Sales unit, standard | AltEnhetOrderStd | ztBoolean |  |  | char
Fixed conversion factor | AltEnhOmrAktiv | ztBoolean |  |  | char
Alt unit tolerance - % | AltEnhTolProcMinus | ZtDecimal73 | 8 | 3 | decimal
Alt unit tolerance + % | AltEnhTolProcPlus | ZtDecimal73 | 8 | 3 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Message on split | MeddelaVidDelning | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xae Alternative units


And/Or (roch)

Definitions which specify whether terms/restrictions will apply together with (and) or independently of (or) each other.

The following standard records exist. Do not alter/delete:

And/Or (ocheller) | Operand (ochelbeskr)
1 | or
2 | and

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Operand | ochelbeskr | ztString | 50 |  | varchar
And/Or | ocheller | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: roch And/Or


Aoru report type (xaru)

Table of types of shop report that can be used to show the status of jobs in progress.

The following standard records exist. Do not alter/delete:

Type of reporting (AoruTyp) | Type of reporting (AoruTypBeskr)
0 | Operation started
10 | Interruption
20 | Interruption, standstill
30 | Operation partially reported
100 | Operation stopped, end of day
130 | Operation stopped, subreport/end of day

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Type of reporting | AoruTyp | ztInteger | 3 |  | smallint
Type of reporting | AoruTypBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xaru Work status


AP payment routes (x2uv)

Definition of the outgoing payment routes that are used mainly for foreign payments via bank giro and plus giro. The outgoing payment routes are used for foreign payments to manage the content in the plus giro file or bank giro file that you create using the report «Create payment file» according to outgoing payment route (rjux2uv). This is because there are a number of differences as to how files for foreign payments are created depending on what bank is making the actual outgoing payment.

An outgoing payment route set-up used in Sweden for foreign payments is supplied as standard. In other countries where Jeeves is used, procedures are created in the database by authorized resellers who program the processing of outgoing payment routes.

All outgoing payment routes that start with DNB and have length (UtbFilPostLaengd) 326 create a payment file according to Den Norske Bank.

The following standard records exist. Do not alter/delete:

Payment route
(Utbetalningsvag) 		Payment route descr
(UtbetalningsVagBeskr) 		Description
BG Bank Giro Domestic outgoing payments via Bank giro.

AP payment routes are not normally used for domestic payments, but this payment route can be used if, for some reason, you wish to control the search path and the name of the outgoing payment file per payment route. (This is normally managed from the system data for Accounts Payable (program Sy1utb).)
BGDN Danska Nordea Payment via BGC Denmark to Nordea.

Note that this requires Net Kernel v2.3 or higher, also that the procedure called JEEVES_DKBgOut is specified on the payment route and length in payment file is -1.

For domestic payments, if the FIK code has a value on the supplier invoice, payment type 46 is used, otherwise payment type 45 is used. For international payments type 49 is used.

The record in the payment file has variable record length, which is solved by making all records 510 positions long if set up as described above.

Detailed specifications of the file formats for domestic and international payments can be provided separately.
bgf For. Swedbank This payment route has been replaced by payment route BGQ.
bgh For. Svenska Handelsbanken International payment via BGC

Summary of the file format for Svenska Handelsbanken:

Record type 3:
Pos 78-78 BgUtlBankKost, 0=Sender pays or one of 1 or 9=Recipient pays
Pos 79-79 BgUtlBetForm, B=Normal, T=Express or C=Check
Note that address field 2 MUST contain data (any character is sufficient)

Record type 4:
Pos 9-38 SwiftMotBankKonto
Pos 39-50 SwiftMotBankAdress
Pos 51-80 SwiftMotBankOrt

IBAN:
Record type 4:
Pos 9-43 SwiftMotBankKonto, IBAN-nummer
Pos 44-67 SwiftMotBankAdress
Pos 68-78 SwiftMotBankOrt

Record type 6:
Pos 80-80 BgUtlBelKto, I=Deposit account, V=Currency account or T=Futures Contract

For Handelsbanken, you can create a file that can be sent directly to the bank without having to be sent through the invoice payment service. The file can only contain international payments. The sender’s record and the Reconciliation record will then look different. This is set in the program payment route field UtbMaterialTyp=BANK.

On Nordea's web page (http://www.nordea.com/sitemod/default/index.aspx?pid=908472) you will find a list of IBAN countries.
bgn For. Nordea International payment via BGC

Summary of the file format for Nordbanken:

Record type 3:
Pos 74-74 BgUtlBelKto, 0=SEK account, 1=Currency account
Pos 78-78 BgUtlBankKost, 0=Sender, Blank or 1=Recipient
Pos 79-79 BgUtlBetForm, Blank or 1=Swift, 0=Check
Pos 80-80 BgUtlPrio, 0=Normal, 1=Express

Record type 4:
Pos 9-31 SwiftMotBankAdress
Pos 32-56 SwiftMotBankKonto
Pos 57-80 SwiftMotBankOrt

IBAN:
Record type 4:
Pos 9-31 SwiftMotBankAdress
Pos 32-56 SwiftMotBankKonto, IBAN-number
Pos 57-80 SwiftMotBankOrt, Blank

For Nordbanken, you can create a file that can be sent directly to the bank without having to be sent through the invoice payment service. The file may only contain international payments. The sender’s record and the Reconciliation record will then look different. This is set in the program payment route field UtbMaterialTyp=BANK.

On Nordea's web page (http://www.nordea.com/sitemod/default/index.aspx?pid=908472) you will find a list of IBAN countries.
BGÖ For. Östgöta Enskilda Banken International payment via BGC

Summary of the file format for Östgöta Enskilda Banken:

Record type 3:
Pos 74-74 Blank
Pos 80-80 BgUtlPrio, Blank or 0=Normal, 1=Express
Pos 78-78 BgUtlBankKost, Blank or 0=Sender pays, 1=Recipient pays
Pos 79-79 Blank (If SwiftMotBankAdress filled =1 Östgöta=Blank)

Record type 4:
Pos 9-20 SwiftMotBankAdress
Pos 21-50 SwiftMotBankKonto
Pos 51-80 MotBankForBindelse
bgq For. Swedbank/Sparbanken International payment via BGC

Summary of the file format for Sparbanken:

Record type 3:
Pos 74-74 BgUtlBelKto, 0=Deposit account, 1=Currency account
Pos 78-78 BgUtlBankKost, 0=Sender, 2=Recipient
Pos 80-80 BgUtlBetForm, Blank or 0=Normal, 1=Express and 2=Check

Record type 4:
Pos 9-20 SwiftMotBankAdress
Pos 21-50 SwiftMotBankKonto
Pos 51-80 SwiftMotBankNamn

IBAN:
Record type 4:
Pos 9-20 SwiftMotBankAdress
Pos 21-50 SwiftMotBankKonto, IBAN-number
Pos 51-80 SwiftMotBankOrt

On Nordea's web page (http://www.nordea.com/sitemod/default/index.aspx?pid=908472) you will find a list of IBAN countries.
BGS For. SEBanken International payment via BGC

Summary of the file format for Skandinaviska Enskilda Banken:

Record type 3:
Pos 74-74 BgUtlBelKto, null, 0=SEK account, 1=Currency account
Pos 76-76 BgUtlBankKost, Charge code, 0=sender, blank or 1=recipient
Pos 77-77 BgUtlBetForm, Betform, blank,1=SWIFT,0=check
Pos 78-78 BgUtlPrio, Payment method, 0=normal, 1=express
Pos 79-79 Blank (If SwiftMotBankAdress filled =1)

Record type 4:
Pos 9-20 SwiftMotBankAdress
Pos 21-50 SwiftMotBankKonto
Pos 51-80 MotBankForBindelse

IBAN:
Record type 4:
Pos 9-20 SwiftMotBankAdress
Pos 21-50 SwiftMotBankKonto, IBAN-number
Pos 51-80 MotBankForBindelse

On Nordea's web page (http://www.nordea.com/sitemod/default/index.aspx?pid=908472) you will find a list of IBAN countries.
DnB Den Norske Bank International payment via BGC

The file format for Den Norska Banken:

Only SwiftMotBankAdress is used.
The Account field for the bank must be filled in for every supplier record for this payment route.
LM02 Finnish banks Domestic payments via Finnish bank.

Note that this requires that the procedure called JEEVES_FIBankOut and payment contents LM02 are specified on the payment route.
LUM2 Intl Finnish banks International payments via Finnish bank.

Note that this requires that the procedure called JEEVES_FIBankOut and payment contents LUM2 are specified on the payment route.
PG Plus giro Domestic payments via Postal giro

Payment routes for domestic payments are not usually used, but this payment route may be used if for any reason you wish to control the search path for and name of the payment file using the payment route. (This is usually directed by the system information for the accounts payable ledger (program Sy1utb).)

Summary of the file format for PG:
Record type 2:
Pos 24-56 Swift to bank account, SWIFT- or IBAN-number
Record type 3:
Pos 18-50 Swift to Bank Name
Pos 51-72 Swift to Bank Location
Record type 5:
Pos 18-50 Swift to Bank Address

On Nordea's web page (http://www.nordea.com/sitemod/default/index.aspx?pid=908472) you will find a list of IBAN countries.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Aegis | Aegis | ztString | 1 |  | varchar
Transfer receipt journal | AutoCreateJournal | ztBoolean |  |  | char
Bank agreement | AvtalNrHosBank | ztString | 30 |  | varchar
Account at bank | BankKonto | ztString | 40 |  | varchar
Bank acct check type | BankKontoTyp | ztString | 4 |  | varchar
BOE ledger | BoE_Code | ztBoolean |  |  | char
Sign conversion | CharConvertType | ztInteger | 5 |  | smallint
Division | Divisjon | ztString | 11 |  | varchar
Bank EDI ID | EDI_Id_HosBank | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Bank customer no. | KundNrHosBank | ztString | 30 |  | varchar
Namn på kvittesnfil | KvittensFilNamn | ztString | 255 |  | varchar
Procedure, after | MatrixPostExecProc | ztString | 255 |  | varchar
Procedure, before | MatrixPreExecProc | ztString | 255 |  | varchar
OpNr | OpNummer | ztString | 11 |  | varchar
Password | PassOrd | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
No Joint sorting BG | SamSort_Bg | ztBoolean |  |  | char
Sekvensnummer | SekvensNr | ZtLong | 6 |  | int
SekvNr | SekvNr | ztInteger | 4 |  | smallint
Procedure | StoredProcedure | ztString | 120 |  | varchar
Sign conversion type | TypeOfCharConvert | ztInteger | 5 |  | smallint
Payment route | Utbetalningsvag | ztString | 6 |  | varchar
Payment route descr | UtbetalningsVagBeskr | ztString | 50 |  | varchar
Payment file name | UtbFilNamn | ztString | 255 |  | varchar
Length in pmt file | UtbFilPostLaengd | ztInteger | 5 |  | smallint
Close char pmt file | UtbFilSlutTkn | ztString | 255 |  | varchar
Start char pmt file | UtbFilStartTkn | ztString | 255 |  | varchar
AP/AR pmt contents | UtbMaterialTyp | ztString | 10 |  | varchar
AP pmt reason/Due dt | UtbOrsak | ztString | 10 |  | varchar

    This table is the main table in the following programs:

    Program: vX2uv AP payment routes

    Program: x2uv AP payment routes


Application area (xapa)

Definition of codes for different Jeeves application areas.
This is used to classify and automatically name JVSP control parameters in Jeeves.

The following standard records exist. Do not alter/delete:

Appl area, code (ApplAreaCode) | Application area (ApplAreaDescr)
1 | Marketing
3 | Försäljning
4 | Purchasing
5 | Manufacturing
6 | Inventory
7 | Service
9 | ICT
10 | Accounts Receivable
11 | Accounts Payable
12 | General Ledger
13 | Projects, Time reporting, Assignments
15 | Product variant management
20 | WEB-applications
25 | Fixed assets ledger
30 | EDI-applications
40 | EDM / PDM
50 | General
60 | Special
70 | Workflow
75 | Warehouse Management System
80 | CRM
81 | Jeeves Business Intelligence
82 | Case management
90 | Customer adapted parameters

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Appl area, code | ApplAreaCode | ztInteger | 2 |  | smallint
Application area | ApplAreaDescr | ztString | 50 |  | varchar
Appl area, prefix | ApplAreaShortCode | ztString | 10 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xapa Application area


Application parameters (jvsp)

Parameter table to control functions in Jeeves.

If, for example, a parameter is to be entered for Application area = Sales, it has shortcut code = SALES, which automatically proposes a parameter name using the syntax SALES999, where 999 is a sequence number obtained automatically from the system.
Both the internal parameter name (JeevesParamName) and the automatically generated parameter name are set as default values, but another value can be set. This is NOT recommended!!!

IMPORTANT! ======== Application areas 90-99 (Customer Adapted parameters) must always be used for customer-specific parameters as they are reserved for entry of parameter values specific to a customer. This avoids problems that otherwise could arise when the customer upgrades to a new version of Jeeves as the standard Jeeves parameters that are classified according to Application areas 0-89 are always reloaded into the table for Jeeves control parameters (JVSP).
No parameters in Application areas 90-99 are affected.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Appl area, code | ApplAreaCode | ztInteger | 2 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Jeeves Param Descr | JeevesParamDescr | ztString | 100 |  | varchar
Distribute | JeevesParamDistribute | ztBoolean |  |  | char
Parameter name | JeevesParamName | ztString | 20 |  | varchar
Parameter name | JeevesParamNameExt | ztString | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Value type | VardeTermT | ztInteger | 3 |  | smallint

    This table is the main table in the following programs:

    Program: jvsp Application parameters


Application parameters, current value (jvss)

Parameter table to control functions in Jeeves.
Completed settings of Jeeves.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
JeevesParamBoolean | JeevesParamBoolean | ztBoolean |  |  | char
Parameter name | JeevesParamName | ztString | 20 |  | varchar
JeevesParamNumeric | JeevesParamNumeric | ztInteger | 5 |  | smallint
JeevesParamString | JeevesParamString | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: jvss Set up control parameters for Jeeves


Approval chain roles (ATKR)

Definition of roles in approval chains.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Change other's posting | AndraKontering | ztBoolean |  |  | char
Consists of quantity | AntBestarAv | ztInteger | 5 |  | smallint
Approval rule | Attestregel | ztInteger | 5 |  | smallint
Approval chain | AttKedja | ztInteger | 5 |  | smallint
Approval chain limit | AttKedjaLimit | ZtBaseCurrAmount | 18 | 2 | money
Apprl chain conditions | AttKedjaVillkor | ztString | 255 |  | varchar
Fictitious resource group | DummyResursGrp | ztBoolean |  |  | char
Approval type | ecoapptypecode | ztInteger | 5 |  | smallint
No amount diff on Web | EjWebDiff | ztBoolean |  |  | char
May post | FarKontera | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Free field 1 | frifalt1 | ztString | 40 |  | varchar
On error return to admin | hlkontroll | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Mandatory level | MandatoryChainLevel | ztBoolean |  |  | char
Next level in apprl chain | NastaPosAttKedja | ztInteger | 5 |  | smallint
O-nivå | ONiva | ztInteger | 1 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | perssign2 | ztString | 6 |  | varchar
Level approval chain | PosAttKedja | ztInteger | 5 |  | smallint
Level apprl chain, descr | PosAttKedjaBeskr | ztString | 60 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Resource group | resursgrp | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence | sequence | ztInteger | 3 |  | smallint
Create apprls fr posting | SkapaAttFrKont | ztBoolean |  |  | char
Create apprs fr posting | SkapaBestFrKont | ztBoolean |  |  | char
Select next resource | ValjResurs | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xatkr Approval chain roles, e-Approval

    Program: xatkreco Approval chain roles, change orders

    Program: xitkr Approval chain roles, e-Purchasing

    Program: xitkrT Approval chain roles, Time report


Approval chain type (atkt)

Definition of occurring approval chain types, i.e. routines or object to which approval chains can be linked.

The following standard records exist. Do not alter/delete:

Approval chain type (AttKedjaTyp) | Approval chain type (AttKedjaTypBeskr)
1 | Supplier invoice
2 | Purchasing
3 | Document
4 | Time report
5 | Change order

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval chain type | AttKedjaTyp | ztInteger | 5 |  | smallint
Approval chain type | AttKedjaTypBeskr | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xatkt Approval chain types


Approval chain, header (ATKH)

Definition of approval chains for electronic approval.

Here you define only the ID, name and type of approval chain. You then build up the approval chains in levels, link resource groups to them and specify the supplemental information in a separate program.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval chain | AttKedja | ztInteger | 5 |  | smallint
Approval chain | AttKedjaBeskr | ztString | 30 |  | varchar
Approval chain type | AttKedjaTyp | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Check rule | kontrollregel | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Collective invoicing | samlingsFaktura | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xatk Approval chains


Approval chain, header (view) (vatkh)

View of definition of approval chains for electronic approval.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval chain | AttKedja | ztInteger | 5 |  | smallint
Approval chain | AttKedjaBeskr | ztString | 30 |  | varchar
Approval chain type | AttKedjaTyp | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Check rule | kontrollregel | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Collective invoicing | samlingsFaktura | ztBoolean |  |  | char


Approval codes (xat)

Definition of approval statuses that can be given to supplier invoices.

The following standard records exist. Do not alter/delete:

Approval status (AttestKod1) | Approval status (AttestBeskr)
0 | Arrival
1 | Pending approval
2 | Approval canceled
5 | Final approval
9 | Invoice canceled

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval status | AttestBeskr | ztString | 50 |  | varchar
Approval status | AttestKod1 | ztInteger | 1 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Utbetalninsattest | LrUtbAttest | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xat Approval status


Approval control groups (kk1)

The accounts of a certain approval control group are stored in this table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
From account | KtoFrom | ztString | 8 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
To account | KtoTom | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Approval control groups/CC (agk2)

Definition of approval control groups. Approval rights in the accounts payable can be limited to specific cost centres/intervals of the cost centre, to specific cost units/intervals of cost units, etc.

There are two options beginning with version 9 service pack 1:

Alternative 1:
You may (as in previous versions) specify in the fiscal year that an approval control will only occur against account segment 2 (cost centre) and specify a control group for respective employees.

Alternative 2:
You may (beginning with version 9 service pack 1) link the approval control group to control groups for all account segments. If you specify a control group(s) in the approval control group header, it is that group will have priority.

Nothing can then be entered or approved in the AP ledger for account segments that do not belong to the specified control groups.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Appr/ctrl grp, CC | AgkBeskr | ztString | 30 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S4 | K4Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S7 | K7Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Control cost group | KontrollKstGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Control group project | PrjGrupp | ztString | 6 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xagk2 Approval control groups


Approval ctrl groups, CC (akk2)

Groups of cost centres that are linked to a signature to assign approval authority.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
From CC | KstFrom | ztString | 8 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
To CC | KstTom | ztString | 8 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime


Approval rule (ATRH)

Definition of approval rules for electronic approval.

A approval rule can be linked to a level in the approval chain for a supplier invoice or for a purchase. The level in the approval chain is activated/deactivated based on the terms you specify in the rows of the approval rule.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval rule | Attestregel | ztInteger | 5 |  | smallint
Approval rule | AttestRegelBeskr | ztString | 100 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xatrh Approval rules


Approval rule row (ATRR)

Definition of conditions, posting data, etc. within approval rules for electronic approval.

A approval rule can be linked to a level in the approval chain for a supplier invoice or for a purchase. The level in the approval chain is activated/deactivated based on the terms you specify in the rows of the approval rule.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval rule | Attestregel | ztInteger | 5 |  | smallint
Exceptions rule | AttestRegelUndantag | ztBoolean |  |  | char
Amount | BeloppAttestRegel | ZtBaseCurrAmount | 18 | 2 | money
Less than | BeloppMindreAn | ztBoolean |  |  | char
Check against budget | BudgetKontroll | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Priority | ForTur | ztBoolean |  |  | char
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
From S4 | K4From | ztString | 8 |  | varchar
To S4 | K4Tom | ztString | 8 |  | varchar
From S5 | K5From | ztString | 8 |  | varchar
To S5 | K5Tom | ztString | 8 |  | varchar
From S6 | K6From | ztString | 8 |  | varchar
To S6 | K6Tom | ztString | 8 |  | varchar
From S7 | K7From | ztString | 8 |  | varchar
To S7 | K7Tom | ztString | 8 |  | varchar
From CU | KbarFrom | ztString | 8 |  | varchar
To S3 | KbarTom | ztString | 8 |  | varchar
From CC | KstFrom | ztString | 8 |  | varchar
To CC | KstTom | ztString | 8 |  | varchar
From account | KtoFrom | ztString | 8 |  | varchar
To account | KtoTom | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
From Proj | PrjFrom | ztString | 30 |  | varchar
ToPrj | PrjTom | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Check against balance | SaldoKontroll | ztBoolean |  |  | char


Approved status time report (tidas)

Status code on time report.

0 - Active 10 - Approved 20 - Not approved

Time report (tidrattest) is marked with a status code,

The following standard records exist. Do not alter/delete:

Approved status (TimeApprovedStatus) | Status description (TidRappStatKdBeskr)
0 | Aktiva
10 | Bekräftad
20 | Godkänd
30 | Ej godkänd

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Status description | Tidrappstatkdbeskr | ztString | 50 |  | varchar
Approved status | TimeApprovedStatus | ztInteger | 2 |  | smallint


Approver/approval code (sy2_Attr_Auth)

Contains the authorization groups that the certifier has the right to attest.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Authorization group ID | AttrAuthorizecode | ztString | 6 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | Perssign2 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: sy2_Attr_Auth Authorizer / Authorization Code


AR payment journal status (x2i)

Definition of the different statuses that an incoming payment journal can be given.

The following standard records exist. Do not alter/delete:

Receipt journal status (InbJournStatusKod) | Receipt jrnl status (InbJournStatusBeskr)
0 | Entry in progress
3 | Can be closed
5 | Closed
-1 | Advance, settlement

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Receipt jrnl status | InbJournStatusBeskr | ztString | 50 |  | varchar
Receipt journal status | InbJournStatusKod | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: x2i AR payment journal status


Area table (xIom)

Table of areas in the fixed asset ledger.

Area is only information and has no controlling function. The purpose of the table is simply to show which fixed assets are in the same area.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Building ID | FastighetsID | ztString | 3 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Area | Omrade | ztString | 5 |  | varchar
Area name | OmradesNamn | ztString | 35 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xiom Fixed assets areas


Arrival codes (xank)

Definition of arrival codes that specify how arrived goods will be handled. Every handling type includes a brief description in text form and information on whether received delivery will be done directly at arrival entry or whether the goods will move on for arrival checks. Suggestions for processing types follow below.

- Receive immediately without control is the easiest processing method and means that updating of the inventory balances is done at arrival entry. Flag the field 'Receive immediately' but not the field 'Check'.

- Arrival and delivery entry in 2 steps, without checks. Neither 'Receive immediately' nor 'Check' should be flagged.

- Checks means that after arrival entry the goods are sent to a special table for goods that will be checked. From this control table you can print reports or find the items waiting to be checked. It is from the control table that you enter the approved quantity either for further processing by delivery personnel or for delivery directly to the inventory.

You can enter several arrival codes for inspection that handle different types of inspection or you can have an inspection instruction on the purchase agreement. The control code is retrieved from the item or the purchase agreement at entry of the purchase order. It can also be determined from the supplier. At arrival entry the strictest control is selected. The idea is that the normal processing for the company is specified on the purchase order and a lower arrival code is specified for the supplier. If you wish to inspect all deliveries from a supplier, for a period, the inspection code for the supplier is increased for that time period.

There is currently no logic in the numbering of the arrival codes, but you should apply ascending numbers for stricter checks.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Arrival handling | AnkomstBeskr | ztString | 40 |  | varchar
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Inspection rule | AvsyningsRegel | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Receive directly | InlevDirekt | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Check | SkaKontrolleras | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xank Arrival codes


Arrival codes (supplier table view) (vxan)

This table can be used to enter different codes describing how material received should be dealt with.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Arrival handling | AnkomstBeskr | ztString | 40 |  | varchar
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Receive directly | InlevDirekt | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Check | SkaKontrolleras | ztBoolean |  |  | char


Arrival remark codes (xann)

Arrival remark codes

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Remark | AnkomstAnm | ztInteger | 5 |  | smallint
Remark | AnkomstAnmBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xann Arrival remark codes


Arrival remarks (bhan)

Remarks on arrived goods.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Remark | AnkomstAnm | ztInteger | 5 |  | smallint
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: bhan Arrival remarks


Arrival reporting (bpa)

Table of all goods arrival reports.

Reports are made by the goods receiving officer and show only that the goods have arrived. Inventory balance is NOT updated.

If the delivery (item/agreement or supplier) is marked to be checked, data regarding what is to be checked is created in a different table. This table is used as the working data by the inspection staff A delivery can be marked in the system if it is not to be inspected but is to update the inventory balance (in this way delivery registration is not required).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Arrival qty invtry unit | AnkomstLevAnt | ZtQty | 14 | 2 | decimal
Arrival qty (suppl unit) | AnkomstLevAntExtQty | ZtQty | 14 | 2 | decimal
Arrival entered | AnkomstRapporterad | ztBoolean |  |  | char
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Lead time from | BasDatLedTid | ztDate |  |  | datetime
Use/Best before | BastForeDatum | ztDate |  |  | datetime
Batch no. required | BatchBokas | ztBoolean |  |  | char
Batch no. | BatchId | ztString | 30 |  | varchar
Delivery note date, rcv | BestFoljesedelsDat | ztDate |  |  | datetime
Delivery note no., rcv | BestFoljesedelsNr | ztString | 30 |  | varchar
Intern del note seq no. | BestFsLopNr | ztInteger | 5 |  | smallint
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
Received qty (suppl unit) | BestLevAntExtQty | ZtQty | 14 | 2 | decimal
Delivery received date | BestLevDat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
Remaining qty invtry unit | BestRestAnt | ZtQty | 14 | 2 | decimal
Remaining qty (suppl unit) | BestRestAntExtQty | ZtQty | 14 | 2 | decimal
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Ankomst/inlev.journal nr | BpaJournNr | ZtLong | 10 |  | int
PO/receiving journal no. | BpiJournNr | ZtLong | 10 |  | int
Diff delivery/planned | Diff_LevDat_2_LovDat | ztInteger | 5 |  | smallint
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Invc checked qty | FaktAvprAntal | ZtQty | 14 | 2 | decimal
InvcCheckQtyExt | FaktAvprAntalExtQty | ZtQty | 14 | 2 | decimal
Consumables | ForbrukningsMaterial | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Price conv factor | InkArtOmvFaktor | ztFloat | 14 | 4 | float
Receiving value | InlevKalkVarde | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location WMS | InventoryLocWMS | ztBoolean |  |  | char
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
Package no. (ID) | KolliNr | ztString | 30 |  | varchar
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
This field is used in the table as follows: |
Corr plan qty (suppl unit) | KorrAntalInExtQty | ZtQty | 14 | 2 | decimal
This field is used in the table as follows: |
Stocked | LagerBokas | ztBoolean |  |  | char
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Quantity, alt unit (+/-) | LagtransAntAltEnh | ZtQty | 14 | 2 | decimal
Dispatch notice | LevAviNr | ztString | 35 |  | varchar
Dispatch notice row | LevAviRadNr | ztInteger | 5 |  | int
Cancel remain qty | MakuleraRestAntal | ztBoolean |  |  | char
Cancel remain qty, order | MakuleraRestAntalOrder | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Excess delivery>customer | OverDelivToCustomer | ztBoolean |  |  | char
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | projcode | ztString | 10 |  | varchar
@zPrompt=null | PvmGridNo | ztInteger | 3 |  | smallint
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Cost | RedovisnRadKostnad | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Returned qty invtry unit | ReturAnt | ZtQty | 14 | 2 | decimal
Returned qty (suppl unit) | ReturAntExtQty | ZtQty | 14 | 2 | decimal
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Date/time (rev) | RowRevWithKeyStrDateTime | ztString | 28 |  | varchar
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Uppd lager vid ankomst | SaldoUpdAnkomst | ztBoolean |  |  | char
Shipment identity | ShipmentId | ZtLong | 10 |  | int
ShipmentId status | ShipmentId_status | ztBoolean |  |  | char
Invtry unit->Purch unit | StockQty2SuppQty | ztFloat | 12 | 6 | float
Date/time | StrDateTime | ztString | 28 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Gross setup price, curr | Vb_InPris_Stall | ztMoney | 14 | 2 | money
Gross start purch price, curr | Vb_InPris_Start | ztMoney | 14 | 2 | money
Purchase price incl tax | Vb_InPrisInklMoms | ztMoney | 14 | 2 | money
Actual lead time | VerklLedTid | ztInteger | 5 |  | smallint
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: xBpa Display arrival reports


Arrived checked goods (bpaa)

Table of inspected goods.
On receipt and so that an inspection can be made, a row is created in the table for goods to be inspected. When this inspection is complete, the delivery can be entered directly into inventory or marked as inspected and is to be entered into inventory. This table contains transactions of goods that have been inspected and are due to be entered into inventory.
Inventory registration is then done in the usual delivery program.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Use/Best before | BastForeDatum | ztDate |  |  | datetime
Batch no. | BatchID | ztString | 30 |  | varchar
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
Received qty (suppl unit) | BestLevAntExtQty | ZtQty | 14 | 2 | decimal
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
Checked qty | KontrolleratAntal | ZtQty | 14 | 2 | decimal
Checked qty (suppl's unit) | KontrolleratAntalExtQty | ZtQty | 14 | 2 | decimal
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
Corr plan qty (suppl unit) | KorrAntalInExtQty | ZtQty | 14 | 2 | decimal
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Returned qty invtry unit | ReturAnt | ZtQty | 14 | 2 | decimal
Returned qty (suppl unit) | ReturAntExtQty | ZtQty | 14 | 2 | decimal
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Update inventory at inspection | SaldoUpdKontrollAntal | ztBoolean |  |  | char
Create delivery note | SkapaFoljesedel | ztBoolean |  |  | char
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: BpaaQdin Q - data (arrived purchase order)


Arrived goods (bpak)

This table contains all the arrival entries that have not yet been inspected.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Use/Best before | BastForeDatum | ztDate |  |  | datetime
Batch no. | BatchID | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Checked qty | KontrolleratAntal | ZtQty | 14 | 2 | decimal
Checked qty (suppl's unit) | KontrolleratAntalExtQty | ZtQty | 14 | 2 | decimal
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Quantity, alt unit (+/-) | LagtransAntAltEnh | ZtQty | 14 | 2 | decimal
Dispatch notice | LevAviNr | ztString | 35 |  | varchar
Dispatch notice row | LevAviRadNr | ztInteger | 5 |  | int
Signature | PersSign | ztString | 30 |  | varchar
@zPrompt=null | PvmGridNo | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Returned qty invtry unit | ReturAnt | ZtQty | 14 | 2 | decimal
Returned qty (suppl unit) | ReturAntExtQty | ZtQty | 14 | 2 | decimal
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Update inventory at inspection | SaldoUpdKontrollAntal | ztBoolean |  |  | char
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: bpak Arrival check

    Program: BpakQdin Q - data (arrived purchase order)


Assigned project staff (prp)

Staff of a certain project.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Create planned activities | AutoCrePlanEvent | ztBoolean |  |  | char
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: prp Project personnel


Assignment (WMS_Assignment)

Assignment identity.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
X pos, final | AssFinalLocXPos | ztString | 5 |  | varchar
Y pos, final | AssFinalLocYPos | ztString | 5 |  | varchar
MHA, final | AssFinalMha | ztString | 5 |  | varchar
Parent ID, final | AssFinalParentPalletId | ztString | 35 |  | varchar
Rack, final | AssFinalRack | ztString | 5 |  | varchar
Storage type, final | AssFinalStorageTypeCode | ztInteger | 3 |  | smallint
Unit code, final | AssFinalUOM | ztString | 10 |  | varchar
X pos, from | AssFromLocXPos | ztString | 5 |  | varchar
Y pos, from | AssFromLocYPos | ztString | 5 |  | varchar
MHA, from | AssFromMha | ztString | 5 |  | varchar
Parent ID, from | AssFromParentPalletId | ztString | 35 |  | varchar
Rack, from | AssFromRack | ztString | 5 |  | varchar
Storage type, from | AssFromStorageTypeCode | ztInteger | 3 |  | smallint
Unit code, from | AssFromUOM | ztString | 10 |  | varchar
ID | AssId | ZtLong | 9 |  | int
Priority | AssPrio | ztDateTime |  |  | datetime
Qty | AssQty | ZtQty | 14 | 2 | decimal
Status | AssStatusCode | ztInteger | 3 |  | smallint
Sub type | AssSubTypeCode | ztInteger | 3 |  | smallint
X pos, to | AssToLocXPos | ztString | 5 |  | varchar
Y pos, to | AssToLocYPos | ztString | 5 |  | varchar
MHA, to | AssToMha | ztString | 5 |  | varchar
Parent ID, to | AssToParentPalletId | ztString | 35 |  | varchar
Rack, to | AssToRack | ztString | 5 |  | varchar
Storage type, to | AssToStorageTypeCode | ztInteger | 3 |  | smallint
Unit code, to | AssToUOM | ztString | 10 |  | varchar
Type | AssTypeCode | ztInteger | 3 |  | smallint
Batch no. | BatchId | ztString | 30 |  | varchar
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Mobile unit | MobileUnit | ztString | 5 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Queue | Queue | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Shipment plan alpha ID | ShipmPlanAlphaId | ztString | 30 |  | varchar
SKU ID | SKUPalletId | ztString | 35 |  | varchar
Sequence number, TU | TUPalletContSeq | ztInteger | 3 |  | smallint
TU ID | TUPalletId | ztString | 35 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_Assignment Assignments

    Program: WMS_MU_AssMovingByLine Transfer assignment

    Program: WMS_MU_AssPickByFullPall Full pallet picking assignment

    Program: WMS_MU_AssPickByPall Picking assignment

    Program: WMS_MU_AssReplByLine Replenishment assignment

    Program: WMS_MU_AssReplPickByLine Replenishment pick assignment


Assignment classes (xUkl)

Definition of optional classification of assignments.

The classification has no controling function. The only purpose is to simply group and search assignments in different classes, e.g. General agreements/Operation agreements, County council/State/Municipality, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Assignment class | Uppdragsklass | ztInteger | 5 |  | smallint
Assignment class | UppdragsklassBeskr | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: xUkl Assignment classes


Assignment status code (WMS_AssStatusCode)

Code for assignment status. Specifies status for assignment.

The following standard records exist. Do not alter/delete:

Status (AssStatusCode) | Description (AssStatusDesc) | Description
1 | To be performed | Assignment is available and shall be performed.
2 | In progress | Assignment is under preparation and locked to a mobile unit.
9 | Error | An error has been discovered when the assignment was processed.
10 | Cancelled | Assignment is cancelled and will be deleted.
99 | Finished | The assignment has been completed and will be processed or deleted.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Status | AssStatusCode | ztInteger | 3 |  | smallint
Description | AssStatusDesc | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_AssStatusCode Assignment status code


Assignment sub type code (WMS_AssSubTypeCode)

Code for assignment sub type. Specifies sub type of assignment.

The following standard records exist. Do not alter/delete:

Sub type (AssSubTypeCode) | Description (AssSubTypeDesc)
10 | Manufacturing
20 | Purchase
30 | Sales

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sub type | AssSubTypeCode | ztInteger | 3 |  | smallint
Description | AssSubTypeDesc | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_AssSubTypeCode Assignment sub type code


Assignment type code (WMS_AssTypeCode)

Code for assignment type. Specifies type of assignment.

The following standard records exist. Do not alter/delete:

Type (AssTypeCode) | Description (AssTypeDesc)
1 | Transfer
201 | Pick
220 | Full pallet pick
300 | Replenishment
301 | Replenishment pick

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Type | AssTypeCode | ztInteger | 3 |  | smallint
Description | AssTypeDesc | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_AssTypeCode Assignment type code


Assignment, not invoiced, header (vuup)

Main table of uninvoiced events (time and expenses) in assignments.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Deducted invoice | AcDrawn | ztBoolean |  |  | char
Posting template | AutoRegel | ztString | 4 |  | varchar
Agreement type | AvtalsKod | ztInteger | 3 |  | smallint
Payment terms | BetKod | ztString | 2 |  | varchar
Invoicing start date | CheckDagPerAvtal | ztBoolean |  |  | char
Detail posting | Detaljkontering | ztBoolean |  |  | char
District | DistrKod | ztString | 4 |  | varchar
Division code | DivisKod | ztString | 3 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Handling charge | ExpAvgKd | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight charge code | FraktAvgKd | ztBoolean |  |  | char
Delivery note Y/N | FsKd | ztBoolean |  |  | char
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Customer order date | KundBestDat | ztDate |  |  | datetime
Ordering dept | KundBestNamn | ztString | 36 |  | varchar
Customer order no. | KundBestNr | ztString | 30 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Invoicing address | KundFaktAdr | ztString | 36 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Customer reference | KundRef2 | ztString | 30 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Ship documents | LevHandlKod | ztBoolean |  |  | char
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Master project no. | MasterProjCode | ztString | 10 |  | varchar
Max date not invoiced | MaxEjFaktDat | ztDate |  |  | datetime
Min date not invoiced | MinEjFaktDat | ztDate |  |  | datetime
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Quotation/agreement | OffBeskr | ztString | 40 |  | varchar
Quote/Agreemt date | OffertDat | ztDate |  |  | datetime
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Quote/assignment status | OffStatus | ztString | 1 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order date | OrdDatum | ztDate |  |  | datetime
Order cost | OrdKostnad | ZtBaseCurrAmount | 14 | 2 | money
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Order value | OrdSum | ZtBaseCurrAmount | 14 | 2 | money
Order type | OrdTyp | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Service price list | PrislistaT | ztInteger | 6 |  | smallint
Pricing method | PrisTyp | ztInteger | 3 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Collective invoicing ID | SamFaktOffNr | ztString | 30 |  | varchar
Skrivskydd | SkrivUtskSk | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Sum items on invoice | SumitemOnInvoice | ztBoolean |  |  | char
Price ceiling | TakPrisAvt | ZtBaseCurrAmount | 12 | 2 | money
Price ceiling expense | TakPrisEx | ZtBaseCurrAmount | 12 | 2 | money
Invoicing type | UFakttyp | ztInteger | 3 |  | smallint
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Order amount, curr | VbOrdSum | ztMoney | 14 | 2 | money
Our reference | VRef | ztString | 30 |  | varchar


Assignment, not invoiced, service (vush)

Shows what assignments have non-invoiced times and/or expenses from service order. One preliminary invoice is created per service order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Quote/assignment status | OffStatus | ztString | 1 |  | varchar
Serv.order no | ServOrderNr | Jeeves_SONo | 9 |  | bigint


Assignments, collective invoicing (ofsf)

Data on assignments for collective invoicing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Payment terms | BetKod | ztString | 2 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Credit period days | KreditTid | ztInteger | 3 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Collective invoicing ID | SamFaktOffNr | ztString | 30 |  | varchar
Collective invoicing | SamFaktUtskr | ztBoolean |  |  | char
Currency | ValKod | ztString | 3 |  | varchar
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint


Astro installation (AstroInstallation)

Main table for Astro installation settings.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | AstroInstallationDescr | ztString | 50 |  | varchar
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AstroInstallation Astro installation


Attached documents (mld)

Table of documents that will be attached to a message.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Identitetskolumn | ConnToSQLIDENTITY | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
PDM (Unique ID) | pdmdummyuniqueid | ztUniqueIdentifier | 100 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar


Attendance reports (AttR_rep)

Attendancy report.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Calculation info | AttRCalcInfo | ztString | 200 |  | varchar
Report origin date | AttROriginRepDat | ztDateTime |  |  | datetime
Reason | AttRReason | ztString | 6 |  | varchar
Reason txt | AttRReasonText | ztString | 255 |  | varchar
Report date | AttRRepDt | ztDateTime |  |  | datetime
Report date | AttrRepDt_Date | ztDate |  |  | datetime
Report time | AttrRepDt_Time | ztTime | 5 |  | datetime
Report type | AttRRepType | ztInteger | 5 |  | smallint
Statuscode | AttRStatuscode | ztInteger | 5 |  | smallint
Work schedule date | AttRWorkScheduleDat | ztDate |  |  | datetime
Created by object | CreatedByDBObject | ztString | 60 |  | nvarchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | perssign2 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLidentity | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: AttR_rep Attendance reports


AttendanceReport Log (attr_AttendanceReport_Log)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Reason | AttRReason | ztString | 6 |  | nvarchar
Reason description | AttRReasonDescr | ztString | 50 |  | nvarchar
Report date | AttRRepDt | ztDateTime |  |  | datetime
Report type | AttRRepType | ztInteger | 5 |  | smallint
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Note | KortNotering | ztString | 255 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Employee ID | PersSign2 | ztString | 6 |  | nvarchar
Row | RadPos | ZtLong | 10 |  | int
Row | radpos2 | ztInteger | 4 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Process ID | spid | ZtLong | 5 |  | int
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Date/time | StrDateTime | ztString | 28 |  | nvarchar
Language code | zlanguage | ztInteger | 4 |  | smallint
Nest Level | ZNestLevel | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: attr_AttendanceReport_Log AttendanceReport Log


Attendancy calculation (AttR_calclog)

(Temporary) table for attendancy calculations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Balance | AttRBalance | ztFloat | 15 | 2 | float
Calculation info | AttRCalcInfo | ztString | 200 |  | varchar
Compensation dayschedule | AttrDayscheduleComp | ztString | 6 |  | varchar
Formula | AttRFormula | ztString | 100 |  | varchar
From time | AttRFromTime | ztDateTime |  |  | datetime
Salary date | AttRSalaryDat | ztDate |  |  | datetime
Salary type | AttRSalaryType | ZtLong | 10 |  | int
Spid | AttRSpId | ZtLong | 10 |  | int
Time type | AttRTimeType | ztString | 6 |  | varchar
To time | AttRToTime | ztDateTime |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | perssign2 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIdentity | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: AttR_calclog Attendancy calculation log


Attributes for item group (PvmVgAttr)

Alphanumeric code for item group, linked to a description of the item group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Attribute 1 | PVMAttribute1 | ztString | 10 |  | varchar
Attribute 10 | PVMAttribute10 | ztString | 10 |  | varchar
Attribute 2 | PVMAttribute2 | ztString | 10 |  | varchar
Attribute 3 | PVMAttribute3 | ztString | 10 |  | varchar
Attribute 4 | PVMAttribute4 | ztString | 10 |  | varchar
Attribute 5 | PVMAttribute5 | ztString | 10 |  | varchar
Attribute 6 | PVMAttribute6 | ztString | 10 |  | varchar
Attribute 7 | PVMAttribute7 | ztString | 10 |  | varchar
Attribute 8 | PVMAttribute8 | ztString | 10 |  | varchar
Attribute 9 | PVMAttribute9 | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar


Attributes for XML import (TactonAttribute)

Index counter for part

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Name of part | ChildPartName | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Key part 1 | Key1 | ztString | 50 |  | varchar
Key part 2 | Key2 | ztString | 50 |  | varchar
Key part 3 | Key3 | ztString | 50 |  | varchar
Key part 4 | Key4 | ztString | 50 |  | varchar
Key part 5 | Key5 | ztString | 50 |  | varchar
Configurator model ID | ModelId | ztString | 60 |  | varchar
Index of part | PartIndex | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Domain of attribute in XML doc | XmlAttributeDomain | ztString | 255 |  | varchar
Name of attribute in XML doc | XmlAttributeName | ztString | 255 |  | varchar
Val desc of attribute in XML doc | XmlAttributeValDesc | ztString | 255 |  | varchar
Value of attribute in XML doc | XmlAttributeValue | ztString | 255 |  | varchar


Authorization group (AttR_auth)

Authorized groups. Is used to classify personnel to authorized person in Attendance-module. For every authorized person you tied which authorized group to authorize.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Authorization group ID | AttRAuthorizeCode | ztString | 6 |  | varchar
Authorization code | AttRAuthorizeDescr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_auth Authorization groups


Authorization user Wf (prea)

Table with information about Workflow users' user group/level. Depending on the group that the user belongs to, different rights apply for what s/he can see and do in Workflow.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
User group | Accgrp | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Signature | WfPersSign | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: prea Authorization user Wf


Authorization Wf (xag)

In this table, the Workflow administrator sets up user groups and levels, and specifies what rights the group/level has.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
User group | accgrp | ztInteger | 5 |  | smallint
Description | accgrpd | ztString | 255 |  | varchar
Delegate activities | AcDelegate | ztBoolean |  |  | char
Delegate all activities | AcDelegateAll | ztBoolean |  |  | char
Automatic start via Jeeves | AutoRunFromJeeves | ztBoolean |  |  | char
Change all processes | ChangeAllProcess | ztBoolean |  |  | char
Change user authorization | ChangeAllUsersAccess | ztBoolean |  |  | char
Prioritize user activities | ChangeAllUsersPriority | ztBoolean |  |  | char
Create all process types | CreateAllProcess | ztBoolean |  |  | char
Enter user | CreateAllUsers | ztBoolean |  |  | char
Delegate user activities | DelegateAllUsersActivity | ztBoolean |  |  | char
Delete all process types | DeleteAllProcess | ztBoolean |  |  | char
Delete user | DeleteAllUsers | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Start user activities | StartAllUsersActivity | ztBoolean |  |  | char
Show activity type | ViewAcType | ztBoolean |  |  | char
Show own activities | ViewAllInToDoList | ztBoolean |  |  | char
Show own processes | ViewAllProcess | ztBoolean |  |  | char
Show all activities | ViewAllProcInToDoList | ztBoolean |  |  | char
Show all users | ViewAllUsers | ztBoolean |  |  | char
View automatic | ViewAutomatic | ztBoolean |  |  | char
Show Create instances | ViewCreateAllInstance | ztBoolean |  |  | char
Show performed activities | ViewFinished | ztBoolean |  |  | char
Show menu | ViewMenu | ztBoolean |  |  | char
Show pause activity time | ViewPausedDuration | ztBoolean |  |  | char
Show resource | ViewResource | ztBoolean |  |  | char
Show resource group | ViewResourceGrp | ztBoolean |  |  | char
Show start - end time | ViewStartFinish | ztBoolean |  |  | char
Show status | ViewStatus | ztBoolean |  |  | char
Show To-do list | ViewToDo | ztBoolean |  |  | char
Show workflow | ViewWf | ztBoolean |  |  | char
Shows workfl. in bottom window | ViewWfBottom | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xag Authorization Wf


Authorized attendance reporting (AttR_sal_Auth)

Autorization records for a calculated day.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Salary date | attrsalarydat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | perssign2 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_sal_Auth Authorized attendance reportings


Auto allocation rules (fd)

Information in template/rule for auto allocation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Auto allocation rule | AutFordRegel | ztString | 10 |  | varchar
Allocation type | AutFordTyp | ztInteger | 1 |  | smallint
Description | Beskrivning | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 contra acct | K4Mot | ztString | 8 |  | varchar
S4 retrieval code | K4MotHKod | ztchar | 1 |  | char
S4 normal acct | K4Normal | ztString | 8 |  | varchar
S4 retrv code normal | K4NormalHKod | ztchar | 1 |  | char
S5 contra acct | K5Mot | ztString | 8 |  | varchar
S5 retrieval code | K5MotHKod | ztchar | 1 |  | char
S5 normal acct | K5Normal | ztString | 8 |  | varchar
S5 retrv code normal | K5NormalHKod | ztchar | 1 |  | char
S6 contra acct | K6Mot | ztString | 8 |  | varchar
S6 retrieval code | K6MotHKod | ztchar | 1 |  | char
S6 normal acct | K6Normal | ztString | 8 |  | varchar
S6 retrv code normal | K6NormalHKod | ztchar | 1 |  | char
S7 contra acct | K7Mot | ztString | 8 |  | varchar
S7 retrieval code | K7MotHKod | ztchar | 1 |  | char
S7 normal acct | K7Normal | ztString | 8 |  | varchar
S7 retrv code normal | K7NormalHKod | ztchar | 1 |  | char
Mot K8 | K8Mot | ztString | 8 |  | varchar
Hämtkod K8 mot | K8MotHKod | ztchar | 1 |  | char
Normal K8 | K8Normal | ztString | 8 |  | varchar
Hämtkod K8 norm | K8NormalHKod | ztchar | 1 |  | char
S3 contra acct | KBarMot | ztString | 8 |  | varchar
S3 retrieval code | KBarMotHKod | ztchar | 1 |  | char
S3 normal acct | KBarNormal | ztString | 8 |  | varchar
S3 retrv code normal | KBarNormalHKod | ztchar | 1 |  | char
CC contra account | KstMot | ztString | 8 |  | varchar
CC retrieval code | KstMotHKod | ztchar | 1 |  | char
CC normal acct | KstNormal | ztString | 8 |  | varchar
CC retrv code normal | KstNormalHKod | ztchar | 1 |  | char
Contra account | KtoMot | ztString | 8 |  | varchar
Acct retrieval code | KtoMotHKod | ztchar | 1 |  | char
Normal account | KtoNormal | ztString | 8 |  | varchar
Acct code normal | KtoNormalHKod | ztchar | 1 |  | char
Batch number | OmgangsNr | ztInteger | 3 |  | smallint
Contra proj | ProjMot | ztString | 10 |  | varchar
Retrieval code prj | ProjMotHKod | ztchar | 1 |  | char
Normal acct proj | ProjNormal | ztString | 10 |  | varchar
Retrieval code prj | ProjNormalHKod | ztchar | 1 |  | char
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xFd Automatic allocation, new


Auto deliv receiving types (xo8)

Internal definitions specifying a type of automatic delivery from manufacturing.

The following standard records exist. Do not alter/delete:

Auto receiving type (AutInlevTyp) | Automatic receiving type (AutInlevTypBeskr) | Description
0 | No automatic | The item is received manually.
2 | Report final labour operation | The item is received based on an approved manufactured quantity for the operation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Auto receiving type | AutInlevTyp | ztInteger | 5 |  | smallint
Automatic receiving type | AutInlevTypBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xo8 Type of automatic delivery


Auto item surcharge (arta)

Table of surcharges i.e. charges that are automatically to be debited from the customer for sales of a normal stock item, or for purchase orders automatically generate purchase order rows for surcharges.

Auto item surcharge can be used for automatic invoicing of deposits, environmental fees, etc., without the need to enter order rows for these.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no., surcharge | ArtNrAddArt | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: arta Surcharges


Auto material issue types (xo7)

Definitions of material issue types for manufacturing orders which specify whether issue is done automatically and in this case at what stage.

The following standard records exist. Do not alter/delete:

Auto mtrl issue type (AutMtrlUttagTyp) | Auto mtrl issue type (AutMtrlUttagBeskr) | Description
0 | No automatic | Manual material issue.
1 | Operation start | Automatic issue - on startup of an operation, all material reservations belonging to the relevant operation are booked out of the inventory.
2 | Operation reporting | Automatic issue - on reporting of material issue according to reported labour, the material is picked based on the manufactured quantity of the operation. The material is booked out of the inventory in relationship to planned manufacturing and based on the BOM of the manufacturing order (not the BOM register).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Auto mtrl issue type | AutMtrlUttagBeskr | ztString | 50 |  | varchar
Auto mtrl issue type | AutMtrlUttagTyp | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xo7 Type of auto.issue, material


Auto posting & alloc rules, balances (akon)

Information on fiscal year and batch number in rule/template for auto posting and allocation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Batch number | OmgangsNr | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xakon Auto posting/allocation rules, balance


Auto posting rules (aknk)

Information in template/rule for auto postings.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allocation percent | FordProc | ZtDecimal73 | 6 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
From S4 | K4From | ztString | 8 |  | varchar
S4 contra acct | K4Mot | ztString | 8 |  | varchar
S4 retrieval code | K4MotHKod | ztchar | 1 |  | char
S4 normal acct | K4Normal | ztString | 8 |  | varchar
S4 retrv code normal | K4NormalHKod | ztchar | 1 |  | char
To S4 | K4Tom | ztString | 8 |  | varchar
From S5 | K5From | ztString | 8 |  | varchar
S5 contra acct | K5Mot | ztString | 8 |  | varchar
S5 retrieval code | K5MotHKod | ztchar | 1 |  | char
S5 normal acct | K5Normal | ztString | 8 |  | varchar
S5 retrv code normal | K5NormalHKod | ztchar | 1 |  | char
To S5 | K5Tom | ztString | 8 |  | varchar
From S6 | K6From | ztString | 8 |  | varchar
S6 contra acct | K6Mot | ztString | 8 |  | varchar
S6 retrieval code | K6MotHKod | ztchar | 1 |  | char
S6 normal acct | K6Normal | ztString | 8 |  | varchar
S6 retrv code normal | K6NormalHKod | ztchar | 1 |  | char
To S6 | K6Tom | ztString | 8 |  | varchar
From S7 | K7From | ztString | 8 |  | varchar
S7 contra acct | K7Mot | ztString | 8 |  | varchar
S7 retrieval code | K7MotHKod | ztchar | 1 |  | char
S7 normal acct | K7Normal | ztString | 8 |  | varchar
S7 retrv code normal | K7NormalHKod | ztchar | 1 |  | char
To S7 | K7Tom | ztString | 8 |  | varchar
Fr o m K8 | K8From | ztString | 8 |  | varchar
Mot K8 | K8Mot | ztString | 8 |  | varchar
Hämtkod K8 mot | K8MotHKod | ztchar | 1 |  | char
Normal K8 | K8Normal | ztString | 8 |  | varchar
Hämtkod K8 norm | K8NormalHKod | ztchar | 1 |  | char
To S8 | K8Tom | ztString | 8 |  | varchar
From CU | KBarFrom | ztString | 8 |  | varchar
S3 contra acct | KBarMot | ztString | 8 |  | varchar
S3 retrieval code | KBarMotHKod | ztchar | 1 |  | char
S3 normal acct | KBarNormal | ztString | 8 |  | varchar
S3 retrv code normal | KBarNormalHKod | ztchar | 1 |  | char
To S3 | KBarTom | ztString | 8 |  | varchar
Constant | KonstantId | ztString | 15 |  | varchar
From CC | KstFrom | ztString | 8 |  | varchar
CC contra account | KstMot | ztString | 8 |  | varchar
CC retrieval code | KstMotHKod | ztchar | 1 |  | char
CC normal acct | KstNormal | ztString | 8 |  | varchar
CC retrv code normal | KstNormalHKod | ztchar | 1 |  | char
To CC | KstTom | ztString | 8 |  | varchar
Contra account | KtoMot | ztString | 8 |  | varchar
Acct retrieval code | KtoMotHKod | ztchar | 1 |  | char
Normal account | KtoNormal | ztString | 8 |  | varchar
Acct code normal | KtoNormalHKod | ztchar | 1 |  | char
Account | KtoNr | ztString | 8 |  | varchar
Hämtkod kvantitet | KvantMotHKod | ztchar | 1 |  | char
Hämktod kvantitet | KvantNormalHKod | ztchar | 1 |  | char
Batch number | OmgangsNr | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
From project | ProjFrom | ztString | 10 |  | varchar
Contra proj | ProjMot | ztString | 10 |  | varchar
Retrieval code prj | ProjMotHKod | ztchar | 1 |  | char
Normal acct proj | ProjNormal | ztString | 10 |  | varchar
Retrieval code prj | ProjNormalHKod | ztchar | 1 |  | char
To project | ProjTom | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Auto posting rules, vouchers (aknn)

Definition of rules for automatic postings of vouchers.

The rules are used to automatically complete a posting or to allocate a posting at the same moment as a certain posting is created.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allocation percent | FordProc | ZtDecimal73 | 6 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
From integ.source | FromIntSource | ztInteger | 5 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
From S4 | K4From | ztString | 8 |  | varchar
S4 contra acct | K4Mot | ztString | 8 |  | varchar
S4 retrieval code | K4MotHKod | ztchar | 1 |  | char
S4 normal acct | K4Normal | ztString | 8 |  | varchar
S4 retrv code normal | K4NormalHKod | ztchar | 1 |  | char
To S4 | K4Tom | ztString | 8 |  | varchar
From S5 | K5From | ztString | 8 |  | varchar
S5 contra acct | K5Mot | ztString | 8 |  | varchar
S5 retrieval code | K5MotHKod | ztchar | 1 |  | char
S5 normal acct | K5Normal | ztString | 8 |  | varchar
S5 retrv code normal | K5NormalHKod | ztchar | 1 |  | char
To S5 | K5Tom | ztString | 8 |  | varchar
From S6 | K6From | ztString | 8 |  | varchar
S6 contra acct | K6Mot | ztString | 8 |  | varchar
S6 retrieval code | K6MotHKod | ztchar | 1 |  | char
S6 normal acct | K6Normal | ztString | 8 |  | varchar
S6 retrv code normal | K6NormalHKod | ztchar | 1 |  | char
To S6 | K6Tom | ztString | 8 |  | varchar
From S7 | K7From | ztString | 8 |  | varchar
S7 contra acct | K7Mot | ztString | 8 |  | varchar
S7 retrieval code | K7MotHKod | ztchar | 1 |  | char
S7 normal acct | K7Normal | ztString | 8 |  | varchar
S7 retrv code normal | K7NormalHKod | ztchar | 1 |  | char
To S7 | K7Tom | ztString | 8 |  | varchar
Fr o m K8 | K8From | ztString | 8 |  | varchar
Mot K8 | K8Mot | ztString | 8 |  | varchar
Hämtkod K8 mot | K8MotHKod | ztchar | 1 |  | char
Normal K8 | K8Normal | ztString | 8 |  | varchar
Hämtkod K8 norm | K8NormalHKod | ztchar | 1 |  | char
To S8 | K8Tom | ztString | 8 |  | varchar
From CU | KBarFrom | ztString | 8 |  | varchar
S3 contra acct | KBarMot | ztString | 8 |  | varchar
S3 retrieval code | KBarMotHKod | ztchar | 1 |  | char
S3 normal acct | KBarNormal | ztString | 8 |  | varchar
S3 retrv code normal | KBarNormalHKod | ztchar | 1 |  | char
To S3 | KBarTom | ztString | 8 |  | varchar
Constant | KonstantId | ztString | 15 |  | varchar
From CC | KstFrom | ztString | 8 |  | varchar
CC contra account | KstMot | ztString | 8 |  | varchar
CC retrieval code | KstMotHKod | ztchar | 1 |  | char
CC normal acct | KstNormal | ztString | 8 |  | varchar
CC retrv code normal | KstNormalHKod | ztchar | 1 |  | char
To CC | KstTom | ztString | 8 |  | varchar
Contra account | KtoMot | ztString | 8 |  | varchar
Acct retrieval code | KtoMotHKod | ztchar | 1 |  | char
Normal account | KtoNormal | ztString | 8 |  | varchar
Acct code normal | KtoNormalHKod | ztchar | 1 |  | char
Account | KtoNr | ztString | 8 |  | varchar
Hämtkod kvantitet | KvantMotHKod | ztchar | 1 |  | char
Hämktod kvantitet | KvantNormalHKod | ztchar | 1 |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Batch number | OmgangsNr | ztInteger | 3 |  | smallint
Only single posting | OnlySinglePosting | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
From project | ProjFrom | ztString | 10 |  | varchar
Contra proj | ProjMot | ztString | 10 |  | varchar
Retrieval code prj | ProjMotHKod | ztchar | 1 |  | char
Normal acct proj | ProjNormal | ztString | 10 |  | varchar
Retrieval code prj | ProjNormalHKod | ztchar | 1 |  | char
To project | ProjTom | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
To integ.source | ToIntSource | ztInteger | 5 |  | smallint
To account no. | TomKtoNr | ztString | 8 |  | varchar
Cell no. | VATcellno | ztInteger | 5 |  | smallint
Cell no., base | VATcellno_basis | ztInteger | 5 |  | smallint
Tax period | VATPeriod | ztString | 8 |  | varchar
Posting type | verkonttyp | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: Aknn Auto posting/allocation rules, vouchers


Auto posting/allocation constants (akk)

Definition of constants, i.e. fixed percentages or amounts that recur in auto postings and/or allocations. Example: relevant percentage for social charges on salaries. If you set this up as a constant, in the event of new rules you only need to change the percentage in one place.

Constants are defined per fiscal year with a designation, description and the current percentage rate or amount.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Constant | AkkBeskrivning | ztString | 30 |  | varchar
Unit price | APris | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Constant | KonstantId | ztString | 15 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Percentage | Procent | ZtDecimal73 | 7 | 2 | decimal
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xAkk Auto posting/allocation constants


Automatic posting trace (akvt)

Detailed information regarding posting per transaction from auto posting.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Auto allocation rule | AutFordRegel | ztString | 10 |  | varchar
Batch no. | AutKontNr | ztInteger | 4 |  | smallint
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Amount to auto post | EjAutKontBel | ZtBaseCurrAmount | 14 | 2 | money
Quantity to auto post | EjAutKontKvant | ztFloat | 15 | 2 | float
Curr.amt to auto post | EjAutKontVbBelopp | ztMoney | 14 | 2 | money
Allocate to S4 | FordTillK4 | ztString | 8 |  | varchar
Allocate to S5 | FordTillK5 | ztString | 8 |  | varchar
Allocate to S6 | FordTillK6 | ztString | 8 |  | varchar
Allocate to S7 | FordTillK7 | ztString | 8 |  | varchar
Fördelas till K8 | FordTillK8 | ztString | 8 |  | varchar
Allocate to S3 | FordTillKBar | ztString | 8 |  | varchar
Allocate to cost ctr | FordTillKst | ztString | 8 |  | varchar
Allocate to account | FordTillKto | ztString | 8 |  | varchar
Allocate to project | FordTillPrj | ztString | 10 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Batch number | OmgangsNr | ztInteger | 3 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Sequence | Sequence | ztInteger | 3 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: vAkvt Show auto posting/allocation and source


Automatic sequence number series (xtf)

Definition of sequence number series used for automatic numbering during a new setup of company, assignment/quotations and project.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sequence no. type | CompanyType | ztInteger | 4 |  | smallint
Include assignment no. | CompanyTypeAssignNo | ztBoolean |  |  | char
Include company no. | CompanyTypeCoNo | ztBoolean |  |  | char
Sequence no. type | CompanyTypedescr | ztString | 40 |  | varchar
Max length | CompanyTypeLength | ztInteger | 2 |  | smallint
To sequence no. | CompanyTypeMaxNo | ZtLong | 9 |  | int
From sequence no. | CompanyTypeMinNo | ZtLong | 9 |  | int
Next sequence no. | CompanyTypeNextNo | ZtLong | 9 |  | int
Man change not allowed | CompanyTypeNoChange | ztBoolean |  |  | char
Seq no. type prefix | CompanyTypePrefix | ztString | 10 |  | varchar
Sequence no. on save | CompanyTypeSave | ztBoolean |  |  | char
Seq no. type suffix | CompanyTypeSuffix | ztString | 10 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Locked | LockedForUse | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xtf Automatic sequence number series


Automatic sequence number series (view 2) (vxtf1)

Definition of sequence number series used for automatic numbering during a new setup of company, assignment/quotations and project.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sequence no. type | CompanyType | ztInteger | 4 |  | smallint
Include assignment no. | CompanyTypeAssignNo | ztBoolean |  |  | char
Include company no. | CompanyTypeCoNo | ztBoolean |  |  | char
Sequence no. type | CompanyTypedescr | ztString | 40 |  | varchar
Max length | CompanyTypeLength | ztInteger | 2 |  | smallint
To sequence no. | CompanyTypeMaxNo | ZtLong | 9 |  | int
From sequence no. | CompanyTypeMinNo | ZtLong | 9 |  | int
Next sequence no. | CompanyTypeNextNo | ZtLong | 9 |  | int
Seq no. type prefix | CompanyTypePrefix | ztString | 10 |  | varchar
Sequence no. on save | CompanyTypeSave | ztBoolean |  |  | char
Seq no. type suffix | CompanyTypeSuffix | ztString | 10 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: vxtf1 Automatic sequence number series cash out


Automatic sequence number series (view) (vxtf)

Definition of sequence number series used for automatic numbering during a new setup of company, assignment/quotations and project.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sequence no. type | CompanyType | ztInteger | 4 |  | smallint
Include assignment no. | CompanyTypeAssignNo | ztBoolean |  |  | char
Include company no. | CompanyTypeCoNo | ztBoolean |  |  | char
Sequence no. type | CompanyTypedescr | ztString | 40 |  | varchar
Max length | CompanyTypeLength | ztInteger | 2 |  | smallint
To sequence no. | CompanyTypeMaxNo | ZtLong | 9 |  | int
From sequence no. | CompanyTypeMinNo | ZtLong | 9 |  | int
Next sequence no. | CompanyTypeNextNo | ZtLong | 9 |  | int
Seq no. type prefix | CompanyTypePrefix | ztString | 10 |  | varchar
Sequence no. on save | CompanyTypeSave | ztBoolean |  |  | char
Seq no. type suffix | CompanyTypeSuffix | ztString | 10 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: vxtf Automatic sequence number series cash in


Automation creating of purchase order ICT (ICTPOCreateType)

Definition of existing types of automation regarding creation of purchase orders in ICT.

The following standard records exist. Do not alter/delete:

Auto create PO ICT (ICTPOCreateType) | Auto create PO ICT (ICTPOCreateTypeDescr) | Description
0 | Directly on order row entry | During order row entry for a customer order in a selling unit, automatically create a purchase order in the selling unit and a corresponding customer order in the delivering unit.
1 | At close of order row entry | When the user leaves order row entry for a customer order in a selling unit, automatically create a purchase order in the selling unit and a corresponding customer order in the delivering unit.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Auto create PO ICT | ICTPOCreateType | ztInteger | 5 |  | smallint
Auto create PO ICT | ICTPOCreateTypeDescr | ztString | 50 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ICTPOCreateType Automation creating purchase order ICT


Automation delivering of purchase order ICT (ICTDelivType)

Definition of existing types of received delivery automation regarding purchase orders in conjunction with ICT.

The following standard records exist. Do not alter/delete:

Auto recvd deliv PO ICT (ICTDelivType) | Auto recvd deliv PO ICT (ICTDelivTypeDescr) | Description
0 | No auto-rec. deliv., NO check against dispatch | NO automation for received delivery from delivering unit to selling unit. When manually receiving delivery in selling unit, Jeeves does NOT check that customer order at delivering unit has been picked. This option cannot be combined with close of supplier invoice with invoice matching.
1 | No auto-rec. deliv., check against dispatch | NO automation for received delivery from delivering unit to selling unit. When manually receiving delivery in selling unit, Jeeves checks that customer order at delivering unit has been picked. This option cannot be combined with close of supplier invoice with invoice matching.
2 | On picking customer order in delivering unit | In conjunction with picking for customer orders in a supplying business unit, received delivery is made automatically for purchase order in the selling business unit
3 | On releasing customer order in delivering unit | In conjunction with release of customer order in a supplying business unit, received delivery is made automatically for purchase order in the selling business unit

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Auto recvd deliv PO ICT | ICTDelivType | ztInteger | 5 |  | smallint
Auto recvd deliv PO ICT | ICTDelivTypeDescr | ztString | 50 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ICTDelivType Automation delivering of purchase order ICT


Automation modes (xwat)

In this table, Jeeves Information Systems sets up the automation types that can occur for activities in a workflow in Workflow.

The following standard records exist. Do not alter/delete:

Automation modes (automationmode) | Automation modes (automationmoded)
10 | Manual
20 | Automatic
30 | Automatic Sql-Agent

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Automation modes | AutomationMode | ztInteger | 5 |  | smallint
Automation modes | AutomationModeD | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xwat Automation modes


Aux properties from configurator (TactonAux)

Auxiliary properties from the Sales configurator.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Key part 1 | Key1 | ztString | 50 |  | varchar
Key part 2 | Key2 | ztString | 50 |  | varchar
Key part 3 | Key3 | ztString | 50 |  | varchar
Key part 4 | Key4 | ztString | 50 |  | varchar
Key part 5 | Key5 | ztString | 50 |  | varchar
Configurator model ID | ModelId | ztString | 60 |  | varchar
Index of part | PartIndex | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Aux property name | XmlAuxName | ztString | 255 |  | varchar
Aux property value | XmlAuxValue | ztString | 255 |  | varchar


Availability check status codes (xbks)

Table of the different availability check statuses that exist in the system. This is used to check whether there is a sufficient quantity of goods in inventory.

The following standard records exist. Do not alter/delete:

Avail check status code (BristKontrolleradStatus) | Avail check status code (BristKontrolleradStatusB)
0 | Not inspected
40 | Shortage on available balance
60 | Shortage in inventory
100 | OK, available balance
200 | OK, inventory balance
900 | Processing complete

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Avail check status code | BristKontrolleradStatus | ztInteger | 5 |  | smallint
Avail check status code | BristKontrolleradStatusB | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xbks Availability check status codes


Available/visible menus (JvsSiteMenuConnection)

Program/table for viewing which menus are available/visible for a specific user, a user group or all users.

By visible we mean menus that are displayed directly to the user(s) in the program menu window. By available we mean menus that are not displayed directly, but can be selected by using the Connected program menus option. Which menus are visible and which menus are only available are set up using the Connect program menus option.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Menu name (lang) | JvsSiteMenuName_Lang |  |  |  | @DataType=NULL
Visible | JvsSiteMenuVisible | ztBoolean |  |  | char
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Menu ID | MenuId | ZtLong | 5 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteMenuConnection Available/visible menus


Backorder handling codes (x1r)

The table contains the different ways of dealing with backorders that are possible in the system.
This is used to define how any remaining quantity that may arise during delivery or dispatch is to be handled in the system.

The following standard records exist. Do not alter/delete:

Backorder handling (RestBehKod) | Backorder handling (RestBehBeskr)
0 | Create backorder
1 | Cancel remain qty
2 | Part delivery NOT allowed

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Backorder handling | RestBehBeskr | ztString | 50 |  | varchar
Backorder handling | RestBehKod | ztInteger | 1 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xx1r Backorder handling codes


Balance per day, account per currency (kodc)

Data in a work table for creating account balances for a given date and currency.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Year opening balance | AretsIngBalans | ZtBaseCurrAmount | 14 | 2 | money
Accounting date | BokfDat | ztDate |  |  | datetime
Day's net amount | DagensNetto | ZtBaseCurrAmount | 14 | 2 | money
Day opening bal | DagIngSaldo | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Accounting date (from) | FromBokfDat | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
Period opening bal | PerIngSaldo | ZtBaseCurrAmount | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Closing balance | UtgSaldo | ZtBaseCurrAmount | 14 | 2 | money
Currency | ValKod | ztString | 3 |  | varchar
Year OB curr | VbAretsIngBal | ztMoney | 14 | 2 | money
Day's net balance curr | VbDagensNetto | ztMoney | 14 | 2 | money
Day OB, curr | VbDagIngSaldo | ztMoney | 14 | 2 | money
Period OB, curr | VbPerIngSaldo | ztMoney | 14 | 2 | money
Closing balance, curr | VbUtgSaldo | ztMoney | 14 | 2 | money


Balance types in MRP (xnes)

Codes for controlling how net requirement is to process existing inventory and existing customer orders. The codes are used in the program Pre-settings, net requirements (nefi) and in the item program.

The following standard records exist. Do not alter/delete:

Balance type at MRP (NE_SaldoTyp) | Balance type at MRP (NE_SaldoTypBeskr) | Description
1 | "Normal" net requirement | "Normal" net requirement
2 | Gross requirement | Does not include inventory balance or customer orders. This alternative can be used for items manufactured the entire year but only sold/used during a portion of the year (season). Then you have manufacturing according to the sales forecast.
3 | Stock requirement | Does not include customer orders. This alternative can be used for items that are sold from inventory (open customer orders must be dispatched directly).
4 | Gross requirement, sales forecast | Does not include planned inventory transactions except for sales forecast.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Balance type at MRP | NE_SaldoTyp | ztInteger | 5 |  | smallint
Balance type at MRP | NE_SaldoTypBeskr | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xnes MRP balance types


Balance VIEW (vbal)

Accounting period within a fiscal year. Any number of periods can be defined.

After the last accounting period, any number of periods can be defined as closing periods. Period 0 is, as standard, reserved for opening balance. The time extent of closing or OB period is not affected by the extent of the normal periods.

A default period can be specified in System data/account (Sye), in which case a default period is proposed in the program:
- Show posted vouchers (vvr)
- Show non-updated vouchers (vejupdvr)
- Show all voucher rows (vallavr)
- Show posted voucher rows (vvr_sy2)
- Show period balance, acc. and CC (xtkt)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Year opening balance | AretsIngBalans |  |  |  | @DataType=NULL
Årets IB budget | AretsIngBalans_b |  |  |  | @DataType=NULL
Ing balans f år | AretsIngBalans_f |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Integration detail | IntField |  |  |  | @DataType=NULL
Cost centre | KostStalleKod |  |  |  | @DataType=NULL
Cost centre | KstBeskr |  |  |  | @DataType=NULL
Account | KtoBeskr |  |  |  | @DataType=NULL
Account | KtoNr |  |  |  | @DataType=NULL
Period opening bal | PerIngSaldo |  |  |  | @DataType=NULL
Period budget open bal | PerIngSaldo_b |  |  |  | @DataType=NULL
Ing saldo f.år | PerIngSaldo_f |  |  |  | @DataType=NULL
Period | Period |  |  |  | @DataType=NULL
Period balace | PerSaldo |  |  |  | @DataType=NULL
Period budget bal | PerSaldo_b |  |  |  | @DataType=NULL
Per saldo f.år | PerSaldo_f |  |  |  | @DataType=NULL
Fiscal year | RedovisnAr |  |  |  | @DataType=NULL
Closing balance | UtgSaldo |  |  |  | @DataType=NULL
Closing budget bal | UtgSaldo_b |  |  |  | @DataType=NULL
Utg saldo f.år | UtgSaldo_f |  |  |  | @DataType=NULL


Balance/curr (tktc_query)

Balance records by currency in the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Year opening balance | AretsIngBalans | ZtBaseCurrAmount | 14 | 2 | money
Year OB deb | AretsIngBalansDeb | ZtBaseCurrAmount | 14 | 2 | money
Year OB cre | AretsIngBalansKre | ZtBaseCurrAmount | 14 | 2 | money
Year OB curr | AretsIngBalansValuta | ztMoney | 14 | 2 | money
Budgeted amount | BudgBelopp | ZtBaseCurrAmount | 14 | 2 | money
Budgeted quantity | BudgKvantitet | ztFloat | 15 | 2 | float
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Tax base amount | MomsGrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
Account record | OnlyAccount | ztBoolean |  |  | char
Period | Period | ztInteger | 4 |  | smallint
Period ing saldo | PeriodensIngBalans | ZtBaseCurrAmount | 14 | 2 | money
Period opening bal deb | PeriodensIngBalansDeb | ZtBaseCurrAmount | 14 | 2 | money
Period opening bal cre | PeriodensIngBalansKre | ZtBaseCurrAmount | 14 | 2 | money
Period OB curr | PeriodensIngBalansValuta | ztMoney | 14 | 2 | money
Periodens nettobelopp | PeriodensNetto | ZtBaseCurrAmount | 14 | 2 | money
Period net amount curr | PeriodensNettoValuta | ztMoney | 14 | 2 | money
Closing balance | PeriodensUtgSaldo | ZtBaseCurrAmount | 14 | 2 | money
Closing balance deb | PeriodensUtgSaldoDeb | ZtBaseCurrAmount | 14 | 2 | money
Closing balance cre | PeriodensUtgSaldoKre | ZtBaseCurrAmount | 14 | 2 | money
Closing balance curr | PeriodensUtgSaldoValuta | ztMoney | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: tktc0_query Query period balance, account and account seg per currency

    Program: tktc1_query Query period balance, account per currency


Balances, item, bin, batch, SN (arsi)

Data on in which bin an item can be found, inventory balance, batch number and serial number.
Records are created in the table on receipt of goods to inventory.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Qty being picked | AntalUnderPlock | ZtQty | 14 | 2 | decimal
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Use/Best before | BastForeDatum | ztDate |  |  | datetime
Batch no. | BatchId | ztString | 30 |  | varchar
Purchase price | BestInPris | ZtBaseCurrAmount | 14 | 2 | money
Delivery received date | BestLevDat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Physical inventory | InvAntal | ZtQty | 14 | 2 | decimal
Physical invtry date | InventeringsDatum | ztDate |  |  | datetime
Phys invtry journ no. | InvJournal | ZtLong | 5 |  | int
Physical invtry diff YTD | LagDiffAnt | ZtQty | 14 | 2 | decimal
Physical inventory | LagInvAnt | ZtQty | 14 | 2 | decimal
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Movement qty | LagRorAnt | ZtLong | 8 |  | int
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Invtry balance, alt unit | LagsaldoAltEnh | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Last disp date | SenUtlevDat | ztDate |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Physical inventory | UnderInventering | ztBoolean |  |  | char
Last sale date | ValidityDate | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: Arsi Item, bin, balance

    Program: ArsiB Item, bin, balance (all)

    Program: ArsiCOA Order-inventory connection

    Program: WMS_PartBalance Item balance, SKUs


Balances, order-specific inventory, LOG (arsl)

Log table showing changes to the order-specific inventory balance.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Cost price at order | ArtKalkPrisO | ZtBaseCurrAmount | 14 | 2 | money
Cost at order (refinement) | ArtKalkPrisOForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost at order (mtrl) | ArtKalkPrisOMtrl | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Receiving value | InlevKalkVarde | ZtBaseCurrAmount | 14 | 2 | money
Calc val rcvd mtrl | InlevKalkVardeMtrl | ZtBaseCurrAmount | 14 | 2 | money
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Physical inventory | InvAntal | ZtQty | 14 | 2 | decimal
Physical invtry date | InventeringsDatum | ztDate |  |  | datetime
Phys invtry journ no. | InvJournal | ZtLong | 5 |  | int
Inventory value, cost price | KalkLagerVarde | ZtBaseCurrAmount | 14 | 2 | money
Invtry value, refinement price | KalkLagerVardeForadling | ZtBaseCurrAmount | 14 | 2 | money
Inventory value, cost price | KalkLagerVardeForandring | ZtBaseCurrAmount | 14 | 2 | money
Invtry value, material price | KalkLagerVardeMtrl | ZtBaseCurrAmount | 14 | 2 | money
Orderspec rcv CC | KstOULager | ztString | 8 |  | varchar
Orderspec rcv account | KtoNrOULager | ztString | 8 |  | varchar
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Transaction date | LagTransDatum | ztDate |  |  | datetime
Sequence no. | LopNr | ZtLong | 10 |  | int
Actual material cost | MtrlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (refinement) | MtrlVerklKostForadling | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (mtrl) | MtrlVerklKostMtrl | ZtBaseCurrAmount | 14 | 2 | money
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Ord-spec invtry bal | OrderUniktLager | ZtQty | 14 | 2 | decimal
Ord-spec invtry bal change | OrderUniktLagerTransKvant | ZtQty | 14 | 2 | decimal
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Date/time | StrDateTime | ztString | 28 |  | varchar
Deliv from MO | UttagFranAoNr | Jeeves_MONo | 7 |  | bigint
Deliv from MO Pos | UttagFranAoPos | ztInteger | 5 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Gross purch price, curr (mtrl) | vb_inpris_mtrl | ztMoney | 14 | 2 | money


Bank account types (x2bt)

Type of bank account. ((Used only in Finland))

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Bank acct check type | BankKontoTyp | ztString | 4 |  | varchar
Bank acct type desc | BankKontoTypBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: x2bt Bank account type


Bank accounts (syk)

Definition of your company’s bank account number which is used for incoming and outgoing payments with a possibility for automatic control of the number and for a link to an outgoing payment method, payment route, and bank.

If your own company has multiple bank or plus giro numbers, enter them here. Please note that the payment method must be specified for each bank and giro number. In the payment method field, specify the relevant bank /plus giro number in the “Account with bank” field in the header of the payment journal.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Bank | BankId | ztString | 10 |  | varchar
Account at bank | BankKonto | ztString | 40 |  | varchar
Bank acct check type | BankKontoTyp | ztString | 4 |  | varchar
Charge account | BgUtlBelKto | ztString | 1 |  | varchar
Local bank code | FilialKod | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Code key | KodNyckel | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SWIFT code | SwiftKod | ztString | 15 |  | varchar
Payment route | UtbetalningsVag | ztString | 6 |  | varchar
Payment methods | UtbSlag | ztString | 3 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar

    This table is the main table in the following programs:

    Program: Syk Bank accounts


Bank file (bank)

Note that this function is only used in some countries, e.g. Finland and France.

Definition of the banks that are used for outgoing or incoming payments. Each bank is linked to a company in the company file, from where address details are taken. The SWIFT code is also given.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Template AP | AP_AutoRegel | ztString | 4 |  | varchar
Template AR | AR_AutoRegel | ztString | 4 |  | varchar
Bank | BankId | ztString | 10 |  | varchar
Bank | BankIdBeskr | ztString | 40 |  | varchar
Branch info 1 | Filial_Info_1 | ztString | 60 |  | varchar
Branch info 2 | Filial_Info_2 | ztString | 60 |  | varchar
Local bank code | FilialKod | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Code key | KodNyckel | ztString | 2 |  | varchar
Own account at bank | OwnBankAccount | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SWIFT code | SwiftKod | ztString | 15 |  | varchar
SWIFT bank location | SwiftMotBankOrt | ztString | 22 |  | varchar

    This table is the main table in the following programs:

    Program: bank Bank details


Bank Giro payment files (lrbg)

Created bank giro payment files.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
80 chars fixed | char80 | ztchar | 80 |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Row | RadPos | ZtLong | 10 |  | int
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int


Bank Giro payment files (lrbu)

Created bank giro invoice payment service files.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
80 chars fixed | char80 | ztchar | 80 |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Row | RadPos | ZtLong | 10 |  | int
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Pmt service journal no. | UtbServJournNr | ZtLong | 6 |  | int


Bank payment details (lrkd)

Details (paid invoices) are stored in this table when completed payments are loaded from the bank. This is done via the import/conversion program (sthi). The approved outgoing payments then create an outgoing payment journal.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Deducted amount BCU | InbAvdrag | ZtBaseCurrAmount | 14 | 2 | money
Early settlmt discnt BCU | InbKassaRab | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Invoice date | LevFaktDat | ztDate |  |  | datetime
Due date | LrFaktFfDat | ztDate |  |  | datetime
Receipt status | LrkdStatus | ztInteger | 5 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Interim vouch no. | MVerNr | Jeeves_VchrNo | 9 |  | bigint
Project ID | ProjCode | ztString | 10 |  | varchar
RadFelNr | RadFelNr | ztInteger | 4 |  | smallint
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Plan/paid amt, BCU | UtbBel | ZtBaseCurrAmount | 14 | 2 | money
Outgoing payment date | UtbDat | ztDate |  |  | datetime
Payment route | UtbetalningsVag | ztString | 6 |  | varchar
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int
Pmt journal no. | UtbKvittensJournNr | ZtLong | 10 |  | int
Payment methods | UtbSlag | ztString | 3 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Deducted amount, curr | VbInbAvdrag | ztMoney | 11 | 2 | money
Early settlmt discnt, curr | VbKassaRab | ztMoney | 14 | 2 | money
Plan/paid amt, curr | VBUtbBel | ztMoney | 14 | 2 | money
Text/info | x255 | ztString | 255 |  | varchar
Text/info | x255_2 | ztString | 255 |  | varchar
Text 3 | x255_3 | ztString | 255 |  | varchar
Text 4 | x255_4 | ztString | 255 |  | varchar


Bank payment file, DUMP? (lrin)

Created bank payment files....

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Text/info | x255 | ztString | 255 |  | varchar
Text/info | x255_2 | ztString | 255 |  | varchar
Text 3 | x255_3 | ztString | 255 |  | varchar
Text 4 | x255_4 | ztString | 255 |  | varchar


Bank payment header (lrkh)

When completed payments are loaded from the bank via the import conversion program (sthi), a main record is created for the load. Detail rows (outgoing payments) for the load are linked to this main record.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Bank charge | BankKost | ZtBaseCurrAmount | 9 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Receipt date | KvittensDatum | ztDate |  |  | datetime
Receipt status | KvittensStatus | ztInteger | 5 |  | smallint
Receipt time | KvittensTid | ztTime | 5 |  | datetime
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
RadFelNr | RadFelNr | ztInteger | 4 |  | smallint
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Total qty | Tot_AntInb | ZtLong | 10 |  | int
Total payment | Tot_InbBel | ZtBaseCurrAmount | 14 | 2 | money
Plan/paid amt, BCU | UtbBel | ZtBaseCurrAmount | 14 | 2 | money
Outgoing payment date | UtbDat | ztDate |  |  | datetime
Payment route | UtbetalningsVag | ztString | 6 |  | varchar
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int
Payment journal status | UtbJournStatusKod | ztInteger | 1 |  | smallint
Pmt journal no. | UtbKvittensJournNr | ZtLong | 10 |  | int
Payment methods | UtbSlag | ztString | 3 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Plan/paid amt, curr | VbUtbBel | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: lrkh Outgoing payment receipts


Basic data (WMS_BasicData)

Specifies the key name of the module parameter.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Key name | KeyName | ztString | 50 |  | varchar
Key value | KeyValue | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Batches (receiving details) (bat)

Information on batches (received delivery ID), i.e. received deliveries which are tagged with a batch number. Inventory balance, reservations, status codes, notes, etc. are also stored on the batch.

You must specify a batch number at received delivery of items that are stocked in batches. The number can be an internal sequence number within the company, the supplier’s delivery note number, a separate manufacturing number, and so on.

The batch number is also required at picking to MPC or against a customer order, and in this way you can trace to whom a batch or lot has been delivered.

This can be used to follow up received deliveries, e.g. in order to trace lots with errors, at booking and picking and in FIFO valuation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Qty being picked | AntalUnderPlock | ZtQty | 14 | 2 | decimal
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Use/Best before | BastForeDatum | ztDate |  |  | datetime
Quantity available for booking | BatchAntalSomKanBokas | ztDate |  |  | datetime
Batch description | BatchDescr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Booking allowed | BatchOkToBook | ztBoolean |  |  | char
Picking allowed | BatchOkToUse | ztBoolean |  |  | char
Batch Res | BatchRes | ZtQty | 8 | 2 | decimal
Batch balance | BatchSaldo | ZtQty | 14 | 2 | decimal
Batch balance, alt unit | BatchSaldoAltEnh | ZtQty | 14 | 2 | decimal
Batch status | BatchStatusKod | ztInteger | 2 |  | smallint
Purchase price | BestInPris | ZtBaseCurrAmount | 14 | 2 | money
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
Delivery received date | BestLevDat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Invc checked qty | FaktAvprAntal | ZtQty | 14 | 2 | decimal
Invc match value BCU | FaktAvprVardeBas | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Included in available balance | InclInAvailInvtBal | ztBoolean |  |  | char
Receive to inventory value | InlevLagerVarde | ZtBaseCurrAmount | 14 | 2 | money
Physical invtry date | InventeringsDatum | ztDate |  |  | datetime
Physical invtry diff YTD | LagDiffAnt | ZtQty | 14 | 2 | decimal
Amount to match | LagerVardeAttFaktAvpr | ZtBaseCurrAmount | 14 | 2 | money
Value to price | LagerVardeEnlInPris | ztBoolean |  |  | char
Physical inventory | LagInvAnt | ZtQty | 14 | 2 | decimal
Movement qty | LagRorAnt | ZtLong | 8 |  | int
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Last sale date, man | ManValidityDate | ztBoolean |  |  | char
FIFO | Mark_FIFO | ztBoolean |  |  | char
LIFO | Mark_LIFO | ztBoolean |  |  | char
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Period closing batch bal | PerUtgBatchSaldo | ZtQty | 14 | 2 | decimal
Per closing batch value | PerUtgBatchVarde | ZtBaseCurrAmount | 14 | 2 | money
Period closing stock (batch) | PerUtgLagVardeBatch | ZtBaseCurrAmount | 14 | 2 | money
Project ID | ProjCode | ztString | 10 |  | varchar
Act grade | QActGrade | ztFloat | 15 | 2 | float
Act gravity | QActGravity | ztFloat | 15 | 2 | float
Act moiety | QActMoiety | ztFloat | 15 | 2 | float
Act potency | QActPotency | ztFloat | 15 | 2 | float
Calc rec value (added costs) | RecDelValueAddedCosts | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Last disp date | SenUtlevDat | ztDate |  |  | datetime
Last sale date | ValidityDate | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: bat Batches

    Program: CalcBat Purchase cost per batch


Bill of exchange (vxrb)

The table contains information about bills of exchange which are created in the BOE ledger, both bills received from a customer and bills sent to a supplier, irrespective of status.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Acceptance due date | BOE_AcceptDt | ztDate |  |  | datetime
Bank charge | BoE_BankAmt | ZtBaseCurrAmount | 14 | 2 | money
OutPmtJournal canc BOE | BoE_Cancel_AP_Journal | ZtLong | 10 |  | int
IncPmtJournal canc BOE | BoE_Cancel_AR_Journal | ZtLong | 10 |  | int
Due date for BoE | BoE_DueDt | ztDate |  |  | datetime
Paid before due date | BoE_Fore_FFDat | ztBoolean |  |  | char
Individual bill of exchnge | BoE_Ind | ztBoolean |  |  | char
Interest amount | BoE_IntrstAmt | ZtBaseCurrAmount | 14 | 2 | money
Journal type | BoE_Journal_Type | ztInteger | 5 |  | smallint
BOE journal no | BoE_JourNNo | ZtLong | 10 |  | int
BOE journal no paid | BoE_JournNo_Def | ZtLong | 9 |  | int
BOE journal no collection | BoE_JournNo_Ink | ZtLong | 9 |  | int
Bill of exchange no. | BoE_No | ZtLong | 9 |  | int
Bill number alpha | BoE_No_Alfa | ztString | 60 |  | varchar
Original ops end date | BoE_Old_DueDate | ztDate |  |  | datetime
BOE status | BoE_Status | ztInteger | 5 |  | smallint
Bank cost, currency | BoE_VbBankAmt | ztMoney | 14 | 2 | money
Interest amount, curr | BoE_VbIntrstAmt | ztMoney | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Acc rec/Acc pay | KRorLR | ztInteger | 5 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Urspr valutakurs | OldValKurs | ZtCurrencyRate | 15 | 7 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Acceptance journal | RemJrnlNo | ZtLong | 9 |  | int
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Plan/paid amt, BCU | UtbBel | ZtBaseCurrAmount | 14 | 2 | money
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int
Payment methods | UtbSlag | ztString | 3 |  | varchar
Invc amt in 3rd currency | V3_FaktSum | ztMoney | 14 | 2 | money
Third currency | V3_ValKod | ztString | 3 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Plan/paid amt, curr | VbUtbBel | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: vxrb Bills of exchange


Billing codes (Xdbk)

Definition of billing codes used to determine whether closed service order rows will be invoiced, and if so in which routine.

The following standard records exist. Do not alter/delete:

Charge (debkod) | Charge (debkodB) | Description
0 | No invoicing | No logic is built into Jeeves standard for this billing code. The billing code is supplied as default with code 1 in the field ‘Transfer to order’, which means that the service order row is transferred to the order routine but that the price is reset.
1 | Under guarantee | No logic is built into Jeeves standard for this billing code. The billing code is supplied as default with code 2 the field ‘Transfer to order’, which means that the service order row is not transferred to the order routine.
3 | To be invoiced | No logic is built into Jeeves standard for this billing code. The billing code is supplied as default with code 0 in the field ‘Transfer to order’, which means that the service order row is transferred to the order routine without being changed and can be invoiced via the order routine on condition that this is permitted in the system data for the service (field ‘Create order’ (ServCreOrd)).
5 | Charge | No logic is built in for this billing code. Service order rows with this code which refer to time are transferred automatically to ‘Time rows’ (hrp) and can then be invoiced via the assignment routine. Service order rows with this code which refer to expenses are transferred automatically to ‘Expenses’ (exp) and can be invoiced via the assignment routine on condition that you do not specify an item number and check the box ‘Create order’ (ServCreOrd). If you specify an item number and check the box ‘Create order’, the row is transferred to the order routine, irrespective of billing code. You can specify further billing codes that involve transfer to the assignment routine using two control parameters.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Charge | debkod | ztInteger | 1 |  | smallint
Charge | debkodB | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Transfer to order | Serv_Over | ztInteger | 1 |  | smallint

    This table is the main table in the following programs:

    Program: xdbk Billing codes


Bills of materials (sr)

Definition of BOMs in manufacturing and package items in sales, which items are included and in what quantity.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
BOM notation code | ArtStruktKod | ztString | 1 |  | varchar
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Qty parent level (setup) | BAntalAviStall | ZtQty | 14 | 2 | decimal
Pieces | BAntalStyck | ZtQty | 14 | 2 | decimal
Item no. (BOM) | BArtnrStrukt | ztString | 30 |  | varchar
Figure no. | BFigNr | ztString | 6 |  | varchar
Figure no. extended | BFigNr255 | ztString | 255 |  | varchar
Quantity per piece | BKvantPerStyck | ztFloat | 12 | 4 | float
BOMCalculatedQty | BOMCalculatedQty | ztFloat | 15 | 2 | float
BOM sequence number | BOMItemSeqNo | ZtLong | 10 |  | int
BOMPercentage | BOMPercentage | ztFloat | 15 | 2 | float
BOM qty per (1/10/100...) | BOMQtyPer | ztInteger | 5 |  | smallint
BOMQtyType | BOMQtyType | ztInteger | 5 |  | smallint
BOMWeightFactor | BOMWeightFactor | ztFloat | 15 | 2 | float
Connected to PDM ... | ConnPdmDummyUniqueID | ztUniqueIdentifier | 100 |  | varchar
Dummy id (copy from) | CopiedFromDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Dimension 1 | Dimension1 | ztFloat | 15 | 2 | float
Dimension 2 | Dimension2 | ztFloat | 15 | 2 | float
Dimension 3 | Dimension3 | ztFloat | 15 | 2 | float
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Own mtrl row | EgenMtrlRad | ztBoolean |  |  | char
Replaced by item | ErsattsAvArtNr | ztString | 30 |  | varchar
Ersätts av artikels varugrupp | ErsattsAvArtNrVG | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, BCU | FPris | ZtBaseCurrAmount | 14 | 2 | money
Valid from date | GiltigFromDatum | ztDate |  |  | datetime
Valid to date | GiltigTomDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Item Revision | ItemRevision | ZtLong | 3 |  | smallint
Copy from item revision | ItemRevision_CopyOfRevision | ZtLong | 3 |  | int
Item rev OK to use? | ItemRevOkToUse | ztBoolean |  |  | char
Scrap factor % BOM | KassStrukt | ztFloat | 5 | 2 | float
Price 0 applies | KodNollPris | ztBoolean |  |  | char
No customer disc | KundEjRabKod | ztBoolean |  |  | char
Invntry loc, mtrl res | LagstalleMtrlRes | ztString | 2 |  | varchar
Discount fr matrix, add | MatrisRabAddKod | ztBoolean |  |  | char
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
This field is used in the table as follows: |
Change package qty->det | PackageItemQty2Det | ztBoolean |  |  | char
PDM (Unique ID) | PdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Pos in figure | posalfa | ztString | 12 |  | varchar
Prisfaktor-1 | PrisFaktor1 | ztFloat | 15 | 2 | float
Prisfaktor 2 | PrisFaktor2 | ztFloat | 15 | 2 | float
Prisfaktor 3 | PrisFaktor3 | ztFloat | 15 | 2 | float
Gross margin | Proc1 | ztFloat | 6 | 2 | float
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Active disc matrix | RabattAktivKod | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Fixed quantity in structure | SrFastAntal | ZtQty | 14 | 2 | decimal
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
TimeGapInDaysToCurrItem | TimeGapInDaysToCurrItem | ztInteger | 5 |  | smallint
Använd property | UseProperty | ztBoolean |  |  | char
Variantelement | variantelement | ztString | 30 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Price, curr | vb_Pris | ZtSalesPrice | 12 | 2 | money
Volume disc %, add | VolymRabAddKod | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: Sr BOM/package items

    Program: Sr_OldItemRev BOM/package items

    Program: sri Included in


Bills of materials (revision diff) (sr_ItemRevDiff)

Alphanumeric code for the item, BOM, fixed asset, or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Item no. (BOM) | BArtnrStrukt | ztString | 30 |  | varchar
Dummy id (copy from) | CopiedFromDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Purchase agreement no. | InkAvt | ztInteger | 4 |  | smallint
Item Revision | ItemRevision | ZtLong | 3 |  | smallint
Copy from item revision | ItemRevision_CopyOfRevision | ZtLong | 3 |  | int
Item revision diff flag | ItemRevisionDiffFlag | ztString | 4 |  | nvarchar
Item rev OK to use? | ItemRevOkToUse | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Created by | RowCreatedBy | ztString | 30 |  | varchar
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar


Bin locations, item (arsh)

Information on bins/locations for an item in inventory.

Inventory balance, bin identity, batch identity and serial number for the item are saved on the bin. Detailed information is stored here about on which bin(s) a batch/serial number of the item is stored.

Several batches can be stored on one bin. Several different items can also be stored on one bin (determined per bin using a parameter). This means that a bin can represent a specific area in the warehouse/shop or on the loading platform, etc. where items are stored under different forms.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Type of bin | LagPlatsTyp | ztString | 6 |  | varchar
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Max received qty | MaxDelivQty | ZtQty | 14 | 2 | decimal
Max quantity/bin | MaxNoOfItemsOnBin | ZtQty | 14 | 2 | decimal
Multi items in bin | MultiItemsOnBin | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Gate | Port | ztString | 6 |  | varchar
Gate area | PortYta | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Last received date | SenInlevDat | ztDate |  |  | datetime
Last disp date | SenUtlevDat | ztDate |  |  | datetime
Print order, alpha | Turordning | ztString | 20 |  | varchar
Print order, num | TurordningNum | ZtLong | 10 |  | int
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: Arsh Bin management


Bin rule (x9)

Definition of handling types for bins (inventory locations).

You specify for each inventory location whether bin checks will be applied for received deliveries and, if so, according to which rule.

The following standard records exist. Do not alter/delete:

Bin rule (BinLocRule) | Bin rule (BinLocRuleDescr) | Description
0 | No bin check | No check of bins for the inventory location in question, i.e. neither that the bin is set up in the bin register or against a specified max. quantity for the bin.
1 | Bin check | Bin is specified manually when entering delivery and a check is done to ensure that the specified bin is in the bin register (table Arsh).
2 | Automatic bin location | The system automatically locates a suitable bin for delivery. First, any existing bins for the inventory location in question are checked and a check is done to see if any bin has room for the entire delivery. If there is no room in the relevant bins, the system automatically searches for a new suitable bin from the bin register (table Arsh). A search is performed for a suitable bin according to the following criteria: Where ‘Type of bin’ conforms with the type that may be specified on the item. Where the max. received quantity is equal to or greater than the quantity in the received delivery in question. Where the max. quantity on the bin is equal to or greater than the quantity in the received delivery in question. The above max. quantity is mandatory information if you want to apply automatic bin location.
3 | Bin and balance check | Bin is specified manually when entering delivery and a check is done to ensure that the specified bin is in the bin register (table Arsh). Additionally, a balance check is done against a specified maximum quantity for the bin in the bin register. If the entire delivery cannot fit in a given bin, the delivery cannot be received to the bin in question.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Bin rule | BinLocRule | ztInteger | 2 |  | smallint
Bin rule | BinLocRuleDescr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xx9 Bin rule


BOE acceptance journal (RemJournal)

Journal for collecting bills of exchange to customers for acceptance.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
To due date | RemJrnlDate | ztDate |  |  | datetime
Acceptance journal | RemJrnlNo | ZtLong | 9 |  | int
Acceptance status | RemJrnlStatus | ztInteger | 2 |  | smallint
Print date | RemPrintDate | ztDateTime |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: RemJournal BOE acceptance journal


BOE acceptance journal transactions (RemJrnlTr)

Remittance transactions.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Bank | BankId | ztString | 10 |  | varchar
Account at bank | BankKonto | ztString | 40 |  | varchar
Reserved in journal | BilagsMark | ztBoolean |  |  | char
Acceptance due date | BOE_AcceptDt | ztDate |  |  | datetime
Due date for BoE | BoE_DueDt | ztDate |  |  | datetime
Bill of exchange no. | BoE_No | ZtLong | 9 |  | int
Bill number alpha | BoE_No_Alfa | ztString | 60 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Separate check | CheckInd | ztBoolean |  |  | char
Check number | CheckNo | ZtLong | 9 |  | int
Check sequence number | Checksequence | ZtLong | 10 |  | int
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Due date | FaktFfDat | ztDate |  |  | datetime
Paid amount BCU | FaktInbBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Branch info 1 | Filial_Info_1 | ztString | 60 |  | varchar
Branch info 2 | Filial_Info_2 | ztString | 60 |  | varchar
Local bank code | FilialKod | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Deducted amount BCU | InbAvdrag | ZtBaseCurrAmount | 14 | 2 | money
Payment date | InbDat | ztDate |  |  | datetime
Early settlmt discnt BCU | InbKassaRab | ZtBaseCurrAmount | 14 | 2 | money
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S-4 f ledg.balance | K4ReskSaldo | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S5 f ledg.balance | K5ReskSaldo | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S6 f ledg.Bal | K6ReskSaldo | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S7 f ledg.balance | K7ReskSaldo | ztString | 8 |  | varchar
Cost unit f ledg.balance | KBarReskSaldo | ztString | 8 |  | varchar
Code key | KodNyckel | ztString | 2 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost unit deduction | KostBarAvdrag | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Balance sheet CC | KstReskSaldo | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Ledger acct | KtoNrReskSaldo | ztString | 8 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Payment suggestion | PaySugg | ztBoolean |  |  | char
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Acceptance journal | RemJrnlNo | ZtLong | 9 |  | int
Acceptance status | RemJrnlStatus | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Exchg rate diff | ValDiff | ZtBaseCurrAmount | 14 | 2 | money
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate | ValKursGrund | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate, operand | ValKursOp | ztInteger | 5 |  | smallint
Exchange rate unit | ValKursPer | ZtDecimal73 | 8 | 3 | decimal
Deducted amount, curr | vbInbAvdrag | ztMoney | 11 | 2 | money
Paid amount, curr | VbInbBel | ztMoney | 14 | 2 | money
Early settlmt discnt, curr | vbKassarab | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint


BOE details -> accounting (vxrt)

Contains posting information for the bills of exchange ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
BOE journal no | BoE_JournNo | ZtLong | 10 |  | int
Bill of exchange no. | BoE_No | ZtLong | 9 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Acc rec/Acc pay | KRorLR | ztInteger | 5 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Plan/paid amt, BCU | UtbBel | ZtBaseCurrAmount | 14 | 2 | money
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Plan/paid amt, curr | VbUtbBel | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint


BOE journal, rows (vxrr)

Contains the bills of exchange that are posted to the journal.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Journal type | BoE_Journal_Type | ztInteger | 5 |  | smallint
BOE journal no | BoE_JournNo | ZtLong | 10 |  | int
Bill of exchange no. | BoE_No | ZtLong | 9 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Acc rec/Acc pay | KrorLR | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


BOE posting (vxre)

BOE postings.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Journal type | BoE_Journal_Type | ztInteger | 5 |  | smallint
BOE journal no | BoE_JournNo | ZtLong | 10 |  | int
BOE journal no paid | BoE_JournNo_Def | ZtLong | 9 |  | int
BOE journal no collection | BoE_JournNo_Ink | ZtLong | 9 |  | int
Bill of exchange no. | BoE_No | ZtLong | 9 |  | int
BOE status | BoE_Status | ztInteger | 5 |  | smallint
Voucher type | BoE_Voucher_TYpe | ztInteger | 5 |  | smallint
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Acc rec/Acc pay | KRorLR | ztInteger | 5 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Plan/paid amt, BCU | UtbBel | ZtBaseCurrAmount | 14 | 2 | money
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int
Payment methods | UtbSlag | ztString | 3 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Plan/paid amt, curr | VbUtbBel | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: vxre Bills of exchange - posting


BOEs, included invoices (vxde)

Contains information about which invoices will be paid for a specific bill of exchange.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Invoice no. | BoE_KRorLR_Faktnr | ztString | 25 |  | varchar
Bill of exchange no. | BoE_No | ZtLong | 9 |  | int
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Acc rec/Acc pay | KRorLR | ztInteger | 5 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Plan/paid amt, BCU | UtbBel | ZtBaseCurrAmount | 14 | 2 | money
Currency | ValKod | ztString | 3 |  | varchar
Plan/paid amt, curr | VbUtbBel | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: vxde Invoice per bill of exchange


BOM level analysis (vsr2)

Contains bills of material.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item description | ArtBeskr | ztString | 30 |  | varchar
Item descr 2 | ArtBeskr2 | ztString | 255 |  | varchar
Specification | ArtBeskrSpec | ztString | 30 |  | varchar
Manufacturing lead time | ArtGenomLoppsTid | ztInteger | 5 |  | smallint
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Net purchase price | ArtInPris | ZtBaseCurrAmount | 14 | 2 | money
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
BOM level | ArtNivaBeskr | ztString | 20 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
BOM notation code | ArtStruktKod | ztString | 1 |  | varchar
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Item no. (BOM) | BArtnrStrukt | ztString | 30 |  | varchar
Figure no. | BFigNr | ztString | 6 |  | varchar
Figure no. extended | BFigNr255 | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Scrap factor % BOM | KassStrukt | ztFloat | 5 | 2 | float
Queue time | KoTid | ztFloat | 15 | 2 | float
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Sequence no. | lopnr | ZtLong | 10 |  | int
Operation no. | OpNr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Planned quantity | PlaneratAntal | ZtQty | 14 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Item group | VaruGruppBeskr | ztString | 30 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar


BOM notation codes (xz1)

BOM notation codes which can be used to determine the processing of the structure record. As well as standard records which are supplied with the system, you can also set up BOM notation costs as required.

The following standard records exist. Do not alter/delete:

BOM notation code (ArtStruktKod) | BOM notations (ArtStruktBeskr) | Description
0 | 0: Normal | Normal processing, i.e. the item is reserved, picked and calculated (estimate and actual cost).
7 | 7: Only calculation | The item is not reserved (no material reservation) and is not picked, but is calculated.
9 | 9: Information | Only included as information, i.e. the item is included in material reservations BUT must should not be reserved in inventory, picked or calculated. The notation can be used for items included in a blueprint or a specification but supplied by the subcontractor.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
BOM notations | ArtStruktBeskr | ztString | 50 |  | varchar
BOM notation code | ArtStruktKod | ztString | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxz1 BOM notations


BOMQtyType (BOMQtyType)

BOMQtyType

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
BOMQtyType | BOMQtyType | ztInteger | 5 |  | smallint
BOMQtyType | BOMQtyTypeDescr | ztString | 80 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: BOMQtyType BOMQtyType


BOMs (view) SUNDS-PDM (vsrp)

View in Jeeves from an external BOM register.
A customer can use this table "as they like".
The table is used as a left-hand window, where the right-hand window is the BOM register.
This was developed for Sunds, where the left-hand window is a table (updated by a button) that "comes" from a PDM system.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item description | ArtBeskr | ztString | 30 |  | varchar
Item descr 2 | ArtBeskr2 | ztString | 255 |  | varchar
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Item class | ArtKod | ztInteger | 3 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
BOM notation code | ArtStruktKod | ztString | 1 |  | varchar
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Qty parent level (setup) | BAntalAviStall | ZtQty | 14 | 2 | decimal
Pieces | BAntalStyck | ZtQty | 14 | 2 | decimal
Item no. (BOM) | BArtnrStrukt | ztString | 30 |  | varchar
Figure no. | BFigNr | ztString | 6 |  | varchar
Figure no. extended | BFigNr255 | ztString | 255 |  | varchar
Quantity per piece | BKvantPerStyck | ztFloat | 12 | 4 | float
Dimension 1 | Dimension1 | ztFloat | 15 | 2 | float
Dimension 2 | Dimension2 | ztFloat | 15 | 2 | float
Dimension 3 | Dimension3 | ztFloat | 15 | 2 | float
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Scrap factor % BOM | KassStrukt | ztFloat | 5 | 2 | float
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
This field is used in the table as follows: |
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar


BOMs from configurator XML (TactonPartStruct)

Bills of material from the Sales configurator.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Index of child part | ChildPartIndex | ztInteger | 5 |  | smallint
Name of part | ChildPartName | ztString | 255 |  | varchar
Child realizing part name | ChildRealizedName | ztString | 128 |  | varchar
Value of child realizing part name | ChildRealizedValue | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Key part 1 | Key1 | ztString | 50 |  | varchar
Key part 2 | Key2 | ztString | 50 |  | varchar
Key part 3 | Key3 | ztString | 50 |  | varchar
Key part 4 | Key4 | ztString | 50 |  | varchar
Key part 5 | Key5 | ztString | 50 |  | varchar
Configurator model ID | ModelId | ztString | 60 |  | varchar
Index to parent part | ParentPartIndex | ztInteger | 5 |  | smallint
Index of part | PartIndex | ztInteger | 5 |  | smallint
Name of part | PartName | ztString | 255 |  | varchar
Part sequence | PartSeqNo | ztString | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Realizing part name | RealizedName | ztString | 128 |  | varchar
Value of realizing part name | RealizedValue | ztString | 255 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


BOMs, analysis (sran)

Table of bills of materials (Explosion) at several levels, including inventory balance, lead times and quantity required.

The results are stored in a table which is used for viewing bills of materials.

The content of the table is generated at each request for analysis. Old rows are automatically deleted after a couple of days.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Quantity to manufacture | AntalAttTillverka | ZtQty | 14 | 2 | decimal
Manufacturing lead time | ArtGenomLoppsTid | ztInteger | 5 |  | smallint
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Net purchase price | ArtInPris | ZtBaseCurrAmount | 14 | 2 | money
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
BOM level | ArtNivaBeskr | ztString | 20 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
BOM notation code | ArtStruktKod | ztString | 1 |  | varchar
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Item no. (BOM) | BArtnrStrukt | ztString | 30 |  | varchar
Required quantity | BehovAntal | ZtQty | 14 | 2 | decimal
Start purch/mfg | BehovStartDat | ztDate |  |  | datetime
Total inventory balance | BerSaldo | ZtQty | 14 | 2 | decimal
Req to date ext | BestBehovLevDat | ztDate |  |  | datetime
Figure no. | BFigNr | ztString | 6 |  | varchar
Shortage/available balance | BristDispSaldo | ZtQty | 14 | 2 | decimal
Avail check status code | BristKontrolleradStatus | ztInteger | 5 |  | smallint
Shortage/balance | BristSaldo | ZtQty | 14 | 2 | decimal
Available invtry balance | DispSaldo | ZtQty | 14 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Scrap factor % BOM | KassStrukt | ztFloat | 5 | 2 | float
Configuration item no. | KonfigArtNr | ztString | 30 |  | varchar
Queue time | KoTid | ztFloat | 15 | 2 | float
Ordered quantity | LagBestAnt | ZtQty | 14 | 2 | decimal
Stocked | LagerBokas | ztBoolean |  |  | char
Qty on order/prod | LagOrdrAnt | ZtQty | 14 | 2 | decimal
Reserved quantity | LagResAnt | ZtQty | 14 | 2 | decimal
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Sequence no. | LopNr | ZtLong | 10 |  | int
Reserved quantity | MrResAnt | ZtQty | 14 | 2 | decimal
Operation no. | OpNr | ztInteger | 3 |  | int
This field is used in the table as follows: |
Signature | PersSign | ztString | 30 |  | varchar
Planned quantity | PlaneratAntal | ZtQty | 14 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Type code in SRAN | SranTypeCode | ztInteger | 5 |  | smallint
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Requisition | StrDateTimeBIA | ztString | 28 |  | varchar
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
Unit time | StyckTid | ztOpTime | 9 | 4 | float
OK to use tool | ToolOkToUse | ztBoolean |  |  | char
Använd property | UseProperty | ztBoolean |  |  | char
Item group | VaruGruppKod | ztString | 8 |  | varchar


BOMs, calculations (srk)

Bills of materials for calculated items.
Only detailed calculation updates this table.
There is a kind of bills of materials copy of the calculated item for every calculated item.
You can also see totaled costs, level by level, in this table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Purchased | AnskaffningKop | ztBoolean |  |  | char
Labour overhead | ArbOmk | ZtCost | 16 | 6 | float
Calculation version no. | ArkVersion | ZtLong | 4 |  | int
Item description | ArtBeskr | ztString | 30 |  | varchar
Specification | ArtBeskrSpec | ztString | 30 |  | varchar
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Labour cost (calculation) | ArtKalkArbKost | ZtBaseCurrAmount | 14 | 2 | money
Fixed cost (calculation) | ArtKalkFastKost | ZtBaseCurrAmount | 14 | 2 | money
Material cost (calculation) | ArtKalkMtrlKost | ZtBaseCurrAmount | 14 | 2 | money
Variable cost (calculation) | ArtKalkRorlKost | ZtBaseCurrAmount | 14 | 2 | money
Average cost price | ArtKalkSnitt | ZtBaseCurrAmount | 14 | 2 | money
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
BOM level | ArtNivaBeskr | ztString | 20 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Startkostnad artikel | ArtStartKost | ZtCost | 16 | 6 | float
BOM notation code | ArtStruktKod | ztString | 1 |  | varchar
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Qty parent level (setup) | BAntalAviStall | ZtQty | 14 | 2 | decimal
Item no. (BOM) | BArtnrStrukt | ztString | 30 |  | varchar
Figure no. | BFigNr | ztString | 6 |  | varchar
Figure no. extended | BFigNr255 | ztString | 255 |  | varchar
Purchase price budget | BudgInPris | ZtBaseCurrAmount | 14 | 2 | money
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Dimension 1 | Dimension1 | ztFloat | 15 | 2 | float
Dimension 2 | Dimension2 | ztFloat | 15 | 2 | float
Dimension 3 | Dimension3 | ztFloat | 15 | 2 | float
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Econ order quantity | Eoq | ZtQty | 14 | 2 | decimal
Extra overhead cost | ExtraOmk | ZtCost | 16 | 6 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Calculation item | KalkArtNr | ztString | 30 |  | varchar
Calculation on quantity | KalkylPaAntal | ZtQty | 14 | 2 | decimal
Average weighted | KalkylPrisEnlSnittPris | ztBoolean |  |  | char
Scrap factor in % | KassAr | ztFloat | 5 | 2 | float
Scrap factor % BOM | KassStrukt | ztFloat | 5 | 2 | float
Inventory location | LagStalle | ztString | 2 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Material cost | MtrlKost | ZtCost | 16 | 6 | float
Indirect mtrl cost | MtrlMoKost | ZtCost | 16 | 6 | float
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
This field is used in the table as follows: |
Overlying seq no. | OverRowNo | ztInteger | 3 |  | smallint
Batch size manufacturing | PartistorlekTillv | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Prisfaktor-1 | PrisFaktor1 | ztFloat | 15 | 2 | float
Prisfaktor 2 | PrisFaktor2 | ztFloat | 15 | 2 | float
Prisfaktor 3 | PrisFaktor3 | ztFloat | 15 | 2 | float
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Technical OH cost | TeknikOmk | ZtCost | 16 | 6 | float
Start cost/MO | ToStartKost | ZtCost | 16 | 6 | float
Tot Kalk ställkostnad | TotArbKalkStallKost | ZtBaseCurrAmount | 14 | 2 | money
Total labour overhead | TotArbOmk | ZtCost | 16 | 6 | float
Total fixed labour OH | TotArbOmkFast | ZtCost | 16 | 6 | float
Labour OH op/total | TotArbOmkOp | ZtCost | 16 | 6 | float
Var OH labour total | TotArbOmkRorl | ZtCost | 16 | 6 | float
Total setup overhead | TotArbOmkStall | ZtCost | 16 | 6 | float
Indirect setup costs | TotArbStallBiKost | ZtCost | 16 | 6 | float
Total setup cost | TotArbStallKost | ZtCost | 16 | 6 | float
Indirect labour costs | TotArbStyckBiKost | ZtCost | 16 | 6 | float
Labour total | TotArbStyckKost | ZtCost | 16 | 6 | float
Total item startup cost | TotArtStartKost | ZtCost | 16 | 6 | float
Extraomkostnad totalt | TotExtraOmk | ZtCost | 16 | 6 | float
Total indir subcontr costs | TotLegoBiKost | ZtCost | 16 | 6 | float
Total subcontract cost | TotLegoKost | ZtCost | 16 | 6 | float
Total material cost | TotMtrlKost | ZtCost | 16 | 6 | float
Mtrl overhead total | TotMtrlMoKost | ZtCost | 16 | 6 | float
Mfg grp depr total | TotPgAvskrKost | ZtCost | 16 | 6 | float
Mfg grp fixed rate tot | TotPgFastKost | ZtCost | 16 | 6 | float
Mfg grp var cost total | TotPgRorlKost | ZtCost | 16 | 6 | float
Mfg grp setup cost | TotPgStallKost | ZtCost | 16 | 6 | float
Ställkostnad | TotStallKost | ZtBaseCurrAmount | 14 | 2 | money
Technical overhead cost tot | TotTeknikOmk | ZtCost | 16 | 6 | float
Total MO startup cost | TotToStartKost | ZtCost | 16 | 6 | float
Total developmt cost | TotUtvKost | ZtCost | 16 | 6 | float
Tot developmt OH cost | TotUtvOmk | ZtCost | 16 | 6 | float
Verkstadspris (totalt) | TotVerkstadPris | ZtBaseCurrAmount | 14 | 2 | money
Total tool depr | TotVyAvskrKost | ZtCost | 16 | 6 | float
Total tool fix cost | TotVyFastKost | ZtCost | 16 | 6 | float
Total tool var cost | TotVyRorlKost | ZtCost | 16 | 6 | float
Total tool setup cost | TotVyStallKost | ZtCost | 16 | 6 | float
Total tool unit cost | TotVySTyckKost | ZtCost | 16 | 6 | float
Använd property | UseProperty | ztBoolean |  |  | char
Development cost | UtvKost | ZtCost | 16 | 6 | float
Development OH cost | UtvOmk | ZtCost | 16 | 6 | float
Item group | VaruGruppKod | ztString | 8 |  | varchar


BOMs, inventory (srla)

Bills of materials used for inventory analysis (assembly analysis)

Explosion at several levels, including inventory balance, lead times and quantity required.

This table is used when running any of the following programs:
- Assembly analysis, item
- Assembly analysis, requisition
- Assembly analysis, MO
- Assembly analysis, MRP proposal

The results are stored in a table which is used for viewing bills of materials.

The content of the table is generated at each request for analysis. Old rows are automatically deleted after a couple of days.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Quantity to manufacture | AntalAttTillverka | ZtQty | 14 | 2 | decimal
Manufacturing lead time | ArtGenomLoppsTid | ztInteger | 5 |  | smallint
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Net purchase price | ArtInPris | ZtBaseCurrAmount | 14 | 2 | money
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
BOM level | ArtNivaBeskr | ztString | 20 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
BOM notation code | ArtStruktKod | ztString | 1 |  | varchar
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Qty parent level (setup) | BAntalAviStall | ZtQty | 14 | 2 | decimal
Item no. (BOM) | BArtnrStrukt | ztString | 30 |  | varchar
Required quantity | BehovAntal | ZtQty | 14 | 2 | decimal
Start purch/mfg | BehovStartDat | ztDate |  |  | datetime
Total inventory balance | BerSaldo | ZtQty | 14 | 2 | decimal
Req to date ext | BestBehovLevDat | ztDate |  |  | datetime
Est disp date | BestBerLevDat | ztDate |  |  | datetime
Shortage/available balance | BristDispSaldo | ZtQty | 14 | 2 | decimal
Avail check status code | BristKontrolleradStatus | ztInteger | 5 |  | smallint
Shortage/balance | BristSaldo | ZtQty | 14 | 2 | decimal
Days->available | DiffDgrBehov2Disp | ztInteger | 5 |  | smallint
Available invtry balance | DispSaldo | ZtQty | 14 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Scrap factor % BOM | KassStrukt | ztFloat | 5 | 2 | float
Configuration item no. | KonfigArtNr | ztString | 30 |  | varchar
Queue time | KoTid | ztFloat | 15 | 2 | float
Ordered quantity | LagBestAnt | ZtQty | 14 | 2 | decimal
Qty on order/prod | LagOrdrAnt | ZtQty | 14 | 2 | decimal
Reserved quantity | LagResAnt | ZtQty | 14 | 2 | decimal
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Reserved quantity | MrResAnt | ZtQty | 14 | 2 | decimal
Old item group | OldVaruGruppKod | ztString | 8 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
This field is used in the table as follows: |
Signature | PersSign | ztString | 30 |  | varchar
Planned quantity | PlaneratAntal | ZtQty | 14 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Fixed quantity in structure | SrFastAntal | ZtQty | 14 | 2 | decimal
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Requisition | StrDateTimeBIA | ztString | 28 |  | varchar
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
Unit time | StyckTid | ztOpTime | 9 | 4 | float
OK to use tool | ToolOkToUse | ztBoolean |  |  | char
Använd property | UseProperty | ztBoolean |  |  | char
Item group | VaruGruppKod | ztString | 8 |  | varchar


BOMs, items (VIEW) (vsrs)

Bills of materials of items.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
BOM notation code | ArtStruktKod | ztString | 1 |  | varchar
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Item no. (BOM) | BArtnrStrukt | ztString | 30 |  | varchar
Figure no. | BFigNr | ztString | 6 |  | varchar
Figure no. extended | BFigNr255 | ztString | 255 |  | varchar
Dimension 1 | Dimension1 | ztFloat | 15 | 2 | float
Dimension 2 | Dimension2 | ztFloat | 15 | 2 | float
Dimension 3 | Dimension3 | ztFloat | 15 | 2 | float
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Scrap factor % BOM | KassStrukt | ztFloat | 5 | 2 | float
Inventory location | LagStalle | ztString | 2 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
This field is used in the table as follows: |
Signature | PersSign | ztString | 30 |  | varchar
Prisfaktor-1 | PrisFaktor1 | ztFloat | 15 | 2 | float
Prisfaktor 2 | PrisFaktor2 | ztFloat | 15 | 2 | float
Prisfaktor 3 | PrisFaktor3 | ztFloat | 15 | 2 | float
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
Använd property | UseProperty | ztBoolean |  |  | char
Item group | VaruGruppKod | ztString | 8 |  | varchar


BOMs, revision/version (srv)

BOM revisions on which you can specify validity date. A link can then be made to a BOM to change its appearance at a certain date.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
BOM rev. (orig) | BOMRev_Orig | ztString | 10 |  | varchar
Copied from BOM rev. | CopiedFromBOMRev | ztString | 10 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Valid from date | GiltigFromDatum | ztDate |  |  | datetime
Valid to date | GiltigTomDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Item Revision | ItemRevision | ZtLong | 3 |  | smallint
Copy from item revision | ItemRevision_CopyOfRevision | ZtLong | 3 |  | int
Item rev OK to use? | ItemRevOkToUse | ztBoolean |  |  | char
Note | KortNotering | ztString | 255 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Quantity PDM | pdmcount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: srv BOM revisions


BOMs, VIEW (vsr)

View of the sr table (BOMs).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
BOM notation code | ArtStruktKod | ztString | 1 |  | varchar
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Qty parent level (setup) | BAntalAviStall | ZtQty | 14 | 2 | decimal
Pieces | BAntalStyck | ZtQty | 14 | 2 | decimal
Item no. (BOM) | BArtnrStrukt | ztString | 30 |  | varchar
Figure no. | BFigNr | ztString | 6 |  | varchar
Figure no. extended | BFigNr255 | ztString | 255 |  | varchar
Quantity per piece | BKvantPerStyck | ztFloat | 12 | 4 | float
BOMCalculatedQty | BOMCalculatedQty | ztFloat | 15 | 2 | float
BOMPercentage | BOMPercentage | ztFloat | 15 | 2 | float
BOMQtyType | BOMQtyType | ztInteger | 5 |  | smallint
BOMWeightFactor | BOMWeightFactor | ztFloat | 15 | 2 | float
Connected to PDM ... | ConnPdmDummyUniqueID | ztUniqueIdentifier | 100 |  | varchar
Dimension 1 | Dimension1 | ztFloat | 15 | 2 | float
Dimension 2 | Dimension2 | ztFloat | 15 | 2 | float
Dimension 3 | Dimension3 | ztFloat | 15 | 2 | float
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Own mtrl row | EgenMtrlRad | ztBoolean |  |  | char
Replaced by item | ErsattsAvArtNr | ztString | 30 |  | varchar
Ersätts av artikels varugrupp | ErsattsAvArtNrVG | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, BCU | FPris | ZtBaseCurrAmount | 14 | 2 | money
Valid from date | GiltigFromDatum | ztDate |  |  | datetime
Valid to date | GiltigTomDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Scrap factor % BOM | KassStrukt | ztFloat | 5 | 2 | float
Price 0 applies | KodNollPris | ztBoolean |  |  | char
No customer disc | KundEjRabKod | ztBoolean |  |  | char
Invntry loc, mtrl res | LagStalleMtrlRes | ztString | 2 |  | varchar
Discount fr matrix, add | MatrisRabAddKod | ztBoolean |  |  | char
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
This field is used in the table as follows: |
Change package qty->det | PackageItemQty2Det | ztBoolean |  |  | char
PDM (Unique ID) | PdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Pos in figure | posalfa | ztString | 12 |  | varchar
Prisfaktor-1 | PrisFaktor1 | ztFloat | 15 | 2 | float
Prisfaktor 2 | PrisFaktor2 | ztFloat | 15 | 2 | float
Prisfaktor 3 | PrisFaktor3 | ztFloat | 15 | 2 | float
Gross margin | Proc1 | ztFloat | 6 | 2 | float
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Active disc matrix | RabattAktivKod | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Fixed quantity in structure | SrFastAntal | ZtQty | 14 | 2 | decimal
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
Använd property | UseProperty | ztBoolean |  |  | char
Variantelement | variantelement | ztString | 30 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Price, curr | vb_Pris | ZtSalesPrice | 12 | 2 | money
Volume disc %, add | VolymRabAddKod | ztBoolean |  |  | char


Booking rule, customer order->invtry (xbru)

Table that contains different selections that can be specified for booking orders against inventory. Only the booking code abbreviations can be changed. See also the topic on booking.

The following standard records exist. Do not alter/delete:

Auto booking rule (AutStockBookingRule) | Auto booking rule (AutStockBookingRuleDescr)
1 | A whole batch in first hand
2 | According to Best before date
3 | ALL from the same batch - Use/Best befor
4 | ALL from the same batch - Remaining Qty

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Auto booking rule | AutStockBookingRule | ztInteger | 5 |  | smallint
Auto booking rule | AutStockBookingRuleDescr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xbru Booking rule, customer order->invtry


Booking/reservation status ICT (ICTOrdResrvStat)

Definition of applicable booking statuses in ICT regarding customer order and purchase order rows.

Information on the current status of a customer order created by another supplying business unit is shown automatically on customer order and purchase order rows for the selling business unit.

The following standard records exist. Do not alter/delete:

Booking status ICT (ICTOrdResrvStat) | Booking status ICT (ICTOrdResrvStatDescr)
0 | No auto.booking done
5 | PO created for order-specific inventory
10 | Could not book according to rule
20 | Partly booked
30 | Fully booked

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Booking status ICT | ICTOrdResrvStat | ztInteger | 5 |  | smallint
Booking status ICT | ICTOrdResrvStatDescr | ztString | 80 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ICTOrdResrvStat Booking/reservation status ICT


Bookings for material reservations (cmrx)

Links between material reservations and existing purchase orders. Records are created in the table when booking material to manufacturing orders against an existing purchase order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | nvarchar
Batch no. | BatchId | ztString | 30 |  | nvarchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | nvarchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Receive to MO | InlevTillAoNr | Jeeves_MONo | 7 |  | bigint
Receive to MO Pos | InlevTillAoPos | ztInteger | 4 |  | int
Receive to MO Op | InlevTillOpNr | ztInteger | 3 |  | int
Bin | LagPlats | ztBinLocation | 20 |  | nvarchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | nvarchar
Source | UlbpTyp | ztString | 2 |  | nvarchar
Deliv from MO | UttagFranAoNr | Jeeves_MONo | 7 |  | bigint
Deliv from MO Pos | UttagFranAoPos | ztInteger | 5 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: cmrx Bookings for material reservations


Break type (PvmBreakType)

Break type for matrix printout rules

The following standard records exist. Do not alter/delete:

Break method (pvmbreaktypeid) | Break type (pvmbreaktypedescr)
0 | 0 - On no. of columns
1 | 1 - On delivery date
2 | 2 - On price
3 | 3 - On delivery date and price

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Break type | PvmBreakTypeDescr | ztString | 50 |  | varchar
Break method | PvmBreakTypeId | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PvmBreakType Break type


Budget allocation details (bfd)

Details on budget allocations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Debit/credit | DebKre | ztchar | 1 |  | char
Allocation curve | FordKurva | ztString | 4 |  | varchar
Budget alloc period | FordPeriod | ztInteger | 4 |  | smallint
Allocation percent | FordProc | ZtDecimal73 | 6 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: Xbfd Budget alloc/det


Budget allocation rates, header (bf)

Main table for budget allocation curves.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Balanced distribution budget | FastFrdBudg | ztBoolean |  |  | char
Allocation curve | FordKurva | ztString | 4 |  | varchar
Allocation curve | FordKurvaBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: bf Budget allocation

    Program: Xbf Budget allocation curves


Budget details (brd)

Budget details that are either entered manually in the program 'Budget entry' (brh) or created through allocation of a preliminary yearly budget in the program 'Allocate preliminary budget' (bfar).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Budget batch no. | BudgetOmg | ZtLong | 10 |  | int
Budgettyp | Budgettabell | ztInteger | 3 |  | smallint
Budget item status | budgstat | ztBoolean |  |  | char
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Shortcut | KortKodVerRad | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | Krebel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Sequence no. | LopNr | ZtLong | 10 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Revision | Revision | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: brd Budget details


Budget items, header (brh)

Main table for budget records per fiscal year, budget revision and account for allocation to budget details according to an allocation curve. Budget items can either be registered manually or loaded and selected from external systems.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Budget batch no. | BudgetOmg | ZtLong | 10 |  | int
Budgettyp | Budgettabell | ztInteger | 3 |  | smallint
Budget text | budgettext | ztString | 60 |  | varchar
Budget item status | budgstat | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
Amount | FordBel | ZtBaseCurrAmount | 14 | 2 | money
Allocation curve | FordKurva | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | k4 | ztString | 8 |  | varchar
S5 | k5 | ztString | 8 |  | varchar
S6 | k6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
Shortcut | KortKodVerRad | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Sequence no. | LopNr | ZtLong | 10 |  | int
OLE-1 | ole1 | ztString | 255 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Revision | Revision | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Date/time | StrDateTime | ztString | 28 |  | varchar
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: brh Budget with allocation entry


Budget revision log (brrl)

Data in the log for budget revisions.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Budget closed | BudgLocked | ztBoolean |  |  | char
Status updated by | BudgStatPersSign | ztString | 6 |  | varchar
Status updated on | BudgStatRegDat | ztDate |  |  | datetime
Update bal table | BudgUpdSaldo | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Prev bdg rev closed | OldBudgLocked | ztBoolean |  |  | char
Prev budget balance | OldBudgUpdSaldo | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Revision | Revision | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Date/time | StrDateTime | ztString | 28 |  | varchar


Budget revisions (brr)

Definition of budget revisions as required. You use the budget revision to identify which revision entered budget transactions belong to and to update the budget balance table by revision, and to lock a budget after balance updating.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Budget closed | BudgLocked | ztBoolean |  |  | char
Status updated by | BudgStatPersSign | ztString | 6 |  | varchar
Status updated on | BudgStatRegDat | ztDate |  |  | datetime
Update bal table | BudgUpdSaldo | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Rounding type | PrisAvrundKod | ztInteger | 2 |  | smallint
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Revision | Revision | ztInteger | 3 |  | smallint
Revision | RevisionBeskr | ztString | 40 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xbrr Budget revisions


Budget, customer (kubu)

Customer budget for period and fiscal year.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Budgeted amount | BudgBelopp | ZtBaseCurrAmount | 14 | 2 | money
Allocation curve | FordKurva | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Revision | Revision | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: kubu Budget, customer


Budget, item class (xmbu)

Item class budget for period and fiscal year.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item class | ArtKod | ztInteger | 3 |  | smallint
Budgeted amount | BudgBelopp | ZtBaseCurrAmount | 14 | 2 | money
Allocation curve | FordKurva | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Revision | Revision | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xmbu Budget, item class


Budget, item group (vgbu)

Item group budget for period and fiscal year.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Budgeted amount | BudgBelopp | ZtBaseCurrAmount | 14 | 2 | money
Allocation curve | FordKurva | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Revision | Revision | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: vgbu Budget, item group


Budget, sales period and year (pebu)

Sales budget for period and fiscal year.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Budgeted amount | BudgBelopp | ZtBaseCurrAmount | 14 | 2 | money
Allocation curve | FordKurva | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Revision | Revision | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: pebu Budget, sales period and year


Budget/forecast type, item (xarx)

Definitions of forecast/budget types for items.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Forecast/budg type | ArtProgBudgTyp | ztInteger | 3 |  | smallint
Forecast/budg type | ArtProgBudgTypBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xXarx Item frcst/budg type


Bundle information (bunt)

Here you enter bundle information for voucher entry that is used to show the highest, last and lowest bundle number related to a certain signature, i.e. person.

No standard records exist in this table. Fill in the table as required.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Last bundle number | LastBuntNr | ZtLong | 10 |  | int
Max bundle no. | MaxBuntNr | ZtLong | 10 |  | int
Min bundle no. | MinBuntNr | ZtLong | 10 |  | int
Signature | Perssign | ztString | 30 |  | varchar
Entry date | Regdat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: bunt Bundle information


Business documents (xpdmb)

Definition of applicable business document types. There is special functionality connected to the standard business document types and therefore type 1-100 are reserved. If you need to define own business document types use number 101 and higher.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Business document | BusinessDocType | ztInteger | 5 |  | smallint
Business document | BusinessDocTypeDescr | ztString | 80 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xpdmb Business documents


Business intelligence documents (JBIdoc)

Busienss intelligence docments available in Jeeves.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
BI document filepath | jbi_doc_filepath | ztString | 100 |  | varchar
BI document name | jbi_doc_name | ztString | 40 |  | varchar
BI document ID | jbi_docid | ztInteger | 5 |  | smallint
BI program | JBI_engine | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | sprakkod | ztInteger | 3 |  | smallint

    This table is the main table in the following programs:

    Program: JBIdoc Business intelligence documents


Business opportunities (pro)

Table of business opportunities/projects in the marketing module as well as contacts who are connected to them. In this table, you can also specify different characteristics for making selections, as well as plan and report activities.

The table is linked to the company file, where you must first enter general details about the company/organization.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | antal | ZtQty | 14 | 2 | decimal
Budgeted amount | BudgBelopp | ZtBaseCurrAmount | 14 | 2 | money
Poss own margin | e_potbidrag | ZtBaseCurrAmount | 12 | 2 | money
Poss own turnover | e_potvolym | ZtBaseCurrAmount | 12 | 2 | money
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | ftgkontaktnr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Company Group ID | ftgnrgrupp | ztCompanyNo | 20 |  | varchar
Contact name | FtgPerson | ztString | 60 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Campaign | KampNr | ZtLong | 4 |  | int
Note | kortnotering | ztString | 255 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Quarter | Kvartal | ztInteger | 1 |  | smallint
Quote/Agreemt date | offertdat | ztDate |  |  | datetime
Quote/agreement no. | offnr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Price conversion factor | omvfaktor | ZtPurQty2Stock | 12 | 6 | decimal
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Poss margin | p_potbidrag | ZtBaseCurrAmount | 14 | 2 | money
Poss sales value | p_potvolym | ZtBaseCurrAmount | 14 | 2 | money
Probability% | p_prob_proc | ztInteger | 3 |  | smallint
Orig probability % | p_prob_proc_orig | ztInteger | 3 |  | smallint
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Period | period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Business opportunity | ProBeskr | ztString | 50 |  | varchar
Est decision date | ProjBerBeslDat | ztDate |  |  | datetime
Project ID | ProjCode | ztString | 10 |  | varchar
Project name | ProjDescr | ztString | 40 |  | varchar
Project source | ProjInit | ztInteger | 2 |  | smallint
Project start date | ProjInitDat | ztDate |  |  | datetime
Current supplier | ProjNuvLev | ztString | 24 |  | varchar
Current product | ProjNuvProd | ztString | 20 |  | varchar
Project start date | ProjStartDat | ztDate |  |  | datetime
Bus opp descr | prospbeskr | ztString | 50 |  | varchar
Bus opp characteristic | ProspEgK6 | ztInteger | 3 |  | smallint
Bus opp characteristic | ProspEgK7 | ztInteger | 3 |  | smallint
Bus opp characteristic | ProspEgK8 | ztInteger | 3 |  | smallint
Bus opp characteristic | ProspEgK9 | ztInteger | 3 |  | smallint
Bus opp characteristic | ProspEgKA | ztInteger | 3 |  | smallint
Bus opp characteristic | ProspEgKB | ztInteger | 3 |  | smallint
Status code | ProspStatKod | ztInteger | 3 |  | smallint
Fiscal year | redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Sales phase | saljfasid | ztInteger | 5 |  | smallint
Sales team | saljteamkod | ztString | 8 |  | varchar
End customer | slutkund | ztCompanyNo | 20 |  | varchar
Identity | SQLidentity | ZtLong | 10 |  | int
Original decision date | Ursprbesldat | ztDate |  |  | datetime
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Own margin, curr | vb_e_potbidrag | ztMoney | 12 |  | money
Own turnover, curr | vb_e_potvolym | ztMoney | 12 |  | money
Poss margin, curr | vb_p_potbidrag | ztMoney | 12 |  | money
Poss turnover, curr | vb_p_potvolym | ztMoney | 12 |  | money
Actual end date | VerklAvslDat | ztDate |  |  | datetime
Count | vrcount | ztInteger | 5 |  | smallint
Won/Lost | vunnenforlorad | ztInteger | 3 |  | smallint
Unique ID link | WfRowUniqueID | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: Pro Business opportunities

    Program: Proh Business opportunities, history

    Program: rPro1 Business opportunities


Business opportunities (view) (vpro)

Table of business opportunities/projects in the marketing module as well as contacts who are connected to them. In this table, you can also specify different characteristics for making selections, as well as plan and report activities.

The table is linked to the company file, where you must first enter general details about the company/organization.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | antal | ZtQty | 14 | 2 | decimal
Poss own margin | e_potbidrag | ZtBaseCurrAmount | 12 | 2 | money
Poss own turnover | e_potvolym | ZtBaseCurrAmount | 12 | 2 | money
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | ftgkontaktnr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Company Group ID | ftgnrgrupp | ztCompanyNo | 20 |  | varchar
Contact name | FtgPerson | ztString | 60 |  | varchar
Note | kortnotering | ztString | 255 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Quarter | Kvartal | ztInteger | 1 |  | smallint
Quote/Agreemt date | offertdat | ztDate |  |  | datetime
Quote/agreement no. | offnr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Price conversion factor | omvfaktor | ZtPurQty2Stock | 12 | 6 | decimal
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Poss margin | p_potbidrag | ZtBaseCurrAmount | 14 | 2 | money
Poss sales value | p_potvolym | ZtBaseCurrAmount | 14 | 2 | money
Probability% | p_prob_proc | ztInteger | 3 |  | smallint
Orig probability % | p_prob_proc_orig | ztInteger | 3 |  | smallint
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Period | period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Business opportunity | ProBeskr | ztString | 50 |  | varchar
Est decision date | ProjBerBeslDat | ztDate |  |  | datetime
Project ID | ProjCode | ztString | 10 |  | varchar
Project name | ProjDescr | ztString | 40 |  | varchar
Project source | ProjInit | ztInteger | 2 |  | smallint
Project start date | ProjInitDat | ztDate |  |  | datetime
Current supplier | ProjNuvLev | ztString | 24 |  | varchar
Current product | ProjNuvProd | ztString | 20 |  | varchar
Project start date | ProjStartDat | ztDate |  |  | datetime
Bus opp descr | prospbeskr | ztString | 50 |  | varchar
Bus opp characteristic | ProspEgK6 | ztInteger | 3 |  | smallint
Bus opp characteristic | ProspEgK7 | ztInteger | 3 |  | smallint
Bus opp characteristic | ProspEgK8 | ztInteger | 3 |  | smallint
Bus opp characteristic | ProspEgK9 | ztInteger | 3 |  | smallint
Bus opp characteristic | ProspEgKA | ztInteger | 3 |  | smallint
Bus opp characteristic | ProspEgKB | ztInteger | 3 |  | smallint
Status code | ProspStatKod | ztInteger | 3 |  | smallint
Fiscal year | redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Sales phase | saljfasid | ztInteger | 5 |  | smallint
Sales team | saljteamkod | ztString | 8 |  | varchar
End customer | slutkund | ztCompanyNo | 20 |  | varchar
Identity | SQLidentity | ZtLong | 10 |  | int
Original decision date | Ursprbesldat | ztDate |  |  | datetime
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Own margin, curr | vb_e_potbidrag | ztMoney | 12 |  | money
Own turnover, curr | vb_e_potvolym | ztMoney | 12 |  | money
Poss margin, curr | vb_p_potbidrag | ztMoney | 12 |  | money
Poss turnover, curr | vb_p_potvolym | ztMoney | 12 |  | money
Actual end date | VerklAvslDat | ztDate |  |  | datetime
Count | vrcount | ztInteger | 5 |  | smallint
Won/Lost | vunnenforlorad | ztInteger | 3 |  | smallint


Business opportunities, history (proh)

Table of history of business opportunities/projects in the marketing module as well as contacts who are connected to them.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | antal | ZtQty | 14 | 2 | decimal
Poss own margin | e_potbidrag | ZtBaseCurrAmount | 12 | 2 | money
Poss own turnover | e_potvolym | ZtBaseCurrAmount | 12 | 2 | money
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | ftgkontaktnr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Company Group ID | ftgnrgrupp | ztCompanyNo | 20 |  | varchar
Contact name | FtgPerson | ztString | 60 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | kortnotering | ztString | 255 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Quarter | Kvartal | ztInteger | 1 |  | smallint
Quote/Agreemt date | offertdat | ztDate |  |  | datetime
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Price conversion factor | omvfaktor | ZtPurQty2Stock | 12 | 6 | decimal
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Poss margin | p_potbidrag | ZtBaseCurrAmount | 14 | 2 | money
Poss sales value | p_potvolym | ZtBaseCurrAmount | 14 | 2 | money
Probability% | p_prob_proc | ztInteger | 3 |  | smallint
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Period | period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Business opportunity | ProBeskr | ztString | 50 |  | varchar
Est decision date | ProjBerBeslDat | ztDate |  |  | datetime
Project ID | ProjCode | ztString | 10 |  | varchar
Project name | ProjDescr | ztString | 40 |  | varchar
Project source | ProjInit | ztInteger | 2 |  | smallint
Project start date | ProjInitDat | ztDate |  |  | datetime
Current supplier | ProjNuvLev | ztString | 24 |  | varchar
Current product | ProjNuvProd | ztString | 20 |  | varchar
Project start date | ProjStartDat | ztDate |  |  | datetime
Bus opp descr | prospbeskr | ztString | 50 |  | varchar
Bus opp characteristic | ProspEgK6 | ztInteger | 3 |  | smallint
Bus opp characteristic | ProspEgK7 | ztInteger | 3 |  | smallint
Bus opp characteristic | ProspEgK8 | ztInteger | 3 |  | smallint
Bus opp characteristic | ProspEgK9 | ztInteger | 3 |  | smallint
Bus opp characteristic | ProspEgKA | ztInteger | 3 |  | smallint
Bus opp characteristic | ProspEgKB | ztInteger | 3 |  | smallint
Business opportunity ID | prospektid | ZtLong | 10 |  | int
Status code | ProspStatKod | ztInteger | 3 |  | smallint
Fiscal year | redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
End customer | slutkund | ztCompanyNo | 20 |  | varchar
Identity | sqlidentity | ZtLong | 10 |  | int
Date/time | StrDateTime | ztString | 28 |  | varchar
Original decision date | Ursprbesldat | ztDate |  |  | datetime
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Own margin, curr | vb_e_potbidrag | ztMoney | 12 |  | money
Own turnover, curr | vb_e_potvolym | ztMoney | 12 |  | money
Poss margin, curr | vb_p_potbidrag | ztMoney | 12 |  | money
Poss turnover, curr | vb_p_potvolym | ztMoney | 12 |  | money
Actual end date | VerklAvslDat | ztDate |  |  | datetime
Won/Lost | vunnenforlorad | ztInteger | 3 |  | smallint


Business opportunity categories (ProEkd1)

Definition of own categories of business opportunities.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description level 1 | ekd1beskr | ztString | 40 |  | varchar
Category level 1 | ekdi1 | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ProEkd Business opportunity categories


Business opportunity characteristics 1 (xps6)

Definition of characteristics that can be used for grouping/classifying business opportunities/projects. There are 6 similar tables for this purpose. Example of usage: Type of business opportunity (e.g. new sales/additional sales), information about previously sold products, etc. You can change field prompts and title headings to describe the current characteristic.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Bus opp characteristic | ProspEgD6 | ztString | 30 |  | varchar
Bus opp characteristic | ProspEgK6 | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xps6 Business opportunity characteristics 1


Business opportunity characteristics 2 (xps7)

Definition of characteristics that can be used for grouping/classifying business opportunities/projects. There are 6 similar tables for this purpose. Example of usage: Type of business opportunity (e.g. new sales/additional sales), information about previously sold products, etc. You can change field prompts and title headings to describe the current characteristic.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Bus opp characteristic | ProspEgD7 | ztString | 30 |  | varchar
Bus opp characteristic | ProspEgK7 | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xps7 Business opportunity characteristics 2


Business opportunity characteristics 3 (xps8)

Definition of characteristics that can be used for grouping/classifying business opportunities/projects. There are 6 similar tables for this purpose. Example of usage: Type of business opportunity (e.g. new sales/additional sales), information about previously sold products, etc. You can change field prompts and title headings to describe the current characteristic.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Bus opp characteristic | ProspEgD8 | ztString | 30 |  | varchar
Bus opp characteristic | ProspEgK8 | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xps8 Business opportunity characteristics 3


Business opportunity characteristics 4 (xps9)

Definition of characteristics that can be used for grouping/classifying business opportunities/projects. There are 6 similar tables for this purpose. Example of usage: Type of business opportunity (e.g. new sales/additional sales), information about previously sold products, etc. You can change field prompts and title headings to describe the current characteristic.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Bus opp characteristic | ProspEgD9 | ztString | 30 |  | varchar
Bus opp characteristic | ProspEgK9 | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xps9 Business opportunity characteristics 4


Business opportunity characteristics 5 (xpsA)

Definition of characteristics that can be used for grouping/classifying business opportunities/projects. There are 6 similar tables for this purpose. Example of usage: Type of business opportunity (e.g. new sales/additional sales), information about previously sold products, etc. You can change field prompts and title headings to describe the current characteristic.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Bus opp characteristic | ProspEgDA | ztString | 30 |  | varchar
Bus opp characteristic | ProspEgKA | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xpsA Business opportunity characteristics 5


Business opportunity characteristics 6 (xpsB)

Definition of characteristics that can be used for grouping/classifying business opportunities/projects. There are 6 similar tables for this purpose. Example of usage: Type of business opportunity (e.g. new sales/additional sales), information about previously sold products, etc. You can change field prompts and title headings to describe the current characteristic.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Bus opp characteristic | ProspEgDB | ztString | 30 |  | varchar
Bus opp characteristic | ProspEgKB | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xpsB Business opportunity characteristics 6


Business opportunity contacts (pkp)

Definition of contacts linked to a particular business opportunity.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Position | BefattKod | ztString | 2 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Business opportunity ID | prospektid | ZtLong | 10 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar


Business opportunity status (xg1)

Definition of status codes and descriptions for business opportunities.

From version 9, there is certain logic for automatically changing a sales phase when changing a business opportunity's status, which is why there are predefined records that can be loaded into the table upon installation (so-called Proposals).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Closing status | Avslutar | ztBoolean |  |  | char
Description | Beskrivning | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Gen plan activities | genplanh | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Log | Loggas | ztBoolean |  |  | char
Probability% | p_prob_proc | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Status code | ProspStatKod | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sales phase | saljfasid | ztInteger | 5 |  | smallint
Won/Lost | vunnenforlorad | ztInteger | 3 |  | smallint

    This table is the main table in the following programs:

    Program: Xxg1 Business opportunity status


Business transactiosn to GL (BTran2GLDef)

In the table the name of the conversion description and which database it applies to are stored.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | BTran2GLDefDescr | ztString | 60 |  | varchar
ID | BTran2GLDefId | ztString | 10 |  | varchar
Receiving table | BTran2GLDefTargetTable | ztString | 40 |  | varchar
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Valid from date | GiltigFromDatum | ztDate |  |  | datetime
Valid to date | GiltigTomDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Value term table | VardeTabId1 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: BTran2GL Business transactions ->GL


Calc transactions->GL (arvt)

Detailed data by transaction of how cost price change transactions are posted when integrated with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Cost change journal | ArskJournNr | ZtLong | 6 |  | int
Cost prc date | ArtKalkDat | ztDate |  |  | datetime
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Invtry unit->Purch unit | StockQty2SuppQty | ztFloat | 12 | 6 | float
Date/time | StrDateTime | ztString | 28 |  | varchar
UniqueIDInAKLT | UniqueIDInAKLT | ZtLong | 10 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint


Calculated cost prices (Inventory location) (alkpris)

Calculated cost prices per Inventory location in batch calculation routine for cost prices.
Costs prices are stored with user ID on each row and automatically cleared when a new batch is run.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Customs duty 2 | Alkp_AlAvgiftTon | ZtBaseCurrAmount | 14 | 4 | money
Calc cost price | Alkp_AlBerKalkPris | ZtBaseCurrAmount | 14 | 4 | money
Calc cost price, refinem | Alkp_AlBerKalkPrisForadling | ZtBaseCurrAmount | 14 | 4 | money
Calc cost price, material | Alkp_AlBerKalkPrisMtrl | ZtBaseCurrAmount | 14 | 4 | money
Calc price curr | Alkp_AlBerKalkPrisVal | ztMoney | 14 | 4 | money
Freight/Deliv/Mtrl cost | Alkp_AlFraktKostnad | ZtBaseCurrAmount | 14 | 4 | money
Basic cost calc | Alkp_AlGrundKalkPris | ZtBaseCurrAmount | 14 | 4 | money
Net purchase price | Alkp_AlInPrisNetto | ZtBaseCurrAmount | 14 | 4 | money
Net purchase price curr | Alkp_AlInPrisNettoVal | ztMoney | 14 | 4 | money
Calculated rate | Alkp_AlKalkKurs | ZtCurrencyRate | 10 | 5 | decimal
Calc/inventory unit | Alkp_AlKostPerLgrEnh | ZtBaseCurrAmount | 14 | 4 | money
Calc/invtry unit curr | Alkp_AlKostPerLgrEnhVal | ztMoney | 14 | 4 | money
Supplier disc | Alkp_AlLevRabatt | ZtBaseCurrAmount | 14 | 4 | money
Markup 1 | Alkp_AlPalbel1 | ZtBaseCurrAmount | 14 | 4 | money
Markup 2 | Alkp_AlPalBel2 | ZtBaseCurrAmount | 14 | 4 | money
Markup 3 | Alkp_AlPalBel3 | ZtBaseCurrAmount | 14 | 4 | money
Markup 4 | Alkp_AlPalBel4 | ZtBaseCurrAmount | 14 | 4 | money
Markup 5 | Alkp_AlPalBel5 | ZtBaseCurrAmount | 14 | 4 | money
Calc total cost | Alkp_AlTotalKostnad | ZtBaseCurrAmount | 14 | 4 | money
Calc total cost curr | Alkp_AlTotalKostnadVal | ztMoney | 14 | 4 | money
Customs duty 1 | Alkp_AlTullKostnad | ZtBaseCurrAmount | 14 | 4 | money
Currency | Alkp_AlValKod | ztString | 3 |  | varchar
Today's rate | Alkp_ArsnDagsKurs | ZtCurrencyRate | 10 | 5 | decimal
Calculated rate | Alkp_ArsnKalkKurs | ZtCurrencyRate | 10 | 5 | decimal
Currency | Alkp_ArsnValKod | ztString | 3 |  | varchar
Basic cost, purchase | Alkp_BasKostnadInkop | ZtBaseCurrAmount | 14 | 4 | money
Creation code | Alkp_CreationCode | ztInteger | 1 |  | smallint
New cost price as of | Alkp_KalkPrisNyttDatum | ztDate |  |  | datetime
Layer code alt suppl | Alkp_LayerCode | ztInteger | 1 |  | smallint
Record type | alkp_PostTyp | ztString | 1 |  | varchar
Setup cost, BCU | Alkp_StallKostnad | ZtBaseCurrAmount | 14 | 4 | money
Main agreement | ArtHuvudAvt | ztBoolean |  |  | char
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Markup 2 chain | ArtKalkChain2 | ztBoolean |  |  | char
Markup 4 chain | ArtKalkChain4 | ztBoolean |  |  | char
Markup template | ArtKalkPalKod | ztString | 4 |  | varchar
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Calc cost price | ArtKalkPris | ZtBaseCurrAmount | 14 | 2 | money
Markup 1 % | ArtKalkProc1 | ztFloat | 6 | 2 | float
Markup 2 % | ArtKalkProc2 | ztFloat | 6 | 2 | float
Markup 3 % | ArtKalkProc3 | ztFloat | 6 | 2 | float
Markup 4 % | ArtKalkProc4 | ztFloat | 6 | 2 | float
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
TARIC code | ArtStatNr | ztString | 20 |  | varchar
Start cost/pc | ArtStyckStartKostnad | ZtCost | 16 | 6 | float
EU/EES source | ArtUrsprung | ztBoolean |  |  | char
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Duty/ton fixed | AvgiftTonFast | ztFloat | 10 | 2 | float
Duty/ton floating | AvgiftTonFlyt | ztFloat | 10 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight cost % | FraktKostnProc | ZtDecimal73 | 7 | 2 | decimal
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Trading area | HandelsOmrKod | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Price conv factor | InkArtOmvFaktor | ztFloat | 14 | 4 | float
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Price unit factor | InkPrisPer | ZtDecimal73 | 8 | 3 | decimal
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
New cost as of date | NewCostsFromDate | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Löpnummer | RadNummer | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Invtry unit->Purch unit | StockQty2SuppQty | ztFloat | 12 | 6 | float
Customs duties % | TullKostnProc | ZtDecimal73 | 6 | 2 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | vb_InPris | ztMoney | 14 | 2 | money
Gross purch price, curr | vb_InPris_Brutto | ztMoney | 14 | 2 | money
Net purchase price, curr | vb_InPris_Netto | ztMoney | 14 | 2 | money
Gross setup price, curr | vb_InPris_Stall | ztMoney | 14 | 2 | money
Cost price, curr | vbKalkPris | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: KalkPrisPerLgr Show calc cost prices/inventory loc, main agreements

    Program: KalkPrisPerLgrO Show calc cost prices/inventory loc, other agreements


Calculated costs (alkp)

Calculated cost in batch costing calculation routine. Costs are stored with user ID on each row and automatically cleared when a new batch is run.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Customs duty 2 | Alkp_AlAvgiftTon | ZtBaseCurrAmount | 14 | 4 | money
Calc cost price | Alkp_AlBerKalkPris | ZtBaseCurrAmount | 14 | 4 | money
Calc cost price, refinem | Alkp_AlBerKalkPrisForadling | ZtBaseCurrAmount | 14 | 4 | money
Calc cost price, material | Alkp_AlBerKalkPrisMtrl | ZtBaseCurrAmount | 14 | 4 | money
Calc price curr | Alkp_AlBerKalkPrisVal | ztMoney | 14 | 4 | money
Freight/Deliv/Mtrl cost | Alkp_AlFraktKostnad | ZtBaseCurrAmount | 14 | 4 | money
Basic cost calc | Alkp_AlGrundKalkPris | ZtBaseCurrAmount | 14 | 4 | money
Net purchase price | Alkp_AlInPrisNetto | ZtBaseCurrAmount | 14 | 4 | money
Net purchase price curr | Alkp_AlInPrisNettoVal | ztMoney | 14 | 4 | money
Calculated rate | Alkp_AlKalkKurs | ZtCurrencyRate | 10 | 5 | decimal
Calc/inventory unit | Alkp_AlKostPerLgrEnh | ZtBaseCurrAmount | 14 | 4 | money
Calc/invtry unit curr | Alkp_AlKostPerLgrEnhVal | ztMoney | 14 | 4 | money
Supplier disc | Alkp_AlLevRabatt | ZtBaseCurrAmount | 14 | 4 | money
Markup 1 | Alkp_AlPalbel1 | ZtBaseCurrAmount | 14 | 4 | money
Markup 2 | Alkp_AlPalBel2 | ZtBaseCurrAmount | 14 | 4 | money
Markup 3 | Alkp_AlPalBel3 | ZtBaseCurrAmount | 14 | 4 | money
Markup 4 | Alkp_AlPalBel4 | ZtBaseCurrAmount | 14 | 4 | money
Markup 5 | Alkp_AlPalBel5 | ZtBaseCurrAmount | 14 | 4 | money
Calc total cost | Alkp_AlTotalKostnad | ZtBaseCurrAmount | 14 | 4 | money
Calc total cost curr | Alkp_AlTotalKostnadVal | ztMoney | 14 | 4 | money
Customs duty 1 | Alkp_AlTullKostnad | ZtBaseCurrAmount | 14 | 4 | money
Currency | Alkp_AlValKod | ztString | 3 |  | varchar
Today's rate | Alkp_ArsnDagsKurs | ZtCurrencyRate | 10 | 5 | decimal
Calculated rate | Alkp_ArsnKalkKurs | ZtCurrencyRate | 10 | 5 | decimal
Currency | Alkp_ArsnValKod | ztString | 3 |  | varchar
Basic cost, purchase | Alkp_BasKostnadInkop | ZtBaseCurrAmount | 14 | 4 | money
New cost price as of | Alkp_KalkPrisNyttDatum | ztDate |  |  | datetime
Setup cost, BCU | Alkp_StallKostnad | ZtBaseCurrAmount | 14 | 4 | money
Main agreement | ArtHuvudAvt | ztBoolean |  |  | char
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Markup 2 chain | ArtKalkChain2 | ztBoolean |  |  | char
Markup 4 chain | ArtKalkChain4 | ztBoolean |  |  | char
Markup template | ArtKalkPalKod | ztString | 4 |  | varchar
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Calc cost price | ArtKalkPris | ZtBaseCurrAmount | 14 | 2 | money
Markup 1 % | ArtKalkProc1 | ztFloat | 6 | 2 | float
Markup 2 % | ArtKalkProc2 | ztFloat | 6 | 2 | float
Markup 3 % | ArtKalkProc3 | ztFloat | 6 | 2 | float
Markup 4 % | ArtKalkProc4 | ztFloat | 6 | 2 | float
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
TARIC code | ArtStatNr | ztString | 20 |  | varchar
Start cost/pc | ArtStyckStartKostnad | ZtCost | 16 | 6 | float
EU/EES source | ArtUrsprung | ztBoolean |  |  | char
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Duty/ton fixed | AvgiftTonFast | ztFloat | 10 | 2 | float
Duty/ton floating | AvgiftTonFlyt | ztFloat | 10 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight cost % | FraktKostnProc | ZtDecimal73 | 7 | 2 | decimal
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Trading area | HandelsOmrKod | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Price conv factor | InkArtOmvFaktor | ztFloat | 14 | 4 | float
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Price unit factor | InkPrisPer | ZtDecimal73 | 8 | 3 | decimal
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Löpnummer | RadNummer | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Invtry unit->Purch unit | StockQty2SuppQty | ztFloat | 12 | 6 | float
Customs duties % | TullKostnProc | ZtDecimal73 | 6 | 2 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | vb_InPris | ztMoney | 14 | 2 | money
Gross purch price, curr | vb_InPris_Brutto | ztMoney | 14 | 2 | money
Net purchase price, curr | vb_InPris_Netto | ztMoney | 14 | 2 | money
Gross setup price, curr | vb_InPris_Stall | ztMoney | 14 | 2 | money
Cost price, curr | vbKalkPris | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: AlkpKalk Show calculated cost prices

    Program: ralkp Calculated costs


Calculated salary (AttR_sal)

Calculated salary.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Agreement ID | AttRAgreement | ztString | 6 |  | varchar
Balance | AttRBalance | ztFloat | 15 | 2 | float
From time | AttRFromTime | ztDateTime |  |  | datetime
Originates from | AttROrigin | ztInteger | 5 |  | smallint
Salary date | AttRSalaryDat | ztDate |  |  | datetime
Salary type | AttRSalaryType | ZtLong | 10 |  | int
To time | AttRToTime | ztDateTime |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | Perssign2 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_sal Calculated salary


Calculation components (xcc)

Contains calculation components that will be available to choose from when entering the calculation components to be included in a certain overhead cost.

The following standard records exist. Do not alter/delete:

Calculation component (KalkylKompTyp) | Calculation component descr (KalkylKompBeskr)
11 | Labour cost
12 | Labour cost, overhead
31 | Mfg group, fixed costs
32 | Mfg group, variable costs
33 | Mfg group, depreciation
34 | Mfg group, setup cost
51 | Tool, fixed costs
52 | Tool, variable costs
53 | Tool, depreciation
54 | Tool, setup cost
91 | Direct material cost
92 | Material cost, overhead

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calculation component descr | KalkylKompBeskr | ztString | 80 |  | varchar
Calculation component | KalkylKompTyp | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xcc Calculation component


Calculation header, calculated item (arkh)

Detailed estimated costs of an item.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Calc admin overhead cost | AdminOmkBelopp | ZtBaseCurrAmount | 14 | 2 | money
Administr OH cost% | ArkAdmOmkProc | ztFloat | 7 | 2 | float
Sales OH cost % | ArkForsOmkProc | ztFloat | 7 | 2 | float
Calculation markup code | ArkPalKod | ztInteger | 5 |  | smallint
Mfg OH cost % | ArkProdOmkProc | ztFloat | 7 | 2 | float
Calculation version no. | ArkVersion | ZtLong | 4 |  | int
Extra profit amount | ArkVinstPalBel | ZtBaseCurrAmount | 14 | 2 | money
Profit % | ArkVinstProc | ztFloat | 7 | 2 | float
Labour cost (calculation) | ArtKalkArbKost | ZtBaseCurrAmount | 14 | 2 | money
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
New cost price from date | ArtKalkBerNyttDatum | ztDate |  |  | datetime
New cost price (refinement) | ArtKalkBerNyttForadling | ZtBaseCurrAmount | 14 | 2 | money
New cost price (mtrl) | ArtKalkBerNyttMtrl | ZtBaseCurrAmount | 14 | 2 | money
Prel cost prc | ArtKalkBerPrel | ZtPurPrice | 12 | 2 | money
Fixed cost (calculation) | ArtKalkFastKost | ZtBaseCurrAmount | 14 | 2 | money
Material cost (calculation) | ArtKalkMtrlKost | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Variable cost (calculation) | ArtKalkRorlKost | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Last PYR date | ArtPyrDat | ztDateTime |  |  | datetime
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Econ order quantity | Eoq | ZtQty | 14 | 2 | decimal
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Calculated sales price | FKalkBerFPris | ZtSalesPrice | 12 | 2 | money
Calculated contr margin/pc | FKalkBerTBStyck | ZtSalesPrice | 12 | 2 | money
Calculated contr margin/hr | FKalkBerTBTimme | ZtSalesPrice | 12 | 2 | money
Actual sales prc bef. est | FKalkVerklFPris | ZtSalesPrice | 12 | 2 | money
Unit contrib profit prior calc | FKalkVerklTbStyck | ZtSalesPrice | 12 | 2 | money
Contrib profit per hour prior calc | FKalkVerklTbTimme | ZtSalesPrice | 12 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Calc admin sales overhead cost. | ForsOmkBelopp | ZtBaseCurrAmount | 14 | 2 | money
Net sales price | FPrisNetto | ZtSalesPrice | 12 | 2 | money
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Calculation item | KalkArtNr | ztString | 30 |  | varchar
Calculation on quantity | KalkylPaAntal | ZtQty | 14 | 2 | decimal
Overheads, work, admin | LabOvhdAdmCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, production | LabOvhdPrdCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, sales | LabOvhdSalesCost | ZtBaseCurrAmount | 14 | 2 | money
Inventory location | LagStalle | ztString | 2 |  | varchar
Batch size manufacturing | PartistorlekTillv | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Calc manuf overhead cost | ProdOmkBelopp | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Sim depr cost chg % | SimAndrProcAvskrKost | ZtDecimal73 | 8 | 3 | decimal
Sim flow grp cost chg% | SimAndrProcFlgKost | ZtDecimal73 | 8 | 3 | decimal
Sim subcontr cost chg % | SimAndrProcLegoKost | ZtDecimal73 | 8 | 3 | decimal
Sim wage cost change % | SimAndrProcLoneKost | ZtDecimal73 | 8 | 3 | decimal
Sim mtrl cost change % | SimAndrProcMtrlKost | ZtDecimal73 | 8 | 3 | decimal
Sim mfg grp cost chg % | SimAndrProcPgKost | ZtDecimal73 | 8 | 3 | decimal
Sim tool cost change % | SimAndrProcVTygKost | ZtDecimal73 | 8 | 3 | decimal
Manufacturing OH 1 | TK1 | ZtBaseCurrAmount | 14 | 2 | money
Manufact cost 2 | TK2 | ZtBaseCurrAmount | 14 | 2 | money
Total labour overhead | TotArbOmk | ZtCost | 16 | 6 | float
Total fixed labour OH | TotArbOmkFast | ZtCost | 16 | 6 | float
Labour OH op/total | TotArbOmkOp | ZtCost | 16 | 6 | float
Var OH labour total | TotArbOmkRorl | ZtCost | 16 | 6 | float
Total setup overhead | TotArbOmkStall | ZtCost | 16 | 6 | float
Indirect setup costs | TotArbStallBiKost | ZtCost | 16 | 6 | float
Total setup cost | TotArbStallKost | ZtCost | 16 | 6 | float
Indirect labour costs | TotArbStyckBiKost | ZtCost | 16 | 6 | float
Labour total | TotArbStyckKost | ZtCost | 16 | 6 | float
Total item startup cost | TotArtStartKost | ZtCost | 16 | 6 | float
Extraomkostnad totalt | TotExtraOmk | ZtCost | 16 | 6 | float
Total indir subcontr costs | TotLegoBiKost | ZtCost | 16 | 6 | float
Total subcontract cost | TotLegoKost | ZtCost | 16 | 6 | float
Total material cost | TotMtrlKost | ZtCost | 16 | 6 | float
Mtrl overhead total | TotMtrlMoKost | ZtCost | 16 | 6 | float
Mfg grp depr total | TotPgAvskrKost | ZtCost | 16 | 6 | float
Mfg grp fixed rate tot | TotPgFastKost | ZtCost | 16 | 6 | float
Mfg grp var cost total | TotPgRorlKost | ZtCost | 16 | 6 | float
Mfg grp setup cost | TotPgStallKost | ZtCost | 16 | 6 | float
Rörlig kostnad | TotRorligKost | ZtBaseCurrAmount | 14 | 2 | money
Cost price | TotSjalvKost | ZtBaseCurrAmount | 14 | 2 | money
Ställkostnad | TotStallKost | ZtBaseCurrAmount | 14 | 2 | money
Technical overhead cost tot | TotTeknikOmk | ZtCost | 16 | 6 | float
Total MO startup cost | TotToStartKost | ZtCost | 16 | 6 | float
Total developmt cost | TotUtvKost | ZtCost | 16 | 6 | float
Tot developmt OH cost | TotUtvOmk | ZtCost | 16 | 6 | float
Total tool depr | TotVyAvskrKost | ZtCost | 16 | 6 | float
Total tool fix cost | TotVyFastKost | ZtCost | 16 | 6 | float
Total tool var cost | TotVyRorlKost | ZtCost | 16 | 6 | float
Total tool setup cost | TotVyStallKost | ZtCost | 16 | 6 | float
Total tool unit cost | TotVyStyckKost | ZtCost | 16 | 6 | float
Item group | VarugruppKod | ztString | 8 |  | varchar
Calc sales profit | VinstBelopp | ZtBaseCurrAmount | 14 | 2 | money

    This table is the main table in the following programs:

    Program: Arkh Cost calculations (detailed)


Calculation of cost and list prices, header (PriceCalcH)

Data in the header of a list price calculation.
The calculation rows are stored in the 'PriceCalcR' table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
New cost price from date | ArtKalkBerNyttDatum | ztDate |  |  | datetime
New list price from date | ArtListPrisNyttDatum | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Date for new calc rate | NewCalcRateDate | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Price calculation date | PriceCalcDate | ztDateTime |  |  | datetime
Price calculation descr | pricecalcdescr | ztString | 50 |  | varchar
Price calculation no | pricecalcno | ZtLong | 10 |  | int
Price updated date | PriceUpdatedDate | ztDateTime |  |  | datetime
Purch price from date | PurchPriceFromDate | ztDate |  |  | datetime
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PriceCalcH Calculation of cost and list prices

    Program: PriceCalcHist Calculated cost and list prices, history

    Program: PriceCalcHSel Calculate cost and list prices, select items


Calculation of cost and list prices, results (PriceCalcRes)

Calculated cost prices per Inventory location in batch calculation routine for cost prices.
Costs prices are stored with user ID on each row and automatically cleared when a new batch is run.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Customs duty 2 | Alkp_AlAvgiftTon | ZtBaseCurrAmount | 14 | 4 | money
Calc cost price | Alkp_AlBerKalkPris | ZtBaseCurrAmount | 14 | 4 | money
Calc cost price, refinem | Alkp_AlBerKalkPrisForadling | ZtBaseCurrAmount | 14 | 4 | money
Calc cost price, material | Alkp_AlBerKalkPrisMtrl | ZtBaseCurrAmount | 14 | 4 | money
Calc price curr | Alkp_AlBerKalkPrisVal | ztMoney | 14 | 4 | money
Freight/Deliv/Mtrl cost | Alkp_AlFraktKostnad | ZtBaseCurrAmount | 14 | 4 | money
Basic cost calc | Alkp_AlGrundKalkPris | ZtBaseCurrAmount | 14 | 4 | money
Net purchase price | Alkp_AlInPrisNetto | ZtBaseCurrAmount | 14 | 4 | money
Net purchase price curr | Alkp_AlInPrisNettoVal | ztMoney | 14 | 4 | money
Calculated rate | Alkp_AlKalkKurs | ZtCurrencyRate | 10 | 5 | decimal
Calc/inventory unit | Alkp_AlKostPerLgrEnh | ZtBaseCurrAmount | 14 | 4 | money
Calc/invtry unit curr | Alkp_AlKostPerLgrEnhVal | ztMoney | 14 | 4 | money
Supplier disc | Alkp_AlLevRabatt | ZtBaseCurrAmount | 14 | 4 | money
Markup 1 | Alkp_AlPalbel1 | ZtBaseCurrAmount | 14 | 4 | money
Markup 2 | Alkp_AlPalBel2 | ZtBaseCurrAmount | 14 | 4 | money
Markup 3 | Alkp_AlPalBel3 | ZtBaseCurrAmount | 14 | 4 | money
Markup 4 | Alkp_AlPalBel4 | ZtBaseCurrAmount | 14 | 4 | money
Markup 5 | Alkp_AlPalBel5 | ZtBaseCurrAmount | 14 | 4 | money
Calc total cost | Alkp_AlTotalKostnad | ZtBaseCurrAmount | 14 | 4 | money
Calc total cost curr | Alkp_AlTotalKostnadVal | ztMoney | 14 | 4 | money
Customs duty 1 | Alkp_AlTullKostnad | ZtBaseCurrAmount | 14 | 4 | money
Currency | Alkp_AlValKod | ztString | 3 |  | varchar
Today's rate | Alkp_ArsnDagsKurs | ZtCurrencyRate | 10 | 5 | decimal
Calculated rate | Alkp_ArsnKalkKurs | ZtCurrencyRate | 10 | 5 | decimal
Currency | Alkp_ArsnValKod | ztString | 3 |  | varchar
Basic cost, purchase | Alkp_BasKostnadInkop | ZtBaseCurrAmount | 14 | 4 | money
Creation code | Alkp_CreationCode | ztInteger | 1 |  | smallint
New cost price as of | Alkp_KalkPrisNyttDatum | ztDate |  |  | datetime
Layer code alt suppl | Alkp_LayerCode | ztInteger | 1 |  | smallint
Record type | alkp_PostTyp | ztString | 1 |  | varchar
Setup cost, BCU | Alkp_StallKostnad | ZtBaseCurrAmount | 14 | 4 | money
Main agreement | ArtHuvudAvt | ztBoolean |  |  | char
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Markup 2 chain | ArtKalkChain2 | ztBoolean |  |  | char
Markup 4 chain | ArtKalkChain4 | ztBoolean |  |  | char
Markup template | ArtKalkPalKod | ztString | 4 |  | varchar
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Calc cost price | ArtKalkPris | ZtBaseCurrAmount | 14 | 2 | money
Markup 1 % | ArtKalkProc1 | ztFloat | 6 | 2 | float
Markup 2 % | ArtKalkProc2 | ztFloat | 6 | 2 | float
Markup 3 % | ArtKalkProc3 | ztFloat | 6 | 2 | float
Markup 4 % | ArtKalkProc4 | ztFloat | 6 | 2 | float
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
TARIC code | ArtStatNr | ztString | 20 |  | varchar
Start cost/pc | ArtStyckStartKostnad | ZtCost | 16 | 6 | float
EU/EES source | ArtUrsprung | ztBoolean |  |  | char
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Duty/ton fixed | AvgiftTonFast | ztFloat | 10 | 2 | float
Duty/ton floating | AvgiftTonFlyt | ztFloat | 10 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight cost % | FraktKostnProc | ZtDecimal73 | 7 | 2 | decimal
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Trading area | HandelsOmrKod | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Price conv factor | InkArtOmvFaktor | ztFloat | 14 | 4 | float
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Price unit factor | InkPrisPer | ZtDecimal73 | 8 | 3 | decimal
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
List price, calc base 1 | ListPriceCalcBase1 | ZtBaseCurrAmount | 14 | 4 | money
List price, calc base 2 | ListPriceCalcBase2 | ZtBaseCurrAmount | 14 | 4 | money
List price, calc per pcs | ListPriceCalcPerPcs | ZtBaseCurrAmount | 14 | 2 | money
List price, calc round | ListPriceCalcRound | ZtBaseCurrAmount | 14 | 2 | money
List price markup 2 chain | ListPriceChain2 | ztBoolean |  |  | char
List price markup 4 chain | ListPriceChain4 | ztBoolean |  |  | char
List price markup-1 % | ListPriceMarkUp1 | ztFloat | 6 | 2 | float
List price markup-2 % | ListPriceMarkUp2 | ztFloat | 6 | 2 | float
List price markup-3 % | ListPriceMarkUp3 | ztFloat | 6 | 2 | float
List price markup-4 % | ListPriceMarkUp4 | ztFloat | 6 | 2 | float
List price markup-1 | ListPriceMarkUpBel1 | ZtBaseCurrAmount | 14 | 4 | money
List price markup-2 | ListPriceMarkUpBel2 | ZtBaseCurrAmount | 14 | 4 | money
List price markup-3 | ListPriceMarkUpBel3 | ZtBaseCurrAmount | 14 | 4 | money
List price markup-4 | ListPriceMarkUpBel4 | ZtBaseCurrAmount | 14 | 4 | money
List price markup-5 | ListPriceMarkUpBel5 | ZtBaseCurrAmount | 14 | 4 | money
List price markup template | ListPriceMarkUpCd | ztString | 10 |  | varchar
New cost as of date | NewCostsFromDate | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Price calculation no | PriceCalcNo | ZtLong | 10 |  | int
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Löpnummer | RadNummer | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Invtry unit->Purch unit | StockQty2SuppQty | ztFloat | 12 | 6 | float
Customs duties % | TullKostnProc | ZtDecimal73 | 6 | 2 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | vb_InPris | ztMoney | 14 | 2 | money
Gross purch price, curr | vb_InPris_Brutto | ztMoney | 14 | 2 | money
Net purchase price, curr | vb_InPris_Netto | ztMoney | 14 | 2 | money
Gross setup price, curr | vb_InPris_Stall | ztMoney | 14 | 2 | money
Cost price, curr | vbKalkPris | ztMoney | 14 | 2 | money


Calculation of cost and list prices, rows (PriceCalcR)

Price calculation rows for items (products). These rows always have an item number that must be in the item table.
The price calculation rows always belongs to an price calculation head (PriceCalcH).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Freight cost % | AlFraktKostnProc | ZtDecimal73 | 5 | 2 | decimal
Delivery cost % | AlHemtKostnProc | ZtDecimal73 | 7 | 2 | decimal
Net purchase price | ArtInPris | ZtBaseCurrAmount | 14 | 2 | money
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
New cost price (refinement) | ArtKalkBerNyttForadling | ZtBaseCurrAmount | 14 | 2 | money
New cost price (mtrl) | ArtKalkBerNyttMtrl | ZtBaseCurrAmount | 14 | 2 | money
Markup 2 chain | ArtKalkChain2 | ztBoolean |  |  | char
Markup 4 chain | ArtKalkChain4 | ztBoolean |  |  | char
Markup 5, amount | ArtKalkPalBel5 | ZtBaseCurrAmount | 14 | 2 | money
Markup template | ArtKalkPalKod | ztString | 4 |  | varchar
Calc cost price | ArtKalkPris | ZtBaseCurrAmount | 14 | 2 | money
Markup 1 % | ArtKalkProc1 | ztFloat | 6 | 2 | float
Markup 2 % | ArtKalkProc2 | ztFloat | 6 | 2 | float
Markup 3 % | ArtKalkProc3 | ztFloat | 6 | 2 | float
Markup 4 % | ArtKalkProc4 | ztFloat | 6 | 2 | float
Average cost price | ArtKalkSnitt | ZtBaseCurrAmount | 14 | 2 | money
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
List price | ArtListPris | ZtBaseCurrAmount | 14 | 2 | money
Calculated List price | ArtListPrisKalk | ZtBaseCurrAmount | 14 | 2 | money
New list price | ArtListPrisNytt | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
TARIC code | ArtStatNr | ztString | 20 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight cost % | FraktKostnProc | ZtDecimal73 | 7 | 2 | decimal
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Delivery cost % | Hemtkostnproc | ZtDecimal73 | 7 | 2 | decimal
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Internal row type | IntrnRowType | ztInteger | 5 |  | smallint
Markup 5, amount | ListPriceAddAmt5 | ZtBaseCurrAmount | 14 | 2 | money
List price markup 2 chain | ListPriceChain2 | ztBoolean |  |  | char
List price markup 4 chain | ListPriceChain4 | ztBoolean |  |  | char
List price markup-1 % | ListPriceMarkUp1 | ztFloat | 6 | 2 | float
List price markup-2 % | ListPriceMarkUp2 | ztFloat | 6 | 2 | float
List price markup-3 % | ListPriceMarkUp3 | ztFloat | 6 | 2 | float
List price markup-4 % | ListPriceMarkUp4 | ztFloat | 6 | 2 | float
List price markup template | ListPriceMarkUpCd | ztString | 10 |  | varchar
Mtrl overhead % | MtrlMoKostProc | ZtDecimal73 | 7 | 2 | decimal
New calculation rate | NewCalcRate | ZtCurrencyRate | 15 | 7 | decimal
New cost as of date | NewCostsFromDate | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Price calculation no | PriceCalcNo | ZtLong | 10 |  | int
Discount 1 % | rabatt1 | ZtDecimal73 | 6 | 2 | decimal
New discount 1 % | Rabatt1Nytt | ztFloat | 6 | 2 | float
Discount 2 % | rabatt2 | ZtDecimal73 | 6 | 2 | decimal
New discount 2 % | Rabatt2Nytt | ztFloat | 6 | 2 | float
Discount 3 % | rabatt3 | ZtDecimal73 | 6 | 2 | decimal
New discount 3 % | Rabatt3Nytt | ztFloat | 6 | 2 | float
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Net purchase price, curr | vb_InPris_Netto | ztMoney | 14 | 2 | money
New gross purch price, curr | Vb_InPrisNytt | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: PriceCalcR Price calculation rows for item list prices


Calculation rule (xccr)

Definition of discount calculation methods for consumer nondurables (industry specific function).

The following standard records exist. Do not alter/delete:

Calculation method (CalcMethod) | Calculation method (CalcMethodB)
0 | Percent of net
1 | Currency per unit
2 | Percent per even pallet
3 | Currency per even pallet

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Calculation method | CalcMethod | ztInteger | 5 |  | smallint
Calculation method | CalcMethodB | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xccr Discount calculation methods


Calendar (kal)

Company calendar with data on the number of working hours per day. The calendar is used in several modules, for example in the function 'Fixed dispatch dates' in the sales module, for the workload capacity in the production module and in Jeeves' graphical planning system (JPS).

The following standard records exist. Do not alter/delete:

Calendar number (KalenderNr) | Calendar (KalenderBeskr)
0 | Standard calendar

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Worked hrs/day | ArbTimPerDag | ZtDecimal73 | 8 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar | KalenderBeskr | ztString | 40 |  | varchar
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | regDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowupdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: kal Calendar


Calendar definition for fixed delivery days (vkafd)

Definition of calendar for fixed delivery days.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calender created | KalenderCreatedDt | ztDateTime |  |  | datetime
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Calendar, fix disp dates | KalFastLevDagBeskr | ztString | 40 |  | varchar
Calendar, fix disp dates | KalFastLevDagNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowupdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Valid to date | TomDatum | ztDate |  |  | datetime


Calendar definition for fixed dispatch days (kafd)

Definition of calendar for fixed delivery days.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calender created | KalenderCreatedDt | ztDateTime |  |  | datetime
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Calendar, fix disp dates | KalFastLevDagBeskr | ztString | 40 |  | varchar
Calendar, fix disp dates | KalFastLevDagNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowupdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Valid to date | TomDatum | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: kafd Calendar for fixed dispatch days


Calendar for fixed dispatch days (kald)

Calendar with calendar information indicating fixed delivery days.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Working day, autocreated | ArbDagAutoSkapad | ztBoolean |  |  | char
Work day | Arbetsdag | ztBoolean |  |  | char
Worked hrs/day | ArbTimPerDag | ZtDecimal73 | 8 | 2 | decimal
Day no. in year | DagNrInomAr | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Internal day number | KalenderDagNummer | ZtLong | 10 |  | int
Date | KalenderDatum | ztDate |  |  | datetime
Kalendermånad | KalenderManad | ztInteger | 2 |  | smallint
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Week number | KalenderVecka | ztInteger | 2 |  | smallint
Calendar, fix disp dates | KalFastLevDagNr | ztInteger | 2 |  | smallint
Dispatch day, autocreated | LevDagAutoSkapad | ztBoolean |  |  | char
Dispatch day | Leveransdag | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Day of week | VeckoDag | ztInteger | 1 |  | smallint


Calendar, capacity by manufactoring group (calc)

Capacity by manufactoring group, working days in calendar.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Work day | Arbetsdag | ztBoolean |  |  | char
Capacity remain | CapacityRemain | ZtLong | 5 |  | int
Day no. in year | DagNrInomAr | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Internal day number | KalenderDagNummer | ZtLong | 10 |  | int
Internal day number (from) | KalenderDagNummerFran | ZtLong | 10 |  | int
Date | KalenderDatum | ztDate |  |  | datetime
Kalendermånad | KalenderManad | ztInteger | 2 |  | smallint
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Week number | KalenderVecka | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Total capacity | TotCapacity | ZtLong | 10 |  | int
Total capacity CO | TotCapacity_CO | ZtLong | 10 |  | int
Total capacity MO | TotCapacity_MO | ZtLong | 10 |  | int
Day of week | VeckoDag | ztInteger | 1 |  | smallint


Calendar, deviations per person (kalp)

Calendar data showing deviation per person against the standard calendar.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Work day | Arbetsdag | ztBoolean |  |  | char
Worked hrs/day | ArbTimPerDag | ZtDecimal73 | 8 | 2 | decimal
Day no. in year | DagNrInomAr | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Internal day number | KalenderDagNummer | ZtLong | 10 |  | int
Date | KalenderDatum | ztDate |  |  | datetime
Kalendermånad | KalenderManad | ztInteger | 2 |  | smallint
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Week number | KalenderVecka | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Reserve | perssignmailreserv | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Valid to date | TomDatum | ztDate |  |  | datetime
Day of week | VeckoDag | ztInteger | 1 |  | smallint

    This table is the main table in the following programs:

    Program: kalp Calendar person, deviations


Calendar, fixed days/carrier (kalt)

Calendar data showing fixed delivery days for carrier (x2t).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Working day, autocreated | ArbDagAutoSkapad | ztBoolean |  |  | char
Work day | Arbetsdag | ztBoolean |  |  | char
Worked hrs/day | ArbTimPerDag | ZtDecimal73 | 8 | 2 | decimal
Day no. in year | DagNrInomAr | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Internal day number | KalenderDagNummer | ZtLong | 10 |  | int
Date | KalenderDatum | ztDate |  |  | datetime
Kalendermånad | KalenderManad | ztInteger | 2 |  | smallint
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Week number | KalenderVecka | ztInteger | 2 |  | smallint
Dispatch day, autocreated | LevDagAutoSkapad | ztBoolean |  |  | char
Dispatch day | Leveransdag | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Carrier code | TransportorsKod | ztString | 17 |  | varchar
Day of week | VeckoDag | ztInteger | 1 |  | smallint


Calendar, fixed days/route (kalr)

Calendar data showing fixed delivery days for transport route (xtr).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Working day, autocreated | ArbDagAutoSkapad | ztBoolean |  |  | char
Work day | Arbetsdag | ztBoolean |  |  | char
Worked hrs/day | ArbTimPerDag | ZtDecimal73 | 8 | 2 | decimal
Day no. in year | DagNrInomAr | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Internal day number | KalenderDagNummer | ZtLong | 10 |  | int
Date | KalenderDatum | ztDate |  |  | datetime
Kalendermånad | KalenderManad | ztInteger | 2 |  | smallint
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Week number | KalenderVecka | ztInteger | 2 |  | smallint
Country | LandsKod | ztString | 3 |  | varchar
Dispatch day, autocreated | LevDagAutoSkapad | ztBoolean |  |  | char
Dispatch day | Leveransdag | ztBoolean |  |  | char
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Carrier code | TransportorsKod | ztString | 17 |  | varchar
Day of week | VeckoDag | ztInteger | 1 |  | smallint


Calendar, fixed delivery days (kalf)

Calendar data showing fixed dispatch days for delivery method (sales).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Working day, autocreated | ArbDagAutoSkapad | ztBoolean |  |  | char
Work day | Arbetsdag | ztBoolean |  |  | char
Worked hrs/day | ArbTimPerDag | ZtDecimal73 | 8 | 2 | decimal
Day no. in year | DagNrInomAr | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Internal day number | KalenderDagNummer | ZtLong | 10 |  | int
Date | KalenderDatum | ztDate |  |  | datetime
Kalendermånad | KalenderManad | ztInteger | 2 |  | smallint
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Week number | KalenderVecka | ztInteger | 2 |  | smallint
Dispatch day, autocreated | LevDagAutoSkapad | ztBoolean |  |  | char
Dispatch day | Leveransdag | ztBoolean |  |  | char
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Day of week | VeckoDag | ztInteger | 1 |  | smallint


Calendar, weekdays (kavd)

Definition of the days of the week used in labour reports, for example in the manufacturing module.

The following standard records exist. Do not alter/delete:

Day of week (VeckoDag) | Day of week (VeckoDagBeskr)
1 | Monday
2 | Tuesday
3 | Wednesday
4 | Thursday
5 | Friday
6 | Saturday
7 | Sunday

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Day of week | VeckoDag | ztInteger | 1 |  | smallint
Day of week | VeckoDagBeskr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: kavd Days of week


Calendar, working days (kala)

Calendar data showing working days.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Work day | Arbetsdag | ztBoolean |  |  | char
Worked hrs/day | ArbTimPerDag | ZtDecimal73 | 8 | 2 | decimal
Day no. in year | DagNrInomAr | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Internal day number | KalenderDagNummer | ZtLong | 10 |  | int
Internal day number (from) | KalenderDagNummerFran | ZtLong | 10 |  | int
Date | KalenderDatum | ztDate |  |  | datetime
Kalendermånad | KalenderManad | ztInteger | 2 |  | smallint
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Week number | KalenderVecka | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Day of week | VeckoDag | ztInteger | 1 |  | smallint
Begin of working hours | WorkHoursBegin | ztTime | 5 |  | datetime
End of working hours | WorkHoursEnd | ztTime | 5 |  | datetime


Campaign contacts (krd)

Table of the companies and contacts to be included in campaigns and mailing lists. This data is used when campaigns are created and responses are entered.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Campaign | KampNr | ZtLong | 4 |  | int
Close follow up | KampResponsKlar | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | saljare | ztString | 6 |  | varchar

    This table is the main table in the following programs:

    Program: krd Campaign selections


Campaign contacts (view) (vkrd)

View of the companies and contacts to be included in campaigns and mailing lists.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company name | FtgNamn | ztString | 36 |  | varchar
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Contact name | FtgPerson | ztString | 60 |  | varchar
Campaign | KampNr | ZtLong | 4 |  | int
Project ID | ProjCode | ztString | 10 |  | varchar


Campaign types (xg)

Definition of applicable types of distribution lists for campaigns and the like. You only need to enter a campaigns if it is necessary to classify the distribution lists created for marketing campaigns and other types of mass mailings in the Campaigns program (mskp).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Campaign type | KamptypBeskr | ztString | 20 |  | varchar
Campaign type | KampTypKod | ztInteger | 1 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxg Campaign types


Campaigns, header (kr)

Table containing data about campaigns and mailing lists.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Activity created | ActivityCreated | ztBoolean |  |  | char
No. addressees/e-mail | Adressantantal | ztInteger | 5 |  | smallint
Activity status | AktStatus | ztInteger | 5 |  | smallint
BCC | bccmail | ztBoolean |  |  | char
Margin (total) | cs_margin_total | ZtBaseCurrAmount | 14 | 2 | money
Number of opportunities | cs_opportunity_count | ztInteger | 5 |  | smallint
Opportunity % | cs_opportunity_proc | ZtDecimal73 | 8 | 3 | decimal
Number of orders | cs_order_count | ztInteger | 5 |  | smallint
Order % | cs_order_proc | ZtDecimal73 | 8 | 3 | decimal
Total order value | cs_order_total | ZtBaseCurrAmount | 14 | 2 | money
Number of quotations | cs_quotation_count | ztInteger | 5 |  | smallint
Quotation % | cs_quotation_proc | ZtDecimal73 | 8 | 3 | decimal
No of Recipients | cs_recievers | ztInteger | 5 |  | smallint
Number of responses | cs_response_count | ztInteger | 5 |  | smallint
Response % | cs_response_proc | ZtDecimal73 | 8 | 3 | decimal
Time accrued (total) | cs_Timeaccrued_total | ztFloat | 15 | 2 | float
Time planned (total) | cs_Timeplanned_total | ztFloat | 15 | 2 | float
Statistics updated by | cs_updated_by | ztString | 12 |  | varchar
Statistics updated dt | cs_updated_dt | ztDateTime |  |  | datetime
Dispatch date | DeliveryDate | ztDate |  |  | datetime
File/dir | DokDir | ztString | 255 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Planned activity | eventkod1 | ztInteger | 3 |  | smallint
Planned activity descr | eventnote | ztString | 60 |  | varchar
Number of days until start | eventplanstartfridag | ztInteger | 5 |  | smallint
Planned date | EventPlDat | ztDate |  |  | datetime
Planned time | EventPlTime | ztTime | 5 |  | datetime
Hours | eventtimant2 | ztHourWithDecimals | 8 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Campaign | KampBeskr | ztString | 60 |  | varchar
Campaign start date | KampDat | ztDate |  |  | datetime
Campaign category | KampKatKod1 | ztInteger | 5 |  | smallint
Campaign cost | KampKostn | ZtBaseCurrAmount | 14 | 2 | money
Campaign | KampNr | ZtLong | 4 |  | int
Campaign type | KampTypKod | ztInteger | 1 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Business opportunity ID | ProspektId | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display e-mail window | VisaMailWin | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: kr Campaigns, selections and mailing lists

    Program: mkp Responses

    Program: mskp Campaigns


Capacity families (kapf)

Each item is classified to a family based on how manufacturing is done.
For example, one family means that the manufacturing flow always consists of Mfg grp1+Mfg grp3+Mfg grp4+Mrg grp5.

Which manufacturing group is the current bottleneck is determined in each family.

A parameter (KapacitetsUtrymme) is determined in each family and indicates how many working days are to comprise the capacity space. I.e., if it is 5, the capacity needed in the bottleneck is measured as accessible capacity for 5 days from the time point the manufacturing order is finished and back in time.

**** UNDER INQUIRY/CONSTRUCTION ****

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Capacity family | KapacitetsFamilj | ztString | 6 |  | varchar
Capacity family | KapacitetsFamiljBeskr | ztString | 40 |  | varchar
Capacity family's mfg group | KapacitetsFamiljProdGr | ztString | 5 |  | varchar
Capacity scope | KapacitetsUtrymme | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: kapf Capacity families


Capacity families, bottlenecks (kaph)

The manufacturing groups that are bottlenecks within a capacity family are stored in this table.

**** UNDER INQUIRY/CONSTRUCTION ****

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Capacity family | KapacitetsFamilj | ztString | 6 |  | varchar
Capacity family's mfg group | KapacitetsFamiljProdGr | ztString | 5 |  | varchar
Capacity scope | KapacitetsUtrymme | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Carrier (x2t)

Definition of the carriers used by the company for customer dispatches.

You can also specify information about weight and volume and fixed dispatch dates for every carrier. If this data is different for different transport routes when a certain carrier is used, the data must instead be specified in and retrieved from the program 'Carrier' (x2t).

Jeeves can automatically determine which carrier will hired for a dispatch if you have defined transport routes (see the description of the program 'Transport route' (Xxtr)).

The information is also necessary for Odette delivery notice, in which case the carrier codes must be set up according to the standard that applies for Odette.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Specified gross wght | BruttoVikt | ztFloat | 10 | 3 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Internal lead time days | InternLedTid | ztInteger | 3 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calender created | KalenderCreatedDt | ztDateTime |  |  | datetime
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Document type ID | LogtradeDocTypeID | ztString | 2 |  | varchar
Logtrade forwarder | LogTradeForwarderCode | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Time limit, dispatch | TimeLimit | ztTime | 5 |  | datetime
Valid to date | TomDatum | ztDate |  |  | datetime
Carrier code | TransportorsKod | ztString | 17 |  | varchar
Carrier name | TransportorsNamn | ztString | 35 |  | varchar
Height | VolHeight | ztInteger | 4 |  | smallint
Length | VolLength | ztInteger | 4 |  | smallint
Volume | Volume | ztFloat | 10 | 3 | float
Width | VolWidth | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: x2t Carriers


Cash equipment, parameters (xkdf)

Table for defining parameters to control POS equipment in Order, store (OrderB).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Cash configuration | CashConfigCode | ztInteger | 5 |  | smallint
Cash configuration | CashConfigDescr | ztString | 50 |  | varchar
Display, clear | CmdDisplayClear | ztString | 30 |  | varchar
Display, codetable | CmdDisplayCodeTable | ztString | 30 |  | varchar
Display, delay | CmdDisplayDelay | ztInteger | 5 |  | smallint
Display, pos row 1 | CmdDisplayPosLine1 | ztString | 30 |  | varchar
Display, pos row 2 | CmdDisplayPosLine2 | ztString | 30 |  | varchar
Cash receipt, cut | CommandCutReceipt | ztString | 30 |  | varchar
Cashbox, open | CommandOpenDrawer | ztString | 30 |  | varchar
Display, amount text | DisplayAmountText | ztString | 50 |  | varchar
Display, end text row 1 | DisplayEndText1 | ztString | 50 |  | varchar
Display, end text row 2 | DisplayEndText2 | ztString | 50 |  | varchar
Display, init text row 1 | DisplayInitText1 | ztString | 50 |  | varchar
Display, init text row 2 | DisplayInitText2 | ztString | 50 |  | varchar
Display, row length | DisplayRowLength | ztInteger | 5 |  | smallint
Display, am V/H/C | DisplayTypAmount | ztString | 1 |  | varchar
Display, end V/H/C | DisplayTypEndText | ztString | 1 |  | varchar
Display, init V/H/C | DisplayTypInitText | ztString | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Display, config | PortConfigDisplay | ztString | 50 |  | varchar
Cashbox, config | PortConfigDrawer | ztString | 50 |  | varchar
Printer, config | PortConfigReceipt | ztString | 50 |  | varchar
Print template, receipt | ReceiptTemplate | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxkdf Cashbox configuration


Cash/Bank book (card)

Definition of cash/bank books that consist of sequence number series for the respective cash/bank book and for ingoing or outgoing payments on the respective cash/bank book, currency, as well as opening balance. In addition, in the underlying nodes, definition of cash/bank report numbers per period and posting.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Cashier | CashierID | ztString | 30 |  | varchar
Sequence no. type cash out | CashissueNoType | ztInteger | 4 |  | smallint
Cash/Bank ID | CashOrBankBookid | ztString | 15 |  | varchar
Cash/Bank ID | CashOrBankBookidDescr | ztString | 40 |  | varchar
Sequence no. type, cash in | CashreceiptNoType | ztInteger | 4 |  | smallint
Mandatory No | CashTransNo | ztBoolean |  |  | char
Sequence no. type | CompanyType | ztInteger | 4 |  | smallint
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Start date | EventStartDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Opening balance | OpenBal | ZtBaseCurrAmount | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar

    This table is the main table in the following programs:

    Program: card Cash/Bank book


Cash/Bank book (CardAcc)

Contains posting information for Cash/Bank book.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Cash/Bank ID | CashOrBankBookid | ztString | 15 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Cash/bank report no. (Cardstmt)

Contains cash/bank statement sequence number for specified period.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Cash/Bank ID | CashOrBankBookid | ztString | 15 |  | varchar
Cash/bank report no. | CashStatementNo | ztString | 40 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Start date | EventStartDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Locked | LockedForUse | ztBoolean |  |  | char
Print date | p_Utskr_dat | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: bCardStmt Print cash/bank


CC appr/ctrl grps (kk2)

Table of approval control groups for account segment 2.
The control groups can then be linked to other account segments.
In this way you can control things so that only certain S2 can be used by certain accounts or segment 3 or ...

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
From CC | KstFrom | ztString | 8 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
To CC | KstTom | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Cell info in posting box, Jvs Viewer (WCel)

The table contains posting information, 1 record for each field on the voucher row to be shown in the posting screen in Jeeves Viewer.
The information from table wfbe, 'Descriptions in grid', are also stored here and the information is stored per instance.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Read/write rights | Access | ZtLong | 9 |  | int
Steps | CellAction | ZtLong | 9 |  | int
Column no. | CellColumn | ZtLong | 9 |  | int
RowNo. | CellRow | ZtLong | 9 |  | int
Text | CellText | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Height | Height | ZtLong | 9 |  | int
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
ID | WCelDummyuniqueid | ztString | 50 |  | varchar
ID | WgrdDummyuniqueid | ztString | 50 |  | varchar
Width | Width | ZtLong | 9 |  | int


Cell structure in Jvs Viewer (WGrd)

Information about the grid's appearance, rows and columns, in the posting stamp in Jeeves Viewer.
The table stores information about the grid per instance.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Name of grid | GridName | ztString | 150 |  | varchar
Height | Height | ZtLong | 9 |  | int
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Max columns | MaxColumns | ZtLong | 9 |  | int
Max rows | MaxRows | ZtLong | 9 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
ID | WDocDummyuniqueid | ztString | 50 |  | varchar
ID | WGrdDummyuniqueid | ztString | 50 |  | varchar
Width | Width | ZtLong | 9 |  | int
x position | XPos | ZtLong | 9 |  | int
y position | YPos | ZtLong | 9 |  | int


Central bank codes (xrk)

Definition of central bank codes that are used for foreign payments.

Specify the central bank code for the supplier in the supplier table, "Foreign payments" node.

No records are defined on delivery.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Ctrl bank code | RiksBanksKod | ztString | 3 |  | varchar
Ctrl bank code | RiksBanksKodBeskr | ztString | 50 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxrk Central bank codes, outgoing payments


Central interest invoicing (qctr)

Customer-specific table Central interest invoice printing.
In this table information about an interest invoice batch is stored in 'flat file format' with record types, etc.
This file is then input into a editing program.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Interest journal batch no. | JKurNr | ztInteger | 4 |  | smallint
Sequence no. | LopNr | ZtLong | 10 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Text/info | x255 | ztString | 255 |  | varchar


Central payment reminder printing (qctk)

Customer-specifictable Central payment reminder printing.
In this table information about a reminder batch is stored in 'flat file format' with record types, etc.
This file is then input into a editing program.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Reminder journal batch no. | JFhkNr | ztInteger | 4 |  | smallint
Sequence no. | LopNr | ZtLong | 10 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Text/info | x255 | ztString | 255 |  | varchar


Change flag for new OA per language (xsos)

Definition of change markings, per language, which are used in the Sales module to mark changes on order rows when printing a new order acknowledgement (OA).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Change type new OA | StatusKodNyttOE | ztInteger | 5 |  | smallint
Flag new OA | StatusMarkNyttOE | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: xxsos Flag for new OA per language


Change flow group (flgb)

Rules for changing production group(s) when changing the flow group of a manufacturing order.
If you change the flow group on a manufacturing order, the production groups can also be changed to the production groups belonging to the new flow group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Change to manufacturing group | Change2ProductionGroup | ztString | 5 |  | varchar
Change to flow group | Change2WorkGroup | ztString | 5 |  | varchar
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Flgb Flow group, manufacturing group, changes


Change item in BOM (srba)

Change of item in the bill of materials (help table).
Log of changes.
When a row in this table is saved, the material requirement item is updated.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Item no. (BOM) | BArtNrStrukt | ztString | 30 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Old item no. in BOM | GamlaBArtNrStrukt | ztString | 30 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence number | SrDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar


Change log of item group for item (arvl)

Table containing logs of item group changes of items.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
New item group | NewItemGrpCd | ztString | 8 |  | varchar
Old item group | OldVaruGruppKod | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SQL sats | SqlStmt | ztString | 255 |  | varchar
Start av updatering/insert | SqlStmtStartedDT | ztDateTime |  |  | datetime
SQL code/Variable | SQLText | ztBlob | 1 |  | varchar
Date/time | StrDateTime | ztString | 28 |  | varchar
Update status | UpdateStatus | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: arvl Change/log item group for item


Change log, order head, status (ohcl)

Table containing information on all changes of orders in regards to order status and estimated dispatch date.
The information is created automatically upon change of these values in the order header.
Rows may not be manually entered in this table. This is done from the trigger in the order header.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry location (previous) | OldLagStalle | ztString | 2 |  | varchar
Estimated dispatch date | OldOrdBerLevDat | ztDate |  |  | datetime
Order status (previous) | OldOrdStat | ztInteger | 2 |  | smallint
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order status | OrdStat | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | sqlidentity | ZtLong | 10 |  | int
Date/time | StrDateTime | ztString | 28 |  | varchar

    This table is the main table in the following programs:

    Program: ohcl Change log, cust order, status


Change order (ECOH)

Table of details in change order headers.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Product class | artprodklass | ztString | 4 |  | varchar
Approval chain | attkedja | ztInteger | 5 |  | smallint
Chain changed | ChainChanged | ztInteger | 5 |  | smallint
Description | Description | ztString | 255 |  | varchar
Due date | duedate | ztDate |  |  | datetime
Change description | ECOChangeDescr | ztBlob | 1 |  | varchar
Change type | ECOCHangeType | ztString | 6 |  | varchar
Change order status | EcoStatusCode | ztInteger | 5 |  | smallint
Change order ID | ECOUniqueID | ztString | 40 |  | varchar
Change requisition | ExtChangeRequisition | ztString | 100 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Issuer | Issuer | ztString | 6 |  | varchar
Quantity PDM | pdmcount | ZtLong | 10 |  | int
PDM (Unique ID) | pdmdummyuniqueid | ztUniqueIdentifier | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Refer to verifying test | ReferToTest | ztString | 100 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Release notes | Releasenotes | ztBlob | 1 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Updated by Workflow | UpdatedByWFL | ztBoolean |  |  | char
Unique ID link | WfRowUniqueID | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: xeco Change orders


Change order approval chain instance (ecoappchain)

Instance of an approval chain, in form of a single resource, linked to a certain change order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval chain | attkedja | ztInteger | 5 |  | smallint
Approval type | ECOAppTypecode | ztInteger | 5 |  | smallint
Change order ID | ecouniqueid | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cancel | Makulerad | ztBoolean |  |  | char
Mandatory level | mandatorychainlevel | ztBoolean |  |  | char
Mandatory resource | mandatoryresource | ztBoolean |  |  | char
Only for distribution | onlydistribute | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | perssign2 | ztString | 6 |  | varchar
Level approval chain | posattkedja | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Resource group | resursgrp | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence | sequence | ztInteger | 3 |  | smallint
Identity | sqlidentity | ZtLong | 10 |  | int
Created by WFL | WFL_Created_By | ztBoolean |  |  | char


Change order approval type (ECOAPPTYPE)

Definition of applicable approval types for change orders, according to the company's own process and requirements.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval type | ECOAppTypeCode | ztInteger | 5 |  | smallint
Approval type descr | ECOAppTypeDescr | ztString | 60 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Only for distribution | OnlyDistribute | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Info/Text | x8000 | ztString | 4000 |  | varchar

    This table is the main table in the following programs:

    Program: ecoapptype Change order approval types


Change order changes type (ECOCHTYPE)

Definition of applicable change types for change orders. The change types control the behaviour in the Change order program when adding and changing document records on change orders..

The following standard records exist. Do not alter/delete:

Change type (ECOchangetype) | Change type (ECOChangeTypeDescr)
A | Add
C | Change
D | Delete

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Change type | ECOchangetype | ztString | 6 |  | varchar
Change type | ECOChangeTypeDescr | ztString | 80 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xecocht Change order change types


Change order rows (ECOR)

Table of details in change order rows, where links to other business objects, usually documents, are entered.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | artnr | ztString | 30 |  | varchar
Product class | artprodklass | ztString | 4 |  | varchar
Release index | artrelindex | ztInteger | 4 |  | smallint
Revision | artrevindex | ztInteger | 4 |  | smallint
Change column | chngCol | ztString | 7000 |  | varchar
Description | description | ztString | 255 |  | varchar
Document ID | docid | ztString | 50 |  | varchar
Document type no. | documenttype | ZtLong | 5 |  | int
Change description | ECOchangedescr | ztBlob | 1 |  | varchar
Change type | ECoChangeType | ztString | 6 |  | varchar
Change order status | EcoStatusCode | ztInteger | 5 |  | smallint
Change order ID | ECOuniqueid | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Locked by change order | LockedByECO | ztString | 40 |  | varchar
PDM (previous ID) | oldpdmdummyuniqueid | ztUniqueIdentifier | 100 |  | varchar
PDM (origin) | originpdmdummyuniqueid | ztUniqueIdentifier | 100 |  | varchar
Quantity PDM | pdmcount | ZtLong | 10 |  | int
PDM (Unique ID) | pdmdummyuniqueid | ztUniqueIdentifier | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Pos in figure | posalfa | ztString | 12 |  | varchar
Row | radpos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Variant (ECO) | Variant | ztBoolean |  |  | char


Change order status (ecostat)

Definition of status codes for change orders.

The following standard records exist. Do not alter/delete:

Change order status (EcoStatusCode) | Change order status (EcoStatusDescr)
10 | Under development
30 | Under approval
40 | Approved
50 | Completed
65 | Disapproved by user
70 | Recalled
90 | Cancelled

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Change order status | EcoStatusCode | ztInteger | 5 |  | smallint
Change order status | EcoStatusDescr | ztString | 60 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Info/Text | x8000 | ztString | 4000 |  | varchar

    This table is the main table in the following programs:

    Program: ecostat Change order status


Change types for new OA, order rows (xsoe)

Definition of codes in respect of change types which are used in the Sales module to specify a change type on order rows when printing a new order acknowledgement (OA). The code is automatically set by the system when rows on an order are updated, added, changed or canceled.

The following standard records exist. Do not alter/delete:

Change type new OA (StatusKodNyttOE) | Change type new OA (StatusNyttOEBeskr)
0 | New row
1 | Changed row
2 | Canceled row

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Change type new OA | StatusKodNyttOE | ztInteger | 5 |  | smallint
Change type new OA | StatusNyttOEBeskr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: xxsoe Change types for new OA, order rows


Change types, credit memo (xcmt)

Definition of existing reasons for customer claims. The definition, which is mandatory if you intend to use the customer claim routine, is done as required and can then be used for searching, selecting and as headings in reports.

You must specify a reason group for every reason, which means that you must define the reason groups first in the program “Customer claim reason group” (Orkg). A group can comprise of several claim reasons, but a reason must not occur in more than one group.

The following standard records exist. Do not alter/delete:

Change types, credit memo (KreditMemoAndrTyp) | Change types, credit memo (KreditMemoAndrBeskr)
1 | Supplier name and address information
2 | Company name and address information
3 | Supplier VAT/tax entry number
4 | Company VAT/tax entry number
5 | Invoice date
6 | Sale/delivery date
7 | Bank information
8 | Payment terms
9 | Item description

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Change types, credit memo | KreditMemoAndrBeskr | ztString | 40 |  | varchar
Change types, credit memo | KreditMemoAndrTyp | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xcmt Change types, credit memo


Charge basis, header (DebH)

Charge basis, main records. Customer-specific development, PBK Outsourcing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period | Period1 | ztString | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Upd charge basis | UpdDeb | ztBoolean |  |  | char
Date upd chrg basis | UpdDebdatum | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: DebitU Charge basis


Charge basis, rows (DebR)

Charge basis details.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Net amount | Belopp | ZtBaseCurrAmount | 14 | 2 | money
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Chart of accounts (ko)

Definition of the company's account (account segment 1) in the chart of accounts. The definition is copied between fiscal years.

Base account plans:
Starting with version 9, the new base account plan Base 2004. Base 2004 uses the designation 2004.

The base account plan Base 2000 has previously had the designation 0. Beginning with version 9 the designation has been changed to 2000.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Version | accountversion | ztString | 50 |  | varchar
Fixed assets group | AnlGrp | ztString | 10 |  | varchar
Posting template | autoregel | ztString | 4 |  | varchar
Posting templ GL reval | AutoRegelGL | ztString | 4 |  | varchar
Avräkningskonto | AvrKtoKod | ztBoolean |  |  | char
As of date | DatKtoFom | ztDate |  |  | datetime
End date | DatKtoTom | ztDate |  |  | datetime
Debit/credit | debkre | ztchar | 1 |  | char
Detailed posting | DetaljKonto | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
Customer's own account class | EgenKontoKlass | ztString | 8 |  | varchar
Customer's own account class 2 | EgenKontoKlass2 | ztString | 8 |  | varchar
Replaced by account no. | ErsattsKtoNr | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Manual posting OK | FarKonterasManuellt | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
GL revaluation | GLCurrReval | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Input/output VAT/tax | IOVAT | ztBoolean |  |  | char
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
Kontrollgrupp K8 | k8grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Account | KtoBeskr | ztString | 80 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Account type | KtoTyp | ztInteger | 3 |  | smallint
Entry inventory, Proj | lager1 | ztInteger | 1 |  | smallint
Entry inventory, Quant | Lager2 | ztInteger | 1 |  | smallint
Entry inventory, CU | Lager3 | ztInteger | 1 |  | smallint
Entry inventory, S4 | Lager4 | ztInteger | 1 |  | smallint
Entry inventory, S5 | Lager5 | ztInteger | 5 |  | smallint
Entry inventory, S6 | Lager6 | ztInteger | 5 |  | smallint
Entry inventory, S7 | Lager7 | ztInteger | 5 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Contra acct, deduction, tax | MotKtoNrAvrMoms | ztString | 8 |  | varchar
Balance per currency | MultiCurrencyAccount | ztBoolean |  |  | char
Mandatory, CC | oblig0 | ztBoolean |  |  | char
Mandatory, Proj | oblig1 | ztBoolean |  |  | char
Mandatory, Quant | oblig2 | ztBoolean |  |  | char
Obligatory, CU | oblig3 | ztBoolean |  |  | char
Mandatory, S4 | oblig4 | ztBoolean |  |  | char
Mandatory, S5 | oblig5 | ztBoolean |  |  | char
Mandatory, S6 | oblig6 | ztBoolean |  |  | char
Mandatory, S7 | oblig7 | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Control group project | PrjGrupp | ztString | 6 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Posting rule S2 | regel1 | ztInteger | 1 |  | smallint
Proj posting rule | regel2 | ztInteger | 1 |  | smallint
Qty posting rule | regel3 | ztInteger | 1 |  | smallint
S3 posting rule | regel4 | ztInteger | 1 |  | smallint
S4 posting rule | regel5 | ztInteger | 1 |  | smallint
S5 posting rule | regel6 | ztInteger | 1 |  | smallint
S6 posting rule | regel7 | ztInteger | 1 |  | smallint
S7 posting rule | regel8 | ztInteger | 1 |  | smallint
Entry inventory, CC | RegLager | ztInteger | 2 |  | smallint
Replaced by | ReplaceByAccNo | ztString | 8 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Used split cost | SplitCostBasis | ztBoolean |  |  | char
SRU 1 | Sru1Nr | ztString | 6 |  | varchar
SRU 2 | Sru2Nr | ztString | 6 |  | varchar
Text | TextLayer | ztInteger | 1 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Pay or receive | VAT_PayedOrReceive | ztBoolean |  |  | char
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax account | VATaccount | ztBoolean |  |  | char
VAT/tax code mandatory | VATmandatory | ztBoolean |  |  | char
Display on web | WebAccountMark | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: bHb Print GL accounts

    Program: ko Chart of accounts

    Program: KoDag Account reconciliation, day


Chart of accounts VIEW (vko)

View of the ko table (Chart of accounts).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S5 | k5grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S6 | k6grupp | ztString | 6 |  | varchar
Account | KtoBeskr | ztString | 80 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Entry inventory, Proj | lager1 | ztInteger | 1 |  | smallint
Entry inventory, Quant | Lager2 | ztInteger | 1 |  | smallint
Entry inventory, CU | Lager3 | ztInteger | 1 |  | smallint
Entry inventory, S4 | Lager4 | ztInteger | 1 |  | smallint
Entry inventory, S5 | Lager5 | ztInteger | 5 |  | smallint
Entry inventory, S6 | Lager6 | ztInteger | 5 |  | smallint
Entry inventory, S7 | Lager7 | ztInteger | 5 |  | smallint
Mandatory, CC | oblig0 | ztBoolean |  |  | char
Mandatory, Proj | oblig1 | ztBoolean |  |  | char
Mandatory, Quant | oblig2 | ztBoolean |  |  | char
Obligatory, CU | oblig3 | ztBoolean |  |  | char
Mandatory, S4 | oblig4 | ztBoolean |  |  | char
Mandatory, S5 | oblig5 | ztBoolean |  |  | char
Mandatory, S6 | oblig6 | ztBoolean |  |  | char
Mandatory, S7 | oblig7 | ztBoolean |  |  | char
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry inventory, CC | RegLager | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: vko View chart of accounts


Chart of accounts VIEW 2 (vko1)

View of the ko table (Chart of accounts).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Account | KtoBeskr | ztString | 80 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Entry inventory, Proj | lager1 | ztInteger | 1 |  | smallint
Entry inventory, Quant | Lager2 | ztInteger | 1 |  | smallint
Entry inventory, CU | Lager3 | ztInteger | 1 |  | smallint
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry inventory, CC | RegLager | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: vko1 View chart of accounts


Chart of accounts VIEW 3 (vko2)

View of the ko table (Chart of accounts).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Account | KtoBeskr | ztString | 80 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Entry inventory, Proj | lager1 | ztInteger | 1 |  | smallint
Entry inventory, Quant | Lager2 | ztInteger | 1 |  | smallint
Entry inventory, CU | Lager3 | ztInteger | 1 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Entry inventory, CC | RegLager | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: vko2 View chart of accounts


Check available batched for MO mtrl rows (V_MOMtrl_BatchNo)

Manufacturing order number/work order number based on an automatically assigned sequence number.
Your own alphanumeric order numbers can be entered in another field on the manufacturing order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Add to MO row | AddToMO | Jeeves_MONo | 20 |  | bigint
Add to purchase order | AddToPO | Jeeves_PONo | 20 |  | bigint
Active | Aktiv | ztInteger | 1 |  | smallint
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
This field is used in the table as follows: |
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Purchased | AnskaffningKop | ztBoolean |  |  | char
Acq to requirement | AnskaffningMotBehov | ztBoolean |  |  | char
Manufactured | AnskaffningTillv | ztBoolean |  |  | char
Qty being picked | AntalUnderPlock | ZtQty | 14 | 2 | decimal
Decimal places | AntDec | ztInteger | 1 |  | smallint
MO type | AoKod | ztInteger | 2 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Operations start date | AoStartDat | ztDate |  |  | datetime
Bin | ars_LagPlats | ztBinLocation | 20 |  | varchar
Item description | ArtBeskr | ztString | 30 |  | varchar
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Main agreement | ArtHuvudAvt | ztBoolean |  |  | char
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
This field is used in the table as follows: |
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
This field is used in the table as follows: |
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Cost price (actual) | ArtKalkprisE | ZtBaseCurrAmount | 14 | 2 | money
Cost price at order | ArtKalkPrisO | ZtBaseCurrAmount | 14 | 2 | money
Cost at order (mtrl) | ArtKalkPrisOMtrl | ZtBaseCurrAmount | 14 | 2 | money
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
BOM level | ArtNivaBeskr | ztString | 20 |  | varchar
Artikelnivå | ArtNivaKod | ztString | 1 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
This field is used in the table as follows: |
Item no, design | ArtNrKonstruktion | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
BOM notation code | ArtStruktKod | ztString | 1 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Aut mtrl.issue allowed | AutMtrlUttagAvArt | ztBoolean |  |  | char
Auto breakdown within MO | AutoVidareNedbrInomTo | ztBoolean |  |  | char
Auto booking rule | AutStockBookingRule | ztInteger | 5 |  | smallint
Agreed/requested prc | AvtalatPris | ZtBaseCurrAmount | 14 | 2 | money
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Qty parent level (setup) | BAntalAviStall | ZtQty | 14 | 2 | decimal
Pieces | BAntalStyck | ZtQty | 14 | 2 | decimal
Item no. (BOM) | BArtNrStrukt | ztString | 30 |  | varchar
Use/Best before | BastForeDatum | ztDate |  |  | datetime
Quantity available for booking | BatchAntalSomKanBokas | ZtQty | 14 | 2 | decimal
Batch description | BatchDescr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Batch no. mtrl | BatchNoMtrlRes | ztString | 30 |  | varchar
Booking allowed | BatchOkToBook | ztBoolean |  |  | char
Picking allowed | BatchOkToUse | ztBoolean |  |  | char
Batch Res | BatchRes | ZtQty | 8 | 2 | decimal
Batch balance | BatchSaldo | ZtQty | 14 | 2 | decimal
Batch status | BatchStatusKod | ztInteger | 2 |  | smallint
Ordered | Bestallas | ztBoolean |  |  | char
Est disp date | BestBerLevDat | ztDate |  |  | datetime
Order date acc. lead time | BestDatEnlLedTid | ztDate |  |  | datetime
Purchase price | BestInPris | ZtBaseCurrAmount | 14 | 2 | money
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
Delivery received date | BestLevDat | ztDate |  |  | datetime
Delivery date supplier quay | BestLevDatFranLevsKaj | ztDate |  |  | datetime
Delivery date to quay | BestLevDatTillKaj | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Figure no. | BFigNr | ztString | 6 |  | varchar
Figure no. extended | BFigNr255 | ztString | 255 |  | varchar
Quantity per piece | BKvantPerStyck | ztFloat | 12 | 4 | float
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Level within work order | BOM_Level_In_WO | ztInteger | 5 |  | smallint
Booked Qty (invt) | BookQtyInvt | ZtQty | 14 | 2 | decimal
Booked Qty (MO) | BookQtyMO | ZtQty | 14 | 2 | decimal
Booked Qty (PO) | BookQtyPO | ZtQty | 14 | 2 | decimal
Availability check date | BristKontrolleradDatum | ztDate |  |  | datetime
Avail check status code | BristKontrolleradStatus | ztInteger | 5 |  | smallint
Copy to parent | CopyUpFromThisItem | ztBoolean |  |  | char
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Days to PO date | DagarTillBestDatum | ZtLong | 10 |  | int
Partial booking allowed | DelBokningTillaten | ztInteger | 5 |  | smallint
Dimension 1 | Dimension1 | ztFloat | 15 | 2 | float
Dimension 2 | Dimension2 | ztFloat | 15 | 2 | float
Dimension 3 | Dimension3 | ztFloat | 15 | 2 | float
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Own mtrl row | EgenMtrlRad | ztBoolean |  |  | char
New MO on explosion | EgenThVidVidareNedbr | ztBoolean |  |  | char
Unit code | EnhetsKod | ztString | 4 |  | varchar
Overhead, work, admin | EstLabOvhdAdmCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, production | EstLabOvhdPrdCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, sales | EstLabOvhdSalesCost | ZtBaseCurrAmount | 14 | 2 | money
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
External qty | ExternQty | ZtQty | 14 | 2 | decimal
External purch agreem no. | ExtInkAvt | ztString | 20 |  | varchar
Invc checked qty | FaktAvprAntal | ZtQty | 14 | 2 | decimal
Invc match value BCU | FaktAvprVardeBas | ZtBaseCurrAmount | 14 | 2 | money
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
RowNo | FFhRadNr | ztInteger | 5 |  | int
Fictitious item | FiktivArtikel | ztBoolean |  |  | char
MO issue purch mtrl (AC) | FKMoMtrlTillv | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Group acquisition by ...... | GroupPoWoOn | ztString | 10 |  | varchar
Included in available balance | InclInAvailInvtBal | ztBoolean |  |  | char
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Receive to inventory value | InlevLagerVarde | ZtBaseCurrAmount | 14 | 2 | money
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Original company | IntrnCoNoOrigin | ztDateTime |  |  | datetime
Exg rate on order date | InValKurs | ZtCurrencyRate | 15 | 7 | decimal
Purch price curr | InValuta | ztString | 3 |  | varchar
Physical invtry date | InventeringsDatum | ztDate |  |  | datetime
Item OK to use? | ItemOkToUse | ztBoolean |  |  | char
Purchase of item | KopAvArtikel | ztBoolean |  |  | char
Buy manuf of item | KopTillvAvArtikel | ztBoolean |  |  | char
Corr reserv qty | KorrAntalUt | ZtQty | 14 | 2 | decimal
Overheads, work, admin | LabOvhdAdmCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, production | LabOvhdPrdCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, sales | LabOvhdSalesCost | ZtBaseCurrAmount | 14 | 2 | money
Physical invtry diff YTD | LagDiffAnt | ZtQty | 14 | 2 | decimal
Stocked | LagerBokas | ztBoolean |  |  | char
Amount to match | LagerVardeAttFaktAvpr | ZtBaseCurrAmount | 14 | 2 | money
Value to price | LagerVardeEnlInPris | ztBoolean |  |  | char
Physical inventory | LagInvAnt | ZtQty | 14 | 2 | decimal
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Movement qty | LagRorAnt | ZtLong | 8 |  | int
Inventory location | LagStalle | ztString | 2 |  | varchar
Lagerst för OU-lager | LagStalleOULager | ztString | 2 |  | varchar
Inventory stock type | LagTyp | ztInteger | 2 |  | smallint
Country | LandsKod | ztString | 3 |  | varchar
Labor operation picking list ID | LbrOpJoinPckList | ZtLong | 10 |  | int
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Adm lead time | LedTidAdm | ztInteger | 3 |  | smallint
Lead time from suppl | LedTidEnlLev | ztInteger | 3 |  | smallint
Lead time extra demand | LedTidExtra1 | ztInteger | 3 |  | smallint
Deliv to supplier | LevMedBestTillLev | ztBoolean |  |  | char
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Supplier item descr | LevsArtBeskr | ztString | 255 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Last sale date, man | ManValidityDate | ztBoolean |  |  | char
FIFO | Mark_FIFO | ztBoolean |  |  | char
LIFO | Mark_LIFO | ztBoolean |  |  | char
No purchase agreement | MarkInkAvtSaknas | ztBoolean |  |  | char
Not within lead time | MarkInkEjInomLedTid | ztBoolean |  |  | char
Ord spec cost price | MarkOrderUniktKalkP | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Max Batch Size | MaxBatchSize | ztFloat | 15 | 2 | float
MO issue purch mtrl | MoMtrlTillv | ZtBaseCurrAmount | 14 | 2 | money
MO% markup mtrl mfg | MoProcMtrlTillv | ZtDecimal73 | 8 | 3 | decimal
Item version, demand | MrArtikelVariant | ztString | 30 |  | varchar
Item no. required | mrArtNr | ztString | 30 |  | varchar
Picked quantity | MrRappAnt | ZtQty | 14 | 2 | decimal
Reserved quantity | MrResAnt | ZtQty | 14 | 2 | decimal
Mtrl due date | MrResDat | ztDate |  |  | datetime
Ställ antal | MrStallAnt | ZtQty | 14 | 2 | decimal
Matr.beh.status | MrStatus | ztInteger | 1 |  | smallint
Original material reservation | MrUrsprKod | ztInteger | 2 |  | smallint
Mtrl Booked Qty | MtrlBookedQty | ZtQty | 14 | 2 | decimal
Calc mtrl cost | MtrlKalkKost | ZtBaseCurrAmount | 14 | 2 | money
Actual material cost | MtrlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (refinement) | MtrlVerklKostForadling | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (adjust) | MtrlVerklKostJustering | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (mtrl) | MtrlVerklKostMtrl | ZtBaseCurrAmount | 14 | 2 | money
Search if agree > net req | NewSearchWhenCreatePur | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Booking status | OrdBokningsStatus | ztInteger | 5 |  | smallint
Fixed number | OrderUniktFixtAntal | ZtQty | 14 | 2 | decimal
Ord-spec invtry bal | OrderUniktLager | ZtQty | 14 | 2 | decimal
Order spec text | OrpRadText | ztString | 255 |  | varchar
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Period closing batch bal | PerUtgBatchSaldo | ZtQty | 14 | 2 | decimal
Per closing batch value | PerUtgBatchVarde | ZtBaseCurrAmount | 14 | 2 | money
Period closing stock (batch) | PerUtgLagVardeBatch | ZtBaseCurrAmount | 14 | 2 | money
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Planned quantity | PlaneratAntal | ZtQty | 14 | 2 | decimal
Planeringsreserv (dgr) | PlanReservTid | ztInteger | 3 |  | smallint
Pos in figure | posalfa | ztString | 12 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Act grade | QActGrade | ztFloat | 15 | 2 | float
Act gravity | QActGravity | ztFloat | 15 | 2 | float
Act moiety | QActMoiety | ztFloat | 15 | 2 | float
Act potency | QActPotency | ztFloat | 15 | 2 | float
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Row | RadPos2 | ztInteger | 4 |  | int
Calc rec value (added costs) | RecDelValueAddedCosts | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Released to WMS | ReleasedToWMS | ztDateTime |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Joint purchase (allowed) | SamInKopMark | ztBoolean |  |  | char
Last disp date | SenUtlevDat | ztDate |  |  | datetime
Sequence | Sequence | ztInteger | 3 |  | smallint
Time sqlcmd->trg start | SQLCmd2EnterTrg | ZtLong | 10 |  | int
Start av updatering/insert | SqlStmtStartedDT | ztDateTime |  |  | datetime
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Requisition | StrDateTimeBIA | ztString | 28 |  | varchar
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
This field is used in the table as follows: |
BOM for item | StycklistaTillArtNr | ztString | 30 |  | varchar
Suborder in capacity subcontr | SubKapacitetsLego | ztBoolean |  |  | char
ID for connection | Ti_LopNr_Ned | ZtLong | 10 |  | int
Visa tillverkningsordern | TiVisas | ztBoolean |  |  | char
OK to use tool | ToolOkToUse | ztBoolean |  |  | char
Transit delivery | TransitLeverans | ztBoolean |  |  | char
Transport days | TransportTid | ztInteger | 3 |  | smallint
Print order, alpha | TurOrdning | ztString | 20 |  | varchar
Original item no. | UrsprArtNr | ztString | 30 |  | varchar
Orig operation no. | UrsprOpNr | ztInteger | 3 |  | smallint
Print PO qty | UtskrBestDokAntal | ZtQty | 14 | 2 | decimal
Print disp date | UtskrBestDokLevDat | ztDate |  |  | datetime
Reprint purch order | UtskrBestDokSkaGoras | ztBoolean |  |  | char
New PO print date | UtskrBestDokUtskrDT | ztDateTime |  |  | datetime
Deliv from MO | UttagFranAoNr | Jeeves_MONo | 7 |  | bigint
Deliv from MO Pos | UttagFranAoPos | ztInteger | 5 |  | int
Book this batch | V_BookThisBatch | ztBoolean |  |  | nvarchar
Last sale date | ValidityDate | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Gross purch price, curr (mtrl) | vb_inpris_mtrl | ztMoney | 14 | 2 | money
Gross setup price, curr | Vb_InPris_Stall | ztMoney | 14 | 2 | money
Gross start purch price, curr | Vb_InPris_Start | ztMoney | 14 | 2 | money
Cost price, curr | VbKalkPris | ztMoney | 14 | 2 | money
Breakdown, MO | VidareNedbrInomTo | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: V_MOMtrl_BatchNo V_MOMtrl_BatchNo


Check digit methods (xchk)

Definition of check digit methods for use in calculating check digits pertaining to, for example, freight bill or shipment number that is retrieved from number series, freight documents.

The following standard records exist. Do not alter/delete:

Check number method (CheckSifferMetod) | Check number method (CheckSifferMetodBeskr)
0 | 10 module method
1 | 11 module method (Record)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Check number method | CheckSifferMetod | ztInteger | 2 |  | smallint
Check number method | CheckSifferMetodBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xxchk Check digit methods


Check journal row (CheckTr)

Check journal rows.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Voucher type | Check_Voucher_Type | ztInteger | 5 |  | smallint
Check journal no | CheckJrnlNo | ZtLong | 6 |  | int
Check number | Checkno | ZtLong | 9 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Acc rec/Acc pay | KRorLR | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Check journal, details (chkd)

Each check that is created receives a row in this table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Check amount | Checkamount | ZtBaseCurrAmount | 14 | 2 | money
Checkbook per day | Checkbookno | ZtLong | 9 |  | int
Check issued date | checkDate | ztDate |  |  | datetime
Check number | Checkno | ZtLong | 9 |  | int
Check sequence number | CheckSequence | ZtLong | 10 |  | int
Canceled, amount | checkVoidAmount | ZtBaseCurrAmount | 14 | 2 | money
Canceled, date | checkVoidDate | ztDate |  |  | datetime
Canceled, descr | checkVoidDescr | ztString | 40 |  | varchar
Canceled | Checkvoided | ztBoolean |  |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | Ftgnr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Opening balance | ingsaldo | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | intsource | ztInteger | 3 |  | smallint
Account | Ktonr | ztString | 8 |  | varchar
Header check number | MCheckno | ZtLong | 9 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Row | Radpos | ZtLong | 10 |  | int
Reconciliation closed | recClose | ztBoolean |  |  | char
Reconciliation date | RecDate | ztDate |  |  | datetime
Reconciled | Reconciled | ztBoolean |  |  | char
Fiscal year | redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Payment journal no. | Utbjournnr | ZtLong | 6 |  | int
Payment methods | utbslag | ztString | 3 |  | varchar
Closing balance | UtgSaldo | ZtBaseCurrAmount | 14 | 2 | money
Voucher no. | vernr | Jeeves_VchrNo | 9 |  | bigint
Check canceled, sequence no | voidno | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: chkd Check journal, details


Check journal, details (vckd)

Unique sequence number for relevant definition. The term is used by a number of functions, in some the number is entered manually and in others it is generated automatically. If the number is generated automatically, this can be done, for example, according to one of the conventions described below.

Example 1:
number of days since 940101
number of seconds since 00.00
process ID in the database
counter

Example 2:
today's date (8char) (YYYYMDD)
current time (8char) (HH:MM:SS)
current time milliseconds (:SSS)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Check amount | checkamount | ZtBaseCurrAmount | 14 | 2 | money
Checkbook per day | Checkbookno | ZtLong | 9 |  | int
Check issued date | checkdate | ztDate |  |  | datetime
Check number | Checkno | ZtLong | 9 |  | int
Check sequence number | CheckSequence | ZtLong | 10 |  | int
Canceled, amount | checkVoidAmount | ZtBaseCurrAmount | 14 | 2 | money
Canceled, date | checkVoidDate | ztDate |  |  | datetime
Canceled, descr | checkVoidDescr | ztString | 40 |  | varchar
Canceled | Checkvoided | ztBoolean |  |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | Ftgnr | ztCompanyNo | 20 |  | varchar
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Opening balance | ingsaldo | ZtBaseCurrAmount | 14 | 2 | money
Integration source | IntSource | ztInteger | 3 |  | smallint
Account | ktonr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Row | Radpos | ZtLong | 10 |  | int
Reconciliation date | RecDate | ztDate |  |  | datetime
Reconciled | Reconciled | ztBoolean |  |  | char
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Payment journal no. | Utbjournnr | ZtLong | 6 |  | int
Payment methods | utbslag | ztString | 3 |  | varchar
Closing balance | UtgSaldo | ZtBaseCurrAmount | 14 | 2 | money
Voucher no. | vernr | Jeeves_VchrNo | 9 |  | bigint


Check journals (CheckJrnl)

Check journals.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Bank | BankId | ztString | 10 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Collection with voucher | Check_Coll_Voucher | ztBoolean |  |  | char
Check journal no | CheckJrnlNo | ZtLong | 6 |  | int
Check journal text | CheckJrnlText | ztString | 50 |  | varchar
Journal type | CheckJrnlType | ztInteger | 1 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Journal status | JrnlStatus | ztInteger | 2 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Print date | RemPrintDate | ztDateTime |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | int

    This table is the main table in the following programs:

    Program: CheckJrnl Check journal collection

    Program: CheckJrnl_paid Check journal paid checks

    Program: rCheckVtColl Create voucher, check for collection

    Program: rCheckVtColl_Rep Reprint voucher, check for collection

    Program: rCheckVtPaid Create voucher, paid checks

    Program: rCheckVtPaidRep Reprint voucher, paid checks


Check ledger (CheckNo)

Checks received from customers.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Bank | BankId | ztString | 10 |  | varchar
Bank charge | BankKost | ZtBaseCurrAmount | 9 | 2 | money
Collection with voucher | Check_Coll_Voucher | ztBoolean |  |  | char
Check status | Check_Status | ztInteger | 2 |  | smallint
Journal no Cancel | CheckJrnlNo_Cancel | ZtLong | 9 |  | int
Journal no Collection | CheckJrnlNo_Coll | ZtLong | 9 |  | int
Journal no paid | CheckJrnlNo_Paid | ZtLong | 9 |  | int
Check number | Checkno | ZtLong | 9 |  | int
Due date | FaktFfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Paid amount | InbBel | ZtBaseCurrAmount | 14 | 2 | money
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Interest amount BCU | IntrstAmtBCU | ztMoney | 14 | 2 | money
Interest amount FCU | IntrstAmtFCU | ztMoney | 14 | 2 | money
Acc rec/Acc pay | KRorLR | ztInteger | 5 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Bank cost, currency | VbBankAmt | ztMoney | 14 | 2 | money
Paid amount, curr | VbInbBel | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: CheckNo Check ledger


Check log (lckd)

Date and time of creation, displayed as a text string.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Check amount | Checkamount | ZtBaseCurrAmount | 14 | 2 | money
Checkbook per day | Checkbookno | ZtLong | 9 |  | int
Check issued date | checkdate | ztDate |  |  | datetime
Check number | Checkno | ZtLong | 9 |  | int
Check sequence number | CheckSequence | ZtLong | 10 |  | int
Canceled, date | checkVoidDate | ztDate |  |  | datetime
Canceled, descr | checkVoidDescr | ztString | 40 |  | varchar
Canceled | Checkvoided | ztBoolean |  |  | char
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | Ftgnr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Opening balance | ingsaldo | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | Radpos | ZtLong | 10 |  | int
Reconciliation date | RecDate | ztDate |  |  | datetime
Reconciled | Reconciled | ztBoolean |  |  | char
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | strdatetime | ztString | 28 |  | varchar
Payment journal no. | Utbjournnr | ZtLong | 6 |  | int
Payment methods | utbslag | ztString | 3 |  | varchar
Closing balance | UtgSaldo | ZtBaseCurrAmount | 14 | 2 | money
Voucher no. | vernr | Jeeves_VchrNo | 9 |  | bigint
Check canceled, sequence no | VoidNo | ZtLong | 10 |  | int


Check posting details (Checkvt)

Check postings.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Voucher type | Check_Voucher_Type | ztInteger | 5 |  | smallint
Check journal no | CheckJrnlNo | ZtLong | 6 |  | int
Journal no Cancel | CheckJrnlNo_Cancel | ZtLong | 9 |  | int
Journal no Collection | CheckJrnlNo_Coll | ZtLong | 9 |  | int
Journal no paid | CheckJrnlNo_Paid | ZtLong | 9 |  | int
Check number | Checkno | ZtLong | 9 |  | int
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Paid amount | InbBel | ZtBaseCurrAmount | 14 | 2 | money
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Payment method | InbSlag | ztString | 3 |  | varchar
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Acc rec/Acc pay | KRorLR | ztInteger | 5 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Paid amount, curr | VbInbBel | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | int


Check postings (CheckGL)

Check postings.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Bank charge | BankKost | ZtBaseCurrAmount | 9 | 2 | money
Check status | Check_Status | ztInteger | 2 |  | smallint
Voucher type | Check_Voucher_Type | ztInteger | 5 |  | smallint
Journal no Collection | CheckJrnlNo_Coll | ZtLong | 9 |  | int
Journal no paid | CheckJrnlNo_Paid | ZtLong | 9 |  | int
Check number | Checkno | ZtLong | 9 |  | int
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Due date | FaktFfDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Paid amount | InbBel | ZtBaseCurrAmount | 14 | 2 | money
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Acc rec/Acc pay | KRorLR | ztInteger | 5 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Bank cost, currency | VbBankAmt | ztMoney | 14 | 2 | money
Paid amount, curr | VbInbBel | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | int


Check rule (ktrh)

Definitions of control rules for electronic approval.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Check rule | kontrollregel | ztInteger | 5 |  | smallint
Check rule description | kontrollregelbeskr | ztString | 80 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xktrh Check rules


Check rule row (ktrr)

Definition of conditions, posting data, etc. within control rules for electronic approval.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Amount | BeloppAttestRegel | ZtBaseCurrAmount | 18 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
On error return to admin | hlkontroll | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
From S4 | K4From | ztString | 8 |  | varchar
To S4 | K4Tom | ztString | 8 |  | varchar
From S5 | K5From | ztString | 8 |  | varchar
To S5 | K5Tom | ztString | 8 |  | varchar
From S6 | K6From | ztString | 8 |  | varchar
To S6 | K6Tom | ztString | 8 |  | varchar
From S7 | K7From | ztString | 8 |  | varchar
To S7 | K7Tom | ztString | 8 |  | varchar
From CU | KbarFrom | ztString | 8 |  | varchar
To S3 | KbarTom | ztString | 8 |  | varchar
Check rule | Kontrollregel | ztInteger | 5 |  | smallint
From CC | KstFrom | ztString | 8 |  | varchar
To CC | KstTom | ztString | 8 |  | varchar
From account | KtoFrom | ztString | 8 |  | varchar
To account | KtoTom | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | perssign2 | ztString | 6 |  | varchar
From Proj | PrjFrom | ztString | 30 |  | varchar
ToPrj | PrjTom | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Attach journal | webbilaga | ztBoolean |  |  | char


Check status (CheckSt)

Check status.

The following standard records exist. Do not alter/delete:

Check status (Check_Status) | Description (Check_Status_Descr) | Description
2 | 2. Prel paid | The check has been received and entered as an incoming payment which means the check is created in the check ledger. The AR is credited and the Check ledger account is debited.
3 | 3. Collected | The check has been “sent” to the bank for collection, i.e. a bank report has been printed. The check ledger is credited and the Checks for collection account debited. This posting step is optional.
4 | 4. Paid | The amount is reported as received in Jeeves on the bank account. The Checks for collection account is credited (or Check ledger) and the bank account is debited.
9 | 9. Canceled | All postings are reversed and the invoice re-opened.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Check status | Check_Status | ztInteger | 2 |  | smallint
Description | Check_Status_Descr | ztString | 80 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: CheckSt Check status


Check view (vchk)

View used when printing checks.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Check number | checkno | ZtLong | 9 |  | int
Check sequence number | CheckSequence | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company name | FtgNamn | ztString | 36 |  | varchar
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Integration source | IntSource | ztInteger | 3 |  | int
Planned pmt date | lrfaktplanbetdat | ztDate |  |  | datetime
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | nvarchar
Payment journal no. | utbjournnr | ZtLong | 6 |  | int
Payment methods | utbslag | ztString | 3 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Plan/paid amt, curr | vbutbbel | ztMoney | 14 | 2 | money


Check void (chvo)

Running numbering of check cancelation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Canceled, descr | checkVoidDescr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Payment methods | Utbslag | ztString | 3 |  | varchar
Cancel from check no. | voidFrChno | ZtLong | 10 |  | int
Check canceled, sequence no | voidno | ZtLong | 10 |  | int
Cancel to and incl. check no | voidToChno | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: chvo Check voids


Checkbook (chkb)

Data in the header for the reconciliation journal for reconciliation of checks. The details in the reconciliation journal is stored in the table Check log (lckd).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Checkbook per day | Checkbookno | ZtLong | 9 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Opening balance | ingsaldo | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | ktonr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Reconciliation date | RecDate | ztDate |  |  | datetime
Interest amount | RecIntAmount | ZtBaseCurrAmount | 14 | 2 | money
Interest date | RecInterestDate | ztDate |  |  | datetime
Interest, voucher no | RecIntVoucherno | Jeeves_VchrNo | 20 |  | bigint
Reconciled | Reconciled | ztBoolean |  |  | char
Service fee, amount | Recservchargeam | ZtBaseCurrAmount | 14 | 2 | money
Service fee, date | RecServChargeDate | ztDate |  |  | datetime
Service fee, voucher no | RecServVoucherNo | Jeeves_VchrNo | 12 |  | bigint
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Payment methods | UtbSlag | ztString | 3 |  | varchar
Closing balance | UtgSaldo | ZtBaseCurrAmount | 14 | 2 | money

    This table is the main table in the following programs:

    Program: chkb Check reconciliation


Claim manager (ClaimResp)

Definition of responsible person, department, or the like for processing of customer claims, supplier claims, or internal claims.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Claim manager | ClaimResp | ztString | 8 |  | varchar
Claim manager text format | ClaimRespName | ztString | 80 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ClaimResp Claim manager


Closing alternatives supplier invoices (ICTSuppl)

Definition of existing closing possibilities for supplier invoices created when the supplying unit invoices the selling unit (in ICT).

The following standard records exist. Do not alter/delete:

Close supp.invoice ICT (ICTSuppInvComplCode) | Close supp invoice (ICTSuppInvComplCodeDescr)
0 | No supplier invoice created
1 | Supplier invoice incl. arrival posting
2 | Supplier invoice incl. invoice matching

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Close supp.invoice ICT | ICTSuppInvComplCode | ztInteger | 5 |  | smallint
Close supp invoice | ICTSuppInvComplCodeDescr | ztString | 40 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ICTSuppl Closing alternatives supplier invoices


Codes for managing alternative items (xsra)

Table containing codes for how alternative items can be used in BOMs.

The table contains standard records, which must not be altered or deleted.

The following standard records exist. Do not alter/delete:

Alt items in BOM
(SrAltAnvTyp) 		Alt items in BOM
(SrAltAnvTypBeskr)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Alt items in BOM | SrAltAnvTyp | ztInteger | 5 |  | smallint
Alt items in BOM | SrAltAnvTypBeskr | ztString | 60 |  | varchar


Codes, planned activities (xa)

Definition of codes for the types of planned activities that can be used in Time, project, assignments to plan project activities and in Marketing and sales support to plan marketing activities.

No standard records exist in the table.

Only types of activities are entered here. If you wish, you can specify each activity further during planning, either in the field for notes or in the Edit field.

It is likely that you will want to be able to report back on the same codes. Codes from a different table, Codes, reported activities (xh), are used for reporting. You can copy the codes for planned activities to the codes for reported activities in the Copy planned to reported activities program (plrp). Here you copy records from left to right in the normal manner in Jeeves.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Planned activity | EventBeskr | ztString | 50 |  | varchar
Planned activity | EventKod1 | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Personnel category | PersKategori | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxa Codes, planned activities


Codes, planned activities/language (xasp)

Language translations of descriptions of planned activities.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Planned activity | EventBeskr | ztString | 50 |  | varchar
Planned activity | EventKod1 | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint


Codes, reported activities (xh)

Definition of codes for the types of reported activities that can be used in Time, project, assignments to plan project activities and in Marketing and sales support to plan marketing activities.

There are two ways to define these:

- Enter them manually in this program. You can also add information for pricing and posting here.

- Create them automatically in the Copy planned to reported activities program (plrp) based on defined codes for planned activities.

Only types of activities are entered here. If you wish, you can specify each activity further during reporting in the field for notes or in the Edit field.

The following standard records exist. Do not alter/delete:

Reported activity (eventrpkod) | Reported activity (eventrpbeskr) | Description
999 | Campaign follow-up | This activity code is suggested automatically when you register responses to campaigns/mailing in the Responses (Mkp) program.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Reported activity | EventRpBeskr | ztString | 50 |  | varchar
Reported activity | EventRpKod | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Wage type | Loneart | ztString | 6 |  | varchar
This field is used in the table as follows: |
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sector | verksamhet | ztInteger | 5 |  | smallint
Visible in Office | VisibleInOffice | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: Xxh Codes, reported activities


Collections/customer (kusi)

This table contains data on collections per customer. The collection is always linked to a customer and a certain collection date and can contain one or several invoices.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Collection file created | CollectFileCreated | ztBoolean |  |  | char
Created by | CollectFileCreatedBy | ztString | 6 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Collection amount | InkassoBelopp | ZtBaseCurrAmount | 14 | 2 | money
Collection date | InkassoDatum | ztDate |  |  | datetime
Collection no. | InkassoNr | ZtLong | 4 |  | int
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
OLE-1 | Ole1 | ztString | 255 |  | varchar
OLE-2 | Ole2 | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xKusi Collections

    Program: xKusia Collections


Colors (colr)

Color code for a color.
Shall be specified with 6 characters (hex format).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Color code (hex) | ColorCode | ztString | 6 |  | varchar
Color | ColorDescription | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: colors Colors


Column and tables in database (Jeeves_View_UserTableColumns)

Database table column name.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
DB Column name | COLUMN_NAME | ztString | 128 |  | nvarchar
@zPrompt=null | table_name | ztString | 255 |  | nvarchar


Column combinations (rs)

Definition of column combinations in reports. A column combination, which normally contains several columns, can be included in several report definitions.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Column combination | RpTypBeskr | ztString | 40 |  | varchar
Column combination | RpTypKod | ztInteger | 4 |  | smallint
Spara resultat i DB | SaveMatrixResultInDatabase | ztString | 120 |  | varchar
Spara resultat i Table | SaveMatrixResultInTable | ztString | 120 |  | varchar

    This table is the main table in the following programs:

    Program: rs Column combinations


Column conditions for replication (tct)

Definition of any conditions regarding which records are to be replicated in a table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Term | ColumnName | ztString | 40 |  | varchar
Data type | DataType | ztString | 30 |  | varchar
Layer | DataTypeLayer | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
ICT conn business unit | ictconbusinessunit | ztString | 8 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLidentity | ZtLong | 10 |  | int
Table name | TableName | ztString | 255 |  | varchar
From value (Alphanum) | TermFromValueAN | ztString | 255 |  | varchar
From value (Date) | TermFromValueDate | ztDate |  |  | datetime
From value (num w/dec) | TermFromValueFloat | ztFloat | 15 | 2 | float
From value (Amount) | TermFromValueMoney | ztMoney | 14 | 2 | money
From value (Num) | TermFromValueNum | ZtLong | 255 |  | int
To value (AlphaNum) | TermToValueAN | ztString | 255 |  | varchar
To value (Date) | TermToValueDate | ztDate |  |  | datetime
To value (Num w/ dec) | TermToValueFloat | ztFloat | 15 | 2 | float
To value (Amount) | TermToValueMoney | ztMoney | 14 | 2 | money
To value (Num) | TermToValueNum | ZtLong | 255 |  | int
To company | ToCompanyNo | ztInteger | 5 |  | smallint
Used at insert | UsedInsert | ztBoolean |  |  | char
Used at update | UsedUpdate | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: tct Column conditions for replication


Column conversion in replication (tcv)

Definition of any conversions to be made during replication.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Term | ColumnName | ztString | 40 |  | varchar
All values | ConvertFromAll | ztBoolean |  |  | char
From value (Alphanum) | ConvertFromValueAN | ztString | 255 |  | varchar
From value (Date) | ConvertFromValueDate | ztDate |  |  | datetime
From value (Num w/dec) | ConvertFromValueFloat | ztFloat | 15 | 2 | float
From value (Amount) | ConvertFromValueMoney | ztMoney | 14 | 2 | money
From value (Num) | ConvertFromValueNum | ZtLong | 10 |  | int
Only Insert | ConvertNoUpdate | ztBoolean |  |  | char
To value (Alphanum) | ConvertToValueAN | ztString | 255 |  | varchar
To value (Date) | ConvertToValueDate | ztDate |  |  | datetime
To value (Num w/dec) | ConvertToValueFloat | ztFloat | 15 | 2 | float
To value (Amount) | ConvertToValueMoney | ztMoney | 14 | 2 | money
To value (Num) | ConvertToValueNum | ZtLong | 255 |  | int
Data type | DataType | ztString | 30 |  | varchar
Layer | DataTypeLayer | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
ICT conn business unit | ictconbusinessunit | ztString | 8 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLidentity | ZtLong | 10 |  | int
Table name | TableName | ztString | 255 |  | varchar
To company | ToCompanyNo | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: tcv Column conversion in replication


Column info, matrix output (MatrixResultColumns)

Number of the column in a column combination in a report, an automatically generated running number.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
WHERE | MatrixCalcWhereStmt | ztString | 255 |  | varchar
Column value from table | MatrixColumnDataFromTable | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Column title | RpKolNamn | ztString | 60 |  | varchar
Column no. | RpKolNr | ztInteger | 4 |  | smallint
Column type | RpKolTyp | ztInteger | 2 |  | smallint
Batch no. | RpKorNr | ZtLong | 5 |  | int
Save result in column | SaveMatrixResultInColumn | ztString | 120 |  | varchar


Column types (xr4)

Table of the column types that can be used in reports created using the report generator.

The following standard records exist. Do not alter/delete:

Column type (RpKolTyp) | Column type (PpKolTypBeskr) | Description
2 | Text | Columns that contain text only.
3 | Calculate using formula | The value is calculated based on other values in the report. For example r10.c10+r11.c10 totals cell/column 10 on row 10 and 11.
4 | Value from database | Values that are retrieved from the database.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Column type | PpKolTypBeskr | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Column type | RpKolTyp | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: Xxr4 Report column types


Columns (JvsSiteWinCols)

Program/table for viewing and editing settings regarding the position of columns in forms. Settings are saved here when a column is moved or a field is moved within a column, also when tabs are created.

The program/table can be accessed through an embedded window in the program Setting dimensions/keys (jvssitenodewin) or from Jeeves' menu.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Column ID | JvsSiteColID | ZtLong | 10 |  | int
Column ID (orig) | JvsSiteColID_orig | ZtLong | 10 |  | int
Frame ID | JvsSiteFrameID | ZtLong | 10 |  | int
Frame ID (orig) | JvsSiteFrameID_orig | ZtLong | 10 |  | int
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Setting ID (orig) | JvsSiteNodeWinSettingsID_orig | ZtLong | 10 |  | int
Tab ID | JvsSiteTabID | ZtLong | 10 |  | int
Tab ID (orig) | JvsSiteTabID_orig | ZtLong | 10 |  | int
Sequence no. | JvsSiteTabSeq | ztInteger | 5 |  | smallint
Unique ID | JvsSiteUniqueId | ztString | 40 |  | nvarchar
ID on window setting | JvsSiteWindowSettingsID | ZtLong | 10 |  | int
ID on window setting (orig) | JvsSiteWindowSettingsID_orig | ZtLong | 10 |  | int
Window type | JvsSiteWindowType | ztString | 2 |  | nvarchar
Startpos X axis | JvsSiteXPos | ZtLong | 10 |  | int
Width | JvsSiteXSize | ZtLong | 10 |  | int
Startpos Y axis | JvsSiteYPos | ZtLong | 10 |  | int
Height | JvsSiteYSize | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteWinCols Columns

    Program: rJvsSiteWinCols_01 Settings, columns in node/window

    Program: rJvsSiteWinCols_02 Settings, columns in node/window, fields


Columns for replication (RepC)

Table of the columns (fields) that will be replicated on the receiving page (database, exchange).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Term | ColumnName | ztString | 40 |  | varchar
External field name | ExtColName | ztString | 30 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Included in key | iskey | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Replication flow | repdirection | ztchar | 1 |  | char
Replication definition | repldefkod | ZtLong | 10 |  | int
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Table name | TableName | ztString | 255 |  | varchar


Columns in tables (vkol)

Column definitions from the database, including the columns entered manually.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Number of characters | AntalTecken | ztInteger | 4 |  | smallint
Data type | DataType | ztString | 30 |  | nvarchar
DB-term/-expression 2 | DbTermName2 | ztString | 255 |  | nvarchar
Default | Konvdefault | ztString | 60 |  | nvarchar
Object no. | ObjectId | ZtLong | 10 |  | int
Row | RadPos | ZtLong | 10 |  | int
Base/value table | ZTable | ztString | 255 |  | nvarchar

    This table is the main table in the following programs:

    Program: xVkol Columns in tables


Columns in tables (vkol_lang)

Database table column name.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
DB Column name | COLUMN_NAME | ztString | 128 |  | nvarchar
column desc | ColumnDescr | ztString | 40 |  | varchar
Base/value table | ztable | ztString | 255 |  | nvarchar


Columns in tables (vkol1)

Column definitions from the database, including the columns entered manually.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Number of characters | AntalTecken | ztInteger | 4 |  | smallint
Data type | DataType | ztString | 30 |  | smallint
DB-term/-expression 2 | DbTermName2 | ztString | 255 |  | nvarchar
Default | Konvdefault | ztString | 60 |  | nvarchar
Object no. | ObjectId | ZtLong | 10 |  | int
Signature | PersSign | ZtLong | 10 |  | int
Row | RadPos | ZtLong | 10 |  | smallint
Entry date | RegDat | ZtLong | 10 |  | smallint
Created by | RowCreatedBy | ZtLong | 10 |  | smallint
Created date/time | RowCreatedDt | ZtLong | 10 |  | smallint
Updated by | RowUpdatedBy | ZtLong | 10 |  | smallint
Updated date/time | RowUpdatedDt | ZtLong | 10 |  | smallint
Base/value table | ZTable | ztString | 255 |  | nvarchar


Columns, e-Applications (wfbt)

Definition of columns that can be presented in e-applications.

The following standard records exist. Do not alter/delete:

Name of column (JvsColumnName) | Term name description (columnnamedescr)
artbeskr |
ArtNr | ArtBeskr
artnr |
AutoRegel | AutoregBeskr
AutoRegel | AutoregBeskr
bestantextqty |
bestberlevdat |
bestlevantextqty |
beststatbeskr |
DebBel |
DebBel |
enhetskod |
K4 | K4Beskr
k4 |
K5 | K5Beskr
K5 | K5Beskr
K6 | K6Beskr
K6 | K6Beskr
K7 | K7Beskr
K7 | K7Beskr
KortKodVerRad |
KortKodVerRad |
KostBar | KostBarBeskr
kostbar |
KoststalleKod | KstBeskr
koststallekod |
KreBel |
KreBel |
KtoNr | KtoBeskr
KtoNr | KtoBeskr
Kvantitet |
Kvantitet |
lagplatsnamn |
lagsaldo |
ProjCode | ProjDescr
ProjCode | ProjDescr
vb_inpris |
VbBelopp |
VbBelopp |
VrVerText |

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Term name description | columnnamedescr | ztString | 40 |  | varchar
Data type | DataType | ztString | 30 |  | varchar
Name of column | JvsColumnName | ztString | 128 |  | varchar
Module ID | Moduleid | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: wfbt Columns, e-Applications


Command rows for EDI messages. (edie)

This table contains the different commands that are used for conversion and communication of EDI traffic.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Command | EdiCommand | ztString | 255 |  | varchar
RowNo. | EdiCommandRowNo | ztInteger | 5 |  | smallint
Sequence no. | EdiCommandSeqNo | ztInteger | 5 |  | smallint
Executed as SQL | EdiExecAsSql | ztBoolean |  |  | char
Job timeout | EdiJobTimeout | ztInteger | 5 |  | smallint
Send with e-mail | EdiMailResultset | ztBoolean |  |  | char
Script | EdiScript | ztBlob | 1 |  | varchar
ScriptFile | EdiScriptFile | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Comments (konkkomm)

Table for comments about competing companies.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | kortnotering | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar


Commitment accounting, requisitions (iavr)

Table of created commitment postings. If the function for commitment accounting is used, these postings are created upon entry of purchase requisitions. At this stage, the postings do not include amounts; amounts are added when the requisitions are converted into purchase orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Purch requisition no. | BiaNr | ZtLong | 10 |  | int
Debit/credit | DebKre | ztchar | 1 |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KoststalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | radpos | ZtLong | 10 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Requisition | StrDateTimeBia | ztString | 28 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal


Commitment acctg, approved requisitions (BpVr)

Table of created commitment postings. If the function for commitment accounting is used, these postings are created when an e-Purchase requisition is approved and converted to one or more purchase orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Purch requisition no. | BiaNr | ZtLong | 10 |  | int
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KoststalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Requisition | StrDateTimeBia | ztString | 28 |  | varchar
Currency | Valkod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint


Common tables/company (xfif)

Definition of the tables that are to be common to the template company and the target company. This means that the records entered, changed, or deleted in the template company will also update (replicate) the target company's tables.

This is done per company, including the template company, and means that certain companies can, for example, have a common chart of accounts while others do not.

Automatic controls are performed before the updates are made. Example:
- - You cannot delete an account if you have used the account in the company in question.
- - You cannot make certain types of changes which entail changed logic.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Sequence no. | Lopnr | ZtLong | 10 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Copy/replicate | Tabellkopiera | ztBoolean |  |  | char
Table | TabellNamn | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: xfif Common tables/company


Communication method for EDI traffic (edix)

Contains the communication method to be used for EDI traffic.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Contact method | ComKod | ztString | 2 |  | varchar
Method of communication | EdiComDescr | ztString | 30 |  | varchar
Sequence no. | EdiCommandSeqNo | ztInteger | 5 |  | smallint
Method of communication | EdiComNo | ztInteger | 5 |  | smallint
Command | EdiComStr | ztString | 255 |  | varchar
Command after conv | EdiExecAfterCom | ztString | 255 |  | varchar
Command before | EdiExecBeforeCom | ztString | 255 |  | varchar
IP Address | EDIIPAdress | ztString | 20 |  | varchar
LastTimeConn | EdiLatestConnTime | ztDateTime |  |  | datetime
E-mail address | EdiMail | ztString | 255 |  | varchar
Phone | EdiPhoneNo | ztString | 30 |  | varchar
Schedule | EdiSched | ztInteger | 5 |  | smallint
Script | EdiScript | ztBlob | 1 |  | varchar
ScriptFile | EdiScriptFile | ztString | 255 |  | varchar
EDI server no | EdiServerNo | ztInteger | 5 |  | smallint
SQLScript | EdiSqlScript | ztBlob | 1 |  | varchar
User name | EdiUserName | ztString | 30 |  | varchar
Password | EdiUserPwd | ztString | 30 |  | varchar
WorkDir | EdiWorkDir | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: edix Method of communication


Companies (fr)

Table of general company data.

In Jeeves, you must first enter all companies, organizations, etc., in this table, regardless of whether it is a customer, a supplier or a prospective customer, etc. You can then add relevant information for each module. In the customer table you add information about sales and the accounts receivable ledger. In the supplier table you add information about purchasing and the accounts payable ledger. In the business opportunities table (in the Marketing module) you add information about prospective customers, etc.

In this way, if a company is both a customer and a supplier, you only need to fill in the general information once.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Restricted equity | Aktiekap | ZtBaseCurrAmount | 14 | 2 | money
Number employees | AntalAnst | ztInteger | 5 |  | smallint
Region | BlockRegion | ztString | 3 |  | varchar
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Store customer | ButiksKund | ztBoolean |  |  | char
CMF company | cmfftg | ztBoolean |  |  | char
No c/o address in del. address | CoAdrEjLevAdr | ztBoolean |  |  | char
Contact details | ComNr | ztString | 200 |  | varchar
This field is used in the table as follows: |
Sequence no. type | CompanyType | ztInteger | 4 |  | smallint
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Delivery from business unit ICT | DelivFromBusinessUnit | ztString | 8 |  | varchar
Delivery to business unit | DelivToBusinessUnit | ztString | 8 |  | varchar
District | DistrKod | ztString | 4 |  | varchar
EAN location code | EAN_Loc_Code | ztString | 30 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
EU VAT/tax registration no. | EUMomsNr | ztString | 20 |  | varchar
Extra1 | Extra1 | ztString | 30 |  | varchar
Extra2 | Extra2 | ztString | 30 |  | varchar
Extra3 | Extra3 | ztString | 30 |  | varchar
Extra4 | Extra4 | ztFloat | 10 | 2 | float
Fax no./e-mail address | FaxNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Distance | FtgAvstand | ztInteger | 4 |  | smallint
ZIP/Post code, visiting addr | FtgBesPostNr | ztString | 10 |  | varchar
Destination | FtgBestOrt | ztString | 25 |  | varchar
Company is customer | FtgKundKod | ztBoolean |  |  | char
Ship to->Visit addr | FtgLevAdressKod | ztBoolean |  |  | char
Company is supplier | FtgLevKod | ztBoolean |  |  | char
ZIP/Post code, del address | FtgLevPostNr | ztString | 10 |  | varchar
Company name | FtgNamn | ztString | 36 |  | varchar
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Company Group ID | FtgNrGrupp | ztCompanyNo | 20 |  | varchar
Business hours | FtgOpenHrs | ztString | 20 |  | varchar
c/o address | FtgPostAdr1 | ztString | 36 |  | varchar
Street addr/box | FtgPostAdr2 | ztString | 36 |  | varchar
Town/City/State | FtgPostAdr3 | ztString | 36 |  | varchar
Visiting address | FtgPostadr4 | ztString | 36 |  | varchar
Delivery address | FtgPostadr5 | ztString | 36 |  | varchar
Town/City/State, visiting address | FtgPostBesAdr3 | ztString | 36 |  | varchar
Town/City/State, del address | FtgPostLevAdr3 | ztString | 36 |  | varchar
ZIP/Post code | FtgPostnr | ztString | 10 |  | varchar
Visiting address | FtgVisAdr | ztString | 36 |  | varchar
Besöksadress | FtgVisAdr1 | ztString | 36 |  | varchar
Besöksadress | FtgVisAdr2 | ztString | 36 |  | varchar
Besöksadress | FtgVisAdr3 | ztString | 36 |  | varchar
Företagsnamn | FtgVisName | ztString | 36 |  | varchar
Trading area | HandelsOmrKod | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Internal company | InterntFtg | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Municipality | kommun | ztString | 5 |  | varchar
Anst kont | Kontanst | ZtLong | 6 |  | int
Customer reference | KundRef2 | ztString | 30 |  | varchar
County | laen | ztString | 5 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
VAT/tax reg no. | MomsRegNr | ztString | 20 |  | varchar
Counterpart entry | MotPart | ztString | 30 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Turnover | Omsattning | ZtBaseCurrAmount | 14 | 2 | money
Organization no. | OrgNr | ztString | 18 |  | varchar
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Project source | ProjInit | ztInteger | 2 |  | smallint
Project start date | ProjInitDat | ztDate |  |  | datetime
Company characteristic | ProspEgK1 | ztInteger | 3 |  | smallint
Company characteristic | ProspEgK2 | ztInteger | 3 |  | smallint
Company characteristic | ProspEgK3 | ztInteger | 3 |  | smallint
Company characteristic | ProspEgK4 | ztInteger | 3 |  | smallint
Company characteristic | ProspEgK5 | ztInteger | 3 |  | smallint
State code | ProvinceCode | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
INN | RU_INN | ztString | 15 |  | varchar
KPP | RU_KPP | ztString | 10 |  | varchar
OGRN | RU_OGRN | ztString | 15 |  | varchar
OKONH | RU_OKONH | ztString | 30 |  | varchar
OKPO | RU_OKPO | ztString | 20 |  | varchar
Salesperson | Saljare | ztString | 6 |  | varchar
In-house salesperson | Saljare2 | ztString | 6 |  | varchar
SNI code | SNIKod | ztString | 8 |  | varchar
Language | SprakKod | ztInteger | 3 |  | smallint
Tax area level 1 | TaxAreaCode1 | ztString | 10 |  | varchar
Tax area level 2 | TaxAreaCode2 | ztString | 10 |  | varchar
Tax area level 3 | TaxAreaCode3 | ztString | 10 |  | varchar
Tax area level 4 | TaxAreaCode4 | ztString | 10 |  | varchar
Tax area level 5 | TaxAreaCode5 | ztString | 10 |  | varchar
Antal ans totalt | Totanst | ZtLong | 5 |  | int
Carrier code | TransportorsKod | ztString | 17 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Web address | webadress | ztString | 100 |  | varchar
E-mail | wEmailAddress | ztString | 100 |  | varchar

    This table is the main table in the following programs:

    Program: fr Companies

    Program: mfr Companies, CRM

    Program: ret Print labels/company

    Program: rFrEtQ Address labels


Company (view 1) (vfr1)

View of the fr table (Company).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Restricted equity | Aktiekap | ZtBaseCurrAmount | 14 | 2 | money
Region | BlockRegion | ztString | 3 |  | varchar
No c/o address in del. address | CoAdrEjLevAdr | ztBoolean |  |  | char
Contact details | ComNr | ztString | 200 |  | varchar
District | DistrKod | ztString | 4 |  | varchar
EAN location code | EAN_Loc_Code | ztString | 30 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
EU VAT/tax registration no. | EUMomsNr | ztString | 20 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Distance | FtgAvstand | ztInteger | 4 |  | smallint
ZIP/Post code, visiting addr | FtgBesPostNr | ztString | 10 |  | varchar
Destination | FtgBestOrt | ztString | 25 |  | varchar
Ship to->Visit addr | FtgLevAdressKod | ztBoolean |  |  | char
ZIP/Post code, del address | FtgLevPostNr | ztString | 10 |  | varchar
Company name | FtgNamn | ztString | 36 |  | varchar
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Company Group ID | FtgNrGrupp | ztCompanyNo | 20 |  | varchar
Business hours | FtgOpenHrs | ztString | 20 |  | varchar
c/o address | FtgPostAdr1 | ztString | 36 |  | varchar
Street addr/box | FtgPostAdr2 | ztString | 36 |  | varchar
Town/City/State | FtgPostAdr3 | ztString | 36 |  | varchar
Visiting address | FtgPostadr4 | ztString | 36 |  | varchar
Delivery address | FtgPostadr5 | ztString | 36 |  | varchar
Town/City/State, visiting address | FtgPostBesAdr3 | ztString | 36 |  | varchar
Town/City/State, del address | FtgPostLevAdr3 | ztString | 36 |  | varchar
ZIP/Post code | FtgPostnr | ztString | 10 |  | varchar
Trading area | HandelsOmrKod | ztInteger | 2 |  | smallint
Internal company | InterntFtg | ztBoolean |  |  | char
Municipality | kommun | ztString | 5 |  | varchar
County | laen | ztString | 5 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
VAT/tax reg no. | MomsRegNr | ztString | 20 |  | varchar
Turnover | Omsattning | ZtBaseCurrAmount | 14 | 2 | money
Organization no. | OrgNr | ztString | 18 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
State code | ProvinceCode | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax area level 1 | TaxAreaCode1 | ztString | 10 |  | varchar
Tax area level 2 | TaxAreaCode2 | ztString | 10 |  | varchar
Tax area level 3 | TaxAreaCode3 | ztString | 10 |  | varchar
Tax area level 4 | TaxAreaCode4 | ztString | 10 |  | varchar
Tax area level 5 | TaxAreaCode5 | ztString | 10 |  | varchar
Carrier code | TransportorsKod | ztString | 17 |  | varchar
Web address | webadress | ztString | 100 |  | varchar
E-mail | wEmailAddress | ztString | 100 |  | varchar

    This table is the main table in the following programs:

    Program: vfr1 View company


Company (view 2) (vfr2)

View of the fr table (Company).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No c/o address in del. address | CoAdrEjLevAdr | ztBoolean |  |  | char
Contact details | ComNr | ztString | 200 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
EU VAT/tax registration no. | EUMomsNr | ztString | 20 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Distance | FtgAvstand | ztInteger | 4 |  | smallint
ZIP/Post code, visiting addr | FtgBesPostNr | ztString | 10 |  | varchar
Destination | FtgBestOrt | ztString | 25 |  | varchar
Ship to->Visit addr | FtgLevAdressKod | ztBoolean |  |  | char
ZIP/Post code, del address | FtgLevPostNr | ztString | 10 |  | varchar
Company name | FtgNamn | ztString | 36 |  | varchar
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Business hours | FtgOpenHrs | ztString | 20 |  | varchar
c/o address | FtgPostAdr1 | ztString | 36 |  | varchar
Street addr/box | FtgPostAdr2 | ztString | 36 |  | varchar
Town/City/State | FtgPostAdr3 | ztString | 36 |  | varchar
Visiting address | FtgPostadr4 | ztString | 36 |  | varchar
Delivery address | FtgPostadr5 | ztString | 36 |  | varchar
Town/City/State, visiting address | FtgPostBesAdr3 | ztString | 36 |  | varchar
Town/City/State, del address | FtgPostLevAdr3 | ztString | 36 |  | varchar
ZIP/Post code | FtgPostnr | ztString | 10 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Organization no. | OrgNr | ztString | 18 |  | varchar


Company (view 3) (vfr3)

View of the fr table (Company).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No c/o address in del. address | CoAdrEjLevAdr | ztBoolean |  |  | char
Contact details | ComNr | ztString | 200 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
EU VAT/tax registration no. | EUMomsNr | ztString | 20 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Distance | FtgAvstand | ztInteger | 4 |  | smallint
ZIP/Post code, visiting addr | FtgBesPostNr | ztString | 10 |  | varchar
Destination | FtgBestOrt | ztString | 25 |  | varchar
Ship to->Visit addr | FtgLevAdressKod | ztBoolean |  |  | char
ZIP/Post code, del address | FtgLevPostNr | ztString | 10 |  | varchar
Company name | FtgNamn | ztString | 36 |  | varchar
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Business hours | FtgOpenHrs | ztString | 20 |  | varchar
c/o address | FtgPostAdr1 | ztString | 36 |  | varchar
Street addr/box | FtgPostAdr2 | ztString | 36 |  | varchar
Town/City/State | FtgPostAdr3 | ztString | 36 |  | varchar
Visiting address | FtgPostadr4 | ztString | 36 |  | varchar
Delivery address | FtgPostadr5 | ztString | 36 |  | varchar
Town/City/State, visiting address | FtgPostBesAdr3 | ztString | 36 |  | varchar
Town/City/State, del address | FtgPostLevAdr3 | ztString | 36 |  | varchar
ZIP/Post code | FtgPostnr | ztString | 10 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Organization no. | OrgNr | ztString | 18 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: vfr3 View company


Company (view), KLAS table (vfr9)

Company file which also forms the basis for customers, suppliers, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Restricted equity | Aktiekap | ZtBaseCurrAmount | 14 | 2 | money
Region | BlockRegion | ztString | 3 |  | varchar
No c/o address in del. address | CoAdrEjLevAdr | ztBoolean |  |  | char
Contact details | ComNr | ztString | 200 |  | varchar
This field is used in the table as follows: |
District | DistrKod | ztString | 4 |  | varchar
EAN location code | EAN_Loc_Code | ztString | 30 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
EU VAT/tax registration no. | EUMomsNr | ztString | 20 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Distance | FtgAvstand | ztInteger | 4 |  | smallint
Destination | FtgBestOrt | ztString | 25 |  | varchar
Ship to->Visit addr | FtgLevAdressKod | ztBoolean |  |  | char
Company name | FtgNamn | ztString | 36 |  | varchar
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Business hours | FtgOpenHrs | ztString | 20 |  | varchar
c/o address | FtgPostAdr1 | ztString | 36 |  | varchar
Street addr/box | FtgPostAdr2 | ztString | 36 |  | varchar
Town/City/State | FtgPostAdr3 | ztString | 36 |  | varchar
Visiting address | FtgPostadr4 | ztString | 36 |  | varchar
Delivery address | FtgPostadr5 | ztString | 36 |  | varchar
ZIP/Post code | FtgPostnr | ztString | 10 |  | varchar
Visiting address | FtgVisAdr | ztString | 36 |  | varchar
Besöksadress | FtgVisAdr1 | ztString | 36 |  | varchar
Besöksadress | FtgVisAdr2 | ztString | 36 |  | varchar
Besöksadress | FtgVisAdr3 | ztString | 36 |  | varchar
Företagsnamn | FtgVisName | ztString | 36 |  | varchar
Trading area | HandelsOmrKod | ztInteger | 2 |  | smallint
Internal company | InterntFtg | ztBoolean |  |  | char
Municipality | kommun | ztString | 5 |  | varchar
Anst kont | Kontanst | ZtLong | 6 |  | int
Customer reference | KundRef2 | ztString | 30 |  | varchar
County | laen | ztString | 5 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Turnover | Omsattning | ZtBaseCurrAmount | 14 | 2 | money
Organization no. | OrgNr | ztString | 18 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Company characteristic | ProspEgK1 | ztInteger | 3 |  | smallint
Company characteristic | ProspEgK2 | ztInteger | 3 |  | smallint
Company characteristic | ProspEgK3 | ztInteger | 3 |  | smallint
Company characteristic | ProspEgK4 | ztInteger | 3 |  | smallint
Company characteristic | ProspEgK5 | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SNI code | SNIKod | ztString | 8 |  | varchar
Language | SprakKod | ztInteger | 3 |  | smallint
Antal ans totalt | Totanst | ZtLong | 5 |  | int
Currency | ValKod | ztString | 3 |  | varchar


Company categories (FrEkd1)

Definition of company categories in 3 levels.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description level 1 | Ekd1Beskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLidentity | ZtLong | 10 |  | int
Identity | SQLIDENTITY_orig | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: FrEkd1 Company categories


Company category in 3 levels (FrEk)

Category code level 1

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Comp.category level 1 | Ekd1 | ztInteger | 15 |  | smallint
Comp.category level 2 | Ekd2 | ztInteger | 15 |  | smallint
Comp.category level 3 | Ekd3 | ztInteger | 15 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Company category level 2 (FrEkd2)

Internal categorization at the company level 2 (CRM) that is included in level 1

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Comp.category level 1 | ekd1 | ztInteger | 15 |  | smallint
Description level 2 | Ekd2Beskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLidentity | ZtLong | 10 |  | int
Identity | SQLIDENTITY_orig | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: FrEkd2 Company category level 2


Company category level 3 (FrEkd3)

Internal categorization at the company level 3 (CRM) that is included in level 2

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Comp.category level 1 | ekd1 | ztInteger | 15 |  | smallint
Comp.category level 2 | ekd2 | ztInteger | 15 |  | smallint
Description level 3 | ekd3Beskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | sqlidentity | ZtLong | 10 |  | int
Identity | SQLIDENTITY_orig | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: FrEkd3 Company category level 3


Company category level 3 (vfrekd3)

Internal categorization at the company level 3 (CRM) that is included in level 2

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Comp.category level 1 | ekd1 | ztInteger | 15 |  | smallint
Comp.category level 2 | ekd2 | ztInteger | 15 |  | smallint
Comp.category level 3 | ekd3 | ztInteger | 15 |  | int
Description level 3 | ekd3Beskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint


Company characteristic 1 (xps1)

Definition of characteristics for grouping/classifying companies in the company table. You can make up to 5 similar groupings/classifications (there are 5 tables for this purpose). Example of usage: relation (customer, partner etc.), size of company, etc. You can change field prompt and list headings to describe the current characteristic.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Company characteristic | ProspEgDx1 | ztString | 30 |  | varchar
Company characteristic | ProspEgK1 | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xps1 Company characteristic 1


Company characteristic 2 (xps2)

Definition of characteristics for grouping/classifying companies in the company table. You can make up to 5 similar groupings/classifications (there are 5 tables for this purpose). Example of usage: relation (customer, partner etc.), size of company, etc. You can change field prompt and list headings to describe the current characteristic.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Company characteristic | ProspEgDx2 | ztString | 30 |  | varchar
Company characteristic | ProspEgK2 | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xps2 Company characteristic 2


Company characteristic 3 (xps3)

Definition of characteristics for grouping/classifying companies in the company table. You can make up to 5 similar groupings/classifications (there are 5 tables for this purpose). Example of usage: relation (customer, partner etc.), size of company, etc. You can change field prompt and list headings to describe the current characteristic.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Company characteristic | ProspEgD3 | ztString | 30 |  | varchar
Company characteristic | ProspEgK3 | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xps3 Company characteristic 3


Company characteristic 4 (xps4)

Definition of characteristics for grouping/classifying companies in the company table. You can make up to 5 similar groupings/classifications (there are 5 tables for this purpose). Example of usage: relation (customer, partner etc.), size of company, etc. You can change field prompt and list headings to describe the current characteristic.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Company characteristic | ProspEgD4 | ztString | 30 |  | varchar
Company characteristic | ProspEgK4 | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xps4 Company characteristic 4


Company characteristic 5 (xps5)

Definition of characteristics for grouping/classifying companies in the company table. You can make up to 5 similar groupings/classifications (there are 5 tables for this purpose). Example of usage: relation (customer, partner etc.), size of company, etc. You can change field prompt and list headings to describe the current characteristic.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Company characteristic | ProspEgD5 | ztString | 30 |  | varchar
Company characteristic | ProspEgK5 | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xps5 Company characteristic 5


Company contact (kp)

Definition of external contacts at companies in the company table, i.e. contacts at customer companies, presumptive customers, suppliers, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of times ordered | antalkop | ztInteger | 5 |  | smallint
Department | avd | ztString | 30 |  | varchar
Position | BefattKod | ztString | 2 |  | varchar
Campaign recipient | CampaignReciever | ztBoolean |  |  | char
Contact details | ComNr | ztString | 200 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Contact name | FtgPerson | ztString | 60 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
This field is used in the table as follows: |
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Contact characteristic 1 | Persegk1 | ztInteger | 4 |  | smallint
Contact characteristic 2 | Persegk2 | ztInteger | 4 |  | smallint
Contact characteristic 3 | Persegk3 | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Exported to Outlook | sent_2_Outl_con | ztBoolean |  |  | char
Language | sprakkod | ztInteger | 3 |  | smallint
Last login | WebLastLogin | ztDate |  |  | datetime
NoLogins | WebLoginCount | ZtLong | 6 |  | int
Entry date | WebRegDate | ztDate |  |  | datetime
Web remote address | WebRemoteAddr | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: kp Contacts


Company file log (frl)

A log of changes to the company file.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Restricted equity | Aktiekap | ZtBaseCurrAmount | 14 | 2 | money
Number employees | AntalAnst | ztInteger | 5 |  | smallint
Region | BlockRegion | ztString | 3 |  | varchar
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Store customer | ButiksKund | ztBoolean |  |  | char
CMF company | CMFFtg | ztBoolean |  |  | char
No c/o address in del. address | CoAdrEjLevAdr | ztBoolean |  |  | char
Contact details | ComNr | ztString | 200 |  | varchar
This field is used in the table as follows: |
Sequence no. type | CompanyType | ztInteger | 4 |  | smallint
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Delivery from business unit ICT | DelivFromBusinessUnit | ztString | 8 |  | varchar
Delivery to business unit | DelivToBusinessUnit | ztString | 8 |  | varchar
District | DistrKod | ztString | 4 |  | varchar
EAN location code | EAN_Loc_Code | ztString | 30 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
EU VAT/tax registration no. | EUMomsNr | ztString | 20 |  | varchar
Fax no./e-mail address | FaxNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Distance | FtgAvstand | ztInteger | 4 |  | smallint
ZIP/Post code, visiting addr | FtgBesPostnr | ztString | 10 |  | varchar
Destination | FtgBestOrt | ztString | 25 |  | varchar
Company is customer | FtgKundKod | ztBoolean |  |  | char
Ship to->Visit addr | FtgLevAdressKod | ztBoolean |  |  | char
Company is supplier | FtgLevKod | ztBoolean |  |  | char
ZIP/Post code, del address | FtgLevPostnr | ztString | 10 |  | varchar
Company name | FtgNamn | ztString | 36 |  | varchar
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Company Group ID | FtgNrGrupp | ztCompanyNo | 20 |  | varchar
Business hours | FtgOpenHrs | ztString | 20 |  | varchar
c/o address | FtgPostAdr1 | ztString | 36 |  | varchar
Street addr/box | FtgPostAdr2 | ztString | 36 |  | varchar
Town/City/State | FtgPostAdr3 | ztString | 36 |  | varchar
Visiting address | FtgPostadr4 | ztString | 36 |  | varchar
Delivery address | FtgPostadr5 | ztString | 36 |  | varchar
Town/City/State, visiting address | FtgPostBesAdr3 | ztString | 36 |  | varchar
Town/City/State, del address | FtgPostLevAdr3 | ztString | 36 |  | varchar
ZIP/Post code | FtgPostnr | ztString | 10 |  | varchar
Visiting address | FtgVisAdr | ztString | 36 |  | varchar
Besöksadress | FtgVisAdr1 | ztString | 36 |  | varchar
Besöksadress | FtgVisAdr2 | ztString | 36 |  | varchar
Besöksadress | FtgVisAdr3 | ztString | 36 |  | varchar
Företagsnamn | FtgVisName | ztString | 36 |  | varchar
Trading area | HandelsOmrkod | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Internal company | InterntFtg | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Municipality | kommun | ztString | 5 |  | varchar
Anst kont | Kontanst | ZtLong | 6 |  | int
Customer reference | KundRef2 | ztString | 30 |  | varchar
County | laen | ztString | 5 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
VAT/tax reg no. | MomsRegNr | ztString | 20 |  | varchar
Counterpart entry | MotPart | ztString | 30 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Turnover | Omsattning | ZtBaseCurrAmount | 14 | 2 | money
Organization no. | OrgNr | ztString | 18 |  | varchar
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Project source | ProjInit | ztInteger | 2 |  | smallint
Project start date | ProjInitDat | ztDate |  |  | datetime
Company characteristic | ProspEgK1 | ztInteger | 3 |  | smallint
Company characteristic | ProspEgK2 | ztInteger | 3 |  | smallint
Company characteristic | ProspEgK3 | ztInteger | 3 |  | smallint
Company characteristic | ProspEgK4 | ztInteger | 3 |  | smallint
Company characteristic | ProspEgK5 | ztInteger | 3 |  | smallint
State code | ProvinceCode | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
INN | RU_INN | ztString | 15 |  | varchar
KPP | RU_KPP | ztString | 10 |  | varchar
OGRN | RU_OGRN | ztString | 15 |  | varchar
OKONH | RU_OKONH | ztString | 30 |  | varchar
OKPO | RU_OKPO | ztString | 20 |  | varchar
Salesperson | Saljare | ztString | 6 |  | varchar
In-house salesperson | Saljare2 | ztString | 6 |  | varchar
SNI code | SNIKod | ztString | 8 |  | varchar
Language | SprakKod | ztInteger | 3 |  | smallint
Identity | sqlidentity | ZtLong | 10 |  | int
Status new fields | StatusNewFields | ztBoolean |  |  | char
Date/time | StrDateTime | ztString | 28 |  | varchar
Antal ans totalt | Totanst | ZtLong | 5 |  | int
Carrier code | TransportorsKod | ztString | 17 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Web address | webadress | ztString | 100 |  | varchar
E-mail | wEmailAddress | ztString | 100 |  | varchar


Company groups (JvsSiteCompanyGroups)

Grouping of own companies to which settings can be linked. In other words, this is used only in multi-company databases. In this table, information is stored about company groups. Information about the company group members is stored in the underlying table Group members, company (jvssitecompanygroupmembers).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company group No. | JvsSiteCmpGroup | ztInteger | 4 |  | smallint
Company group name | JvsSiteCmpGroupName | ztString | 128 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteCompanyGroups Company groups


Company key performance indicators (fmfr)

Table of values in key performance indicators for companies.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Trading area | HandelsOmrKod | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Obsolete | inaktuell | ztBoolean |  |  | char
Source | infosource | ztString | 80 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
KPI id | nyckeltalid | ztInteger | 5 |  | smallint
KPI value curr | nyckeltalvarde | ztMoney | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLidentity | ZtLong | 10 |  | int
Currency | valkod | ztString | 3 |  | varchar
KPI value | vb_nyckeltalvarde | ZtBaseCurrAmount | 14 | 2 | money
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xfmfr Company key performance indicators


Company link (kon)

Definition of the company hierarchy (corporation), i.e. relationship between parent company and subsidiary defined in Jeeves.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Share | Andel | ZtDecimal73 | 8 | 3 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Subsidiary | FtgNrDtr | ztCompanyNo | 20 |  | varchar
Parent company | FtgNrMdr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Link order displaying | konOrder | ztBoolean |  |  | char
Link ordering | KonOrderSkapa | ztBoolean |  |  | char
Link service module | KonService | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: kon Company link


Company settings, windows (JvsSiteWindows)

Company settings in window.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Setting ID (orig) | JvsSiteNodeWinSettingsID_orig | ZtLong | 10 |  | int
ID on window setting | JvsSiteWindowSettingsID | ZtLong | 10 |  | int
ID on window setting (orig) | JvsSiteWindowSettingsID_orig | ZtLong | 10 |  | int
Window type | JvsSiteWindowType | ztString | 2 |  | nvarchar
Startpos X axis | JvsSiteXPos | ZtLong | 10 |  | int
Width | JvsSiteXSize | ZtLong | 10 |  | int
Startpos Y axis | JvsSiteYPos | ZtLong | 10 |  | int
Height | JvsSiteYSize | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteWindow Company settings, windows (keys)

    Program: JvsSiteWindows Company settings, windows


Company VIEW (vfr)

View of the fr table (Company).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No c/o address in del. address | CoAdrEjLevAdr | ztBoolean |  |  | char
Contact details | ComNr | ztString | 200 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
EU VAT/tax registration no. | EUMomsNr | ztString | 20 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Distance | FtgAvstand | ztInteger | 4 |  | smallint
ZIP/Post code, visiting addr | FtgBesPostNr | ztString | 10 |  | varchar
Destination | FtgBestOrt | ztString | 25 |  | varchar
Ship to->Visit addr | FtgLevAdressKod | ztBoolean |  |  | char
ZIP/Post code, del address | FtgLevPostNr | ztString | 10 |  | varchar
Company name | FtgNamn | ztString | 36 |  | varchar
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Business hours | FtgOpenHrs | ztString | 20 |  | varchar
c/o address | FtgPostAdr1 | ztString | 36 |  | varchar
Street addr/box | FtgPostAdr2 | ztString | 36 |  | varchar
Town/City/State | FtgPostAdr3 | ztString | 36 |  | varchar
Visiting address | FtgPostadr4 | ztString | 36 |  | varchar
Delivery address | FtgPostadr5 | ztString | 36 |  | varchar
Town/City/State, visiting address | FtgPostBesAdr3 | ztString | 36 |  | varchar
Town/City/State, del address | FtgPostLevAdr3 | ztString | 36 |  | varchar
ZIP/Post code | FtgPostnr | ztString | 10 |  | varchar
Trading area | HandelsOmrKod | ztInteger | 2 |  | smallint
Internal company | InterntFtg | ztBoolean |  |  | char
Country | LandsKod | ztString | 3 |  | varchar
VAT/tax reg no. | momsregnr | ztString | 20 |  | varchar
Organization no. | OrgNr | ztString | 18 |  | varchar

    This table is the main table in the following programs:

    Program: vfr View company


Compensation day schedule (Attr_dsds)

Each dayschedule can be linked up with one or several compensationschedules. Example of compensation schedules: paid over time, save over time. It is important that Saturday and Sunday have compensations schedules as well.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Day schedule | attrdayschedule | ztString | 6 |  | varchar
Compensation dayschedule | AttrDayscheduleComp | ztString | 6 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Attr_dsds Compensation dayschedule


Competitor company (konk)

Table of competitors.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Business model | affmodell | ztString | 255 |  | varchar
Business model | Affmodellbeskr | ztBlob | 1 |  | varchar
Item description | Artbeskr | ztString | 30 |  | varchar
Text | edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Parent company | FtgNrMdr | ztCompanyNo | 20 |  | varchar
History | Historik | ztBlob | 1 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Competitor item no. | KonkArtNr | ztString | 50 |  | varchar
Price model | konkprismodell | ztBlob | 1 |  | varchar
R&D | KonkRND | ztBlob | 1 |  | varchar
Service/support | konkservsupp | ztBlob | 1 |  | varchar
Strategy | KonkStrategi | ztBlob | 1 |  | varchar
Segmenting 1 ID | ksegment1 | ztInteger | 5 |  | smallint
Segmenting 2 ID | ksegment2 | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sales argument | usp | ztBlob | 1 |  | varchar

    This table is the main table in the following programs:

    Program: konk Competitor monitoring


Competitor item (ArKonk)

Table of competitor's items.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Analysis | analys | ztBlob | 1 |  | varchar
Item description | Artbeskr | ztString | 30 |  | varchar
Item descr 2 | Artbeskr2 | ztString | 255 |  | varchar
List price | ArtListPris | ZtBaseCurrAmount | 14 | 2 | money
Item no. | Artnr | ztString | 30 |  | varchar
Text | edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | Ftgnr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Source | infosource | ztString | 80 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Competitor item part | KonkArtDel | ztInteger | 5 |  | smallint
Competitor item no. | KonkArtNr | ztString | 50 |  | varchar
Competitor item type | KonkArtTyp | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Ranking | rankning | ztString | 50 |  | varchar
Fiscal year | redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | sqlidentity | ZtLong | 10 |  | int
Sales argument | usp | ztBlob | 1 |  | varchar

    This table is the main table in the following programs:

    Program: arkonk Competitor items


Competitor item BOM (SrKonk)

Sub-item/function in competitor item.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Analysis | analys | ztBlob | 1 |  | varchar
Item description | artbeskr | ztString | 30 |  | varchar
List price | artlistpris | ZtBaseCurrAmount | 14 | 2 | money
Item no. | artnr | ztString | 30 |  | varchar
Identitetskolumn | ConnToSQLIDENTITY | ZtLong | 10 |  | int
Unique drop-down record | ddlstring | ztString | 18 |  | varchar
Text | edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Competitor item part | KonkArtDel | ztInteger | 5 |  | smallint
Competitor item no. | Konkartnr | ztString | 50 |  | varchar
Competitor item function | KonkArtnrSr | ztString | 50 |  | varchar
Competitor item type | KonkArtTyp | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLidentity | ZtLong | 10 |  | int
Sales argument | usp | ztBlob | 1 |  | varchar


Competitor item part (ArKonkD)

Part of competitor item

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Competitor item part | KonkArtDel | ztInteger | 5 |  | smallint
Competitor item part | KonkArtDelBeskr | ztString | 50 |  | varchar
Competitor item type | KonkArtTyp | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Competitor item type (ArKonkT)

Numeric code for standard item type for competitor item.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Competitor item type | KonkArtTyp | ztInteger | 5 |  | smallint
Competitor item type | KonkArtTypBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: KonkArtT Competitor item types


Compression prg (vzpa)

Table for storing file extensions of compression programs.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod |  |  |  | @DataType=NULL
Pack extension | YndPackExt | ztString | 8 |  | nvarchar
Compress program | YndPackPgm | ztString | 255 |  | nvarchar
Decompression pgm | YndUnPackPgm | ztString | 255 |  | nvarchar

    This table is the main table in the following programs:

    Program: vzpa EDI file extensions


Condition codes (sht1)

Definition of IRIS condition codes. This is used when entering service orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Condition code (IRIS) | Condition | ztString | 30 |  | varchar
Condition code (IRIS) | ConditionCode | ztString | 3 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: sht1 Condition codes IRIS


Configuration, attribute (ConfAttr)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Attributbeskrivning | ConfAttrDescr | ztString | 30 |  | varchar
AttributId | ConfAttrID | ZtLong | 10 |  | int
KlassId | ConfClassID | ZtLong | 10 |  | int
DomänId | ConfDomID | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Configuration, class (ConfClass)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Klassbeskrivning | ConfClassDescr | ztString | 30 |  | varchar
KlassId | ConfClassID | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Configuration, class model (ConfClassMod)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
KlassId | ConfClassID | ZtLong | 10 |  | int
Modell version | ConfModVerID | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Configuration, domain (ConfDom)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
DomänId | ConfDomID | ZtLong | 10 |  | int
Domäntyp | ConfDomType | ZtLong | 10 |  | int
Modell version | ConfModVerID | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Configuration, model (ConfModel)

Describes an item’s configuration model

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Modellbeskrivning | ConfModDescr | ztString | 30 |  | varchar
Modellid | ConfModID | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Configuration, model version (ConfModelVer)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Modellbeskrivning | ConfModDescr | ztString | 30 |  | varchar
Modell version | ConfModVerID | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ConfModelVer Configuration model, version


Connect Employees to agreements (AttR_prvagr)

What agreement is valid per employee (and when).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Agreement ID | AttRAgreement | ztString | 6 |  | varchar
Valid from date | AttRValidFromDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | Perssign2 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_prvagr Connect employee to agreement


Connect Employees to schedule (AttR_prvws)

Connects employees and schedule groups.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
From weekday | AttRFromWeekday | ztInteger | 5 |  | smallint
Valid from date | AttRValidFromDat | ztDate |  |  | datetime
Work schedule template | AttRWorkScheduleTemplate | ztString | 6 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | Perssign2 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_prvws Connect employee to schedule template


Connect voucherlhead to journals... (VchrHead_2_Journal)

Numeric designation for fiscal year.

Recommendation:

- We recommend that a four-digit designation be used for the fiscal year (e.g. 2004), not a two-digit designation (e.g. 04).

- For a fiscal year that extends over several calendar years, you should NOT use designations that specify a start and end year, such as 0102 for 2001-2002. Because this is a numeric value, the sort and sort order can be disrupted if you change the designation format. Example: The designation 0203 (203) is sorted before 2002. Instead use the field 'Fiscal year desc' (Redarbeskr) to describe the length of the fiscal year.

The default fiscal year can be specified in "System data/account" (Sye), in which case a default year is suggested in most entry and selection programs in the accounting routines.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg journal no. | AorJournNr | ZtLong | 6 |  | int
Cost change journal | ArskJournNr | ZtLong | 6 |  | int
Depreciation journal | Avskrjournal | ZtLong | 5 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
PO/receiving journal no. | BpiJournNr | ZtLong | 10 |  | int
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Phys invtry journ no. | InvJournal | ZtLong | 5 |  | int
Fixed asset journal | InvJournNr | ZtLong | 6 |  | int
Invtry transaction journal no | JlJournNr | ZtLong | 6 |  | int
Material journal no. | MruJournNr | ZtLong | 6 |  | int
Picking journal no. | OruJournNr | ZtLong | 10 |  | int
Ord-spec jrnl no. | OulJournNr | ZtLong | 6 |  | int
Signature | PersSign | ZtLong | 6 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztInteger | 4 |  | smallint
Created date/time | RowCreatedDt | ztInteger | 4 |  | smallint
Updated by | RowUpdatedBy | ztInteger | 4 |  | smallint
Updated date/time | RowUpdatedDt | ztInteger | 4 |  | smallint
Manufacturing journal | ThJournNr | ZtLong | 6 |  | int
Manufacturing journal | TiiJournNr | ZtLong | 6 |  | int
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint


Connect voucherline to journals... (VchrLine_2_Journal)

Numeric designation for fiscal year.

Recommendation:

- We recommend that a four-digit designation be used for the fiscal year (e.g. 2004), not a two-digit designation (e.g. 04).

- For a fiscal year that extends over several calendar years, you should NOT use designations that specify a start and end year, such as 0102 for 2001-2002. Because this is a numeric value, the sort and sort order can be disrupted if you change the designation format. Example: The designation 0203 (203) is sorted before 2002. Instead use the field 'Fiscal year desc' (Redarbeskr) to describe the length of the fiscal year.

The default fiscal year can be specified in "System data/account" (Sye), in which case a default year is suggested in most entry and selection programs in the accounting routines.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg journal no. | AorJournNr | ZtLong | 6 |  | int
Cost change journal | ArskJournNr | ZtLong | 6 |  | int
Depreciation journal | Avskrjournal | ZtLong | 5 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
PO/receiving journal no. | BpiJournNr | ZtLong | 10 |  | int
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Phys invtry journ no. | InvJournal | ZtLong | 5 |  | int
Fixed asset journal | InvJournNr | ZtLong | 6 |  | int
Invtry transaction journal no | JlJournNr | ZtLong | 6 |  | int
Material journal no. | MruJournNr | ZtLong | 6 |  | int
Picking journal no. | OruJournNr | ZtLong | 10 |  | int
Ord-spec jrnl no. | OulJournNr | ZtLong | 6 |  | int
Signature | PersSign | ZtLong | 6 |  | int
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztInteger | 4 |  | smallint
Created date/time | RowCreatedDt | ztInteger | 4 |  | smallint
Updated by | RowUpdatedBy | ztInteger | 4 |  | smallint
Updated date/time | RowUpdatedDt | ztInteger | 4 |  | smallint
Manufacturing journal | ThJournNr | ZtLong | 6 |  | int
Manufacturing journal | TiiJournNr | ZtLong | 6 |  | int
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint


Connection menu and signature (mnud)

Table of links between program menus and signatures.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
Default menu | DefMenu | ztBoolean |  |  | char
Group | grupp | ztInteger | 4 |  | smallint
Menu ID | MenuId | ZtLong | 5 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language code | zlanguage | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: mnud Personal menus


Connection Time Type - Time Type Class (AttR_ttcltt)

Connects time type to time type class.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Time type | AttRTimeType | ztString | 6 |  | varchar
Time type class | AttRTimeTypeClass | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_ttcltt Connection Time Type - Time Type Class


Contact details (cr)

Here you can enter, maintain and search for telephone numbers, fax numbers, e-mail addresses, etc. for both companies and contact persons. You can also produce this information in the programs for company and contact persons, but there only information on one company or contact person is shown at a time.

You can search for a certain person's or company's contact details. You can search for the name of the company/person that has a specific number.

There is also an application that can be integrated with Jeeves for automatic number presentation on incoming calls. For more details, see the documentation for the Marketing and sales support module or for the CTI application.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Contact method | ComKod | ztString | 2 |  | varchar
Contact details | ComNr | ztString | 200 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Dispatch notify method | GodsAvisKod | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | KortNotering | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: cr Contact details


Contact details, view (vcre)

External contact details for companies, contacts, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Contact method | ComKod | ztString | 2 |  | varchar
Contact details | ComNr | ztString | 200 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar


Contact methods (X4)

Definition of applicable types of contact details, such as Direct no., Exchange no., Fax no., Home no., e-Mail etc.

For further information, see Help for the Contact method field (combeskr).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Contact method | ComBeskr | ztString | 50 |  | varchar
Contact method | ComKod | ztString | 2 |  | varchar
Contact method | ComKort | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Contact method, internal | StaticComKod | ztInteger | 20 |  | smallint

    This table is the main table in the following programs:

    Program: XX4 Contact methods


Contact pers. category level 3 (vkpekd3)

Internal categorization level 3 at contact pers. Level (KP)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Comp.category level 1 | ekd1 | ztInteger | 15 |  | smallint
Comp.category level 2 | ekd2 | ztInteger | 15 |  | smallint
Comp.category level 3 | Ekd3 | ztInteger | 15 |  | int
Description level 3 | Ekd3Beskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint


Contact pers.category in 3 levels (KpEk)

Category code level 1

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Comp.category level 1 | Ekd1 | ztInteger | 15 |  | smallint
Comp.category level 2 | Ekd2 | ztInteger | 15 |  | smallint
Comp.category level 3 | Ekd3 | ztInteger | 15 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | ftgkontaktnr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Contact person categories, level 1 (KpEkd1)

Definition of your own categories of contact persons, level 1 of 3.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Comp.category level 1 | Ekd1 | ztInteger | 15 |  | smallint
Description level 1 | Ekd1Beskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Jvs_Internal_LDDL_ID | Jvs_Internal_LDDL_ID | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | sqlidentity | ZtLong | 10 |  | int
Identity | SQLIDENTITY_orig | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: KpEkd Contact person categories


Contact person categories, level 2 (KpEkd2)

Definition of your own categories of contact persons, level 2 of 3.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Comp.category level 1 | ekd1 | ztInteger | 15 |  | smallint
Comp.category level 2 | Ekd2 | ztInteger | 15 |  | smallint
Description level 2 | Ekd2Beskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | sqlidentity | ZtLong | 10 |  | int
Identity | SQLIDENTITY_orig | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: KpEkd2 Contact person category level 2


Contact person categories, level 3 (KpEkd3)

Definition of your own categories of contact persons, level 3 of 3.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Comp.category level 1 | ekd1 | ztInteger | 15 |  | smallint
Comp.category level 2 | ekd2 | ztInteger | 15 |  | smallint
Comp.category level 3 | Ekd3 | ztInteger | 15 |  | smallint
Description level 3 | Ekd3Beskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | sqlidentity | ZtLong | 10 |  | int
Identity | SQLIDENTITY_orig | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: KpEkd3 Contact person category level 3


Contacts (view) (vpr1)

Database view of the Contacts table (PR).
Only use those found in stt (service technicians).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Name | RespNamn | ztString | 50 |  | varchar


Contacts copied to Outlook per user (Kp2OutlCont)

Contacts copied to Outlook per user including timpestamp.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Copied to Outlook | CopiedToOutlookDt | ztDateTime |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Kp2OutlCont Contacts copied to Outlook per user


Control groups, account segment 4 (gk4)

Definition of possible control groups for account segment 4. The definition is copied between years.

You can then link the group of account segment 4 in question to accounts, for example, and/or cost centres, etc., so that in this way you specify which combinations of account segments are permitted.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Appr/ctrl grp, S4 | Gk4Beskr | ztString | 30 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xGk4 Control groups, account segment 4


Control groups, account segment 5 (gk5)

Definition of possible control groups for account segment 5. The definition is copied between years.

You can then link the group of account segment 5 question to accounts, for example, and/or cost centres, etc., so that in this way you specify which combinations of account segments are permitted.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Appr/ctrl grp, S5 | Gk5Beskr | ztString | 30 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xGk5 Control groups, account segment 5


Control groups, account segment 6 (gk6)

Definition of possible control groups for account segment 6. The definition is copied between years.

You can then link the group of account segment 6 question to accounts, for example, and/or cost centres, etc., so that in this way you specify which combinations of account segments are permitted.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Appr/ctrl grp, S6 | Gk6Beskr | ztString | 30 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xGk6 Control groups, account segment 6


Control groups, account segment 7 (gk7)

Definition of possible control groups for account segment 7. The definition is copied between years.

You can then link the group of account segment 7 question to accounts, for example, and/or cost centres, etc., so that in this way you specify which combinations of account segments are permitted.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Appr/ctrl grp, S7 | Gk7Beskr | ztString | 30 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xGk7 Control groups, account segment 7


Control groups, chart of accounts (gk1)

Definition of possible control groups for accounts (account segment 1). The definition is copied between years.

You can then link the group of accounts in question to cost centres, for example, and/or cost units, etc., so that in this way you specify which combinations of account segments are permitted.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Appr/ctrl grp, account | Gk1Beskr | ztString | 30 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xGk1 Control groups, chart of accounts


Control groups, cost centres (gk2)

Definition of possible control groups for cost centres (account segment 2). The definition is copied between years.

You can then link the group of cost centres in question to accounts, for example, and/or cost units, etc., so that in this way you specify which combinations of account segments are permitted.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Appr/ctrl grp, CC | Gk2Beskr | ztString | 30 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Approval control group | KstGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xGk2 Control groups, cost centres


Control groups, cost units (gk3)

Definition of possible control groups for cost units (account segment 3). The definition is copied between years.

You can then link the group of cost units in question to accounts, for example, and/or cost centres, etc., so that in this way you specify which combinations of account segments are permitted.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Appr/ctrl grp, S3 | Gk3Beskr | ztString | 30 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xGk3 Control groups, cost units


Control groups, project (gprj)

Definition of any control groups for the project. Later you can link the current group from the project to, for example, the accounts or cost centres, etc. in order to specify which combinations of account segments are allowed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Control group project | GprjBeskr | ztString | 30 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Control group project | prjgrupp | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: gprj Control groups, project


Control table at update (xfic)

Table for monitoring which tables are updated when logging into Jeeves.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Process ID | Spid | ZtLong | 5 |  | int
Table | Tabellnamn | ztString | 40 |  | varchar


Control view over journals (valt)

A view showing which journals have been created but have not gone into the general ledger.
The relevant journals are

- Labour reporting journal
- Material journal
- Manufacturing delivery journal
- Rcvd delivery journal, calc value
- Delivery receipt journal, PO
- Picking journal, customer order
- Order-specific inventory journal
- Cost price change journal
- Inventory transaction journal

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Mfg journal no. | AorJournNr | ZtLong | 6 |  | int
Final report date | AoSlutMarkDat | ztDate |  |  | datetime
Cost change journal | ArskJournNr | ZtLong | 6 |  | int
Item no. | ArtNr | ztString | 30 |  | nvarchar
Delivery received date | BestLevDat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
PO/receiving journal no. | bpiJournNr | ZtLong | 10 |  | int
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | nvarchar
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
RowNo. | FaktRadNr | ztInteger | 4 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Invtry transaction journal no | JlJournNr | ZtLong | 6 |  | int
Inventory location | LagStalle | ztString | 2 |  | nvarchar
Transaction date | LagTransDatum | ztDate |  |  | datetime
Sequence no. | LopNr | ZtLong | 10 |  | int
Item no. required | mrArtNr | ztString | 30 |  | nvarchar
Material journal no. | MruJournNr | ZtLong | 6 |  | int
OK to pick date | MrUtplDat | ztDate |  |  | datetime
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | int
Picking journal no. | OruJournNr | ZtLong | 10 |  | int
Ord-spec jrnl no. | OulJournNr | ZtLong | 6 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | int
Date/time | StrDateTime | ztString | 28 |  | nvarchar
Table | Tabellnamn | ztString | 40 |  | nvarchar
Manufacturing journal | ThJournNr | ZtLong | 6 |  | int
Manufacturing journal | TiiJournNr | ZtLong | 6 |  | int
Delivery received date | TiInlevDat | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: valt Incorrect journals


Conversation History (PTPConvHistrory)

Numerical ID for a member of a conversation group, used in the Collaboration function.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Member ID | MemberId | ZtLong | 6 |  | int
Comment content | PComCont | ztBlob | 1 |  | varchar
Comment Type | PComType | ztInteger | 3 |  | smallint
Conversation ID | PConvId | ztInteger | 5 |  | smallint
File name | PFileName | ztString | 250 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int


Conversation Invitations (PTPInvite)

Numerical ID for a member of a conversation group, used in the Collaboration function.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Member ID | MemberId | ZtLong | 6 |  | int
Accept State | PAcceptState | ztInteger | 3 |  | smallint
Conversation ID | PCOnvId | ztInteger | 5 |  | smallint
From member ID | PFromMemberId | ZtLong | 6 |  | int
Topic | PTopic | ztString | 250 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Conversation participant (PTPConvPart)

Numerical ID for a member of a conversation group, used in the Collaboration function.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Member ID | MemberId | ZtLong | 6 |  | int
Conversation ID | PCOnvId | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Member standing | PMemberState | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Conversion restrictions (rekv)

Definition of restrictions for conversion, i.e. conditions for whether a record will be handled in the relevant conversion step.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
DB-term/-expression 1 | DbTermname1 | ztString | 120 |  | varchar
From value | firstvarde | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
To value | lastvarde | ztString | 255 |  | varchar
And/Or | ocheller | ztInteger | 3 |  | smallint
Operand | Operator | ztString | 20 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry time | regtime | ztTime | 5 |  | datetime
Restriction type | restrtype | ztInteger | 2 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Sequence | Sequence | ztInteger | 3 |  | smallint
Date/time | StrDateTime | ztString | 28 |  | varchar
Value term table | VardeTabId1 | ztString | 255 |  | varchar
Negation | WhereNot | ztBoolean |  |  | char


Conversion step (BTran2GLDefStep)

Definition of conversion step. One table header is created per conversion step.

The sequence between the conversion steps does not have any meaning from performance-point of view but it is an advantage to find some kind of logic handling sequence. If the function for direction away is used in any conversion step, it is important that the definitions are made in a certain sequence. If an already existing conversion shall be inserted into Jeeves the same sequence may be able to be used.

Some general guidance
------------------------------
Describe the conversion steps on a paper and do not insert them in the tables until all steps are finished. For every step is stated:

- Description in text format
- Conditions/Restrictions
- Which terms will be included in the Jeeves record (remember to update the list of terms after they are defined)

Start with a general direction away, e.g. on company level.

- Handle the exceptions first so that the larger majority can be handled in the same conversion step.
- All records that shall contain the same posting contents (whether the terms are allowed or shall exist) can be processed in the same conversion step.

Be very careful when you refer to terms in the source table (external system file) so that you avoid writing or spelling errors.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Direction away | BortStyra | ztBoolean |  |  | char
ID | BTran2GLDefId | ztString | 10 |  | varchar
Descr of conversion step | BTran2GLDefStepDescr | ztString | 100 |  | varchar
Step in conversion | BTran2GLDefStepNo | ZtLong | 10 |  | int
Input data from table/view | BTranFrom_Table_View | ztString | 60 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Convert seq | KonvStyra | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Conversion translation table (xstr)

Reference to a translation table if accounts will be translated in connection with conversion.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Translation table | KTabell | ztString | 30 |  | varchar
Translation table | ktabellbeskr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xstr Conversion translations


Cost centre for CO (orkt)

The cost centres that can be entered manually on customer orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
As of date | DatKstFom | ztDate |  |  | datetime
End date | DatKstTom | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Cost centre | KstBeskr | ztString | 25 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: orkt Cost centre on order


Cost centre Internal sales for CO (OrktIntFsg)

The cost centres for Internal sales that can be entered manually on customer orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
As of date | DatKstFom | ztDate |  |  | datetime
End date | DatKstTom | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost centre, intrn sales | KostStalleKodIntFsg | ztString | 8 |  | varchar
Cost centre | KstBeskr | ztString | 25 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: OrktIntFsg Cost centre Internal sales on order


Cost centre posting rules (xl1)

Internal definitions which are used to determine whether account segment 2 (cost centre) can/will be specified for a specific account.

The following standard records exist. Do not alter/delete:

Posting rule S2 (regel1) | Posting rule S2 (regelbeskr1)
1 | Does not exist
2 | Optional
3 | Mandatory

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Mandatory, CC | oblig0 | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Posting rule S2 | regel1 | ztInteger | 1 |  | smallint
Posting rule S2 | regelbeskr1 | ztString | 50 |  | varchar
Entry inventory, CC | RegLager | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xl1 Posting rule/cost centres


Cost centre translation (ktt)

Translation table of segment 2 (cost centre) at auto posting and auto allocation in the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allocate to cost ctr | FordTillKst | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Translation group | OversattnGrp | ztString | 8 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xKtt Translate cost centres


Cost centres (segment 2) (kt)

Definition of the company's cost centres (account segment 2) in the chart of accounts. The definition is copied between fiscal years.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
As of date | DatKstFom | ztDate |  |  | datetime
End date | DatKstTom | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Replaced by cost centre | ErsattsKostStalleKod | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Cost centre | KstBeskr | ztString | 25 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Legal entity | LegalEntity | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Control group project | PrjGrupp | ztString | 6 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display on web | WebAccountMark | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: bHbKst Print GL cost centres

    Program: kt Cost centre


Cost centres VIEW (vkt)

View of the kt table (Cost centre).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Cost centre | KstBeskr | ztString | 25 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: vkt Cost centres (view)


Cost centres VIEW 2 (vkt1)

View of the kt table (Cost centre).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Cost centre | KstBeskr | ztString | 25 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: vkt1 Cost centres (view)


Cost centres VIEW 3 (vkt2)

View of the kt table (Cost centre).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Cost centre | KstBeskr | ztString | 25 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: vkt2 Cost centres (view)


Cost detail types (xkdt)

Table of cost detail types that are used for cost estimates and actual costs of purchasing goods to inventory or transferring goods between different inventories.

The following standard records exist. Do not alter/delete:

Calc detail type (KalkDetKod) | Calc detail type (KalkDetBeskr)
1 | Purchase cost
2 | Freight cost
3 | Insurance
4 | Bank charge
5 | Customs/import fee

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calc detail type | KalkDetBeskr | ztString | 50 |  | varchar
Retrieve purchase value | KalkDetGetInkVarde | ztBoolean |  |  | char
For purchase calc | KalkDetInkopKalkyl | ztBoolean |  |  | char
Calc detail type | KalkDetKod | ztInteger | 2 |  | smallint
For inventory calc | KalkDetLagerKalkyl | ztBoolean |  |  | char
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xxkdt Cost detail types


Cost price change journal header (jark)

Data in the header of the inventory cost changes journal for products/items.
A journal only includes data of changes for one day, which is why one journal a day is normally created (several journals a day can however be created).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Cost change journal | ArskJournNr | ZtLong | 6 |  | int
Cost prc date | ArtKalkDat | ztDate |  |  | datetime
Accounting date | BokfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: Jark Cost price change journal


Cost price change log, items (arkl)

Log of changes of estimated costs by item.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost prc date | ArtKalkDat | ztDate |  |  | datetime
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Calc cost price | ArtKalkPris | ZtBaseCurrAmount | 14 | 2 | money
Average cost price | ArtKalkSnitt | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost update code | KalkPrisAndrTypKod | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Prev cost price BCU | OldArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Prev cost price refinement | OldArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Previous cost price mtrl | OldArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Prev budg cost prc | OldArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Prev cost prc/pc | OldArtKalkPer | ztInteger | 1 |  | smallint
Prev calculated cost price | OldArtKalkPris | ZtBaseCurrAmount | 14 | 2 | money
Previous average cost | OldArtKalkSnitt | ZtBaseCurrAmount | 14 | 2 | money
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: xArkl Log changes in purch costs


Cost price, operation (opk)

Operations for calculated items.
Only detailed calculation updates this table.
There is a kind of operation copy of the calculated item for every calculated item.
You can see the calculated costs for every operation (for all levels) in this table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternativ op | AltOpKod | ztString | 2 |  | varchar
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Quantity per hour | AntalPerTimme | ztFloat | 15 | 6 | float
Calc setup cost | ArbKalkStallKost | ZtBaseCurrAmount | 14 | 2 | money
Fixed labour OH | ArbOmkFast | ZtCost | 16 | 6 | float
Tot labour OH/op | ArbOmkOp | ZtCost | 16 | 6 | float
Variable labour OH | ArbOmkRorl | ZtCost | 16 | 6 | float
Setup labour OH/unit | ArbOmkStall | ZtCost | 16 | 6 | float
Setup overhead, labour | ArbStallBiKost | ZtCost | 16 | 6 | float
Setup cost labour | ArbStallKost | ZtCost | 16 | 6 | float
Labour overhead/unit | ArbStyckBiKost | ZtCost | 16 | 6 | float
Labour cost/unit | ArbStyckKost | ZtCost | 16 | 6 | float
Calculation version no. | ArkVersion | ZtLong | 4 |  | int
Labour cost (calculation) | ArtKalkArbKost | ZtBaseCurrAmount | 14 | 2 | money
Fixed cost (calculation) | ArtKalkFastKost | ZtBaseCurrAmount | 14 | 2 | money
Material cost (calculation) | ArtKalkMtrlKost | ZtBaseCurrAmount | 14 | 2 | money
Variable cost (calculation) | ArtKalkRorlKost | ZtBaseCurrAmount | 14 | 2 | money
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
BOM level | ArtNivaBeskr | ztString | 20 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Autom mtrl.uttag | AutMtrlUttag | ztBoolean |  |  | char
Auto mtrl issue type | AutMtrlUttagTyp | ztInteger | 5 |  | smallint
Workload factor | BelaggningsFaktor | ztFloat | 15 | 2 | float
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Calculation item | KalkArtNr | ztString | 30 |  | varchar
Calculation date | KalkBerDatum | ztDate |  |  | datetime
Calculation on quantity | KalkylPaAntal | ZtQty | 14 | 2 | decimal
Scrap degree/op | KassOp | ztFloat | 5 | 2 | float
Queue time | KoTid | ztFloat | 15 | 2 | float
Inventory location | LagStalle | ztString | 2 |  | varchar
Subcontract overhead cost | LegoBiKost | ZtCost | 16 | 6 | float
Subcontract cost | LegoKost | ZtCost | 16 | 6 | float
Subcontract price/unit | LegoPris | ZtBaseCurrAmount | 14 | 2 | money
Subcontract setup price | LegoPrisStall | ZtBaseCurrAmount | 14 | 2 | money
Subcontract start price | LegoPrisStart | ZtBaseCurrAmount | 14 | 2 | money
Sequence no. | LopNr | ZtLong | 10 |  | int
MO% markup mtrl mfg | MoProcMtrlTillv | ZtDecimal73 | 8 | 3 | decimal
OLE-1 | Ole1 | ztString | 255 |  | varchar
OLE-2 | Ole2 | ztString | 255 |  | varchar
Personnel/operation | OpBemanning | ztFloat | 6 | 3 | float
Personnel/operation, setup | OpBemanningStall | ztFloat | 6 | 3 | float
Operation | OpBen | ztString | 30 |  | varchar
Operation | OpBeskr | ztBlob | 1 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Overlying seq no. | OverRowNo | ztInteger | 3 |  | smallint
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Mfg grp deprec. | PgAvskrKost | ZtCost | 16 | 6 | float
Mfg grp fixed cost | PgFastKost | ZtCost | 16 | 6 | float
Mfg grp var cost | PgRorlKost | ZtCost | 16 | 6 | float
Mfg grp setup cost | PgStallKost | ZtCost | 16 | 6 | float
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Mfg grp subcontr OH % | ProdGrLegoOmkP | ztFloat | 6 | 2 | float
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Ställkostnad | StallKost | ZtBaseCurrAmount | 14 | 2 | money
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Unit time B | StyckTidB | ztFloat | 8 | 4 | float
Unit time C | StyckTidC | ztFloat | 8 | 4 | float
Item group | VaruGruppKod | ztString | 8 |  | varchar
Shop price | VerkstadPris | ZtBaseCurrAmount | 14 | 2 | money
Tools | Verktyg | ztString | 16 |  | varchar
Tool deprec | VyAvskrKost | ZtCost | 16 | 6 | float
Fixed tool cost | VyFastKost | ZtCost | 16 | 6 | float
Var tool cost | VyRorlKost | ZtCost | 16 | 6 | float
Tool setup cost | VySTallKost | ZtCost | 16 | 6 | float
Tool unit cost | VyStyckKost | ZtCost | 16 | 6 | float


Cost update codes (xark)

Code for cost price changes.
To a manually entered price, the change could be calculated from the purchase agreement, from purchase invoice matching, or from received deliveries based on average cost price, etc.

The following standard records exist. Do not alter/delete:

Cost update code (KalkPrisAndrTypKod) | Cost change desc (KalkPrisAndrTypBeskr)
0 | Manually changed
111 | Received delivery, avg prc
112 | Invoice matching, avg price
113 | Crediting customer order, avg price
114 | Received delivery fr mfg, avg price
400 | Purchase price change on batch
410 | Cost change on batch
411 | Price change at transfer

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost change desc | KalkPrisAndrTypBeskr | ztString | 50 |  | varchar
Cost update code | KalkPrisAndrTypKod | ztInteger | 5 |  | smallint
To be posted | Konteras | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xXark Cost update codes


Costing, item (ark)

Estimated costs of items are stored in this table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Purchased | AnskaffningKop | ztBoolean |  |  | char
Labour overhead | ArbOmk | ZtCost | 16 | 6 | float
Fixed labour OH | ArbOmkFast | ZtCost | 16 | 6 | float
Tot labour OH/op | ArbOmkOp | ZtCost | 16 | 6 | float
Labour OH cost % | ArbOmkProc | ztFloat | 7 | 2 | float
Variable labour OH | ArbOmkRorl | ZtCost | 16 | 6 | float
Setup labour OH/unit | ArbOmkStall | ZtCost | 16 | 6 | float
Setup overhead, labour | ArbStallBiKost | ZtCost | 16 | 6 | float
Setup cost labour | ArbStallKost | ZtCost | 16 | 6 | float
Labour overhead/unit | ArbStyckBiKost | ZtCost | 16 | 6 | float
Labour cost/unit | ArbStyckKost | ZtCost | 16 | 6 | float
Calculation version no. | ArkVersion | ZtLong | 4 |  | int
Net purchase price | ArtInPris | ZtBaseCurrAmount | 14 | 2 | money
Labour cost (calculation) | ArtKalkArbKost | ZtBaseCurrAmount | 14 | 2 | money
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
New cost price from date | ArtKalkBerNyttDatum | ztDate |  |  | datetime
New cost price (refinement) | ArtKalkBerNyttForadling | ZtBaseCurrAmount | 14 | 2 | money
New cost price (mtrl) | ArtKalkBerNyttMtrl | ZtBaseCurrAmount | 14 | 2 | money
Prel cost prc | ArtKalkBerPrel | ZtPurPrice | 12 | 2 | money
Fixed cost (calculation) | ArtKalkFastKost | ZtBaseCurrAmount | 14 | 2 | money
Material cost (calculation) | ArtKalkMtrlKost | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Variable cost (calculation) | ArtKalkRorlKost | ZtBaseCurrAmount | 14 | 2 | money
Average cost price | ArtKalkSnitt | ZtBaseCurrAmount | 14 | 2 | money
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Last PYR date | ArtPyrDat | ztDateTime |  |  | datetime
Purchase price budget | BudgInPris | ZtBaseCurrAmount | 14 | 2 | money
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Econ order quantity | Eoq | ZtQty | 14 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Calc admin sales overhead cost. | ForsOmkBelopp | ZtBaseCurrAmount | 14 | 2 | money
Average weighted | KalkylPrisEnlSnittPris | ztBoolean |  |  | char
Scrap factor in % | KassAr | ztFloat | 5 | 2 | float
Overheads, work, admin | LabOvhdAdmCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, production | LabOvhdPrdCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, sales | LabOvhdSalesCost | ZtBaseCurrAmount | 14 | 2 | money
Inventory location | LagStalle | ztString | 2 |  | varchar
Subcontract overhead cost | LegoBiKost | ZtCost | 16 | 6 | float
Subcontract cost | LegoKost | ZtCost | 16 | 6 | float
Material cost | MtrlKost | ZtCost | 16 | 6 | float
Indirect mtrl cost | MtrlMoKost | ZtCost | 16 | 6 | float
Batch size manufacturing | PartistorlekTillv | ZtQty | 14 | 2 | decimal
Mfg grp deprec. | PgAvskrKost | ZtCost | 16 | 6 | float
Mfg grp fixed cost | PgFastKost | ZtCost | 16 | 6 | float
Mfg grp var cost | PgRorlKost | ZtCost | 16 | 6 | float
Mfg grp setup cost | PgStallKost | ZtCost | 16 | 6 | float
Calc manuf overhead cost | ProdOmkBelopp | ZtBaseCurrAmount | 14 | 2 | money
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Sim depr cost chg % | SimAndrProcAvskrKost | ZtDecimal73 | 8 | 3 | decimal
Sim flow grp cost chg% | SimAndrProcFlgKost | ZtDecimal73 | 8 | 3 | decimal
Sim subcontr cost chg % | SimAndrProcLegoKost | ZtDecimal73 | 8 | 3 | decimal
Sim wage cost change % | SimAndrProcLoneKost | ZtDecimal73 | 8 | 3 | decimal
Sim mtrl cost change % | SimAndrProcMtrlKost | ZtDecimal73 | 8 | 3 | decimal
Sim mfg grp cost chg % | SimAndrProcPgKost | ZtDecimal73 | 8 | 3 | decimal
Sim tool cost change % | SimAndrProcVTygKost | ZtDecimal73 | 8 | 3 | decimal
Total labour overhead | TotArbOmk | ZtCost | 16 | 6 | float
Total fixed labour OH | TotArbOmkFast | ZtCost | 16 | 6 | float
Labour OH op/total | TotArbOmkOp | ZtCost | 16 | 6 | float
Var OH labour total | TotArbOmkRorl | ZtCost | 16 | 6 | float
Total setup overhead | TotArbOmkStall | ZtCost | 16 | 6 | float
Indirect setup costs | TotArbStallBiKost | ZtCost | 16 | 6 | float
Total setup cost | TotArbStallKost | ZtCost | 16 | 6 | float
Indirect labour costs | TotArbStyckBiKost | ZtCost | 16 | 6 | float
Labour total | TotArbStyckKost | ZtCost | 16 | 6 | float
Total indir subcontr costs | TotLegoBiKost | ZtCost | 16 | 6 | float
Total subcontract cost | TotLegoKost | ZtCost | 16 | 6 | float
Total material cost | TotMtrlKost | ZtCost | 16 | 6 | float
Mtrl overhead total | TotMtrlMoKost | ZtCost | 16 | 6 | float
Mfg grp depr total | TotPgAvskrKost | ZtCost | 16 | 6 | float
Mfg grp fixed rate tot | TotPgFastKost | ZtCost | 16 | 6 | float
Mfg grp var cost total | TotPgRorlKost | ZtCost | 16 | 6 | float
Mfg grp setup cost | TotPgStallKost | ZtCost | 16 | 6 | float
Total tool depr | TotVyAvskrKost | ZtCost | 16 | 6 | float
Total tool fix cost | TotVyFastKost | ZtCost | 16 | 6 | float
Total tool var cost | TotVyRorlKost | ZtCost | 16 | 6 | float
Total tool setup cost | TotVyStallKost | ZtCost | 16 | 6 | float
Total tool unit cost | TotVyStyckKost | ZtCost | 16 | 6 | float
Item group | VarugruppKod | ztString | 8 |  | varchar
Tool deprec | VyAvskrKost | ZtCost | 16 | 6 | float
Fixed tool cost | VyFastKost | ZtCost | 16 | 6 | float
Var tool cost | VyRorlKost | ZtCost | 16 | 6 | float
Tool setup cost | VyStallKost | ZtCost | 16 | 6 | float
Tool unit cost | VyStyckKost | ZtCost | 16 | 6 | float

    This table is the main table in the following programs:

    Program: xArk Cost calculations, manufacturing items


Counter entry (mofr)

Definition of counter entries in an assignment. This function is part of the industry specific solution for client agencies which are used in order to see directly what counter entries there are for an assignment, for example in a legal process.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quote/agreement no. | Offnr | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: mofr Counter parties


Counters In JEEVES (JvsCntTable)

Name of counter for sequence numbers in Jeeves.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Name of counter | JvsCntName | ztString | 40 |  | varchar
Value on counter | JvsCntValue | Jeeves_InvNo | 20 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsCntTable Table with counter, sequence no


Country codes (xr)

Country codes according to international standard with an optional link to trade areas, e.g. link to the EU trade area for Intrastat statistics purposes.

The following standard records exist. Do not alter/delete:

Country (LandsKod) | Country (Land)
AL | Albania
AM | Armenia
AR | Argentina
AT | Austria
AU | Australia
BE | Belgium
BG | Bulgaria
BR | Brazil
CA | Canada
CH | Switzerland
CL | Chile
CN | China
CO | Colombia
CU | Cuba
CY | Cyprus
CZ | Czech Republic
DE | Germany
DK | Denmark
DO | The Dominican Republic
DZ | Algeria
EC | Ecuador
EE | Estonia
EG | Egypt
ES | Spain
ET | Ethiopia
FR | France
GB | United Kingdom
GH | Ghana
GI | Gibraltar
GL | Greenland
GM | Gambia
GR | Greece
HK | Hong Kong
HN | Honduras
HR | Croatia
HU | Hungary
ID | Indonesia
IE | Ireland
IL | Israel
IN | India
IQ | Iraq
IR | Iran
IS | Iceland
IT | Italy
JM | Jamaica
JO | Jordan
JP | Japan
KE | Kenya
KW | Kuwait
LK | Sri Lanka
LT | Lithuania
LU | Luxembourg
LV | Latvia
LY | Libya
MA | Morocco
MC | Monaco
MT | Malta
MX | Mexico
MY | Malaysia
MZ | Mozambique
NA | Namibia
NG | Nigeria
NI | Nicaragua
NL | Netherlands
NO | Norway
NZ | New Zealand
OM | Oman
PE | Peru
PH | The Philippines
PK | Pakistan
PL | Poland
PR | Puerto Rico
PT | Portugal
PY | Paraguay
RO | Romania
RU | Russia
SA | Saudi Arabia
SD | Sudan
SE | Sverige
SG | Singapore
SI | Slovenia
SK | Slovakia
SY | Syria
TH | Thailand
TM | Turkmenistan
TN | Tunisia
TR | Turkey
TW | Taiwan
UA | Ukraine
UG | Uganda
US | USA
VE | Venezuela
YE | Yemen
YU | Yugoslavia
ZA | South Africa
ZM | Zambia
ZW | Zimbabwe

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Bank acct check type | BankKontoTyp | ztString | 4 |  | varchar
This field is used in the table as follows: |
Create FHSN table | Create_FHSN | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Trading area | HandelsOmrKod | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
A 2 ID (ISO 3166) | ISO3166_A2 | ztString | 2 |  | varchar
A 3 ID (ISO 3166) | ISO3166_A3 | ztString | 3 |  | varchar
Number (ISO 3166) | ISO3166_N | ztInteger | 3 |  | smallint
Country | Land | ztString | 50 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Payment route | UtbetalningsVag | ztString | 6 |  | varchar
This field is used in the table as follows: |

    This table is the main table in the following programs:

    Program: Xxr Country codes


County (xn3)

Definition of counties or equivalent as per individual need for grouping/searching of companies in the company table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
County | laen | ztString | 5 |  | varchar
County | laenbeskr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xn3 County


Create opening balances (wing)

Data on the creation of opening balances for a new fiscal year.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Account profit/loss | InterimsKtoNrVinstForlust | ztString | 8 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Interim vouch no. | MVerNr | Jeeves_VchrNo | 9 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
New fiscal year | RedovisnArNew | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: XrarIngB Create opening balances


Created payment file log (jufl)

Log of batches for creating outgoing payment files.
The table is also used to check which dates have been used for outgoing payment files for Postal Giros.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Transmit to bank date | BankSandDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
PG manufacturing date | PostGiroProdDat | ztDate |  |  | datetime
PG manufacturing no. | PostGiroProdNr | ztInteger | 1 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Date/time | StrDateTime | ztString | 28 |  | varchar
Pmt file created by | UtbFileCreatedBy | ztString | 6 |  | varchar
Pmt file created date | UtbFileCreatedDt | ztDateTime |  |  | datetime
Period for prel pmt | UtbFilePeriod | ztInteger | 4 |  | smallint
Fiscal year | UtbFileRedovisnAr | ztInteger | 4 |  | smallint
AP payment file sent | UtbFileSend | ztBoolean |  |  | char
Expedited by | UtbFileSendBy | ztString | 6 |  | varchar
Sent date/time | UtbFileSendDt | ztDateTime |  |  | datetime
Voucher no. | UtbFileVerNr | Jeeves_VchrNo | 9 |  | bigint
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int

    This table is the main table in the following programs:

    Program: xJufl Created payment files


Credit block status (xks)

Table for different types of credit block statuses of orders in the order routine.

The following standard records exist. Do not alter/delete:

Credit block status (KreditSparrStatus) | Credit block status (KreditSparrStatusBeskr) | Description
0 | Approved at credit limit check | The order has undergone a credit limit check and has been approved.
1 | Manually approved after credit block | The order has been approved manually in spite of a credit block.
10 | Blocked at credit limit check | The order has been blocked automatically during a credit limit check.
11 | Manually blocked at credit limit check | The order has been blocked manually during a credit limit check.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Credit block status | KreditSparrStatus | ztInteger | 2 |  | smallint
Credit block status | KreditSparrStatusBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxks Credit block status


Credit limit check types (xkk)

Definition of applicable credit limit check types in the order routine.

If a credit limit is specified for a customer, a credit limit check type can also be specified for that customer. If no credit limit check type is specified, 0 (manual) is assumed.

The following standard records exist. Do not alter/delete:

Credit limit check type (KreditCheckTyp) | Credit limit check type (KreditCheckTypBeskr) | Description
0 | Manual choice of credit block | Means that, when credit limit is exceeded, you receive a question as to whether the current order should be credit blocked or not. If you answer Yes, the order is assigned credit status Blocked at credit limit check. If you answer No the order is assigned credit status Approved at credit limit check.
1 | Automatic credit block | Means that, when credit limit is exceeded, the order is blocked automatically. The order is assigned credit status Blocked at credit limit check.
2 | Cash on exceeded credit limit | Means that when credit limit is exceeded, a message is displayed that only cash orders can be entered. In other words, you can only enter orders with payment terms of 0 days' credit for the current customer, and you can only proceed with the order being entered if you change to such payment terms on the order header.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Credit limit check type | KreditCheckTyp | ztInteger | 2 |  | smallint
Credit limit check type | KreditCheckTypBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxkk Credit limit check types


Credit memo, changes (cmec)

Numeric code for change type for credit memo regarding supplier invoices.

Relevant fields are displayed depending on selected change type.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item description | ArtBeskr | ztString | 30 |  | varchar
Item description, corr | ArtBeskrKorr | ztString | 30 |  | varchar
Specification | ArtBeskrSpec | ztString | 30 |  | varchar
Specification, corr | ArtBeskrSpecKorr | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Account at bank | BankKonto | ztString | 40 |  | varchar
Account at bank, corr | BankKontoKorr | ztString | 40 |  | varchar
EU VAT/tax registration no. | EUMomsNr | ztString | 20 |  | varchar
EU VAT/tax reg no., corr | EUMomsNrKorr | ztString | 20 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company name | FtgNamn | ztString | 36 |  | varchar
Company name, corr | FtgNamnKorr | ztString | 36 |  | varchar
c/o address | FtgPostAdr1 | ztString | 36 |  | varchar
c/o address, corr | FtgPostAdr1Korr | ztString | 36 |  | varchar
Street addr/box | FtgPostAdr2 | ztString | 36 |  | varchar
Street addr/box, corr | FtgPostAdr2Korr | ztString | 36 |  | varchar
Town/City/State | FtgPostAdr3 | ztString | 36 |  | varchar
City, corr | FtgPostAdr3Korr | ztString | 36 |  | varchar
ZIP/Post code | FtgPostNr | ztString | 10 |  | varchar
ZIP/Post code, corr | FtgPostnrKorr | ztString | 10 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Early settlmt discnt % | KassaRab | ztFloat | 6 | 2 | float
Early settlmt discnt %, corr | KassaRabKorr | ztFloat | 6 | 2 | float
Change types, credit memo | KreditMemoAndrTyp | ztInteger | 5 |  | smallint
Credit memo number | KreditMemoNr | ZtLong | 10 |  | int
Bank Giro | LevBankGiro | ztBgNr | 11 |  | varchar
Bank giro, corr | LevBankgiroKorr | ztBgNr | 11 |  | varchar
Payment terms | LevBetVillK | ztString | 2 |  | varchar
Payment terms | LevBetVkBeskr | ztString | 50 |  | varchar
Payment condition, corr | LevBetvkBeskrKorr | ztString | 50 |  | varchar
Sale/delivery date | LevDatBest | ztDate |  |  | datetime
Sale/deliv.date, corr | LevDatBestKorr | ztDate |  |  | datetime
Invoice date | LevFaktDat | ztDate |  |  | datetime
Invoice date, corr | LevFaktDatKorr | ztDate |  |  | datetime
Plus giro no. | LevPostGiro | ztPgNr | 11 |  | varchar
Plus giro no., corr | LevPostgiroKorr | ztPgNr | 11 |  | varchar
Due date | LrFaktFfDat | ztDate |  |  | datetime
Due date, corr | LrFaktFFDatKorr | ztDate |  |  | datetime
Early settlmt discnt dt | LrFaktKRabDat | ztDate |  |  | datetime
Cashdisc.date, corr | LrFaktKRabDatKorr | ztDate |  |  | datetime
VAT/tax reg no. | MomsRegNr | ztString | 20 |  | varchar
VAT/tax reg no., corr | MomsRegNrKorr | ztString | 20 |  | varchar
Organization no. | OrgNr | ztString | 18 |  | varchar
Organization no., corr | OrgNrKorr | ztString | 18 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Credit memo, delivered invoices (cmed)

Suppliers' invoice number.

The number must be unique, i.e. you can not enter several invoices with the same number for the same supplier.

Exception: if you enter a number longer than 20 characters you can enter a number to replace the invoice number in the bank giro payment file. This is used for recurring tax payments to the same tax reference number.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Credit memo number | KreditMemoNr | ZtLong | 10 |  | int
Credit memo number, alpha | KreditMemoNrAlfa | ztString | 30 |  | varchar
Sale/delivery date | LevDatBest | ztDate |  |  | datetime
Invoice date | LevFaktDat | ztDate |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Credit memo, header (cmeh)

Numeric identity of a Credit memo, header. There is also a field for alphanumeric credit memo numbers.
Created automatically by the system by retrieving the last used number from the database + 1.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Comments | Kommentar | ztBlob | 1 |  | varchar
Credit memo, date | KreditMemoDatum | ztDate |  |  | datetime
Credit memo, ready-flag | KreditMemoKlarMark | ztBoolean |  |  | char
Credit memo, locked | KreditMemoLocked | ztBoolean |  |  | char
Credit memo, recipient | KreditMemoMottAvSign | ztString | 50 |  | varchar
Credit memo number | KreditMemoNr | ZtLong | 10 |  | int
Credit memo number, alpha | KreditMemoNrAlfa | ztString | 30 |  | varchar
Credit memo, issuer | KreditMemoUtfAvSign | ztString | 6 |  | varchar
Print.date, copy | KreditMemoUtskrDatKopia | ztDateTime |  |  | datetime
Print.date, original | KreditMemoUtskrDatOriginal | ztDateTime |  |  | datetime
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: cmeh Credit memos


Credit status type (xkf)

Table for credit status types for a special function for automatic credit checks in the sales ledger. Used to specify whether a credit block or warning should be set for a customer when due invoices exceed the minimum amount specified for the customer when running a function for automatic credit checks in the sales ledger.

The following standard records exist. Do not alter/delete:

Credit status type (KreditStatusTyp) | Credit status type (KreditStatusTypBeskr)
0 | Credit warning
1 | Credit block

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Credit status type | KreditStatusTyp | ztInteger | 2 |  | smallint
Credit status type | KreditStatusTypBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxkf Credit status types


Currencies (xx)

Definition of the currencies used in the system.

For each currency you can specify a number of calculation parameters, such as the number of decimals the currency should be rounded to when printing invoices, etc. You can also enter a mask for each currency if you wish to give amounts in the currency a certain appearance.

Every currency has three underlying exchange rate tables:

- In the left-hand embedded window Exchange rate, today's rate (table vak) you maintain today's rates which are used in invoicing, in ledgers and so on.

- In the middle embedded window Exchange rate, calculation rate (table vakk) you maintain the exchange rates for calculating cost prices and so on. The idea here is to be able to specify in advance rates used to calculate costs and so on. Using a function button you can then update purchase agreements with the latest specified calculation rate.

- In the right-hand embedded window Exchange rate, customs rate (table vakt) you maintain the exchange rates for conversion of invoiced value in foreign currency to base currency in the Intrastat report.

The main form also includes a field for the current exchange rate, but the rate is not retrieved from this field. Instead it is retrieved from the today's rate table or the calculation rate table. The purpose of this field is to facilitate calculations when producing reports (customized or via external tools) and to make it easier to build own SQL queries. However, the exchange rate entered in this field is automatically copied to the today's rate table and stored on the specified date.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
AP revaluation date | APRevaluationDate | ztDateTime |  |  | datetime
AR revaluation date | ARRevaluationDate | ztDateTime |  |  | datetime
Posting templ AP reval | AutoRegelAP | ztString | 4 |  | varchar
Posting templ AR reval | AutoRegelAR | ztString | 4 |  | varchar
Posting templ GL reval | AutoRegelGL | ztString | 4 |  | varchar
Currency, decimal places | CurrencyDecimals | ztInteger | 5 |  | smallint
Discount amount | DisAmount | ztMoney | 14 | 2 | money
Discount % | DisAmountProc | ztFloat | 15 | 2 | float
Mask | Editmask | ztString | 30 |  | varchar
EMU currency | EMU | ztBoolean |  |  | char
Euro rate | Eurokurs | ZtCurrencyRate | 11 | 6 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
GL revaluation date | GLRevaluationDate | ztDateTime |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Switch to curr in client | Klientvxl | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Prisavrundn.typ fakt.rad | PrisAvrundKodFaktRad | ztInteger | 2 |  | smallint
Rounding type inv.tot | PrisAvrundKodFaktTot | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate bank per | ValKursBankPer | ztInteger | 5 |  | smallint
Exchange rate | ValKursGrund | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate, operand | ValKursOp | ztInteger | 5 |  | smallint
Exchange rate unit | ValKursPer | ZtDecimal73 | 8 | 3 | decimal
Min amount revaluation | ValOmrAvrund | ZtBaseCurrAmount | 14 | 2 | money

    This table is the main table in the following programs:

    Program: xx Currency codes


Currencies on customer invoices (vKuv)

View of the kus table (Customers) and fh table (Customer invoice) which shows per customer number in which currencies the customer has invoices.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Payer, company ID | KundbetalareNr | ztCompanyNo | 20 |  | varchar
Language | SprakKod | ztInteger | 3 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar


Currencies, calculation rate (vakk)

Calculation exchange rate used for price calculations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Exchg rate date | ValDat | ztDate |  |  | datetime
Exchange rate, calc | ValKalkKurs | ZtCurrencyRate | 10 | 5 | decimal
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKursGrund | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate, operand | ValKursOp | ztInteger | 5 |  | smallint
Exchange rate unit | ValKursPer | ZtDecimal73 | 8 | 3 | decimal

    This table is the main table in the following programs:

    Program: vakk Calculated exchange rates


Currencies, customs rate (vakt)

Currency exchange rates set by customs for conversion of invoiced value in foreign currency to base currency in Intrastat reporting.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Exchg rate date | ValDat | ztDate |  |  | datetime
Exchange rate, calc | ValKalkKurs | ZtCurrencyRate | 10 | 5 | decimal
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKursGrund | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate, operand | ValKursOp | ztInteger | 5 |  | smallint
Exchange rate unit | ValKursPer | ZtDecimal73 | 8 | 3 | decimal


Currencies, today's rate (vak)

Current exchange rate, used when invoicing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Exchg rate date | ValDat | ztDate |  |  | datetime
Exchange rate, calc | ValKalkKurs | ZtCurrencyRate | 10 | 5 | decimal
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKursGrund | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate, operand | ValKursOp | ztInteger | 5 |  | smallint
Exchange rate unit | ValKursPer | ZtDecimal73 | 8 | 3 | decimal

    This table is the main table in the following programs:

    Program: vak Exchange rates (today's)


Currency clauses (xvx)

Definition of currency clauses to automatically adjust the sale price in connection with invoicing if a major change in exchange rates occurs between the time of ordering and the time of invoicing.

NOTE:
===========
If a currency clause is not used, the table will be empty, i.e. no definition with currency code 0 or similar can exist!

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Change in exch rate % | procBval | ztFloat | 6 | 2 | float
Row amount % to recalculate | ProcIval | ztFloat | 6 | 2 | float
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency clause | ValKlausul | ztInteger | 5 |  | smallint
Currency clause | ValKlausulB | ztString | 50 |  | varchar
Curr clause, Sales | ValKlausulFsg | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xvx Currency clause


Currency clauses, language (xvxs)

Language translations of descriptions of currency clauses.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Currency clause | ValKlausul | ztInteger | 5 |  | smallint
Currency clause | ValKlausulB | ztString | 50 |  | varchar


Currency reval per account (glko)

Balances for GL currency revaluation journals (per account).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Closing balance, BCU | ClBalBCU | ZtBaseCurrAmount | 14 | 2 | money
Closing balance curr | ClBalFCU | ztMoney | 14 | 2 | money
Debit amount | debbel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Journal no. | GlJournNo | ZtLong | 6 |  | int
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Credit amount | krebel | ZtBaseCurrAmount | 14 | 2 | money
Account | ktonr | ztString | 8 |  | varchar
Opening balance, BCU | OpBalBCU | ZtBaseCurrAmount | 14 | 2 | money
Opening balance curr | OpBalFCU | ztMoney | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Amount, curr | vbbelopp | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint


Currency revaluation - details (glvt)

GL currency revaluation details.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Amount curr | amountFCU | ztMoney | 14 | 2 | money
Base voucher row no. | BasVerRadpos | ztInteger | 4 |  | smallint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | bokfdat | ztDate |  |  | datetime
Created by object | createdbydbobject | ztString | 60 |  | varchar
Debit amount | debbel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | debkre | ztchar | 1 |  | char
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Remaining to pay BCU | FaktRestBel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Journal no. | GLJournno | ZtLong | 6 |  | int
Journal voucherno | GLVchrNo | Jeeves_VchrNo | 12 |  | bigint
Integration detail | intfield | ztInteger | 2 |  | smallint
Integration source | intsource | ztInteger | 3 |  | smallint
S4 | k4 | ztString | 8 |  | varchar
S5 | k5 | ztString | 8 |  | varchar
S6 | k6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
Cost unit | kostbar | ztString | 8 |  | varchar
Cost centre | koststallekod | ztString | 8 |  | varchar
Credit amount | krebel | ZtBaseCurrAmount | 14 | 2 | money
Account | ktonr | ztString | 8 |  | varchar
Ledger acct | KtoNrReskSaldo | ztString | 8 |  | varchar
Quantity | kvantitet | ztFloat | 9 | 2 | float
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Old exchange rate | OldExchangeRate | ZtCurrencyRate | 15 | 7 | decimal
Period | period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | projcode | ztString | 10 |  | varchar
Row | radpos | ZtLong | 10 |  | int
Fiscal year | redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Amount, curr | vbbelopp | ztMoney | 14 | 2 | money
Outst invc amt, curr | VbFaktRest | ztMoney | 14 | 2 | money
Voucher no. | vernr | Jeeves_VchrNo | 9 |  | bigint


Currency summary, subsidiary ledger (reva)

This table is for storing currency summaries for different ledger lists.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Not due | Age_0 | ZtBaseCurrAmount | 14 | 2 | money
Total | Age_05 | ZtBaseCurrAmount | 14 | 2 | money
Total rem amount BCU | Age_05Bas | ZtBaseCurrAmount | 14 | 2 | money
Due -1 | Age_1 | ZtBaseCurrAmount | 14 | 2 | money
Total not yet due | Age_15 | ZtBaseCurrAmount | 14 | 2 | money
Total not due, BCU | Age_15Bas | ZtBaseCurrAmount | 14 | 2 | money
Due -2 | Age_2 | ZtBaseCurrAmount | 14 | 2 | money
Due -3 | Age_3 | ZtBaseCurrAmount | 14 | 2 | money
Due -4 | Age_4 | ZtBaseCurrAmount | 14 | 2 | money
Due - 5 | Age_5 | ZtBaseCurrAmount | 14 | 2 | money
Due | Age_Due | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Acc rec/Acc pay | KRorLR | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal


Cust def terms etc. (yext)

Different types of customer specific settings in respect of terms and fields. The type is governed by a code specified in the field 'Setting type' (Ztype) as follows:
1 = Added terms in the system
2 = Added fields in tables
3 = Edited terms (i.e. own prompts, column headings, lengths and masks) and hidden terms
4 = Added fields in reports
6 = Special setting type for defining a graphical view in a list window (only Net Kernel)
7 = Term linked to a macro

Choose from personal/global: No
Per company: No

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Site-settings | Descr | ztBlob | 1 |  | text
ID setting | Id1 | ztString | 40 |  | nvarchar
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Setting type | zType | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: yext Own terms etc.


Cust no. change on invoice (fhnk)

Invoices that are affected by a customer number change.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Journal no. cust no. change | FnkJournNr | ZtLong | 6 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Prev invoice no. | OldFaktNr | Jeeves_InvNo | 9 |  | bigint
Original payer | OldKundBetalareNr | ztCompanyNo | 20 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar


Cust no./agreement (shta)

Table for storing the customers that can use an agreement.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Assignment in Agreement | AgrNoInclude | ztString | 10 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Customer | KundNr | ztCompanyNo | 20 |  | varchar
Quote/agreement no. | Offnr | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Cust order picking list journal (jkpl)

Table of journal data linking picking list printouts for a customer order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Volume m3 | ArtVolym | ztFloat | 15 | 4 | float
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Del note print date | FSUtskrDat | ztDateTime |  |  | datetime
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Plock t.o.m. datum | JkplTomDatum | ztDate |  |  | datetime
Inventory location | LagStalle | ztString | 2 |  | varchar
This field is used in the table as follows: |
Gross weight, kg, deliv | LevArtBtotVikt | ztFloat | 10 | 3 | float
Net weight , deliv | LevArtVikt | ztFloat | 10 | 3 | float
Volume, m³, deliv | LevArtVolym | ztFloat | 15 | 2 | float
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
This field is used in the table as follows: |
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
This field is used in the table as follows: |
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
This field is used in the table as follows: |
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
This field is used in the table as follows: |
Signature | PersSign | ztString | 30 |  | varchar
Picking index for order | PlockIndexOrder | ZtLong | 10 |  | int
Picking list no. | PlockJnrOrder | ZtLong | 10 |  | int
Picking list status | Plockjnrstat | ztInteger | 5 |  | smallint
Picking list date | PLUtskrDat | ztDateTime |  |  | datetime
Entry date | RegDat | ztDate |  |  | datetime
Gross weight, kg, remain value | RestArtBtotVikt | ztFloat | 10 | 3 | float
Net weight, kg, remain value | RestArtVikt | ztFloat | 10 | 3 | float
Volume, remain value | RestArtVolym | ztFloat | 15 | 2 | float
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Language | SprakKod | ztInteger | 3 |  | smallint
Carrier code | TransportorsKod | ztString | 17 |  | varchar

    This table is the main table in the following programs:

    Program: JkplUtPl Pick reporting, part picking list

    Program: JkplUtPl_All Pick reporting, part picking list, all


Customer categories (x1k)

Definition of customer categories that can be used to group/classify customers.

You can use the categorization in posting templates to link customers to different accounts receivable depending on category. From version 8 service pack 2, you can also use customer categories to indicate which categories you want to have separate accounting of internal sales (described in a separate chapter).

Customer category 0 must be entered in this table because certain checks are performed on that number.

The following standard records exist. Do not alter/delete:

Customer category (KundKategoriKod) | Customer category (KundKatBeskr)
0 | Domestic customers

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Internal sales type | InternFsgTyp | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Customer category | KundKatBeskr | ztString | 50 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: Xx1k Customer categories


Customer claims (ork)

Claims, e.g. protests and opinions about customer items.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Revision date | ArtRevDat | ztDate |  |  | datetime
Revision no. | ArtRevId | ztString | 10 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Department | AvdelningsBeskr | ztString | 50 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Replacement | ByteKund | ztBoolean |  |  | char
Replacement supplier | ByteLev | ztBoolean |  |  | char
Actual finish date | ClaimActEndDt | ztDate |  |  | datetime
Activity status | ClaimActivityStatus | ztInteger | 4 |  | smallint
Claimed actual qty | ClaimActQty | ZtQty | 14 | 2 | decimal
Claim expense | ClaimCostTotal | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 1 | ClaimCostType1 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 2 | ClaimCostType2 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 3 | ClaimCostType3 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 4 | ClaimCostType4 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 5 | ClaimCostType5 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 6 | ClaimCostType6 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 7 | ClaimCostType7 | ZtBaseCurrAmount | 14 | 2 | money
Claim | ClaimNo | ZtLong | 10 |  | int
Counterpart claim number | ClaimNoCounterPart | ztString | 30 |  | varchar
Planned finish date | ClaimPlEndDt | ztDate |  |  | datetime
Claimed quantity | ClaimQty | ZtQty | 14 | 2 | decimal
Revised quantity | ClaimRepairQty | ZtQty | 14 | 2 | decimal
Claim manager | ClaimResp | ztString | 8 |  | varchar
Scrapped qty | ClaimScrapQty | ZtQty | 14 | 2 | decimal
Claim origination | ClaimSrcCd | ztInteger | 5 |  | smallint
Claim origination | ClaimSrcDescr | ztString | 60 |  | varchar
Activity order | ClaimWFSeqNo | ztInteger | 5 |  | smallint
Claim flow | ClaimWorkFlow | ZtLong | 10 |  | int
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Planned activity descr | EventNote | ztString | 60 |  | varchar
Report date | EventRpDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Cust claim reason | KundReklamationOrsak | ztInteger | 5 |  | smallint
Cust claim reason group | KundReklamationOrsakGrp | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Price | Pris | ZtBaseCurrAmount | 14 | 2 | money
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Quality Categori (MO/PO/SO) | Qkategori | ztInteger | 5 |  | smallint
Quality to do no. | QualityCheckToDo_No | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Rejected item sellable | RekArtSaljbar | ztBoolean |  |  | char
RMA number | RMAnr | ztString | 30 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Salesperson name | SaljareNamn | ztString | 40 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Unique ID link | WfRowUniqueID | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: ork Customer claims

    Program: rOrkAr Claims, item, date

    Program: rOrkArO Claims, item, reason

    Program: rOrkKus Customer claims

    Program: rOrkOAr Claim reason, item


Customer class (x1kk)

Customer classification.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Customer class | Kundklass | ztString | 12 |  | varchar
Customer class | KundKlassBeskr | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: x1kk Customer classes


Customer discount class (xrbk)

Definition of customer discount classes which can be used to group several customers who are to have similar discount management. You can specify in the customer table which discount class the customer will belong to.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Cust discount class | RabKlass | ztInteger | 3 |  | smallint
Cust discount class | RabKlassBeskr | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xrbk Discount class, customer


Customer information per contact (vkpkus)

Numerical ID for a contact within an internal or external company.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Payment terms | BetKod |  |  |  | @DataType=NULL
Payment terms | BetVillBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | ftgkontaktnr | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Customer category | kundkatbeskr | ztString | 50 |  | varchar
Customer category | kundkategorikod | ztInteger | 2 |  | smallint
Customer class | kundklass | ztInteger | 2 |  | smallint
Customer class | kundklassbeskr | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Customer invoice header (fh)

Data in the header of the customer invoice.
A row is created in this table for each invoice.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accept code payment | AcceptCodePayment | ztString | 30 |  | varchar
Posting complete | AccountingDone | ztBoolean |  |  | char
On account to invoice number | AContoFaktNr | Jeeves_InvNo | 8 |  | bigint
On account to order number | AContoOrderNr | Jeeves_SONo | 8 |  | bigint
Full advance pmt | AdvDeduction | ztBoolean |  |  | char
Direct debit journal no. | AgJournNr | ZtLong | 6 |  | int
No. of EUR pallets | AntalEURPall | ztInteger | 5 |  | smallint
No. of packages | AntalKolli | ztInteger | 5 |  | smallint
Orders on invc | AntalOrder | ztInteger | 2 |  | smallint
No. of other pallets | AntalOvrPall | ztInteger | 5 |  | smallint
Number of assignments on inv | AntalUppdrag | ztInteger | 2 |  | smallint
Days fr due dt to pmt | AntDgrSedanFfDat | ZtLong | 7 |  | int
AR revaluation date | ARRevaluationDate | ztDateTime |  |  | datetime
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Volume m3 | ArtVolym | ztFloat | 15 | 4 | float
Amount to pay | AttBetalaBelopp | ZtBaseCurrAmount | 14 | 2 | money
Direct debit creation dt | AutoGiroDat | ztDate |  |  | datetime
Autogiro | AutoGiroKod | ztBoolean |  |  | char
Posting template | AutoRegel | ztString | 4 |  | varchar
Posting template, advance | AutoRegelForskott | ztString | 4 |  | varchar
Injunction no. | BetForelaggandeNr | ZtLong | 4 |  | int
Payment terms | BetKod | ztString | 2 |  | varchar
Reserved in journal | BilagsMark | ztBoolean |  |  | char
Bill of exchange no. | BoE_No | ZtLong | 9 |  | int
BOE status | BoE_Status | ztInteger | 5 |  | smallint
Accounting date | BokfDat | ztDate |  |  | datetime
Specified gross wght | BruttoVikt | ztFloat | 10 | 3 | float
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Early stlmt dsct basis curr | CashDiscBaseFCU | ztMoney | 14 | 2 | money
VAT bas early settlmt discnt curr | CashDiscBaseFCU_VAT | ztMoney | 14 | 2 | money
Check status | Check_Status | ztInteger | 2 |  | smallint
Create FHSN table | Create_FHSN | ztBoolean |  |  | char
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Credit card number | CreditCardNumber | ztString | 30 |  | varchar
VAT/tax GL date | DateOfTaxSupply | ztDate |  |  | datetime
Delivery to business unit | DelivToBusinessUnit | ztString | 8 |  | varchar
Division code | DivisKod | ztString | 3 |  | varchar
Penalty interest % | DrRtaProc | ZtDecimal73 | 5 | 2 | decimal
eBrev sent | ebfilsent | ztBoolean |  |  | char
eBrev file sent date | ebfilsentdt | ztDateTime |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Packaging BCU | EmballageKostnad | ZtBaseCurrAmount | 14 | 2 | money
Packaging inland, BCU | EmballageKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Körtid, skapa arbetsorder | ExecutionTimeCreateInv | ztFloat | 15 | 2 | float
Handling charge BCU | ExpeditionKostnad | ZtBaseCurrAmount | 14 | 2 | money
Invoiced by | FaktAvPersSign | ztString | 6 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice book date | FaktDat2BokfDat | ztDate |  |  | datetime
Invoice date/time | FaktDateTime | ztDateTime |  |  | datetime
Invoice date, change | FaktDatKorr | ztDate |  |  | datetime
Invoice date, original | FaktDatOrg | ztDate |  |  | datetime
Due date | FaktFfDat | ztDate |  |  | datetime
Paid amount BCU | FaktInbBel | ZtBaseCurrAmount | 14 | 2 | money
Paid amt booked, BCU | FaktInbBokfBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
CSG invoice | FaktKost | ZtBaseCurrAmount | 14 | 2 | money
Sales tax | FaktMoms | ZtBaseCurrAmount | 14 | 2 | money
Paid VAT/tax posted, BCU | FaktMomsInbBokfBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice reference no. | FaktNr_OCR | ztString | 40 |  | varchar
Invoice bar code | FaktNr_StreckKod | ztString | 100 |  | varchar
Invoice no, on account | FaktNrAConto | Jeeves_InvNo | 9 |  | bigint
Invoice no., change | FaktNrKorr | Jeeves_InvNo | 9 |  | bigint
Invoice no., original | FaktNrOrg | Jeeves_InvNo | 9 |  | bigint
VAT/tax original invc | FaktNrOrg_Moms | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax curr orig invc | FaktNrOrg_VbMoms | ztMoney | 14 | 2 | money
CSG invoice, std cost | FaktStdKost | ZtBaseCurrAmount | 14 | 2 | money
Margin, std cost | FaktStdKostTB | ZtBaseCurrAmount | 14 | 2 | money
Degree of margin, std cost | FaktStdKostTG | ZtDecimal73 | 8 | 3 | decimal
Invoice status | FaktStKod | ztInteger | 2 |  | smallint
Margin | FaktTB | ZtBaseCurrAmount | 14 | 2 | money
Degree of margin | FaktTG | ZtDecimal73 | 8 | 3 | decimal
Invc tot ded.adv, BCU | FaktTotAvdrForskottBas | ZtBaseCurrAmount | 14 | 2 | money
Invc tot ded adv curr | FaktTotAvdrForskottVal | ztMoney | 14 | 2 | money
Invc tot excl adv, BCU | FaktTotExklForskottBas | ZtBaseCurrAmount | 14 | 2 | money
Invc tot excl adv curr | FaktTotExklForskottVal | ztMoney | 14 | 2 | money
Invoice total incl tax | FaktTotMMoms | ZtBaseCurrAmount | 14 | 2 | money
Summa rabatt | FaktTotRabatt | ZtBaseCurrAmount | 14 | 2 | money
Invoice total excl tax | FaktTotUMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice type | FakturaTyp | ztInteger | 3 |  | smallint
Invoice source, code | FaktUrsprKod | ztInteger | 5 |  | smallint
Exchange rate at inv date | FaktValKurs | ZtCurrencyRate | 15 | 7 | decimal
Delivery note/disp no. | FfhNr | ZtLong | 10 |  | int
Invoice print date | FhUtskrDat | ztDateTime |  |  | datetime
Delivery note reference | FoljesedelsRef | ztString | 17 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Insurance BCU | ForsakringsKostnad | ZtBaseCurrAmount | 14 | 2 | money
Insurance inland, BCU | ForsakrKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Adv amt incl tax, BCU | ForskottBelopp | ZtBaseCurrAmount | 14 | 2 | money
Acc advance amt, BCU | ForskottBeloppAck | ZtBaseCurrAmount | 14 | 2 | money
Ded advance amt, BCU | ForskottBeloppAvdr | ZtBaseCurrAmount | 14 | 2 | money
Adv amt excl tax, BCU | ForskottBeloppExklMoms | ZtBaseCurrAmount | 14 | 2 | money
Remaining adv amt, BCU | ForskottBeloppRest | ZtBaseCurrAmount | 14 | 2 | money
Accum rem adv amt, BCU | ForskottBelRestAck | ZtBaseCurrAmount | 14 | 2 | money
Advance, post | ForskottBokfKrsk | ztBoolean |  |  | char
Advance on account | ForskottFaktAconto | ztBoolean |  |  | char
Advance invoice | ForskottFaktura | ztBoolean |  |  | char
Advance, post VAT/tax | ForskottMomsBokf | ztBoolean |  |  | char
Adv amt received date | ForskottMottagetDatum | ztDate |  |  | datetime
Advance from order no. | ForskottOrderNr | Jeeves_SONo | 8 |  | bigint
Deduction order-lnkd adv | ForskottOrdKopplTyp | ztInteger | 2 |  | smallint
Adv paid on delivery | ForskottSlutBetVidLev | ztBoolean |  |  | char
Freight charge code | FraktAvgKd | ztBoolean |  |  | char
Auto calc freight BCU | FraktKostnBer | ZtBaseCurrAmount | 14 | 2 | money
Total freight BCU | FraktKostnDeb | ZtBaseCurrAmount | 14 | 2 | money
Freight inland, BCU | FraktKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Man calc freight BCU | FraktKostnMan | ZtBaseCurrAmount | 14 | 2 | money
Gross frght weight kg | FraktVikt | ztFloat | 10 | 3 | float
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Third party trade | Handel3Part | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Deducted amount BCU | InbAvdrag | ZtBaseCurrAmount | 14 | 2 | money
Payment date | InbDat | ztDate |  |  | datetime
Early settlmt discnt BCU | InbKassaRab | ZtBaseCurrAmount | 14 | 2 | money
Inb momsbelopp | InbMomsBelopp | ZtBaseCurrAmount | 14 | 2 | money
Payment method | InbSlag | ztString | 3 |  | varchar
Collection no. | InkassoNr | ZtLong | 4 |  | int
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Inv amt in words | InvoiceAmountAsString | ztString | 255 |  | varchar
Amendment invoicing | InvoiceChange | ztBoolean |  |  | char
S4 | K4 | ztString | 8 |  | varchar
S-4 f ledg.balance | K4ReskSaldo | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S5 f ledg.balance | K5ReskSaldo | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S6 f ledg.Bal | K6ReskSaldo | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S7 f ledg.balance | K7ReskSaldo | ztString | 8 |  | varchar
Cash reconciliation ID | KassaAvstID | ztString | 30 |  | varchar
Early settlmt discnt % | KassaRab | ztFloat | 6 | 2 | float
Calc early settlmt discnt BCU | KassaRabBas_calc | ZtBaseCurrAmount | 14 | 2 | money
Cost unit f ledg.balance | KBarReskSaldo | ztString | 8 |  | varchar
Cash invoice | KontantFaktura | ztBoolean |  |  | char
Copied to order | KopieradTillOrderNr | Jeeves_SONo | 8 |  | bigint
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
No. of reminders | KravAnt | ztInteger | 1 |  | smallint
Reminder code | KravKd | ztBoolean |  |  | char
Date last reminder | KravSenUtskr | ztDate |  |  | datetime
Block reminders until | KravSparrTomDat | ztDate |  |  | datetime
Early settlmt discnt date | KrFaktKRabDat | ztDate |  |  | datetime
Momskostnadsställe | KstMoms | ztString | 8 |  | varchar
Balance sheet CC | KstReskSaldo | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Momskonto | KtoNrMoms | ztString | 8 |  | varchar
Ledger acct | KtoNrReskSaldo | ztString | 8 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Calculation Tax | KundMomsBer | ztBoolean |  |  | char
Customer reference | KundRef2 | ztString | 30 |  | varchar
Text on PO | KundSpecTextBe | ztBoolean |  |  | char
Text on invoice | KundSpecTextFa | ztBoolean |  |  | char
Text on delivery note | KundSpecTextFs | ztBoolean |  |  | char
Text on order acknowledgement | KundSpecTextOe | ztBoolean |  |  | char
Text on picking list | KundSpecTextPl | ztBoolean |  |  | char
Text on mfg/works order | KundSpecTextTo | ztBoolean |  |  | char
Customer specific text | KundTextKod | ztString | 4 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Proof of ID number | LegitimationNumber | ztString | 30 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Tax amount 0 | MomsBelopp0 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 1 | MomsBelopp1 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 2 | MomsBelopp2 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 3 | MomsBelopp3 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 4 | MomsBelopp4 | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax amt curr 0 | MomsBeloppVal0 | ztMoney | 14 | 2 | money
VAT/tax amt curr 1 | MomsBeloppVal1 | ztMoney | 14 | 2 | money
VAT/tax amt curr 2 | MomsBeloppVal2 | ztMoney | 14 | 2 | money
VAT/tax amt curr 3 | MomsBeloppVal3 | ztMoney | 14 | 2 | money
VAT/tax amt curr 4 | MomsBeloppVal4 | ztMoney | 14 | 2 | money
Tax date | MomsDatum | ztDate |  |  | datetime
Tax basis 0 | MomsGrundBelopp0 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 1 | MomsGrundBelopp1 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 2 | MomsGrundBelopp2 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 3 | MomsGrundBelopp3 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 4 | MomsGrundBelopp4 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis curr 0 | MomsGrundBeloppVal0 | ztMoney | 14 | 2 | money
Tax basis curr 1 | MomsGrundBeloppVal1 | ztMoney | 14 | 2 | money
Tax basis curr 2 | MomsGrundBeloppVal2 | ztMoney | 14 | 2 | money
Tax basis curr 3 | MomsGrundBeloppVal3 | ztMoney | 14 | 2 | money
Tax basis curr 4 | MomsGrundBeloppVal4 | ztMoney | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax 0 | MomsKod0 | ztInteger | 5 |  | smallint
VAT/tax 1 | MomsKod1 | ztInteger | 5 |  | smallint
VAT/tax 2 | MomsKod2 | ztInteger | 5 |  | smallint
VAT/tax 3 | MomsKod3 | ztInteger | 5 |  | smallint
VAT/tax 4 | MomsKod4 | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
VAT/tax rate 0 | MomsSats0 | ZtDecimal73 | 6 | 2 | decimal
VAT/tax rate 1 | MomsSats1 | ZtDecimal73 | 6 | 2 | decimal
VAT/tax rate 2 | MomsSats2 | ZtDecimal73 | 6 | 2 | decimal
VAT/tax rate 3 | MomsSats3 | ZtDecimal73 | 6 | 2 | decimal
VAT/tax rate 4 | MomsSats4 | ZtDecimal73 | 6 | 2 | decimal
Amount received | MottagetBelopp | ZtBaseCurrAmount | 14 | 2 | money
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order No., change | OrderNrKorr | Jeeves_SONo | 8 |  | bigint
Order No., original | OrderNrOrg | Jeeves_SONo | 8 |  | bigint
Delivery note no. | OrdFoljesedelsNr | ZtLong | 10 |  | int
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Delivery addr, company | OrdLevAdr1 | ztString | 36 |  | varchar
Delivery address 1 | OrdLevAdr2 | ztString | 36 |  | varchar
Delivery address 2 | OrdLevAdr3 | ztString | 36 |  | varchar
Delivery address 3 | OrdLevAdr4 | ztString | 36 |  | varchar
Destination, district | OrdLevAdrBstOrt | ztString | 36 |  | varchar
Destination, country | OrdLevAdrLandsKod | ztString | 3 |  | varchar
State code | OrdlevAdrProvinceCode | ztString | 5 |  | varchar
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Order type, amendment order | OrdTypFaktKorr | ztInteger | 3 |  | smallint
Orderns valutakurs | OrdValKurs | ZtCurrencyRate | 15 | 7 | decimal
Dispatched on, actual | OrdVerklLevDat | ztDate |  |  | datetime
Rounding | OresUtj | ZtBaseCurrAmount | 5 | 2 | money
Other inv. cost-1 BCU | OvrFaktAvgift1 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-10 BCU | OvrFaktAvgift10 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-2 BCU | OvrFaktAvgift2 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-3 BCU | OvrFaktAvgift3 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-4 BCU | OvrFaktAvgift4 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-5 BCU | OvrFaktAvgift5 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-6 BCU | OvrFaktAvgift6 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-7 BCU | OvrFaktAvgift7 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-8 BCU | OvrFaktAvgift8 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-9 BCU | OvrFaktAvgift9 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-1 BCU | OvrFaktKostnad1 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-2 BCU | OvrFaktKostnad2 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-1 inland, BCU | OvrFaktKostnInland1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 inland, BCU | OvrFaktKostnInland2 | ZtBaseCurrAmount | 14 | 2 | money
Print date | p_Utskr_Dat | ztDate |  |  | datetime
Print date/time | p_Utskr_DatTid | ztDateTime |  |  | datetime
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fakturering avslutad | Proc_oh_2_fh_end | ztDateTime |  |  | datetime
Fakturering tidsåtgång | Proc_oh_2_fh_Seconds | ZtLong | 10 |  | int
Fakturering startad | Proc_oh_2_fh_start | ztDateTime |  |  | datetime
Project ID | ProjCode | ztString | 10 |  | varchar
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Reference number | ReferensNr | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Acceptance journal | RemJrnlNo | ZtLong | 9 |  | int
Report template | ReportTemplate | ztString | 255 |  | varchar
Remaining to pay | Restbelfakt | ZtBaseCurrAmount | 14 | 2 | money
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Last interest calc | RtaSenBer | ztDate |  |  | datetime
Interest invoice | RteFaktKd | ztBoolean |  |  | char
Account | ru_account | ztString | 20 |  | varchar
Sales tax handling | SalesTaxHandling | ztBoolean |  |  | char
Salesperson | Saljare | ztString | 6 |  | varchar
SBI number | SBINr | ztString | 25 |  | varchar
Send EDI | SendEdi | ztBoolean |  |  | char
Sent EDI | SendEdiDT | ztDateTime |  |  | datetime
Serv.order no | ServOrderNr | Jeeves_SONo | 9 |  | bigint
Language | SprakKod | ztInteger | 3 |  | smallint
Time sqlcmd->trg start | SQLCmd2EnterTrg | ZtLong | 10 |  | int
Tax area level 1 | TaxAreaCode1 | ztString | 10 |  | varchar
Tax area level 2 | TaxAreaCode2 | ztString | 10 |  | varchar
Tax area level 3 | TaxAreaCode3 | ztString | 10 |  | varchar
Tax area level 4 | TaxAreaCode4 | ztString | 10 |  | varchar
Tax area level 5 | TaxAreaCode5 | ztString | 10 |  | varchar
Sales tax code | TaxCode | ztInteger | 2 |  | smallint
Forward rate | TerminsKurs | ZtCurrencyRate | 11 | 6 | decimal
Forward contract | TerminsNr | ZtLong | 10 |  | int
Text after document rows | TextEfterDokRader | ztBoolean |  |  | char
Amount back | TillbakaBelopp | ZtBaseCurrAmount | 14 | 2 | money
Basis def | UDef | ZtLong | 3 |  | int
Basis no. | UNr | ZtLong | 6 |  | int
Tax in 3rd currency | V3_FaktMoms | ztMoney | 14 | 2 | money
Invc amt in 3rd currency | V3_FaktSum | ztMoney | 14 | 2 | money
Invc tot excl tax, 3rd ccy | V3_FaktTotUMoms | ztMoney | 14 | 2 | money
Third currency | V3_ValKod | ztString | 3 |  | varchar
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax exchange rate | VATExchRate | ZtCurrencyRate | 15 | 7 | decimal
Packaging, curr | vb_EmballageKostnad | ztMoney | 14 | 2 | money
Packaging inland, curr | vb_EmballageKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Handling charge curr | vb_ExpeditionKostnad | ztMoney | 14 | 2 | money
Invoice amount, curr | vb_faktsum | ztMoney | 14 | 2 | money
Insurance, curr | vb_ForsakringsKostnad | ztMoney | 14 | 2 | money
Insurance inland, curr | vb_ForsakrKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Adv amt incl tax, curr | vb_ForskottBelopp | ztMoney | 14 | 2 | money
Accum adv amt, curr | vb_ForskottBeloppAck | ztMoney | 14 | 2 | money
Ded advance amt, curr | vb_ForskottBeloppAvdr | ztMoney | 14 | 2 | money
Adv amt excl tax, curr | vb_ForskottBeloppExklMoms | ztMoney | 14 | 2 | money
Remaining adv amt, curr | vb_ForskottBeloppRest | ztMoney | 14 | 2 | money
Accum rem adv amt, curr | vb_ForskottBelRestAck | ztMoney | 14 | 2 | money
Auto calc freight, curr | vb_FraktKostnBer | ztMoney | 14 | 2 | money
Total freight, curr | vb_FraktKostnDeb | ztMoney | 14 | 2 | money
Freight inland, curr | vb_FraktKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Man calc freight, curr | vb_FraktKostnMan | ztMoney | 14 | 2 | money
Rounding off, curr | Vb_OresUtj | ztMoney | 14 | 2 | money
Other invc cost-1, curr | vb_OvrFaktAvgift1 | ztMoney | 14 | 2 | money
Other invc cost-10, curr | vb_OvrFaktAvgift10 | ztMoney | 14 | 2 | money
Other invc cost-2, curr | vb_OvrFaktAvgift2 | ztMoney | 14 | 2 | money
Other invc cost-3, curr | vb_OvrFaktAvgift3 | ztMoney | 14 | 2 | money
Other invc cost-4, curr | vb_OvrFaktAvgift4 | ztMoney | 14 | 2 | money
Other invc cost-5, curr | vb_OvrFaktAvgift5 | ztMoney | 14 | 2 | money
Other invc cost-6, curr | vb_OvrFaktAvgift6 | ztMoney | 14 | 2 | money
Other invc cost-7, curr | vb_OvrFaktAvgift7 | ztMoney | 14 | 2 | money
Other invc cost-8, curr | vb_OvrFaktAvgift8 | ztMoney | 14 | 2 | money
Other invc cost-9, curr | vb_OvrFaktAvgift9 | ztMoney | 14 | 2 | money
Other invc cost-1, curr | vb_OvrFaktKostnad1 | ztMoney | 14 | 2 | money
Other invc cost-2, curr | vb_OvrFaktKostnad2 | ztMoney | 14 | 2 | money
Extra cost-1 inland, curr | vb_OvrFaktKostnInland1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 inland, curr | vb_OvrFaktKostnInland2 | ZtBaseCurrAmount | 14 | 2 | money
Outstanding amt, curr | vb_restbelf | ztMoney | 14 | 2 | money
Amount paid, curr | VbFaktInbBel | ztMoney | 14 | 2 | money
Paid amt booked, curr | VbFaktInbBokfBel | ztMoney | 14 | 2 | money
VAT/tax, curr | VbFaktMoms | ztMoney | 14 | 2 | money
Paid VAT/tax posted, curr | VbFaktMomsInbBokfBel | ZtBaseCurrAmount | 14 | 2 | money
Outst invc amt, curr | VbFaktRest | ztMoney | 14 | 2 | money
Summa rabatt i valuta | vbFaktTotRabatt | ztMoney | 14 | 2 | money
Invoice total excl tax | VbFaktTotUMoms | ztMoney | 14 | 2 | money
Deducted amount, curr | vbInbAvdrag | ztMoney | 11 | 2 | money
Inb momsbelopp | VbInbMomsBelopp | ztMoney | 14 | 2 | money
Early settlmt discnt, curr | VbKassaRab | ztMoney | 14 | 2 | money
Calc early settlmt discnt curr | VbKassaRab_Calc | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Weight/volume automatic | ViktSumOrder | ztBoolean |  |  | char
Volume | Volume | ztFloat | 10 | 3 | float
Our reference | VRef | ztString | 30 |  | varchar
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint
Template | YndMall | ztString | 40 |  | varchar
Deleted | zDeleted | ztInteger | 1 |  | smallint
This field is used in the table as follows: |

    This table is the main table in the following programs:

    Program: bFhVt Create invoicing journal

    Program: fh Customer invoices

    Program: Fh2GL Customer invoices->GL

    Program: fhKAvst Customer invoice, cash reconciliation

    Program: fhkorr Create amendment order from invoice

    Program: fhkred Create credit order from invoice

    Program: FktForsk Invoice, link to advance

    Program: FskAConto Advance, link to On-account invoice

    Program: FskFakt Advance, link to invoice

    Program: FskOrder Advance, link to order


Customer invoice header VIEW (vfh)

View of the fh table (Customer invoices).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Orders on invc | AntalOrder | ztInteger | 2 |  | smallint
Days fr due dt to pmt | AntDgrSedanFfDat | ZtLong | 7 |  | int
Posting template | AutoRegel | ztString | 4 |  | varchar
Payment terms | BetKod | ztString | 2 |  | varchar
Division code | DivisKod | ztString | 3 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Due date | FaktFfDat | ztDate |  |  | datetime
Paid amount BCU | FaktInbBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
CSG invoice | FaktKost | ZtBaseCurrAmount | 14 | 2 | money
Sales tax | FaktMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice status | FaktStKod | ztInteger | 2 |  | smallint
Invoice total incl tax | FaktTotMMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice total excl tax | FaktTotUMoms | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight charge code | FraktAvgKd | ztBoolean |  |  | char
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Payment date | InbDat | ztDate |  |  | datetime
Integration source | IntSource | ztInteger | 3 |  | smallint
Early settlmt discnt % | KassaRab | ztFloat | 6 | 2 | float
Cost centre | KostStalleKod | ztString | 8 |  | varchar
No. of reminders | KravAnt | ztInteger | 1 |  | smallint
Reminder code | KravKd | ztBoolean |  |  | char
Early settlmt discnt date | KrFaktKRabDat | ztDate |  |  | datetime
Ledger acct | KtoNrReskSaldo | ztString | 8 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Rounding | OresUtj | ZtBaseCurrAmount | 5 | 2 | money
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Remaining to pay | Restbelfakt | ZtBaseCurrAmount | 14 | 2 | money
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Interest invoice | RteFaktKd | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Invoice amount, curr | vb_faktsum | ztMoney | 14 | 2 | money
Outstanding amt, curr | vb_restbelf | ztMoney | 14 | 2 | money
Amount paid, curr | VbFaktInbBel | ztMoney | 14 | 2 | money
Outst invc amt, curr | VbFaktRest | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Deleted | zDeleted | ztInteger | 1 |  | smallint
This field is used in the table as follows: |


Customer invoice log (fhl)

Log of customer invoices.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Due date | FaktFfDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice status | FaktStKod | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
No. of reminders | KravAnt | ztInteger | 1 |  | smallint
Block reminders until | KravSparrTomDat | ztDate |  |  | datetime
Prev due date | OldFaktFfDat | ztDate |  |  | datetime
Prev invoice status | OldFaktStKod | ztInteger | 1 |  | smallint
Prev reminder qties | OldKravAnt | ztInteger | 1 |  | smallint
Prev reminder block until | OldKravSparrTomDat | ztDate |  |  | datetime
Prev interest invoicing | OldRteFaktKd | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Interest invoice | RteFaktKd | ztBoolean |  |  | char
Date/time | StrDateTime | ztString | 28 |  | varchar


Customer invoice to AP (ktl)

Customer invoices transferred to the accounts payable ledger.
This could also be credit invoices that are to be paid to a customer.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Transfer journal no. | KrTillLrJournNr | ZtLong | 4 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Outst invc amt, curr | VbFaktRest | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: xKtl Transfer customer invoice to AP


Customer number change (fnk)

Data on invoices that are affected by a customer number change.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Journal no. cust no. change | FnkJournNr | ZtLong | 6 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Original payer | OldKundBetalareNr | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xFnk Customer number change


Customer payment routes (x2iv)

Definition of the customer payment routes (automatic payment or OCR) used during loading of paid customer invoices from bank giro and postal giro via the program "Import data to work table" (vsthi).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Transfer receipt journal | AutoCreateJournal | ztBoolean |  |  | char
Bank agreement | AvtalNrHosBank | ztString | 30 |  | varchar
Account at bank | BankKonto | ztString | 40 |  | varchar
Bank acct check type | BankKontoTyp | ztString | 4 |  | varchar
Sign conversion | CharConvertType | ztInteger | 5 |  | smallint
Bank EDI ID | EDI_Id_HosBank | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment route | InbetalningsVag | ztString | 6 |  | varchar
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Bank customer no. | KundNrHosBank | ztString | 30 |  | varchar
Namn på kvittesnfil | KvittensFilNamn | ztString | 255 |  | varchar
Procedure, after | MatrixPostExecProc | ztString | 255 |  | varchar
Procedure, before | MatrixPreExecProc | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sign conversion type | TypeOfCharConvert | ztInteger | 5 |  | smallint
Payment route descr | UtbetalningsVagBeskr | ztString | 50 |  | varchar
Payment file name | UtbFilNamn | ztString | 255 |  | varchar
Length in pmt file | UtbFilPostLaengd | ztInteger | 5 |  | smallint
Close char pmt file | UtbFilSlutTkn | ztString | 255 |  | varchar
Start char pmt file | UtbFilStartTkn | ztString | 255 |  | varchar
AP/AR pmt contents | UtbMaterialTyp | ztString | 10 |  | varchar
AP pmt reason/Due dt | UtbOrsak | ztString | 10 |  | varchar

    This table is the main table in the following programs:

    Program: vX2iv Customer payment routes

    Program: x2iv AR payment routes


Customer payment types (x2bb)

Definitions used to show how an invoice has been paid. ((Only for Finland))

The following standard records exist. Do not alter/delete:

Payment type (BetalningsTyp) | Payment type (BetalningsTypBeskr)
0 | Normal
1 | Direct debit
2 | Cash

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Payment type | BetalningsTyp | ztInteger | 5 |  | smallint
Payment type | BetalningsTypBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: x2bb Payment types


Customer point of delivery (lp)

Definition of different points of delivery for a customer. This can be used for delivery addresses, end-customers, or the like.

First, enter general company data for points of delivery in the company table. Then connect these to customers in this program/table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Storage code | ForradsKod | ztString | 17 |  | varchar
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Print point of delivery | KOdUtskrLevPlats | ztBoolean |  |  | char
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Recipient code | MottagarKod | ztString | 17 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Point of delivery, name | OrdLevPlBeskr | ztString | 36 |  | varchar
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Gate description | PortBeskrivning | ztString | 35 |  | varchar
Gate code | PortKod | ztString | 17 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: lp Customer point of delivery


Customer prio (PvmCustomerPrio)

Definition of priority for customers used in picking proposals when allocating received quantities among booked orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Customer priority | PvmCustomerPrio | ztInteger | 5 |  | smallint
Customer prio descr | PvmCustomerPrioDescr | ztString | 50 |  | varchar
Customer prio id | PvmCustomerPrioId | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PvmCustomerPrio Customer prio


Customer specific texts (xktx)

Table of customer-specific texts to print on various documents in the system, such as order confirmations and delivery notes.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Default text | KodDefaultText | ztBoolean |  |  | char
Copyable text | KodFastText | ztBoolean |  |  | char
Choice at copy | KodValCopyText | ztBoolean |  |  | char
Text on PO | KundSpecTextBe | ztBoolean |  |  | char
Text on invoice | KundSpecTextFa | ztBoolean |  |  | char
Text on delivery note | KundSpecTextFs | ztBoolean |  |  | char
Text on order acknowledgement | KundSpecTextOe | ztBoolean |  |  | char
Text on quotation | KundSpecTextOff | ztBoolean |  |  | char
Text on picking list | KundSpecTextPl | ztBoolean |  |  | char
Text on mfg/works order | KundSpecTextTo | ztBoolean |  |  | char
Customer specific text | KundTextKod | ztString | 4 |  | varchar
Customer specific text | KundTextKodBeskr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Text after document rows | TextEfterDokRader | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xktx Customer specific texts


Customer statistics (skus)

Statistics per customer and period.

The statistics are generated by running the report c, "Create statistics, customer + period". Select the year and the period for which you want statistics.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Days fr due dt to pmt | AntDgrSedanFfDat | ZtLong | 7 |  | int
Budgeted amount | Budgbelopp | ZtBaseCurrAmount | 14 | 2 | money
Invc row amount | faktradsumma | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period invoiced qty | PerFaktAnt | ZtQty | 14 | 2 | decimal
Per invoiced amt | PerFaktBel | ZtBaseCurrAmount | 14 | 2 | money
CSG | PerFaktRadKost | ZtBaseCurrAmount | 14 | 2 | money
Per försenade utlev | PerForsenUtLev | ZtQty | 14 | 2 | decimal
Paid/period | PerInbBel | ZtBaseCurrAmount | 14 | 2 | money
Period | Period | ztInteger | 4 |  | smallint
Orders/period value | PerOrderIngBel | ZtBaseCurrAmount | 14 | 2 | money
Per utg ord.stock ant | PerOrderStock | ZtQty | 14 | 2 | decimal
Period dispatches | PerTotUtlev | ZtQty | 14 | 2 | decimal
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Remaining to pay | RestBelFakt | ZtBaseCurrAmount | 14 | 2 | money
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Statistical item value | StatistikRadVarde | ZtBaseCurrAmount | 14 | 2 | money
Period invc amt, curr | VbPerFaktBel | ztMoney | 14 | 2 | money
Period pmt amt, curr | VbPerInbBel | ztMoney | 14 | 2 | money
Outstanding amt, curr | vbRestbelfakt | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: xSkus Customer statistics


Customer user table (wq01)

Customer user table.
This table has no logic in Jeeves.
It is intended to make it easier for the customer to devise their own solutions when a new table is needed.
The table contains fields/terms that are commonly used, but as already stated, there is no business logic behind these.
The logic must be added, with user-defined procedures and macros.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
Note | KortNotering | ztString | 255 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Closed | TransactionFinished | ztBoolean |  |  | char
Closed by | TransactionFinishedBy | ztString | 6 |  | varchar
Date closed | TransactionFinishedDT | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Price, curr | Vb_Pris | ZtSalesPrice | 12 | 2 | money
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint
Input status | Xin1Status | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: wq01 Customer user table


Customer work STATUS input file/table (win1)

Customer work input file/table.
This table has no logic in Jeeves.
It meant to make it easier for the customer devise their own solutions for reading external date (e.g. EDI).
The table contains fields/terms that are commonly used, but as already stated, there is no business logic behind these.
The logic must be added, with user-defined procedures and macros.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Payment terms | BetKod | ztString | 2 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Packaging BCU | EmballageKostnad | ZtBaseCurrAmount | 14 | 2 | money
Handling charge BCU | ExpeditionKostnad | ZtBaseCurrAmount | 14 | 2 | money
Invoice date | FaktDat | ztDate |  |  | datetime
Due date | FaktFFDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice reference no. | FaktNr_OCR | ztString | 40 |  | varchar
Invoice bar code | FaktNr_StreckKod | ztString | 100 |  | varchar
Invoice total incl tax | FaktTotMMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice total excl tax | FaktTotUMoms | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Insurance BCU | ForsakringsKostnad | ZtBaseCurrAmount | 14 | 2 | money
Total freight BCU | FraktKostnDeb | ZtBaseCurrAmount | 14 | 2 | money
Company name | FtgNamn | ztString | 36 |  | varchar
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
c/o address | FtgPostAdr1 | ztString | 36 |  | varchar
Street addr/box | FtgPostAdr2 | ztString | 36 |  | varchar
Town/City/State | FtgPostAdr3 | ztString | 36 |  | varchar
ZIP/Post code | FtgPostNr | ztString | 10 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
Note | KortNotering | ztString | 255 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Order date | OrdDatum | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Order type | OrdTyp | ztInteger | 3 |  | smallint
Other inv. cost-1 BCU | OvrFaktKostnad1 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-2 BCU | OvrFaktKostnad2 | ZtBaseCurrAmount | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Closed | TransactionFinished | ztBoolean |  |  | char
Closed by | TransactionFinishedBy | ztString | 6 |  | varchar
Date closed | TransactionFinishedDT | ztDateTime |  |  | datetime
Original item no. | UrsprArtNr | ztString | 30 |  | varchar
Payment methods | UtbSlag | ztString | 3 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Packaging, curr | vb_EmballageKostnad | ztMoney | 14 | 2 | money
Handling charge curr | vb_ExpeditionKostnad | ztMoney | 14 | 2 | money
Insurance, curr | vb_ForsakringsKostnad | ztMoney | 14 | 2 | money
Total freight, curr | vb_FraktKostnDeb | ztMoney | 14 | 2 | money
Other invc cost-1, curr | vb_OvrFaktKostnad1 | ztMoney | 14 | 2 | money
Other invc cost-2, curr | vb_OvrFaktKostnad2 | ztMoney | 14 | 2 | money
Price, curr | Vb_Pris | ZtSalesPrice | 12 | 2 | money
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint
Input status | Xin1Status | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: Win1 External input data


Customer's bank accounts/Inc pymt mthd (kusk)

Table of the bank accounts of a customer. The accounts are used when printing bills.
(Adaptation for France).
Code key calculated automatic if jeeves parameter ACCPAY005 activated.
The table is not used in Sweden since payment is controlled by the postal giro or bank giro number.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Bank | BankId | ztString | 10 |  | varchar
Account at bank | BankKonto | ztString | 40 |  | varchar
Bank acct check type | BankKontoTyp | ztString | 4 |  | varchar
Branch info 1 | Filial_Info_1 | ztString | 60 |  | varchar
Branch info 2 | Filial_Info_2 | ztString | 60 |  | varchar
Local bank code | FilialKod | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Code key | KodNyckel | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SWIFT bank location | SwiftMotBankOrt | ztString | 22 |  | varchar

    This table is the main table in the following programs:

    Program: kusk Customer's bank accounts/Inc pymt mthd


Customer-specific item data (vkar)

Table that converts the customer's item number to a Jeeves item number.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item description | ArtBeskr | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Customer item no. | ArtNrKund | ztString | 30 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Note | KortNotering | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Customer-specific item data (kuar)

Customer-specific information about items, e.g. customers' item number corresponding to the internal item number, customer-specific naming conventions, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item description | ArtBeskr | ztString | 30 |  | varchar
Item descr 2 | ArtBeskr2 | ztString | 255 |  | varchar
Specification | ArtBeskrSpec | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Customer item no. | ArtNrKund | ztString | 30 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Copyable text | KodFastText | ztBoolean |  |  | char
Choice at copy | KodValCopyText | ztBoolean |  |  | char
Note | KortNotering | ztString | 255 |  | varchar
Ord.spec text -> PO | OrpRadTextBe | ztBoolean |  |  | char
Order spec text/inv | OrpRadTextFa | ztBoolean |  |  | char
Order spec text/DN | OrpRadTextFs | ztBoolean |  |  | char
Order spec text OA | OrpRadTextOe | ztBoolean |  |  | char
Order spec text/PL | OrpRadTextPl | ztBoolean |  |  | char
Order spec text->MO | OrpRadTextTo | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Replace item name | ReplaceItemDescr | ztBoolean |  |  | char
Replace item number | ReplaceItemNo | ztBoolean |  |  | char
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Technical status | TekniskStatus | ztString | 35 |  | varchar
Validity time, days | ValidityTime | ztInteger | 3 |  | smallint
Publish on Web | webpublish | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: kuar Customer-specific item data


Customer/item joint view (ukar)

This view is used for handling planned inventory events by customer and item.
These events are from:
-customer orders
-purchase orders
-manufacturing deliveries
-manufacturing consumption

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item description | ArtBeskr |  |  |  | @DataType=NULL
Specification | ArtBeskrSpec |  |  |  | @DataType=NULL
Item no. | ArtNr |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Company name | FtgNamn |  |  |  | @DataType=NULL
Company ID | FtgNr |  |  |  | @DataType=NULL
Inventory location | LagStalle |  |  |  | @DataType=NULL
Order date | OrdDatum |  |  |  | @DataType=NULL
Record type | PostTyp |  |  |  | @DataType=NULL


Customers (kus)

Customer-specific information, which supplements the basic information in the company file.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No surcharges | AddArtEjAktiv | ztBoolean |  |  | char
Max amt for direct debit | AgPayLimit | ZtLong | 5 |  | int
Alternative buyer reference | AltBuyerRef | ztchar | 35 |  | char
No. days, due | AntDgrForfallet | ztInteger | 5 |  | smallint
Days fr due dt to pmt | AntDgrSedanFfDat | ZtLong | 7 |  | int
Av days fr due dte to pmt | AntDgrSedanFfDatSnitt | ZtLong | 5 |  | int
No. of incoming pmts | AntInb | ZtLong | 10 |  | int
Days fr inv dt to pmt | AntInbDgr | ZtLong | 10 |  | int
Avg days fr inv dte to pmt | AntInbDgrSnitt | ZtLong | 10 |  | int
Direct debit BG/acct no | AutoGiroBetKtoNr | ztString | 20 |  | varchar
Auto, credit function | AutoKreditKontrollKod | ztBoolean |  |  | char
Auto booking rule | AutStockBookingRule | ztInteger | 5 |  | smallint
Average credit time | AvgCreditDays | ZtLong | 10 |  | int
Bank | BankId | ztString | 10 |  | varchar
Rest to pay collection | BasFaktRestInkasso | ZtBaseCurrAmount | 14 | 2 | money
Rest to pay claim 1 | BasFaktRestK1 | ZtBaseCurrAmount | 14 | 2 | money
Rest to pay claim 2 | BasFaktRestK2 | ZtBaseCurrAmount | 14 | 2 | money
Rest to pay claim 3 | BasFaktRestK3 | ZtBaseCurrAmount | 14 | 2 | money
Rest to pay claim 4 | BasFaktRestK4 | ZtBaseCurrAmount | 14 | 2 | money
Req cust | BehovsKund | ztCompanyNo | 20 |  | varchar
This field is used in the table as follows: |
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Payment terms | BetKod | ztString | 2 |  | varchar
Payment terms, advance | BetKodForskott | ztString | 2 |  | varchar
BOE balance | BOE_Balance | ztMoney | 14 | 2 | money
No bill with invoice | BOE_NoPrint | ztBoolean |  |  | char
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Check balance | Check_Balance | ztMoney | 14 | 2 | money
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Include bill value | CreditInclBOE | ztBoolean |  |  | char
Include check | CreditInclCheck | ztBoolean |  |  | char
Delivery to business unit | DelivToBusinessUnit | ztString | 8 |  | varchar
Part delivery allowed | DelLevTillaten | ztInteger | 5 |  | smallint
This field is used in the table as follows: |
Discount priority | DiscountPrio | ztInteger | 5 |  | smallint
District | DistrKod | ztString | 4 |  | varchar
Due % | DueAmountPerc | ZtDecimal73 | 8 | 2 | decimal
Text | edit | ztBlob | 1 |  | varchar
Charge packaging cost | EmballageFakt | ztBoolean |  |  | char
Ship method, EU | EULevSattKod | ztInteger | 2 |  | smallint
Handling charge | expavgkd | ztBoolean |  |  | char
Extra1 | Extra1 | ztString | 30 |  | varchar
Extra2 | Extra2 | ztString | 30 |  | varchar
Extra3 | Extra3 | ztString | 30 |  | varchar
Extra4 | Extra4 | ztFloat | 10 | 2 | float
Invoice fully deliv order | FaktSlutLevOrder | ztBoolean |  |  | char
Del Note, inv per order | FFhNr_Separata_Fakturor | ztBoolean |  |  | char
Coll.invoice, delivery note | FfhSamFaktUtskr | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Charge insurance fee | ForsakringFakt | ztBoolean |  |  | char
Insurance cost % | ForsakrKostnProc | ZtDecimal73 | 6 | 2 | decimal
Deduction order-lnkd adv | ForskottOrdKopplTyp | ztInteger | 2 |  | smallint
Solvency date | FromInvoiceDate | ztDate |  |  | datetime
Delivery note Y/N | fskd | ztBoolean |  |  | char
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Goods label row 1 | GodsMarke1 | ztString | 40 |  | varchar
Goods label row 2 | GodsMarke2 | ztString | 40 |  | varchar
Goods terminal | GodsTerminalKod | ztString | 17 |  | varchar
Third party trade | Handel3Part | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Interest invoiced prev year | IntrstAmtPreYr | ZtBaseCurrAmount | 14 | 2 | money
Interest invoiced curr year | IntrstAmtThYr | ZtBaseCurrAmount | 14 | 2 | money
Reminder code | kravkd | ztBoolean |  |  | char
Date last reminder | KravSenUtskr | ztDate |  |  | datetime
Reminders blocked | KravSparr | ztBoolean |  |  | char
Block reminders until | KravSparrTomDat | ztDate |  |  | datetime
Credit limit check type | KreditCheckTyp | ztInteger | 2 |  | smallint
Credit exclude order value | KreditExklOrdSaldo | ztBoolean |  |  | char
Credit block | kreditsparr | ztBoolean |  |  | char
Credit block type | KreditSparrTyp | ztInteger | 2 |  | smallint
Credit status type | KreditStatusTyp | ztInteger | 2 |  | smallint
Credit warning | KreditVarning | ztBoolean |  |  | char
Plocklista (j/n) | Kund_PlKod | ztString | 1 |  | varchar
Alternative items | KundAltArtiklar | ztBoolean |  |  | char
Payer, company ID | kundbetalarenr | ztCompanyNo | 20 |  | varchar
Customer balance, adv | KundForskottSaldo | ZtBaseCurrAmount | 14 | 2 | money
Freight payer | KundFraktBetalareNr | ztCompanyNo | 20 |  | varchar
Charge freight cost | KundFraktDeb | ztBoolean |  |  | char
Customer balance, paid adv | KundInbetForskottSaldo | ZtBaseCurrAmount | 14 | 2 | money
Paid-in previous year | KundInbPreYr | ZtBaseCurrAmount | 14 | 2 | money
Paid-in this year | KundInbThYr | ZtBaseCurrAmount | 14 | 2 | money
Customer category | kundkategorikod | ztInteger | 2 |  | smallint
Customer class | kundklass | ztString | 12 |  | varchar
Average days credit | kundkreddag | ztInteger | 3 |  | smallint
Credit limit | kundkredlim | ZtBaseCurrAmount | 14 | 2 | money
Calculation Tax | KundMomsBer | ztBoolean |  |  | char
Turnover YTD | kundoms | ZtBaseCurrAmount | 14 | 2 | money
Turnover previous year | kundomsfa | ZtBaseCurrAmount | 14 | 2 | money
T-ov prev yr incl VAT/tax | KundOmsFaInklMoms | ZtBaseCurrAmount | 14 | 2 | money
T-ov curr yr incl VAT/tax | KundOmsInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Sales price incl VAT/tax | KundPrisInklMoms | ztBoolean |  |  | char
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Rabatt ej rab.gr art | KundRabattKod | ztBoolean |  |  | char
Discountable item | KundRabattKod0 | ztBoolean |  |  | char
Discounted item | KundRabattKod1 | ztBoolean |  |  | char
Non discountable item | KundRabattKod2 | ztBoolean |  |  | char
Max order disc % | KundRabattMax | ztFloat | 6 | 2 | float
Min order disc % | KundRabattMin | ztFloat | 6 | 2 | float
Customer reference | kundref2 | ztString | 30 |  | varchar
AR ledger balance | kundsaldo | ZtBaseCurrAmount | 14 | 2 | money
Tier qty + order value | KundStafflKod | ztBoolean |  |  | char
Customer specific text | KundTextKod | ztString | 4 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Ship documents | levhandlkod | ztBoolean |  |  | char
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Payment terms acc to payer | MarkBetBetVillkStyr | ztBoolean |  |  | char
Tax code acc to customer | MarkKundsMomsStyr | ztBoolean |  |  | char
Max. amount due | MaxBelForfallet | ZtBaseCurrAmount | 14 | 2 | money
Delivery note rows/page | MaxFsRaderPerSida | ztInteger | 5 |  | smallint
Send permission | medgivSendDt | ztDate |  |  | datetime
Permission status | medgivstatus | ztInteger | 1 |  | smallint
Private permission | MedgivTyp | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Additional time | NoAddCreditDays | ZtLong | 10 |  | int
Agreed credit time | NoAgrCreditDays | ZtLong | 10 |  | int
Real credit time | NoRealCreditDays | ZtLong | 10 |  | int
Goods label layout | OdetteFlaggLayout | ztString | 1 |  | varchar
Print order acknowl. | OeKod | ztBoolean |  |  | char
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Order date | OrdDatum | ztDate |  |  | datetime
Order link | OrderKoppling | ztBoolean |  |  | char
Order per deliv.note WMS | OrderPerDelNoteWMS | ztBoolean |  |  | char
Order spec text | OrderTextKod | ztString | 4 |  | varchar
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Order value | ordsum | ZtBaseCurrAmount | 14 | 2 | money
Order value (incl tax) | OrdSumInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Order value (+ tax), payer | OrdSumInklMomsSomBet | ZtBaseCurrAmount | 14 | 2 | money
Order value, payer | OrdSumSomBet | ZtBaseCurrAmount | 14 | 2 | money
Order type | OrdTyp | ztInteger | 3 |  | smallint
Due% pay inv | OverDuePercent | ztFloat | 15 | 2 | float
Charge other invoice.cost-1 | OvrFaktKostn1Fakt | ztBoolean |  |  | char
Charge other invoice.cost-2 | OvrFaktKostn2Fakt | ztBoolean |  |  | char
Payment priority | PaymentPrio | ztInteger | 5 |  | smallint
Payment surplus | PayMentSurplus | ztInteger | 5 |  | smallint
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Price list, customer-specific | PrisListaKundSpec | ztInteger | 6 |  | smallint
Customer prio id | PvmCustomerPrioId | ztInteger | 5 |  | smallint
Surplus disc | PvmSurPlusDisc | ZtDecimal73 | 6 | 2 | decimal
Cust discount class | RabKlass | ztInteger | 3 |  | smallint
Alt Kundrabklass | RabKlass1 | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
demand 1 - % of SupLdgrBal | reminderperc1 | ZtDecimal73 | 8 | 2 | decimal
demand 2 - % of SupLdgrBal | reminderperc2 | ZtDecimal73 | 8 | 2 | decimal
demand 3 - % of SupLdgrBal | reminderperc3 | ZtDecimal73 | 8 | 2 | decimal
demand 4 - % of SupLdgrBal | reminderperc4 | ZtDecimal73 | 8 | 2 | decimal
collection - % of SupLdgrBal | ReminderPercFCU | ZtDecimal73 | 8 | 2 | decimal
Backorder handling | RestBehKod | ztInteger | 1 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Interest amt calc to date | rtasaldobertomdat | ztDate |  |  | datetime
Pmt rmdr/intrst invc rule | RteFaktAvtal | ztInteger | 2 |  | smallint
Interest invoice | RteFaktKd | ztBoolean |  |  | char
Account | ru_account | ztString | 20 |  | varchar
Salesperson | Saljare | ztString | 6 |  | varchar
Collective invoicing | SamFaktUtskr | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Total assignments invoice | SumUppdrag | ztBoolean |  |  | char
Trading, sales price % | TradeFsgMarkup | ztFloat | 7 | 2 | float
Trading, cost price % | TradeKalkMarkup | ztFloat | 7 | 2 | float
Carrier code | TransportorsKod | ztString | 17 |  | varchar
Choice of carrier | TransportorsVal | ztBoolean |  |  | char
Transport days | TransportTid | ztInteger | 3 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax agent no. | VATAgentNo | ztCompanyNo | 20 |  | varchar
Rest to pay claim 1 | VbFaktRestK1 | ztMoney | 14 | 2 | money
Rest to pay claim 2 | VbFaktRestK2 | ztMoney | 14 | 2 | money
Rest to pay claim 3 | VbFaktRestK3 | ztMoney | 14 | 2 | money
Rest to pay claim 4 | VbFaktRestK4 | ztMoney | 14 | 2 | money
Remaining for collection | VbFaktRestKI | ztMoney | 14 | 2 | money
Show Edit at order | VisaEditVidOrder | ztBoolean |  |  | char
Our supplier no. | VLevNr | ztString | 17 |  | varchar
Web tree ID | WebTreeID | ztString | 25 |  | varchar
E-mail | wEmailAddress | ztString | 100 |  | varchar
User Id | wPassword | ztString | 50 |  | varchar
Web user ID | wUserId | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: bKus Print AR info, interest and reminders

    Program: KrKus Accounts receivable queries

    Program: KuArtSok Customer, Search item

    Program: kus Customers

    Program: KusAr Items by customer

    Program: kuskred Customer credit status

    Program: KusLevP Dispatch planning per cust

    Program: KusLevPU Dispatch planning per cust, picked

    Program: SrAn9 Simulation price calculation structure


Customers to whom an offer is sent (okrd)

Kunder som finns med i ett offertutskick.
*** Under förstudie ***

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Payment terms | BetKod | ztString | 2 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Campaign | KampNr | ZtLong | 4 |  | int
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Dispatch method | LevsattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Quotation printed | OffUtskrDat | ztDateTime |  |  | datetime
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Print date | p_utskr_dat | ztDate |  |  | datetime
Print date/time | p_utskr_datTid | ztDateTime |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Identity | SQLIDENTITY | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: okrd Customers to whom an offer is sent


Customers, calc VIEW (vkub)

View of the kus table (Customers) where a credit limit remains.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Unused credit | KusKvarPaKredit | ZtBaseCurrAmount | 14 | 2 | decimal


Customizations (vyex)

Different types of customer specific settings in respect of terms and fields. The type is governed by a code specified in the field Pos (corr. Ztype column) as follows:
1 = Added terms in the system
2 = Added fields in tables
3 = Edited terms (i.e. own prompts, column headings, lengths and masks)
4 = Added fields in reports
6 = Special setting type for defining a graphical view in a list window (only Net Kernel)
7 = Term linked to a macro

Choose from personal/global: No
Per company: No

The Jeeves table Vyex is a view against the Yext table in site repository.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit |  |  |  | @DataType=NULL
Definition | kDefine |  |  |  | @DataType=NULL
Row | RadPos |  |  |  | @DataType=NULL
Text/info | x255 |  |  |  | @DataType=NULL


Customized window settings (yct)

Added fields per window (window context), i.e. added in the form or in the list using the option ‘Tools/Add...’

Choose from personal/global: Yes
Per company: No

(This table replaces table Vyct.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Global settings | Global | ztString | 1 |  | char
Group | Grupp | ztInteger | 4 |  | smallint
No_Replicate_Exec | No_Replicate_Exec | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Settings | Props | ztBlob | 1 |  | text
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Window context (site rep) | Wctxt | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: yct Own window settings


Customs document (TullDok)

Customs documents/customs invoices can be linked to supplier invoices.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Tax date | MomsDatum | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Transfd t VAT/tax register | TransfToVATRegister | ztBoolean |  |  | char
Customs document date | Tulldokdatum | ztDate |  |  | datetime
Customs document ID | TullDokid | ztString | 20 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Invoice amount, curr | vb_FaktSum | ztMoney | 14 | 2 | money
VAT/tax, curr | vbFaktMoms | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: TullDok Customs documents


Customs duties (TullKostnad)

Definition of existing types of customs duties and the like with information as to whether these should be saved in the special VAT register and if they must be linked to a supplier invoice.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
VAT/tax code | Momskod | ztInteger | 5 |  | smallint
Upd VAT/tax register | MomsPlikt | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Suppl invoice mandatory | SuppinvMustEnter | ztBoolean |  |  | char
Customs duties | TullKostBeskr | ztchar | 50 |  | char
Customs duties | TullkostTyp | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: Tullkostnad Customs duties


Customs processing document detail (TullDokD)

Row number in the relevant table, an automatically generated running number. The purpose is to create unique ids for storing information in different tables.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Invoice date | LevFaktDat | ztDate |  |  | datetime
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Upd VAT/tax register | MomsPlikt | ztBoolean |  |  | char
Subj to VAT/tax, bas | MomsPliktigBelopp | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Suppl invoice mandatory | SuppinvMustEnter | ztBoolean |  |  | char
Customs document ID | TullDokid | ztString | 20 |  | varchar
Customs duties, base | TullkostnadBAs | ZtBaseCurrAmount | 14 | 2 | money
Customs duties curr | TullkostnadVal | ztMoney | 14 | 2 | money
Customs duties | TullkostTyp | ztInteger | 5 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | VAlKurs | ZtCurrencyRate | 15 | 7 | decimal


Custs edited error messages in triggers and procedures (UsrChgJder)

The customer's changed messages written in triggers and procedures.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Documentation | Documentation | ztBlob | 1 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Sequence no. | LopNr | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: UsrChgJder Error msgs from Jeeves server pgm


Cycle count (WMS_V_MU_CycleCount)

Pkg identity.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
X Pos. | LocXPos | ztString | 5 |  | varchar
Y Pos. | LocYPos | ztString | 5 |  | varchar
MHA | Mha | ztString | 5 |  | varchar
Availability | PalletAvailCode | ztInteger | 3 |  | smallint
Sequence number | PalletContSeq | ztInteger | 3 |  | smallint
Created | PalletCreateDateTime | ztDateTime |  |  | datetime
ID | PalletId | ztString | 35 |  | varchar
Reason code | PalletSKUCreateReasonCode | ztInteger | 3 |  | smallint
Status, SKU | PalletSKUStatusCode | ztInteger | 3 |  | smallint
Type | PalletTypeCode | ztInteger | 3 |  | smallint
Pallet unit type | PalletUnitType | ztString | 5 |  | varchar
Parent ID | ParentPalletId | ztString | 35 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Rack | Rack | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Cycle count date | SKUCycleCountDateTime | ztDateTime |  |  | datetime
Delivered qty, SKU | SKUDelQty | ZtQty | 14 | 2 | decimal
Qty, SKU | SKUQty | ZtQty | 14 | 2 | decimal

    This table is the main table in the following programs:

    Program: WMS_MU_CycleCount Cycle count


Data configuration (WMS_UIDataConfiguration)

Definition of which data that should be available in the mobile client and how it should be sorted.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Data selection | DataSelection | ztBlob | 4000 |  | varchar
Default sort | DefaultSort | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Window name | WindowName | ztString | 255 |  | varchar
Work flow | Workflow | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_UIDataConfiguration Data configuration


Data for installation of chart of accounts (KoSruStdDataInstall)

Installation data regarding standard base chart of accounts and SRU codes. This table is filled with data when installing Jeeves. A function button in the Import accounts and SRU codes (importko) program is used to read from this table and insert data into the import tables (importko, importsruh and importsrud).

The contents of this table remain intact, which means you can re-import the standard chart of accounts and SRU codes if necessary.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Identity | sqlidentity | ZtLong | 10 |  | int
SQL code/Variable | sqltext | ztBlob | 1 |  | varchar


Data for item characteristics (egar)

Data for item properties

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | artnr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Property Data | propertydata | ztString | 30 |  | varchar
PropNo. | PropertyNo | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sorteringsordning egenskaper | SortEg | ztInteger | 4 |  | smallint


Data management rules (ICTtcr)

Definition of rules for how replicated tables can be used in replicated companies. Note that the rules are read in the replicated (TO) company. Therefore, we recommend that you replicate this table too.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Hide with compression | ICTColumnHide | ztBoolean |  |  | char
ICT conn business unit | ictconbusinessunit | ztString | 8 |  | varchar
Delete allowed | ICTDeleteAllowed | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Rule description | ICTRuleNumberDescr | ztString | 40 |  | varchar
Update allowed | ICTUpdateAllowed | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Table name | TableName | ztString | 255 |  | varchar
To company | ToCompanyNo | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: ICTtcr Data management rules


Data per TARIC code and country code (arsnland)

This table is an underlying table to TARIC codes (arsn). The table is used to enter duties etc. per country code. If no data is found for the relevant country code when TARIC codes are used for calculations, the system retrieves the values from the overlying TARIC codes table (arsn).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
TARIC code | ArtStatNr | ztString | 20 |  | varchar
Duty/ton fixed | AvgiftTonFast | ztFloat | 10 | 2 | float
Duty/ton floating | AvgiftTonFlyt | ztFloat | 10 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Country | LandsKod | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Customs duties % | TullKostnProc | ZtDecimal73 | 6 | 2 | decimal
Currency | ValKod | ztString | 3 |  | varchar


Database object dependence (jsdp)

This is a copy of the SysDepends table.
SysDepends, however, does not always have all references sysdepends (T-SQL) Contains dependency information between objects (views, procedures, and triggers), and the objects (tables, views, and procedures) contained in their definition. This table is stored in each database.

Column name Description id Object ID. depid Dependent object ID. number Procedure number. depnumber Dependent procedure number. status Internal status information. depdbid Reserved. depsiteid Reserved. selall On if the object is used in a SELECT * statement. resultobj On if the object is being updated. readobj On if the object is being read.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
DB-term/-expression 1 | DbTermName1 | ztString | 120 |  | varchar
Dep object name | DepObjectId | ZtLong | 10 |  | int
Dep object name | depObjectName | ztString | 60 |  | varchar
Object type | DepObjectType | ztString | 2 |  | varchar
Dep object seq no. | DepObjNumber | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Object no. | ObjectId | ZtLong | 10 |  | int
Object name | ObjectName | ztString | 128 |  | varchar
Object type | ObjectType | ztString | 2 |  | varchar
Object sequence no. | ObjNumber | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Select all | SelectAllObj | ztBoolean |  |  | char
Select | SelectObj | ztBoolean |  |  | char
Update | UpdateObj | ztBoolean |  |  | char


Database object dependence (vsdp)

Dependent object.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Dep object name | DepObjectId | ZtLong | 10 |  | int
Dep object name | depObjectName | ztString | 60 |  | nvarchar
Object type | DepObjectType | ztString | 2 |  | char
Dep object seq no. | DepObjNumber | ztInteger | 4 |  | smallint
Object no. | ObjectId | ZtLong | 10 |  | int
Object name | ObjectName | ztString | 128 |  | nvarchar
Object type | ObjectType | ztString | 2 |  | char
Object sequence no. | ObjNumber | ztInteger | 4 |  | smallint
Select all | SelectAllObj | ztBoolean |  |  | bit
Select | SelectObj | ztBoolean |  |  | bit
Update | UpdateObj | ztBoolean |  |  | bit


Database objects (vsob)

Numeric code for an object in the database, liked to an object name.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Object no. | ObjectId | ZtLong | 10 |  | int
Object name | ObjectName | ztString | 128 |  | nvarchar
ObjectSourceText | ObjectSourceText | ztBlob | 1 |  | varchar
Object type | ObjectType | ztString | 2 |  | char
Parent_ObjectId | Parent_ObjectId | ZtLong | 10 |  | int
Objektnamn på ägare | Parent_ObjectName | ztString | 128 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xVsob Database objects


Database objects in package solution (JvsPackageDBObjects)

Database objects included in a package solution. Used for defining triggers, procedures, functions and views to be included in a package solution.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Object name | DB_Object_Name | ztString | 128 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Solution ID | SolutionID | ZtLong | 10 |  | int


Database servers, Mobile sales (mobsaldbsrv)

Table of SQL servers in laptop computers used for Mobile sales.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mobile Database server | dbserver | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLidentity | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: Mobsaldb Database servers, mobile sales


Database tables (vtbd)

Name of table in specified/current database that contains the values you want to retrieve. The information is used on conversion, when entering definitions for import/export of data and when defining reports in the report generator.

Example
-------------
- During conversion: User-defined table in which you have loaded data for example from the salary system Agda. The table should, for example, be able to be called q_agda or q_loner.

- For import/export: The table "Incoming/Outgoing payment files, receipt" (table Krin) or the SIE Export table (table Sie).

- For definition of reports: The table "GL account balances" (table Tko) or "GL segment balances" (table Tkt).

The designation must be in agreement with an existing table in the database.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Value term table | VardeTabId1 | ztString | 255 |  | nvarchar
Base/value table | ZTABLE | ztString | 255 |  | nvarchar

    This table is the main table in the following programs:

    Program: xVtbd Database tables


Database tables (vtbd_lang)

Alphanumeric ID term for base table or value table in the Jeeves database. Example: Kus is the internal data name for the Customer table.

The simplest way to find out a table's data name is to used the Ctrl+Alt+F12 command. The table's and field's datanames are displayed in the format Table name.Term name.

Editing texts in drop-down lists

This field is not editable if you right-click to the editing program (changecdd) from a record in a base table. It is, however, editable if you start the program standalone from the menu. This is to allow you to add translations manually if you add own new records in base tables.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Table name | TableName | ztString | 255 |  | varchar
Base/value table | ztable | ztString | 255 |  | nvarchar


Databases (xr12)

Definition of the databases that can be accessed from Jeeves. They must all be on the same database server as the open database.

The information is used, for example, in the conversion routine and in the report generator.

From version 129 of Jeeves Net Kernel, most functions require you to name a database. In earlier versions of Net Kernel you were able to leave the name blank and then the open database was used.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
Database | DataBasBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xr12 Databases


Day Schedule (AttR_daysched)

Describes day schedules and compensation schedules. The compensation schedule is constructed in the same way as the day schedule. In the field: Day schedule type (attrdayscheduletype) you define whether it is a day schedule or a compensation schedule.

Each dayschedule can be linked to several compensation schedules.

The schedule is not connected to a date, instead it includes the times when changes occur.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Day schedule | AttRDaySchedule | ztString | 6 |  | varchar
Schedule description | AttRDayScheduleDescr | ztString | 100 |  | varchar
Day schedule type | attrdayscheduletype | ztInteger | 5 |  | smallint
Minimum lunch (mins) | AttrMinlunch | ZtLong | 10 |  | int
Work metrics in minutes | AttRNormalHrsMins | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Total summarized hours | Total_Hours | ztString | 5 |  | varchar

    This table is the main table in the following programs:

    Program: AttR_daysched Day schedules


Day Schedule Row (AttR_dayschedrow)

Day schedule row.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Day schedule | AttRDaySchedule | ztString | 6 |  | varchar
Day schedule row type | AttRdayschedulerowtype | ztInteger | 5 |  | smallint
Day schedule time | AttRDayScheduleTime | ztTime | 5 |  | datetime
Originates from | AttRMoveTo | ztInteger | 5 |  | smallint
Reason after | AttRReasonAfter | ztString | 6 |  | varchar
Reason before | AttRReasonBefore | ztString | 6 |  | varchar
Time stamp requested | AttRRepReq | ztBoolean |  |  | char
Time limit after | AttRTimeLimitAfter | ZtLong | 10 |  | int
Time limit before | AttRTimeLimitBefore | ZtLong | 10 |  | int
Time interval after | AttRTimeStepAfter | ZtLong | 10 |  | int
Time interval before | AttRTimeStepBefore | ZtLong | 10 |  | int
Time type | AttRTimeType | ztString | 6 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_dayschedrow Day schedule rows


Day schedule row origins (Attr_dsrowxx)

States what day the time belongs to when shift working.

The following standard records exist. Do not alter/delete:

Originates from (AttRMoveTo) | Originates from descr (AttRMoveToDescr)
0 | Same day
1 | Next day
-1 | Previous day

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Originates from | AttRMoveTo | ztInteger | 5 |  | smallint
Originates from descr | AttRMoveToDescr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Attr_dsrowxx Day schedule row origins


Day schedule row types (AttR_dsrowtp)

Row types for the day schedule.

States whether the time is start, end, break, lunch, return/new type.
Return/New type means that a new salary type/ time type start to be valid from that time.
Start/End states the first and last record. Break and lunch states when these types get started.

The following standard records exist. Do not alter/delete:

Day schedule row type (AttRDayScheduleRowType) | Description (AttRDayScheduleRowTypeDescr) | Description
1 | 1. Start | Row type to specify the time a day schedule starts.
2 | 2. Return/New Type | Row type to specify the time of return to the previous time type, or the start of a new salary/time type.
3 | 3. Break | Row type to specify the time a break starts.
4 | 4. Lunch | Row type to specify the time lunch starts.
9 | 9. End | Row type to specify the time a day schedule ends.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Day schedule row type | AttRDayScheduleRowType | ztInteger | 5 |  | smallint
Description | AttRDayScheduleRowTypedescr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_dsrowtp Day schedule row types


Day schedule, shop reporting (vedc)

Table of which working days are included in a weekly schedule.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Not overtime evening | EjOvertidSlut | ztTime | 5 |  | datetime
Not overtime morning | EjOvertidStart | ztTime | 5 |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Day of week | VeckoDag | ztInteger | 1 |  | smallint
Week schedule | VeVeckoSchema | ztInteger | 5 |  | smallint


Day schedules (Compensation schedule) (vAttR_daysched2)

Alphanumerical code for the day schedule.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Day schedule | attrdayschedule | ztString | 6 |  | varchar
Schedule description | attrdayscheduledescr | ztString | 100 |  | varchar
Day schedule type | attrdayscheduletype | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: vAttR_daysched2 Dayschedule (Compensation schedule)


Day's account balance (kod)

Data in a work table for creating balances for a given date.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Year opening balance | AretsIngBalans | ZtBaseCurrAmount | 14 | 2 | money
Accounting date | BokfDat | ztDate |  |  | datetime
Day's net amount | DagensNetto | ZtBaseCurrAmount | 14 | 2 | money
Day opening bal | DagIngSaldo | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Accounting date (from) | FromBokfDat | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
Period opening bal | PerIngSaldo | ZtBaseCurrAmount | 14 | 2 | money
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Closing balance | UtgSaldo | ZtBaseCurrAmount | 14 | 2 | money
Year OB curr | VbAretsIngBal | ztMoney | 14 | 2 | money
Day's net balance curr | VbDagensNetto | ztMoney | 14 | 2 | money
Day OB, curr | VbDagIngSaldo | ztMoney | 14 | 2 | money
Period OB, curr | VbPerIngSaldo | ztMoney | 14 | 2 | money
Closing balance, curr | VbUtgSaldo | ztMoney | 14 | 2 | money


Dayschedule (Normal schedule) (vAttR_daysched)

Alphanumerical code for the day schedule.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Day schedule | AttRDaySchedule | ztString | 6 |  | varchar
Schedule description | AttRDayScheduledescr | ztString | 100 |  | varchar
Day schedule type | attrdayscheduletype | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: vAttR_daysched Dayschedule (View 1)


Dayscheduletype (Attr_dstp)

Here you define whether it is a day schedule or a compensation schedule.

The following standard records exist. Do not alter/delete:

Day schedule type (attrdayscheduletype) | Day schedule type descr (attrdayscheduletypedescr) | Description
1 | Day schedule | Code for day schedule.
2 | Compensation schedule | Code for compensation schedule. Used for calculating different types of time, e.g. unsocial working hours, overtime, compensatory leave etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Day schedule type | attrdayscheduletype | ztInteger | 5 |  | smallint
Day schedule type descr | attrdayscheduletypedescr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Attr_dstp Day schedule types


Debit/credit text form (vrdk)

Definition of texts which specify whether an amount is entered in debit or credit, which is determined by the content in the field 'Debit/credit' (term DebKre).

The definition has been added in version 8 service pack 1 primarily to facilitate language management of the texts and can be linked to all tables containing the term 'DebKre'.

The following standard records exist. Do not alter/delete:

Debit/credit (DebKre) | Debit/credit description (debKre_description)
d | Debit
k | Credit

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
Debit/credit | DebKre | ztchar | 1 |  | char
Debit/credit description | debKre_description | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: vrdk Debit/credit text form


Deduction type, order-linked advance (xz4)

Table of different Deduction types for order-linked advance payment.

The following standard records exist. Do not alter/delete:

Deduction order-lnkd adv (ForskottOrdKopplTyp) | Deduction order-lnkd adv (ForskottOrdKopplBeskr)
0 | Entire amount on current order
1 | Outstanding amount on other orders

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Deduction order-lnkd adv | ForskottOrdKopplBeskr | ztString | 50 |  | varchar
Deduction order-lnkd adv | ForskottOrdKopplTyp | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxz4 Deduction type, order-linked advance


Def fixed delivery days per route (xtrl)

Data for the calculation of fixed dispatch days for transport routes(xtr).

Enter the start day and interval in days, e.g. Tuesday and day interval=7 gives a fixed dispatch day=Tuesday each week, Tuesday and day interval=3 gives the fixed dispatch days=Friday, Monday, Thursday, Monday, etc.

If data on the transport route is entered and a calendar for dispatch days has been established, the calculated dispatch day is proposed automatically when customer orders are entered as the first current dispatch day in the calendar that is linked to the transport route. If an internal lead time is specified for the transport route, this is subtracted from the proposed dispatch day in the order routine and the product given as the prepare day. If this day falls on a non-working day, Jeeves will propose the closest previous working day.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Day interval | FastLevIntervDag | ztInteger | 5 |  | smallint
Start day of the week | FastLevVeckoDag | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Country | LandsKod | ztString | 3 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Carrier code | TransportorsKod | ztString | 17 |  | varchar


Defaults in own windows (UsrDefWindowDefaults)

Definition of own nodes in own programs which you have added and are not included in Jeeves standard.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Link from column | JvsConnectionFromColumn | ztString | 40 |  | varchar
Link from table | JvsConnectionFromTable | ztString | 40 |  | varchar
Link to column | JvsConnectionToColumn | ztString | 40 |  | varchar
Link to table | JvsConnectionToTable | ztString | 40 |  | varchar
Sequence no. | JvsSeqNo | ZtLong | 10 |  | int
Window name in Jeeves | JvsWindowName | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Development project | UsrDefDevProj | ztString | 10 |  | varchar


Defect types (sht3)

Definition of IRIS defect codes. This is used when reporting against service orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Defect IRIS | Defect | ztString | 30 |  | varchar
Defect IRIS | DefectCode | ztString | 3 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: sht3 Defect codes IRIS


Definition internal sales, item (arif)

Definition of relevant combinations in respect of item and internal sales type which, on sale of an item to a customers and the relevant combination between item and internal sales type according to the customer's customer category is defined in this table, means that an internal sale is involved, from the department that purchases the product from a supplier to inventory, to the department that sells the product to a customer.
This function facilitates follow-up in the general ledger for revenues, costs and margin regarding such sales, both for the department that purchases the product from a supplier to inventory, and the department that purchases the product internally and sells to a customer.
Normal accounting regarding revenue, cost and margin always refers to the department that sells the product to a customer.
Using this function you can therefore achieve accounting of revenue, cost and margin in connection with sales also for the department that purchases the product from a supplier to inventory. For internal product sales, information is also obtained regarding revenue, cost and margin on the invoice row, both for the department that purchases the product from a supplier to inventory, and the department that purchases the product internally and sells to a customer.
These internal sales are made at an agreed internal sales price which is defined in this table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, internal | FPrisInternt | ZtBaseCurrAmount | 14 | 2 | money
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Internal sales type | InternFsgTyp | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Cost centre (elim) | KostStalleKodEliminera | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xArif Definition internal sales, items


Definition of fixed delivery days (kadd)

Definition of weekdays that will be fixed delivery days in the calendar.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Day interval | FastLevIntervDag | ztInteger | 5 |  | smallint
Start day of the week | FastLevVeckoDag | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar, fix disp dates | KalFastLevDagNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: kadd Definition of fixed delivery days


Definition of target table (scth)

Definition of conversion step. One table header is created per conversion step.

The sequence between the conversion steps does not have any meaning from performance-point of view but it is an advantage to find some kind of logic handling sequence. If the function for direction away is used in any conversion step, it is important that the definitions are done in a certain sequence. If an already existing conversion shall be inserted into Jeeves maybe the same sequence can be used.

Some general guidance
------------------------------
Describe the conversion steps on a paper and do not insert them in the tables until all steps are finished. For every step is stated:

Description in text form
- Conditions/restrictions
- Which terms will be included in the Jeeves record (remember to update the list of terms as they are defined)

Start with a general direct away, for ex. on company level.

- Handle the exceptions first so that the big crowd can be handled in the same conversion step.
- All records that shall contain the same posting contents (even if the terms are allowed or shall exist) can be handled in the same conversion step.

Be very careful when you refer to terms in the source table (external system file) so that you avoid write or spelling errors.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Direction away | BortStyra | ztBoolean |  |  | char
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Conversion rule | Konvbeskr1 | ztString | 100 |  | varchar
Convert seq | KonvStyra | ztBoolean |  |  | char
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Sequence | Sequence | ztInteger | 3 |  | smallint
Value term table | VardeTabId1 | ztString | 255 |  | varchar


Definition row calculation (VATcalcRow)

Definition of sum rows for the calculation of the tax statement (country specific adaptation).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Cell no. | VatCellNo | ztInteger | 5 |  | smallint
Cell no Sum | VATCellNoSum | ztInteger | 5 |  | smallint
VAT/tax operator | VATOperator | ztString | 8 |  | varchar
Tax period | VATPeriod | ztString | 8 |  | varchar
VAT/tax stmt status | VatStatus | ztString | 1 |  | varchar

    This table is the main table in the following programs:

    Program: VATcalcRow Definition row calculation


deleted/removed data after last import (deleted_JvsSite)

Data name for table to which the setting applies.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Table | JvsSiteTableName | ztString | 40 |  | varchar
No of rows | NoOfRows | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: deleted_JvsSite deleted/removed data after last import


Deliveries from MO (tii)

Received deliveries from manufacturing order position.

Received deliveries from manufacturing orders are posted as follows:
------------------------------------------------------------------------
DEBIT: The manufactured item's product account, stock transaction type 120 (or 0 if 120 is missing) and detail for integration 0 (stock account).

CREDIT: Detail for integration 5 (WIP account)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Decimal places | AntDec | ztInteger | 1 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Cost price at order | ArtKalkPrisO | ZtBaseCurrAmount | 14 | 2 | money
Cost at order (mtrl) | ArtKalkPrisOMtrl | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Use/Best before | BastForeDatum | ztDate |  |  | datetime
Batch no. | BatchId | ztString | 30 |  | varchar
Delivery note date, rcv | BestFoljesedelsDat | ztDate |  |  | datetime
Delivery note no., rcv | BestFoljesedelsNr | ztString | 30 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Diff delivery/planned | Diff_LevDat_2_LovDat | ztInteger | 5 |  | smallint
Document ID | docnumid | ztString | 30 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Extra overhead cost % | ExtraOmkProc | ztFloat | 7 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Reason code | FsOrsakKod | ztInteger | 5 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Receiving value | InlevKalkVarde | ZtBaseCurrAmount | 14 | 2 | money
Calc delivery value (adjustm) | InlevKalkVardeJustering | ZtBaseCurrAmount | 14 | 2 | money
Calc val rcvd mtrl | InlevKalkVardeMtrl | ZtBaseCurrAmount | 14 | 2 | money
Receive to MO | InlevTillAoNr | Jeeves_MONo | 7 |  | bigint
Receive to MO Pos | InlevTillAoPos | ztInteger | 4 |  | int
Receive to MO Op | InlevTillOpNr | ztInteger | 3 |  | smallint
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans journal no. | LthJournNr | ZtLong | 6 |  | int
Cancel remain qty | MakuleraRestAntal | ztBoolean |  |  | char
Lagerjournal MPS | MpsJournNr | ztInteger | 4 |  | smallint
Prev cost price BCU | OldArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | nvarchar
Doc. printed | printed | ztBoolean |  |  | char
Project ID | ProjCode | ztString | 10 |  | varchar
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Rec delivery from WMS | RecDelivFromWMS | ztBoolean |  |  | char
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Send: Delivered | SendDeliv | ztBoolean |  |  | char
Deliv notification date | SendDelivDoneDT | ztDateTime |  |  | datetime
EDI deliv journal | SendDelivJournNr | ZtLong | 10 |  | int
Sequence for S/N | Serial_No_Count | ZtLong | 10 |  | int
Time sqlcmd->trg start | SQLCmd2EnterTrg | ZtLong | 10 |  | int
Start av updatering/insert | SqlStmtStartedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Technical overhead cost % | TeknikOmkProc | ztFloat | 7 | 2 | float
Manufacturing journal | TiiJournNr | ZtLong | 6 |  | int
Delivery received date | TiInlevDat | ztDate |  |  | datetime
Reported mfg qty | TiRappAnt | ZtQty | 14 | 2 | decimal
Development cost | UtvKost | ZtCost | 16 | 6 | float
Development OH cost | UtvOmk | ZtCost | 16 | 6 | float
Item group | VaruGruppKod | ztString | 8 |  | varchar
Actual lead time | VerklLedTid | ztInteger | 5 |  | smallint
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: Tii2GL Received deliveries, production->GL

    Program: xTii Received deliveries, mfg


Delivery (EDI) journal (jibp)

Sequence number for a journal of deliveries from external systems, EDI or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Delivery received date | BestLevDat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Message type | BplTyp | ztInteger | 3 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Goods label row 1 | GodsMarke1 | ztString | 40 |  | varchar
Goods label row 2 | GodsMarke2 | ztString | 40 |  | varchar
Goods label row 3 | GodsMarke3 | ztString | 40 |  | varchar
Goods label row 4 | GodsMarke4 | ztString | 40 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
EDI rcving journ no. | JibpJournal | ZtLong | 10 |  | int
EDI input only | OnlyCreateBplRec | ztBoolean |  |  | char
Print date | p_utskr_dat | ztDate |  |  | datetime
Print date/time | p_utskr_DatTid | ztDateTime |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Closed | TransactionFinished | ztBoolean |  |  | char
Closed by | TransactionFinishedBy | ztString | 6 |  | varchar
Date closed | TransactionFinishedDT | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Jibp_bx1 Receiving journal (Customer specific)

    Program: xJibp EDI - delivery receipt journal


Delivery data, batch (batn)

Table of delivery data regarding inventory batches.

If unique batch IDs are applied, the ID number is checked against this table, i.e. not against the ‘Batches’ (Bat) table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Use/Best before | BastForeDatum | ztDate |  |  | datetime
Batch description | BatchDescr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Booking allowed | BatchOkToBook | ztBoolean |  |  | char
Picking allowed | BatchOkToUse | ztBoolean |  |  | char
Batch Res | BatchRes | ZtQty | 8 | 2 | decimal
Batch balance | BatchSaldo | ZtQty | 14 | 2 | decimal
Batch status | BatchStatusKod | ztInteger | 2 |  | smallint
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money


Delivery data, batch - view (vbat)

Table of delivery data regarding inventory batches.
A batch can be: an internal sequence number for received deliveries; or the supplier's delivery note number; or the supplier's unique identification for a manufactured/sold consignment.
A batch includes inventory balance and reservations.
A batch can be booked for a customer order.
A unique cost price can even be given to each batch (the flag for this is controlled by the item's product account).
Using Jeeves, it is also possible to stock items by serial number, but this function is given in a different table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Qty being picked | AntalUnderPlock | ZtQty | 14 | 2 | decimal
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Use/Best before | BastForeDatum | ztDate |  |  | datetime
Batch description | BatchDescr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Booking allowed | BatchOkToBook | ztBoolean |  |  | char
Picking allowed | BatchOkToUse | ztBoolean |  |  | char
Batch Res | BatchRes | ZtQty | 8 | 2 | decimal
Batch balance | BatchSaldo | ZtQty | 14 | 2 | decimal
Batch status | BatchStatusKod | ztInteger | 2 |  | smallint
Purchase price | BestInPris | ZtBaseCurrAmount | 14 | 2 | money
Delivery received date | BestLevDat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Physical invtry date | InventeringsDatum | ztDate |  |  | datetime
Physical invtry diff YTD | LagDiffAnt | ZtQty | 14 | 2 | decimal
Value to price | LagerVardeEnlInPris | ztBoolean |  |  | char
Physical inventory | LagInvAnt | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Last sale date, man | ManValidityDate | ztBoolean |  |  | char
FIFO | Mark_FIFO | ztBoolean |  |  | char
LIFO | Mark_LIFO | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Last sale date | ValidityDate | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money


Delivery methods, purchases (xbs)

Definition of the delivery methods that can be applied to purchase orders.

You can specify a default delivery method in the System file, own co. program (Sy) and/or for the supplier, but you can change the information on the purchase order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Dispatch method | BestLevSatt | ztString | 50 |  | varchar
Dispatch method | BestLevsattKod | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Delivery cost % | Hemtkostnproc | ZtDecimal73 | 7 | 2 | decimal
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
GAN/Cust no. | KundnrHosFraktb | ztString | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Intrastat, transport method | TranspSattKod | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: xbs Delivery methods, purchases


Delivery note (fso)

Delivery notes in the order routine.
This is the processing of delivery notes by order number.
The delivery note number is set automatically when you make the first picking for the customer order (NOTE! Not on dispatch but at picking entry).
The delivery note number is stored in the order header, and a row is created in the delivery note table.
The delivery note number on the order header is used for subsequent picking for the same customer order.
When invoicing, the delivery note number is copied to the invoice header. If there should be a backorder the delivery note number is zeroed (set to NULL) on the order header, and the next new picking will generate the new delivery note number.
The number series for delivery notes is stored in the system table (sy1).
If you set the delivery note number to a value lower than zero, the delivery note by order function will not be used, and no rows will be created in the delivery note table.
There is also another way of handling delivery notes where you manually specify which orders and rows within an order shall be linked to a delivery note.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Del note print date | FSUtskrDat | ztDateTime |  |  | datetime
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Delivery note no. | OrdFoljesedelsNr | ZtLong | 10 |  | int
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: fso Delivery note


Delivery note header (ffh)

Delivery note header

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Address label type | AdressLappTyp | ztInteger | 2 |  | smallint
Label print date | AdressLappUtskrDat | ztDateTime |  |  | datetime
Active | Aktiv | ztInteger | 1 |  | smallint
No. of EUR pallets | AntalEurPall | ztInteger | 5 |  | smallint
No. of packages | AntalKolli | ztInteger | 5 |  | smallint
No. of other pallets | AntalOvrPall | ztInteger | 5 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Volume m3 | ArtVolym | ztFloat | 15 | 4 | float
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Payment terms | BetKod | ztString | 2 |  | varchar
Specified gross wght | BruttoVikt | ztFloat | 10 | 3 | float
District | DistrKod | ztString | 4 |  | varchar
Division code | DivisKod | ztString | 3 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
DelNoteText | EditFsBlob | ztBlob | 1 |  | varchar
Text on picking list | EditPLBlob | ztBlob | 1 |  | varchar
Charge packaging cost | EmballageFakt | ztBoolean |  |  | char
Packaging BCU | EmballageKostnad | ZtBaseCurrAmount | 14 | 2 | money
Packaging inland, BCU | EmballageKostnInland | ZtBaseCurrAmount | 14 | 2 | money
One-package delivery | EnKolliSendNummer | ztBoolean |  |  | char
EUR certificate | EurCertifikat | ztString | 17 |  | varchar
Handling charge | ExpAvgKd | ztBoolean |  |  | char
Handling charge BCU | ExpeditionKostnad | ZtBaseCurrAmount | 14 | 2 | money
Express shipment | ExpressKod | ztBoolean |  |  | char
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoiced by | FakturerareKod | ztInteger | 2 |  | smallint
DelNoteText according to doc.rows | FastTextEfterDokRader | ztBoolean |  |  | char
Internal code FFH | FfhCreateType | ztInteger | 5 |  | smallint
Delivery note date | FFhDate | ztDate |  |  | datetime
Subsystem | FFhInt | ztInteger | 2 |  | smallint
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
Del Note, inv per order | FFhNr_Separata_Fakturor | ztBoolean |  |  | char
Delivery note no. (alpha) | FFhNrAlfa | ztString | 30 |  | varchar
Coll.invoice, delivery note | FfhSamFaktUtskr | ztBoolean |  |  | char
Status | FFhStatKod | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Charge insurance fee | ForsakringFakt | ztBoolean |  |  | char
Insurance BCU | ForsakringsKostnad | ZtBaseCurrAmount | 14 | 2 | money
Insurance inland, BCU | ForsakrKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Insurance cost % | ForsakrKostnProc | ZtDecimal73 | 6 | 2 | decimal
Freight charge code | FraktAvgKd | ztBoolean |  |  | char
Freight documents | FraktHandlKod | ztBoolean |  |  | char
Auto calc freight BCU | FraktKostnBer | ZtBaseCurrAmount | 14 | 2 | money
Total freight BCU | FraktKostnDeb | ZtBaseCurrAmount | 14 | 2 | money
Freight inland, BCU | FraktKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Man calc freight BCU | FraktKostnMan | ZtBaseCurrAmount | 14 | 2 | money
Freight bill no. | FraktSedelNr | ztString | 30 |  | varchar
Freight bill no., auto | FraktSedelNrAuto | ztBoolean |  |  | char
Freight bill type | FraktSedelTyp | ztInteger | 2 |  | smallint
Freight bill print date | FraktSedelUtskrDat | ztDateTime |  |  | datetime
Dispatch no. | FraktSendNummer | ztString | 15 |  | varchar
Bulk taxation | FraktSkrymmeKod | ztBoolean |  |  | char
Gross frght weight kg | FraktVikt | ztFloat | 10 | 3 | float
Delivery note Y/N | FsKd | ztBoolean |  |  | char
Delivery note no. | FsNr | ZtLong | 10 |  | int
Följesedelsnr kund | FsNrKund | ztString | 35 |  | varchar
Reason code | FsOrsakKod | ztInteger | 5 |  | smallint
Delivery note text | FsTextKod | ztString | 4 |  | varchar
Del note print date | FsUtskrDat | ztDateTime |  |  | datetime
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
ZIP/Post code | FtgPostnr | ztString | 10 |  | varchar
Goods label row 1 | GodsMarke1 | ztString | 40 |  | varchar
Goods label row 2 | GodsMarke2 | ztString | 40 |  | varchar
Goods label row 3 | GodsMarke3 | ztString | 40 |  | varchar
Goods label row 4 | GodsMarke4 | ztString | 40 |  | varchar
Third party trade | Handel3Part | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Credit order | KreditOrder | ztBoolean |  |  | char
Customer order date | KundBestDat | ztDate |  |  | datetime
Ordering dept | KundBestNamn | ztString | 36 |  | varchar
Customer order no. | KundBestNr | ztString | 30 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Freight payer | KundFraktBetalareNr | ztCompanyNo | 20 |  | varchar
Charge freight cost | KundFraktDeb | ztBoolean |  |  | char
Sales price incl VAT/tax | KundPrisInklMoms | ztBoolean |  |  | char
Customer reference | KundRef2 | ztString | 30 |  | varchar
Text on invoice | KundSpecTextFa | ztBoolean |  |  | char
Text on delivery note | KundSpecTextFs | ztBoolean |  |  | char
Text on picking list | KundSpecTextPl | ztBoolean |  |  | char
Customer specific text | KundTextKod | ztString | 4 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Gross weight, kg, deliv | LevArtBtotVikt | ztFloat | 10 | 3 | float
Net weight , deliv | LevArtVikt | ztFloat | 10 | 3 | float
Volume, m³, deliv | LevArtVolym | ztFloat | 15 | 2 | float
Dispatch notice | LevAviNr | ztString | 35 |  | varchar
Dispatch notice | LevAviseringKod | ztBoolean |  |  | char
Before 12 deliv | LevForeTolv | ztBoolean |  |  | char
Ship documents | LevHandlKod | ztBoolean |  |  | char
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Preparation day | OrdBerednDat | ztDate |  |  | datetime
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order date | OrdDatum | ztDate |  |  | datetime
Cost | OrderCostCurrency | ztBoolean |  |  | char
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Delivery addr, company | OrdLevAdr1 | ztString | 36 |  | varchar
Delivery address 1 | OrdLevAdr2 | ztString | 36 |  | varchar
Delivery address 2 | OrdLevAdr3 | ztString | 36 |  | varchar
Delivery address 3 | OrdLevAdr4 | ztString | 36 |  | varchar
Destination, district | OrdLevAdrBstOrt | ztString | 36 |  | varchar
Destination, country | OrdLevAdrLandsKod | ztString | 3 |  | varchar
State code | OrdLevAdrProvinceCode | ztString | 5 |  | varchar
Delivery notice 1 | OrdLevAnvisnRad1 | ztString | 30 |  | varchar
Delivery notice 2 | OrdLevAnvisnRad2 | ztString | 30 |  | varchar
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Order value | OrdSum | ZtBaseCurrAmount | 14 | 2 | money
Est.order value | OrdSumFraktBer | ZtBaseCurrAmount | 14 | 2 | money
Dispatched on, actual | OrdVerklLevDat | ztDate |  |  | datetime
Other inv. cost-1 BCU | OvrFaktAvgift1 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-10 BCU | OvrFaktAvgift10 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-2 BCU | OvrFaktAvgift2 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-3 BCU | OvrFaktAvgift3 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-4 BCU | OvrFaktAvgift4 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-5 BCU | OvrFaktAvgift5 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-6 BCU | OvrFaktAvgift6 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-7 BCU | OvrFaktAvgift7 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-8 BCU | OvrFaktAvgift8 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-9 BCU | OvrFaktAvgift9 | ZtBaseCurrAmount | 14 | 2 | money
Charge other invoice.cost-1 | OvrFaktKostn1Fakt | ztBoolean |  |  | char
Charge other invoice.cost-2 | OvrFaktKostn2Fakt | ztBoolean |  |  | char
Other inv. cost-1 BCU | OvrFaktKostnad1 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-2 BCU | OvrFaktKostnad2 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-1 inland, BCU | OvrFaktKostnInland1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 inland, BCU | OvrFaktKostnInland2 | ZtBaseCurrAmount | 14 | 2 | money
Packer | PackareKod | ztInteger | 2 |  | smallint
Packing slip printed | PackSedelUtskrDat | ztDateTime |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Picked date WMS | PickedDateWMS | ztDateTime |  |  | datetime
Picking list date | PLUtskrDat | ztDateTime |  |  | datetime
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Send EDI | SendEdi | ztBoolean |  |  | char
Sent EDI | SendEdiDT | ztDateTime |  |  | datetime
Serv.order no | ServOrderNr | Jeeves_SONo | 9 |  | bigint
Shipment plan alpha ID | ShipmPlanAlphaId | ztString | 30 |  | varchar
Language | SprakKod | ztInteger | 3 |  | smallint
COD/adv amt | TA_AmtCOD | ztMoney | 14 | 2 | money
Freight bill number | TA_ConsNo | ztString | 20 |  | varchar
CMR document message | TA_CustomerMessage | ztString | 40 |  | varchar
From TA | TA_edit | ztBlob | 1 |  | varchar
Fax notification number | TA_FaxNotifiedNo | ztString | 40 |  | varchar
GAN no | TA_GANno | ztString | 20 |  | varchar
Pallet meterage | TA_Loadmeter | ztFloat | 8 | 2 | float
Email address notification | TA_MailNotified | ztString | 60 |  | varchar
Phone notification number | TA_PhonNotifiedNo | ztString | 40 |  | varchar
AffectTemplCode | TA_TemplKompCd | ztString | 1 |  | varchar
Text after document rows | TextEfterDokRader | ztBoolean |  |  | char
General/fixed text | TextKod | ztString | 4 |  | varchar
Trailer ID | TrailerId | ztString | 17 |  | varchar
Transport reservation no. | TransBokNr | ztString | 35 |  | varchar
Transport ID | TransportId | ztString | 17 |  | varchar
Carrier code | TransportorsKod | ztString | 17 |  | varchar
Transport ref | TransportRef | ztString | 17 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Packaging, curr | vb_EmballageKostnad | ztMoney | 14 | 2 | money
Packaging inland, curr | vb_EmballageKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Handling charge curr | vb_ExpeditionKostnad | ztMoney | 14 | 2 | money
Invoice amount, curr | Vb_FaktSum | ztMoney | 14 | 2 | money
Insurance, curr | vb_ForsakringsKostnad | ztMoney | 14 | 2 | money
Insurance inland, curr | vb_ForsakrKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Auto calc freight, curr | vb_FraktKostnBer | ztMoney | 14 | 2 | money
Total freight, curr | vb_FraktKostnDeb | ztMoney | 14 | 2 | money
Freight inland, curr | vb_FraktKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Man calc freight, curr | vb_FraktKostnMan | ztMoney | 14 | 2 | money
Other invc cost-1, curr | vb_OvrFaktAvgift1 | ztMoney | 14 | 2 | money
Other invc cost-10, curr | vb_OvrFaktAvgift10 | ztMoney | 14 | 2 | money
Other invc cost-2, curr | vb_OvrFaktAvgift2 | ztMoney | 14 | 2 | money
Other invc cost-3, curr | vb_OvrFaktAvgift3 | ztMoney | 14 | 2 | money
Other invc cost-4, curr | vb_OvrFaktAvgift4 | ztMoney | 14 | 2 | money
Other invc cost-5, curr | vb_OvrFaktAvgift5 | ztMoney | 14 | 2 | money
Other invc cost-6, curr | vb_OvrFaktAvgift6 | ztMoney | 14 | 2 | money
Other invc cost-7, curr | vb_OvrFaktAvgift7 | ztMoney | 14 | 2 | money
Other invc cost-8, curr | vb_OvrFaktAvgift8 | ztMoney | 14 | 2 | money
Other invc cost-9, curr | vb_OvrFaktAvgift9 | ztMoney | 14 | 2 | money
Other invc cost-1, curr | vb_OvrFaktKostnad1 | ztMoney | 14 | 2 | money
Other invc cost-2, curr | vb_OvrFaktKostnad2 | ztMoney | 14 | 2 | money
Extra cost-1 inland, curr | vb_OvrFaktKostnInland1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 inland, curr | vb_OvrFaktKostnInland2 | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax, curr | VbFaktMoms | ztMoney | 14 | 2 | money
Invoice total excl tax | VbFaktTotUMoms | ztMoney | 14 | 2 | money
Weight/volume automatic | ViktSumOrder | ztBoolean |  |  | char
Height | VolHeight | ztInteger | 4 |  | smallint
Length | VolLength | ztInteger | 4 |  | smallint
Volume | Volume | ztFloat | 10 | 3 | float
Width | VolWidth | ztInteger | 4 |  | smallint
Our reference | Vref | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: FFhDoc Freight documents

    Program: FFhDocX Frght bill/del note/addr label

    Program: FFhFakt Invoicing, delivery note

    Program: FFhFaktA Reprint invoicing, delivery note

    Program: FfhLevK Dispatch planning, cust order

    Program: FfhLevL Dispatch planning, mtrl -> subcontract

    Program: FfhLevP Dispatch planning per delivery note

    Program: FfhLevPU Dispatch planning per del note, picked

    Program: FfhLevPWMS Dispatch planning per delivery note

    Program: FFhPack Packing plan, delivery note

    Program: FfhUCorl Pick deliv note, bookings

    Program: FfhUtPl Picking, delivery note


Delivery note rows (ffl)

Delivery note rows.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Bin | Ars_LagPlats | ztBinLocation | 20 |  | varchar
Item description | ArtBeskr | ztString | 30 |  | varchar
Item class | ArtKod | ztInteger | 3 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Customer item no. | ArtNrKund | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Product class | ArtProdKlass | ztString | 4 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
External text | EdiText | ztBlob | 1 |  | varchar
Unit code | EnHetsKod | ztString | 4 |  | varchar
Subsystem | FFhInt | ztInteger | 2 |  | smallint
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
RowNo | FFhRadNr | ztInteger | 5 |  | int
Row status | FFlRadSt | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Delivery note no. | FsNr | ZtLong | 10 |  | int
Row number | FsRadNr | ztInteger | 4 |  | int
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Supplier item descr | LevsArtBeskr | ztString | 255 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Item no. required | mrArtNr | ztString | 30 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Order row qty, alt unit | OrdAntalAltEnh | ZtQty | 14 | 2 | decimal
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Preparation day | OrdBerednDat | ztDate |  |  | datetime
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order date | OrdDatum | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Dispatch qty alt unit | OrdLevAntalAltEnh | ZtQty | 14 | 2 | decimal
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Remaining qty | OrdRestAnt | ZtQty | 14 | 2 | decimal
Remaining qty, alt unit | OrdRestAntAltEnh | ZtQty | 14 | 2 | decimal
Backorder | OrdRestNot | ztBoolean |  |  | char
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Order spec text | OrpRadText | ztString | 255 |  | varchar
Order spec text/DN | OrpRadTextFs | ztBoolean |  |  | char
Package item | PaketArtikel | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Serv.order no | ServOrderNr | Jeeves_SONo | 9 |  | bigint
Order row, service | ServOrdRadNr | ztInteger | 5 |  | int
Language | SprakKod | ztInteger | 3 |  | smallint
Orig order qty | UrsprOrderAntal | ZtQty | 14 | 2 | decimal
Print on delivery note | UtskrFoljesedel | ztBoolean |  |  | char
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Row value, curr (+tax) | Vb_RadVardeInklMoms | ztMoney | 14 | 2 | money
Order row amt, curr | VbOrdRadSum | ztMoney | 14 | 2 | money


Delivery note status (x8)

The delivery note status table is used to see the current status of a freight bill or delivery note.

The following standard records exist. Do not alter/delete:

Status (FfhStatKod) | Delivery note status (FfhStatBeskr) | Description
10 | Entry in progress |
13 | Entered |
20 | Planned |
40 | Dispatch started |
50 | Released for invoicing |
70 | Invoiced | Invoice printed and invoice number assigned from order
80 | Closed |
90 | Canceled |

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Delivery note status | FfhStatBeskr | ztString | 50 |  | varchar
Status | FfhStatKod | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xx8 Delivery note status


Delivery note, fixed texts (xftx)

Fixed texts that can be used when printing delivery notes from delivery planning routine.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Delivery note text | FsTextKod | ztString | 4 |  | varchar
Delivery note text | FsTextKodBeskr | ztString | 30 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Default text | KodDefaultText | ztBoolean |  |  | char
Copyable text | KodFastText | ztBoolean |  |  | char
Choice at copy | KodValCopyText | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Text after document rows | TextEfterDokRader | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xftx Delivery note text


Delivery note, row connection (vfflk)

Table linking customer order rows, manufacturing orders (subcontract), service order rows, etc. to the delivery note routine.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Delivery note date, rcv | BestFoljesedelsDat | ztDate |  |  | datetime
Delivery note no., rcv | BestFoljesedelsNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
To dispatch | FfhAntalAttLev | ZtQty | 14 | 2 | decimal
To disp, alt unit | FfhAntalAttLevAltEnh | ZtQty | 14 | 2 | decimal
Delivery note date | FFhDate | ztDate |  |  | datetime
Subsystem | FFhInt | ztInteger | 2 |  | smallint
Picked quantity | FfhLevAntal | ZtQty | 14 | 2 | decimal
Picked qty, alt unit | FfhLevAntalAltEnh | ZtQty | 14 | 2 | decimal
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
Delivery note no. (alpha) | FFhNrAlfa | ztString | 30 |  | varchar
RowNo | FFhRadNr | ztInteger | 5 |  | int
RowNoBOMpos | FFhRadNrStrPos | ztInteger | 5 |  | int
Row status | FFlRadSt | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
External qty | FsExternQty | ztBoolean |  |  | char
Received deliv | FsInleverans | ztBoolean |  |  | char
Delivery note no. | FsNr | ZtLong | 10 |  | int
Reason code | FsOrsakKod | ztInteger | 5 |  | smallint
Row number | FsRadNr | ztInteger | 4 |  | int
Dispatch | FsUtleverans | ztBoolean |  |  | char
Del note print date | FsUtskrDat | ztDateTime |  |  | datetime
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Dispatch notice row | LevAviRadNr | ztInteger | 5 |  | int
Item version, demand | mrArtikelVariant | ztString | 30 |  | varchar
Item no. required | mrArtNr | ztString | 30 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Dispatch qty alt unit | OrdLevAntalAltEnh | ZtQty | 14 | 2 | decimal
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Rad inom sidan | RadInomSida | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Serv.order no | ServOrderNr | Jeeves_SONo | 9 |  | bigint
Order row, service | ServOrdRadNr | ztInteger | 5 |  | int
Shipment plan alpha ID | ShipmPlanAlphaId | ztString | 30 |  | varchar
Sidnummer special | SidNrSpec | ztInteger | 5 |  | smallint
Language | SprakKod | ztInteger | 3 |  | smallint
Print on delivery note | UtskrFoljeSedel | ztBoolean |  |  | char
Item group | VaruGruppKod | ztString | 8 |  | varchar


Delivery note, row connection (fflk)

Table linking customer order rows, manufacturing orders (subcontract), service order rows, etc. to the delivery note routine.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Delivery note date, rcv | BestFoljesedelsDat | ztDate |  |  | datetime
Delivery note no., rcv | BestFoljesedelsNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
To dispatch | FfhAntalAttLev | ZtQty | 14 | 2 | decimal
To disp, alt unit | FfhAntalAttLevAltEnh | ZtQty | 14 | 2 | decimal
Delivery note date | FFhDate | ztDate |  |  | datetime
Subsystem | FFhInt | ztInteger | 2 |  | smallint
Picked quantity | FfhLevAntal | ZtQty | 14 | 2 | decimal
Picked qty, alt unit | FfhLevAntalAltEnh | ZtQty | 14 | 2 | decimal
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
Delivery note no. (alpha) | FFhNrAlfa | ztString | 30 |  | varchar
RowNo | FFhRadNr | ztInteger | 5 |  | int
RowNoBOMpos | FFhRadNrStrPos | ztInteger | 5 |  | int
Row status | FFlRadSt | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
External qty | FsExternQty | ztBoolean |  |  | char
Received deliv | FsInleverans | ztBoolean |  |  | char
Delivery note no. | FsNr | ZtLong | 10 |  | int
Reason code | FsOrsakKod | ztInteger | 5 |  | smallint
Row number | FsRadNr | ztInteger | 4 |  | int
Dispatch | FsUtleverans | ztBoolean |  |  | char
Del note print date | FsUtskrDat | ztDateTime |  |  | datetime
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Stocked | LagerBokas | ztBoolean |  |  | char
Dispatch notice row | LevAviRadNr | ztInteger | 5 |  | int
Item version, demand | mrArtikelVariant | ztString | 30 |  | varchar
Item no. required | mrArtNr | ztString | 30 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Dispatch qty alt unit | OrdLevAntalAltEnh | ZtQty | 14 | 2 | decimal
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Rad inom sidan | RadInomSida | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Serv.order no | ServOrderNr | Jeeves_SONo | 9 |  | bigint
Order row, service | ServOrdRadNr | ztInteger | 5 |  | int
Shipment plan alpha ID | ShipmPlanAlphaId | ztString | 30 |  | varchar
Sidnummer special | SidNrSpec | ztInteger | 5 |  | smallint
Language | SprakKod | ztInteger | 3 |  | smallint
Print on delivery note | UtskrFoljeSedel | ztBoolean |  |  | char
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: xfflk Show delivery note rows


Delivery plan comparison (ordj)

External order numbers.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
External order number | ExtOrderNr | ztString | 17 |  | varchar
External order row number | ExtOrdRadNr | ztInteger | 5 |  | int
External order row no. for pkg | ExtOrdRadNrStrPos | ztInteger | 4 |  | int
External backorder no. | ExtOrdRestNr | ztInteger | 2 |  | smallint
External order status | ExtOrdSta | ztInteger | 2 |  | smallint
External order type | ExtOrdTyp | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Old order quantity | OldOrdAntal | ZtQty | 14 | 2 | decimal
Estimated dispatch date | OldOrdBerLevDat | ztDate |  |  | datetime
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Delivery remarks (view) (vlbh)

View to summarize delivery remarks by arrival notification and year under a supplier.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Remark | AnkomstAnm | ztInteger | 5 |  | smallint
Quantity | Antal | ZtQty | 14 | 2 | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint


Delivery role, details (LevD)

Delivery role, details

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | lagplatsnamn | ztString | 50 |  | varchar
Inventory location | lagstalle | ztString | 2 |  | varchar
Dispatch role | Leveransroll | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Delivery roles (levr)

Definition of delivery roles, consisting of one or more cost centres, that are used for e-purchasing.

The delivery address to be printed on the purchase order is specified in the respective inventory location.

The delivery role is linked to a purchasing role (and therefore to the individuals who have a specific purchasing role) in order to specify to which cost centre purchases can be made by the relevant purchasing role.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Dispatch role | Leveransroll | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Levr Delivery roles


Demand letter texts (fhkt)

Definition of demand letter texts per language and demand level (max. 4 levels) for printing on demand letters.

NOTE. If the check box 'Claim collection' (kravejinkasso) is checked in the program 'Interest invoice/reminder agreement' (xrav) there will be a demand letter text for demand 5 which applies when the demand is sent to collection.

No records are defined on delivery.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
No. of reminders | KravAnt | ztInteger | 1 |  | smallint
Reminder text | KravText | ztBlob | 1 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint

    This table is the main table in the following programs:

    Program: xFhkt Demand letter texts


Departments (Attr_Dep)

Definition of department to use when classify personnel. This classification is only used if the need arises, e.g. for search or statistic purposes, and does not control any processes in the system.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Department | AttrDepartment | ztString | 6 |  | varchar
Department | AttrDepartmentdescr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Attr_Dep Departments


Depreciation details, fixed assets (inad)

Table of fixed asset depreciation details.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Activation date | aktiveringsdatum | ztDate |  |  | datetime
Fixed assets group | anlgrp | ztString | 10 |  | varchar
Acquisition amount | Anskbelopp | ZtBaseCurrAmount | 14 | 2 | money
Deprn fr acq date | AvskrAnskDat | ztBoolean |  |  | char
No. of deprec periods | AvskrAntalPerioder | ztInteger | 3 |  | smallint
Depreciated amount | Avskrbelopp | ZtBaseCurrAmount | 14 | 2 | money
Deprn (whole number) | AvskrHeltal | ztBoolean |  |  | char
Depreciation journal | Avskrjournal | ZtLong | 5 |  | int
Depreciation method | avskrmet | ztInteger | 2 |  | smallint
Deprec. percent | AvskrProcent | ztFloat | 8 | 4 | float
Accounting date | bokfdat | ztDate |  |  | datetime
Text | edit | ztBlob | 1 |  | varchar
Economic life | EkLivsL | ztInteger | 4 |  | smallint
Econ life in months | EklivsM | ztInteger | 4 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Fixed asset no | inventarie | ZtLong | 10 |  | int
Component fixed asset | InventariePos | ztInteger | 5 |  | smallint
Fixed asset trans amount | InventarieTransBelopp | ZtBaseCurrAmount | 14 | 2 | money
Residual value | InvRest | ZtBaseCurrAmount | 14 | 2 | money
Period | period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | redovisnar | ztInteger | 4 |  | smallint
Entry date | regdat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Last depreciation year | SenAvskrAr | ztInteger | 5 |  | smallint
Last depreciation period | SenAvskrPer | ztInteger | 5 |  | smallint
Voucher no. | vernr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: inad Recorded depreciation details


Depreciation journal status (xins)

Table of depreciation journal status.

The journal must have the status Ready for posting (20) for a depreciation journal and posting to be created, after which the status is changed to Posted (30). The status can be changed to Canceled (90) as long as the journal has not received a voucher number.

The following standard records exist. Do not alter/delete:

Deprn journal status (avskjstatus) | avskjstatusB (avskjstatusB)
0 | Entry in progress
20 | Ready for posting
30 | Posted
90 | Canceled

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Deprn journal status | avskjstatus | ztInteger | 2 |  | smallint
Avskr.journ.status | avskjstatusB | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xins Depreciation journal status


Depreciation methods (xav)

Table of depreciation methods used to determine how the fixed assets are to be written off.

The following standard records exist. Do not alter/delete:

Depreciation method (avskrmet) | Depreciation method (avskrmetB)
0 | According to plan
90 | Tax Principle rule
91 | Tax Supplementary rule

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accelerated method | AccelDepr | ztBoolean |  |  | char
Deprn (whole number) | Avskrheltal | ztBoolean |  |  | char
Depreciation layer | AvskrLayer | ztInteger | 1 |  | smallint
Depreciation method | avskrmet | ztInteger | 2 |  | smallint
Depreciation method | avskrmetB | ztString | 50 |  | varchar
Deprec. percent | AvskrProcent | ztFloat | 8 | 4 | float
Degressive depreciation | Degressiv | ztBoolean |  |  | char
Factor | DepRatio | ZtDecimal73 | 8 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xav Depreciation methods


Dept/grp (xxo)

Table of groups/competence areas that can later be linked to people and used for planning, e.g. in JPS.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Dept/grp | avdgrupp | ztInteger | 5 |  | smallint
Planning group | avdgruppb | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xxo Department/group for planning


Description of resource types for capacity workload (ManufRes_Type)

Internal definition of occurring resource types in manufacturing. Definition is used (introduced in Version 9) from the function Ceiling for workload capacity.

The following standard records exist. Do not alter/delete:

Type of resource (ManufRes_Type) | Resource type (ManufRes_Type_Descr)
1 | Manufacturing group
2 | Work group

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Type of resource | ManufRes_Type | ztInteger | 5 |  | smallint
Resource type | ManufRes_Type_Descr | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ManufRes_Type Resource types for capacity workload


Designations, posting (wfbf)

Setting of columns in Jeeves e-Applications. You can specify prompts in available languages, if the term is to be shown in the form and/or list etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Change allowed | ChangeColumn | ztBoolean |  |  | char
Link to previous | connprevcol | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Name of column | JvsColumnName | ztString | 128 |  | varchar
Module ID | ModuleId | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Displaymode | wflgridshowmode | ztInteger | 1 |  | smallint
Position | wflgridsortnr | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: wfbf Designations, posting


Designations, posting OLD (wfbe)

Definition of names for account segments and other terms that will be presented (posting stamp), and the order of these upon electronic approval in Jeeves e-applications.

The designation of the account segments for external users may be different from the standard prompts in Jeeves. This definition makes it possible to use several designations for the same account segment.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegBeskr | ztString | 50 |  | varchar
Description | BenBeskr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4Beskr | ztString | 30 |  | varchar
S5 | K5Beskr | ztString | 30 |  | varchar
S6 | K6Beskr | ztString | 30 |  | varchar
S7 | K7Beskr | ztString | 30 |  | varchar
Cost unit | KostbarBeskr | ztString | 30 |  | varchar
Cost centre | KstBeskr | ztString | 25 |  | varchar
Account | KtoBeskr | ztString | 80 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project name | ProjDescr | ztString | 40 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Description debit | wfldebbeskr | ztString | 25 |  | varchar
Printout auto rule | wflgridsortnr_auto | ztInteger | 2 |  | smallint
Printing designation | wflgridsortnr_ben | ztInteger | 2 |  | smallint
Printing debit | wflgridsortnr_deb | ztInteger | 2 |  | smallint
Printout S4 | wflgridsortnr_k4 | ztInteger | 2 |  | smallint
Printout S5 | wflgridsortnr_k5 | ztInteger | 2 |  | smallint
Printout S6 | wflgridsortnr_k6 | ztInteger | 2 |  | smallint
Printout S7 | wflgridsortnr_k7 | ztInteger | 2 |  | smallint
Printing S3 | wflgridsortnr_kb | ztInteger | 2 |  | smallint
Print Shortcut | wflgridsortnr_KortKod | ztInteger | 2 |  | smallint
Printing credit | wflgridsortnr_kre | ztInteger | 2 |  | smallint
Printing cost centre | wflgridsortnr_kst | ztInteger | 2 |  | smallint
Printing acct | wflgridsortnr_kto | ztInteger | 2 |  | smallint
Printing quantity | wflgridsortnr_kvant | ztInteger | 2 |  | smallint
Printing projects | wflgridsortnr_prj | ztInteger | 2 |  | smallint
Print currency amount | wflgridsortnr_vbbelopp | ztInteger | 2 |  | smallint
Description shortcut | wflkortkodbeskr | ztString | 25 |  | varchar
Description credit | wflkrebeskr | ztString | 25 |  | varchar
Description quantity | wflkvantbeskr | ztString | 25 |  | varchar
Descr currency amount | wflVbBeloppBeskr | ztString | 25 |  | varchar


Detail. Cust Pmts->GL (jivt)

Detailed information per transaction of how incoming payments are posted when integrated with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Bank | BankId | ztString | 10 |  | varchar
Bill of exchange no. | BoE_No | ZtLong | 9 |  | int
Check number | checkNo | ZtLong | 9 |  | int
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no., advance | FaktNrForskott | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Integration detail | IntField | ztInteger | 2 |  | smallint
IntField in template | IntFieldTempl | ztInteger | 5 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Reference number | ReferensNr | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: vJivt Show incoming payment journal posting


Detailed workload and capacity (WorkloadU)

Booked and available capacity for resource and time interval.
Resource intended for existing production groups.
Time interval is controlled by the time interval you have defined yourself via the daily calendar (work time calendar) that you link to the resource.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of machines | AntMaskiner | ztFloat | 6 | 2 | float
Work group | ArbetsLag | ztString | 6 |  | varchar
Identitetskolumn | DummySQLIdentity | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Record has been updated | IsUpdated | ztBoolean |  |  | char
Manufacturing resource | ManufRes_Descr | ztString | 60 |  | varchar
Manufacturing resource ID | ManufRes_Id | ZtLong | 10 |  | int
%-tol overload | OverLoadTolProc | ZtDecimal73 | 8 | 3 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Row | radpos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Start date cal.month | workload_CalenderMonth | ztInteger | 5 |  | smallint
Start date cal.week | workload_CalenderWeek | ztInteger | 5 |  | smallint
Start date weekday | workload_CalenderWeekday | ztInteger | 5 |  | smallint
Capacity | Workload_Capacity | ZtDecimal73 | 9 | 2 | decimal
Acc capacity | workload_capacity_Ack | ZtDecimal73 | 9 | 2 | decimal
Acc capacity (tol) | Workload_Capacity_Ack_OLT | ZtDecimal73 | 9 | 2 | decimal
Available capacity | Workload_Capacity_Avail | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity | Workload_Capacity_Avail_Ack | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity, lowest | workload_Capacity_Avail_Ack_LV | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity, lowest (tol) | workload_Capacity_Avail_Ack_LV_OLT | ZtDecimal73 | 9 | 2 | decimal
Acc MRP avail cap, lowest | workload_Capacity_Avail_Ack_LV_Prel | ZtDecimal73 | 9 | 2 | decimal
Acc MRP avail cap, lowest (tol) | workload_Capacity_Avail_Ack_LV_Prel_OLT | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity (tol) | Workload_Capacity_Avail_Ack_OLT | ZtDecimal73 | 9 | 2 | decimal
Acc MRP avail cap | workload_capacity_avail_Ack_Prel | ZtDecimal73 | 9 | 2 | decimal
Acc MRP avail cap (tol) | workload_capacity_avail_Ack_Prel_olt | ZtDecimal73 | 9 | 2 | decimal
Available capacity (tol) | Workload_Capacity_Avail_OLT | ZtDecimal73 | 9 | 2 | decimal
MRP avail cap | Workload_Capacity_Avail_Prel | ZtDecimal73 | 9 | 2 | decimal
MRP avail cap (tol) | Workload_Capacity_Avail_Prel_OLT | ZtDecimal73 | 9 | 2 | decimal
Booked workload | Workload_Capacity_Booked | ZtDecimal73 | 9 | 2 | decimal
Acc workload | workload_capacity_booked_Ack | ZtDecimal73 | 9 | 2 | decimal
MRP Acc workload | workload_capacity_booked_Ack_Prel | ZtDecimal73 | 9 | 2 | decimal
MRP booked workload | workload_capacity_booked_Prel | ZtDecimal73 | 9 | 2 | decimal
Capacity (tol) | Workload_Capacity_OLT | ZtDecimal73 | 9 | 2 | decimal
Start date/time | Workload_Startdate | ztDateTime |  |  | datetime
End date/time | Workload_Stopdate | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Workload Detailed workload and capacity


Detailed workload and capacity (WorkLoad)

Booked and available capacity for resource and time interval.
Resource intended for existing production groups.
Time interval is controlled by the time interval you have defined yourself via the daily calendar (work time calendar) that you link to the resource.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of machines | AntMaskiner | ztFloat | 6 | 2 | float
Work group | ArbetsLag | ztString | 6 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Record has been updated | IsUpdated | ztBoolean |  |  | char
Manufacturing resource ID | ManufRes_Id | ZtLong | 10 |  | int
%-tol overload | OverLoadTolProc | ZtDecimal73 | 8 | 3 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Row | radpos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLidentity | ZtLong | 10 |  | int
Identity | SQLIDENTITY_next | ZtLong | 10 |  | int
Identity | SQLIDENTITY_prev | ZtLong | 10 |  | int
Start date cal.month | workload_CalenderMonth | ztInteger | 5 |  | smallint
Start date cal.week | workload_CalenderWeek | ztInteger | 5 |  | smallint
Start date weekday | workload_CalenderWeekday | ztInteger | 5 |  | smallint
Capacity | Workload_Capacity | ZtDecimal73 | 9 | 2 | decimal
Acc capacity | workload_capacity_Ack | ZtDecimal73 | 9 | 2 | decimal
Acc capacity (tol) | Workload_Capacity_Ack_OLT | ZtDecimal73 | 9 | 2 | decimal
Available capacity | Workload_Capacity_Avail | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity | Workload_Capacity_Avail_Ack | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity, lowest | workload_Capacity_Avail_Ack_LV | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity, lowest (tol) | workload_Capacity_Avail_Ack_LV_OLT | ZtDecimal73 | 9 | 2 | decimal
Acc MRP avail cap, lowest | workload_Capacity_Avail_Ack_LV_Prel | ZtDecimal73 | 9 | 2 | decimal
Acc MRP avail cap, lowest (tol) | workload_Capacity_Avail_Ack_LV_Prel_OLT | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity (tol) | Workload_Capacity_Avail_Ack_OLT | ZtDecimal73 | 9 | 2 | decimal
Acc MRP avail cap | workload_capacity_avail_Ack_Prel | ZtDecimal73 | 9 | 2 | decimal
Acc MRP avail cap (tol) | workload_capacity_avail_Ack_Prel_OLT | ZtDecimal73 | 9 | 2 | decimal
Available capacity (tol) | Workload_Capacity_Avail_OLT | ZtDecimal73 | 9 | 2 | decimal
MRP avail cap | Workload_Capacity_Avail_Prel | ZtDecimal73 | 9 | 2 | decimal
MRP avail cap (tol) | Workload_Capacity_Avail_Prel_OLT | ZtDecimal73 | 9 | 2 | decimal
Booked workload | Workload_Capacity_Booked | ZtDecimal73 | 9 | 2 | decimal
Acc workload | workload_capacity_booked_Ack | ZtDecimal73 | 9 | 2 | decimal
MRP Acc workload | workload_capacity_booked_Ack_Prel | ZtDecimal73 | 9 | 2 | decimal
MRP booked workload | workload_capacity_booked_Prel | ZtDecimal73 | 9 | 2 | decimal
Capacity (tol) | Workload_Capacity_OLT | ZtDecimal73 | 9 | 2 | decimal
Ej aktuella värden | Workload_DirtyValues | ztInteger | 5 |  | smallint
Start date/time | Workload_Startdate | ztDateTime |  |  | datetime
End date/time | Workload_Stopdate | ztDateTime |  |  | datetime


Detailed workload and capacity (reconstruction) (WorkLoad_tmp)

Booked and available capacity for resource and time interval.
Resource intended for existing production groups.
Time interval is controlled by the time interval you have defined yourself via the daily calendar (work time calendar) that you link to the resource.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of machines | AntMaskiner | ztFloat | 6 | 2 | float
Work group | ArbetsLag | ztString | 6 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Manufacturing resource ID | ManufRes_Id | ZtLong | 10 |  | int
%-tol overload | OverLoadTolProc | ZtDecimal73 | 8 | 3 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Row | radpos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
@zPrompt=null | sqlidentity_from_wl | ZtLong | 10 |  | int
Identity | SQLIDENTITY_next | ZtLong | 10 |  | int
Identity | SQLIDENTITY_prev | ZtLong | 10 |  | int
Start date cal.month | workload_CalenderMonth | ztInteger | 5 |  | smallint
Start date cal.week | workload_CalenderWeek | ztInteger | 5 |  | smallint
Start date weekday | workload_CalenderWeekday | ztInteger | 5 |  | smallint
Capacity | Workload_Capacity | ZtDecimal73 | 9 | 2 | decimal
Acc capacity | workload_capacity_Ack | ZtDecimal73 | 9 | 2 | decimal
Acc capacity (tol) | Workload_Capacity_Ack_OLT | ZtDecimal73 | 9 | 2 | decimal
Available capacity | Workload_Capacity_Avail | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity | Workload_Capacity_Avail_Ack | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity, lowest | workload_Capacity_Avail_Ack_LV | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity, lowest (tol) | workload_Capacity_Avail_Ack_LV_OLT | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity (tol) | Workload_Capacity_Avail_Ack_OLT | ZtDecimal73 | 9 | 2 | decimal
Available capacity (tol) | Workload_Capacity_Avail_OLT | ZtDecimal73 | 9 | 2 | decimal
Booked workload | Workload_Capacity_Booked | ZtDecimal73 | 9 | 2 | decimal
Acc workload | workload_capacity_booked_Ack | ZtDecimal73 | 9 | 2 | decimal
Capacity (tol) | Workload_Capacity_OLT | ZtDecimal73 | 9 | 2 | decimal
Ej aktuella värden | Workload_DirtyValues | ztInteger | 5 |  | smallint
Start date/time | Workload_Startdate | ztDateTime |  |  | datetime
End date/time | Workload_Stopdate | ztDateTime |  |  | datetime


Detailed workload and capacity (reconstruction) (WorkloadU_tmp)

Booked and available capacity for resource and time interval.
Resource intended for existing production groups.
Time interval is controlled by the time interval you have defined yourself via the daily calendar (work time calendar) that you link to the resource.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of machines | AntMaskiner | ztFloat | 6 | 2 | float
Work group | ArbetsLag | ztString | 6 |  | varchar
Identitetskolumn | DummySQLIdentity | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Manufacturing resource | ManufRes_Descr | ztString | 60 |  | varchar
Manufacturing resource ID | ManufRes_Id | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Row | radpos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Start date cal.month | workload_CalenderMonth | ztInteger | 5 |  | smallint
Start date cal.week | workload_CalenderWeek | ztInteger | 5 |  | smallint
Start date weekday | workload_CalenderWeekday | ztInteger | 5 |  | smallint
Capacity | Workload_Capacity | ZtDecimal73 | 9 | 2 | decimal
Acc capacity | workload_capacity_Ack | ZtDecimal73 | 9 | 2 | decimal
Available capacity | Workload_Capacity_Avail | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity | Workload_Capacity_Avail_Ack | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity, lowest | workload_Capacity_Avail_Ack_LV | ZtDecimal73 | 9 | 2 | decimal
Booked workload | Workload_Capacity_Booked | ZtDecimal73 | 9 | 2 | decimal
Acc workload | workload_capacity_booked_Ack | ZtDecimal73 | 9 | 2 | decimal
Start date/time | Workload_Startdate | ztDateTime |  |  | datetime
End date/time | Workload_Stopdate | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Workload_tmp Detailed workload and capacity (reconstruction)


Detailed workload and capacity for net requirements (WorkLoad_NetReq)

Booked and available capacity for resource and time interval.
Resource intended for existing production groups.
Time interval is controlled by the time interval you have defined yourself via the daily calendar (work time calendar) that you link to the resource.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Identitetskolumn | ConnToSQLidentity | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Manufacturing resource ID | ManufRes_Id | ZtLong | 10 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Identity | SQLIdentity_Next | ZtLong | 10 |  | int
Identity | SQLIdentity_Prev | ZtLong | 10 |  | int
Capacity | Workload_Capacity | ZtDecimal73 | 9 | 2 | decimal
Acc capacity | workload_capacity_Ack | ZtDecimal73 | 9 | 2 | decimal
Acc capacity (tol) | Workload_Capacity_Ack_OLT | ZtDecimal73 | 9 | 2 | decimal
Available capacity | Workload_Capacity_Avail | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity | Workload_Capacity_Avail_Ack | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity, lowest | workload_Capacity_Avail_Ack_LV | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity, lowest (tol) | workload_Capacity_Avail_Ack_LV_OLT | ZtDecimal73 | 9 | 2 | decimal
Acc MRP avail cap, lowest | workload_Capacity_Avail_Ack_LV_Prel | ZtDecimal73 | 9 | 2 | decimal
Acc MRP avail cap, lowest (tol) | workload_Capacity_Avail_Ack_LV_Prel_OLT | ZtDecimal73 | 9 | 2 | decimal
Acc avail capacity (tol) | Workload_Capacity_Avail_Ack_OLT | ZtDecimal73 | 9 | 2 | decimal
Acc MRP avail cap | workload_capacity_avail_Ack_Prel | ZtDecimal73 | 9 | 2 | decimal
Acc MRP avail cap (tol) | workload_capacity_avail_Ack_Prel_OLT | ZtDecimal73 | 9 | 2 | decimal
Available capacity (tol) | Workload_Capacity_Avail_OLT | ZtDecimal73 | 9 | 2 | decimal
MRP avail cap | Workload_Capacity_Avail_Prel | ZtDecimal73 | 9 | 2 | decimal
MRP avail cap (tol) | Workload_Capacity_Avail_Prel_OLT | ZtDecimal73 | 9 | 2 | decimal
Booked workload | Workload_Capacity_Booked | ZtDecimal73 | 9 | 2 | decimal
Acc workload | workload_capacity_booked_Ack | ZtDecimal73 | 9 | 2 | decimal
MRP Acc workload | workload_capacity_booked_Ack_Prel | ZtDecimal73 | 9 | 2 | decimal
MRP booked workload | workload_capacity_booked_Prel | ZtDecimal73 | 9 | 2 | decimal
Capacity (tol) | Workload_Capacity_OLT | ZtDecimal73 | 9 | 2 | decimal
Ej aktuella värden | Workload_DirtyValues | ztInteger | 5 |  | smallint
End date/time | WorkLoad_StopDate | ztDateTime |  |  | datetime


Details posting template, fixed assets (intk)

Details of the template for the automatic posting of fixed assets by fixed assets group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Fixed assets group | AnlGrp | ztString | 10 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Transaction type | InvTransTyp | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowupdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xintk Posting templates, fixed assets


Details, posting templates man posting (akko)

Posting template details for manual accounting transactions.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Automatic save | autospar | ztBoolean |  |  | char
Debit/credit | DebKre | ztchar | 1 |  | char
Text | Edit | ztBlob | 1 |  | varchar
Amount | FordBel | ZtBaseCurrAmount | 14 | 2 | money
Allocation percent | FordProc | ZtDecimal73 | 6 | 2 | decimal
Allocation rule | FordRegel | ztString | 3 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Transaction type | Foringskod | ztInteger | 3 |  | smallint
From account no. | FromKtoNr | ztString | 8 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Period/relative | PeriodRelativ | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher amount | VerBel | ZtBaseCurrAmount | 14 | 2 | money


Differences for backdated inventory transactions (StockTranDiffAmt)

Differences for backdated inventory transactions.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Identitetskolumn | ConnToSQLIdentity | ZtLong | 10 |  | int
Diff when backdating | DiffAmtBackDateStockTran | ZtBaseCurrAmount | 14 | 2 | money
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Invtry trans date | LagerDatum | ztDate |  |  | datetime
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIdentity | ZtLong | 10 |  | int


Direct debit customers (vkua)

View of the customer table where the direct debit account field (AutoGiroBetKtoNr) is filled in.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Direct debit BG/acct no | AutoGiroBetKtoNr | ztString | 20 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar


Direct debit invoices (krut)

Direct debit invoices to be sent to the bank are stored in this table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Direct debit journal no. | AgJournNr | ZtLong | 6 |  | int
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Row | RadPos | ZtLong | 10 |  | int
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Payment route | UtbetalningsVag | ztString | 6 |  | varchar
Text/info | x255 | ztString | 255 |  | varchar
Text/info | x255_2 | ztString | 255 |  | varchar
Text 3 | x255_3 | ztString | 255 |  | varchar
Text 4 | x255_4 | ztString | 255 |  | varchar


Direct debit journal (jag)

Direct debit journal with details of the assignment, number of invoices, amount, etc.

To create an direct debit journal no. for a specific customer and invoice, the field Direct debit BG/account no. for the customer should be filled in. A payment route should also be linked to the relevant payment terms.

To include the invoices in the journal, the due date for the invoices must be two days less than the journal's entry date.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of invoices | AgAntalFakturor | ZtLong | 4 |  | int
Direct debit amount | AgFaktBel | ZtBaseCurrAmount | 14 | 2 | money
Direct debit file created | AgFileCreated | ztBoolean |  |  | char
Created by | AgFileCreatedBy | ztString | 6 |  | varchar
Creation date | AgFileCreatedDt | ztDateTime |  |  | datetime
Direct debit journal no. | AgJournNr | ZtLong | 6 |  | int
To due date | AgTomFfDat | ztDate |  |  | datetime
Direct debit creation dt | AutoGiroDat | ztDate |  |  | datetime
Transmit to bank date | BankSandDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment route | InbetalningsVag | ztString | 6 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xJag Direct debit journal


Direct debit journal log (JagLog)

Contains error-flagged direct debit journal rows that are missing Direct debit BG-/account number in the customer table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Direct debit journal no. | AgJournNr | ZtLong | 6 |  | int
Max amt for direct debit | AgPayLimit | ZtLong | 5 |  | int
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Payer, company ID | KundBetalarenr | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Text/info | x255 | ztString | 255 |  | varchar


Direct debit journal VIEW (vjag)

View of the direct debit journal table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Direct debit journal no. | AgJournNr | ZtLong | 6 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar


Discount class, item (xarb)

Definition of item discount classes which can be used to group several items which are to have similar discount management. You can specify in the item table which discount class the item will belong to.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item discount class | ArtRabKlass | ztInteger | 3 |  | smallint
Item discount class | ArtRabKlassBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xarb Discount class, item


Discount code, item grp (xlrb)

Table with discount codes, item group for suppliers.

"Discount code, item group" is a grouping that can be used for suppliers to allow different discounts on an item group when the function for item group price list is used during customer order entry.

The supplier discount code is entered and, in the function for item group price list, different rates of discount are entered per discount code for an item group.

When entering customer orders, a quantity tiered discount is retrieved from the price list function for item group depending on the discount code specified for the supplier in question for an item and its item group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Discount code, item grp | LevVgrpRabGrupp | ztInteger | 4 |  | smallint
Discount code, item grp | LevVgrpRabGruppBeskr | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xlrb Discount code, item grp


Discount info, order value/cust (kora)

Definition of intervals for customer specific order value discounts.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order value >= | LimitLow | ZtBaseCurrAmount | 14 | 2 | money
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Discount 1 % | rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: kora Order discount/customer


Discount matrix (pri)

Matrix for the calculation of discounts, based on groups defined for customer and item.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item discount class | ArtRabKlass | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quantity limit >= | Limitlowant | ztFloat | 10 | 2 | float
Tiering, row value | LimitType | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Discount 1 % | rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Discount curr 1 | RabattVal1 | ztMoney | 14 | 2 | money
Discount curr 2 | rabattval2 | ztMoney | 14 | 2 | money
Discount curr 3 | Rabattval3 | ztMoney | 14 | 2 | money
Cust discount class | RabKlass | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: pri Discount matrix


Discount types (xdt)

Numeric code for type of discount. Used for printing specifications of discounts on invoices in the branch specific function for retail/pallet discounts.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Calculation method | CalcMethod | ztInteger | 5 |  | smallint
Show per detail row | Calcperline | ztBoolean |  |  | char
DB-term/-expression 1 | DbTermname1 | ztString | 120 |  | varchar
DB-term/-expression 2 | DbTermname2 | ztString | 255 |  | varchar
Text | edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Ignore if prev | ignoreifprev | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Price per piece. | PricePerItem | ztBoolean |  |  | char
Priority | Prioritet | ztInteger | 2 |  | smallint
Discount type | RabTyp | ztInteger | 3 |  | smallint
Discount type | RabTypB | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Show per detail row | showdet | ztBoolean |  |  | char
Show total | Showtot | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xdt Discount types


Discounts, service option (sht8opt)

Definition of applicable service options on service items that affect the agreement discount.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Component item no. | ArtNrSerieIng | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Discount % | Rabatt | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Reparation type | RepNr | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Disp method, inventory loc (xbls)

Definition of dispatch methods by inventory location with data for freight calculation and for printing delivery notes, e.g. carrier customer number, etc.

No records are defined on delivery.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight calc terms | FraktBerVillk | ztInteger | 2 |  | smallint
Freight matrix | FraktMatrisKod | ztInteger | 2 |  | smallint
Customer no. at EAN | FtgKnrHosEAN | ztString | 20 |  | varchar
Transport agreemt no. | FtgTranspAvtalNr | ztString | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
GAN/Cust no. | KundnrHosFraktb | ztString | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Lead time, load before | LoadBeforeDays | ztInteger | 3 |  | smallint
Lead time, load before | LoadBeforeHours | ztInteger | 3 |  | smallint
Lead time, load before | LoadBeforeMinutes | ztInteger | 3 |  | smallint
Lead time, order gate | OrderGateDays | ztInteger | 3 |  | smallint
Lead time, order gate | OrderGateHours | ztInteger | 3 |  | smallint
Lead time, order gate | OrderGateMinutes | ztInteger | 3 |  | smallint
Lead time, pack before | PackBeforeDays | ztInteger | 3 |  | smallint
Lead time, pack before | PackBeforeHours | ztInteger | 3 |  | smallint
Lead time, pack before | PackBeforeMinutes | ztInteger | 3 |  | smallint
Pallet number | PallRegNummer | ztString | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Lead time, pick before | PickBeforeDays | ztInteger | 3 |  | smallint
Lead time, pick before | PickBeforeHours | ztInteger | 3 |  | smallint
Lead time, pick before | PickBeforeMinutes | ztInteger | 3 |  | smallint
Lead time, pick release | PickReleaseDays | ztInteger | 3 |  | smallint
Lead time, pick release | PickReleaseHours | ztInteger | 3 |  | smallint
Lead time, pick release | PickReleaseMinutes | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Reserve pkgID EAN | ResUtvKolliIdEnlEAN | ztString | 20 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Lead time, shipment lock | ShipLockBeforeDays | ztInteger | 3 |  | smallint
Lead time, shipment lock | ShipLockBeforeHours | ztInteger | 3 |  | smallint
Lead time, shipment lock | ShipLockBeforeMinutes | ztInteger | 3 |  | smallint
Alternative transporter | TA_AltTransporterName | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: xbls Dispatch methods per invtry loc


Dispatch from MO pos -> customer (EDI) (tiil)

Received deliveries from manufacturing orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Accounting date | BokfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Receiving value | InlevKalkVarde | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Send: Delivered | SendDeliv | ztBoolean |  |  | char
Deliv notification date | SendDelivDoneDT | ztDateTime |  |  | datetime
EDI deliv journal | SendDelivJournNr | ZtLong | 10 |  | int
Date/time | StrDateTime | ztString | 28 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: xTiil Send out rcvd MO deliveries


Dispatch header rows (lar)

Contains dispatch notice rows.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Item no. EAN | artnrean | ztString | 30 |  | varchar
Automatically created | AutomatSkapad | ztBoolean |  |  | char
Notified qty (invtry unit) | AviseratAntal | ZtQty | 14 | 2 | decimal
Notified qty (alt unit) | AviseratAntalAltEnh | ZtQty | 14 | 2 | decimal
Notified qty (suppl's unit) | AviseratAntalExtQty | ZtQty | 14 | 2 | decimal
Use/Best before | bastforedatum | ztDate |  |  | datetime
Batch no. | BatchId | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
Unit code | EnhetsKod | ztString | 4 |  | varchar
External order status | ExtOrdsta | ztInteger | 2 |  | smallint
RowNo | FfhRadNr | ztInteger | 5 |  | int
RowNoBOMpos | FFhRadNrStrPos | ztInteger | 5 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Dispatch notice | LevAviNr | ztString | 35 |  | varchar
Dispatch notice row | LevAviRadNr | ztInteger | 5 |  | int
Notification type | Notif_Type | ztInteger | 2 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Defect reason | OrdErrorCd | ztInteger | 4 |  | smallint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Package instr | PackInstrKod | ztString | 35 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Technical status | TekniskStatus | ztString | 35 |  | varchar


Dispatch method per order split type (x2fo)

Table for code definitions for automatic order division.
This function means that you enter an order division code on items that is then automatically used upon order entry to divide (split) a main order into dispatch orders based on the relevant order division type.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Disp.method, order split type | LevSattKodDelnTyp | ztInteger | 2 |  | smallint
Order split type | OrderDelningsTyp | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Dispatch method, purchasing, lang. (xbss)

Language translations of descriptions for delivery method regarding purchases.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Dispatch method | BestLevSatt | ztString | 50 |  | varchar
Dispatch method | BestLevSattKod | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint


Dispatch method, sales (view) (vx2f)

Method of dispatch to customers, with information on freight handling.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Address label type | AdressLappTyp | ztInteger | 2 |  | smallint
Packaging type | EmballageTyp | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight documents | FraktHandlKod | ztBoolean |  |  | char
Freight bill type | FraktSedelTyp | ztInteger | 2 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
GAN/Cust no. | FtgKnrHosFraktb | ztString | 20 |  | varchar
Transport agreemt no. | FtgTranspAvtalNr | ztString | 20 |  | varchar
Internal lead time days | InternLedTid | ztInteger | 3 |  | smallint
Calender created | KalenderCreatedDt | ztDateTime |  |  | datetime
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Dispatch method | LevSattBeskr | ztString | 50 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Kod EU-statistik | LevSattNrEU | ztInteger | 2 |  | smallint
Disp method per cust | LevSattPerKund | ztBoolean |  |  | char
Pallet number | PallregNummer | ztString | 20 |  | varchar
Valid to date | TomDatum | ztDate |  |  | datetime
Transport ID code EDIFACT | TransportIdKod | ztString | 3 |  | varchar
Carrier code | TransportorsKod | ztString | 17 |  | varchar
Intrastat, transport method | TranspSattKod | ztInteger | 2 |  | smallint
Vol weight/cubic meter | VolymVikt | ztFloat | 15 | 2 | float


Dispatch method/customer (ls)

Dispatch method by customer containing data for printout such as GAN/Customer no. and entry numbers for pallet handling.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight calc terms | FraktBerVillk | ztInteger | 2 |  | smallint
Freight matrix | FraktMatrisKod | ztInteger | 2 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
GAN/Cust no. | KundnrHosFraktb | ztString | 20 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Pallet number | PallRegNummer | ztString | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Created UTC date/time | RowCreatedUTCDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Updated date/time | RowUpdatedUTCDT | ztDateTime |  |  | datetime
Time zone code | TimeZoneCode | ztInteger | 4 |  | smallint
Transport days | TransportTid | ztInteger | 3 |  | smallint

    This table is the main table in the following programs:

    Program: ls Dispatch method/customer


Dispatch method/supplier (lexbs)

Dispatch method by customer containing data for printout such as GAN/Customer no. and entry numbers for pallet handling.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Dispatch method | BestLevsattKod | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar, fix disp dates | KalFastLevDagNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Transport days | TransportTid | ztInteger | 3 |  | smallint

    This table is the main table in the following programs:

    Program: LeXbs Dispatch method/supplier


Dispatch methods, sales (x2f)

Definition of dispatch methods for sales to customers, e.g. lorry, air, etc., with information for printing on freight documents and any fixed dispatch dates.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Address label type | AdressLappTyp | ztInteger | 2 |  | smallint
Packaging type | EmballageTyp | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight documents | FraktHandlKod | ztBoolean |  |  | char
Freight bill type | FraktSedelTyp | ztInteger | 2 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
Customer no. at EAN | FtgKnrHosEAN | ztString | 20 |  | varchar
GAN/Cust no. | FtgKnrHosFraktb | ztString | 20 |  | varchar
Transport agreemt no. | FtgTranspAvtalNr | ztString | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Internal lead time days | InternLedTid | ztInteger | 3 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calender created | KalenderCreatedDt | ztDateTime |  |  | datetime
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Dispatch, EU direct | KodEUDirekt | ztBoolean |  |  | char
Dispatch method | LevSattBeskr | ztString | 50 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch method, Astro | LevSattKodAstro | ztchar | 6 |  | char
Kod EU-statistik | LevSattNrEU | ztInteger | 2 |  | smallint
Disp method per cust | LevSattPerKund | ztBoolean |  |  | char
Lead time, load before | LoadBeforeDays | ztInteger | 3 |  | smallint
Lead time, load before | LoadBeforeHours | ztInteger | 3 |  | smallint
Lead time, load before | LoadBeforeMinutes | ztInteger | 3 |  | smallint
Product code | LogtradeProductCode | ztString | 60 |  | varchar
Lead time, order gate | OrderGateDays | ztInteger | 3 |  | smallint
Lead time, order gate | OrderGateHours | ztInteger | 3 |  | smallint
Lead time, order gate | OrderGateMinutes | ztInteger | 3 |  | smallint
Lead time, pack before | PackBeforeDays | ztInteger | 3 |  | smallint
Lead time, pack before | PackBeforeHours | ztInteger | 3 |  | smallint
Lead time, pack before | PackBeforeMinutes | ztInteger | 3 |  | smallint
Pallet number | PallregNummer | ztString | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Lead time, pick before | PickBeforeDays | ztInteger | 3 |  | smallint
Lead time, pick before | PickBeforeHours | ztInteger | 3 |  | smallint
Lead time, pick before | PickBeforeMinutes | ztInteger | 3 |  | smallint
Lead time, pick release | PickReleaseDays | ztInteger | 3 |  | smallint
Lead time, pick release | PickReleaseHours | ztInteger | 3 |  | smallint
Lead time, pick release | PickReleaseMinutes | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Reserve pkgID EAN | ResUtvKolliIdEnlEAN | ztString | 20 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Lead time, shipment lock | ShipLockBeforeDays | ztInteger | 3 |  | smallint
Lead time, shipment lock | ShipLockBeforeHours | ztInteger | 3 |  | smallint
Lead time, shipment lock | ShipLockBeforeMinutes | ztInteger | 3 |  | smallint
TextID | TextID | ZtLong | 10 |  | int
Valid to date | TomDatum | ztDate |  |  | datetime
Transport ID code EDIFACT | TransportIdKod | ztString | 3 |  | varchar
Transport instr, row 1 | TransportInstruktion1 | ztString | 40 |  | varchar
Transport instr, row 2 | TransportInstruktion2 | ztString | 40 |  | varchar
Transport instr, row 3 | TransportInstruktion3 | ztString | 40 |  | varchar
Transport instr, row 4 | TransportInstruktion4 | ztString | 40 |  | varchar
Carrier code | TransportorsKod | ztString | 17 |  | varchar
Intrastat, transport method | TranspSattKod | ztInteger | 2 |  | smallint
Vol weight/cubic meter | VolymVikt | ztFloat | 15 | 2 | float

    This table is the main table in the following programs:

    Program: Xx2f Dispatch methods, sales


Dispatch notice header (lah)

The headers of the received dispatch notices are stored here and then used as the basis for received deliveries of purchase orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
EAN buyer | By_EANLocCd | ztString | 30 |  | varchar
EAN delivery party | Dp_EANLocCd | ztString | 30 |  | varchar
External order status | ExtOrdSta | ztInteger | 2 |  | smallint
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Storage code | Forradskod | ztString | 17 |  | varchar
Freight bill no. | FraktsedelNr | ztString | 30 |  | varchar
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Goods terminal | GodsTerminalKod | ztString | 17 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Customer order no. | KundBestNr | ztString | 30 |  | varchar
Customer | KundNr | ztCompanyNo | 20 |  | varchar
Notification date | LevAviDatum | ztDate |  |  | datetime
Dispatch notice | LevAviNr | ztString | 35 |  | varchar
Dispatch not time | LevAviTid | ztTime | 5 |  | datetime
Recipient code | MottagarKod | ztString | 17 |  | varchar
Notification type | Notif_Type | ztInteger | 2 |  | smallint
Defect reason | OhdErrorCd | ztInteger | 4 |  | smallint
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order no. | ordernr | Jeeves_SONo | 8 |  | bigint
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Gate description | PortBeskrivning | ztString | 35 |  | varchar
Gate code | PortKod | ztString | 17 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
EAN shipper | Sh_EANLocCd | ztString | 30 |  | varchar
EAN supplier | Su_EANLocCd | ztString | 30 |  | varchar
Trailer ID | TrailerId | ztString | 17 |  | varchar
Transport ID | TransportId | ztString | 17 |  | varchar
Carrier code | TransportorsKod | ztString | 17 |  | varchar
Carrier name | TransportorsNamn | ztString | 35 |  | varchar
Transport ref | TransportRef | ztString | 17 |  | varchar
EAN warehouse | Wh_EANLocCd | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: DelivFromDesadv Make delivery from incoming dispatch

    Program: EdiUtpl EDI Dispatch order picking

    Program: LAviAnk Incoming delivery notice

    Program: LevAvi Delivery notices


Dispatch notify methods (x1g)

Definition of existing notification method, e.g. telephone or fax, that will be used for goods notification. This function is used for customers when printing delivery instructions on SIS freight bills, and for suppliers when printing purchase order documents.

The following standard records exist. Do not alter/delete:

Dispatch notify method (GodsAvisKod) | Dispatch notify method (GodsAvisBeskr)
1 | Notification, phone
2 | Notification, fax
3 | Notification, other

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Dispatch notify method | GodsAvisBeskr | ztString | 50 |  | varchar
Dispatch notify method | GodsAvisKod | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xx1g Dispatch notify method


Dispatch package rows (lark)

Contains information about how an incomming dispatch is packed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Dispatch package row | DispatchPackageRow | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Package seq. no. | KolliLopNr | ztString | 17 |  | varchar
Dispatch notice | LevAviNr | ztString | 35 |  | varchar
Dispatch notice row | LevAviRadNr | ztInteger | 5 |  | int
Master lable ID | MasterLableId | ztString | 35 |  | varchar
Flag type | OdetteFlaggTyp | ztString | 1 |  | varchar
Packed quantity | OrdPackAntal | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Dispatch plan rows (lpr)

Contains dispatch plan rows.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Degree of commitment | AtagandeGrad | ztInteger | 2 |  | smallint
Order qty (invtry unit) | BestAnt | ZtQty | 14 | 2 | decimal
Order qty (suppl unit) | BestAntExtQty | ZtQty | 14 | 2 | decimal
Est disp date | BestBerLevDat | ztDate |  |  | datetime
Delivery received date | BestInlevDat | ztDateTime |  |  | datetime
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
Received qty (suppl unit) | BestLevAntExtQty | ZtQty | 14 | 2 | decimal
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
Purchase order created | BestSkapadDat | ztDateTime |  |  | datetime
External order row number | ExtOrdRadNr | ztInteger | 5 |  | int
External order row no. for pkg | ExtOrdRadNrStrPos | ztInteger | 4 |  | int
External backorder no. | ExtOrdRestNr | ztInteger | 2 |  | smallint
Prev Del.plan date | FLevPlanDatum | ztDate |  |  | datetime
Previous dispatch plan | FLevPlanNr | ztString | 17 |  | varchar
Prev Del.plan row no. | FLevPlanRadNr | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Ord. no., del.plan out | LevPlanBestNr | ZtLong | 6 |  | int
Ord. row no., del.plan out | LevPlanBestRadNr | ztInteger | 5 |  | smallint
Compensation method | LevPlanErsMetod | ztInteger | 1 |  | smallint
Disp.plan number | LevPlanNr | ZtLong | 10 |  | int
Disp.plan no, alpha | LevPlanNrAlfa | ztString | 35 |  | varchar
Dispatch plan row no. | LevPlanRadNr | ZtLong | 10 |  | int
Supplier item descr | LevsArtBeskr | ztString | 255 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Requisition | StrDateTimeBia | ztString | 28 |  | varchar


Dispatch plan, header (lph)

This table contains dispatch plan headers.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Arrival entered | AnkomstRapporterad | ztBoolean |  |  | char
Arrival text | AnkomstText | ztBlob | 1 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Lead time from | BasDatLedTid | ztDate |  |  | datetime
Request disp date | BestBegLevDat | ztDate |  |  | datetime
Est disp date | BestBerLevDat | ztDate |  |  | datetime
Upd agrmt fr invoice | BestFaktPris2Avtal | ztBoolean |  |  | char
Upd agrmt fr purch order | BestInpris2Avtal | ztBoolean |  |  | char
Delivery received date | BestLevDat | ztDate |  |  | datetime
Delivery date supplier quay | BestLevDatFranLevsKaj | ztDate |  |  | datetime
Dispatch method | BestLevsattKod | ztInteger | 2 |  | smallint
Dispatch terms | BestLevVilkKd | ztInteger | 2 |  | smallint
Promised disp date | BestLovLevDat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Purchase order created | BestSkapadDat | ztDateTime |  |  | datetime
PO type | BestTyp | ztInteger | 3 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Ext Företagsnr/-id | ExtFtgNr | ztCompanyNo | 20 |  | varchar
External order number | ExtOrderNr | ztString | 17 |  | varchar
Change calc price/item | FaktInpris2Artikel | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Joint purchase date limit | HorisontDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Internal company | InterntFtg | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Joint prch suitable send date | LampligtSandDatum | ztDate |  |  | datetime
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Dispatch plan date | LevPlanDatum | ztDate |  |  | datetime
Disp.plan number | LevPlanNr | ZtLong | 10 |  | int
Disp.plan no, alpha | LevPlanNrAlfa | ztString | 35 |  | varchar
Er ref | LevRef1 | ztInteger | 6 |  | smallint
Supplier reference | LevRef2 | ztString | 50 |  | varchar
Text on PO | LevSpecTextBe | ztBoolean |  |  | char
Supplier specific text | LevTextKod | ztString | 4 |  | varchar
Dispatch plan | MarkLevPlanUt | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
OLE-1 | ole1 | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Send EDI | SendEdi | ztBoolean |  |  | char
Sent EDI | SendEdiDT | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Covered | TerminsSakrad | ztBoolean |  |  | char
Valid to date | TomDatum | ztDate |  |  | datetime
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Our reference | VRef | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: LPlanUt Outgoing dispatch plan

    Program: LPlanUtO Outgoing dispatch plan (replanning)


Dispatch terms, sales (x2e)

Definition of the dispatch terms that the company applies for sales to customers, with information for freight charges and EDI.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Charge freight Y/N | FraktDebKod | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Intrastat, excl costs | IntStatKostExklKod | ztBoolean |  |  | char
Intrastat, delivery terms | IntStatLevVillkor | ztString | 3 |  | varchar
Dispatch terms | LevVillkBeskr | ztString | 50 |  | varchar
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Dispatch terms EDI | LevVillkKodEdi | ztString | 3 |  | varchar
Disp terms place | LevVillkPlats | ztString | 17 |  | varchar
Freight recipient | Mottagarfrakt | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Combitermcode | TA_CombitermCod | ztString | 5 |  | varchar
Dispatch terms transport | TA_ShipTermCustDescr | ztString | 40 |  | varchar
TextID | TextID | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: Xx2e Dispatch terms, sales


Dispatch terms, sales, language (x2es)

Language translations of descriptions for delivery terms regarding sales.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Dispatch terms | LevVillkBeskr | ztString | 50 |  | varchar
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint


Dispatch terms, sales, language (x2fs)

Language translations of descriptions for delivery method regarding sales.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Dispatch method | LevSattBeskr | ztString | 50 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint


Dispatch terms, sales, language (x2s)

Language translations of descriptions for payment terms regarding sales.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Payment terms | BetKod | ztString | 2 |  | varchar
Payment terms | BetVillBeskr | ztString | 50 |  | varchar
Spec payment terms | BetVillBeskr255 | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint


Dispatch transactions->GL (ouvt)

Detailed data by transaction of how dispatches under customer orders are posted when integrated with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Document ID | docnumid | ztString | 30 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Posting per invtry location | KonterasEnlLagStalle | ztString | 2 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Inventory location | LagStalle | ztString | 2 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Picking journal no. | OruJournNr | ZtLong | 10 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Date/time | StrDateTime | ztString | 28 |  | varchar
UniqueIDInAKFT | UniqueIDInAKFT | ZtLong | 10 |  | int
UniqueIDInAKLT | UniqueIDInAKLT | ZtLong | 10 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: Ouvt Show picked order posting


Dispatch types, package items (xo9)

Table of dispatch types used to indicate how dispatch of packaged items is to be handled during picking for customer orders.

The following standard records exist. Do not alter/delete:

Dispatch type, package (PackageDelivCode) | Dispatch type, package (PackageDelivDescr) | Description
0 | No part delivery, pick detail | The individual package details are presented in the left-hand window in the picking program. Part delivery of a detail is not allowed. Example: The order is for 10 packages containing items A, B and C. You can deliver only item B, but not only 5 units of item B.
1 | No part delivery, pick package | In the picking program the package items are presented in their entirety, which means that you cannot deliver individual details from the package. Part delivery is not allowed, i.e. you cannot deliver e.g. 5 of 10 packages.
2 | Part delivery, whole package | In the picking program the package items are presented in their entirety, which means that you cannot deliver individual details from the package. Part delivery is allowed, i.e. you can deliver e.g. 5 of 10 packages.
3 | Part delivery, pick detail | The individual package details are presented in the left-hand window in the picking program. Part delivery of a detail is allowed. Example: The order is for 10 packages containing items A, B and C. You can deliver only item B. You can also deliver only 5 units of item B. (New from version 8.0.)
4 | Part delivery, whole pkg, pick detail | The individual package details are presented in the left-hand window in the picking program. Part delivery is allowed, i.e. you can deliver e.g. 5 of 10 packages, but not only 5 units of say item B.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Dispatch type, package | PackageDelivCode | ztInteger | 1 |  | smallint
Dispatch type, package | PackageDelivDescr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xo9 Dispatch types, package items


Disrupted Jeeves processes (syse)

Each time a Jeeves process is interrupted, a record is created in this table. In the course of time the table will grow and shouldtherefore be emptied.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
DB login sign | DBLogInSign | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Program ID | JeevesPgmId | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
DB lib process ID | ProcIdDBLib | ZtLong | 10 |  | int
DB lib proc ID 1:a | ProcIdDBLibPgmId | ZtLong | 10 |  | int
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Process ID | spid | ZtLong | 5 |  | int
Process ID, pgm | spidpgm | ZtLong | 5 |  | int
Date/time | StrDateTime | ztString | 28 |  | varchar

    This table is the main table in the following programs:

    Program: xSyse Disrupted Jeeves processes


District (xn1)

Definition of geographical district as per individual need for grouping/searching of companies in the company table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
District | Distrbeskr | ztString | 30 |  | varchar
District | DistrKod | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCOls | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xn1 District


Document (pdm)

Table in which a document, in the form of a file pointer, is entered with a unique ID and linked to business objects such as order number, PO number, customer, contact, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Consists of, no. of items | AntBestarAvSr | ZtLong | 5 |  | int
ComponentQty | AntIngarISr | ZtLong | 5 |  | int
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | aopos | ztInteger | 4 |  | int
File record | ArkivPdmId | ztString | 25 |  | varchar
Item class | ArtKod | ztInteger | 3 |  | smallint
Priority | artlevprior | ztInteger | 2 |  | smallint
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
Ny beräkning av nivåkod | ArtNiva_Dirty | ztBoolean |  |  | char
Item no. | ArtNr | ztString | 30 |  | varchar
Product class | ArtProdKlass | ztString | 4 |  | varchar
Release | artrelease | ztString | 6 |  | nvarchar
Release Date | artreleasedat | ztDate |  |  | datetime
Release index | artrelindex | ztInteger | 4 |  | smallint
Release sign | artrelsign | ztString | 6 |  | varchar
Release valid from | ArtRelValidFrDt | ztDate |  |  | datetime
Release valid to | ArtRelValidToDt | ztDate |  |  | datetime
Revision date | ArtRevDat | ztDate |  |  | datetime
Revision no. | ArtRevID | ztString | 10 |  | varchar
Revision | artrevindex | ztInteger | 4 |  | smallint
Revision signature | ArtRevSign | ztString | 6 |  | varchar
Revision valid from | ArtRevValidFrDt | ztDate |  |  | datetime
Revision Valid to | ArtRevValidToDt | ztDate |  |  | datetime
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Will be approved | Attesteras | ztBoolean |  |  | char
Batch no. | batchid | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Purch requisition no. | bianr | ZtLong | 10 |  | int
Connected to PDM ... | ConnPdmDummyUniqueID | ztUniqueIdentifier | 100 |  | varchar
Document description | docdescr | ztString | 50 |  | varchar
Document ID | DocId | ztString | 50 |  | varchar
Documentation | Documentation | ztBlob | 1 |  | varchar
File extension | DocumentExt | ztString | 30 |  | varchar
File type new record | DocumentExtTemp | ztString | 30 |  | varchar
Document type no. | DocumentType | ZtLong | 5 |  | int
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Document owner | dokagare | ztString | 6 |  | varchar
Approval status | DokAttStatus | ztInteger | 5 |  | smallint
File/dir | DokDir | ztString | 255 |  | varchar
Author | DokForfattare | ztString | 30 |  | varchar
Doc header/directory | dokmapp | ztBoolean |  |  | char
Document status | Dokstatus | ztInteger | 5 |  | smallint
Document structure template | DokStruktMall | ztBoolean |  |  | char
No file link | DokUtanFIl | ztBoolean |  |  | char
Row no. | EcoRow | ztInteger | 5 |  | smallint
Change order ID | ecouniqueid | ztString | 40 |  | varchar
Invoice no. | faktnr | Jeeves_InvNo | 9 |  | bigint
File name | FileName | ztString | 255 |  | varchar
Filepointer terms | FilePointerTerms | ztInteger | 5 |  | smallint
File status | Filstatus | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Fixed asset no | Inventarie | ZtLong | 10 |  | int
Component fixed asset | Inventariepos | ztInteger | 5 |  | smallint
Link -> Purchasing claim | IrkDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Item Revision | ItemRevision | ZtLong | 3 |  | smallint
Copy from item revision | ItemRevision_CopyOfRevision | ZtLong | 3 |  | int
Item rev OK to use? | ItemRevOkToUse | ztBoolean |  |  | char
Item status | ItemStatusCode | ztInteger | 5 |  | smallint
Campaign | kampnr | ZtLong | 4 |  | int
Complete doc structure | KomplettDokStr | ztBoolean |  |  | char
Note | KortNotering | ztString | 255 |  | varchar
Inventory location | lagstalle | ztString | 2 |  | varchar
Locked by change order | LockedByECO | ztString | 40 |  | varchar
Log | Loggas | ztBoolean |  |  | char
Sequence no. | LopNr | ZtLong | 10 |  | int
File count | MultipleFileCount | ztInteger | 5 |  | smallint
Consist of muliple files | MultipleFiles | ztBoolean |  |  | char
Quote/agreement no. | offnr | ztString | 10 |  | varchar
Item no. | oldArtNr | ztString | 30 |  | varchar
Sequence number | oldDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
PDM (previous ID) | oldPDMDummyuniqueId | ztUniqueIdentifier | 100 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Est disp date | OrdBerLevdat | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Point of delivery, co. ID | ordlevplats1 | ztCompanyNo | 20 |  | varchar
Order row no. | ordradnr | ztInteger | 5 |  | int
Subrow no. | ordradnrstrpos | ztInteger | 5 |  | int
Backorder no. | OrdrestNr | ztInteger | 2 |  | smallint
PDM (origin) | originPDMDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
Link - Customer claims | OrkDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Normally on purchase order | Pdm2PO | ztBoolean |  |  | char
Normally on work order | Pdm2WO | ztBoolean |  |  | char
PDM quantity 1 | PdmAntal1 | ZtLong | 10 |  | int
PDM quantity 1 | PdmAntal2 | ZtLong | 10 |  | int
PDM (Unique ID) | PdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
Document file path | PDMFileName | ztString | 250 |  | varchar
Own category 1 | pdmkat1kod | ztInteger | 5 |  | smallint
Own category 2 | pdmkat2kod | ztInteger | 5 |  | smallint
PDM ref 1 | PdmRef1 | ztString | 40 |  | varchar
PDM ref 2 | PdmRef2 | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Pos in figure | posalfa | ztString | 12 |  | varchar
Preliminary release | Prelartrelindex | ztInteger | 5 |  | smallint
Preliminary revision | Prelartrevindex | ztInteger | 5 |  | smallint
Project ID | projcode | ztString | 10 |  | varchar
Business opportunity ID | ProspektId | ZtLong | 10 |  | int
Quality parameter | QParamId | ZtLong | 10 |  | int
Row | radpos2 | ztInteger | 4 |  | int
Fiscal year | redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Replace file | replacefile | ztBoolean |  |  | char
Name | respnamn | ztString | 50 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Serv.order no | servordernr | Jeeves_SONo | 9 |  | bigint
Order row, service | ServOrdRadNr | ztInteger | 5 |  | int
Language | sprakkod | ztInteger | 3 |  | smallint
Date/time | StrDateTime | ztString | 28 |  | varchar
Requisition | StrDateTimeBia | ztString | 28 |  | varchar
Connection->planned activities | StrDateTimeHr | ztString | 28 |  | varchar
Time report no. | TidrapportNr | ZtLong | 10 |  | int
Connection->Manufact. claim | TorkDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Being approved | UnderAttest | ztBoolean |  |  | char
Checked out | utcheckad | ztBoolean |  |  | char
Checkout date | UtCheckDat | ztDateTime |  |  | datetime
Checked out File | UtCheckPath | ztString | 255 |  | varchar
Checked out sign | utchecksign | ztString | 6 |  | varchar
Valid version | validpdm | ztBoolean |  |  | char
Item group | VaruGruppKod | ztString | 8 |  | varchar
Tools | verktyg | ztString | 16 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Web structure | webdoccode | ztInteger | 5 |  | smallint
Publish on Web | webpublish | ztBoolean |  |  | char
Web tree ID | WebTreeID | ztString | 25 |  | varchar
Unique ID link | wfrowuniqueid | ztString | 50 |  | varchar
Wildchar positions | WildCharPositions | ztInteger | 5 |  | smallint
XML document | XmlDoc | ztBlob | 1 |  | varchar
Archive file name | ZipFileName | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: EcoPdm Change order documents

    Program: EDM Documents, view

    Program: Pdm Product Document (PDM)

    Program: PdmN Documents, history

    Program: PdmnAtt Document approval

    Program: PdmNV Documents, valid


Document approval status (pdmatt)

Table of available approval status for a document.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval status | DokAttStatus | ztInteger | 5 |  | smallint
Approval status | DokAttStatusBeskr | ztString | 50 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: pdmattstat Approval status, document


Document number series (docnum)

Definition of document number series that can be used for various transaction types.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Document no. series | docnoserie | ztString | 3 |  | varchar
Document no. series | docnoseriedescr | ztString | 50 |  | varchar
Document type | doctype | ztInteger | 3 |  | smallint
Fiscal year | FiscalYear | ztInteger | 4 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
From no. | fromno | ZtLong | 9 |  | int
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Last used no. | lastusedno | ZtLong | 9 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
To no. | tono | ZtLong | 9 |  | int

    This table is the main table in the following programs:

    Program: docnum Document number series


Document rights (pdmsec)

Table of read, write and change rights per document type linked to internal roles or external contact persons.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
User group | accgrp | ztInteger | 5 |  | smallint
Document type no. | documenttype | ZtLong | 5 |  | int
Right to approve file | EdmAssign | ztBoolean |  |  | char
Right to create file | EdmCreate | ztBoolean |  |  | char
Right to erase file | EdmDelete | ztBoolean |  |  | char
Right to edit file | EdmModify | ztBoolean |  |  | char
Right to publish file | EdmPublish | ztBoolean |  |  | char
Right to read file | EdmRead | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | ftgkontaktnr | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | perssign2 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Resource group | resursgrp | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | sqlidentity | ZtLong | 10 |  | int


Document status (pdmstat)

Definition of occurring document status that will be included in the review or approval flow, e.g. For review, Approved, Published, etc.

Note that status 0-100 is reserved for standard status codes. In other words, your own status codes may be entered beginning with number 101.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Document status | Dokstatus | ztInteger | 5 |  | smallint
Document status | DokStatusBeskr | ztString | 50 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: pdmstat Document status


Document status for JvsViewer (WStp)

Table where the document status that is sent to Jeeves Viewer is stored per instance.
The status is retrieved from the xwst table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Height | height | ZtLong | 9 |  | int
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Reply code | StampNo | ztInteger | 5 |  | smallint
Selected stamp | StampStatus | ztInteger | 5 |  | smallint
Reply code | StampText | ztString | 50 |  | varchar
ID | wdocdummyuniqueid | ztString | 50 |  | varchar
Width | width | ZtLong | 9 |  | int
Unique ID stamp | wstpdummyuniqueid | ztString | 50 |  | varchar
x position | xpos | ZtLong | 9 |  | int
y position | ypos | ZtLong | 9 |  | int


Document structure (vpds)

Unique document ID for child document in a document structure.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | artnr | ztString | 30 |  | varchar
Release index | artrelindex | ztInteger | 4 |  | smallint
Revision | artrevindex | ztInteger | 4 |  | smallint
Qty parent BOM/pkg level | bantalavi | ztFloat | 12 | 4 | float
Item no. (BOM) | BArtnrStrukt | ztString | 30 |  | varchar
Document ID, subdocument | bDocId | ztString | 50 |  | varchar
Document type, subdocument | bdocumenttype | ZtLong | 5 |  | int
P D M consists of | bPdmDummy | ztString | 100 |  | varchar
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Document ID | DocId | ztUniqueIdentifier | 38 |  | varchar
Document type no. | documenttype | ZtLong | 5 |  | int
To MPC | DokTillsr | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Complete doc structure | KomplettDokStr | ztBoolean |  |  | char
Sequence number | oldDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
PDM (previous ID) | oldPDMDummyuniqueId | ztUniqueIdentifier | 100 |  | varchar
PDM (Unique ID) | PdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Pos in figure | posalfa | ztString | 12 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Valid version | validpdm | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: vpds Document structure (view)


Document structure (pdms)

Table of relationships between different documents. Each table record contains a unique ID for a parent document and a unique ID for a related child document.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | artnr | ztString | 30 |  | varchar
Release index | artrelindex | ztInteger | 4 |  | smallint
Revision | artrevindex | ztInteger | 4 |  | smallint
Qty parent BOM/pkg level | bantalavi | ztFloat | 12 | 4 | float
Item no. (BOM) | BArtnrStrukt | ztString | 30 |  | varchar
Document ID, subdocument | bDocId | ztString | 50 |  | varchar
File ext, child document | bDocumentExt | ztString | 30 |  | varchar
Document type, subdocument | bDocumentType | ZtLong | 5 |  | int
P D M consists of | bPdmDummy | ztString | 100 |  | varchar
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Document type no. | documenttype | ZtLong | 5 |  | int
To MPC | DokTillSr | ztBoolean |  |  | char
External text | editext | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Complete doc structure | KomplettDokStr | ztBoolean |  |  | char
Locked by change order | lockedbyeco | ztString | 40 |  | varchar
Sequence number | oldDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
PDM (previous ID) | oldPDMDummyuniqueId | ztUniqueIdentifier | 100 |  | varchar
PDM (Unique ID) | PdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Pos in figure | PosAlfa | ztString | 12 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Valid version | validpdm | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: pdms Document structure detail, history

    Program: pdmSV Document structure detail, valid


document type (doctype)

Definition of applicable document types, which can be used on various transaction types.

The following standard records exist. Do not alter/delete:

Document type (doctype) | Document type (doctypedescr)
1 | 1: Fixed assets
2 | 2: Inventory transaction
3 | 3: Bill of exchange

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Document type | doctype | ztInteger | 3 |  | smallint
Document type | doctypedescr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: doctype Document type


Document types for LogTrade export (LogTradeDocType)

Definition of document types used in integration between Jeeves' transport administration and LogTrade. The document types are used in the Carriers program(x2t).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Document type descr | LogtradeDocTypeDesc | ztString | 60 |  | varchar
Document type ID | LogtradeDocTypeId | ztString | 2 |  | varchar
This field is used in the table as follows: |
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: LogtradeDocType Document types for LogTrade export


Document types visible in office (vxpdmoff)

View showing document types visible in office, implying they can be chosen when storing documents from Excel or Word to EDM.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
File extension | documentext | ztString | 30 |  | varchar
Document type no. | documenttype | ZtLong | 5 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: vxpdmoff Document types visible in office


Document types Web (webm)

ID term for a document type linked to a description. The document type is used primarily to specify physical properties, but can also be used for logical classification.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Document type no. | DocumentType | ZtLong | 5 |  | int
Document type | DocumentTypeDescr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Door area (warehouse area) (pyta)

Space or area in an inventory location belonging to a "gate".
Door areas to inventory are defined in this table.
Bins can be linked to a door area (or gate, see another table).
Planned events (deliveries) can be planned to a door area (or gate).
***** Not used in Jeeves standard *****

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Gate | Port | ztString | 6 |  | varchar
Gate area | PortYta | ztString | 6 |  | varchar
Gate area descr | PortYtaBeskr | ztString | 40 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: pyta Gate area


Drop-down list texts, std and own (CustomerDropDown)

This table should normally only be used if you need language management in the drop-down lists in the system. In other words, if you want the content in drop-down lists to be affected when you switch language in the client. For further information, see the corresponding program help and the program help for Change drop-down list texts (changecdd).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Block auto-update | CDDIsUpdated | ztBoolean |  |  | char
Description (to lang) | DescText | ztString | 100 |  | varchar
Description (from lang) | Desctext_from | ztString | 100 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ictrulenumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Jvs_Internal_LDDL_ID | Jvs_Internal_LDDL_ID | ztString | 30 |  | varchar
Key in list | KeyText | ztString | 100 |  | varchar
Locked fr auto-updating | LockedForAutomaticUpdate | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language code | zLanguage | ztInteger | 4 |  | smallint
Base/value table | ztable | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: ChangeCDD Change drop-down list texts

    Program: CustomerDropDown Drop-down list texts, std and own


Due invoices, credit check (kkfh)

Internal table used for running credit checks for customers.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Days fr due dt to pmt | AntDgrSedanFFDat | ZtLong | 7 |  | int
Amount, due | BelForfallet1 | ZtBaseCurrAmount | 14 | 2 | money
Amount due > x days | BelForfallet2 | ZtBaseCurrAmount | 14 | 2 | money
Invoice date | FaktDat | ztDate |  |  | datetime
Due date | FaktFFDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice total incl tax | FaktTotMMoms | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Remaining to pay | RestBelFakt | ZtBaseCurrAmount | 14 | 2 | money
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Dynamic reports, templates (dynrep)

Sequence number.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
MATRIX | datablob | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Sequence no. | lopnr | ZtLong | 10 |  | int
Program node | node | ztString | 35 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Program | pgm | ztString | 40 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


e-Approval parameters (eAttParamView)

Designation of the Jeeves system parameter that is primarily used internally in the system, i.e. for program logic in procedures, triggers, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | edit |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
JeevesParamBoolean | jeevesparamboolean |  |  |  | @DataType=NULL
Jeeves Param Descr | jeevesparamdescr |  |  |  | @DataType=NULL
Parameter name | jeevesparamname |  |  |  | @DataType=NULL
JeevesParamNumeric | jeevesparamnumeric |  |  |  | @DataType=NULL
JeevesParamString | jeevesparamstring |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL
Language | sprakkod |  |  |  | @DataType=NULL
Value type | vardetermt |  |  |  | @DataType=NULL

    This table is the main table in the following programs:

    Program: eAttParamView Parameters e-Approval


e-Invoice agreement, details (einvoiceadmdet)

Details regarding administering of report definitions for e-invoicing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
e-Invoice | Einvoice | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Template | YndMall | ztString | 40 |  | varchar
Report program | YndReport | ztString | 40 |  | varchar


e-Invoice agreements (einvoiceadm)

Main table handling reports for e-invoicing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Archive | Archive | ztBoolean |  |  | char
e-Invoice B2B | einvoice_B2B | ztBoolean |  |  | char
e-Invoice B2C | einvoice_B2C | ztBoolean |  |  | char
Agreement active | EinvoiceAgrActive | ztBoolean |  |  | char
External printer | ExternalPrint | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Consolidator | NameOfConsolidator | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: einvoiceadm e-Invoice agreements


EAN codes per item (arean)

Defining EAN codes for each item.

If an item, for example, is put into Inventory and is sold in various different units, various EAN codes can exist.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Item no. EAN | ArtNrEAN | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: arean EAN codes per item


Early settlement discount on invoice (fhcd)

Contains early settlement discount basis amount in currency for each invoice.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Net aft early stlmt discnt | AmountMinusCashDiscFCU | ztMoney | 14 | 2 | money
VAT early stlmt dsct curr | CashDiscAmountFCU_VAT | ztMoney | 14 | 2 | money
Early stlmt dsct basis curr | CashDiscBaseFCU | ztMoney | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Early settlmt discnt % | KassaRab | ztFloat | 6 | 2 | float
Early settlmt discnt days | KassaRabDag | ztInteger | 3 |  | smallint
Early settlmt discnt date | KrFaktKRabDat | ztDate |  |  | datetime
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Early settlmt discnt, curr | VbKassaRab | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: fhcd Early settlement discount on invoice


Early settlement discount on invoice (lrcd)

Contains early settlement discount basis amount in currency for each supplier invoice.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Net aft early stlmt discnt | AmountMinusCashDiscFCU | ztMoney | 14 | 2 | money
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
VAT early stlmt dsct curr | CashDiscAmountFCU_VAT | ztMoney | 14 | 2 | money
Early stlmt dsct basis curr | CashDiscBaseFCU | ztMoney | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Early settlmt discnt % | KassaRab | ztFloat | 6 | 2 | float
Early settlmt discnt days | KassaRabDag | ztInteger | 3 |  | smallint
Early settlmt discnt dt | LrFaktKRabDat | ztDate |  |  | datetime
Cancel | makulerad | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Early settlmt discnt, curr | VbKassaRab | ztMoney | 14 | 2 | money


Early settlement discount terms, details (xrbr)

Definition of terms for early settlement discounts used to control discount calculation both for incoming payment of customer invoices and outgoing payment of supplier invoices. This function makes it possible to apply several discount periods and percentages per payment terms.

No standard records exist in this table. Fill in as needed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Early settlmt discnt % | Kassarab | ztFloat | 6 | 2 | float
Early settlmt discnt days | KassarabDag | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Early settlmt discnt terms | rabkod | ztString | 3 |  | varchar
Row | radpos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Early settlement discount terms, header (xrbh)

Definition of terms for early settlement discounts used to control discount calculation both for incoming payment of customer invoices and outgoing payment of supplier invoices. This function makes it possible to apply several discount periods and percentages per payment terms.

No standard records exist in this table. Fill in as needed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Early settlmt discnt MFD | FriLevMKassa | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Early settlmt discnt terms | RabKod | ztString | 3 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xrbh Early settlement discount terms


EDI command header (edig)

This table contains headers for the commands executed when converting EDI messages and during communication.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sequence name | EdiCommandSeqName | ztString | 35 |  | varchar
Sequence no. | EdiCommandSeqNo | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: edig Command sequences for EDI


EDI log codes (xedl)

Table of EDI log codes, i.e. the codes and descriptions that can be relevant to the EDI message log.

The following standard records exist. Do not alter/delete:

EDI log code (EdiLoggKod) | EDI log text (EdiLoggBeskr)
0 | Unknown error
1 | Error loading file
2 | Error exporting file
3 | Error updating inbox
4 | Error updating outbox
5 | Error running external program
6 | Error when processing a message (blob)
7 | Cannot match EDI addresses to EDI ID
8 | File name does not exist
10 | EDI server started
11 | EDI server not started
12 | EDI server not available
13 | EDI server: Incoming EDI message
14 | EDI server: Unidentified EDI file !
15 | EDI server: Have encountered problems
100 | Incorrect parameters to xp_EdiSplitFile
101 | Incorrect parameters to xp_EdiLoadText
102 | Incorrect parameters to xp_EdiExportText
103 | File cannot be opened for reading
104 | File cannot be created w+
105 | File cannot be opened for additions a+
106 | Cannot transfer file
107 | Reserved text EDI server 107
108 | Reserved text EDI server 108
109 | Reserved text EDI server 109
110 | Sql commando failed
111 | Sql result incorrect
112 | Only one column can be entered
113 | Column is not Text or Image
114 | Cannot load data
115 | Cannot retrieve Text-pointer
116 | Cannot retrieve date of the text
117 | Selection gives more than one row
118 | Cannot retrieve Text or Image
119 | Cannot write Text
120 | Cannot verify written Text
121 | File cannot create w+b
122 | Cannot write Text block
123 | Cannot send Sql code to buffer
124 | Interruption in the db communication
125 | Jobs in progress at start
126 | Reserved text EDI server 126
127 | Reserved text EDI server 127
128 | Reserved text EDI server 128
129 | Reserved text EDI server 129
130 | Reserved text EDI server 130

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
EDI log text | EdiLoggBeskr | ztString | 50 |  | varchar
EDI log code | EdiLoggKod | ztInteger | 5 |  | smallint
Degree of severity | EdiLoggLevel | ztInteger | 1 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xedl Codes for EDI message log


EDI message log (edil)

This table is used to log events for incoming and outgoing EDI messages. The log is filled in by the programs that enter and retrieve data from the in and out boxes.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Reference to in/out box | EdibRef | ztString | 21 |  | varchar
In/Out | EdiInUt | ztBoolean |  |  | char
Job number | EdiJob | ZtLong | 10 |  | int
Sequence number | EdiJobSeq | ztInteger | 5 |  | smallint
Resolved | EdiLoggAtgardat | ztBoolean |  |  | char
Log date & time | EdiLoggDT | ztDateTime |  |  | datetime
EDI log code | EdiLoggKod | ztInteger | 5 |  | smallint
Message log | EdiMsgLogg | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: edil EDI message log


EDI messages (edih)

The EDI messages to be sent are entered in this table. Each message has a unique dispatch number.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
EDI partner profile | EdiId | ZtLong | 6 |  | int
EDI message ID | EdiMeddId | ztString | 35 |  | varchar
Message number | EdiMsgNo | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Send EDI | SendEdi | ztBoolean |  |  | char
Sent EDI | SendEdiDT | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: edih EDI messages


EDI partner profiles (edid)

Here, a record is created for each combination of EDI partner and EDI message sent or received.

Example: A company's subcontractors that send order messages and expect order responses and invoice messages in return will have to create three records in this table.

Each record of this kind is called a partner profile, which is automatically assigned a unique identity in the EDIID field.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Receive automatically | AutoRecive | ztBoolean |  |  | char
Automatic send | AutoSend | ztBoolean |  |  | char
Issue agency | ControllingAgency | ztString | 2 |  | varchar
Error sequence | EdiAlertCommandSeqNo | ztInteger | 5 |  | smallint
E-mail Error Report | EdiAlertMail | ztString | 255 |  | varchar
Application reference | EdiApplRef | ztString | 14 |  | varchar
Auto process | EdiAutoRun | ztBoolean |  |  | char
Backup directory | EdiBackupDir | ztString | 255 |  | varchar
Method of communication | EdiComNo | ztInteger | 5 |  | smallint
EDI receipt ID | EdiContrlId | ztInteger | 5 |  | smallint
Receipt required | EdiContrlReq | ztBoolean |  |  | char
File extension | EdiFileExt | ztString | 10 |  | varchar
Name of EDI file | EdiFileName | ztString | 255 |  | varchar
File number | EdiFileNo | ZtLong | 10 |  | int
Grouped | EdiGruppera | ztBoolean |  |  | char
EDI partner profile | EdiId | ZtLong | 6 |  | int
In-box directory | EdiInBoxDir | ztString | 255 |  | varchar
In directory | EdiInDir | ztString | 255 |  | varchar
Last used Date/time | EdiLatestUseDT | ztDateTime |  |  | datetime
E-mail address | EdiMail | ztString | 255 |  | varchar
Message number | EdiMsgNo | ztInteger | 5 |  | smallint
E-mail, incoming | EdiNotifyMail | ztString | 255 |  | varchar
Out box directory | EdiOutBoxDir | ztString | 255 |  | varchar
Out directory | EdiOutDir | ztString | 255 |  | varchar
Program for incoming EDI | EdiPgmIn | ztString | 255 |  | varchar
In program type | EdiPgmInType | ztInteger | 5 |  | smallint
Program for outgoing EDI | EdiPgmOut | ztString | 255 |  | varchar
Out program type | EdiPgmOutType | ztInteger | 5 |  | smallint
Procedure after conv | EdiPostProc | ztString | 255 |  | varchar
Procedure before conv | EdiPreProc | ztString | 255 |  | varchar
Load EDI files | EdiReadFile | ztBoolean |  |  | char
Allow resend | EdiReSend | ztBoolean |  |  | char
Resend EDI ID | EdiReSendEdiId | ZtLong | 6 |  | int
Schedule | EdiSched | ztInteger | 5 |  | smallint
Test indicator | EdiTestIndicator | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Message | MessageType | ztString | 6 |  | varchar
Message version | MessageVer | ztString | 3 |  | varchar
Recipient's logical address | PartnerId | ztString | 35 |  | varchar
Recip. phys addr | PartnerPhysicID | ztString | 35 |  | varchar
Recip. qualifier | PartnerQualifier | ztString | 4 |  | varchar
Qual. Ref/Passw | PartnerQualRefPsw | ztString | 2 |  | varchar
Recip. Ref/Passw | PartnerRefPsw | ztString | 14 |  | varchar
Recip. subaddress | PartnerSubId | ztString | 14 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Release | ReleaseNumber | ztString | 3 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sender's Logical EDI addr | SenderId | ztString | 35 |  | varchar
Sender's phys addr | SenderPhysicID | ztString | 35 |  | varchar
Sender's qualifier | SenderQualifier | ztString | 4 |  | varchar
Sender's subaddress | SenderSubId | ztString | 14 |  | varchar

    This table is the main table in the following programs:

    Program: edid Partner profiles


Edition status (xwps)

In this table, Jeeves Information Systems sets up the options that can occur in respect of issue status for the workflows in Workflow.

The following standard records exist. Do not alter/delete:

Edition status (publicationstatus) | Edition status (publstatusdescr)
0 | Entry in progress
10 | Active

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Edition status | PublicationStatus | ztInteger | 5 |  | smallint
Edition status | PublStatusDescr | ztString | 50 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xwps Edition status


EDM activity types (pdat)

Table of different EDM activity types that can be logged.

The following standard records exist. Do not alter/delete:

EDM activity type (pdmacctype) | EDM activity type (pdmaccdescr)
0 | Created
1 | Checked out
2 | Checked in
3 | Opened
4 | New version
5 | Printed
6 | By E-mail
7 | Published

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Log | Loggas | ztBoolean |  |  | char
EDM activity type | PDMAccDescr | ztString | 50 |  | varchar
EDM activity type | pdmacctype | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: pdma EDM activity types


Electronic address (vzpd)

Table for storing file extensions of compression programs.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod |  |  |  | @DataType=NULL
E-mail address | YndEmailAddr | ztString | 255 |  | nvarchar
Mail type | YndKindOfMail | ztString | 20 |  | nvarchar
Partner ID | YndPartner | ztString | 20 |  | nvarchar

    This table is the main table in the following programs:

    Program: vzpd EDI e-mail addresses


Embedded lists (JvsSiteWindowDetails)

Program/table for viewing and editing settings regarding the position and size of embedded lists.

The program/table can be accessed through an embedded window in the program Setting dimensions/keys (jvssitenodewin) or from Jeeves' menu.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Embedded list ID | JvsSiteDetailId | ZtLong | 10 |  | int
Detail list id (orig) | JvsSiteDetailId_orig | ZtLong | 10 |  | int
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Setting ID (orig) | JvsSiteNodeWinSettingsID_orig | ZtLong | 10 |  | int
Tab ID | JvsSiteTabID | ZtLong | 10 |  | int
Tab ID (orig) | JvsSiteTabID_orig | ZtLong | 10 |  | int
Window context | JvsSiteWindowName | ztString | 40 |  | nvarchar
Startpos X axis | JvsSiteXPos | ZtLong | 10 |  | int
Width | JvsSiteXSize | ZtLong | 10 |  | int
Startpos Y axis | JvsSiteYPos | ZtLong | 10 |  | int
Height | JvsSiteYSize | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteWindowDetails Embedded lists


Entry journal types, fixed assets transactions (FAjt)

Definition of journal types used in the entry journal program Fixed asset transactions entry journal (fatransj). Examples: changes in value, sales etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Addn fr suppl invc | AddIntegrFA | ztBoolean |  |  | char
Addn cmpnt fr suppl invc | AddNewFAcomp | ztBoolean |  |  | char
Addn cmpnt man | AddNewManFAcomp | ztBoolean |  |  | char
Entry layer | FA_TransLayer | ztInteger | 1 |  | smallint
FA journaltype descr | FAjTDescr | ztString | 40 |  | varchar
Min FA journal No | FAjTfromNo | ZtLong | 9 |  | int
FA journal type ID | FAjTId | ztInteger | 4 |  | smallint
FA Journal number | FAjTNo | ZtLong | 9 |  | int
Entry journal prefix | FAjTPrefix | ztString | 10 |  | varchar
Max FA journal No | FAjTtomNo | ZtLong | 9 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Transaction type | invtranstyp | ztInteger | 3 |  | smallint
To be posted | Konteras | ztBoolean |  |  | char
Entry fr suppl invc | NewIntegrFA | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Manual entry | RegManFA | ztBoolean |  |  | char
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: FAjt Entry journal types, fixed assets transactions


Entry journal types, inventory transactions (xljt)

Definition of the different types that an entry journal for inventory transactions can have, according to your own need. You can, for example, apply journal types per inventory transaction type (Manual deliv receipt, Manual dispatch, Inventory transfer, etc.), per inventory location or per inventory location manager.

For each journal type you can specify the following information in the three embedded list windows:
- permitted inventory transaction types
- possible issuers of the journal type - only specified users can create the journal header and change status!
- possible recipients of the journal type- optional information, recipient can also be manually specified on the journal header

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Ent.journal, move item | KodFlyttningAvArtikel | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Ent.journ type, inv trans | RegJournalLagerBeskr | ztString | 50 |  | varchar
Ent.journ no., inv trans | RegJournalLagerNr | ZtLong | 9 |  | int
From ent.journ no. | RegJournalLagerNrFrom | ZtLong | 9 |  | int
Ent.journal no. (alpha) prefix | RegJournalLagerNrPrefix | ztString | 10 |  | varchar
To ent.journ no. | RegJournalLagerNrTom | ZtLong | 9 |  | int
Ent.journ type, inv trans | RegJournalLagerTyp | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
To inventory location | TillLagStalle | ztString | 2 |  | varchar

    This table is the main table in the following programs:

    Program: xljt Entry journal types, inventory transactions


Entry layer (xfl)

Definition of entry layer (leading layer) in appendix entry. The information is used internally in Jeeves to determine which fields will be filled in.

The following standard records exist. Do not alter/delete:

Entry layer (forlayer) | Entry layer (ForlayerB)
20 | Customer invoice
25 | Supplier invoice
30 | General Ledger
40 | Difference posting
41 | Incoming pmt
42 | Advance from customer
45 | Outgoing payment
50 | Cash
90 | Cash-/bankbook

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Entry layer | forlayer | ztInteger | 2 |  | smallint
Entry layer | ForlayerB | ztString | 50 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xfl Entry layers


Error codes EDI order row (xed4)

Table of error codes for an order row that can arise during validation of EDI data.

Records 23 Could not create agreement, 28 Automatically created agreement header and 29 Automatically created agreement row are introduced in version 8, service pack 2.

The following standard records exist. Do not alter/delete:

Defect reason (OrdErrorCd) | Defect reason (OrdErrorCdB) | Description
0 | OK | No error
1 | Incorrect order number |
2 | Incorrect order type |
3 | Incorrect company no. | The company does not exist in the customer table (kus)
4 | Incorrect backorder no. |
5 | Incorrect row no. |
6 | Incorrect position no. |
7 | Incorrect currency |
8 | Incorrect exchange rate |
9 | No inventory loc entered |
10 | OrdvRabkod not found |
11 | OrpStrPrisBer not found |
13 | No price list |
14 | No price type entered |
15 | No/incorrect currency clause |
16 | No item entered | The specified item is not entered. A check has been done against customer specific item numbers and supplier specific item numbers without result.
17 | No/incorrect unit | The unit code entered on the order row or item is not set up as a unit.
18 | No estimated dispatch date |
19 | Receiving=Sending inventory loc |
20 | Purchase order row missing | The purchase order row referred to does not exist.
21 | Order acknowledged Item no. <> Ordered | The item on the order acknowledgement is not the same as the ordered item number.
22 | Rec deliveries missing | There are no received deliveries to cover the quantity that is invoice matched. (edft.FaktAvprAntalExtQty - edft.BestLevAntExtQty) > (bp.BestLevAntExtQty-bp.FaktAvprAntalExtQty).
23 | Could not create agreement | The routine failed to create an agreement header for the row. This is only done on receipt of dispatch plans.
24 | Supplier not found! |
25 | Incorrect row tax | The specified tax code or tax rate cannot be found in the tax table.
26 | Item not saleable | The item must be flagged as saleable to be able to create orders on it.
27 | The item cannot be used | The item must be flagged as usable to be able to create an order on it.
28 | Automatically created agreement header | The validation has produced an automatically created agreement header. According to the Jeeves parameter EDIAPP008, you have stated that you want to be able to look at this automatically created agreement before orders are created. You must remove the cross in the automatically created field on the agreement to be able to move on.
29 | Automatically created agreement row | The validation has produced an automatically created agreement row. According to the Jeeves parameter EDIAPP009, you have stated that you want to be able to look at this automatically created agreement row before orders are created. You must remove the cross in the automatically created field on the agreement row to be able to move on.
30 | PO missing |
31 | Delivery note number not found | No delivery note number is entered on the SBI invoice.
32 | Delivery note not invoiced | No invoice is flagged with the same delivery note number as the SBI invoice.
33 | Delivery note on several invoices |
35 | No match for item | The item entered on the SBI invoice does not exist on your own invoice.
36 | No match for quantity | The quantity entered on the SBI invoice does not match the quantity on your own invoice.
37 | No match for currency | The currency code on the SBI invoice does not match your own invoice.
38 | No match for row sum | The row total on the SBI invoice does not match your own invoice row total.
39 | No matching invoice row | Unable to match the SBI invoice against any invoice row on your own invoice. Not possible even to suggest a possible match.
40 | Row not found on SBI invoice | The invoice row exists on your own invoice but not on the SBI invoice.
41 | Syncro/deljit without Individ/kanban | When you receive a SYNCRO or DELJIT message, every row must have an item individual reference specified.
42 | Acknowledge Edi log | You should read the important information in the text field ‘EDI Log’. Perform the necessary steps and run a new validation. If you want to accept the record without steps, the field ‘Acknowledge Edi log’ must be checked. The tests that caused the EDI log will not then be done.
43 | Row missing in order acknowledgment | The order acknowledgement does not have any rows that are on the purchase order. Control parameter EDIAPP011, or the order acknowledgement header, governs whether the order acknowledgement must contain all purchase order rows.
44 | Incoming detail not saleable |
45 | Incoming detail may not be used. |
46 | Defects on item | When working on delivery plans, an item must be read in its entirety. The current row therefore contains no error. However, there is another row with the same item number which is incorrect.
47 | Step code must be entered |
48 | Unknown step code |
49 | Order row status does not allow changes |
50 | No matching order rows found |
51 | Order row status does not allow cancellation |
52 | Order specific inventory Cancellation not allowed. |
53 | Delivery note exists. Cancellation not allowed. |
54 | Quantity/value picked. Cancellation not allowed. |
55 | Linked to order. Cancellation not allowed. |
56 | Linked to manuf.order. Cancellation not allowed. |
57 | Item to be discontinued, NOT AVAILABLE! |
58 | Unable to create deliv. note |
98 | Data changed, run new validation | When a record which has validated status is changed, a new validation must be run to check that the change is correct.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Defect reason | OrdErrorCd | ztInteger | 4 |  | smallint
Defect reason | OrdErrorCdB | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xed4 Error codes EDI order row


Error codes, EDI order header (xed3)

Table indicating errors that may arise when validating incoming EDI data. This table only contains the error codes that may relate to the header. Ex: Order header.

The following standard records exist. Do not alter/delete:

Defect reason (OhdErrorCd) | Defect reason (OhdErrorCdB) | Description
0 | OK | No error
1 | Incorrect order number | External order number must be filled in (ExtOrderNr).
2 | Incorrect order type |
3 | Incorrect company no. | Company number must be filled in.
4 | No dispatch method entered (xbls) | Check that the dispatch method for the customer exists in the ‘Dispatch methods per invtry loc’ table (xbls)
5 | No (delivery) customer/customer deleted | The company does not exist in the customer table (kus) or the customer is flagged as “canceled”.
6 | No paying customer/cust deleted | The customer specified as payer does not exist in the table (kus) or is flagged as “canceled”. On receipt of an invoice, the error code means that the specified payment recipient is not set up as a supplier.
7 | No payment terms entered for payer | Payment term not found or number of days credit not entered on payment term.
8 | Payer is credit blocked | Payer is credit blocked. Cash orders only.
10 | Incorrect currency | The currency code specified is not set up.
11 | Incorrect exchange rate |
12 | No dispatch method entered | No dispatch method for the order / customer.
13 | No dispatch terms entered | No dispatch terms for the order / customer
14 | No payment terms entered | No payment terms for the order / customer.
15 | No tax code entered | No tax code for the order / invoice / customer / supplier
16 | No seller entered | No seller for the order / customer.
17 | No language code entered | No language for the order / customer.
18 | Point of delivery not defined | Incorrect point of delivery entered for the order/customer
19 | Incorrect point of delivery |
20 | Customer is not internal |
21 | No inventory loc entered |
22 | Receiving=Sending inventory loc |
23 | Could not create agreement | The routine attempted to create an agreement header but was unsuccessful.
24 | Supplier not found! |
25 | Invoice date missing |
26 | Incorrect PO number | The purchase order entered on the order acknowledgement/invoice is not entered.
27 | Incorrect freight tax | The tax code entered for the freight cannot be found in the tax table.
28 | Incorrect tax on deduction | The tax code specified for the deduction amount cannot be found in the tax table.
29 | Different supplier No. on purchase order | The supplier number entered on the order acknowledgement is not the same as on the purchase order that the order acknowledgement refers to.
30 | Incorrect due date | A due date is not specified for the invoice. Or the due date is earlier than the invoice date.
31 | Invoice amount missing | The invoice amount is missing or 0.
32 | SBI invoice referred to not found | The invoice to be corrected by this amendment invoice does not exist.
33 | Incorrect status for SBI referred to | The SBI invoice to be corrected by the amendment invoice in question has already been transferred / canceled.
34 | Diff on currency code | The SBI invoice does not have the same currency code as your own invoice.
35 | Diff on exchange rate | The SBI invoice does not have the same exchange rate as your own invoice.
36 | Diff on tax amount | The SBI invoice does not have the same tax amount as your own invoice.
37 | Diff on invoice sum | The SBI invoice does not have the same total invoice amount as your own invoice.
38 | Diff on tax rate | The SBI invoice does not have the same tax rate as your own invoice.
39 | Order linking not allowed | Customer does now allow order coupling at the same time there is an order coupling code for the order type that applies to the order that will be created.
40 | SYNCRO/DELJIT not implemented |
42 | Acknowledge Edi log | You should read the important information in the text field ‘EDI Log’. Perform the necessary steps and run a new validation. If you want to accept the record without steps, the field ‘Edi.logg kvitterad’ must be checked. The tests that caused the EDI log will not then be done.
50 | Currency code PO not equal |
51 | Payment recipient not set up |
52 | Invoice data older than 60 days |
53 | Customer order not found | Customer order could not be found as given. Order number is used preferably as given. If no order number is given, the customer’s purchase order number is used to attempt to find which order number is being referred to.
54 | Customer order must be entered | Neither customer order number nor customer’s purchase order number have been given. This is necessary to be able to find the customer order referred to.
55 | Current order status does not allow changes | Changes not allowed to customer order with higher status than registered.
56 | No message function |
57 | Unknown message function |
58 | Unable to create deliv. note |
59 | Unable pack deliv. note |
60 | Unable to pick deliv. note |
61 | Unable to release deliv. note |
98 | Data changed, run new validation | The company or external order number has changed on the record, new validation must be run.
99 | Error on order row | Invoice/order headers are OK but one of the associated rows is error-flagged and needs to be rectified to be able to transfer the record.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Defect reason | OhdErrorCd | ztInteger | 4 |  | smallint
Defect reason | OhdErrorCdB | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xed3 Error codes, EDI order header


Error message rows received via EDI (EdiErrL)

Used when receiving error reports via EDI. (APERAK-notice).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
In/Out box EDI | EdiBoxRef | ztString | 21 |  | varchar
Document reference | EdiDocRef | ztString | 35 |  | varchar
Row number | EdiDocRefLineNo | ztString | 6 |  | varchar
Document type | EdiDocRefType | ztString | 3 |  | varchar
Error row | EdiErrLineNo | ZtLong | 10 |  | int
Error code | EdiErrorCode | ztString | 8 |  | varchar
EDI message ID | EdiMeddId | ztString | 35 |  | varchar
Text | edit | ztBlob | 1 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
RowNo. | FaktRadNr | ztInteger | 4 |  | int
Delivery note/disp no. | FfhNr | ZtLong | 10 |  | int
RowNo | FFhRadNr | ztInteger | 5 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Error message/receipts via EDI (EdiErrH)

Used when receiving error reports via EDI. (APERAK-notice).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Date | EdiAperakDatum | ztDate |  |  | datetime
Receipt by | EdiAperakKvitteradAv | ztString | 6 |  | varchar
Receipt date and time | EdiAperakKvitteradDt | ztDateTime |  |  | datetime
In/Out box EDI | EdiBoxRef | ztString | 21 |  | varchar
Document reference | EdiDocRef | ztString | 35 |  | varchar
Document type | EdiDocRefType | ztString | 3 |  | varchar
EDI message ID | EdiMeddId | ztString | 35 |  | varchar
Text | edit | ztBlob | 1 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Delivery note/disp no. | FfhNr | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: edi_APERAK EDI error message, increased


Error messages in triggers/procedures (jder)

Messages written based on triggers and procedures.

Note that customer-specific texts must be assigned number >999999.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Documentation | Documentation | ztBlob | 1 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Revision | Revision | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: jder Error msgs from Jeeves server pgm


Error types (sht6)

Definition of existing error types that can be used for entry and reporting of service orders.

This is a simpler classification of errors and steps that can be applied instead of IRIS classification.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
Error type | FelNr | ztString | 3 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: sht6 Error types


Errors, triggers & procedures (view) (vjd1)

Error messages and other texts written in triggers and procedures.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Documentation | Documentation | ztBlob | 1 |  | varchar
Company | ForetagKod | ztBlob | 1 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Text/info | x255 | ztString | 255 |  | varchar


Errors, triggers & procedures (view) (vjd2)

Error messages and other texts written in triggers and procedures.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Documentation | Documentation | ztBlob | 1 |  | varchar
Company | ForetagKod | ztBlob | 1 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Text/info | x255 | ztString | 255 |  | varchar


Errors, triggers & procedures (view) (vjde)

Error messages and other texts written in triggers and procedures.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Documentation | Documentation | ztBlob | 1 |  | varchar
Company | ForetagKod | ztBlob | 1 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: vjde Error msgs from Jeeves server pgm


EU quarterly report, definition of report period (EUPer)

Table for main records with definitions of report periods for EU quarterly reports.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
EU quarterly report printout | EUSumUtskrDat | ztDateTime |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Date for submission | InlamningsDatum | ztDate |  |  | datetime
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period number | KalArPeriod | ztInteger | 4 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Period from date | PerFromDatum | ztDate |  |  | datetime
Period designation | PeriodBeskr | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Period to date | PerTomDatum | ztDate |  |  | datetime
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Resp submit, last name | UppgAnsvEfterNamn | ztString | 30 |  | varchar
Resp submit, first name | UppgAnsvForNamn | ztString | 30 |  | varchar
Resp submit, telephone | UppgAnsvTelefon | ztString | 20 |  | varchar

    This table is the main table in the following programs:

    Program: EUPer EU quarterly report, definition report period


EU quarterly report, totals export/import (EUSum)

Totals for calendar years and period per EU VAT number for customers/suppliers regarding exports and imports.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
EU VAT/tax registration no. | EUMomsNr | ztString | 20 |  | varchar
Type | EUSumTyp | ztInteger | 1 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Third party trade | Handel3Part | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period number | KalArPeriod | ztInteger | 4 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Customer | KundNr | ztCompanyNo | 20 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Amount to report | SumBelAttRedovisa | ZtBaseCurrAmount | 14 | 2 | money
Total amt excl VAT/tax | SumBelExklMoms | ZtBaseCurrAmount | 14 | 2 | money
Total amt, incl VAT/tax | SumBelInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Total VAT/tax amount | SumBelMoms | ZtBaseCurrAmount | 14 | 2 | money


Event type code (WMS_EventTypeCode)

Definition of event types.

Standard event types are distributed during installation but customer specific event types can be entered.

The available customer specific intervals are:

* SKU, automatic events: 160 - 169
* SKU, manual events: 170 - 179
* TU, automatic events: 260 - 269
* TU, manual events: 270 - 279

Note! Customer specific event types demands modification of the Mod printing procedures to handle the added events.

The following standard records exist. Do not alter/delete:

Event type (EventTypeCode) | Event description (EventTypeDesc) | Description
100 | SKU created | A SKU is created.
101 | SKU created manually | A SKU is created manually.
102 | SKU created by split | When performing replenishment pick assignments a quantity is picked from a stock SKU and a new SKU is created for the picked quantity.
190 | SKU print request | A print out of a SKU label is manually requested.
210 | TU created by transfer | During the picking process the picker decided that the TU was filled up and therefore a new TU was created for the remaining picking tasks.
220 | TU being picked | A picking assignment is assigned to a mobile unit. This indicates that it is time to carry out the assignment by filling the TU of the picking assignment.
230 | TU picked | A TU is fully picked. This indicates that it is time to print a content list.
290 | TU print request | A print out of a TU label is manually requested.
330 | TU Content picked | A TU content is fully picked.
390 | TU Content print request | A print out of a TU Content label is manually requested.
590 | MHA print request | A print out of a MHA label is manually requested.
690 | Rack print request | A print out of a rack label is manually requested.
790 | Location print request | A print out of a location label is manually requested.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Event type | EventTypeCode | ztInteger | 3 |  | smallint
Event description | EventTypeDesc | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_EventTypeCode Event type code


Exception calendar for resource overload (WorkLoadOverLoadTolCal)

Exceptions from work schedule, in other words, a date when manufacturing resource (manufacturing group or work group) has another quantity of resources on hand.

When creating or updating a detailed workload, a control is performed to see if there are any exceptions from the schedule.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Date | kalenderdatum | ztDate |  |  | datetime
Manufacturing resource ID | manufres_id | ZtLong | 10 |  | int
%-tol overload | OverLoadTolProc | ZtDecimal73 | 8 | 3 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Valid to date | TomDatum | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: WorkLoadOverLoadTolCal Exception calendar, manufacturing resource overload


Exception calendar for resources (WorkloadExceptionCal)

Exceptions from work schedule, in other words, a date when manufacturing resource (manufacturing group or work group) has another quantity of resources on hand.

In the creation and updating of detailed workload a control is performed to see if there are exceptions from the schedule.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity Machines/Staffing | AntalMaskinEllerBemanning | ztFloat | 6 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Date | kalenderdatum | ztDate |  |  | datetime
Manufacturing resource ID | manufres_id | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Valid to date | TomDatum | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: WorkloadExceptionCal exception calendar for manufacturing resources


Exception tolerance for resource overload (WorkLoadOverLoadTolDays)

Exceptions from work schedule, in other words, a date when current manufacturing resource (manufacturing group or work group) has another quantity of resources on hand.

When creating or updating a detailed workload, a control is performed to see if there are any exceptions from the schedule.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Manufacturing resource ID | manufres_id | ZtLong | 10 |  | int
Tol overload after days | OverLoadTolAfterNoDays | ztInteger | 4 |  | smallint
%-tol overload | OverLoadTolProc | ZtDecimal73 | 8 | 3 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WorkLoadOverLoadTolDays Manufacturing resource overload after days


Expense and material issue (ex)

Inventory issues and expenses in assignments and projects for eventual invoicing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | antal | ZtQty | 14 | 2 | decimal
Item description | ArtBeskr | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
This field is used in the table as follows: |
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Component serial no. | ArtSerieing | ztString | 30 |  | varchar
Item serial no. | artserienr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
PO no. | bestnr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Reported activity | EventRpKod | ztInteger | 3 |  | smallint
Expense date | ExLevDat | ztDate |  |  | datetime
Text on invoice row | exRadText | ztString | 255 |  | varchar
List ext costs No. | ExtKostnadLista | ZtLong | 10 |  | int
Sales tax | FaktMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no., original | FaktNrOrg | Jeeves_InvNo | 9 |  | bigint
RowNo. | FaktRadNr | ztInteger | 4 |  | int
Invoice row no., original | FaktRadNrOrg | ZtLong | 9 |  | int
Invc row amount | FaktRadSumma | ZtBaseCurrAmount | 14 | 2 | money
Invoice row amount (+tax) | FaktRadSummaInklMoms | ZtBaseCurrAmount | 14 | 2 | money
To be invoiced | Faktureras | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Invoice row no | InvRowNo | ZtLong | 5 |  | int
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Customer | KundNr | ztCompanyNo | 20 |  | varchar
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Wage type | Loneart | ztString | 6 |  | varchar
This field is used in the table as follows: |
Markup/reduction % | markup | ztFloat | 14 | 4 | float
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OK to invoice | OKtoInvoice | ztBoolean |  |  | char
OLE-1 | ole1 | ztString | 255 |  | varchar
Order no. | ordernr | Jeeves_SONo | 8 |  | bigint
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Price | pris | ZtBaseCurrAmount | 14 | 2 | money
Price list | prislista | ztInteger | 5 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Row | RadPos | ZtLong | 10 |  | int
Pos | RadPos1 | ztInteger | 4 |  | int
Row | RadPos2 | ztInteger | 4 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Time report no. | Tidrapportnr | ZtLong | 10 |  | int
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Price, curr | vb_pris | ZtSalesPrice | 12 | 2 | money
VAT/tax, curr | VbFaktMoms | ztMoney | 14 | 2 | money
Week no | Veckonr | ztInteger | 6 |  | smallint
Voucher no. | Vernr | Jeeves_VchrNo | 9 |  | bigint
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint
Prel invoice no. org | WorkFaktNrOrg | Jeeves_InvNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: ex Expenses


External business units ICT (ICTConBusUnit)

Definition of the external business units or equivalent, i.e. units within other companies with which the home company has business relations. The term “business unit” shows the unit that owns an order, purchase order, invoice etc, as well as the unit to which the order, purchase order, or invoice is directed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
ICT conn business unit | ICTConBusinessUnit | ztString | 8 |  | varchar
ICT conn business unit | ICTConBusinessUnitDescr | ztString | 50 |  | varchar
Database connection ICT | ICTDataBase | ztString | 120 |  | varchar
Database schema ICT | ICTDataBaseSchema | ztString | 120 |  | varchar
External company ICT | ICTExtrnCoNo | ztInteger | 4 |  | smallint
Internal company ICT | ICTIntrnCoNo | ztInteger | 5 |  | smallint
Inventory location ICT | ICTInvLocation | ztString | 16 |  | varchar
Inventory loc group ICT | ICTInvtryLocGrp | ztString | 8 |  | varchar
Linked server ICT | ICTLinkedServer | ztString | 120 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Connection type ICT | ICTType | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ICTConBusUnit External business units ICT


External interface to workflow (wext)

Workflow table to control flows externally, such as To be able to control activities via the web

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Activity status | activitystatus | ztInteger | 3 |  | smallint
Quantity | Antal | ZtQty | 14 | 2 | decimal
Optional date | DataDate1 | ztDateTime |  |  | datetime
Integer 1 | DataInt1 | ztInteger | 5 |  | smallint
Integer 2 | DataInt2 | ztInteger | 5 |  | smallint
Command | DataVarchar1 | ztString | 255 |  | varchar
Activity | Datavarchar2 | ztString | 255 |  | varchar
Date for escalation | EscalationDateTime | ztDateTime |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | NoteText | ztString | 8000 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
This field is used in the table as follows: |
E-mail signature | perssignEmail | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Resource group | resursgrp | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | sqlidentity | ZtLong | 10 |  | int
Selected stamp | StampStatus | ztInteger | 5 |  | smallint
Unique ID (wext) | wextdummyuniqueid | ztUniqueIdentifier | 50 |  | varchar
Activity information | WfInfo | ztString | 255 |  | varchar
Signature | Wfperssign | ztString | 30 |  | varchar
This field is used in the table as follows: |
Unique ID link | wfrowuniqueid | ztString | 50 |  | varchar
Unique ID activity instance | wpiadummyuniqueid | ztUniqueIdentifier | 50 |  | varchar
Info/Text | x8000 | ztString | 4000 |  | varchar
Base/value table | ztable | ztString | 255 |  | varchar


External order status EDI (xed2)

Table of external order status codes for EDI. This is used to indicate the status of external EDI orders.

The following standard records exist. Do not alter/delete:

External order status (ExtOrdSta) | External order status (ExtOrdStaB)
0 | New
1 | Error
2 | Validated
3 | Activated
4 | Partly transferred
5 | Transferred
8 | History
9 | Canceled

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
External order status | ExtOrdSta | ztInteger | 2 |  | smallint
External order status | ExtOrdStaB | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xed2 External order status EDI


External order types EDI (xed1)

Table of external order types for EDI that are used to describe the transaction types that come in.

The following standard records exist. Do not alter/delete:

External order type (ExtOrdTyp) | External order type (ExtOrdTypB)
1 | External invoice
2 | External backorder
3 | Odette delivery plan
4 | Restocking order
5 | EDI order
6 | Order acknowledgement
7 | Supplier invoice

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
External order type | ExtOrdTyp | ztInteger | 3 |  | smallint
External order type | ExtOrdTypB | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xed1 External order types EDI


Fast reporting of MOs (thq)

Work table used when fast reporting manufacturing orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
No. of open receiving rows | InlevAntRaderEjKlara | ZtLong | 10 |  | int
Receiving value | InlevKalkVarde | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
No. not finished mtrl rows | MtrlAntRaderEjKlara | ZtLong | 10 |  | int
Material Row, ext qty | MtrlAntRaderExtQty | ZtLong | 10 |  | int
Incomplete op rows | OpAntRaderEjKlara | ZtLong | 10 |  | int
Not ready ord-spec rows | OULAntRaderEjKlara | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Can be finished | Possible2Finish | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Actual cost | ThVerKalk | ZtBaseCurrAmount | 14 | 2 | money
Calc diff amount | ti_KalkDiff_Belopp | ZtBaseCurrAmount | 14 | 2 | money
Calc diff % | ti_KalkDiff_Proc | ZtBaseCurrAmount | 14 | 2 | money
Max cost diff amount | ti_Max_KalkDiff_Belopp | ZtBaseCurrAmount | 14 | 2 | money
Max cost diff % | ti_Max_KalkDiff_Proc | ztFloat | 15 | 2 | float
Max neg cost diff amount | ti_Max_Neg_KalkDiff_Belopp | ZtBaseCurrAmount | 14 | 2 | money
Max neg cost diff % | ti_Max_Neg_KalkDiff_Proc | ztFloat | 15 | 2 | float
Mfg cost diff | TillvVinst | ZtBaseCurrAmount | 14 | 2 | money
Closed | TransactionFinished | ztBoolean |  |  | char


Fictitious resource groups (XRGF)

Numeric ID for approval chain in Workflow.

During electronic attest of supplier invoices, this information is only available if the control parameter ACCPAY021 is set to YES.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval chain | attkedja | ztInteger | 5 |  | smallint
Incl in fict resource group | FiktivResursGrp | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
NextResourceGrp | NastaResursGrp | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Level approval chain | posattkedja | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Resource group | ResursGrp | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Field positions (JvsSiteWinFields)

Program/table for viewing and editing settings regarding the position of fields in columns. Settings are saved here when a column is moved or a field is moved within a column, also when tabs and buttons are created.

The program/table can be accessed through an embedded window in the program Setting dimensions/keys (jvssitenodewin) or from Jeeves' menu.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Column ID | JvsSiteColID | ZtLong | 10 |  | int
Column ID (orig) | JvsSiteColID_orig | ZtLong | 10 |  | int
Term | JvsSiteColumnName | ztString | 40 |  | nvarchar
Frame ID | JvsSiteFrameID | ZtLong | 10 |  | int
Frame ID (orig) | JvsSiteFrameID_orig | ZtLong | 10 |  | int
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Setting ID (orig) | JvsSiteNodeWinSettingsID_orig | ZtLong | 10 |  | int
Active | JvsSiteSettingActive | ztBoolean |  |  | char
Tab ID | JvsSiteTabID | ZtLong | 10 |  | int
Tab ID (orig) | JvsSiteTabID_orig | ZtLong | 10 |  | int
Table | JvsSiteTableName | ztString | 40 |  | nvarchar
Sequence no. | JvsSiteTabSeq | ztInteger | 5 |  | smallint
Unique ID | JvsSiteUniqueId | ztString | 40 |  | nvarchar
Field ID | JvsSiteWindowFieldID | ZtLong | 11 |  | int
Field ID (orig) | JvsSiteWindowFieldID_orig | ZtLong | 11 |  | int
ID on window setting | JvsSiteWindowSettingsID | ZtLong | 10 |  | int
ID on window setting (orig) | JvsSiteWindowSettingsID_orig | ZtLong | 10 |  | int
Window type | JvsSiteWindowType | ztString | 2 |  | nvarchar
Conn to added fields GUID | JvsSiteWinFields_get_AF_GUID | ztString | 2 |  | nvarchar
Startpos X axis | JvsSiteXPos | ZtLong | 10 |  | int
Width | JvsSiteXSize | ZtLong | 10 |  | int
Startpos Y axis | JvsSiteYPos | ZtLong | 10 |  | int
Height | JvsSiteYSize | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteWinFields Field positions


Field settings (JvsSiteWinFieldPropertys)

Program/table for viewing and editing settings regarding the appearance of fields. Example of settings that are stored here are hidden fields, changed or hidden prompt texts, fields expanded to multiple lines, tooltips etc.

The program/table can be accessed through an embedded window in the program Setting dimensions/keys (jvssitenodewin) or from Jeeves' menu.

For settings involving own texts there is also an embedded window for translating these texts to other languages in which the system is run.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Term | JvsSiteColumnName | ztString | 40 |  | nvarchar
Frame ID | JvsSiteFrameID | ZtLong | 10 |  | int
Frame ID (orig) | JvsSiteFrameID_orig | ZtLong | 10 |  | int
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Setting ID (orig) | JvsSiteNodeWinSettingsID_orig | ZtLong | 10 |  | int
Data | JvsSitePropertyData | ztString | 7500 |  | nvarchar
Type | JvsSitePropertyName | ztString | 64 |  | nvarchar
Tab ID | JvsSiteTabID | ZtLong | 10 |  | int
Tab ID (orig) | JvsSiteTabID_orig | ZtLong | 10 |  | int
Table | JvsSiteTableName | ztString | 40 |  | nvarchar
Field ID | JvsSiteWindowFieldID | ZtLong | 11 |  | int
Field ID (orig) | JvsSiteWindowFieldID_orig | ZtLong | 11 |  | int
Window type | JvsSiteWindowType | ztString | 2 |  | nvarchar
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteWinFieldPropertys Field settings


Fields in own windows (UsrDefWindowFields)

Definition of which fields will be included in customized images in customized tables.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Name of column | JvsColumnName | ztString | 128 |  | varchar
Sequence no. | JvsSeqNo | ZtLong | 10 |  | int
Table name | JvsTableName | ztString | 128 |  | varchar
Window name in Jeeves | JvsWindowName | ztString | 40 |  | varchar
Internal no (winfield) | JvsWinFieldIntrNo | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Development project | UsrDefDevProj | ztString | 10 |  | varchar
Drop-down value column | UsrDefDropDownValueColumn | ztString | 255 |  | varchar
Show as checkbox | UsrDefFieldAsCheckBox | ztBoolean |  |  | char
Drop down list | UsrDefFieldAsDropDownList | ztBoolean |  |  | char
Displayed in form | UsrDefFieldOutOnForm | ztBoolean |  |  | char
Displayed in list window | UsrDefFieldOutOnList | ztBoolean |  |  | char
Displayed in total window | UsrDefFieldOutOnTotal | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: UsrDefWindowFields Fields in own windows


File exporting (fexp)

Table of basic data for file exports.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mail address if error | AlarmmailAdress | ztString | 100 |  | varchar
Do not attach image file | EjFilKopiering | ztBoolean |  |  | char
Export doc type | FilExpDokTyp | ZtLong | 5 |  | int
Export mail address | FilExpMailAdress | ztString | 100 |  | varchar
Export description | FilExportBeskr | ztString | 60 |  | varchar
File export type | FIlExporttyp | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | kortnotering | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Temporary doc type | TempDokTyp | ZtLong | 5 |  | int
Valid to date | TomDatum | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: xfexp Export file and image->external system


File status EDM (PDMF)

Definition of applicable file statuses for documents in document management (EDM).

The following standard records exist. Do not alter/delete:

File status (FilStatus) | File status (FilStatusBeskr) | Description
0 | No file link | Refers to a document record to which no file is linked, for example a newly created document record.
10 | Local file | Local documents are ones that have a file pointer specified in the Full File/Path field (pdmfilename). When you open a document, Jeeves first looks for a local file pointer and secondly for a central document.
20 | Central file | Refers to a document that is saved under its own Unique ID (field: pdmdummyuniqueid) in the directory specified for the document type, field: File/Dir (DokDir). When you open a document, Jeeves first looks for a local file pointer and secondly for a central document.
40 | Archived | Refers to a document record for which the file has been zipped and archived using the Archive button (UF_pdm_archive).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
File status | FilStatus | ztInteger | 5 |  | smallint
File status | FilStatusBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PDMF EDM file status


File types (xpdf)

Definition of occurring file types in document management.

You can link one or more physical file types to a document. You associate programs and readers to the file types or to the documents types with associated file types.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
File extension | documentext | ztString | 30 |  | varchar
Program (edit file) | documenttypeprogram | ztString | 100 |  | varchar
Program (view file) | documenttypeviewer | ztString | 100 |  | varchar
File type | FilTypBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xpdf File types


File types per document type (xpdmf)

Table of file types linked to a specific document type.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Crystal report file | CrystalReportFile | ztString | 100 |  | varchar
Default document type | defdoktyp | ztBoolean |  |  | char
Document template | doctemplate | ztString | 255 |  | varchar
File extension | documentext | ztString | 30 |  | varchar
Document type no. | documenttype | ZtLong | 5 |  | int
Program (edit file) | documenttypeprogram | ztString | 100 |  | varchar
Program (view file) | documenttypeviewer | ztString | 100 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Filepointer defining fields (pdmfpdf)

Table over different definitions for how a filepointer to a file linked to a document should be built.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | description | ztString | 255 |  | varchar
Filepointer terms | filepointerterms | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: pdmfpdf Filepointer defining fields


Files (JvsSiteResource)

Program/table for storing resource files such as background and icon images, used in settings, in the site repository.

The program/table can be accessed through an embedded window in the Setting dimensions/keys program (jvssitenodewin) or from Jeeves' menu.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
File ID | jvssiteresid | ztString | 60 |  | nvarchar
File type | JvsSiteResTyp | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Columns updated | RowUpdatedCols | ztString | 255 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteResource Files


Filter configuration (WMS_UIFilterConfiguration)

Definition of which data that should be displayed in the mobile client.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Term | ColumnName | ztString | 40 |  | varchar
Display index | DisplayIndex | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Window name | WindowName | ztString | 255 |  | varchar
Work flow | Workflow | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_UIFilterConfiguration Filter configuration


Financial description Level 1 (JBIFinLvl1)

Descriptions for the highest grouping level on the balance sheet and income statement, on the second tab in the Jeeves Business Intelligence Financials sheet.

Example:
Level 1 Fixed assets
Level 2 Machines, Buildings, Computers etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Balance sheet group | JBIBalSheetGrp | ztBoolean |  |  | char
Ext. descr. 1 | JBIextdescr1 | ztString | 80 |  | varchar
Ext ID descr 1 | JBIextid1 | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sort order | sortorder | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: JBIFin1 Financial grouping JBI level 1


Financial description Level 2 (JBIFinLvl2)

Descriptions for the second grouping level on the balance sheet and income statement, on the second tab in the Jeeves Business Intelligence Financials sheet.

Example:
Level 1 Fixed assets
Level 2 Machines, Buildings, Computers etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Ext. descr. 2 | JBIextdescr2 | ztString | 80 |  | varchar
Ext ID descr 1 | JBIextid1 | ztInteger | 5 |  | smallint
Ext ID descr 2 | JBIextid2 | ztInteger | 5 |  | smallint
From account | ktofrom | ztString | 8 |  | varchar
To account | ktotom | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sort order | SortOrder | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: JBIFin2 Financial grouping JBI level 2


Financials snapshot BI (view) (vJBI_snapshot)

View used for the financials snapshot in Jeeves Business intelligence.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Net amount | belopp | ZtBaseCurrAmount | 14 | 2 | money
Customer's own account class | egenkontoklassbeskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint


Fiscal year (xrar)

Table of fiscal year with information on corporation identity and which segment shall be used for approval inspection.

Recommendation:

- we recommend that a four-digit designation be used for the fiscal year (e.g. 2004), not a two-digit designation (e.g. 04).

- For a fiscal year that extends over several calendar years, you should NOT use designations that specify a start and end year, such as 0102 for 2001-2002. Because this is a numeric value, the sort and sort order can be disrupted if you change the designation format. Example: The designation 0203 (203) is sorted before 2002. Instead use the field 'Fiscal year desc' (Redarbeskr) to describe the length of the fiscal year.

The following standard records exist. Do not alter/delete:

Fiscal year
(Redovisnar) 		Fiscal year desc
(Redarbeskr)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Appr/ctrl w seg | AttSignKtoDel | ztInteger | 1 |  | smallint
Journal no | DagBoksNr | ZtLong | 9 |  | int
Upd chronological vouch no. | EntryNo_GL_Update | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Posting date | HbUpDat | ztDate |  |  | datetime
Huvudboksdatum | HbUpDatTid | ztDateTime |  |  | datetime
Period for OB | IngBalPeriod | ztInteger | 4 |  | smallint
Account profit/loss | InterimsKtoNrVinstForlust | ztString | 8 |  | varchar
Consolidation code | KoncernKtoKod | ztString | 8 |  | varchar
Acct. diff -> Euro | KtoNr_EUR_Diff | ztString | 8 |  | varchar
PO/invc diff acct | KtoNrBestDiff | ztString | 8 |  | varchar
Max. diff. -> Euro | Max_EUR_Diff | ZtBaseCurrAmount | 14 | 2 | money
Max diff PO/invoice | MaxBestDiffBel | ZtBaseCurrAmount | 14 | 2 | money
Max diff PO/invoice | MaxBestDiffProc | ZtDecimal73 | 7 | 2 | decimal
Max diff% PO row/invc | MaxDiffAmtPercPOLine2APLine | ZtDecimal73 | 8 | 3 | decimal
Max diff PO row/invc | MaxDiffAmtPOLine2APLine | ZtBaseCurrAmount | 14 | 2 | money
Period check | PeriodCheck | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year desc | Redarbeskr | ztString | 50 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Open locked voucher | UnlockClosedVer | ztBoolean |  |  | char
Currency | ValKod | ztString | 3 |  | varchar
This field is used in the table as follows: |
VAT from prev per | VAT_Prev_Period | ztBoolean |  |  | char
Tax index | VATindex | ztFloat | 10 | 6 | float
VAT/tax report number | VATReportNo | ZtLong | 9 |  | int
Voucher no. fr fiscal yr | VerNrFranRedovisnAr | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: RedAr Fiscal year and periods


Fiscal year (view) (vxra)

Database view of the Fiscal year table.
Database view is used in windows in which two different fiscal years are used simultaneously (including when creating opening balances).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Appr/ctrl w seg | AttSignKtoDel | ztInteger | 1 |  | smallint
Journal no | DagBoksNr | ZtLong | 9 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Posting date | HbUpDat | ztDate |  |  | datetime
Huvudboksdatum | HbUpDatTid | ztDateTime |  |  | datetime
Period for OB | IngBalPeriod | ztInteger | 4 |  | smallint
Account profit/loss | InterimsKtoNrVinstForlust | ztString | 8 |  | varchar
Consolidation code | KoncernKtoKod | ztString | 8 |  | varchar
Acct. diff -> Euro | KtoNr_EUR_Diff | ztString | 8 |  | varchar
PO/invc diff acct | KtoNrBestDiff | ztString | 8 |  | varchar
Max. diff. -> Euro | Max_EUR_Diff | ZtBaseCurrAmount | 14 | 2 | money
Max diff PO/invoice | MaxBestDiffBel | ZtBaseCurrAmount | 14 | 2 | money
Max diff PO/invoice | MaxBestDiffProc | ZtDecimal73 | 7 | 2 | decimal
Period check | PeriodCheck | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year desc | Redarbeskr | ztString | 50 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Open locked voucher | UnlockClosedVer | ztBoolean |  |  | char
Currency | ValKod | ztString | 3 |  | varchar
This field is used in the table as follows: |
Voucher no. fr fiscal yr | VerNrFranRedovisnAr | ztInteger | 5 |  | smallint


Fixed asset depreciation journal (inva)

Fixed asset depreciation journal.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Deprn journal status | avskjstatus | ztInteger | 2 |  | smallint
Depreciated amount | Avskrbelopp | ZtBaseCurrAmount | 14 | 2 | money
Depreciation journal | Avskrjournal | ZtLong | 5 |  | int
Depreciation layer | AvskrLayer | ztInteger | 1 |  | smallint
Depreciation method | avskrmet | ztInteger | 2 |  | smallint
Deprec. percent | AvskrProcent | ztFloat | 8 | 4 | float
Calculated deprec, amt | BerAvskrBelopp | ZtBaseCurrAmount | 14 | 2 | money
Calculated deprec, percent | BerAvskrProcent | ztFloat | 8 | 4 | float
Accounting date | Bokfdat | ztDate |  |  | datetime
Text | edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | Perssign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | Regdat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: inva Recorded depreciation journal


Fixed asset groups (anlg)

Table of fixed asset group data, such as depreciation method and lifetime.

Each fixed asset must belong to a fixed asset group. Common to such a group is depreciation method, economic life, and the accounts to be used for acquisitions, depreciations, etc. Technical life has no controlling function.

The program node in the far left of the window lists all fixed assets that belong to the group. The node to your right is part of an underlying program where you enter the posting templates to be used for acquisition, depreciation, etc.
The posting templates are fixed to fiscal years and are copied when tables are copied between different years. Details in the integration source are entered in the table "Posting details/fixed assets" (xixk) and describe the different accounts that can be linked together with fixed asset management. These descriptions are then linked to an account. Other account segments are often retrieved from the individual asset and should not be entered here. A check is done against the chart of accounts to see which account segments this account should include; only these account segments will be taken into consideration when posting.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Fixed assets group | anlgrp | ztString | 10 |  | varchar
Fixed assets group | anlgrpB | ztString | 50 |  | varchar
Reverse deprn at sales | AterforVidForsaljning | ztBoolean |  |  | char
Deprn fr acq date | AvskrAnskDat | ztBoolean |  |  | char
Depreciation method | avskrmet | ztInteger | 2 |  | smallint
Avskrtid | Avskrtid | ztInteger | 4 |  | smallint
Depr to 0, last | AvskrTillNoll | ztBoolean |  |  | char
Deprn->0 on % resid val | AvskrTillNollProc | ZtDecimal73 | 8 | 4 | decimal
Delete at sale | BorttagVidFors | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
Economic life | eklivsl | ztInteger | 4 |  | smallint
Econ life in months | EklivsM | ztInteger | 4 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Tax depreciation type | inskAvsTypid | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Loss account | KtoNrFsgForlust | ztString | 8 |  | varchar
Profit account | KtoNrFsgVinst | ztString | 8 |  | varchar
Depreciation periodicity | Periodicitet | ztInteger | 2 |  | smallint
Signature | perssign | ztString | 30 |  | varchar
Recorded depreciation | Planavskr | ztBoolean |  |  | char
Entry date | regdat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax depreciation | SkattAvskr | ztBoolean |  |  | char
Technical life | teknliv | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: anlg Fixed assets groups


Fixed asset status (ints)

Table of status terms used to control how fixed assets are processed.

Status 0 means that the fixed asset is not processed because it lacks certain data (or the like). Status codes between 100 and 899 are used in depreciations and the like.

The following standard records exist. Do not alter/delete:

Fixed asset status (InventarieStatus) | Fixed asset status (InventarieStatusBeskr)
0 | Preliminary (not complete) fixed asset
100 | Approved fixed asset
900 | Discarded
910 | Sold
940 | Canceled

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Fixed asset status | InventarieStatus | ztInteger | 3 |  | smallint
Fixed asset status | InventarieStatusBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ints Fixed asset status


Fixed asset transaction types (xix)

Table of available fixed asset transaction types.

The following standard records exist. Do not alter/delete:

Transaction type (InvTransTyp) | Transaction type descr (InvTransTypBeskr) | Description
10 | Entry of new fixed asset | Generated at entry of assets/fixed assets via a supplier invoice in the Supplier invoices program (xlr) or manual entry in the Fixed assets program (int). No GL postings are involved.
20 | Change status of fixed asset | Created during manual status change in the Fixed assets program (Int). No GL postings are involved.
30 | Division of fixed asset | Generated at division of asset/fixed asset records via the Divide fixed asset function button (Button: PB_Copy_Int) in the program Fixed assets (int). No GL postings are involved.
40 | Addition costs from supplier invoice | Created when another supplier invoice is linked to an existing fixed asset. The GL is posted acc. to the voucher created from the invoice.
210 | Discardment of fixed asset | Entered manually in the Fixed asset transactions program (intt). The transaction amount is filled in automatically with the residual value. GL postings are created with integration details 0, Fixed assets account, 1, Provision for depreciation and 5, Discardment.
220 | Sale of fixed asset | Entered manually in the Fixed asset transactions program (intt). The transaction amount is filled in automatically with the residual value. GL postings are created with integration details 0, Fixed assets account, 1, Provision for depreciation, 6, Sale, and where applicable 8, Gain on sale or 9, Loss on sale.
300 | Move of fixed assets | Entered manually in the Fixed assets transactions program (intt). No GL postings are involved.
910 | Change in acquisition value | Entered manually in the Fixed asset transactions program (intt). GL postings are created with integration details 0, Fixed assets account and 7, Adjustment of acquisition amount.
920 | Change in residual value | Entered manually in the Fixed asset transactions program (intt). The program checks that the residual value is not higher than the acquisition value. GL postings are created with integration details 1, Provision for depreciation and 2, Depreciation.
930 | Change in depreciated amount | Entered manually in the Fixed asset transactions program (intt). GL postings are created with integration details 1, Provision for depreciation and 2, Depreciation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Transaction type | InvTransTyp | ztInteger | 3 |  | smallint
Transaction type descr | InvTransTypBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xix Fixed assets transactions types


Fixed assets (int)

This table is used to enter fixed assets, if it has not been done automatically from the supplier invoice.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Activation date | AktiveringsDatum | ztDate |  |  | datetime
Fixed assets group | anlgrp | ztString | 10 |  | varchar
Acquisition amount | Anskbelopp | ZtBaseCurrAmount | 14 | 2 | money
Acquisition date | anskDat | ztDate |  |  | datetime
Quantity | Antal | ZtQty | 14 | 2 | decimal
Item no. | artnr | ztString | 30 |  | varchar
Item serial no. | artserienr | ztString | 30 |  | varchar
Reversed amount | AterfortBelopp | ZtBaseCurrAmount | 14 | 2 | money
Approved by | Attestsign | ztString | 6 |  | varchar
Depreciated amount | Avskrbelopp | ZtBaseCurrAmount | 14 | 2 | money
Deprn (whole number) | AvskrHeltal | ztBoolean |  |  | char
Depreciation method | avskrmet | ztInteger | 2 |  | smallint
Supplier invoice no. | bestrkgnr | ztString | 25 |  | varchar
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Text | edit | ztBlob | 1 |  | varchar
Economic life | eklivsl | ztInteger | 4 |  | smallint
Econ life in months | EklivsM | ztInteger | 4 |  | smallint
Manufacturer | Fabrikat | ztString | 30 |  | varchar
Building ID | FastighetsID | ztString | 3 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Insured | Forsakrad | ztBoolean |  |  | char
Amount insured | ForsakradBelopp | ZtBaseCurrAmount | 14 | 2 | money
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Rental agreement | Hyresavtal | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Location | intPlaceringKod | ztString | 10 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Owner/User | invAgare | ztInteger | 4 |  | smallint
Power effect | invEffekt | ztFloat | 15 | 2 | float
Fixed asset no | inventarie | ZtLong | 10 |  | int
Fixed asset description | inventarieB | ztString | 35 |  | varchar
Component fixed asset | InventariePos | ztInteger | 5 |  | smallint
Fixed asset status | InventarieStatus | ztInteger | 3 |  | smallint
Fixed asset type | inventarietyp | ztInteger | 5 |  | smallint
Component | invKomponent | ztBlob | 1 |  | varchar
Production date | invProdDatum | ztDate |  |  | datetime
Residual value | InvRest | ZtBaseCurrAmount | 14 | 2 | money
Fixed asset source | InvSource | ztInteger | 2 |  | smallint
Weight | invVikt | ztFloat | 15 | 2 | float
Volume | invVolym | ztFloat | 15 | 2 | float
S4 | K4 | ztString | 8 |  | varchar
S5 | k5 | ztString | 8 |  | varchar
S6 | k6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
S8 | k8 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | ktonr | ztString | 8 |  | varchar
Supplier name | LevNamn | ztString | 36 |  | varchar
Model | Modell | ztString | 30 |  | varchar
Write-down amount | NedskrBelopp | ZtBaseCurrAmount | 14 | 2 | money
Area | Omrade | ztString | 5 |  | varchar
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Period | period | ztInteger | 4 |  | smallint
Signature | perssign | ztString | 30 |  | varchar
Place | Placering | ztString | 40 |  | varchar
Recorded depreciation | PlanAvskr | ztBoolean |  |  | char
Depreciation prev yr | PlanAvskrBeloppFAr | ZtBaseCurrAmount | 14 | 2 | money
Depreciation curr yr | PlanAvskrBeloppIAr | ZtBaseCurrAmount | 14 | 2 | money
Planned residual value | PlanInvRest | ZtBaseCurrAmount | 14 | 2 | money
Project ID | Projcode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | regdat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Last depreciation year | SenAvskrAr | ztInteger | 5 |  | smallint
Last depreciation date | SenAvskrDat | ztDate |  |  | datetime
Last depreciation period | SenAvskrPer | ztInteger | 5 |  | smallint
Technical life | teknliv | ztInteger | 4 |  | smallint
Write-up amount | UppskrBelopp | ZtBaseCurrAmount | 14 | 2 | money
Discard/sale amount | UtRangBelopp | ZtBaseCurrAmount | 14 | 2 | money
Discard/sale date | utrangdat | ztDate |  |  | datetime
Currency | valkod | ztString | 3 |  | varchar
Voucher no. | vernr | Jeeves_VchrNo | 9 |  | bigint
Profit/loss at sale | VinstForsBelopp | ZtBaseCurrAmount | 14 | 2 | money
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: int Fixed assets


Fixed assets (view) (vint)

Fixed asset number or identity.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Fixed assets group | anlgrp |  |  |  | @DataType=NULL
Fixed assets group | anlgrpb | ztString | 50 |  | varchar
Depreciation method | avskrmet | ztInteger | 2 |  | smallint
Depreciation method | avskrmetb | ztString | 50 |  | varchar
Deprec. percent | avskrprocent | ztFloat | 8 | 4 | float
Factor | depratio | ZtDecimal73 | 8 | 2 | decimal
Economic life | Eklivsl | ztInteger | 4 |  | smallint
Econ life in months | eklivsM | ztInteger | 4 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Fixed asset no | inventarie | ZtLong | 10 |  | int
Component fixed asset | InventariePos | ztInteger | 5 |  | smallint
Depreciation periodicity | periodicitet | ztInteger | 2 |  | smallint
Periodicity descr | periodicitetsbeskrivning | ztString | 50 |  | varchar
Signature | PersSign | ztString | 50 |  | varchar
Entry date | RegDat | ztString | 50 |  | varchar
Created by | RowCreatedBy | ztString | 50 |  | varchar
Created date/time | RowCreatedDt | ztString | 50 |  | varchar
Updated by | RowUpdatedBy | ztString | 50 |  | varchar
Updated date/time | RowUpdatedDt | ztString | 50 |  | varchar


Fixed assets depreciations ->GL (iavt)

Table giving detailed information per transaction on how fixed assets depreciations were posted during integration to the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Depreciation journal | AvskrJournal | ZtLong | 5 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Fixed asset no | Inventarie | ZtLong | 10 |  | int
Component fixed asset | InventariePos | ztInteger | 5 |  | smallint
Transaction type | InvTransTyp | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint


Fixed assets journal (FA_TransJour)

Journal headers for fixed assets transactions. The table is only used if you activate FIXASS007.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Transaction date | EventDat | ztDate |  |  | datetime
Entry layer | FA_TransLayer | ztInteger | 1 |  | smallint
Ent.journal inv alphaID | FA_TrJourAlfa | ztString | 30 |  | varchar
FA journal type ID | FAjTId | ztInteger | 4 |  | smallint
FA Journal number | FAjTNo | ZtLong | 9 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Transaction type | InvTransTyp | ztInteger | 3 |  | smallint
Journal status | JournalStatusKod | ztInteger | 2 |  | smallint
To be posted | Konteras | ztBoolean |  |  | char
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: FAtransJ Fixed assets transactions, entry journal


Fixed assets transactions->GL (itvt)

Table containing detailed information per transaction on how fixed assets depreciations were posted during integration to the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Fixed asset no | Inventarie | ZtLong | 10 |  | int
Component fixed asset | InventariePos | ztInteger | 5 |  | smallint
Fixed asset journal | InvJournNr | ZtLong | 6 |  | int
Transaction type | InvTransTyp | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint


Fixed assets types (xit)

Definition of fixed assets types that can be used for own classification purposes where required.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Document no. series | docnoserie | ztString | 3 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Free field 1 | FriFalt1 | ztString | 40 |  | varchar
Free field 2 | FriFalt2 | ztString | 40 |  | varchar
Free field 3 | FriFalt3 | ztString | 40 |  | varchar
Free field 4 | FriFalt4 | ztString | 40 |  | varchar
Free field 5 | FriFalt5 | ztString | 40 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Fixed asset type | inventarietyp | ztInteger | 5 |  | smallint
Fixed asset type | inventarietypB | ztString | 50 |  | varchar
OLE-1 | Ole1 | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xit Fixed assets types


Fixed delivery days (x2fl)

Data for the calculation of fixed dispatch days for deliveries to customers.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Day interval | FastLevIntervDag | ztInteger | 5 |  | smallint
Start day of the week | FastLevVeckoDag | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xx2fl Fixed delivery days/dispatch method


Fixed delivery days per carrier (x2tl)

Data for calculating fixed dispatch days for carriers (x2t).

Enter the start day and interval in days, e.g. Tuesday and day interval=7 gives a fixed dispatch day=Tuesday each week, Tuesday and day interval=3 gives the fixed dispatch days=Friday, Monday, Thursday, Monday, etc.

If the carrier data is entered and a calendar for dispatch days has been established, the calculated dispatch day is proposed automatically when customer orders are entered as the first current dispatch day in the calendar that is linked to the carrier. If an internal lead time is specified for the carrier, this is subtracted from the proposed dispatch day in the order routine and given as the preparation day. If this day falls on a non-working day, Jeeves will propose the closest previous working day.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Day interval | FastLevIntervDag | ztInteger | 5 |  | smallint
Start day of the week | FastLevVeckoDag | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Carrier code | TransportorsKod | ztString | 17 |  | varchar


Fixed departures for dispatch methods (x2fa)

Data for the calculation of fixed departures for deliveries to customers.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Departure unique ID | DepartureUniqueId | ztInteger | 5 |  | smallint
Time of departure | FastLevAvgTid | ztTime | 5 |  | datetime
Start date for depart day | FastLevDagStartDat | ztDate |  |  | datetime
Day interval | FastLevIntervDag | ztInteger | 5 |  | smallint
Start day of the week | FastLevVeckoDag | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Lead time, load before | LoadBeforeDays | ztInteger | 3 |  | smallint
Lead time, load before | LoadBeforeHours | ztInteger | 3 |  | smallint
Lead time, load before | LoadBeforeMinutes | ztInteger | 3 |  | smallint
Loading gate WMS | LoadingGateWMS | ztString | 10 |  | varchar
Load location WMS | LoadLocationWMS | ztString | 10 |  | varchar
Lead time, order gate | OrderGateDays | ztInteger | 3 |  | smallint
Lead time, order gate | OrderGateHours | ztInteger | 3 |  | smallint
Lead time, order gate | OrderGateMinutes | ztInteger | 3 |  | smallint
Lead time, pack before | PackBeforeDays | ztInteger | 3 |  | smallint
Lead time, pack before | PackBeforeHours | ztInteger | 3 |  | smallint
Lead time, pack before | PackBeforeMinutes | ztInteger | 3 |  | smallint
Pack location WMS | PackLocationWMS | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Lead time, pick before | PickBeforeDays | ztInteger | 3 |  | smallint
Lead time, pick before | PickBeforeHours | ztInteger | 3 |  | smallint
Lead time, pick before | PickBeforeMinutes | ztInteger | 3 |  | smallint
Lead time, pick release | PickReleaseDays | ztInteger | 3 |  | smallint
Lead time, pick release | PickReleaseHours | ztInteger | 3 |  | smallint
Lead time, pick release | PickReleaseMinutes | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Lead time, shipment lock | ShipLockBeforeDays | ztInteger | 3 |  | smallint
Lead time, shipment lock | ShipLockBeforeHours | ztInteger | 3 |  | smallint
Lead time, shipment lock | ShipLockBeforeMinutes | ztInteger | 3 |  | smallint
Transport resource | TranspResrcType | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: xx2fa Fixed departures/dispatch method


Flag voucher rows (vxpo)

Journal of flagging voucher rows. See the description of the Flag voucher rows (Vxpo) program for more information.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Note date | Date_of_bank_notification | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Opening balance | IngSaldo | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Journal# | Point_JournNo | ZtLong | 9 |  | int
Journal description | Point_JournNoBeskr | ztString | 40 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Closing balance | UtgSaldo | ZtBaseCurrAmount | 14 | 2 | money
Flag text | vr_Pointage | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: vxpo Flag voucher rows


Flow group history (flghis)

Contains history of the accumulators in the tool record. In this table, a record is created per tool each time resetting of the accumulators in the tool is performed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Acc start date | AckFromDatum | ztDate |  |  | datetime
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Flow group, calculation (flgk)

Tools.
Calculations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Calculation version no. | ArkVersion | ZtLong | 4 |  | int
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calculation item | KalkArtNr | ztString | 30 |  | varchar
Calculation on quantity | KalkylPaAntal | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Tot Kalk ställkostnad | TotArbKalkStallKost | ZtBaseCurrAmount | 14 | 2 | money
Total fixed labour OH | TotArbOmkFast | ZtCost | 16 | 6 | float
Labour OH op/total | TotArbOmkOp | ZtCost | 16 | 6 | float
Var OH labour total | TotArbOmkRorl | ZtCost | 16 | 6 | float
Total setup overhead | TotArbOmkStall | ZtCost | 16 | 6 | float
Ställkostnad | TotStallKost | ZtBaseCurrAmount | 14 | 2 | money


Flow group, person, time reports/day (tflv)

Reported time per flow group, person and report day.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Worked hrs/person | ArbTimPerPers | ztHourWithDecimals | 8 | 2 | decimal
Text | Edit | ztBlob | 1 |  | varchar
Hours | EventTimant2 | ztHourWithDecimals | 8 | 2 | decimal
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | KortNotering | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Flow group, time reports/day (tflg)

Flow group time report header.
In the header, specify the flow group and the end date of the time report.
A default time can also be entered, which is then copied to those working in the flow group for the calendar period that the report covers.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Report man. setup time | AoRappStallTid_Man | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Rep manual run time | AoRappStyckTid_Man | ztOpTime | 9 | 4 | float
Worked hours/flow group | ArbTimFlodesGrupp | ztHourWithDecimals | 8 | 2 | decimal
Hrs per flow grp | ArbTimPerFlg | ztHourWithDecimals | 8 | 2 | decimal
Worked hrs/person | ArbTimPerPers | ztHourWithDecimals | 8 | 2 | decimal
This field is used in the table as follows: |
Text | Edit | ztBlob | 1 |  | varchar
Hours | EventTimant2 | ztHourWithDecimals | 8 | 2 | decimal
Rep yr | FlgRappAr | ztInteger | 4 |  | smallint
Rep Week number | FlgRappVecka | ztInteger | 2 |  | smallint
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Allocated hrs/flow grp | FordelatTimPerFlg | ztHourWithDecimals | 8 | 4 | decimal
Allocation factor | FordelnFaktorFlg | ztFloat | 15 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Correction factor | KorrFaktorFlg | ztFloat | 15 | 2 | float
Signature | PersSign | ztString | 30 |  | varchar
Planned hrs/flow group | PlanTimPerFlg | ztOpTime | 9 | 4 | float
Activity finished | PlanUtford | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Remain hrs/flow group | RestTimPerFlg | ztOpTime | 9 | 4 | float
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: tflg Labour reports per flow group


Flow groups (flg)

Flow groups in manufacturing, containing manufacturing, costing and posting data and also information about workloads for flow groups.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Acc start date | AckFromDatum | ztDate |  |  | datetime
No. of machines | AntMaskiner | ztFloat | 6 | 2 | float
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
This field is used in the table as follows: |
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
This field is used in the table as follows: |
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
This field is used in the table as follows: |
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
This field is used in the table as follows: |
Product acct, labour | ArbProdKonto | ztString | 8 |  | varchar
Worked hrs/day | ArbTimPerDag | ZtDecimal73 | 8 | 2 | decimal
Product acct | ArtProdKonto | ztString | 8 |  | varchar
This field is used in the table as follows: |
Change to manufacturing group | Change2ProductionGroup | ztString | 5 |  | varchar
Extra days for recvd delivery | ExtraDagarInlev | ztInteger | 5 |  | smallint
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Flow group | FlodesGruppBeskr | ztString | 40 |  | varchar
Allocate time to people | FordelaTidPaPersoner | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
OrderSpec S4 (rcv cost centre) | K4OULager | ztString | 8 |  | varchar
OS-S5 (rcv deliveries) | K5OULager | ztString | 8 |  | varchar
OrderSpec S6 (rcv deliveries) | K6OULager | ztString | 8 |  | varchar
OrderSpec S7 (rcv deliveries) | K7OULager | ztString | 8 |  | varchar
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Sent from dept/S3 | KBarAvsandandeEnhet | ztString | 8 |  | varchar
CO specific CC (rec) | KBarOULager | ztString | 8 |  | varchar
WIP Cost units/segment 3 | KBarPIA | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
CC dispatched unit | KstAvsandandeEnhet | ztString | 8 |  | varchar
Orderspec rcv CC | KstOULager | ztString | 8 |  | varchar
WIP CC | KstPIA | ztString | 8 |  | varchar
CC manufacturing diff | KstTillvDiff | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Orderspec rcv account | KtoNrOULager | ztString | 8 |  | varchar
WIP account | KtoNrPIA | ztString | 8 |  | varchar
Acct manufacturing diff | KtoNrTillvDiff | ztString | 8 |  | varchar
New cost as of date | NewCostsFromDate | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Fixed labour OH cost | ProdGrArbOmkFast | ZtBaseCurrAmount | 14 | 2 | money
Fixed labour OH cost (new) | ProdGrArbOmkFastNytt | ZtBaseCurrAmount | 14 | 2 | money
Var labour OH cost | ProdGrArbOmkRorl | ZtBaseCurrAmount | 14 | 2 | money
Var labour OH cost (new) | ProdGrArbOmkRorlNytt | ZtBaseCurrAmount | 14 | 2 | money
Mfg grp OH/operation | ProdGrOmkPerOp | ZtBaseCurrAmount | 14 | 2 | money
Mfg grp OH/op (new) | ProdGrOmkPerOpNytt | ZtBaseCurrAmount | 14 | 2 | money
Mfg grp avail % | ProdGrTillgProc | ZtDecimal73 | 7 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Max cost diff amount | ti_Max_KalkDiff_Belopp | ZtBaseCurrAmount | 14 | 2 | money
Max cost diff % | ti_Max_KalkDiff_Proc | ztFloat | 15 | 2 | float
Max neg cost diff amount | ti_Max_Neg_KalkDiff_Belopp | ZtBaseCurrAmount | 14 | 2 | money
Max neg cost diff % | ti_Max_Neg_KalkDiff_Proc | ztFloat | 15 | 2 | float
Time bank | TidBankFlg | ztHourWithDecimals | 8 | 2 | decimal

    This table is the main table in the following programs:

    Program: flg Flow groups

    Program: ftflg Time allocation (flow group)

    Program: thq_flg Fast reporting, flow group


Flow groups (view) (vflg)

Flow groups in manufacturing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Product acct, labour | ArbProdKonto | ztString | 8 |  | varchar
Worked hrs/day | ArbTimPerDag | ZtDecimal73 | 8 | 2 | decimal
Product acct | ArtProdKonto | ztString | 8 |  | varchar
This field is used in the table as follows: |
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Flow group | FlodesGruppBeskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Orderspec rcv CC | KstOULager | ztString | 8 |  | varchar
WIP CC | KstPIA | ztString | 8 |  | varchar
CC manufacturing diff | KstTillvDiff | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Orderspec rcv account | KtoNrOULager | ztString | 8 |  | varchar
WIP account | KtoNrPIA | ztString | 8 |  | varchar
Acct manufacturing diff | KtoNrTillvDiff | ztString | 8 |  | varchar
New cost as of date | NewCostsFromDate | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Fixed labour OH cost | ProdGrArbOmkFast | ZtBaseCurrAmount | 14 | 2 | money
Fixed labour OH cost (new) | ProdGrArbOmkFastNytt | ZtBaseCurrAmount | 14 | 2 | money
Var labour OH cost | ProdGrArbOmkRorl | ZtBaseCurrAmount | 14 | 2 | money
Var labour OH cost (new) | ProdGrArbOmkRorlNytt | ZtBaseCurrAmount | 14 | 2 | money
Mfg grp OH/operation | ProdGrOmkPerOp | ZtBaseCurrAmount | 14 | 2 | money
Mfg grp OH/op (new) | ProdGrOmkPerOpNytt | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Fonts, ebrev (ebfs)

Fonts, eBrev.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Form call | ebBlankett | ztString | 4 |  | varchar
Font control code | ebFont | ztchar | 1 |  | char
Font name | ebFOntBeskr | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xebfs Fonts, eBrev


Forecast allocation keys (Prfo)

Allocation keys for item forecasts.
The percentage allocation of the main forecast over the included forecast periods.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allocation percent | FordProc | ZtDecimal73 | 6 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Main period | HuvudPeriod | ztString | 25 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Sequence no. | PerOrdNr | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Forecast key | PrognosNyckel | ztString | 25 |  | varchar
Forecast period | PrognosPeriod | ztString | 25 |  | varchar
Forecast version | PrognosVer | ZtLong | 4 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Prfo Forecast keys


Forecast allocation keys, head (Prfh)

Definition of distribution keys that make it possible to enter item forecasts at an optional forecast level and automatically allocate the forecast on other levels. Example: If you enter an item's year forecast you can allocate it automatically to the year's periods.

NOTE. In order for automatic totaling/allocation to function, the same forecast key must be entered for all forecast levels and the allocation must be specified for all periods within all the forecast levels.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Default key, master schedule | DefNyckelHuvudPlan | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Main level | HuvudNiva | ztInteger | 4 |  | smallint
Main period | HuvudPeriod | ztString | 25 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Forecast key | PrognosNyckel | ztString | 25 |  | varchar
Forecast version | PrognosVer | ZtLong | 4 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
To main period | To_HuvudPeriod | ztString | 25 |  | varchar
To forecast key | To_PrognosNyckel | ztString | 25 |  | varchar
To forecast version | To_PrognosVer | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: Prfh Forecast allocation keys


Forecast family (prgf)

Group division of items in forecast families.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Forecast family | PrognosFamilj | ztString | 4 |  | varchar
Forecast family | PrognosFamiljBeskr | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: prgf Forecast families


Forecast family, detail (PrgFamDet)

Definition of any families (groups) of items with a similar sales character to facilitate work with forecasts and master planning.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Forecast family | PrognosFamiljId | ztString | 10 |  | varchar
Forecast share in % | PrognosFordProc | ztFloat | 10 | 6 | float
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Forecast family, forecast version (afpv)

Group division of items in forecast families.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Forecast family | PrognosFamilj | ztString | 4 |  | varchar
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Forecast version | PrognosVer | ZtLong | 4 |  | int

    This table is the main table in the following programs:

    Program: PrgfSrne Market forecast with month values, fmly


Forecast family, header (PrgFamHuv)

Definition of any families (groups) of items with a similar sales character to facilitate work with forecasts and master planning.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Valid from date | GiltigFromDatum | ztDate |  |  | datetime
Valid to date | GiltigTomDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Forecast family active | PrognosFamiljAktiv | ztBoolean |  |  | char
Forecast family | PrognosFamiljBeskr | ztString | 50 |  | varchar
Forecast family | PrognosFamiljId | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PrgFamDef Forecast families


Forecast group, sales (FsgPrgGrp)

Forecast group, sales.
Sales forecast can be set up according to forecast group.
Forecast group can, for example, be a market or seller.
In seller, you can specify to which forecast group the seller belongs.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Forecast group, sales | FsgPrgGrp | ztString | 8 |  | varchar
Forecast group, sales | FsgPrgGrpBeskr | ztString | 60 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Display yearly forecast | ShowForcstAnnualRowsFlag | ztBoolean |  |  | char
Display forecast from date | ShowForcstFromDate | ztDate |  |  | datetime
Display period forecast | ShowForcstPeriodRowsFlag | ztBoolean |  |  | char
Display forecast end date | ShowForcstToDate | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: FsgPrgGrp Forecast group, sales


Forecast header (PrgHuvSel)

Numeric designation of a forecast header.

At new entry, the number is filled in automatically with the next free number if you leave the field blank.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Main level | HuvudNiva | ztInteger | 4 |  | smallint
Main period | HuvudPeriod | ztString | 25 |  | varchar
Master plan number | HuvudPlanNr | ZtLong | 10 |  | int
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Forecast active | PrognosAktiv | ztBoolean |  |  | char
Breakdown date | PrognosNedbrytDatum | ztDateTime |  |  | datetime
ID for breakdown | PrognosNedbrytSign | ztString | 6 |  | varchar
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Forecast no. | PrognosNr | ZtLong | 10 |  | int
Forecast key | PrognosNyckel | ztString | 25 |  | varchar
Forecast object | PrognosObjektId | ztString | 20 |  | varchar
Forecast period | PrognosPeriod | ztString | 25 |  | varchar
Forecast version | PrognosVer | ZtLong | 4 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Forecast header (PrgHuvud)

Table of main data in market forecasts.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Copy of forecast no | FromPrognosNr | ZtLong | 10 |  | int
Main level | HuvudNiva | ztInteger | 4 |  | smallint
Main period | HuvudPeriod | ztString | 25 |  | varchar
Date for master schedule | HuvudPlanDatum | ztDateTime |  |  | datetime
Master plan number | HuvudPlanNr | ZtLong | 10 |  | int
Signature for master schedule | HuvudPlanSign | ztString | 6 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Lowest forecast label | LagstaPrognosNiva | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Forecast active | PrognosAktiv | ztBoolean |  |  | char
Calculation automation | PrognosAutomatik | ztBoolean |  |  | char
Forecast value in whole numbers | PrognosAvrundning | ztBoolean |  |  | char
Breakdown date | PrognosNedbrytDatum | ztDateTime |  |  | datetime
ID for breakdown | PrognosNedbrytSign | ztString | 6 |  | varchar
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Forecast no. | PrognosNr | ZtLong | 10 |  | int
Forecast key | PrognosNyckel | ztString | 25 |  | varchar
Forecast object | PrognosObjektId | ztString | 20 |  | varchar
Forecast period | PrognosPeriod | ztString | 25 |  | varchar
Forecast version | PrognosVer | ZtLong | 4 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PrgFromAr Create forecast from items

    Program: PrgMarknad Forecast, market totaled

    Program: PrgMarknad1 Show forecast, market(ing) forecast period

    Program: PrgMarknad2 Show forecast, market detailed


Forecast item structure (Srpr)

Special table that contains item forecasts, broken down to item components of the BOM.
Note! This table has no programs or reports.
It can be used to create your own reports using, for example, Crystal Reports.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Net requirement level | NettoNiva | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Period forecast | PrognosAntalPeriod | ZtQty | 14 | 2 | decimal
Forecast family | PrognosFamilj | ztString | 4 |  | varchar
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Forecast key | PrognosNyckel | ztString | 25 |  | varchar
Forecast period | PrognosPeriod | ztString | 25 |  | varchar
Forecast version | PrognosVer | ZtLong | 4 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: srpr Forecast, broken down per BOM


Forecast levels (Prni)

Definition of forecast levels for building up item forecasts. A forecast level consists of a specific number of forecast periods and therefore always represents a time period.

If there are several forecast periods, they normally have a relationship with each other which is defined in the field 'Main level', e.g.:
- Three year forecast is a superior level to Year forecast.
- Year forecast is a superior level to Quarterly forecast.
- Quarterly forecast is a superior level to Month forecast, and so on.

It is also here, in the embedded list window 'Forecast periods' (program Prpe), that you define a start date, end date and order for each period within the forecast level.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Number of forecast units | AntalEnheter | ztInteger | 5 |  | smallint
Period forecast | ForcstPeriodFlag | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Main level | HuvudNiva | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Net requirement level | NettoNiva | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Forecast unit | PrognosEnhet | ztInteger | 4 |  | smallint
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Forecast level | PrognosNivaNamn | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Year forecast | YearPrognos | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: Prni Forecast levels

    Program: Prni3 Forecast level, version, item


Forecast object (PrgObjekt)

Definition of occurring market segment that is used when entering market forecasts.

You can enter an unlimited quantity of combinations of sellers, customer categories and geographic segments for which market forecasts are being prepared.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Region | BlockRegion | ztString | 3 |  | varchar
District | DistrKod | ztString | 4 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Valid from date | GiltigFromDatum | ztDate |  |  | datetime
Valid to date | GiltigTomDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Municipality | Kommun | ztString | 5 |  | varchar
Customer category | KundkategoriKod | ztInteger | 2 |  | smallint
County | Laen | ztString | 5 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Forecast object | PrognosObjektBeskr | ztString | 50 |  | varchar
Forecast object | PrognosObjektId | ztString | 20 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar

    This table is the main table in the following programs:

    Program: PrgObjekt Forecast object


Forecast periods (Prpe)

Definition of forecast periods for item forecasts within the relevant forecast level. The definition specifies a start date, end date and order for each period within the forecast level.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
Main level | HuvudNiva | ztInteger | 4 |  | smallint
Main period | HuvudPeriod | ztString | 25 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Sequence no. | PerOrdNr | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Forecast period | PrognosPeriod | ztString | 25 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Valid to date | TomDatum | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: Prpe Forecast periods


Forecast rows (PrgRader)

Table of details in market forecasts.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Autoskapad prognosrad | AutoPrognosRad | ztInteger | 5 |  | smallint
Prev forecast, quantity | ForegPrognosAntal | ZtQty | 14 | 2 | decimal
Prev forecast, amount | ForegPrognosBelopp | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Main level | HuvudNiva | ztInteger | 4 |  | smallint
Main period | HuvudPeriod | ztString | 25 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Keep year forecast | KeepYearValue | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Lowest forecast label | LagstaPrognosNiva | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Forecast, quantity | PrognosAntal | ZtQty | 14 | 2 | decimal
Forecast outcome, quantity | PrognosAntalUtfall | ZtQty | 14 | 2 | decimal
Calculation automation | PrognosAutomatik | ztBoolean |  |  | char
Forecast, amount | PrognosBelopp | ZtBaseCurrAmount | 14 | 2 | money
Forecast outcome, amount | PrognosBeloppUtfall | ZtBaseCurrAmount | 14 | 2 | money
Forecast family | PrognosFamiljId | ztString | 10 |  | varchar
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Forecast no. | PrognosNr | ZtLong | 10 |  | int
Forecast key | PrognosNyckel | ztString | 25 |  | varchar
Forecast object | PrognosObjektId | ztString | 20 |  | varchar
Forecast period | PrognosPeriod | ztString | 25 |  | varchar
Forecast row no | PrognosRadNr | ZtLong | 10 |  | int
Forecast row no (family) | PrognosRadNrStrPos | ZtLong | 10 |  | int
Forecast version | PrognosVer | ZtLong | 4 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PrognosRad Forecast rows, market


Forecast rows, history (PrgRaderH)

Numeric designation of a forecast header.

At new entry, the number is filled in automatically with the next free number if you leave the field blank.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Prev forecast, quantity | ForegPrognosAntal | ZtQty | 14 | 2 | decimal
Prev forecast, amount | ForegPrognosBelopp | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Forecast, quantity | PrognosAntal | ZtQty | 14 | 2 | decimal
Forecast outcome, quantity | PrognosAntalUtfall | ZtQty | 14 | 2 | decimal
Forecast, amount | PrognosBelopp | ZtBaseCurrAmount | 14 | 2 | money
Forecast outcome, amount | PrognosBeloppUtfall | ZtBaseCurrAmount | 14 | 2 | money
Forecast family | PrognosFamiljId | ztString | 10 |  | varchar
Forecast no. | PrognosNr | ZtLong | 10 |  | int
Forecast row no | PrognosRadNr | ZtLong | 10 |  | int
Forecast row no (family) | PrognosRadNrStrPos | ZtLong | 10 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Date/time | StrDateTime | ztString | 28 |  | varchar


Forecast types (ForcstType)

Table that contains the forecast types that may be used in Jeeves.
The forecast type is used when input will be created for running net requirements from the forecast system.

The following standard records exist. Do not alter/delete:

Forecast type (check against) (ForcstType) | Forecast type (check against) (ForcstTypeDescr) | Description
0 | Sales forecast (calculate curr customer order for MRP) | Sales forecast. If the current sales forecast is used as input for the net requirement calculation, the existing customer order will reduce the forecast so that it will be "double" manufacturing.
1 | Manufacturing forecast (calculate curr MO for MRP) | Manufacturing forecast. If the current manufacturing forecast is used as input for the net requirement calculation, the existing manufacturing order will reduce the forecast so that it will be "double" manufacturing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Forecast type (check against) | ForcstType | ztInteger | 5 |  | smallint
Forecast type (check against) | ForcstTypeDescr | ztString | 80 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ForcstType Forecast types


Forecast versions (prve)

Forecast versions according to own definition, e.g. to mirror revisions, division into different markets, for example, and so on.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Forecast type (check against) | ForcstType | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Forecast, master plan block | PrognosHuvudplanSparr | ztBoolean |  |  | char
Forecast version | PrognosNamn | ztString | 60 |  | varchar
Forecast version | PrognosVer | ZtLong | 4 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Prve Forecast versions


Forecast, master plan row (PrgHPlanRad)

Table of main data in master plans.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Main level | HuvudNiva | ztInteger | 4 |  | smallint
Main period | HuvudPeriod | ztString | 25 |  | varchar
Master plan number | HuvudPlanNr | ZtLong | 10 |  | int
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Breakdown date | PrognosNedbrytDatum | ztDateTime |  |  | datetime
ID for breakdown | PrognosNedbrytSign | ztString | 6 |  | varchar
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Forecast no. | PrognosNr | ZtLong | 10 |  | int
Forecast object | PrognosObjektId | ztString | 20 |  | varchar
Forecast period | PrognosPeriod | ztString | 25 |  | varchar
Forecast fulfillment-% | PrognosUppfyllnadProc | ZtDecimal73 | 6 | 2 | decimal
Forecast version | PrognosVer | ZtLong | 4 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Forecast/budget, item (arsx)

Item forecast and budget data by period.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Product class | ArtProdKlass | ztString | 4 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Forecast/budg type | ArtProgBudgTyp | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quarter | Kvartal | ztInteger | 1 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Period invoiced qty | PerFaktAnt | ZtQty | 14 | 2 | decimal
Per försenade inl | PerForsenInLev | ZtQty | 14 | 2 | decimal
Per försenade utlev | PerForsenUtLev | ZtQty | 14 | 2 | decimal
Per avg inventory bal | PerGenomsnittsLager | ztFloat | 15 | 2 | float
Period | Period | ztInteger | 4 |  | smallint
Per closing invtry bal | PeriodLagSaldo | ZtQty | 14 | 2 | decimal
Lager*dagar | PerLagerGgrDagar | ZtQty | 14 | 2 | decimal
Per inventory turnover | PerLagOmsHast | ztFloat | 15 | 2 | float
Per order intake qty | PerOrderIng | ZtQty | 14 | 2 | decimal
Per utg ord.stock ant | PerOrderStock | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Period rcvd deliveries | PerTotInlev | ZtQty | 14 | 2 | decimal
Per closing bal (FIFO) | PerUtgLagVardeFifo | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (cost) | PerUtgLagVardeKalk | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (repl) | PerUtgLagVardeSink | ZtBaseCurrAmount | 14 | 2 | money
Period forecast | PrognosAntalPeriod | ZtQty | 14 | 2 | decimal
Forecast version | PrognosVer | ZtLong | 4 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: Arsx Item forecast/budget


Forecast/budget, item grp, period (vgpx)

Forecast and budget data for item group and period.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Forecast/budg type | ArtProgBudgTyp | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quarter | Kvartal | ztInteger | 1 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Period invoiced qty | PerFaktAnt | ZtQty | 14 | 2 | decimal
Per försenade inl | PerForsenInLev | ZtQty | 14 | 2 | decimal
Per försenade utlev | PerForsenUtLev | ZtQty | 14 | 2 | decimal
Per avg inventory bal | PerGenomsnittsLager | ztFloat | 15 | 2 | float
Period | Period | ztInteger | 4 |  | smallint
Per closing invtry bal | PeriodLagSaldo | ZtQty | 14 | 2 | decimal
Lager*dagar | PerLagerGgrDagar | ZtQty | 14 | 2 | decimal
Per inventory turnover | PerLagOmsHast | ztFloat | 15 | 2 | float
Per order intake qty | PerOrderIng | ZtQty | 14 | 2 | decimal
Per utg ord.stock ant | PerOrderStock | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Period rcvd deliveries | PerTotInlev | ZtQty | 14 | 2 | decimal
Per closing bal (FIFO) | PerUtgLagVardeFifo | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (cost) | PerUtgLagVardeKalk | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (repl) | PerUtgLagVardeSink | ZtBaseCurrAmount | 14 | 2 | money
Period forecast | PrognosAntalPeriod | ZtQty | 14 | 2 | decimal
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar


Forecast/budget, item grp, quarter (vgkx)

Forecast and budget data for item group and quarter.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Forecast/budg type | ArtProgBudgTyp | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quarter | Kvartal | ztInteger | 1 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Period invoiced qty | PerFaktAnt | ZtQty | 14 | 2 | decimal
Per försenade inl | PerForsenInLev | ZtQty | 14 | 2 | decimal
Per försenade utlev | PerForsenUtLev | ZtQty | 14 | 2 | decimal
Per avg inventory bal | PerGenomsnittsLager | ztFloat | 15 | 2 | float
Per closing invtry bal | PeriodLagSaldo | ZtQty | 14 | 2 | decimal
Lager*dagar | PerLagerGgrDagar | ZtQty | 14 | 2 | decimal
Per inventory turnover | PerLagOmsHast | ztFloat | 15 | 2 | float
Per order intake qty | PerOrderIng | ZtQty | 14 | 2 | decimal
Per utg ord.stock ant | PerOrderStock | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Period rcvd deliveries | PerTotInlev | ZtQty | 14 | 2 | decimal
Per closing bal (FIFO) | PerUtgLagVardeFifo | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (cost) | PerUtgLagVardeKalk | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (repl) | PerUtgLagVardeSink | ZtBaseCurrAmount | 14 | 2 | money
Quarterly forecast | PrognosAntalKvartal | ZtQty | 14 | 2 | decimal
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: Vgkx Forecast, item group/quarter


Forecast/net requirement items (Pne)

Contains forecast by article at net requirement level.
This table is used for material requirement planning.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity to manufacture | AntalAttTillverka | ZtQty | 14 | 2 | decimal
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Calc net requirement | BerNettoBehov | ZtQty | 14 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Manual net demand | ManNettoBehov | ZtQty | 14 | 2 | decimal
Reserved quantity | MrResAnt | ZtQty | 14 | 2 | decimal
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Period forecast | PrognosAntalPeriod | ZtQty | 14 | 2 | decimal
Forecast family | PrognosFamilj | ztString | 4 |  | varchar
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Forecast period | PrognosPeriod | ztString | 25 |  | varchar
Forecast version | PrognosVer | ZtLong | 4 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Pne Forecast/net requirements


Forecast/Statistics, item (pars)

Work table to create records for form and list windows in the program that shows forecast and sales for an item (ARSPROG).
There is no storage in this table. It is only used internally in the procedure, which is linked to the aforementioned program.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Qty sold prev yr | FsgAntalFAr | ZtQty | 14 | 2 | decimal
Qty sold YTD | FsgAntalIAr | ZtQty | 14 | 2 | decimal
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Ordered quantity | LagBestAnt | ZtQty | 14 | 2 | decimal
Reserved quantity | LagResAnt | ZtQty | 14 | 2 | decimal
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Period | Period1 | ztString | 20 |  | varchar
Period | Period2 | ztString | 20 |  | varchar
Period forecast | PrognosAntalPeriod | ZtQty | 14 | 2 | decimal
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar


Foreman area (fomr)

Definition of the different foreman areas in your own workshop. The information is used, for example, in workload analyses and planning and can also be used in manufacturing claims.

Jeeves has the following levels for workload analysis:
- Total
- Product area
- Foreman area
- Work group
- Manufacturing group

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Foreman area | FormansOmrade | ztString | 6 |  | varchar
Foreman area | FormansOmradeB | ztString | 50 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Product area | produktOmrade | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | ROwUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: fomr Foreman areas


Forms, eBrev (ebbs)

Forms eBrev.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Form call | ebBlankett | ztString | 4 |  | varchar
Form description | ebBlankettBeskr | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xebbs Forms, eBrev


Forwarder codes for logtrade (LogtradeForwarderCode)

Code for the forwarder. This code in sent to Logtrade when using integration with Logtrade for transport administration.

The following standard records exist. Do not alter/delete:

Logtrade forwarder (LogTradeForwarderCode) | Logtrade forwarder (LogTradeForwarderDescr)
DhlSweden | DHL forwarder
DsvRoadSweden | DSV Road Sweden
OnRoadSweden | OnRoad Sweden
PnlSweden | Pan Nordic Logistics Sweden
PostenSweden | Posten Sweden
SchenkerSweden | Schenker Sweden

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Logtrade forwarder | LogTradeForwarderCode | ztString | 30 |  | varchar
Logtrade forwarder | LogTradeForwarderDescr | ztString | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: LogtradeForwarderCode Forwarder codes for LogTrade


Frames (JvsSiteWinFrames)

Definition of own frames in the form window. By placing fields within a frame you can give them a logical grouping.

The program/table can be accessed through an embedded window in the Setting dimensions/keys program (jvssitenodewin) or from Jeeves' menu.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Frame ID | JvsSiteFrameID | ZtLong | 10 |  | int
Frame ID (orig) | JvsSiteFrameID_orig | ZtLong | 10 |  | int
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Setting ID (orig) | JvsSiteNodeWinSettingsID_orig | ZtLong | 10 |  | int
Tab ID | JvsSiteTabID | ZtLong | 10 |  | int
Tab ID (orig) | JvsSiteTabID_orig | ZtLong | 10 |  | int
TextID | JvsSiteTextID | ztString | 40 |  | varchar
Startpos X axis | JvsSiteXPos | ZtLong | 10 |  | int
Width | JvsSiteXSize | ZtLong | 10 |  | int
Startpos Y axis | JvsSiteYPos | ZtLong | 10 |  | int
Height | JvsSiteYSize | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteWinFrames Frames


Freight bill no series (frst)

Definition of number series per dispatch method and freight bill type used for automatic freight bill numbering.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Bar code, start | BarCodeStart | ztString | 10 |  | varchar
Bar code, start/stop | BarCodeStartStop | ztString | 4 |  | varchar
Bar code, complete | BarCodeStop | ztString | 10 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight number series | FraktNrSerieKod | ztInteger | 2 |  | smallint
Freight series no. type | FraktNrSerieTyp | ztInteger | 2 |  | smallint
Freight bill type | FraktSedelTyp | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Code EAN data element | KodEANDataElement | ztString | 10 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
General/fixed text | TextKod | ztString | 4 |  | varchar

    This table is the main table in the following programs:

    Program: xfrst Freight bill, def. No. series


Freight bill types, Sales (xfrs)

A number of standard freight bill types are entered during installation. you cannot add your own freight bill types.

You link the freight bill types to dispatch methods in the program 'Dispatch methods, sales' (Xx2f). When you enter a customer order, a freight bill type is retrieved according to the definition for the dispatch method in question. You cannot print a different freight bill type for the order.

The following standard records exist. Do not alter/delete:

Freight bill type (FraktSedelTyp) | Freight bill type (FraktSedelTypBeskr)
1 | SIS freight bill/regular goods
2 | SIS freight bill/dangerous goods

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight bill type | FraktSedelTyp | ztInteger | 2 |  | smallint
Freight bill type | FraktSedelTypBeskr | ztString | 50 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Number series types | KodFraktNrSerieTyp | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xxfrs Freight bill types, Sales


Freight bill, fixed texts (xtxt)

Definition of fixed texts that can be used for printing on different freight documents, e.g. freight bills.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
General/fixed text | TextKod | ztString | 4 |  | varchar
General/fixed text | TextKodBeskr | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: xtxt Freight bill, fixed texts


Freight calculation terms, Sales (xfrb)

Definition of terms that can be used in freight matrixes (relevant if automatic freight calculation is applied for dispatch of customer orders).

The following standard records exist. Do not alter/delete:

Freight calc terms (FraktBerVillk) | Freight calc terms (FraktBerVillkBeskr)
1 | Distance
2 | County
3 | District
4 | Region
5 | ZIP/Post code

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight calc terms | FraktBerVillk | ztInteger | 2 |  | smallint
Freight calc terms | FraktBerVillkBeskr | ztString | 50 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xxfrb Freight calculation terms, Sales


Freight doc number series (fnrs)

Definition of number series of freight documents (freight bills and address labels) with start and stop numbers for the number series. You can also see the next available number here.

The number series are linked amongst other things to dispatch method and freight bill type in the Freight bill, def. no. series (xfrst) or Address label, def. No. series (xadlt) program.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Check number method | CheckSifferMetod | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight number series | FraktNrSerieBeskr | ztString | 35 |  | varchar
Freight number series | FraktNrSerieKod | ztInteger | 2 |  | smallint
Next freight series no. | FraktNrSerieNext | ztMoney | 15 |  | money
End freight series no. | FraktNrSerieSlut | ztMoney | 15 |  | money
Begin freight series no. | FraktNrSerieStart | ztMoney | 15 |  | money
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xfnrs Freight doc number series


Freight document number series (xnrs)

Several number series types for freight documents (freight bills/address labels) are set up during installation.

The following standard records exist. Do not alter/delete:

Freight series no. type (FraktNrSerieTyp) | Freight series no. type (FraktNrSerieTypBeskr) | Description
0 | Normal | Normal freight series number type for automatic numbering of freight bills.
1 | 1: Package number | Only refers to ASG - STE Labels. Jeeves automatically generates a unique dispatch number and, within the dispatch, a unique package number. The condition for this to function is described in a separate document on managing ASG - STE Labels.
11 | One-package delivery | Only refers to Forwarder's address labels for domestic packages or goods. Jeeves automatically gets the dispatch number from a special number series for one-package deliveries (provided that you have checked the 'Number series types' box for the address label type, set up a one-package number series and linked the number series to the address label type in question).
12 | Multiple-package delivery | Only refers to Forwarder's address labels for domestic packages or goods. Jeeves automatically gets the dispatch number from a special number series for multiple-package deliveries (provided that you have checked the 'Number series types' box for the address label type, set up a multiple-package number series and linked the number series to the address label type in question).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight series no. type | FraktNrSerieTyp | ztInteger | 2 |  | smallint
Freight series no. type | FraktNrSerieTypBeskr | ztString | 50 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xxnrs Freight document number series


Freight matrix detail (xfrl)

In this embedded list window for the freight matrix, you enter the freight prices to be charged to the customer, as well as various limit values.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Area limit <= | FraktKol1Limit | ztString | 8 |  | varchar
Distance limit | FraktKol2Limit | ZtLong | 6 |  | int
Weight/pallets/volume limit<= | FraktKol3Limit | ztFloat | 7 | 1 | float
Fixed freight cost | FraktKostnad | ZtBaseCurrAmount | 14 | 2 | money
Variable freight cost/kg | FraktKostnadPerKg | ZtBaseCurrAmount | 14 | 2 | money
Freight matrix | FraktMatrisKod | ztInteger | 2 |  | smallint
Bulk goods | FraktStorGods | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Freight matrix header (xfr)

Definition of freight calculation matrix (header).

You make the definition by giving the matrix a name and choosing which type of matrix you want to create. There are also a number of different surcharges and fees, which you can add in addition to freight cost.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Check next interval | FraktCheckNextIntervall | ztBoolean |  |  | char
COD limit 1 | FraktEfterKrav1 | ZtBaseCurrAmount | 14 | 2 | money
COD limit 2 | FraktEfterKrav2 | ZtBaseCurrAmount | 14 | 2 | money
COD limit 3 | FraktEfterKrav3 | ZtBaseCurrAmount | 14 | 2 | money
COD fee 1 | FraktEfterKravAvg1 | ZtBaseCurrAmount | 14 | 2 | money
COD fee 2 | FraktEfterKravAvg2 | ZtBaseCurrAmount | 14 | 2 | money
COD fee 3 | FraktEfterKravAvg3 | ZtBaseCurrAmount | 14 | 2 | money
EU surcharge % | FraktEUTillagg | ztFloat | 5 | 2 | float
Before 12 surchg | FraktForeTolvTillagg | ZtBaseCurrAmount | 14 | 2 | money
Freight bill costs | FraktFsedelKost | ZtBaseCurrAmount | 14 | 2 | money
Spec freight surchg % | FraktGotlTillagg | ztFloat | 5 | 2 | float
Gen freight surchg % | FraktGotlTillaggGen | ztFloat | 5 | 2 | float
Freight matrix | FraktMatrisBeskr | ztString | 30 |  | varchar
Freight matrix | FraktMatrisKod | ztInteger | 2 |  | smallint
Freight matrix type | FraktMatrisTyp | ztInteger | 2 |  | smallint
Fuel surcharge % | FraktOljeTillagg | ztFloat | 5 | 2 | float
Pallet handling chg | FraktPallhantAvgift | ZtBaseCurrAmount | 14 | 2 | money
Pallet chg | FraktPallKostnad | ZtBaseCurrAmount | 14 | 2 | money
Freight discount % | FraktRabatt | ztFloat | 5 | 2 | float
Weight calc factor/kg | FraktViktUpprFaktor | ztInteger | 5 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxfr Freight matrix


Freight matrix types, Sales (xfrm)

Definition of freight matrix types that govern how the freight will be calculation if automatic freight calculation is applied for dispatch of customer orders.

The following standard records exist. Do not alter/delete:

Freight matrix type (FraktMatrisTyp) | Freight matrix type (FraktMatrisTypBeskr) | Description
1 | Weight | Calculates a fixed cost per goods as long as Bulk goods is not flagged, when the cost is calculated per kg instead.
2 | Pallet | Always calculates a fixed cost per pallet.
3 | Package/Fi | Always calculates a fixed cost per weight, i.e. as alternative 1 but without the bulk goods handling.
4 | Pkg/Variab | Calculates a variable cost per kg as well as a fixed cost.
5 | Volume | Calculates a fixed cost based on volume.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight matrix type | FraktMatrisTyp | ztInteger | 2 |  | smallint
Freight matrix type | FraktMatrisTypBeskr | ztString | 50 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xxfrm Freight matrix types, Sales


Freight payer (view) (vkuf)

View of the customer table (kus).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Direct debit BG/acct no | AutoGiroBetKtoNr | ztString | 20 |  | varchar
Payment terms | BetKod | ztString | 2 |  | varchar
District | DistrKod | ztString | 4 |  | varchar
Text | edit | ztBlob | 1 |  | varchar
Handling charge | expavgkd | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Delivery note Y/N | fskd | ztBoolean |  |  | char
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Reminder code | kravkd | ztBoolean |  |  | char
Reminders blocked | KravSparr | ztBoolean |  |  | char
Block reminders until | KravSparrTomDat | ztDate |  |  | datetime
Credit block | kreditsparr | ztBoolean |  |  | char
Credit block type | KreditSparrTyp | ztInteger | 2 |  | smallint
Payer, company ID | kundbetalarenr | ztCompanyNo | 20 |  | varchar
Customer category | kundkategorikod | ztInteger | 2 |  | smallint
Average days credit | kundkreddag | ztInteger | 3 |  | smallint
Credit limit | kundkredlim | ZtBaseCurrAmount | 14 | 2 | money
Turnover YTD | kundoms | ZtBaseCurrAmount | 14 | 2 | money
Turnover previous year | kundomsfa | ZtBaseCurrAmount | 14 | 2 | money
AR ledger balance | kundsaldo | ZtBaseCurrAmount | 14 | 2 | money
Unused credit | KusKvarPaKredit | ZtBaseCurrAmount | 14 | 2 | decimal
Country | LandsKod | ztString | 3 |  | varchar
Ship documents | levhandlkod | ztBoolean |  |  | char
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Date/time canceled | MakdateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Order date | OrdDatum | ztDate |  |  | datetime
Order value | ordsum | ZtBaseCurrAmount | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Cust discount class | RabKlass | ztInteger | 3 |  | smallint
Interest amt calc to date | rtasaldobertomdat | ztDate |  |  | datetime
Pmt rmdr/intrst invc rule | RteFaktAvtal | ztInteger | 2 |  | smallint
Interest invoice | RteFaktKd | ztBoolean |  |  | char
Salesperson | Saljare | ztString | 6 |  | varchar
Collective invoicing | SamFaktUtskr | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar

    This table is the main table in the following programs:

    Program: vkuf View customers (freight payers)


Frequency (WMS_Frequence)

Definition of frequencies and their relative order. Frequencies are used to direct SKUs, in location-based MHAs, to the desired locations depending on the frequency of the item definition and location. It is the value in the Sequence field, not the value in the Frequency field, that controls what the highest or lowest frequency is.

A typical setup could be:
Frequency	Sequence	Comment
A		1		Most frequent
B		2
C		3		Least frequent

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Frequency | Frequence | ztString | 1 |  | varchar
Description | FrequenceDesc | ztString | 50 |  | varchar
Sequence | FrequenceSeq | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_Frequence Frequency


FTP profile (ftp)

Table for definition of FTP profile.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
File/dir | DokDir | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
FTP file | FTPfil | ztString | 100 |  | varchar
FTP user ID | FTPlogin | ztString | 40 |  | varchar
FTP profile | FTPprofil | ztInteger | 5 |  | smallint
Description, FTP profile | FTPProfilBeskr | ztString | 60 |  | varchar
FTP server | FTPserver | ztString | 50 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Password | passord | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xftp FTP settings


Full pallet pick, task (WMS_V_MU_FullPallPickLine)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
X pos, from | AssFromLocXPos | ztString | 5 |  | varchar
Y pos, from | AssFromLocYPos | ztString | 5 |  | varchar
MHA, from | AssFromMha | ztString | 5 |  | varchar
Rack, from | AssFromRack | ztString | 5 |  | varchar
ID | AssId | ZtLong | 9 |  | int
Batch no. | BatchId | ztString | 30 |  | varchar
Check digits | CheckSum | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Location search no. | LocSortKey | ZtLong | 10 |  | int
Sequence | MhaPickQueueSeq | ztInteger | 3 |  | smallint
Mobile unit | MobileUnit | ztString | 5 |  | varchar
Remaining qty, SKU | RemainingQty | ZtQty | 14 | 2 | decimal
SKU ID | SKUPalletId | ztString | 35 |  | varchar
Qty, SKU | SKUQty | ZtQty | 14 | 2 | decimal
ID | TaskIId | ZtLong | 9 |  | int
TU ID | TUPalletId | ztString | 35 |  | varchar
Unit code | UOM | ztString | 10 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_MU_FullPallPickLine Full pallet pick, task


Full pallet picking queue (WMS_V_FullPallPickQueue)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Assignments | Assignments | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Queue | Queue | ztString | 5 |  | varchar
Description | QueueDesc | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


General item texts (gatx)

Table of general item texts to print on various documents in the system, such as purchase orders, etc.
This can concern information to the supplier about inspections, etc.
(This has been developed for Sunds defribrator. They print the texts from Crystal Reports)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text on PO | ArtSpecTextBe | ztBoolean |  |  | char
General item text | ArtTextKod | ztString | 4 |  | varchar
General item text | ArtTextKodBeskr | ztString | 50 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Default text | KodDefaultText | ztBoolean |  |  | char
Copyable text | KodFastText | ztBoolean |  |  | char
Choice at copy | KodValCopyText | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: gatx General item texts


General texts (xgtx)

Table where general texts are entered. Irrespective of the customer, these will be entered into all flagged documents during the given period.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Opening text | KodFirstText | ztBoolean |  |  | char
Text on invoice | KundSpecTextFa | ztBoolean |  |  | char
Text on invoice exp | KundSpecTextFaExp | ztBoolean |  |  | char
Text on invoice time | KundSpecTextFaTid | ztBoolean |  |  | char
Text on delivery note | KundSpecTextFs | ztBoolean |  |  | char
Text on order acknowledgement | KundSpecTextOe | ztBoolean |  |  | char
Text on quotation | KundSpecTextOff | ztBoolean |  |  | char
Text on picking list | KundSpecTextPl | ztBoolean |  |  | char
Text on mfg/works order | KundSpecTextTo | ztBoolean |  |  | char
Text on PO | LevSpecTextBe | ztBoolean |  |  | char
Text on purchase agreement | LevSpecTextInkAvt | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Receipt text (end) | SpecTextKvitto | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Text after document rows | TextEfterDokRader | ztBoolean |  |  | char
General/fixed text | TextKod | ztString | 4 |  | varchar
General/fixed text | TextKodBeskr | ztString | 30 |  | varchar
Valid to date | TomDatum | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: xgtx General texts


General texts within order (tatx)

Table of general item texts for manufacturing orders to print on various documents in the system, such as purchase orders, etc.
This can concern information to the supplier about inspections, etc.
((Pressure vessel standards, surface treatment requirements)).
(This has been developed for Sunds defribrator. They print the texts from Crystal Reports)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Text on PO | ArtSpecTextBe | ztBoolean |  |  | char
General item text | ArtTextKod | ztString | 4 |  | varchar
General item text | ArtTextKodBeskr | ztString | 50 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Default text | KodDefaultText | ztBoolean |  |  | char
Copyable text | KodFastText | ztBoolean |  |  | char
Choice at copy | KodValCopyText | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


GL account balances (tko)

Balance records by account in the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Tax base amount | MomsGrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
Period | Period | ztInteger | 4 |  | smallint
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: Xtko Show period balance, account


GL account balances (tko_query)

Balance records by account in the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Year opening balance | AretsIngBalans | ZtBaseCurrAmount | 14 | 2 | money
Year OB deb | AretsIngBalansDeb | ZtBaseCurrAmount | 14 | 2 | money
Year OB cre | AretsIngBalansKre | ZtBaseCurrAmount | 14 | 2 | money
Year OB curr | AretsIngBalansValuta | ztMoney | 14 | 2 | money
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Tax base amount | MomsGrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
Period | Period | ztInteger | 4 |  | smallint
Period ing saldo | PeriodensIngBalans | ZtBaseCurrAmount | 14 | 2 | money
Period opening bal deb | PeriodensIngBalansDeb | ZtBaseCurrAmount | 14 | 2 | money
Period opening bal cre | PeriodensIngBalansKre | ZtBaseCurrAmount | 14 | 2 | money
Period OB curr | PeriodensIngBalansValuta | ztMoney | 14 | 2 | money
Periodens nettobelopp | PeriodensNetto | ZtBaseCurrAmount | 14 | 2 | money
Period net amount curr | PeriodensNettoValuta | ztMoney | 14 | 2 | money
Closing balance | PeriodensUtgSaldo | ZtBaseCurrAmount | 14 | 2 | money
Closing balance deb | PeriodensUtgSaldoDeb | ZtBaseCurrAmount | 14 | 2 | money
Closing balance cre | PeriodensUtgSaldoKre | ZtBaseCurrAmount | 14 | 2 | money
Closing balance curr | PeriodensUtgSaldoValuta | ztMoney | 14 | 2 | money
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: tko_Query Query period balance, account


GL accounts, PO (beko)

Definition of the general ledger accounts you can specify on purchase order rows when pre-posting the received delivery. This is mainly applied for items with the ‘Consumables’ inventory stock type.

Corresponding definitions can also be made to specify account segments 2 to 4.

Control parameter PURCH008 determines whether you can post purchase order rows manually or not.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
As of date | DatKtoFom | ztDate |  |  | datetime
End date | DatKtoTom | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Account | KtoBeskr | ztString | 80 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
This field is used in the table as follows: |
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: beko GL accounts on purchase orders


GL segment balances (tkt)

Balance records by account in the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Budgeted amount | BudgBelopp | ZtBaseCurrAmount | 14 | 2 | money
Budgeted quantity | BudgKvantitet | ztFloat | 15 | 2 | float
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Deb amt not consolidated | DebBelEjKoncSam | ZtBaseCurrAmount | 14 | 2 | money
Amount to auto post | EjAutKontBel | ZtBaseCurrAmount | 14 | 2 | money
Quantity to auto post | EjAutKontKvant | ztFloat | 15 | 2 | float
Curr.amt to auto post | EjAutKontVbBelopp | ztMoney | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Jnr konc.sammanst | JournNrKoncSam | ZtLong | 5 |  | int
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Cred amt not consolidated | KreBelEjKoncSam | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Koncern ej överfört kvant | KvantitetEjKoncSam | ztFloat | 15 | 2 | float
Tax base amount | MomsGrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
Period | Period | ztInteger | 4 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: Xtkt Show period balance, account and account seg


GL segment balances (tkt_query)

Balance records by account in the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Year opening balance | AretsIngBalans | ZtBaseCurrAmount | 14 | 2 | money
Year OB deb | AretsIngBalansDeb | ZtBaseCurrAmount | 14 | 2 | money
Year OB cre | AretsIngBalansKre | ZtBaseCurrAmount | 14 | 2 | money
Year OB curr | AretsIngBalansValuta | ztMoney | 14 | 2 | money
Budgeted amount | BudgBelopp | ZtBaseCurrAmount | 14 | 2 | money
Budgeted quantity | BudgKvantitet | ztFloat | 15 | 2 | float
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Deb amt not consolidated | DebBelEjKoncSam | ZtBaseCurrAmount | 14 | 2 | money
Amount to auto post | EjAutKontBel | ZtBaseCurrAmount | 14 | 2 | money
Quantity to auto post | EjAutKontKvant | ztFloat | 15 | 2 | float
Curr.amt to auto post | EjAutKontVbBelopp | ztMoney | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Jnr konc.sammanst | JournNrKoncSam | ZtLong | 5 |  | int
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Cred amt not consolidated | KreBelEjKoncSam | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Koncern ej överfört kvant | KvantitetEjKoncSam | ztFloat | 15 | 2 | float
Tax base amount | MomsGrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
Period | Period | ztInteger | 4 |  | smallint
Period ing saldo | PeriodensIngBalans | ZtBaseCurrAmount | 14 | 2 | money
Period opening bal deb | PeriodensIngBalansDeb | ZtBaseCurrAmount | 14 | 2 | money
Period opening bal cre | PeriodensIngBalansKre | ZtBaseCurrAmount | 14 | 2 | money
Period OB curr | PeriodensIngBalansValuta | ztMoney | 14 | 2 | money
Periodens nettobelopp | PeriodensNetto | ZtBaseCurrAmount | 14 | 2 | money
Period net amount curr | PeriodensNettoValuta | ztMoney | 14 | 2 | money
Closing balance | PeriodensUtgSaldo | ZtBaseCurrAmount | 14 | 2 | money
Closing balance deb | PeriodensUtgSaldoDeb | ZtBaseCurrAmount | 14 | 2 | money
Closing balance cre | PeriodensUtgSaldoKre | ZtBaseCurrAmount | 14 | 2 | money
Closing balance curr | PeriodensUtgSaldoValuta | ztMoney | 14 | 2 | money
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: tkt_query Query period balance, account and account seg


Global settings (ygb)

General settings that apply for all programs, e.g. setting fonts and color in a form, settings in the Jeeves menu bar etc., that are made using the option 'Tools/Settings...'

Choose from personal/global: Yes
Per company: No

(This table replaces table Vygb.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Global settings | Global | ztString | 1 |  | char
Group | Grupp | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | nvarchar
Settings | Props | ztBlob | 1 |  | text
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ygb Global settings


Goods type specification (GoodsType)

Definition of types of goods used, for example, in the transport administration system (TA) to give a short description of the contents of packages.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Goods type | GoodsTypeDesc | ztString | 50 |  | varchar
Goods type ID | GoodsTypeid | ztInteger | 5 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: GoodsType Goods type specification


Group members, company (JvsSiteCompanyGroupMembers)

Definition of members within groups of companies to which settings can be linked. In other words, this is used only in multi-company databases. In this table, information is stored about company group members. Information about company groups is stored in the overlying table Company groups (jvssitecompanygroups).

Requires Net Kernel Version 2.0 or higher.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company code | ForetagKodAll | ztInteger | 5 |  | smallint
Company group No. | JvsSiteCmpGroup | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Group members, user (JvsSiteGroupMembers)

Definition of members of user groups to which settings can be linked. In this table, information is stored about group members. Information about groups is stored in the overlying table User groups (jvssitegroups).

Requires Net Kernel Version 2.0 or higher.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allow settings | JvsSiteAllowChange | ztBoolean |  |  | char
Allow settings/subgroups | JvsSiteAllowChangeSubGroups | ztBoolean |  |  | char
Group ID | JvsSiteGroupId | ZtLong | 6 |  | int
Group name (lang) | JvsSiteGroupName_Lang | ZtLong | 6 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Group procedures (lekl)

Definition of the group types (criteria) which are applied when evaluating suppliers.

There are some default group types. NOTE. Only the weighting in these group types may be changed.

Other group types are user-defined.

The following standard records exist. Do not alter/delete:

Group type (Klasstyp) | Description (Beskrivning) | Description
1 | 1 - Delivery assurance | Automatic assessment of delivery assurance. The procedure given in this 'JEEVES_cre_le_bed' group type calculates the delivery dependability based on two factors: 1) number of orders and 2) number of incorrect deliveries with regard to quantity and delivery date.
2 | 2 - Supplier evaluation | Manual supplier evaluation.
3 | 3 - Purchase evaluation | Manual purchase evaluation.
999 | Total supplier evaluation | This group type gives a total of all evaluations per customer.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Group type | Klasstyp | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Procedure | StoredProcedure | ztString | 120 |  | varchar
Weight | Viktning | ztFloat | 6 | 2 | float

    This table is the main table in the following programs:

    Program: lekl Suppl eval, group procedure


Group schedule, shop reporting (vegc)

If several people work with the same time schedule, you can use a group schedule for shop reporting. In this table, you enter the group schedule with information on to which weekly schedule or week it is to be linked.

Use the program "Shop floor personnel" (prv) to tie shop floor personnel to a schedule.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Group schedule | VeGruppSchema | ztInteger | 5 |  | smallint
Group schedule | VeGruppSchemaBeskr | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: vegc Group schedule, shop reporting


Group schedule, shop reporting, weeks (vegd)

Table for specifying by week which weekly schedule is to be used.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Week number | KalenderVecka | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Group schedule | VeGruppSchema | ztInteger | 5 |  | smallint
Week schedule | VeVeckoSchema | ztInteger | 5 |  | smallint


Group types (JvsSiteGroupType)

Type of group according the following standard:

10 = Grouping (own groupings are N0T recommended if using pre-defined packages)
20 = Setting
30 = Role
40 = Tab
50 = Package

Note that group 0, Personal and group 9999, All users should not have a type defined, i.e. this field should be left blank.

The purpose of the group type is to label groups, in order to make it easier for companies that choose to work with different types of groups. If you do not wish to do so, leave the field blank on all groups.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Group type | JvsSiteGroupType | ztInteger | 5 |  | int
Group type | JvsSiteGroupTypeDescr | ztString | 255 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteGroupType Group types


Group value/supplier (lekf)

The value of each group type by supplier for supplier evaluation is entered or updated here. The value of group types for which a procedure has been specified in the program 'Supplier eval, group procedure' (lekl) is updated automatically by Jeeves.

The sum of all values of all group types per supplier is set for group type 999 which forms the basis for the total supplier evaluation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Group type | KlassTyp | ztInteger | 3 |  | smallint
Quality group | KvalitetsKlass | ztString | 20 |  | varchar
Revision date | RevDatum | ztDateTime |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Value | TypVarde | ztFloat | 7 | 2 | float
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: lekf Group value/supplier


GroupBox Fields, Frame fields (JvsSiteFrameFields)

Unique ID number for the frame. If the number is 0 it means that there is no frame.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Column ID | JvsSiteColId | ZtLong | 10 |  | int
Term | JvsSiteColumnName | ztString | 40 |  | nvarchar
Frame ID | JvsSiteFrameId | ZtLong | 10 |  | int
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Table | JvsSiteTableName | ztString | 40 |  | nvarchar
Field ID | JvsSiteWindowFieldID | ZtLong | 11 |  | int
Startpos X axis | JvsSiteXPos | ZtLong | 10 |  | int
Width | JvsSiteXSize | ZtLong | 10 |  | int
Startpos Y axis | JvsSiteYPos | ZtLong | 10 |  | int
Height | JvsSiteYSize | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


GroupBox, Frame (JvsSiteFrame)

Unique ID number for the frame. If the number is 0 it means that there is no frame.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Frame ID | JvsSiteFrameId | ZtLong | 10 |  | int
Frame ID (orig) | JvsSiteFrameId_orig | ZtLong | 10 |  | int
TextID | JvsSiteTextId | ztString | 40 |  | nvarchar
ID on window setting | JvsSiteWindowSettingsID | ZtLong | 10 |  | int
ID on window setting (orig) | JvsSiteWindowSettingsID_orig | ZtLong | 10 |  | int
Width | JvsSiteXSize | ZtLong | 10 |  | int
Height | JvsSiteYSize | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Grouping of groups (JvsSiteGroupMapping)

Numeric ID of group (role, user group, setting group etc.) to which settings can be connected.

Note that the following group numbers have a special, built in meaning:
- Group 0 refers to personal settings
- Group 9999 refers to global settings for all users

Besides these, groups can be created and numbered according to your own needs.

This number works as a primary key to identify the group in a specific site database. In order to be able to export and import packages of groups between different environments, this number is re-generated on records to be imported that have an id that is already in use.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Group ID | JvsSiteGroupId | ZtLong | 6 |  | int
Group name (lang) | jvssitegroupname_lang | ZtLong | 6 |  | int
Group name (lang) | jvssitegroupname_lang1 | ZtLong | 6 |  | int
Group type | JvsSiteGroupType | ztInteger | 5 |  | int
Unique package ID | JvsSitePackageUniqueId | ztInteger | 5 |  | int
Package name | JvsSitePackageUniqueId_Lang | ztInteger | 5 |  | int
Parent group type | JvsSiteParentGroupType | ztInteger | 5 |  | int
Parent group | JvsSiteParentId | ZtLong | 6 |  | int
Priority | JvsSitePriority | ztInteger | 4 |  | smallint
This field is used in the table as follows: |
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Groups (JvsSiteGroups)

Definition of groups that represent packages, groupings, groups of roles, roles, tabs and settings, also where applicable, any group member users. For further information, see the program help for the User groups and Grouping of groups programs.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allow settings | JvsSiteAllowChange | ztBoolean |  |  | char
Group description | JvsSiteGroupDescr | ztString | 40 |  | nvarchar
Group description | JvsSiteGroupDescr_Lang | ztString | 40 |  | nvarchar
Group ID | JvsSiteGroupId | ZtLong | 6 |  | int
Group ID (orig) | JvsSiteGroupId_orig | ZtLong | 6 |  | int
Group name | JvsSiteGroupName | ztString | 128 |  | nvarchar
Group name (lang) | JvsSiteGroupName_Lang | ztString | 128 |  | nvarchar
Group type | JvsSiteGroupType | ztInteger | 5 |  | int
Unique package ID | JvsSitePackageUniqueId | ztString | 40 |  | nvarchar
Package name | JvsSitePackageUniqueId_Lang | ztString | 40 |  | nvarchar
Priority | JvsSitePriority | ztInteger | 4 |  | smallint
Unique ID | JvsSiteUniqueId | ztString | 40 |  | nvarchar
No of rows on next level | NoOfGroupsOnNextLevel | ztInteger | 5 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteGroupMappingP Connect groups

    Program: JvsSiteGroups Groups


Handling charges (xore)

Definition of intervals for order amounts in base currency for automatic charging of handling charges in base currency on customer orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Handling charge | ExpAvgiftKronor | ZtBaseCurrAmount | 14 | 2 | money
Order amount, BCU<= | ExpVardeLimit | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xxore Handling charges


Handling charges curr (xorv)

Definition of intervals for order amounts in currency for automatic charging of handling charges in currency on customer orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Handling charge curr | ExpAvgiftValuta | ztMoney | 14 | 2 | money
Order amount curr <= | ExpVardeLimitVal | ztMoney | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar

    This table is the main table in the following programs:

    Program: xxorv Handling charges curr, order


Help table, amendment of inv. orders (worp)

Order numbers in numeric format. There is also a field for alphanumeric order numbers.

When defining the company's order types, it is possible to set different number series for each order type. The orders whose order types do not have order number series, receive their order numbers from the highest number series.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no., change | FaktNrKorr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
At cost | KalkylPrisFaktura | ztString | 1 |  | varchar
Credit order | KreditOrder | ztBoolean |  |  | char
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Order row qty, alt unit | OrdAntalAltEnh | ZtQty | 14 | 2 | decimal
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order No., change | OrderNrKorr | Jeeves_SONo | 8 |  | bigint
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Order row no., new | OrdRadNrNew | ztInteger | 4 |  | smallint
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Ord.row no for package, original | OrdRadNrStrPosNew | ztInteger | 4 |  | smallint
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Order type, amendment order | OrdTypFaktKorr | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Pricing type | PrisHantTyp | ztInteger | 3 |  | smallint
Price adjustment | PrisJustOrder | ztBoolean |  |  | char
CSG on price adjustment | PrisJustOrderKost | ztBoolean |  |  | char
Pricing method | PrisTypP | ztInteger | 3 |  | smallint
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Orig order qty | UrsprOrderAntal | ZtQty | 14 | 2 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Invoice 0-price | Varuprov | ztString | 1 |  | varchar
Price, curr | vb_Pris | ZtSalesPrice | 12 | 2 | money
Volume disc % | VolymRabatt | ZtDecimal73 | 10 | 2 | decimal
Row type | WOrpTyp | ztInteger | 1 |  | smallint


Help table, amendment of inv. orders (orpc)

Internal help table which is used for changing invoice row order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Help table, man. registration template (morp)

Internal help table for detail items when using entry templates.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Price 0 applies | KodNollPris | ztBoolean |  |  | char
No customer disc | KundEjRabKod | ztBoolean |  |  | char
Discount fr matrix, add | MatrisRabAddkod | ztBoolean |  |  | char
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Gross margin | Proc1 | ztFloat | 6 | 2 | float
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Active disc matrix | RabattAktivKod | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Price, curr | vb_Pris | ZtSalesPrice | 12 | 2 | money
Volume disc %, add | VolymRabAddKod | ztBoolean |  |  | char


Hidden programs/reports (ypgm)

Program/table for viewing and editing settings regarding hidden programs. This applies to program hidden in Jeeves program menu and report menus.

This program/table can be accessed through an embedded window in the program Setting dimensions/keys (jvssitenodewin) or from Jeeves' menu.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Group | Grupp | ztInteger | 4 |  | int
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Program | Pgm | ztString | 40 |  | nvarchar
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Show hidden program | VisaDoltProgram | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: ypgm Hidden programs/reports


Hidden window contexts (JvsSiteWindowPropertys)

Program/table for viewing and editing settings regarding hidden window contexts, i.e. all instances of a window shared by several programs. These can only be hidden using Jeeves Implementation Wizard.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Setting ID (orig) | JvsSiteNodeWinSettingsID_orig | ZtLong | 10 |  | int
Data | JvsSitePropertyData | ztString | 7500 |  | nvarchar
Type | JvsSitePropertyName | ztString | 64 |  | nvarchar
Window context | JvsSiteWindowName | ztString | 40 |  | nvarchar
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteWindowPropertys Hidden window contexts


Historically weighted forecast (phf)

Definition of weighting rules used for forecast calculation from history.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Percentage | Procent | ZtDecimal73 | 7 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Weighting factor | ViktningsFaktor | ztFloat | 6 | 2 | float
Weighting rule | ViktningsRegel | ztString | 4 |  | varchar
Weighting rule | ViktningsRegelBeskr | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: phf Historically weighted forecast


History log employee - work group (SFR_wgrpsfplog)

Holds historical changes in connection employee - work group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Work group | arbetslag | ztString | 6 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | perssign2 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Clock In | SFRWorkGrpInDat | ztDateTime |  |  | datetime
Clock Out | SFRWorkgrpOutDat | ztDateTime |  |  | datetime
Identity | SQLIdentity | ZtLong | 10 |  | int
Indirect job/labour | veovrigtjobb | ztInteger | 5 |  | smallint


History, fixed assets transactions (intt)

Table containing history of fixed asset transactions.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Acc depreciation | AckDeprAmt | ZtBaseCurrAmount | 14 | 2 | money
Quantity | Antal | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Transaction date | EventDat | ztDate |  |  | datetime
FA sequence no | FA_sequence | ZtLong | 10 |  | int
Entry layer | FA_TransLayer | ztInteger | 1 |  | smallint
Ent.journal inv alphaID | FA_TrJourAlfa | ztString | 30 |  | varchar
FA journal type ID | FAjTId | ztInteger | 4 |  | smallint
FA Journal number | FAjTNo | ZtLong | 9 |  | int
Manual posting OK | FarKonterasManuellt | ztBoolean |  |  | char
Placement to | FAssetLocAftMov | ztString | 10 |  | varchar
Placement from | FAssetLocBefMov | ztString | 10 |  | varchar
New owner | FAssetOwnAftMov | ztInteger | 4 |  | smallint
Previous owner | FAssetOwnBefMov | ztInteger | 4 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price | ForsaljningsBelopp | ZtBaseCurrAmount | 14 | 2 | money
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Purch price curr | InValuta | ztString | 3 |  | varchar
Fixed asset no | Inventarie | ZtLong | 10 |  | int
Component fixed asset | InventariePos | ztInteger | 5 |  | smallint
Fixed asset status | InventarieStatus | ztInteger | 3 |  | smallint
Fixed asset trans amount | InventarieTransBelopp | ZtBaseCurrAmount | 14 | 2 | money
Fixed asset journal | InvJournNr | ZtLong | 6 |  | int
Transaction type | InvTransTyp | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | k5 | ztString | 8 |  | varchar
S6 | k6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
S8 | k8 | ztString | 8 |  | varchar
To be posted | Konteras | ztBoolean |  |  | char
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Manuall added FA | ManAddFA | ztBoolean |  |  | char
Print date | p_utskr_dat | ztDate |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Place | Placering | ztString | 40 |  | varchar
Fiscal year | ProdDFiscalYear | ztInteger | 4 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Transfer date | VtVrUpDat | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: Intt Fixed assets transactions


Hrp-rows per month (VTidrAttSum)

Calendar year.
This is entered with four digits.
Example: 1996, 1997

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Worked hrs/day | arbtimperdag | ZtDecimal73 | 8 | 2 | decimal
Reported end date | eventrpenddat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Calendar year | kalenderar | ztInteger | 4 |  | smallint
Date | kalenderdatum | ztDate |  |  | datetime
Kalendermånad | kalendermanad | ztInteger | 2 |  | smallint
Calendar number | kalendernr | ztInteger | 2 |  | smallint
Time accrued | nedlagdtid | ztHourWithDecimals | 8 | 2 | decimal
Period | period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | redovisnar | ztInteger | 4 |  | smallint
Time report no. | tidrapportnr | ZtLong | 10 |  | int
Day of week | veckodag | ztInteger | 1 |  | smallint
Day of week | veckodagbeskr | ztString | 50 |  | varchar
Week no | veckonr | ztInteger | 6 |  | smallint


Hrp-rows per week (TimeReportingPerWeek_view)

For planned activities, the number of hours the activity is planned to take. For reported activities specifies a/the number of hours reported on the activity.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Worked hrs/day | arbtimperdag | ZtDecimal73 | 8 | 2 | decimal
Planned activity descr | EventNote | ztString | 60 |  | nvarchar
Reported end date | eventrpenddat | ztDate |  |  | datetime
Hours | EventTimAnt2 | ztHourWithDecimals | 8 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Calendar year | kalenderar | ztInteger | 4 |  | smallint
Date | kalenderdatum | ztDate |  |  | datetime
Kalendermånad | kalendermanad | ztInteger | 2 |  | smallint
Calendar number | kalendernr | ztInteger | 2 |  | int
Time accrued | nedlagdtid | ztHourWithDecimals | 8 | 2 | decimal
Period | period | ztInteger | 4 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | nvarchar
Fiscal year | redovisnar | ztInteger | 4 |  | smallint
Serv.order no | ServOrderNr | Jeeves_SONo | 9 |  | bigint
Time report no. | tidrapportnr | ZtLong | 10 |  | int
Day of week | veckodag | ztInteger | 1 |  | smallint
Day of week | veckodagbeskr | ztString | 50 |  | varchar
Week no | veckonr | ztInteger | 6 |  | smallint


Import accounts and SRU codes (importko)

Import table for accounts. The account data can also be modified here. When you are satisfied with the import data it can be installed to the accounts table (ko). Installing imported accounts is done in the Charts of accounts (ko) program.

Note that this table is not company-specific, which means that the same data can be edited from all companies in the database.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Version | accountversion | ztString | 50 |  | varchar
Fixed assets group | AnlGrp | ztString | 10 |  | varchar
Posting template | autoregel | ztString | 4 |  | varchar
Posting templ GL reval | AutoRegelGL | ztString | 4 |  | varchar
Avräkningskonto | AvrKtoKod | ztBoolean |  |  | char
As of date | DatKtoFom | ztDate |  |  | datetime
End date | DatKtoTom | ztDate |  |  | datetime
Debit/credit | debkre | ztchar | 1 |  | char
Detailed posting | DetaljKonto | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
Customer's own account class | EgenKontoKlass | ztString | 8 |  | varchar
Customer's own account class 2 | EgenKontoKlass2 | ztString | 8 |  | varchar
Replaced by account no. | ErsattsKtoNr | ztString | 8 |  | varchar
Budgeting allowed | FarBudgeterasPa | ztBoolean |  |  | char
Manual posting OK | FarKonterasManuellt | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
GL revaluation | GLCurrReval | ztBoolean |  |  | char
Input/output VAT/tax | IOVAT | ztBoolean |  |  | char
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
Kontrollgrupp K8 | k8grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Account | KtoBeskr | ztString | 80 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Account type | KtoTyp | ztInteger | 3 |  | smallint
Entry inventory, Proj | lager1 | ztInteger | 1 |  | smallint
Entry inventory, Quant | Lager2 | ztInteger | 1 |  | smallint
Entry inventory, CU | Lager3 | ztInteger | 1 |  | smallint
Entry inventory, S4 | Lager4 | ztInteger | 1 |  | smallint
Entry inventory, S5 | Lager5 | ztInteger | 5 |  | smallint
Entry inventory, S6 | Lager6 | ztInteger | 5 |  | smallint
Entry inventory, S7 | Lager7 | ztInteger | 5 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Contra acct, deduction, tax | MotKtoNrAvrMoms | ztString | 8 |  | varchar
Balance per currency | MultiCurrencyAccount | ztBoolean |  |  | char
Mandatory, CC | oblig0 | ztBoolean |  |  | char
Mandatory, Proj | oblig1 | ztBoolean |  |  | char
Mandatory, Quant | oblig2 | ztBoolean |  |  | char
Obligatory, CU | oblig3 | ztBoolean |  |  | char
Mandatory, S4 | oblig4 | ztBoolean |  |  | char
Mandatory, S5 | oblig5 | ztBoolean |  |  | char
Mandatory, S6 | oblig6 | ztBoolean |  |  | char
Mandatory, S7 | oblig7 | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Control group project | PrjGrupp | ztString | 6 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Posting rule S2 | regel1 | ztInteger | 1 |  | smallint
Proj posting rule | regel2 | ztInteger | 1 |  | smallint
Qty posting rule | regel3 | ztInteger | 1 |  | smallint
S3 posting rule | regel4 | ztInteger | 1 |  | smallint
S4 posting rule | regel5 | ztInteger | 1 |  | smallint
S5 posting rule | regel6 | ztInteger | 1 |  | smallint
S6 posting rule | regel7 | ztInteger | 1 |  | smallint
S7 posting rule | regel8 | ztInteger | 1 |  | smallint
Entry inventory, CC | RegLager | ztInteger | 2 |  | smallint
Replaced by | ReplaceByAccNo | ztString | 8 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Used split cost | splitcostbasis | ztBoolean |  |  | char
SRU 1 | Sru1Nr | ztString | 6 |  | varchar
SRU 2 | Sru2Nr | ztString | 6 |  | varchar
Text | TextLayer | ztInteger | 1 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Pay or receive | VAT_PayedOrReceive | ztBoolean |  |  | char
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax account | VATaccount | ztBoolean |  |  | char
VAT/tax code mandatory | VATmandatory | ztBoolean |  |  | char
Display on web | WebAccountMark | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: Importko Import accounts and SRU codes


Imported accounts - replace accounts (Import_Ko_replace_ktonr)

This table is used when importing a new chart of accounts. The table and its subtable (import_ko_replcase_ktonr_detail) stores information about which account numbers that should be replaced when installing chart of accounts.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Replaced by account no. | ErsattsKtoNr | ztString | 8 |  | varchar
Account | ktonr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Import_Ko_replace_ktonr Imported accounts - replace accounts


Imported accounts - replace accounts, details (Import_Ko_replace_ktonr_detail)

This table is used when importing a new chart of accounts. The table and its mastertable (import_ko_replcase_ktonr) stores information about which account numbers that should be replaced when installing chart of accounts.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Replaced by account no. | ErsattsKtoNr | ztString | 8 |  | varchar
Company | FtgReplaceKtoNr | ztInteger | 4 |  | smallint
Account | ktonr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Type | ReplaceAccountType | ztInteger | 5 |  | smallint
Type Descr | ReplaceAccountTypeDescr | ztInteger | 5 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Base/value table | ztable | ztString | 255 |  | varchar
Field | zterm | ztString | 255 |  | varchar


Imported data to site repository (JvsSiteImportedData)

A globally unique ID which can be used to identify an object, thereby making it possible to export and import between databases. Should two objects appear to be the same when you consider name and numeric key they can be distinguished by this ID.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Internal text | EditInt | ztBlob | 1 |  | nvarchar
File name | JvsSiteFileName | ztString | 255 |  | varchar
@zPrompt=null | JvsSiteImportedData | ztBlob | 1 |  | varchar
Unique ID | JvsSiteUniqueId | ztString | 40 |  | nvarchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Imported invoice details (Lrd)

Information about imported reviewed supplier invoice details.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Alternative item | ArtNrAltArt | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Received qty invtry unit | bestlevant | ZtQty | 14 | 2 | decimal
Received qty (suppl unit) | BestLevAntextQty | ZtQty | 14 | 2 | decimal
PO no. | bestnr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
Supplier invoice no. | bestrkgnr | ztString | 25 |  | varchar
PO order value | BestValue | ZtBaseCurrAmount | 14 | 2 | money
Invc match value | FaktAvprVarde | ztMoney | 14 | 2 | money
Invc cost code | FaktKostnTyp | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Price conv factor | inkartomvfaktor | ztFloat | 14 | 4 | float
Price unit factor | inkprisper | ZtDecimal73 | 8 | 3 | decimal
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Customer order no. | kundbestnr | ztString | 30 |  | varchar
Mail to buyer | MailToBuyer | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
SeqNo. | PvLrid | ZtLong | 10 |  | int
Discount 1 % | rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
RejectCause | RejectCause | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Gross setup price, curr | vb_inpris_stall | ztMoney | 14 | 2 | money
Gross start purch price, curr | vb_inpris_start | ztMoney | 14 | 2 | money
Purch value, curr | VbBestValue | ztMoney | 14 | 2 | money


Imported SRU codes, details (importsrud)

Details, i.e. account interval(s) in the SRU code (Standardized accounts extract). See under the program Help/dedicated chapter for more information.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Version | accountversion | ztString | 50 |  | varchar
From account no. | FromKtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SRU 1 | Sru1Nr | ztString | 6 |  | varchar
SRU 2 | Sru2Nr | ztString | 6 |  | varchar
To account no. | TomKtoNr | ztString | 8 |  | varchar


Imported SRU codes, headers (importsruh)

Table header indicating the group in the SRU code (Standardized accounts extract). See under the program Help/dedicated chapter for more information.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Version | accountversion | ztString | 50 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SRU 1 | Sru1Nr | ztString | 6 |  | varchar
SRU 2 | Sru2Nr | ztString | 6 |  | varchar
SRU 3 | Sru3Nr | ztString | 6 |  | varchar
Description | SruBeskrivning | ztString | 60 |  | varchar

    This table is the main table in the following programs:

    Program: ImportSru Imported SRU codes


Imports->work table->Jeeves (sthi)

Table containing definitions for reading of external data to work tables in Jeeves.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Command shell post | CmdShellPost | ztString | 255 |  | varchar
Command shell pre | CmdShellPre | ztString | 255 |  | varchar
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
DB-term/-expression 2 | DbTermname2 | ztString | 255 |  | varchar
Document type no. | DocumentType | ZtLong | 5 |  | int
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment route | InbetalningsVag | ztString | 6 |  | varchar
Name of input/output data file | InputFileName | ztString | 255 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | KortNotering | ztString | 255 |  | varchar
Procedure, after | MatrixPostExecProc | ztString | 255 |  | varchar
Procedure, before | MatrixPreExecProc | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Payment route | UtbetalningsVag | ztString | 6 |  | varchar
Value term table | VardeTabId1 | ztString | 255 |  | varchar
Text/info | x255 | ztString | 255 |  | varchar
Delete at new loading | YndzDeleteRecv | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: sthi Def and import external data -> work table

    Program: vSthi Import extern data -> work table


In and out box for EDI (edib)

This table contains all received and sent EDI messages. The table also serves as a file for such. For outgoing messages, it also serves as a block to prevent the same message from being sent several times. To resend an order, for example, it must first be deleted from the outbox before a new one can be created.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Processed by | BearbetadEdiAv | ztString | 6 |  | varchar
Process date | BearbetadEdiDT | ztDateTime |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Issue agency | ControllingAgency | ztString | 2 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Receipt | EdiAcknowledged | ztBoolean |  |  | char
Application reference | EdiApplRef | ztString | 14 |  | varchar
In/Out box EDI | EdiBoxRef | ztString | 21 |  | varchar
Issuer's code | EdiDesignCode | ztString | 6 |  | varchar
Name of EDI file | EdiFileName | ztString | 255 |  | varchar
Main record | EdiHuvudPost | ztBoolean |  |  | char
EDI partner profile | EdiId | ZtLong | 6 |  | int
In-box directory | EdiInBoxDir | ztString | 255 |  | varchar
In/Out | EdiInUt | ztBoolean |  |  | char
EDI message | EdiMeddelande | ztBlob | 1 |  | varchar
EDI message ID | EdiMeddId | ztString | 35 |  | varchar
Out box directory | EdiOutBoxDir | ztString | 255 |  | varchar
Queued for conversion | EdiQueueDTConv | ztDateTime |  |  | datetime
Queued for transmission | EdiQueueDTSend | ztDateTime |  |  | datetime
Test indicator | EdiTestIndicator | ztBoolean |  |  | char
Where | EdiWhere | ztString | 255 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Disp.plan number | LevPlanNr | ZtLong | 10 |  | int
Sent by e-mail | Mailed | ztBoolean |  |  | char
Cancel | Makulerad | ztBoolean |  |  | char
Message | MessageType | ztString | 6 |  | varchar
Message version | MessageVer | ztString | 3 |  | varchar
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Recipient's logical address | PartnerId | ztString | 35 |  | varchar
Recip. phys addr | PartnerPhysicId | ztString | 35 |  | varchar
Recip. qualifier | PartnerQualifier | ztString | 4 |  | varchar
Recip. subaddress | PartnerSubId | ztString | 14 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Price list EDI | PrislistaEdi | ztString | 35 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Release | ReleaseNumber | ztString | 3 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sender's Logical EDI addr | SenderId | ztString | 35 |  | varchar
Sender's phys addr | SenderPhysicId | ztString | 35 |  | varchar
Sender's qualifier | SenderQualifier | ztString | 4 |  | varchar
Sender's subaddress | SenderSubId | ztString | 14 |  | varchar
Report program | YndReport | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: edib Incoming/outgoing EDI messages

    Program: EdibIn Incoming EDI messages

    Program: EdibUt Outgoing EDI messages


In-house document category1 (pdmkat1)

Definition of your own document categories, type 1.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Own category desc 1 | pdmkat1beskr | ztString | 80 |  | varchar
Own category 1 | pdmkat1kod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: pdmkat1 Company document category 1


In-house document category2 (pdmkat2)

Definition of your own document categories, type 2.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Own category desc 2 | pdmkat2beskr | ztString | 80 |  | varchar
Own category 2 | pdmkat2kod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: pdmkat2 Company document category 2


IN/OUT Day's schedule, shop reporting (veiu)

Table of which time intervals are worked each day for a weekly schedule.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Last clock out time | GickTid | ztTime | 5 |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Last clock in date | KomTid | ztTime | 5 |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Day of week | VeckoDag | ztInteger | 1 |  | smallint
Week schedule | VeVeckoSchema | ztInteger | 5 |  | smallint


Incoming payment file detail (krkd)

Details (paid invoices) are stored in this table when payments are loaded from the bank. This is done via the import/conversion program (sthi). The approved payments then create an incoming payment journal.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Avdragstyp | AvdragsTyp | ztInteger | 5 |  | smallint
Bankens arkiverings-id | BankensArkiveringsID | ztString | 30 |  | varchar
Account at bank | BankKonto | ztString | 40 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Due date | FaktFfDat | ztDate |  |  | datetime
Paid amount BCU | FaktInbBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice reference no. | FaktNr_OCR | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Deducted amount BCU | InbAvdrag | ZtBaseCurrAmount | 14 | 2 | money
Paid amount | InbBel | ZtBaseCurrAmount | 14 | 2 | money
Payment date | InbDat | ztDate |  |  | datetime
Payment route | InbetalningsVag | ztString | 6 |  | varchar
External pmt ID | InbExtId | ztString | 60 |  | varchar
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Early settlmt discnt BCU | InbKassaRab | ZtBaseCurrAmount | 14 | 2 | money
Pmt receipt journal no. | InbKvittensJournNr | ZtLong | 10 |  | int
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Status code pmt detail | KrkdStatus | ztInteger | 5 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
Kundens inbet.dat | KundensInbDat | ztDate |  |  | datetime
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Quantity | Kvantitet | ztFloat | 9 | 2 | float
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Interim vouch no. | MVerNr | Jeeves_VchrNo | 9 |  | bigint
Urspr valutakurs | OldValKurs | ZtCurrencyRate | 15 | 7 | decimal
Project ID | ProjCode | ztString | 10 |  | varchar
RadFelNr | RadFelNr | ztInteger | 4 |  | smallint
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Exchg rate diff | ValDiff | ZtBaseCurrAmount | 14 | 2 | money
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Deducted amount, curr | VbInbAvdrag | ztMoney | 11 | 2 | money
Paid amount, curr | VbInbBel | ztMoney | 14 | 2 | money
Early settlmt discnt, curr | VbKassaRab | ztMoney | 14 | 2 | money
Text/info | x255 | ztString | 255 |  | varchar
Text/info | x255_2 | ztString | 255 |  | varchar
Text 3 | x255_3 | ztString | 255 |  | varchar
Text 4 | x255_4 | ztString | 255 |  | varchar


Incoming payment file header (krkh)

When payments are loaded from the bank via the import conversion program (sthi), a main record is created for the load. Detail rows (incoming payments) for the load are linked to this main record.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Amount not allocated | EjFordelatBel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Paid amount | InbBel | ZtBaseCurrAmount | 14 | 2 | money
Payment date | InbDat | ztDate |  |  | datetime
Payment route | InbetalningsVag | ztString | 6 |  | varchar
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Receipt journal status | Inbjournstatuskod | ztInteger | 2 |  | smallint
Pmt receipt journal no. | InbKvittensJournNr | ZtLong | 10 |  | int
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Receipt date | KvittensDatum | ztDate |  |  | datetime
Receipt status | KvittensStatus | ztInteger | 5 |  | smallint
Receipt time | KvittensTid | ztTime | 5 |  | datetime
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
RadFelNr | RadFelNr | ztInteger | 4 |  | smallint
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Total qty | Tot_AntInb | ZtLong | 10 |  | int
Total payment | Tot_InbBel | ZtBaseCurrAmount | 14 | 2 | money
Totalt inbet val | Tot_VbInbBel | ztMoney | 14 | 2 | money
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Deducted amount, curr | VbInbAvdrag | ztMoney | 11 | 2 | money
Paid amount, curr | VbInbBel | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: krkh Incoming payment receipts


Incoming payment journal (ji)

Data in the incoming payment journal.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Bank | BankId | ztString | 10 |  | varchar
Bank charge | BankKost | ZtBaseCurrAmount | 9 | 2 | money
Reserved in journal | BilagsMark | ztBoolean |  |  | char
BOE ledger | BoE_Code | ztBoolean |  |  | char
Accounting date | BokfDat | ztDate |  |  | datetime
Cash/Bank ID | CashOrBankBookid | ztString | 15 |  | varchar
Check ledger | Check_Ledger | ztBoolean |  |  | char
Discount priority | DiscountPrio | ztInteger | 5 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
Amount not allocated | EjFordelatBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice journal no. | Faktjournal | ZtLong | 6 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Advance pmt deduction | ForskottAvrakning | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Paid amount | InbBel | ZtBaseCurrAmount | 14 | 2 | money
Payment date | InbDat | ztDate |  |  | datetime
Payment route | InbetalningsVag | ztString | 6 |  | varchar
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Receipt journal status | InbJournStatusKod | ztInteger | 2 |  | smallint
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Kundnummer | JiFtgNr | ztString | 10 |  | varchar
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Customer reference | KundRef2 | ztString | 30 |  | varchar
Receipt print date | KvittoUtskr | ztDate |  |  | datetime
Payment priority | PaymentPrio | ztInteger | 5 |  | smallint
Payment surplus | PaymentSurplus | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Reference number | ReferensNr | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate | ValKursGrund | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate, operand | ValKursOp | ztInteger | 5 |  | smallint
Exchange rate unit | ValKursPer | ZtDecimal73 | 8 | 3 | decimal
Surplus amount | Vb_SurplusAmount | ztMoney | 14 | 2 | money
Bank cost, currency | VbBankAmt | ztMoney | 14 | 2 | money
Paid amount, curr | VbInbBel | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Deleted | zDeleted | ztInteger | 1 |  | smallint

    This table is the main table in the following programs:

    Program: FskUtbet Repayment advance, individual customer

    Program: inb Incoming payment journal

    Program: inbcv Incoming payments, another currency

    Program: InbKFsk Payments and advances, customer

    Program: InbKlar Payments (marked Done)

    Program: InbKund Payments per customer


Incoming payment work table (jivx)

Work table for transfer to general ledger. Used for the incoming payment journal.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template, advance | AutoRegelForskott | ztString | 4 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Paid amount BCU | FaktInbBel | ZtBaseCurrAmount | 14 | 2 | money
Paid VAT/tax posted, BCU | FaktMomsInbBokfBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no., advance | FaktNrForskott | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Deducted amount BCU | InbAvdrag | ZtBaseCurrAmount | 14 | 2 | money
Payment date | InbDat | ztDate |  |  | datetime
Incoming pmt, advance | InBetForskRad | ztInteger | 5 |  | smallint
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Early settlmt discnt BCU | InbKassaRab | ZtBaseCurrAmount | 14 | 2 | money
Payment status | InbStatus | ztInteger | 1 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S-4 f ledg.balance | K4ReskSaldo | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S5 f ledg.balance | K5ReskSaldo | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S6 f ledg.Bal | K6ReskSaldo | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S7 f ledg.balance | K7ReskSaldo | ztString | 8 |  | varchar
Cost unit f ledg.balance | KbarReskSaldo | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Balance sheet CC | KstReskSaldo | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Ledger acct | KtoNrReskSaldo | ztString | 8 |  | varchar
Customer reference | KundRef2 | ztString | 30 |  | varchar
Urspr valutakurs | OldValKurs | ZtCurrencyRate | 15 | 7 | decimal
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Reference number | ReferensNr | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Exchg rate diff | ValDiff | ZtBaseCurrAmount | 14 | 2 | money
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Paid VAT/tax posted, curr | VbFaktMomsInbBokfBel | ZtBaseCurrAmount | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint


Incoming payment, receipt status (xkrk)

Definition of the status codes automatically set for the receipt journal upon loading of paid customer invoices from bank giro and plus giro via the program "Import external data to work table" (vsthi). The status code shows the result of loading for the journal.

The following standard records exist. Do not alter/delete:

Receipt status (KvittensStatus) | Receipt status (KvittensStatusBeskr) | Description
0 | Created | The receipt journal receives this status if no payment could be loaded.
10 | Journal created | The receipt journal receives this status, and an incoming payment journal number for the incoming payment journal that is created, if one or more incoming payments could be loaded, i.e. Jeeves found a matching invoice in the accounts receivable ledger.
99 | Incorrect total | The receipt journal receives this status when the sum amount in the incoming payment file does not match the sum of the invoice rows that were loaded.
100 | Closed, transferred | (Not used).
200 | Canceled | (Not used).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Receipt status | KvittensStatus | ztInteger | 5 |  | smallint
Receipt status | KvittensStatusBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xkrk Status codes, pmt receipt heads


Incoming payments (inb)

Customer invoice payments.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Days fr due dt to pmt | AntDgrSedanFfDat | ZtLong | 7 |  | int
Repayment of advance | AterBetForskott | ztBoolean |  |  | char
Posting template | AutoRegel | ztString | 4 |  | varchar
Posting template, advance | AutoRegelForskott | ztString | 4 |  | varchar
Bank | BankId | ztString | 10 |  | varchar
Account at bank | BankKonto | ztString | 40 |  | varchar
Reserved in journal | BilagsMark | ztBoolean |  |  | char
Bill of exchange no. | BoE_No | ZtLong | 9 |  | int
Bill number alpha | BoE_No_Alfa | ztString | 60 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Final payment ? | C_RestMark | ztBoolean |  |  | char
Currency code, new currency | C_ValKod | ztString | 4 |  | varchar
Exchange rate, new currency | C_ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Remaining to pay, new currency | C_VbFaktRest | ztMoney | 14 | 2 | money
Exchange rate, new currency | C_VbInbAvdrag | ztMoney | 14 | 2 | money
Paid amount, new currency | C_VbInbBel | ztMoney | 14 | 2 | money
Early settlmt discnt, new curr | C_VbKassaRab | ztMoney | 14 | 2 | money
Separate check | CheckInd | ztBoolean |  |  | char
Check number | CheckNo | ZtLong | 9 |  | int
Check sequence number | Checksequence | ZtLong | 10 |  | int
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Datum dröjsm.ränta | DrRtaDat | ztDate |  |  | datetime
Penalty int block | DrRtaLimit | ztchar | 1 |  | char
Invoice date | FaktDat | ztDate |  |  | datetime
Due date | FaktFfDat | ztDate |  |  | datetime
Paid amount BCU | FaktInbBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Paid VAT/tax posted, BCU | FaktMomsInbBokfBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no., advance | FaktNrForskott | Jeeves_InvNo | 9 |  | bigint
Branch info 1 | Filial_Info_1 | ztString | 60 |  | varchar
Branch info 2 | Filial_Info_2 | ztString | 60 |  | varchar
Local bank code | FilialKod | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Deducted amount BCU | InbAvdrag | ZtBaseCurrAmount | 14 | 2 | money
Payment date | InbDat | ztDate |  |  | datetime
Dröjsmålsränta | inbdrrta | ztInteger | 1 |  | smallint
Incoming pmt, advance | InbetForskRad | ztInteger | 5 |  | smallint
External pmt ID | InbExtId | ztString | 60 |  | varchar
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Early settlmt discnt BCU | InbKassaRab | ZtBaseCurrAmount | 14 | 2 | money
Pmt receipt journal no. | InbKvittensJournNr | ZtLong | 10 |  | int
Inb momsbelopp | InbMomsBelopp | ZtBaseCurrAmount | 14 | 2 | money
Payment method | InbSlag | ztString | 3 |  | varchar
Payment status | InbStatus | ztInteger | 1 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S-4 f ledg.balance | K4ReskSaldo | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S5 f ledg.balance | K5ReskSaldo | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S6 f ledg.Bal | K6ReskSaldo | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S7 f ledg.balance | K7ReskSaldo | ztString | 8 |  | varchar
Cost unit f ledg.balance | KBarReskSaldo | ztString | 8 |  | varchar
Code key | KodNyckel | ztString | 2 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost unit deduction | KostBarAvdrag | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Cost centre deduction | KstAvdrag | ztString | 8 |  | varchar
Balance sheet CC | KstReskSaldo | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Account no. deduction | KtoNrAvdrag | ztString | 8 |  | varchar
Ledger acct | KtoNrReskSaldo | ztString | 8 |  | varchar
Kundens inbet.dat | KundensInbDat | ztDate |  |  | datetime
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Customer reference | KundRef2 | ztString | 30 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Urspr valutakurs | oldValKurs | ZtCurrencyRate | 15 | 7 | decimal
Orig exchange rate | OldValKursGrund | ZtCurrencyRate | 15 | 7 | decimal
Orig exchange rate, operand | OldValKursOp | ztInteger | 5 |  | smallint
Orig exchange rate per | OldValKursPer | ZtDecimal73 | 8 | 3 | decimal
Payment suggestion | PaySugg | ztBoolean |  |  | char
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Reference number | ReferensNr | ZtLong | 10 |  | int
Acceptance journal | RemJrnlNo | ZtLong | 9 |  | int
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Last interest calc | RtaSenBer | ztDate |  |  | datetime
SWIFT bank location | SwiftMotBankOrt | ztString | 22 |  | varchar
Exchg rate diff | ValDiff | ZtBaseCurrAmount | 14 | 2 | money
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate | ValKursGrund | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate, operand | ValKursOp | ztInteger | 5 |  | smallint
Exchange rate unit | ValKursPer | ZtDecimal73 | 8 | 3 | decimal
Currency revaluation | ValutaOmrakning | ztBoolean |  |  | char
Paid VAT/tax posted, curr | VbFaktMomsInbBokfBel | ZtBaseCurrAmount | 14 | 2 | money
Deducted amount, curr | vbInbAvdrag | ztMoney | 11 | 2 | money
Paid amount, curr | VbInbBel | ztMoney | 14 | 2 | money
Inb momsbelopp | VbInbMomsBelopp | ztMoney | 14 | 2 | money
Early settlmt discnt, curr | vbKassarab | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: inbdet Show payment info

    Program: inbkrkd Incoming pmt details


Incoming pmt journal VIEW (vji)

View of the ji table (Incoming pmt journal).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Bank charge | BankKost | ZtBaseCurrAmount | 9 | 2 | money
Accounting date | BokfDat | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Amount not allocated | EjFordelatBel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Paid amount | InbBel | ZtBaseCurrAmount | 14 | 2 | money
Payment date | InbDat | ztDate |  |  | datetime
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Payment method | InbSlag | ztString | 3 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Paid amount, curr | VbInbBel | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Deleted | zDeleted | ztInteger | 1 |  | smallint


Incoming/outgoing payment files, receipt (krin)

A help table, used when loading completed incoming and outgoing payments via the import/conversion program sthi.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Text/info | x255 | ztString | 255 |  | varchar
Text/info | x255_2 | ztString | 255 |  | varchar
Text 3 | x255_3 | ztString | 255 |  | varchar
Text 4 | x255_4 | ztString | 255 |  | varchar
String | xString | ztString | 4000 |  | varchar


Injunction to pay (kusb)

Data on injunctions to pay. The injunction is always linked to a customer and can contain one or several invoices.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Injunction amount | BetForelaggandeBelopp | ZtBaseCurrAmount | 14 | 2 | money
Injunction date | BetForelaggandeDatum | ztDate |  |  | datetime
Injunction no. | BetForelaggandeNr | ZtLong | 4 |  | int
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
OLE-1 | Ole1 | ztString | 255 |  | varchar
OLE-2 | Ole2 | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xKusb Injunctions to pay


Integr dets, in/outgoing payment type (xaku)

Definition of integration details for incoming and outgoing payment types used to control the posting of bank transactions per payment type.

The following standard records exist. Do not alter/delete:

Integration detail (AkuTyp) | Integration detail (AkuBeskrivning) | Description
0 | Bank | Bank refers to the incoming or outgoing net payment given in the incoming or payment journal header.
1 | Bank overhead costs | Bank costs refers to deductions made by banks on receipt of payments and that are given in the incoming payment journal header.
2 | Acct for transf outgoing pmt bank | Both "Acct for transf outgoing pmt" and "Account for transferred debt" refer to cases where an outgoing payment is provisionally posted as a debt, until the bank or equivalent notify that the payment has actually been made. The accounting date is set to the date when the outgoing payments are sent to the bank. The current date is used if the field is empty. Note! For preliminary payments to be posted, this must be requested by flagging the field 'Create vch/pmt file' (term UtbSkapaPrelVer) in 'AP system data', which can only be applied for manual outgoing payments, not via an outgoing payment service.
3 | Account for transferred debt | Both "Acct for transf outgoing pmt" and "Account for transferred debt" refer to cases where an outgoing payment is provisionally posted as a debt, until the bank or equivalent notify that the payment has actually been made. For the posting type "Acct for transferred debt" an accounts payable account must be specified. The accounting date is set to the date when the outgoing payments are sent to the bank. The current date is used if the field is empty. Note! For preliminary payments to be posted, this must be requested by flagging the field 'Create vch/pmt file' (term UtbSkapaPrelVer) in 'AP system data', which can only be applied for manual outgoing payments, not via an outgoing payment service.
4 | Service fee (Check) | Refers to service costs for checking account.
5 | Interest (Check) | Refers to interest charges for checking account.
6 | Difference currency | Refers to decimal differences which arise when customers pay in a currency which differs from the invoice currency.
7 | Bill of exchange paid | Refers to account when bill of exchange is paid, for both bills from customer and to supplier.
8 | Bill of exchange for payment | Refers to account for bill of exchange for payment on customer bill.
9 | Interest charges | Refers to interest charges for payment of a bill of exchange.
10 | Contra account Bank charge+Interest charge | Refers to a contra account for bank and interest charges for settling a bill of exchange.
11 | Bill of exchange for payment before due date | Refers to account when bill of exchange is paid before due date on bill from customer.
20 | Paid advance, local currency | Refers to account for received advance payments in base currency for customer.
21 | Paid advance currency | Refers to account for received advance payments in currency for customer.
30 | Paid advance, outgoing VAT/tax |
31 | Paid advance, outgoing VAT/tax settlement |
40 | Invoiced unpaid advance, local currency | Refers to account for invoiced, unpaid advances in base currency when the advance invoice is booked in the accounts receivable ledger.
41 | Invoiced unpaid advance currency | Refers to account for invoiced, unpaid advances in currency when the advance invoice is booked in the accounts receivable ledger.
48 | Check for payments |
49 | Checks paid |
50 | Checks interest charges |
51 | Check bank costs |
52 | Check contra account Bank charge+Interest charge |

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Integration detail | AkuBeskrivning | ztString | 50 |  | varchar
Integration detail | AkuTyp | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xXaku Integr dets, in/outgoing payment type


Integration details (ak1)

Definition of integration details per integration source that describe the source and type of posting on voucher details. Example: the source is a customer invoice and the type of posting is the invoice amount excluding tax.

The table is built up of a number of so-called views. You can read about the standard records supplied by looking up the table help for these views:
vx0	Manual entry details
vx1	Customer invoice totals
vx2	Customer invoice details
vx6	Incoming payments
vx11	Supplier invoices
vx12	Supplier invoice payments
vx13	Supplier invc currency re-valuation
vx20	Voucher allocations
vx21	Fixed vouchers
vx23	Inventory transactions
vx50	BOE supplier invoices
vx51	BOE customer invoices
vx52	BOE collection
The following tables contain integration details not included in this table:
xaku	In/outgoing payments per type
xfrk	Internal deliveries
xopa	Labour costs
xixk	Fixed assets
xPid	Projects

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Ak1 Integration details


Integration details, allocation of vouchers (vx20)

Extract from (view of) the Source of integration details table (ak1) where integration source=20, Allocation of voucher.

This can be used to control postings during allocation of interim vouchers.

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldBeskr)
1 | Percentage allocation
2 | Remaining

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Integration details, AP currency revaluation (vx13)

Extract from (view of) the integration details table (ak1) where integration source=13, AP currency revaluation.

This can be used to control postings for currency revaluated supplier invoices.

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldBeskr)
0 | Currency diff

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar


Integration details, AP currency revaluation (vx194)

Extract from (view of) the Source of integration details table (ak1) where integration source=194, AP Currency revaluation

This can be used to control postings when running AP Currency revaluation.

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldBeskr)
1 | Interim account
50 | Exchange rate diff debit
51 | Exchange rate diff credit
53 | Unrealized exchange rate diff debit
54 | Unrealized exchange rate diff credit

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Integration details, AR currency revaluation (vx193)

Extract from (view of) the Source of integration details table (ak1) where integration source=193, AR Currency revaluation

This can be used to control postings when running AR Currency revaluation.

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldBeskr)
1 | Interim account
50 | Exchange rate diff debit
51 | Exchange rate diff credit
53 | Unrealized exchange rate diff debit
54 | Unrealized exchange rate diff credit

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Integration details, BOE collection (vx52)

Extract from (view of) the Source of integration details table (ak1) where integration source=52, BOE Collection

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldBeskr)
30 | BOE for payment
31 | BOE paid
32 | Interest charges
33 | Bank charges
34 | Contra account bank+interest chrgs

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Integration details, BOE customer invoice (vx51)

Extract from (view of) the Source of integration details table (ak1) where integration source=51, BOE Customer invoice

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldBeskr)
30 | BOE for payment
31 | BOE paid

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Integration details, BOE supplier invoice (vx50)

Extract from (view of) the Source of integration details table (ak1) where integration source=50, BOE Supplier invoice

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldBeskr)
30 | BOE for payment
31 | BOE paid

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Integration details, customer invoice details (vx2)

Extract from (view of) the Source of integration details table (ak1) where integration source=2, Customer invoice details.

This can be used to control postings of invoice details.

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldBeskr)
0 | Row value/revenues
1 | CSG/Cost of sold goods
3 | Inventory
5 | Order discounts
6 | Volume disc
7 | Customer discount
8 | Order value discount
9 | Matrix disc 1
10 | Matrix disc 2
11 | Matrix disc 3
20 | Deduction, paid customer advance, local currency
21 | Deduction, paid customer advance, currency
22 | Paid advance, outgoing VAT/tax
23 | Paid advance, outgoing VAT/tax settlement
24 | Paid advance, turnover
25 | Paid advance, turnover settlement
31 | Dispatch (material) )
32 | Dispatch (refinement)
40 | Gain on exchange rate, advance deduction
41 | Loss on exchange rate, advance deduction
50 | Row value/revenues, clearing account internal sales
51 | CSG/Cost of sold goods, clearing account internal sales
71 | Preliminary revenue, picking
72 | Contra account, preliminary revenue, picking
83 | Counter posting, picked value, not invoiced

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Integration details, fixed assets (xixk)

Integration details for fixed assets, used to control the postings of the both fixed assets transactions and depreciations.

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldBeskr)
0 | Fixed assets account
1 | Accumulated depreciation
2 | Depreciations
5 | Discardment
6 | Sale
7 | Adjustment acquisition amt
8 | Gains on sales
9 | Losses on sales
10 | interim account for fixed asset

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xixk Integration details, fixed assets


Integration details, fixed vouchers (vx21)

Extract from (view of) the Integration details per integration source table (ak1) where integration source=21, Fixed vouchers.

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldBeskr)
0 | Dummy0

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Integration details, GL Revaluation (vx195)

Extract from (view of) the Source of integration details table (ak1) where integration source=195, GL Revaluation.

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldBeskr)
2 | Exchange rate diff
50 | Exchange rate diff debit
51 | Exchange rate diff credit

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Integration details, incoming payments (vx6)

Extract from (view of) the Source of integration details table (ak1) where integration source=6, Customer payments.

This can be used to control postings of paid customer invoices.

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldBeskr)
0 | Receivables, local currency (origin)
1 | Bank account, local currency (curr rate)
2 | Exchange rate diff
4 | Deductions
5 | Bank overhead costs
6 | Early settlement discounts
7 | Tax, clearing account
8 | Contra account tax deduction
10 | Canceled
20 | Paid customer advance, local currency
21 | Paid customer advance, currency
30 | Paid advance, outgoing VAT/tax
31 | Paid advance, outgoing VAT/tax settlement
32 | Paid advance, turnover
33 | Paid advance, turnover settlement
40 | Invoiced unpaid customer advance, local currency
41 | Invoiced unpaid customer advance, currency
50 | Exchange rate diff debit
51 | Exchange rate diff credit
52 | Unrealized exchange rate diff
53 | Unrealized exchange rate diff debit
54 | Unrealized exchange rate diff credit
60 | Bill of exchange paid
61 | Bill of exchange for payment
62 | Bill of exchange for payment before due date

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Integration details, internal delivery (xfrk)

Definition of integration details used to control postings that can be done when shipping goods between own units within the same company.
- The interval 0 to 3 is used when posting a delivery from a manufacturing order to another unit within the company.
- The interval 11 to 13 is used when posting a delivery from an internal purchase order from another unit within the company.
- The interval 20 to 23 is used when posting a pick customer order from an internal purchase order from another unit within the company.
The posting is defined for each company in Jeeves (the units of the company are entered as companies in Jeeves).

The following standard records exist. Do not alter/delete:

Integration detail (AccountDelivCode) | Integration detail (AccountDelivCodeDescr) | Description
0 | Receive manufacturing -> invtry | Refers to what normally would be the inventory account when manufacturing for own inventory (delivery to inventory account). Here, you can enter an account for the receiving company (receiving unit). If type 0 is entered with an empty account number (NULL in account number), no posting is done of type 0. If type 0 is not specified for a company, the posting is done according to the item's product account like a normal manufacturing order.
1 | Received from MO (mtrl)-> invtry | Refers to posting of an item's material cost price. Only used if the item's product account is marked for posting of material and refinement. (The cost price of an item can be divided up into material and refinement (labour)). Types 1 and 2 should be used if you wish to have calculations in the General Ledger system on key ratios for own refinement and purchased material. If type 1 is entered with an empty account number (NULL in account number), no posting is done of type 1. If type 1 is not specified for a company, the posting is done according to the item's product account like a normal manufacturing order.
2 | Received from MO (refinement)-> invtry | Refers to posting of an item's refinement cost price. Only used if the item's product account is marked for posting of material and refinement. (The cost price of an item can be divided up into material and refinement (labour)). Types 1 and 2 should be used if you wish to have calculations in the General Ledger system on key ratios for own refinement and purchased material. If type 2 is entered with an empty account number (NULL in account number), no posting is done of type 2. If type 2 is not specified for a company, the posting is done according to the item's product account like a normal manufacturing order.
3 | Received from MO (poss rebook) -> invtry | Only used if the item's product account is flagged for posting of material and refinement to define a rebooking account which is mandatory when type 0 is used together with type 1 and 2 as follows: Integr.detail 0 = Inventory account (debit) Integr.detail 1 = Value of material being dispatched (debit) Integr.detail 2 = Value of refinement being dispatched (debit) Integr.detail 3 = Rebooking account (credit) The PIP account is also posted (credit) Example: Cost price 1000.00, Material 600.00, Refinement 400.00 Result: 0: Debit 1000.00 1: Debit 600.00 2: Debit 400.00 3: Credit 1000.00 (PIP: credit 1000.00)
11 | Received purchse (mtrl)-> invtry | Refers to posting of an item's material cost price. Only used if the item's product account is marked for posting of material and refinement. (The cost price of an item can be divided up into material and refinement (labour)). Types 11 and 12 should be used if you wish to have calculations in the General Ledger system on key ratios for own refinement and purchased material. If type 11 is not entered for a company, the posting is done according to the item's product account with integration type 41.
12 | Received purchse (refinement)-> invtry | Refers to posting of an item's refinement cost price. Only used if the item's product account is marked for posting of material and refinement. (The cost price of an item can be divided up into material and refinement (labour)). Types 11 and 12 should be used if you wish to have calculations in the General Ledger system on key ratios for own refinement and purchased material. If type 12 is not specified for a company, the posting is done according to the item's product account like a normal manufacturing order.
13 | Received purchse (poss rebook) -> invtry | Only used if the item's product account is flagged for posting of material and refinement to define a rebooking account which is mandatory when the received delivery will be posted for material and refinement.
19 | Delivery when transferring between inventory locations |
20 | Picking customer order -> picked inventory value (not inv) | Refers to what normally would be the inventory account for picking of customer orders from own stock (picking from inventory account). Used to define an account for the receiving company (receiving unit). If type 20 is entered with an empty account number (NULL in account number), no posting is done of type 0. If type 20 is not specified for a company, the posting is done according to the item's product account like a normal picking transaction.
21 | Picking customer order (mtrl) from inventory | Refers to posting of an item's material cost price. Only used if the item's product account is marked for posting of material and refinement. (The cost price of an item can be divided up into material and refinement (labour)). Types 21 and 22 should be used if you wish to have calculations in the General Ledger system on key ratios for own refinement and purchased material. If type 21 is entered with an empty account number (NULL in account number), no posting is done of type 21. If type 21 is not specified for a company, the posting is done according to the item's product account like a normal manufacturing order.
22 | Picking customer order (refinement) from inventory | Refers to posting of an item's refinement cost price. Only used if the item's product account is marked for posting of material and refinement. (The cost price of an item can be divided up into material and refinement (labour)). Types 21 and 22 should be used if you wish to have calculations in the General Ledger system on key ratios for own refinement and purchased material. If type 22 is entered with an empty account number (NULL in account number), no posting is done of type 22. If type 22 is not specified for a company, the posting is done according to the item's product account like a normal manufacturing order.
23 | Picking customer order (poss rebook) -> inventory value | Only used if the item's product account is flagged for posting of material and refinement to define a rebooking account which is mandatory when type 20 is used together with type 21 and 22 as follows: Integr.detail 20 : Inventory account (debit) Integr.detail 21 : Value of material being dispatched (debit) Integr.detail 22 : Value of refinement being dispatched (debit) Integr.detail 23 : Rebooking account (credit) The PIP account is also posted (credit) Example: Cost price 1000.00, Material 600.00, Refinement 400.00 Result: 20 : Debit 1000.00 21 : Debit 600.00 22 : Debit 400.00 23 : Credit 1000.00 (Dispatched not invoiced 1000.00)
29 | Dispatch when transferring between inventory locations | This posting is primarily used for counter-booking of a picked inventory value. If the posting is missing, then the item's product account and inventory transfer integration type are used.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Integration detail | AccountDelivCode | ztInteger | 5 |  | smallint
Integration detail | AccountDelivCodeDescr | ztString | 60 |  | varchar
Description | AccountDelivCodeDoc | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xfrk Integration details, internal delivery


Integration details, inventory (vx23)

Extract from (view of) the Source of integration details table (ak1) where integration source=23, Inventory.

This can be used to control postings of all types of inventory movements, for example dispatch/received deliveries, physical inventory differences.

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldBeskr)
0 | Inventory account
1 | Contra account
2 | Purchase price diff (+)
3 | Purchase price diff (-)
5 | Products in progress
6 | Invtry adjustment (avg price)... (+)
7 | Invtry adjustment (avg price)... (-)
8 | Contra account, invtry adjustment (avg price)
10 | Development cost (received MO)
11 | Development OH cost (received MO)
12 | Technology OH (received MO)
13 | Extra OH (received MO)
14 | Startup cost MO (received MO)
15 | OH markup, picking purchased material for MO
18 | Cost posting (OU manufacturing)
19 | Cost posting (OU manuf), contra account WIP
21 | Purch cost (OH/refinement)
22 | Inventory acct, commitment posting
23 | Overhead, commitment posting
26 | Fictitious inventory adjustment MO, inv matching, avg price (+)
27 | Fictitious inventory adjustment MO, inv matching, avg price (-)
28 | Fictitious contra account MO, inv matching, avg price
31 | Dispatch (material)
32 | Dispatch (refinement)
33 | Dispatch (rebook material+refinement)
35 | Dispatch (base value markup)
40 | Rec delivery from alt unit (invoice)
41 | Rec delivery fr alt unit (material)
42 | Rec delivery fr alt unit (refinement)
43 | Rec delivery from alt unit (rebooking)
44 | Calculation difference manufacturing, mtrl (+)
45 | Calculation difference manufacturing, mtrl (-)
46 | Calculation difference manufacturing, labour (+)
47 | Calculation difference manufacturing, labour (-)
50 | Material issue, shadow account
51 | Material issue, shadow account, contra account
52 | Received delivery manufacturing, shadow account
53 | Received delivery fr manufacturing, shadow account, contra account
56 | Utleverans kundorder, omkostnadspålägg (GO2+ARPK)
57 | Utleverans kundorder, omkostnadspålägg (EO+ARPK)
58 | Utleverans kundorder, omkostnadspålägg (EO2+ARPK)
65 | OH, manufacturing admin
66 | OH, manufacturing production
67 | OH, manufacturing sales
71 | Prel revenue, picked customer order
72 | Prel revenue, picked customer order, contra account
81 | Purch, prel cost excl. VAT/tax (debit, cost accounting)
82 | Purch, prel tax on cost (debit, cost accounting)
83 | Purch, invoices to be received (credit, cost accounting)
86 | (86) Calculated received customs duties
87 | (87) Calculated received freight charges
88 | (88) Calculated received handling charges
90 | Different account purchase order invoice
95 | Dispatch customer order, NOT for invoicing

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Integration details, invoice totals (vx1)

Extract from (view of) the Integration details per integration source table (ak1) where integration source=1, Customer invoices.

This can be used to control postings of the total amounts for customer invoices.

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldbeskr)
1 | Invoiced amount incl tax
2 | Tax
3 | Rounding
7 | Revenues, manual invoice
9 | Revenues, interest invoice
10 | Invoiced unpaid customer advance, local currency
11 | Invoiced unpaid customer advance, currency

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Integration details, labour transactions (xopa)

Integration details for labour cost types for labour operations.

The following standard records exist. Do not alter/delete:

Integration detail (ArbTransTyp) | Integration detail (ArbTransTypBeskr)
0 | Default all postings
10 | Labour (default)
11 | Labour, manufacturing wage
12 | Labour, manufacturing, wage OH
13 | Labour, setup cost
14 | Labour, setup, wage OH
20 | Subcontract (default)
21 | Subcontract cost
22 | Subcontract, overhead costs
26 | Subcontract, invc matched amount
27 | Price diff (+), invc matched
28 | Price diff (-), invc matched
30 | Manufacturing group (default)
31 | Mfg group, fixed costs
32 | Mfg group, variable costs
33 | Mfg group, depreciation
34 | Mfg group, setup cost
40 | Labour overhead cost (default)
41 | Labour overhead cost, fixed
42 | Labour overhead cost, variable
43 | Labour OH, per operation
44 | Labour OH, setup
50 | Tools (default)
51 | Tools, fixed
52 | Tools, variable
53 | Tools, depreciation
54 | Tools, setup cost
55 | Tools, unit cost
61 | Labour OH, item
90 | WIP posting
100 | Cost posting; Default all postings
110 | Cost posting; Labour (default)
111 | Cost posting; Labour, mfg wage
112 | Cost posting; Labour, mfg, wage OH
113 | Cost posting; Labour, setup cost
114 | Cost posting; Labour, setup, wage OH
120 | Cost posting; Subcontracting (default)
121 | Cost posting; Subcontract cost
122 | Cost posting; Subcontract, OH
126 | Cost posting; Subcontract, invc matched
130 | Cost posting; Mfg group (default)
131 | Cost posting; Mfg group, fixed costs
132 | Cost posting; Mfg group, variable costs
133 | Cost posting; Mfg group, depreciation
134 | Cost posting; Mfg group, setup cost
140 | Cost posting; Labour OH (default)
141 | Cost posting; Labour OH, Fixed
142 | Cost posting; Labour OH, Variable
143 | Cost posting; Labour OH, per op
144 | Cost posting; Labour OH, setup
150 | Cost posting; Tools (default)
151 | Cost posting; Tools, fixed
152 | Cost posting; Tools, variable
153 | Cost posting; Tools, depreciation
154 | Cost posting; Tools, setup cost
155 | Cost posting; Tools, unit cost
161 | Cost posting; Labour OH cost, Item
190 | Cost posting; WIP posting

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Integration detail | ArbTransTyp | ztInteger | 3 |  | smallint
Integration detail | ArbTransTypBeskr | ztString | 50 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xopa Integration details, labour transactions


Integration details, manual entry (vx0)

Extract from (view of) the Integration details per integration source table (ak1) where integration source=0, Manual entry.

This is used internally in the system.

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldBeskr)
0 | Dummy0
1 | Dummy1

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Integration details, supplier invoices (vx11)

Extract from (view of) the Source of integration details table (ak1) where integration source=11, Supplier invoices.

This can be used to control postings of the supplier invoices.

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldBeskr)
0 | Invoice amount incl tax
1 | Tax
2 | Invoice amount excl tax
3 | Diff debit-credit
40 | Insurance
41 | Handling charge
42 | Packaging cost
43 | Freight cost
50 | Advance - Credit
51 | Advance - Debit
60 | Tax according to base 0
61 | Tax according to base 1
62 | Tax according to base 2
63 | Tax according to base 3
64 | Tax according to base 4
70 | Tax according to base 0 invoice period <> TAX period
71 | Tax according to base 1 invoice period <> TAX period
72 | Tax according to base 2 invoice period <> TAX period
73 | Tax according to base 3 invoice period <> TAX period
74 | Tax according to base 4 invoice period <> TAX period
75 | Tax, invoice period <> TAX period

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Integration details, supplier payments (vx12)

Extract from (view of) the Source of integration details table (ak1) where integration source=12, Supplier payments.

This can be used to control postings when supplier invoices are paid.

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldBeskr)
0 | Paid amount base currency/Debts
1 | Paid amount local ccy (Current rate)/BankGiro, PostalGiro
2 | Exchange rate diff
3 | Fakt belopp efter moms
4 | Deductions
5 | Bank overhead costs
6 | Volume disc
7 | Early settlement discounts
8 | Reversering kredit
9 | Reversering debet
10 | Canceled-1
11 | Canceled-2
12 | Canceled-3
13 | Canceled-4
14 | Canceled-5
15 | Canceled-6
16 | Canceled-7
17 | Canceled-8
18 | Canceled-9
19 | Canceled-10
20 | Canceled-11
21 | Makulerad-12
22 | Paid advance, outgoing VAT/tax
23 | Paid advance, outgoing VAT/tax settlement
24 | Paid advance, turnover
25 | Paid advance, turnover settlement
30 | BOE for payment
31 | Dispatch (material) )
32 | Dispatch (refinement)
40 | Insurance
41 | Handling charge
42 | Packaging cost
43 | Freight cost
50 | Exchange rate diff debit
51 | Exchange rate diff credit
52 | Unrealized exchange rate diff
53 | Unrealized exchange rate diff debit
54 | Unrealized exchange rate diff credit
60 | Bill of exchange paid
61 | Tax according to base 1
62 | Tax according to base 2
63 | Tax according to base 3
64 | Tax according to base 4
70 | Tax according to base 0 invoice period <> TAX period
71 | Tax according to base 1 invoice period <> TAX period
72 | Tax according to base 2 invoice period <> TAX period
73 | Tax according to base 3 invoice period <> TAX period
74 | Tax according to base 4 invoice period <> TAX period
75 | Tax, invoice period <> TAX period
83 | Counter posting, picked value, not invoiced

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Integration details, time, projects, assignments (xPid)

Integration details for projects, used to control postings of project costs and revenues.

The following standard records exist. Do not alter/delete:

Integration detail (IntField) | Integration detail (IntFieldBeskr)
0 | Cost posting
1 | Counter-booking cost posting
10 | Accumulated revenue for period
11 | Accumulated cost for period
12 | Accumulated result for period
13 | Change in loss risk reserve
14 | Result after loss risk reserve
20 | Internal debiting, revenue
21 | Internal debiting, cost

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xPid Integration details, time, projects, assignments


Integration sources (xa6)

Definition of integration sources describing the origin for vouchers. You define the posting details within the respective integration source in the embedded list window.

Example: For integration source 6, Customer payments, you enter the available appropriate posting details such as Customer receivable, Early settlement discount, etc.

If you want to add your own integration sources, these must be within the interval 200-899. Your own integration sources can be specified when entering manual vouchers.

You can specify a voucher number interval for the integration source in an underlying program node.

The following standard records exist. Do not alter/delete:

Integration source (IntSource) | Integration source (IntSourceBeskr)
0 | Manual entry
1 | Customer invoices
2 | Invoice detail/product
6 | Incoming payments
10 | Issue for customer order
11 | Supplier invoice
12 | Suppl. invoice, payment
13 | Suppl. invoice, curr.conv
15 | Automatic allocation
16 | Automatic posting
18 | Period closing voucher
20 | Allocated voucher
21 | Fix voucher
22 | From external system
23 | Inventory
24 | Labour posting
25 | Fixed assets depreciations
26 | Book project to income
27 | Receive from MO
28 | Material issue for MO
29 | Calculation diff, MO
30 | Received deliv, PO
31 | Order-specific inventory
32 | Cost price change
33 | Phys inventory
34 | Fixed assets transactions
35 | Commitment accounting
40 | Time/Project/Assignments
50 | BOE supplier invoices
51 | BOE customer invoices
52 | BOE collection
53 | Check collection
54 | Check paid
91 | Suppl. invoice, final approval
102 | Journal voucher
103 | Check routine
193 | AR revaluation
194 | AP revaluation
195 | GL revaluation
196 | Internal invoice
197 | Customs invoice
198 | VAT/tax invoice
199 | Chronological voucher no.
900 | Reversal

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Create expenses | CreateEx | ztBoolean |  |  | char
Debit/credit | DebKre | ztchar | 1 |  | char
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Integration source | IntSourceBeskr | ztString | 50 |  | varchar
Journal group | JourGrupp | ZtLong | 9 |  | int
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Manual entry | Manreg | ztBoolean |  |  | char
Move to next period | NextPeriodIfClosed | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Entry inventory, CC | RegLager | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SIE voucher series out | SieVchrNoSerieCd | ztchar | 3 |  | char
SIE voucher series in | SieVchrNoSerieCd_in | ztchar | 3 |  | char
Open locked voucher | UnlockClosedVer | ztBoolean |  |  | char
This field is used in the table as follows: |
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: Xxa6 Integration sources


Interest invoice balance/customer (kusr)

The interest values are based on interest invoicing by the balance method.
The interest is calculated from the customer balance of due invoices and not from individual invoices.
Credit invoices will therefore counter balance debit invoices.
If the credit balance exceeds the debit balance, interest will be due. The interest rate can be defined per day. The rates for debit and credit balances can differ.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Days fr due dt to pmt | AntDgrSedanFfDat | ZtLong | 7 |  | int
Due date | FaktFfDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Interest balance curr | IntrstBalFCURev | ztMoney | 14 | 2 | money
Interest balance | IntrstBalRev | ZtBaseCurrAmount | 14 | 2 | money
Interest journal batch no. | JKurNr | ztInteger | 4 |  | smallint
Row | RadPos | ZtLong | 10 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Interest amount | RtaBelopp | ZtBaseCurrAmount | 14 | 2 | money
Interest days | RtaDagar | ztInteger | 4 |  | smallint
Itrst from | RtaFromDat | ztDate |  |  | datetime
Activity date | RtaHandDatum | ztDate |  |  | datetime
Interest % | RtaProcent | ZtDecimal73 | 6 | 2 | decimal
Interest balance | RtaSaldo | ZtBaseCurrAmount | 14 | 2 | money
Last interest calc | RtaSenBer | ztDate |  |  | datetime
Interest up to date | RtaTomDat | ztDate |  |  | datetime
SaldoSort | SaldoSort | ZtLong | 9 |  | int
Record type | UkrtTyp | ztInteger | 1 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Interest amount curr | ValRtabelopp | ztMoney | 14 | 2 | money
Interest balance curr | ValRtaSaldo | ztMoney | 14 | 2 | money


Interest invoices (kusq)

Data on customer interest invoices.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Payment terms | BetKod | ztString | 2 |  | varchar
Amount due | DueAmount | ZtBaseCurrAmount | 14 | 2 | money
Due amount, curr | DueAmountVb | ztMoney | 14 | 2 | money
External text | EditExt | ztBlob | 1 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Itrst journal batch no. origin | JKurNoOrigin | ztInteger | 4 |  | smallint
Interest journal batch no. | JKurNr | ztInteger | 4 |  | smallint
Itrst journal batch no. credit | JKurNrKre | ztInteger | 4 |  | smallint
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Invoice not printed | No_Invoice | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Interest amount | RtaBelopp | ZtBaseCurrAmount | 14 | 2 | money
Itrst from | RtaFromDat | ztDate |  |  | datetime
Balance method | RteSaldoMetoden | ztBoolean |  |  | char
Currency | ValKod | ztString | 3 |  | varchar
Interest amount curr | ValRtaBelopp | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: xJkurKus Interest batches by customer


Interest invoicing (balance method) jrnl (jkur)

Journal with data from interest invoice (balance method) batches.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Interest journal batch no. | JKurNr | ztInteger | 4 |  | smallint
Legal entity | LegalEntity | ztString | 10 |  | varchar
Print date | p_utskr_dat | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Interest up to date | RtaTomDat | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: xJKur Interest batches journal


Interest rates, dispatch&ledger (xrut)

Here you can enter interest rates for lending and for due debit invoices in Accounts Receivable, linked to interest invoicing agreements. For more information see the field help for the field 'Interest rate lending/credit (Field: RtaUtProcent).

Note that if you use the balance method, interest rates must be entered here and in the table 'Interest rate, lending, credit invoices' (xrin).

No interest rates are defined on delivery.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Interest rate chg date | RtaDatum | ztDate |  |  | datetime
Interest, loans/debit | RtaUtProcent | ZtDecimal73 | 6 | 2 | decimal
Pmt rmdr/intrst invc rule | RteFaktAvtal | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: Xxrut Interest rate, lending, debit


Interest rates, rcv&ledger (xrin)

Here you can enter interest rates for borrowing and for due credit invoices in Accounts Receivable, linked to interest invoicing agreements. For more information see the field help for the field 'Interest deposits/credit (Field: RtaInProcent).

Note that if you use the balance method, interest rates must be entered here and in the table 'Interest rate, lending, debit' (xrut).

No interest rates are defined on delivery.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Interest rate chg date | RtaDatum | ztDate |  |  | datetime
Interest, deposits/credit | RtaInProcent | ZtDecimal73 | 6 | 2 | decimal
Pmt rmdr/intrst invc rule | RteFaktAvtal | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: Xxrin Interest on credit invcs


Interim voucher header (hmvt)

View showing the results of conversions as default .
The view can be altered so that it shows historical conversions, if these are stored (via your own script) in a different database or table.
Contact the system administrator if a history of interim vouchers is required.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Reversal period | AterBokasPeriod | ztInteger | 4 |  | smallint
Per bok.ver s/t | AterBokasST | ztInteger | 1 |  | smallint
Reversal voucher no. | AterBokasVerNr | Jeeves_VchrNo | 9 |  | bigint
Approved by | AttestSign | ztString | 6 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Interim vouch no. | MVerNr | Jeeves_VchrNo | 9 |  | bigint
Interim vchr status | MvtStatus | ztInteger | 2 |  | smallint
OLE-1 | ole1 | ztString | 255 |  | varchar
Print date | p_utskr_dat | ztDate |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Value term table | VardeTabId1 | ztString | 255 |  | varchar
Voucher amount | VerBel | ZtBaseCurrAmount | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Prel voucher no. | VerNrP | Jeeves_VchrNo | 9 |  | bigint
Voucher text | VerText | ztString | 60 |  | varchar
Voucher status | VtStatus | ztInteger | 2 |  | smallint
Cancel | VtVrMakKod | ztBoolean |  |  | char
Transfer date | VtVrUpDat | ztDate |  |  | datetime
Deleted | zDeleted | ztInteger | 1 |  | smallint

    This table is the main table in the following programs:

    Program: xHMvt Interim vouchers, history


Interim voucher rows (hmvr)

Voucher rows in interim vouchers.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Net amount | Belopp | ZtBaseCurrAmount | 14 | 2 | money
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | bokfdat | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | k4 | ztString | 8 |  | varchar
S5 | k5 | ztString | 8 |  | varchar
S6 | k6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | krebel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Account type | ktotyp | ztInteger | 3 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Sequence no. | lopnr | ZtLong | 10 |  | int
Compression flag | MarkKomp | ztBoolean |  |  | char
Interim vouch no. | MVerNr | Jeeves_VchrNo | 9 |  | bigint
Arb.övers.fält | MvrTranslate1 | ztString | 30 |  | varchar
Arb.övers.fält | MvrTranslate2 | ztString | 30 |  | varchar
Arb.övers.fält | MvrTranslate3 | ztString | 30 |  | varchar
Arb.övers.fält | MvrTranslate4 | ztString | 30 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Sequence | Sequence | ztInteger | 3 |  | smallint
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Prel voucher no. | VerNrP | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint
Statuskod på rad | VrStMark | ztInteger | 2 |  | smallint
Uppdateringskod | VrUpdateCode | ztInteger | 1 |  | smallint
Voucher row text | VrVerText | ztString | 60 |  | varchar
Transfer date | VtVrUpDat | ztDate |  |  | datetime


Interim voucher rows (mvr)

Table of interim voucher rows created in Jeeves conversion routine. Interim vouchers can also be created manually, if desired.

Both a voucher header is created in the table 'Interim voucher, header' (mvt), and the individual voucher rows/transactions are created in this table. The status of the conversion is shown in the voucher header. If all transactions are correct and are in balance, the status will be set to 'Registration finished'. Otherwise the incorrect one will be marked.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Net amount | Belopp | ZtBaseCurrAmount | 14 | 2 | money
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | bokfdat | ztDate |  |  | datetime
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | k4 | ztString | 8 |  | varchar
S5 | k5 | ztString | 8 |  | varchar
S6 | k6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Conv to company | KonvTillForetagKod | ztInteger | 5 |  | smallint
Cost unit | kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | krebel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Account type | KtoTyp | ztInteger | 3 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Sequence no. | lopnr | ZtLong | 10 |  | int
Compression flag | MarkKomp | ztBoolean |  |  | char
Tax date | MomsDatum | ztDate |  |  | datetime
Tax base amount | MomsGrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Interim vouch no. | MVerNr | Jeeves_VchrNo | 9 |  | bigint
Arb.övers.fält | MvrTranslate1 | ztString | 30 |  | varchar
Arb.övers.fält | MvrTranslate2 | ztString | 30 |  | varchar
Arb.övers.fält | MvrTranslate3 | ztString | 30 |  | varchar
Arb.övers.fält | MvrTranslate4 | ztString | 30 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Reference number | ReferensNr | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Sequence | Sequence | ztInteger | 3 |  | smallint
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
VAT/tax type | Vat_Type | ztInteger | 4 |  | smallint
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Prel voucher no. | VerNrP | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint
Statuskod på rad | VrStMark | ztInteger | 2 |  | smallint
Uppdateringskod | VrUpdateCode | ztInteger | 1 |  | smallint
Voucher row text | VrVerText | ztString | 60 |  | varchar
Transfer date | VtVrUpDat | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: mvr Interim voucher rows


Interim voucher status (x1u)

Internal definitions of status codes which describe the status of interim vouchers.

The following standard records exist. Do not alter/delete:

Interim vchr status (MvtStatus) | Interim vchr status (MvtBeskrivning)
0 | Wait to transfer
5 | Ready for transfer
8 | Transfer complete
9 | Canceled
21 | Transferring from external system

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Interim vchr status | MvtBeskrivning | ztString | 50 |  | varchar
Interim vchr status | MvtStatus | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: x1u Interim voucher status

    Program: xX1u Interim voucher status


Interim voucher, header (mvt)

Main table for interim vouchers created in Jeeves conversion routine. Interim vouchers can also be created manually, if desired.

Both a voucher header is created in this table, and the individual voucher rows/transactions are created in the table 'Interim voucher rows' (mvr). The status of the conversion is shown in the voucher header. If all transactions are correct and are in balance, the status will be set to 'Registration finished'. Otherwise the incorrect one will be marked.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Reversal period | AterBokasPeriod | ztInteger | 4 |  | smallint
Per bok.ver s/t | AterBokasST | ztInteger | 1 |  | smallint
Reversal voucher no. | AterBokasVerNr | Jeeves_VchrNo | 9 |  | bigint
Approved by | AttestSign | ztString | 6 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Text | Edit | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Journal group | JourGrupp | ZtLong | 9 |  | int
Conv to company | KonvTillForetagKod | ztInteger | 5 |  | smallint
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Interim vouch no. | MVerNr | Jeeves_VchrNo | 9 |  | bigint
Interim vchr status | MvtStatus | ztInteger | 2 |  | smallint
OLE-1 | ole1 | ztString | 255 |  | varchar
Print date | p_utskr_dat | ztDate |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Voucher per desc | PerVer | ztInteger | 1 |  | smallint
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Value term table | VardeTabId1 | ztString | 255 |  | varchar
Voucher amount | VerBel | ZtBaseCurrAmount | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Prel voucher no. | VerNrP | Jeeves_VchrNo | 9 |  | bigint
Voucher text | VerText | ztString | 60 |  | varchar
Voucher status | VtStatus | ztInteger | 2 |  | smallint
Cancel | VtVrMakKod | ztBoolean |  |  | char
Transfer date | VtVrUpDat | ztDate |  |  | datetime
Deleted | zDeleted | ztInteger | 1 |  | smallint

    This table is the main table in the following programs:

    Program: xMvt Interim vouchers


Interim vouchers VIEW (vmvt)

View of the mvt table (Interim vouchers).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Interim vouch no. | MVerNr | Jeeves_VchrNo | 9 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar


Internal business units ICT (BusinessUnit)

Definition of the business units or equivalent within home company. The term “business unit” shows the unit that owns an order, purchase order, invoice etc, as well as the unit to which the order, purchase order, or invoice is directed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Business unit ICT | BusinessUnitDescr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: BusinessUnit Internal business units ICT


Internal sales types (xifs)

Table for definition of different types of internal sales.
You can use this type to link the customer category code for customers to a definition for internal sales with respect to the item and internal sales type (table ARIF).
Definition of relevant combinations with respect tof item and internal sales type which, upon sale of an item to a customer and the current combination between item and internal sales type according to the customer's customer category is defined in this table, means that an internal sale is involved, from the department that purchases the product from a supplier to inventory, to the department that sells the product to a customer.
This function facilitates follow-up in the general ledger for revenues, costs and margin regarding such sales, both for the department that purchases the product from a supplier to inventory, and the department that purchases the product internally and sells to a customer.
Normal accounting regarding revenue, cost and margin always refers to the department that sells the product to a customer.
Using this function you can therefore achieve accounting of revenue, cost and margin in connection with sales also for the department that purchases the product from a supplier to inventory. For internal sales of a product, information is also obtained regarding revenue, cost and margin on the invoice row, both for the department that purchases the product from a supplier to inventory, and the department that purchases the product internally and sells to a customer.
These internal sales are made at an agreed internal sales price which is defined in this table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Internal sales type | InternFsgTyp | ztInteger | 2 |  | smallint
Internal sales type | InternFsgTypBeskr | ztString | 30 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxifs Internal sales types


Internal VAT/tax specification (PvLrintArt)

Data for internal VAT/tax invoice regarding EU import (country specific function for Poland). Data can be added, changed and deleted as long as the invoice has not been integrated with the general ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Amount BCU | AmountBCU | ztMoney | 14 | 2 | money
Quantity | Antal | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | nvarchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Tax date | MomsDatum | ztDate |  |  | datetime
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | nvarchar
SeqNo. | PvlrId | ZtLong | 10 |  | int
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Columns updated | RowUpdatedCols | ztString | 255 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | nvarchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
VAT/tax type purchase | VAT_Type_Purchase | ztInteger | 4 |  | smallint
VAT/tax type sales | VAT_Type_Sales | ztInteger | 4 |  | smallint
VAT/tax amount BCU | VATAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Purchase price incl tax | vb_inprisinklmoms | ztMoney | 14 | 2 | money


Internal VAT/tax specification (LrintArt)

Data for internal VAT/tax invoice regarding EU import (country specific function for Poland). Data can be added, changed and deleted as long as the invoice has not been integrated with the general ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Amount BCU | AmountBCU | ztMoney | 14 | 2 | money
Quantity | Antal | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Supplier invoice no. | BestrkgNr | ztString | 25 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
PO no. | MomsBestNr | ZtLong | 6 |  | int
Row no. in PO | MomsBestRadNr | ztInteger | 5 |  | smallint
Tax date | MomsDatum | ztDate |  |  | datetime
VAT/tax invc basis | MomsFaktUnderlag | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
VAT/tax type purchase | VAT_Type_Purchase | ztInteger | 4 |  | smallint
VAT/tax type sales | VAT_Type_Sales | ztInteger | 4 |  | smallint
VAT/tax amount BCU | VATAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Purchase price incl tax | vb_inprisinklmoms | ztMoney | 14 | 2 | money


Interrupt code indicating reason (aoak)

In this table, you can definepossible reasons for interruptions that may occur in manufacturing, such as Out of material, Reprioritization, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Interruption code | AoAvbrottsKod | ztInteger | 5 |  | smallint
Interruption reason | AoAvbrottsKodBeskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Aoak Interruption codes, ops/orders


Interruption codes (sht5)

Definition of interruption codes used when entering/reporting service orders.

There are a number of standard codes that determine which fields are set up in the form for entering interruptions, but you can also enter your own codes as required.

The following standard records exist. Do not alter/delete:

Interruption (AvbNr) | Description (Beskrivning)
1 | Cost proposed
2 | Lack of spare parts
5 | Customer message

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Interruption | AvbNr | ztInteger | 3 |  | smallint
Description | Beskrivning | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: sht5 Interruption codes


Interruption status (shas)

Definition of existing status codes as required which can be used when entering interruptions on service orders and projects.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Interruption status | AvbCode | ztString | 3 |  | varchar
Interruption status | Avbrott | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: shas Interruption status


Interruption table (shav)

Information on interruptions on service orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Interruption status | AvbCode | ztString | 3 |  | varchar
Interruption | AvbNr | ztInteger | 3 |  | smallint
External description | ExtBeskriv | ztBlob | 1 |  | varchar
Fault description | FelBeskriv | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight price | FraktPris | ZtBaseCurrAmount | 14 | 2 | money
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost proposal price | KostFPris | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | Momskod | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Signature | PersSign3 | ztString | 6 |  | varchar
Final inspection | PersSign4 | ztString | 6 |  | varchar
Position | Position | ztString | 10 |  | varchar
Row | RadPos2 | ztInteger | 4 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Repair price | RepPris | ZtBaseCurrAmount | 14 | 2 | money
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Examination price | UndSPris | ZtBaseCurrAmount | 14 | 2 | money

    This table is the main table in the following programs:

    Program: shav Interruption


Intervals, rounding table price incl VAT/tax (xavpm)

Definition of price rounding per price interval that can be used when calculating a price including VAT/tax, based on the price excluding VAT/tax.

The definition is based on linking a rounding level according to the static system table Price rounding types (xavr) to a price interval. Example: prices < 100 are rounded to the nearest 50 decimals, prices < 1000 are rounded to SEK 1.00, and so on.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Limit price rounding <= | LimitPrisAvrund | ZtSalesPrice | 12 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Rounding type | PrisAvrundKod | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xxavpm Rounding table price incl VAT/tax


Intrastat, accounting types (xistr)

Definition of accounting types appearing in Intrastat reports.

The following standard records exist. Do not alter/delete:

Intrastat accounting type (IntStatRedovTyp) | Intrastat accounting type (IntStatRedovTypBeskr)
1 | Export and import
2 | Export
3 | Import

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Intrastat accounting type | IntStatRedovTyp | ztInteger | 2 |  | smallint
Intrastat accounting type | IntStatRedovTypBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xistr Intrastat, accounting types


Intrastat, cost allocation types (xistk)

Definition of codes that control if and how invoice costs shall be included in the item value that is reported in Intrastat reporting.
The code also specifies how the invoice cost shall be allocated, according to weight, volume, or value, on the item rows included in an invoice.

The following standard records exist. Do not alter/delete:

Intrastat, allocation type (IntStatKostFordTyp) | Intrastat, allocation type (IntStatKostFordBeskr)
1 | Allocation by weight
2 | Allocation by volume
3 | Allocation by value

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Intrastat, allocation type | IntStatKostFordBeskr | ztString | 50 |  | varchar
Intrastat, allocation type | IntStatKostFordTyp | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xistk Intrastat, cost allocation types


Intrastat, cost factor statistical value export (x2fisk)

Table for entry of percentages used to calculate how large a part of freight and insurance costs in connection with export of goods is calculated to regard the transport from your own company to the border of your own country, and that shall be included in the statistical value that is reported for item records in connection with Intrastat reporting regarding export of goods.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost.factor %, stat.value | IntStatVardeKostFaktor | ztFloat | 5 | 2 | float
Country | LandsKod | ztString | 3 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Intrastat, cost factor statistical value import (xbsisk)

Table for entry of percentages used to calculate how large a part of freight and insurance costs in connection with import of goods is calculated to regard the transport from the supplier up to the border of your own country, and that shall be included in the statistical value that is reported for item records in connection with Intrastat reporting regarding import of goods.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Dispatch method | BestLevSattKod | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost.factor %, stat.value | IntStatVardeKostFaktor | ztFloat | 5 | 2 | float
Country | LandsKod | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Intrastat, definition of report period (istper)

Table for main records with definition of report period for Intrastat report.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Date for submission | InlamningsDatum | ztDate |  |  | datetime
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Number of records, sales | IntStatFsgAntPost | ZtLong | 10 |  | int
Inv value, sales | IntStatFsgFaktBel | ZtBaseCurrAmount | 14 | 2 | money
Net weight in kg, sales | IntStatFsgNtoVikt | ztFloat | 15 | 2 | float
Statistical value, sales | IntStatFsgStatBel | ZtBaseCurrAmount | 14 | 2 | money
Number of records, purchasing | IntStatInkAntPost | ZtLong | 10 |  | int
Inv value, purchasing | IntStatInkFaktBel | ZtBaseCurrAmount | 14 | 2 | money
Net weight in kg, purchasing | IntStatInkNtoVikt | ztFloat | 15 | 2 | float
Statistical value, purchasing | IntStatInkStatBel | ZtBaseCurrAmount | 14 | 2 | money
Intrastat accounting type | IntStatRedovTyp | ztInteger | 2 |  | smallint
Intrastat print.date | IntStatUtskrDat | ztDateTime |  |  | datetime
Version number | IntStatVersionNr | ZtLong | 3 |  | int
Version, subnumber | IntStatVersionSubNr | ztInteger | 5 |  | smallint
Period number | KalArPeriod | ztInteger | 4 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Period from date | PerFromDatum | ztDate |  |  | datetime
Period designation | PeriodBeskr | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Period to date | PerTomDatum | ztDate |  |  | datetime
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Resp submit, last name | UppgAnsvEfterNamn | ztString | 30 |  | varchar
Resp submit, first name | UppgAnsvForNamn | ztString | 30 |  | varchar
Resp submit, e-mail address | UppgAnsvMailAdress | ztString | 50 |  | varchar
Resp submit, fax | UppgAnsvTelefax | ztString | 20 |  | varchar
Resp submit, telephone | UppgAnsvTelefon | ztString | 20 |  | varchar

    This table is the main table in the following programs:

    Program: IntStat Intrastat report period and generation


Intrastat, log detail records (istdet)

Table for totals records per workgroup regarding export/import per report period for Intrastat reporting.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
TARIC code | ArtStatNr | ztString | 20 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Volume m3 | ArtVolym | ztFloat | 15 | 4 | float
Dispatch method | BestLevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | BestLevVilkKd | ztInteger | 2 |  | smallint
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Packaging BCU | EmballageKostnad | ZtBaseCurrAmount | 14 | 2 | money
Packaging inland, BCU | EmballageKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Packaging overs, BCU | EmballageKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Packaging import, BCU | EmbKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Intrastat, unit code | EnhetsKodIntraStat | ztString | 10 |  | varchar
Invc match cost, abroad | FaktAvprKostnUtland | ztMoney | 14 | 2 | money
Invoice match method | FaktAvprTypBest | ztInteger | 3 |  | smallint
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
RowNo. | FaktRadNr | ztInteger | 4 |  | int
Invc row amount | FaktRadSumma | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Insurance BCU | ForsakringsKostnad | ZtBaseCurrAmount | 14 | 2 | money
Insurance import, BCU | ForsakrKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Insurance inland, BCU | ForsakrKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Insurance overs, BCU | ForsakrKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Total freight BCU | FraktKostnDeb | ZtBaseCurrAmount | 14 | 2 | money
Freight import, BCU | FraktKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Freight inland, BCU | FraktKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Insurance overs, BCU | FraktKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purch OH type | InkOmkTyp | ztInteger | 5 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Other quantity | IntStatAnnanKvant | ztFloat | 15 | 2 | float
Invoiced value | IntStatFaktBel | ZtBaseCurrAmount | 14 | 2 | money
Identity no., Intrastat | IntStatIdentityNo | ZtLong | 10 |  | int
Intrastat, excl costs | IntStatKostExklKod | ztBoolean |  |  | char
Delivered quantity | IntStatLevAntal | ztFloat | 15 | 2 | float
Intrastat, delivery terms | IntStatLevVillkor | ztString | 3 |  | varchar
Net weight in kg | IntStatNettoVikt | ztFloat | 15 | 2 | float
Item record seq no. | IntStatPostNr | ZtLong | 5 |  | int
Intrastat, record type | IntStatPostTyp | ztInteger | 5 |  | smallint
Intrastat accounting type | IntStatRedovTyp | ztInteger | 2 |  | smallint
Intrastat, region | IntStatRegionCode | ztString | 10 |  | varchar
Statistical value | IntStatStatBel | ZtBaseCurrAmount | 14 | 2 | money
Intrastat trans type | IntStatTransTyp | ztInteger | 2 |  | smallint
Cost.factor %, stat.value | IntStatVardeKostFaktor | ztFloat | 5 | 2 | float
Version number | IntStatVersionNr | ZtLong | 3 |  | int
Version, subnumber | IntStatVersionSubNr | ztInteger | 5 |  | smallint
Period number | KalArPeriod | ztInteger | 4 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Country | LandsKod | ztString | 3 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Auto created OH row | OmkFordAutoRad | ztBoolean |  |  | char
Intrastat, conv.factor | OmvFaktorIntraStat | ZtDecimal73 | 14 | 5 | decimal
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Other inv. cost-1 BCU | OvrFaktKostnad1 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-2 BCU | OvrFaktKostnad2 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-1 inland, BCU | OvrFaktKostnInland1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 inland, BCU | OvrFaktKostnInland2 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-1 overs, BCU | OvrFaktKostnUtland1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 overs, BCU | OvrFaktKostnUtland2 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-1 import, BCU | OvrKostnImport1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 import, BCU | OvrKostnImport2 | ZtBaseCurrAmount | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Intrastat, transport method | TranspSattKod | ztInteger | 2 |  | smallint
Country of origin | UrsprungsLand | ztString | 3 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Row amt, curr | vb_FaktRadSumma | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: IntStatDet1 Intrastat, log item records sales

    Program: IntStatDet2 Intrastat, log item records purchase


Intrastat, regions (xistreg)

Definition of geographical regions within a country used to indicate region of origin for export and region of destination for import in the Intrastat report.
This is an optional information in the Intrastat report.
If it is used this table has to be filled with definitions of the geographical regions within current country and then the current region has to be indicated in the Inventory location record (table xb).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Intrastat, region | IntStatRegionCode | ztString | 10 |  | varchar
Intrastat, region | IntStatRegionDescr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: XistReg Intrastat, regions


Intrastat, total records per item class (istsum)

Table for totals records per item type regarding export/import per report period for Intrastat reporting.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
TARIC code | ArtStatNr | ztString | 20 |  | varchar
Packaging BCU | EmballageKostnad | ZtBaseCurrAmount | 14 | 2 | money
Packaging inland, BCU | EmballageKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Packaging overs, BCU | EmballageKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Packaging import, BCU | EmbKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Intrastat, unit code | EnhetsKodIntraStat | ztString | 10 |  | varchar
Invc row amount | FaktRadSumma | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Insurance BCU | ForsakringsKostnad | ZtBaseCurrAmount | 14 | 2 | money
Insurance import, BCU | ForsakrKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Insurance inland, BCU | ForsakrKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Insurance overs, BCU | ForsakrKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Total freight BCU | FraktKostnDeb | ZtBaseCurrAmount | 14 | 2 | money
Freight import, BCU | FraktKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Freight inland, BCU | FraktKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Insurance overs, BCU | FraktKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Other quantity | IntStatAnnanKvant | ztFloat | 15 | 2 | float
Invoiced value | IntStatFaktBel | ZtBaseCurrAmount | 14 | 2 | money
Identity no., Intrastat | IntStatIdentityNo | ZtLong | 10 |  | int
Delivered quantity | IntStatLevAntal | ztFloat | 15 | 2 | float
Intrastat, delivery terms | IntStatLevVillkor | ztString | 3 |  | varchar
Net weight in kg | IntStatNettoVikt | ztFloat | 15 | 2 | float
Item record seq no. | IntStatPostNr | ZtLong | 5 |  | int
Intrastat, record type | IntStatPostTyp | ztInteger | 5 |  | smallint
Intrastat accounting type | IntStatRedovTyp | ztInteger | 2 |  | smallint
Intrastat, region | IntStatRegionCode | ztString | 10 |  | varchar
Statistical value | IntStatStatBel | ZtBaseCurrAmount | 14 | 2 | money
Intrastat trans type | IntStatTransTyp | ztInteger | 2 |  | smallint
Version number | IntStatVersionNr | ZtLong | 3 |  | int
Version, subnumber | IntStatVersionSubNr | ztInteger | 5 |  | smallint
Period number | KalArPeriod | ztInteger | 4 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Country | LandsKod | ztString | 3 |  | varchar
Other inv. cost-1 BCU | OvrFaktKostnad1 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-2 BCU | OvrFaktKostnad2 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-1 inland, BCU | OvrFaktKostnInland1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 inland, BCU | OvrFaktKostnInland2 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-1 overs, BCU | OvrFaktKostnUtland1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 overs, BCU | OvrFaktKostnUtland2 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-1 import, BCU | OvrKostnImport1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 import, BCU | OvrKostnImport2 | ZtBaseCurrAmount | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Intrastat, transport method | TranspSattKod | ztInteger | 2 |  | smallint
Country of origin | UrsprungsLand | ztString | 3 |  | varchar


Intrastat, transaction types (xistt)

Definition of different transaction types for reporting in the Intrastat report, if used.

These are specified by the user according to the standard Intrastat transaction types, with either 1 character (column A only) or 2 characters (column A and B) depending on what detail level is being applied.

Example:
1 = Transactions that regard transfer of legal ownership against payment

OR if 2 characters:
11 = Purchase/sale against payment

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Intrastat trans type | IntStatTransTyp | ztInteger | 2 |  | smallint
Intrastat transaction type | IntStatTransTypBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xistt Intrastat, transaction types


Inventory balance group (InvLocBalanceGrp)

Inventory balance group.
Used for totaling inventory balance on questionnaire.
If an item is kept at several inventory locations, you can group the inventory locations so that you obtain balance by group.
An inventory location group can be a sales inventory, a separate service inventory, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inv balance grp | InvBalanceGrpDescr | ztString | 80 |  | varchar
Invtry loc group | LagStalleGrupp | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: InvLocBalanceGrp Inventory location balance group


Inventory cost price group (InvLocCostPriceGrp)

Grouping of inventory locations for common calculation of average cost price or standard cost price.
All inventory locations with the same code are processed together.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inv loc cost price grp | InvLocCostPriceGrp | ztString | 8 |  | varchar
Inv loc cost price grp | InvLocCostPriceGrpDescr | ztString | 80 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: InvLocCostPriceGrp Inventory cost price groups


Inventory issuer per entry journal type, inventory trans (xljlp)

Definition of inventory supervisor issuer that applies per type of entry journal for inventory transactions.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Ent.journ type, inv trans | RegJournalLagerTyp | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Inventory supervisor, issuer | UtfLagerAnsvSign | ztString | 6 |  | varchar


Inventory items VIEW (var)

Information of items, i.e. the physical products, that are for sale or used in manufacturing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Consists of, no. of items | AntBestarAvSr | ZtLong | 5 |  | int
Decimal places | AntDec | ztInteger | 1 |  | smallint
ComponentQty | AntIngarISr | ZtLong | 5 |  | int
No. of operations | AntOp | ztInteger | 3 |  | smallint
Item description | ArtBeskr | ztString | 30 |  | varchar
Item descr 2 | ArtBeskr2 | ztString | 255 |  | varchar
Specification | ArtBeskrSpec | ztString | 30 |  | varchar
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Sales price date | ArtFPrisDat | ztDate |  |  | datetime
Item Creation date | ArtInlDat | ztDate |  |  | datetime
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost prc date | ArtKalkDat | ztDate |  |  | datetime
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Item class | ArtKod | ztInteger | 3 |  | smallint
List price | ArtListPris | ZtBaseCurrAmount | 14 | 2 | money
Material cost total | ArtMatKost | ZtBaseCurrAmount | 14 | 2 | money
Assembly time | ArtMontTid | ztFloat | 7 | 2 | float
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
Artikelnivå | ArtNivaKod | ztString | 1 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Product class | ArtProdKlass | ztString | 4 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Last PYR date | ArtPyrDat | ztDateTime |  |  | datetime
Item discount class | ArtRabKlass | ztInteger | 3 |  | smallint
Revision date | ArtRevDat | ztDate |  |  | datetime
Revision no. | ArtRevId | ztString | 10 |  | varchar
Revision signature | ArtRevSign | ztString | 6 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Service level code | ArtServKod | ztInteger | 2 |  | smallint
TARIC code | ArtStatNr | ztString | 20 |  | varchar
Uppsk kostn | ArtUpps | ZtBaseCurrAmount | 8 | 2 | money
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Viktighetskod | ArtViktighetKod | ztInteger | 1 |  | smallint
Volume m3 | ArtVolym | ztFloat | 15 | 4 | float
Batch no. required | BatchBokas | ztBoolean |  |  | char
Model | BVariant | ztInteger | 4 |  | smallint
Diameter | Diam | ztInteger | 4 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Scrap factor in % | KassAr | ztFloat | 5 | 2 | float
Stocked | LagerBokas | ztBoolean |  |  | char
Inventory stock type | LagTyp | ztInteger | 2 |  | smallint
Length | Length | ztFloat | 4 | 2 | float
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Change package qty->det | PackageItemQty2Det | ztBoolean |  |  | char
Package item | PaketArtikel | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Serial no. required | SerieNrBokas | ztBoolean |  |  | char
Original item no. | UrsprArtNr | ztString | 30 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: ArSrPDM Items' PDM connections

    Program: ArTis Change drawing -> MO


Inventory journal (jlth)

Posting journal for manual inventory transactions.
A voucher is created for each journal.
If a manual inventory transaction is not given a voucher number when run from the arsm table, possibly due to an error in the integration details, you can re-run the update of the inventory journal from here (report b) once the error has been rectified.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Transaction date | LagTransDatum | ztDate |  |  | datetime
Invtry trans journal no. | LthJournNr | ZtLong | 6 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Transfer date | VtVrUpdat | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: JLth Inventory transaction journal


Inventory loc, periods (lper)

Table showing current inventory locations and statistical periods.
Used as an order/start window for various period batches for inventory management etc..
For those interested...
This is not a proper table but a database view between inventory locations and periods.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: lper Inventory loc, periods


Inventory location definition (WMS_LagStalleDef)

Definition of parameters to control how WMS inventory locations should be handled in the WMS module. You can only define parameters for inventory locations that have been flagged as WMS inventory locations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inherit SKU ID | LagDefInheritSKUId | ztBoolean |  |  | char
Create operative log | LagDefOpLog | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Returns, subtract (days) | ReturnsFifoSubtractDays | ztInteger | 5 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_LagStalleDef Inventory location definition


Inventory location groups (lstg)

Definition of inventory location groups, of grouping with respect to planning, e.g. if several inventory locations make joint plans and purchases.

Inventory location groups are used in certain query programs and in a special program to create purchase proposals by inventory location group.

Inventory location groups are not used in MPC or for automatic customer order processing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
This field is used in the table as follows: |
Invtry loc group | LagStalleGrupp | ztString | 8 |  | varchar
Invtry loc group | LagStalleGruppBeskr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Percentage | Procent | ZtDecimal73 | 7 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: lstg Inventory location groups


Inventory location statistics (sxb)

Statistics per inventory location.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Period invoiced qty | PerFaktAnt | ZtQty | 14 | 2 | decimal
Per försenade inl | PerForsenInLev | ZtQty | 14 | 2 | decimal
Per försenade utlev | PerForsenUtLev | ZtQty | 14 | 2 | decimal
Per avg inventory bal | PerGenomsnittsLager | ztFloat | 15 | 2 | float
Period | Period | ztInteger | 4 |  | smallint
Per closing invtry bal | PeriodLagSaldo | ZtQty | 14 | 2 | decimal
Lager*dagar | PerLagerGgrDagar | ZtQty | 14 | 2 | decimal
Per inventory turnover | PerLagOmsHast | ztFloat | 15 | 2 | float
Per order intake qty | PerOrderIng | ZtQty | 14 | 2 | decimal
Per utg ord.stock ant | PerOrderStock | ZtQty | 14 | 2 | decimal
Period rcvd deliveries | PerTotInlev | ZtQty | 14 | 2 | decimal
Period dispatches | PerTotUtlev | ZtQty | 14 | 2 | decimal
Per closing bal (FIFO) | PerUtgLagVardeFifo | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (cost) | PerUtgLagVardeKalk | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (repl) | PerUtgLagVardeSink | ZtBaseCurrAmount | 14 | 2 | money
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar


Inventory location type (xby)

Table of inventory location types, which are used for purchases to define inventory posting, depending on whether the item is ordered for drop shipment or for inventory.

The following standard records exist. Do not alter/delete:

Inventory location type (lagStTyp) | Inventory location type (lagStTypB) | Description
0 | Std inventory location | (Refers to own inventory.)
1 | External supplier | Means that all reservations on this inventory location will involve purchasing from the supplier specified for the inventory location. THIS INVENTORY LOCATION TYPE IS NOT CURRENTLY USED IN STANDARD VERSIONS OF JEEVES.
3 | Supplier within the corporatio |
5 | Posting inventory loc | Means that the inventory location is only used for definition of posting rules for inventory posting. The posting inventory location to be used can be specified on the purchase order type. This way, the same item can be posted differently depending on whether it is a drop shipment or purchase for restocking, for example. Can today only be used with regard to purchasing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location type | lagStTyp | ztInteger | 2 |  | smallint
Inventory location type | lagStTypB | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xby Invtry loc types


Inventory locations (xb)

Definition of the company's inventory locations. An inventory location is normally an area where inventory is kept, but it can also be set up to handle several sales points, service inventories, etc. within the same area.

The inventory location code can also be used to control sales and inventory postings via posting templates. The internal accounting terms Account segment 2-4 (cost centre, cost unit, etc.) can also be taken from the inventory location.

The inventory balance of an item is shown per inventory location. Item statistics are also shown per inventory location.

Inventory location 0, Main inventory is standard but can be changed.

Grouping
---------------
Inventory locations can also be grouped into inventory location groups. These are used in certain query programs.

Division
-------------
Inventory locations can be divided into bins or inventory positions (in the program arsh) and specific batch numbers (in the program bat).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Shortage tol, days | AnmEjAtgTolDgr | ztInteger | 5 |  | smallint
Excess invtry ctrl | AnmodanOverlagerEnl | ztInteger | 5 |  | smallint
- Replan.horizon | AnmodanTolDgrMinus | ztInteger | 5 |  | smallint
+Replan.horizont | AnmodanTolDgrPlus | ztInteger | 5 |  | smallint
Acq to order point | AnskaffningBestp | ztBoolean |  |  | char
Purchased | AnskaffningKop | ztBoolean |  |  | char
Acq to requirement | AnskaffningMotBehov | ztBoolean |  |  | char
Acquired via MRP run | AnskaffningNettobehov | ztBoolean |  |  | char
Acq to plan | AnskaffningPlanering | ztBoolean |  |  | char
Acquisition method | Anskaffningssatt | ztInteger | 2 |  | smallint
Manufactured | AnskaffningTillv | ztBoolean |  |  | char
Average cost prc (inv.loc.grp) | ArtKalkSnittLstGrupp | ztString | 8 |  | varchar
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Posting template, advance | AutoRegelForskott | ztString | 4 |  | varchar
Round EOQ down to pkg. | AvrEokNerTillForp | ZtDecimal73 | 8 | 3 | decimal
Round EOQ up to pkg. | AvrEokUppTillForp | ZtDecimal73 | 8 | 3 | decimal
Purch auto-create invtry | BestAutoCreateARS | ztBoolean |  |  | char
Bin ID required | BinLocMustEnter | ztBoolean |  |  | char
Bin rule | BinLocRule | ztInteger | 2 |  | smallint
Code fixed departure | CodeFixedDeparture | ztBoolean |  |  | char
Database connection for ICT | Database4InventoryLoc | ztString | 120 |  | varchar
Database schema for ICT | DBSchema4InventoryLoc | ztString | 120 |  | varchar
Def PO priority | DefItmPOPriority4InvLoc | ztInteger | 5 |  | smallint
Delivery from business unit ICT | DelivFromBusinessUnit | ztString | 8 |  | varchar
Availability check | DispCheckAtOrder | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company name | FtgNamn | ztString | 36 |  | varchar
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Inventory acc to ICT | ICTInvLoc4InvPlanList | ztBoolean |  |  | char
Order type ICT | ICTOrderType | ztInteger | 3 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Internal CoNo, inv transfer | InternKundNr | ztCompanyNo | 20 |  | varchar
Company ID for ICT | IntrnCoNo4InventoryLoc | ztInteger | 5 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Intrastat, region | IntStatRegionCode | ztString | 10 |  | varchar
Inventory location for ICT | InventoryLoc4InventoryLoc | ztString | 16 |  | varchar
Inventory location Astro | InventoryLocAstro | ztBoolean |  |  | char
Inventory location WMS | InventoryLocWMS | ztBoolean |  |  | char
Inv loc cost price -> item | InvLocCostPrice2Item | ztBoolean |  |  | char
Inv loc cost price grp | InvLocCostPriceGrp | ztString | 8 |  | varchar
Invtry loc group for ICT | InvtryLocGrp4InvtryLocGrp | ztString | 8 |  | varchar
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Package no. (alpha), prefix | KolliNrAlfaPrefix | ztString | 30 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Cost centre (elim) | KostStalleKodEliminera | ztString | 8 |  | varchar
Stock build-up in days | LagerUppbyggnadIDagar | ztInteger | 5 |  | smallint
Inventory location | LagPlatsNamn | ztString | 50 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry loc group | LagStalleGrupp | ztString | 8 |  | varchar
Lagerst för lev.order | LagStalleLevOrder | ztString | 2 |  | varchar
Lagerst för OU-lager | LagStalleOULager | ztString | 2 |  | varchar
Inventory location type | lagStTyp | ztInteger | 2 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Linked server for ICT | LinkedServer4InventoryLoc | ztString | 120 |  | varchar
In MRP runs all invtry loc | NE_Behandlas_Vid_Alla_Lst | ztBoolean |  |  | char
Re-plan or new order | NE_OmplanEllerNyOrder | ztInteger | 5 |  | smallint
Rule for last NE proposal | NE_RegelSistaForslag | ztInteger | 5 |  | smallint
PO/inventory location | OrderTillBestNyBestLst | ztString | 4 |  | varchar
Delivery addr, company | OrdLevAdr1 | ztString | 36 |  | varchar
Delivery address 1 | OrdLevAdr2 | ztString | 36 |  | varchar
Delivery address 2 | OrdLevAdr3 | ztString | 36 |  | varchar
Delivery address 3 | OrdLevAdr4 | ztString | 36 |  | varchar
A n v ä n d s e j !! | OrdLevAdr5 | ztString | 1 |  | varchar
Destination, district | OrdLevAdrBstOrt | ztString | 36 |  | varchar
Destination, country | OrdLevAdrLandsKod | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Region of destination | RegionOfDestCode | ztString | 10 |  | varchar
Får reserveras | ResAllowed | ztBoolean |  |  | char
Order auto-create invtry | ResAutoCreateARS | ztBoolean |  |  | char
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Created UTC date/time | RowCreatedUTCDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowupdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Updated date/time | RowUpdatedUTCDT | ztDateTime |  |  | datetime
Same acq method as item | SameAcquisitionMethodAsItem | ztBoolean |  |  | char
Same cost price as item | SammaKalkPSomArt | ztBoolean |  |  | char
End date of holiday | SemesterSlutDatum | ztDate |  |  | datetime
Start date of holiday | SemesterStartDatum | ztDate |  |  | datetime
Shipm plan alpha prefix | ShipmPlanAlphaPrefix | ztString | 10 |  | varchar
Shipment plan no start | ShipmPlanNoStart | ZtLong | 9 |  | int
To bin no. | TillLagPlats | ztBinLocation | 20 |  | varchar
Time zone code | TimeZoneCode | ztInteger | 4 |  | smallint
Update item forecast | upd_arpr_invcontrol | ztBoolean |  |  | char
Update item record | Upd_Ars | ztBoolean |  |  | char
Show balance on web | WEB_WH_InvtBal_2_Item | ztBoolean |  |  | char
Balance totalled to item | WH_InvtBal_2_Item | ztBoolean |  |  | char
Phone | xb_ComNr | ztString | 20 |  | varchar
Dispatch location | xb_FtgAvsOrt | ztString | 35 |  | varchar
Dispatch address | xb_FtgNamn | ztString | 36 |  | varchar
c/o delivery address | xb_FtgPostAdr1 | ztString | 36 |  | varchar
Dispatch addr 2 | xb_FtgPostAdr2 | ztString | 36 |  | varchar
Dispatch address 3 | xb_FtgPostAdr3 | ztString | 36 |  | varchar
Dispatch ZIP/Post code | xb_FtgPostNr | ztString | 8 |  | varchar
@zPrompt=null | xbUpdFlag | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: rSy1Ar1 Cost price calc (pyramidic)

    Program: xxb Inventory locations


Inventory locations (view) (viewxb)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Inventory location Astro | InventoryLocAstro | ztBoolean |  |  | char
Inventory location WMS | InventoryLocWMS | ztBoolean |  |  | char
Package no. (alpha), prefix | KolliNrAlfaPrefix | ztString | 30 |  | varchar
Inventory location | LagPlatsNamn | ztString | 50 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry loc group | LagStalleGrupp | ztString | 8 |  | varchar
Lagerst för lev.order | LagStalleLevOrder | ztString | 2 |  | varchar
Lagerst för OU-lager | LagStalleOULager | ztString | 2 |  | varchar
Inventory location type | lagStTyp | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Inventory locations (view) (vwxb)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Package no. (alpha), prefix | KolliNrAlfaPrefix | ztString | 30 |  | varchar
Inventory location | LagPlatsNamn | ztString | 50 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry loc group | LagStalleGrupp | ztString | 8 |  | varchar
Lagerst för lev.order | LagStalleLevOrder | ztString | 2 |  | varchar
Lagerst för OU-lager | LagStalleOULager | ztString | 2 |  | varchar
Inventory location type | lagStTyp | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Inventory receiver per entry journal type, inventory trans (xljlm)

Definition of inventory supervisor recipient that applies per type of entry journal for inventory transactions.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory supervisor, receiver | MottLagerAnsvSign | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Ent.journ type, inv trans | RegJournalLagerTyp | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Inventory stock types (xz)

Definition of existing inventory stock types which determine specific processing of items, such as
- if the item is stocked,
- if the item requires a batch number,
- if the item requires a serial number,
- if the item is a package item,
etc.

The following inventory stock types are supplied as proposals, but they can be changed/added to:
0 = Stocked, normal item in inventory
1 = Not stocked. Used for purchases for order specific orders, for example
3 = Stocked by series. The user must enter a serial number for dispatch
4 = Stocked in batches. The user must enter a batch number
5 = Automatic invoicing. For packages and the like. Items are released automatically
7 = Fictitious. An item that is never sold or stocked, but is simply used to collect items in one BOM
8 = Consumables. For purchasing items that are NOT sold, such as office supplies. Inventory balance and value are not created
9 = Package. Items that contain a number of other items and which are not normally stocked. Normally, the items that make up the package are stocked.
10 = Serial no., mandatory. A serial number must be entered upon delivery and shipping
17 = Stocked, further explosion. Indication of whether the item should be further broken down on the same manufacturing order

It is not the inventory stock code itself that controls the processing. This is done by control codes that you fill in for each inventory stock type. This allows you to also enter your own inventory stock types and set up the controls that you desire. You can also have several inventory stock types with the exact same control, but with different designations that you can use as search terms for querying items.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Automatic release | AutoFrislappas | ztBoolean |  |  | char
Auto breakdown within MO | AutoVidareNedbrInomTo | ztBoolean |  |  | char
Batch no. required | BatchBokas | ztBoolean |  |  | char
Batch bkg, not mandatory | BatchBoknEjKrav | ztBoolean |  |  | char
Fictitious item | FiktivArtikel | ztBoolean |  |  | char
Consumables | ForbrukningsMaterial | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Stocked | LagerBokas | ztBoolean |  |  | char
Layer | LagLayer | ztInteger | 2 |  | smallint
Inventory stock type | LagTyp | ztInteger | 2 |  | smallint
Inventory stock type | LagTypBeskr | ztString | 50 |  | varchar
Dispatch type, package | PackageDelivCode | ztInteger | 1 |  | smallint
Package on picking list | PackageItemOnPickList | ztBoolean |  |  | char
Change package qty->det | PackageItemQty2Det | ztBoolean |  |  | char
Package, create 0 details | PackageItemZero | ztBoolean |  |  | char
Package item | PaketArtikel | ztBoolean |  |  | char
Package item as order template | PaketOrdRegMall | ztBoolean |  |  | char
Package template row, cancel | PaketOrdRegMallAnnull | ztBoolean |  |  | char
Package, ord reg.template qty=0 | PaketOrdRegMallAntNoll | ztBoolean |  |  | char
Order reg template, type | PaketOrdRegMallTyp | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Pkg+details on picking list | PkgAndDetailOnPickList | ztBoolean |  |  | char
Package item controls discounts | PkgItemDiscnt2Detail | ztBoolean |  |  | char
Rule to def batch ID | RecDelivBatIdRule | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Serial no. at receiving | serialnoilev | ztBoolean |  |  | char
Serial no., quantity=1.0 | SerialNoItemOne | ztBoolean |  |  | char
Serial no., unique | SerialNoUnique | ztBoolean |  |  | char
Serial no. required | SerieNrBokas | ztBoolean |  |  | char
Service | ServiceItem | ztBoolean |  |  | char
Print on delivery note | UtskrFoljesedel | ztBoolean |  |  | char
Print on picking list | UtskrPlocklista | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: Xxz Inventory stock types


Inventory trans types per entry journal type, inventory trans (xljlt)

Definition of inventory supervisor preparer that applies per type of entry journal for inventory transactions.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Default inv trans.type | DefaultLagTransTyp | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Ent.journ type, inv trans | RegJournalLagerTyp | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Inventory trans->general ledger: Log on changes (akll)

Detailed information per transaction of how inventory transactions are posted when integrated with the general.
Log of all changes!!!

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIdentity | ZtLong | 10 |  | int
Date/time | StrDateTime | ztString | 28 |  | varchar

    This table is the main table in the following programs:

    Program: xAkll Log inventory/accounting integration


Inventory trans->GL (ltvt)

Detailed information per transaction of how manual inventory transactions are posted when integrated with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Identitetskolumn | ConnToSQLIDENTITY | ZtLong | 10 |  | int
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Document ID | docnumid | ztString | 30 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Assembly journ no. | JournNrIULT | ZtLong | 5 |  | int
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Inventory location | LagStalle | ztString | 2 |  | varchar
Transaction date | LagTransDatum | ztDate |  |  | datetime
Invtry trans. origin | LagTransSource | ztInteger | 3 |  | smallint
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Invtry trans journal no. | LthJournNr | ZtLong | 6 |  | int
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Date/time | StrDateTime | ztString | 28 |  | varchar
UniqueIDInAKFT | UniqueIDInAKFT | ZtLong | 10 |  | int
UniqueIDInAKLT | UniqueIDInAKLT | ZtLong | 10 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: ltvt Inventory posting log


Inventory trans->GL (lavt)

Detailed information per transaction of how manual inventory transactions are posted when integrated with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Document ID | docnumid | ztString | 30 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Invtry transaction journal no | JlJournNr | ZtLong | 6 |  | int
Assembly journ no. | JournNrIULT | ZtLong | 5 |  | int
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
UniqueIDInAKLT | UniqueIDInAKLT | ZtLong | 10 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint


Inventory transaction history (lth)

History of all transactions that affect the inventory value by inventory movements and price changes.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Quantity | Antal | ZtQty | 14 | 2 | decimal
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Cost change journal | ArskJournNr | ZtLong | 6 |  | int
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Cost price at order | ArtKalkPrisO | ZtBaseCurrAmount | 14 | 2 | money
Cost at order (mtrl) | ArtKalkPrisOMtrl | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Batch balance | BatchSaldo | ZtQty | 14 | 2 | decimal
Delivery note date, rcv | BestFoljesedelsDat | ztDate |  |  | datetime
Delivery note no., rcv | BestFoljesedelsNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Purch order no. (alpha) | BestNrAlfa | ztString | 50 |  | varchar
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
PO/receiving journal no. | BpiJournNr | ZtLong | 10 |  | int
Purchase price budget | BudgInPris | ZtBaseCurrAmount | 14 | 2 | money
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Identitetskolumn | ConnToSQLIDENTITY | ZtLong | 10 |  | int
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Delivery from business unit ICT | DelivFromBusinessUnit | ztString | 8 |  | varchar
Delivery to business unit | DelivToBusinessUnit | ztString | 8 |  | varchar
Diff when backdating | DiffAmtBackDateStockTran | ZtBaseCurrAmount | 14 | 2 | money
Changed inventory value | DiffLagVarde | ZtBaseCurrAmount | 14 | 2 | money
Drop ship | DirektLeverans | ztBoolean |  |  | char
Document ID | docnumid | ztString | 30 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Delivery note date | FfhDate | ztDate |  |  | datetime
Subsystem | FfhInt | ztInteger | 2 |  | smallint
Delivery note/disp no. | FfhNr | ZtLong | 10 |  | int
Delivery note no. (alpha) | FfhNrAlfa | ztString | 30 |  | varchar
RowNo | FfhRadNr | ztInteger | 5 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Reason code | FsOrsakKod | ztInteger | 5 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
From backorder no. ICT | ICTDelivFromBackOrderNo | ztInteger | 5 |  | smallint
From order no. ICT | ICTDelivFromOrderNo | ZtLong | 10 |  | int
From order row no. ICT | ICTDelivFromOrdLnNo | ztInteger | 5 |  | smallint
From order row no. for pkg ICT | ICTDelivFromOrdSubLnNo | ztInteger | 5 |  | smallint
Backorder.no. ICT | ICTDelivToPOBackOrderNo | ztInteger | 5 |  | smallint
Purchase order row no. ICT | ICTDelivToPOLnNo | ztInteger | 5 |  | smallint
Purchase order no. ICT | ICTDelivToPONo | ZtLong | 10 |  | int
Receive to MO | InlevTillAoNr | Jeeves_MONo | 7 |  | bigint
Receive to MO Pos | InlevTillAoPos | ztInteger | 4 |  | int
Receive to MO Op | InlevTillOpNr | ztInteger | 3 |  | smallint
Rcvd deliv f CO no. | InlevTillOrderNr | Jeeves_SONo | 20 |  | bigint
Rcvd deliv f order row no. | InlevTillOrdRadNr | ztInteger | 5 |  | int
Rcvd deliv f CO row BOM | InlevTillOrdRadNrStrPos | ztInteger | 5 |  | int
Rcvd deliv f backorder no. | InlevTillOrdRestNr | ztInteger | 5 |  | smallint
Exg rate on order date | InValKurs | ZtCurrencyRate | 15 | 7 | decimal
Purch price curr | InValuta | ztString | 3 |  | varchar
Inventory location WMS | InventoryLocWMS | ztBoolean |  |  | char
Phys invtry journ no. | InvJournal | ZtLong | 5 |  | int
Invtry transaction journal no | JlJournNr | ZtLong | 6 |  | int
Adjust. of recvd cost with inv. chk. | JustAvInlevMedFaktAvpr | ztBoolean |  |  | char
Adjustment value average price | JustVardeSnittPrisBer | ZtBaseCurrAmount | 14 | 2 | money
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Inventory value, cost price | KalkLagerVarde | ZtBaseCurrAmount | 14 | 2 | money
Invtry value, material price | KalkLagerVardeMtrl | ZtBaseCurrAmount | 14 | 2 | money
Average weighted | KalkylPrisEnlSnittPris | ztBoolean |  |  | char
To be posted | Konteras | ztBoolean |  |  | char
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Stocked | LagerBokas | ztBoolean |  |  | char
Invtry trans date | LagerDatum | ztDate |  |  | datetime
Inventory transfer | LagerFlyttning | ztBoolean |  |  | char
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Lagerst för OU-lager | LagStalleOULager | ztString | 2 |  | varchar
Inventory location type | LagStTyp | ztInteger | 2 |  | smallint
Invtry trans qty (+/-) | LagTransAntal | ZtQty | 14 | 2 | decimal
Quantity, alt unit (+/-) | LagtransAntAltEnh | ZtQty | 14 | 2 | decimal
Invtry trans. origin | LagTransSource | ztInteger | 3 |  | smallint
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Delete invtry trans | LthDelete | ztBoolean |  |  | char
Invtry trans journal no. | LthJournNr | ZtLong | 6 |  | int
FIFO | Mark_FIFO | ztBoolean |  |  | char
LIFO | Mark_LIFO | ztBoolean |  |  | char
Inventory effect | MarkIfQty2Stock | ztBoolean |  |  | char
Ord spec cost price | MarkOrderUniktKalkP | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Material journal no. | MruJournNr | ZtLong | 6 |  | int
Actual mtrl cost (adjust) | MtrlVerklKostJustering | ZtBaseCurrAmount | 14 | 2 | money
Prev cost price BCU | OldArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order no. (alpha) | OrderNrAlfa | ztString | 50 |  | varchar
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Picking journal no. | OruJournNr | ZtLong | 10 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | nvarchar
Picking list no. | PlockJnrOrder | ZtLong | 10 |  | int
Doc. printed | printed | ztBoolean |  |  | char
Project ID | ProjCode | ztString | 10 |  | varchar
Season | PVMSeasonId | ztString | 15 |  | varchar
Rec delivery from WMS | RecDelivFromWMS | ztBoolean |  |  | char
Mtrl OH rec delivery | RecvMtrlOverheadCost | ZtCost | 16 | 6 | float
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Ent journal alpha ID | RegJournalLagerAlfaId | ztString | 30 |  | varchar
Ent.journal inventory code | RegJournalLagerKod | ztInteger | 5 |  | smallint
Ent.journ no., inv trans | RegJournalLagerNr | ZtLong | 9 |  | int
Ent.journ type, inv trans | RegJournalLagerTyp | ztInteger | 2 |  | smallint
Returned qty invtry unit | ReturAnt | ZtQty | 14 | 2 | decimal
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Serv.order no | ServOrderNr | Jeeves_SONo | 9 |  | bigint
Order row, service | ServOrdRadNr | ztInteger | 5 |  | int
Shipment plan alpha ID | ShipmPlanAlphaid | ztString | 30 |  | varchar
Process ID | Spid | ZtLong | 5 |  | int
Identity | SqlIdentity | ZtLong | 10 |  | int
Historical cost invc row | StatistikRadKostnad | ZtBaseCurrAmount | 14 | 2 | money
Recalculated value | StockTranRecalcValue | ZtBaseCurrAmount | 14 | 2 | money
Man trans rec/del | StockTranTypeStat | ztInteger | 5 |  | smallint
Date/time | StrDateTime | ztString | 28 |  | varchar
Manufacturing journal | TiiJournNr | ZtLong | 6 |  | int
Transit delivery | TransitLeverans | ztBoolean |  |  | char
Source | ulbpTyp | ztString | 2 |  | varchar
UniqueIDInAKLT | UniqueIDInAKLT | ZtLong | 10 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Cost price, curr | VbKalkPris | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint
Transfer date | VtVrUpdat | ztDate |  |  | datetime
ID number | X_IdNr | ZtLong | 10 |  | int
ID row | X_IdRad | ZtLong | 10 |  | int
ID row sub-row | X_IdSubRad | ZtLong | 10 |  | int
Journal No | X_Journal | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: Lth2GL Inventory transactions->GL

    Program: xLth Inventory transaction history


Inventory transaction history (VIEW) (vlth)

History of all transactions that affect the inventory value by inventory movements and price changes.
*** THIS IS A VIEW OF THE LTH TABLE ***

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Cost price at order | ArtKalkPrisO | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
Purchase price budget | BudgInPris | ZtBaseCurrAmount | 14 | 2 | money
Changed inventory value | DiffLagVarde | ZtBaseCurrAmount | 14 | 2 | money
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Receive to MO | InlevTillAoNr | Jeeves_MONo | 7 |  | bigint
Receive to MO Pos | InlevTillAoPos | ztInteger | 4 |  | int
Receive to MO Op | InlevTillOpNr | ztInteger | 3 |  | smallint
Rcvd deliv f CO no. | InlevTillOrderNr | Jeeves_SONo | 20 |  | bigint
Rcvd deliv f order row no. | InlevTillOrdRadNr | ztInteger | 5 |  | int
Rcvd deliv f CO row BOM | InlevTillOrdRadNrStrPos | ztInteger | 5 |  | int
Rcvd deliv f backorder no. | InlevTillOrdRestNr | ztInteger | 5 |  | smallint
Purch price curr | InValuta | ztString | 3 |  | varchar
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Average weighted | KalkylPrisEnlSnittPris | ztBoolean |  |  | char
To be posted | Konteras | ztBoolean |  |  | char
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Stocked | LagerBokas | ztBoolean |  |  | char
Invtry trans date | LagerDatum | ztDate |  |  | datetime
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Lagerst för OU-lager | LagStalleOULager | ztString | 2 |  | varchar
Inventory location type | LagStTyp | ztInteger | 2 |  | smallint
Invtry trans qty (+/-) | LagTransAntal | ZtQty | 14 | 2 | decimal
Invtry trans. origin | LagTransSource | ztInteger | 3 |  | smallint
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Invtry trans journal no. | LthJournNr | ZtLong | 6 |  | int
FIFO | Mark_FIFO | ztBoolean |  |  | char
LIFO | Mark_LIFO | ztBoolean |  |  | char
Ord spec cost price | MarkOrderUniktKalkP | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Prev cost price BCU | OldArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order no. (alpha) | OrderNrAlfa | ztString | 50 |  | varchar
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Process ID | Spid | ZtLong | 5 |  | int
Historical cost invc row | StatistikRadKostnad | ZtBaseCurrAmount | 14 | 2 | money
Date/time | StrDateTime | ztString | 28 |  | varchar
Source | ulbpTyp | ztString | 2 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Cost price, curr | VbKalkPris | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint
Transfer date | VtVrUpdat | ztDate |  |  | datetime
ID number | X_IdNr | ZtLong | 10 |  | int
ID row | X_IdRad | ZtLong | 10 |  | int
ID row sub-row | X_IdSubRad | ZtLong | 10 |  | int


Inventory transaction journal, manual transactions (jl)

Posting journal for manual inventory transactions.
A voucher is created for each journal.
If a manual inventory transaction is not given a voucher number when run from the arsm table, possibly due to an error in the integration details, you can re-run the update of the inventory journal from here (report b) once the error has been rectified.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Invtry transaction journal no | JlJournNr | ZtLong | 6 |  | int
Transaction date | LagTransDatum | ztDate |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Ent journal alpha ID | RegJournalLagerAlfaId | ztString | 30 |  | varchar
Ent.journal inventory code | RegJournalLagerKod | ztInteger | 5 |  | smallint
Ent.journ no., inv trans | RegJournalLagerNr | ZtLong | 9 |  | int
Ent.journ type, inv trans | RegJournalLagerTyp | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: xJl Inventory transaction journal, manual transactions


Inventory transaction sources (xlth)

Table of inventory transaction sources, used with information on how each type of transaction is to be posted.

The following standard records exist. Do not alter/delete:

Invtry trans. origin (LagTransSource) | Invtry trans. origin (lagTransSourceBeskr)
10 | Customer orders
20 | Material issue for manufacturing
22 | Material issue for assembly
50 | Transfer between inventory locations
80 | Phys inventory
90 | Cost price change
110 | Purchase/order
120 | Received from MO
180 | Manual transactions
190 | Enter new inventory bal
210 | Manual issue service

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
To be posted | Konteras | ztBoolean |  |  | char
Invtry trans. origin | LagTransSource | ztInteger | 3 |  | smallint
Invtry trans. origin | lagTransSourceBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xXlth Inventory transaction sources


Inventory transaction types (xlt)

Definition of inventory transaction types that are used to enter inventory movements. An underlying program node also contains links to posting templates.

In addition to Jeeves standard transaction types you can set up your own types as required, suitably at a much higher number series, such as 900-999.

Several inventory transaction types can refer to the same transaction source but specify different entry methods, etc. Example: For transaction source 80, Physical inventory, the inventory transaction types 80 (+ quantity) and 81 (- quantity) exist.

The following standard records exist. Do not alter/delete:

Invtry trans. type (LagTransTyp) | Invtry trans. type (LagTransBeskr) | Description
0 | Default inventory posting | Fictitious inventory transaction type that can be used if no posting rule is defined for the inventory transaction type in question (10-120).
10 | Issue for CO | You can define how inventory issue for customer orders will be posted in the sales module (described in a separate chapter on posting in the documentation for the sales module) or in the inventory module. The definition in the sales module is used first. Applicable integration detail: 0 = inventory account (credit) Counter booking of the cost of sold goods is done according to the rules for posting of customer invoices
20 | Mtrl issue, manufacturing | Applicable integration detail: 0 = Inventory account (credit If control parameter MANUF051 is changed to N: 5 = WIP account If control parameter MANUF051 is changed to N, counter-booking is defined by WIP account on inventory transaction type 120
22 | Mtrl issue, assembly | Refers to inventory issue for simple assembly without manufacturing orders in the program 'Inventory issues, assembly/BOM' (xIult). Applicable integration detail: 0 = Inventory account (credit) Counter booking of PIP accounts is defined for inventory transaction type 120
50 | Transfer between invtry locations | Refers to transfer between inventory locations in the order routine. Applicable integration details: 0 = Inventory account (credit) 1 = Contra account... e.g. inventory change account
80 | Physical inventory (+qty) | Applicable integration details: 0 = Inventory account 1 = Contra account... i.e. physical inventory difference account
81 | Physical inventory (-qty) | Applicable integration details: 0 = Inventory account 1 = Contra account... i.e. physical inventory difference account
90 | Cost price change (+amount) | Applicable integration details: 0 = Inventory account 1 = Contra account... i.e. calculated price change account
91 | Cost price change (-amount) | Applicable integration details: 0 = Inventory account 1 = Contra account... i.e. calculated price change account
100 | Commitment accounting | Applicable integration details: 22 = Goods in transit 1 = Contra account... 23 = OH cost account, if applicable
110 | Received deliv, PO | Applicable integration details: 0 = Inventory account (debit) 1 = Contra account... i.e. interim account for delivered and not matched calculated value (canceled on matching). 2 = Price difference between purchase price and calculated price(+) (calculated price greater than purchase price) 3 = Price difference between purchase price and calculated price(-) 6 = Invtry adjustment (avg price).(+). Only relevant if Average weighted (cost price average) has been flagged on the product account. 7 = Invtry adjustment (avg price).(-). Only relevant if Average weighted (cost price average) has been flagged on the product account. 8 = Counter-booking invtry adjustment (avg price). Only relevant if Average weighted (cost price average) has been flagged on the product account. 21 = Purch cost (MO/refinement) Only relevant if 'Post mtrl/refinement' (InkKontMtrlOchForadling) is flagged on the product account.
120 | Received deliv, MO | Applicable integration details: 0 = Inventory account (debit) 1 = Contra account...i.e. manufacturing gain (diff. calc. against actual) 5 = PIP account (material issue: debit, received deliveries: credit). If a cost centre for the manufacturing unit is specified on the manufacturing order, this is used in the PIP posting 10 = Development cost 11 = Development OH cost 12 = Technical overhead cost 13 = Extra overhead cost 14 = Startup cost MO
180 | Default transaction type | Fictitious inventory transaction type that is used if no posting rule is defined for the inventory transaction type in question.
190 | Enter new invtry balance (item) | Applicable integration details: 0 = Inventory account 1 = Contra account... i.e. physical inventory difference, etc.
210 | Manual issue | Can be used for manual dispatch, or you can define your own transaction type for this at a much higher number. Also used for issue to service orders if no other transaction type is specified on the billing code.
300 | Quick count | Used only if the quick physical count function is used at the company and only by authorized personnel.
310 | Manual deliv receipt | Can be used for manual delivery receipt, or you can define your own transaction type for this at a much higher number.
500 | Scrap | Customer specific transaction type.
510 | Received deliv, subcontract |
520 | Mtrl issue -> customer |
530 | Mtrl sales at cust site |

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Document no. series | docnoserie | ztString | 3 |  | varchar
Manual posting OK | FarKonterasManuellt | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Quick count | ImpulsInventering | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Trans type for WMS | InvtTranTypeWMS | ztBoolean |  |  | char
Invtry trans. type | LagTransBeskr | ztString | 50 |  | varchar
Invtry trans. origin | LagTransSource | ztInteger | 3 |  | smallint
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Quantity +/- | LtAntal | ztBoolean |  |  | char
Print cust no. | LtFtgNr | ztBoolean |  |  | char
Received deliv | LtInleverans | ztBoolean |  |  | char
Inventory balance | LtLagSaldo | ztBoolean |  |  | char
Dispatch | LtUtleverans | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xXlt Inventory transaction types


Inventory transaction types VIEW (vxlt)

Extract from (view of) the Inventory transaction types table, i.e. the different entry methods for inventory movements. See the table Help for Inventory transaction types (xlt).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Manual posting OK | FarKonterasManuellt | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Quick count | ImpulsInventering | ztBoolean |  |  | char
Invtry trans. type | LagTransBeskr | ztString | 50 |  | varchar
Invtry trans. origin | LagTransSource | ztInteger | 3 |  | smallint
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Quantity +/- | LtAntal | ztBoolean |  |  | char
Print cust no. | LtFtgNr | ztBoolean |  |  | char
Received deliv | LtInleverans | ztBoolean |  |  | char
Inventory balance | LtLagSaldo | ztBoolean |  |  | char
Dispatch | LtUtleverans | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: vXlt Inventory transaction types


Inventory transfers (arsf)

This table contains transactions created in the program Inventory transfers (arsf), i.e. transferring items between/within inventory locations in the inventory procedures.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Use/Best before | BastForeDatum | ztDate |  |  | datetime
Batch no. | BatchId | ztString | 30 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Purch price curr | InValuta | ztString | 3 |  | varchar
Invtry transaction journal no | JlJournNr | ZtLong | 6 |  | int
Assembly journ no. | JournNrIULT | ZtLong | 5 |  | int
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Note | KortNotering | ztString | 255 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Inventory location type | LagStTyp | ztInteger | 2 |  | smallint
Invtry trans qty (+/-) | LagTransAntal | ZtQty | 14 | 2 | decimal
Quantity, alt unit (+/-) | LagtransAntAltEnh | ZtQty | 14 | 2 | decimal
Transaction date | LagTransDatum | ztDate |  |  | datetime
Invtry trans. origin | LagTransSource | ztInteger | 3 |  | smallint
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Print date | P_Utskr_Dat | ztDate |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Ent journal alpha ID | RegJournalLagerAlfaId | ztString | 30 |  | varchar
Ent.journal inventory code | RegJournalLagerKod | ztInteger | 5 |  | smallint
Ent.journ no., inv trans | RegJournalLagerNr | ZtLong | 9 |  | int
Ent.journ type, inv trans | RegJournalLagerTyp | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Historical cost invc row | StatistikRadKostnad | ZtBaseCurrAmount | 14 | 2 | money
Date/time | StrDateTime | ztString | 28 |  | varchar
To batch | TillBatchId | ztString | 30 |  | varchar
To bin no. | TillLagPlats | ztBinLocation | 20 |  | varchar
To inventory location | TillLagStalle | ztString | 2 |  | varchar
To invtry loc type | TillLagStTyp | ztInteger | 2 |  | smallint
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Cost price, curr | VbKalkPris | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: Arsf Inventory transfers


Invoice claim codes (fhno)

Definition of existing reasons for invoice notes/claims. Fill in the table as required.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Department | AvdelningsBeskr | ztString | 50 |  | varchar
Reason not paid | FaktNotOrsak | ztInteger | 5 |  | smallint
Reason not paid | FaktNotOrsakBeskr | ztString | 40 |  | varchar
Not paid group | FaktNotOrsakGrpBeskr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price | Pris | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xFhno Invoice claim reason


Invoice cost types, sales (xfks)

This table defines which types of invoice costs can be applied for customer invoices. The different costs within each type are defined in the xfkst program.

The following standard records exist. Do not alter/delete:

Invc cost code (FaktKostnTyp) | Invc cost code (FaktKostnTypBeskr)
1 | Packaging
2 | Insurance
3 | Freight
4 | Handling charge
5 | Other invoice cost-1
6 | Other invoice cost-2
10 | Advance
101 | Other invoicing fee-1
102 | Other invoicing fee-2
103 | Other invoicing fee-3
104 | Other invoicing fee-4
105 | Other invoicing fee-5
106 | Other invoicing fee-6
107 | Other invoicing fee-7
108 | Other invoicing fee-8
109 | Other invoicing fee-9
110 | Other invoicing fee-10
200 | Price diff Package and details

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invc cost code | FaktKostnTyp | ztInteger | 3 |  | smallint
Invc cost code | FaktKostnTypBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xxfks Invoice cost types, sales


Invoice costs (fkst)

Definition of costs for freight, packaging, insurance, and handling charge for printing on customer invoices. There are a number of "other" cost types you can use as you wish. Please note that cost types 100 and higher must be activated with the control parameter SALES173.

The definition is based on
- - linking a type of invoice cost from the drop-down list (whose content we have defined in the program 'Invoice cost types,' fsg (xxfks)) with the item in the item table for which the cost has been defined, and
- - specifying whether each cost will be printed as separate detail rows on the invoice or be reported in the invoice footer.

You specify the amount itself manually in the close order screen. In this way you avoid entering this type of costs as separate order rows.

VAT management for freight
================

In cases where the freight cost applies to sales of items with differing VAT rates, e.g. books (6 %) and music CDs (25 %), the taxation basis for the freight costs is distributed in accordance with that of the respective items. In other words, the portion of the freight costs that applies to the sale of books is taxed at a rate of 6 % and the portion that applies to the sale of CDs is taxed at a rate of 25 %.

For the example above to work, freight must be entered as a cost twice in this table and you must link the first definition to VAT code 6 % and the second definition to VAT code 25%.

If freight costs are printed as separate invoice rows and you want the VAT rate to appear on the row, you can either add the invoice row VAT rate onto the invoice template (but then this data will be printed for normal item rows as well) or you can set up several items for freight with the VAT rate in the item name.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Print invc row Y/N | FaktKostnSkrivKod | ztBoolean |  |  | char
Invc cost code | FaktKostnTyp | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Intrastat, allocation type | IntStatKostFordTyp | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xfkst Invoice costs


Invoice details->GL (fhvt)

Detailed data by transaction of how customer invoice details are posted when integrated with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Document ID | docnumid | ztString | 30 |  | varchar
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no., advance | FaktNrForskott | Jeeves_InvNo | 9 |  | bigint
RowNo. | FaktRadnr | ztInteger | 4 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Integration detail | IntField | ztInteger | 2 |  | smallint
Detail in integr source 1 | IntField_1 | ztInteger | 2 |  | smallint
Detail in integr source 2 | IntField_2 | ztInteger | 2 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Item group | Jeeves_FN_ItemGrpDescr | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Posting per invtry location | KonterasEnlLagStalle | ztString | 2 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Cost centre (elim) | KostStalleKodEliminera | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Inventory location | LagStalle | ztString | 2 |  | varchar
Tax base amount | MomsGrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Order type | OrdTyp | ztInteger | 3 |  | smallint
@zPrompt=null | origin | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Reference number | ReferensNr | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
UniqueIDInAKFT | UniqueIDInAKFT | ZtLong | 10 |  | int
UniqueIDInAKLT | UniqueIDInAKLT | ZtLong | 10 |  | int
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: vFhVt Show invoice row posting


Invoice header EDI (edfh)

The table is used for receiving supplier invoices and self-billing invoices via EDI.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Tax deduction code | AvdrMomsKod | ztInteger | 5 |  | smallint
Tax deduction% | AvdrMomsProc | ZtDecimal73 | 6 | 2 | decimal
Deducted amt curr | AvdrVal | ztMoney | 14 | 2 | money
Bank | BankidBeskr | ztString | 40 |  | varchar
Account at bank | BankKonto | ztString | 40 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Payee EAN loc code | BetMottEANLocCode | ztString | 30 |  | varchar
Contact details | ComNr | ztString | 200 |  | varchar
In/Out box EDI | EdiBoxRef | ztString | 21 |  | varchar
EDI Log | EdiLogg | ztBlob | 1 |  | varchar
EU VAT/tax registration no. | EumomsNr | ztString | 20 |  | varchar
Handling charge BCU | ExpeditionKostnad | ZtBaseCurrAmount | 14 | 2 | money
Invoice type, descr | ExtFaktTyp | ztString | 3 |  | varchar
External order status | ExtOrdSta | ztInteger | 2 |  | smallint
Invoice date | FaktDat | ztDate |  |  | datetime
Due date | FaktFfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Total freight BCU | FraktKostnDeb | ZtBaseCurrAmount | 14 | 2 | money
Tax | FraktMomsKod | ztInteger | 5 |  | smallint
Freight tax % | FraktMomsProc | ZtDecimal73 | 6 | 2 | decimal
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Disp EAN location code | LevEANLocCode | ztString | 30 |  | varchar
Invoice date | LevFaktDat | ztDate |  |  | datetime
Supplier reference | LevRef2 | ztString | 50 |  | varchar
Due date | LrFaktFFDat | ztDate |  |  | datetime
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Defect reason | OhdErrorCd | ztInteger | 4 |  | smallint
Organization no. | OrgNr | ztString | 18 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SBI number | SBINr | ztString | 25 |  | varchar
Refers to SBI no | SBINrRef | ztString | 25 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Invoice amount, curr | Vb_FaktSum | ztMoney | 14 | 2 | money
VAT/tax, curr | VbFaktMoms | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: edfh Supplier invoices, EDI

    Program: EdfSbi EDI customer invoice (Self Billing)


Invoice header sales tax (FhSalesTax)

Customer invoice number.

The number is retrieved from the number series for the invoice type in question which is entered in one of the following programs.

For invoices created in the order routine:
- Order types (xx6) or
- Invoice types (xxz2) or
- if applied, from the number series for the invoice number series group and invoice type in question in Invoice No. Series Group (xz2g)

For invoices manually entered in the accounts receivable:
- Invoice types (xxz2) or
- if applied, from the number series for the invoice number series group and invoice type in question in Invoice No. Series Group (xz2g)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax amount | TaxAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Tax area level | TaxAreaCode | ztString | 10 |  | varchar
Tax area rate | TaxAreaRate | ZtDecimal73 | 10 | 4 | decimal
Tax base amount | TaxBaseAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Sales tax code | TaxCode | ztInteger | 2 |  | smallint
Tax jurisdiction | TaxJurCode | ztInteger | 2 |  | smallint
Tax row no | TaxRowNo | ztInteger | 5 |  | smallint


Invoice header sales tax, view (VFhSalesTax)

Customer invoice number.

The number is retrieved from the number series for the invoice type in question which is entered in one of the following programs.

For invoices created in the order routine:
- Order types (xx6) or
- Invoice types (xxz2) or
- if applied, from the number series for the invoice number series group and invoice type in question in Invoice No. Series Group (xz2g)

For invoices manually entered in the accounts receivable:
- Invoice types (xxz2) or
- if applied, from the number series for the invoice number series group and invoice type in question in Invoice No. Series Group (xz2g)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax amount | TaxAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Tax area level | TaxAreaCode | ztString | 10 |  | varchar
Tax area level | TaxAreaDescr | ztString | 60 |  | nvarchar
Tax area rate | TaxAreaRate | ZtDecimal73 | 10 | 4 | decimal
Tax base amount | TaxBaseAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Sales tax code | TaxCode | ztInteger | 2 |  | smallint
Tax jurisdiction | TaxJurCode | ztInteger | 2 |  | smallint
Tax row no | TaxRowNo | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: FhSalesTax Invoice header sales tax


Invoice journal VIEW (vjf)

View of the jf table (Invoice journal).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint


Invoice matching (bpf)

Invoice matching against the purchase order row.
A "base" row is created for each invoice match and opening purchase order row. Any differences in purchase prices and cost prices are recorded in a log row.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Use/Best before | BastForeDatum | ztDate |  |  | datetime
Batch no. | BatchId | ztString | 30 |  | varchar
Upd agrmt fr invoice | BestFaktPris2Avtal | ztBoolean |  |  | char
Delivery note date, rcv | BestFoljesedelsDat | ztDate |  |  | datetime
Delivery note no., rcv | BestFoljesedelsNr | ztString | 30 |  | varchar
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
Received qty (suppl unit) | BestLevAntExtQty | ZtQty | 14 | 2 | decimal
Received qty (invc) | BestLevAntExtQty_Lrd | ZtQty | 14 | 2 | decimal
Delivery received date | bestlevdat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
Remaining qty invtry unit | BestRestAnt | ZtQty | 14 | 2 | decimal
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Bokat antal (lev enh) | BokatAntalExtQty | ZtQty | 14 | 2 | decimal
Accounting date | BokfDat | ztDate |  |  | datetime
Link inv. checking | BpfConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Inv.matching from lr | BpfFromLrbh | ztBoolean |  |  | char
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Changed inventory value | DiffLagVarde | ZtBaseCurrAmount | 14 | 2 | money
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Invc checked qty | FaktAvprAntal | ZtQty | 14 | 2 | decimal
InvcCheckQtyExt | FaktAvprAntalExtQty | ZtQty | 14 | 2 | decimal
Invc match cost, abroad | FaktAvprKostnUtland | ztMoney | 14 | 2 | money
Invoice match method | FaktAvprTypBest | ztInteger | 3 |  | smallint
Invc match value | FaktAvprVarde | ztMoney | 14 | 2 | money
Invc match value (invc) | FaktAvprVarde_lrd | ztMoney | 14 | 2 | money
Change calc price/item | FaktInpris2Artikel | ztBoolean |  |  | char
Overhead/qty | FaktOmkKvantitet | ztFloat | 15 | 2 | float
Overhead/PO | FaktOmkVarde | ZtBaseCurrAmount | 14 | 2 | money
Consumables | ForbrukningsMaterial | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Reason code | FsOrsakKod | ztInteger | 5 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Price conv factor | InkArtOmvFaktor | ztFloat | 14 | 4 | float
Quantity for OH allocation | InkOmkAntal | ztFloat | 15 | 2 | float
Allocation purch OH | InkOmkFord | ztInteger | 5 |  | smallint
Purch OH type | InkOmkTyp | ztInteger | 5 |  | smallint
Value for OH allocation | InkOmkVarde | ztMoney | 14 | 2 | money
Qty/weight/vol/value | InkopsOmkostnadsAntal | ztFloat | 15 | 2 | float
Purch value to invc match | InkopsVardeAttFaktAvpr | ZtBaseCurrAmount | 14 | 2 | money
Price unit factor | InkPrisPer | ZtDecimal73 | 8 | 3 | decimal
Receiving value | InlevKalkVarde | ZtBaseCurrAmount | 14 | 2 | money
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Identity no., Intrastat | IntStatIdentityNo | ZtLong | 10 |  | int
Item record seq no. | IntStatPostNr | ZtLong | 5 |  | int
Version number | IntStatVersionNr | ZtLong | 3 |  | int
Version, subnumber | IntStatVersionSubNr | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
To be posted | Konteras | ztBoolean |  |  | char
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
Corr plan qty (suppl unit) | KorrAntalInExtQty | ZtQty | 14 | 2 | decimal
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Stocked | LagerBokas | ztBoolean |  |  | char
Amount to match | LagerVardeAttFaktAvpr | ZtBaseCurrAmount | 14 | 2 | money
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invoice date | LevFaktDat | ztDate |  |  | datetime
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Sequence no. | LrbhRadPos | ztInteger | 5 |  | int
Mail to buyer | MailToBuyer | ztBoolean |  |  | char
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Prev cost price BCU | OldArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Urspr valutakurs | OldValKurs | ZtCurrencyRate | 15 | 7 | decimal
Auto created OH row | OmkFordAutoRad | ztBoolean |  |  | char
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | projcode | ztString | 10 |  | varchar
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Invtry unit->Purch unit | StockQty2SuppQty | ztFloat | 12 | 6 | float
Date/time | StrDateTime | ztString | 28 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Gr purch prc, curr (invc) | vb_inpris_lrd | ztMoney | 14 | 2 | money
Gross setup price, curr | Vb_InPris_Stall | ztMoney | 14 | 2 | money
Gross start purch price, curr | Vb_InPris_Start | ztMoney | 14 | 2 | money
Purchase price incl tax | Vb_InPrisInklMoms | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint
Statuskod på rad | VrStMark | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: xBpf Show invoice matching


Invoice matching proposal (PrelimUbpi)

Preliminary proposal for invoice matching in the function for preliminary supplier invoice.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item description | ArtBeskr | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Upd agrmt fr invoice | BestFaktPris2Avtal | ztBoolean |  |  | char
Delivery note no., rcv | BestFoljesedelsNr | ztString | 30 |  | varchar
Intern del note seq no. | BestFsLopNr | ztInteger | 5 |  | smallint
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
Received qty (suppl unit) | BestLevAntExtQty | ZtQty | 14 | 2 | decimal
Delivery received date | bestlevdat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Invc checked qty | FaktAvprAntal | ZtQty | 14 | 2 | decimal
InvcCheckQtyExt | FaktAvprAntalExtQty | ZtQty | 14 | 2 | decimal
Invc match value | FaktAvprVarde | ztMoney | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Price conv factor | InkArtOmvFaktor | ztFloat | 14 | 4 | float
Qty/weight/vol/value | InkopsOmkostnadsAntal | ztFloat | 15 | 2 | float
Price unit factor | InkPrisPer | ZtDecimal73 | 8 | 3 | decimal
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Supplier item descr | LevsArtBeskr | ztString | 255 |  | varchar
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
SeqNo. | PrelimLrid | ZtLong | 10 |  | int
Matched | PrelimLrMark | ztBoolean |  |  | char
Project ID | projcode | ztString | 10 |  | varchar
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Invtry unit->Purch unit | StockQty2SuppQty | ztFloat | 12 | 6 | float
Date/time | StrDateTime | ztString | 28 |  | varchar
Source | UlbpTyp | ztString | 2 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Gross setup price, curr | Vb_Inpris_Stall | ztMoney | 14 | 2 | money
Gross start purch price, curr | Vb_Inpris_Start | ztMoney | 14 | 2 | money
Purchase price incl tax | vb_inprisInklMoms | ztMoney | 14 | 2 | money
Text/info | x255 | ztString | 255 |  | varchar


Invoice matching proposal (ubpi)

Proposal for invoice matching.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item description | ArtBeskr | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Upd agrmt fr invoice | BestFaktPris2Avtal | ztBoolean |  |  | char
Delivery note date, rcv | BestFoljesedelsDat | ztDate |  |  | datetime
Delivery note no., rcv | BestFoljesedelsNr | ztString | 30 |  | varchar
Intern del note seq no. | BestFsLopNr | ztInteger | 5 |  | smallint
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
Received qty (suppl unit) | BestLevAntExtQty | ZtQty | 14 | 2 | decimal
Received qty (invc) | BestLevAntExtQty_Lrd | ZtQty | 14 | 2 | decimal
Delivery received date | bestlevdat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Invc checked qty | FaktAvprAntal | ZtQty | 14 | 2 | decimal
InvcCheckQtyExt | FaktAvprAntalExtQty | ZtQty | 14 | 2 | decimal
Invc match value | FaktAvprVarde | ztMoney | 14 | 2 | money
Invc match value (invc) | FaktAvprVarde_lrd | ztMoney | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Price conv factor | InkArtOmvFaktor | ztFloat | 14 | 4 | float
Quantity for OH allocation | InkOmkAntal | ztFloat | 15 | 2 | float
Value for OH allocation | InkOmkVarde | ztMoney | 14 | 2 | money
Qty/weight/vol/value | InkopsOmkostnadsAntal | ztFloat | 15 | 2 | float
Price unit factor | InkPrisPer | ZtDecimal73 | 8 | 3 | decimal
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invoice date | LevFaktDat | ztDate |  |  | datetime
Supplier item descr | LevsArtBeskr | ztString | 255 |  | varchar
Sequence no. | LrbhRadPos | ztInteger | 5 |  | smallint
Mail to buyer | MailtoBuyer | ztBoolean |  |  | char
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project ID | projcode | ztString | 10 |  | varchar
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
RejectCause | RejectCause | ztInteger | 4 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Invtry unit->Purch unit | StockQty2SuppQty | ztFloat | 12 | 6 | float
Date/time | StrDateTime | ztString | 28 |  | varchar
Source | UlbpTyp | ztString | 2 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Gr purch prc, curr (invc) | vb_inpris_lrd | ztMoney | 14 | 2 | money
Gross setup price, curr | Vb_Inpris_Stall | ztMoney | 14 | 2 | money
Gross start purch price, curr | Vb_Inpris_Start | ztMoney | 14 | 2 | money
Purchase price incl tax | vb_inprisInklMoms | ztMoney | 14 | 2 | money
Text/info | x255 | ztString | 255 |  | varchar


Invoice matching type (xbpf)

Internal definition of invoice matching against purchase orders which describe whether matching of a supplier invoice against a purchase order refers to a stocked product that is price matched, some type of correction, entry of extra costs or the like.

The following standard records exist. Do not alter/delete:

Invoice match method (faktavprtypbest) | Invoice match method (faktavprtypbestbeskr) | Description
0 | Inventory | Stocked item which is matched in respect of price (has no posting).
1 | Non-stocked | Unstocked item which is matched in respect of price (will also contain posting). These can be costs which are not specified per purchase order row; freight, insurance ...)
11 | Purchase price differences | Stocked goods (p-type) (price difference posting created automatically from the rules).
100 | Purchasing overheads | Purchase costs affecting purchase order rows/received deliveries. The type is automatically allocated to the rows that are created when allocating purchasing costs. This is used when the purchase is booked to purchase price (FIFO) and you wish to book additional costs which affect the purchase price.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoice match method | FaktAvprTypBest | ztInteger | 3 |  | smallint
Invoice match method | FaktAvprTypBestBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xXbpf Invoice matching types


Invoice matching type (VIEW) (vxbf)

View of the xbpf table (Invoice matching type) where the invoice matching type is not between 1 and 99.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoice match method | FaktAvprTypBest | ztInteger | 3 |  | smallint
Invoice match method | FaktAvprTypBestBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Invoice No. series for group (xz2n)

Number series per invoice type and invoice number series group.
In the user file, you can enter invoice number series groups so that a special number series applies for one person when numbering invoices/cash notes that are printed in the system.
If no invoice number series group is specified in the user file, the number series specified in the xz2 table, "Invoice types", applies.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no. series group | FakturaNrGrupp | ztInteger | 3 |  | smallint
Invoice type | FakturaTyp | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
From invoice no. | FromFaktNr | Jeeves_InvNo | 9 |  | bigint
From cash note no. | FromKontantNr | Jeeves_InvNo | 9 |  | bigint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cash note no. | KontantNr | Jeeves_InvNo | 9 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
To invoice no. | TomFaktNr | Jeeves_InvNo | 9 |  | bigint
To cash note no. | TomKontantNr | Jeeves_InvNo | 9 |  | bigint


Invoice no. series groups (xz2g)

Definition of groups of invoice number series if required and, for each group, different number series per invoice type.

In the System data person, own co. program (Xsy2) you can enter invoice number series groups so that a special number series applies for the user or user group when printing and numbering invoices/cash notes.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoice no. series group | FakturaNrGrupp | ztInteger | 3 |  | smallint
Invoice no. series group | FakturaNrGruppBeskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xz2g Invoice no. series groups


Invoice notes (fhn)

Notes (measure log) on customer invoices.
Please note that when a reminder block or due date is changed, a new note must always be entered. These fields cannot be changed on an existing note.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Department | AvdelningsBeskr | ztString | 50 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Planned activity descr | EventNote | ztString | 60 |  | varchar
Report date | EventRpDat | ztDate |  |  | datetime
Due date | FaktFfDat | ztDate |  |  | datetime
Reason not paid | FaktNotOrsak | ztInteger | 5 |  | smallint
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Reminders blocked | KravSparr | ztBoolean |  |  | char
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
OLE-1 | Ole1 | ztString | 255 |  | varchar
OLE-2 | Ole2 | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Price | Pris | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Salesperson name | SaljareNamn | ztString | 40 |  | varchar
Date/time | StrDateTime | ztString | 28 |  | varchar

    This table is the main table in the following programs:

    Program: xFhn Invoice notes


Invoice row detail (ft)

Detail rows on an invoice, usually corresponding to rows from a customer order or from a preliminary customer order (assignment invoicing/agreement invoicing).

To view/search among invoice rows use the invoice statistics program (vfaktst).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Deducted invoice | AcDrawn | ztBoolean |  |  | char
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Bin | ars_LagPlats | ztBinLocation | 20 |  | varchar
Item description | ArtBeskr | ztString | 30 |  | varchar
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Qualification number | ArtKvalifNr | ztString | 20 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
TARIC code | ArtStatNr | ztString | 20 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Volume m3 | ArtVolym | ztFloat | 15 | 4 | float
Autoskapad orderrad | AutoOrderLine | ztInteger | 5 |  | smallint
Posting template | AutoRegel | ztString | 4 |  | varchar
Posting template per cost | AutoRegelK | ztString | 4 |  | varchar
PO order value | BestValue | ZtBaseCurrAmount | 14 | 2 | money
Region | BlockRegion | ztString | 3 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Delivery from business unit ICT | DelivFromBusinessUnit | ztString | 8 |  | varchar
Delivery to business unit | DelivToBusinessUnit | ztString | 8 |  | varchar
Drop ship | DirektLeverans | ztBoolean |  |  | char
District | DistrKod | ztString | 4 |  | varchar
Division code | DivisKod | ztString | 3 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Planned activity | EventKod1 | ztInteger | 3 |  | smallint
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice date, change | FaktDatKorr | ztDate |  |  | datetime
Invoice date, original | FaktDatOrg | ztDate |  |  | datetime
Invoice row, advance | FaktForskRad | ztInteger | 5 |  | smallint
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Print invc row Y/N | FaktKostnSkrivKod | ztBoolean |  |  | char
Invc cost code | FaktKostnTyp | ztInteger | 3 |  | smallint
Shipped invc qty | FaktLevAnt | ZtQty | 14 | 2 | decimal
Invoiced qty, alt unit | FaktLevAntAltEnh | ZtQty | 14 | 2 | decimal
Sales tax | FaktMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no., advance | FaktNrForskott | Jeeves_InvNo | 9 |  | bigint
Invoice no., change | FaktNrKorr | Jeeves_InvNo | 9 |  | bigint
Invoice no., original | FaktNrOrg | Jeeves_InvNo | 9 |  | bigint
CSG invc row | FaktRadKost | ZtBaseCurrAmount | 14 | 2 | money
Kost (budg) varor | FaktRadKostBudg | ZtBaseCurrAmount | 14 | 2 | money
CSG invc row (+tax) | FaktRadKostInklMoms | ZtBaseCurrAmount | 14 | 2 | money
CSG invc row, intrn sls | FaktRadKostIntFsg | ZtBaseCurrAmount | 14 | 2 | money
CSG invc row, int.prchs | FaktRadKostIntKop | ZtBaseCurrAmount | 14 | 2 | money
RowNo. | FaktRadnr | ztInteger | 4 |  | int
Invc row discount % | FaktRadRab | ztFloat | 8 | 2 | float
Invc row discount | FaktRadRabSumma | ZtBaseCurrAmount | 14 | 2 | money
CSG invc row, std cost | FaktRadStdKost | ZtBaseCurrAmount | 14 | 2 | money
Margin, std cost | FaktRadStdKostTB | ZtBaseCurrAmount | 14 | 2 | money
Degree of margin, std cost | FaktRadStdKostTG | ZtDecimal73 | 8 | 3 | decimal
Invc row amount | FaktRadSumma | ZtBaseCurrAmount | 14 | 2 | money
Invoice row amount (+tax) | FaktRadSummaInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Inv.row amt, intrn sales | FaktRadSummaIntFsg | ZtBaseCurrAmount | 14 | 2 | money
Inv.row amt, int.prchs | FaktRadSummaIntKop | ZtBaseCurrAmount | 14 | 2 | money
Margin | FaktTB | ZtBaseCurrAmount | 14 | 2 | money
Margin (incl tax) | FaktTBInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Margin, internal sales | FaktTBIntFsg | ZtBaseCurrAmount | 14 | 2 | money
Margin, internal purch | FaktTBIntKop | ZtBaseCurrAmount | 14 | 2 | money
Degree of margin | FaktTG | ZtDecimal73 | 8 | 3 | decimal
Margin, internal sales | FaktTGIntFsg | ZtDecimal73 | 8 | 3 | decimal
Margin degree intrn prch | FaktTGIntKop | ZtDecimal73 | 8 | 3 | decimal
Delivery note/disp no. | FfhNr | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Advance on account | ForskottFaktAconto | ztBoolean |  |  | char
Exchange rate, advance | ForskottValKurs | ZtCurrencyRate | 15 | 7 | decimal
Sales price, BCU | FPris | ZtBaseCurrAmount | 14 | 2 | money
Fixed sales price, BCU | FPrisFast | ZtBaseCurrAmount | 14 | 2 | money
Sales price, internal | FPrisInternt | ZtBaseCurrAmount | 14 | 2 | money
Sales price, intrn by rule | FPrisInterntEnlRegel | ZtBaseCurrAmount | 14 | 2 | money
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Backorder.no. ICT | ICTDelivToPOBackOrderNo | ztInteger | 5 |  | smallint
Purchase order row no. ICT | ICTDelivToPOLnNo | ztInteger | 5 |  | smallint
Purchase order no. ICT | ICTDelivToPONo | ZtLong | 10 |  | int
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Identity no., Intrastat | IntStatIdentityNo | ZtLong | 10 |  | int
Item record seq no. | IntStatPostNr | ZtLong | 5 |  | int
Intrastat trans type | IntStatTransTyp | ztInteger | 2 |  | smallint
Version number | IntStatVersionNr | ZtLong | 3 |  | int
Version, subnumber | IntStatVersionSubNr | ztInteger | 5 |  | smallint
Exg rate on order date | InValKurs | ZtCurrencyRate | 15 | 7 | decimal
Exg rate on invc date | InValKursFakt | ZtCurrencyRate | 15 | 7 | decimal
Purch price curr | InValuta | ztString | 3 |  | varchar
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
At cost | KalkylPrisFaktura | ztString | 1 |  | varchar
Do not print invoice | KodEJUtskrFA | ztBoolean |  |  | char
Code intrn sales | KodInternFsg | ztBoolean |  |  | char
Municipality | Kommun | ztString | 5 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Cost centre, intrn sales | KostStalleKodIntFsg | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Sales price incl VAT/tax | KundPrisInklMoms | ztBoolean |  |  | char
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Customer discount value | KundRabattVarde | ZtBaseCurrAmount | 14 | 2 | money
Quantity | Kvantitet | ztFloat | 9 | 2 | float
County | Laen | ztString | 5 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
VAT/tax fr pkg item | MarkSumMomsPkt | ztBoolean |  |  | char
Tax base amount | MomsGrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Actual mtrl cost (refinement) | MtrlVerklKostForadling | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (adjust) | MtrlVerklKostJustering | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (mtrl) | MtrlVerklKostMtrl | ZtBaseCurrAmount | 14 | 2 | money
Net price in BCU | NettoPris | ZtSalesPrice | 12 | 2 | money
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Quote/agreement row no | OffRadNr | ztInteger | 5 |  | int
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Request disp date | OrdBegLevDat | ztDate |  |  | datetime
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order No., change | OrderNrKorr | Jeeves_SONo | 8 |  | bigint
Order No., original | OrderNrOrg | Jeeves_SONo | 8 |  | bigint
Order row invoice cost | OrderRadFaktKostnad | ztBoolean |  |  | char
Delivery note no. | OrdFoljesedelsNr | ZtLong | 10 |  | int
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Promised disp date | OrdLovLevDat | ztDate |  |  | datetime
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Order discount value | OrdRabattVarde | ZtBaseCurrAmount | 14 | 2 | money
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Order row no, original | OrdRadNrOrg | ztInteger | 4 |  | smallint
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Ord.row no f package, original | OrdRadNrStrPosOrg | ztInteger | 4 |  | smallint
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Backorder no., original | OrdRestNrOrg | ztInteger | 2 |  | smallint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Order spec text | OrpRadText | ztString | 255 |  | varchar
Order spec text/inv | OrpRadTextFa | ztBoolean |  |  | char
Price calc method, pkg | OrpStrPrisBer | ztInteger | 2 |  | smallint
Package item | PaketArtikel | ztBoolean |  |  | char
Markup % | Palagg | ztFloat | 5 | 2 | float
Period | Period | ztInteger | 4 |  | smallint
Personnel category | PersKategori | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Backorder no., package | PktOrdRestNr | ztInteger | 2 |  | smallint
Preliminary revenue at dsptch | PrelFaktVardeUtlev | ZtBaseCurrAmount | 14 | 2 | money
Date of price chg | PrisAndrDatum | ztDate |  |  | datetime
Price adjustment | PrisJustOrder | ztBoolean |  |  | char
CSG on price adjustment | PrisJustOrderKost | ztBoolean |  |  | char
Project ID | ProjCode | ztString | 10 |  | varchar
Season | PVMSeasonId | ztString | 15 |  | varchar
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Discount 1 % | rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 1 value | Rabatt1Varde | ZtBaseCurrAmount | 14 | 2 | money
Discount 2 % | rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 value | Rabatt2Varde | ZtBaseCurrAmount | 14 | 2 | money
Discount 3 % | rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 value | Rabatt3Varde | ZtBaseCurrAmount | 14 | 2 | money
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Cost | RedovisnRadKostnad | ZtBaseCurrAmount | 14 | 2 | money
Invoiced | RedovisnRadVarde | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sales tax handling | SalesTaxHandling | ztBoolean |  |  | char
Salesperson | Saljare | ztString | 6 |  | varchar
Collective invoicing ID | SamFaktOffNr | ztString | 30 |  | varchar
Serv.order no | ServOrderNr | Jeeves_SONo | 9 |  | bigint
Order row, service | ServOrdRadNr | ztInteger | 5 |  | int
Skrivskydd | SkrivUtskSk | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Time sqlcmd->trg start | SQlcmd2EnterTrg | ZtLong | 10 |  | int
Historical cost invc row | StatistikRadKostnad | ZtBaseCurrAmount | 14 | 2 | money
Statistical item value | StatistikRadVarde | ZtBaseCurrAmount | 14 | 2 | money
Connection->planned activities | StrDateTimeHr | ztString | 28 |  | varchar
Sales tax code | TaxCode | ztInteger | 2 |  | smallint
Time type | TidKod | ztInteger | 5 |  | smallint
Service | TjKod | ztInteger | 4 |  | smallint
Transit delivery | TransitLeverans | ztBoolean |  |  | char
Tax in 3rd currency | V3_FaktMoms | ztMoney | 14 | 2 | money
Invc row amt, 3rd currency | V3_FaktRadSumma | ztMoney | 14 | 2 | money
Gross invc row amt, 3rd ccy | V3_FaktRadSumma_Brutto | ztMoney | 14 | 2 | money
Invc row amt incl tax, 3rd ccy | V3_FaktRadSummaInklMoms | ztMoney | 14 | 2 | money
Prc in 3rd ccy | V3_Pris | ztMoney | 14 | 2 | money
Price incl tax 3rd ccy | V3_PrisInklMoms | ZtSalesPrice | 12 | 2 | money
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency clause | ValKlausul | ztInteger | 5 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Invoice 0-price | VaruProv | ztString | 1 |  | varchar
Skattekod 2 | VATCode2 | ztInteger | 5 |  | smallint
Skattekod 3 | VATCode3 | ztInteger | 5 |  | smallint
Row amt, curr | vb_FaktRadSumma | ztMoney | 14 | 2 | money
Gross invoice row amt, curr | vb_FaktRadSumma_Brutto | ztMoney | 14 | 2 | money
Invoice row amt, curr (+ tax) | vb_FaktRadSummaInklMoms | ztMoney | 14 | 2 | money
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Net price, curr | vb_NettoPris | ZtSalesPrice | 12 | 2 | money
Price, curr | vb_pris | ZtSalesPrice | 12 | 2 | money
Price, curr (at order) | Vb_Pris_Ord | ZtSalesPrice | 12 | 2 | money
Price, curr (package) | vb_Pris_Paket | ZtSalesPrice | 12 | 2 | money
Fixed price, currency | vb_PrisFast | ZtSalesPrice | 12 | 2 | money
Price incl tax, curr | Vb_PrisInklMoms | ZtSalesPrice | 12 | 2 | money
VAT/tax, curr | VbFaktMoms | ztMoney | 14 | 2 | money
Invc row discount, curr | vbFaktRadRabSumma | ztMoney | 14 | 2 | money
Cost price, curr | VbKalkPris | ztMoney | 14 | 2 | money
Price acc to rule | VbPrisER | ZtSalesPrice | 12 | 2 | money
Sector | Verksamhet | ztInteger | 5 |  | smallint
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Volume disc % | VolymRabatt | ZtDecimal73 | 10 | 2 | decimal
Volume discount value | VolymRabattVarde | ZtBaseCurrAmount | 14 | 2 | money
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: vFAKTST Show invoice statistics

    Program: vFAKTST1 Show invoice statistics, pckg header

    Program: vFAKTST2 Show invoice statistics, pckg detail

    Program: vFAKTST3 Show invoice statistics, deducted Advance


Invoice row details (ftD)

Customer invoice number.

The number is retrieved from the number series for the invoice type in question which is entered in one of the following programs.

For invoices created in the order routine:
- Order types (xx6) or
- Invoice types (xxz2) or
- if applied, from the number series for the invoice number series group and invoice type in question in Invoice No. Series Group (xz2g)

For invoices manually entered in the accounts receivable:
- Invoice types (xxz2) or
- if applied, from the number series for the invoice number series group and invoice type in question in Invoice No. Series Group (xz2g)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoice no. | Faktnr | Jeeves_InvNo | 9 |  | bigint
RowNo. | FaktRadNr | ztInteger | 4 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Priority | prioritet | ztInteger | 2 |  | smallint
Discount % | Rabatt | ZtDecimal73 | 6 | 2 | decimal
Discount curr | Rabattval | ztMoney | 14 | 2 | money
Discount type | RabTyp | ztInteger | 3 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Discount, curr | vbrab | ztMoney | 14 | 2 | money


Invoice row details sales tax (FtSalesTax)

Customer invoice number.

The number is retrieved from the number series for the invoice type in question which is entered in one of the following programs.

For invoices created in the order routine:
- Order types (xx6) or
- Invoice types (xxz2) or
- if applied, from the number series for the invoice number series group and invoice type in question in Invoice No. Series Group (xz2g)

For invoices manually entered in the accounts receivable:
- Invoice types (xxz2) or
- if applied, from the number series for the invoice number series group and invoice type in question in Invoice No. Series Group (xz2g)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
RowNo. | FaktRadnr | ztInteger | 4 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax amount | TaxAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Tax area level | TaxAreaCode | ztString | 10 |  | varchar
Tax area rate | TaxAreaRate | ZtDecimal73 | 10 | 4 | decimal
Tax base amount | TaxBaseAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Sales tax code | TaxCode | ztInteger | 2 |  | smallint
Tax jurisdiction | TaxJurCode | ztInteger | 2 |  | smallint
Tax row no | TaxRowNo | ztInteger | 5 |  | smallint


Invoice row details sales tax, view (VFtSalesTax)

Customer invoice number.

The number is retrieved from the number series for the invoice type in question which is entered in one of the following programs.

For invoices created in the order routine:
- Order types (xx6) or
- Invoice types (xxz2) or
- if applied, from the number series for the invoice number series group and invoice type in question in Invoice No. Series Group (xz2g)

For invoices manually entered in the accounts receivable:
- Invoice types (xxz2) or
- if applied, from the number series for the invoice number series group and invoice type in question in Invoice No. Series Group (xz2g)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
RowNo. | FaktRadnr | ztInteger | 4 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax amount | TaxAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Tax area level | TaxAreaCode | ztString | 10 |  | varchar
Tax area level | TaxAreaDescr | ztString | 60 |  | nvarchar
Tax area rate | TaxAreaRate | ZtDecimal73 | 10 | 4 | decimal
Tax base amount | TaxBaseAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Sales tax code | TaxCode | ztInteger | 2 |  | smallint
Tax jurisdiction | TaxJurCode | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: FtSalesTax Invoice row sales tax


Invoice row EDI (edft)

Used for receiving supplier invoices and self-billing invoices via EDI.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item variant | Artikelvariant | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Automatically created | AutomatSkapad | ztBoolean |  |  | char
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
Received qty (suppl unit) | BestLevAntExtQty | ZtQty | 14 | 2 | decimal
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
In/Out box EDI | EdiBoxRef | ztString | 21 |  | varchar
EDI unit | EdiEnhet | ztString | 3 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Invoice row no | ExtFaktRadNr | ztInteger | 4 |  | int
Invoice type, descr | ExtFaktTyp | ztString | 3 |  | varchar
External order status | ExtOrdSta | ztInteger | 2 |  | smallint
Invc checked qty | FaktAvprAntal | ZtQty | 14 | 2 | decimal
InvcCheckQtyExt | FaktAvprAntalExtQty | ZtQty | 14 | 2 | decimal
Shipped invc qty | FaktLevAnt | ZtQty | 14 | 2 | decimal
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
RowNo. | FaktRadNr | ztInteger | 4 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Delivery note date | FsDatum | ztDate |  |  | datetime
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Price unit factor | InkPrisPer | ZtDecimal73 | 8 | 3 | decimal
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Supplier item descr | LevsArtBeskr | ztString | 255 |  | varchar
Delivery note | MottFoljesedel | ztString | 17 |  | varchar
Defect reason | OrdErrorCd | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Row tax code | RadMomsKod | ztInteger | 5 |  | smallint
Row tax % | RadMomsSats | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Row amt, curr | vb_FaktRadSumma | ztMoney | 14 | 2 | money
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Gross setup price, curr | Vb_InPris_Stall | ztMoney | 14 | 2 | money
Gross start purch price, curr | Vb_InPris_Start | ztMoney | 14 | 2 | money
Price, curr | vb_Pris | ZtSalesPrice | 12 | 2 | money


Invoice rows summary printout (vft)

Sum of invoice rows in assignment invoicing for printing on invoices.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Bin | ars_LagPlats | ztBinLocation | 20 |  | varchar
Item description | ArtBeskr | ztString | 30 |  | varchar
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
TARIC code | ArtStatNr | ztString | 20 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Volume m3 | ArtVolym | ztFloat | 15 | 4 | float
Autoskapad orderrad | AutoOrderLine | ztInteger | 5 |  | smallint
Posting template | AutoRegel | ztString | 4 |  | varchar
Posting template per cost | AutoRegelK | ztString | 4 |  | varchar
PO order value | BestValue | ZtBaseCurrAmount | 14 | 2 | money
Region | BlockRegion | ztString | 3 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
District | DistrKod | ztString | 4 |  | varchar
Division code | DivisKod | ztString | 3 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Planned activity | EventKod1 | ztInteger | 3 |  | smallint
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Print invc row Y/N | FaktKostnSkrivKod | ztBoolean |  |  | char
Shipped invc qty | FaktLevAnt | ZtQty | 14 | 2 | decimal
Invoiced qty, alt unit | FaktLevAntAltEnh | ZtQty | 14 | 2 | decimal
Sales tax | FaktMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no., change | FaktNrKorr | Jeeves_InvNo | 9 |  | bigint
Invoice no., original | FaktNrOrg | Jeeves_InvNo | 9 |  | bigint
CSG invc row | FaktRadKost | ZtBaseCurrAmount | 14 | 2 | money
Kost (budg) varor | FaktRadKostBudg | ZtBaseCurrAmount | 14 | 2 | money
CSG invc row (+tax) | FaktRadKostInklMoms | ZtBaseCurrAmount | 14 | 2 | money
RowNo. | FaktRadnr | ztInteger | 4 |  | int
Invc row discount % | FaktRadRab | ztFloat | 8 | 2 | float
Invc row discount | FaktRadRabSumma | ZtBaseCurrAmount | 14 | 2 | money
Invc row amount | FaktRadSumma | ZtBaseCurrAmount | 14 | 2 | money
Invoice row amount (+tax) | FaktRadSummaInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Margin | FaktTB | ZtBaseCurrAmount | 14 | 2 | money
Margin (incl tax) | FaktTBInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Degree of margin | FaktTG | ZtDecimal73 | 8 | 3 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, BCU | FPris | ZtBaseCurrAmount | 14 | 2 | money
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Exg rate on order date | InValKurs | ZtCurrencyRate | 15 | 7 | decimal
Exg rate on invc date | InValKursFakt | ZtCurrencyRate | 15 | 7 | decimal
Purch price curr | InValuta | ztString | 3 |  | varchar
At cost | KalkylPrisFaktura | ztString | 1 |  | varchar
Municipality | Kommun | ztString | 5 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Quantity | Kvantitet | ztFloat | 9 | 2 | float
County | Laen | ztString | 5 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Actual mtrl cost (refinement) | MtrlVerklKostForadling | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (adjust) | MtrlVerklKostJustering | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (mtrl) | MtrlVerklKostMtrl | ZtBaseCurrAmount | 14 | 2 | money
Net price in BCU | NettoPris | ZtSalesPrice | 12 | 2 | money
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Request disp date | OrdBegLevDat | ztDate |  |  | datetime
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order No., change | OrderNrKorr | Jeeves_SONo | 8 |  | bigint
Order No., original | OrderNrOrg | Jeeves_SONo | 8 |  | bigint
Delivery note no. | OrdFoljesedelsNr | ZtLong | 10 |  | int
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Promised disp date | OrdLovLevDat | ztDate |  |  | datetime
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Order spec text | OrpRadText | ztString | 255 |  | varchar
Order spec text/inv | OrpRadTextFa | ztBoolean |  |  | char
Price calc method, pkg | OrpStrPrisBer | ztInteger | 2 |  | smallint
Package item | PaketArtikel | ztBoolean |  |  | char
Markup % | Palagg | ztFloat | 5 | 2 | float
Period | Period | ztInteger | 4 |  | smallint
Personnel category | Perskategori | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Date of price chg | PrisAndrDatum | ztDate |  |  | datetime
Price adjustment | PrisJustOrder | ztBoolean |  |  | char
CSG on price adjustment | PrisJustOrderKost | ztBoolean |  |  | char
Project ID | ProjCode | ztString | 10 |  | varchar
Discount 1 % | rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Cost | RedovisnRadKostnad | ZtBaseCurrAmount | 14 | 2 | money
Invoiced | RedovisnRadVarde | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Collective invoicing ID | SamFaktOffNr | ztString | 30 |  | varchar
Serv.order no | ServOrderNr | Jeeves_SONo | 9 |  | bigint
Order row, service | ServOrdRadNr | ztInteger | 5 |  | int
Skrivskydd | SkrivUtskSk | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Historical cost invc row | StatistikRadKostnad | ZtBaseCurrAmount | 14 | 2 | money
Statistical item value | StatistikRadVarde | ZtBaseCurrAmount | 14 | 2 | money
Time type | TidKod | ztInteger | 5 |  | smallint
Service | TjKod | ztInteger | 4 |  | smallint
Tax in 3rd currency | V3_FaktMoms | ztMoney | 14 | 2 | money
Invc row amt, 3rd currency | V3_FaktRadSumma | ztMoney | 14 | 2 | money
Gross invc row amt, 3rd ccy | V3_FaktRadSumma_Brutto | ztMoney | 14 | 2 | money
Invc row amt incl tax, 3rd ccy | V3_FaktRadSummaInklMoms | ztMoney | 14 | 2 | money
Prc in 3rd ccy | V3_Pris | ztMoney | 14 | 2 | money
Price incl tax 3rd ccy | V3_PrisInklMoms | ZtSalesPrice | 12 | 2 | money
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency clause | ValKlausul | ztInteger | 5 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Invoice 0-price | VaruProv | ztString | 1 |  | varchar
Skattekod 2 | VATCode2 | ztInteger | 5 |  | smallint
Skattekod 3 | VATCode3 | ztInteger | 5 |  | smallint
Row amt, curr | vb_FaktRadSumma | ztMoney | 14 | 2 | money
Gross invoice row amt, curr | vb_FaktRadSumma_Brutto | ztMoney | 14 | 2 | money
Invoice row amt, curr (+ tax) | vb_FaktRadSummaInklMoms | ztMoney | 14 | 2 | money
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Net price, curr | vb_NettoPris | ZtSalesPrice | 12 | 2 | money
Price, curr | vb_pris | ZtSalesPrice | 12 | 2 | money
Price, curr (at order) | Vb_Pris_Ord | ZtSalesPrice | 12 | 2 | money
Price incl tax, curr | Vb_PrisInklMoms | ZtSalesPrice | 12 | 2 | money
VAT/tax, curr | VbFaktMoms | ztMoney | 14 | 2 | money
Invc row discount, curr | vbFaktRadRabSumma | ztMoney | 14 | 2 | money
Cost price, curr | VbKalkPris | ztMoney | 14 | 2 | money
Price acc to rule | VbPrisER | ZtSalesPrice | 12 | 2 | money
Sector | Verksamhet | ztInteger | 5 |  | smallint
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Volume disc % | VolymRabatt | ZtDecimal73 | 10 | 2 | decimal
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint


Invoice status (xz0)

Table of different customer invoice statuses, e.g. paid.

The following standard records exist. Do not alter/delete:

Invoice status (FaktStKod) | Invoice status (FaktStBeskr)
0 | Invoiced
3 | Under inquiry
5 | Paid
9 | Canceled
-2 | Print preview (not inv)
-1 | Prel invc (entry in progress)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoice status | FaktStBeskr | ztString | 50 |  | varchar
Invoice status | FaktStKod | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxz0 Invoice status


Invoice types (xz2)

Definition of customer invoice types to which invoice number series, etc. are linked.

NOTE: For any number interval to work, you must fill in both the start and end of the interval. If this is not done, the next available number is used when invoicing.

The following standard records exist. Do not alter/delete:

Invoice type (FakturaTyp) | Invoice type (FakturaTypBeskr)
0 | Credit order entry
1 | Credit manual invoicing
2 | Assignment invoicing, credit
10 | On account
70 | Credit invoice from external system
90 | Credit interest invoice
100 | Invoice from normal order entry
101 | Debit manual invoicing
102 | Assignment invoicing
104 | Assignment, On account
112 | Advance invoice, assignments
115 | Advance invoice, manual
116 | Advance invoice->On account, manual
120 | Advance invoice, order routine
121 | Advance invoice->On account, order routine
170 | Invoice from external system
190 | Interest invoice
200 | Company invoicing
210 | VAT invoice

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Full advance no. | AdvDeductionNo | Jeeves_InvNo | 9 |  | bigint
Posting template | AutoRegel | ztString | 4 |  | varchar
Payment terms | BetKod | ztString | 2 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no. unique | FaktNrIntervUnikt | ztBoolean |  |  | char
Invoice type | FakturaTyp | ztInteger | 3 |  | smallint
Invoice type | FakturaTypBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Advance, post | ForskottBokfKrsk | ztBoolean |  |  | char
Advance on account | ForskottFaktAconto | ztBoolean |  |  | char
Advance invoice | ForskottFaktura | ztBoolean |  |  | char
Advance, post VAT/tax | ForskottMomsBokf | ztBoolean |  |  | char
From invoice no. | FromFaktNr | Jeeves_InvNo | 9 |  | bigint
From cash note no. | FromKontantNr | Jeeves_InvNo | 9 |  | bigint
From full advance no. | FromNoDeduction | Jeeves_InvNo | 9 |  | bigint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cash note no. | KontantNr | Jeeves_InvNo | 9 |  | bigint
Cash note no. unique | KontNotaNrIntervUnikt | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Interest invoice | RteFaktKd | ztBoolean |  |  | char
To invoice no. | TomFaktNr | Jeeves_InvNo | 9 |  | bigint
To cash note no. | TomKontantNr | Jeeves_InvNo | 9 |  | bigint
To full advance no. | ToNoDeduction | Jeeves_InvNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: xxz2 Invoice types


Invoice types, assignments (xut)

Table of invoice types in the assignment module that are used to determine means of payment.

The following standard records exist. Do not alter/delete:

Invoice type, descr (PrelfaktTyp) | Invoice type, descr (PrelFaktTypB)
0 | From invoicing
1 | Manual
2 | Credit
3 | Periodical invoicing, assignme
4 | On account

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Credit order | KreditOrder | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Invoice type, descr | PrelfaktTyp | ztInteger | 5 |  | smallint
Invoice type, descr | PrelFaktTypB | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xut Preliminary invoice origin


Invoice, subtotals per order (fho)

In this table, subtotals are created per order for collective and amendment invoices, i.e. such invoices can consist of several orders.
Created automatically by the invoicing program.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sales tax | FaktMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice total incl tax | FaktTotMMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice total incl tax | FaktTotMMomsFaktOrg | ZtBaseCurrAmount | 14 | 2 | money
Invoice total excl tax | FaktTotUMoms | ZtBaseCurrAmount | 14 | 2 | money
Record type | FhoTyp | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Invoice amount, curr | vb_FaktSum | ztMoney | 14 | 2 | money
Invoice amount, curr | vb_FaktSumFaktOrg | ztMoney | 14 | 2 | money
VAT/tax, curr | VbFaktMoms | ztMoney | 14 | 2 | money
Invoice total excl tax | vbFaktTotUMoms | ztMoney | 14 | 2 | money


Invoiced by (x1fk)

Name of invoicing entity for purposes of internal information and any printout of the invoice.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoiced by | FakturerareBeskr | ztString | 30 |  | varchar
Invoiced by | FakturerareKod | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: Xx1fk Invoiced by


Invoices and payments per supplier (lrLru)

Suppliers' invoice number.

The number must be unique, i.e. you can not enter several invoices with the same number for the same supplier.

Exception: if you enter a number longer than 20 characters you can enter a number to replace the invoice number in the bank giro payment file. This is used for recurring tax payments to the same tax reference number.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Amount BCU | AmountBCU | ztMoney | 14 | 2 | money
Amount curr | amountFCU | ztMoney | 14 | 2 | money
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | bokfdat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Invoice date | levfaktdat | ztDate |  |  | datetime
Due date | LrFaktFFDat | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Type | Rowtype2 | ztString | 50 |  | varchar
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SqlIdentity | ZtLong | 10 |  | int
Currency | valkod | ztString | 3 |  | varchar
Voucher no. | vernr | Jeeves_VchrNo | 9 |  | bigint


Invoices for collection (fhi)

Invoices in collections.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Collection amount | InkassoBelopp | ZtBaseCurrAmount | 14 | 2 | money
Collection no. | InkassoNr | ZtLong | 4 |  | int
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar


Invoices on check (CheckDe)

Invoices on check.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Check number | Checkno | ZtLong | 9 |  | int
Due date | FaktFfDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Paid amount | InbBel | ZtBaseCurrAmount | 14 | 2 | money
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Acc rec/Acc pay | KRorLR | ztInteger | 5 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Paid amount, curr | VbInbBel | ztMoney | 14 | 2 | money


Invoices per order (ohfh)

Invoices per order or order per invoice.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoiced by | FaktAvPersSign | ztString | 6 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice date/time | FaktDateTime | ztDateTime |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice print date | FhUtskrDat | ztDateTime |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar


Invoices with payment injunctions (fhb)

Invoices that are the object of an injunction to pay.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Injunction amount | BetForelaggandeBelopp | ZtBaseCurrAmount | 14 | 2 | money
Injunction no. | BetForelaggandeNr | ZtLong | 4 |  | int
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar


Invoices, payment reminders (fhk)

Invoices with payment reminders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Days fr due dt to pmt | AntDgrSedanFfDat | ZtLong | 7 |  | int
Days fr inv dt to pmt | AntInbDgr | ZtLong | 10 |  | int
Due date | FaktFfDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice status | FaktStKod | ztInteger | 2 |  | smallint
Invoice type | FakturaTyp | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Reminder journal batch no. | JfhkNr | ztInteger | 4 |  | smallint
No. of reminders | KravAnt | ztInteger | 1 |  | smallint
Date last reminder | KravSenUtskr | ztDate |  |  | datetime
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Prev reminder qties | OldKravAnt | ztInteger | 1 |  | smallint
Föreg kravutskrift | OldKravSenUtskr | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Remaining to pay | Restbelfakt | ZtBaseCurrAmount | 14 | 2 | money
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Interest days | RtaDagar | ztInteger | 4 |  | smallint
Skrivskydd | SkrivUtskSk | ztBoolean |  |  | char
Currency | ValKod | ztString | 3 |  | varchar
Reminder charge | Vb_KravAvgift | ztMoney | 14 | 2 | money
Outst invc amt, curr | VbFaktRest | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: fhk Reminder batch details


Invoices/payment service file (lrfb)

Data on supplier invoices in invoice payment service file.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Deduction curr | AvdrVal_Fbs | ztMoney | 14 | 2 | money
Account at bank | BankKonto | ztString | 40 |  | varchar
Transmit to bank date | BankSandDat | ztDate |  |  | datetime
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Currency pocket | Curr_P | ztString | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Guarantee account | G_BankAccount | ztString | 40 |  | varchar
Guarantee payment | G_Paym | ztBoolean |  |  | char
Guarantee % | G_Percentage | ZtDecimal73 | 5 | 2 | decimal
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Pmt to acct | KontoIns | ztInteger | 1 |  | smallint
Country | LandsKod | ztString | 3 |  | varchar
Due date | LrFaktFfDat | ztDate |  |  | datetime
Planned pmt date | LrFaktPlanBetDat | ztDate |  |  | datetime
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Date/time | StrDateTime | ztString | 28 |  | varchar
Fixed deduction date | TK_15 | ztBoolean |  |  | char
Plan/paid amt, BCU | UtbBel | ZtBaseCurrAmount | 14 | 2 | money
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int
Pmt service journal no. | UtbServJournNr | ZtLong | 6 |  | int
AP payment notif text | UtbText | ztString | 60 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Pmt amt, curr (pmt srvc) | VbFbsBelopp | ztMoney | 14 | 2 | money
Amount (Invc pmt srvc) | VbFbsUtbBel | ztMoney | 14 | 2 | money
Total amount | VbFbsWorkAmount | ztMoney | 14 | 2 | money
Total Amount BCU | VbFbsWorkAmountBCU | ztMoney | 14 | 2 | money
Early settlmt discnt, curr | VbKassaRab_Fbs | ztMoney | 14 | 2 | money


Invoicing batch, assgnmt (ufo)

Data in the header of assignment invoice batches.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Agreement type | AvtalsKod | ztInteger | 3 |  | smallint
Text | edit | ztBlob | 1 |  | varchar
Invoice to date | Fakttomdat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Release prel invc immediately | FrislappPrelFaktura | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
OLE-1 | ole1 | ztString | 255 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Description | UJournbeskr | ztString | 30 |  | varchar
This field is used in the table as follows: |
Prel invc journal no. | UppdJournNr | ZtLong | 4 |  | int
Tot amt, prel invc jrnl | UppJournbel | ZtBaseCurrAmount | 14 | 2 | money

    This table is the main table in the following programs:

    Program: ufo Create preliminary assignment invoice

    Program: Ufo2 Create prel periodic assignment invoice

    Program: ufo4 Create prel monthly assignment invoice

    Program: ufo6 Create prel project invoice

    Program: ufo8 Create preliminary service invoice

    Program: ufo9 Create preliminary add on invoices


Invoicing journal (jf)

Data in the journal header about the invoicing of customer invoices.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Created journal | Bilags_Create | ztBoolean |  |  | char
Accounting date | BokfDat | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Reported end time | EventRpTime | ztTime | 5 |  | datetime
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice book date | Faktdat2BokfDat | ztDate |  |  | datetime
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Invc journal total | FaktJournbel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Print date | P_Utskr_Dat | ztDate |  |  | datetime
Print date/time | P_Utskr_DatTid | ztDateTime |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: Xjf Invoicing journal


Invoicing types, assignments (xu1)

Definition of invoicing types for assignments that are used to specify whether an invoice shall be specified by person, personnel category, sector, etc. If for example ‘Per person’ is selected, the customer invoice will include a row for each person, even if a person has reported different events. The invoicing type also controls the posting of reported events.

The invoicing types in the system are shown below, as well as the order in which the system looks for posting rules depending on invoicing type.

The following standard records exist. Do not alter/delete:

Invoicing type (UFakttyp) | Invoicing type (UFakttbeskr) | Description
0 | Per person | Invoices are specified per person. Posting is performed as follows: 1) According to the product account specified for the person (if any). 2) Posting follows the general rules entered as posting templates for invoice details and totals (in the programs xAkFt and xAkFh).
1 | Per category | Invoices are specified per personnel category. Posting is performed as follows: 1) According to the product account specified for the category (if any). 2) Posting follows the general rules entered as posting templates for invoice details and totals (in the programs xAkFt and xAkFh).
2 | Per category/person | Invoices are specified per personnel category and person. Posting is performed as follows: 1) According to the product account specified for the category (if any). 2) According to the product account specified for the person (if any). 3) Posting follows the general rules entered as posting templates for invoice details and totals (in the programs xAkFt and xAkFh).
3 | Sector | Invoices are specified per business area. Posting is performed as follows: 1) According to the product account specified for the sector (if any). 2) Product account with number 0. 3) The first product account in the product account table (e.g. number 1 if the accounts are numbered 1, 2 and 3).
4 | Per person/time code | Invoices are specified per person and time type. Posting is performed as follows: 1) According to the product account specified for the person (if any). 2) Posting follows the general rules entered as posting templates for invoice details and totals (in the programs xAkFt and xAkFh).
5 | Per category/time code | Invoices are specified per personnel category and time type. Posting is performed as follows: 1) According to the product account specified for the category (if any). 2) Posting follows the general rules entered as posting templates for invoice details and totals (in the programs xAkFt and xAkFh).
6 | Per category/person/time code | Invoices are specified per personnel category, person and time type. Posting is performed as follows: 1) According to the product account specified for the category (if any). 2) According to the product account specified for the person (if any). 3) Posting follows the general rules entered as posting templates for invoice details and totals (in the programs xAkFt and xAkFh).
7 | Per line of business/time code | Invoices are specified per business area and time type. Posting is performed as follows: 1) According to the product account specified for the sector (if any). 2) Product account with number 0. 3) The first product account in the product account table (e.g. number 1 if the accounts are numbered 1, 2 and 3).
9 | Total time & details expenses | Only used in combination with the field 'Detail posting' being flagged. Posting is performed according to invoicing type 99. Total amounts for time and a specification of expenses are printed on the invoice.
10 | Total time & expenses | Only used in combination with the field 'Detail posting' being flagged. Posting is performed according to invoicing type 99. Subtotals for time and expenses are printed on the invoice.
11 | Activity | Posting is performed according to the services account for the project. Cost centre and Cost unit are retrieved from the transaction row. The invoice is printed sorted in project number order and totaled within every project per planned event.
12 | Activity/person | Posting is performed according to the services account for the project. Cost centre and Cost unit are retrieved from the transaction row. The invoice is printed sorted in project number order and totaled within every project per planned event and person.
13 | Total Time/Project | Invoices are specified per project and unit cost. Posting is performed as follows: 2) Product account with number 0. 2) The first product account in the product account table (e.g. number 1 if the accounts are numbered 1, 2 and 3).
91 | Advance invoice | When invoicing an assignment using this invoicing type, invoice type 112 (Advance invoice) is used. You can specify a posting rule for type 112 for integration into the General Ledger, but the same rule must be defined in the program Posting templates, invoice totals (program xAkFh). In this way you can control posting of customer receivables and VAT.
99 | Detailed | A detailed specification of activities and expenses is printed on the invoice. Posting is performed as follows: 1) According to the product account specified for the line of business (if any). 2) Product account with number 0. 3) The first product account in the product account table (e.g. number 1 if the accounts are numbered 1, 2 and 3).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Invoicing type | UFakttbeskr | ztString | 50 |  | varchar
Invoicing type | UFakttyp | ztInteger | 3 |  | smallint

    This table is the main table in the following programs:

    Program: xu1 Invoicing type, assignmt


Item - replan any type of order (it2p)

Table with (re-)planning proposals by item and order/PO/MO.
*** in part use ***

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Work group | ArbetsLag | ztString | 6 |  | varchar
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Receive to MO | InlevTillAoNr | Jeeves_MONo | 7 |  | bigint
Receive to MO Pos | InlevTillAoPos | ztInteger | 4 |  | int
Receive to MO Op | InlevTillOpNr | ztInteger | 3 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Typ av plan att göra | It2pTo | ztInteger | 5 |  | smallint
Type of plan | It2pType | ztInteger | 5 |  | smallint
Note | KortNotering | ztString | 255 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Deliv from MO | UttagFranAoNr | Jeeves_MONo | 7 |  | bigint
Deliv from MO Pos | UttagFranAoPos | ztInteger | 5 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
ID number | X_IdNr | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: It2p Replan orders, etc.


Item calc cost-% per Inventory loc (arcc)

Definition of cost percentages per Inventory location to be used when calculating standard/average cost price for a specific Item (table ar), when functionality for cost price per Inventory location is active in the system.
Percentages can be definied for the following costs:
- Delivery cost (HemtKostnProc)
- Freight cost (FraktKostnProc)
- Indirect material cost (MtrlMoKostProc) If a record is entered for an Inventory location in this table, the percentages defined will have priority over any percentages defined on the Item record (table ar) itself.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight cost % | FraktKostnProc | ZtDecimal73 | 7 | 2 | decimal
Delivery cost % | HemtKostnProc | ZtDecimal73 | 7 | 2 | decimal
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Mtrl overhead % | MtrlMoKostProc | ZtDecimal73 | 7 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Arcc Item calc cost-% per inventory loc


Item calculation markup (arkk)

The table contains markups used to calculate the cost price and sales price in the cost calculation.
This applies to manufactured items.
The markup on purchased items is controlled from the purchase agreement.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Adm OH in cost price | AdmOmkIKalkPris | ztBoolean |  |  | char
Administr OH cost% | ArkAdmOmkProc | ztFloat | 7 | 2 | float
Sales OH cost % | ArkForsOmkProc | ztFloat | 7 | 2 | float
Calculation markup code | ArkPalKod | ztInteger | 5 |  | smallint
Calculation markup code | ArkPalKodBeskr | ztString | 50 |  | varchar
Mfg OH cost % | ArkProdOmkProc | ztFloat | 7 | 2 | float
Extra profit amount | ArkVinstPalBel | ZtBaseCurrAmount | 14 | 2 | money
Profit % | ArkVinstProc | ztFloat | 7 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales OH in cost price | ForsOmkIKalkPris | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Prod OH in cost price | ProdOmkIKalkPris | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: arkk Manufacturing markup templates


Item categories (xakh)

Definition of item category which constitutes an overall classification of items, i.e. a more general division of items. This classification is only used if the need arises, e.g. for search or statistic purposes, and does not control any processes in the system.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item category | ArtKat | ztString | 10 |  | varchar
Item category | ArtKatBeskr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Web description | webbeskr | ztString | 60 |  | varchar
This field is used in the table as follows: |
Publish on Web | webpublish | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: Xxakh Item categories


Item characteristics (eg)

The properties table is used to describe various fields which are connected to items via item type-1.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Property designation | PropertyDesc | ztString | 100 |  | varchar
PropNo. | propertyno | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: eg Properties


Item cost calc versions (arkv)

Versions of cost calculations for items.
When calculating costs you can enter different version to calculate from.
This can be used to save earlier calculations for comparison.
This can also be used to make a calculation that will apply from a date in the future.
The calculated cost price can be copied to a field on the items for the new cost price (NOTE! Not the current cost).
Another function can then copy the new price to the current price.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Calculation markup code | ArkPalKod | ztInteger | 5 |  | smallint
Calculation version no. | ArkVersion | ZtLong | 4 |  | int
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | KortNotering | ztString | 255 |  | varchar
New cost as of date | NewCostsFromDate | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sim depr cost chg % | SimAndrProcAvskrKost | ZtDecimal73 | 8 | 3 | decimal
Sim flow grp cost chg% | SimAndrProcFlgKost | ZtDecimal73 | 8 | 3 | decimal
Sim subcontr cost chg % | SimAndrProcLegoKost | ZtDecimal73 | 8 | 3 | decimal
Sim wage cost change % | SimAndrProcLoneKost | ZtDecimal73 | 8 | 3 | decimal
Sim mtrl cost change % | SimAndrProcMtrlKost | ZtDecimal73 | 8 | 3 | decimal
Sim mfg grp cost chg % | SimAndrProcPgKost | ZtDecimal73 | 8 | 3 | decimal
Sim tool cost change % | SimAndrProcVTygKost | ZtDecimal73 | 8 | 3 | decimal

    This table is the main table in the following programs:

    Program: Arkv Calculation versions


Item cost change (arsk)

Changes of inventory values caused by cost changes for an item. Records are only created for items with an inventory balance when the changes are made. The content of the table is the basis for posting inventory value changes.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Cost change journal | ArskJournNr | ZtLong | 6 |  | int
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost prc date | ArtKalkDat | ztDate |  |  | datetime
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Link inv. checking | ConnBpfDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Link delivery | ConnBpiDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Link dispatch | ConnOruDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Changed inventory value | DiffLagVarde | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Old inventory value | GammaltLagVarde | ZtBaseCurrAmount | 14 | 2 | money
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Purch price curr | InValuta | ztString | 3 |  | varchar
Phys invtry journ no. | InvJournal | ZtLong | 5 |  | int
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost update code | KalkPrisAndrTypKod | ztInteger | 5 |  | smallint
To be posted | Konteras | ztBoolean |  |  | char
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans journal no. | LthJournNr | ZtLong | 6 |  | int
New invtry value | NyttLagVarde | ZtBaseCurrAmount | 14 | 2 | money
Prev cost price BCU | OldArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Prev cost price refinement | OldArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Previous cost price mtrl | OldArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Prev budg cost prc | OldArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Prev cost prc/pc | OldArtKalkPer | ztInteger | 1 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Cost price, curr | VbKalkPris | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: Arsk Cost price change, inventory value


Item data/inventory group (arlg)

Inventory location group.
Used for totaling inventory balance on questionnaire.
If an item is kept at several inventory locations, you can group the inventory locations so that you obtain balance by group.
An inventory location group can be a sales inventory, a separate service inventory, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Acquisition method | AnskaffningsSatt | ztInteger | 2 |  | smallint
ABC code | ArtABC | ztchar | 1 |  | char
Item description | ArtBeskr | ztString | 30 |  | varchar
Specification | ArtBeskrSpec | ztString | 30 |  | varchar
Max stock level | ArtMaxLager | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Safety stock calc | ArtSecBerTyp | ztInteger | 5 |  | smallint
Safety stock days | ArtSecDagar | ztInteger | 5 |  | smallint
Safety stock level | ArtSecLager | ZtQty | 14 | 2 | decimal
Total inventory balance | BerSaldo | ZtQty | 14 | 2 | decimal
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Shortage/available balance | BristDispSaldo | ZtQty | 14 | 2 | decimal
Shortage/balance | BristSaldo | ZtQty | 14 | 2 | decimal
Available invtry balance | DispSaldo | ZtQty | 14 | 2 | decimal
Econ order quantity | Eoq | ZtQty | 14 | 2 | decimal
Purchase quantity acc days | EplDagar | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Requisition quantity | InkAnAntal | ZtQty | 14 | 2 | decimal
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purch qty according to rule | InkKvantEnlRegel | ztInteger | 5 |  | smallint
Inventory value, cost price | KalkLagerVarde | ZtBaseCurrAmount | 14 | 2 | numeric
Ordered quantity | LagBestAnt | ZtQty | 14 | 2 | decimal
Order point | LagBestPkt | ZtQty | 14 | 2 | decimal
Physical invtry diff YTD | LagDiffAnt | ZtQty | 14 | 2 | decimal
Qty used YTD | LagForbr | ZtQty | 14 | 2 | decimal
Qty used during period | LagForbrPer | ZtQty | 14 | 2 | decimal
Qty used prev yr | LagForbrPreYr | ZtQty | 14 | 2 | decimal
Rcvd delivery YTD | LagInlev | ZtQty | 14 | 2 | decimal
Received deliv during period | LagInlevPer | ZtQty | 14 | 2 | decimal
Received del prev yr | LagInlevPreYr | ZtQty | 14 | 2 | decimal
Physical inventory | LagInvAnt | ZtQty | 14 | 2 | decimal
Quoted quantity | LagOff | ZtQty | 14 | 2 | decimal
Qty on order/prod | LagOrdrAnt | ZtQty | 14 | 2 | decimal
Type of bin | LagPlatsTyp | ztString | 6 |  | varchar
Reserved quantity | LagResAnt | ZtQty | 14 | 2 | decimal
Movement qty | LagRorAnt | ZtLong | 8 |  | int
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Invtry loc group | LagStalleGrupp | ztString | 8 |  | varchar
Usage forecast 1 yr | LagUtlevPrg | ZtQty | 14 | 2 | decimal
Usage forecast this year | LagUtlevPrgAAr | ZtQty | 14 | 2 | decimal
Usage forecast prop | LagUtlevPrgForsl | ZtQty | 14 | 2 | decimal
Usage forecst nxt yr | LagUtlevPrgNAr | ZtQty | 14 | 2 | decimal
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Forecast turnover | PrgOmsVarde | ZtBaseCurrAmount | 14 | 2 | numeric
Not included in avail. balance | QtyNotInAvailInvtBal | ZtQty | 14 | 2 | decimal
Last received date | SenInlevDat | ztDate |  |  | datetime
Last disp date | SenUtlevDat | ztDate |  |  | datetime
Item group | VaruGruppBeskr | ztString | 30 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: xArlg Item info/inventory grp query


Item data/inventory location (ars)

Item details by inventory location. By inventory location it is meant the place where inventory is kept, or a delimited function within the company.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active in Amase | Active_in_inventory_control | ztBoolean |  |  | char
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Status | AmaseStatus | ztInteger | 5 |  | smallint
-Tol qty perc not rect | AnmEjAtgTolAntProcMinus | ztInteger | 5 |  | smallint
+Tol ant proc ej åtg | AnmEjAtgTolAntProcPlus | ztInteger | 5 |  | smallint
-Tol qty sftystk not rect | AnmEjAtgTolAntSakLMinus | ZtQty | 14 | 2 | decimal
Shortage tol, days | AnmEjAtgTolDgr | ztInteger | 5 |  | smallint
-Tolerans dgr ej åtg | AnmEjAtgTolDgrMinus | ztInteger | 5 |  | smallint
Excess invtry tol, days | AnmEjAtgTolDgrPlus | ztInteger | 5 |  | smallint
-Tol % sftystk not rect | AnmEjAtgTolProcSakLMinus | ZtQty | 14 | 2 | decimal
Excess invtry tol, qty | AnmodanEjAtgOvlAntSakL | ZtQty | 14 | 2 | decimal
Excess invtry tol, % | AnmodanEjAtgOvlProcSakL | ZtQty | 14 | 2 | decimal
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Excess invtry ctrl | AnmodanOverLagerEnl | ztInteger | 5 |  | smallint
-Tol qty % requisition | AnmodanTolAntProcMinus | ztInteger | 5 |  | smallint
+Tol qty % requisition | AnmodanTolAntProcPlus | ztInteger | 5 |  | smallint
- Replan.horizon | AnmodanTolDgrMinus | ztInteger | 5 |  | smallint
+Replan.horizont | AnmodanTolDgrPlus | ztInteger | 5 |  | smallint
Acq to order point | AnskaffningBestp | ztBoolean |  |  | char
Purchased | AnskaffningKop | ztBoolean |  |  | char
Acq to requirement | AnskaffningMotBehov | ztBoolean |  |  | char
Acquired via MRP run | AnskaffningNettobehov | ztBoolean |  |  | char
Acq to plan | AnskaffningPlanering | ztBoolean |  |  | char
Acquisition method | Anskaffningssatt | ztInteger | 2 |  | smallint
Manufactured | AnskaffningTillv | ztBoolean |  |  | char
Qty being picked | AntalUnderPlock | ZtQty | 14 | 2 | decimal
Item type EOQ/SS | ArpsTyp | ztInteger | 5 |  | smallint
Supplier for invtry loc | ArsLevNr | ztCompanyNo | 20 |  | varchar
ABC code | ArtABC | ztchar | 1 |  | char
Net purchase price | ArtInPris | ZtBaseCurrAmount | 14 | 2 | money
Purch price date | ArtInPrisDat | ztDate |  |  | datetime
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price (incl. tax) | ArtKalkBerInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
New cost price from date | ArtKalkBerNyttDatum | ztDate |  |  | datetime
New cost price (refinement) | ArtKalkBerNyttForadling | ZtBaseCurrAmount | 14 | 2 | money
New cost price (mtrl) | ArtKalkBerNyttMtrl | ZtBaseCurrAmount | 14 | 2 | money
Startkostnad | ArtKalkBerStart | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost prc date | ArtKalkDat | ztDate |  |  | datetime
Calculate costs | ArtKalkKod | ztBoolean |  |  | char
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Ber kalk.pris bas | ArtKalkPrel | ZtBaseCurrAmount | 14 | 2 | money
Calc cost price | ArtKalkPris | ZtBaseCurrAmount | 14 | 2 | money
Average cost price | ArtKalkSnitt | ZtBaseCurrAmount | 14 | 2 | money
Average cost prc (inv.loc.grp) | ArtKalkSnittLstGrupp | ztString | 8 |  | varchar
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Max stock level | ArtMaxLager | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Last PYR date | ArtPyrDat | ztDateTime |  |  | datetime
Safety stock calc | ArtSecBerTyp | ztInteger | 5 |  | smallint
Safety stock days | ArtSecDagar | ztInteger | 5 |  | smallint
Safety stock level | ArtSecLager | ZtQty | 14 | 2 | decimal
Auto breakdown within MO | AutoVidareNedbrInomTo | ztBoolean |  |  | char
Cost prc date (backdated) | BakdateraArtKalkDat | ztDate |  |  | datetime
Batch no. | BatchId | ztString | 30 |  | varchar
Incl in assmbly analysis | BehandlasIMontAnalys | ztBoolean |  |  | char
Bin ID required | BinLocMustEnter | ztBoolean |  |  | char
Bin rule | BinLocRule | ztInteger | 2 |  | smallint
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Purchase price budget | BudgInPris | ZtBaseCurrAmount | 14 | 2 | money
Copied from Item No. | CopiedFromArtNr | ztString | 30 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Create log for item in MRP | CreateNRPLog | ztBoolean |  |  | char
Econ order quantity | Eoq | ZtQty | 14 | 2 | decimal
Purchase quantity acc days | EplDagar | ztInteger | 5 |  | smallint
Forecast model | ForecastModel | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Requisition quantity | InkAnAntal | ZtQty | 14 | 2 | decimal
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Purch qty according to rule | InkKvantEnlRegel | ztInteger | 5 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Purch price curr | InValuta | ztString | 3 |  | varchar
Inv loc cost price grp | InvLocCostPriceGrp | ztString | 8 |  | varchar
Avail inventory balance | ItemAvailInvBal | ztString | 8 |  | varchar
Calc inventory balance | ItemCalcInvBal | ztString | 8 |  | varchar
Item Revision | ItemRevision | ZtLong | 3 |  | int
Cost update code | KalkPrisAndrTypKod | ztInteger | 5 |  | smallint
Ordered quantity | LagBestAnt | ZtQty | 14 | 2 | decimal
Ordered qty, alt unit | LagBestAntAltEnh | ZtQty | 14 | 2 | decimal
Order point | LagBestPkt | ZtQty | 14 | 2 | decimal
Block purchase quantity | LagBlockBestAnt | ZtQty | 14 | 2 | decimal
Block order quantity | LagBlockOrderAnt | ZtQty | 14 | 2 | decimal
Physical invtry diff YTD | LagDiffAnt | ZtQty | 14 | 2 | decimal
Inventory as of | LagerPerDen | ztDate |  |  | datetime
Stock build-up in days | LagerUppbyggnadIDagar | ztInteger | 5 |  | smallint
Qty used YTD | LagForbr | ZtQty | 14 | 2 | decimal
Qty used during period | LagForbrPer | ZtQty | 14 | 2 | decimal
Qty used prev yr | LagForbrPreYr | ZtQty | 14 | 2 | decimal
Qty used prev year 2 | LagForbrPreYr2 | ZtQty | 14 | 2 | decimal
Rcvd delivery YTD | LagInlev | ZtQty | 14 | 2 | decimal
Received deliv during period | LagInlevPer | ZtQty | 14 | 2 | decimal
Received del prev yr | LagInlevPreYr | ZtQty | 14 | 2 | decimal
Rcvd del prev year2 | LagInLevPreYr2 | ZtQty | 14 | 2 | decimal
Physical inventory | LagInvAnt | ZtQty | 14 | 2 | decimal
Physical invtry code | LagInvKod | ztInteger | 2 |  | smallint
Quoted quantity | LagOff | ZtQty | 14 | 2 | decimal
Inventory turnover | LagOmsHast | ztFloat | 15 | 2 | float
Invtry turnover prev year | LagOmsHastPreYr | ztFloat | 15 | 2 | float
Invtry turnov prev yr 2 | LagOmsHastPreYr2 | ztFloat | 15 | 2 | float
Qty on order/prod | LagOrdrAnt | ZtQty | 14 | 2 | decimal
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Type of bin | LagPlatsTyp | ztString | 6 |  | varchar
Reserved quantity | LagResAnt | ZtQty | 14 | 2 | decimal
Reserved qty, alt unit | LagResAntAltEnh | ZtQty | 14 | 2 | decimal
Movement qty | LagRorAnt | ZtLong | 8 |  | int
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Invtry balance, alt unit | LagsaldoAltEnh | ZtQty | 14 | 2 | decimal
Blocked quantity | LagSaldoEjAnv | ZtQty | 14 | 2 | decimal
Inventory balance blocked | LagSaldoSparrat | ztBoolean |  |  | char
Invtry balance, blocked qty | LagSaldoSparratAntal | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry loc group | LagStalleGrupp | ztString | 8 |  | varchar
Usage forecast 1 yr | LagUtlevPrg | ZtQty | 14 | 2 | decimal
Usage forecast this year | LagUtlevPrgAAr | ZtQty | 14 | 2 | decimal
Usage forecast prop | LagUtlevPrgForsl | ZtQty | 14 | 2 | decimal
Usage forecst nxt yr | LagUtlevPrgNAr | ZtQty | 14 | 2 | decimal
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Max qty per MO | MaxTillvAntPerTO | ZtQty | 14 | 2 | decimal
Assmbly analys, aftr lead time | MontAnalysEfterLedTid | ztBoolean |  |  | char
Re-plan or new order | NE_OmplanEllerNyOrder | ztInteger | 5 |  | smallint
Rule for last NE proposal | NE_RegelSistaForslag | ztInteger | 5 |  | smallint
Balance type at MRP | NE_SaldoTyp | ztInteger | 5 |  | smallint
Orig order row qty | Orp_UrsprOrdAntal | ZtQty | 14 | 2 | decimal
Per closing invtry bal | PeriodLagSaldo | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Per closing batch value | PerUtgBatchVarde | ZtBaseCurrAmount | 14 | 2 | money
Period closing stock (batch) | PerUtgLagVardeBatch | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (FIFO) | PerUtgLagVardeFifo | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (cost) | PerUtgLagVardeKalk | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (repl) | PerUtgLagVardeSInk | ZtBaseCurrAmount | 14 | 2 | money
Phase | Phase | ztInteger | 5 |  | smallint
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Forecast this year | Prognos | ZtQty | 14 | 2 | decimal
Forecast prev year | PrognosPreYr | ZtQty | 14 | 2 | decimal
Forecast prev year 2 | PrognosPreYr2 | ZtQty | 14 | 2 | decimal
Proposal for each need | ProposalForEachNeed | ztBoolean |  |  | char
Not included in avail. balance | QtyNotInAvailInvtBal | ZtQty | 14 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Delete this item | RemoveItem | ztBoolean |  |  | char
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
End date of holiday | SemesterSlutDatum | ztDate |  |  | datetime
Start date of holiday | SemesterStartDatum | ztDate |  |  | datetime
Last received date | SenInlevDat | ztDate |  |  | datetime
Last disp date | SenUtlevDat | ztDate |  |  | datetime
Setup cost/MO | ToStallKostnad | ZtCost | 16 | 6 | float
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Purchase price incl tax | Vb_InPrisInklMoms | ztMoney | 14 | 2 | money
Cost price, curr | vbArtKalkPris | ztMoney | 14 | 2 | money
Cost price, curr | vbKalkPris | ztMoney | 14 | 2 | money
Nytt kalk.pris valuta | vbKalkPrisNytt | ztMoney | 14 | 2 | money
Weighting rule | ViktningsRegel | ztString | 4 |  | varchar

    This table is the main table in the following programs:

    Program: ars Item balances

    Program: arsp Item balances, price/prod class

    Program: ArsProg Item forecast and sales

    Program: MontAn1 Assembly analysis

    Program: MontAn2 Assembly analysis

    Program: SrLa1 Assembly analysis, item


Item data/inventory location (view) (arla)

Item details by inventory location. By inventory location it is meant the place where inventory is kept, or a delimited function within the company (cold stock, spare parts stock, etc.).

Balance details, reservation totals, consumption, forecast, ABC code, order point, etc., for the item are stored on the inventory location.

This table is a view against the ‘Item data/inventory location’ (ars) table and contains a selection of information from the table and additional calculated information.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Adjust OP purch | AdjustOpPurch | ztBoolean |  |  | char
-Tol qty perc not rect | AnmEjAtgTolAntProcMinus | ztInteger | 5 |  | smallint
+Tol ant proc ej åtg | AnmEjAtgTolAntProcPlus | ztInteger | 5 |  | smallint
-Tol qty sftystk not rect | AnmEjAtgTolAntSakLMinus | ZtQty | 14 | 2 | decimal
Shortage tol, days | AnmEjAtgTolDgr | ztInteger | 5 |  | smallint
-Tolerans dgr ej åtg | AnmEjAtgTolDgrMinus | ztInteger | 5 |  | smallint
Excess invtry tol, days | AnmEjAtgTolDgrPlus | ztInteger | 5 |  | smallint
-Tol % sftystk not rect | AnmEjAtgTolProcSakLMinus | ZtQty | 14 | 2 | decimal
Excess invtry tol, qty | AnmodanEjAtgOvlAntSakL | ZtQty | 14 | 2 | decimal
Excess invtry tol, % | AnmodanEjAtgOvlProcSakL | ZtQty | 14 | 2 | decimal
-Tol qty % requisition | AnmodanTolAntProcMinus | ztInteger | 5 |  | smallint
+Tol qty % requisition | AnmodanTolAntProcPlus | ztInteger | 5 |  | smallint
- Replan.horizon | AnmodanTolDgrMinus | ztInteger | 5 |  | smallint
+Replan.horizont | AnmodanTolDgrPlus | ztInteger | 5 |  | smallint
Acq to order point | AnskaffningBestp | ztBoolean |  |  | char
Purchased | AnskaffningKop | ztBoolean |  |  | char
Acq to plan | AnskaffningPlanering | ztBoolean |  |  | char
Acquisition method | AnskaffningsSatt | ztInteger | 2 |  | smallint
Manufactured | AnskaffningTillv | ztBoolean |  |  | char
Decimal places | AntDec | ztInteger | 1 |  | smallint
Item type EOQ/SS | ArpsTyp | ztInteger | 5 |  | smallint
Supplier for invtry loc | ArsLevNr | ztCompanyNo | 20 |  | varchar
ABC code | ArtABC | ztchar | 1 |  | char
Item description | ArtBeskr | ztString | 30 |  | varchar
Item descr 2 | ArtBeskr2 | ztString | 255 |  | varchar
Specification | ArtBeskrSpec | ztString | 30 |  | varchar
Net purchase price | ArtInPris | ZtBaseCurrAmount | 14 | 2 | money
Purch price date | ArtInPrisDat | ztDate |  |  | datetime
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Calc cost price | ArtKalkPris | ZtBaseCurrAmount | 14 | 2 | money
Average cost price | ArtKalkSnitt | ZtBaseCurrAmount | 14 | 2 | money
Item class | ArtKod | ztInteger | 3 |  | smallint
Max stock level | ArtMaxLager | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Safety stock calc | ArtSecBerTyp | ztInteger | 5 |  | smallint
Safety stock days | ArtSecDagar | ztInteger | 5 |  | smallint
Safety stock level | ArtSecLager | ZtQty | 14 | 2 | decimal
Total inventory balance | BerSaldo | ZtQty | 14 | 2 | decimal
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Shortage/available balance | BristDispSaldo | ZtQty | 14 | 2 | decimal
Shortage/balance | BristSaldo | ZtQty | 14 | 2 | decimal
Available invtry balance | DispSaldo | ZtQty | 14 | 2 | decimal
Unit code | EnhetsKod | ztString | 4 |  | varchar
Econ order quantity | Eoq | ZtQty | 14 | 2 | decimal
Purchase quantity acc days | EplDagar | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company name | FtgNamn | ztString | 36 |  | varchar
Requisition quantity | InkAnAntal | ZtQty | 14 | 2 | decimal
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Purch qty according to rule | InkKvantEnlRegel | ztInteger | 5 |  | smallint
Inventory value, cost price | KalkLagerVarde | ZtBaseCurrAmount | 14 | 2 | numeric
Invtry value, refinement price | KalkLagerVardeForadling | ZtBaseCurrAmount | 14 | 2 | numeric
Invtry value, material price | KalkLagerVardeMtrl | ZtBaseCurrAmount | 14 | 2 | numeric
Ordered quantity | LagBestAnt | ZtQty | 14 | 2 | decimal
Order point | LagBestPkt | ZtQty | 14 | 2 | decimal
Physical invtry diff YTD | LagDiffAnt | ZtQty | 14 | 2 | decimal
Stocked | LagerBokas | ztBoolean |  |  | char
Inventory as of | LagerPerDen | ztDate |  |  | datetime
Qty used YTD | LagForbr | ZtQty | 14 | 2 | decimal
Qty used during period | LagForbrPer | ZtQty | 14 | 2 | decimal
Qty used prev yr | LagForbrPreYr | ZtQty | 14 | 2 | decimal
Qty used prev year 2 | LagForbrPreYr2 | ZtQty | 14 | 2 | decimal
Rcvd delivery YTD | LagInlev | ZtQty | 14 | 2 | decimal
Received deliv during period | LagInlevPer | ZtQty | 14 | 2 | decimal
Received del prev yr | LagInlevPreYr | ZtQty | 14 | 2 | decimal
Rcvd del prev year2 | LagInLevPreYr2 | ZtQty | 14 | 2 | decimal
Physical inventory | LagInvAnt | ZtQty | 14 | 2 | decimal
Physical invtry code | LagInvKod | ztInteger | 2 |  | smallint
Quoted quantity | LagOff | ZtQty | 14 | 2 | decimal
Inventory turnover | LagOmsHast | ztFloat | 15 | 2 | float
Invtry turnover prev year | LagOmsHastPreYr | ztFloat | 15 | 2 | float
Invtry turnov prev yr 2 | LagOmsHastPreYr2 | ztFloat | 15 | 2 | float
Qty on order/prod | LagOrdrAnt | ZtQty | 14 | 2 | decimal
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Type of bin | LagPlatsTyp | ztString | 6 |  | varchar
Reserved quantity | LagResAnt | ZtQty | 14 | 2 | decimal
Movement qty | LagRorAnt | ZtLong | 8 |  | int
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Blocked quantity | LagSaldoEjAnv | ZtQty | 14 | 2 | decimal
Inventory balance blocked | LagSaldoSparrat | ztBoolean |  |  | char
Invtry balance, blocked qty | LagSaldoSparratAntal | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry loc group | LagStalleGrupp | ztString | 8 |  | varchar
Usage forecast 1 yr | LagUtlevPrg | ZtQty | 14 | 2 | decimal
Usage forecast this year | LagUtlevPrgAAr | ZtQty | 14 | 2 | decimal
Usage forecast prop | LagUtlevPrgForsl | ZtQty | 14 | 2 | decimal
Usage forecst nxt yr | LagUtlevPrgNAr | ZtQty | 14 | 2 | decimal
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Re-plan or new order | NE_OmplanEllerNyOrder | ztInteger | 5 |  | smallint
Rule for last NE proposal | NE_RegelSistaForslag | ztInteger | 5 |  | smallint
Per closing invtry bal | PeriodLagSaldo | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Period closing stock (batch) | PerUtgLagVardeBatch | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (FIFO) | PerUtgLagVardeFifo | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (cost) | PerUtgLagVardeKalk | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (repl) | PerUtgLagVardeSInk | ZtBaseCurrAmount | 14 | 2 | money
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Forecast turnover | PrgOmsVarde | ZtBaseCurrAmount | 14 | 2 | numeric
Forecast this year | Prognos | ZtQty | 14 | 2 | decimal
Forecast family | PrognosFamilj | ztString | 4 |  | varchar
Forecast prev year | PrognosPreYr | ZtQty | 14 | 2 | decimal
Forecast prev year 2 | PrognosPreYr2 | ZtQty | 14 | 2 | decimal
Not included in avail. balance | QtyNotInAvailInvtBal | ZtQty | 14 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Last received date | SenInlevDat | ztDate |  |  | datetime
Last disp date | SenUtlevDat | ztDate |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Currency | ValKod | ztString | 3 |  | varchar
Item group | VaruGruppBeskr | ztString | 30 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Weighting rule | ViktningsRegel | ztString | 4 |  | varchar

    This table is the main table in the following programs:

    Program: ArsArpr Item forecast, complete

    Program: ArtInlev Received deliveries, item

    Program: ArtUtpl Picking, item

    Program: ArtUtpl2 Picking, item

    Program: rArlaLp Inventory value as of

    Program: rArlaLv1 Inventory value, product account

    Program: xArla Item balances, queries

    Program: xArlabpp Item balances, create requisition

    Program: xOrpBokL Booking, item for order

    Program: xxarla Item data/invtry location


Item data/inventory location from ASTRO (arsi_ASTRO)

Alphanumeric code for the item, BOM, fixed asset, or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Astro status | Astro_errorstatus | ztInteger | 1 |  | smallint
Batch no. | BatchId | ztString | 30 |  | varchar
@zPrompt=null | error_msg | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory balance Astro | LagSaldoAstro | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AstroBalanceDiff Balance list ASTRO


Item data/invtry loc and dispatch date (arsd)

Dispatch situation per day for an item per inventory location.
By inventory location it is meant the place where inventory is kept, or a delimited function within the company.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Available invtry balance | Arsd_LagDispSaldo | ZtQty | 14 | 2 | decimal
Total inventory balance | Arsd_LagTotSaldo | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Ordered quantity | LagBestAnt | ZtQty | 14 | 2 | decimal
Quoted quantity | LagOff | ZtQty | 14 | 2 | decimal
Qty on order/prod | LagOrdrAnt | ZtQty | 14 | 2 | decimal
Reserved quantity | LagResAnt | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Arsd Dispatch situation per day


Item data/stock location, MRP (arns)

Table containing data per inventory location on items processed in MRP. (Inventory location refers to a place where inventory is kept or a delimited function within the company.)

Inventory balance, safety stock and other fields that affect MRP are also stored in this table.
This data may have been changed on the item's inventory balance record after the requirement calculation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
-Tol qty perc not rect | AnmEjAtgTolAntProcMinus | ztInteger | 5 |  | smallint
+Tol ant proc ej åtg | AnmEjAtgTolAntProcPlus | ztInteger | 5 |  | smallint
-Tol qty sftystk not rect | AnmEjAtgTolAntSakLMinus | ZtQty | 14 | 2 | decimal
Shortage tol, days | AnmEjAtgTolDgr | ztInteger | 5 |  | smallint
-Tolerans dgr ej åtg | AnmEjAtgTolDgrMinus | ztInteger | 5 |  | smallint
Excess invtry tol, days | AnmEjAtgTolDgrPlus | ztInteger | 5 |  | smallint
-Tol % sftystk not rect | AnmEjAtgTolProcSakLMinus | ZtQty | 14 | 2 | decimal
Excess invtry tol, qty | AnmodanEjAtgOvlAntSakL | ZtQty | 14 | 2 | decimal
Excess invtry tol, % | AnmodanEjAtgOvlProcSakL | ZtQty | 14 | 2 | decimal
-Tol qty % requisition | AnmodanTolAntProcMinus | ztInteger | 5 |  | smallint
+Tol qty % requisition | AnmodanTolAntProcPlus | ztInteger | 5 |  | smallint
- Replan.horizon | AnmodanTolDgrMinus | ztInteger | 5 |  | smallint
+Replan.horizont | AnmodanTolDgrPlus | ztInteger | 5 |  | smallint
No. of rows | AntalRader | ZtLong | 10 |  | int
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Max stock level | ArtMaxLager | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Safety stock level | ArtSecLager | ZtQty | 14 | 2 | decimal
Internal text | EditInt | ztBlob | 1 |  | varchar
Econ order quantity | Eoq | ZtQty | 14 | 2 | decimal
Purchase quantity acc days | EplDagar | ztInteger | 5 |  | smallint
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Requisition quantity | InkAnAntal | ZtQty | 14 | 2 | decimal
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Purch qty according to rule | InkKvantEnlRegel | ztInteger | 5 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Ordered quantity | LagBestAnt | ZtQty | 14 | 2 | decimal
Order point | LagBestPkt | ZtQty | 14 | 2 | decimal
Quoted quantity | LagOff | ZtQty | 14 | 2 | decimal
Qty on order/prod | LagOrdrAnt | ZtQty | 14 | 2 | decimal
Reserved quantity | LagResAnt | ZtQty | 14 | 2 | decimal
Movement qty | LagRorAnt | ZtLong | 8 |  | int
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Usage forecast 1 yr | LagUtlevPrg | ZtQty | 14 | 2 | decimal
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Max qty per MO | MaxTillvAntPerTO | ZtQty | 14 | 2 | decimal
Re-plan or new order | NE_OmplanEllerNyOrder | ztInteger | 5 |  | smallint
MRP batch -> Sign/mgr | NE_PlanAnsv | ztString | 8 |  | varchar
Rule for last NE proposal | NE_RegelSistaForslag | ztInteger | 5 |  | smallint
Balance type at MRP | NE_SaldoTyp | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Forecast this year | Prognos | ZtQty | 14 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: arns MRP runs, history


Item definition per unit (WMS_PartDefUOM)

Definition of applicable units of measure per item with WMS specific data regarding storage, replenishment etc. The program/table is accessed via an embedded list window in the Item definition program (WMS_partdef).

First you must define all units of measure, including full pallets, for your WMS items in the programs for Alternative units (xae) and Alternative units per item (xare). Then you add WMS specific information for each individual unit of measure in this program/table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
X Pos. | LocXPos | ztString | 5 |  | varchar
Y Pos. | LocYPos | ztString | 5 |  | varchar
MHA | Mha | ztString | 5 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Rack | Rack | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Repl assignment type | ReplAssTypeCode | ztInteger | 3 |  | smallint
Min qty | ReplMinQty | ZtQty | 14 | 2 | decimal
Repl qty | ReplQty | ZtQty | 14 | 2 | decimal
Repl storage type | ReplStorageTypeCode | ztInteger | 3 |  | smallint
Repl unit code | ReplUOM | ztString | 10 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Exact match | StorageExactMatch | ztBoolean |  |  | char
Storage type | StorageTypeCode | ztInteger | 3 |  | smallint
Unit code | UOM | ztString | 10 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_PartDefUOM Item definition per unit


Item definition WMS (WMS_PartDef)

Definition of items to be processed by the WMS module with information about frequency, replenishment logic, buffer MHA, picking MHA, etc. This is one of the most important parts in the setup of the WMS module.

You create one record per item and inventory location (in order to be able to do so, a corresponding record in the Item balance table (ars) must exist) and in the embedded list window you create one record per item and unit of measure.

You can only set up items for inventory locations that have been flagged as WMS inventory locations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Frequency | Frequence | ztString | 1 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
X pos, buffer | PartDefBuffLocXPos | ztString | 5 |  | varchar
Y pos, buffer | PartDefBuffLocYPos | ztString | 5 |  | varchar
Exact match, buffer | PartDefBuffMatch | ztBoolean |  |  | char
MHA, buffer | PartDefBuffMha | ztString | 5 |  | varchar
Rack, buffer | PartDefBuffRack | ztString | 5 |  | varchar
Change permitted (%) | PartDefCountAllowPercent | ztInteger | 5 |  | smallint
Activation level (%) | PartDefCountTrigPercent | ztInteger | 5 |  | smallint
Full pallet quantity | PartDefFullUnitQty | ZtQty | 14 | 2 | decimal
Pallet unit type | PartDefFullUnitType | ztString | 5 |  | varchar
Floating picking location | PartDefPickFloat | ztBoolean |  |  | char
Exact match, pick | PartDefPickFloatMatch | ztBoolean |  |  | char
X pos, pick | PartDefPickLocXPos | ztString | 5 |  | varchar
Y pos, pick | PartDefPickLocYPos | ztString | 5 |  | varchar
MHA, pick | PartDefPickMha | ztString | 5 |  | varchar
Min qty | PartDefPickMinQty | ZtQty | 14 | 2 | decimal
Replenishment, qty | PartDefPickOrderQty | ZtQty | 14 | 2 | decimal
Rack, pick | PartDefPickRack | ztString | 5 |  | varchar
Replenishment | PartDefReplenishment | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Lead time, best before | SKULeadTimeBestBefore | ztInteger | 3 |  | smallint
Lead time, pick before | SKULeadTimePickBefore | ztInteger | 3 |  | smallint

    This table is the main table in the following programs:

    Program: WMS_PartDef Item definition


Item descriptions, language (arb)

Table of item designations in different languages for use in external documents.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item description | ArtBeskr | ztString | 30 |  | varchar
Item descr 2 | ArtBeskr2 | ztString | 255 |  | varchar
Specification | ArtBeskrSpec | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Web description | webBeskr | ztString | 60 |  | varchar

    This table is the main table in the following programs:

    Program: Arb Item descriptions, language


Item forecast (Arpr)

Contains sales forecast by article at all forecast levels.
Used as data to create the pne table, which is the basis for the net requirements batch.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Status | AmaseStatus | ztInteger | 5 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Forecast model | ForecastModel | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Main period | HuvudPeriod | ztString | 25 |  | varchar
Master plan number | HuvudPlanNr | ZtLong | 10 |  | int
Keep year forecast | KeepYearValue | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Phase | Phase | ztInteger | 5 |  | smallint
Period forecast | PrognosAntalPeriod | ZtQty | 14 | 2 | decimal
Forecast family | PrognosFamilj | ztString | 4 |  | varchar
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Forecast key | PrognosNyckel | ztString | 25 |  | varchar
Forecast period | PrognosPeriod | ztString | 25 |  | varchar
Forecast version | PrognosVer | ZtLong | 4 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Arpr Item forecast

    Program: ItemForecast Item forecast


Item forecast (view) (Arpr_view)

Contains sales forecast by article at all forecast levels.
Used as data to create the pne table, which is the basis for the net requirements batch.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Status | AmaseStatus |  |  |  | @DataType=NULL
Item no. | ArtNr |  |  |  | @DataType=NULL
Forecast model | ForecastModel |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Main period | HuvudPeriod |  |  |  | @DataType=NULL
Master plan number | HuvudPlanNr |  |  |  | @DataType=NULL
Keep year forecast | KeepYearValue |  |  |  | @DataType=NULL
Inventory location | LagStalle |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Phase | Phase |  |  |  | @DataType=NULL
Period forecast | PrognosAntalPeriod |  |  |  | @DataType=NULL
Forecast family | PrognosFamilj |  |  |  | @DataType=NULL
Forecast level | PrognosNiva |  |  |  | @DataType=NULL
Forecast key | PrognosNyckel |  |  |  | @DataType=NULL
Forecast period | PrognosPeriod |  |  |  | @DataType=NULL
Forecast version | PrognosVer |  |  |  | @DataType=NULL
Fiscal year | Redovisnar |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Columns updated | RowUpdatedCols |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL


Item forecast/sales, forecast parameters (apfp)

Contains parameter values for defining forecast data for Current/Following year, when the forecast values will be retrieved from
the table ARPR - Item forecast in a special query program from Item forecast and sales (ArsProg).
These parameter values are necessary to be able to retrieve the correct forecast values from the table ARPR - Item forecast.
JEEVES System parameter SALES135, Forecast values in the program item forecast/sales is used to activate this function.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Monthly forecast, this year | PrognosNivaManadIAr | ztInteger | 5 |  | smallint
Monthly forecast, next year | PrognosNivaManadNAr | ztInteger | 5 |  | smallint
Forecast key, this year | PrognosNyckelIAr | ztString | 25 |  | varchar
Forecast key, next year | PrognosNyckelNAr | ztString | 25 |  | varchar
Forecast version, this year | PrognosVerIAr | ZtLong | 4 |  | int
Forecast version, next year | PrognosVerNAr | ZtLong | 4 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Apfp Item forecast/sales, forecast parameters


Item group roles (vgr)

Definition of item group roles, consisting of one or more item groups, that are used for e-purchasing.

The item group role is linked to a purchasing role (and therefore to the individuals who have a specific purchasing role) in order to specify within which item groups items can be purchased by the relevant purchasing role.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group roles | Varugrupproll | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: Vgr Item group roles


Item group roles, details (vgrd)

Item group roles, details

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | sprakkod | ztInteger | 3 |  | smallint
Item group | varugruppbeskr | ztString | 30 |  | varchar
Item group | varugruppkod | ztString | 8 |  | varchar
Item group roles | varugrupproll | ztInteger | 4 |  | smallint


Item group statistics (svgl)

Statistics per item group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Budgeted amount | BudgBelopp | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Period invoiced qty | PerFaktAnt | ZtQty | 14 | 2 | decimal
Per invcd qty (wholesale) | PerFaktAntGross | ZtQty | 14 | 2 | decimal
Per invoiced amt | PerFaktBel | ZtBaseCurrAmount | 14 | 2 | money
CSG | PerFaktRadKost | ZtBaseCurrAmount | 14 | 2 | money
Per försenade inl | PerForsenInLev | ZtQty | 14 | 2 | decimal
Per försenade utlev | PerForsenUtLev | ZtQty | 14 | 2 | decimal
Per avg inventory bal | PerGenomsnittsLager | ztFloat | 15 | 2 | float
Period | Period | ztInteger | 4 |  | smallint
Per closing invtry bal | PeriodLagSaldo | ZtQty | 14 | 2 | decimal
Lager*dagar | PerLagerGgrDagar | ZtQty | 14 | 2 | decimal
Per inventory turnover | PerLagOmsHast | ztFloat | 15 | 2 | float
Per order intake qty | PerOrderIng | ZtQty | 14 | 2 | decimal
Per utg ord.stock ant | PerOrderStock | ZtQty | 14 | 2 | decimal
Period rcvd deliveries | PerTotInlev | ZtQty | 14 | 2 | decimal
Period dispatches | PerTotUtlev | ZtQty | 14 | 2 | decimal
Dispatch/per (wholesaler) | PerTotUtlevGross | ZtQty | 14 | 2 | decimal
Per closing bal (FIFO) | PerUtgLagVardeFifo | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (cost) | PerUtgLagVardeKalk | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (repl) | PerUtgLagVardeSink | ZtBaseCurrAmount | 14 | 2 | money
Per utg pia arbete | PerUtgPiaao | ZtQty | 14 | 2 | decimal
Per utg pia inköp | PerUtgPiaBp | ZtQty | 14 | 2 | decimal
Per utg pia material | PerUtgPiaMr | ZtQty | 14 | 2 | decimal
Per utg pia kundorder | PerUtgPiaOrp | ZtQty | 14 | 2 | decimal
Per utg pia tillv.inlev | PerUtgPiaTi | ZtQty | 14 | 2 | decimal
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar


Item group statistics period (svgp)

Statistics for item group per year and period.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Budgeted amount | Budgbelopp | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Per invoiced amt | PerFaktBel | ZtBaseCurrAmount | 14 | 2 | money
CSG | PerFaktRadKost | ZtBaseCurrAmount | 14 | 2 | money
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: svgp Item group statistics


Item groups (vg)

Definition of the item/product groups in which the company's items/products are organized.

The item group is the next level above the item in the item data structure. Item groups can in turn be linked to the next level up, the product class.

Item group names are stored for each language. The names are used as the default and copied to the first row of item descriptions and printed on documents, unless they are replaced with different text.

Item group 0 should always be present, because many programs in Jeeves use item group 0 if no item is defined.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item class | ArtKod | ztInteger | 3 |  | smallint
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Capacity consume | CapacityConsume | ZtLong | 5 |  | int
Early settlmt discnt goods | CashDiscount | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Lead time to PO/MO | LedTid_orp_2_bp_ti | ztInteger | 5 |  | smallint
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Item group | VaruGruppBeskr | ztString | 30 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Web item text | webarttext | ztString | 255 |  | varchar
Web description | webBeskr | ztString | 60 |  | varchar
Publish on Web | webPublish | ztBoolean |  |  | char
Web text | wLongDescription | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: vg Item groups


Item groups for Mfr (FrVg)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Item class | artkod | ztInteger | 3 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Product class | artprodklass | ztString | 4 |  | varchar
Dispatch date | DeliveryDate | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Link ID | FrVgTypKod | ztString | 10 |  | varchar
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Item individual reference | IndividRef | ztString | 35 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Item type 1 | ItemTypeCd1 | ztInteger | 5 |  | smallint
Item type 2 | ItemTypeCd2 | ztInteger | 5 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Order row qty | ordantal | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLidentity | ZtLong | 10 |  | int
Item group | varugruppkod | ztString | 8 |  | varchar


Item groups for Pro (ProVg)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item class | ArtKod | ztInteger | 3 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Product class | artprodklass | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Item type 1 | ItemTypeCd1 | ztInteger | 5 |  | smallint
Item type 2 | ItemTypeCd2 | ztInteger | 5 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Order row qty | ordantal | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Business opportunity ID | prospektid | ZtLong | 10 |  | int
Link ID | ProVgTypKod | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLidentity | ZtLong | 10 |  | int
Item group | varugruppkod | ztString | 8 |  | varchar


Item groups per item category (xakl)

Definition of which item groups belong to an item category. The item category is an overall classification and is only used if the need arises, e.g. for search or statistic purposes, and does not control any processes in the system.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item category | ArtKat | ztString | 10 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: Xxakl Item groups per item category


Item groups VIEW (vvg)

Item groups with information about item class and language code.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item class | ArtKod | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Language | SprakKod | ztInteger | 3 |  | smallint
Item group | VaruGruppBeskr | ztString | 30 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar


Item product accounts (arpk)

Definition of existing product accounts. Each item must be linked to a product account.

The product accounts can, if desired, be used to control how sales and inventory events will be posted. You can set up these posting templates in the programs 'Posting templates, invoice rows' (xAkFt) or 'Posting templates, inventory' (xAkLt) or in the embedded list windows in this program. If the product accounts are not to control the postings, you can use the independent programs and leave the product account field blank.

The product account header also has a function button with which you can copy the posting control from the relevant product account to another product account.

If you do not fill in an account segment in the posting details (in the embedded list windows) the account segment is retrieved from the product account header if one is specified there.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allow deliv non-stocked item | AllowDelivOfNonStockItem | ztBoolean |  |  | char
Allow invc qty > disp qty | AllowInvQtyGTDelivQty | ztBoolean |  |  | char
Calculation markup code | ArkPalKod | ztInteger | 5 |  | smallint
This field is used in the table as follows: |
Product acct | ArtprodKonto | ztString | 8 |  | varchar
Product acct | ArtProdKontoBeskr | ztString | 60 |  | varchar
Overhead cost % | cmfPalaggsProcent | ZtDecimal73 | 8 | 3 | decimal
New overhead cost % | cmfPalaggsProcentNytt | ZtDecimal73 | 8 | 3 | decimal
Post COG from Assignm | COGFlagA | ztBoolean |  |  | char
Cost acc to purchase price | CostPriceFromPurPrice | ztInteger | 1 |  | smallint
Invoice segment 4 | FaktK4 | ztString | 8 |  | varchar
Invoice segment 5 | Faktk5 | ztString | 8 |  | varchar
Invoice segment 6 | FaktK6 | ztString | 8 |  | varchar
Invoice segment 7 | FaktK7 | ztString | 8 |  | varchar
Invoice cost unit | FaktKostBar | ztString | 8 |  | varchar
Invoice cost centre | FaktKostStalleKod | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Base value markup % | GOPalaggsProcent | ZtDecimal73 | 8 | 3 | decimal
New base value markup % | GOPalaggsProcentNytt | ZtDecimal73 | 8 | 3 | decimal
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Rec del, mtrl+refinement | InkKontMtrlOchForadling | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calc mtrl acc to budg pur prc | KalkMtrlEnlBudgInPris | ztBoolean |  |  | char
Average weighted | KalkylPrisEnlSnittPris | ztBoolean |  |  | char
Extra post del order | KontBeInlevRegel1 | ztBoolean |  |  | char
Overhead cost. | KonteraCMFPalagg | ztBoolean |  |  | char
Post base value markup | KonteraGOPalagg | ztBoolean |  |  | char
Post cost of sold goods | KonteraKSV | ztBoolean |  |  | char
Post prel rev at dispatch | KonteraPrelFaktVardeUtlev | ztBoolean |  |  | char
Extra post picking | KontUtplRegel1 | ztBoolean |  |  | char
Extra post picking | KontUtplRegel2 | ztBoolean |  |  | char
Cost post purchasing | KostKontInkop | ztBoolean |  |  | char
Cost centre, intrn sales | KostStalleKodIntFsg | ztString | 8 |  | varchar
Separate invtry calc | LagerKalkyl | ztBoolean |  |  | char
Value to price | LagerVardeEnlInPris | ztBoolean |  |  | char
Picking, mtrl+refinement | LevKontMtrlOchForadling | ztBoolean |  |  | char
Allow negative invtry qty | Mark_Allow_Neg_Stock_Qty | ztBoolean |  |  | char
Allow negative invtry/bin | Mark_Allow_Neg_Stock_Qty_Arsi | ztBoolean |  |  | char
FIFO | Mark_FIFO | ztBoolean |  |  | char
LIFO | Mark_LIFO | ztBoolean |  |  | char
Ord spec cost price | MarkOrderUniktKalkP | ztBoolean |  |  | char
Mtrl overhead % | MtrlMoKostProc | ZtDecimal73 | 7 | 2 | decimal
Indir mtrl OH % (new) | MtrlMoKostProcNytt | ZtDecimal73 | 7 | 2 | decimal
New cost as of date | NewCostsFromDate | ztDate |  |  | datetime
Pick post via pick journ | OrdUtplKontViaUtplJourn | ztBoolean |  |  | char
OSI cost price according to MO cost | OUSCostPriceFromMfgPreCost | ztBoolean |  |  | char
OrdSpec cost prc = purch prc | OUSCostPriceFromPurPrice | ztBoolean |  |  | char
Lot handling | PartiHantering | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Prel post tax at deliv | PrelKonteraMomsVidInlev | ztBoolean |  |  | char
Extra overhead cost2 % | q_ALFA_EO2PalaggsProcent | ZtDecimal73 | 8 | 3 | decimal
New extra overhead cost 2% | q_ALFA_EO2PalaggsProcentNytt | ZtDecimal73 | 8 | 3 | decimal
Extra overhead cost % | q_ALFA_EOPalaggsProcent | ZtDecimal73 | 8 | 3 | decimal
New extra overhead cost % | q_ALFA_EOPalaggsProcentNytt | ZtDecimal73 | 8 | 3 | decimal
Base value markup 2 % | q_ALFA_GO2PalaggsProcent | ZtDecimal73 | 8 | 3 | decimal
New base value markup 2 % | q_ALFA_GO2PalaggsProcentNytt | ZtDecimal73 | 8 | 3 | decimal
Posting extra overhead2 | q_ALFA_KonteraEO2Palagg | ztBoolean |  |  | char
Posting extra overhead | q_ALFA_KonteraEOPalagg | ztBoolean |  |  | char
Posting basevalue 2 | q_ALFA_KonteraGO2Palagg | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: xArtpk Product account


Item qualification codes (arpkw)

Definition of alphanumeric codes for qualification of goods and services according to a custom-defined or otherwise established terminology.

May, for example, be any country-specific condition that establishes that goods and services must be qualified according to specific, established terminology. An example of this is Poland, where there is a provision that goods and services must have a so-called PKWiU number (Polish Qualification of Articles and Services) defined in terminology established by a government authority.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Qualification description | ArtKvalifBeskr | ztString | 60 |  | varchar
Qualification ID | ArtKvalifId | ZtLong | 6 |  | int
Qualification number | ArtKvalifNr | ztString | 20 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Arpkw Item qualification codes


Item revision status (ItemRevisionStatus)

Status for items according to your own definition.

The item status governs the flag whether the item can be used or not (see 'Can item be used' field (ItemOkToUse)).

The term can also be used as a search concept if there are regular/major changes in the product range.

The following standard records exist. Do not alter/delete:

Item rev status
(ItemRevisionStatus) 		Item revision status
(ItemRevisionStatusDescr)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Allow changes | ItemRevAllowChanges | ztBoolean |  |  | char
Item rev status | ItemRevisionStatus | ztInteger | 5 |  | smallint
Item revision status | ItemRevisionStatusDescr | ztString | 80 |  | varchar
Item rev OK to use? | ItemRevOkToUse | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ItemRevisionStatus Item revision status


Item revision subject (ItemRevisionSubject)

Status for items according to your own definition.

The item status governs the flag whether the item can be used or not (see 'Can item be used' field (ItemOkToUse)).

The term can also be used as a search concept if there are regular/major changes in the product range.

The following standard records exist. Do not alter/delete:

Item rev subject
(ItemRevisionSubject) 		Columns updated
(RowUpdatedCols)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Item rev subject | ItemRevisionSubject | ztInteger | 5 |  | smallint
Item revision subject | ItemRevisionSubjectDescr | ztString | 80 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ItemRevisionSubject Item revision subject


Item statistics (sars)

Total order entry, inventory and sales statistics per item.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Product class | ArtProdKlass | ztString | 4 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Period invoiced qty | PerFaktAnt | ZtQty | 14 | 2 | decimal
Per invcd qty (wholesale) | PerFaktAntGross | ZtQty | 14 | 2 | decimal
Per invoiced amt | PerFaktBel | ZtBaseCurrAmount | 14 | 2 | money
CSG | PerFaktRadKost | ZtBaseCurrAmount | 14 | 2 | money
Per försenade inl | PerForsenInLev | ZtQty | 14 | 2 | decimal
Per försenade utlev | PerForsenUtLev | ZtQty | 14 | 2 | decimal
Per avg inventory bal | PerGenomsnittsLager | ztFloat | 15 | 2 | float
Period | Period | ztInteger | 4 |  | smallint
Per closing invtry bal | PeriodLagSaldo | ZtQty | 14 | 2 | decimal
Lager*dagar | PerLagerGgrDagar | ZtQty | 14 | 2 | decimal
Per inventory turnover | PerLagOmsHast | ztFloat | 15 | 2 | float
Per order intake qty | PerOrderIng | ZtQty | 14 | 2 | decimal
Per utg ord.stock ant | PerOrderStock | ZtQty | 14 | 2 | decimal
Period rcvd deliveries | PerTotInlev | ZtQty | 14 | 2 | decimal
Per rcvd del drop shipm | PerTotInlevDirekt | ZtQty | 14 | 2 | decimal
Per rcvd del inventory | PerTotInlevLager | ZtQty | 14 | 2 | decimal
Per rcvd del trf not csums | PerTotInlevLgrFlyttEjForbr | ZtQty | 14 | 2 | decimal
Per rcvd del trf csums | PerTotInlevLgrFlyttForbr | ZtQty | 14 | 2 | decimal
Per rcvd del man trf not cs | PerTotInlevManTransEjForbr | ZtQty | 14 | 2 | decimal
Per rcvd del man trf cs | PerTotInlevManTransForbr | ZtQty | 14 | 2 | decimal
Per rcvd del transit | PerTotInlevTransit | ZtQty | 14 | 2 | decimal
Period dispatches | PerTotUtlev | ZtQty | 14 | 2 | decimal
Per disp drop shipm | PerTotUtlevDirekt | ZtQty | 14 | 2 | decimal
Dispatch/per (wholesaler) | PerTotUtlevGross | ZtQty | 14 | 2 | decimal
Per disp inventory | PerTotUtlevLager | ZtQty | 14 | 2 | decimal
Per disp trf not csums | PerTotUtlevLgrFlyttEjForbr | ZtQty | 14 | 2 | decimal
Per disp transf csums | PerTotUtlevLgrFlyttForbr | ZtQty | 14 | 2 | decimal
Per disp man trf not cs | PerTotUtlevManTransEjForbr | ZtQty | 14 | 2 | decimal
Per disp man trf csums | PerTotUtlevManTransForbr | ZtQty | 14 | 2 | decimal
Per dispatches transit | PerTotUtlevTransit | ZtQty | 14 | 2 | decimal
Per closing batch value | PerUtgBatchVarde | ZtBaseCurrAmount | 14 | 2 | money
Period closing stock (batch) | PerUtgLagVardeBatch | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (FIFO) | PerUtgLagVardeFifo | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (cost) | PerUtgLagVardeKalk | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (repl) | PerUtgLagVardeSink | ZtBaseCurrAmount | 14 | 2 | money
Per utg pia arbete | PerUtgPiaao | ZtQty | 14 | 2 | decimal
Per utg pia inköp | PerUtgPiaBp | ZtQty | 14 | 2 | decimal
Per utg pia material | PerUtgPiaMr | ZtQty | 14 | 2 | decimal
Per utg pia kundorder | PerUtgPiaOrp | ZtQty | 14 | 2 | decimal
Per utg pia tillv.inlev | PerUtgPiaTi | ZtQty | 14 | 2 | decimal
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: rSars21 Item statistics


Item statistics (view) (vsar)

Extract from (view of) the Item statistics table (sars) containing overall order intake, inventory and sales statistics per item.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item description | ArtBeskr | ztString | 30 |  | varchar
Item descr 2 | ArtBeskr2 | ztString | 255 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Product class | ArtProdKlass | ztString | 4 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Period invoiced qty | PerFaktAnt | ZtQty | 14 | 2 | decimal
Per invcd qty (wholesale) | PerFaktAntGross | ZtQty | 14 | 2 | decimal
Per invoiced amt | PerFaktBel | ZtBaseCurrAmount | 14 | 2 | money
CSG | PerFaktRadKost | ZtBaseCurrAmount | 14 | 2 | money
Per försenade inl | PerForsenInLev | ZtQty | 14 | 2 | decimal
Per försenade utlev | PerForsenUtLev | ZtQty | 14 | 2 | decimal
Per avg inventory bal | PerGenomsnittsLager | ztFloat | 15 | 2 | float
Period | Period | ztInteger | 4 |  | smallint
Per closing invtry bal | PeriodLagSaldo | ZtQty | 14 | 2 | decimal
Lager*dagar | PerLagerGgrDagar | ZtQty | 14 | 2 | decimal
Per inventory turnover | PerLagOmsHast | ztFloat | 15 | 2 | float
Per order intake qty | PerOrderIng | ZtQty | 14 | 2 | decimal
Per utg ord.stock ant | PerOrderStock | ZtQty | 14 | 2 | decimal
Period rcvd deliveries | PerTotInlev | ZtQty | 14 | 2 | decimal
Per rcvd del drop shipm | PerTotInlevDirekt | ZtQty | 14 | 2 | decimal
Per rcvd del inventory | PerTotInlevLager | ZtQty | 14 | 2 | decimal
Per rcvd del trf not csums | PerTotInlevLgrFlyttEjForbr | ZtQty | 14 | 2 | decimal
Per rcvd del trf csums | PerTotInlevLgrFlyttForbr | ZtQty | 14 | 2 | decimal
Per rcvd del man trf not cs | PerTotInlevManTransEjForbr | ZtQty | 14 | 2 | decimal
Per rcvd del man trf cs | PerTotInlevManTransForbr | ZtQty | 14 | 2 | decimal
Per rcvd del transit | PerTotInlevTransit | ZtQty | 14 | 2 | decimal
Period dispatches | PerTotUtlev | ZtQty | 14 | 2 | decimal
Per disp drop shipm | PerTotUtlevDirekt | ZtQty | 14 | 2 | decimal
Dispatch/per (wholesaler) | PerTotUtlevGross | ZtQty | 14 | 2 | decimal
Per disp inventory | PerTotUtlevLager | ZtQty | 14 | 2 | decimal
Per disp trf not csums | PerTotUtlevLgrFlyttEjForbr | ZtQty | 14 | 2 | decimal
Per disp transf csums | PerTotUtlevLgrFlyttForbr | ZtQty | 14 | 2 | decimal
Per disp man trf not cs | PerTotUtlevManTransEjForbr | ZtQty | 14 | 2 | decimal
Per disp man trf csums | PerTotUtlevManTransForbr | ZtQty | 14 | 2 | decimal
Per dispatches transit | PerTotUtlevTransit | ZtQty | 14 | 2 | decimal
Per closing batch value | PerUtgBatchVarde | ZtBaseCurrAmount | 14 | 2 | money
Period closing stock (batch) | PerUtgLagVardeBatch | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (FIFO) | PerUtgLagVardeFifo | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (cost) | PerUtgLagVardeKalk | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (repl) | PerUtgLagVardeSink | ZtBaseCurrAmount | 14 | 2 | money
Per utg pia arbete | PerUtgPiaao | ZtQty | 14 | 2 | decimal
Per utg pia inköp | PerUtgPiaBp | ZtQty | 14 | 2 | decimal
Per utg pia material | PerUtgPiaMr | ZtQty | 14 | 2 | decimal
Per utg pia kundorder | PerUtgPiaOrp | ZtQty | 14 | 2 | decimal
Per utg pia tillv.inlev | PerUtgPiaTi | ZtQty | 14 | 2 | decimal
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group | VaruGruppBeskr | ztString | 30 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: xSars Item statistics


Item status (xits)

Status for items according to your own definition.

The item status governs the flag whether the item can be used or not (see 'Can item be used' field (ItemOkToUse)).

The term can also be used as a search concept if there are regular/major changes in the product range.

The following standard records exist. Do not alter/delete:

Item status (ItemStatusCode) | Item status (ItemStatusDescr)
0 | Sellable
2 | Under construction
3 | Preparation for production
4 | Active / Approved for production
8 | Outgoing item
9 | Obsolete item

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sellable item | ArtSaljBar | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Item OK to offer | ItemOkToOffer | ztBoolean |  |  | char
Item OK to use? | ItemOkToUse | ztBoolean |  |  | char
Item status | ItemStatusCode | ztInteger | 5 |  | smallint
Item status | ItemStatusDescr | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Outgoing item | UtgArtikel | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xits Item status


Item to be marked for deletion (Jeeves_View_Remove_Item_Check)

Database view which shows quantity per item:
- order rows
- purchase order rows
- manufacturing orders
- manual inventory transactions

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Late invtry trans date | LastStockTranDate | ztInteger | 4 |  | smallint
No. of bins <> 0 | NO_BinLocNZ | ztInteger | 4 |  | smallint
No. of MOs | NO_MO | ztInteger | 4 |  | smallint
Number of material reservations | NO_MR | ztInteger | 4 |  | smallint
No. of manual invtry trans | NO_MST | ztInteger | 4 |  | smallint
Quantity order-specific invtry | NO_OUS | ztInteger | 4 |  | smallint
No. of purchase orders | NO_PO | ztInteger | 4 |  | smallint
No. of sales orders | NO_SO | ztInteger | 4 |  | smallint
Quantity inventory <> 0 | NO_StockLocNZ | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Delete this item | RemoveItem | ztBoolean |  |  | char
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: RemoveItemAndInfo Mark items for deletion, with info


Item type (PVMItemType)

Table that contains item types for variant items, for example item master, item attribute, variant item.

The following standard records exist. Do not alter/delete:

Item type ID (PVMItemTypeId) | Item Type Descr (PVMItemTypeDescr) | Description
10 | Item master | Manually entered item master, used for creating product variants. This top level, fictitious item does not have an inventory balance and it is not possibile to place orders on it.
20 | Item attribute | Automatically created item attribute, one record for each combination of intermediate level attributes. This intermediate level fictitious item does not have an inventory balance and it is not possibile to place orders on it.
30 | Variant item | Automatically created item variant, one record for each combination of last level attributes. This last level actual item has an inventory balance and it is possibile to place orders on it.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Item Type Descr | PVMItemTypeDescr | ztString | 50 |  | varchar
Item type ID | PVMItemTypeId | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PVMItemType Item Type


Item type characteristics (egatp)

This is where the properties to be displayed for a given item type are specified.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Item type 1 | ItemTypeCd1 | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
PropNo. | propertyno | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sorteringsordning egenskaper | sorteg | ztInteger | 4 |  | smallint


Item types 1 (atp1)

Definition of item types for optional categorization of the items. There are 6 item type tables of which this is the first, which means that you can build up to 6 different categorizations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Item type 1 | ItemTypeCd1 | ztInteger | 5 |  | smallint
Item type description | ItemTypeDesc | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Atp1 Item types 1


Item types 2 (atp2)

Definition of item types for optional categorization of the items. There are 6 item type tables of which this is the second, which means that you can build up to 6 different categorizations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Item type 2 | ItemTypeCd2 | ztInteger | 5 |  | smallint
Item type description | ItemTypeDesc | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Atp2 Item types 2


Item types 3 (atp3)

Definition of item types for optional categorization of the items. There are 6 item type tables of which this is the third, which means that you can build up to 6 different categorizations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Item type 3 | ItemTypeCd3 | ztInteger | 5 |  | smallint
Item type description | ItemTypeDesc | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Atp3 Item types 3


Item types 4 (atp4)

Definition of item types for optional categorization of the items. There are 6 item type tables of which this is the fourth, which means that you can build up to 6 different categorizations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Item type 4 | ItemTypeCd4 | ztInteger | 5 |  | smallint
Item type description | ItemTypeDesc | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Atp4 Item types 4


Item types 5 (Atp5)

Definition of item types for optional categorization of the items. There are 6 item type tables of which this is the fifth, which means that you can build up to 6 different categorizations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Item type 5 | ItemTypeCd5 | ztInteger | 5 |  | smallint
Item type description | ItemTypeDesc | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Atp5 Item types 5


Item types 6 (Atp6)

Definition of item types for optional categorization of the items. There are 6 item type tables of which this is the sixth, which means that you can build up to 6 different categorizations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Item type 6 | ItemTypeCd6 | ztInteger | 5 |  | smallint
Item type description | ItemTypeDesc | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Atp6 Item types 6


Item types/classes (xm)

Definition of item classes which constitute an overall classification of item groups, i.e. a more general division of items. The information can be used to control whether item groups within the category will display on the Web or not.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item class | ArtKod | ztInteger | 3 |  | smallint
Item class | ArtTypBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Web item text | webarttext | ztString | 255 |  | varchar
Web description | webBeskr | ztString | 60 |  | varchar
Publish on Web | webPublish | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: Xxm Item classes


Item types/classes, plan mgr -> purch (xmpi)

A buyer can be defined per item class and planning manager. Customer specific function.

Those planning are responsible for different types of end product. A planning manger is responsible for an entire manufacturing order, which can consist of several thousand purchased items. These purchased items are divided up into different classes/groups, which the buyers take care of.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item class | ArtKod | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xmpi Purchaser/planning manager


Item types/safety stock calc (arat)

Definition of item types that can be used to
- specify inventory cost and order overhead to calculate the economic order quantity per item type, and
- perform ABC analysis per item type.

Item type combined with ABC code constitutes a safety stock type. Calculation of safety stock can be done for each safety stock type.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item type EOQ/SS | ArpsTyp | ztInteger | 5 |  | smallint
Item type EOQ/SS | ArpsTypBeskr | ztString | 50 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory cost % | LagerKostProc | ZtDecimal73 | 6 | 2 | decimal
Order overhead | Ordersarkostnad | ZtBaseCurrAmount | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Arat Item types EOQ/safety stock


Item, forecast version (arpv)

Alphanumeric code for the item, BOM, fixed asset, or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item class | ArtKod | ztInteger | 3 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Forecast family | PrognosFamilj | ztString | 4 |  | varchar
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Forecast version | PrognosVer | ZtLong | 4 |  | int

    This table is the main table in the following programs:

    Program: ArSrne Market forecast with month values, item


Item, revision/version (ItemRevision)

BOM revisions on which you can specify validity date. A link can then be made to a BOM to change its appearance at a certain date.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Calculation version no. | ArkVersion | ZtLong | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Valid from date | GiltigFromDatum | ztDate |  |  | datetime
Valid to date | GiltigTomDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Item Revision | ItemRevision | ZtLong | 3 |  | smallint
Copy from item revision | ItemRevision_CopyOfRevision | ZtLong | 3 |  | int
Item revision descr | ItemRevisionDescr | ztString | 80 |  | varchar
Item rev status | ItemRevisionStatus | ztInteger | 5 |  | smallint
Item rev subject | ItemRevisionSubject | ztInteger | 5 |  | smallint
Item rev OK to use? | ItemRevOkToUse | ztBoolean |  |  | char
Note | KortNotering | ztString | 255 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Quantity PDM | pdmcount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: ItemRevision Item, revision/version

    Program: ItemRevision_AR Item revision, Item

    Program: ItemRevision_Ars Item revision, Item Balances

    Program: ItemRevision_BOM Item, revision/version, BOM

    Program: ItemRevision_LO Item, revision/version, Labor

    Program: ItemRevision_QPar Item, revision/version, Q-par

    Program: ItemRevision_Supplier Item, revision/version, Supplier, agreement


Item->MRP (planner) (arpn)

Work table of the selected items to be included in a net requirements batch.
Underlying items based on the items' BOMs are entered automatically into this table.
Other items are also included in the net requirements batch, but never give rise to proposals.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Reported end time | EventRpTime | ztTime | 5 |  | datetime
Start time | EventStartTime | ztTime | 5 |  | datetime
Time | EventTime | ztTime | 4 |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
MRP batch -> Sign/mgr | NE_PlanAnsv | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Arpn Select items for MRP


Item/packaging type (arem)

Definition of relevant combinations of Item and Packaging type.
All possible combinations of items and packaging types that can be used in shipping items to customers are stored here.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Qty per package | AntalEmb | ZtQty | 14 | 2 | decimal
Item no. | Artnr | ztString | 30 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Description | beskrivning | ztString | 50 |  | varchar
Number of shipments/packaging | EmballageAntalKolli | ztInteger | 5 |  | smallint
Packaging price | Emballagepris | ZtBaseCurrAmount | 14 | 2 | money
Return packaging | EmballageRetur | ztBoolean |  |  | char
Packaging type | Emballagetyp | ztString | 4 |  | varchar
For package items | Embkod | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Height | volheight | ztInteger | 4 |  | smallint
Length | vollength | ztInteger | 4 |  | smallint
Volume | volume | ztFloat | 10 | 3 | float
Width | volwidth | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: arem Item/packaging type


Item/packaging type, language (ares)

Additional description in other languages of the relevant combinations of Item and Packaging type.
Used when printing packing slips to present the extra description of the packaging type according to the customers' current language codes.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | Artnr | ztString | 30 |  | varchar
Description | Beskrivning | ztString | 50 |  | varchar
Packaging type | Emballagetyp | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint


ItemBalanceBookingRcvdDeliveries (arsr)

Table of reservations made for an item.
The table contains one row per active material reservation (MR)
*** Under construction ***

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Activity type layer | AktTypLayer | ztInteger | 3 |  | smallint
Quantity | Antal | ZtQty | 14 | 2 | decimal
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
MO/Works order status | AoStatKod | ztInteger | 1 |  | smallint
Available invtry balance | Arsd_LagDispSaldo | ZtQty | 14 | 2 | decimal
Total inventory balance | Arsd_LagTotSaldo | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
PO status | BestStatKod | ztInteger | 2 |  | smallint
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Drop ship | DirektLeverans | ztBoolean |  |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Planned date | EventPlDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Receive to MO | InlevTillAoNr | Jeeves_MONo | 7 |  | bigint
Receive to MO Pos | InlevTillAoPos | ztInteger | 4 |  | int
Receive to MO Op | InlevTillOpNr | ztInteger | 3 |  | smallint
Stocked | LagerBokas | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Subcontract flag | MarkLego | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
@zPrompt=null | NoUpdateOfBaseTable | ztBoolean |  |  | char
Pick status | OkAttPlockaStatus | ztInteger | 5 |  | smallint
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Order row status | OrdRadSt | ztInteger | 2 |  | smallint
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Order status | OrdStat | ztInteger | 2 |  | smallint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row type plan list | PlanLstRadTyp | ztString | 2 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos2 | ztInteger | 4 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Status code, Service | ServStatus | ztInteger | 2 |  | smallint
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Date/time | StrDateTime | ztString | 28 |  | varchar
Transit delivery | TransitLeverans | ztBoolean |  |  | char
Item group | VaruGruppKod | ztString | 8 |  | varchar
ID number | x_IdNr | ZtLong | 10 |  | int
ID row | X_IdRad | ZtLong | 10 |  | int
ID row sub-row | X_IdSubRad | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: arsr Planned activities for item


Items (ar)

Table of the company's items/products. On this main level in the item’s basic data structure, information is stored which is common for all inventory locations, such as descriptions in basic language, prices, classifications, posting rules, etc.

In Jeeves, the basic data structure for items is built up as follows (see the chapter Items, basic data structure, for detailed information):

Items with descriptions in basic language (this table Ar)

Descriptions in other languages (table Arb)

Information per inventory location (table Ars)

Batch (table Bat)
Serial number items (table Ari)
Bin (table Arsh)
Information per supplier (table Al)

Operations for own manufacturing (table Op)

BOM (table Sr)
BOM/package for sales (without link to an operation) (table Sr)

Item statistics per period for received deliveries and dispatches, invoicing, order entry, average inventory, inventory turnover rate, inventory value (cost price/last purchase price/FIFO), etc., are also stored in the ‘Item statistics’ (Sars) table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Adjust OP purch | AdjustOpPurch | ztBoolean |  |  | char
Inventory balance, alt unit | AltEnhSaldo | ztBoolean |  |  | char
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Acq to order point | AnskaffningBestp | ztBoolean |  |  | char
Purchased | AnskaffningKop | ztBoolean |  |  | char
Acq to requirement | AnskaffningMotBehov | ztBoolean |  |  | char
Acquired via MRP run | AnskaffningNettobehov | ztBoolean |  |  | char
Acq to plan | AnskaffningPlanering | ztBoolean |  |  | char
Acquisition method | AnskaffningsSatt | ztInteger | 2 |  | smallint
Manufactured | AnskaffningTillv | ztBoolean |  |  | char
Quantity per pallet | AntalPerPall | ZtLong | 10 |  | int
Qty alternative invtry items | AntAltArtiklar | ztInteger | 5 |  | smallint
Qty optional items | AntalTillValArt | ztInteger | 5 |  | smallint
Consists of, no. of items | AntBestarAvSr | ZtLong | 5 |  | int
Decimal places | AntDec | ztInteger | 1 |  | smallint
ComponentQty | AntIngarISr | ZtLong | 5 |  | int
No. of operations | AntOp | ztInteger | 3 |  | smallint
Work group | ArbetsLag | ztString | 6 |  | varchar
This field is used in the table as follows: |
Labour OH cost % | ArbOmkProc | ztFloat | 7 | 2 | float
Calculation markup code | ArkPalKod | ztInteger | 5 |  | smallint
@zPrompt=null | ArtArsOmsattUpdDat | ztDateTime |  |  | datetime
Item description | ArtBeskr | ztString | 30 |  | varchar
Item descr 2 | ArtBeskr2 | ztString | 255 |  | varchar
Specification | ArtBeskrSpec | ztString | 30 |  | varchar
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Recommended price | ArtCirkaPris | ZtSalesPrice | 12 | 2 | money
Item for config only | ArtEnbartForKonfig | ztBoolean |  |  | char
Sales price date | ArtFPrisDat | ztDate |  |  | datetime
Pkg.size sales | ArtFsgForp | ZtQty | 14 | 2 | decimal
Selection 1 | ArtFtgSpec1 | ztBoolean |  |  | char
Selection 2 | ArtFtgSpec2 | ztBoolean |  |  | char
Selection-3 | ArtFtgSpec3 | ztBoolean |  |  | char
Manufacturing lead time | ArtGenomloppsTid | ztInteger | 5 |  | smallint
Item Creation date | ArtInlDat | ztDate |  |  | datetime
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
A-kostnad | ArtKalkBerA | ZtBaseCurrAmount | 14 | 2 | money
B-kostnad | ArtKalkBerB | ZtBaseCurrAmount | 14 | 2 | money
C-kostnad | ArtKalkBerC | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price (incl. tax) | ArtKalkBerInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
New cost price from date | ArtKalkBerNyttDatum | ztDate |  |  | datetime
New cost price (refinement) | ArtKalkBerNyttForadling | ZtBaseCurrAmount | 14 | 2 | money
New cost price (mtrl) | ArtKalkBerNyttMtrl | ZtBaseCurrAmount | 14 | 2 | money
Startkostnad | ArtKalkBerStart | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost prc date | ArtKalkDat | ztDate |  |  | datetime
Calculate costs | ArtKalkKod | ztBoolean |  |  | char
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Ber kalk.pris bas | ArtKalkPrel | ZtBaseCurrAmount | 14 | 2 | money
Calc cost price | ArtKalkPris | ZtBaseCurrAmount | 14 | 2 | money
Average cost price | ArtKalkSnitt | ZtBaseCurrAmount | 14 | 2 | money
Item category | ArtKat | ztString | 10 |  | varchar
Item class | ArtKod | ztInteger | 3 |  | smallint
Customer discnt allowed | ArtKundRabKod | ztBoolean |  |  | char
Qualification ID | ArtKvalifId | ZtLong | 6 |  | int
Qualification number | ArtKvalifNr | ztString | 20 |  | varchar
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Lev.rabatt % | ArtLevRabatt | ztFloat | 4 | 2 | float
List price | ArtListPris | ZtBaseCurrAmount | 14 | 2 | money
New list price | ArtListPrisNytt | ZtBaseCurrAmount | 14 | 2 | money
New list price from date | ArtListPrisNyttDatum | ztDate |  |  | datetime
Material cost total | ArtMatKost | ZtBaseCurrAmount | 14 | 2 | money
Assembly time | ArtMontTid | ztFloat | 7 | 2 | float
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
Ny beräkning av nivåkod | ArtNiva_Dirty | ztBoolean |  |  | char
Artikelnivå | ArtNivaKod | ztString | 1 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Item no., surcharge | ArtNrAddArt | ztString | 30 |  | varchar
Item no. EAN | ArtNrEAN | ztString | 30 |  | varchar
Pack separately | ArtPackSeparat | ztBoolean |  |  | char
Product class | ArtProdKlass | ztString | 4 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Last PYR date | ArtPyrDat | ztDateTime |  |  | datetime
Item discount class | ArtRabKlass | ztInteger | 3 |  | smallint
Revision date | ArtRevDat | ztDate |  |  | datetime
Revision no. | ArtRevId | ztString | 10 |  | varchar
Revision signature | ArtRevSign | ztString | 6 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Sellable item | ArtSaljBar | ztBoolean |  |  | char
Service level code | ArtServKod | ztInteger | 2 |  | smallint
Document no. | ArtSkyddsBladNr | ztString | 30 |  | varchar
Sortering inom tillv.order | ArtSortOrp2Ti | ztInteger | 5 |  | smallint
TARIC code | ArtStatNr | ztString | 20 |  | varchar
Bar code | ArtStreckKod | ztString | 15 |  | varchar
BOM notation code | ArtStruktKod | ztString | 1 |  | varchar
General item text | ArtTextKod | ztString | 4 |  | varchar
Uppsk kostn | ArtUpps | ZtBaseCurrAmount | 8 | 2 | money
EU/EES source | ArtUrsprung | ztBoolean |  |  | char
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Viktighetskod | ArtViktighetKod | ztInteger | 1 |  | smallint
Volume m3 | ArtVolym | ztFloat | 15 | 4 | float
Auto receiving type | AutInlevTyp | ztInteger | 5 |  | smallint
Aut mtrl.issue allowed | AutMtrlUttagAvArt | ztBoolean |  |  | char
Auto mtrl issue type | AutMtrlUttagTyp | ztInteger | 5 |  | smallint
Automatic release | AutoFrislappas | ztBoolean |  |  | char
Auto breakdown within MO | AutoVidareNedbrInomTo | ztBoolean |  |  | char
Auto booking rule | AutStockBookingRule | ztInteger | 5 |  | smallint
Agreement signed | AvtalTecknasKod | ztBoolean |  |  | char
Cost prc date (backdated) | BakdateraArtKalkDat | ztDate |  |  | datetime
Base(prefix) for S/N | Base_Serial_No | ztString | 30 |  | varchar
Batch no. required | BatchBokas | ztBoolean |  |  | char
Batch bkg, not mandatory | BatchBoknEjKrav | ztBoolean |  |  | char
BOMBaseQty | BOMBaseQty | ztFloat | 15 | 2 | float
Purchase price budget | BudgInPris | ZtBaseCurrAmount | 14 | 2 | money
Purchase price budget (new) | BudgInPrisNytt | ZtBaseCurrAmount | 14 | 2 | money
Model | BVariant | ztInteger | 4 |  | smallint
Capacity consume | CapacityConsume | ZtLong | 5 |  | int
List price table | CaPrisTabKod | ztString | 6 |  | varchar
Early settlmt discnt goods | CashDiscount | ztBoolean |  |  | char
Code fixed departure | CodeFixedDeparture | ztBoolean |  |  | char
Copied from Item No. | CopiedFromArtNr | ztString | 30 |  | varchar
Copy to parent | CopyUpFromThisItem | ztBoolean |  |  | char
Requisition, copy to parent | CopyUpFromThisItemPur | ztBoolean |  |  | char
CopyUpToThisItem | CopyUpToThisItem | ztBoolean |  |  | char
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Customer group | CustomsGroup | ztString | 8 |  | varchar
Table, terms | DebObjekt | ztString | 255 |  | varchar
Partial booking allowed | DelBokningTillaten | ztInteger | 5 |  | smallint
Part delivery allowed | DelLevTillaten | ztInteger | 5 |  | smallint
Diameter | Diam | ztInteger | 4 |  | smallint
Dry weight | DryWeight | ztFloat | 15 | 2 | float
Text | Edit | ztBlob | 1 |  | varchar
New MO on explosion | EgenThVidVidareNedbr | ztBoolean |  |  | char
Unit code | EnhetsKod | ztString | 4 |  | varchar
Replaces item | ErsatterArtNr | ztString | 30 |  | varchar
Replaced by item | ErsattsAvArtNr | ztString | 30 |  | varchar
PDM | ExistsPdm | ztBoolean |  |  | char
PDM (order) | ExistsPdmPO | ztBoolean |  |  | char
PDM (MO) | ExistsPdmWO | ztBoolean |  |  | char
Extra1 | Extra1 | ztString | 30 |  | varchar
Extra2 | Extra2 | ztString | 30 |  | varchar
Extra3 | Extra3 | ztString | 30 |  | varchar
Extra4 | Extra4 | ztFloat | 10 | 2 | float
Extra overhead cost % | ExtraOmkProc | ztFloat | 7 | 2 | float
Fakt avpr försl enl | FaktAvprForslEnl | ztInteger | 5 |  | smallint
Fictitious item | FiktivArtikel | ztBoolean |  |  | char
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Consumables | ForbrukningsMaterial | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, internal | FPrisInternt | ZtBaseCurrAmount | 14 | 2 | money
Freight cost % | FraktKostnProc | ZtDecimal73 | 7 | 2 | decimal
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Warranty period (mon) | GarantiTid | ztInteger | 2 |  | smallint
Valid to date | GiltigTomDatum | ztDate |  |  | datetime
Delivery cost % | Hemtkostnproc | ZtDecimal73 | 7 | 2 | decimal
Order type ICT | ICTOrderType | ztInteger | 3 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Suborder item (purchase) | InkopsAvropsArtikel | ztBoolean |  |  | char
Suborder purchase | InkopsAvropsBestNr | ZtLong | 10 |  | int
Delivery tolerance % - | InlevTolProcMinus | ZtDecimal73 | 8 | 3 | decimal
Delivery tolerance % + | InlevTolProcPlus | ZtDecimal73 | 8 | 3 | decimal
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Purch price curr | InValuta | ztString | 3 |  | varchar
Material type | ItemMtrlType | ztString | 30 |  | varchar
Item OK to offer | ItemOkToOffer | ztBoolean |  |  | char
Item OK to use? | ItemOkToUse | ztBoolean |  |  | char
Item Revision | ItemRevision | ZtLong | 3 |  | int
Item status | ItemStatusCode | ztInteger | 5 |  | smallint
Item type 1 | ItemTypeCd1 | ztInteger | 5 |  | smallint
Item type 2 | ItemTypeCd2 | ztInteger | 5 |  | smallint
Item type 3 | ItemTypeCd3 | ztInteger | 5 |  | smallint
Item type 4 | ItemTypeCd4 | ztInteger | 5 |  | smallint
Item type 5 | ItemTypeCd5 | ztInteger | 5 |  | smallint
Item type 6 | ItemTypeCd6 | ztInteger | 5 |  | smallint
Cost update code | KalkPrisAndrTypKod | ztInteger | 5 |  | smallint
Average weighted | KalkylPrisEnlSnittPris | ztBoolean |  |  | char
Capacity family | KapacitetsFamilj | ztString | 6 |  | varchar
Scrap factor in % | KassAr | ztFloat | 5 | 2 | float
Do not print invoice | KodEjUtskrFa | ztBoolean |  |  | char
Do not print DN | KodEjUtskrFs | ztBoolean |  |  | char
Do not print OA | KodEjUtskrOE | ztBoolean |  |  | char
Configuration item no. | KonfigArtNr | ztString | 30 |  | varchar
Inspection instruction | KontrollInstruktion | ztBlob | 1 |  | varchar
Credit percentage | KreditProcent | ztFloat | 15 | 2 | float
Stocked | LagerBokas | ztBoolean |  |  | char
Type of bin | LagPlatsTyp | ztString | 6 |  | varchar
Inventory balance | LagSaldoArtikel | ZtQty | 14 | 2 | decimal
Inventory balance (web) | LagSaldoWeb | ZtQty | 14 | 2 | decimal
Inventory location | Lagstalle | ztString | 2 |  | varchar
Inventory location, purchase | LagstalleInkop | ztString | 2 |  | varchar
Invntry loc, mtrl res | LagstalleMtrlRes | ztString | 2 |  | varchar
Inventory stock type | LagTyp | ztInteger | 2 |  | smallint
Country | LandsKod | ztString | 3 |  | varchar
Lead time to PO/MO | LedTid_orp_2_bp_ti | ztInteger | 5 |  | smallint
Surcharge, alloying | LegeringsTillaggId | ZtLong | 10 |  | int
Length | Length | ztFloat | 4 | 2 | float
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Markup 5, amount | ListPriceAddAmt5 | ZtBaseCurrAmount | 14 | 2 | money
List price markup 2 chain | ListPriceChain2 | ztBoolean |  |  | char
List price markup 4 chain | ListPriceChain4 | ztBoolean |  |  | char
List price markup-1 % | ListPriceMarkUp1 | ztFloat | 6 | 2 | float
List price markup-2 % | ListPriceMarkUp2 | ztFloat | 6 | 2 | float
List price markup-3 % | ListPriceMarkUp3 | ztFloat | 6 | 2 | float
List price markup-4 % | ListPriceMarkUp4 | ztFloat | 6 | 2 | float
List price markup template | ListPriceMarkUpCd | ztString | 10 |  | varchar
Manuf yield % | ManufYieldPercent | ZtDecimal73 | 8 | 3 | decimal
Dispatch plan item | MarkLevPlanArtikel | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Mtrl overhead % | MtrlMoKostProc | ZtDecimal73 | 7 | 2 | decimal
Pkg size purchase | Multipel | ZtQty | 14 | 2 | decimal
New cost as of date | NewCostsFromDate | ztDate |  |  | datetime
New item number | NyttArtNr | ztString | 30 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Intrastat, conv.factor | OmvFaktorIntraStat | ZtDecimal73 | 14 | 5 | decimal
Order up to oblig. | OrderAtagande | ztInteger | 3 |  | smallint
Order split type | OrderdelningsTyp | ztInteger | 2 |  | smallint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Disc code order value | OrdvRabKod | ztInteger | 2 |  | smallint
Price calc method, pkg | OrpStrPrisBer | ztInteger | 2 |  | smallint
Change package qty->det | PackageItemQty2Det | ztBoolean |  |  | char
Package item | PaketArtikel | ztBoolean |  |  | char
Markup, split pkg | PalaggDelForp | ztFloat | 6 | 2 | float
Markup, split pkg amt | PalaggDelForpBelopp | ztBoolean |  |  | char
Batch size manufacturing | PartistorlekTillv | ZtQty | 14 | 2 | decimal
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Graphics file name | PictureFileName | ztString | 150 |  | varchar
Package item controls discounts | PkgItemDiscnt2Detail | ztBoolean |  |  | char
Price calc no (current price) | PriceCalcNoCurr | ZtLong | 10 |  | int
Price calc no (new price) | PriceCalcNoNew | ZtLong | 10 |  | int
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Forecast family | PrognosFamilj | ztString | 4 |  | varchar
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Proposal for each need | ProposalForEachNeed | ztBoolean |  |  | char
Attribute 1 | PVMAttribute1 | ztString | 10 |  | varchar
Attribute 10 | PVMAttribute10 | ztString | 10 |  | varchar
Attribute 2 | PVMAttribute2 | ztString | 10 |  | varchar
Attribute 3 | PVMAttribute3 | ztString | 10 |  | varchar
Attribute 4 | PVMAttribute4 | ztString | 10 |  | varchar
Attribute 5 | PVMAttribute5 | ztString | 10 |  | varchar
Attribute 6 | PVMAttribute6 | ztString | 10 |  | varchar
Attribute 7 | PVMAttribute7 | ztString | 10 |  | varchar
Attribute 8 | PVMAttribute8 | ztString | 10 |  | varchar
Attribute 9 | PVMAttribute9 | ztString | 10 |  | varchar
Overlying item | PvmHigherItem | ztString | 30 |  | varchar
Item type ID | PVMItemTypeId | ztInteger | 5 |  | smallint
Master item | PvmMasterItem | ztString | 30 |  | varchar
Variant 1 | PVMVariant1 | ztString | 10 |  | varchar
Variant 10 | PVMVariant10 | ztString | 10 |  | varchar
Variant 2 | PVMVariant2 | ztString | 10 |  | varchar
Variant 3 | PVMVariant3 | ztString | 10 |  | varchar
Variant 4 | PVMVariant4 | ztString | 10 |  | varchar
Variant 5 | PVMVariant5 | ztString | 10 |  | varchar
Variant 6 | PVMVariant6 | ztString | 10 |  | varchar
Variant 7 | PVMVariant7 | ztString | 10 |  | varchar
Variant 8 | PVMVariant8 | ztString | 10 |  | varchar
Variant 9 | PVMVariant9 | ztString | 10 |  | varchar
Shelf life in days | QShelfLifeInDays | ztInteger | 5 |  | smallint
Shelf life rule | QShelfLifeRule | ztInteger | 5 |  | smallint
Std grade | QStdGrade | ztFloat | 15 | 2 | float
Std gravity | QStdGravity | ztFloat | 15 | 2 | float
Std moiety | QStdMoiety | ztFloat | 15 | 2 | float
Std potency | QStdPotency | ztFloat | 15 | 2 | float
Entry date | RegDat | ztDate |  |  | datetime
Delete this item | RemoveItem | ztBoolean |  |  | char
Backorder handling | RestBehKod | ztInteger | 1 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Joint purchase (allowed) | SamInKopMark | ztBoolean |  |  | char
Joint delivery code | SamlevKod | ztString | 4 |  | varchar
Max qty joint pick | Samplock_Antal | ZtQty | 14 | 2 | decimal
Sequence for S/N | Serial_No_Count | ZtLong | 10 |  | int
Serial no. at receiving | SerialNoIlev | ztBoolean |  |  | char
Serial no., quantity=1.0 | SerialNoItemOne | ztBoolean |  |  | char
Serial no., unique | SerialNoUnique | ztBoolean |  |  | char
Serial no. required | SerieNrBokas | ztBoolean |  |  | char
Service | ServiceItem | ztBoolean |  |  | char
Create forecast rows | SkapaPrognos | ztBoolean |  |  | char
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Start dag i veckan | StartVeckoDag | ztInteger | 1 |  | smallint
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Sum itemNo | SumItemNo | ztString | 30 |  | varchar
Sum item on invoice | SumitemOnInvoiceTot | ztBoolean |  |  | char
Dangerous goods | TA_DGD | ztInteger | 5 |  | smallint
Technical overhead cost % | TeknikOmkProc | ztFloat | 7 | 2 | float
Technical status | TekniskStatus | ztString | 35 |  | varchar
Optional items, auto save | TillValArtikelAuto | ztBoolean |  |  | char
Optional items, auto create | TillValArtikelAutoSkapa | ztBoolean |  |  | char
In-house or subcontract | TillvPriorEgenLego | ztInteger | 5 |  | smallint
Setup cost/MO | ToStallKostnad | ZtCost | 16 | 6 | float
Start cost/MO | ToStartKostnad | ZtCost | 16 | 6 | float
Freight cost (amt/kg) | TransportKostnadsID | ZtLong | 10 |  | int
URL link | URLLink | ztString | 350 |  | varchar
Original item no. | UrsprArtNr | ztString | 30 |  | varchar
Country of origin | UrsprungsLand | ztString | 3 |  | varchar
Outgoing item | UtgArtikel | ztBoolean |  |  | char
Print on delivery note | UtskrFoljesedel | ztBoolean |  |  | char
Print on picking list | UtskrPlocklista | ztBoolean |  |  | char
Development cost | UtvKostnad | ZtCost | 16 | 6 | float
Development OH cost% | UtvOmkProc | ztFloat | 7 | 2 | float
Validity time, days | ValidityTime | ztInteger | 3 |  | smallint
Variantelement | variantelement | ztString | 30 |  | varchar
Variantkod | Variantkod | ztString | 8 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
VAT/tax type purchase | VAT_Type_Purchase | ztInteger | 4 |  | smallint
VAT/tax type sales | VAT_Type_Sales | ztInteger | 4 |  | smallint
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Purchase price incl tax | Vb_InPrisInklMoms | ztMoney | 14 | 2 | money
Cost price, curr | vbArtKalkPris | ztMoney | 14 | 2 | money
Cost price, curr | vbKalkPris | ztMoney | 14 | 2 | money
Nytt kalk.pris valuta | vbKalkPrisNytt | ztMoney | 14 | 2 | money
Tools | Verktyg | ztString | 16 |  | varchar
List of tools | VerktygsLista | ztString | 35 |  | varchar
Show Edit at order | VisaEditVidOrder | ztBoolean |  |  | char
Display on web | WebAccountMark | ztBoolean |  |  | char
Web item text | webarttext | ztString | 255 |  | varchar
Web description | webBeskr | ztString | 60 |  | varchar
Publish on Web | webPublish | ztBoolean |  |  | char
Wet weight | WetWeight | ztFloat | 15 | 2 | float
Unique ID link | WfRowUniqueID | ztString | 50 |  | varchar
Web text | wLongDescription | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: ArMrTis Change drawing -> MO

    Program: ArProd Items

    Program: Arq_from_Arq Copy item attributes

    Program: artikel Items

    Program: artinq Item/inventory details

    Program: artinq1 Item query, inventory info

    Program: ArvSr2 Item explosion

    Program: ArVsr2II Item implosion

    Program: AsSr Item structures

    Program: Item_AlternativeRoutings Alternative routings

    Program: PVMCreateItem Create variant items

    Program: RemoveItem Mark items for deletion

    Program: SrAn1 Item explosion

    Program: SrAn2 Item explosion, PDM

    Program: srba Change item in BOM

    Program: uar Items for expense and material issue

    Program: v_atg Items

    Program: VxAr Show inventory item table


Items by customer/supplier (klas)

Table that is automatically updated with a record for each new combination of the terms below, which occur when entering customer/purchase orders:
- customer and item
- supplier and item
- customer and supplier

The KLAS table is a help function for transaction searches in special programs analyzing sales and purchase situations as follows:
- Cust/item, order analysis (KKLAS)
- Cust/supplier, order analysis (CKLAS)
- Supplier/item purchase analysis (LKLAS)

The Table cannot be updated by users.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Show all items | KodAllaartiklar | ztchar | 1 |  | char
Show all custs/suppl | KodAllaFtgNr | ztchar | 1 |  | char
Layer | LagLayer | ztInteger | 2 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Record type | PostTyp | ztchar | 1 |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: CKlas Customer/supplier order analysis

    Program: CKlasSel Customer/supplier order analysis

    Program: KKlas Customer/item, order analysis

    Program: KKlasSel Customer/item, order analysis

    Program: LKlas Supplier/item purchase analysis

    Program: LKlasSel Supplier/item purchase analysis


Items in forecast family (prgfar)

Alphanumeric code for the item, BOM, fixed asset, or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Allocation percent | FordProc | ZtDecimal73 | 6 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Forecast family | PrognosFamilj | ztString | 4 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Items, compens items (vare)

Items/products.

This is a database view that uses regular item data to show in the same program (BOM rows) the designations of:
- parent item
- component
- compensatory item

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Acq to order point | AnskaffningBestp | ztBoolean |  |  | char
Purchased | AnskaffningKop | ztBoolean |  |  | char
Acq to requirement | AnskaffningMotBehov | ztBoolean |  |  | char
Acq to plan | AnskaffningPlanering | ztBoolean |  |  | char
Acquisition method | AnskaffningsSatt | ztInteger | 2 |  | smallint
Manufactured | AnskaffningTillv | ztBoolean |  |  | char
Quantity per pallet | AntalPerPall | ZtLong | 10 |  | int
Consists of, no. of items | AntBestarAvSr | ZtLong | 5 |  | int
Decimal places | AntDec | ztInteger | 1 |  | smallint
ComponentQty | AntIngarISr | ZtLong | 5 |  | int
No. of operations | AntOp | ztInteger | 3 |  | smallint
Labour OH cost % | ArbOmkProc | ztFloat | 7 | 2 | float
Calculation markup code | ArkPalKod | ztInteger | 5 |  | smallint
Item description | ArtBeskr | ztString | 30 |  | varchar
Item descr 2 | ArtBeskr2 | ztString | 255 |  | varchar
Specification | ArtBeskrSpec | ztString | 30 |  | varchar
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Recommended price | ArtCirkaPris | ZtSalesPrice | 12 | 2 | money
Sales price date | ArtFPrisDat | ztDate |  |  | datetime
Pkg.size sales | ArtFsgForp | ZtQty | 14 | 2 | decimal
Selection 1 | ArtFtgSpec1 | ztBoolean |  |  | char
Selection 2 | ArtFtgSpec2 | ztBoolean |  |  | char
Manufacturing lead time | ArtGenomloppsTid | ztInteger | 5 |  | smallint
Item Creation date | ArtInlDat | ztDate |  |  | datetime
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
A-kostnad | ArtKalkBerA | ZtBaseCurrAmount | 14 | 2 | money
B-kostnad | ArtKalkBerB | ZtBaseCurrAmount | 14 | 2 | money
C-kostnad | ArtKalkBerC | ZtBaseCurrAmount | 14 | 2 | money
Cost price (incl. tax) | ArtKalkBerInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
New cost price from date | ArtKalkBerNyttDatum | ztDate |  |  | datetime
New cost price (mtrl) | ArtKalkBerNyttMtrl | ZtBaseCurrAmount | 14 | 2 | money
Startkostnad | ArtKalkBerStart | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost prc date | ArtKalkDat | ztDate |  |  | datetime
Calculate costs | ArtKalkKod | ztBoolean |  |  | char
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Ber kalk.pris bas | ArtKalkPrel | ZtBaseCurrAmount | 14 | 2 | money
Item class | ArtKod | ztInteger | 3 |  | smallint
Customer discnt allowed | ArtKundRabKod | ztBoolean |  |  | char
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Lev.rabatt % | ArtLevRabatt | ztFloat | 4 | 2 | float
List price | ArtListPris | ZtBaseCurrAmount | 14 | 2 | money
Material cost total | ArtMatKost | ZtBaseCurrAmount | 14 | 2 | money
Assembly time | ArtMontTid | ztFloat | 7 | 2 | float
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
Artikelnivå | ArtNivaKod | ztString | 1 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Product class | ArtProdKlass | ztString | 4 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Last PYR date | ArtPyrDat | ztDateTime |  |  | datetime
Item discount class | ArtRabKlass | ztInteger | 3 |  | smallint
Revision date | ArtRevDat | ztDate |  |  | datetime
Revision no. | ArtRevId | ztString | 10 |  | varchar
Revision signature | ArtRevSign | ztString | 6 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Sellable item | ArtSaljBar | ztBoolean |  |  | char
Service level code | ArtServKod | ztInteger | 2 |  | smallint
Document no. | ArtSkyddsBladNr | ztString | 30 |  | varchar
Sortering inom tillv.order | ArtSortOrp2Ti | ztInteger | 5 |  | smallint
TARIC code | ArtStatNr | ztString | 20 |  | varchar
Bar code | ArtStreckKod | ztString | 15 |  | varchar
BOM notation code | ArtStruktKod | ztString | 1 |  | varchar
Uppsk kostn | ArtUpps | ZtBaseCurrAmount | 8 | 2 | money
EU/EES source | ArtUrsprung | ztBoolean |  |  | char
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Viktighetskod | ArtViktighetKod | ztInteger | 1 |  | smallint
Volume m3 | ArtVolym | ztFloat | 15 | 4 | float
Auto receiving type | AutInlevTyp | ztInteger | 5 |  | smallint
Automatic release | AutoFrislappas | ztBoolean |  |  | char
Auto breakdown within MO | AutoVidareNedbrInomTo | ztBoolean |  |  | char
Batch no. required | BatchBokas | ztBoolean |  |  | char
Model | BVariant | ztInteger | 4 |  | smallint
List price table | CaPrisTabKod | ztString | 6 |  | varchar
Diameter | Diam | ztInteger | 4 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Replaced by item | ErsattsAvArtNr | ztString | 30 |  | varchar
Fictitious item | FiktivArtikel | ztBoolean |  |  | char
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Consumables | ForbrukningsMaterial | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Valid to date | GiltigTomDatum | ztDate |  |  | datetime
Delivery cost % | Hemtkostnproc | ZtDecimal73 | 7 | 2 | decimal
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purch price curr | InValuta | ztString | 3 |  | varchar
Item OK to use? | ItemOkToUse | ztBoolean |  |  | char
Item status | ItemStatusCode | ztInteger | 5 |  | smallint
Cost update code | KalkPrisAndrTypKod | ztInteger | 5 |  | smallint
Scrap factor in % | KassAr | ztFloat | 5 | 2 | float
Configuration item no. | KonfigArtNr | ztString | 30 |  | varchar
Inspection instruction | KontrollInstruktion | ztBlob | 1 |  | varchar
Stocked | LagerBokas | ztBoolean |  |  | char
Inventory stock type | LagTyp | ztInteger | 2 |  | smallint
Country | LandsKod | ztString | 3 |  | varchar
Length | Length | ztFloat | 4 | 2 | float
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Pkg size purchase | Multipel | ZtQty | 14 | 2 | decimal
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Intrastat, conv.factor | OmvFaktorIntraStat | ZtDecimal73 | 14 | 5 | decimal
Order type | OrdTyp | ztInteger | 3 |  | smallint
Disc code order value | OrdvRabKod | ztInteger | 2 |  | smallint
Price calc method, pkg | OrpStrPrisBer | ztInteger | 2 |  | smallint
Package item | PaketArtikel | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Joint purchase (allowed) | SamInKopMark | ztBoolean |  |  | char
Serial no. at receiving | SerialNoIlev | ztBoolean |  |  | char
Serial no., quantity=1.0 | SerialNoItemOne | ztBoolean |  |  | char
Serial no., unique | SerialNoUnique | ztBoolean |  |  | char
Serial no. required | SerieNrBokas | ztBoolean |  |  | char
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Start dag i veckan | StartVeckoDag | ztInteger | 1 |  | smallint
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Original item no. | UrsprArtNr | ztString | 30 |  | varchar
Print on delivery note | UtskrFoljesedel | ztBoolean |  |  | char
Print on picking list | UtskrPlocklista | ztBoolean |  |  | char
Validity time, days | ValidityTime | ztInteger | 3 |  | smallint
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Purchase price incl tax | Vb_InPrisInklMoms | ztMoney | 14 | 2 | money
Cost price, curr | vbKalkPris | ztMoney | 14 | 2 | money
Nytt kalk.pris valuta | vbKalkPrisNytt | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: vare Items, compensatory


Items, compens items (varf)

Items/products.

This is a database view that uses regular item data to show in the same program (BOM rows) the designations of:
- parent item
- component
- compensatory item

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Acq to order point | AnskaffningBestp | ztBoolean |  |  | char
Purchased | AnskaffningKop | ztBoolean |  |  | char
Acq to requirement | AnskaffningMotBehov | ztBoolean |  |  | char
Acq to plan | AnskaffningPlanering | ztBoolean |  |  | char
Acquisition method | AnskaffningsSatt | ztInteger | 2 |  | smallint
Manufactured | AnskaffningTillv | ztBoolean |  |  | char
Quantity per pallet | AntalPerPall | ZtLong | 10 |  | int
Consists of, no. of items | AntBestarAvSr | ZtLong | 5 |  | int
Decimal places | AntDec | ztInteger | 1 |  | smallint
ComponentQty | AntIngarISr | ZtLong | 5 |  | int
No. of operations | AntOp | ztInteger | 3 |  | smallint
Labour OH cost % | ArbOmkProc | ztFloat | 7 | 2 | float
Calculation markup code | ArkPalKod | ztInteger | 5 |  | smallint
Item description | ArtBeskr | ztString | 30 |  | varchar
Item descr 2 | ArtBeskr2 | ztString | 255 |  | varchar
Specification | ArtBeskrSpec | ztString | 30 |  | varchar
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Recommended price | ArtCirkaPris | ZtSalesPrice | 12 | 2 | money
Sales price date | ArtFPrisDat | ztDate |  |  | datetime
Pkg.size sales | ArtFsgForp | ZtQty | 14 | 2 | decimal
Selection 1 | ArtFtgSpec1 | ztBoolean |  |  | char
Selection 2 | ArtFtgSpec2 | ztBoolean |  |  | char
Manufacturing lead time | ArtGenomloppsTid | ztInteger | 5 |  | smallint
Item Creation date | ArtInlDat | ztDate |  |  | datetime
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
A-kostnad | ArtKalkBerA | ZtBaseCurrAmount | 14 | 2 | money
B-kostnad | ArtKalkBerB | ZtBaseCurrAmount | 14 | 2 | money
C-kostnad | ArtKalkBerC | ZtBaseCurrAmount | 14 | 2 | money
Cost price (incl. tax) | ArtKalkBerInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
New cost price from date | ArtKalkBerNyttDatum | ztDate |  |  | datetime
New cost price (mtrl) | ArtKalkBerNyttMtrl | ZtBaseCurrAmount | 14 | 2 | money
Startkostnad | ArtKalkBerStart | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost prc date | ArtKalkDat | ztDate |  |  | datetime
Calculate costs | ArtKalkKod | ztBoolean |  |  | char
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Ber kalk.pris bas | ArtKalkPrel | ZtBaseCurrAmount | 14 | 2 | money
Item class | ArtKod | ztInteger | 3 |  | smallint
Customer discnt allowed | ArtKundRabKod | ztBoolean |  |  | char
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Lev.rabatt % | ArtLevRabatt | ztFloat | 4 | 2 | float
List price | ArtListPris | ZtBaseCurrAmount | 14 | 2 | money
Material cost total | ArtMatKost | ZtBaseCurrAmount | 14 | 2 | money
Assembly time | ArtMontTid | ztFloat | 7 | 2 | float
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
Artikelnivå | ArtNivaKod | ztString | 1 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Product class | ArtProdKlass | ztString | 4 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Last PYR date | ArtPyrDat | ztDateTime |  |  | datetime
Item discount class | ArtRabKlass | ztInteger | 3 |  | smallint
Revision date | ArtRevDat | ztDate |  |  | datetime
Revision no. | ArtRevId | ztString | 10 |  | varchar
Revision signature | ArtRevSign | ztString | 6 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Sellable item | ArtSaljBar | ztBoolean |  |  | char
Service level code | ArtServKod | ztInteger | 2 |  | smallint
Document no. | ArtSkyddsBladNr | ztString | 30 |  | varchar
Sortering inom tillv.order | ArtSortOrp2Ti | ztInteger | 5 |  | smallint
TARIC code | ArtStatNr | ztString | 20 |  | varchar
Bar code | ArtStreckKod | ztString | 15 |  | varchar
BOM notation code | ArtStruktKod | ztString | 1 |  | varchar
Uppsk kostn | ArtUpps | ZtBaseCurrAmount | 8 | 2 | money
EU/EES source | ArtUrsprung | ztBoolean |  |  | char
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Viktighetskod | ArtViktighetKod | ztInteger | 1 |  | smallint
Volume m3 | ArtVolym | ztFloat | 15 | 4 | float
Auto receiving type | AutInlevTyp | ztInteger | 5 |  | smallint
Automatic release | AutoFrislappas | ztBoolean |  |  | char
Auto breakdown within MO | AutoVidareNedbrInomTo | ztBoolean |  |  | char
Batch no. required | BatchBokas | ztBoolean |  |  | char
Model | BVariant | ztInteger | 4 |  | smallint
List price table | CaPrisTabKod | ztString | 6 |  | varchar
Diameter | Diam | ztInteger | 4 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Replaced by item | ErsattsAvArtNr | ztString | 30 |  | varchar
Fictitious item | FiktivArtikel | ztBoolean |  |  | char
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Consumables | ForbrukningsMaterial | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Valid to date | GiltigTomDatum | ztDate |  |  | datetime
Delivery cost % | Hemtkostnproc | ZtDecimal73 | 7 | 2 | decimal
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purch price curr | InValuta | ztString | 3 |  | varchar
Item OK to use? | ItemOkToUse | ztBoolean |  |  | char
Item status | ItemStatusCode | ztInteger | 5 |  | smallint
Cost update code | KalkPrisAndrTypKod | ztInteger | 5 |  | smallint
Scrap factor in % | KassAr | ztFloat | 5 | 2 | float
Configuration item no. | KonfigArtNr | ztString | 30 |  | varchar
Inspection instruction | KontrollInstruktion | ztBlob | 1 |  | varchar
Stocked | LagerBokas | ztBoolean |  |  | char
Inventory stock type | LagTyp | ztInteger | 2 |  | smallint
Country | LandsKod | ztString | 3 |  | varchar
Length | Length | ztFloat | 4 | 2 | float
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Pkg size purchase | Multipel | ZtQty | 14 | 2 | decimal
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Intrastat, conv.factor | OmvFaktorIntraStat | ZtDecimal73 | 14 | 5 | decimal
Order type | OrdTyp | ztInteger | 3 |  | smallint
Disc code order value | OrdvRabKod | ztInteger | 2 |  | smallint
Price calc method, pkg | OrpStrPrisBer | ztInteger | 2 |  | smallint
Package item | PaketArtikel | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Joint purchase (allowed) | SamInKopMark | ztBoolean |  |  | char
Serial no. at receiving | SerialNoIlev | ztBoolean |  |  | char
Serial no., quantity=1.0 | SerialNoItemOne | ztBoolean |  |  | char
Serial no., unique | SerialNoUnique | ztBoolean |  |  | char
Serial no. required | SerieNrBokas | ztBoolean |  |  | char
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Start dag i veckan | StartVeckoDag | ztInteger | 1 |  | smallint
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Original item no. | UrsprArtNr | ztString | 30 |  | varchar
Print on delivery note | UtskrFoljesedel | ztBoolean |  |  | char
Print on picking list | UtskrPlocklista | ztBoolean |  |  | char
Validity time, days | ValidityTime | ztInteger | 3 |  | smallint
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Purchase price incl tax | Vb_InPrisInklMoms | ztMoney | 14 | 2 | money
Cost price, curr | vbKalkPris | ztMoney | 14 | 2 | money
Nytt kalk.pris valuta | vbKalkPrisNytt | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: vare1 Items, comp. items


Items, inventory (view ArtSok) (varx)

Item details by inventory location. By inventory location it is meant the place where inventory is kept, or a delimited function within the company (cold stock, spare parts stock, etc.).

Balance details, reservation totals, consumption, forecast, ABC code, order point, etc., for the item are stored on the inventory location.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
-Tol qty perc not rect | AnmEjAtgTolAntProcMinus | ztInteger | 5 |  | smallint
+Tol ant proc ej åtg | AnmEjAtgTolAntProcPlus | ztInteger | 5 |  | smallint
-Tol qty sftystk not rect | AnmEjAtgTolAntSakLMinus | ZtQty | 14 | 2 | decimal
Shortage tol, days | AnmEjAtgTolDgr | ztInteger | 5 |  | smallint
-Tolerans dgr ej åtg | AnmEjAtgTolDgrMinus | ztInteger | 5 |  | smallint
Excess invtry tol, days | AnmEjAtgTolDgrPlus | ztInteger | 5 |  | smallint
-Tol % sftystk not rect | AnmEjAtgTolProcSakLMinus | ZtQty | 14 | 2 | decimal
Excess invtry tol, qty | AnmodanEjAtgOvlAntSakL | ZtQty | 14 | 2 | decimal
Excess invtry tol, % | AnmodanEjAtgOvlProcSakL | ZtQty | 14 | 2 | decimal
Excess invtry ctrl | AnmodanOverLagerEnl | ztInteger | 5 |  | smallint
-Tol qty % requisition | AnmodanTolAntProcMinus | ztInteger | 5 |  | smallint
+Tol qty % requisition | AnmodanTolAntProcPlus | ztInteger | 5 |  | smallint
- Replan.horizon | AnmodanTolDgrMinus | ztInteger | 5 |  | smallint
+Replan.horizont | AnmodanTolDgrPlus | ztInteger | 5 |  | smallint
Qty being picked | AntalUnderPlock | ZtQty | 14 | 2 | decimal
Item type EOQ/SS | ArpsTyp | ztInteger | 5 |  | smallint
Supplier for invtry loc | ArsLevNr | ztCompanyNo | 20 |  | varchar
ABC code | ArtABC | ztchar | 1 |  | char
Item description | ArtBeskr | ztString | 30 |  | varchar
Specification | ArtBeskrSpec | ztString | 30 |  | varchar
Net purchase price | ArtInPris | ZtBaseCurrAmount | 14 | 2 | money
Purch price date | ArtInPrisDat | ztDate |  |  | datetime
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Calc cost price | ArtKalkPris | ZtBaseCurrAmount | 14 | 2 | money
Average cost price | ArtKalkSnitt | ZtBaseCurrAmount | 14 | 2 | money
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Max stock level | ArtMaxLager | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Safety stock calc | ArtSecBerTyp | ztInteger | 5 |  | smallint
Safety stock days | ArtSecDagar | ztInteger | 5 |  | smallint
Safety stock level | ArtSecLager | ZtQty | 14 | 2 | decimal
Batch no. | BatchId | ztString | 30 |  | varchar
Incl in assmbly analysis | BehandlasIMontAnalys | ztBoolean |  |  | char
Total inventory balance | BerSaldo | ZtQty | 14 | 2 | decimal
Bin rule | BinLocRule | ztInteger | 2 |  | smallint
Shortage/balance | BristSaldo | ZtQty | 14 | 2 | decimal
Purchase price budget | BudgInPris | ZtBaseCurrAmount | 14 | 2 | money
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Available invtry balance | DispSaldo | ZtQty | 14 | 2 | decimal
Disponibelt levdat | DispSaldoLevdat | ZtQty | 14 | 2 | decimal
Econ order quantity | Eoq | ZtQty | 14 | 2 | decimal
Purchase quantity acc days | EplDagar | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Requisition quantity | InkAnAntal | ZtQty | 14 | 2 | decimal
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Purch qty according to rule | InkKvantEnlRegel | ztInteger | 5 |  | smallint
Ordered quantity | LagBestAnt | ZtQty | 14 | 2 | decimal
Order point | LagBestPkt | ZtQty | 14 | 2 | decimal
Block purchase quantity | LagBlockBestAnt | ZtQty | 14 | 2 | decimal
Block order quantity | LagBlockOrderAnt | ZtQty | 14 | 2 | decimal
Physical invtry diff YTD | LagDiffAnt | ZtQty | 14 | 2 | decimal
Inventory as of | LagerPerDen | ztDate |  |  | datetime
Qty used YTD | LagForbr | ZtQty | 14 | 2 | decimal
Qty used during period | LagForbrPer | ZtQty | 14 | 2 | decimal
Qty used prev yr | LagForbrPreYr | ZtQty | 14 | 2 | decimal
Qty used prev year 2 | LagForbrPreYr2 | ZtQty | 14 | 2 | decimal
Rcvd delivery YTD | LagInlev | ZtQty | 14 | 2 | decimal
Received deliv during period | LagInlevPer | ZtQty | 14 | 2 | decimal
Received del prev yr | LagInlevPreYr | ZtQty | 14 | 2 | decimal
Rcvd del prev year2 | LagInLevPreYr2 | ZtQty | 14 | 2 | decimal
Physical inventory | LagInvAnt | ZtQty | 14 | 2 | decimal
Physical invtry code | LagInvKod | ztInteger | 2 |  | smallint
Quoted quantity | LagOff | ZtQty | 14 | 2 | decimal
Inventory turnover | LagOmsHast | ztFloat | 15 | 2 | float
Invtry turnover prev year | LagOmsHastPreYr | ztFloat | 15 | 2 | float
Invtry turnov prev yr 2 | LagOmsHastPreYr2 | ztFloat | 15 | 2 | float
Qty on order/prod | LagOrdrAnt | ZtQty | 14 | 2 | decimal
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Type of bin | LagPlatsTyp | ztString | 6 |  | varchar
Reserved quantity | LagResAnt | ZtQty | 14 | 2 | decimal
Movement qty | LagRorAnt | ZtLong | 8 |  | int
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Blocked quantity | LagSaldoEjAnv | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Usage forecast 1 yr | LagUtlevPrg | ZtQty | 14 | 2 | decimal
Usage forecast this year | LagUtlevPrgAAr | ZtQty | 14 | 2 | decimal
Usage forecast prop | LagUtlevPrgForsl | ZtQty | 14 | 2 | decimal
Usage forecst nxt yr | LagUtlevPrgNAr | ZtQty | 14 | 2 | decimal
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Max qty per MO | MaxTillvAntPerTO | ZtQty | 14 | 2 | decimal
Assmbly analys, aftr lead time | MontAnalysEfterLedTid | ztBoolean |  |  | char
Re-plan or new order | NE_OmplanEllerNyOrder | ztInteger | 5 |  | smallint
Rule for last NE proposal | NE_RegelSistaForslag | ztInteger | 5 |  | smallint
Balance type at MRP | NE_SaldoTyp | ztInteger | 5 |  | smallint
Orig order row qty | Orp_UrsprOrdAntal | ZtQty | 14 | 2 | decimal
Package item | PaketArtikel | ztBoolean |  |  | char
Per closing invtry bal | PeriodLagSaldo | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Period closing stock (batch) | PerUtgLagVardeBatch | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (FIFO) | PerUtgLagVardeFifo | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (cost) | PerUtgLagVardeKalk | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (repl) | PerUtgLagVardeSInk | ZtBaseCurrAmount | 14 | 2 | money
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Forecast this year | Prognos | ZtQty | 14 | 2 | decimal
Forecast prev year | PrognosPreYr | ZtQty | 14 | 2 | decimal
Forecast prev year 2 | PrognosPreYr2 | ZtQty | 14 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Last received date | SenInlevDat | ztDate |  |  | datetime
Last disp date | SenUtlevDat | ztDate |  |  | datetime
Weighting rule | ViktningsRegel | ztString | 4 |  | varchar


Items, inventory (view) (ItemInvtLoc_ICT)

View of the ars table (Item data/inventory location).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Total inventory balance | BerSaldo | ZtQty | 14 | 2 | decimal
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Shortage/balance | BristSaldo | ZtQty | 14 | 2 | decimal
Available invtry balance | DispSaldo | ZtQty | 14 | 2 | decimal
Disponibelt levdat | DispSaldoLevDat | ZtQty | 14 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Requisition quantity | InkAnAntal | ZtQty | 14 | 2 | decimal
Ordered quantity | LagBestAnt | ZtQty | 14 | 2 | decimal
Quoted quantity | LagOff | ZtQty | 14 | 2 | decimal
Qty on order/prod | LagOrdrAnt | ZtQty | 14 | 2 | decimal
Reserved quantity | LagResAnt | ZtQty | 14 | 2 | decimal
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory balance blocked | LagSaldoSparrat | ztBoolean |  |  | char
Invtry balance, blocked qty | LagSaldoSparratAntal | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ItemPlanningICT Item planning ICT


Items, upper when BOM (UpperItem)

Vy (view) av tabellen ar (Artiklar).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Qty alternative invtry items | AntAltArtiklar |  |  |  | @DataType=NULL
Qty optional items | AntalTillValArt |  |  |  | @DataType=NULL
Consists of, no. of items | AntBestarAvSr |  |  |  | @DataType=NULL
Decimal places | AntDec |  |  |  | @DataType=NULL
ComponentQty | AntIngarISr |  |  |  | @DataType=NULL
No. of operations | AntOp |  |  |  | @DataType=NULL
Item description | ArtBeskr |  |  |  | @DataType=NULL
Item descr 2 | ArtBeskr2 |  |  |  | @DataType=NULL
Specification | ArtBeskrSpec |  |  |  | @DataType=NULL
Gross weight kg | ArtBtotVikt |  |  |  | @DataType=NULL
Sales price date | ArtFPrisDat |  |  |  | @DataType=NULL
Item Creation date | ArtInlDat |  |  |  | @DataType=NULL
Current cost price | ArtKalkBer |  |  |  | @DataType=NULL
Budgeted cost | ArtKalkBudg |  |  |  | @DataType=NULL
Cost prc date | ArtKalkDat |  |  |  | @DataType=NULL
Cost price unit | ArtKalkPer |  |  |  | @DataType=NULL
Item class | ArtKod |  |  |  | @DataType=NULL
List price | ArtListPris |  |  |  | @DataType=NULL
Material cost total | ArtMatKost |  |  |  | @DataType=NULL
Assembly time | ArtMontTid |  |  |  | @DataType=NULL
Lowest level f item | ArtNiva |  |  |  | @DataType=NULL
Artikelnivå | ArtNivaKod |  |  |  | @DataType=NULL
Item no. | ArtNr |  |  |  | @DataType=NULL
Product class | ArtProdKlass |  |  |  | @DataType=NULL
Product acct | ArtProdKonto |  |  |  | @DataType=NULL
Last PYR date | ArtPyrDat |  |  |  | @DataType=NULL
Item discount class | ArtRabKlass |  |  |  | @DataType=NULL
Revision date | ArtRevDat |  |  |  | @DataType=NULL
Revision no. | ArtRevId |  |  |  | @DataType=NULL
Revision signature | ArtRevSign |  |  |  | @DataType=NULL
Blueprint | ArtRitnNr |  |  |  | @DataType=NULL
Service level code | ArtServKod |  |  |  | @DataType=NULL
TARIC code | ArtStatNr |  |  |  | @DataType=NULL
Uppsk kostn | ArtUpps |  |  |  | @DataType=NULL
Net weight kg | ArtVikt |  |  |  | @DataType=NULL
Viktighetskod | ArtViktighetKod |  |  |  | @DataType=NULL
Volume m3 | ArtVolym |  |  |  | @DataType=NULL
Automatic release | AutoFrislappas |  |  |  | @DataType=NULL
Batch no. required | BatchBokas |  |  |  | @DataType=NULL
Model | BVariant |  |  |  | @DataType=NULL
Copy to parent | CopyUpFromThisItem |  |  |  | @DataType=NULL
Requisition, copy to parent | CopyUpFromThisItemPur |  |  |  | @DataType=NULL
CopyUpToThisItem | CopyUpToThisItem |  |  |  | @DataType=NULL
Diameter | Diam |  |  |  | @DataType=NULL
Text | Edit |  |  |  | @DataType=NULL
Unit code | EnhetsKod |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Delivery cost % | Hemtkostnproc |  |  |  | @DataType=NULL
Purch price curr | InValuta |  |  |  | @DataType=NULL
Scrap factor in % | KassAr |  |  |  | @DataType=NULL
Stocked | LagerBokas |  |  |  | @DataType=NULL
Inventory stock type | LagTyp |  |  |  | @DataType=NULL
Length | Length |  |  |  | @DataType=NULL
VAT/tax code | MomsKod |  |  |  | @DataType=NULL
OLE-1 | ole1 |  |  |  | @DataType=NULL
OLE-2 | ole2 |  |  |  | @DataType=NULL
Price calc method, pkg | OrpStrPrisBer |  |  |  | @DataType=NULL
Package item | PaketArtikel |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL
Serial no. required | SerieNrBokas |  |  |  | @DataType=NULL
Original item no. | UrsprArtNr |  |  |  | @DataType=NULL
Item group | VaruGruppKod |  |  |  | @DataType=NULL
Gross purch price, curr | vb_inpris |  |  |  | @DataType=NULL
Cost price, curr | vbKalkPris |  |  |  | @DataType=NULL


Items/inventory VIEW (varl)

Alphanumeric code for the item, BOM, fixed asset, or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
ABC code | ArtABC |  |  |  | @DataType=NULL
Net purchase price | ArtInPris |  |  |  | @DataType=NULL
Purch price date | ArtInPrisDat |  |  |  | @DataType=NULL
Item no. | ArtNr |  |  |  | @DataType=NULL
Safety stock calc | ArtSecBerTyp |  |  |  | @DataType=NULL
Safety stock days | ArtSecDagar |  |  |  | @DataType=NULL
Safety stock level | ArtSecLager |  |  |  | @DataType=NULL
Total inventory balance | BerSaldo |  |  |  | @DataType=NULL
Shortage/balance | BristSaldo |  |  |  | @DataType=NULL
Available invtry balance | DispSaldo |  |  |  | @DataType=NULL
Disponibelt levdat | DispSaldoLevDat |  |  |  | @DataType=NULL
Econ order quantity | Eoq |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Requisition quantity | InkAnAntal |  |  |  | @DataType=NULL
Purchase agreement no. | InkAvt |  |  |  | @DataType=NULL
Ordered quantity | LagBestAnt |  |  |  | @DataType=NULL
Order point | LagBestPkt |  |  |  | @DataType=NULL
Block purchase quantity | LagBlockBestAnt |  |  |  | @DataType=NULL
Block order quantity | LagBlockOrderAnt |  |  |  | @DataType=NULL
Physical invtry diff YTD | LagDiffAnt |  |  |  | @DataType=NULL
Qty used YTD | LagForbr |  |  |  | @DataType=NULL
Qty used prev yr | LagForbrPreYr |  |  |  | @DataType=NULL
Rcvd delivery YTD | LagInlev |  |  |  | @DataType=NULL
Received del prev yr | LagInlevPreYr |  |  |  | @DataType=NULL
Physical inventory | LagInvAnt |  |  |  | @DataType=NULL
Physical invtry code | LagInvKod |  |  |  | @DataType=NULL
Quoted quantity | LagOff |  |  |  | @DataType=NULL
Qty on order/prod | LagOrdrAnt |  |  |  | @DataType=NULL
Bin | LagPlats |  |  |  | @DataType=NULL
Reserved quantity | LagResAnt |  |  |  | @DataType=NULL
Movement qty | LagRorAnt |  |  |  | @DataType=NULL
Inventory balance | LagSaldo |  |  |  | @DataType=NULL
Inventory location | LagStalle |  |  |  | @DataType=NULL
Usage forecast 1 yr | LagUtlevPrg |  |  |  | @DataType=NULL
Usage forecast this year | LagUtlevPrgAAr |  |  |  | @DataType=NULL
Usage forecast prop | LagUtlevPrgForsl |  |  |  | @DataType=NULL
Usage forecst nxt yr | LagUtlevPrgNAr |  |  |  | @DataType=NULL
Lead time in days | LedTid |  |  |  | @DataType=NULL
Supplier number | LevNr |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Planning manager | PlanAnsv |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL
Last received date | SenInlevDat |  |  |  | @DataType=NULL
Last disp date | SenUtlevDat |  |  |  | @DataType=NULL
Weighting rule | ViktningsRegel |  |  |  | @DataType=NULL


Items/inventory VIEW (vars)

View of the ars table (Item data/inventory location).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
-Tol qty perc not rect | AnmEjAtgTolAntProcMinus | ztInteger | 5 |  | smallint
+Tol ant proc ej åtg | AnmEjAtgTolAntProcPlus | ztInteger | 5 |  | smallint
-Tol qty sftystk not rect | AnmEjAtgTolAntSakLMinus | ZtQty | 14 | 2 | decimal
Shortage tol, days | AnmEjAtgTolDgr | ztInteger | 5 |  | smallint
-Tolerans dgr ej åtg | AnmEjAtgTolDgrMinus | ztInteger | 5 |  | smallint
Excess invtry tol, days | AnmEjAtgTolDgrPlus | ztInteger | 5 |  | smallint
-Tol % sftystk not rect | AnmEjAtgTolProcSakLMinus | ZtQty | 14 | 2 | decimal
Excess invtry tol, qty | AnmodanEjAtgOvlAntSakL | ZtQty | 14 | 2 | decimal
Excess invtry tol, % | AnmodanEjAtgOvlProcSakL | ZtQty | 14 | 2 | decimal
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Excess invtry ctrl | AnmodanOverLagerEnl | ztInteger | 5 |  | smallint
-Tol qty % requisition | AnmodanTolAntProcMinus | ztInteger | 5 |  | smallint
+Tol qty % requisition | AnmodanTolAntProcPlus | ztInteger | 5 |  | smallint
- Replan.horizon | AnmodanTolDgrMinus | ztInteger | 5 |  | smallint
+Replan.horizont | AnmodanTolDgrPlus | ztInteger | 5 |  | smallint
Acq to order point | AnskaffningBestp | ztBoolean |  |  | char
Purchased | AnskaffningKop | ztBoolean |  |  | char
Acq to requirement | AnskaffningMotBehov | ztBoolean |  |  | char
Acquired via MRP run | AnskaffningNettobehov | ztBoolean |  |  | char
Acq to plan | AnskaffningPlanering | ztBoolean |  |  | char
Acquisition method | Anskaffningssatt | ztInteger | 2 |  | smallint
Manufactured | AnskaffningTillv | ztBoolean |  |  | char
Qty being picked | AntalUnderPlock | ZtQty | 14 | 2 | decimal
Item type EOQ/SS | ArpsTyp | ztInteger | 5 |  | smallint
Supplier for invtry loc | ArsLevNr | ztCompanyNo | 20 |  | varchar
ABC code | ArtABC | ztchar | 1 |  | char
Net purchase price | ArtInPris | ZtBaseCurrAmount | 14 | 2 | money
Purch price date | ArtInPrisDat | ztDate |  |  | datetime
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price (incl. tax) | ArtKalkBerInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
New cost price from date | ArtKalkBerNyttDatum | ztDate |  |  | datetime
New cost price (refinement) | ArtKalkBerNyttForadling | ZtBaseCurrAmount | 14 | 2 | money
New cost price (mtrl) | ArtKalkBerNyttMtrl | ZtBaseCurrAmount | 14 | 2 | money
Startkostnad | ArtKalkBerStart | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost prc date | ArtKalkDat | ztDate |  |  | datetime
Calculate costs | ArtKalkKod | ztBoolean |  |  | char
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Ber kalk.pris bas | ArtKalkPrel | ZtBaseCurrAmount | 14 | 2 | money
Calc cost price | ArtKalkPris | ZtBaseCurrAmount | 14 | 2 | money
Average cost price | ArtKalkSnitt | ZtBaseCurrAmount | 14 | 2 | money
Average cost prc (inv.loc.grp) | ArtKalkSnittLstGrupp | ztString | 8 |  | varchar
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Max stock level | ArtMaxLager | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Last PYR date | ArtPyrDat | ztDateTime |  |  | datetime
Safety stock calc | ArtSecBerTyp | ztInteger | 5 |  | smallint
Safety stock days | ArtSecDagar | ztInteger | 5 |  | smallint
Safety stock level | ArtSecLager | ZtQty | 14 | 2 | decimal
Auto breakdown within MO | AutoVidareNedbrInomTo | ztBoolean |  |  | char
Cost prc date (backdated) | BakdateraArtKalkDat | ztDate |  |  | datetime
Batch no. | BatchId | ztString | 30 |  | varchar
Incl in assmbly analysis | BehandlasIMontAnalys | ztBoolean |  |  | char
Total inventory balance | BerSaldo | ZtQty | 14 | 2 | decimal
Bin ID required | BinLocMustEnter | ztBoolean |  |  | char
Bin rule | BinLocRule | ztInteger | 2 |  | smallint
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Shortage/balance | BristSaldo | ZtQty | 14 | 2 | decimal
Purchase price budget | BudgInPris | ZtBaseCurrAmount | 14 | 2 | money
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Create log for item in MRP | CreateNRPLog | ztBoolean |  |  | char
Available invtry balance | DispSaldo | ZtQty | 14 | 2 | decimal
Disponibelt levdat | DispSaldoLevDat | ZtQty | 14 | 2 | decimal
Econ order quantity | Eoq | ZtQty | 14 | 2 | decimal
Purchase quantity acc days | EplDagar | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Requisition quantity | InkAnAntal | ZtQty | 14 | 2 | decimal
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Purch qty according to rule | InkKvantEnlRegel | ztInteger | 5 |  | smallint
Purch price curr | InValuta | ztString | 3 |  | varchar
Inv loc cost price grp | InvLocCostPriceGrp | ztString | 8 |  | varchar
Avail inventory balance | ItemAvailInvBal | ztString | 8 |  | varchar
Calc inventory balance | ItemCalcInvBal | ztString | 8 |  | varchar
Cost update code | KalkPrisAndrTypKod | ztInteger | 5 |  | smallint
Ordered quantity | LagBestAnt | ZtQty | 14 | 2 | decimal
Order point | LagBestPkt | ZtQty | 14 | 2 | decimal
Block purchase quantity | LagBlockBestAnt | ZtQty | 14 | 2 | decimal
Block order quantity | LagBlockOrderAnt | ZtQty | 14 | 2 | decimal
Physical invtry diff YTD | LagDiffAnt | ZtQty | 14 | 2 | decimal
Inventory as of | LagerPerDen | ztDate |  |  | datetime
Stock build-up in days | LagerUppbyggnadIDagar | ztInteger | 5 |  | smallint
Qty used YTD | LagForbr | ZtQty | 14 | 2 | decimal
Qty used during period | LagForbrPer | ZtQty | 14 | 2 | decimal
Qty used prev yr | LagForbrPreYr | ZtQty | 14 | 2 | decimal
Qty used prev year 2 | LagForbrPreYr2 | ZtQty | 14 | 2 | decimal
Rcvd delivery YTD | LagInlev | ZtQty | 14 | 2 | decimal
Received deliv during period | LagInlevPer | ZtQty | 14 | 2 | decimal
Received del prev yr | LagInlevPreYr | ZtQty | 14 | 2 | decimal
Rcvd del prev year2 | LagInlevPreYr2 | ZtQty | 14 | 2 | decimal
Physical inventory | LagInvAnt | ZtQty | 14 | 2 | decimal
Physical invtry code | LagInvKod | ztInteger | 2 |  | smallint
Quoted quantity | LagOff | ZtQty | 14 | 2 | decimal
Inventory turnover | LagOmsHast | ztFloat | 15 | 2 | float
Invtry turnover prev year | LagOmsHastPreYr | ztFloat | 15 | 2 | float
Invtry turnov prev yr 2 | LagOmsHastPreYr2 | ztFloat | 15 | 2 | float
Qty on order/prod | LagOrdrAnt | ZtQty | 14 | 2 | decimal
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Reserved quantity | LagResAnt | ZtQty | 14 | 2 | decimal
Movement qty | LagRorAnt | ZtLong | 8 |  | int
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Blocked quantity | LagSaldoEjAnv | ZtQty | 14 | 2 | decimal
Inventory balance blocked | LagSaldoSparrat | ztBoolean |  |  | char
Invtry balance, blocked qty | LagSaldoSparratAntal | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry loc group | LagStalleGrupp | ztString | 8 |  | varchar
Usage forecast 1 yr | LagUtlevPrg | ZtQty | 14 | 2 | decimal
Usage forecast this year | LagUtlevPrgAAr | ZtQty | 14 | 2 | decimal
Usage forecast prop | LagUtlevPrgForsl | ZtQty | 14 | 2 | decimal
Usage forecst nxt yr | LagUtlevPrgNAr | ZtQty | 14 | 2 | decimal
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Max qty per MO | MaxTillvAntPerTO | ZtQty | 14 | 2 | decimal
Assmbly analys, aftr lead time | MontAnalysEfterLedTid | ztBoolean |  |  | char
Re-plan or new order | NE_OmplanEllerNyOrder | ztInteger | 5 |  | smallint
Rule for last NE proposal | NE_RegelSistaForslag | ztInteger | 5 |  | smallint
Balance type at MRP | NE_SaldoTyp | ztInteger | 5 |  | smallint
Orig order row qty | Orp_UrsprOrdAntal | ZtQty | 14 | 2 | decimal
Per closing invtry bal | PeriodLagSaldo | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Per closing batch value | PerUtgBatchVarde | ZtBaseCurrAmount | 14 | 2 | money
Period closing stock (batch) | PerUtgLagVardeBatch | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (FIFO) | PerUtgLagVardeFifo | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (cost) | PerUtgLagVardeKalk | ZtBaseCurrAmount | 14 | 2 | money
Per closing bal (repl) | PerUtgLagVardeSInk | ZtBaseCurrAmount | 14 | 2 | money
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Forecast this year | Prognos | ZtQty | 14 | 2 | decimal
Forecast prev year | PrognosPreYr | ZtQty | 14 | 2 | decimal
Forecast prev year 2 | PrognosPreYr2 | ZtQty | 14 | 2 | decimal
Proposal for each need | ProposalForEachNeed | ztBoolean |  |  | char
Not included in avail. balance | QtyNotInAvailInvtBal | ZtQty | 14 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Delete this item | RemoveItem | ztBoolean |  |  | char
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
End date of holiday | SemesterSlutDatum | ztDate |  |  | datetime
Start date of holiday | SemesterStartDatum | ztDate |  |  | datetime
Last received date | SenInlevDat | ztDate |  |  | datetime
Last disp date | SenUtlevDat | ztDate |  |  | datetime
Setup cost/MO | ToStallKostnad | ZtCost | 16 | 6 | float
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Purchase price incl tax | Vb_InPrisInklMoms | ztMoney | 14 | 2 | money
Cost price, curr | vbArtKalkPris | ztMoney | 14 | 2 | money
Cost price, curr | vbKalkPris | ztMoney | 14 | 2 | money
Nytt kalk.pris valuta | vbKalkPrisNytt | ztMoney | 14 | 2 | money
Weighting rule | ViktningsRegel | ztString | 4 |  | varchar

    This table is the main table in the following programs:

    Program: ArsBatX Batch item planning

    Program: ArsPlan Item planning

    Program: ArsPlanX Special item planning

    Program: OrpArt Orders per item


Jeeves - Control param., current value, VIEW (vjvss)

Parameter table to control functions in Jeeves.
Completed settings of Jeeves.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
JeevesParamBoolean | JeevesParamBoolean | ztBoolean |  |  | char
Parameter name | JeevesParamName | ztString | 20 |  | varchar
JeevesParamNumeric | JeevesParamNumeric | ztInteger | 5 |  | smallint
JeevesParamString | JeevesParamString | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Jeeves - control param., documentation (jvst)

Table with documentation of parameters that control functionality in different Jeeves modules.
This table contains a description of each parameter in each language.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Jeeves Param Descr | JeevesParamDescr | ztString | 100 |  | varchar
Parameter name | JeevesParamName | ztString | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint

    This table is the main table in the following programs:

    Program: jvst Jeeves - control param., documentation


Jeeves company's own term description (jctd)

Used when you want to define different prompts for different Jeeves companies in the same database.
Via the tools menu in Jeeves you can insert your own prompts for fields in Jeeves screens, but it will then be the same prompt for all Jeeves companies in the same database. You can specify prompts per Jeeves company in the table in question.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Term | ColumnName | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Table name | TableName | ztString | 255 |  | varchar
Prompt | TermPrompt | ztString | 30 |  | varchar
Language code | zlanguage | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: jctd Deviating prompts per company


Jeeves messages (jmsg)

Messages / error messages from Jeeves.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Planned activity descr | EventNote | ztString | 60 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Reported end time | EventRpTime | ztTime | 5 |  | datetime
Hours | EventTimant2 | ztHourWithDecimals | 8 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Note | KortNotering | ztString | 255 |  | varchar
Print date | p_utskr_dat | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Row | radpos2 | ztInteger | 4 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Entry time | regtime | ztTime | 5 |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Process ID | Spid | ZtLong | 5 |  | int
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Date/time | StrDateTime | ztString | 28 |  | varchar

    This table is the main table in the following programs:

    Program: jmsg Messages from Jeeves.


Jeeves program menu (JvsPgmMenu)

Numerical identity of Jeeves program menu.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Menu definition | JvsPgmMenuBLOB |  |  |  | @DataType=NULL
Jeeves pgm menu | JvsPgmMenuDescr |  |  |  | @DataType=NULL
Jeeves pgm menu ID | JvsPgmMenuId |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL

    This table is the main table in the following programs:

    Program: JvsPgmMenu Program menues in Jeeves application


Jeeves program menu connection to signature (JvsPgmMenu2Signarture)

Numerical identity of Jeeves program menu.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber |  |  |  | @DataType=NULL
Original company | IntrnCoNoOrigin |  |  |  | @DataType=NULL
Jeeves pgm menu | JvsPgmMenuDescr |  |  |  | @DataType=NULL
Jeeves pgm menu ID | JvsPgmMenuId |  |  |  | @DataType=NULL
User group ID | JvsUsrGroupId |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Columns updated | RowUpdatedCols |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL
Language code | zLanguage |  |  |  | @DataType=NULL

    This table is the main table in the following programs:

    Program: JvsPgmMenu2Signarture Program menues connect to signature


Jeeves stored procedures (xspr)

Namn på stored procedure eller trigger i JEEVES.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Procedur/Triggernamn | SprTrgName | ztString | 100 |  | nvarchar
Procedurtyp, Jeeves | SprTrgType | ztString | 2 |  | varchar


Jeeves system process (vsyp)

Process ID in SQL Server. ((SQL Server Books On Line master SysProcesses))

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
DB login sign | DBLogInSign | ztString | 8 |  | varchar
Program ID | JeevesPgmId | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
DB lib process ID | ProcIdDBLib | ZtLong | 10 |  | int
DB lib proc ID 1:a | ProcIdDBLibPgmId | ZtLong | 10 |  | int
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Process ID | spid | ZtLong | 5 |  | int
Process ID, pgm | spidpgm | ZtLong | 5 |  | int
Process status | SpidStatus | ztString | 30 |  | nchar

    This table is the main table in the following programs:

    Program: xVsyp Jeeves system processes


Jeeves system process (sysp)

Internal table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
CancelSQLQuery | CancelSQLProcedure | ztBoolean |  |  | char
DB login sign | DBLogInSign | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Group | Grupp | ztInteger | 4 |  | smallint
(InfoFromSQLProcedure) | InfoFromSQLProcedure | ztString | 255 |  | varchar
Program ID | JeevesPgmId | ztString | 8 |  | varchar
Object name | ObjectName | ztString | 128 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
DB lib process ID | ProcIdDBLib | ZtLong | 10 |  | int
DB lib proc ID 1:a | ProcIdDBLibPgmId | ZtLong | 10 |  | int
Row | RadPos | ZtLong | 10 |  | int
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Process ID | spid | ZtLong | 5 |  | int
Process ID, pgm | spidpgm | ZtLong | 5 |  | int
Language | SprakKod | ztInteger | 3 |  | smallint
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xSysp Users logged in to Jeeves

    Program: xSysp1 User logins


Jeeves user groups (JvsUsrGroups)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber |  |  |  | @DataType=NULL
Original company | IntrnCoNoOrigin |  |  |  | @DataType=NULL
User group descr | JvsUsrGroupDescr |  |  |  | @DataType=NULL
User group ID | JvsUsrGroupId |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Columns updated | RowUpdatedCols |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL

    This table is the main table in the following programs:

    Program: JvsUsrGroups User groups


Job queue for EDI server (edij)

Contains the job queue to be processed by the EDI server. The records in the queue are generated when the EDI server calls the procedure JEEVES_Edi_WhatDoNow.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Error sequence | EdiAlertCommandSeqNo | ztInteger | 5 |  | smallint
In/Out box EDI | EdiBoxRef | ztString | 21 |  | varchar
Method of communication | EdiComNo | ztInteger | 5 |  | smallint
ErrorLevel | EdiErrorLevel | ztInteger | 5 |  | smallint
EDI partner profile | EdiId | ZtLong | 6 |  | int
Job number | EdiJob | ZtLong | 10 |  | int
Argument 1 | EdiJobArg1 | ztString | 255 |  | varchar
Argument 2 | EdiJobArg2 | ztString | 255 |  | varchar
Argument 3 | EdiJobArg3 | ztString | 255 |  | varchar
Argument 4 | EdiJobArg4 | ztString | 255 |  | varchar
Argument 5 | EdiJobArg5 | ztString | 255 |  | varchar
EDI command | EdiJobCommand | ztString | 35 |  | varchar
Compl time | EdiJobDoneDT | ztDateTime |  |  | datetime
Sequence number | EdiJobSeq | ztInteger | 5 |  | smallint
Starting time | EdiJobStartDT | ztDateTime |  |  | datetime
Status | EdiJobStatus | ztInteger | 2 |  | smallint
Job timeout | EdiJobTimeout | ztInteger | 5 |  | smallint
ReqStartTime | EdiJobWhenDT | ztDateTime |  |  | datetime
Log text 1 | EdiLogg1 | ztBlob | 1 |  | varchar
Log text 2 | EdiLogg2 | ztBlob | 1 |  | varchar
Log text 3 | EdiLogg3 | ztBlob | 1 |  | varchar
Log text 4 | EdiLogg4 | ztBlob | 1 |  | varchar
Log text 5 | EdiLogg5 | ztBlob | 1 |  | varchar
Log text 6 | EdiLogg6 | ztBlob | 1 |  | varchar
EDI log code | EdiLoggKod | ztInteger | 5 |  | smallint
Message number | EdiMsgNo | ztInteger | 5 |  | smallint
Script | EdiScript | ztBlob | 1 |  | varchar
ScriptFile | EdiScriptFile | ztString | 255 |  | varchar
EDI server no | EdiServerNo | ztInteger | 5 |  | smallint
Command type | EdiSubCommand | ztString | 20 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Sent by e-mail | Mailed | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: edij Job queue for EDI server


Joint customers per assignment (meku)

Contains the customers on an assignment to be jointly invoiced when the assignment is invoiced. A percentage rate controls the customer's share of the invoice.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quote/agreement no. | Offnr | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Percent of invoice | ProcentavFaktura | ztFloat | 7 | 2 | float
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Joint picking list (solh)

Joint picking list header combines several dispatch orders to ease picking.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Packer | Packarekod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Picking list date | PlUtskrDat | ztDateTime |  |  | datetime
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Joint pick | Samplockas | ztBoolean |  |  | char
Joint pick list No. | samplocklistenr | ZtLong | 6 |  | int

    This table is the main table in the following programs:

    Program: Solh Joint picking, create list

    Program: SolhUCorl Joint picking list, picking bookings

    Program: Solhutpl Joint picking


Joint picking, order connection (olhf)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | Lagstalle | ztString | 2 |  | varchar
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order no. | Ordernr | Jeeves_SONo | 8 |  | bigint
Dispatch type | Ordlevnr | ztInteger | 5 |  | int
Backorder no. | Ordrestnr | ztInteger | 2 |  | smallint
Packer | Packarekod | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Joint pick list No. | SamplocklisteNr | ZtLong | 6 |  | int


Joint view cust invoice calc (ukrt)

Generated work table of Jeeves for the Preliminary interest calc report.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoice date | FaktDat |  |  |  | @DataType=NULL
Due date | FaktFfDat |  |  |  | @DataType=NULL
Invoice no. | FaktNr |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Company ID | FtgNr |  |  |  | @DataType=NULL
Interest amount | RtaBelopp |  |  |  | @DataType=NULL
Interest days | RtaDagar |  |  |  | @DataType=NULL
Itrst from | RtaFromDat |  |  |  | @DataType=NULL
Activity date | RtaHandDatum |  |  |  | @DataType=NULL
Interest % | RtaProcent |  |  |  | @DataType=NULL
Interest balance | RtaSaldo |  |  |  | @DataType=NULL
Last interest calc | RtaSenBer |  |  |  | @DataType=NULL
Interest up to date | RtaTomDat |  |  |  | @DataType=NULL
Record type | UkrtTyp |  |  |  | @DataType=NULL
Currency | ValKod |  |  |  | @DataType=NULL
Interest amount curr | ValRtaBelopp |  |  |  | @DataType=NULL
Interest balance curr | ValRtaSaldo |  |  |  | @DataType=NULL
Invoice amount, curr | Vb_FaktSum |  |  |  | @DataType=NULL


Joint view inventory/purch/mfg (ulbp)

This view is used for handling planned inventory events.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr |  |  |  | @DataType=NULL
Row | AoPos |  |  |  | @DataType=NULL
Item description | ArtBeskr |  |  |  | @DataType=NULL
Current cost price | ArtKalkBer |  |  |  | @DataType=NULL
Cost price (actual) | ArtKalkPrisE |  |  |  | @DataType=NULL
Assembly time | ArtMontTid |  |  |  | @DataType=NULL
Item no. | ArtNr |  |  |  | @DataType=NULL
Item serial no. | ArtSerieNr |  |  |  | @DataType=NULL
Use/Best before | BastForeDatum |  |  |  | @DataType=NULL
Batch description | BatchDescr |  |  |  | @DataType=NULL
Batch no. | BatchId |  |  |  | @DataType=NULL
Order qty (invtry unit) | BestAnt |  |  |  | @DataType=NULL
Purchase price | BestInPris |  |  |  | @DataType=NULL
Delivery received date | BestLevDat |  |  |  | @DataType=NULL
PO no. | BestNr |  |  |  | @DataType=NULL
Row no. in PO | BestRadNr |  |  |  | @DataType=NULL
PO backorder no. | BestRestNr |  |  |  | @DataType=NULL
Quantity booked | BokatAntal |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Company name | FtgNamn |  |  |  | @DataType=NULL
Integration detail | IntField |  |  |  | @DataType=NULL
Bin | LagPlats |  |  |  | @DataType=NULL
Reserved quantity | LagResAnt |  |  |  | @DataType=NULL
Inventory balance | LagSaldo |  |  |  | @DataType=NULL
Inventory location | LagStalle |  |  |  | @DataType=NULL
Lead time in days | LedTid |  |  |  | @DataType=NULL
Remaining qty | OrdRestAnt |  |  |  | @DataType=NULL
Project ID | ProjCode |  |  |  | @DataType=NULL
Date/time | StrDateTime |  |  |  | @DataType=NULL
Source | ulbpTyp |  |  |  | @DataType=NULL
Last sale date | ValidityDate |  |  |  | @DataType=NULL
Item group | VaruGruppBeskr |  |  |  | @DataType=NULL
Gross purch price, curr | Vb_InPris |  |  |  | @DataType=NULL


Joint view OrpC+inventory (uocl)

This view is used for handling planned inventory events.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal |  |  |  | @DataType=NULL
Item no. | ArtNr |  |  |  | @DataType=NULL
Item serial no. | ArtSerieNr |  |  |  | @DataType=NULL
Batch no. | BatchId |  |  |  | @DataType=NULL
Quantity booked | BokatAntal |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Bin | LagPlats |  |  |  | @DataType=NULL
Inventory location | LagStalle |  |  |  | @DataType=NULL
Order no. | OrderNr |  |  |  | @DataType=NULL
Order row no. | OrdRadnr |  |  |  | @DataType=NULL
Subrow no. | OrdRadNrStrPos |  |  |  | @DataType=NULL
Backorder no. | OrdRestNr |  |  |  | @DataType=NULL
Date/time | StrDateTime |  |  |  | @DataType=NULL
Row type | UoclTyp |  |  |  | @DataType=NULL


Joint view, planned inventory trans (uphl)

This view is used for handling planned inventory events.
These events are from:
-customer orders
-purchase orders
-manufacturing deliveries
-manufacturing consumption

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Arrival entered | AnkomstRapporterad |  |  |  | @DataType=NULL
Quantity | Antal |  |  |  | @DataType=NULL
Mfg/Works order no. | AoNr |  |  |  | @DataType=NULL
Row | AoPos |  |  |  | @DataType=NULL
Item description | ArtBeskr |  |  |  | @DataType=NULL
Specification | ArtBeskrSpec |  |  |  | @DataType=NULL
Current cost price | ArtKalkBer |  |  |  | @DataType=NULL
Priority | ArtLevPrior |  |  |  | @DataType=NULL
Item no. | ArtNr |  |  |  | @DataType=NULL
Base company in plan.list | BASEIntrnCoNo |  |  |  | @DataType=NULL
Base inventory location in plan.list | BASEInventoryLoc |  |  |  | @DataType=NULL
Batch no. | BatchId |  |  |  | @DataType=NULL
Request disp date | BestBegLevDat |  |  |  | @DataType=NULL
Received qty invtry unit | BestLevAnt |  |  |  | @DataType=NULL
Delivery received date | BestLevDat |  |  |  | @DataType=NULL
Promised disp date | BestLovLevDat |  |  |  | @DataType=NULL
PO no. | BestNr |  |  |  | @DataType=NULL
Row no. in PO | BestRadNr |  |  |  | @DataType=NULL
PO backorder no. | BestRestNr |  |  |  | @DataType=NULL
Quantity booked | BokatAntal |  |  |  | @DataType=NULL
Drop ship | DirektLeverans |  |  |  | @DataType=NULL
Costing complete | EfterKalkKod |  |  |  | @DataType=NULL
Invoice date | FaktDat |  |  |  | @DataType=NULL
Invoice no. | FaktNr |  |  |  | @DataType=NULL
Delivery note/disp no. | ffhnr |  |  |  | @DataType=NULL
RowNo | ffhradnr |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Sales price, BCU | FPris |  |  |  | @DataType=NULL
Destination | FtgBestOrt |  |  |  | @DataType=NULL
Ship to->Visit addr | FtgLevAdressKod |  |  |  | @DataType=NULL
Company name | FtgNamn |  |  |  | @DataType=NULL
Company name | FtgNamnLevAdress |  |  |  | @DataType=NULL
Company ID | FtgNr |  |  |  | @DataType=NULL
c/o address | FtgPostAdr1 |  |  |  | @DataType=NULL
Street addr/box | FtgPostAdr2 |  |  |  | @DataType=NULL
Town/City/State | FtgPostAdr3 |  |  |  | @DataType=NULL
Visiting address | FtgPostAdr4 |  |  |  | @DataType=NULL
Delivery address | FtgPostAdr5 |  |  |  | @DataType=NULL
ZIP/Post code | FtgPostNr |  |  |  | @DataType=NULL
Purchase agreement no. | InkAvt |  |  |  | @DataType=NULL
Customer | KundNr |  |  |  | @DataType=NULL
Layer | LagLayer |  |  |  | @DataType=NULL
Inventory location | LagStalle |  |  |  | @DataType=NULL
Supplier number | LevNr |  |  |  | @DataType=NULL
Dispatch terms | LevVillkBeskr |  |  |  | @DataType=NULL
Dispatch terms | LevVillkKod |  |  |  | @DataType=NULL
Order-specific inventory | MarkOrderUniktLager |  |  |  | @DataType=NULL
Quote/agreement no. | OffNr |  |  |  | @DataType=NULL
Pick status | OkAttPlockaStatus |  |  |  | @DataType=NULL
Pick status description | OkAttPlockaStatusBeskr |  |  |  | @DataType=NULL
Operation no. | OpNr |  |  |  | @DataType=NULL
Order row qty | OrdAntal |  |  |  | @DataType=NULL
Order date | OrdDatum |  |  |  | @DataType=NULL
Order no. | OrderNr |  |  |  | @DataType=NULL
Order no. (alpha) | OrderNrAlfa |  |  |  | @DataType=NULL
Point of delivery, co. ID | OrdLevPlats1 |  |  |  | @DataType=NULL
Point of delivery, name | OrdLevPlBeskr |  |  |  | @DataType=NULL
Order row no. | OrdRadNr |  |  |  | @DataType=NULL
Subrow no. | OrdRadNrStrPos |  |  |  | @DataType=NULL
Total row discount % | OrdRadRab |  |  |  | @DataType=NULL
Backorder no. | OrdRestNr |  |  |  | @DataType=NULL
Order status | OrdStatBeskr |  |  |  | @DataType=NULL
Order type | OrdTyp |  |  |  | @DataType=NULL
Order type | OrdTypAlfa |  |  |  | @DataType=NULL
Order type | OrdTypBeskr |  |  |  | @DataType=NULL
Row type plan list | PlanLstRadTyp |  |  |  | @DataType=NULL
Project ID | ProjCode |  |  |  | @DataType=NULL
Dummy planning list | qUphlDummy1 |  |  |  | @DataType=NULL
Dummy planning list | qUphlDummy2 |  |  |  | @DataType=NULL
Discount | RadRabattBelopp |  |  |  | @DataType=NULL
Requisition | StrDateTimeBIA |  |  |  | @DataType=NULL
Transit delivery | TransitLeverans |  |  |  | @DataType=NULL
Source | ulbpTyp |  |  |  | @DataType=NULL
Currency | ValKod |  |  |  | @DataType=NULL
Exchange rate | ValKurs |  |  |  | @DataType=NULL
Item group | VaruGruppBeskr |  |  |  | @DataType=NULL
Price, curr | vb_Pris |  |  |  | @DataType=NULL
Balance (2,3) | x23_PlanSaldo |  |  |  | @DataType=NULL
Sort type | XSortTyp |  |  |  | @DataType=NULL


Joint view, planned invtry activities, spcl (uphx)

This view is used for handling planned inventory movements in the special planning list (ArsPlanX). These movemvents are from:
-customer orders
-purchase orders
-manufacturing deliveries
-manufacturing consumption

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Arrival entered | AnkomstRapporterad |  |  |  | @DataType=NULL
Quantity | Antal |  |  |  | @DataType=NULL
Mfg/Works order no. | AoNr |  |  |  | @DataType=NULL
Row | AoPos |  |  |  | @DataType=NULL
Item description | ArtBeskr |  |  |  | @DataType=NULL
Specification | ArtBeskrSpec |  |  |  | @DataType=NULL
Current cost price | ArtKalkBer |  |  |  | @DataType=NULL
Priority | ArtLevPrior |  |  |  | @DataType=NULL
Item no. | ArtNr |  |  |  | @DataType=NULL
Batch no. | BatchId |  |  |  | @DataType=NULL
Request disp date | BestBegLevDat |  |  |  | @DataType=NULL
Received qty invtry unit | BestLevAnt |  |  |  | @DataType=NULL
Delivery received date | BestLevDat |  |  |  | @DataType=NULL
Promised disp date | BestLovLevDat |  |  |  | @DataType=NULL
PO no. | BestNr |  |  |  | @DataType=NULL
Row no. in PO | BestRadNr |  |  |  | @DataType=NULL
PO backorder no. | BestRestNr |  |  |  | @DataType=NULL
Supplier invoice no. | BestRkgNr |  |  |  | @DataType=NULL
Quantity booked | BokatAntal |  |  |  | @DataType=NULL
Drop ship | DirektLeverans |  |  |  | @DataType=NULL
Costing complete | EfterKalkKod |  |  |  | @DataType=NULL
Invoice date | FaktDat |  |  |  | @DataType=NULL
Invoice no. | FaktNr |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Sales price, BCU | FPris |  |  |  | @DataType=NULL
Destination | FtgBestOrt |  |  |  | @DataType=NULL
Ship to->Visit addr | FtgLevAdressKod |  |  |  | @DataType=NULL
Company name | FtgNamn |  |  |  | @DataType=NULL
Company name | FtgNamnLevAdress |  |  |  | @DataType=NULL
Company ID | FtgNr |  |  |  | @DataType=NULL
c/o address | FtgPostAdr1 |  |  |  | @DataType=NULL
Street addr/box | FtgPostAdr2 |  |  |  | @DataType=NULL
Town/City/State | FtgPostAdr3 |  |  |  | @DataType=NULL
Visiting address | FtgPostAdr4 |  |  |  | @DataType=NULL
Delivery address | FtgPostAdr5 |  |  |  | @DataType=NULL
ZIP/Post code | FtgPostNr |  |  |  | @DataType=NULL
Goods label row 1 | GodsMarke1 |  |  |  | @DataType=NULL
Goods label row 2 | GodsMarke2 |  |  |  | @DataType=NULL
Goods label row 3 | GodsMarke3 |  |  |  | @DataType=NULL
Goods label row 4 | GodsMarke4 |  |  |  | @DataType=NULL
Purchase agreement no. | InkAvt |  |  |  | @DataType=NULL
Customer | KundNr |  |  |  | @DataType=NULL
Layer | LagLayer |  |  |  | @DataType=NULL
Inventory location | LagStalle |  |  |  | @DataType=NULL
Supplier number | LevNr |  |  |  | @DataType=NULL
Dispatch terms | LevVillkBeskr |  |  |  | @DataType=NULL
Dispatch terms | LevVillkKod |  |  |  | @DataType=NULL
Order-specific inventory | MarkOrderUniktLager |  |  |  | @DataType=NULL
Quote/agreement no. | OffNr |  |  |  | @DataType=NULL
Quote/agreement row no | OffRadNr |  |  |  | @DataType=NULL
Pick status | OkAttPlockaStatus |  |  |  | @DataType=NULL
Pick status description | OkAttPlockaStatusBeskr |  |  |  | @DataType=NULL
Operation no. | OpNr |  |  |  | @DataType=NULL
Order row qty | OrdAntal |  |  |  | @DataType=NULL
Order date | OrdDatum |  |  |  | @DataType=NULL
Order no. | OrderNr |  |  |  | @DataType=NULL
Order no. (alpha) | OrderNrAlfa |  |  |  | @DataType=NULL
Point of delivery, co. ID | OrdLevPlats1 |  |  |  | @DataType=NULL
Point of delivery, name | OrdLevPlBeskr |  |  |  | @DataType=NULL
Order row no. | OrdRadNr |  |  |  | @DataType=NULL
Subrow no. | OrdRadNrStrPos |  |  |  | @DataType=NULL
Total row discount % | OrdRadRab |  |  |  | @DataType=NULL
Backorder no. | OrdRestNr |  |  |  | @DataType=NULL
Order status | OrdStatBeskr |  |  |  | @DataType=NULL
Order type | OrdTyp |  |  |  | @DataType=NULL
Order type | OrdTypAlfa |  |  |  | @DataType=NULL
Order type | OrdTypBeskr |  |  |  | @DataType=NULL
Row type plan list | PlanLstRadTyp |  |  |  | @DataType=NULL
Project ID | ProjCode |  |  |  | @DataType=NULL
Discount | RadRabattBelopp |  |  |  | @DataType=NULL
Serv.order no | ServOrderNr |  |  |  | @DataType=NULL
Order row, service | ServOrdRadNr |  |  |  | @DataType=NULL
Requisition | StrDateTimeBIA |  |  |  | @DataType=NULL
Transit delivery | TransitLeverans |  |  |  | @DataType=NULL
Source | ulbpTyp |  |  |  | @DataType=NULL
Currency | ValKod |  |  |  | @DataType=NULL
Exchange rate | ValKurs |  |  |  | @DataType=NULL
Item group | VaruGruppBeskr |  |  |  | @DataType=NULL
Price, curr | vb_Pris |  |  |  | @DataType=NULL
Balance (2,3) | X23_PlanSaldo |  |  |  | @DataType=NULL
Sort type | XSortTyp |  |  |  | @DataType=NULL


Journal BOEs (vxrj)

Contains bill of exchange journals.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Bank | BankId | ztString | 10 |  | varchar
Paid before due date | BoE_Fore_FFDat | ztBoolean |  |  | char
Transferred General Ledger | BoE_Jour_Status | ztBoolean |  |  | char
Journal text | BoE_Jour_Text | ztString | 50 |  | varchar
Journal type | Boe_Journal_Type | ztInteger | 5 |  | smallint
BOE journal no | BoE_JournNo | ZtLong | 10 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Journal status | JrnlStatus | ztInteger | 2 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Print date | RemPrintDate | ztDateTime |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
To due date | ToDueDate | ztDate |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: vxri BOE paid journal

    Program: vxrj Supplier invoice BOE journal

    Program: vxrk BOE collection journal


Journal groups (jgrp)

Definition of journal group numbers and descriptions for optional grouping of integration sources. See under the Help field for more information.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Journal group | JourGrupp | ZtLong | 9 |  | int
Journal group descr | JourGruppBeskr | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: jgrp Journal groups


Journal header (fvt)

When journals are entered, details of the journal header are stored in this table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of journals | AntBilag | ZtLong | 10 |  | int
Reversal voucher no. | AterBokasVerNr | Jeeves_VchrNo | 9 |  | bigint
Approved by | AttestSign | ztString | 6 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
JournalNo. | BilagJournNr | ZtLong | 7 |  | int
Journal type | Bilagsart | ZtLong | 8 |  | int
Journal date | Bilagsdato | ztDate |  |  | datetime
Journal no. | Bilagsnr | Jeeves_VchrNo | 9 |  | bigint
Accounting date | BokfDat | ztDate |  |  | datetime
Bundle no. | buntnr | ZtLong | 9 |  | int
Cashier | Cashierid | ztString | 30 |  | varchar
Sequence no., cash out | CashIssueno | ztString | 40 |  | varchar
Cash/Bank ID | CashOrBankBookid | ztString | 15 |  | varchar
Sequence no., cash in | Cashreceiptno | ztString | 40 |  | varchar
Cash/bank report no. | CashStatementNo | ztString | 40 |  | varchar
Debit amount | debbel | ZtBaseCurrAmount | 14 | 2 | money
Text | Edit | ztBlob | 1 |  | varchar
Customer's own account class | egenkontoklass | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Transaction type | Foringskod | ztInteger | 3 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Company text | FtgText | ztString | 40 |  | varchar
Transferred ->GL | FvtStatus | ztBoolean |  |  | char
Posting date | HbUpDat | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Opening balance | ingsaldo | ZtBaseCurrAmount | 14 | 2 | money
Opening balance curr | ingSaldoFCU | ztMoney | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Credit amount | krebel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Voucher no. type | ManVer | ztInteger | 2 |  | smallint
OLE-1 | ole1 | ztString | 255 |  | varchar
Print date | p_utskr_dat | ztDate |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Total closing balance | sumutgsaldo | ZtBaseCurrAmount | 14 | 2 | money
Tot closing balance curr | SumUtgSaldoFCU | ztMoney | 14 | 2 | money
Closing balance | UtgSaldo | ZtBaseCurrAmount | 14 | 2 | money
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Closing balance, curr | vbUtgSaldo | ztMoney | 14 | 2 | money
Voucher amount | VerBel | ZtBaseCurrAmount | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Voucher no. group | VerNrGrupp | ztString | 6 |  | varchar
Voucher text | VerText | ztString | 60 |  | varchar
Voucher amount curr | VoucheramountFCU | ztMoney | 14 | 2 | money
Voucher status | VtStatus | ztInteger | 2 |  | smallint
Deleted | zDeleted | ztInteger | 1 |  | smallint

    This table is the main table in the following programs:

    Program: nobi Journal entry


Journal rows (fvr)

When journals are entered, details of the journal rows are stored in this table.

A journal row is a kind of preliminary row when posting supplier invoices (primarily when the invoice originates from purchase orders) and customer invoices.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval status | AttestKod1 | ztInteger | 1 |  | smallint
Approved by | AttestSign | ztString | 6 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Posting template, advance | AutoRegelForskott | ztString | 4 |  | varchar
Avräkningskonto | AvrKtoKod | ztBoolean |  |  | char
Account at bank | BankKonto | ztString | 40 |  | varchar
Net amount | Belopp | ZtBaseCurrAmount | 14 | 2 | money
This field is used in the table as follows: |
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | Bestrkgnr | ztString | 25 |  | varchar
Advance, linked invoice no. | BestRkgNrForskott | ztString | 25 |  | varchar
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Payment terms | betkod | ztString | 2 |  | varchar
Journal type | Bilagsart | ZtLong | 8 |  | int
Journal no. | Bilagsnr | Jeeves_VchrNo | 9 |  | bigint
Row text | BilagsRadText | ztString | 60 |  | varchar
TextID | BilagsTextNr | ztInteger | 3 |  | smallint
Accounting date | BokfDat | ztDate |  |  | datetime
Bundle no. | BuntNr | ZtLong | 9 |  | int
Early stlmt dsct basis curr | CashDiscBaseFCU | ztMoney | 14 | 2 | money
VAT bas early settlmt discnt curr | CashDiscBaseFCU_VAT | ztMoney | 14 | 2 | money
Sequence no., cash out | CashissueNo | ztString | 40 |  | varchar
Cash/Bank ID | CashOrBankBookid | ztString | 15 |  | varchar
Sequence no., cash in | CashreceiptNo | ztString | 40 |  | varchar
Cash/bank report no. | CashStatementNo | ztString | 40 |  | varchar
Credit amount curr | CreAmtFCU | ztMoney | 14 | 2 | money
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
VAT/tax GL date | DateOfTaxSupply | ztDate |  |  | datetime
Debit amount curr | DebAmtFCU | ztMoney | 14 | 2 | money
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | Debkre | ztchar | 1 |  | char
Text | Edit | ztBlob | 1 |  | varchar
Customer's own account class | egenkontoklass | ztString | 8 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Due date | FaktFfDat | ztDate |  |  | datetime
Sales tax | FaktMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | faktnr | Jeeves_InvNo | 9 |  | bigint
Invoice reference no. | FaktNr_ocr | ztString | 40 |  | varchar
Invoice total incl tax | FaktTotMMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice total excl tax | FaktTotUMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice type | FakturaTyp | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Transaction type | Foringskod | ztInteger | 3 |  | smallint
Adv amt received date | ForskottMottagetDatum | ztDate |  |  | datetime
Adv paid on delivery | ForskottSlutBetVidLev | ztBoolean |  |  | char
From template | FromAutoPostTempl | ztBoolean |  |  | char
Company ID | Ftgnr | ztCompanyNo | 20 |  | varchar
Supplier invoice no. | FvrBestRkgNr | ztString | 25 |  | varchar
Invoice no. | FvrFaktNr | Jeeves_InvNo | 9 |  | bigint
Guarantee account | G_BankAccount | ztString | 40 |  | varchar
Guarantee payment | G_PayM | ztBoolean |  |  | char
Guarantee % | G_Percentage | ZtDecimal73 | 5 | 2 | decimal
Posting date | HbUpDat | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Deducted amount BCU | InbAvdrag | ZtBaseCurrAmount | 14 | 2 | money
Paid amount | InbBel | ZtBaseCurrAmount | 14 | 2 | money
Payment date | InbDat | ztDate |  |  | datetime
Early settlmt discnt BCU | InbKassaRab | ZtBaseCurrAmount | 14 | 2 | money
Payment method | inbslag | ztString | 3 |  | varchar
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Early settlmt discnt % | Kassarab | ztFloat | 6 | 2 | float
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Early settlmt discnt date | KrFaktKRabDat | ztDate |  |  | datetime
Account | KtoNr | ztString | 8 |  | varchar
Account type | ktotyp | ztInteger | 3 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Customer reference | KundRef2 | ztString | 30 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Actual pmt date | LevFaktBetDat | ztDate |  |  | datetime
Invoice date | Levfaktdat | ztDate |  |  | datetime
Invoice Type | LevFaktTyp | ztInteger | 3 |  | smallint
Supplier category | LevKategori | ztInteger | 2 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Supplier reference | LevRef2 | ztString | 50 |  | varchar
Arrival date | LrFaktAnkDat | ztDate |  |  | datetime
Due date | LrFaktFfDat | ztDate |  |  | datetime
Early settlmt discnt dt | LrfaktKrabdat | ztDate |  |  | datetime
Cancel | Makulerad | ztBoolean |  |  | char
Tax amount 0 | MomsBelopp0 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 1 | MomsBelopp1 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 2 | MomsBelopp2 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 3 | MomsBelopp3 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 4 | MomsBelopp4 | ZtBaseCurrAmount | 14 | 2 | money
Tax base amount | MomsGrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 0 | MomsGrundBelopp0 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 1 | MomsGrundBelopp1 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 2 | MomsGrundBelopp2 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 3 | MomsGrundBelopp3 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 4 | MomsGrundBelopp4 | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Contra account | MotKtoNr | ztString | 8 |  | varchar
Urspr valutakurs | OldValKurs | ZtCurrencyRate | 15 | 7 | decimal
Preliminary voucher | oldvernr | Jeeves_VchrNo | 9 |  | bigint
Original row no | OrgRowNo | ztInteger | 5 |  | smallint
Orig row no journal rows | OrigFvrRowNo | ztInteger | 5 |  | smallint
@zPrompt=null | origin | ztInteger | 5 |  | smallint
Payment rate | PaymentCurrRate | ZtCurrencyRate | 15 | 7 | decimal
Payment suggestion | PaySugg | ztBoolean |  |  | char
Period | Period | ztInteger | 4 |  | smallint
Regarding | Personalinfo | ztBlob | 1 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Priority | Prioritet | ztInteger | 2 |  | smallint
Project ID | projcode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Payment methods | UtbSlag | ztString | 3 |  | varchar
Payment blocked | UtbSparr | ztBoolean |  |  | char
Amt recd in 3rd currency | V3_InbBel | ztMoney | 14 | 2 | money
Third currency | V3_ValKOd | ztString | 3 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
Affect Tax calculation | VATCalcCheck | ztBoolean |  |  | char
Invoice amount, curr | Vb_FaktSum | ztMoney | 14 | 2 | money
Surplus amount | Vb_SurplusAmount | ztMoney | 14 | 2 | money
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money
Paid on invc, curr | VbFaktBet | ztMoney | 14 | 2 | money
Amount paid, curr | VbFaktInbBel | ztMoney | 14 | 2 | money
VAT/tax, curr | VbFaktMoms | ztMoney | 14 | 2 | money
Invoice amount, curr | VbFaktValue | ztMoney | 14 | 2 | money
Deducted amount, curr | vbInbAvdrag | ztMoney | 11 | 2 | money
Early settlmt discnt, curr | VbKassaRab | ztMoney | 14 | 2 | money
Cash amount, curr | vbKontantBelopp | ztMoney | 14 | 2 | money
Pmt suggestion amt | VbPaymentSugg | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Voucher reference number | VoucherRefNo | ztInteger | 5 |  | smallint
Row no. ver | VoucherRowNo | ztInteger | 5 |  | smallint
Row status | vrstatus | ztInteger | 4 |  | smallint
Statuskod på rad | vrstmark | ztInteger | 2 |  | smallint


Journal status (JrnlStatus)

Journal status for bill of exchange and check journals.

The following standard records exist. Do not alter/delete:

Journal status (JrnlStatus) | Journal status descr (JrnlStatusDesc)
0 | 0. Preliminary
3 | 3. Ready
5 | 5. Closed

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Journal status | JrnlStatus | ztInteger | 2 |  | smallint
Journal status descr | JrnlStatusDesc | ztString | 80 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JrnlStatus Journal status


Journal texts (fvte)

You enter standard voucher texts which can be retrieved to the journal rows here.

No standard records exist in this table. Fill in the table as required.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Row text | BilagsRadText | ztString | 60 |  | varchar
TextID | BilagsTextNr | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: fvte Journal texts


Journal types (fba)

Definition of the journal types that can occur for journal entry according to own definition. The journal types can be seen as a kind of voucher template.

Via the transaction type, integration source and invoice type, the journal type determines which records will be created in the ledgers for the transfer to the general ledger and how the posting will be done.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Arrival report | AnkomstReg | ztInteger | 5 |  | smallint
Approved by | AttestSign | ztString | 6 |  | varchar
Aut bilagsnr | AutBilagsNr | ztBoolean |  |  | char
Posting template | autoregel | ztString | 4 |  | varchar
Posting template, advance | AutoRegelForskott | ztString | 4 |  | varchar
Arrival reg | BilagsAnkReg | ztBoolean |  |  | char
Journal type | Bilagsart | ZtLong | 8 |  | int
Journal type | BilagsartB | ztString | 35 |  | varchar
Active | BilagsArtStatus | ztBoolean |  |  | char
As of | BilagsFromDat | ztDate |  |  | datetime
Up to | BilagsToDat | ztDate |  |  | datetime
Cash/Bank ID | CashOrBankBookid | ztString | 15 |  | varchar
Disable auto create | DisableCreatefvr | ztBoolean |  |  | char
Invoice type | FakturaTyp | ztInteger | 3 |  | smallint
Check in/out curr | FCUCheckIO | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Transaction type | Foringskod | ztInteger | 3 |  | smallint
Entry layer | Forlayer | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
Högsta bilagsnr | MaxBilNr | ZtLong | 9 |  | int
Lägsta bilagsnr | MinBilnr | ZtLong | 9 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Payment methods | UtbSlag | ztString | 3 |  | varchar
Layer | valLayer | ztInteger | 2 |  | smallint
Other currencies | ValReg | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: Fba Journal types


Journal types/authorized personnel (fbau)

Authorized accounting users per journal type in journal entry program.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Journal type | BilagsArt | ZtLong | 8 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: fbau Jrnl types/PersSign auth. journal entry


Journal, fixed assets transactions (jint)

Table containing journal data of manual posting of fixed asset transactions.
A voucher is created for each journal.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Text | edit | ztBlob | 1 |  | varchar
Transaction date | EventDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Fixed asset journal | InvJournNr | ZtLong | 6 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: jint Fixed assets transactions journal


Journal, labour transactions (jaor)

Data in the journal header of labour reports for manufacturing orders.
A journal only includes data of labour for one day, which is why one journal a day is normally created (several journals a day can however be created).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Mfg journal no. | AorJournNr | ZtLong | 6 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: xJaor Labour journal


Journal, MO, cost posting (jtkk)

Journal, MO, cost posting.
This journal is used to cost post work carried out and material issue in manufacturing against a customer order.
*** Under development/inquiry *** TC ***

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Cost post start date | TillvKostKontFromDatum | ztDate |  |  | datetime
Cost posting journal | TillvKostKontJournal | ZtLong | 10 |  | int
Cost post end date | TillvKostKontTomDatum | ztDate |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: jtkk Cost posting from manufacturing order


Journal, MO, cost posting, details (tkkd)

Journal, MO, cost posting.
This journal is used to cost post work carried out and material issue in manufacturing against a customer order.
*** Under development/inquiry *** TC ***

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Product acct, labour | ArbProdKonto | ztString | 8 |  | varchar
Integration detail | ArbTransTyp | ztInteger | 3 |  | smallint
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | k6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Item no. required | MrArtNr | ztString | 30 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Cost posting journal | TillvKostKontJournal | ZtLong | 10 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
Tools | Verktyg | ztString | 16 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint


Journal, percentage of completion accounting (Psvj)

Journal data for percentage of completion accounting on projects.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | Vernr | Jeeves_VchrNo | 9 |  | bigint
Journal no. | VinstAvrakningJournal | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: psvj Journal, percentage of completion accounting


Journal, prod.del.transactions (jtii)

Journal with data on integration with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Manufacturing journal | TiiJournNr | ZtLong | 6 |  | int
Delivery received date | TiInlevDat | ztDate |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: Jtii Receiving journal, mfg


Journal, tax depreciation (insk)

Journal information on tax depreciation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Year opening balance | AretsIngBalans | ZtBaseCurrAmount | 14 | 2 | money
Reversal voucher no. | aterbokasvernr | Jeeves_VchrNo | 9 |  | bigint
Deprn journal status | avskjstatus | ztInteger | 2 |  | smallint
Depreciation journal | Avskrjournal | ZtLong | 5 |  | int
Depreciation method | avskrmet | ztInteger | 2 |  | smallint
Tot recorded deprn YTD | AvSkrTotAr | ZtBaseCurrAmount | 14 | 2 | money
Accounting date | Bokfdat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Year's acquisitions | InskAr | ZtBaseCurrAmount | 14 | 2 | money
Acq value tax year | InskAr1 | ZtBaseCurrAmount | 14 | 2 | money
80% thereof = | InskAr1Ber | ZtBaseCurrAmount | 14 | 2 | money
Acq value prev year | InskAr2 | ZtBaseCurrAmount | 14 | 2 | money
60% thereof = | InskAr2Ber | ZtBaseCurrAmount | 14 | 2 | money
Acq value prev year 2 | InskAr3 | ZtBaseCurrAmount | 14 | 2 | money
40% thereof = | InskAr3Ber | ZtBaseCurrAmount | 14 | 2 | money
Acq value prev year 3 | InskAr4 | ZtBaseCurrAmount | 14 | 2 | money
20% thereof = | InskAr4Ber | ZtBaseCurrAmount | 14 | 2 | money
70% of outst amount | InskArBer | ZtBaseCurrAmount | 14 | 2 | money
New tax deprn | Insknyh | ZtBaseCurrAmount | 14 | 2 | money
New tax deprn | InsknyK | ZtBaseCurrAmount | 14 | 2 | money
70% of outst amount | InskSaH | ZtBaseCurrAmount | 14 | 2 | money
Remuneration received | InskSald | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Max allowed deprn | MaxAvsH | ZtBaseCurrAmount | 14 | 2 | money
Max allowed deprn | MaxAvsK | ZtBaseCurrAmount | 14 | 2 | money
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Depreciation curr yr | PlanAvskrBeloppIAR | ZtBaseCurrAmount | 14 | 2 | money
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax depreciation amount | TaxDeprAmount | ZtBaseCurrAmount | 14 | 2 | money
Tax depreciation amount | TaxDeprAmountK | ZtBaseCurrAmount | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: insk Tax depreciation journal


Jrnl group view (vfrf)

View of GL transactions.
Adaptation for France

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | nvarchar
Approved by | AttestSign | ztString | 6 |  | varchar
Bank | BankId | ztString | 10 |  | nvarchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | nvarchar
Bill of exchange no. | BoE_No | ZtLong | 9 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
PO/receiving journal no. | BpiJournNr | ZtLong | 10 |  | int
Check number | checkno | ZtLong | 9 |  | int
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
District | DistrKod | ztString | 4 |  | varchar
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Journal group | JourGrupp | ZtLong | 9 |  | int
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | int
Supplier category | LevKategori | ztInteger | 2 |  | int
VAT/tax code | MomsKod | ztInteger | 5 |  | int
Period | Period | ztInteger | 4 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Salesperson | Saljare | ztString | 6 |  | nvarchar
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int
Item group | VaruGruppKod | ztString | 8 |  | nvarchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: vfrf GL transactions


JvsLogMessage (JvsLogMessage)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Message | JvsMessage | ztString | 255 |  | varchar
Message no | JvsMessageNo | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Identity | SqlIdentity | ZtLong | 10 |  | int


Kernel parameters (jini)

System parameters that govern how Jeeves should function in general. This includes parameters about the how the database is set up, how information should be displayed, how the client should behave etc.

These can be set for a certain signature, a certain group or globally.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Configuration name | ConfigName | ztString | 50 |  | varchar
Group | grupp | ztInteger | 4 |  | smallint
Parameter data | ParamData | ztString | 255 |  | varchar
Ini parameter | ParamEntry | ztString | 50 |  | varchar
Parameter section | ParamSection | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: jini Kernel parameters


Key performance indicators (fm)

Table for setting up different key performance indicators (KPI).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
KPI | Nyckeltalbeskr | ztString | 50 |  | varchar
KPI id | NyckeltalId | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xfm Key performance indicators


Keywords (xp1)

Definition of keywords with which you can create profiles for company, contacts and serial no. items in addition to the geographical market segments, specifications and characteristics that are available.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Keywords | ProspegBeskr | ztString | 30 |  | varchar
Keyword | ProspegID | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xp1 Keywords


Keywords, company/contact (kpn)

Linking of external contacts (as defined in the program Key word (xp1)) to create profiles for the contacts in addition to the posts and personal characteristics available.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Keyword | ProspegID | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: kpn Keywords/company & person


Keywords, serial no. items (arin)

Table of keywords for individual records. The keyword is retrieved from the "Keyword" table/program (xp1), where keywords for companies, contacts and individuals are defined.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Keyword | ProSpegId | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: arin Keywords, serial no. items


Keywords, service report (shpn)

Keywords.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Keywords | keyword | ztString | 40 |  | varchar
Signature | perssign | ztString | 30 |  | varchar
Entry date | regdat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Date/time | strdatetime | ztString | 28 |  | varchar


Keywords/company (frn)

Linking of companies to keywords (as defined in the program Key word (xp1)) for creating profiles of companies in the company table in addition to the geographical market segment and characteristics available.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Keyword | ProspegID | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: frn Keywords/company


Label action (WMS_LabelAction)

Alpha numeric ID for label type.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
COM, serial port | ComPort | ztString | 5 |  | varchar
COM, start characters | ComStartCharacters | ztString | 255 |  | varchar
Email, address | EmailAddress | ztString | 255 |  | varchar
Email, subject template | EmailSubjectTemplate | ztString | 255 |  | varchar
File, destination folder | FileDestinationFolder | ztString | 255 |  | varchar
File, name template | FileNameTemplate | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Label type | LabelType | ztString | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Printer type | PrinterType | ztString | 20 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
TCP/IP, address | TCPIPAddress | ztString | 100 |  | varchar
TCP/IP, port | TCPIPPort | ztInteger | 5 |  | smallint
TCP/IP, start characters | TCPIPStartCharacters | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_LabelAction Label action


Label event (WMS_LabelEvent)

Code for event type.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Active | ztBoolean |  |  | char
Event type | EventTypeCode | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Label type | LabelType | ztString | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence | Sequence | ztInteger | 3 |  | smallint

    This table is the main table in the following programs:

    Program: WMS_LabelEvent Label event


Label type (WMS_LabelType)

Definition of WMS label types. Example of basic label types that could typically be setup are described below. The names of the label types are not important. What is important is the type of information the label type represents.

Label types that are normally printed automatically, and the information they present:
- SKULABEL - Information about the SKU
- TUPICKLABEL - Information about the TU
- TUCONTENTLABEL - Information about the TU and all the content within a TU

Other kinds of label types that could be setup:
- MHALABEL - Information about the MHA
- RACKLABEL - Information about the Rack
- LOCATIONLABEL - Information about the Position

All label types that are created are associated with an object type and this makes it possible to present only applicable label types in manual print request dialogues.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Label type | LabelType | ztString | 20 |  | varchar
Description | LabelTypeDesc | ztString | 50 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Object type | ObjectTypeCode | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_LabelType Label type


Labour operation, its tools (aov)

Table indicating the tools used by operation for work orders that are created.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Number of tools | AntalVerktygVidTillv | ZtDecimal73 | 8 | 3 | float
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Deliv to supplier | LevMedBestTillLev | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
BOM for item | StyckListaTillArtNr | ztString | 30 |  | varchar
ID for connection | Ti_LopNr_Ned | ZtLong | 10 |  | int
OK to use tool | ToolOkToUse | ztBoolean |  |  | char
Original tool | UrsprVerktyg | ztString | 16 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Tools | Verktyg | ztString | 16 |  | varchar
List of tools | VerktygsLista | ztString | 35 |  | varchar
Sequence in list of tools | VerktygslistaSekvNr | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: aov Tools for manufacturing order

    Program: aov_all Tools for manufacturing order


Labour operations (ao)

Current manufacturing operations, i.e. data about work to be done or that has recently been reported.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Plan mfg qty/op | AoAntal | ZtQty | 14 | 2 | decimal
Interruption code | AoAvbrottsKod | ztInteger | 5 |  | smallint
Aut. reported | AoDummyRapp | ztBoolean |  |  | char
MO type | AoKod | ztInteger | 2 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Remaining qty | AoRestAnt | ZtQty | 14 | 2 | decimal
Operations end date | AoSlutDat | ztDate |  |  | datetime
Slutdat/tid (JPS) | AoSlutDatTid | ztDateTime |  |  | datetime
End date when creating OP | AoSlutDatTidOrig | ztDateTime |  |  | datetime
Operations start date | AoStartDat | ztDate |  |  | datetime
Startdatum/tid (JPS) | AoStartDatTid | ztDateTime |  |  | datetime
Start date when creating OP | AoStartDatTidOrig | ztDateTime |  |  | datetime
Date+time when OP was upd | AoUpdMedDatum | ztDateTime |  |  | datetime
Show operation | AoVisas | ztBoolean |  |  | char
Work group | ArbetsLag | ztString | 6 |  | varchar
CalcCost labour/op | ArbKalkArbKost | ZtBaseCurrAmount | 14 | 2 | money
Calc setup cost | ArbKalkStallKost | ZtBaseCurrAmount | 14 | 2 | money
Labour overhead | ArbOmk | ZtCost | 16 | 6 | float
Fixed labour OH | ArbOmkFast | ZtCost | 16 | 6 | float
Tot labour OH/op | ArbOmkOp | ZtCost | 16 | 6 | float
Variable labour OH | ArbOmkRorl | ZtCost | 16 | 6 | float
Setup labour OH/unit | ArbOmkStall | ZtCost | 16 | 6 | float
Setup overhead, labour | ArbStallBiKost | ZtCost | 16 | 6 | float
Setup cost labour | ArbStallKost | ZtCost | 16 | 6 | float
Labour overhead/unit | ArbStyckBiKost | ZtCost | 16 | 6 | float
Labour cost/unit | ArbStyckKost | ZtCost | 16 | 6 | float
Actual labour cost | ArbVerklArbKost | ZtBaseCurrAmount | 14 | 2 | money
Actual setup cost | ArbVerklStallKost | ZtBaseCurrAmount | 14 | 2 | money
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
BOM level | ArtNivaBeskr | ztString | 20 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Auto receiving type | AutInlevTyp | ztInteger | 5 |  | smallint
Autom mtrl.uttag | AutMtrlUttag | ztBoolean |  |  | char
Auto mtrl issue type | AutMtrlUttagTyp | ztInteger | 5 |  | smallint
Workload factor | BelaggningsFaktor | ztFloat | 15 | 2 | float
Ordered | Bestallas | ztBoolean |  |  | char
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Bottleneck priority | BNeckPrio | ztInteger | 5 |  | smallint
BOM sequence number | BOMItemSeqNo | ZtLong | 10 |  | int
Availability check date | BristKontrolleradDatum | ztDate |  |  | datetime
Avail check status code | BristKontrolleradStatus | ztInteger | 5 |  | smallint
Calculated cost | CalcLaborCostDone | ztBoolean |  |  | char
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Workload alloc date | DatumBelaggning | ztDate |  |  | datetime
Partial booking allowed | DelBokningTillaten | ztInteger | 5 |  | smallint
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
Overhead, work, admin | EstLabOvhdAdmCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, production | EstLabOvhdPrdCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, sales | EstLabOvhdSalesCost | ZtBaseCurrAmount | 14 | 2 | money
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Start date | EventStartDat | ztDate |  |  | datetime
Start time | EventStartTime | ztTime | 5 |  | datetime
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Extra overhead cost | ExtraOmk | ZtCost | 16 | 6 | float
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
Appr 1st part | FirstPartCheckPersSign | ztString | 30 |  | varchar
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Throughput time | GenomLoppsTid | ztFloat | 8 | 2 | float
Throughput time adj | GenomLoppsTidJust | ztFloat | 8 | 2 | float
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Kalendermånad | KalenderManad | ztInteger | 2 |  | smallint
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Week number | KalenderVecka | ztInteger | 2 |  | smallint
Op join list No. | Kaplista | ZtLong | 10 |  | int
Scrap degree/op | KassOp | ztFloat | 5 | 2 | float
Inspection instruction | KontrollInstruktion | ztBlob | 1 |  | varchar
Buy manuf of item | KopTillvAvArtikel | ztBoolean |  |  | char
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
Job card | KortNrAo | ZtLong | 10 |  | int
Queue time | KoTid | ztFloat | 15 | 2 | float
Labor operation picking list ID | LbrOpJoinPckList | ZtLong | 10 |  | int
Lead time material | LeadTimeMtrlOnOp | ztInteger | 5 |  | smallint
Subcontract overhead cost | LegoBiKost | ZtCost | 16 | 6 | float
Subcontract cost | LegoKost | ZtCost | 16 | 6 | float
Subcontract price/unit | LegoPris | ZtBaseCurrAmount | 14 | 2 | money
Subcontract setup price | LegoPrisStall | ZtBaseCurrAmount | 14 | 2 | money
Subcontract start price | LegoPrisStart | ZtBaseCurrAmount | 14 | 2 | money
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
New prel finish date | LONewPrelComplDt | ztDate |  |  | datetime
Diff new prel end date | LONewPrelComplDtDiff | ztInteger | 5 |  | smallint
Prel material requirement date | LONewPrelMtrlResrvDt | ztDate |  |  | datetime
New prel start dat | LONewPrelStartDt | ztDate |  |  | datetime
Sequence no. | LopNr | ZtLong | 10 |  | int
Subcontract flag | MarkLego | ztBoolean |  |  | char
Subcontract quantity | MOSubcontractQty | ZtQty | 14 | 2 | decimal
Subcontract received quantity | MOSubcontractRecQty | ZtQty | 14 | 2 | decimal
Next operation | NextOpNr | ztInteger | 5 |  | int
Personnel/operation | OpBemanning | ztFloat | 6 | 3 | float
Personnel/operation, setup | OpBemanningStall | ztFloat | 6 | 3 | float
Personnel/operation, ext setup | OpBemanningYttreStall | ztFloat | 6 | 3 | float
Operation | OpBen | ztString | 30 |  | varchar
Operation | OpBeskr | ztBlob | 1 |  | varchar
End of parallel workload | OpEndParallelWorkload | ztInteger | 5 |  | smallint
Operation text ID | OperationsTextNr | ztInteger | 4 |  | smallint
Priority code | OpKoPrioritet | ztInteger | 5 |  | smallint
Fixed quantity operation | OpMarkFastAntal | ztBoolean |  |  | char
Material requirement date | OpMtrlResrvDt | ztDate |  |  | datetime
Material status | OpMtrlStatus | ztInteger | 5 |  | smallint
Operation no. | OpNr | ztInteger | 3 |  | int
Operation sort | OpSorteringsNr | ZtLong | 4 |  | int
Operation split | OpSplitt | ztFloat | 15 | 2 | float
Operationssplitt från op | OpSplittFranOpNr | ztInteger | 5 |  | int
Operationssplitt till op | OpSplittTillOpNr | ztInteger | 5 |  | int
Start parallel workload | OpStartParallelWorkload | ztBoolean |  |  | char
OpStartsMinutesAfterMO | OpStartsMinutesAfterMO | ztInteger | 5 |  | smallint
Operation status | OpStatus | ztInteger | 3 |  | smallint
Status föregående op | OpStatusPrevOpNr | ztInteger | 3 |  | smallint
Booking status | OrdBokningsStatus | ztInteger | 5 |  | smallint
Orig operation no. | OrigOpNo | ztInteger | 3 |  | smallint
Overlapping after quantity | OverLappEfterAntal | ZtQty | 14 | 2 | decimal
Overlapping after time | OverLappEfterTid | ztOpTime | 9 | 4 | float
Print date | p_utskr_dat | ztDate |  |  | datetime
Pay-Roll Type | PayRollType | ztString | 8 |  | varchar
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Mfg grp deprec. | PgAvskrKost | ZtCost | 16 | 6 | float
Mfg grp fixed cost | PgFastKost | ZtCost | 16 | 6 | float
Mfg grp var cost | PgRorlKost | ZtCost | 16 | 6 | float
Mfg grp setup cost | PgStallKost | ZtCost | 16 | 6 | float
Planned quantity | PlaneratAntal | ZtQty | 14 | 2 | decimal
Picking list date | PLUtskrDat | ztDateTime |  |  | datetime
Previous operation | PrevOpNr | ztInteger | 5 |  | int
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Produktionsgrupp | ProdGrUrspr | ztString | 5 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Row | RadPos2 | ztInteger | 4 |  | int
Rep manhours setup | RappMantidStall | ztOpTime | 9 | 4 | float
Rep manhours manufacturing | RappMantidTillverkning | ztOpTime | 9 | 4 | float
Entry date | RegDat | ztDate |  |  | datetime
Entry time | RegTime | ztTime | 5 |  | datetime
Spare part order | ReservdelsOrder | ztBoolean |  |  | char
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Reportingtype SFR | SFRReptype | ztInteger | 5 |  | smallint
End stamp time | SFRWORepEndDt | ztDateTime |  |  | datetime
Start Stamptime | SFRWORepStartDt | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Requisition | StrDateTimeBIA | ztString | 28 |  | varchar
BOM for item | StycklistaTillArtNr | ztString | 30 |  | varchar
Unit time | StyckTid | ztOpTime | 9 | 4 | float
time per unit | StyckTidA | ztFloat | 8 | 4 | float
Unit time B | StyckTidB | ztFloat | 8 | 4 | float
Unit time C | StyckTidC | ztFloat | 8 | 4 | float
Technical OH cost | TeknikOmk | ZtCost | 16 | 6 | float
Work order printed | ThUtskrDat | ztDateTime |  |  | datetime
ID for connection | Ti_LopNr_Ned | ZtLong | 10 |  | int
In-house or subcontract | TillvPriorEgenLego | ztInteger | 5 |  | smallint
TimeGapInDaysAfterPrevOp | TimeGapInDaysAfterPrevOp | ztInteger | 5 |  | smallint
TimeGapInDaysTonextOp | TimeGapInDaysToNextOp | ztInteger | 5 |  | smallint
Start date before adjustment | TiMinStartDatOrig | ztDateTime |  |  | datetime
OK to use tool | ToolOkToUse | ztBoolean |  |  | char
Start cost/MO | ToStartKost | ZtCost | 16 | 6 | float
Update all op | UpdatAvvik | ztBoolean |  |  | char
Incl scrapped mtrl | UpDatAvvikMru | ztBoolean |  |  | char
Update workload ... | UpdateWorkLoadTable | ztBoolean |  |  | char
@zPrompt=null | UpdFlag | ztInteger | 5 |  | smallint
Flagga om trigger ..... | UpdWLFromTrg | ztBoolean |  |  | char
Development cost | UtvKost | ZtCost | 16 | 6 | float
Development OH cost | UtvOmk | ZtCost | 16 | 6 | float
Item group | VaruGruppKod | ztString | 8 |  | varchar
Shop price | VerkstadPris | ZtBaseCurrAmount | 14 | 2 | money
Tools | Verktyg | ztString | 16 |  | varchar
List of tools | VerktygsLista | ztString | 35 |  | varchar
Tool deprec | VyAvskrKost | ZtCost | 16 | 6 | float
Fixed tool cost | VyFastKost | ZtCost | 16 | 6 | float
Var tool cost | VyRorlKost | ZtCost | 16 | 6 | float
Tool setup cost | VySTallKost | ZtCost | 16 | 6 | float
Tool unit cost | VyStyckKost | ZtCost | 16 | 6 | float
WL_Log_Accum_Time | WL_Log_Accum_Time | ZtHugeInt | 20 |  | bigint
External setup time for op | YttreStallTid | ztOpTime | 9 | 4 | float

    This table is the main table in the following programs:

    Program: Ao Labour operations, incl history

    Program: AoBeLego Order subcontract

    Program: AoEjKlar Labour operations - not closed

    Program: AoqQdin Q - data (labor operation)

    Program: AoToDo Mfg operation queue

    Program: MOLO_PIK MOLO_PIK

    Program: MOMtrl_PIK_LO Material issues, booking, labor operation

    Program: xAo Labour operations


Labour operations (sum and sort) (wwao)

Sorted and totaled labour per production group during printing of manufacturing order documents.
This work table is only used in a report during order document printing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Plan mfg qty/op | AoAntal | ZtQty | 14 | 2 | decimal
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Operations end date | AoSlutDat | ztDate |  |  | datetime
Operations start date | AoStartDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Operation no. | OpNr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Calc remaining processing time | wwaoEstRemainRunTime | ztOpTime | 9 | 4 | float
Calc remaining setup time | wwaoEstRemainSetupTime | ztOpTime | 9 | 4 | float


Labour operations (view) (vao)

Database view of labour operations.
This is a double definition of the table for labour operations (AO).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Plan mfg qty/op | AoAntal | ZtQty | 14 | 2 | decimal
Aut. reported | AoDummyRapp | ztBoolean |  |  | char
MO type | AoKod | ztInteger | 2 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Remaining qty | AoRestAnt | ZtQty | 14 | 2 | decimal
Operations end date | AoSlutDat | ztDate |  |  | datetime
Slutdat/tid (JPS) | AoSlutDatTid | ztDateTime |  |  | datetime
Operations start date | AoStartDat | ztDate |  |  | datetime
Startdatum/tid (JPS) | AoStartDatTid | ztDateTime |  |  | datetime
Show operation | AoVisas | ztBoolean |  |  | char
CalcCost labour/op | ArbKalkArbKost | ZtBaseCurrAmount | 14 | 2 | money
Calc setup cost | ArbKalkStallKost | ZtBaseCurrAmount | 14 | 2 | money
Fixed labour OH | ArbOmkFast | ZtCost | 16 | 6 | float
Tot labour OH/op | ArbOmkOp | ZtCost | 16 | 6 | float
Variable labour OH | ArbOmkRorl | ZtCost | 16 | 6 | float
Setup labour OH/unit | ArbOmkStall | ZtCost | 16 | 6 | float
Setup overhead, labour | ArbStallBiKost | ZtCost | 16 | 6 | float
Setup cost labour | ArbStallKost | ZtCost | 16 | 6 | float
Labour overhead/unit | ArbStyckBiKost | ZtCost | 16 | 6 | float
Labour cost/unit | ArbStyckKost | ZtCost | 16 | 6 | float
Actual labour cost | ArbVerklArbKost | ZtBaseCurrAmount | 14 | 2 | money
Actual setup cost | ArbVerklStallKost | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Autom mtrl.uttag | AutMtrlUttag | ztBoolean |  |  | char
Auto mtrl issue type | AutMtrlUttagTyp | ztInteger | 5 |  | smallint
Workload factor | BelaggningsFaktor | ztFloat | 15 | 2 | float
Ordered | Bestallas | ztBoolean |  |  | char
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Text | Edit | ztBlob | 1 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Start date | EventStartDat | ztDate |  |  | datetime
Start time | EventStartTime | ztTime | 5 |  | datetime
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Throughput time | GenomLoppsTid | ztFloat | 8 | 2 | float
Throughput time adj | GenomLoppsTidJust | ztFloat | 8 | 2 | float
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Scrap degree/op | KassOp | ztFloat | 5 | 2 | float
Queue time | KoTid | ztFloat | 15 | 2 | float
Subcontract overhead cost | LegoBiKost | ZtCost | 16 | 6 | float
Subcontract cost | LegoKost | ZtCost | 16 | 6 | float
Subcontract price/unit | LegoPris | ZtBaseCurrAmount | 14 | 2 | money
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Subcontract flag | MarkLego | ztBoolean |  |  | char
Next operation | NextOpNr | ztInteger | 5 |  | int
Personnel/operation | OpBemanning | ztFloat | 6 | 3 | float
Personnel/operation, setup | OpBemanningStall | ztFloat | 6 | 3 | float
Operation | OpBen | ztString | 30 |  | varchar
Operation | OpBeskr | ztBlob | 1 |  | varchar
Material status | OpMtrlStatus | ztInteger | 5 |  | smallint
Operation no. | OpNr | ztInteger | 3 |  | int
Operation sort | OpSorteringsNr | ZtLong | 4 |  | int
Operation split | OpSplitt | ztFloat | 15 | 2 | float
Operation status | OpStatus | ztInteger | 3 |  | smallint
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Mfg grp deprec. | PgAvskrKost | ZtCost | 16 | 6 | float
Mfg grp fixed cost | PgFastKost | ZtCost | 16 | 6 | float
Mfg grp var cost | PgRorlKost | ZtCost | 16 | 6 | float
Mfg grp setup cost | PgStallKost | ZtCost | 16 | 6 | float
Planned quantity | PlaneratAntal | ZtQty | 14 | 2 | decimal
Previous operation | PrevOpNr | ztInteger | 5 |  | int
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Entry time | RegTime | ztTime | 5 |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float
time per unit | StyckTidA | ztFloat | 8 | 4 | float
Unit time B | StyckTidB | ztFloat | 8 | 4 | float
Unit time C | StyckTidC | ztFloat | 8 | 4 | float
Item group | VaruGruppKod | ztString | 8 |  | varchar
Shop price | VerkstadPris | ZtBaseCurrAmount | 14 | 2 | money
Tools | Verktyg | ztString | 16 |  | varchar
Tool deprec | VyAvskrKost | ZtCost | 16 | 6 | float
Fixed tool cost | VyFastKost | ZtCost | 16 | 6 | float
Var tool cost | VyRorlKost | ZtCost | 16 | 6 | float
Tool setup cost | VySTallKost | ZtCost | 16 | 6 | float
Tool unit cost | VyStyckKost | ZtCost | 16 | 6 | float


Labour operations (view) (vao2)

Database view of labour operations.
This is a double definition of the table for labour operations (AO).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Plan mfg qty/op | AoAntal | ZtQty | 14 | 2 | decimal
Aut. reported | AoDummyRapp | ztBoolean |  |  | char
MO type | AoKod | ztInteger | 2 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Remaining qty | AoRestAnt | ZtQty | 14 | 2 | decimal
Operations end date | AoSlutDat | ztDate |  |  | datetime
Slutdat/tid (JPS) | AoSlutDatTid | ztDateTime |  |  | datetime
Operations start date | AoStartDat | ztDate |  |  | datetime
Startdatum/tid (JPS) | AoStartDatTid | ztDateTime |  |  | datetime
Show operation | AoVisas | ztBoolean |  |  | char
CalcCost labour/op | ArbKalkArbKost | ZtBaseCurrAmount | 14 | 2 | money
Calc setup cost | ArbKalkStallKost | ZtBaseCurrAmount | 14 | 2 | money
Fixed labour OH | ArbOmkFast | ZtCost | 16 | 6 | float
Tot labour OH/op | ArbOmkOp | ZtCost | 16 | 6 | float
Variable labour OH | ArbOmkRorl | ZtCost | 16 | 6 | float
Setup labour OH/unit | ArbOmkStall | ZtCost | 16 | 6 | float
Setup overhead, labour | ArbStallBiKost | ZtCost | 16 | 6 | float
Setup cost labour | ArbStallKost | ZtCost | 16 | 6 | float
Labour overhead/unit | ArbStyckBiKost | ZtCost | 16 | 6 | float
Labour cost/unit | ArbStyckKost | ZtCost | 16 | 6 | float
Actual labour cost | ArbVerklArbKost | ZtBaseCurrAmount | 14 | 2 | money
Actual setup cost | ArbVerklStallKost | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Autom mtrl.uttag | AutMtrlUttag | ztBoolean |  |  | char
Auto mtrl issue type | AutMtrlUttagTyp | ztInteger | 5 |  | smallint
Workload factor | BelaggningsFaktor | ztFloat | 15 | 2 | float
Ordered | Bestallas | ztBoolean |  |  | char
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Text | Edit | ztBlob | 1 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Start date | EventStartDat | ztDate |  |  | datetime
Start time | EventStartTime | ztTime | 5 |  | datetime
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Throughput time | GenomLoppsTid | ztFloat | 8 | 2 | float
Throughput time adj | GenomLoppsTidJust | ztFloat | 8 | 2 | float
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Scrap degree/op | KassOp | ztFloat | 5 | 2 | float
Queue time | KoTid | ztFloat | 15 | 2 | float
Subcontract overhead cost | LegoBiKost | ZtCost | 16 | 6 | float
Subcontract cost | LegoKost | ZtCost | 16 | 6 | float
Subcontract price/unit | LegoPris | ZtBaseCurrAmount | 14 | 2 | money
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Subcontract flag | MarkLego | ztBoolean |  |  | char
Next operation | NextOpNr | ztInteger | 5 |  | int
Personnel/operation | OpBemanning | ztFloat | 6 | 3 | float
Personnel/operation, setup | OpBemanningStall | ztFloat | 6 | 3 | float
Operation | OpBen | ztString | 30 |  | varchar
Operation | OpBeskr | ztBlob | 1 |  | varchar
Material status | OpMtrlStatus | ztInteger | 5 |  | smallint
Operation no. | OpNr | ztInteger | 3 |  | int
Operation sort | OpSorteringsNr | ZtLong | 4 |  | int
Operation split | OpSplitt | ztFloat | 15 | 2 | float
Operation status | OpStatus | ztInteger | 3 |  | smallint
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Mfg grp deprec. | PgAvskrKost | ZtCost | 16 | 6 | float
Mfg grp fixed cost | PgFastKost | ZtCost | 16 | 6 | float
Mfg grp var cost | PgRorlKost | ZtCost | 16 | 6 | float
Mfg grp setup cost | PgStallKost | ZtCost | 16 | 6 | float
Planned quantity | PlaneratAntal | ZtQty | 14 | 2 | decimal
Previous operation | PrevOpNr | ztInteger | 5 |  | int
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Entry time | RegTime | ztTime | 5 |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float
time per unit | StyckTidA | ztFloat | 8 | 4 | float
Unit time B | StyckTidB | ztFloat | 8 | 4 | float
Unit time C | StyckTidC | ztFloat | 8 | 4 | float
Item group | VaruGruppKod | ztString | 8 |  | varchar
Shop price | VerkstadPris | ZtBaseCurrAmount | 14 | 2 | money
Tools | Verktyg | ztString | 16 |  | varchar
Tool deprec | VyAvskrKost | ZtCost | 16 | 6 | float
Fixed tool cost | VyFastKost | ZtCost | 16 | 6 | float
Var tool cost | VyRorlKost | ZtCost | 16 | 6 | float
Tool setup cost | VySTallKost | ZtCost | 16 | 6 | float
Tool unit cost | VyStyckKost | ZtCost | 16 | 6 | float


Labour reporting (aor)

Labour reports on manufacturing orders, i.e. labour performed on labour operations.

Labour reporting is posted as follows:
--------------------------------------------------------------------
CREDIT: A special set of rules linked to the type of labour done (see the description of labour cost codes).

DEBIT: WIP is debited according to the manufactured items product account, inventory transaction type 120 (or 0 if 120 is missing) and detail for integration 5 (WIP-account).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting complete | AccountingDone | ztBoolean |  |  | char
Pre-posting executed | AccountingDone2 | ztBoolean |  |  | char
Number of tools | AntalVerktygVidTillv | ZtDecimal73 | 8 | 3 | float
Use ext calc cost | AnvExtKalkKostnader | ztBoolean |  |  | char
Interruption code | AoAvbrottsKod | ztInteger | 5 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Remaining to report | AoRestInnanRapp | ZtQty | 14 | 2 | decimal
Mfg journal no. | AorJournNr | ZtLong | 6 |  | int
Work group | arbetslag | ztString | 6 |  | varchar
Labour overhead | ArbOmk | ZtCost | 16 | 6 | float
Fixed labour OH | ArbOmkFast | ZtCost | 16 | 6 | float
Tot labour OH/op | ArbOmkOp | ZtCost | 16 | 6 | float
Variable labour OH | ArbOmkRorl | ZtCost | 16 | 6 | float
Setup labour OH/unit | ArbOmkStall | ZtCost | 16 | 6 | float
Setup overhead, labour | ArbStallBiKost | ZtCost | 16 | 6 | float
Setup cost labour | ArbStallKost | ZtCost | 16 | 6 | float
Labour overhead/unit | ArbStyckBiKost | ZtCost | 16 | 6 | float
Labour cost/unit | ArbStyckKost | ZtCost | 16 | 6 | float
Actual labour cost | ArbVerklArbKost | ZtBaseCurrAmount | 14 | 2 | money
Actual setup cost | ArbVerklStallKost | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Estimate manhours from equipment time | BeraknaMantidFranMaskinTid | ztBoolean |  |  | char
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Extra overhead cost | ExtraOmk | ZtCost | 16 | 6 | float
Invoiced | fakturerad | ztBoolean |  |  | char
Appr 1st part | FirstPartCheckPersSign | ztString | 30 |  | varchar
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
To be posted | Konteras | ztBoolean |  |  | char
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
Note | KortNotering | ztString | 255 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
added cost LO (manuf qty) | LabAddedCostManufQty | ZtQty | 14 | 2 | decimal
added cost LO (setup time) | LabAddedCostSetUpTime | ztOpTime | 9 | 4 | float
added cost LO (work time) | LabAddedCostWorkTime | ztOpTime | 9 | 4 | float
Type of labour reporting | LaborReportingType | ztInteger | 5 |  | smallint
Overheads, work, admin | LabOvhdAdmCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, production | LabOvhdPrdCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, sales | LabOvhdSalesCost | ZtBaseCurrAmount | 14 | 2 | money
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Subcontract overhead cost | LegoBiKost | ZtCost | 16 | 6 | float
Subcontract cost | LegoKost | ZtCost | 16 | 6 | float
Subcontract price/unit | LegoPris | ZtBaseCurrAmount | 14 | 2 | money
Subcontract setup price | LegoPrisStall | ZtBaseCurrAmount | 14 | 2 | money
Subcontract start price | LegoPrisStart | ZtBaseCurrAmount | 14 | 2 | money
Maskin | MaskinID | ztString | 16 |  | varchar
Personnel/operation | OpBemanning | ztFloat | 6 | 3 | float
Personnel/operation, setup | OpBemanningStall | ztFloat | 6 | 3 | float
Operation no. | OpNr | ztInteger | 3 |  | int
Pay-Roll Type | PayRollType | ztString | 8 |  | varchar
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Mfg grp deprec. | PgAvskrKost | ZtCost | 16 | 6 | float
Mfg grp fixed cost | PgFastKost | ZtCost | 16 | 6 | float
Mfg grp var cost | PgRorlKost | ZtCost | 16 | 6 | float
Mfg grp setup cost | PgStallKost | ZtCost | 16 | 6 | float
Activity finished | PlanUtford | ztBoolean |  |  | char
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Rep manhours setup | RappMantidStall | ztOpTime | 9 | 4 | float
Rep manhours manufacturing | RappMantidTillverkning | ztOpTime | 9 | 4 | float
Reported finish date | RappSlutDatum | ztDate |  |  | datetime
Reported finish time | RappSlutTid | ztTime | 5 |  | datetime
Start date | RappStartDatum | ztDate |  |  | datetime
Reported start time | RappStartTid | ztTime | 5 |  | datetime
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Origin ID | SFROriginId | ZtLong | 10 |  | int
Origin row | SFROriginrow | ztInteger | 5 |  | smallint
Origin type | SFROrigintp | ztInteger | 5 |  | smallint
Time sqlcmd->trg start | SQLCmd2EnterTrg | ZtLong | 10 |  | int
Date/time | StrDateTime | ztString | 28 |  | varchar
Technical OH cost | TeknikOmk | ZtCost | 16 | 6 | float
Cost posting journal | TillvKostKontJournal | ZtLong | 10 |  | int
Start cost/MO | ToStartKost | ZtCost | 16 | 6 | float
Update all op | UpdatAvvik | ztBoolean |  |  | char
Incl scrapped mtrl | UpDatAvvikMru | ztBoolean |  |  | char
Development cost | UtvKost | ZtCost | 16 | 6 | float
Development OH cost | UtvOmk | ZtCost | 16 | 6 | float
Item group | VaruGruppKod | ztString | 8 |  | varchar
Indirect job/labour | veovrigtjobb | ztInteger | 5 |  | smallint
Shop price | VerkstadPris | ZtBaseCurrAmount | 14 | 2 | money
Tools | Verktyg | ztString | 16 |  | varchar
List of tools | VerktygsLista | ztString | 35 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Transfer date | VtVrUpDat | ztDate |  |  | datetime
Tool deprec | VyAvskrKost | ZtCost | 16 | 6 | float
Fixed tool cost | VyFastKost | ZtCost | 16 | 6 | float
Var tool cost | VyRorlKost | ZtCost | 16 | 6 | float
Tool setup cost | VySTallKost | ZtCost | 16 | 6 | float
Tool unit cost | VyStyckKost | ZtCost | 16 | 6 | float
External setup time for op | YttreStallTid | ztOpTime | 9 | 4 | float

    This table is the main table in the following programs:

    Program: aor1 Labour reporting, operations

    Program: Aor2GL Labour journal->GL

    Program: xAorre Completed labour reporting


Labour reports per order and mfg grp (MoLR)

Labour reports per order and manufacturing group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
Type of labour reporting | MoLRType | ztInteger | 5 |  | smallint
Operation no. | OpNr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: MoLR Labour reporting, order/mfg group


Labour reports, manufacturing group (aorp)

Labour reports of manufacturing orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Report auto setup time | AoRappStallTid_Aut | ztOpTime | 9 | 4 | float
Report man. setup time | AoRappStallTid_Man | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Rep auto run time | AoRappStyckTid_Aut | ztOpTime | 9 | 4 | float
Rep manual run time | AoRappStyckTid_Man | ztOpTime | 9 | 4 | float
Remaining to report | AoRestInnanRapp | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
Subcontract price/unit | LegoPris | ZtBaseCurrAmount | 14 | 2 | money
Personnel/operation | OpBemanning | ztFloat | 6 | 3 | float
Operation no. | OpNr | ztInteger | 3 |  | int
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Activity finished | PlanUtford | ztBoolean |  |  | char
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Reported finish date | RappSlutDatum | ztDate |  |  | datetime
Reported finish time | RappSlutTid | ztTime | 5 |  | datetime
Start date | RappStartDatum | ztDate |  |  | datetime
Reported start time | RappStartTid | ztTime | 5 |  | datetime
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Shop price | VerkstadPris | ZtBaseCurrAmount | 14 | 2 | money
Tools | Verktyg | ztString | 16 |  | varchar
List of tools | Verktygslista | ztString | 35 |  | varchar


Labour reports, op. join list (aork)

Labour report transactions on an op join list.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Report auto setup time | AoRappStallTid_Aut | ztOpTime | 9 | 4 | float
Report man. setup time | AoRappStallTid_Man | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Rep auto run time | AoRappStyckTid_Aut | ztOpTime | 9 | 4 | float
Rep manual run time | AoRappStyckTid_Man | ztOpTime | 9 | 4 | float
Remaining to report | AoRestInnanRapp | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Op join list No. | Kaplista | ZtLong | 10 |  | int
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
Subcontract price/unit | LegoPris | ZtBaseCurrAmount | 14 | 2 | money
Personnel/operation | OpBemanning | ztFloat | 6 | 3 | float
Operation no. | OpNr | ztInteger | 3 |  | int
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Activity finished | PlanUtford | ztBoolean |  |  | char
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Reported finish date | RappSlutDatum | ztDate |  |  | datetime
Reported finish time | RappSlutTid | ztTime | 5 |  | datetime
Start date | RappStartDatum | ztDate |  |  | datetime
Reported start time | RappStartTid | ztTime | 5 |  | datetime
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Shop price | VerkstadPris | ZtBaseCurrAmount | 14 | 2 | money
Tools | Verktyg | ztString | 16 |  | varchar
List of tools | Verktygslista | ztString | 35 |  | varchar


Labour time entered using time unit (InputUnitTimeType)

Instead of enter labour time in hours you can use another time unit that converts to hours.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
DivideInput2GetHour | DivideInput2GetHour | ZtDecimal73 | 12 | 6 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Input2GetHour_NoOfDec | Input2GetHour_NoOfDec | ztInteger | 5 |  | smallint
Input2GetQtyPerHour_NoOfDec | Input2GetQtyPerHour_NoOfDec | ztInteger | 5 |  | smallint
InputUnitTimeType | InputUnitTimeType | ztInteger | 5 |  | smallint
InputUnitTimeTypeDescr | InputUnitTimeTypeDescr | ztString | 80 |  | varchar
MultiplyInput2GetHour | MultiplyInput2GetHour | ZtDecimal73 | 12 | 6 | decimal
Signature | PersSign | ztString | 30 |  | varchar
QtyInput2GetHour_flag | QtyInput2GetHour_flag | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: InputUnitTimeType


Labour transaction detail types (xopb)

Description of integration detail.

Integration sources and their details identify the origin of financial transactions, e.g. issues for customer orders, received deliveries from own manufacturing, outgoing payments to suppliers, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Integration detail | ArbTransTyp | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar


Labour transactions->GL (aovt)

Detailed data by transaction of how labour reports are posted when integrated with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Mfg journal no. | AorJournNr | ZtLong | 6 |  | int
Product acct, labour | ArbProdKonto | ztString | 8 |  | varchar
Integration detail | ArbTransTyp | ztInteger | 3 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Link, labour reporting | ConnAorDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Inventory location | LagStalle | ztString | 2 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Period | Period | ztInteger | 4 |  | smallint
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Tools | Verktyg | ztString | 16 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: xAovt GL posting labour operations


Labour transactions->GL (akop)

Detailed information per transaction of how labour reports are posted when integrated with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Product acct, labour | ArbProdKonto | ztString | 8 |  | varchar
Integration detail | ArbTransTyp | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Akop Posting templates, labour costs


Language (xw)

Internal definition of languages according to Jeeves' own standard. Language codes cannot be changed.

The information is used to manage the language for some external texts depending on the external company's language.

The following standard records exist. Do not alter/delete:

Language (SprakKod) | Language (Sprak)
0 | Swedish
1 | UK English
2 | German
3 | Danish
4 | French
5 | US English
6 | Japanese
7 | Norwegian
8 | Turkish
9 | Finnish
10 | Spanish
11 | Chinese
12 | Polish
13 | Dutch
14 | Italian
15 | Russian
16 | Estonian
17 | Slovak
18 | Czech
999 | International English

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Reprint invoice header | ReprintHeader | ztString | 255 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Coll.invoice text-1 | SamlFaktText1 | ztString | 20 |  | varchar
Coll.invoice text-2 | SamlFaktText2 | ztString | 20 |  | varchar
Coll.invoice text-3 | SamlFaktText3 | ztString | 20 |  | varchar
Coll.invoice text-4 | SamlFaktText4 | ztString | 20 |  | varchar
Coll.invoice text-5 | SamlFaktText5 | ztString | 20 |  | varchar
Language | Sprak | ztString | 50 |  | varchar
Language | SprakKod | ztInteger | 3 |  | smallint
Use CustomerDropDown | UseCdd | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: Xxw Languages


Language columns (wfbl)

Name (internal data name) of a column in a database table that can be used by Jeeves.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
column desc | ColumnDescr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Name of column | JvsColumnName | ztString | 128 |  | varchar
Module ID | Moduleid | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint


Language management (JvsSiteLang)

Translations of texts in the site repository, for example translated menus, tab names etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Default | JvsSiteLangDefault | ztBoolean |  |  | char
Language | JvsSiteLangId | ztInteger | 5 |  | int
Text | JvsSiteLangString | ztString | 7500 |  | nvarchar
TextID | JvsSiteTextID | ztString | 40 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteLang Language management


Ledger voucher rows (vrsk)

Preliminary postings for incoming payments in accounts receivable.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Account type | KtoTyp | ztInteger | 3 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money
Voucher row text | VrVerText | ztString | 60 |  | varchar


Legal entities (leen)

Definition of legal entities with a link to a cost centre.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Legal entity | LegalEntity | ztString | 10 |  | varchar
Designation | LegalEntityDesc | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: leen Legal entities


Link between business units ICT (ICTConDef)

Alphanumeric ID for the internal business unit, i.e. in your own company.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Suppl inv approv by ICT | ICTAttestSign | ztString | 6 |  | varchar
Chg deliv salesorder ICT | ICTChgDelivSalesOrder | ztBoolean |  |  | char
ICT conn business unit | ICTConBusinessUnit | ztString | 8 |  | varchar
Customer number ICT | ICTCustomerNo | ztCompanyNo | 20 |  | varchar
Auto recvd deliv PO ICT | ICTDelivType | ztInteger | 5 |  | smallint
Auto deliv drop shipm ICT | ICTDropDelivType | ztInteger | 5 |  | smallint
Inventory location ICT | ICTInvLocation | ztString | 16 |  | varchar
Order type del.order ICT | ICTOrdTypeDSO | ztInteger | 3 |  | smallint
Signature for ICT | ICTPersSign | ztString | 6 |  | varchar
Auto create PO ICT | ICTPOCreateType | ztInteger | 5 |  | smallint
Goods in transit PO ICT | ICTPOTransitType | ztInteger | 5 |  | smallint
Release sales order ICT | ICTRelType | ztInteger | 5 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Close supp.invoice ICT | ICTSuppInvComplCode | ztInteger | 5 |  | smallint
Supplier number ICT | ICTSupplierNo | ztCompanyNo | 20 |  | varchar
Goods in transit stat ICT | ICTTransitStatus | ztInteger | 3 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ICTConDef Link between business units ICT


Link mtrl reservations-PO (cmrb)

Links between material reservations and existing purchase orders. Records are created in the table when booking material for manufacturing orders against an existing PO.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: cmrb Material reservation - PO connection


Link On account, invoice to Advance invoice (fskac)

Unique sequence number for relevant definition. The term is used by a number of functions, in some the number is entered manually and in others it is generated automatically. If the number is generated automatically, this can be done, for example, according to one of the conventions described below.

Example 1:
number of days since 940101
number of seconds since 00.00
process ID in the database
counter

Example 2:
today's date (8char) (YYYYMDD)
current time (8char) (HH:MM:SS)
current time milliseconds (:SSS)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Paid amount BCU | FaktInbBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no, on account | FaktNrAConto | Jeeves_InvNo | 9 |  | bigint
Invoice no., advance | FaktNrForskott | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment date | InbDat | ztDate |  |  | datetime
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Amount paid, curr | vbFaktInbBel | ztMoney | 14 | 2 | money


Link order-invtry, PO, MO (corx)

Links between customer order rows and batches (received delivery ID), purchase orders and manufacturing orders.

This table is an interim table. All rows that are created in the table are transferred to one of the tables:
- Order-inventory connection (Corl)
- Purchase order-inventory connection (Corb)
- Order-manufacturing order connection (Ctio)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | nvarchar
Batch no. | BatchId | ztString | 30 |  | nvarchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
@zPrompt=null | DoNotCreateRowInCorx | ztBoolean |  |  | int
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | nvarchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Bin | LagPlats | ztBinLocation | 20 |  | nvarchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | nvarchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | nvarchar
Source | ulbpTyp | ztString | 2 |  | nvarchar
Item group | VaruGruppKod | ztString | 8 |  | varchar


Link order-MO (ctio)

Links between customer orders and manufacturing orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Active connection | Koppling | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: ctio Booking MO from order

    Program: orti MO from CO


Link PO-supplier invc (lrbh)

Links between purchase orders and supplier invoices and vice versa.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Delivery note date, rcv | BestFoljesedelsDat | ztDate |  |  | datetime
Delivery note no., rcv | BestFoljesedelsNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Fakt avpr försl enl | FaktAvprForslEnl | ztInteger | 5 |  | smallint
Invoice match method | FaktAvprTypBest | ztInteger | 3 |  | smallint
Invc match value | FaktAvprVarde | ztMoney | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Reason code | FsOrsakKod | ztInteger | 5 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Allocation purch OH | InkOmkFord | ztInteger | 5 |  | smallint
Purch OH type | InkOmkTyp | ztInteger | 5 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Sequence no. | LrbhRadPos | ztInteger | 5 |  | int
No deliveries exists | NoDelivExists | ztBoolean |  |  | char
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: lrbh Show invoice/PO connection


Link types ICT (ICTTypeTable)

Definition of existing types of connections between, for example, inventory locations or business units in Jeeves ICT.

The following standard records exist. Do not alter/delete:

Connection type ICT (ICTType) | Connection type ICT (ICTTypeDescr) | Description
0 | Inventory location in same company |
1 | Company in same database |
2 | Company in same DBase server but different DBase |
3 | Company in different database servers |
4 | Other company, NON-JEEVES company | Not currently used.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Connection type ICT | ICTType | ztInteger | 2 |  | smallint
Connection type ICT | ICTTypeDescr | ztString | 50 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ICTTypeTable Link types ICT


Link, business opportunities-products (ProVgTyp)

Definition of links (relationships) between business opportunities and products, e.g. Requested sample, Sent sample etc. You can then specify the products that the company requests or has been sent samples of in the Business opportunity program.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Link description | ProVgTypBeskr | ztString | 30 |  | varchar
Link ID | ProVgTypKod | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xProVgTyp Link, business opportunities-products


Link, company-products (FrVgTyp)

Definition of links (relationships) between company and products, e.g. reference customer, test customer or wants demo, interested buyer etc. You can specify later on in the program Company, marketing products for which company, for example, will serve as a reference or test customer or similar function.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Link description | FrVgTypBeskr | ztString | 30 |  | varchar
Link ID | FrVgTypKod | ztString | 10 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xfrvgtyp Link, company-products


Linked table, report row (ebrt)

Linked table for main table in report object, eBRev.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Link | Connection | ztBlob | 1 |  | varchar
Report object | ebRPtObjekt | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Type of join | jointyp | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sort order | SortOrder | ztInteger | 5 |  | smallint
Table name | TableName | ztString | 255 |  | varchar
Report program | YndReport | ztString | 40 |  | varchar


Links work operations-workload (Ao2Workload)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | aonr | Jeeves_MONo | 7 |  | bigint
Row | aopos | ztInteger | 4 |  | int
Identitetskolumn | conntosqlidentity | ZtLong | 10 |  | int
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Jeeves_Init_Insert_Enter | Jeeves_Init_Insert_Enter | ztDateTime |  |  | datetime
Jeeves_Init_Insert_PreIns | Jeeves_Init_Insert_PreIns | ztDateTime |  |  | datetime
Origin of workload detail | LO2WL_Type | ztInteger | 5 |  | smallint
Manufacturing resource ID | ManufRes_Id | ZtLong | 10 |  | int
Operation no. | opnr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | sqlidentity | ZtLong | 10 |  | int
Booked workload | Workload_Capacity_Booked | ZtDecimal73 | 9 | 2 | decimal
Workload, detailed Org.value | Workload_Capacity_Booked_Org | ZtDecimal73 | 9 | 2 | decimal
Unit time, det/resource | Workload_LaborHrs | ZtDecimal73 | 8 | 3 | decimal
Workload, det/resource | Workload_LaborHrs_Org | ZtDecimal73 | 8 | 3 | decimal
Setup time, det/resource | Workload_SetUpTime | ZtDecimal73 | 8 | 3 | decimal
Setup time, detailed/resource Org.value | Workload_SetUpTime_Org | ZtDecimal73 | 8 | 3 | decimal
Start date/time | Workload_Startdate | ztDateTime |  |  | datetime
End date/time | Workload_Stopdate | ztDateTime |  |  | datetime


Links work operations-workload (Ao2WorkloadU)

DummySQLIdentity... Intern teknisk lösning i Jeeves för att komma runt problem med instead_of_trigger

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | aonr | Jeeves_MONo | 7 |  | bigint
MRP Manufacturing order no | AoNrNE | Jeeves_MONo | 7 |  | bigint
Row | aopos | ztInteger | 4 |  | int
MRP Pos | AoPosNE | ztInteger | 4 |  | int
Work group | ArbetsLag | ztString | 6 |  | varchar
Identitetskolumn | conntosqlidentity | ZtLong | 10 |  | int
Identitetskolumn | DummySQLIdentity | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Origin of workload detail | LO2WL_Type | ztInteger | 5 |  | smallint
Manufacturing resource | ManufRes_Descr | ztString | 60 |  | varchar
Manufacturing resource ID | ManufRes_Id | ZtLong | 10 |  | int
Operation no. | opnr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Booked workload | Workload_Capacity_Booked | ZtDecimal73 | 9 | 2 | decimal
Unit time, det/resource | Workload_LaborHrs | ZtDecimal73 | 8 | 3 | decimal
Setup time, det/resource | Workload_SetUpTime | ZtDecimal73 | 8 | 3 | decimal
Start date/time | Workload_Startdate | ztDateTime |  |  | datetime
End date/time | Workload_Stopdate | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Ao2Workload Links planned labour - det.workload


Links work operations-workload (reconstruction) (Ao2WorkloadU_tmp)

DummySQLIdentity... Intern teknisk lösning i Jeeves för att komma runt problem med instead_of_trigger

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | aonr | Jeeves_MONo | 7 |  | bigint
Row | aopos | ztInteger | 4 |  | int
Work group | ArbetsLag | ztString | 6 |  | varchar
Identitetskolumn | conntosqlidentity | ZtLong | 10 |  | int
Identitetskolumn | DummySQLIdentity | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Manufacturing resource | ManufRes_Descr | ztString | 60 |  | varchar
Manufacturing resource ID | ManufRes_Id | ZtLong | 10 |  | int
Operation no. | opnr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Booked workload | Workload_Capacity_Booked | ZtDecimal73 | 9 | 2 | decimal
Unit time, det/resource | Workload_LaborHrs | ZtDecimal73 | 8 | 3 | decimal
Setup time, det/resource | Workload_SetUpTime | ZtDecimal73 | 8 | 3 | decimal
Start date/time | Workload_Startdate | ztDateTime |  |  | datetime
End date/time | Workload_Stopdate | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Ao2WorkLoad_tmp Links planned labour - det.workload


Links work operations-workload (reconstruction) (Ao2Workload_tmp)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | aonr | Jeeves_MONo | 7 |  | bigint
Row | aopos | ztInteger | 4 |  | int
Identitetskolumn | conntosqlidentity | ZtLong | 10 |  | int
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Manufacturing resource ID | ManufRes_Id | ZtLong | 10 |  | int
Operation no. | opnr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | sqlidentity | ZtLong | 10 |  | int
Booked workload | Workload_Capacity_Booked | ZtDecimal73 | 9 | 2 | decimal
Unit time, det/resource | Workload_LaborHrs | ZtDecimal73 | 8 | 3 | decimal
Setup time, det/resource | Workload_SetUpTime | ZtDecimal73 | 8 | 3 | decimal
Start date/time | Workload_Startdate | ztDateTime |  |  | datetime
End date/time | Workload_Stopdate | ztDateTime |  |  | datetime


Liquidity forecast (lipt)

Liquidity forecasts (main table).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Incl order | AddOrder | ztBoolean |  |  | char
Incl purchase | AddPO | ztBoolean |  |  | char
All customers | AllCustNo | ztBoolean |  |  | char
All suppliers | AllSupplNo | ztBoolean |  |  | char
On account sum | AmountOnAcct | ZtBaseCurrAmount | 14 | 2 | money
On account sum LR | AmountOnAcct_AP | ZtBaseCurrAmount | 14 | 2 | money
On account sum AR | AmountOnAcct_AR | ZtBaseCurrAmount | 14 | 2 | money
Amount due | DueAmount | ZtBaseCurrAmount | 14 | 2 | money
Amount due LR | DueAmount_AP | ZtBaseCurrAmount | 14 | 2 | money
Amount due AR | DueAmount_AR | ZtBaseCurrAmount | 14 | 2 | money
Forecast date | ForeCastDate | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
From customer no. | FromCustNo | ztCompanyNo | 20 |  | varchar
From supplier no. | FromSupplNo | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Incl prel paid invoices | InclPrePayedInvoice | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Liquidity forecast | LikvidPrognos | ztString | 6 |  | varchar
Balance | LiquidityBalance | ZtBaseCurrAmount | 14 | 2 | money
Balance LR | LiquidityBalance_AP | ZtBaseCurrAmount | 14 | 2 | money
Balance KR | LiquidityBalance_AR | ZtBaseCurrAmount | 14 | 2 | money
Forecast no. | LiquidityForeCastNo | ZtLong | 8 |  | int
Sign AP/PO | LiquiditySign | ztBoolean |  |  | char
Total | LiquidityTotal | ZtBaseCurrAmount | 14 | 2 | money
Total LR | LiquidityTotal_AP | ZtBaseCurrAmount | 14 | 2 | money
Total KR | LiquidityTotal_AR | ZtBaseCurrAmount | 14 | 2 | money
Order total | LiquidityTotal_OH | ZtBaseCurrAmount | 14 | 2 | money
Total purchase | LiquidityTotal_PO | ZtBaseCurrAmount | 14 | 2 | money
Amount not due | NotDueAmount | ZtBaseCurrAmount | 14 | 2 | money
Amount not due LR | NotDueAmount_AP | ZtBaseCurrAmount | 14 | 2 | money
Amount not due AR | notDueAmount_AR | ZtBaseCurrAmount | 14 | 2 | money
Only approved | OnlyApproval | ztBoolean |  |  | char
Only total | OnlyTotal | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Real credit time | RealCreditDays | ztBoolean |  |  | char
Calc Real credit time | ReCalcRealCreditDays | ztBoolean |  |  | char
Calc date real credit time | ReCalcRealCreditDaysDate | ztDate |  |  | datetime
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Procedure | StoredProcedure | ztString | 120 |  | varchar
To customer no. | ToCustNo | ztCompanyNo | 20 |  | varchar
To supplier no. | ToSupplNo | ztCompanyNo | 20 |  | varchar

    This table is the main table in the following programs:

    Program: lipt Liquidity forecast


Liquidity forecast details/forecast (lipr)

ID term for the liquidity forecast.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Amount | ForeCastAmount | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | KortNotering | ztString | 255 |  | varchar
Liquidity forecast | LikvidPrognos | ztString | 6 |  | varchar
No. of days | LikvidPrognosDgr | ztInteger | 5 |  | smallint
Forecast type | LiquidityFCType | ztInteger | 1 |  | smallint
Forecast no. | LiquidityForeCastNo | ZtLong | 8 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Liquidity forecast inc invoices AP (lipl)

Suppliers' invoice number.

The number must be unique, i.e. you can not enter several invoices with the same number for the same supplier.

Exception: if you enter a number longer than 20 characters you can enter a number to replace the invoice number in the bank giro payment file. This is used for recurring tax payments to the same tax reference number.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Amount | ForeCastAmount | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Liquidity forecast | LikvidPrognos | ztString | 6 |  | varchar
No. of days | LikvidPrognosDgr | ztInteger | 5 |  | smallint
Forecast type | LiquidityFCType | ztInteger | 1 |  | smallint
Forecast no. | LiquidityForeCastNo | ZtLong | 8 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Liquidity forecast incoming detail AR/AP/OH/PO/MA (lipk)

Unique sequence number for relevant definition. The term is used by a number of functions, in some the number is entered manually and in others it is generated automatically. If the number is generated automatically, this can be done, for example, according to one of the conventions described below.

Example 1:
number of days since 940101
number of seconds since 00.00
process ID in the database
counter

Example 2:
today's date (8char) (YYYYMDD)
current time (8char) (HH:MM:SS)
current time milliseconds (:SSS)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Amount | ForeCastAmount | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Liquidity forecast | LikvidPrognos | ztString | 6 |  | varchar
No. of days | LikvidPrognosDgr | ztInteger | 5 |  | smallint
Forecast type | LiquidityFCType | ztInteger | 1 |  | smallint
Forecast no. | LiquidityForeCastNo | ZtLong | 8 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Liquidity forecast interval (liph)

Definition of liquidity forecast intervals in Accounts Receivable and Accounts Payable to see how much will be due or is already past due within the desired period intervals.

Each definition can consist of up to 10 intervals and you must have a final interval for due or past due.

Example:
No. of days	Interval designation
 -9999		<10 (final interval)
 -10		6-10
 -5		0-5
 5		0-5
 10		6-10
 50		11-50
 9999		>50 (final interval)

+ = due within X days from the due date in relation to the as-of date
- = past due X days from the due date in relation to the as-of date

If the as-of date = due date = is due.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Liquidity forecast | LikvidPrognos | ztString | 6 |  | varchar
Liquidity forecast designation | LikvidPrognosBeskr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: liph Liquidity forecast intervals


Liquidity forecast types (lipx)

Type of liquidity forecast

0 = Total 1 = Accounts receivable 2 = Accounts payable 3 = Order 4 = Purchase order 5 = Manual

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Forecast type | LiquidityFCType | ztInteger | 1 |  | smallint
Forecast description | LiquidityFCTypeDescr | ztString | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: lipx Liquidity forecast types


Liquidity forecast, details (lipd)

Details in liquidity forecasts.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Liquidity forecast | LikvidPrognos | ztString | 6 |  | varchar
Scope | LikvidPrognosBeskrDet | ztString | 10 |  | varchar
No. of days | LikvidPrognosDgr | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: lipd Forecast details/forecast


List of tools (vyl)

A tool list is collective term used to describe more than one tool. This means that a number of tools can be linked to a single operation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Deliv to supplier | LevMedBestTillLev | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Quality parameter | QParamId | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Unique for item | UnikForArtikel | ztBoolean |  |  | char
List of tools | Verktygslista | ztString | 35 |  | varchar
List of tools | VerktygslistaBeskr | ztString | 60 |  | varchar

    This table is the main table in the following programs:

    Program: vyl Tool lists


List price change log (arpl)

Log of price changes by item.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
List price | ArtListPris | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Previous list price | OldArtListPris | ZtBaseCurrAmount | 14 | 2 | money
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: xArpl Log list price changes


List prices, rows (xcpl)

Details in the list price table for the conversion of sales prices to list prices for customers using limits for sales prices linked to a markup percentage.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Upper limit sales price | CaFsgPrisLimit | ZtSalesPrice | 12 | 2 | money
Markup % | CaPaslagProcent | ZtDecimal73 | 6 | 2 | decimal
List price table | CaPrisTabKod | ztString | 6 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Load status of shipment plans (ShipmLoadStatus)

Definition of load status codes for shipmant plans.

Examples of load status codes for a shipment plan are Order lines connected, Picking released, Picked etc.

Information on the current load status is shown on the shipment plan.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Shipment load status | ShipmLoadStatus | ztInteger | 2 |  | smallint
Shipment load status | ShipmLoadStatusDescr | ztString | 50 |  | varchar


Location (WMS_Location)

Definition of locations on racks within location-based MHAs. A location is identified by coordinates within the rack. Each location can hold one or more SKUs. The definition also describes the location's type, frequency, check digits, status, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Check digits | CheckSum | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Frequency | Frequence | ztString | 1 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Availability | LocAvailCode | ztInteger | 3 |  | smallint
Max no. pallets | LocPallMax | ztInteger | 3 |  | smallint
Location search no. | LocSortKey | ZtLong | 10 |  | int
Status | LocStatusCode | ztInteger | 3 |  | smallint
Location type | LocType | ztString | 5 |  | varchar
X Pos. | LocXPos | ztString | 5 |  | varchar
Y Pos. | LocYPos | ztString | 5 |  | varchar
MHA | Mha | ztString | 5 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Rack | Rack | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_Location Location


Location status code (WMS_LocStatusCode)

Numerical code specifying the status of the location.

The following standard records exist. Do not alter/delete:

Status (LocStatusCode) | Description (LocStatusDesc) | Description
1 | Available | The location is empty.
5 | Partially occupied | The location is partly occupied but has room for at least one more transport or stock keeping unit.
10 | Occupied | The location is occupied.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Status | LocStatusCode | ztInteger | 3 |  | smallint
Description | LocStatusDesc | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_LocStatusCode Location status code


Location type (WMS_LocType)

Definition of existing location types, for example for different types of pallets, for different storage needs, etc. Location types are not inventory location specific.

Each location in an inventory location should have a location type defined.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Location type | LocType | ztString | 5 |  | varchar
Description | LocTypeDesc | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_LocType Location type


Locations, fixed assets (intPlacering)

Definition of possible locations of fixed assets according to own requirements. These can represent buildings, departments, rooms, working areas or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Location | intPlaceringBeskr | ztString | 60 |  | varchar
Location | intPlaceringKod | ztString | 10 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: intPlacering Fixed assets locations


Log created outgoing pmt service files (jfbl)

Log of invoice payment service batches and the files created.
The table is also used to check which dates have been used for outgoing payment files for Postal Giros.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Transmit to bank date | BankSandDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
PG manufacturing date | PostGiroProdDat | ztDate |  |  | datetime
PG manufacturing no. | PostGiroProdNr | ztInteger | 1 |  | smallint
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Pmt file created by | UtbFileCreatedBy | ztString | 6 |  | varchar
Pmt file created date | UtbFileCreatedDt | ztDateTime |  |  | datetime
Period for prel pmt | UtbFilePeriod | ztInteger | 4 |  | smallint
Fiscal year | UtbFileRedovisnAr | ztInteger | 4 |  | smallint
AP payment file sent | UtbFileSend | ztBoolean |  |  | char
Expedited by | UtbFileSendBy | ztString | 6 |  | varchar
Sent date/time | UtbFileSendDt | ztDateTime |  |  | datetime
Voucher no. | UtbFileVerNr | Jeeves_VchrNo | 9 |  | bigint
Pmt service journal no. | UtbServJournNr | ZtLong | 6 |  | int


Log created payment service files (jfbf)

Log of batches for creating outgoing payment files.
The table is also used to check which dates have been used for outgoing payment files for Postal Giros.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
PG manufacturing date | PostGiroProdDat | ztDate |  |  | datetime
PG manufacturing no. | PostGiroProdNr | ztInteger | 1 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Date/time | StrDateTime | ztString | 28 |  | varchar
Pmt file created by | UtbFileCreatedBy | ztString | 6 |  | varchar
Pmt file created date | UtbFileCreatedDt | ztDateTime |  |  | datetime
Period for prel pmt | UtbFilePeriod | ztInteger | 4 |  | smallint
Fiscal year | UtbFileRedovisnAr | ztInteger | 4 |  | smallint
AP payment file sent | UtbFileSend | ztBoolean |  |  | char
Expedited by | UtbFileSendBy | ztString | 6 |  | varchar
Sent date/time | UtbFileSendDt | ztDateTime |  |  | datetime
Voucher no. | UtbFileVerNr | Jeeves_VchrNo | 9 |  | bigint
Pmt service journal no. | UtbServJournNr | ZtLong | 6 |  | int


Log DDL events (JvsLogDDLEvent)

se JvsLogEvent.sql

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Date and time ISO-8601 | DateTimeAsISO8601 | ztString | 23 |  | varchar
DDL Database name | DDL_DatabaseName | ztString | 100 |  | varchar
DDL Event type | DDL_EventType | ztString | 40 |  | varchar
DDL Host name | DDL_HostName | ztString | 60 |  | varchar
DDL Login name | DDL_LoginName | ztString | 100 |  | varchar
DDL NT domain | DDL_NT_Domain | ztString | 100 |  | varchar
DDL NT User name | DDL_NT_UserName | ztString | 100 |  | varchar
DDL Object name | DDL_ObjectName | ztString | 100 |  | varchar
DDL Object type | DDL_ObjectType | ztString | 30 |  | varchar
DDL Program name | DDL_Program_Name | ztString | 100 |  | varchar
DDL Schema name | DDL_SchemaName | ztString | 100 |  | varchar
DDL Server name | DDL_ServerName | ztString | 100 |  | varchar
DDL TSQL Command | DDL_TSQLCommand | ztString | 4000 |  | varchar
DDL User name | DDL_UserName | ztString | 100 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Process ID | Spid | ZtLong | 5 |  | int
Identity | SqlIdentity | ZtLong | 10 |  | bigint

    This table is the main table in the following programs:

    Program: JvsLogDDLEvent Log off DDL event


Log definitions (sysl)

Definition of the changes in the database that will be logged.

In the program you can specify which tables and columns (fields) will be included in the Jeeves change log. This requires you to be well-acquainted with the structure of the Jeeves database and how the relevant tables and fields are used. This work is best performed by- or in consultation with -the systems administrator of the company.

You can log new entries, changes and deletions. Logging can occur at the table- or field level, including customized tables and fields. You can also make these events require a reason code and/or a password.

Note that the change log only functions for changes made from Jeeves clients and not for changes made, for example, via Access, Query Analyses, etc. It should also be noted that if you are conducting a search in this program or table, only records with a logged-in ID are displayed.

There is a separate program for viewing the log and printing it in various sorting orders. There is also a function to empty the log up to a specific date.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
DB-term/-expression 1 | DbTermname1 | ztString | 120 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Use in Item Revision | ItemRevisionInUse | ztBoolean |  |  | char
Macro | JvsSiteMacroName | ztString | 40 |  | varchar
Log deletion | LogDelete | ztBoolean |  |  | char
Log insert | LogInsert | ztBoolean |  |  | char
Reason code must be indicated | LogOrsakKodMark | ztBoolean |  |  | char
Prompt text for reason query | LogOrsakLedtext | ztString | 80 |  | varchar
Password must be indicated | LogOrsakLosenMark | ztBoolean |  |  | char
Log update (amendment) | LogUpdate | ztBoolean |  |  | char
Signature | perssign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | strdatetime | ztString | 28 |  | varchar
Base/value table | ztable | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: sysl Log definition

    Program: sysl_all Log definition


Log definitions, reason codes (syslo)

Definition of codes for and descriptions of reasons for changes in the database. The data is completed if you are using the expanded change log (from version 9) and only for the changes that require the user to specify a reason and any note.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
DB-term/-expression 1 | DbTermname1 | ztString | 120 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Log deletion | LogDelete | ztBoolean |  |  | char
Log insert | LogInsert | ztBoolean |  |  | char
Reason code | LogOrsakBeskr | ztString | 120 |  | varchar
Own notation must be indicated | LogOrsakEgenNotOblig | ztBoolean |  |  | char
Reason code | LogOrsakKod | ztInteger | 5 |  | smallint
Log update (amendment) | LogUpdate | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Base/value table | zTable | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: syslo Log definition, reason codes


Log for XML export (XmlOutLog)

Log of XML exports . Shows the status of the export (0=Error, 1=Successful).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Key part 1 | Key1 | ztString | 50 |  | varchar
Key part 2 | Key2 | ztString | 50 |  | varchar
Key part 3 | Key3 | ztString | 50 |  | varchar
Key part 4 | Key4 | ztString | 50 |  | varchar
Key part 5 | Key5 | ztString | 50 |  | varchar
Configurator model ID | ModelId | ztString | 60 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
XML document | XmlDoc | ztBlob | 1 |  | varchar
Status of XML file | XmlLogStatus | ztInteger | 5 |  | smallint
State of configuration | XmlState | ztBlob | 1 |  | varchar


Log for XML import (TactonXmlLog)

Log of XML imports from the Sales configurator (header table). Shows the status of the import (0=Error, 1=Successful).

If an error occurs (status 0) the order row is not updated. You can press the Error text, insert button to view the error text, correct the problem and re-start the configurator.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Key part 1 | Key1 | ztString | 50 |  | varchar
Key part 2 | Key2 | ztString | 50 |  | varchar
Key part 3 | Key3 | ztString | 50 |  | varchar
Key part 4 | Key4 | ztString | 50 |  | varchar
Key part 5 | Key5 | ztString | 50 |  | varchar
Configurator model ID | ModelId | ztString | 60 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
XML document | XmlDoc | ztBlob | 1 |  | varchar
Status of XML file | XmlLogStatus | ztInteger | 5 |  | smallint
State of configuration | XmlState | ztBlob | 1 |  | varchar


Log from matching supp.inv. against order (SuppInvMatchingPO_Log)

Log from matching supplier invoices against orders, showing start times and information if rows cannot be matched.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Text/info | x255 | ztString | 255 |  | varchar


Log from MRP runs (internal use) (MRPExecLog)

Log of MRP runs, for analizing processing time and troubleshooting when problems arise.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Process (No. days) | NE_Beh_Antal_Dgr | ztInteger | 5 |  | smallint
Delete earlier proposals | NE_Del_Bia_Pans | ztBoolean |  |  | char
Delete purch prognosis | NE_Del_Bp_Prognos | ztBoolean |  |  | char
MRP template description | NE_Fi_Beskr | ztString | 60 |  | varchar
MRP template ID | NE_Fi_Id | ztInteger | 5 |  | smallint
Proposal No. days | NE_Forsl_Antal_Dgr | ztInteger | 5 |  | smallint
From order row status | NE_From_OrdRadSt | ztInteger | 5 |  | smallint
MRP filter description | NE_Fw_Beskr | ztString | 60 |  | varchar
MRP filter ID | NE_Fw_Id | ztInteger | 5 |  | smallint
MRP batch -> Sign/mgr | NE_PlanAnsv | ztString | 8 |  | varchar
Invtry bal acc to inv grp | NE_Saldo_LstGrupp | ztBoolean |  |  | char
Balance type at MRP | NE_SaldoTyp | ztInteger | 5 |  | smallint
Excess inventory test | NE_TestaOverLager | ztBoolean |  |  | char
To order code | NE_Tom_OrderKod | ztInteger | 5 |  | smallint
Where | NE_Where | ztString | 255 |  | varchar
Using limited capacity MRP | NRP_UseFiniteCapacity | ztBoolean |  |  | char
Use forecast in MRP | NRP_UseForecast | ztBoolean |  |  | char
Use security layer in MRP | NRP_UseSafetyLevel | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Process ID | Spid | ZtLong | 5 |  | int
Identity | SqlIdentity | ZtLong | 10 |  | int
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: MRPExecLog Log from MRP run (internal use)


Log loading man. inventory transactions (arsm_pre_log)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Text/info | x255 | ztString | 255 |  | varchar


Log of changes in the database according to log.def (ItemRevDiffColumns)

Table for Jeeves change log.

Changes in the database are logged according to the definition made in the programs Log definition (sysl) and Log definition, reason codes (syslo).

A row/record is created in the log per table or field covered by the change log when the table/field is changed. In other words, if three fields in a specific table are covered by the change log, and these three fields are changed, this results in three rows/records in the log.

The following is shown on the log record:
- table/field changed
- date and time of the change
- signature for the user who made the change
- old value
- new value
- primary key for the changed record (if the key includes several columns/fields, all are displayed separated by a semicolon)

The expanded change log (from version 9) also displays:
- any reason code and description
- to what extent the change required a password
- any reason note

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative routing | AltOpPrior |  |  |  | @DataType=NULL
Priority | ArtLevPrior |  |  |  | @DataType=NULL
Item no. | ArtNr |  |  |  | @DataType=NULL
DB-term/-expression 1 | DbTermname1 |  |  |  | @DataType=NULL
Sequence number | DummyUniqueId |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Company ID | FtgNr |  |  |  | @DataType=NULL
Purchase agreement no. | InkAvt |  |  |  | @DataType=NULL
Item Revision | ItemRevision |  |  |  | @DataType=NULL
Inventory location | LagStalle |  |  |  | @DataType=NULL
New value | Lognewvalue |  |  |  | @DataType=NULL
Old value | Logoldvalue |  |  |  | @DataType=NULL
Sequence no. | lopnr |  |  |  | @DataType=NULL
Operation no. | OpNr |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Language | SprakKod |  |  |  | @DataType=NULL
Prompt | TermPrompt |  |  |  | @DataType=NULL
Base/value table | ztable |  |  |  | @DataType=NULL


Log of changes in the database according to log.def (ItemRevDiffColumnsClient)

Table for Jeeves change log.

Changes in the database are logged according to the definition made in the programs Log definition (sysl) and Log definition, reason codes (syslo).

A row/record is created in the log per table or field covered by the change log when the table/field is changed. In other words, if three fields in a specific table are covered by the change log, and these three fields are changed, this results in three rows/records in the log.

The following is shown on the log record:
- table/field changed
- date and time of the change
- signature for the user who made the change
- old value
- new value
- primary key for the changed record (if the key includes several columns/fields, all are displayed separated by a semicolon)

The expanded change log (from version 9) also displays:
- any reason code and description
- to what extent the change required a password
- any reason note

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative routing | AltOpPrior |  |  |  | @DataType=NULL
Priority | ArtLevPrior |  |  |  | @DataType=NULL
Item no. | ArtNr |  |  |  | @DataType=NULL
DB-term/-expression 1 | DbTermname1 |  |  |  | @DataType=NULL
Sequence number | DummyUniqueId |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Company ID | FtgNr |  |  |  | @DataType=NULL
Purchase agreement no. | InkAvt |  |  |  | @DataType=NULL
Item Revision | ItemRevision |  |  |  | @DataType=NULL
Inventory location | LagStalle |  |  |  | @DataType=NULL
New value | Lognewvalue |  |  |  | @DataType=NULL
Old value | Logoldvalue |  |  |  | @DataType=NULL
Sequence no. | lopnr |  |  |  | @DataType=NULL
Operation no. | OpNr |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Language | SprakKod |  |  |  | @DataType=NULL
Prompt | TermPrompt |  |  |  | @DataType=NULL
Base/value table | ztable |  |  |  | @DataType=NULL


Log of changes in the database according to log.def (sycg)

Table for Jeeves change log.

Changes in the database are logged according to the definition made in the programs Log definition (sysl) and Log definition, reason codes (syslo).

A row/record is created in the log per table or field covered by the change log when the table/field is changed. In other words, if three fields in a specific table are covered by the change log, and these three fields are changed, this results in three rows/records in the log.

The following is shown on the log record:
- table/field changed
- date and time of the change
- signature for the user who made the change
- old value
- new value
- primary key for the changed record (if the key includes several columns/fields, all are displayed separated by a semicolon)

The expanded change log (from version 9) also displays:
- any reason code and description
- to what extent the change required a password
- any reason note

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Identitetskolumn | ConnToSQLIdentity | ZtLong | 10 |  | int
DB-term/-expression 1 | DbTermname1 | ztString | 120 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Log deletion | LogDelete | ztBoolean |  |  | char
Log insert | LogInsert | ztBoolean |  |  | char
New value | Lognewvalue | ztString | 60 |  | varchar
Old value | Logoldvalue | ztString | 60 |  | varchar
Reason code | LogOrsakBeskr | ztString | 120 |  | varchar
Reason code | LogOrsakKod | ztInteger | 5 |  | smallint
Password must be indicated | LogOrsakLosenMark | ztBoolean |  |  | char
Manual notation of reason | LogOrsakNotering | ztString | 255 |  | varchar
Log update (amendment) | LogUpdate | ztBoolean |  |  | char
Primary key | PKey | ztString | 255 |  | varchar
DB lib process ID | ProcIdDBLib | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedby | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Identity | SQLIdentity | ZtLong | 10 |  | int
Date/time | strdatetime | ztString | 28 |  | varchar
Where | YndWhere | ztString | 255 |  | varchar
Base/value table | ztable | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: sycg Change log


Log on item from MRP runs (MRPExecLogInputData)

Log of MRP runs for analizing processing time and troubleshooting when problems arise.

Only items that are flagged for logging in MRP runs are included. The table is automatically purged after 90 days.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Identitetskolumn | ConnToSqlIdentity | ZtLong | 10 |  | int
Planned date | EventPlDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Change to date | NRP_ToDate | ztDate |  |  | datetime
Change to quantity | NRP_ToQty | ZtQty | 14 | 2 | decimal
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Identity | SQLIdentity | ZtLong | 10 |  | int
ID number | X_IdNr | ZtLong | 10 |  | int
ID row | X_IdRad | ZtLong | 10 |  | int
ID row sub-row | X_IdSubRad | ZtLong | 10 |  | int


Log on item from MRP runs (MRPExecLogItem)

Log of MRP runs broken down per item, for analizing processing time and troubleshooting when problems arise.

Only items that are flagged for logging in MRP runs are included.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Identitetskolumn | ConnToSqlIdentity | ZtLong | 10 |  | int
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SqlIdentity | ZtLong | 10 |  | int


Log on manufacturing resorces from MRP runs (MRPExecLogManufres)

Log of MRP runs broken down per manufacturing resource, for analizing processing time and troubleshooting when problems arise.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Identitetskolumn | ConnToSqlIdentity | ZtLong | 10 |  | int
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Manufacturing resource ID | Manufres_Id | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SqlIdentity | ZtLong | 10 |  | int
WL_Log_Accum_Time | WL_Log_Accum_Time | ZtHugeInt | 20 |  | bigint
WL_Log_Upd_Ack_Times | WL_Log_Upd_Ack_Times | ZtLong | 10 |  | int
WL_Log_Upd_LW_Times | WL_Log_Upd_LW_Times | ZtLong | 10 |  | int
WL_Log_Upd_Times | WL_Log_Upd_Times | ZtLong | 10 |  | int


Log rows for XML export (XmlOutLogRows)

Log of XML exports . Shows the status of the export (0=Error, 1=Successful).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Delete SQL script | DeleteSql | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Error text, insert | InsertError | ztBlob | 1 |  | varchar
Insert SQL script | InsertSql | ztBlob | 1 |  | varchar
Key part 1 | Key1 | ztString | 50 |  | varchar
Key part 2 | Key2 | ztString | 50 |  | varchar
Key part 3 | Key3 | ztString | 50 |  | varchar
Key part 4 | Key4 | ztString | 50 |  | varchar
Key part 5 | Key5 | ztString | 50 |  | varchar
Configurator model ID | ModelId | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Transaction Id | TranId | ZtHugeInt | 20 |  | int
Error text, update | UpdateError | ztBlob | 1 |  | varchar
Update SQL script | UpdateSql | ztBlob | 1 |  | varchar
Status of XML file | XmlLogStatus | ztInteger | 5 |  | smallint


Log rows for XML import (TactonXmlLogRows)

Log of XML imports from the Sales configurator (details table). Shows the status of the import (0=Error, 1=Successful).

If an error occurs (status 0) the order row is not updated. You can press the Error text, insert button to view the error text, correct the problem and re-start the configurator.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Delete SQL script | DeleteSql | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Error text, insert | InsertError | ztBlob | 1 |  | varchar
Insert SQL script | InsertSql | ztBlob | 1 |  | varchar
Key part 1 | Key1 | ztString | 50 |  | varchar
Key part 2 | Key2 | ztString | 50 |  | varchar
Key part 3 | Key3 | ztString | 50 |  | varchar
Key part 4 | Key4 | ztString | 50 |  | varchar
Key part 5 | Key5 | ztString | 50 |  | varchar
Configurator model ID | ModelId | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Transaction Id | TranId | ZtHugeInt | 20 |  | bigint
Error text, update | UpdateError | ztBlob | 1 |  | varchar
Update SQL script | UpdateSql | ztBlob | 1 |  | varchar
Status of XML file | XmlLogStatus | ztInteger | 5 |  | smallint


Log table printed BOEs (vxdi)

A record for every invoice (Order and Extract) is saved in this table for every bill of exchange that is printed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Bill of exchange no. | BoE_No | ZtLong | 9 |  | int
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Log transfer item statistics (arls)

Alphanumeric code for the item, BOM, fixed asset, or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | Artnr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
New item number | NyttArtNr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Table name | TableName | ztString | 255 |  | varchar


Log, allocation fixed vouchers (remdlog)

Log for peridoic auto postings. Creted from report Batch periodic voucher basis in program Booking periodic vouchers (bvrremh).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Debit/credit | DebKre | ztchar | 1 |  | char
Text | edit | ztBlob | 1 |  | varchar
Amount | FordBel | ZtBaseCurrAmount | 14 | 2 | money
Allocation percent | FordProc | ZtDecimal73 | 6 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | k5 | ztString | 8 |  | varchar
S6 | k6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
S8 | k8 | ztString | 8 |  | varchar
Cost unit | kostbar | ztString | 8 |  | varchar
Cost centre | koststallekod | ztString | 8 |  | varchar
Account | ktonr | ztString | 8 |  | varchar
Quantity | kvantitet | ztFloat | 9 | 2 | float
Period | period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | projcode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Voucher text | remdvertext | ztString | 40 |  | varchar
Fördelningstyp | remfordtyp | ztInteger | 2 |  | smallint
Periodic vch. no | RemNr | ZtLong | 6 |  | int
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | valkod | ztString | 3 |  | varchar
Amount, curr | vbbelopp | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint


Log, customer solvency (kuss)

Alphanumeric designation for the company.

When you enter a company for the first time, this number is not automatically set by the system. You must enter it manually.

This is the unique ID for the company and cannot be changed, which means that if you base it on the company name, e.g. the first letters of the company name, you will not be able to change the ID if the company changes name. It is therefore best to construct the ID a different way or just use sequence numbers. You can search for the company using different terms, e.g. its name.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Days fr due dt to pmt | AntDgrSedanFfDat | ZtLong | 7 |  | int
Av days fr due dte to pmt | AntDgrSedanFfDatSnitt | ZtLong | 5 |  | int
No. of incoming pmts | AntInb | ZtLong | 10 |  | int
Days fr inv dt to pmt | AntInbDgr | ZtLong | 10 |  | int
Avg days fr inv dte to pmt | AntInbDgrSnitt | ZtLong | 10 |  | int
Average credit time | AvgCreditDays | ZtLong | 10 |  | int
Rest to pay collection | BasFaktRestInkasso | ZtBaseCurrAmount | 14 | 2 | money
Rest to pay claim 1 | BasFaktRestK1 | ZtBaseCurrAmount | 14 | 2 | money
Rest to pay claim 2 | BasFaktRestK2 | ZtBaseCurrAmount | 14 | 2 | money
Rest to pay claim 3 | BasFaktRestK3 | ZtBaseCurrAmount | 14 | 2 | money
Rest to pay claim 4 | BasFaktRestK4 | ZtBaseCurrAmount | 14 | 2 | money
Due % | DueAmountPerc | ZtDecimal73 | 8 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Solvency date | FromInvoiceDate | ztDate |  |  | datetime
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Interest invoiced prev year | IntrstAmtPreYr | ZtBaseCurrAmount | 14 | 2 | money
Interest invoiced curr year | IntrstAmtThYr | ZtBaseCurrAmount | 14 | 2 | money
Date last reminder | Kravsenutskr | ztDate |  |  | datetime
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Paid-in previous year | KundInbPreYr | ZtBaseCurrAmount | 14 | 2 | money
Paid-in this year | KundInbThYr | ZtBaseCurrAmount | 14 | 2 | money
Credit limit | KundKredLim | ZtBaseCurrAmount | 14 | 2 | money
Turnover YTD | kundoms | ZtBaseCurrAmount | 14 | 2 | money
Turnover previous year | kundomsfa | ZtBaseCurrAmount | 14 | 2 | money
T-ov prev yr incl VAT/tax | KundOmsFaInklMoms | ZtBaseCurrAmount | 14 | 2 | money
T-ov curr yr incl VAT/tax | KundOmsInklMoms | ZtBaseCurrAmount | 14 | 2 | money
AR ledger balance | KundSaldo | ZtBaseCurrAmount | 14 | 2 | money
Additional time | NoAddCreditDays | ZtLong | 10 |  | int
Agreed credit time | NoAgrCreditDays | ZtLong | 10 |  | int
Real credit time | NoRealCreditDays | ZtLong | 10 |  | int
Order value | OrdSum | ZtBaseCurrAmount | 14 | 2 | money
Due% pay inv | OverDuePercent | ztFloat | 15 | 2 | float
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
demand 1 - % of SupLdgrBal | reminderperc1 | ZtDecimal73 | 8 | 2 | decimal
demand 2 - % of SupLdgrBal | reminderperc2 | ZtDecimal73 | 8 | 2 | decimal
demand 3 - % of SupLdgrBal | reminderperc3 | ZtDecimal73 | 8 | 2 | decimal
demand 4 - % of SupLdgrBal | reminderperc4 | ZtDecimal73 | 8 | 2 | decimal
collection - % of SupLdgrBal | reminderpercFCU | ZtDecimal73 | 8 | 2 | decimal
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar

    This table is the main table in the following programs:

    Program: kuss Log, customer solvency


Log, deleted and inserted template company rows (JvsPackageTemplateDiff)

Number of imported and deleted rows per table after an import of a template company in a package solution.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company Code | CompanyCode | ztInteger | 5 |  | smallint
Terms | Cond | ztBlob | 1 |  | varchar
Table name | JvsTableName | ztString | 128 |  | varchar
Number of deleted rows | nodeletedrows | ZtLong | 10 |  | int
Number of new rows | nonewrows | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Solution ID | SolutionID | ZtLong | 10 |  | int


Log, final posting PO (AccountsPayable_PO_2_GL)

Work table and log table covering posting of supplier invoices with linked purchase orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invc match, trans type GL | AP_PO_2_GL_TranType | ztInteger | 5 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Sequence no. | LrbhRadPos | ztInteger | 5 |  | int
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
UniqueIDInAKLT | UniqueIDInAKLT | ZtLong | 10 |  | int
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Voucher row text | VrVerText | ztString | 60 |  | varchar
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: AccountsPayable_PO_2_GL Log of invoice matching against PO


Log, invoicing of delivery note (ffhf)

Data on orders for collective invoicing by delivery note (ffh).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of days disp -> invoice | AntDagLev2Fakt | ztInteger | 3 |  | smallint
Payment terms | BetKod | ztString | 2 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Delivery note/disp no. | FfhNr | ZtLong | 10 |  | int
Del Note brk-down on coll inv | FFhNr_Bryt_SamlingsFakt | ZtLong | 10 |  | int
@zPrompt=null | FFhNr_SamFakt | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight documents | FraktHandlKod | ztBoolean |  |  | char
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Credit period days | KreditTid | ztInteger | 3 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Dispatched on, actual | OrdVerklLevDat | ztDate |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Collective invoicing | SamFaktUtskr | ztBoolean |  |  | char
Currency | ValKod | ztString | 3 |  | varchar
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: ffhf Log, invoicing of delivery note


Log; steps from importing site repository (LogImportJvsSite)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
JvsSite Import LogId | JvsSiteImportLogId | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SQL error message | SQLErrMsg | ztBlob | 1 |  | varchar
SQL error number | SQLErrNo | ZtLong | 10 |  | int
Identity | SQLIdentity | ZtLong | 10 |  | int
SQL statement | SQLStmtStr | ztBlob | 1 |  | varchar


Logical file record, eBrev (eblp)

Logical file record eBrev.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Unique ID eBrev | eb_komm_id | ztInteger | 5 |  | smallint
Unique ID Logic file | eb_uppdr_id | ztInteger | 5 |  | smallint
Destination eBrev | ebDestination | ztString | 10 |  | varchar
External reference | ebExtRef | ztString | 7 |  | varchar
Final record, eBrev | ebSlutPost | ztString | 4 |  | varchar
Start record eBrev | ebStartPost | ztString | 4 |  | varchar
Assignment ID eBrev | ebUppdragsId | ztString | 10 |  | varchar
Source eBrev | ebUrsprung | ztString | 10 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Logical page, eBrev (ebls)

Identity record - logical page.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Term | ColumnName | ztString | 40 |  | varchar
Unique ID logical page | eb_logsida_id | ztInteger | 5 |  | smallint
Page header interval | eb_sidhuvudintervall | ztInteger | 5 |  | smallint
Total last | eb_summering_sist | ztBoolean |  |  | char
Selective appendix | ebbilaga | ztInteger | 2 |  | smallint
Form call | ebblankett | ztString | 4 |  | varchar
Form following page | ebblankett_rader | ztString | 4 |  | varchar
Font control code | ebfont | ztchar | 1 |  | char
No. of copies | ebkopia | ztInteger | 2 |  | smallint
Horizontal position logo | ebLogoHP | ztInteger | 4 |  | smallint
Logo type | ebLogotyp | ztString | 6 |  | varchar
Vertical position Logo | ebLogoVP | ztInteger | 4 |  | smallint
Row control code | ebRad | ztchar | 1 |  | char
Rowcntrlcus row form | ebrad_radblankett | ztchar | 1 |  | char
Report object | ebrptobjekt | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Table name | jvstablename | ztString | 128 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Number rows following form | radantal_radblankett | ztInteger | 5 |  | smallint
Number rows sum | radantal_summering | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Overwrite sum rows | skrivover_summering | ztBoolean |  |  | char
Report program | yndreport | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: xebls Logic page, eBrev


Logical pages, eBrev (eblf)

Logical pages in specific logical file (assignment)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Unique ID logical page | eb_logsida_id | ztInteger | 5 |  | smallint
Unique ID Logic file | eb_uppdr_id | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Logins, Jeeves clients (jvsi)

Logins in Jeeves clients.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
DB login sign | DBLogInSign | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Program ID | JeevesPgmId | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
DB lib process ID | ProcIdDBLib | ZtLong | 10 |  | int
DB lib proc ID 1:a | ProcIdDBLibPgmId | ZtLong | 10 |  | int
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Process ID | spid | ZtLong | 5 |  | int
Process ID, pgm | spidpgm | ZtLong | 5 |  | int
Date/time | StrDateTime | ztString | 28 |  | varchar


Logo types, eBrev (eblt)

Table for definition of logos for eBrev.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Logo type | ebLogotyp | ztString | 6 |  | varchar
Logo type description | ebLogotypBeskr | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xeblt Logo types, eBrev


Macro (mcr)

Information on user defined macros created in Jeeves macro manager, including the programs and nodes they are called from.

Choose from personal/global: Yes
Per company: No

(This table replaces table Vmcr.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Code | code | ztBlob | 1 |  | text
Macro code | code_255char | ztBlob | 1 |  | text
Doc | doc | ztBlob | 1 |  | text
Group | Grupp | ztInteger | 4 |  | smallint
Name | Name | ztString | 60 |  | nvarchar
Program node | Node | ztString | 35 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Program | Pgm | ztString | 40 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: mcr Own macros


Macros (JvsSiteMcr)

Program/table for viewing and editing user defined macros created in Jeeves macro manager.

The program/table can be accessed through an embedded window in the program Setting dimensions/keys (jvssitenodewin) or from Jeeves' menu.

Note that the fields in the header show the program/node/window in which the setting applies, e.g. if a program is named in the Program field, the setting only applies if that program is open.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Code | code | ztBlob | 1 |  | text
Doc | doc | ztBlob | 1 |  | text
Macro | JvsSiteMacroName | ztString | 40 |  | nvarchar
Macro unique ID | JvsSiteMacroUniqueId | ztString | 40 |  | nvarchar
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Setting ID (orig) | JvsSiteNodeWinSettingsID_orig | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteMcr Macros


Mail list (mll)

E-mail list that covers a number of underlying address records.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | kortnotering | ztString | 255 |  | varchar
Mail list ID | maillista | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: mll Mailing lists


Mail profiles for dabasemail (SysMail_Profiles)

The identifier of the profile used to send the message.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Send if error | DBM_append_query_error | ztInteger | 1 |  | smallint
Query result to file | DBM_attach_query_result_as_file | ztInteger | 1 |  | smallint
Exclude query output | DBM_exclude_query_output | ztInteger | 1 |  | smallint
Mail profile description | DBM_profile_description | ztString | 256 |  | varchar
Mail profile id | DBM_profile_id | ztInteger | 5 |  | smallint
Mail profile name | DBM_profile_name | ztString | 256 |  | varchar
No truncate data | DBM_query_no_truncate | ztInteger | 5 |  | smallint
Query result header | DBM_query_result_header | ztInteger | 1 |  | smallint
Query result separator | DBM_query_result_separator | ztchar | 1 |  | char
Query result width | DBM_query_result_width | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: DbMailProfile Mail profiles for database mail


Mail reminder and escalation (wrem)

Unique identity of a row in the Workflow table (wrem).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Optional date | datadate1 | ztDateTime |  |  | datetime
Integer 1 | dataint1 | ztInteger | 5 |  | smallint
Integer 2 | dataint2 | ztInteger | 5 |  | smallint
Command | datavarchar1 | ztString | 255 |  | varchar
Activity | datavarchar2 | ztString | 255 |  | varchar
Date of return | DateOfReturn | ztDateTime |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Max no. mail | MailMaxNo | ztInteger | 5 |  | smallint
Mail per day | mailperdag | ztBoolean |  |  | char
Last sent | mailsendtime | ztDateTime |  |  | datetime
Mail status | mailstatus | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
E-mail signature | perssignEmail | ztString | 30 |  | varchar
perssignEmailSend | perssignEmailSend | ztString | 30 |  | varchar
E-mail address | perssignEmailSendAddress | ztString | 255 |  | varchar
Flow number | processidentifier | ZtLong | 9 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Reminder number | ReminderNo | ztInteger | 5 |  | smallint
Reminder Type | Remindertype | ztInteger | 5 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Unique ID activity instance | wpiadummyuniqueid | ztUniqueIdentifier | 50 |  | varchar
Unique ID (wrem) | wremdummyuniqueid | ztString | 50 |  | varchar


Manual inventory transactions (arsm)

Inventory changes caused by manual transactions such as scrapping and transfers between inventory locations. Inventory changes for integrated routines (order, purchase order, MPC etc.) are done in a respective routine.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Cost price at order | ArtKalkPrisO | ZtBaseCurrAmount | 14 | 2 | money
Average cost price | ArtKalkSnitt | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Use/Best before | BastForeDatum | ztDate |  |  | datetime
Batch no. | BatchId | ztString | 30 |  | varchar
Delivery note date, rcv | BestFoljesedelsDat | ztDate |  |  | datetime
Delivery note no., rcv | BestFoljesedelsNr | ztString | 30 |  | varchar
Purchase price | BestInPris | ZtBaseCurrAmount | 14 | 2 | money
Accounting date | BokfDat | ztDate |  |  | datetime
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Linked to expenses... | ConnExDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Changed inventory value | DiffLagVarde | ZtBaseCurrAmount | 14 | 2 | money
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Manual posting OK | FarKonterasManuellt | ztBoolean |  |  | char
Delivery note date | FfhDate | ztDate |  |  | datetime
Delivery note/disp no. | FfhNr | ZtLong | 10 |  | int
Delivery note no. (alpha) | FfhNrAlfa | ztString | 30 |  | varchar
RowNo | FfhRadNr | ztInteger | 5 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Flytta fr batch nr | FromBatchId | ztString | 30 |  | varchar
Flytta från hylla | FromLagPlats | ztBinLocation | 20 |  | varchar
Flytta fr lag.ställe nr | FromLagStalle | ztString | 2 |  | varchar
Reason code | FsOrsakKod | ztInteger | 5 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
To receive, blocked inventory | InLevAntalSparrat | ZtQty | 14 | 2 | decimal
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Purch price curr | InValuta | ztString | 3 |  | varchar
Invtry transaction journal no | JlJournNr | ZtLong | 6 |  | int
Assembly journ no. | JournNrIULT | ZtLong | 5 |  | int
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Average weighted | KalkylPrisEnlSnittPris | ztBoolean |  |  | char
To be posted | Konteras | ztBoolean |  |  | char
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
Corr reserv qty | KorrAntalUt | ZtQty | 14 | 2 | decimal
Note | KortNotering | ztString | 255 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Inventory location type | LagStTyp | ztInteger | 2 |  | smallint
Invtry trans qty (+/-) | LagTransAntal | ZtQty | 14 | 2 | decimal
Quantity, alt unit (+/-) | LagtransAntAltEnh | ZtQty | 14 | 2 | decimal
Transaction date | LagTransDatum | ztDate |  |  | datetime
Received quantity | LagTransInlev | ZtQty | 14 | 2 | decimal
Received qty, alt unit | LagTransInlevAltEnh | ZtQty | 14 | 2 | decimal
Invtry trans. origin | LagTransSource | ztInteger | 3 |  | smallint
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Dispatched quantity | LagTransUtlev | ZtQty | 14 | 2 | decimal
Dispatched qty, alt unit | LagTransUtlevAltEnh | ZtQty | 14 | 2 | decimal
To dispatch, blocked | LevAntalSparrat | ZtQty | 14 | 2 | decimal
Print cust no. | LtFtgNr | ztBoolean |  |  | char
Invtry trans journal no. | LthJournNr | ZtLong | 6 |  | int
FIFO | Mark_FIFO | ztBoolean |  |  | char
LIFO | Mark_LIFO | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Actual mtrl cost (adjust) | MtrlVerklKostJustering | ZtBaseCurrAmount | 14 | 2 | money
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order no. (alpha) | OrderNrAlfa | ztString | 50 |  | varchar
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdradNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Print date | P_Utskr_Dat | ztDate |  |  | datetime
Lot handling | PartiHantering | ztBoolean |  |  | char
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Rec delivery from WMS | RecDelivFromWMS | ztBoolean |  |  | char
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Ent journal alpha ID | RegJournalLagerAlfaId | ztString | 30 |  | varchar
Ent.journal inventory code | RegJournalLagerKod | ztInteger | 5 |  | smallint
Ent.journ no., inv trans | RegJournalLagerNr | ZtLong | 9 |  | int
Ent.journ type, inv trans | RegJournalLagerTyp | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Serv.order no | ServOrderNr | Jeeves_SONo | 9 |  | bigint
Order row, service | ServOrdRadNr | ztInteger | 5 |  | int
Historical cost invc row | StatistikRadKostnad | ZtBaseCurrAmount | 14 | 2 | money
Date/time | StrDateTime | ztString | 28 |  | varchar
To batch | TillBatchId | ztString | 30 |  | varchar
To inventory location | TillLagStalle | ztString | 2 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Purchase price incl tax | Vb_InPrisInklMoms | ztMoney | 14 | 2 | money
Cost price, curr | VbKalkPris | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint
Statuskod på rad | VrStMark | ztInteger | 2 |  | smallint
Transfer date | VtVrUpDat | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: Arsm2GL Manual inventory transactions->GL

    Program: xArsm Manual inventory transactions


Manual inventory transactions, entry journal (ArsmH)

Posting journal for manual inventory transactions.
A voucher is created for each journal.
If a manual inventory transaction is not given a voucher number when run from the arsm table, possibly due to an error in the integration details, you can re-run the update of the inventory journal from here (report b) once the error has been rectified.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Invtry transaction journal no | JlJournNr | ZtLong | 6 |  | int
Journal status | JournalStatusKod | ztInteger | 2 |  | smallint
Comments | Kommentar | ztBlob | 1 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Transaction date | LagTransDatum | ztDate |  |  | datetime
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Received by signature | MottagetAvSign | ztString | 50 |  | varchar
Received date | MottagetDatum | ztDate |  |  | datetime
Inventory supervisor, receiver | MottLagerAnsvSign | ztString | 6 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Ent journal alpha ID | RegJournalLagerAlfaId | ztString | 30 |  | varchar
Ent.journal inventory code | RegJournalLagerKod | ztInteger | 5 |  | smallint
Ent.journ no., inv trans | RegJournalLagerNr | ZtLong | 9 |  | int
Ent.journ type, inv trans | RegJournalLagerTyp | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
To inventory location | TillLagStalle | ztString | 2 |  | varchar
Inventory supervisor, issuer | UtfLagerAnsvSign | ztString | 6 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Transfer date | VtVrUpdat | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: ArsfH Inventory transfers, entry journal

    Program: ArsmH Manual inventory transactions, entry journal


Manual scanned invoice (pmlr)

Manual entry, scanned invoice Not currently used

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Document type no. | documenttype | ZtLong | 5 |  | int
File/dir | DokDir | ztString | 255 |  | varchar
File name | Filename | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Unique ID | pmlrid | ztString | 21 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Text/info | x255 | ztString | 255 |  | varchar
Text/info | x255_2 | ztString | 255 |  | varchar


Manufacturing claims (tork)

Claims and opinions about manufacturing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity to manufacture | AntalAttTillverka | ZtQty | 14 | 2 | decimal
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Revision date | ArtRevDat | ztDate |  |  | datetime
Revision no. | ArtRevId | ztString | 10 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Department | AvdelningsBeskr | ztString | 50 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Actual finish date | ClaimActEndDt | ztDate |  |  | datetime
Activity status | ClaimActivityStatus | ztInteger | 4 |  | smallint
Claimed actual qty | ClaimActQty | ZtQty | 14 | 2 | decimal
Claim expense | ClaimCostTotal | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 1 | ClaimCostType1 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 2 | ClaimCostType2 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 3 | ClaimCostType3 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 4 | ClaimCostType4 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 5 | ClaimCostType5 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 6 | ClaimCostType6 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 7 | ClaimCostType7 | ZtBaseCurrAmount | 14 | 2 | money
Claim | ClaimNo | ZtLong | 10 |  | int
Counterpart claim number | ClaimNoCounterPart | ztString | 30 |  | varchar
Planned finish date | ClaimPlEndDt | ztDate |  |  | datetime
Claimed quantity | ClaimQty | ZtQty | 14 | 2 | decimal
Revised quantity | ClaimRepairQty | ZtQty | 14 | 2 | decimal
Claim manager | ClaimResp | ztString | 8 |  | varchar
Scrapped qty | ClaimScrapQty | ZtQty | 14 | 2 | decimal
Claim origination | ClaimSrcCd | ztInteger | 5 |  | smallint
Claim origination | ClaimSrcDescr | ztString | 60 |  | varchar
Activity order | ClaimWFSeqNo | ztInteger | 5 |  | smallint
Claim flow | ClaimWorkFlow | ZtLong | 10 |  | int
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Planned activity descr | EventNote | ztString | 60 |  | varchar
Report date | EventRpDat | ztDate |  |  | datetime
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Foreman area | FormansOmrade | ztString | 6 |  | varchar
Foreman area | FormansOmradeB | ztString | 50 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Item no. required | MrArtNr | ztString | 30 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Price | Pris | ZtBaseCurrAmount | 14 | 2 | money
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Quality Categori (MO/PO/SO) | Qkategori | ztInteger | 5 |  | smallint
Quality to do no. | QualityCheckToDo_No | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
RMA number | RMAnr | ztString | 30 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Delivery received date | TiInlevDat | ztDate |  |  | datetime
Manuf.claim reason | TillvReklamationOrsak | ztInteger | 5 |  | smallint
Manuf.claim reason group | TillvReklamationOrsakGrp | ztInteger | 5 |  | smallint
Reported mfg qty | TiRappAnt | ZtQty | 14 | 2 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: rTorkAr Claims, item, date

    Program: rTorkArO Claims, item, reason

    Program: rTorkOAr Claim reason, item

    Program: rTorkTi Claims, MO

    Program: tork Manufacturing claims


Manufacturing group definition (WMS_ManufGroupDef)

Connection of manufacturing groups to production MHA(s), defining to which MHA picked material should be delivered for each relevant manufacturing group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Lead time, pick before | ManufPickBeforeDays | ztInteger | 3 |  | smallint
MHA | Mha | ztString | 5 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_ManufGroupDef Manufacturing group definition


Manufacturing groups (pg)

Manufacturing groups in manufacturing with production and cost data.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Acc start date | AckFromDatum | ztDate |  |  | datetime
No. of machines | AntMaskiner | ztFloat | 6 | 2 | float
Aut. reported | AoDummyRapp | ztBoolean |  |  | char
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
This field is used in the table as follows: |
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
This field is used in the table as follows: |
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
This field is used in the table as follows: |
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
This field is used in the table as follows: |
Show operation | AoVisas | ztBoolean |  |  | char
Work group | ArbetsLag | ztString | 6 |  | varchar
Product acct, labour | ArbProdKonto | ztString | 8 |  | varchar
Worked hrs/day | ArbTimPerDag | ZtDecimal73 | 8 | 2 | decimal
Product acct | ArtProdKonto | ztString | 8 |  | varchar
This field is used in the table as follows: |
Autom inleverans | AutInlev | ztBoolean |  |  | char
Auto receiving type | AutInlevTyp | ztInteger | 5 |  | smallint
Autom mtrl.uttag | AutMtrlUttag | ztBoolean |  |  | char
Auto mtrl issue type | AutMtrlUttagTyp | ztInteger | 5 |  | smallint
Workload against ceiling | BelaggningMotTak | ztBoolean |  |  | char
Bottleneck priority | BNeckPrio | ztInteger | 5 |  | smallint
Color code (hex) | ColorCodeJPS | ztString | 6 |  | varchar
Copy to op no | CopyUpToOpNr | ztInteger | 5 |  | smallint
Copy with op text | CopyUpUseDescr | ztString | 40 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Extra days for recvd delivery | ExtraDagarInlev | ztInteger | 5 |  | smallint
Flera operationer samtidigt | FleraOpSamtidigt | ztBoolean |  |  | char
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Allocate time to people | FordelaTidPaPersoner | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Foreman area | FormansOmrade | ztString | 6 |  | varchar
Horizontal freeze re-planning | FreezeHorizonDaysRePlan | ztInteger | 5 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Reg tool for op | GoDown2Tools | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
InputUnitTimeType | InputUnitTimeType | ztInteger | 5 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Scrap degree/op | KassOp | ztFloat | 5 | 2 | float
Queue time | KoTid | ztFloat | 15 | 2 | float
Lead time material | LeadTimeMtrlOnOp | ztInteger | 5 |  | smallint
Manufacturing resource ID | ManufRes_Id | ZtLong | 10 |  | int
Subcontract flag | MarkLego | ztBoolean |  |  | char
MO% markup mtrl mfg | MoProcMtrlTillv | ZtDecimal73 | 8 | 3 | decimal
New cost as of date | NewCostsFromDate | ztDate |  |  | datetime
Personnel/operation | OpBemanning | ztFloat | 6 | 3 | float
Personnel/operation, setup | OpBemanningStall | ztFloat | 6 | 3 | float
Personnel/operation, ext setup | OpBemanningYttreStall | ztFloat | 6 | 3 | float
Operation text ID | OperationsTextNr | ztInteger | 4 |  | smallint
Operation split | OpSplitt | ztFloat | 15 | 2 | float
Pay-Roll Type | PayRollType | ztString | 8 |  | varchar
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Fixed labour OH cost | ProdGrArbOmkFast | ZtBaseCurrAmount | 14 | 2 | money
Fixed labour OH cost (new) | ProdGrArbOmkFastNytt | ZtBaseCurrAmount | 14 | 2 | money
Var labour OH cost | ProdGrArbOmkRorl | ZtBaseCurrAmount | 14 | 2 | money
Var labour OH cost (new) | ProdGrArbOmkRorlNytt | ZtBaseCurrAmount | 14 | 2 | money
Depreciation | ProdGrAvskrKost | ZtBaseCurrAmount | 14 | 2 | money
Depreciation (new) | ProdGrAvskrKostNYTT | ZtBaseCurrAmount | 14 | 2 | money
Manufacturing group | ProdGrBen | ztString | 30 |  | varchar
Fixed hourly rate | ProdGrFastKost | ZtBaseCurrAmount | 14 | 2 | money
Fixed hourly rate (new) | ProdGrFastKostNYTT | ZtBaseCurrAmount | 14 | 2 | money
Mfg grp subcontr OH % | ProdGrLegoOmkP | ztFloat | 6 | 2 | float
Mfg grp OH/operation | ProdGrOmkPerOp | ZtBaseCurrAmount | 14 | 2 | money
Mfg grp OH/op (new) | ProdGrOmkPerOpNytt | ZtBaseCurrAmount | 14 | 2 | money
Var hourly rate | ProdGrRorlKost | ZtBaseCurrAmount | 14 | 2 | money
Var hourly rate (new) | ProdGrRorlKostNYTT | ZtBaseCurrAmount | 14 | 2 | money
Mfg grp avail % | ProdGrTillgProc | ZtDecimal73 | 7 | 2 | decimal
Product area | ProduktOmrade | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Ställtid för op (tot) | SumStallTid | ztOpTime | 9 | 4 | float
Stycktid (tot) | SumStyckTid | ztOpTime | 9 | 4 | float
Total capacity | TotCapacity | ZtLong | 10 |  | int
Trång sektor | TrangSektor | ztBoolean |  |  | char
Update all op | UpdatAvvik | ztBoolean |  |  | char
Incl scrapped mtrl | UpDatAvvikMru | ztBoolean |  |  | char
Update workload ... | UpdateWorkLoadTable | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: pg Manufacturing groups

    Program: pg_NE Manufacturing groups, MRP workload


Manufacturing groups (view) (vpg)

Information about manufacturing groups.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of machines | AntMaskiner | ztFloat | 6 | 2 | float
Aut. reported | AoDummyRapp | ztBoolean |  |  | char
Show operation | AoVisas | ztBoolean |  |  | char
Product acct, labour | ArbProdKonto | ztString | 8 |  | varchar
Autom inleverans | AutInlev | ztBoolean |  |  | char
Autom mtrl.uttag | AutMtrlUttag | ztBoolean |  |  | char
Auto mtrl issue type | AutMtrlUttagTyp | ztInteger | 5 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
Flera operationer samtidigt | FleraOpSamtidigt | ztBoolean |  |  | char
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Scrap degree/op | KassOp | ztFloat | 5 | 2 | float
Queue time | KoTid | ztFloat | 15 | 2 | float
Subcontract flag | MarkLego | ztBoolean |  |  | char
New cost as of date | NewCostsFromDate | ztDate |  |  | datetime
Personnel/operation | OpBemanning | ztFloat | 6 | 3 | float
Personnel/operation, setup | OpBemanningStall | ztFloat | 6 | 3 | float
Operation split | OpSplitt | ztFloat | 15 | 2 | float
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Fixed labour OH cost | ProdGrArbOmkFast | ZtBaseCurrAmount | 14 | 2 | money
Fixed labour OH cost (new) | ProdGrArbOmkFastNytt | ZtBaseCurrAmount | 14 | 2 | money
Var labour OH cost | ProdGrArbOmkRorl | ZtBaseCurrAmount | 14 | 2 | money
Var labour OH cost (new) | ProdGrArbOmkRorlNytt | ZtBaseCurrAmount | 14 | 2 | money
Depreciation | ProdGrAvskrKost | ZtBaseCurrAmount | 14 | 2 | money
Depreciation (new) | ProdGrAvskrKostNYTT | ZtBaseCurrAmount | 14 | 2 | money
Manufacturing group | ProdGrBen | ztString | 30 |  | varchar
Fixed hourly rate | ProdGrFastKost | ZtBaseCurrAmount | 14 | 2 | money
Fixed hourly rate (new) | ProdGrFastKostNYTT | ZtBaseCurrAmount | 14 | 2 | money
Mfg grp subcontr OH % | ProdGrLegoOmkP | ztFloat | 6 | 2 | float
Mfg grp OH/operation | ProdGrOmkPerOp | ZtBaseCurrAmount | 14 | 2 | money
Mfg grp OH/op (new) | ProdGrOmkPerOpNytt | ZtBaseCurrAmount | 14 | 2 | money
Var hourly rate | ProdGrRorlKost | ZtBaseCurrAmount | 14 | 2 | money
Var hourly rate (new) | ProdGrRorlKostNYTT | ZtBaseCurrAmount | 14 | 2 | money
Mfg grp avail % | ProdGrTillgProc | ZtDecimal73 | 7 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Trång sektor | TrangSektor | ztBoolean |  |  | char


Manufacturing groups, calculation (pgk)

Manufacturing groups.
Calculations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Calculation version no. | ArkVersion | ZtLong | 4 |  | int
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calculation item | KalkArtNr | ztString | 30 |  | varchar
Calculation on quantity | KalkylPaAntal | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Total fixed labour OH | TotArbOmkFast | ZtCost | 16 | 6 | float
Labour OH op/total | TotArbOmkOp | ZtCost | 16 | 6 | float
Var OH labour total | TotArbOmkRorl | ZtCost | 16 | 6 | float
Total setup overhead | TotArbOmkStall | ZtCost | 16 | 6 | float
Total indir subcontr costs | TotLegoBiKost | ZtCost | 16 | 6 | float
Total subcontract cost | TotLegoKost | ZtCost | 16 | 6 | float
Mfg grp depr total | TotPgAvskrKost | ZtCost | 16 | 6 | float
Mfg grp fixed rate tot | TotPgFastKost | ZtCost | 16 | 6 | float
Mfg grp var cost total | TotPgRorlKost | ZtCost | 16 | 6 | float
Mfg grp setup cost | TotPgStallKost | ZtCost | 16 | 6 | float


Manufacturing groups, workload, day (pgbd)

Workload per day per manufacturing group.
This is a total of workload per manufacturing group and day for each labour operation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Workload alloc date | DatumBelaggning | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float

    This table is the main table in the following programs:

    Program: pgbd Workload from mfg group, by day


Manufacturing order header (th)

Data in the manufacturing order header.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Quantity to manufacture | AntalAttTillverka | ZtQty | 14 | 2 | decimal
No. unprocessed purch | AntMtrlKopEjBeh | ZtLong | 10 |  | int
MO type | AoKod | ztInteger | 2 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
MO number series | AoNrSerie | ztInteger | 5 |  | smallint
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Operations end date | AoSlutDat | ztDate |  |  | datetime
Slutdat/tid (JPS) | AoSlutDatTid | ztDateTime |  |  | datetime
Final report date | AoSlutMarkDat | ztDate |  |  | datetime
Operations start date | AoStartDat | ztDate |  |  | datetime
Startdatum/tid (JPS) | AoStartDatTid | ztDateTime |  |  | datetime
MO/Works order status | AoStatKod | ztInteger | 1 |  | smallint
Original ops end date | AoUrsprSlutDat | ztDate |  |  | datetime
Worked hours | ArbetadeTimmmar | ztHourWithDecimals | 8 | 2 | decimal
CalcCost labour/op | ArbKalkArbKost | ZtBaseCurrAmount | 14 | 2 | money
Calc setup cost | ArbKalkStallKost | ZtBaseCurrAmount | 14 | 2 | money
Actual labour cost | ArbVerklArbKost | ZtBaseCurrAmount | 14 | 2 | money
Actual setup cost | ArbVerklStallKost | ZtBaseCurrAmount | 14 | 2 | money
Item description | ArtBeskr | ztString | 30 |  | varchar
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Revision no. | ArtRevId | ztString | 10 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Serienr from | ArtSerieNrFrom | ztString | 30 |  | varchar
T.o.m. serienr | ArtSerieNrTom | ztString | 30 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Workload type | BelaggningsKod | ztInteger | 2 |  | smallint
Delivery note date, rcv | BestFoljesedelsDat | ztDate |  |  | datetime
Delivery note no., rcv | BestFoljesedelsNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Purch order no. (alpha) | BestNrAlfa | ztString | 50 |  | varchar
Confirmed date | BestOEDatum | ztDate |  |  | datetime
Availability check date | BristKontrolleradDatum | ztDate |  |  | datetime
Avail check status code | BristKontrolleradStatus | ztInteger | 5 |  | smallint
Partial booking allowed | DelBokningTillaten | ztInteger | 5 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
New MO/flow grp on explosion | EgenThFlgVidVidareNedbr | ztBoolean |  |  | char
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Körtid, skapa arbetsorder | ExecutionTimeCreateWO | ztFloat | 15 | 2 | float
Completely received | FardigInlev | ztBoolean |  |  | char
Ready date | FardigInlevDatum | ztDate |  |  | datetime
Est delivery value | FkalkInlevVarde | ZtBaseCurrAmount | 14 | 2 | money
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Reason code | FsOrsakKod | ztInteger | 5 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Throughput time | GenomLoppsTid | ztFloat | 8 | 2 | float
Throughput time adj | GenomLoppsTidJust | ztFloat | 8 | 2 | float
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Receiving value | InlevKalkVarde | ZtBaseCurrAmount | 14 | 2 | money
Calc val rcvd mtrl | InlevKalkVardeMtrl | ZtBaseCurrAmount | 14 | 2 | money
Capacity status | KapacitetsStatus | ztInteger | 5 |  | smallint
CO specific CC (rec) | KBarOULager | ztString | 8 |  | varchar
KörID | KorId | ZtLong | 10 |  | int
Queue time | KoTid | ztFloat | 15 | 2 | float
Orderspec rcv CC | KstOULager | ztString | 8 |  | varchar
WIP CC | KstPIA | ztString | 8 |  | varchar
CC manufacturing diff | KstTillvDiff | ztString | 8 |  | varchar
Orderspec rcv account | KtoNrOULager | ztString | 8 |  | varchar
WIP account | KtoNrPIA | ztString | 8 |  | varchar
Acct manufacturing diff | KtoNrTillvDiff | ztString | 8 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Lead time adj | LedTidJust | ztInteger | 3 |  | smallint
All positions same date | MarkIfAllTi2ThStartDate | ztBoolean |  |  | char
Multiple flow groups | MarkIfMultiFlowGroups | ztBoolean |  |  | char
Tot pos lead time->MO | MarkIfTi2ThLedTid | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Calc mtrl cost | MtrlKalkKost | ZtBaseCurrAmount | 14 | 2 | money
Actual material cost | MtrlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (refinement) | MtrlVerklKostForadling | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (mtrl) | MtrlVerklKostMtrl | ZtBaseCurrAmount | 14 | 2 | money
Pick flag date | OkAttPlockaSattDatum | ztDate |  |  | datetime
Pick status | OkAttPlockaStatus | ztInteger | 5 |  | smallint
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Booking status | OrdBokningsStatus | ztInteger | 5 |  | smallint
Order date | OrdDatum | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order no. (alpha) | OrderNrAlfa | ztString | 50 |  | varchar
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Order value | OrdSum | ZtBaseCurrAmount | 14 | 2 | money
Order spec text | OrpRadText | ztString | 255 |  | varchar
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Picking list date | PlUtskrDat | ztDateTime |  |  | datetime
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Spare part order | ReservdelsOrder | ztBoolean |  |  | char
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Joint purchase (allowed) | SamInKopMark | ztBoolean |  |  | char
Send: Delivered | SendDeliv | ztBoolean |  |  | char
Deliv notification date | SendDelivDoneDT | ztDateTime |  |  | datetime
Skrivskydd | SkrivUtskSk | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Start av updatering/insert | SqlStmtStartedDT | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Start dag i veckan | StartVeckoDag | ztInteger | 1 |  | smallint
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Est product cost | ThBerKalkr | ZtBaseCurrAmount | 14 | 2 | money
Order description | ThBeskr | ztString | 35 |  | varchar
Work order printed | ThUtskrDat | ztDateTime |  |  | datetime
Actual cost | ThVerKalk | ZtBaseCurrAmount | 14 | 2 | money
Mfg cost diff | TillvVinst | ZtBaseCurrAmount | 14 | 2 | money
Mtrl/op created on | TiNedbrutenDatum | ztDateTime |  |  | datetime
Ready date | TiSlutDat | ztDate |  |  | datetime
Start date | TiStartDat | ztDate |  |  | datetime
OK to use tool | ToolOkToUse | ztBoolean |  |  | char
Reprint purch order | UtskrBestDokSkaGoras | ztBoolean |  |  | char
New PO print date | UtskrBestDokUtskrDT | ztDateTime |  |  | datetime
Print order acknowl | UtskrDokLovSkaGoras | ztBoolean |  |  | char
Print date new OA | UtskrDokLovUtskrDT | ztDateTime |  |  | datetime
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
MO/Works order status | WoUserStatus | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: Bia2Ti Single MO from requisition

    Program: MoLR_MO Labour reporting, order/mfg.group checked

    Program: Mru1 Mtrl issues, labour and rec deliveries

    Program: ThTii Received deliveries, MO

    Program: ThTiiS Received deliveries, MO

    Program: Xth Manufacturing orders

    Program: XthS Manufacturing order, customer specific

    Program: xThX Mfg/works order header entry


Manufacturing order, header (alloc) (fth)

Used for the allocation of reported time per flow group.
Contains one record per manufacturing order header.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Report auto setup time | AoRappStallTid_Aut | ztOpTime | 9 | 4 | float
Report man. setup time | AoRappStallTid_Man | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Rep auto run time | AoRappStyckTid_Aut | ztOpTime | 9 | 4 | float
Rep manual run time | AoRappStyckTid_Man | ztOpTime | 9 | 4 | float
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float


Manufacturing order, subcontract (MOSubcontract)

Manufacturing order, subcontract.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Delivery note/disp no. | FfhNr | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Sequence no. | MOSubcontractSeqNo | ZtLong | 6 |  | int
Operation no. | OpNr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: MOSubcontract Manufacturing order, subcontract


Manufacturing priority own subcontr (xtel)

Code for controlling if the labour operation will be performed in-house or at a subcontractor.
This code is used for graphical planning where different colors can be used for the priority code.
0 = performed in-house as first choice
1 = in-house or subcontract
2 = subcontract as first choice During periods of overload, 1 and 2 are sent to a subcontractor (and even 0).
If the workshop is working below capacity 0 and 1 are performed in-house (and even 2).
The idea is that when there is an overload of work you will be able to see if work can be subcontracted. An overload when the code is 1 or 2 can most likely be solved by subcontracting.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
In-house or subcontract | TillvPriorEgenLego | ztInteger | 5 |  | smallint
Egen eller lego | TillvPriorEgenLegoB | ztString | 40 |  | varchar


Manufacturing reporting person (SFR_AoP)

Reported mantime.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Work group | arbetslag | ztString | 6 |  | varchar
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | perssign2 | ztString | 6 |  | varchar
Rep no. minutes | RappAntalMinuter | ZtLong | 10 |  | int
Rep manhours manufacturing | RappMantidtillverkning | ztOpTime | 9 | 4 | float
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Calculation priority | SFRCalcPrio | ztInteger | 5 |  | smallint
Ref to table SFRAo | sfrconnaoid | ZtLong | 10 |  | int
Ref to parent table | SFRConnSQLIdentity | ZtLong | 10 |  | int
Ref to parent table | SFRConnSQLIdentity2 | ZtLong | 10 |  | int
Manually created | sfrmancreated | ztBoolean |  |  | char
Reportingtype SFR | SFRRepType | ztInteger | 5 |  | smallint
Status | SFRStatus | ZtLong | 10 |  | int
Stamp time | SFRWORepDat | ztDateTime |  |  | datetime
End stamp time | SFRWORepEndDt | ztDateTime |  |  | datetime
Start Stamptime | SFRWORepStartDt | ztDateTime |  |  | datetime
Status | SFRWOStatus | ztInteger | 5 |  | smallint
Identity | SQLIdentity | ZtLong | 10 |  | int
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: SFR_AoP Manufacturing report, mantime


Manufacturing reporting quantity (SFR_AoQ)

Reported quantity.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Scrapped qty | AoRappKassant | ZtQty | 14 | 2 | decimal
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Return/scrap reason | KassOrsakskod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | perssign2 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Ref to table SFRAo | sfrconnaoid | ZtLong | 10 |  | int
Manually created | sfrmancreated | ztBoolean |  |  | char
Reportingtype SFR | SFRRepType | ztInteger | 5 |  | smallint
Stamp time | SFRWORepDat | ztDateTime |  |  | datetime
Identity | SQLIdentity | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: SFR_AoQ Manufactoring report, quantity


Manufacturing resources (ManufRes)

Definition of resources in manufacturing with links to current work time schedule. This can be for machines, workshop personnel or other resources. Definition is used (introduced in Version 9) from the function for workload ceiling.

For new setups of production groups and work load, a manufacturing resource is created automatically with the next available resource number and the same name as the production group/workload. The definition only needs to be completed with a group schedule.

For production groups and work loads that already exist, the definition must be made manually by right-clicking on this program.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Work group | ArbetsLag | ztString | 6 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Manufacturing resource | ManufRes_Descr | ztString | 60 |  | varchar
Manufacturing resource ID | ManufRes_Id | ZtLong | 10 |  | int
Type of resource | ManufRes_Type | ztInteger | 5 |  | smallint
Maskin | MaskinID | ztString | 16 |  | varchar
Passed time, limit | Passed_Time_Date | ztDateTime |  |  | datetime
Passed time, rule | Passed_Time_Rule | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Group schedule | vegruppschema | ztInteger | 5 |  | smallint
WL_Log_Accum_Time | WL_Log_Accum_Time | ZtHugeInt | 20 |  | bigint
WL_Log_Upd_Ack_Times | WL_Log_Upd_Ack_Times | ZtLong | 10 |  | int
WL_Log_Upd_LW_Times | WL_Log_Upd_LW_Times | ZtLong | 10 |  | int
WL_Log_Upd_Times | WL_Log_Upd_Times | ZtLong | 10 |  | int
Aktuella värden t o m datum | Workload_DateLimit_LV | ztDate |  |  | datetime
Ej aktuella värden | Workload_DirtyValues | ztInteger | 5 |  | smallint
Aktuella värden antal dagar | Workload_NoOfDays_LV | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: ManufRes Manufacturing resources


Mapping configurator from Jeeves, details (XmlOutMappingRows)

Mapping of xml out of Jeeves (Details table.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Name of part | ChildPartName | ztString | 255 |  | varchar
Description | Description | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Name of column | JvsColumnName | ztString | 128 |  | varchar
Init/default value | JvsInitValue | ztString | 255 |  | varchar
Table name | JvsTableName | ztString | 128 |  | varchar
Multiple hits | ManyHits | ztBoolean |  |  | char
Configurator model ID | ModelId | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sort order | SortOrder | ztInteger | 5 |  | smallint
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Table grouping | TableGroupOrder | ztInteger | 5 |  | smallint
Attribute type | TactonAttrType | ztString | 50 |  | varchar
Name of configurator table | TactonTableName | ztString | 255 |  | varchar
Tag condition | TactonTagCondition | ztBlob | 1 |  | varchar
Tag name | TactonTagName | ztString | 255 |  | varchar
Only update | UpdateNoInsert | ztBoolean |  |  | char
Nodetype | XmlNodeType | ztInteger | 5 |  | smallint
Root part | XmlRootPath | ztString | 255 |  | varchar
XPath | XmlXPath | ztString | 1024 |  | varchar

    This table is the main table in the following programs:

    Program: XmlOutMappingRows Mapping configurator from Jeeves, details


Mapping configurator out from Jeeves (XmlOutMapping)

Mapping of xml-messages out of Jeeves. (Header table.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Description | Description | ztString | 255 |  | varchar
Document ID | DocId | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Configurator model ID | ModelId | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Template Id | TactonTemplateId | ztString | 60 |  | varchar
File path to XML file | TactonXmlFilePath | ztString | 255 |  | varchar
Path in XML file | TactonXmlPath | ztString | 255 |  | varchar
XML document | XmlDoc | ztBlob | 1 |  | varchar
XML document 1 | XmlDocParse1 | ztBlob | 1 |  | varchar
XML document 2 | XmlDocParse2 | ztBlob | 1 |  | varchar
State of configuration | XmlState | ztBlob | 1 |  | varchar
State of configuration | XmlState1 | ztBlob | 1 |  | varchar
XML Type | XmlType | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: XmlOutMapping Mapping configurator from Jeeves


Mapping configurator to Jeeves (TactonMapping)

Main table for:

- mapping models, created in Tacton studio, to Jeeves tables (part of the Sales configuration functionality)

- mapping incoming XML messages from Astro (part of the Astro integration functionality)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | int
Description | Description | ztString | 255 |  | varchar
Document ID | DocId | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Configurator model ID | ModelId | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Send Error | SendError | ztBoolean |  |  | char
Send OK | SendOk | ztBoolean |  |  | char
Template Id | TactonTemplateId | ztString | 60 |  | varchar
File path to XML file | TactonXmlFilePath | ztString | 255 |  | varchar
Path in XML file | TactonXmlPath | ztString | 255 |  | varchar
XML document | XmlDoc | ztBlob | 1 |  | varchar
XML document 1 | XmlDocParse1 | ztBlob | 1 |  | varchar
XML document 2 | XmlDocParse2 | ztBlob | 1 |  | varchar
State of configuration | XmlState | ztBlob | 1 |  | varchar
State of configuration | XmlState1 | ztBlob | 1 |  | varchar
XML Type | XmlType | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: TactonMapping Mapping configurator to Jeeves


Mapping configurator to Jeeves (TactonMapping_Template)

Mapping of models, created in Tacton studio, to Jeeves tables. (Header table.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Description | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Template Id | TactonTemplateId | ztString | 60 |  | varchar

    This table is the main table in the following programs:

    Program: TactonMapping_Template Template for Mapping configurator to Jeeves


Mapping configurator to Jeeves, details (TactonMappingRows)

Mapping of models, created in Tacton studio, to Jeeves tables. (Details table.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | int
Name of part | ChildPartName | ztString | 255 |  | varchar
Description | Description | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Name of column | JvsColumnName | ztString | 128 |  | varchar
Init/default value | JvsInitValue | ztString | 255 |  | varchar
Table name | JvsTableName | ztString | 128 |  | varchar
Configurator model ID | ModelId | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sort order | SortOrder | ztInteger | 5 |  | smallint
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Table grouping | TableGroupOrder | ztInteger | 5 |  | smallint
Attribute type | TactonAttrType | ztString | 50 |  | varchar
Name of configurator table | TactonTableName | ztString | 255 |  | varchar
Tag condition | TactonTagCondition | ztBlob | 1 |  | varchar
Tag name | TactonTagName | ztString | 255 |  | varchar
Only update | UpdateNoInsert | ztBoolean |  |  | char
Nodetype | XmlNodeType | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: TactonMappingRows Mapping configurator to Jeeves, details


Mapping configurator to Jeeves, details (TactonMappingRows_template)

Mapping of models, created in Tacton studio, to Jeeves tables. (Details table.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Description | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Name of column | JvsColumnName | ztString | 128 |  | varchar
Init/default value | JvsInitValue | ztString | 255 |  | varchar
Table name | JvsTableName | ztString | 128 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Table grouping | TableGroupOrder | ztInteger | 5 |  | smallint
Attribute type | TactonAttrType | ztString | 50 |  | varchar
Name of configurator table | TactonTableName | ztString | 255 |  | varchar
Tag condition | TactonTagCondition | ztBlob | 1 |  | varchar
Tag name | TactonTagName | ztString | 255 |  | varchar
Template Id | TactonTemplateId | ztString | 60 |  | varchar
Only update | UpdateNoInsert | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: TactonMappingRows_Template Mapping configurator to Jeeves, details


Mapping from Jeeves to configurator (TactonModelMapping)

Mapping of models, created in Tacton studio, to Jeeves tables. (Header table.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Tacton component class ID | ClassId | ztString | 100 |  | varchar
Description | Description | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Table name | JvsTableName | ztString | 128 |  | varchar
Configurator model ID | ModelId | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Dataload config data | TactonLoadConfData | ztBoolean |  |  | char
Initial dataload | TactonLoadData | ztBoolean |  |  | char
Dataload next step | TactonLoadDynData | ztBoolean |  |  | char
SQL condition for table | TactonTableCondition | ztBlob | 1 |  | varchar
SQL/procedure | TactonTableSql | ztBlob | 1 |  | varchar


Mapping Jeeves to configurator , details (TactonModelMappingRows)

Mapping of models, created in Tacton studio, to Jeeves tables. (Details table.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Tacton component class ID | ClassId | ztString | 100 |  | varchar
Domain ID | DomainId | ztString | 60 |  | varchar
Feature Name | FeatureName | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Name of column | JvsColumnName | ztString | 128 |  | varchar
Init/default value | JvsInitValue | ztString | 255 |  | varchar
Table name | JvsTableName | ztString | 128 |  | varchar
Configurator model ID | ModelId | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SQL condition for table | TactonTableCondition | ztBlob | 1 |  | varchar
SQL/procedure | TactonTableSql | ztBlob | 1 |  | varchar


Market per company (mafr)

Alphanumeric designation for the company.

When you enter a company for the first time, this number is not automatically set by the system. You must enter it manually.

This is the unique ID for the company and cannot be changed, which means that if you base it on the company name, e.g. the first letters of the company name, you will not be able to change the ID if the company changes name. It is therefore best to construct the ID a different way or just use sequence numbers. You can search for the company using different terms, e.g. its name.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Number employees | AntalAnst | ztInteger | 5 |  | smallint
Number users | antalanv | ztInteger | 5 |  | smallint
Number customers | antalkunder | ztInteger | 5 |  | smallint
Number countries | AntalLand | ztInteger | 5 |  | smallint
Message | budskap | ztBlob | 1 |  | varchar
Focused market | fokusmarknad | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Trading area | handelsomrkod | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | kortnotering | ztString | 255 |  | varchar
Customers | kunder | ztBlob | 1 |  | varchar
Market share | markandel | ztFloat | 15 | 2 | float
Countries | nationer | ztBlob | 1 |  | varchar
Partner | partner | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Quantity used per customer | Snittantalanv | ztInteger | 5 |  | smallint
Sales argument | usp | ztBlob | 1 |  | varchar


Markup templates (arkp)

Definition of templates with different types of markups used when calculating item cost prices.

Note! You should NOT set up markup templates with zero values. If markup templates are not needed, you must not specify a template in the system information or item/supplier records (table Al).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Markup 2 chain | ArtKalkChain2 | ztBoolean |  |  | char
Markup 4 chain | ArtKalkChain4 | ztBoolean |  |  | char
Markup 5, amount | ArtKalkPalBel5 | ZtBaseCurrAmount | 14 | 2 | money
Markup template | ArtKalkPalBen | ztString | 30 |  | varchar
Markup template | ArtKalkPalKod | ztString | 4 |  | varchar
Item specific markup | ArtKalkPalSpec | ztBoolean |  |  | char
Markup 1 % | ArtKalkProc1 | ztFloat | 6 | 2 | float
Markup 2 % | ArtKalkProc2 | ztFloat | 6 | 2 | float
Markup 3 % | ArtKalkProc3 | ztFloat | 6 | 2 | float
Markup 4 % | ArtKalkProc4 | ztFloat | 6 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: arkp Cost price markup templates


Markup templates, Item list price (PriceCalcT)

Definition of templates with different types of markups used when calculating item list prices.

Note! You should NOT set up markup templates with zero values. If markup templates are not needed, you must not specify a template in item records (table AR).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Markup 5, amount | ListPriceAddAmt5 | ZtBaseCurrAmount | 14 | 2 | money
List price markup 2 chain | ListPriceChain2 | ztBoolean |  |  | char
List price markup 4 chain | ListPriceChain4 | ztBoolean |  |  | char
List price markup-1 % | ListPriceMarkUp1 | ztFloat | 6 | 2 | float
List price markup-2 % | ListPriceMarkUp2 | ztFloat | 6 | 2 | float
List price markup-3 % | ListPriceMarkUp3 | ztFloat | 6 | 2 | float
List price markup-4 % | ListPriceMarkUp4 | ztFloat | 6 | 2 | float
List price markup template | ListPriceMarkUpCd | ztString | 10 |  | varchar
List price markup template | ListPriceMarkUpCdDescr | ztString | 30 |  | varchar
Item specific markup | ListPriceMarkUpChgFlag | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PriceCalcT List price markup templates


Master plan forecasts (PrgHPlan)

Table of details in master plans.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Main level | HuvudNiva | ztInteger | 4 |  | smallint
Main period | HuvudPeriod | ztString | 25 |  | varchar
Master plan description | HuvudPlanBeskr | ztString | 50 |  | varchar
Date for master schedule | HuvudPlanDatum | ztDateTime |  |  | datetime
Master plan number | HuvudPlanNr | ZtLong | 10 |  | int
Signature for master schedule | HuvudPlanSign | ztString | 6 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Forecast key | PrognosNyckel | ztString | 25 |  | varchar
Forecast period | PrognosPeriod | ztString | 25 |  | varchar
Forecast version | PrognosVer | ZtLong | 4 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PrgHPlan Forecast, master plan


Master syslocks (vslk)

Sequence number.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Database (SQL) ID | DataBas | ztString | 30 |  | nvarchar
Company | ForetagKod | ztString | 30 |  | nvarchar
Sequence no. | LopNr | ztString | 30 |  | nvarchar
Object no. | objectid | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | tinyint
Process ID | Spid | ZtLong | 5 |  | int
Base/value table | zTable | ztString | 255 |  | nvarchar

    This table is the main table in the following programs:

    Program: xvslk System locks


Match multiple POs (LrbhColl)

Record for multi match of supplier invoice.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Invoice match method | FaktAvprTypBest | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Allocation purch OH | InkOmkFord | ztInteger | 5 |  | smallint
Purch OH type | InkOmkTyp | ztInteger | 5 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Material and size of items (itmt)

Table that shows the materials and sizes in use.
Information and search terms only.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Material type | ItemMtrlType | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: itmt Material and size of items


Material issue for MO (mru)

Material issue for manufacturing orders.

Material issue is posted as follows:
--------------------------------------------------------------------
CREDIT: The issued materials product account, stock transaction type 20 (or 0 if 20 is missing) and detail for integration 0 (stock account).

DEBIT: WIP is debited according the manufactured items product account, stock transaction type 120 (or 0 if 120 is missing) and detail for integration 5 (WIP-account).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting complete | AccountingDone | ztBoolean |  |  | char
Pre-posting executed | AccountingDone2 | ztBoolean |  |  | char
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Cost price at order | ArtKalkPrisO | ZtBaseCurrAmount | 14 | 2 | money
Cost at order (mtrl) | ArtKalkPrisOMtrl | ZtBaseCurrAmount | 14 | 2 | money
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Batch no. required | BatchBokas | ztBoolean |  |  | char
Batch no. | BatchId | ztString | 30 |  | varchar
Batch no. (multi fifo) | BatchId_Multi_Str | ztString | 255 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Link, labour reporting | ConnAorDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Document ID | docnumid | ztString | 30 |  | varchar
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Extra overhead cost | ExtraOmk | ZtCost | 16 | 6 | float
Delivery note/disp no. | FfhNr | ZtLong | 10 |  | int
RowNo | FfhRadNr | ztInteger | 5 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Purch price curr | InValuta | ztString | 3 |  | varchar
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
To be posted | Konteras | ztBoolean |  |  | char
Corr reserv qty | KorrAntalUt | ZtQty | 14 | 2 | decimal
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Overheads, work, admin | LabOvhdAdmCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, production | LabOvhdPrdCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, sales | LabOvhdSalesCost | ZtBaseCurrAmount | 14 | 2 | money
Stocked | LagerBokas | ztBoolean |  |  | char
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Labor operation picking list ID | LbrOpJoinPckList | ZtLong | 10 |  | int
Invtry trans journal no. | LthJournNr | ZtLong | 6 |  | int
Cancel remain qty | MakuleraRestAntal | ztBoolean |  |  | char
MO issue purch mtrl | MoMtrlTillv | ZtBaseCurrAmount | 14 | 2 | money
Lagerjournal MPS | MpsJournNr | ztInteger | 4 |  | smallint
Item version, demand | MrArtikelVariant | ztString | 30 |  | varchar
Item no. required | mrArtNr | ztString | 30 |  | varchar
Picked quantity | MrRappAnt | ZtQty | 14 | 2 | decimal
Material journal no. | MruJournNr | ZtLong | 6 |  | int
OK to pick date | MrUtplDat | ztDate |  |  | datetime
Reversering av materialuttag | MtrlRevCode | ztInteger | 2 |  | smallint
Actual material cost | MtrlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (refinement) | MtrlVerklKostForadling | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (adjust) | MtrlVerklKostJustering | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (mtrl) | MtrlVerklKostMtrl | ZtBaseCurrAmount | 14 | 2 | money
Operation no. | OpNr | ztInteger | 3 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | nvarchar
Doc. printed | printed | ztBoolean |  |  | char
Project ID | ProjCode | ztString | 10 |  | varchar
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Rec delivery from WMS | RecDelivFromWMS | ztBoolean |  |  | char
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Serial no. required | SerieNrBokas | ztBoolean |  |  | char
Time sqlcmd->trg start | SQLCmd2EnterTrg | ZtLong | 10 |  | int
Start av updatering/insert | SqlStmtStartedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Technical OH cost | TeknikOmk | ZtCost | 16 | 6 | float
Cost posting journal | TillvKostKontJournal | ZtLong | 10 |  | int
Exchange rate | Valkurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Cost price, curr | VbKalkPris | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: Mru2GL Material issues->GL

    Program: MruRapp Material issues

    Program: xMru Completed material issues


Material reservation - mfg order connections (ctim)

Links between received deliveries from one or more manufacturing orders to material on one or more manufacturing orders. Records are created in the table when booking material for manufacturing orders against received deliveries from other manufacturing orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Receive to MO | inlevTillAoNr | Jeeves_MONo | 7 |  | bigint
Receive to MO Pos | InlevTillAoPos | ztInteger | 4 |  | int
Receive to MO Op | InlevTillOpNr | ztInteger | 3 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Item version, demand | MrArtikelVariant | ztString | 30 |  | varchar
Item no. required | MrArtNr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: ctim Material reservation - mfg/works order connections


Material reservation, net req (mrn)

Material reservations for calculated net requirement.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Purchased | AnskaffningKop | ztBoolean |  |  | char
Acq to requirement | AnskaffningMotBehov | ztBoolean |  |  | char
Manufactured | AnskaffningTillv | ztBoolean |  |  | char
Qty being picked | AntalUnderPlock | ZtQty | 14 | 2 | decimal
Decimal places | AntDec | ztInteger | 1 |  | smallint
MO type | AoKod | ztInteger | 2 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Operations start date | AoStartDat | ztDate |  |  | datetime
Bin | ars_LagPlats | ztBinLocation | 20 |  | varchar
Item description | ArtBeskr | ztString | 30 |  | varchar
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Main agreement | ArtHuvudAvt | ztBoolean |  |  | char
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Cost price (actual) | ArtKalkprisE | ZtBaseCurrAmount | 14 | 2 | money
Cost price at order | ArtKalkPrisO | ZtBaseCurrAmount | 14 | 2 | money
Cost at order (mtrl) | ArtKalkPrisOMtrl | ZtBaseCurrAmount | 14 | 2 | money
Artikelnivå | ArtNivaKod | ztString | 1 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
BOM notation code | ArtStruktKod | ztString | 1 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Auto breakdown within MO | AutoVidareNedbrInomTo | ztBoolean |  |  | char
Qty parent level (setup) | BAntalAviStall | ZtQty | 14 | 2 | decimal
Pieces | BAntalStyck | ZtQty | 14 | 2 | decimal
Batch no. | BatchId | ztString | 30 |  | varchar
Ordered | Bestallas | ztBoolean |  |  | char
Est disp date | BestBerLevDat | ztDate |  |  | datetime
Order date acc. lead time | BestDatEnlLedTid | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Figure no. | BFigNr | ztString | 6 |  | varchar
Figure no. extended | BFigNr255 | ztString | 255 |  | varchar
Quantity per piece | BKvantPerStyck | ztFloat | 12 | 4 | float
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Level within work order | BOM_Level_In_WO | ztInteger | 5 |  | smallint
Availability check date | BristKontrolleradDatum | ztDate |  |  | datetime
Avail check status code | BristKontrolleradStatus | ztInteger | 5 |  | smallint
Copy to parent | CopyUpFromThisItem | ztBoolean |  |  | char
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Dimension 1 | Dimension1 | ztFloat | 15 | 2 | float
Dimension 2 | Dimension2 | ztFloat | 15 | 2 | float
Dimension 3 | Dimension3 | ztFloat | 15 | 2 | float
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Own mtrl row | EgenMtrlRad | ztBoolean |  |  | char
Unit code | EnhetsKod | ztString | 4 |  | varchar
Qty includes safety level | ExistsNeed4StockSafetyLevel | ztBoolean |  |  | char
Qty includes forecast | ExistsNeedFromPNEForcst | ztBoolean |  |  | char
Qty includes SO forecast | ExistsNeedFromSOForcst | ztBoolean |  |  | char
Qty includes SO and MO | ExistsNeedFromSOMO | ztBoolean |  |  | char
Fictitious item | FiktivArtikel | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Exg rate on order date | InValKurs | ZtCurrencyRate | 15 | 7 | decimal
Purch price curr | InValuta | ztString | 3 |  | varchar
Buy manuf of item | KopTillvAvArtikel | ztBoolean |  |  | char
Stocked | LagerBokas | ztBoolean |  |  | char
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Lagerst för OU-lager | LagStalleOULager | ztString | 2 |  | varchar
Inventory stock type | LagTyp | ztInteger | 2 |  | smallint
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Adm lead time | LedTidAdm | ztInteger | 3 |  | smallint
Lead time from suppl | LedTidEnlLev | ztInteger | 3 |  | smallint
Lead time extra demand | LedTidExtra1 | ztInteger | 3 |  | smallint
No purchase agreement | MarkInkAvtSaknas | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Item version, demand | MrArtikelVariant | ztString | 30 |  | varchar
Item no. required | mrArtNr | ztString | 30 |  | varchar
Picked quantity | MrRappAnt | ZtQty | 14 | 2 | decimal
Reserved quantity | MrResAnt | ZtQty | 14 | 2 | decimal
Mtrl due date | MrResDat | ztDate |  |  | datetime
Ställ antal | MrStallAnt | ZtQty | 14 | 2 | decimal
Matr.beh.status | MrStatus | ztInteger | 1 |  | smallint
Calc mtrl cost | MtrlKalkKost | ZtBaseCurrAmount | 14 | 2 | money
Actual material cost | MtrlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
MRP batch -> Sign/mgr | NE_PlanAnsv | ztString | 8 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Ord-spec invtry bal | OrderUniktLager | ZtQty | 14 | 2 | decimal
Qty includes safety level | PercentNeed4StockSafetyLevel | ZtDecimal73 | 8 | 3 | decimal
Qty includes forecast | PercentNeedFromPNEForcst | ZtDecimal73 | 8 | 3 | decimal
Qty includes forecast | PercentNeedFromSOForcst | ZtDecimal73 | 8 | 3 | decimal
Qty includes forecast | PercentNeedFromSOMO | ZtDecimal73 | 8 | 3 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Planned quantity | PlaneratAntal | ZtQty | 14 | 2 | decimal
Planeringsreserv (dgr) | PlanReservTid | ztInteger | 3 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Qty for safety stock level | QtyNeed4StockSafetyLevel | ZtQty | 14 | 2 | decimal
Qty from forecast | QtyNeedFromPNEForcst | ZtQty | 14 | 2 | decimal
Qty from SO forecast | QtyNeedFromSOForcst | ZtQty | 14 | 2 | decimal
Qty existing needs | QtyNeedFromSOMO | ZtQty | 14 | 2 | decimal
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Joint purchase (allowed) | SamInkopMark | ztBoolean |  |  | char
Sequence | Sequence | ztInteger | 3 |  | smallint
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
BOM for item | StycklistaTillArtNr | ztString | 30 |  | varchar
Transport days | TransportTid | ztInteger | 3 |  | smallint
Original item no. | UrsprArtNr | ztString | 30 |  | varchar
Print PO qty | UtskrBestDokAntal | ZtQty | 14 | 2 | decimal
Print disp date | UtskrBestDokLevDat | ztDate |  |  | datetime
Reprint purch order | UtskrBestDokSkaGoras | ztBoolean |  |  | char
New PO print date | UtskrBestDokUtskrDT | ztDateTime |  |  | datetime
Deliv from MO | UttagFranAoNr | Jeeves_MONo | 7 |  | bigint
Deliv from MO Pos | UttagFranAoPos | ztInteger | 5 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Gross setup price, curr | Vb_InPris_Stall | ztMoney | 14 | 2 | money
Gross start purch price, curr | Vb_InPris_Start | ztMoney | 14 | 2 | money
Cost price, curr | VbKalkPris | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: mrn Mtrl reservation, net requirement


Material reservation, work copy (mrw)

mr work copy.
Used for comparison with mr when a blueprint has been updated.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Purchased | AnskaffningKop | ztBoolean |  |  | char
Acq to requirement | AnskaffningMotBehov | ztBoolean |  |  | char
Manufactured | AnskaffningTillv | ztBoolean |  |  | char
Decimal places | AntDec | ztInteger | 1 |  | smallint
MO type | AoKod | ztInteger | 2 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Item description | ArtBeskr | ztString | 30 |  | varchar
Main agreement | ArtHuvudAvt | ztBoolean |  |  | char
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Cost price at order | ArtKalkPrisO | ZtBaseCurrAmount | 14 | 2 | money
Cost at order (mtrl) | ArtKalkPrisOMtrl | ZtBaseCurrAmount | 14 | 2 | money
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Artikelnivå | ArtNivaKod | ztString | 1 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
BOM notation code | ArtStruktKod | ztString | 1 |  | varchar
Aut mtrl.issue allowed | AutMtrlUttagAvArt | ztBoolean |  |  | char
Auto breakdown within MO | AutoVidareNedbrInomTo | ztBoolean |  |  | char
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Qty parent level (setup) | BAntalAviStall | ZtQty | 14 | 2 | decimal
Pieces | BAntalStyck | ZtQty | 14 | 2 | decimal
Ordered | Bestallas | ztBoolean |  |  | char
Order date acc. lead time | BestDatEnlLedTid | ztDate |  |  | datetime
Delivery date supplier quay | BestLevDatFranLevsKaj | ztDate |  |  | datetime
Delivery date to quay | BestLevDatTillKaj | ztDate |  |  | datetime
Figure no. | BFigNr | ztString | 6 |  | varchar
Figure no. extended | BFigNr255 | ztString | 255 |  | varchar
Quantity per piece | BKvantPerStyck | ztFloat | 12 | 4 | float
Level within work order | BOM_Level_In_WO | ztInteger | 5 |  | smallint
Copy to parent | CopyUpFromThisItem | ztBoolean |  |  | char
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Days to PO date | DagarTillBestDatum | ZtLong | 10 |  | int
Dimension 1 | Dimension1 | ztFloat | 15 | 2 | float
Dimension 2 | Dimension2 | ztFloat | 15 | 2 | float
Dimension 3 | Dimension3 | ztFloat | 15 | 2 | float
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Own mtrl row | EgenMtrlRad | ztBoolean |  |  | char
New MO on explosion | EgenThVidVidareNedbr | ztBoolean |  |  | char
Unit code | EnhetsKod | ztString | 4 |  | varchar
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Fictitious item | FiktivArtikel | ztBoolean |  |  | char
MO issue purch mtrl (AC) | FKMoMtrlTillv | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Purch price curr | InValuta | ztString | 3 |  | varchar
Record has been updated | IsUpdated | ztBoolean |  |  | char
Stocked | LagerBokas | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Inventory stock type | LagTyp | ztInteger | 2 |  | smallint
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Adm lead time | LedTidAdm | ztInteger | 3 |  | smallint
Lead time from suppl | LedTidEnlLev | ztInteger | 3 |  | smallint
Lead time extra demand | LedTidExtra1 | ztInteger | 3 |  | smallint
No purchase agreement | MarkInkAvtSaknas | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
MO% markup mtrl mfg | MoProcMtrlTillv | ZtDecimal73 | 8 | 3 | decimal
Item version, demand | MrArtikelVariant | ztString | 30 |  | varchar
Item no. required | mrArtNr | ztString | 30 |  | varchar
Reserved quantity | MrResAnt | ZtQty | 14 | 2 | decimal
Mtrl due date | MrResDat | ztDate |  |  | datetime
Calc mtrl cost | MtrlKalkKost | ZtBaseCurrAmount | 14 | 2 | money
Operation no. | OpNr | ztInteger | 3 |  | int
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Fixed number | OrderUniktFixtAntal | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Planned quantity | PlaneratAntal | ZtQty | 14 | 2 | decimal
Planeringsreserv (dgr) | PlanReservTid | ztInteger | 3 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Created by | RowCreatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Joint purchase (allowed) | SamInkopMark | ztBoolean |  |  | char
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
BOM for item | StycklistaTillArtNr | ztString | 30 |  | varchar
Transport days | TransportTid | ztInteger | 3 |  | smallint
Original item no. | UrsprArtNr | ztString | 30 |  | varchar
Deliv from MO | UttagFranAoNr | Jeeves_MONo | 7 |  | bigint
Deliv from MO Pos | UttagFranAoPos | ztInteger | 5 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Gross setup price, curr | Vb_InPris_Stall | ztMoney | 14 | 2 | money
Gross start purch price, curr | Vb_InPris_Start | ztMoney | 14 | 2 | money
Cost price, curr | VbKalkPris | ztMoney | 14 | 2 | money


Material reservations (mrx)

All material reservations for a manufacturing order.
The material reservations include expected picking for manufacturing.
Completed material issue is stored in the 'mru' table, expected deliveries from manufacturing in the 'ti' table (Manufacturing order, receiving) and received deliveries in the 'th' table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv |  |  |  | @DataType=NULL
Alternative routing | AltOpPrior |  |  |  | @DataType=NULL
This field is used in the table as follows: |
Arrival handling | AnkomstKod |  |  |  | @DataType=NULL
Requisition (not purch) | AnmodanMark |  |  |  | @DataType=NULL
Purchased | AnskaffningKop |  |  |  | @DataType=NULL
Acq to requirement | AnskaffningMotBehov |  |  |  | @DataType=NULL
Manufactured | AnskaffningTillv |  |  |  | @DataType=NULL
Qty being picked | AntalUnderPlock |  |  |  | @DataType=NULL
Decimal places | AntDec |  |  |  | @DataType=NULL
MO type | AoKod |  |  |  | @DataType=NULL
Mfg/Works order no. | AoNr |  |  |  | @DataType=NULL
Mfg/Works order no. (alpha) | AoNrAlfa |  |  |  | @DataType=NULL
Row | AoPos |  |  |  | @DataType=NULL
Scrapped qty | AoRappKassAnt |  |  |  | @DataType=NULL
Operations start date | AoStartDat |  |  |  | @DataType=NULL
Bin | ars_LagPlats |  |  |  | @DataType=NULL
Item description | ArtBeskr |  |  |  | @DataType=NULL
Gross weight kg | ArtBtotVikt |  |  |  | @DataType=NULL
Main agreement | ArtHuvudAvt |  |  |  | @DataType=NULL
Item variant | ArtikelVariant |  |  |  | @DataType=NULL
Current cost price | ArtKalkBer |  |  |  | @DataType=NULL
This field is used in the table as follows: |
Cost price, material | ArtKalkBerMtrl |  |  |  | @DataType=NULL
This field is used in the table as follows: |
Budgeted cost | ArtKalkBudg |  |  |  | @DataType=NULL
Cost price unit | ArtKalkPer |  |  |  | @DataType=NULL
Cost price (actual) | ArtKalkprisE |  |  |  | @DataType=NULL
Cost price at order | ArtKalkPrisO |  |  |  | @DataType=NULL
Cost at order (mtrl) | ArtKalkPrisOMtrl |  |  |  | @DataType=NULL
Priority | ArtLevPrior |  |  |  | @DataType=NULL
Lowest level f item | ArtNiva |  |  |  | @DataType=NULL
BOM level | ArtNivaBeskr |  |  |  | @DataType=NULL
Artikelnivå | ArtNivaKod |  |  |  | @DataType=NULL
Item no. | ArtNr |  |  |  | @DataType=NULL
This field is used in the table as follows: |
Item no, design | ArtNrKonstruktion |  |  |  | @DataType=NULL
Supplier item no. | ArtNrLev |  |  |  | @DataType=NULL
Product acct | ArtProdKonto |  |  |  | @DataType=NULL
Item serial no. | ArtSerieNr |  |  |  | @DataType=NULL
BOM notation code | ArtStruktKod |  |  |  | @DataType=NULL
Net weight kg | ArtVikt |  |  |  | @DataType=NULL
Auto breakdown within MO | AutoVidareNedbrInomTo |  |  |  | @DataType=NULL
Auto booking rule | AutStockBookingRule |  |  |  | @DataType=NULL
Agreed/requested prc | AvtalatPris |  |  |  | @DataType=NULL
Qty parent level (setup) | BAntalAviStall |  |  |  | @DataType=NULL
Pieces | BAntalStyck |  |  |  | @DataType=NULL
Item no. (BOM) | BArtNrStrukt |  |  |  | @DataType=NULL
Batch no. | BatchId |  |  |  | @DataType=NULL
Ordered | Bestallas |  |  |  | @DataType=NULL
Est disp date | BestBerLevDat |  |  |  | @DataType=NULL
Order date acc. lead time | BestDatEnlLedTid |  |  |  | @DataType=NULL
Delivery date supplier quay | BestLevDatFranLevsKaj |  |  |  | @DataType=NULL
Delivery date to quay | BestLevDatTillKaj |  |  |  | @DataType=NULL
PO no. | BestNr |  |  |  | @DataType=NULL
Row no. in PO | BestRadNr |  |  |  | @DataType=NULL
PO backorder no. | BestRestNr |  |  |  | @DataType=NULL
Figure no. | BFigNr |  |  |  | @DataType=NULL
Figure no. extended | BFigNr255 |  |  |  | @DataType=NULL
Quantity per piece | BKvantPerStyck |  |  |  | @DataType=NULL
Quantity booked | BokatAntal |  |  |  | @DataType=NULL
Availability check date | BristKontrolleradDatum |  |  |  | @DataType=NULL
Avail check status code | BristKontrolleradStatus |  |  |  | @DataType=NULL
Copy to parent | CopyUpFromThisItem |  |  |  | @DataType=NULL
Created by object | CreatedByDBObject |  |  |  | @DataType=NULL
Days to PO date | DagarTillBestDatum |  |  |  | @DataType=NULL
Partial booking allowed | DelBokningTillaten |  |  |  | @DataType=NULL
Dys rec.del -> need | DiffDgrInlevOchBehov |  |  |  | @DataType=NULL
Dimension 1 | Dimension1 |  |  |  | @DataType=NULL
Dimension 2 | Dimension2 |  |  |  | @DataType=NULL
Dimension 3 | Dimension3 |  |  |  | @DataType=NULL
@zPrompt=null | DoIndirectUpdate |  |  |  | @DataType=NULL
Sequence number | DummyUniqueId |  |  |  | @DataType=NULL
Text | Edit |  |  |  | @DataType=NULL
External text | EditExt |  |  |  | @DataType=NULL
Own mtrl row | EgenMtrlRad |  |  |  | @DataType=NULL
New MO on explosion | EgenThVidVidareNedbr |  |  |  | @DataType=NULL
Unit code | EnhetsKod |  |  |  | @DataType=NULL
Log | Exec_Time_Log_String |  |  |  | @DataType=NULL
Processing time | ExecutionTime |  |  |  | @DataType=NULL
External qty | ExternQty |  |  |  | @DataType=NULL
External purch agreem no. | ExtInkAvt |  |  |  | @DataType=NULL
Delivery note/disp no. | FFhNr |  |  |  | @DataType=NULL
RowNo | FFhRadNr |  |  |  | @DataType=NULL
Fictitious item | FiktivArtikel |  |  |  | @DataType=NULL
MO issue purch mtrl (AC) | FKMoMtrlTillv |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Company ID | FtgNr |  |  |  | @DataType=NULL
Purchase agreement no. | InkAvt |  |  |  | @DataType=NULL
Purchasing manager | InkHandl |  |  |  | @DataType=NULL
Start trigger | Ins_DT_MilliSecond |  |  |  | @DataType=NULL
Exg rate on order date | InValKurs |  |  |  | @DataType=NULL
Purch price curr | InValuta |  |  |  | @DataType=NULL
Item OK to use? | ItemOkToUse |  |  |  | @DataType=NULL
Purchase of item | KopAvArtikel |  |  |  | @DataType=NULL
Buy manuf of item | KopTillvAvArtikel |  |  |  | @DataType=NULL
Corr reserv qty | KorrAntalUt |  |  |  | @DataType=NULL
Stocked | LagerBokas |  |  |  | @DataType=NULL
Bin | LagPlats |  |  |  | @DataType=NULL
Inventory location | LagStalle |  |  |  | @DataType=NULL
Lagerst för OU-lager | LagStalleOULager |  |  |  | @DataType=NULL
Inventory stock type | LagTyp |  |  |  | @DataType=NULL
Lead time in days | LedTid |  |  |  | @DataType=NULL
Adm lead time | LedTidAdm |  |  |  | @DataType=NULL
Lead time from suppl | LedTidEnlLev |  |  |  | @DataType=NULL
Lead time extra demand | LedTidExtra1 |  |  |  | @DataType=NULL
Deliv to supplier | LevMedBestTillLev |  |  |  | @DataType=NULL
Supplier item descr | LevsArtBeskr |  |  |  | @DataType=NULL
Sequence no. | LopNr |  |  |  | @DataType=NULL
No purchase agreement | MarkInkAvtSaknas |  |  |  | @DataType=NULL
Not within lead time | MarkInkEjInomLedTid |  |  |  | @DataType=NULL
Ord spec cost price | MarkOrderUniktKalkP |  |  |  | @DataType=NULL
Order-specific inventory | MarkOrderUniktLager |  |  |  | @DataType=NULL
MO issue purch mtrl | MoMtrlTillv |  |  |  | @DataType=NULL
MO% markup mtrl mfg | MoProcMtrlTillv |  |  |  | @DataType=NULL
Item version, demand | MrArtikelVariant |  |  |  | @DataType=NULL
Item no. required | mrArtNr |  |  |  | @DataType=NULL
Picked quantity | MrRappAnt |  |  |  | @DataType=NULL
Reserved quantity | MrResAnt |  |  |  | @DataType=NULL
Mtrl due date | MrResDat |  |  |  | @DataType=NULL
Ställ antal | MrStallAnt |  |  |  | @DataType=NULL
Matr.beh.status | MrStatus |  |  |  | @DataType=NULL
Calc mtrl cost | MtrlKalkKost |  |  |  | @DataType=NULL
Actual material cost | MtrlVerklKost |  |  |  | @DataType=NULL
Actual mtrl cost (refinement) | MtrlVerklKostForadling |  |  |  | @DataType=NULL
Actual mtrl cost (adjust) | MtrlVerklKostJustering |  |  |  | @DataType=NULL
Actual mtrl cost (mtrl) | MtrlVerklKostMtrl |  |  |  | @DataType=NULL
Search if agree > net req | NewSearchWhenCreatePur |  |  |  | @DataType=NULL
Operation no. | OpNr |  |  |  | @DataType=NULL
Item descr (order) | OrdArtBeskr |  |  |  | @DataType=NULL
Booking status | OrdBokningsStatus |  |  |  | @DataType=NULL
Ord-spec invtry bal | OrderUniktLager |  |  |  | @DataType=NULL
Order spec text | OrpRadText |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Planning manager | PlanAnsv |  |  |  | @DataType=NULL
Planned quantity | PlaneratAntal |  |  |  | @DataType=NULL
Planeringsreserv (dgr) | PlanReservTid |  |  |  | @DataType=NULL
Pos in figure | posalfa |  |  |  | @DataType=NULL
Project ID | ProjCode |  |  |  | @DataType=NULL
Start trigger | QQ_Ins_Trg_Start |  |  |  | @DataType=NULL
Discount 1 % | Rabatt1 |  |  |  | @DataType=NULL
Discount 2 % | Rabatt2 |  |  |  | @DataType=NULL
Discount 3 % | Rabatt3 |  |  |  | @DataType=NULL
Row | RadPos2 |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL
Joint purchase (allowed) | SamInKopMark |  |  |  | @DataType=NULL
Sequence | Sequence |  |  |  | @DataType=NULL
Start av updatering/insert | SqlStmtStartedDT |  |  |  | @DataType=NULL
Sequence number | SrDummyUniqueId |  |  |  | @DataType=NULL
Requisition | StrDateTimeBIA |  |  |  | @DataType=NULL
BOM rev. | StrukturRevision |  |  |  | @DataType=NULL
This field is used in the table as follows: |
BOM for item | StycklistaTillArtNr |  |  |  | @DataType=NULL
Suborder in capacity subcontr | SubKapacitetsLego |  |  |  | @DataType=NULL
ID for connection | Ti_LopNr_Ned |  |  |  | @DataType=NULL
Visa tillverkningsordern | TiVisas |  |  |  | @DataType=NULL
OK to use tool | ToolOkToUse |  |  |  | @DataType=NULL
Transit delivery | TransitLeverans |  |  |  | @DataType=NULL
Transport days | TransportTid |  |  |  | @DataType=NULL
Original item no. | UrsprArtNr |  |  |  | @DataType=NULL
Orig operation no. | UrsprOpNr |  |  |  | @DataType=NULL
Print PO qty | UtskrBestDokAntal |  |  |  | @DataType=NULL
Print disp date | UtskrBestDokLevDat |  |  |  | @DataType=NULL
Reprint purch order | UtskrBestDokSkaGoras |  |  |  | @DataType=NULL
New PO print date | UtskrBestDokUtskrDT |  |  |  | @DataType=NULL
Deliv from MO | UttagFranAoNr |  |  |  | @DataType=NULL
Deliv from MO Pos | UttagFranAoPos |  |  |  | @DataType=NULL
Item group | VaruGruppKod |  |  |  | @DataType=NULL
Gross purch price, curr | Vb_InPris |  |  |  | @DataType=NULL
Gross purch price, curr (mtrl) | vb_inpris_mtrl |  |  |  | @DataType=NULL
Gross setup price, curr | Vb_InPris_Stall |  |  |  | @DataType=NULL
Gross start purch price, curr | Vb_InPris_Start |  |  |  | @DataType=NULL
Cost price, curr | VbKalkPris |  |  |  | @DataType=NULL
Breakdown, MO | VidareNedbrInomTo |  |  |  | @DataType=NULL

    This table is the main table in the following programs:

    Program: Mrx_upd Material reservations, ord spec ...


Material reservations (mr)

All material reservations for a manufacturing order.
The material reservations include expected picking for manufacturing.
Completed material issue is stored in the 'mru' table, expected deliveries from manufacturing in the 'ti' table (Manufacturing order, receiving) and received deliveries in the 'th' table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Add to MO row | AddToMO | Jeeves_MONo | 20 |  | bigint
Add to purchase order | AddToPO | Jeeves_PONo | 20 |  | bigint
Active | Aktiv | ztInteger | 1 |  | smallint
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
This field is used in the table as follows: |
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Purchased | AnskaffningKop | ztBoolean |  |  | char
Acq to requirement | AnskaffningMotBehov | ztBoolean |  |  | char
Manufactured | AnskaffningTillv | ztBoolean |  |  | char
Qty being picked | AntalUnderPlock | ZtQty | 14 | 2 | decimal
Decimal places | AntDec | ztInteger | 1 |  | smallint
MO type | AoKod | ztInteger | 2 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Operations start date | AoStartDat | ztDate |  |  | datetime
Bin | ars_LagPlats | ztBinLocation | 20 |  | varchar
Item description | ArtBeskr | ztString | 30 |  | varchar
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Main agreement | ArtHuvudAvt | ztBoolean |  |  | char
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
This field is used in the table as follows: |
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
This field is used in the table as follows: |
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Cost price (actual) | ArtKalkprisE | ZtBaseCurrAmount | 14 | 2 | money
Cost price at order | ArtKalkPrisO | ZtBaseCurrAmount | 14 | 2 | money
Cost at order (mtrl) | ArtKalkPrisOMtrl | ZtBaseCurrAmount | 14 | 2 | money
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
BOM level | ArtNivaBeskr | ztString | 20 |  | varchar
Artikelnivå | ArtNivaKod | ztString | 1 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
This field is used in the table as follows: |
Item no, design | ArtNrKonstruktion | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
BOM notation code | ArtStruktKod | ztString | 1 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Aut mtrl.issue allowed | AutMtrlUttagAvArt | ztBoolean |  |  | char
Auto breakdown within MO | AutoVidareNedbrInomTo | ztBoolean |  |  | char
Auto booking rule | AutStockBookingRule | ztInteger | 5 |  | smallint
Agreed/requested prc | AvtalatPris | ZtBaseCurrAmount | 14 | 2 | money
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Qty parent level (setup) | BAntalAviStall | ZtQty | 14 | 2 | decimal
Pieces | BAntalStyck | ZtQty | 14 | 2 | decimal
Item no. (BOM) | BArtNrStrukt | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Ordered | Bestallas | ztBoolean |  |  | char
Est disp date | BestBerLevDat | ztDate |  |  | datetime
Order date acc. lead time | BestDatEnlLedTid | ztDate |  |  | datetime
Delivery date supplier quay | BestLevDatFranLevsKaj | ztDate |  |  | datetime
Delivery date to quay | BestLevDatTillKaj | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Figure no. | BFigNr | ztString | 6 |  | varchar
Figure no. extended | BFigNr255 | ztString | 255 |  | varchar
Quantity per piece | BKvantPerStyck | ztFloat | 12 | 4 | float
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Level within work order | BOM_Level_In_WO | ztInteger | 5 |  | smallint
Booked Qty (invt) | BookQtyInvt | ztInteger | 5 |  | smallint
Booked Qty (MO) | BookQtyMO | ZtQty | 14 | 2 | decimal
Booked Qty (PO) | BookQtyPO | ZtQty | 14 | 2 | decimal
Availability check date | BristKontrolleradDatum | ztDate |  |  | datetime
Avail check status code | BristKontrolleradStatus | ztInteger | 5 |  | smallint
Copy to parent | CopyUpFromThisItem | ztBoolean |  |  | char
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Days to PO date | DagarTillBestDatum | ZtLong | 10 |  | int
Partial booking allowed | DelBokningTillaten | ztInteger | 5 |  | smallint
Dimension 1 | Dimension1 | ztFloat | 15 | 2 | float
Dimension 2 | Dimension2 | ztFloat | 15 | 2 | float
Dimension 3 | Dimension3 | ztFloat | 15 | 2 | float
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Own mtrl row | EgenMtrlRad | ztBoolean |  |  | char
New MO on explosion | EgenThVidVidareNedbr | ztBoolean |  |  | char
Unit code | EnhetsKod | ztString | 4 |  | varchar
Overhead, work, admin | EstLabOvhdAdmCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, production | EstLabOvhdPrdCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, sales | EstLabOvhdSalesCost | ZtBaseCurrAmount | 14 | 2 | money
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
External qty | ExternQty | ZtQty | 14 | 2 | decimal
External purch agreem no. | ExtInkAvt | ztString | 20 |  | varchar
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
RowNo | FFhRadNr | ztInteger | 5 |  | int
Fictitious item | FiktivArtikel | ztBoolean |  |  | char
MO issue purch mtrl (AC) | FKMoMtrlTillv | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Group acquisition by ...... | GroupPoWoOn | ztString | 10 |  | varchar
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Exg rate on order date | InValKurs | ZtCurrencyRate | 15 | 7 | decimal
Purch price curr | InValuta | ztString | 3 |  | varchar
Item OK to use? | ItemOkToUse | ztBoolean |  |  | char
Purchase of item | KopAvArtikel | ztBoolean |  |  | char
Buy manuf of item | KopTillvAvArtikel | ztBoolean |  |  | char
Corr reserv qty | KorrAntalUt | ZtQty | 14 | 2 | decimal
Overheads, work, admin | LabOvhdAdmCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, production | LabOvhdPrdCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, sales | LabOvhdSalesCost | ZtBaseCurrAmount | 14 | 2 | money
Stocked | LagerBokas | ztBoolean |  |  | char
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Lagerst för OU-lager | LagStalleOULager | ztString | 2 |  | varchar
Inventory stock type | LagTyp | ztInteger | 2 |  | smallint
Labor operation picking list ID | LbrOpJoinPckList | ZtLong | 10 |  | int
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Adm lead time | LedTidAdm | ztInteger | 3 |  | smallint
Lead time from suppl | LedTidEnlLev | ztInteger | 3 |  | smallint
Lead time extra demand | LedTidExtra1 | ztInteger | 3 |  | smallint
Deliv to supplier | LevMedBestTillLev | ztBoolean |  |  | char
Supplier item descr | LevsArtBeskr | ztString | 255 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
No purchase agreement | MarkInkAvtSaknas | ztBoolean |  |  | char
Not within lead time | MarkInkEjInomLedTid | ztBoolean |  |  | char
Ord spec cost price | MarkOrderUniktKalkP | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
MO issue purch mtrl | MoMtrlTillv | ZtBaseCurrAmount | 14 | 2 | money
MO% markup mtrl mfg | MoProcMtrlTillv | ZtDecimal73 | 8 | 3 | decimal
Item version, demand | MrArtikelVariant | ztString | 30 |  | varchar
Item no. required | mrArtNr | ztString | 30 |  | varchar
Picked quantity | MrRappAnt | ZtQty | 14 | 2 | decimal
Reserved quantity | MrResAnt | ZtQty | 14 | 2 | decimal
Mtrl due date | MrResDat | ztDate |  |  | datetime
Ställ antal | MrStallAnt | ZtQty | 14 | 2 | decimal
Matr.beh.status | MrStatus | ztInteger | 1 |  | smallint
Original material reservation | MrUrsprKod | ztInteger | 2 |  | smallint
Calc mtrl cost | MtrlKalkKost | ZtBaseCurrAmount | 14 | 2 | money
Actual material cost | MtrlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (refinement) | MtrlVerklKostForadling | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (adjust) | MtrlVerklKostJustering | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (mtrl) | MtrlVerklKostMtrl | ZtBaseCurrAmount | 14 | 2 | money
Search if agree > net req | NewSearchWhenCreatePur | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Booking status | OrdBokningsStatus | ztInteger | 5 |  | smallint
Fixed number | OrderUniktFixtAntal | ZtQty | 14 | 2 | decimal
Ord-spec invtry bal | OrderUniktLager | ZtQty | 14 | 2 | decimal
Order spec text | OrpRadText | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Planned quantity | PlaneratAntal | ZtQty | 14 | 2 | decimal
Planned qty no rounding | PlannedQtyNoRounding | ZtQty | 14 | 2 | decimal
Planeringsreserv (dgr) | PlanReservTid | ztInteger | 3 |  | smallint
Pos in figure | posalfa | ztString | 12 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Row | RadPos2 | ztInteger | 4 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Released to WMS | ReleasedToWMS | ztDateTime |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Joint purchase (allowed) | SamInKopMark | ztBoolean |  |  | char
Sequence | Sequence | ztInteger | 3 |  | smallint
Time sqlcmd->trg start | SQLCmd2EnterTrg | ZtLong | 10 |  | int
Start av updatering/insert | SqlStmtStartedDT | ztDateTime |  |  | datetime
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Requisition | StrDateTimeBIA | ztString | 28 |  | varchar
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
This field is used in the table as follows: |
BOM for item | StycklistaTillArtNr | ztString | 30 |  | varchar
Suborder in capacity subcontr | SubKapacitetsLego | ztBoolean |  |  | char
ID for connection | Ti_LopNr_Ned | ZtLong | 10 |  | int
Visa tillverkningsordern | TiVisas | ztBoolean |  |  | char
OK to use tool | ToolOkToUse | ztBoolean |  |  | char
Transit delivery | TransitLeverans | ztBoolean |  |  | char
Transport days | TransportTid | ztInteger | 3 |  | smallint
Print order, alpha | TurOrdning | ztString | 20 |  | varchar
Original item no. | UrsprArtNr | ztString | 30 |  | varchar
Orig operation no. | UrsprOpNr | ztInteger | 3 |  | smallint
Print PO qty | UtskrBestDokAntal | ZtQty | 14 | 2 | decimal
Print disp date | UtskrBestDokLevDat | ztDate |  |  | datetime
Reprint purch order | UtskrBestDokSkaGoras | ztBoolean |  |  | char
New PO print date | UtskrBestDokUtskrDT | ztDateTime |  |  | datetime
Deliv from MO | UttagFranAoNr | Jeeves_MONo | 7 |  | bigint
Deliv from MO Pos | UttagFranAoPos | ztInteger | 5 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Gross purch price, curr (mtrl) | vb_inpris_mtrl | ztMoney | 14 | 2 | money
Gross setup price, curr | Vb_InPris_Stall | ztMoney | 14 | 2 | money
Gross start purch price, curr | Vb_InPris_Start | ztMoney | 14 | 2 | money
Cost price, curr | VbKalkPris | ztMoney | 14 | 2 | money
Breakdown, MO | VidareNedbrInomTo | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: Mr Material reservations

    Program: Mr_upd Material reservations, change

    Program: MrBooking Material reservations, booking


Material reservations (sum and sort) (wmr)

Sorted and totaled material reservations during printing of manufacturing order documents.
This work table is only used in a report during order document printing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Bin | ars_LagPlats | ztBinLocation | 20 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Op join list No. | KapLista | ZtLong | 10 |  | int
Labor operation picking list ID | LbrOpJoinPckList | ZtLong | 10 |  | int
Item version, demand | MrArtikelVariant | ztString | 30 |  | varchar
Item no. required | MrArtNr | ztString | 30 |  | varchar
Picked quantity | MrRappAnt | ZtQty | 14 | 2 | decimal
Reserved quantity | MrResAnt | ZtQty | 14 | 2 | decimal
Operation no. | OpNr | ztInteger | 3 |  | int
Ord-spec invtry bal | OrderUniktLager | ZtQty | 14 | 2 | decimal
Planned quantity | PlaneratAntal | ZtQty | 14 | 2 | decimal
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Deliv from MO | UttagFranAoNr | Jeeves_MONo | 7 |  | bigint
Deliv from MO Pos | UttagFranAoPos | ztInteger | 5 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar


Material reservations to change (wmrc)

Temporary table for storing the material reservations that are to affect change drawing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | Aopos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Item no. required | MrArtNr | ztString | 30 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Material reservations, picking, ser nos. (wmrs)

Work table to simply make a selection of material reservations by serial number.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Item no. required | MrArtNr | ztString | 30 |  | varchar
Reserved quantity | MrResAnt | ZtQty | 14 | 2 | decimal
Operation no. | OpNr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Material transaction journal (jmru)

Data in the journal header about material issue for manufacturing orders.
A journal only includes data of picking for one day, which is why one journal a day is normally created (several journals a day can however be created).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Material journal no. | MruJournNr | ZtLong | 6 |  | int
OK to pick date | MrUtplDat | ztDate |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: Jmru Material journal


Material-inventory connections (cmrl)

Links between manufacturing orders and existing batches/received deliveries in inventory. Records are created in the table when booking inventory to manufacturing orders (material reservations).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: cmrl Show bookings material-inventory


MATRIX batch log (jvsl)

Log of result/calculations from program batch.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Text | Edit | ztBlob | 1 |  | text
Hours | EventTimant2 | ztHourWithDecimals | 8 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | int
SQL-log (255 char) | JVSL_Edit_2_255 | ztInteger | 4 |  | int
Row | RadPos | ZtLong | 10 |  | int
Row | RadPos2 | ztInteger | 4 |  | int
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Column no. | RpKolNr | ztInteger | 4 |  | smallint
Batch no. | RpKorNr | ZtLong | 5 |  | int

    This table is the main table in the following programs:

    Program: xJvsl MATRIX batch log, errors


MATRIX batches, row results (jvsr)

Table for storing results from report batches. Information is stored here per result row.

Information about a generated report is stored in a table structure as follows:

- The report header lies in the table 'MATRIX report batches, header' (Jvsk) and always has one or more underlying subreports.

- Subreports (per report) lie in the table 'MATRIX report batch, results' (Jvsd) and always have one or more underlying result rows.

- Result rows (per subreport) lie in this table (Jvsr).

(The table is a view against the report database table Matrix_Jvsr.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Blank rows current row | AntalBlankrader | ztInteger | 5 |  | smallint
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | int
@zPrompt=null | IsThisASpec | ztBoolean |  |  | varchar
Signature | PersSign | ztBoolean |  |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Row | RadPos2 | ztInteger | 4 |  | int
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Column no. | RpKolNr | ztInteger | 4 |  | smallint
Batch no. | RpKorNr | ZtLong | 5 |  | int
Layout per template window | UseReportWindowNo | ztInteger | 5 |  | smallint
Text/info | x255 | ztString | 255 |  | varchar


Matrix printout rules (PvmPrintoutRules)

Set up printout rules for matrix printouts

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Break method | PvmBreakTypeId | ztInteger | 3 |  | smallint
No. of columns | PvmColumns | ztInteger | 5 |  | smallint
Exclude empty rows | PvmFill | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Template | YndMall | ztString | 40 |  | varchar
Report program | YndReport | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: PvmPrintoutRules Product variant matrix printout rules


MATRIX report batch, results (jvsd)

Table for storing results from report batches. Information is stored per subreport, i.e. per report structure, subreport, and so on.

Information about a generated report is stored in a table structure as follows:

- The report header lies in the table 'MATRIX report batches, header' (Jvsk) and always has one or more underlying subreports.

- Subreports (per report) lie in this table (Jvsd) and always have one or more underlying result rows.

- Result rows (per subreport) lie in the table 'MATRIX batches, row results' (Jvsr).

(The table is a view against the report database table Matrix_Jvsd.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
MATRIX | DataBlob | ztBlob | 1 |  | text
Value subreport 1 | DecTerm1Value | ztString | 30 |  | varchar
Value subreport 2 | DecTerm2Value | ztString | 30 |  | varchar
Value subreport 3 | DecTerm3Value | ztString | 30 |  | varchar
Value subreport 4 | DecTerm4Value | ztString | 30 |  | varchar
Value subreport 5 | DecTerm5Value | ztString | 30 |  | varchar
Decimal term | DecTermXValueBeskr | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | int
OLE-1 | Ole1 | ztString | 255 |  | varchar
OLE-2 | Ole2 | ztString | 255 |  | varchar
Print date | p_utskr_dat | ztDate |  |  | datetime
Row | RadPos | ZtLong | 10 |  | int
Row | RadPos2 | ztInteger | 4 |  | int
Structure description | RbStrBBeskr | ztString | 60 |  | varchar
Value report structure | RbStrBVarde | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Report request | RpBegNr | ZtLong | 6 |  | int
Column no. | RpKolNr | ztInteger | 4 |  | smallint
Batch no. | RpKorNr | ZtLong | 5 |  | int
Report no. | RpNr | ZtLong | 5 |  | int
Struct/subreport | StrAndDecDescrBlob | ztBlob | 1 |  | text

    This table is the main table in the following programs:

    Program: xJvsd Print MATRIX output (subreport)


MATRIX report batches, header (jvsk)

Main table for storing results from report batches. Information is stored here that belongs to the report header, i.e. general information such as report headers, report structure definition, report parameters, etc.

Information about a generated report is stored in a table structure as follows:

- The report header lies in this table (Jvsk) and always has one or more underlying subreports.

- Subreports (per report) lie in the table 'MATRIX report batch, results' (Jvsd) and always have one or more underlying result rows.

- Result rows (per subreport) lie in the table 'MATRIX batches, row results' (Jvsr)

(The table is a view against the report database table Matrix_Jvsk.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Column headings | ColHeadingBlob | ztBlob | 1 |  | text
Column definition | ColumnDefinition | ztBlob | 1 |  | text
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
Specification/sub-report | DecDefid | ztString | 6 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | int
Title | HeadingBlob | ztBlob | 1 |  | text
OLE-1 | Ole1 | ztString | 255 |  | varchar
OLE-2 | Ole2 | ztString | 255 |  | varchar
Print date | p_Utskr_Dat | ztDate |  |  | datetime
Parameters, batch | ParameterBlob | ztBlob | 1 |  | text
Report group | RapportGrupp | ztString | 6 |  | varchar
Structure ID | RbStrId | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Row definition | RowDefinition | ztBlob | 1 |  | text
Report request | RpBegBeskr | ztString | 45 |  | varchar
Report request | RpBegNr | ZtLong | 6 |  | int
Batch no. | RpKorNr | ZtLong | 5 |  | int
Report no. | RpNr | ZtLong | 5 |  | int
Report title | RpRubrik | ztString | 255 |  | varchar
Save result in column | SaveMatrixResultInColumn | ztString | 120 |  | varchar
Spara resultat i DB | SaveMatrixResultInDatabase | ztString | 120 |  | varchar
Spara resultat i Table | SaveMatrixResultInTable | ztString | 120 |  | varchar
Specification | SpecDefId | ztString | 6 |  | varchar
Structure definition | StructureBlob | ztBlob | 1 |  | text

    This table is the main table in the following programs:

    Program: xJvsk Print MATRIX output


Members, approval chain (atkrpres)

Selection of members from a resource group to be part of an approval chain for change orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval chain | attkedja | ztInteger | 5 |  | smallint
Approval type | ECOAppTypecode | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Mandatory level | mandatorychainlevel | ztBoolean |  |  | char
Mandatory resource | mandatoryresource | ztBoolean |  |  | char
Only for distribution | onlydistribute | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | perssign2 | ztString | 6 |  | varchar
Level approval chain | posattkedja | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Resource group | resursgrp | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence | sequence | ztInteger | 3 |  | smallint

    This table is the main table in the following programs:

    Program: xatkrpres Members, approval chain


Menus (JvsSiteMenu)

Program/table for viewing and editing menus.

In the left embedded window you can see the menu's current name per language, and also edit these texts.

In the right embedded window you can see the whole menu with the internal ids of menu folders and the datanames of the programs in each folder. To view and edit the names of menu folders you use the Language management program (jvssitelang).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Menu content | JvsSiteMenuDesc | ztBlob | 1 |  | varchar
Name | JvsSiteMenuName | ztString | 40 |  | nvarchar
Menu name (lang) | JvsSiteMenuName_Lang | ztString | 40 |  | nvarchar
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Menu ID | MenuId | ZtLong | 5 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteMenu Menus


Message types (edim)

Contains the different EDI message types to be processed. Incoming as well as outgoing message types are placed in this table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Issue agency | ControllingAgency | ztString | 2 |  | varchar
Sequence no. | EdiCommandSeqNo | ztInteger | 5 |  | smallint
Conversion program | EdiConvProg | ztString | 255 |  | varchar
Issuer's code | EdiDesignCode | ztString | 6 |  | varchar
Command after conv | EdiExecAfterConv | ztString | 255 |  | varchar
Command before conv. | EdiExecBeforeConv | ztString | 255 |  | varchar
File extension | EdiFileExt | ztString | 10 |  | varchar
In/Out | EdiInUt | ztBoolean |  |  | char
Main table | EdiMainTable | ztString | 30 |  | varchar
Variant (EDI) | EdiMessageVariant | ztString | 35 |  | varchar
EDI message | EdiMsgDescr | ztString | 50 |  | varchar
Message number | EdiMsgNo | ztInteger | 5 |  | smallint
SQLScript | EdiSqlScript | ztBlob | 1 |  | varchar
Syntax converter | EdiSyntaxConvNo | ztInteger | 5 |  | smallint
Command | EdiSyntaxConvStr | ztString | 255 |  | varchar
Save trace.log | EdiTraceLog | ztBoolean |  |  | char
End variant | EdiWrite_Mode | ztInteger | 1 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Message | MessageType | ztString | 6 |  | varchar
Message version | MessageVer | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Release | ReleaseNumber | ztString | 3 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: edim Message types


Message, eBrev (ebml)

Sent eBrev files.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Number letters | eb_antalbrev | ZtLong | 10 |  | int
No. of rows | eb_antalrader | ZtLong | 10 |  | int
Number of pages | eb_antalsidor | ZtLong | 10 |  | int
Unique ID eBrev | eb_komm_id | ztInteger | 5 |  | smallint
eBrev sent | ebFilSent | ztBoolean |  |  | char
eBrev file sent date | ebFilSentDt | ztDateTime |  |  | datetime
eBrev created | ebFilSkapad | ztBoolean |  |  | char
File created | ebFilSkapadDt | ztDateTime |  |  | datetime
Receipt | ebKvitterad | ztBoolean |  |  | char
Receipt, date | ebKvitteradDt | ztDateTime |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | kortnotering | ztString | 255 |  | varchar
Document file path | pdmfilename | ztString | 250 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | Sqlidentity | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: xebml Log, eBrev


Mfg group, person, time rep (tpgv)

Reported time per manufacturing group, person and report day.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Worked hrs/person | ArbTimPerPers | ztHourWithDecimals | 8 | 2 | decimal
Text | Edit | ztBlob | 1 |  | varchar
Hours | EventTimant2 | ztHourWithDecimals | 8 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | KortNotering | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Mfg suborder (ti)

Suborders for manufacturing orders. A manufacturing order (header) can contain several sub orders for the manufacturing of entirely different items or items with different delivery dates.
If there are 'logical/non stocked' items in a bill of materials, these are broken down one level further and create a new suborder.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting complete | AccountingDone | ztBoolean |  |  | char
Active | Aktiv | ztInteger | 1 |  | smallint
Booking of MO | AllowBookingMO | ztBoolean |  |  | char
Replan in net req | AllowReplanInNetReq | ztBoolean |  |  | char
Alternativ op | AltOpKod | ztString | 2 |  | varchar
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Quantity | Antal | ZtQty | 14 | 2 | decimal
Quantity to manufacture | AntalAttTillverka | ZtQty | 14 | 2 | decimal
Decimal places | AntDec | ztInteger | 1 |  | smallint
No days to plan dispatch | AntDgrTillPlanLevDat | ztInteger | 1 |  | smallint
No. unprocessed purch | AntMtrlKopEjBeh | ZtLong | 10 |  | int
Interruption code | AoAvbrottsKod | ztInteger | 5 |  | smallint
MO type | AoKod | ztInteger | 2 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
MO number series | AoNrSerie | ztInteger | 5 |  | smallint
Row | AoPos | ztInteger | 4 |  | int
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
This field is used in the table as follows: |
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
This field is used in the table as follows: |
Final report date | AoSlutMarkDat | ztDate |  |  | datetime
MO/Works order status | AoStatKod | ztInteger | 1 |  | smallint
Original ops end date | AoUrsprSlutDat | ztDate |  |  | datetime
CalcCost labour/op | ArbKalkArbKost | ZtBaseCurrAmount | 14 | 2 | money
This field is used in the table as follows: |
Calc setup cost | ArbKalkStallKost | ZtBaseCurrAmount | 14 | 2 | money
This field is used in the table as follows: |
Actual labour cost | ArbVerklArbKost | ZtBaseCurrAmount | 14 | 2 | money
This field is used in the table as follows: |
Actual setup cost | ArbVerklStallKost | ZtBaseCurrAmount | 14 | 2 | money
This field is used in the table as follows: |
Item description | ArtBeskr | ztString | 30 |  | varchar
This field is used in the table as follows: |
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Item variant | ArtikelVariant | ztString | 30 |  | varchar
This field is used in the table as follows: |
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
B-kostnad | ArtKalkBerB | ZtBaseCurrAmount | 14 | 2 | money
C-kostnad | ArtKalkBerC | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Cost price (actual) | ArtKalkprisE | ZtBaseCurrAmount | 14 | 2 | money
Cost price at order | ArtKalkprisO | ZtBaseCurrAmount | 14 | 2 | money
Cost at order (mtrl) | ArtKalkPrisOMtrl | ZtBaseCurrAmount | 14 | 2 | money
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
BOM level | ArtNivaBeskr | ztString | 20 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Revision date | ArtRevDat | ztDate |  |  | datetime
Revision no. | ArtRevId | ztString | 10 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Agreed/requested prc | AvtalatPris | ZtBaseCurrAmount | 14 | 2 | money
Base(prefix) for S/N | Base_Serial_No | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Workload type | BelaggningsKod | ztInteger | 2 |  | smallint
Ordered | Bestallas | ztBoolean |  |  | char
This field is used in the table as follows: |
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Purch order no. (alpha) | BestNrAlfa | ztString | 50 |  | varchar
Confirmed date | BestOEDatum | ztDate |  |  | datetime
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Bottleneck priority | BNeckPrio | ztInteger | 5 |  | smallint
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Accounting date | BokfDat | ztDate |  |  | datetime
Availability check date | BristKontrolleradDatum | ztDate |  |  | datetime
Avail check status code | BristKontrolleradStatus | ztInteger | 5 |  | smallint
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
CTP Status | CTP_Stat | ztInteger | 1 |  | smallint
This field is used in the table as follows: |
Partial booking allowed | DelBokningTillaten | ztInteger | 5 |  | smallint
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Overhead, work, admin | EstLabOvhdAdmCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, production | EstLabOvhdPrdCost | ZtBaseCurrAmount | 14 | 2 | money
Overheads, work, sales | EstLabOvhdSalesCost | ZtBaseCurrAmount | 14 | 2 | money
Reported end time | EventRpTime | ztTime | 5 |  | datetime
Time | EventTime | ztTime | 4 |  | datetime
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Körtid, skapa arbetsorder | ExecutionTimeCreateWO | ztFloat | 15 | 2 | float
Extra days for recvd delivery | ExtraDagarInlev | ztInteger | 5 |  | smallint
Delivery received date plan.list | ExtraDagarInlevDatum | ztDate |  |  | datetime
Actual fixed cost | FastVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Est delivery value | FkalkInlevVarde | ZtBaseCurrAmount | 14 | 2 | money
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Throughput time | GenomLoppsTid | ztFloat | 8 | 2 | float
Throughput time adj | GenomLoppsTidJust | ztFloat | 8 | 2 | float
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Receiving value | InlevKalkVarde | ZtBaseCurrAmount | 14 | 2 | money
Calc delivery value (adjustm) | InlevKalkVardeJustering | ZtBaseCurrAmount | 14 | 2 | money
Calc val rcvd mtrl | InlevKalkVardeMtrl | ZtBaseCurrAmount | 14 | 2 | money
Receive to MO | InlevTillAoNr | Jeeves_MONo | 7 |  | bigint
Receive to MO Pos | InlevTillAoPos | ztInteger | 4 |  | int
Receive to MO Op | InlevTillOpNr | ztInteger | 3 |  | smallint
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Calculation date | KalkBerDatum | ztDate |  |  | datetime
Capacity status | KapacitetsStatus | ztInteger | 5 |  | smallint
Allocated time, subcontr cap | KapLegoAnslagenTid | ztOpTime | 9 | 4 | float
Prel alloc time, subcontr cap | KapLegoAnslagenTidP | ztOpTime | 9 | 4 | float
Sent from dept/S3 | KBarAvsandandeEnhet | ztString | 8 |  | varchar
CO specific CC (rec) | KBarOULager | ztString | 8 |  | varchar
WIP Cost units/segment 3 | KBarPIA | ztString | 8 |  | varchar
Purchase of item | KopAvArtikel | ztBoolean |  |  | char
Buy manuf of item | KopTillvAvArtikel | ztBoolean |  |  | char
KörID | KorId | ZtLong | 10 |  | int
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
Note | KortNotering | ztString | 255 |  | varchar
Shortcut/number | KortNrTi | ZtLong | 10 |  | int
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Queue time | KoTid | ztFloat | 15 | 2 | float
CC dispatched unit | KstAvsandandeEnhet | ztString | 8 |  | varchar
Orderspec rcv CC | KstOULager | ztString | 8 |  | varchar
WIP CC | KstPIA | ztString | 8 |  | varchar
CC manufacturing diff | KstTillvDiff | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Orderspec rcv account | KtoNrOULager | ztString | 8 |  | varchar
WIP account | KtoNrPIA | ztString | 8 |  | varchar
Acct manufacturing diff | KtoNrTillvDiff | ztString | 8 |  | varchar
Stocked | LagerBokas | ztBoolean |  |  | char
Value to price | LagerVardeEnlInPris | ztBoolean |  |  | char
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invntry loc, mtrl res | LagstalleMtrlRes | ztString | 2 |  | varchar
Lagerst för OU-lager | LagStalleOULager | ztString | 2 |  | varchar
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Lead time adj | LedTidJust | ztInteger | 3 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Locked for date change | LockedForIndirectDteChg | ztBoolean |  |  | char
Locked end date MO | LockedProdDueDt | ztBoolean |  |  | char
Sequence no. | LopNr | ZtLong | 10 |  | int
Manuf yield % | ManufYieldPercent | ZtDecimal73 | 8 | 3 | decimal
All positions same date | MarkIfAllTi2ThStartDate | ztBoolean |  |  | char
Multiple flow groups | MarkIfMultiFlowGroups | ztBoolean |  |  | char
Ord spec cost price | MarkOrderUniktKalkp | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Order run | MarkTiOrderKord | ztBoolean |  |  | char
New prel finish date | MONewPrelComplDt | ztDate |  |  | datetime
Diff new prel end date | MONewPrelComplDtDiff | ztInteger | 5 |  | smallint
New prel start dat | MONewPrelStartDt | ztDate |  |  | datetime
Priority ordering MO | MOPriority | ztInteger | 2 |  | smallint
MO qty pre yield calc | MOQtyPreYieldCalc | ZtQty | 14 | 2 | decimal
Status in WIP for MO | MoWipStatCd | ztInteger | 3 |  | smallint
Calc mtrl cost | MtrlKalkKost | ZtBaseCurrAmount | 14 | 2 | money
Actual material cost | MtrlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (refinement) | MtrlVerklKostForadling | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (mtrl) | MtrlVerklKostMtrl | ZtBaseCurrAmount | 14 | 2 | money
Pick flag date | OkAttPlockaSattDatum | ztDate |  |  | datetime
Pick status | OkAttPlockaStatus | ztInteger | 5 |  | smallint
B quantity | OrdAntalB | ztFloat | 15 | 2 | float
C quantity | OrdAntalC | ztFloat | 15 | 2 | float
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Booking status | OrdBokningsStatus | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Order spec text | OrpRadText | ztString | 255 |  | varchar
Print date | p_Utskr_Dat | ztDate |  |  | datetime
Quantity PDM | pdmcount | ZtLong | 10 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project manager | PersSign1 | ztString | 6 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Pick order | PlockOrder | ztBoolean |  |  | char
Picking list date | PLUtskrDat | ztDateTime |  |  | datetime
Manufacturing group | ProdGr | ztString | 5 |  | varchar
This field is used in the table as follows: |
Project ID | ProjCode | ztString | 10 |  | varchar
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Row | RadPos2 | ztInteger | 4 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Spare part order | ReservdelsOrder | ztBoolean |  |  | char
Act variable cost | RorlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Build-up of safety stock | SakLagUppByggnad | ZtQty | 14 | 2 | decimal
Joint purchase (allowed) | SamInKopMark | ztBoolean |  |  | char
Send: Delivered | SendDeliv | ztBoolean |  |  | char
Deliv notification date | SendDelivDoneDT | ztDateTime |  |  | datetime
Sequence for S/N | Serial_No_Count | ZtLong | 10 |  | int
Time sqlcmd->trg start | SQLCmd2EnterTrg | ZtLong | 10 |  | int
Start av updatering/insert | SqlStmtStartedDT | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Startkonterad | StartKonterad | ztBoolean |  |  | char
Date/time | StrDateTime | ztString | 28 |  | varchar
Requisition | StrDateTimeBia | ztString | 28 |  | varchar
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Suborder in capacity subcontr | SubKapacitetsLego | ztBoolean |  |  | char
Rapp ställtid (tot) | SumAoRappStallTid | ztOpTime | 9 | 4 | float
Rapp styckarb.tid (tot) | SumAoRappStyckTid | ztOpTime | 9 | 4 | float
Ställtid för op (tot) | SumStallTid | ztOpTime | 9 | 4 | float
Stycktid (tot) | SumStyckTid | ztOpTime | 9 | 4 | float
Manufacturing journal | ThJournNr | ZtLong | 6 |  | int
Work order printed | ThUtskrDat | ztDateTime |  |  | datetime
ID for connection | Ti_LopNr_Ned | ZtLong | 10 |  | int
Manufacturing cost posted | TillvKostKonteras | ztBoolean |  |  | char
Mfg cost diff | TillvVinst | ZtBaseCurrAmount | 14 | 2 | money
Start date before adjustment | TiMinStartDatOrig | ztDateTime |  |  | datetime
Mtrl/op created on | TiNedbrutenDatum | ztDateTime |  |  | datetime
Reported mfg qty | TiRappAnt | ZtQty | 14 | 2 | decimal
This field is used in the table as follows: |
MO entry date | TiRegDat | ztDate |  |  | datetime
Remaining qty to manuf | TiRestAnt | ZtQty | 14 | 2 | decimal
Ready date | TiSlutDat | ztDate |  |  | datetime
Ready date when creating MO | TiSlutDatOrig | ztDateTime |  |  | datetime
Finish date (JPS) | TiSlutDatTid | ztDateTime |  |  | datetime
BOM, revision date | TiSrRevDatum | ztDate |  |  | datetime
Start date | TiStartDat | ztDate |  |  | datetime
Start date when creating MO | TiStartDatOrig | ztDateTime |  |  | datetime
Start date (JPS) | TiStartDatTid | ztDateTime |  |  | datetime
Tillverkningstatus | TiStatKod | ztInteger | 1 |  | smallint
Visa tillverkningsordern | TiVisas | ztBoolean |  |  | char
OK to use tool | ToolOkToUse | ztBoolean |  |  | char
Reprint purch order | UtskrBestDokSkaGoras | ztBoolean |  |  | char
New PO print date | UtskrBestDokUtskrDT | ztDateTime |  |  | datetime
Print promised qty | UtskrDokLovAntal | ZtQty | 14 | 2 | decimal
Print promised disp date | UtskrDokLovLevDat | ztDate |  |  | datetime
Print promised price | UtskrDokLovPris | ZtSalesPrice | 12 | 2 | money
Print order acknowl | UtskrDokLovSkaGoras | ztBoolean |  |  | char
Print date new OA | UtskrDokLovUtskrDT | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Price, curr | Vb_Pris | ZtSalesPrice | 12 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
External setup time for op | YttreStallTid | ztOpTime | 9 | 4 | float

    This table is the main table in the following programs:

    Program: aor_to_hrp Manhours -> Rep. act.

    Program: AoUpdMoFromBlueprint MO Update, view labour operations

    Program: MODeliv_PIK MODeliv_PIK

    Program: MOLinePickBookedMtrl Material issues, suborders

    Program: MOMtrl_PIK Material issues, booking

    Program: Mru2 Material issues, suborders

    Program: Mru3 Labour reporting, suborders

    Program: Mru4 Material issues, booking (suborders)

    Program: MrUpdMoFromBlueprint MO Update, view material reservations

    Program: SrLa3 Assembly analysis, MO

    Program: ti Mfg suborder

    Program: ti_prg Mfg suborder

    Program: ti_ReCalc_Workload MO, preliminary changed end date

    Program: Ti2GL Final posting manufacturing orders->GL

    Program: TiChgAoMr Suborder, manuf., draw. chg. in report

    Program: TiqQdin Q - data (manufacturing order)

    Program: UpdMoFromBlueprint MO Update

    Program: XthRapp Material issues and received deliveries

    Program: xTi Manufacturing suborders

    Program: xTiEnd Final posting manufacturing order


Mfg suborder VIEW (vti)

A manufacturing order (header) can contain several suborders (this table) for the manufacturing of entirely different items or items with different delivery dates.
If there are 'logical/non stocked' items in a bill of materials, these are broken down one level further and create a new suborder.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Quantity | Antal | ZtQty | 14 | 2 | decimal
Decimal places | AntDec | ztInteger | 1 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Final report date | AoSlutMarkDat | ztDate |  |  | datetime
MO/Works order status | AoStatKod | ztInteger | 1 |  | smallint
Original ops end date | AoUrsprSlutDat | ztDate |  |  | datetime
CalcCost labour/op | ArbKalkArbKost | ZtBaseCurrAmount | 14 | 2 | money
Calc setup cost | ArbKalkStallKost | ZtBaseCurrAmount | 14 | 2 | money
Actual labour cost | ArbVerklArbKost | ZtBaseCurrAmount | 14 | 2 | money
Actual setup cost | ArbVerklStallKost | ZtBaseCurrAmount | 14 | 2 | money
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Cost price (actual) | ArtKalkprisE | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Revision date | ArtRevDat | ztDate |  |  | datetime
Revision no. | ArtRevId | ztString | 10 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Workload type | BelaggningsKod | ztInteger | 2 |  | smallint
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Purch order no. (alpha) | BestNrAlfa | ztString | 50 |  | varchar
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Accounting date | BokfDat | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Actual fixed cost | FastVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Throughput time | GenomLoppsTid | ztFloat | 8 | 2 | float
Throughput time adj | GenomLoppsTidJust | ztFloat | 8 | 2 | float
Receiving value | InlevKalkVarde | ZtBaseCurrAmount | 14 | 2 | money
Receive to MO | InlevTillAoNr | Jeeves_MONo | 7 |  | bigint
Receive to MO Pos | InlevTillAoPos | ztInteger | 4 |  | int
Receive to MO Op | InlevTillOpNr | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
Calculation date | KalkBerDatum | ztDate |  |  | datetime
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Orderspec rcv CC | KstOULager | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Orderspec rcv account | KtoNrOULager | ztString | 8 |  | varchar
Stocked | LagerBokas | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Lagerst för OU-lager | LagStalleOULager | ztString | 2 |  | varchar
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Calc mtrl cost | MtrlKalkKost | ZtBaseCurrAmount | 14 | 2 | money
Actual material cost | MtrlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project manager | PersSign1 | ztString | 6 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Act variable cost | RorlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Manufacturing journal | ThJournNr | ZtLong | 6 |  | int
Mfg cost diff | TillvVinst | ZtBaseCurrAmount | 14 | 2 | money
Mtrl/op created on | TiNedbrutenDatum | ztDateTime |  |  | datetime
Reported mfg qty | TiRappAnt | ZtQty | 14 | 2 | decimal
MO entry date | TiRegDat | ztDate |  |  | datetime
Remaining qty to manuf | TiRestAnt | ZtQty | 14 | 2 | decimal
Ready date | TiSlutDat | ztDate |  |  | datetime
Start date | TiStartDat | ztDate |  |  | datetime
Tillverkningstatus | TiStatKod | ztInteger | 1 |  | smallint
Reprint purch order | UtskrBestDokSkaGoras | ztBoolean |  |  | char
Print promised qty | UtskrDokLovAntal | ZtQty | 14 | 2 | decimal
Print promised disp date | UtskrDokLovLevDat | ztDate |  |  | datetime
Print order acknowl | UtskrDokLovSkaGoras | ztBoolean |  |  | char
Print date new OA | UtskrDokLovUtskrDT | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint


Mfg transactions->GL (tovt)

Detailed data by transaction of how manufacturing transactions are posted when integrated with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Tillverkningsjournal | ToJournNr | ZtLong | 6 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint


MHA (WMS_Mha)

Definition of MHAs, Material handling areas, with information about type, management, etc. Each inventory location in the WMS module must be comprised of at least one MHA.

If the MHA is location based, racks and locations must also be defined for the area. If the MHA is area based then only the MHA needs to be defined.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Check digits | CheckSum | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
MHA | Mha | ztString | 5 |  | varchar
Description | MhaDesc | ztString | 50 |  | varchar
Picking queue | MhaPickQueue | ztString | 5 |  | varchar
Sequence | MhaPickQueueSeq | ztInteger | 3 |  | smallint
Storage queue | MhaPutQueue | ztString | 5 |  | varchar
Type | MhaTypeCode | ztInteger | 3 |  | smallint
Handling | MhaUsageCode | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_Mha MHA

    Program: WMS_MhaPallet MHA areas, pallets

    Program: WMS_MhaRack MHA location, racks


MHA (WMS_V_Mha)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 4 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
MHA | Mha | ztString | 5 |  | varchar
Description | MhaDesc | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_Mha2 MHA


MHA type code (WMS_MhaTypeCode)

Numeric code for type of MHA.

The following standard records exist. Do not alter/delete:

Type (MhaTypeCode) | Description (MhaTypeDesc) | Description
1 | Area | The MHA is an area within the inventory location without division into racks and specific locations.
2 | Location based | The MHA is location-based, i.e. divided into racks and specific locations that are used in all inventory transactions within the MHA.
3 | Mobile | A mobile unit is also a MHA with this type code, which makes it possible to store, transport or stock keeping units on the mobile unit, much like area based areas.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Type | MhaTypeCode | ztInteger | 3 |  | smallint
Description | MhaTypeDesc | ztString | 50 |  | varchar
Location based | MhaTypeHasLoc | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_MhaTypeCode MHA type code


MHA usage code (WMS_MhaUsageCode)

Code for MHA management. Specifies what type of operations can be made on each MHA.

The following standard records exist. Do not alter/delete:

Handling (MhaUsageCode) | Description (MhaUsageDesc) | Description
1 | Storage | MHAs used as buffer areas or picking areas should have this usage code.
2 | Receiving | Received deliveries in the WMS module can only be placed in MHAs with this usage code.
3 | Dispatch | Dispatch of goods is done via MHAs with this usage code. Only MHAs with this usage code can be chosen as load locations in the shipment planning program.
4 | Manufacturing | MHAs used as destination areas for manufacturing order picking should have this usage code. Only MHAs with this usage code can be connected to a manufacturing group. When material is returned from production it can only be received in MHAs with this usage code.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Handling | MhaUsageCode | ztInteger | 3 |  | smallint
Description | MhaUsageDesc | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_MhaUsageCode MHA usage code


MHA, view (VWms_Mha)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Check digits | CheckSum | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
MHA | Mha | ztString | 5 |  | varchar
Description | MhaDesc | ztString | 50 |  | varchar
Picking queue | MhaPickQueue | ztString | 5 |  | varchar
Sequence | MhaPickQueueSeq | ztInteger | 3 |  | smallint
Storage queue | MhaPutQueue | ztString | 5 |  | varchar
Type | MhaTypeCode | ztInteger | 3 |  | smallint
Handling | MhaUsageCode | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: VWMS_Mha MHA, view


MHA, view (VwWms_Mha)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Check digits | CheckSum | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
MHA | Mha | ztString | 5 |  | varchar
Description | MhaDesc | ztString | 50 |  | varchar
Picking queue | MhaPickQueue | ztString | 5 |  | varchar
Sequence | MhaPickQueueSeq | ztInteger | 3 |  | smallint
Storage queue | MhaPutQueue | ztString | 5 |  | varchar
Type | MhaTypeCode | ztInteger | 3 |  | smallint
Handling | MhaUsageCode | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: VwWMS_Mha MHA, view


MO -> GL (thvt)

Detailed data by transaction of how manufacturing calculation differences are posted when integrated with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Product acct, labour | ArbProdKonto | ztString | 8 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Manufacturing journal | ThJournNr | ZtLong | 6 |  | int
UniqueIDInAKLT | UniqueIDInAKLT | ZtLong | 10 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: xThvt GL posting, mfg cost discrepancies


MO types (xo3)

Definition of manufacturing order types and specification of number series per manufacturing order type.

The following standard records exist. Do not alter/delete:

MO type (AoKod) | MO type (AoKodBeskr) | Description
0 | Manufacturing order | The normal order type for an order that is manufactured.
50 | Forecast incl material | Forecast orders cannot be reported. Forecast order with material reservation can be used when the reservation is not to be done exactly according to BOM or if you always wish to have the material reservation in the planning list.
80 | Forecast excl material | Forecast excluding material makes it easier and quicker to enter, change and delete an order, but remember that there is no demand for on material or workload.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
MO type | AoKod | ztInteger | 2 |  | smallint
MO type | AoKodBeskr | ztString | 50 |  | varchar
MO number series | AoNrSerie | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xo3 MO types


MO WIP status (MoWipStat)

Table containing the different status codes available for WIP status on manufacturing orders.
(WIP = work in progress).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Status in WIP for MO | MoWipStatCd | ztInteger | 3 |  | smallint
Status in WIP for MO | MoWipStatDescr | ztString | 80 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: MoWipStat WIP status codes for manufacturing order


MO, user status (xths)

Definition of status codes defined by the customer for manufacturing orders. These status codes are intended to describe where an order is in the manufacturing process to make it easier to answer questions about orders.

***** Not used in Jeeves standard *****

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
MO/Works order status | WoUserStatus | ztInteger | 5 |  | smallint
MO/Works order status | WoUserStatusDescr | ztString | 50 |  | varchar


MO/Works order status (x1a)

Definition of occurring manufacturing order statuses, used to indicate which phase of manufacturing an order is in.

The following standard records exist. Do not alter/delete:

MO/Works order status (AoStatKod) | MO/Works order status (AoStatBeskr) | Description
0 | MO entered | Status is assigned automatically when the manufacturing order is registered.
1 | MO printed | Status is assigned automatically when the manufacturing order is printed out.
2 | MO started/activated | Status is not assigned by default but can be set manually or by using a macro when necessary to show that the order is pending, etc.
3 | Material picked | Status is assigned automatically when material is pulled for the manufacturing order.
4 | Work started | Status is assigned automatically upon reporting of time worked on the manufacturing order.
6 | Partially received/received | Status is assigned automatically upon delivery of the manufactured items.
7 | Canceled | Status is assigned manually to cancel a manufacturing order.
8 | Completed | Status is assigned automatically when the manufacturing order is marked complete.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
MO/Works order status | AoStatBeskr | ztString | 50 |  | varchar
MO/Works order status | AoStatKod | ztInteger | 1 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xx1a Work order status


MO/Works order status, time (thst)

Table to facilitate reporting manufacturing orders.
Reported time and the status of the order are given under the manufacturing order.
The status codes are defined in a table according to customer requirements (theses are not used actively in Jeeves but are used to facilitate the setting of order status for searches and similar).
*** NOT IN USE ***

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Worked hours | ArbetadeTimmmar | ztHourWithDecimals | 8 | 2 | decimal
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Foreman area | FormansOmrade | ztString | 6 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Note | KortNotering | ztString | 255 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Pay-Roll transfer type | PayRollTransferType | ztInteger | 5 |  | smallint
Pay-Roll Type | PayRollType | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Price | Pris | ZtBaseCurrAmount | 14 | 2 | money
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Reported mfg qty | TiRappAnt | ZtQty | 14 | 2 | decimal
MO/Works order status | WoUserStatus | ztInteger | 5 |  | smallint


Mobile terminal (WMS_Terminal)

Definition of terminals used in mobile operations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Description | TerminalDesc | ztString | 50 |  | varchar
Terminal | TerminalId | ztString | 20 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_Terminal Mobile terminal


Mobile unit (WMS_MobileUnit)

Definition of mobile units used in the specified inventory location, with information about logged-in users, terminal etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Default printer | DefaultPrinter | ztString | 20 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Mobile unit | MobileUnit | ztString | 5 |  | varchar
Description | MobileUnitDesc | ztString | 50 |  | varchar
Installed terminal | MobileUnitTerminalMount | ztBoolean |  |  | char
User | MobileUnitUser | ztString | 6 |  | varchar
Number of labels | NumberOfLabels | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Printer | Printer | ztString | 20 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Terminal | TerminalId | ztString | 20 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_MobileUnit Mobile unit

    Program: WMS_MU_FetchPallet Fetch

    Program: WMS_MU_FullPallPick Full pallet pick

    Program: WMS_MU_PallPick Pick

    Program: WMS_MU_ReplenPick Replenishment pick

    Program: WMS_MU_UnLoadPallet Unload


Monetary factors (pf)

This table defines costs for labour (wage related costs).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Product acct, labour | ArbProdKonto | ztString | 8 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
New cost as of date | NewCostsFromDate | ztDate |  |  | datetime
Monetary factor | PenningFaktBen | ztString | 40 |  | varchar
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Piece rate wages | PfAckordsLon | ZtBaseCurrAmount | 14 | 2 | money
Ackordslön | PfAckordsLonNytt | ZtBaseCurrAmount | 14 | 2 | money
Payroll overhead | PfLoneBiKost | ZtDecimal73 | 7 | 2 | decimal
Lönebikostnad % (ny) | PfLoneBiKostNytt | ZtDecimal73 | 7 | 2 | decimal
Fxd wage setup time | PfStallLon | ZtBaseCurrAmount | 14 | 2 | money
Fast lön und ställtid(ny) | PfStallLonNytt | ZtBaseCurrAmount | 14 | 2 | money
Fxd wages per hour | PfTimLon | ZtBaseCurrAmount | 14 | 2 | money
Fast timlön (ny) | PfTimLonNytt | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: pf Monetary factors


MPC product accounts (apk)

Rules for the posting of labour transactions.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Product acct, labour | ArbProdKonto | ztString | 8 |  | varchar
Product acct, labour | ArbProdKontoBeskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: apk Product accounts, labour


MRP - batches (nefr)

This table specifies which default setting for batch selection and what preset selection will be used.
Net requirement planning can be done based on this table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
MRP template ID | NE_Fi_Id | ztInteger | 5 |  | smallint
MRP batch ID | NE_Fr_Id | ztInteger | 5 |  | smallint
MRP filter ID | NE_Fw_Id | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: nefr MRP - batches, preset


MRP log (xnel)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Error code | ErrCode | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
ID number | X_IdNr | ZtLong | 10 |  | int
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xnel MRP log


Mtrl transactions->GL (mrvt)

Detailed information per transaction of how material transactions are posted when integrated to the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Document ID | docnumid | ztString | 30 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Material journal no. | MruJournNr | ZtLong | 6 |  | int
Operation no. | OpNr | ztInteger | 3 |  | int
Period | Period | ztInteger | 4 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
UniqueIDInAKLT | UniqueIDInAKLT | ZtLong | 10 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: xMrvt Posting, material issues


Multi POs linked to invoice (LrCollBh)

Record for multi match purchases on a supplier invoice.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
PO no. | BestNr | Jeeves_PONo | 6 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Multi-company reports (mcrp)

Definition of the reports that can be printed/run simultaneously for several companies

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Group | grupp | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Report program | YndReport | ztString | 40 |  | nvarchar

    This table is the main table in the following programs:

    Program: mcrp Multi-company reports


Multiple settings (JvsSiteNodeWinMultiProperty)

Program/table for viewing and editing multiple settings, i.e. settings of which there can be several instances for the same key and setting dimensions. Example of settings stored here are saved search conditions, program connections, accelerator keys etc.

The program/table can be accessed through an embedded window in the program Setting dimensions/keys (jvssitenodewin) or from Jeeves' menu.

For settings involving own texts there is also an embedded window for translating these texts to other languages in which the system is run.

Note that the fields in the header show the program/node/window in which the setting applies, e.g. if a program is named in the Program field, the setting only applies if that program is open. For settings that apply to programs, but do not require the program in question to be open, the program name is stored in the Edit field.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Setting ID (orig) | JvsSiteNodeWinSettingsID_orig | ZtLong | 10 |  | int
Data | JvsSitePropertyData | ztString | 7500 |  | nvarchar
Name | JvsSitePropertyKey | ztString | 64 |  | nvarchar
Type | JvsSitePropertyName | ztString | 64 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: jvssitenodewinmultiproperty Multiple settings


Municipalities (xn4)

Definition of municipalities or equivalent as per individual need for grouping/searching of companies in the company table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Municipality | kommun | ztString | 5 |  | varchar
Municipality | kommunbeskr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xn4 Municipalities


New year (wxra)

Information about the new fiscal year.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
New fiscal year | RedovisnArNew | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Date/time | StrDateTime | ztString | 28 |  | varchar

    This table is the main table in the following programs:

    Program: XrarNew Generate new fiscal year


Next free transaction id (XmlTran)

A table that holds details about the next free transaction id for xml messages.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Transaction Id | TranId | ZtHugeInt | 20 |  | bigint

    This table is the main table in the following programs:

    Program: XmlTran Next free transaction id


Node settings (ynd)

Settings for individual programs and program nodes made using options under Tools on the menu bar such as the first fields at entry, hide program node, macro calls, the form’s or list’s mode in the window and column settings. In addition, any possible settings which reports should be shown on the program report menu.

Choose from personal/global: Yes
Per company: No

(This table replaces table Vynd.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Global settings | Global | ztString | 1 |  | char
Group | Grupp | ztInteger | 4 |  | smallint
Program node | Node | ztString | 35 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Program | pgm | ztString | 40 |  | nvarchar
Settings | Props | ztBlob | 1 |  | text
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ynd Personal settings for programs/screens


Nodes from xml file (used in mapping program) (XmlNodes)

Help table for xml-mapping

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Configurator model ID | ModelId | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Mapping Out | XmlMappingOut | ztBoolean |  |  | char
Nodeindex | XmlNodeIndex | ztInteger | 5 |  | smallint
Nodename | XmlNodeName | ztString | 128 |  | varchar
Nodetype | XmlNodeType | ztInteger | 5 |  | smallint
Nodevalue | XmlNodeValue | ztString | 1600 |  | varchar
Parent nodeindex | XmlParentNodeIndex | ztInteger | 5 |  | smallint
Top parent nodeindex | XmlTopParentNodeIndex | ztInteger | 5 |  | smallint
XPath | XmlXPath | ztString | 1024 |  | varchar
XPath in Jeeves | XmlXPathJvs | ztString | 255 |  | varchar


Non jeeves database objects (Jeeves_Views_Non_Jeeves_Objects)

Name of database object as defined in the Added/modified objects program (usrdefmodsqlobject).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Object name | DB_Object_Name | ztString | 128 |  | nvarchar
Procedurtyp, Jeeves | SprTrgType | ztString | 2 |  | char


Notes for invoice (wnot)

Table for storing the notes to be shown in Jeeves Viewer. The entries come from lr.editint and the information is stored per instance.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Font | Font | ztString | 100 |  | varchar
Color | FontColor | ztInteger | 5 |  | smallint
Font size | FontSize | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Height | height | ZtLong | 9 |  | int
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | NoteText | ztString | 8000 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
ID | wdocdummyuniqueid | ztString | 50 |  | varchar
Width | width | ZtLong | 9 |  | int
Unique ID record | wnotdummyuniqueid | ztString | 50 |  | varchar
x position | xpos | ZtLong | 9 |  | int
y position | ypos | ZtLong | 9 |  | int


Number generator (WMS_NumGen)

Definition of number series used in the WMS module, such as number series for SKUs, TUs, picking assignments, etc., with information about the start number, prefix, suffix, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Increment | NumGenIncr | ZtLong | 9 |  | int
Max length | NumGenMaxLen | ztInteger | 3 |  | smallint
Next | NumGenNext | ZtLong | 9 |  | int
Prefix | NumGenPrefix | ztString | 50 |  | varchar
Restart | NumGenRestart | ztBoolean |  |  | char
Start | NumGenStart | ZtLong | 9 |  | int
Stop | NumGenStop | ZtLong | 9 |  | int
Suffix | NumGenSuffix | ztString | 50 |  | varchar
Type | NumGenTypeCode | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_NumGen Number generator


Number generator type code (WMS_NumGenTypeCode)

Code for number generator type. Specifies what the number series is to be used for.

The following standard records exist. Do not alter/delete:

Type (NumGenTypeCode) | Description (NumGenTypeDesc) | Description
1 | SKU ID | When stock keeping units are created they are assigned an ID from this number series. Since SKUs have an alphanumeric id an alphanumeric prefix or/and suffix can be entered. Max length should be 35.
2 | TU ID | When transport units are created they are assigned an ID from this number series. Since TUs have an alphanumeric id an alphanumeric prefix or/and suffix can be entered. Max length should be 35.
10 | Assignment ID | When assignments are created they are assigned an ID from this number series. This is a numeric ID, i.e. no alphanumeric prefix/suffix is allowed. Max length should be 9.
15 | Task ID | When tasks are created they are assigned an ID from this number series. This is a numeric ID, i.e. no alphanumeric prefix/suffix is allowed. Max length should be 9.
20 | Log ID | When operative log records are created they are assigned an ID from this number series. This is a numeric ID, i.e. no alphanumeric prefix/suffix is allowed. Max length should be 9.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Type | NumGenTypeCode | ztInteger | 3 |  | smallint
Description | NumGenTypeDesc | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_NumGenTypeCode Number generator type code


Object type code (WMS_ObjectTypeCode)

Definition of applicable types of objects, which are then connected to the different label types that have been defined in the system. When you press the Print label button in the different programs, a dialogue box is opened and you can choose between the label types that are connected to the relevant object type.

The following standard records exist. Do not alter/delete:

Object type (ObjectTypeCode) | Object description (ObjectTypeDesc) | Description
10 | SKU | Stock-keeping unit
20 | TU | Transport unit
30 | TU Content | Transport unit content
50 | MHA | Material handling area
60 | Rack | Rack
70 | Location | Location

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Object type | ObjectTypeCode | ztInteger | 3 |  | smallint
Object description | ObjectTypeDesc | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_ObjectTypeCode Object type


OK to pick status (xpls)

Table of picking status that is used in the booking routine for customer orders. This data is used to indicate whether or not it is OK to pick an order.

The following standard records exist. Do not alter/delete:

Pick status (OkAttPlockaStatus) | Pick status description (OkAttPlockaStatusBeskr) | Description
0 | Not tested for pick | This status is set before any booking is done.
10 | No pick, part delivery not allowed | This status is set if there is not enough inventory for full booking and neither partial booking nor partial delivery are allowed.
60 | Booked, NO picking, no part delivery | This status is set if there is not enough inventory for full booking and partial booking but not partial delivery is allowed.
100 | May be picked, partly booked | This status is set if there is not enough inventory for full booking and both partial booking or partial delivery are allowed.
110 | May be picked, fully booked | Quantity of inventory sufficient to book the whole order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Pick status | OkAttPlockaStatus | ztInteger | 5 |  | smallint
Pick status description | OkAttPlockaStatusBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xpls OK to pick status


On account invoicing, assignments (pjac)

Data on account invoicing of assignments.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
On account amt | BelAConto | ZtBaseCurrAmount | 14 | 2 | money
Est invoice date | BerFaktDat | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
External text | editext | ztBlob | 1 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Approved for invoicing | GodKand | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar


On account, assignment (ac)

Amount remaining to be invoiced for the current assignment with payment plan.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Deducted invoice | AcDrawn | ztBoolean |  |  | char
Deducted on account | AcDrawnAmount | ztMoney | 14 | 2 | money
Deducted invoice no. | AcDrawnInvNo | Jeeves_InvNo | 9 |  | bigint
Deducted invoice org | AcDrawnInvNoOrg | Jeeves_InvNo | 9 |  | bigint
Deducted invoice row | AcDrawnInvRowNo | ZtLong | 5 |  | int
Deducted inv row org | AcDrawnInvRowNoOrg | ZtLong | 5 |  | int
Deducted prel invoice | AcDrawnPrelInvNo | Jeeves_InvNo | 9 |  | bigint
Deducted prel inv org | AcDrawnPrelInvNoOrg | Jeeves_InvNo | 9 |  | bigint
Deducted prel inv row | AcDrawnPrelInvRowNo | ZtLong | 5 |  | int
Ded prel inv row org | AcDrawnPrelInvRowNoOrg | ZtLong | 5 |  | int
Product acct | ArtProdKonto | ztString | 8 |  | varchar
On account amt | BelAConto | ZtBaseCurrAmount | 14 | 2 | money
Est invoice date | BerFaktDat | ztDate |  |  | datetime
Payment terms | BetKod | ztString | 2 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | editext | ztBlob | 1 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no., original | FaktNrOrg | Jeeves_InvNo | 9 |  | bigint
RowNo. | FaktRadNr | ztInteger | 4 |  | int
Invoice row no., original | FaktRadNrOrg | ZtLong | 9 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Approved for invoicing | GodKand | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint
Prel invoice no. org | WorkFaktNrOrg | Jeeves_InvNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: aco Create prel invoice from on account

    Program: faco On account amount to invoice


Op join lists (kapl)

The table of information in op join list header, i.e. Op join list No., description and other information that is common to the Op join lists.

An op-join list is a collection term (/-number) for several labour operations that are similar and can be performed as a joint labour operation. This could involve the cutting of the same material for several manufacturing orders. It can also be the same type of work that can be carried out as a joint operation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Work hours on op join list | ArbTidKaplista | ztOpTime | 9 | 4 | float
Worked hrs/person | ArbTimPerPers | ztHourWithDecimals | 8 | 2 | decimal
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Op join list No. | Kaplista | ZtLong | 10 |  | int
Op join list descr | KaplistaBeskr | ztString | 60 |  | varchar
Operation text ID | OperationsTextNr | ztInteger | 4 |  | smallint
Print date | p_Utskr_Dat | ztDate |  |  | datetime
Print date/time | p_Utskr_DatTid | ztDateTime |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Activity finished | PlanUtford | ztBoolean |  |  | char
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Reportingtype SFR | sfrreptype | ztInteger | 5 |  | smallint
End stamp time | SFRWORepEndDt | ztDateTime |  |  | datetime
Start Stamptime | SFRWORepStartDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Kapl Labour operation join lists


Opening balance per currency, account (segments) (tktc)

Opening balance per currency for all account segments in the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Budgeted amount | Budgbelopp | ZtBaseCurrAmount | 14 | 2 | money
Budgeted quantity | Budgkvantitet | ztFloat | 15 | 2 | float
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Manually entered | ManualAdded | ztBoolean |  |  | char
Tax base amount | MomsGrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
Account record | OnlyAccount | ztBoolean |  |  | char
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: tktc0 Create OB, account and account seg per currency

    Program: tktc1 Display OB, account per currency


Operands (rop)

Operands used for defining reports.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Operand | Operator | ztString | 20 |  | varchar
Operand | Operatorbeskr | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: rop Operators


Operation -> bin (aoh)

Table indicating the bin(s) where the result of an operation is stored before it is used in the next operation.
This can be used when the time between two operations is great, and when the material is voluminous.
The contents of the table can be shown on the screen or printed out on a job ticket.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Operation no. | OpNr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Aoh Operation -> bin


Operation queue (UAoToDo)

View that is used in the operation queue in Shop floor control.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | antal |  |  |  | @DataType=NULL
Plan mfg qty/op | aoantal |  |  |  | @DataType=NULL
Mfg/Works order no. | aonr |  |  |  | @DataType=NULL
Row | aopos |  |  |  | @DataType=NULL
Manufactured qty/op | aorappant |  |  |  | @DataType=NULL
Scrapped qty | aorappkassant |  |  |  | @DataType=NULL
Reported setup time | aorappstalltid |  |  |  | @DataType=NULL
Reported time per unit | aorappstycktid |  |  |  | @DataType=NULL
Remaining qty | aorestant |  |  |  | @DataType=NULL
Operations end date | aoslutdat |  |  |  | @DataType=NULL
Operations start date | aostartdat |  |  |  | @DataType=NULL
Item description | artbeskr |  |  |  | @DataType=NULL
Specification | artbeskrspec |  |  |  | @DataType=NULL
Item no. | artnr |  |  |  | @DataType=NULL
Revision date | artrevdat |  |  |  | @DataType=NULL
Revision no. | artrevid |  |  |  | @DataType=NULL
Blueprint | artritnnr |  |  |  | @DataType=NULL
Auto receiving type | autinlevtyp |  |  |  | @DataType=NULL
Avail check status code | BristKontrolleradStatus |  |  |  | @DataType=NULL
Avail check status code | BristKontrolleradStatusB |  |  |  | @DataType=NULL
Unit code | enhetskod |  |  |  | @DataType=NULL
Extra1 | Extra1 |  |  |  | @DataType=NULL
Extra2 | Extra2 |  |  |  | @DataType=NULL
Extra3 | Extra3 |  |  |  | @DataType=NULL
Extra4 | Extra4 |  |  |  | @DataType=NULL
Flow group | flodesgrupp |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Op join list No. | kaplista |  |  |  | @DataType=NULL
Inspection instruction | kontrollinstruktion |  |  |  | @DataType=NULL
Job card | kortnrao |  |  |  | @DataType=NULL
Bin | lagplats |  |  |  | @DataType=NULL
Inventory location | lagstalle |  |  |  | @DataType=NULL
Next operation | nextopnr |  |  |  | @DataType=NULL
Personnel/operation | opbemanning |  |  |  | @DataType=NULL
Personnel/operation, setup | opbemanningstall |  |  |  | @DataType=NULL
Operation | opben |  |  |  | @DataType=NULL
Operation | opbeskr |  |  |  | @DataType=NULL
Priority code | OpKoPrioritet |  |  |  | @DataType=NULL
Operation no. | opnr |  |  |  | @DataType=NULL
Operation sort | OpSorteringsNr |  |  |  | @DataType=NULL
Operation status | opstatus |  |  |  | @DataType=NULL
Operation status | opstatusbeskr |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Previous operation | prevopnr |  |  |  | @DataType=NULL
Manufacturing group | prodgr |  |  |  | @DataType=NULL
Manufacturing group | prodgrben |  |  |  | @DataType=NULL
Scrap quantity in procent of rep. | SFRAorappkassantproc |  |  |  | @DataType=NULL
Rep.setuptime in procent | SFRAorappstalltidproc |  |  |  | @DataType=NULL
Rep.lab.time in procent | SFRAorappstycktidproc |  |  |  | @DataType=NULL
Remaing quantity in procent | SFRaorestantproc |  |  |  | @DataType=NULL
Next Mfg qty/op | SFRNextAoRappAnt |  |  |  | @DataType=NULL
Next Rep date | SFRNextAoRappDat |  |  |  | @DataType=NULL
Next scrapped qty | SFRNextAoRappKassAnt |  |  |  | @DataType=NULL
Next operation | SFRNextOpBen |  |  |  | @DataType=NULL
Next operation status | SFRNextOpStatus |  |  |  | @DataType=NULL
Next operation status | SFRNextOpStatusBeskr |  |  |  | @DataType=NULL
Next mfgrp | SFRNextProdgr |  |  |  | @DataType=NULL
Next Mfg group descr | SFRNextProdgrBen |  |  |  | @DataType=NULL
Previous Mfg qty/op | SFRPrevAoRappAnt |  |  |  | @DataType=NULL
Previous Rep date | SFRPrevAoRappDat |  |  |  | @DataType=NULL
Previous scrapped qty | SFRPrevAoRappKassAnt |  |  |  | @DataType=NULL
Operation | SFRPrevOpBen |  |  |  | @DataType=NULL
Previous operation status | SFRPrevOpStatus |  |  |  | @DataType=NULL
Previous op status | SFRPrevOpStatusBeskr |  |  |  | @DataType=NULL
Previous mfgrp | SFRPrevProdgr |  |  |  | @DataType=NULL
Previous Mfg group descr | SFRPrevProdgrBen |  |  |  | @DataType=NULL
Remain time | SFRRemTime |  |  |  | @DataType=NULL
Reportingtype SFR | SFRReptype |  |  |  | @DataType=NULL
Identity | SQLIdentity |  |  |  | @DataType=NULL
Setup time for op | stalltid |  |  |  | @DataType=NULL
Unit time | stycktid |  |  |  | @DataType=NULL
Work order printed | ThUtskrDat |  |  |  | @DataType=NULL
Reported mfg qty | tiRappant |  |  |  | @DataType=NULL
Remaining qty to manuf | tiRestant |  |  |  | @DataType=NULL
Ready date | tislutdat |  |  |  | @DataType=NULL
Start date | tistartdat |  |  |  | @DataType=NULL
Tool status | ToolStatusCode |  |  |  | @DataType=NULL
Tool status | ToolStatusCodeDescr |  |  |  | @DataType=NULL
Dummy AoToDo (SFR) | uAoToDoDummy1 |  |  |  | @DataType=NULL
Dummy AoToDo 2 (SFR) | uAoToDoDummy2 |  |  |  | @DataType=NULL
Tools | verktyg |  |  |  | @DataType=NULL
Tool description | verktygben |  |  |  | @DataType=NULL
List of tools | verktygslista |  |  |  | @DataType=NULL


Operation status (xo5)

Table of statuses of operations in manufacturing orders.

The following standard records exist. Do not alter/delete:

Operation status (OpStatus) | Operation status (OpStatusBeskr)
0 | Work order created
20 | Previous op started
40 | Interruption
80 | Ready for start
100 | Operation started
200 | Partially reported
900 | Operation finished

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Operation status | OpStatus | ztInteger | 3 |  | smallint
Operation status | OpStatusBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xo5 Operations, status


Operation texts (opt)

This table contains predefined operation texts.
Under Operation (in basic data) you can specify the code of the operation text and leave out the manual operation text.
The operation text will be entered into the manufacturing order if no manual operation text has been entered. In this way, certain standard texts will be used rather than texts that are written differently by different people.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Operation text | OperationsText | ztString | 60 |  | varchar
Operation text ID | OperationsTextNr | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: opt Operation texts


Operation, net requirements (aon)

Labour reservations for calculated net requirement.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Plan mfg qty/op | AoAntal | ZtQty | 14 | 2 | decimal
Aut. reported | AoDummyRapp | ztBoolean |  |  | char
MO type | AoKod | ztInteger | 2 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Remaining qty | AoRestAnt | ZtQty | 14 | 2 | decimal
Operations end date | AoSlutDat | ztDate |  |  | datetime
Slutdat/tid (JPS) | AoSlutDatTid | ztDateTime |  |  | datetime
Operations start date | AoStartDat | ztDate |  |  | datetime
Startdatum/tid (JPS) | AoStartDatTid | ztDateTime |  |  | datetime
Date+time when OP was upd | AoUpdMedDatum | ztDateTime |  |  | datetime
Show operation | AoVisas | ztBoolean |  |  | char
Work group | ArbetsLag | ztString | 6 |  | varchar
CalcCost labour/op | ArbKalkArbKost | ZtBaseCurrAmount | 14 | 2 | money
Calc setup cost | ArbKalkStallKost | ZtBaseCurrAmount | 14 | 2 | money
Fixed labour OH | ArbOmkFast | ZtCost | 16 | 6 | float
Tot labour OH/op | ArbOmkOp | ZtCost | 16 | 6 | float
Variable labour OH | ArbOmkRorl | ZtCost | 16 | 6 | float
Setup labour OH/unit | ArbOmkStall | ZtCost | 16 | 6 | float
Setup overhead, labour | ArbStallBiKost | ZtCost | 16 | 6 | float
Setup cost labour | ArbStallKost | ZtCost | 16 | 6 | float
Labour overhead/unit | ArbStyckBiKost | ZtCost | 16 | 6 | float
Labour cost/unit | ArbStyckKost | ZtCost | 16 | 6 | float
Actual labour cost | ArbVerklArbKost | ZtBaseCurrAmount | 14 | 2 | money
Actual setup cost | ArbVerklStallKost | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Auto mtrl issue type | AutMtrlUttagTyp | ztInteger | 5 |  | smallint
Workload factor | BelaggningsFaktor | ztFloat | 15 | 2 | float
Text | Edit | ztBlob | 1 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Throughput time | GenomLoppsTid | ztFloat | 8 | 2 | float
Throughput time adj | GenomLoppsTidJust | ztFloat | 8 | 2 | float
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Kalendermånad | KalenderManad | ztInteger | 2 |  | smallint
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Week number | KalenderVecka | ztInteger | 2 |  | smallint
Scrap degree/op | KassOp | ztFloat | 5 | 2 | float
Queue time | KoTid | ztFloat | 15 | 2 | float
Lead time material | LeadTimeMtrlOnOp | ztInteger | 5 |  | smallint
Subcontract overhead cost | LegoBiKost | ZtCost | 16 | 6 | float
Subcontract cost | LegoKost | ZtCost | 16 | 6 | float
Subcontract price/unit | LegoPris | ZtBaseCurrAmount | 14 | 2 | money
Subcontract setup price | LegoPrisStall | ZtBaseCurrAmount | 14 | 2 | money
Subcontract start price | LegoPrisStart | ZtBaseCurrAmount | 14 | 2 | money
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Subcontract flag | MarkLego | ztBoolean |  |  | char
MRP batch -> Sign/mgr | NE_PlanAnsv | ztString | 8 |  | varchar
Personnel/operation | OpBemanning | ztFloat | 6 | 3 | float
Personnel/operation, setup | OpBemanningStall | ztFloat | 6 | 3 | float
Personnel/operation, ext setup | OpBemanningYttreStall | ztFloat | 6 | 3 | float
Operation | OpBen | ztString | 30 |  | varchar
Operation | OpBeskr | ztBlob | 1 |  | varchar
End of parallel workload | OpEndParallelWorkload | ztInteger | 5 |  | smallint
Operation text ID | OperationsTextNr | ztInteger | 4 |  | smallint
Fixed quantity operation | OpMarkFastAntal | ztBoolean |  |  | char
Material requirement date | OpMtrlResrvDt | ztDate |  |  | datetime
Operation no. | OpNr | ztInteger | 3 |  | int
Operation sort | OpSorteringsNr | ZtLong | 4 |  | int
Operation split | OpSplitt | ztFloat | 15 | 2 | float
Start parallel workload | OpStartParallelWorkload | ztBoolean |  |  | char
OpStartsMinutesAfterMO | OpStartsMinutesAfterMO | ztInteger | 5 |  | smallint
Overlapping after quantity | OverLappEfterAntal | ZtQty | 14 | 2 | decimal
Overlapping after time | OverLappEfterTid | ztOpTime | 9 | 4 | float
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Mfg grp deprec. | PgAvskrKost | ZtCost | 16 | 6 | float
Mfg grp fixed cost | PgFastKost | ZtCost | 16 | 6 | float
Mfg grp var cost | PgRorlKost | ZtCost | 16 | 6 | float
Mfg grp setup cost | PgStallKost | ZtCost | 16 | 6 | float
Planned quantity | PlaneratAntal | ZtQty | 14 | 2 | decimal
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float
time per unit | StyckTidA | ztFloat | 8 | 4 | float
Unit time B | StyckTidB | ztFloat | 8 | 4 | float
Unit time C | StyckTidC | ztFloat | 8 | 4 | float
In-house or subcontract | TillvPriorEgenLego | ztInteger | 5 |  | smallint
TimeGapInDaysAfterPrevOp | TimeGapInDaysAfterPrevOp | ztInteger | 5 |  | smallint
TimeGapInDaysTonextOp | TimeGapInDaysToNextOp | ztInteger | 5 |  | smallint
Start date before adjustment | TiMinStartDatOrig | ztDateTime |  |  | datetime
Shop price | VerkstadPris | ZtBaseCurrAmount | 14 | 2 | money
Tools | Verktyg | ztString | 16 |  | varchar
List of tools | VerkTygsLista | ztString | 35 |  | varchar
Tool deprec | VyAvskrKost | ZtCost | 16 | 6 | float
Fixed tool cost | VyFastKost | ZtCost | 16 | 6 | float
Var tool cost | VyRorlKost | ZtCost | 16 | 6 | float
Tool setup cost | VySTallKost | ZtCost | 16 | 6 | float
Tool unit cost | VyStyckKost | ZtCost | 16 | 6 | float
WL_Log_Accum_Time | WL_Log_Accum_Time | ZtHugeInt | 20 |  | bigint
External setup time for op | YttreStallTid | ztOpTime | 9 | 4 | float

    This table is the main table in the following programs:

    Program: Aon Labour req. from net req.


Operation, work copy (aow)

ao work copy.
Used for comparison with ao when a blueprint has been updated.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Plan mfg qty/op | AoAntal | ZtQty | 14 | 2 | decimal
Aut. reported | AoDummyRapp | ztBoolean |  |  | char
MO type | AoKod | ztInteger | 2 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Remaining qty | AoRestAnt | ZtQty | 14 | 2 | decimal
Show operation | AoVisas | ztBoolean |  |  | char
Work group | ArbetsLag | ztString | 6 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Auto receiving type | AutInlevTyp | ztInteger | 5 |  | smallint
Auto mtrl issue type | AutMtrlUttagTyp | ztInteger | 5 |  | smallint
Workload factor | BelaggningsFaktor | ztFloat | 15 | 2 | float
BOM sequence number | BOMItemSeqNo | ZtLong | 10 |  | int
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Scrap degree/op | KassOp | ztFloat | 5 | 2 | float
Queue time | KoTid | ztFloat | 15 | 2 | float
Lead time material | LeadTimeMtrlOnOp | ztInteger | 5 |  | smallint
Subcontract price/unit | LegoPris | ZtBaseCurrAmount | 14 | 2 | money
Subcontract setup price | LegoPrisStall | ZtBaseCurrAmount | 14 | 2 | money
Subcontract start price | LegoPrisStart | ZtBaseCurrAmount | 14 | 2 | money
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Subcontract flag | MarkLego | ztBoolean |  |  | char
Personnel/operation | OpBemanning | ztFloat | 6 | 3 | float
Personnel/operation, setup | OpBemanningStall | ztFloat | 6 | 3 | float
Personnel/operation, ext setup | OpBemanningYttreStall | ztFloat | 6 | 3 | float
Operation | OpBen | ztString | 30 |  | varchar
Operation | OpBeskr | ztBlob | 1 |  | varchar
End of parallel workload | OpEndParallelWorkload | ztInteger | 5 |  | smallint
Operation text ID | OperationsTextNr | ztInteger | 4 |  | smallint
Fixed quantity operation | OpMarkFastAntal | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Operation sort | OpSorteringsNr | ZtLong | 4 |  | int
Operation split | OpSplitt | ztFloat | 15 | 2 | float
Start parallel workload | OpStartParallelWorkload | ztBoolean |  |  | char
OpStartsMinutesAfterMO | OpStartsMinutesAfterMO | ztInteger | 5 |  | smallint
Operation status | OpStatus | ztInteger | 3 |  | smallint
Orig operation no. | OrigOpNo | ztInteger | 3 |  | smallint
Overlapping after quantity | OverLappEfterAntal | ZtQty | 14 | 2 | decimal
Overlapping after time | OverLappEfterTid | ztOpTime | 9 | 4 | float
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Spare part order | ReservdelsOrder | ztBoolean |  |  | char
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
BOM for item | StycklistaTillArtNr | ztString | 30 |  | varchar
Unit time | StyckTid | ztOpTime | 9 | 4 | float
time per unit | StyckTidA | ztFloat | 8 | 4 | float
Unit time B | StyckTidB | ztFloat | 8 | 4 | float
Unit time C | StyckTidC | ztFloat | 8 | 4 | float
In-house or subcontract | TillvPriorEgenLego | ztInteger | 5 |  | smallint
TimeGapInDaysAfterPrevOp | TimeGapInDaysAfterPrevOp | ztInteger | 5 |  | smallint
TimeGapInDaysTonextOp | TimeGapInDaysToNextOp | ztInteger | 5 |  | smallint
Update all op | UpDatAvvik | ztBoolean |  |  | char
Incl scrapped mtrl | UpDatAvvikMru | ztBoolean |  |  | char
Flagga om trigger ..... | UpdWLFromTrg | ztBoolean |  |  | char
Item group | VaruGruppKod | ztString | 8 |  | varchar
Shop price | VerkstadPris | ZtBaseCurrAmount | 14 | 2 | money
Tools | Verktyg | ztString | 16 |  | varchar
List of tools | VerkTygsLista | ztString | 35 |  | varchar


Operation/item group (opvg)

Item group operations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item description | ArtBeskr | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Item group | VaruGruppBeskr | ztString | 30 |  | varchar
Item group | VarugruppKod | ztString | 8 |  | varchar


Operations in progress (aoru)

Table showing the jobs in progress for a person.
At the start of an operation, a record is generated in this table. The record is removed when the operation is reported as complete.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Interruption code | AoAvbrottsKod | ztInteger | 5 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Remaining to report | AoRestInnanRapp | ZtQty | 14 | 2 | decimal
Status reported labour | AoruStatus | ztInteger | 5 |  | smallint
Type of reporting | AoruTyp | ztInteger | 3 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Reported end time | EventRpTime | ztTime | 5 |  | datetime
Start date | EventStartDat | ztDate |  |  | datetime
Start time | EventSTartTime | ztTime | 5 |  | datetime
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
Subcontract overhead cost | LegoBiKost | ZtCost | 16 | 6 | float
Subcontract cost | LegoKost | ZtCost | 16 | 6 | float
Subcontract price/unit | LegoPris | ZtBaseCurrAmount | 14 | 2 | money
Operation no. | OpNr | ztInteger | 3 |  | int
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Start date | RappStartDatum | ztDate |  |  | datetime
Reported start time | RappStartTid | ztTime | 5 |  | datetime
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Indirect job/labour | VeOvrigtJobb | ztInteger | 5 |  | smallint
Shop price | VerkstadPris | ZtBaseCurrAmount | 14 | 2 | money
Tools | Verktyg | ztString | 16 |  | varchar

    This table is the main table in the following programs:

    Program: aoru Jobs in progress


Operations, item (op)

Definition of the operations involved in the manufacturing of an item, with the option of specifying times and costs.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternativ op | AltOpKod | ztString | 2 |  | varchar
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Alternative routing | AltRouting_Orig | ztInteger | 2 |  | smallint
Quantity per hour | AntalPerTimme | ztFloat | 15 | 6 | float
Aut. reported | AoDummyRapp | ztBoolean |  |  | char
Show operation | AoVisas | ztBoolean |  |  | char
Fixed labour OH | ArbOmkFast | ZtCost | 16 | 6 | float
Tot labour OH/op | ArbOmkOp | ZtCost | 16 | 6 | float
Variable labour OH | ArbOmkRorl | ZtCost | 16 | 6 | float
Setup labour OH/unit | ArbOmkStall | ZtCost | 16 | 6 | float
Setup overhead, labour | ArbStallBiKost | ZtCost | 16 | 6 | float
Setup cost labour | ArbStallKost | ZtCost | 16 | 6 | float
Labour overhead/unit | ArbStyckBiKost | ZtCost | 16 | 6 | float
Labour cost/unit | ArbStyckKost | ZtCost | 16 | 6 | float
Item no. | ArtNr | ztString | 30 |  | varchar
Auto receiving type | AutInlevTyp | ztInteger | 5 |  | smallint
Autom mtrl.uttag | AutMtrlUttag | ztBoolean |  |  | char
Auto mtrl issue type | AutMtrlUttagTyp | ztInteger | 5 |  | smallint
Workload factor | BelaggningsFaktor | ztFloat | 15 | 2 | float
Dispatch plan->subcontr | DispatchPlanToSubcontractor | ztBoolean |  |  | char
PDM | ExistsPdm | ztBoolean |  |  | char
PDM (order) | ExistsPdmPO | ztBoolean |  |  | char
PDM (MO) | ExistsPdmWO | ztBoolean |  |  | char
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Price conv factor | InkArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | InkPrisPer | ZtDecimal73 | 8 | 3 | decimal
InputUnitTimeType | InputUnitTimeType | ztInteger | 5 |  | smallint
InputUnitTimeValue | InputUnitTimeValue | ztOpTime | 9 | 4 | float
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Purch price curr | InValuta | ztString | 3 |  | varchar
Item Revision | ItemRevision | ZtLong | 3 |  | smallint
Copy from item revision | ItemRevision_CopyOfRevision | ZtLong | 3 |  | int
Item rev OK to use? | ItemRevOkToUse | ztBoolean |  |  | char
Calculation date | KalkBerDatum | ztDate |  |  | datetime
Scrap degree/op | KassOp | ztFloat | 5 | 2 | float
Inspection instruction | KontrollInstruktion | ztBlob | 1 |  | varchar
Queue time | KoTid | ztFloat | 15 | 2 | float
Lead time material | LeadTimeMtrlOnOp | ztInteger | 5 |  | smallint
Subcontract overhead cost | LegoBiKost | ZtCost | 16 | 6 | float
Subcontract cost | LegoKost | ZtCost | 16 | 6 | float
Subcontract price/unit | LegoPris | ZtBaseCurrAmount | 14 | 2 | money
Subcontract setup price | LegoPrisStall | ZtBaseCurrAmount | 14 | 2 | money
Subcontract start price | LegoPrisStart | ZtBaseCurrAmount | 14 | 2 | money
Subcontract flag | MarkLego | ztBoolean |  |  | char
OLE-1 | Ole1 | ztString | 255 |  | varchar
OLE-2 | Ole2 | ztString | 255 |  | varchar
Personnel/operation | OpBemanning | ztFloat | 6 | 3 | float
Personnel/operation, setup | OpBemanningStall | ztFloat | 6 | 3 | float
Personnel/operation, ext setup | OpBemanningYttreStall | ztFloat | 6 | 3 | float
Operation | OpBen | ztString | 30 |  | varchar
Operation | OpBeskr | ztBlob | 1 |  | varchar
End of parallel workload | OpEndParallelWorkload | ztInteger | 5 |  | smallint
Operation text ID | OperationsTextNr | ztInteger | 4 |  | smallint
Fixed quantity/operation | OpFastAntal | ZtQty | 14 | 2 | decimal
Description, subcontract | OpLegoBen | ztString | 30 |  | varchar
Fixed quantity operation | OpMarkFastAntal | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Operation sort | OpSorteringsNr | ZtLong | 4 |  | int
Operation split | OpSplitt | ztFloat | 15 | 2 | float
Start parallel workload | OpStartParallelWorkload | ztBoolean |  |  | char
OpStartsMinutesAfterMO | OpStartsMinutesAfterMO | ztInteger | 5 |  | smallint
Overlapping after quantity | OverLappEfterAntal | ZtQty | 14 | 2 | decimal
Overlapping after time | OverLappEfterTid | ztOpTime | 9 | 4 | float
Pay-Roll Type | PayRollType | ztString | 8 |  | varchar
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Mfg grp deprec. | PgAvskrKost | ZtCost | 16 | 6 | float
Mfg grp fixed cost | PgFastKost | ZtCost | 16 | 6 | float
Mfg grp var cost | PgRorlKost | ZtCost | 16 | 6 | float
Mfg grp setup cost | PgStallKost | ZtCost | 16 | 6 | float
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Spare part order | ReservdelsOrder | ztBoolean |  |  | char
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Unit time B | StyckTidB | ztFloat | 8 | 4 | float
Unit time C | StyckTidC | ztFloat | 8 | 4 | float
Subcontract discount 1 % | SubctrctCurrentDiscnt1 | ZtDecimal73 | 6 | 2 | decimal
Subcontract discount 2 % | SubctrctCurrentDiscnt2 | ZtDecimal73 | 6 | 2 | decimal
Subcontract discount 3 % | SubctrctCurrentDiscnt3 | ZtDecimal73 | 6 | 2 | decimal
Subcontract price/unit | SubctrctCurrentPrice | ZtPurPrice | 12 | 2 | money
Subcontract setup price | SubctrctCurrentSetupPrice | ZtPurPrice | 12 | 2 | money
Subcontract start price | SubctrctCurrentStartPrice | ZtPurPrice | 12 | 2 | money
New cost as of date | SubctrctNewCostsFromDate | ztDate |  |  | datetime
Subcontract discount 1 % | SubctrctNextDiscnt1 | ZtDecimal73 | 6 | 2 | decimal
Subcontract discount 2 % | SubctrctNextDiscnt2 | ZtDecimal73 | 6 | 2 | decimal
Subcontract discount 2 % | SubctrctNextDiscnt3 | ZtDecimal73 | 6 | 2 | decimal
Subcontract price/unit (next) | SubctrctNextPrice | ZtPurPrice | 1 | 2 | money
Subcontract setup price (next) | SubctrctNextSetupPrice | ZtPurPrice | 12 | 2 | money
Subcontract start price (next) | SubctrctNextStartPrice | ZtPurPrice | 12 | 2 | money
In-house or subcontract | TillvPriorEgenLego | ztInteger | 5 |  | smallint
TimeGapInDaysAfterPrevOp | TimeGapInDaysAfterPrevOp | ztInteger | 5 |  | smallint
TimeGapInDaysTonextOp | TimeGapInDaysToNextOp | ztInteger | 5 |  | smallint
Trång sektor | TrangSektor | ztBoolean |  |  | char
Update all op | UpdatAvvik | ztBoolean |  |  | char
Incl scrapped mtrl | UpDatAvvikMru | ztBoolean |  |  | char
Item group | VaruGruppKod | ztString | 8 |  | varchar
Shop price | VerkstadPris | ZtBaseCurrAmount | 14 | 2 | money
Tools | Verktyg | ztString | 16 |  | varchar
List of tools | VerktygsLista | ztString | 35 |  | varchar
Tool deprec | VyAvskrKost | ZtCost | 16 | 6 | float
Fixed tool cost | VyFastKost | ZtCost | 16 | 6 | float
Var tool cost | VyRorlKost | ZtCost | 16 | 6 | float
Tool setup cost | VySTallKost | ZtCost | 16 | 6 | float
Tool unit cost | VyStyckKost | ZtCost | 16 | 6 | float
External setup time for op | YttreStallTid | ztOpTime | 9 | 4 | float

    This table is the main table in the following programs:

    Program: xOp Operations

    Program: xOp_OldItemRev Operations, old item revision


Operations, item (revision diff) (op_ItemRevDiff)

Definition of applicable alternative routings for an item.

By default, the basic operations for manufacturing an item are identified by routing number 0 (zero), but you can set up a different routing alternative as main alternative if required. Other alternatives have incremental numbers, for example 10, 20...

You can manually change to another alternative routing on a manufacturing order when manufacturing is overloaded, when manufacturing smaller quantities, etc., and then replan the order. From version 10 you can also control which alternative routing is to be applied depending on the inventory location, if required.

The same applies when costing; alternative 0 is used as default unless you set up different costs and perform costing per inventory location.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Item Revision | ItemRevision | ZtLong | 3 |  | smallint
Copy from item revision | ItemRevision_CopyOfRevision | ZtLong | 3 |  | smallint
Item revision diff flag | ItemRevisionDiffFlag | ztString | 4 |  | nvarchar
Item rev OK to use? | ItemRevOkToUse | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Created by | RowCreatedBy | ztString | 30 |  | varchar
Sequence number | SrDummyUniqueId | ztString | 30 |  | varchar


Operative log (WMS_OperationalLog)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
X pos, from | AssFromLocXPos | ztString | 5 |  | varchar
Y pos, from | AssFromLocYPos | ztString | 5 |  | varchar
MHA, from | AssFromMha | ztString | 5 |  | varchar
Parent ID, from | AssFromParentPalletId | ztString | 35 |  | varchar
Rack, from | AssFromRack | ztString | 5 |  | varchar
Priority | AssPrio | ztDateTime |  |  | datetime
Qty | AssQty | ZtQty | 14 | 2 | decimal
X pos, to | AssToLocXPos | ztString | 5 |  | varchar
Y pos, to | AssToLocYPos | ztString | 5 |  | varchar
MHA, to | AssToMha | ztString | 5 |  | varchar
Parent ID, to | AssToParentPalletId | ztString | 35 |  | varchar
Rack, to | AssToRack | ztString | 5 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Mobile unit | MobileUnit | ztString | 5 |  | varchar
Time | OpLogDateTime | ztDateTime |  |  | datetime
ID | OpLogId | ZtLong | 9 |  | int
Code | OpLogTypeCode | ztInteger | 3 |  | smallint
User | OpLogUser | ztString | 6 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Origin, Mfg/Wrk ord.no | OriginAoNr | Jeeves_MONo | 7 |  | bigint
Origin, Row | OriginAoPos | ztInteger | 4 |  | smallint
Origin, PO no. | OriginBestNr | Jeeves_PONo | 6 |  | bigint
Origin, Row no. in PO | OriginBestRadNr | ztInteger | 5 |  | smallint
Origin, PO backorder no. | OriginBestRestNr | ztInteger | 4 |  | smallint
Origin, Order no. | OriginOrderNr | Jeeves_SONo | 8 |  | bigint
Origin, Order row no. | OriginOrdRadNr | ztInteger | 5 |  | smallint
Origin, Subrow no. | OriginOrdRadNrStrPos | ztInteger | 5 |  | smallint
Origin, Backorder no. | OriginOrdRestNr | ztInteger | 2 |  | smallint
Pallet unit type | PalletUnitType | ztString | 5 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Queue | Queue | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Shipment plan alpha ID | ShipmPlanAlphaId | ztString | 30 |  | varchar
Shipment plan row no | ShipmPlanRowNo | ZtLong | 9 |  | int
SKU ID | SKUPalletId | ztString | 35 |  | varchar
Date/time | StrDateTime | ztString | 28 |  | varchar
Terminal | TerminalId | ztString | 20 |  | varchar
Sequence number, TU | TUPalletContSeq | ztInteger | 3 |  | smallint
TU ID | TUPalletId | ztString | 35 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_OperationalLog Operative log


Operative log type code (WMS_OpLogTypeCode)

Code for type of log in the operative log.

The following standard records exist. Do not alter/delete:

Code (OpLogTypeCode) | Description (OpLogTypeDesc) | Description
1 | Transfer | Transfer assignment completed.
5 | Load pallet | Pallet loaded.
10 | Unload pallet | Pallet unloaded.
20 | Pick qty |
100 | Receiving | Reception of SKU completed.
101 | Manually |
102 | Split |
103 | Merge |
104 | Cycle count | Physical inventory completed.
201 | Pick | Picking assignment completed.
202 | Row pick | Picking completed.
203 | Zero pick | Zero picking completed.
220 | Full pallet pick | Full pallet picking completed.
300 | Replenishment | Replenishment assignment completed.
301 | Replenishment pick |
350 | Sign in | Logged in.
351 | Sign out | Logged out.
401 | Transfer cancelled | Transfer assignment cancelled.
402 | Replenishment cancelled | Replenishment assignment cancelled.
403 | Replenishment pick cancelled |

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Code | OpLogTypeCode | ztInteger | 3 |  | smallint
Description | OpLogTypeDesc | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_OpLogTypeCode Operative log type code


Optional items (artv)

In Jeeves, you can enter an unlimited number of optional items for an item. Optional items are used in the order routine to present possible options for an item. For example with a sale of a laser printer you could also offer an extra paper tray, color cartridges, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Optional item | ArtNrTillValArt | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Price 0 applies | KodNollPris | ztBoolean |  |  | char
No customer disc | KundEjRabKod | ztBoolean |  |  | char
Discount fr matrix, add | MatrisRabAddKod | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Gross margin | Proc1 | ztFloat | 6 | 2 | float
% on main item order value | ProcBerOrdVarde | ztFloat | 14 | 4 | float
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Active disc matrix | RabattAktivKod | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Quantity | TillValArtAntal | ZtQty | 14 | 2 | decimal
Multiply quantity | TillValArtAntalMultKod | ztBoolean |  |  | char
Priority code | TillValArtPrior | ZtDecimal73 | 18 |  | decimal
Valid to date | TomDatum | ztDate |  |  | datetime
Price, curr | vb_Pris | ZtSalesPrice | 12 | 2 | money
Volume disc %, add | VolymRabAddKod | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: artv Optional items


Order acknowledged (bhoe)

Table containing information about when (and by whom) a purchase order was acknowledged.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Confirmed date | BestOEDatum | ztDate |  |  | datetime
Confirmed by | BestOESign | ztString | 6 |  | varchar
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar

    This table is the main table in the following programs:

    Program: Bhoe Order acknowledged


Order acknowledged EDI (xed5)

Status codes for order acknowledgements via EDI.

The following standard records exist. Do not alter/delete:

Acknowledgement status EDI (OeStatusEdi) | Order acknowledged EDI (OeStatusEdiBeskr)
4 | Changed
27 | 27: Not Accepted
29 | Unchanged
100 | Order acknowledged

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Acknowledgement status EDI | OeStatusEdi | ztInteger | 5 |  | smallint
Order acknowledged EDI | OeStatusEdiBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xed5 Order acknowledgement status EDI


Order booking status (xobs)

Table for booking status for customer orders.

The following standard records exist. Do not alter/delete:

Booking status (OrdBokningsStatus) | Order booking status (OrdBokningsStatusBeskr)
0 | No auto booking done
5 | PO created for order specific inventory
10 | Could not book acc to rule
20 | Partly booked
30 | Fully booked

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Booking status | OrdBokningsStatus | ztInteger | 5 |  | smallint
Order booking status | OrdBokningsStatusBeskr | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xobs Order booking status


Order details for season (PVMSeasonDetailOrd)

Definition of seasons for orders. For more information see the example in the help for the Seasons program (PVMSeason).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Allow | PvmSeasonAllow | ztBoolean |  |  | char
Season end | PVMSeasonEnd | ztDate |  |  | datetime
Season | PVMSeasonId | ztString | 15 |  | varchar
Season start | PVMSeasonStart | ztDate |  |  | datetime
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Order discount/customer discount class (rora)

Definition of intervals for order value discounts per customer discount class.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order value >= | LimitLow | ZtBaseCurrAmount | 14 | 2 | money
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Discount 1 % | rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Cust discount class | RabKlass | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: rora Order discount/customer discount class


Order entry template types, package (xomt)

Definition of function types when package item is used as a template for order entry.

If no value is specified, function according to type 0 is assumed to apply.

The following standard records exist. Do not alter/delete:

Order reg template, type (PaketOrdRegMallTyp) | Order reg template, type (PaketOrdRegMallBeskr) | Description
0 | Automatic | Order rows for the details included in the package item are created automatically in connection with saving the order row for the relevant package item.
1 | Automatic->sublevel order rows | The same function as alternative 0. The automatically created order rows also display automatically in an underlying program node.
2 | Manual | The package item's detail rows are automatically retrieved one by one to the order row form after the order row for the relevant package item is saved.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order reg template, type | PaketOrdRegMallBeskr | ztString | 50 |  | varchar
Order reg template, type | PaketOrdRegMallTyp | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xomt Order entry template types, package


Order header (ohvw)

Data in the header of a customer order.
Besides information that applies to the order, there are also default values used when entering the order rows.
The order rows are stored in the 'orp' table.
A customer order can be divided into several dispatch orders, depending on the backorder notes or planned deliveries on different dates, in which case one row per dispatch order is stored in the 'olh' table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accept code payment | AcceptCodePayment |  |  |  | @DataType=NULL
Address label type | AdressLappTyp |  |  |  | @DataType=NULL
Label print date | AdresslappUtskrDat |  |  |  | @DataType=NULL
Active | Aktiv |  |  |  | @DataType=NULL
Requisition (not purch) | AnmodanMark |  |  |  | @DataType=NULL
No. of EUR pallets | AntalEURPall |  |  |  | @DataType=NULL
No. of packages | AntalKolli |  |  |  | @DataType=NULL
No. of other pallets | AntalOvrPall |  |  |  | @DataType=NULL
No. of rows | AntalRader |  |  |  | @DataType=NULL
This field is used in the table as follows: |
Mfg/Works order no. | AoNr |  |  |  | @DataType=NULL
Mfg/Works order no. (alpha) | AoNrAlfa |  |  |  | @DataType=NULL
Gross weight kg | ArtBtotVikt |  |  |  | @DataType=NULL
Serienr from | ArtSerieNrFrom |  |  |  | @DataType=NULL
T.o.m. serienr | ArtSerieNrTom |  |  |  | @DataType=NULL
Net weight kg | ArtVikt |  |  |  | @DataType=NULL
Volume m3 | ArtVolym |  |  |  | @DataType=NULL
Amount to pay | AttBetalaBelopp |  |  |  | @DataType=NULL
Automatic release | AutoFrislappas |  |  |  | @DataType=NULL
Posting template | AutoRegel |  |  |  | @DataType=NULL
Posting template, advance | AutoRegelForskott |  |  |  | @DataType=NULL
Payment terms | BetKod |  |  |  | @DataType=NULL
Payment terms, advance | BetKodForskott |  |  |  | @DataType=NULL
Not booked on picking list | BookQtyNotOnPickListFlag |  |  |  | @DataType=NULL
Availability check date | BristKontrolleradDatum |  |  |  | @DataType=NULL
Avail check status code | BristKontrolleradStatus |  |  |  | @DataType=NULL
Avail status (invtry-out) | BristStatusLagerUtlev |  |  |  | @DataType=NULL
Availability status (plan/req) | BristStatusPlaneringBegLevDat |  |  |  | @DataType=NULL
Availability status (plan/req) | BristStatusPlaneringBerLevDat |  |  |  | @DataType=NULL
Specified gross wght | BruttoVikt |  |  |  | @DataType=NULL
Business unit ICT | BusinessUnit |  |  |  | @DataType=NULL
Code fixed departure | CodeFixedDeparture |  |  |  | @DataType=NULL
Created by object | CreatedByDbObject |  |  |  | @DataType=NULL
Credit card number | CreditCardNumber |  |  |  | @DataType=NULL
Partial booking allowed | DelBokningTillaten |  |  |  | @DataType=NULL
Delivery to business unit | DelivToBusinessUnit |  |  |  | @DataType=NULL
Dispatch to PO | DelivToPONo |  |  |  | @DataType=NULL
Part delivery allowed | DelLevTillaten |  |  |  | @DataType=NULL
Days from DispD to today | DiffDgrVerklLevDatDagDat |  |  |  | @DataType=NULL
Drop ship | DirektLeverans |  |  |  | @DataType=NULL
Direct issue | DirektUttag |  |  |  | @DataType=NULL
District | DistrKod |  |  |  | @DataType=NULL
Division code | DivisKod |  |  |  | @DataType=NULL
Logg enter ordervärde | dtwe_JEEVES_Oh_OrderVarde |  |  |  | @DataType=NULL
Logg exit ordervärde | dtwu_JEEVES_Oh_OrderVarde |  |  |  | @DataType=NULL
eBrev sent | ebfilsent |  |  |  | @DataType=NULL
eBrev file sent date | ebfilsentdt |  |  |  | @DataType=NULL
Text | Edit |  |  |  | @DataType=NULL
External text | Editext |  |  |  | @DataType=NULL
Text on picking list | EditPlBLOB |  |  |  | @DataType=NULL
Charge packaging cost | EmballageFakt |  |  |  | @DataType=NULL
Packaging BCU | EmballageKostnad |  |  |  | @DataType=NULL
Packaging inland, BCU | EmballageKostnInland |  |  |  | @DataType=NULL
Log | Exec_Time_Log_String |  |  |  | @DataType=NULL
Processing time | ExecutionTime |  |  |  | @DataType=NULL
Handling charge | ExpAvgKd |  |  |  | @DataType=NULL
Handling charge BCU | ExpeditionKostnad |  |  |  | @DataType=NULL
Express shipment | ExpressKod |  |  |  | @DataType=NULL
External order number | ExtorderNr |  |  |  | @DataType=NULL
External order type | ExtOrdTyp |  |  |  | @DataType=NULL
Invoiced by | FaktAvPersSign |  |  |  | @DataType=NULL
Invoice date | FaktDat |  |  |  | @DataType=NULL
Invoice date/time | FaktDateTime |  |  |  | @DataType=NULL
Invoice date, change | FaktDatKorr |  |  |  | @DataType=NULL
Invoice date, original | FaktDatOrg |  |  |  | @DataType=NULL
Due date | FaktFfDat |  |  |  | @DataType=NULL
Invoice no. | FaktNr |  |  |  | @DataType=NULL
Invoice no, on account | FaktNrAConto |  |  |  | @DataType=NULL
Invoice no., advance | FaktNrForskott |  |  |  | @DataType=NULL
Invoice no., change | FaktNrKOrr |  |  |  | @DataType=NULL
Invoice no., original | FaktNrOrg |  |  |  | @DataType=NULL
Invoice fully deliv order | FaktSlutLevOrder |  |  |  | @DataType=NULL
Margin | FaktTB |  |  |  | @DataType=NULL
Margin (incl tax) | FaktTbInklMoms |  |  |  | @DataType=NULL
Invoiced by | FakturerareKod |  |  |  | @DataType=NULL
Delivery note/disp no. | FfhNr |  |  |  | @DataType=NULL
Date for fiscalization | FiscalPrinterStatusDate |  |  |  | @DataType=NULL
Flow sequence no. | FlowDummyUniqueId |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Charge insurance fee | ForsakringFakt |  |  |  | @DataType=NULL
Insurance BCU | ForsakringsKostnad |  |  |  | @DataType=NULL
Insurance inland, BCU | ForsakrKostnInland |  |  |  | @DataType=NULL
Insurance cost % | ForsakrKostnProc |  |  |  | @DataType=NULL
Adv amt incl tax, BCU | ForskottBelopp |  |  |  | @DataType=NULL
Acc advance amt, BCU | ForskottBeloppAck |  |  |  | @DataType=NULL
Adv amt received date | ForskottMottagetDatum |  |  |  | @DataType=NULL
Deduction order-lnkd adv | ForskottOrdKopplTyp |  |  |  | @DataType=NULL
Freight charge code | FraktAvgKd |  |  |  | @DataType=NULL
Freight documents | FrakthandlKod |  |  |  | @DataType=NULL
Auto calc freight BCU | FraktKostnBer |  |  |  | @DataType=NULL
Total freight BCU | FraktKostnDeb |  |  |  | @DataType=NULL
Freight inland, BCU | FraktKostnInland |  |  |  | @DataType=NULL
Man calc freight BCU | FraktKostnMan |  |  |  | @DataType=NULL
Freight bill type | FraktSedelTyp |  |  |  | @DataType=NULL
Freight bill print date | FraktsedelUtskrDat |  |  |  | @DataType=NULL
Bulk taxation | FraktSkrymmeKod |  |  |  | @DataType=NULL
Gross frght weight kg | FraktVikt |  |  |  | @DataType=NULL
Release time | FriSlappDatTid |  |  |  | @DataType=NULL
Delivery note Y/N | FsKd |  |  |  | @DataType=NULL
Del note print date | FSUtskrDat |  |  |  | @DataType=NULL
Contact no. | FtgKontaktNr |  |  |  | @DataType=NULL
Company ID | FtgNr |  |  |  | @DataType=NULL
Contact name | ftgperson |  |  |  | @DataType=NULL
ZIP/Post code | FtgPostnr |  |  |  | @DataType=NULL
Card expiration date | Giltighetstid |  |  |  | @DataType=NULL
Valid to date | GiltigTomDatum |  |  |  | @DataType=NULL
Godsmärke | GodsMarke |  |  |  | @DataType=NULL
Goods label row 1 | GodsMarke1 |  |  |  | @DataType=NULL
Goods label row 2 | GodsMarke2 |  |  |  | @DataType=NULL
Goods label row 3 | GodsMarke3 |  |  |  | @DataType=NULL
Goods label row 4 | GodsMarke4 |  |  |  | @DataType=NULL
Third party trade | Handel3Part |  |  |  | @DataType=NULL
Hide order | HideOrder |  |  |  | @DataType=NULL
From order no. ICT | ICTDelivFromOrderNo |  |  |  | @DataType=NULL
To order no ICT | ICTDelivToOrderNo |  |  |  | @DataType=NULL
Purchase order no. ICT | ICTDelivToPONo |  |  |  | @DataType=NULL
Rule no | ICTRuleNumber |  |  |  | @DataType=NULL
Payment method | InbSlag |  |  |  | @DataType=NULL
Start trigger | Ins_DT_MilliSecond |  |  |  | @DataType=NULL
Original company | IntrnCoNoOrigin |  |  |  | @DataType=NULL
Intrastat trans type | IntStatTransTyp |  |  |  | @DataType=NULL
Inventory location WMS | InventoryLocWMS |  |  |  | @DataType=NULL
Amendment invoicing | InvoiceChange |  |  |  | @DataType=NULL
Jeeves_Init_Insert_Enter | Jeeves_Init_Insert_Enter |  |  |  | @DataType=NULL
Jeeves_Init_Insert_PreIns | Jeeves_Init_Insert_PreIns |  |  |  | @DataType=NULL
S4 | K4 |  |  |  | @DataType=NULL
S5 | K5 |  |  |  | @DataType=NULL
S6 | K6 |  |  |  | @DataType=NULL
S7 | K7 |  |  |  | @DataType=NULL
At cost | KalkylPrisFaktura |  |  |  | @DataType=NULL
Sent from dept/S3 | KBarAvsandandeEnhet |  |  |  | @DataType=NULL
No invoicing | KodEjFakturera |  |  |  | @DataType=NULL
Copied from invoice | KopieradFranFaktNr |  |  |  | @DataType=NULL
Copied from order | KopieradFranOrderNr |  |  |  | @DataType=NULL
Copied to order | KopieradTillOrderNr |  |  |  | @DataType=NULL
Card-specific info | Kortspecifikinfo |  |  |  | @DataType=NULL
Card purchase status string | Kortstatus |  |  |  | @DataType=NULL
Transact. type for card purch. (debit or credit) | KortTransaktionsTyp |  |  |  | @DataType=NULL
Cost unit | KostBar |  |  |  | @DataType=NULL
Cost centre | KostStalleKod |  |  |  | @DataType=NULL
Credit order | KreditOrder |  |  |  | @DataType=NULL
Credit block status | KreditSparrStatus |  |  |  | @DataType=NULL
CC dispatched unit | KstAvsandandeEnhet |  |  |  | @DataType=NULL
Plocklista (j/n) | Kund_PlKod |  |  |  | @DataType=NULL
Customer order date | KundBestDat |  |  |  | @DataType=NULL
Ordering dept | KundBestNamn |  |  |  | @DataType=NULL
Customer order no. | KundBestNr |  |  |  | @DataType=NULL
Payer, company ID | KundBetalareNr |  |  |  | @DataType=NULL
Invoicing address | KundFaktAdr |  |  |  | @DataType=NULL
Freight payer | KundFraktBetalareNr |  |  |  | @DataType=NULL
Charge freight cost | KundFraktDeb |  |  |  | @DataType=NULL
Customer category | KundKategoriKod |  |  |  | @DataType=NULL
Lev.sätt kund | KundLevSattKod |  |  |  | @DataType=NULL
Sales price incl VAT/tax | KundPrisInklMoms |  |  |  | @DataType=NULL
Discount % | KundRabatt |  |  |  | @DataType=NULL
Rabatt ej rab.gr art | KundRabattKod |  |  |  | @DataType=NULL
Discountable item | KundRabattKod0 |  |  |  | @DataType=NULL
Discounted item | KundRabattKod1 |  |  |  | @DataType=NULL
Non discountable item | KundRabattKod2 |  |  |  | @DataType=NULL
Max order disc % | KundRabattMax |  |  |  | @DataType=NULL
Min order disc % | KundRabattMin |  |  |  | @DataType=NULL
Customer reference | KundRef2 |  |  |  | @DataType=NULL
Text on PO | KundSpecTextBe |  |  |  | @DataType=NULL
Text on invoice | KundSpecTextFa |  |  |  | @DataType=NULL
Text on delivery note | KundSpecTextFs |  |  |  | @DataType=NULL
Text on order acknowledgement | KundSpecTextOe |  |  |  | @DataType=NULL
Text on picking list | KundSpecTextPl |  |  |  | @DataType=NULL
Text on mfg/works order | KundSpecTextTo |  |  |  | @DataType=NULL
Tier qty + order value | KundStafflKod |  |  |  | @DataType=NULL
Customer specific text | KundTextKod |  |  |  | @DataType=NULL
Inventory transfer | LagerFlyttning |  |  |  | @DataType=NULL
Bin | LagPlats |  |  |  | @DataType=NULL
This field is used in the table as follows: |
Inventory location | LagStalle |  |  |  | @DataType=NULL
Country | LandsKod |  |  |  | @DataType=NULL
Proof of ID number | LegitimationNumber |  |  |  | @DataType=NULL
Gross weight, kg, deliv | LevArtBtotVikt |  |  |  | @DataType=NULL
Net weight , deliv | LevArtVikt |  |  |  | @DataType=NULL
Volume, m³, deliv | LevArtVolym |  |  |  | @DataType=NULL
Dispatch notice | LevAviseringKod |  |  |  | @DataType=NULL
Before 12 deliv | LevForeTolv |  |  |  | @DataType=NULL
Ship documents | LevHandlKod |  |  |  | @DataType=NULL
Dispatch method | LevSattKod |  |  |  | @DataType=NULL
Dispatch terms | LevVillkKod |  |  |  | @DataType=NULL
Man reconc, change date | ManReAvstDT |  |  |  | @DataType=NULL
Man reconc, date | ManReAvstPerDen |  |  |  | @DataType=NULL
Man reconc, sign | ManReAvstPersSign |  |  |  | @DataType=NULL
Tax code acc to customer | MarkKundsMomsStyr |  |  |  | @DataType=NULL
New OA printed | MarkNyttOEUtskr |  |  |  | @DataType=NULL
Order-specific inventory | MarkOrderUniktLager |  |  |  | @DataType=NULL
VAT/tax code | MomsKod |  |  |  | @DataType=NULL
Tax, advance | MomsKodForskott |  |  |  | @DataType=NULL
Amount received | MottagetBelopp |  |  |  | @DataType=NULL
Print order acknowl. | OeKod |  |  |  | @DataType=NULL
Acknowledgement status EDI | OeStatusEdi |  |  |  | @DataType=NULL
Ord ackn print date | OEUtskrDat |  |  |  | @DataType=NULL
Quote row no. -> Order row no. | OffertRadNrToOrdRadNr |  |  |  | @DataType=NULL
Quote/agreement no. | OffNr |  |  |  | @DataType=NULL
Orderingång skapad | OIngSkapad |  |  |  | @DataType=NULL
Pick flag date | OkAttPlockaSattDatum |  |  |  | @DataType=NULL
Pick status | OkAttPlockaStatus |  |  |  | @DataType=NULL
OLE-1 | ole1 |  |  |  | @DataType=NULL
OLE-2 | ole2 |  |  |  | @DataType=NULL
Request disp date | OrdBegLevDat |  |  |  | @DataType=NULL
Preparation day | OrdBerednDat |  |  |  | @DataType=NULL
Est disp date | OrdBerLevDat |  |  |  | @DataType=NULL
Est disp time | OrdBerLevTid |  |  |  | @DataType=NULL
Order description | OrdBeskr |  |  |  | @DataType=NULL
Booking status | OrdBokningsStatus |  |  |  | @DataType=NULL
Order date | OrdDatum |  |  |  | @DataType=NULL
Order closed | OrderAvslutad |  |  |  | @DataType=NULL
Order amt, intrn sales | OrderBeloppIntFsg |  |  |  | @DataType=NULL
Order amt, intrn prch | OrderBeloppIntKop |  |  |  | @DataType=NULL
Cost | OrderCostCurrency |  |  |  | @DataType=NULL
Orderavslut | OrderEnding |  |  |  | @DataType=NULL
Order link type | OrderKopplKod |  |  |  | @DataType=NULL
CSG order, intrn sales | OrderKostnadIntFsg |  |  |  | @DataType=NULL
CSG order, intrn purch | OrderKostnadIntKop |  |  |  | @DataType=NULL
Order no. | OrderNr |  |  |  | @DataType=NULL
Order no. (alpha) | OrderNrAlfa |  |  |  | @DataType=NULL
Link order No. | OrderNrKoppl |  |  |  | @DataType=NULL
Order No., change | OrderNrKorr |  |  |  | @DataType=NULL
Order no. quote | OrderNrOffert |  |  |  | @DataType=NULL
Order No., original | OrderNrOrg |  |  |  | @DataType=NULL
Order no. | OrderNrServ |  |  |  | @DataType=NULL
Margin, internal sales | OrderTBIntFsg |  |  |  | @DataType=NULL
Margin, internal purch | OrderTBIntKop |  |  |  | @DataType=NULL
Order spec text | OrderTextKod |  |  |  | @DataType=NULL
Margin, internal sales | OrderTGIntFsg |  |  |  | @DataType=NULL
Margin degree, intrn prch | OrderTGIntKop |  |  |  | @DataType=NULL
Delivery note no. | OrdFoljesedelsNr |  |  |  | @DataType=NULL
Order cost | OrdKostnad |  |  |  | @DataType=NULL
Order cost (incl tax) | OrdKostnadInklMoms |  |  |  | @DataType=NULL
Delivery addr, company | OrdLevAdr1 |  |  |  | @DataType=NULL
Delivery address 1 | OrdLevAdr2 |  |  |  | @DataType=NULL
Delivery address 2 | OrdLevAdr3 |  |  |  | @DataType=NULL
Delivery address 3 | OrdLevAdr4 |  |  |  | @DataType=NULL
Destination, district | OrdLevAdrBstOrt |  |  |  | @DataType=NULL
Destination, country | OrdLevAdrLandsKod |  |  |  | @DataType=NULL
State code | OrdLevAdrProvinceCode |  |  |  | @DataType=NULL
Delivery notice 1 | OrdLevAnvisnRad1 |  |  |  | @DataType=NULL
Delivery notice 2 | OrdLevAnvisnRad2 |  |  |  | @DataType=NULL
Dispatch date | OrdLevDat |  |  |  | @DataType=NULL
Dispatch type | OrdLevNr |  |  |  | @DataType=NULL
Point of delivery, co. ID | OrdLevPlats1 |  |  |  | @DataType=NULL
Promised disp date | OrdLovLevDat |  |  |  | @DataType=NULL
Order discount % | OrdRabatt |  |  |  | @DataType=NULL
Backorder | OrdRestNot |  |  |  | @DataType=NULL
Backorder no. | OrdRestNr |  |  |  | @DataType=NULL
Order status | OrdStat |  |  |  | @DataType=NULL
Order value | OrdSum |  |  |  | @DataType=NULL
Est.order value | OrdSumFraktBer |  |  |  | @DataType=NULL
Order value (incl tax) | OrdSumInklMoms |  |  |  | @DataType=NULL
Order discountable val | OrdSumRabGr |  |  |  | @DataType=NULL
Entered order value | OrdSumReg |  |  |  | @DataType=NULL
Entered order value curr | OrdSumValReg |  |  |  | @DataType=NULL
Actual transport date | OrdTranspDat |  |  |  | @DataType=NULL
Order type | OrdTyp |  |  |  | @DataType=NULL
Dispatched on, actual | OrdVerklLevDat |  |  |  | @DataType=NULL
Auto pick ord-spec items | OULager_Auto_Utplock |  |  |  | @DataType=NULL
Order specific; only complete | OULager_Leverera_Allt |  |  |  | @DataType=NULL
Other inv. cost-1 BCU | OvrFaktAvgift1 |  |  |  | @DataType=NULL
Other inv. cost-10 BCU | OvrFaktAvgift10 |  |  |  | @DataType=NULL
Other inv. cost-2 BCU | OvrFaktAvgift2 |  |  |  | @DataType=NULL
Other inv. cost-3 BCU | OvrFaktAvgift3 |  |  |  | @DataType=NULL
Other inv. cost-4 BCU | OvrFaktAvgift4 |  |  |  | @DataType=NULL
Other inv. cost-5 BCU | OvrFaktAvgift5 |  |  |  | @DataType=NULL
Other inv. cost-6 BCU | OvrFaktAvgift6 |  |  |  | @DataType=NULL
Other inv. cost-7 BCU | OvrFaktAvgift7 |  |  |  | @DataType=NULL
Other inv. cost-8 BCU | OvrFaktAvgift8 |  |  |  | @DataType=NULL
Other inv. cost-9 BCU | OvrFaktAvgift9 |  |  |  | @DataType=NULL
Charge other invoice.cost-1 | OvrFaktKostn1Fakt |  |  |  | @DataType=NULL
Charge other invoice.cost-2 | OvrFaktKostn2Fakt |  |  |  | @DataType=NULL
Other inv. cost-1 BCU | OvrFaktKostnad1 |  |  |  | @DataType=NULL
Other inv. cost-2 BCU | OvrFaktKostnad2 |  |  |  | @DataType=NULL
Extra cost-1 inland, BCU | OvrFaktKostnInland1 |  |  |  | @DataType=NULL
Extra cost-2 inland, BCU | OvrFaktKostnInland2 |  |  |  | @DataType=NULL
Package date | PackagingDate |  |  |  | @DataType=NULL
Packer | PackareKod |  |  |  | @DataType=NULL
Packing slip printed | PackSedelUtskrDat |  |  |  | @DataType=NULL
Quantity PDM | PdmCount |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Picking index for order | PlockIndexOrder |  |  |  | @DataType=NULL
Picking list no. | PlockJnrOrder |  |  |  | @DataType=NULL
Picking list date | PLUtskrDat |  |  |  | @DataType=NULL
Price adjustment | PrisJustOrder |  |  |  | @DataType=NULL
CSG on price adjustment | PrisJustOrderKost |  |  |  | @DataType=NULL
Price list | PrisLista |  |  |  | @DataType=NULL
Project ID | ProjCode |  |  |  | @DataType=NULL
Start trigger | QQ_Ins_Trg_Start |  |  |  | @DataType=NULL
Cust discount class | RabKlass |  |  |  | @DataType=NULL
Reference number | Referensnummer |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Gross weight, kg, remain value | RestArtBtotVikt |  |  |  | @DataType=NULL
Net weight, kg, remain value | RestArtVikt |  |  |  | @DataType=NULL
Volume, remain value | RestArtVolym |  |  |  | @DataType=NULL
Backorder handling | RestBehKod |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Columns updated | RowUpdatedCols |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL
Account | RU_Account |  |  |  | @DataType=NULL
Sales type | SalesType |  |  |  | @DataType=NULL
Salesperson | Saljare |  |  |  | @DataType=NULL
Collective invoicing | SamFaktUtskr |  |  |  | @DataType=NULL
Joint purchase (allowed) | SamInKopMark |  |  |  | @DataType=NULL
Send EDI | SendEdi |  |  |  | @DataType=NULL
Sent EDI | SendEdiDT |  |  |  | @DataType=NULL
Skrivskydd | SkrivUtskSk |  |  |  | @DataType=NULL
End customer 1 | SlutKundNamn1 |  |  |  | @DataType=NULL
End customer 2 | SlutKundNamn2 |  |  |  | @DataType=NULL
Language | SprakKod |  |  |  | @DataType=NULL
Time sqlcmd->trg start | SQLCmd2EnterTrg |  |  |  | @DataType=NULL
Stock replenishment ICT | StockReplenishment |  |  |  | @DataType=NULL
COD/adv amt | TA_AmtCOD |  |  |  | @DataType=NULL
Freight bill number | TA_ConsNo |  |  |  | @DataType=NULL
CMR document message | TA_CustomerMessage |  |  |  | @DataType=NULL
From TA | TA_Edit |  |  |  | @DataType=NULL
Fax notification number | TA_FaxNotifiedNo |  |  |  | @DataType=NULL
GAN no | TA_GANno |  |  |  | @DataType=NULL
SeqNo. | TA_IntAutoNo |  |  |  | @DataType=NULL
Pallet meterage | TA_Loadmeter |  |  |  | @DataType=NULL
Email address notification | TA_MailNotified |  |  |  | @DataType=NULL
Phone notification number | TA_PhonNotifiedNo |  |  |  | @DataType=NULL
AffectTemplCode | TA_TemplKompCd |  |  |  | @DataType=NULL
Covered | TerminsSakradOrder |  |  |  | @DataType=NULL
Text after document rows | TextEfterDokRader |  |  |  | @DataType=NULL
General/fixed text | TextKod |  |  |  | @DataType=NULL
Amount back | TillbakaBelopp |  |  |  | @DataType=NULL
To inventory location | TillLagStalle |  |  |  | @DataType=NULL
Transit delivery | TransitLeverans |  |  |  | @DataType=NULL
Carrier code | TransportorsKod |  |  |  | @DataType=NULL
Reprint purch order | UtskrBestDokSkaGoras |  |  |  | @DataType=NULL
New PO print date | UtskrBestDokUtskrDT |  |  |  | @DataType=NULL
Print order acknowl | UtskrDokLovSkaGoras |  |  |  | @DataType=NULL
Print date new OA | UtskrDokLovUtskrDT |  |  |  | @DataType=NULL
Exchg rate date | ValDat |  |  |  | @DataType=NULL
Currency | ValKod |  |  |  | @DataType=NULL
Exchange rate | ValKurs |  |  |  | @DataType=NULL
Invoice 0-price | VaruProv |  |  |  | @DataType=NULL
VAT/tax type | VAT_Type |  |  |  | @DataType=NULL
Packaging, curr | vb_EmballageKostnad |  |  |  | @DataType=NULL
Packaging inland, curr | vb_EmballageKostnInland |  |  |  | @DataType=NULL
Handling charge curr | vb_ExpeditionKostnad |  |  |  | @DataType=NULL
Insurance, curr | vb_ForsakringsKostnad |  |  |  | @DataType=NULL
Insurance inland, curr | vb_ForsakrKostnInland |  |  |  | @DataType=NULL
Adv amt incl tax, curr | vb_ForskottBelopp |  |  |  | @DataType=NULL
Accum adv amt, curr | vb_ForskottBeloppAck |  |  |  | @DataType=NULL
Auto calc freight, curr | vb_FraktKostnBer |  |  |  | @DataType=NULL
Total freight, curr | vb_FraktKostnDeb |  |  |  | @DataType=NULL
Freight inland, curr | vb_FraktKostnInland |  |  |  | @DataType=NULL
Man calc freight, curr | vb_FraktKostnMan |  |  |  | @DataType=NULL
Other invc cost-1, curr | vb_OvrFaktAvgift1 |  |  |  | @DataType=NULL
Other invc cost-10, curr | vb_OvrFaktAvgift10 |  |  |  | @DataType=NULL
Other invc cost-2, curr | vb_OvrFaktAvgift2 |  |  |  | @DataType=NULL
Other invc cost-3, curr | vb_OvrFaktAvgift3 |  |  |  | @DataType=NULL
Other invc cost-4, curr | vb_OvrFaktAvgift4 |  |  |  | @DataType=NULL
Other invc cost-5, curr | vb_OvrFaktAvgift5 |  |  |  | @DataType=NULL
Other invc cost-6, curr | vb_OvrFaktAvgift6 |  |  |  | @DataType=NULL
Other invc cost-7, curr | vb_OvrFaktAvgift7 |  |  |  | @DataType=NULL
Other invc cost-8, curr | vb_OvrFaktAvgift8 |  |  |  | @DataType=NULL
Other invc cost-9, curr | vb_OvrFaktAvgift9 |  |  |  | @DataType=NULL
Other invc cost-1, curr | vb_OvrFaktKostnad1 |  |  |  | @DataType=NULL
Other invc cost-2, curr | vb_OvrFaktKostnad2 |  |  |  | @DataType=NULL
Extra cost-1 inland, curr | vb_OvrFaktKostnInland1 |  |  |  | @DataType=NULL
Extra cost-2 inland, curr | vb_OvrFaktKostnInland2 |  |  |  | @DataType=NULL
Order amount, curr | VbOrdSum |  |  |  | @DataType=NULL
Order value, curr (incl. tax) | VbOrdSumInklMoms |  |  |  | @DataType=NULL
Discntbl order value, curr | VbOrdSumRabGr |  |  |  | @DataType=NULL
Weight/volume automatic | ViktSumOrder |  |  |  | @DataType=NULL
Height | VolHeight |  |  |  | @DataType=NULL
Length | VolLength |  |  |  | @DataType=NULL
Volume | Volume |  |  |  | @DataType=NULL
Width | VolWidth |  |  |  | @DataType=NULL
Our reference | VRef |  |  |  | @DataType=NULL
Publish on Web | webpublish |  |  |  | @DataType=NULL
Prel invoice no. | WorkFaktNr |  |  |  | @DataType=NULL


Order header (oh)

Data in the header of a customer order.
Besides information that applies to the order, there are also default values used when entering the order rows.
The order rows are stored in the 'orp' table.
A customer order can be divided into several dispatch orders, depending on the backorder notes or planned deliveries on different dates, in which case one row per dispatch order is stored in the 'olh' table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accept code payment | AcceptCodePayment | ztString | 30 |  | varchar
Address label type | AdressLappTyp | ztInteger | 2 |  | smallint
Label print date | AdresslappUtskrDat | ztDateTime |  |  | datetime
Active | Aktiv | ztInteger | 1 |  | smallint
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
No. of EUR pallets | AntalEURPall | ztInteger | 5 |  | smallint
No. of packages | AntalKolli | ztInteger | 5 |  | smallint
No. of other pallets | AntalOvrPall | ztInteger | 5 |  | smallint
No. of rows | AntalRader | ZtLong | 10 |  | int
This field is used in the table as follows: |
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Serienr from | ArtSerieNrFrom | ztString | 30 |  | varchar
T.o.m. serienr | ArtSerieNrTom | ztString | 30 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Volume m3 | ArtVolym | ztFloat | 15 | 4 | float
Amount to pay | AttBetalaBelopp | ZtBaseCurrAmount | 14 | 2 | money
Automatic release | AutoFrislappas | ztBoolean |  |  | char
Posting template | AutoRegel | ztString | 4 |  | varchar
Posting template, advance | AutoRegelForskott | ztString | 4 |  | varchar
Payment terms | BetKod | ztString | 2 |  | varchar
Payment terms, advance | BetKodForskott | ztString | 2 |  | varchar
Not booked on picking list | BookQtyNotOnPickListFlag | ztBoolean |  |  | char
Availability check date | BristKontrolleradDatum | ztDate |  |  | datetime
Avail check status code | BristKontrolleradStatus | ztInteger | 5 |  | smallint
Avail status (invtry-out) | BristStatusLagerUtlev | ztInteger | 5 |  | smallint
Availability status (plan/req) | BristStatusPlaneringBegLevDat | ztInteger | 5 |  | smallint
Availability status (plan/req) | BristStatusPlaneringBerLevDat | ztInteger | 5 |  | smallint
Specified gross wght | BruttoVikt | ztFloat | 10 | 3 | float
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Code fixed departure | CodeFixedDeparture | ztBoolean |  |  | char
Costs excl VAT, BCU | CostsExclVatBCU | ZtBaseCurrAmount | 14 | 2 | money
Costs excl VAT, curr | CostsExclVatCurr | ztMoney | 14 | 2 | money
Costs incl VAT, BCU | CostsInclVatBCU | ZtBaseCurrAmount | 14 | 2 | money
Costs incl VAT, curr | CostsInclVatCurr | ztMoney | 14 | 2 | money
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Credit card number | CreditCardNumber | ztString | 30 |  | varchar
Partial booking allowed | DelBokningTillaten | ztInteger | 5 |  | smallint
Delivery to business unit | DelivToBusinessUnit | ztString | 8 |  | varchar
Dispatch to PO | DelivToPONo | ZtLong | 10 |  | int
Part delivery allowed | DelLevTillaten | ztInteger | 5 |  | smallint
Days from DispD to today | DiffDgrVerklLevDatDagDat | ZtLong | 10 |  | int
Drop ship | DirektLeverans | ztBoolean |  |  | char
Direct issue | DirektUttag | ztBoolean |  |  | char
District | DistrKod | ztString | 4 |  | varchar
Division code | DivisKod | ztString | 3 |  | varchar
Logg enter ordervärde | dtwe_JEEVES_Oh_OrderVarde | ztDateTime |  |  | datetime
Logg exit ordervärde | dtwu_JEEVES_Oh_OrderVarde | ztDateTime |  |  | datetime
eBrev sent | ebfilsent | ztBoolean |  |  | char
eBrev file sent date | ebfilsentdt | ztDateTime |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Text on picking list | EditPlBLOB | ztBlob | 1 |  | varchar
Charge packaging cost | EmballageFakt | ztBoolean |  |  | char
Packaging BCU | EmballageKostnad | ZtBaseCurrAmount | 14 | 2 | money
Packaging inland, BCU | EmballageKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Handling charge | ExpAvgKd | ztBoolean |  |  | char
Handling charge BCU | ExpeditionKostnad | ZtBaseCurrAmount | 14 | 2 | money
Express shipment | ExpressKod | ztBoolean |  |  | char
External order number | ExtorderNr | ztString | 17 |  | varchar
External order type | ExtOrdTyp | ztInteger | 3 |  | smallint
Invoiced by | FaktAvPersSign | ztString | 6 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice date/time | FaktDateTime | ztDateTime |  |  | datetime
Invoice date, change | FaktDatKorr | ztDate |  |  | datetime
Invoice date, original | FaktDatOrg | ztDate |  |  | datetime
Due date | FaktFfDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice reference no. | FaktNr_OCR | ztString | 40 |  | varchar
Invoice no, on account | FaktNrAConto | Jeeves_InvNo | 9 |  | bigint
Invoice no., advance | FaktNrForskott | Jeeves_InvNo | 9 |  | bigint
Invoice no., change | FaktNrKOrr | Jeeves_InvNo | 9 |  | bigint
Invoice no., original | FaktNrOrg | Jeeves_InvNo | 9 |  | bigint
Invoice fully deliv order | FaktSlutLevOrder | ztBoolean |  |  | char
Margin | FaktTB | ZtBaseCurrAmount | 14 | 2 | money
Margin (incl tax) | FaktTbInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoiced by | FakturerareKod | ztInteger | 2 |  | smallint
Delivery note/disp no. | FfhNr | ZtLong | 10 |  | int
Date for fiscalization | FiscalPrinterStatusDate | ztDate |  |  | datetime
Flow sequence no. | FlowDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Charge insurance fee | ForsakringFakt | ztBoolean |  |  | char
Insurance BCU | ForsakringsKostnad | ZtBaseCurrAmount | 14 | 2 | money
Insurance inland, BCU | ForsakrKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Insurance cost % | ForsakrKostnProc | ZtDecimal73 | 6 | 2 | decimal
Adv amt incl tax, BCU | ForskottBelopp | ZtBaseCurrAmount | 14 | 2 | money
Acc advance amt, BCU | ForskottBeloppAck | ZtBaseCurrAmount | 14 | 2 | money
Adv amt received date | ForskottMottagetDatum | ztDate |  |  | datetime
Deduction order-lnkd adv | ForskottOrdKopplTyp | ztInteger | 2 |  | smallint
Freight charge code | FraktAvgKd | ztBoolean |  |  | char
Freight documents | FrakthandlKod | ztBoolean |  |  | char
Auto calc freight BCU | FraktKostnBer | ZtBaseCurrAmount | 14 | 2 | money
Total freight BCU | FraktKostnDeb | ZtBaseCurrAmount | 14 | 2 | money
Freight inland, BCU | FraktKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Man calc freight BCU | FraktKostnMan | ZtBaseCurrAmount | 14 | 2 | money
Freight bill type | FraktSedelTyp | ztInteger | 2 |  | smallint
Freight bill print date | FraktsedelUtskrDat | ztDateTime |  |  | datetime
Bulk taxation | FraktSkrymmeKod | ztBoolean |  |  | char
Gross frght weight kg | FraktVikt | ztFloat | 10 | 3 | float
Release time | FriSlappDatTid | ztDateTime |  |  | datetime
Delivery note Y/N | FsKd | ztBoolean |  |  | char
Del note print date | FSUtskrDat | ztDateTime |  |  | datetime
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Contact name | ftgperson | ztString | 60 |  | varchar
ZIP/Post code | FtgPostnr | ztString | 10 |  | varchar
Card expiration date | Giltighetstid | ztString | 10 |  | varchar
Valid to date | GiltigTomDatum | ztDate |  |  | datetime
Godsmärke | GodsMarke | ztString | 40 |  | varchar
Goods label row 1 | GodsMarke1 | ztString | 40 |  | varchar
Goods label row 2 | GodsMarke2 | ztString | 40 |  | varchar
Goods label row 3 | GodsMarke3 | ztString | 40 |  | varchar
Goods label row 4 | GodsMarke4 | ztString | 40 |  | varchar
Third party trade | Handel3Part | ztBoolean |  |  | char
Handling charge processed | HandlingChargeProcessed | ztBoolean |  |  | char
Hide order | HideOrder | ztBoolean |  |  | char
From order no. ICT | ICTDelivFromOrderNo | ZtLong | 10 |  | int
To order no ICT | ICTDelivToOrderNo | ZtLong | 10 |  | int
Purchase order no. ICT | ICTDelivToPONo | ZtLong | 10 |  | int
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment method | InbSlag | ztString | 3 |  | varchar
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Intrastat trans type | IntStatTransTyp | ztInteger | 2 |  | smallint
Inventory location WMS | InventoryLocWMS | ztBoolean |  |  | char
Amendment invoicing | InvoiceChange | ztBoolean |  |  | char
Jeeves_Init_Insert_Enter | Jeeves_Init_Insert_Enter | ztDateTime |  |  | datetime
Jeeves_Init_Insert_PreIns | Jeeves_Init_Insert_PreIns | ztDateTime |  |  | datetime
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
At cost | KalkylPrisFaktura | ztString | 1 |  | varchar
Campaign | kampnr | ZtLong | 4 |  | int
Sent from dept/S3 | KBarAvsandandeEnhet | ztString | 8 |  | varchar
No invoicing | KodEjFakturera | ztBoolean |  |  | char
Copied from invoice | KopieradFranFaktNr | Jeeves_InvNo | 20 |  | bigint
Copied from order | KopieradFranOrderNr | Jeeves_SONo | 8 |  | bigint
Copied to order | KopieradTillOrderNr | Jeeves_SONo | 8 |  | bigint
Card-specific info | Kortspecifikinfo | ztString | 255 |  | varchar
Card purchase status string | Kortstatus | ztString | 30 |  | varchar
Transact. type for card purch. (debit or credit) | KortTransaktionsTyp | ztString | 30 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit order | KreditOrder | ztBoolean |  |  | char
Credit block status | KreditSparrStatus | ztInteger | 2 |  | smallint
CC dispatched unit | KstAvsandandeEnhet | ztString | 8 |  | varchar
Plocklista (j/n) | Kund_PlKod | ztString | 1 |  | varchar
Customer order date | KundBestDat | ztDate |  |  | datetime
Ordering dept | KundBestNamn | ztString | 36 |  | varchar
Customer order no. | KundBestNr | ztString | 30 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Invoicing address | KundFaktAdr | ztString | 36 |  | varchar
Freight payer | KundFraktBetalareNr | ztCompanyNo | 20 |  | varchar
Charge freight cost | KundFraktDeb | ztBoolean |  |  | char
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Lev.sätt kund | KundLevSattKod | ztInteger | 2 |  | smallint
Sales price incl VAT/tax | KundPrisInklMoms | ztBoolean |  |  | char
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Rabatt ej rab.gr art | KundRabattKod | ztBoolean |  |  | char
Discountable item | KundRabattKod0 | ztBoolean |  |  | char
Discounted item | KundRabattKod1 | ztBoolean |  |  | char
Non discountable item | KundRabattKod2 | ztBoolean |  |  | char
Max order disc % | KundRabattMax | ztFloat | 6 | 2 | float
Min order disc % | KundRabattMin | ztFloat | 6 | 2 | float
Customer reference | KundRef2 | ztString | 30 |  | varchar
Text on PO | KundSpecTextBe | ztBoolean |  |  | char
Text on invoice | KundSpecTextFa | ztBoolean |  |  | char
Text on delivery note | KundSpecTextFs | ztBoolean |  |  | char
Text on order acknowledgement | KundSpecTextOe | ztBoolean |  |  | char
Text on picking list | KundSpecTextPl | ztBoolean |  |  | char
Text on mfg/works order | KundSpecTextTo | ztBoolean |  |  | char
Tier qty + order value | KundStafflKod | ztBoolean |  |  | char
Customer specific text | KundTextKod | ztString | 4 |  | varchar
Inventory transfer | LagerFlyttning | ztBoolean |  |  | char
Bin | LagPlats | ztBinLocation | 20 |  | varchar
This field is used in the table as follows: |
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Proof of ID number | LegitimationNumber | ztString | 30 |  | varchar
Gross weight, kg, deliv | LevArtBtotVikt | ztFloat | 10 | 3 | float
Net weight , deliv | LevArtVikt | ztFloat | 10 | 3 | float
Volume, m³, deliv | LevArtVolym | ztFloat | 15 | 2 | float
Dispatch notice | LevAviseringKod | ztBoolean |  |  | char
Before 12 deliv | LevForeTolv | ztBoolean |  |  | char
Ship documents | LevHandlKod | ztBoolean |  |  | char
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Man reconc, change date | ManReAvstDT | ztDateTime |  |  | datetime
Man reconc, date | ManReAvstPerDen | ztDate |  |  | datetime
Man reconc, sign | ManReAvstPersSign | ztString | 6 |  | varchar
Tax code acc to customer | MarkKundsMomsStyr | ztBoolean |  |  | char
New OA printed | MarkNyttOEUtskr | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Tax, advance | MomsKodForskott | ztInteger | 5 |  | smallint
Amount received | MottagetBelopp | ZtBaseCurrAmount | 14 | 2 | money
Print order acknowl. | OeKod | ztBoolean |  |  | char
Acknowledgement status EDI | OeStatusEdi | ztInteger | 5 |  | smallint
Ord ackn print date | OEUtskrDat | ztDateTime |  |  | datetime
Quote row no. -> Order row no. | OffertRadNrToOrdRadNr | ztBoolean |  |  | char
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Orderingång skapad | OIngSkapad | ztBoolean |  |  | char
Pick flag date | OkAttPlockaSattDatum | ztDate |  |  | datetime
Pick status | OkAttPlockaStatus | ztInteger | 5 |  | smallint
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Request disp date | OrdBegLevDat | ztDate |  |  | datetime
Preparation day | OrdBerednDat | ztDate |  |  | datetime
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Est disp time | OrdBerLevTid | ztTime | 6 |  | datetime
Order description | OrdBeskr | ztString | 40 |  | varchar
Booking status | OrdBokningsStatus | ztInteger | 5 |  | smallint
Order date | OrdDatum | ztDate |  |  | datetime
Order closed | OrderAvslutad | ztBoolean |  |  | char
Order amt, intrn sales | OrderBeloppIntFsg | ZtBaseCurrAmount | 14 | 2 | money
Order amt, intrn prch | OrderBeloppIntKop | ZtBaseCurrAmount | 14 | 2 | money
Cost | OrderCostCurrency | ztBoolean |  |  | char
Orderavslut | OrderEnding | ztBoolean |  |  | char
Order link type | OrderKopplKod | ztInteger | 2 |  | smallint
CSG order, intrn sales | OrderKostnadIntFsg | ZtBaseCurrAmount | 14 | 2 | money
CSG order, intrn purch | OrderKostnadIntKop | ZtBaseCurrAmount | 14 | 2 | money
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order no. (alpha) | OrderNrAlfa | ztString | 50 |  | varchar
Link order No. | OrderNrKoppl | Jeeves_SONo | 9 |  | bigint
Order No., change | OrderNrKorr | Jeeves_SONo | 8 |  | bigint
Order no. quote | OrderNrOffert | Jeeves_SONo | 8 |  | bigint
Order No., original | OrderNrOrg | Jeeves_SONo | 8 |  | bigint
Order no. | OrderNrServ | Jeeves_SONo | 9 |  | bigint
Margin, internal sales | OrderTBIntFsg | ZtBaseCurrAmount | 14 | 2 | money
Margin, internal purch | OrderTBIntKop | ZtBaseCurrAmount | 14 | 2 | money
Order spec text | OrderTextKod | ztString | 4 |  | varchar
Margin, internal sales | OrderTGIntFsg | ZtDecimal73 | 10 | 3 | decimal
Margin degree, intrn prch | OrderTGIntKop | ZtDecimal73 | 10 | 3 | decimal
Delivery note no. | OrdFoljesedelsNr | ZtLong | 10 |  | int
Order cost | OrdKostnad | ZtBaseCurrAmount | 14 | 2 | money
Order cost (incl tax) | OrdKostnadInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Delivery addr, company | OrdLevAdr1 | ztString | 36 |  | varchar
Delivery address 1 | OrdLevAdr2 | ztString | 36 |  | varchar
Delivery address 2 | OrdLevAdr3 | ztString | 36 |  | varchar
Delivery address 3 | OrdLevAdr4 | ztString | 36 |  | varchar
Destination, district | OrdLevAdrBstOrt | ztString | 36 |  | varchar
Destination, country | OrdLevAdrLandsKod | ztString | 3 |  | varchar
State code | OrdLevAdrProvinceCode | ztString | 5 |  | varchar
Delivery notice 1 | OrdLevAnvisnRad1 | ztString | 30 |  | varchar
Delivery notice 2 | OrdLevAnvisnRad2 | ztString | 30 |  | varchar
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Promised disp date | OrdLovLevDat | ztDate |  |  | datetime
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Backorder | OrdRestNot | ztBoolean |  |  | char
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Order status | OrdStat | ztInteger | 2 |  | smallint
Order value | OrdSum | ZtBaseCurrAmount | 14 | 2 | money
Order value (excl tax) | OrdSumExklMoms | ZtBaseCurrAmount | 14 | 2 | money
Est.order value | OrdSumFraktBer | ZtBaseCurrAmount | 14 | 2 | money
Order value (incl tax) | OrdSumInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Order discountable val | OrdSumRabGr | ZtBaseCurrAmount | 14 | 2 | money
Entered order value | OrdSumReg | ZtBaseCurrAmount | 14 | 2 | money
Entered order value curr | OrdSumValReg | ztMoney | 14 | 2 | money
Actual transport date | OrdTranspDat | ztDate |  |  | datetime
Order type | OrdTyp | ztInteger | 3 |  | smallint
Dispatched on, actual | OrdVerklLevDat | ztDate |  |  | datetime
Auto pick ord-spec items | OULager_Auto_Utplock | ztBoolean |  |  | char
Order specific; only complete | OULager_Leverera_Allt | ztBoolean |  |  | char
Other inv. cost-1 BCU | OvrFaktAvgift1 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-10 BCU | OvrFaktAvgift10 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-2 BCU | OvrFaktAvgift2 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-3 BCU | OvrFaktAvgift3 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-4 BCU | OvrFaktAvgift4 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-5 BCU | OvrFaktAvgift5 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-6 BCU | OvrFaktAvgift6 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-7 BCU | OvrFaktAvgift7 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-8 BCU | OvrFaktAvgift8 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-9 BCU | OvrFaktAvgift9 | ZtBaseCurrAmount | 14 | 2 | money
Charge other invoice.cost-1 | OvrFaktKostn1Fakt | ztBoolean |  |  | char
Charge other invoice.cost-2 | OvrFaktKostn2Fakt | ztBoolean |  |  | char
Other inv. cost-1 BCU | OvrFaktKostnad1 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-2 BCU | OvrFaktKostnad2 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-1 inland, BCU | OvrFaktKostnInland1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 inland, BCU | OvrFaktKostnInland2 | ZtBaseCurrAmount | 14 | 2 | money
Package date | PackagingDate | ztDateTime |  |  | datetime
Packer | PackareKod | ztInteger | 2 |  | smallint
Packing slip printed | PackSedelUtskrDat | ztDateTime |  |  | datetime
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Picking index for order | PlockIndexOrder | ZtLong | 10 |  | int
Picking list no. | PlockJnrOrder | ZtLong | 10 |  | int
Picking list date | PLUtskrDat | ztDateTime |  |  | datetime
Price adjustment | PrisJustOrder | ztBoolean |  |  | char
CSG on price adjustment | PrisJustOrderKost | ztBoolean |  |  | char
Price list | PrisLista | ztInteger | 5 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Business opportunity ID | ProspektId | ZtLong | 10 |  | int
Season | PVMSeasonId | ztString | 15 |  | varchar
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Cust discount class | RabKlass | ztInteger | 3 |  | smallint
Reference number | Referensnummer | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Gross weight, kg, remain value | RestArtBtotVikt | ztFloat | 10 | 3 | float
Net weight, kg, remain value | RestArtVikt | ztFloat | 10 | 3 | float
Volume, remain value | RestArtVolym | ztFloat | 15 | 2 | float
Backorder handling | RestBehKod | ztInteger | 1 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Created UTC date/time | RowCreatedUTCDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Updated date/time | RowUpdatedUTCDT | ztDateTime |  |  | datetime
Account | RU_Account | ztString | 20 |  | varchar
Sales tax handling | SalesTaxHandling | ztBoolean |  |  | char
Sales type | SalesType | ztString | 3 |  | varchar
Salesperson | Saljare | ztString | 6 |  | varchar
Collective invoicing | SamFaktUtskr | ztBoolean |  |  | char
Joint purchase (allowed) | SamInKopMark | ztBoolean |  |  | char
Send EDI | SendEdi | ztBoolean |  |  | char
Sent EDI | SendEdiDT | ztDateTime |  |  | datetime
Skrivskydd | SkrivUtskSk | ztBoolean |  |  | char
End customer 1 | SlutKundNamn1 | ztString | 40 |  | varchar
End customer 2 | SlutKundNamn2 | ztString | 40 |  | varchar
Language | SprakKod | ztInteger | 3 |  | smallint
Time sqlcmd->trg start | SQLCmd2EnterTrg | ZtLong | 10 |  | int
Stock replenishment ICT | StockReplenishment | ztBoolean |  |  | char
COD/adv amt | TA_AmtCOD | ztMoney | 14 | 2 | money
Freight bill number | TA_ConsNo | ztString | 20 |  | varchar
CMR document message | TA_CustomerMessage | ztString | 40 |  | varchar
From TA | TA_Edit | ztBlob | 1 |  | varchar
Fax notification number | TA_FaxNotifiedNo | ztString | 40 |  | varchar
GAN no | TA_GANno | ztString | 20 |  | varchar
SeqNo. | TA_IntAutoNo | ztInteger | 5 |  | smallint
Pallet meterage | TA_Loadmeter | ztFloat | 8 | 2 | float
Email address notification | TA_MailNotified | ztString | 60 |  | varchar
Phone notification number | TA_PhonNotifiedNo | ztString | 40 |  | varchar
AffectTemplCode | TA_TemplKompCd | ztString | 1 |  | varchar
Tax area level 1 | TaxAreaCode1 | ztString | 10 |  | varchar
Tax area level 2 | TaxAreaCode2 | ztString | 10 |  | varchar
Tax area level 3 | TaxAreaCode3 | ztString | 10 |  | varchar
Tax area level 4 | TaxAreaCode4 | ztString | 10 |  | varchar
Tax area level 5 | TaxAreaCode5 | ztString | 10 |  | varchar
Tax area rate | TaxAreaRate | ZtDecimal73 | 10 | 4 | decimal
Sales tax code | TaxCode | ztInteger | 2 |  | smallint
Covered | TerminsSakradOrder | ztBoolean |  |  | char
Text after document rows | TextEfterDokRader | ztBoolean |  |  | char
General/fixed text | TextKod | ztString | 4 |  | varchar
Amount back | TillbakaBelopp | ZtBaseCurrAmount | 14 | 2 | money
To inventory location | TillLagStalle | ztString | 2 |  | varchar
Time zone code | TimeZoneCode | ztInteger | 4 |  | smallint
Transit delivery | TransitLeverans | ztBoolean |  |  | char
Carrier code | TransportorsKod | ztString | 17 |  | varchar
Reprint purch order | UtskrBestDokSkaGoras | ztBoolean |  |  | char
New PO print date | UtskrBestDokUtskrDT | ztDateTime |  |  | datetime
Print order acknowl | UtskrDokLovSkaGoras | ztBoolean |  |  | char
Print date new OA | UtskrDokLovUtskrDT | ztDateTime |  |  | datetime
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Invoice 0-price | VaruProv | ztString | 1 |  | varchar
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
Packaging, curr | vb_EmballageKostnad | ztMoney | 14 | 2 | money
Packaging inland, curr | vb_EmballageKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Handling charge curr | vb_ExpeditionKostnad | ztMoney | 14 | 2 | money
Insurance, curr | vb_ForsakringsKostnad | ztMoney | 14 | 2 | money
Insurance inland, curr | vb_ForsakrKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Adv amt incl tax, curr | vb_ForskottBelopp | ztMoney | 14 | 2 | money
Accum adv amt, curr | vb_ForskottBeloppAck | ztMoney | 14 | 2 | money
Auto calc freight, curr | vb_FraktKostnBer | ztMoney | 14 | 2 | money
Total freight, curr | vb_FraktKostnDeb | ztMoney | 14 | 2 | money
Freight inland, curr | vb_FraktKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Man calc freight, curr | vb_FraktKostnMan | ztMoney | 14 | 2 | money
Other invc cost-1, curr | vb_OvrFaktAvgift1 | ztMoney | 14 | 2 | money
Other invc cost-10, curr | vb_OvrFaktAvgift10 | ztMoney | 14 | 2 | money
Other invc cost-2, curr | vb_OvrFaktAvgift2 | ztMoney | 14 | 2 | money
Other invc cost-3, curr | vb_OvrFaktAvgift3 | ztMoney | 14 | 2 | money
Other invc cost-4, curr | vb_OvrFaktAvgift4 | ztMoney | 14 | 2 | money
Other invc cost-5, curr | vb_OvrFaktAvgift5 | ztMoney | 14 | 2 | money
Other invc cost-6, curr | vb_OvrFaktAvgift6 | ztMoney | 14 | 2 | money
Other invc cost-7, curr | vb_OvrFaktAvgift7 | ztMoney | 14 | 2 | money
Other invc cost-8, curr | vb_OvrFaktAvgift8 | ztMoney | 14 | 2 | money
Other invc cost-9, curr | vb_OvrFaktAvgift9 | ztMoney | 14 | 2 | money
Other invc cost-1, curr | vb_OvrFaktKostnad1 | ztMoney | 14 | 2 | money
Other invc cost-2, curr | vb_OvrFaktKostnad2 | ztMoney | 14 | 2 | money
Extra cost-1 inland, curr | vb_OvrFaktKostnInland1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 inland, curr | vb_OvrFaktKostnInland2 | ZtBaseCurrAmount | 14 | 2 | money
Order amount, curr | VbOrdSum | ztMoney | 14 | 2 | money
Order value, curr (excl tax) | VbOrdSumExklMoms | ztMoney | 14 | 2 | money
Order value, curr (incl. tax) | VbOrdSumInklMoms | ztMoney | 14 | 2 | money
Discntbl order value, curr | VbOrdSumRabGr | ztMoney | 14 | 2 | money
Weight/volume automatic | ViktSumOrder | ztBoolean |  |  | char
Height | VolHeight | ztInteger | 4 |  | smallint
Length | VolLength | ztInteger | 4 |  | smallint
Volume | Volume | ztFloat | 10 | 3 | float
Width | VolWidth | ztInteger | 4 |  | smallint
Our reference | VRef | ztString | 30 |  | varchar
Publish on Web | webpublish | ztBoolean |  |  | char
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: FaktFsk Invoicing, advance

    Program: FhKorrP Order processing, amendment order

    Program: OhAvsl Close order

    Program: ohp Packing, package contents

    Program: OhPack Packing, order

    Program: OhPackF Packing, invoiced order

    Program: OhPkt Plan packing, order

    Program: OhSRapp1 Manually close orders in GL

    Program: OhUCorl Order picking, booking etc

    Program: Order Order processing, complete

    Program: Order1 Order processing, standard

    Program: OrderB Order processing, EPOS

    Program: OrderConf Order processing, configuration

    Program: OrderF Invoicing

    Program: OrderFakt Invoicing, normal invoice

    Program: OrderFP Invoice amendment order

    Program: OrderFromOH Order processing, configuration from order

    Program: OrderFromQA Order processing, configuration fr quotation/agrmt

    Program: OrderFsk Order, link to advance

    Program: OrderFU Reprint invoice

    Program: OrderFUP Reprint amendment invoice

    Program: OrderO Order processing, order-spec. pkg. etc.

    Program: OrderP Order processing, package

    Program: OrderS Order processing, special

    Program: OrderSamFakt Invoicing, collective invoice

    Program: OrderT Order processing, trading

    Program: OrderX Order processing, special package

    Program: OrderZ Order processing, extra special

    Program: ordofh Order from quotation/agreement

    Program: UtPl Picking, order


Order header EDI (ohd)

The data is stored in this table before it is transferred to Jeeves and is a part of the external system for EDI/Odette. For example, the order header is stored in this table when it concerns an order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Payment terms | BetKod | ztString | 2 |  | varchar
Payee EAN loc code | BetMottEANLocCode | ztString | 30 |  | varchar
CallOffNo | CallOffNr | ztString | 17 |  | varchar
Contact details | ComNr | ztString | 200 |  | varchar
Part delivery allowed | DelLevTillaten | ztInteger | 5 |  | smallint
EAN location code | EAN_Loc_Code | ztString | 30 |  | varchar
This field is used in the table as follows: |
In/Out box EDI | EdiBoxRef | ztString | 21 |  | varchar
Supplement acknowledgement | EdiKomplOrdrsp | ztBoolean |  |  | char
EDI Log | EdiLogg | ztBlob | 1 |  | varchar
Edi log acknowledged | EdiLoggKvitterad | ztBoolean |  |  | char
Message function | EdiMsgFuncCode | ztString | 3 |  | varchar
EDI order type | EdiOrderTyp | ztString | 3 |  | varchar
Redirected | EdiRedirectedDispPlanDate | ztDateTime |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
External order number | ExtOrderNr | ztString | 17 |  | varchar
External order status | ExtOrdSta | ztInteger | 2 |  | smallint
External order type | ExtOrdTyp | ztInteger | 3 |  | smallint
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
This field is used in the table as follows: |
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Contact name | ftgperson | ztString | 60 |  | varchar
Goods label row 1 | GodsMarke1 | ztString | 40 |  | varchar
Goods label row 2 | GodsMarke2 | ztString | 40 |  | varchar
Goods label row 3 | GodsMarke3 | ztString | 40 |  | varchar
Goods label row 4 | GodsMarke4 | ztString | 40 |  | varchar
Goods recipient EAN | GodsMottEAN | ztString | 30 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Customer order no. | KundBestNr | ztString | 30 |  | varchar
Payer, company ID | KundbetalareNr | ztCompanyNo | 20 |  | varchar
Customer's intrn order no | KundIntOrderNr | ztString | 35 |  | varchar
Cust no. at supplier | KundNrHosLev | ztString | 15 |  | varchar
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Customer reference | KundRef2 | ztString | 30 |  | varchar
Inventory location | Lagstalle | ztString | 2 |  | varchar
Disp EAN location code | LevEANLocCode | ztString | 30 |  | varchar
Delivery recipient EAN | LevMottEAN | ztString | 30 |  | varchar
Dispatch plan date | LevPlanDatum | ztDate |  |  | datetime
Supplier reference | LevRef2 | ztString | 50 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Dispatch terms EDI | LevVillkKodEdi | ztString | 3 |  | varchar
Disp terms place | LevVillkPlats | ztString | 17 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Acknowledgement status EDI | OeStatusEdi | ztInteger | 5 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Defect reason | OhdErrorCd | ztInteger | 4 |  | smallint
Request disp date | OrdBegLevDat | ztDate |  |  | datetime
Preparation day | OrdBerednDat | ztDate |  |  | datetime
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order date | OrdDatum | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Delivery addr, company | OrdLevAdr1 | ztString | 36 |  | varchar
Delivery address 1 | OrdLevAdr2 | ztString | 36 |  | varchar
Delivery address 2 | OrdLevAdr3 | ztString | 36 |  | varchar
Delivery address 3 | OrdLevAdr4 | ztString | 36 |  | varchar
Destination, district | OrdLevAdrBstOrt | ztString | 36 |  | varchar
Destination, country | OrdLevAdrLandsKod | ztString | 3 |  | varchar
State code | OrdLevAdrProvinceCode | ztString | 5 |  | varchar
Delivery notice 1 | OrdLevAnvisnRad1 | ztString | 30 |  | varchar
Delivery notice 2 | OrdLevAnvisnRad2 | ztString | 30 |  | varchar
Delivery date to quay | OrdLevDatTillKaj | ztDate |  |  | datetime
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Promised disp date | OrdLovLevDat | ztDate |  |  | datetime
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Order type | OrdTyp | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Price list EDI | PrisListaEdi | ztString | 35 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Language | SprakKod | ztInteger | 3 |  | smallint
Valid to date | TomDatum | ztDate |  |  | datetime
This field is used in the table as follows: |
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Our supplier no. | VLevNr | ztString | 17 |  | varchar
Our reference | VRef | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: ohd EDI order (special)

    Program: ohdedi EDI order

    Program: ohdo Odette dispatch plans

    Program: ordchg EDI order change

    Program: ordrsp EDI order acknowledgement


Order header sales tax (OhSalesTax)

Order numbers in numeric format. There is also a field for alphanumeric order numbers.

When defining the company's order types, it is possible to set different number series for each order type. The orders whose order types do not have order number series, receive their order numbers from the highest number series.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax amount | TaxAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Tax area level | TaxAreaCode | ztString | 10 |  | varchar
Tax area rate | TaxAreaRate | ZtDecimal73 | 10 | 4 | decimal
Tax base amount | TaxBaseAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Sales tax code | TaxCode | ztInteger | 2 |  | smallint
Tax jurisdiction | TaxJurCode | ztInteger | 2 |  | smallint
Tax row no | TaxRowNo | ztInteger | 5 |  | smallint


Order header sales tax, view (VOhSalesTax)

Order numbers in numeric format. There is also a field for alphanumeric order numbers.

When defining the company's order types, it is possible to set different number series for each order type. The orders whose order types do not have order number series, receive their order numbers from the highest number series.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax amount | TaxAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Tax area level | TaxAreaCode | ztString | 10 |  | varchar
Tax area level | TaxAreaDescr | ztString | 60 |  | nvarchar
Tax area rate | TaxAreaRate | ZtDecimal73 | 10 | 4 | decimal
Tax base amount | TaxBaseAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Tax jurisdiction | TaxJurCode | ztInteger | 2 |  | smallint
Tax row no | TaxRowNo | ztInteger | 5 |  | smallint


Order intake (orpo)

A row is created in order entry statistics for each order row that is entered. When changes are made to an order row, the row is adjusted, or a new row is created according to the following:

- When entering a new order row, an order entry is created for the period specified in the order date, provided that the order status is Entry in progress. Example: If the order date is 020915 but today's date is 021015, the order row will end up in order entry statistics for period 9.

- When adding an order row to an order with status > or = Entered, order entry statistics will be created for the present period (period of today's date) even though the order date in the order header is in an earlier period.

- When changing an order row, the date in the field Entry date (regdat) will be checked on the original order entry statistics row. A change that is made the same day will result in the the order entry statistics row being adjusted with respect to quantity and amount. If a change is made on another day, a "credit" is issued and a new row will be created to show the adjustment. These records are always created in the current period.

- When cancelling the remaining quantity in connection with dispatch, no crediting of order entry is done. In order to receive credit of the order entry statistics, the order row must be canceled by changing the status directly on the order row.

Forecast order rows: As of version 8 revision 5, forecast order rows do not create any order entry statistics. When changing an forecast order row to status Entered, order entry statistics will be created according to Entry date (RegDat). The order entry statistics period can thus differ from the order date on the order row and order entry statistics row.

Odette dispatch plans: As of version 8 revision 5 servicepack 1 the creation of of order entry statistics is controlled by control parameter EDIAPP012.

EDIAPP012=1 means that Odette dispatch plans will create order entry statistics per order date. Order date = OrdBerLevDat

EDIAPP012=2 means that Odette dispatch plans will create order entry statistics when the order is created, i.e. when the dispatch plan is entered and transferred. Entry date (RegDat) is always used to determine in which period order entry statistics should be created. The order date in all order rows is set according to Entry date (RegDat) even if the dispatch is in the future.

Change of calculation delivery date As of version 8 revision 5 servicepack 1 the update of of order entry statistics is controlled by control parameter SALES114. Using this parameter you can get adjustment records in order entry statistics that reflect changes to the calculated delivery date (OrdBerLevDat) on the order row. This can be used when the control parameter is EDIAPP012=1

In this way, you can follow up how dispatch plans change, i.e. are rescheduled in the order entry statistics. When changing an order date and calculated delivery date due to entry of a new dispatch plan the order entry statistics also change.

Example: When a dispatch plan is moved, the credit record in the order entry statistics will be assigned an order date and calculated delivery date based on the original order date and calculated delivery date, respectively. A debit record will be created based on new order date and calculated delivery date, respectively. However, both records will end up in the current period, i.e. the corresponding Entry date (RegDat).

If delivery date is changed manually on an order row, this too will affect the order entry statistics but without changing the order date.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price (incl. tax) | ArtKalkBerInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Cost price at order | artkalkpriso | ZtBaseCurrAmount | 14 | 2 | money
Fixed cost price for order | ArtKalkPrisOFast | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Product class | ArtprodKlass | ztString | 4 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Debit/credit | DebKre | ztchar | 1 |  | char
District | DistrKod | ztString | 4 |  | varchar
Division code | DivisKod | ztString | 3 |  | varchar
CSG invc row | FaktRadKost | ZtBaseCurrAmount | 14 | 2 | money
CSG invc row (+tax) | FaktRadKostInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Margin | FaktTB | ZtBaseCurrAmount | 14 | 2 | money
Margin (incl tax) | FaktTBInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Degree of margin | FaktTG | ZtDecimal73 | 8 | 3 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, BCU | FPris | ZtBaseCurrAmount | 14 | 2 | money
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Exg rate on order date | InValKurs | ZtCurrencyRate | 15 | 7 | decimal
Purch price curr | InValuta | ztString | 3 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit order | KreditOrder | ztBoolean |  |  | char
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Net price in BCU | NettoPris | ZtSalesPrice | 12 | 2 | money
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Quote/agreement row no | OffRadNr | ztInteger | 5 |  | int
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Order row qty, alt unit | OrdAntalAltEnh | ZtQty | 14 | 2 | decimal
Orderantal, oing | OrdAntalOIng | ZtQty | 14 | 2 | decimal
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order date | OrdDatum | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Total row discount % | OrdRadRab | ZtDecimal73 | 8 | 2 | decimal
Row value, BCU | OrdRadSum | ZtBaseCurrAmount | 14 | 2 | money
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Package item | PaketArtikel | ztBoolean |  |  | char
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Pricing method | PrisAdaco | ztInteger | 3 |  | smallint
Price adjustment | PrisJustOrder | ztBoolean |  |  | char
Project ID | ProjCode | ztString | 10 |  | varchar
Discount 1 % | rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Discount curr | RabattVal | ztMoney | 14 | 2 | money
Discount curr 1 | RabattVal1 | ztMoney | 14 | 2 | money
Discount curr 2 | RabattVal2 | ztMoney | 14 | 2 | money
Discount curr 3 | RabattVal3 | ztMoney | 14 | 2 | money
Row value BCU incl tax | RadVardeInklMoms | ZtSalesPrice | 12 | 2 | money
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Historical cost invc row | StatistikRadKostnad | ZtBaseCurrAmount | 14 | 2 | money
Statistical item value | StatistikRadVarde | ZtBaseCurrAmount | 14 | 2 | money
Date/time | StrDateTime | ztString | 28 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Net price, curr | vb_NettoPris | ZtSalesPrice | 12 | 2 | money
Price, curr | Vb_Pris | ZtSalesPrice | 12 | 2 | money
Fixed price, currency | Vb_PrisFast | ZtSalesPrice | 12 | 2 | money
Price incl tax, curr | Vb_PrisInklMoms | ZtSalesPrice | 12 | 2 | money
Row value, curr (+tax) | Vb_RadVardeInklMoms | ztMoney | 14 | 2 | money
Cost price, curr | VbKalkPris | ztMoney | 14 | 2 | money
Order row amt, curr | VbOrdRadSum | ztMoney | 14 | 2 | money
Net Order row amt, curr | vbOrdRadSumNetto | ztMoney | 14 | 2 | money
Price acc to rule | VbPrisER | ZtSalesPrice | 12 | 2 | money
Volume disc % | VolymRabatt | ZtDecimal73 | 10 | 2 | decimal

    This table is the main table in the following programs:

    Program: vOIngSt Order intake


Order link type (xz3)

Definition of codes for controlling the function for automatic order link (order on hold).
The code can be entered on the order type and then automatically linked to the order header or it can be entered manually.

The following standard records exist. Do not alter/delete:

Order link type (OrderKopplKod) | Order link type (OrderKopplBeskr) | Description
1 | Main order | Suborders of type 2 or 3 can be linked to this order link type. During order entry Jeeves automatically goes through all orders for the customer in question and proposes that orders should be linked.
2 | Suborder, deliverable | This order link type can be expedited separately, i.e. dispatched and invoiced separately without being linked to a main order.
3 | Suborder, to be connected | This order link type can NOT be expedited separately but MUST be linked to a main order for dispatch and invoicing.
4 | Order to connect | All other types, 1, 2 and 3, can be linked to this order link type. During order entry it is always suggested that orders should be linked.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order link type | OrderKopplBeskr | ztString | 50 |  | varchar
Order link type | OrderKopplKod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xz3 Order link type


Order packaging (ohp)

Data on the packaging of an order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Volume m3 | ArtVolym | ztFloat | 15 | 4 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Package no. (ID) | KolliNr | ztString | 30 |  | varchar
Package type | KolliTyp | ztString | 4 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: Ohp2 Packing, package contents


Order packing, package records (orpk)

Data about the package and current packaging type. This is used when packing order rows for a customer delivery.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Qty per package | AntalEmb | ZtQty | 14 | 2 | decimal
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Auto-delete package | AutoDelKolli | ztBoolean |  |  | char
Auto created pkg | AutoGenKolli | ztBoolean |  |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Packaging price | EmballagePris | ZtBaseCurrAmount | 14 | 2 | money
Packaging type | EmballageTyp | ztString | 4 |  | varchar
Packaging weight | EmballageVikt | ztFloat | 10 | 3 | float
Specification | EmbBeskrSpec | ztString | 30 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight pkg no., auto | FraktKolliNrAuto | ztBoolean |  |  | char
Pkg identity | FraktKolliNummer | ztString | 30 |  | varchar
Goods label row 1 | GodsMarke1 | ztString | 40 |  | varchar
Goods label row 2 | GodsMarke2 | ztString | 40 |  | varchar
Goods label row 3 | GodsMarke3 | ztString | 40 |  | varchar
Goods label row 4 | GodsMarke4 | ztString | 40 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Internal code, packing invoice | KodFriFaktPack | ztInteger | 5 |  | smallint
Internal code ORPK | KodOrderSort | ztInteger | 5 |  | smallint
Package, no packing | KolliEjPackKod | ztBoolean |  |  | char
Package no. (alpha), man | KolliNrAlfa | ztString | 30 |  | varchar
Package no. (alpha), automatic | KolliNrAlfaauto | ztString | 30 |  | varchar
Package number | KolliNummer | ztInteger | 5 |  | smallint
Quantity to pack | KolliPackAntal | ZtQty | 14 | 2 | decimal
Pkg sequence no. | KolliSekvNr | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Backorder No. | Olh_OrdRestNr | ztInteger | 2 |  | smallint
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Automatic order packing | OrderPackAuto | ztBoolean |  |  | char
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Packed quantity | OrdPackAntal | ZtQty | 14 | 2 | decimal
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Packing slip printed | PackSedelUtskrDat | ztDateTime |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Carrier code | TransportorsKod | ztString | 17 |  | varchar
Height | VolHeight | ztInteger | 4 |  | smallint
Length | VolLength | ztInteger | 4 |  | smallint
Volume | Volume | ztFloat | 10 | 3 | float
Width | VolWidth | ztInteger | 4 |  | smallint


Order packing, package records (pktk)

Data about the package and current packaging type. This is used when packing order rows for a customer delivery.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Qty per package | AntalEmb | ZtQty | 14 | 2 | decimal
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Auto-delete package | AutoDelKolli | ztBoolean |  |  | char
Auto created pkg | AutoGenKolli | ztBoolean |  |  | char
Batch no. | Batchid | ztString | 30 |  | varchar
Dummy no | Dummy_FFhNr | ZtLong | 10 |  | int
Packaging price | EmballagePris | ZtBaseCurrAmount | 14 | 2 | money
Packaging type | EmballageTyp | ztString | 4 |  | varchar
Specification | EmbBeskrSpec | ztString | 30 |  | varchar
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
Prev Package seq. no. | ForegKolliLopNr | ztString | 17 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight pkg no., auto | FraktKolliNrAuto | ztBoolean |  |  | char
Pkg identity | FraktKolliNummer | ztString | 30 |  | varchar
Goods flag printed | GodsFlaggaUtskr | ztBoolean |  |  | char
Goods label row 1 | GodsMarke1 | ztString | 40 |  | varchar
Goods label row 2 | GodsMarke2 | ztString | 40 |  | varchar
Goods label row 3 | GodsMarke3 | ztString | 40 |  | varchar
Goods label row 4 | GodsMarke4 | ztString | 40 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Internal code ORPK | KodOrderSort | ztInteger | 5 |  | smallint
Package seq. no. | KolliLopNr | ztString | 17 |  | varchar
Package no. (alpha), man | KolliNrAlfa | ztString | 30 |  | varchar
Package no. (alpha), automatic | KolliNrAlfaauto | ztString | 30 |  | varchar
Package number | KolliNummer | ztInteger | 5 |  | smallint
Quantity to pack | KolliPackAntal | ZtQty | 14 | 2 | decimal
Package status | KolliStatus | ztInteger | 2 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Flag type | OdetteFlaggTyp | ztString | 1 |  | varchar
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Automatic order packing | OrderPackAuto | ztBoolean |  |  | char
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Packed quantity | OrdPackAntal | ZtQty | 14 | 2 | decimal
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Package instr | PackInstrKod | ztString | 35 |  | varchar
Packing slip printed | PackSedelUtskrDat | ztDateTime |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Packing ways | PktkPackKod | ztInteger | 1 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Height | VolHeight | ztInteger | 4 |  | smallint
Length | VolLength | ztInteger | 4 |  | smallint
Volume | Volume | ztFloat | 10 | 3 | float
Width | VolWidth | ztInteger | 4 |  | smallint


Order packing, records (pktp)

Data on the packed quantity of items per package for a customer delivery.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Batch no. | Batchid | ztString | 30 |  | varchar
Packaging price | EmballagePris | ZtBaseCurrAmount | 14 | 2 | money
Packaging type | EmballageTyp | ztString | 4 |  | varchar
Pkg label | EmbEtikett | ztBoolean |  |  | char
Unit code | EnhetsKod | ztString | 4 |  | varchar
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
Prev Package seq. no. | ForegKolliLopNr | ztString | 17 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Goods flag printed | GodsFlaggaUtskr | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Package seq. no. | KolliLopNr | ztString | 17 |  | varchar
Package number | KolliNummer | ztInteger | 5 |  | smallint
Package row no. | KolliRadNr | ztInteger | 5 |  | int
Inventory location | LagStalle | ztString | 2 |  | varchar
Backorder No. | Olh_OrdRestNr | ztInteger | 2 |  | smallint
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Packed quantity | OrdPackAntal | ZtQty | 14 | 2 | decimal
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Item group | VaruGruppKod | ztString | 8 |  | varchar
Volume | Volume | ztFloat | 10 | 3 | float


Order packing, records (orpp)

Data on the packed quantity of items per package for a customer delivery.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Internal code, packing invoice | KodFriFaktPack | ztInteger | 5 |  | smallint
Package number | KolliNummer | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Backorder No. | Olh_OrdRestNr | ztInteger | 2 |  | smallint
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Packed quantity | OrdPackAntal | ZtQty | 14 | 2 | decimal
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar


Order row status (xs)

Table of order row status that is used in the sales module to indicate the status of an order row. The code is automatically set by the system when an order is updated.

The following standard records exist. Do not alter/delete:

Order row status (OrdRadSt) | Order row status (OrdRStatBeskr) | Description
0 | Quotation | The order row is only a quotation and cannot be seen in the picking programs.
5 | Not approved | There is no built-in logic in this status. It can be set manually if, for example, an order row needs to be approved before it is assigned status Entered.
8 | Forecast order row |
10 | Entry in progress | The order row is reserved and a basis for statistics, but not yet ready for dispatch. No picking list can be printed.
12 | EDI order |
13 | Entered | The order row is complete, which means that it is ready for dispatch, a picking list can be printed and picking can be done.
15 | Released to Astro |
20 | Planned | The order is partially delivered; remaining order rows are planned.
30 | (reserve) |
40 | Picking in progress | Dispatch started, picked order rows are given status 'Picking in progress'.
50 | Released | The order row is released and ready for invoicing.
70 | Invoiced | The order row is invoiced.
90 | Canceled | The order row is canceled.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order row status | OrdRadSt | ztInteger | 2 |  | smallint
Order row status | OrdRStatBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxs Order row status


Order row status ICT (ICTOrdLnStatus)

Definition of status codes in ICT regarding customer order and purchase order rows.

Information on the current status of a customer order created by another supplying business unit is shown automatically on customer order and purchase order rows for the selling business unit.

The following standard records exist. Do not alter/delete:

Order row status ICT (ICTOrdLnStatus) | Order row status ICT (ICTOrdLnStatusDescr)
10 | Entry in progress
13 | Entered
20 | Planned
40 | Picking (in progress)
50 | Released
70 | Invoiced
90 | Cancelled

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Order row status ICT | ICTOrdLnStatus | ztInteger | 5 |  | smallint
Order row status ICT | ICTOrdLnStatusDescr | ztString | 50 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ICTOrdLnStatus Order row status ICT


Order row total picking list (wopl)

Sorted and totaled order row reservations during printing of picking list.
This work table is only used in a report during order document printing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Bin | ars_LagPlats | ztBinLocation | 20 |  | varchar
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Ord-spec invtry bal | OrderUniktLager | ZtQty | 14 | 2 | decimal
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Remaining qty | OrdRestAnt | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar


Order row, packing proposal (orpf)

Package number when packing orders for customer dispatch.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item description | ArtBeskr | ztString | 30 |  | varchar
Specification | ArtBeskrSpec | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Unit code | EnhetsKod | ztString | 4 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Internal code, packing invoice | KodFriFaktPack | ztInteger | 5 |  | smallint
Package number | KolliNummer | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Backorder No. | Olh_OrdRestNr | ztInteger | 2 |  | smallint
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Packed quantity | OrdPackAntal | ZtQty | 14 | 2 | decimal
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Remaining to pack | OrdRestAntPack | ZtQty | 14 | 2 | decimal
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Package item | PaketArtikel | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Language | SprakKod | ztInteger | 3 |  | smallint
Item group | VaruGruppBeskr | ztString | 30 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar


Order row, packing proposal (pktf)

Contains packaging proposals. Used when packing delivery notes.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item description | ArtBeskr | ztString | 30 |  | varchar
Specification | ArtBeskrSpec | ztString | 30 |  | varchar
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Packaging price | EmballagePris | ZtBaseCurrAmount | 14 | 2 | money
Packaging type | EmballageTyp | ztString | 4 |  | varchar
Pkg label | EmbEtikett | ztBoolean |  |  | char
Unit code | EnhetsKod | ztString | 4 |  | varchar
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Package number | KolliNummer | ztInteger | 5 |  | smallint
Package row no. | KolliRadNr | ztInteger | 5 |  | int
Inventory location | LagStalle | ztString | 2 |  | varchar
Backorder No. | Olh_OrdRestNr | ztInteger | 2 |  | smallint
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Automatic order packing | OrderPackAuto | ztBoolean |  |  | char
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Packed quantity | OrdPackAntal | ZtQty | 14 | 2 | decimal
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Remaining to pack | OrdRestAntPack | ZtQty | 14 | 2 | decimal
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Package item | PaketArtikel | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Language | SprakKod | ztInteger | 3 |  | smallint
Item group | VaruGruppBeskr | ztString | 30 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Volume | Volume | ztFloat | 10 | 3 | float


Order row/manufacturing BOM (orps)

Information about material linked to a special order row in the customer order register.
This is not a material reservation but should be considered as an alternative bill of materials register that contains customer-specific BOMs (normally only used once).
If a customer-specific bill of materials turns out to be useful for other customers or as a standard bill of materials, it can be copied to the standard BOM register.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Decimal places | AntDec | ztInteger | 1 |  | smallint
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
BOM notation code | ArtStruktKod | ztString | 1 |  | varchar
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Qty parent level (setup) | BAntalAviStall | ZtQty | 14 | 2 | decimal
Item no. (BOM) | BArtnrStrukt | ztString | 30 |  | varchar
Figure no. | BFigNr | ztString | 6 |  | varchar
Figure no. extended | BFigNr255 | ztString | 255 |  | varchar
Level within work order | BOM_Level_In_WO | ztInteger | 5 |  | smallint
BOM path | BOM_Path | ztString | 255 |  | varchar
BOM sequence number | BOMItemSeqNo | ZtLong | 10 |  | int
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Scrap factor % BOM | KassStrukt | ztFloat | 5 | 2 | float
Operation no. | OpNr | ztInteger | 3 |  | int
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Fixed number | OrderUniktFixtAntal | ZtQty | 14 | 2 | decimal
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Planned quantity | PlaneratAntal | ZtQty | 14 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
TimeGapInDaysToCurrItem | TimeGapInDaysToCurrItem | ztInteger | 5 |  | smallint
Använd property | UseProperty | ztBoolean |  |  | char
Price, curr | vb_pris | ZtSalesPrice | 12 | 2 | money

    This table is the main table in the following programs:

    Program: orps Order-specific mtrl per cust order row


Order rows sales tax (OrpSalesTax)

Order numbers in numeric format. There is also a field for alphanumeric order numbers.

When defining the company's order types, it is possible to set different number series for each order type. The orders whose order types do not have order number series, receive their order numbers from the highest number series.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax amount | TaxAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Tax area level | TaxAreaCode | ztString | 10 |  | varchar
Tax area rate | TaxAreaRate | ZtDecimal73 | 10 | 4 | decimal
Tax base amount | TaxBaseAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Sales tax code | TaxCode | ztInteger | 2 |  | smallint
Tax jurisdiction | TaxJurCode | ztInteger | 2 |  | smallint


Order rows sales tax, view (VOrpSalesTax)

Order numbers in numeric format. There is also a field for alphanumeric order numbers.

When defining the company's order types, it is possible to set different number series for each order type. The orders whose order types do not have order number series, receive their order numbers from the highest number series.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax amount | TaxAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Tax area level | TaxAreaCode | ztString | 10 |  | varchar
Tax area level | TaxAreaDescr | ztString | 60 |  | nvarchar
Tax area rate | TaxAreaRate | ZtDecimal73 | 10 | 4 | decimal
Tax base amount | TaxBaseAmountBCU | ZtBaseCurrAmount | 14 | 2 | money
Sales tax code | TaxCode | ztInteger | 2 |  | smallint
Tax jurisdiction | TaxJurCode | ztInteger | 2 |  | smallint


Order rows, EDI (ord)

This table contains the order rows of the external orders that have been received via EDI/Odette.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Item no. EAN | ArtNrEAN | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Degree of commitment | AtagandeGrad | ztInteger | 2 |  | smallint
Days commitmt 1 | AtagandeGrad1 | ztInteger | 3 |  | smallint
Days commitmt 2 | AtagandeGrad2 | ztInteger | 3 |  | smallint
Days commitmt 3 | AtagandeGrad3 | ztInteger | 3 |  | smallint
Days commitmt 4 | AtagandeGrad4 | ztInteger | 3 |  | smallint
Days commitmt 9 | AtagandeGrad9 | ztInteger | 3 |  | smallint
Automatically created | AutomatSkapad | ztBoolean |  |  | char
Batch no. | BatchId | ztString | 30 |  | varchar
Requested dispatch date | BegPlanLevDatum | ztDate |  |  | datetime
Quantity acc to plan | BestAntalLevPlan | ZtQty | 14 | 2 | decimal
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
Step code | EdiAtgardsKod | ztString | 3 |  | varchar
In/Out box EDI | EdiboxRef | ztString | 21 |  | varchar
EDI unit | EdiEnhet | ztString | 3 |  | varchar
EDI Log | EdiLogg | ztBlob | 1 |  | varchar
Edi log acknowledged | EdiLoggKvitterad | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
Backlog | Efterslap | ztBoolean |  |  | char
Unit code | EnhetsKod | ztString | 4 |  | varchar
Exclude row | ExkluderaRad | ztBoolean |  |  | char
External order number | ExtOrderNr | ztString | 17 |  | varchar
External order row number | ExtOrdRadnr | ztInteger | 5 |  | int
External order row no. for pkg | ExtOrdRadNrStrPos | ztInteger | 4 |  | int
External backorder no. | ExtOrdRestNr | ztInteger | 2 |  | smallint
External order status | ExtOrdSta | ztInteger | 2 |  | smallint
External order type | ExtOrdTyp | ztInteger | 3 |  | smallint
Prev Del.plan date | FLevPlanDatum | ztDate |  |  | datetime
Previous dispatch plan | FLevPlanNr | ztString | 17 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Storage code | ForradsKod | ztString | 17 |  | varchar
Sales price, BCU | fpris | ZtBaseCurrAmount | 14 | 2 | money
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Contact name | ftgperson | ztString | 60 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Item individual reference | IndividRef | ztString | 35 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Just In Time signal | KanbanSignal | ztString | 35 |  | varchar
Customer order no. | KundBestNr | ztString | 30 |  | varchar
Customer's intrn order no | KundIntOrderNr | ztString | 35 |  | varchar
Customer's order row | KundIntOrdRadNr | ZtLong | 6 |  | int
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | landskod | ztString | 3 |  | varchar
Compensation method | LevPlanErsMetod | ztInteger | 1 |  | smallint
Disp.plan number | LevplanNr | ZtLong | 10 |  | int
Dispatch plan row no. | LevPlanRadNr | ZtLong | 10 |  | int
Dispatch time | LevTid | ztTime | 5 |  | datetime
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Recipient code | MottagarKod | ztString | 17 |  | varchar
Acknowledgement status EDI | OeStatusEdi | ztInteger | 5 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Order row qty, alt unit | OrdAntalAltEnh | ZtQty | 14 | 2 | decimal
Request disp date | OrdBegLevDat | ztDate |  |  | datetime
Preparation day | OrdBerednDat | ztDate |  |  | datetime
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order date | OrdDatum | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Defect reason | OrdErrorCd | ztInteger | 4 |  | smallint
Delivery addr, company | ordlevadr1 | ztString | 36 |  | varchar
Delivery address 1 | ordlevadr2 | ztString | 36 |  | varchar
Delivery address 2 | ordlevadr3 | ztString | 36 |  | varchar
Delivery address 3 | ordlevadr4 | ztString | 36 |  | varchar
Delivery date to quay | OrdLevDatTillKaj | ztDate |  |  | datetime
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Promised disp date | OrdLovLevDat | ztDate |  |  | datetime
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Row value, BCU | OrdRadSum | ZtBaseCurrAmount | 14 | 2 | money
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Disc code order value | OrdvRabKod | ztInteger | 2 |  | smallint
Order spec text | OrpRadText | ztString | 255 |  | varchar
Price calc method, pkg | OrpStrPrisBer | ztInteger | 2 |  | smallint
Package item | PaketArtikel | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Gate description | PortBeskrivning | ztString | 35 |  | varchar
Gate code | PortKod | ztString | 17 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Price list EDI | PrisListaEdi | ztString | 35 |  | varchar
Pricing method | PrisTypP | ztInteger | 3 |  | smallint
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence status | SeqStatusEdi | ztString | 3 |  | varchar
Service level code | ServiceLevelCode | ztString | 35 |  | varchar
Last dispatch date | SistaPlanLevDatum | ztDate |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Subcontract Company | SubContractCompany | ztCompanyNo | 20 |  | varchar
Currency clause | ValKlausul | ztInteger | 5 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Price, curr | Vb_Pris | ZtSalesPrice | 12 | 2 | money
Price incl tax, curr | vb_PrisInklMoms | ZtSalesPrice | 12 | 2 | money
Order row amt, curr | vbOrdRadSum | ztMoney | 14 | 2 | money
Price acc to rule | VbPriser | ZtSalesPrice | 12 | 2 | money
Volume disc % | VolymRabatt | ZtDecimal73 | 10 | 2 | decimal


Order rows, items (orp)

Order rows for items (products). These order rows always have an item number that must be in the item table. Such items are normally flagged as stocked, but can also be flagged as non-stocked (services, freight, fees, ....)

The order row always belongs to an order header (OH) and a dispatch order header (OLH).If the order row is released and noted for backorder, it is flagged as backorder (OrdRestNr > 0) and a new row is created (OrdRestNr = 0) with the backorder noted quantity. Active order rows always have backorder number zero (OrdRestNr=0) and a remaining quantity (OrdRestAnt <> 0).

To view/search among open order rows use the order analysis program (orp).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Extra charge deactivated | AddArtInAktiv | ztBoolean |  |  | char
Add to MO row | AddToMO | Jeeves_MONo | 20 |  | bigint
Add to purchase order | AddToPO | Jeeves_PONo | 20 |  | bigint
Active | Aktiv | ztInteger | 1 |  | smallint
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
This field is used in the table as follows: |
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Purchased | AnskaffningKop | ztBoolean |  |  | char
Acq to requirement | AnskaffningMotBehov | ztBoolean |  |  | char
Manufactured | AnskaffningTillv | ztBoolean |  |  | char
To dispatch | AntalAttLev | ZtQty | 14 | 2 | decimal
To disp, alt unit | AntalAttLevAltEnh | ZtQty | 14 | 2 | decimal
Quantity on picking list | AntalPaPlocklista | ZtQty | 14 | 2 | decimal
Qty being picked | AntalUnderPlock | ZtQty | 14 | 2 | decimal
Decimal places | AntDec | ztInteger | 1 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Operations start date | AoStartDat | ztDate |  |  | datetime
Bin | ars_LagPlats | ztBinLocation | 20 |  | varchar
Item description | Artbeskr | ztString | 30 |  | varchar
Recommended price | ArtCirkaPris | ZtSalesPrice | 12 | 2 | money
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
A-kostnad | ArtKalkBerA | ZtBaseCurrAmount | 14 | 2 | money
B-kostnad | ArtKalkBerB | ZtBaseCurrAmount | 14 | 2 | money
C-kostnad | ArtKalkBerC | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Startkostnad | ArtKalkBerStart | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Calc cost price | ArtKalkPris | ZtBaseCurrAmount | 14 | 2 | money
Cost price (actual) | ArtKalkprisE | ZtBaseCurrAmount | 14 | 2 | money
Cost price at order | ArtKalkprisO | ZtBaseCurrAmount | 14 | 2 | money
Fixed cost price for order | ArtKalkprisOFast | ZtBaseCurrAmount | 14 | 2 | money
Cost at order (mtrl) | ArtKalkprisOMtrl | ZtBaseCurrAmount | 14 | 2 | money
Item class | ArtKod | ztInteger | 3 |  | smallint
Customer discnt allowed | ArtKundRabKod | ztBoolean |  |  | char
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Alternative item | ArtNrAltArt | ztString | 30 |  | varchar
Item no. EAN | ArtNrEAN | ztString | 30 |  | varchar
Customer item no. | ArtNrKund | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Reg.template item | ArtNrRegMall | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Pack separately | ArtPackSeparat | ztBoolean |  |  | char
Product class | ArtProdKlass | ztString | 4 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Revision no. | ArtRevId | ztString | 10 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Serienr from | ArtSerieNrFrom | ztString | 30 |  | varchar
T.o.m. serienr | ArtSerieNrTom | ztString | 30 |  | varchar
Degree of commitment | AtagandeGrad | ztInteger | 2 |  | smallint
Aut inlev av TO vid utplock | AutDelivOU_MO | ztInteger | 5 |  | smallint
Automatskapad | AutoCreated | ztBoolean |  |  | char
Automatic release | AutoFrislappas | ztBoolean |  |  | char
Autoskapad orderrad | AutoOrderLine | ztInteger | 5 |  | smallint
Posting template | AutoRegel | ztString | 4 |  | varchar
Auto booking rule | AutStockBookingRule | ztInteger | 5 |  | smallint
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Batch no. required | BatchBokas | ztBoolean |  |  | char
Batch no. | BatchId | ztString | 30 |  | varchar
Ordered | Bestallas | ztBoolean |  |  | char
Order qty (invtry unit) | BestAnt | ZtQty | 14 | 2 | decimal
Order qty (suppl unit) | BestAntExtQty | ZtQty | 14 | 2 | decimal
Purchase price | BestInPris | ZtBaseCurrAmount | 14 | 2 | money
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Figure no. | BFigNr | ztString | 6 |  | varchar
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Booked Qty (invt) | BookQtyInvt | ZtQty | 14 | 2 | decimal
Booked Qty (MO) | BookQtyMO | ZtQty | 14 | 2 | decimal
Booked Qty (PO) | BookQtyPO | ZtQty | 14 | 2 | decimal
Avail check status code | BristKontrolleradStatus | ztInteger | 5 |  | smallint
Avail status (invtry-out) | BristStatusLagerUtlev | ztInteger | 5 |  | smallint
Availability status (plan/req) | BristStatusPlaneringBegLevDat | ztInteger | 5 |  | smallint
Availability status (plan/req) | BristStatusPlaneringBerLevDat | ztInteger | 5 |  | smallint
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Code fixed departure | CodeFixedDeparture | ztBoolean |  |  | char
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Partial booking allowed | DelBokningTillaten | ztInteger | 5 |  | smallint
This field is used in the table as follows: |
Delivery from business unit ICT | DelivFromBusinessUnit | ztString | 8 |  | varchar
Delivery to business unit | DelivToBusinessUnit | ztString | 8 |  | varchar
Dispatch to PO | DelivToPOBackorderNo | ztInteger | 5 |  | smallint
Dispatch to PO | DelivToPOLnNo | ztInteger | 5 |  | smallint
Dispatch to PO | DelivToPONo | ZtLong | 10 |  | int
Part delivery allowed | DelLevTillaten | ztInteger | 5 |  | smallint
This field is used in the table as follows: |
Drop ship | DirektLeverans | ztBoolean |  |  | char
Direct issue | DirektUttag | ztBoolean |  |  | char
Rabattorderrad | DiscountOrderLine | ztInteger | 5 |  | smallint
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
External qty | ExternQty | ZtQty | 14 | 2 | decimal
External order number | ExtOrderNr | ztString | 17 |  | varchar
External order row number | ExtOrdRadNr | ztInteger | 5 |  | int
External order type | ExtOrdTyp | ztInteger | 3 |  | smallint
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice date, change | FaktDatKorr | ztDate |  |  | datetime
Invoice date, original | FaktDatOrg | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no., change | FaktNrKorr | Jeeves_InvNo | 9 |  | bigint
Invoice no., original | FaktNrOrg | Jeeves_InvNo | 9 |  | bigint
Delivery note/disp no. | FfhNr | ZtLong | 10 |  | int
RowNo | FfhRadNr | ztInteger | 5 |  | int
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Delivery note reference | FoljesedelsRef | ztString | 17 |  | varchar
Consumables | ForbrukningsMaterial | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, BCU | FPris | ZtBaseCurrAmount | 14 | 2 | money
Fixed sales price, BCU | FPrisFast | ZtBaseCurrAmount | 14 | 2 | money
Sales price, internal | FPrisInternt | ZtBaseCurrAmount | 14 | 2 | money
Sales price, intrn by rule | FPrisInterntEnlRegel | ZtBaseCurrAmount | 14 | 2 | money
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Godsmärke | GodsMarke | ztString | 40 |  | varchar
Group acquisition by ...... | GroupPoWoOn | ztString | 10 |  | varchar
Third party trade | Handel3Part | ztBoolean |  |  | char
From backorder no. ICT | ICTDelivFromBackOrderNo | ztInteger | 5 |  | smallint
From order no. ICT | ICTDelivFromOrderNo | ZtLong | 10 |  | int
From order row no. ICT | ICTDelivFromOrdLnNo | ztInteger | 5 |  | smallint
From order row no. for pkg ICT | ICTDelivFromOrdSubLnNo | ztInteger | 5 |  | smallint
To backorder no. ICT | ICTDelivToBackOrderNo | ztInteger | 5 |  | smallint
To order no ICT | ICTDelivToOrderNo | ZtLong | 10 |  | int
To order row no ICT | ICTDelivToOrdLnNo | ztInteger | 5 |  | smallint
To order row no pkg ICT | ICTDelivToOrdSubLnNo | ztInteger | 5 |  | smallint
Backorder.no. ICT | ICTDelivToPOBackorderNo | ztInteger | 5 |  | smallint
Purchase order row no. ICT | ICTDelivToPOLnNo | ztInteger | 5 |  | smallint
Purchase order no. ICT | ICTDelivToPONo | ZtLong | 10 |  | int
Order row status ICT | ICTOrdLnStatus | ztInteger | 5 |  | smallint
Booking status ICT | ICTOrdResrvStat | ztInteger | 5 |  | smallint
Code package Item ICT | ICTPackageCode | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Item individual reference | IndividRef | ztString | 35 |  | varchar
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Intrastat trans type | IntStatTransTyp | ztInteger | 2 |  | smallint
Exg rate on order date | InValKurs | ZtCurrencyRate | 15 | 7 | decimal
Purch price curr | InValuta | ztString | 3 |  | varchar
Inventory location WMS | InventoryLocWMS | ztBoolean |  |  | char
Jeeves_Init_Insert_Enter | Jeeves_Init_Insert_Enter | ztDateTime |  |  | datetime
Jeeves_Init_Insert_PreIns | Jeeves_Init_Insert_PreIns | ztDateTime |  |  | datetime
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
At cost | KalkylPrisFaktura | ztString | 1 |  | varchar
Campaign | kampnr | ZtLong | 4 |  | int
Just In Time signal | KanbanSignal | ztString | 35 |  | varchar
Sent from dept/S3 | KBarAvsandandeEnhet | ztString | 8 |  | varchar
No invoicing | KodEjFakturera | ztBoolean |  |  | char
Do not print invoice | KodEJUtskrFA | ztBoolean |  |  | char
Do not print DN | KodEJUtskrFS | ztBoolean |  |  | char
Do not print OA | KodEJUtskrOE | ztBoolean |  |  | char
External text -> order | KodExtTextToOrder | ztBoolean |  |  | char
Invtry transfer, rebook | KodLagerOmBokning | ztBoolean |  |  | char
Configuration item no. | KonfigArtNr | ztString | 30 |  | varchar
Copied from invoice | KopieradFranFaktNr | Jeeves_InvNo | 20 |  | bigint
Copied from order | KopieradFranOrderNr | Jeeves_SONo | 8 |  | bigint
Copied to order | KopieradTillOrderNr | Jeeves_SONo | 8 |  | bigint
KörID | KorId | ZtLong | 10 |  | int
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Cost centre, intrn sales | KostStalleKodIntFsg | ztString | 8 |  | varchar
Credit order | KreditOrder | ztBoolean |  |  | char
CC dispatched unit | KstAvsandandeEnhet | ztString | 8 |  | varchar
Customer's intrn order no | KundIntOrderNr | ztString | 35 |  | varchar
Customer's order row | KundIntOrdRadNr | ZtLong | 6 |  | int
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Sales price incl VAT/tax | KundPrisInklMoms | ztBoolean |  |  | char
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Stocked | LagerBokas | ztBoolean |  |  | char
Inventory transfer | LagerFlyttning | ztBoolean |  |  | char
Inventory mgmt type | LagerHanteringTyp | ztInteger | 2 |  | smallint
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Lagerst för lev.order | LagStalleLevOrder | ztString | 2 |  | varchar
Lagerst för OU-lager | LagStalleOULager | ztString | 2 |  | varchar
Lead time to PO/MO | LedTid_orp_2_bp_ti | ztInteger | 5 |  | smallint
To disp alt unit, blocked | LevAntalAltEnhSparrat | ZtQty | 14 | 2 | decimal
To dispatch, blocked | LevAntalSparrat | ZtQty | 14 | 2 | decimal
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Suppl discount-1 in % | LevRabattProc1 | ZtDecimal73 | 6 | 2 | decimal
Supplier item descr | LevsArtBeskr | ztString | 255 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch time | LevTid | ztTime | 5 |  | datetime
Man reconc, change date | ManReAvstDT | ztDateTime |  |  | datetime
Man reconc, date | ManReAvstPerDen | ztDate |  |  | datetime
Man reconc, sign | ManReAvstPersSign | ztString | 6 |  | varchar
Partially shipped package | MarkDelLevPkt | ztBoolean |  |  | char
Ord spec cost price | MarkOrderUniktKalkP | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Actual material cost | MtrlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (adjust) | MtrlVerklKostJustering | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (mtrl) | MtrlVerklKostMtrl | ZtBaseCurrAmount | 14 | 2 | money
Net, no discount | NettoEjRabKod | ztBoolean |  |  | char
Net price in BCU | NettoPris | ZtSalesPrice | 12 | 2 | money
Do not invoice order row | NotInvoiceOrderLine | ztBoolean |  |  | char
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Quote/agreement row no | OffRadNr | ztInteger | 5 |  | int
Orderingång skapad | OingSkapad | ztBoolean |  |  | char
Pick flag date | OkAttPlockaSattDatum | ztDate |  |  | datetime
Pick status | OkAttPlockaStatus | ztInteger | 5 |  | smallint
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Order row qty, alt unit | OrdAntalAltEnh | ZtQty | 14 | 2 | decimal
B quantity | OrdAntalB | ztFloat | 15 | 2 | float
C quantity | OrdAntalC | ztFloat | 15 | 2 | float
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Request disp date | OrdBegLevDat | ztDate |  |  | datetime
Preparation day | OrdBerednDat | ztDate |  |  | datetime
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Calc deliv.date, backorder deliv | OrdBerLevDatRest | ztDate |  |  | datetime
Est disp time | OrdBerLevTid | ztTime | 6 |  | datetime
Booking status | OrdBokningsStatus | ztInteger | 5 |  | smallint
This field is used in the table as follows: |
Order date | OrdDatum | ztDate |  |  | datetime
Order amt, intrn sales | OrderBeloppIntFsg | ZtBaseCurrAmount | 14 | 2 | money
Order amt, intrn prch | OrderBeloppIntKop | ZtBaseCurrAmount | 14 | 2 | money
Order row from quote | OrderFranOffert | ztBoolean |  |  | char
Order code | OrderKod | ztInteger | 5 |  | smallint
Qty from linked orders | OrderKopplAntal | ZtQty | 14 | 2 | decimal
Order link type | OrderKopplKod | ztInteger | 2 |  | smallint
CSG order, intrn sales | OrderKostnadIntFsg | ZtBaseCurrAmount | 14 | 2 | money
CSG order, intrn purch | OrderKostnadIntKop | ZtBaseCurrAmount | 14 | 2 | money
Orderline from Order, store | OrderLineFromOrderB | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order no. (alpha) | OrderNrAlfa | ztString | 50 |  | varchar
Link order No. | OrderNrKoppl | Jeeves_SONo | 9 |  | bigint
Order No., change | OrderNrKorr | Jeeves_SONo | 8 |  | bigint
Order no. quote | OrderNrOffert | Jeeves_SONo | 8 |  | bigint
Order No., original | OrderNrOrg | Jeeves_SONo | 8 |  | bigint
Order no. | OrderNrServ | Jeeves_SONo | 9 |  | bigint
Order row invoice cost | OrderRadFaktKostnad | ztBoolean |  |  | char
Margin, internal sales | OrderTBIntFsg | ZtBaseCurrAmount | 14 | 2 | money
Margin, internal purch | OrderTBIntKop | ZtBaseCurrAmount | 14 | 2 | money
Margin, internal sales | OrderTGIntFsg | ZtDecimal73 | 10 | 3 | decimal
Margin degree, intrn prch | OrderTGIntKop | ZtDecimal73 | 10 | 3 | decimal
Ord-spec invtry bal | OrderUniktLager | ZtQty | 14 | 2 | decimal
Delivery note no. | OrdFoljesedelsNr | ZtLong | 10 |  | int
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Dispatch qty alt unit | OrdLevAntalAltEnh | ZtQty | 14 | 2 | decimal
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Promised disp date | OrdLovLevDat | ztDate |  |  | datetime
Order row qty on FFH | OrdQtyOnFfh | ZtQty | 14 | 2 | decimal
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Link row No. | OrdRadNrKoppl | ztInteger | 5 |  | int
Order row no, template | OrdRadNrMall | ztInteger | 4 |  | int
Order row no. | OrdRadNrOffert | ztInteger | 5 |  | smallint
Order row no, original | OrdRadNrOrg | ztInteger | 4 |  | smallint
Order row sales | OrdRadNrServ | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPosOffert | ztInteger | 5 |  | smallint
Ord.row no f package, original | OrdRadNrStrPosOrg | ztInteger | 4 |  | smallint
Orig row no in order | OrdRadNrStrPosUrspr | ztInteger | 5 |  | smallint
Orig row no in order | OrdRadNrUrspr | ztInteger | 5 |  | smallint
Total row discount % | OrdRadRab | ZtDecimal73 | 8 | 2 | decimal
Code row split, cust orders | OrdRadSplitKod | ztInteger | 5 |  | smallint
Order row status | OrdRadSt | ztInteger | 2 |  | smallint
Remaining qty | OrdRestAnt | ZtQty | 14 | 2 | decimal
Remaining qty, alt unit | OrdRestAntAltEnh | ZtQty | 14 | 2 | decimal
Remaining to pack | OrdRestAntPack | ZtQty | 14 | 2 | decimal
Backorder | OrdRestNot | ztBoolean |  |  | char
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Backorder no., original | OrdRestNrOrg | ztInteger | 2 |  | smallint
Std order qty | OrdStdAntal | ZtQty | 14 | 2 | decimal
Order type | OrdTyp | ztInteger | 3 |  | smallint
Disc code order value | OrdvRabKod | ztInteger | 2 |  | smallint
Order spec text | OrpRadText | ztString | 255 |  | varchar
Ord.spec text -> PO | OrpRadTextBe | ztBoolean |  |  | char
Order spec text/inv | OrpRadTextFa | ztBoolean |  |  | char
Order spec text/DN | OrpRadTextFs | ztBoolean |  |  | char
Order spec text OA | OrpRadTextOe | ztBoolean |  |  | char
Order spec text/PL | OrpRadTextPl | ztBoolean |  |  | char
Order spec text->MO | OrpRadTextTo | ztBoolean |  |  | char
Utskriftstyp, paket | OrpStrDetUt | ztInteger | 1 |  | smallint
Price calc method, pkg | OrpStrPrisBer | ztInteger | 2 |  | smallint
Package on picking list | PackageItemOnPickList | ztBoolean |  |  | char
Change package qty->det | PackageItemQty2Det | ztBoolean |  |  | char
Package, create 0 details | PackageItemZero | ztBoolean |  |  | char
Package date | PackagingDate | ztDateTime |  |  | datetime
Package item | PaketArtikel | ztBoolean |  |  | char
Pkg w mixed VAT/tax | PaketMultiMomsKod | ztBoolean |  |  | char
Paketartikel (klar?) | PaketUnderArbete | ztBoolean |  |  | char
Quantity PDM | pdmcount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Pkg+details on picking list | PkgAndDetailOnPickList | ztBoolean |  |  | char
Package item controls discounts | PkgItemDiscnt2Detail | ztBoolean |  |  | char
Backorder no., package | PktOrdRestNr | ztInteger | 2 |  | smallint
Net Orig row amt pkg, curr | PktVbOrdRadSumNettoUrspr | ztMoney | 14 | 2 | money
Orig row amt pkg, curr | PktVbOrdRadSumUrspr | ztMoney | 14 | 2 | money
Picking list no. | PlockJnrOrder | ZtLong | 10 |  | int
Picking list date | PLUtskrDat | ztDateTime |  |  | datetime
Preliminary revenue at dsptch | PrelFaktVardeUtlev | ZtBaseCurrAmount | 14 | 2 | money
Pricing method | PrisAdaco | ztInteger | 3 |  | smallint
Date of price chg | PrisAndrDatum | ztDate |  |  | datetime
Pricing type | PrisHantTyp | ztInteger | 3 |  | smallint
Pricing type, intrn sales | PrisHantTypIntFsg | ztInteger | 3 |  | smallint
Price adjustment | PrisJustOrder | ztBoolean |  |  | char
CSG on price adjustment | PrisJustOrderKost | ztBoolean |  |  | char
Price list | PrisLista | ztInteger | 5 |  | smallint
Pricing method | PrisTypP | ztInteger | 3 |  | smallint
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Business opportunity ID | ProspektId | ZtLong | 10 |  | int
Error msg from matrix | PvmErrMessage | ztBlob | 2000 |  | varchar
@zPrompt=null | PvmGridNo | ztInteger | 3 |  | smallint
PvmOrdRadNrOrg | PvmOrdRadNrOrg | ZtLong | 10 |  | smallint
PvmOrdRadNrStrPosOrg | PvmOrdRadNrStrPosOrg | ztInteger | 4 |  | smallint
PvmOrdRestNrOrg | PvmOrdRestNrOrg | ztInteger | 2 |  | smallint
Picking proposal qty | PvmPickPropQty | ZtQty | 14 | 2 | decimal
Product variant management Row | PvmRowIsPvm | ztInteger | 3 |  | smallint
Warning (on variant) | PvmWarningMessage | ztBlob | 2000 |  | varchar
Posting extra overhead2 | q_ALFA_KonteraEO2Palagg | ztBoolean |  |  | char
Posting extra overhead | q_ALFA_KonteraEOPalagg | ztBoolean |  |  | char
Posting basevalue 2 | q_ALFA_KonteraGO2Palagg | ztBoolean |  |  | char
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Discount % | rabatt | ZtDecimal73 | 6 | 2 | decimal
Discount 1 % | rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Qty discount basis | RabattGrundAntal | ZtQty | 14 | 2 | decimal
Discount curr | rabattval | ztMoney | 14 | 2 | money
Discount curr 1 | rabattval1 | ztMoney | 14 | 2 | money
Discount curr 2 | rabattval2 | ztMoney | 14 | 2 | money
Discount curr 3 | rabattval3 | ztMoney | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Spare part order | ReservdelsOrder | ztBoolean |  |  | char
Backorder handling | RestBehKod | ztInteger | 1 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Created UTC date/time | RowCreatedUTCDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Updated date/time | RowUpdatedUTCDT | ztDateTime |  |  | datetime
Sales tax handling | SalesTaxHandling | ztBoolean |  |  | char
Salesperson | Saljare | ztString | 6 |  | varchar
Joint purchase (allowed) | SamInKopMark | ztBoolean |  |  | char
Joint delivery code | SamLevKod | ztString | 4 |  | varchar
Joint pick | SamPlockas | ztBoolean |  |  | char
Joint pick list No. | SamPlockListeNr | ZtLong | 6 |  | int
Joint picking, running no | SamPlockLopNr | ztInteger | 5 |  | int
Serial no. required | SerieNrBokas | ztBoolean |  |  | char
Shipment plan alpha ID | ShipmPlanAlphaid | ztString | 30 |  | varchar
Language | SprakKod | ztInteger | 3 |  | smallint
Time sqlcmd->trg start | SQLCmd2EnterTrg | ZtLong | 10 |  | int
Start av updatering/insert | SqlStmtStartedDT | ztDateTime |  |  | datetime
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Tiering code | StafflingsKod | ztBoolean |  |  | char
Change type new OA | StatusKodNyttOE | ztInteger | 5 |  | smallint
Stock replenishment ICT | StockReplenishment | ztBoolean |  |  | char
Requisition | StrDateTimeBIA | ztString | 28 |  | varchar
Order intake statistics | StrDateTimeOrpo | ztString | 28 |  | varchar
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
This field is used in the table as follows: |
Component cost | SumKalkVardeIngDet | ZtBaseCurrAmount | 14 | 2 | money
Component cost (mtrl) | SumKalkVardeIngDetMtrl | ZtBaseCurrAmount | 14 | 2 | money
Total upbook cost inc MO | SumUppbokKostFranIngTO | ZtBaseCurrAmount | 14 | 2 | money
Component value, BCU | SumVardeIngDet | ZtBaseCurrAmount | 14 | 2 | money
Tot pkg detail value, curr | SumVbVardeIngDet | ztMoney | 14 | 2 | money
Surcharge of row | SurChOfRow | ztInteger | 5 |  | smallint
Sales tax code | TaxCode | ztInteger | 2 |  | smallint
To bin no. | TillLagPlats | ztBinLocation | 20 |  | varchar
Optional item created | TillValArtikelSkapad | ztBoolean |  |  | char
Optional for item | TillValArtToArtNr | ztString | 30 |  | varchar
Optional item for order row no. | TillValArtToOrdRadNr | ztInteger | 4 |  | smallint
Time zone code | TimeZoneCode | ztInteger | 4 |  | smallint
Total deliv quantity | TotOrdLevAntal | ZtQty | 14 | 2 | decimal
Transit delivery | TransitLeverans | ztBoolean |  |  | char
Print order, alpha | Turordning | ztString | 20 |  | varchar
Orig order qty | UrsprOrderAntal | ZtQty | 14 | 2 | decimal
Pick code | UtplocksKod | ztBoolean |  |  | char
Print promised qty | UtskrDokLovAntal | ZtQty | 14 | 2 | decimal
Print promised disp date | UtskrDokLovLevDat | ztDate |  |  | datetime
Print promised price | UtskrDokLovPris | ZtSalesPrice | 12 | 2 | money
Print order acknowl | UtskrDokLovSkaGoras | ztBoolean |  |  | char
Print date new OA | UtskrDokLovUtskrDT | ztDateTime |  |  | datetime
Print on delivery note | UtskrFoljesedel | ztBoolean |  |  | char
Print on picking list | UtskrPlocklista | ztBoolean |  |  | char
Currency clause | ValKlausul | ztInteger | 5 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Variant gruppH | VariantGruppH | ztString | 30 |  | varchar
Variant gruppT | VariantGruppT | ztString | 30 |  | varchar
Variant gruppV | VariantGruppV | ztString | 30 |  | varchar
Variant gruppX | VariantGruppX | ztString | 30 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Invoice 0-price | VaruProv | ztString | 1 |  | varchar
Skattekod 2 | VATCode2 | ztInteger | 5 |  | smallint
Skattekod 3 | VATCode3 | ztInteger | 5 |  | smallint
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Gross purch price, curr (mtrl) | Vb_InPris_Mtrl | ztMoney | 14 | 2 | money
Net price, curr | vb_NettoPris | ZtSalesPrice | 12 | 2 | money
Package diff amount | vb_PkgToDetCalcDiff | ZtBaseCurrAmount | 14 | 2 | money
Price, curr | vb_pris | ZtSalesPrice | 12 | 2 | money
Fixed price, currency | vb_PrisFast | ZtSalesPrice | 12 | 2 | money
Price incl tax, curr | Vb_PrisInklMoms | ZtSalesPrice | 12 | 2 | money
Row value, curr (excl tax) | Vb_RadVardeExklMoms | ztMoney | 14 | 2 | money
Row value, curr (+tax) | Vb_RadVardeInklMoms | ztMoney | 14 | 2 | money
Cost price, curr | vbKalkPris | ztMoney | 14 | 2 | money
Discount | VbOrdRabattSum | ztMoney | 14 | 2 | money
Discount (net price based) | VbOrdRabattSumNetto | ztMoney | 14 | 2 | money
Order row amt, curr | VbOrdRadSum | ztMoney | 14 | 2 | money
Net Order row amt, curr | VbOrdRadSumNetto | ztMoney | 14 | 2 | money
Price acc to rule | VbPrisER | ZtSalesPrice | 12 | 2 | money
Volume disc % | VolymRabatt | ZtDecimal73 | 10 | 2 | decimal

    This table is the main table in the following programs:

    Program: off Open quotation analysis

    Program: OhSRapp2 Manually close order rows in GL

    Program: OrdRadS Order history without totals

    Program: orp Open order analysis

    Program: orp_all Open order analysis (all status levels)

    Program: orp_op_orpa Order row, creating order-spec. op. list

    Program: orp_q Order analysis, inventory reconciliation

    Program: orp_sr_orps Ord. row, creating order-spec. struct.

    Program: orp_upd Open order analysis (change)

    Program: OrpFakt Invoiced order rows

    Program: orpplan Order rows, planning

    Program: orpX Open order rows

    Program: rOrpSSL1 Open orders, seller, est disp

    Program: xOrpBok Booking, order row

    Program: xOrpBokG Booking, order against invtry, PO or MO

    Program: xOrpBokX Booking, order rows against invtry


Order split types (x1z)

Table for code definitions for automatic order division.
This function means that you enter an order division code on items that is then used upon order entry to automatically divide (split) a main order into dispatch orders based on the order division type.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Order split type | OrderDelningsBeskr | ztString | 30 |  | varchar
Order split code | OrderDelningsKod | ztInteger | 2 |  | smallint
Order split type | OrderDelningsTyp | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xx1z Order split types


Order status (x7)

Definition of the different order statuses used to follow the order in the system. The system sets this status automatically when an order is updated.

The following standard records exist. Do not alter/delete:

Order status (OrdStat) | Order status (OrdStatBeskr) | Description
0 | Quotation | The order is only a quotation and cannot be seen in the picking programs.
10 | Entry in progress | The order is reserved and included in statistics, but not yet ready for acknowledgement or dispatch. The order is not displayed in the picking programs and no picking list can be printed.
13 | Entered | The order is ready for dispatch. You can print a picking list and perform picking.
15 | Released to Astro |
20 | Planned | The order is partially delivered. What is backordered is planned.
40 | Dispatch started | Picking has started. You can print a delivery note. Freight and other charges can be entered on the order.
50 | Released for invoicing | The order has been dispatched and released and is now in the invoicing routine. If it is partially delivered, a backorder has been created.
70 | Invoiced | Invoice is printed and invoice number assigned, transferred to the accounts receivable ledger.
90 | Canceled | The order is canceled and therefore cannot be processed. You cannot “reactivate” a canceled order, i.e. you cannot reverse the status to an active status.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order status | OrdStat | ztInteger | 2 |  | smallint
Order status | OrdStatBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xx7 Order status


Order structure (OrpPktDetOrpaOrps)

Order numbers in numeric format. There is also a field for alphanumeric order numbers.

When defining the company's order types, it is possible to set different number series for each order type. The orders whose order types do not have order number series, receive their order numbers from the highest number series.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Item no. (BOM) | BArtNrStrukt | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Text/info | x255 | ztString | 255 |  | varchar


Order types (x6)

This table contains order types and associated information. Please note that the codes of order types that come with Jeeves must not be changed, while the texts, however, may be changed.

Customer-specific order types
---------------------------------
In addition to the standard order types supplied with Jeeves, you can also define your own order types based on the existing ones. For example, it may be useful to apply different order types depending on how the order is received. When creating your own order types, these should be entered at a higher number, suitably at a number 900-999. The order type term can then be used in statistical searches and reports, etc.

Order types between 10 and 29 are reserved for entering new types of drop shipments.

The following standard records exist. Do not alter/delete:

Order type (OrdTyp) | Order type (OrdTypBeskr) | Description
1 | Normal | This order type is used when items from inventory are sold to a customer. Order acknowledgement, picking lists, packing lists, freight bills, invoices, etc. can be printed. Withdrawal from inventory is done by the picking list program.
3 | Internet | Used when you want a separate number series for Internet orders (necessary for replication). Otherwise this is the same as normal orders.
5 | Direct issue | A variant of the standard order, where the inventory is issued as soon as the order row is entered. No picking lists are printed. This order type is used when entering orders after dispatch or when selling over the counter.
6 | Automatic release | This is a variant of direct issue, but the inventory is not issued until the order is released. This means that order rows that are changed or cancelled before release do not generate inventory transactions (since no picking is done). When you exit the order rows upon entry of an order, you are automatically asked if you wish to release it. (As in a "standard order", where you are asked if the order status should be set to "Entered")
10 | Drop shipment (supplier->cust) | Here the items are NOT sold from own inventory and an order is created to a supplier who sends the items directly to the customer. No picking lists, delivery notes or freight bills are printed. The order is invoiced when the supplier confirms shipment to the customer, or when the invoice from the supplier arrives. Inventory balances are not affected.
11 | Transit (supplier->inventory->customer) | A variant of drop shipment in which the items are always purchased from a supplier for a customer order, but the goods are shipped through our own inventory. Processing is much like standard orders, except that you never need to pick the items (they are automatically shipped upon receipt).
15 | Order-specific inventory | A variation of transit via own inventory. Goods are not picked for customer orders on delivery but are placed in a separate inventory linked to the customer order (order-specific inventory). From this order-specific inventory, items can be picked for the order. If any non-picked goods remain in the order-specific inventory when the order is released, they are automatically picked (from version 6 you can control when this will be done via a control code in the system table). An order-specific inventory is useful when the goods have a high value and remain in stock a while before being shipped to the customer. There are programs and lists that show the value of the order unique stock.
70 | Stock replenishment ICT | Customer order type is used for internal stock replenishment from the own business unit to another demanding business unit (internal company/inventory location) by using the functionality for Inter Company Transactions (ICT). This means that a purchase order is entered at the business unit where the stock is to be replenished, and a customer order is automatically created from the purchase order at the business unit to supply the goods for replenishment. Customer/purchase orders of this type require a company ID that is flagged as an internal company, when you enter the supplier ID on the replenishment purchase order at the own business unit, and also for the customer ID used on the customer order that is automatically created at the supplying business unit.
101 | Credit order sv | Credit order is a flag that the order is a negative standard order. The quantity on the order row must be entered as a negative quantity for return to inventory. (Note: The order type does not control returns to inventory; the quantity field does this.) Jeeves does not actually use this order type to create a credit invoice; the invoice total determines if an invoice is a charge or credit invoice.
201 | Price adjustment | Incorrect prices on earlier invoices are adjusted with this order type. The cost price is set to zero on the invoice. No inventory balances are affected.
203 | Sample | A variation of a standard order where the sales price on the invoice is zero. If you have also flagged the field 'Temporary inventory transfer' (MoveStockToStock) for the order type, the items are automatically moved to the inventory location specified in the field 'To inventory location' (TillLagStalle), i.e. the inventory location that refers to loans/temporary dispatches. If the order type is flagged in this way it is automatically blocked from invoicing.
212 | Transfer between inventory locations | This transfer order type can be used to transfer goods between different inventory locations and allow inventory and other personnel to treat it as a standard order in which you can plan and generate picking lists and delivery notes. This type of order does not generate an invoice; inventory posting is instead performed so that the inventory value is transferred between the inventory units. The receiving inventory location must have a customer number with a name and address to print on the documents. Note! From version 8.0 you must not use order type 212 for this purpose, this is controlled through a flag in the 'Inventory transfer' check box. However, order type number 212 cannot be used for another order type. Also note that it is not possible to use transfer order types for order rows marked for ordering/manufacturing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Automatic release | AutoFrislappas | ztBoolean |  |  | char
Status at order close | AutoOrderEnding | ztString | 1 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Aut utplock OU lager | AutoUtplOULager | ztBoolean |  |  | char
Ordered | Bestallas | ztBoolean |  |  | char
Test, create PO/MO | CheckBestGen | ztInteger | 5 |  | smallint
Code fixed departure | CodeFixedDeparture | ztBoolean |  |  | char
Drop ship | DirektLeverans | ztBoolean |  |  | char
Direct issue | DirektUttag | ztBoolean |  |  | char
Credt block OFF (Edi) | EdiKreditSparrAv | ztBoolean |  |  | char
Handling charge | ExpAvgKd | ztBoolean |  |  | char
Usage, invent transf | ForbruknVidLagerFlytt | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Invoice insurance fee | ForSakrKostnKod | ztBoolean |  |  | char
From our order no. | FromOrderNr | Jeeves_SONo | 8 |  | bigint
Close order, CO entry | GoToOrderEnding1 | ztInteger | 1 |  | smallint
Close order, picking | GoToOrderEnding2 | ztInteger | 1 |  | smallint
Close order, release | GoToOrderEnding3 | ztInteger | 1 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Intrastat trans type | IntStatTransTyp | ztInteger | 2 |  | smallint
Invoice on invtry transfer | InvoiceInvtTransf | ztBoolean |  |  | char
At cost | KalkylPrisFaktura | ztString | 1 |  | varchar
No invoicing | KodEjFakturera | ztBoolean |  |  | char
Post cost of sold goods | KonteraKSV | ztBoolean |  |  | char
This field is used in the table as follows: |
Posting per invtry location | KonterasEnlLagStalle | ztString | 2 |  | varchar
Code by invtry rule | KonterasEnlLagStalleRegel | ztInteger | 2 |  | smallint
Credit limit check | KreditKontroll | ztBoolean |  |  | char
Credit order | KreditOrder | ztBoolean |  |  | char
Inv change, for invc | LagerAndringForFakt | ztBoolean |  |  | char
Inv change, not to row | LagerAndringKod | ztBoolean |  |  | char
Inventory transfer | LagerFlyttning | ztBoolean |  |  | char
Inventory mgmt type | LagerHanteringTyp | ztInteger | 2 |  | smallint
Value to price | LagerVardeEnlInPris | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Manual order no. | ManRegOrderNr | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
May be used mobil | mobsaleordtyp | ztBoolean |  |  | char
Temporary invtry transfer | MoveStockToStock | ztBoolean |  |  | char
Order link, days | OrderKopplDagar | ztInteger | 5 |  | smallint
Order link type | OrderKopplKod | ztInteger | 2 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Order type | OrdTypBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Price adjustment | PrisJustOrder | ztBoolean |  |  | char
CSG on price adjustment | PrisJustOrderKost | ztBoolean |  |  | char
No Avail Check (Matrix) | PvmNoAvailCheck | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Backorder handling | RestBehKod | ztInteger | 1 |  | smallint
Order link type, backorder | RestOrderKopplKod | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Collective invoicing | SamFaktUtskr | ztBoolean |  |  | char
Stock replenishment ICT | StockReplenishment | ztBoolean |  |  | char
To inventory location | TillLagStalle | ztString | 2 |  | varchar
To our order no. | TomOrderNr | Jeeves_SONo | 8 |  | bigint
Transit delivery | TransitLeverans | ztBoolean |  |  | char
Invoice 0-price | VaruProv | ztString | 1 |  | varchar

    This table is the main table in the following programs:

    Program: Xx6 Order types


Order types internal purchase, view (vx6w)

Table containing order types and associated information. Please note that the codes of order types that come with Jeeves must not be changed, whereas the texts, however, may be changed.

Customer-specific order types
---------------------------------
In addition to the standard order types supplied with Jeeves, you can also define your own order types based on the existing ones. For example, it may be useful to apply different order types depending on how the order is received. The order type term can then be used in statistical queries and reports.

Order types between 10 and 29 are reserved for entering new types of drop shipments.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Automatic release | AutoFrislappas | ztBoolean |  |  | char
Status at order close | AutoOrderEnding | ztString | 1 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Aut utplock OU lager | AutoUtplOULager | ztBoolean |  |  | char
Ordered | Bestallas | ztBoolean |  |  | char
Test, create PO/MO | CheckBestGen | ztInteger | 5 |  | smallint
Drop ship | DirektLeverans | ztBoolean |  |  | char
Direct issue | DirektUttag | ztBoolean |  |  | char
Credt block OFF (Edi) | EdiKreditSparrAv | ztBoolean |  |  | char
Handling charge | ExpAvgKd | ztBoolean |  |  | char
Usage, invent transf | ForbruknVidLagerFlytt | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Invoice insurance fee | ForSakrKostnKod | ztBoolean |  |  | char
From our order no. | FromOrderNr | Jeeves_SONo | 8 |  | bigint
Close order, CO entry | GoToOrderEnding1 | ztInteger | 1 |  | smallint
Close order, picking | GoToOrderEnding2 | ztInteger | 1 |  | smallint
Close order, release | GoToOrderEnding3 | ztInteger | 1 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Invoice on invtry transfer | InvoiceInvtTransf | ztBoolean |  |  | char
At cost | KalkylPrisFaktura | ztString | 1 |  | varchar
No invoicing | KodEjFakturera | ztBoolean |  |  | char
Post cost of sold goods | KonteraKSV | ztBoolean |  |  | char
This field is used in the table as follows: |
Posting per invtry location | KonterasEnlLagStalle | ztString | 2 |  | varchar
Code by invtry rule | KonterasEnlLagStalleRegel | ztInteger | 2 |  | smallint
Credit limit check | KreditKontroll | ztBoolean |  |  | char
Credit order | KreditOrder | ztBoolean |  |  | char
Inv change, for invc | LagerAndringForFakt | ztBoolean |  |  | char
Inv change, not to row | LagerAndringKod | ztBoolean |  |  | char
Inventory transfer | LagerFlyttning | ztBoolean |  |  | char
Inventory mgmt type | LagerHanteringTyp | ztInteger | 2 |  | smallint
Value to price | LagerVardeEnlInPris | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Manual order no. | ManRegOrderNr | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Temporary invtry transfer | MoveStockToStock | ztBoolean |  |  | char
Order link, days | OrderKopplDagar | ztInteger | 5 |  | smallint
Order link type | OrderKopplKod | ztInteger | 2 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Order type | OrdTypBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Price adjustment | PrisJustOrder | ztBoolean |  |  | char
CSG on price adjustment | PrisJustOrderKost | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Backorder handling | RestBehKod | ztInteger | 1 |  | smallint
Order link type, backorder | RestOrderKopplKod | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Collective invoicing | SamFaktUtskr | ztBoolean |  |  | char
Stock replenishment ICT | StockReplenishment | ztBoolean |  |  | char
To inventory location | TillLagStalle | ztString | 2 |  | varchar
To our order no. | TomOrderNr | Jeeves_SONo | 8 |  | bigint
Transit delivery | TransitLeverans | ztBoolean |  |  | char
Invoice 0-price | VaruProv | ztString | 1 |  | varchar


Order types price adjustment, view (vwx6p)

Table containing order types and associated information. Please note that the codes of order types that come with Jeeves must not be changed, whereas the texts, however, may be changed.

Customer-specific order types
---------------------------------
In addition to the standard order types supplied with Jeeves, you can also define your own order types based on the existing ones. For example, it may be useful to apply different order types depending on how the order is received. The order type term can then be used in statistical queries and reports.

Order types between 10 and 29 are reserved for entering new types of drop shipments.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Automatic release | AutoFrislappas | ztBoolean |  |  | char
Status at order close | AutoOrderEnding | ztString | 1 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Aut utplock OU lager | AutoUtplOULager | ztBoolean |  |  | char
Ordered | Bestallas | ztBoolean |  |  | char
Test, create PO/MO | CheckBestGen | ztInteger | 5 |  | smallint
Drop ship | DirektLeverans | ztBoolean |  |  | char
Direct issue | DirektUttag | ztBoolean |  |  | char
Credt block OFF (Edi) | EdiKreditSparrAv | ztBoolean |  |  | char
Handling charge | ExpAvgKd | ztBoolean |  |  | char
Usage, invent transf | ForbruknVidLagerFlytt | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Invoice insurance fee | ForSakrKostnKod | ztBoolean |  |  | char
From our order no. | FromOrderNr | Jeeves_SONo | 8 |  | bigint
Close order, CO entry | GoToOrderEnding1 | ztInteger | 1 |  | smallint
Close order, picking | GoToOrderEnding2 | ztInteger | 1 |  | smallint
Close order, release | GoToOrderEnding3 | ztInteger | 1 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Invoice on invtry transfer | InvoiceInvtTransf | ztBoolean |  |  | char
At cost | KalkylPrisFaktura | ztString | 1 |  | varchar
No invoicing | KodEjFakturera | ztBoolean |  |  | char
Post cost of sold goods | KonteraKSV | ztBoolean |  |  | char
This field is used in the table as follows: |
Posting per invtry location | KonterasEnlLagStalle | ztString | 2 |  | varchar
Code by invtry rule | KonterasEnlLagStalleRegel | ztInteger | 2 |  | smallint
Credit limit check | KreditKontroll | ztBoolean |  |  | char
Credit order | KreditOrder | ztBoolean |  |  | char
Inv change, for invc | LagerAndringForFakt | ztBoolean |  |  | char
Inv change, not to row | LagerAndringKod | ztBoolean |  |  | char
Inventory transfer | LagerFlyttning | ztBoolean |  |  | char
Inventory mgmt type | LagerHanteringTyp | ztInteger | 2 |  | smallint
Value to price | LagerVardeEnlInPris | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Manual order no. | ManRegOrderNr | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Temporary invtry transfer | MoveStockToStock | ztBoolean |  |  | char
Order link, days | OrderKopplDagar | ztInteger | 5 |  | smallint
Order link type | OrderKopplKod | ztInteger | 2 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Order type | OrdTypBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Price adjustment | PrisJustOrder | ztBoolean |  |  | char
CSG on price adjustment | PrisJustOrderKost | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Backorder handling | RestBehKod | ztInteger | 1 |  | smallint
Order link type, backorder | RestOrderKopplKod | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Collective invoicing | SamFaktUtskr | ztBoolean |  |  | char
Stock replenishment ICT | StockReplenishment | ztBoolean |  |  | char
To inventory location | TillLagStalle | ztString | 2 |  | varchar
To our order no. | TomOrderNr | Jeeves_SONo | 8 |  | bigint
Transit delivery | TransitLeverans | ztBoolean |  |  | char
Invoice 0-price | VaruProv | ztString | 1 |  | varchar


Order types, number series (x66)

Number series for order types in the order/invoicing module.

If you wish to designate a number series to a specific order type, orders of other order types will be given the next unused number in the highest number series. E.g. if the highest number series is 80000 to 84999, the orders of order types without number series will be numbers from 85000 and upwards.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no. unique | FaktNrIntervUnikt | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
From invoice no. | FromFaktNr | Jeeves_InvNo | 9 |  | bigint
From cash note no. | FromKontantNr | Jeeves_InvNo | 9 |  | bigint
From our order no. | FromOrderNr | Jeeves_SONo | 8 |  | bigint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cash note no. | KontantNr | Jeeves_InvNo | 9 |  | bigint
Cash note no. unique | KontNotaNrIntervUnikt | ztBoolean |  |  | char
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order no interv, unique | OrderNrIntervUnikt | ztBoolean |  |  | char
Order type | OrdTyp | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
To invoice no. | TomFaktNr | Jeeves_InvNo | 9 |  | bigint
To cash note no. | TomKontantNr | Jeeves_InvNo | 9 |  | bigint
To our order no. | TomOrderNr | Jeeves_SONo | 8 |  | bigint


Order types, view (Amendment order) (vwx6)

This table contains order types and associated information. Please note that the codes of order types that come with Jeeves must not be changed. The texts however may be changed.

Customer-specific order types
---------------------------------
In addition to the standard order types supplied with Jeeves, you can also define your own order types based on the existing ones. For example, you may want to apply different order types depending on how the order is received. The order type term can then be used in statistical queries and reports.

Order types between 10 and 29 are reserved for entering new types of drop shipments.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Automatic release | AutoFrislappas | ztBoolean |  |  | char
Status at order close | AutoOrderEnding | ztString | 1 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Aut utplock OU lager | AutoUtplOULager | ztBoolean |  |  | char
Ordered | Bestallas | ztBoolean |  |  | char
Test, create PO/MO | CheckBestGen | ztInteger | 5 |  | smallint
Drop ship | DirektLeverans | ztBoolean |  |  | char
Direct issue | DirektUttag | ztBoolean |  |  | char
Credt block OFF (Edi) | EdiKreditSparrAv | ztBoolean |  |  | char
Handling charge | ExpAvgKd | ztBoolean |  |  | char
Usage, invent transf | ForbruknVidLagerFlytt | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Invoice insurance fee | ForSakrKostnKod | ztBoolean |  |  | char
From our order no. | FromOrderNr | Jeeves_SONo | 8 |  | bigint
Close order, CO entry | GoToOrderEnding1 | ztInteger | 1 |  | smallint
Close order, picking | GoToOrderEnding2 | ztInteger | 1 |  | smallint
Close order, release | GoToOrderEnding3 | ztInteger | 1 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Invoice on invtry transfer | InvoiceInvtTransf | ztBoolean |  |  | char
At cost | KalkylPrisFaktura | ztString | 1 |  | varchar
No invoicing | KodEjFakturera | ztBoolean |  |  | char
Post cost of sold goods | KonteraKSV | ztBoolean |  |  | char
This field is used in the table as follows: |
Posting per invtry location | KonterasEnlLagStalle | ztString | 2 |  | varchar
Code by invtry rule | KonterasEnlLagStalleRegel | ztInteger | 2 |  | smallint
Credit limit check | KreditKontroll | ztBoolean |  |  | char
Credit order | KreditOrder | ztBoolean |  |  | char
Inv change, for invc | LagerAndringForFakt | ztBoolean |  |  | char
Inv change, not to row | LagerAndringKod | ztBoolean |  |  | char
Inventory transfer | LagerFlyttning | ztBoolean |  |  | char
Inventory mgmt type | LagerHanteringTyp | ztInteger | 2 |  | smallint
Value to price | LagerVardeEnlInPris | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Manual order no. | ManRegOrderNr | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Temporary invtry transfer | MoveStockToStock | ztBoolean |  |  | char
Order link, days | OrderKopplDagar | ztInteger | 5 |  | smallint
Order link type | OrderKopplKod | ztInteger | 2 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Order type | OrdTypBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Price adjustment | PrisJustOrder | ztBoolean |  |  | char
CSG on price adjustment | PrisJustOrderKost | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Backorder handling | RestBehKod | ztInteger | 1 |  | smallint
Order link type, backorder | RestOrderKopplKod | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Collective invoicing | SamFaktUtskr | ztBoolean |  |  | char
Stock replenishment ICT | StockReplenishment | ztBoolean |  |  | char
To inventory location | TillLagStalle | ztString | 2 |  | varchar
To our order no. | TomOrderNr | Jeeves_SONo | 8 |  | bigint
Transit delivery | TransitLeverans | ztBoolean |  |  | char
Invoice 0-price | VaruProv | ztString | 1 |  | varchar


Order types/view (vx6s)

View of the order types with corresponding data on which activities they are to go through.

The following order types are standard. Note that the codes of these types CANNOT be changed, but the text can.

1 Standard order
5 Direct issue
6 Automatically released
10 Drop shipment (from supplier directly to customer)
11 Transit order (from supplier via own inventory to customer)
15 Order-specific inventory
101 Credit
201 Price adjustment
203 Sample
212 Transfer between inventory locations

Order types between 10 and 29 are reserved to add new types of "drop shipments".

Customer-specific order types
------------------------------
You can add your own order types (you may wish to have different order types depending on how the order is received). For this purpose, we recommend that you use the number range 900-999.

The order type can be used in statistical queries and reports.

For a more detailed description of each order type, see the help texts for each term (OrdTyp).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Automatic release | AutoFrislappas | ztBoolean |  |  | char
Posting template | AutoRegel | ztString | 4 |  | varchar
Aut utplock OU lager | AutoUtplOULager | ztBoolean |  |  | char
Ordered | Bestallas | ztBoolean |  |  | char
Drop ship | DirektLeverans | ztBoolean |  |  | char
Direct issue | DirektUttag | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
From our order no. | FromOrderNr | Jeeves_SONo | 8 |  | bigint
At cost | KalkylPrisFaktura | ztString | 1 |  | varchar
Credit order | KreditOrder | ztBoolean |  |  | char
Value to price | LagerVardeEnlInPris | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Order type | OrdTypBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Price adjustment | PrisJustOrder | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
To our order no. | TomOrderNr | Jeeves_SONo | 8 |  | bigint
Transit delivery | TransitLeverans | ztBoolean |  |  | char
Invoice 0-price | VaruProv | ztString | 1 |  | varchar


Order value discount codes (xaor)

Definition of codes for how the item values will affect the calculation of order value discounts.

The following standard records exist. Do not alter/delete:

Disc code order value (OrdvRabKod) | Order value discount (OrdvRabBeskr) | Description
0 | Net discount basis | The value of the item is eligible for an order value discount, i.e. it is included in an order's total discount basis value, but no discount is granted for the item in question.
1 | Discounted/discountable | The value of the item is eligible for an order value discount, i.e. it is included in an order's total discount basis value, and a discount is granted for the item in question.
2 | Net non-discountable | The value of the item is not eligible for an order value discount, i.e. it is not included in an order's total discount basis value, and no discount is granted for the item in question.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order value discount | OrdvRabBeskr | ztString | 50 |  | varchar
Discount flag | OrdvRabGrund | ztBoolean |  |  | char
Disc code order value | OrdvRabKod | ztInteger | 2 |  | smallint
Order value disc | OrdvRabLamn | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xaor Order value discount codes


Order value discounts (xorb)

Definition of intervals for general order value discounts.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order value >= | LimitLow | ZtBaseCurrAmount | 14 | 2 | money
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xxorb Order value discounts


Order, collective invoicing (ohsf)

Data on orders for collective invoicing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of days disp -> invoice | AntDagLev2Fakt | ztInteger | 3 |  | smallint
Payment terms | BetKod | ztString | 2 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight documents | FraktHandlKod | ztBoolean |  |  | char
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
@zPrompt=null | KeyCodeOhsf | ztInteger | 5 |  | smallint
Credit period days | KreditTid | ztInteger | 3 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Dispatched on, actual | OrdVerklLevDat | ztDate |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Collective invoice object | SamFaktObjekt | ztInteger | 1 |  | smallint
Collective invoicing ID | SamFaktOffNr | ztString | 30 |  | varchar
Collective invoicing | SamFaktUtskr | ztBoolean |  |  | char
Server process ID | ServerProcessId | ZtLong | 10 |  | int
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Currency | ValKod | ztString | 3 |  | varchar
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: ohsf Log, collective invoicing


Order-inventory connection (view) (vcrl)

Links between customer order rows and existing batches/deliveries in inventory. Records are created in the table when booking inventory to customer orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal |  |  |  | @DataType=NULL
Item no. | ArtNr |  |  |  | @DataType=NULL
Item serial no. | ArtSerieNr |  |  |  | @DataType=NULL
Batch no. | BatchId |  |  |  | @DataType=NULL
Sequence number | DummyUniqueId |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Active connection | Koppling |  |  |  | @DataType=NULL
Bin | LagPlats |  |  |  | @DataType=NULL
Inventory location | LagStalle |  |  |  | @DataType=NULL
Order no. | OrderNr |  |  |  | @DataType=NULL
Order row no. | OrdRadnr |  |  |  | @DataType=NULL
Subrow no. | OrdRadNrStrPos |  |  |  | @DataType=NULL
Backorder no. | OrdRestNr |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Project ID | ProjCode |  |  |  | @DataType=NULL
Row | RadPos |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDT |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDT |  |  |  | @DataType=NULL
Date/time | StrDateTime |  |  |  | @DataType=NULL
Item group | VaruGruppKod |  |  |  | @DataType=NULL


Order-inventory connections (corl)

Links between customer order rows and existing batches/deliveries in inventory. Records are created in the table when booking inventory to customer orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Automatskapad | BoknAutoCreated | ztBoolean |  |  | char
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Active connection | Koppling | ztBoolean |  |  | char
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Picking index for order | PlockIndexOrder | ZtLong | 10 |  | int
Picking list no. | PlockJnrOrder | ZtLong | 10 |  | int
Picking list date | PLUtskrDat | ztDateTime |  |  | datetime
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: corl Show order-inventory bookings

    Program: corl2 Show inventory-order bookings


Order-purchase order connections (corb)

Links between order rows and open purchase orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Active connection | Koppling | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: corpbp Order-purchase order connections


Order-specific inventory journal (joul)

Posting journal of reports for order specific inventory.
A voucher is created for each journal.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Transaction date | LagTransDatum | ztDate |  |  | datetime
Ord-spec jrnl no. | OulJournNr | ZtLong | 6 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: Joul Order-spec inventory journal


Order-specific inventory->GL (olvt)

Detailed information per transaction of how order-specific inventory transactions are posted when integrated with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans qty (+/-) | LagTransAntal | ZtQty | 14 | 2 | decimal
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Sequence no. | LopNr | ZtLong | 10 |  | int
Operation no. | OpNr | ztInteger | 3 |  | int
Ord-spec jrnl no. | OulJournNr | ZtLong | 6 |  | int
Period | Period | ztInteger | 4 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint


Order-specific invtry balance (arsp)

Order-specific inventory balance received from purchases/manufacturing order directly from customer orders. The inventory balance is then NOT saved for the item in the normal inventory balance table (ars) but on the customer order or the manufacturing order in this separate table for order-specific inventory balances.

The order-specific inventory balance is then canceled at dispatch of a customer order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Decimal places | AntDec | ztInteger | 1 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Cost price at order | ArtKalkPrisO | ZtBaseCurrAmount | 14 | 2 | money
Cost at order (refinement) | ArtKalkPrisOForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost at order (mtrl) | ArtKalkPrisOMtrl | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Purchase price budget | BudgInPris | ZtBaseCurrAmount | 14 | 2 | money
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Invc checked qty | FaktAvprAntal | ZtQty | 14 | 2 | decimal
Invc match value BCU | FaktAvprVardeBas | ZtBaseCurrAmount | 14 | 2 | money
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Receiving value | InlevKalkVarde | ZtBaseCurrAmount | 14 | 2 | money
Calc val rcvd mtrl | InlevKalkVardeMtrl | ZtBaseCurrAmount | 14 | 2 | money
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Physical inventory | InvAntal | ZtQty | 14 | 2 | decimal
Inv diff qty OrdSpec inv | InvDiffAntalOULager | ZtQty | 14 | 2 | decimal
Inv.diff value OS inventory | InvDiffVardeOULager | ZtBaseCurrAmount | 14 | 2 | money
Physical invtry date | InventeringsDatum | ztDate |  |  | datetime
Phys invtry journ no. | InvJournal | ZtLong | 5 |  | int
OrderSpec S4 (rcv cost centre) | K4OULager | ztString | 8 |  | varchar
OS-S5 (rcv deliveries) | K5OULager | ztString | 8 |  | varchar
OrderSpec S6 (rcv deliveries) | K6OULager | ztString | 8 |  | varchar
OrderSpec S7 (rcv deliveries) | K7OULager | ztString | 8 |  | varchar
Inventory value, cost price | KalkLagerVarde | ZtBaseCurrAmount | 14 | 2 | money
Invtry value, refinement price | KalkLagerVardeForadling | ZtBaseCurrAmount | 14 | 2 | money
Invtry value, material price | KalkLagerVardeMtrl | ZtBaseCurrAmount | 14 | 2 | money
CO specific CC (rec) | KBarOUlager | ztString | 8 |  | varchar
Orderspec rcv CC | KstOULager | ztString | 8 |  | varchar
Orderspec rcv account | KtoNrOULager | ztString | 8 |  | varchar
Amount to match | LagerVardeAttFaktAvpr | ZtBaseCurrAmount | 14 | 2 | money
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Transaction date | LagTransDatum | ztDate |  |  | datetime
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Ord spec cost price | MarkOrderUniktKalkp | ztBoolean |  |  | char
Actual material cost | MtrlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (refinement) | MtrlVerklKostForadling | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (mtrl) | MtrlVerklKostMtrl | ZtBaseCurrAmount | 14 | 2 | money
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order no. (alpha) | OrderNrAlfa | ztString | 50 |  | varchar
Ord-spec invtry bal | OrderUniktLager | ZtQty | 14 | 2 | decimal
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
OrdSpec cost prc = purch prc | OUSCostPriceFromPurPrice | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Picking index for order | PlockIndexOrder | ZtLong | 10 |  | int
Picking list no. | PlockJnrOrder | ZtLong | 10 |  | int
Picking list date | PLUtskrDat | ztDateTime |  |  | datetime
Calc rec value (added costs) | RecDelValueAddedCosts | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Date/time | StrDateTime | ztString | 28 |  | varchar
Physical inventory | UnderInventering | ztBoolean |  |  | char
Deliv from MO | UttagFranAoNr | Jeeves_MONo | 7 |  | bigint
Deliv from MO Pos | UttagFranAoPos | ztInteger | 5 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Gross purch price, curr (mtrl) | vb_inpris_mtrl | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: xArsp Order-specific inventory


Order-specific operations, item (orpa)

Definition of customer order-unique work operations, i.e. the different work stages for manufacturing of an item, with the option to specify where they are performed, times and costs, etc. The data are linked to a customer order row and can then be made unique for each customer order despite being the same item manufactured.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity per hour | AntalPerTimme | ztFloat | 15 | 6 | float
Aut. reported | AoDummyRapp | ztBoolean |  |  | char
Show operation | AoVisas | ztBoolean |  |  | char
CalcCost labour/op | ArbKalkArbKost | ZtBaseCurrAmount | 14 | 2 | money
Calc setup cost | ArbKalkStallKost | ZtBaseCurrAmount | 14 | 2 | money
Labour overhead | ArbOmk | ZtCost | 16 | 6 | float
Fixed labour OH | ArbOmkFast | ZtCost | 16 | 6 | float
Tot labour OH/op | ArbOmkOp | ZtCost | 16 | 6 | float
Variable labour OH | ArbOmkRorl | ZtCost | 16 | 6 | float
Setup labour OH/unit | ArbOmkStall | ZtCost | 16 | 6 | float
Setup overhead, labour | ArbStallBiKost | ZtCost | 16 | 6 | float
Setup cost labour | ArbStallKost | ZtCost | 16 | 6 | float
Labour overhead/unit | ArbStyckBiKost | ZtCost | 16 | 6 | float
Labour cost/unit | ArbStyckKost | ZtCost | 16 | 6 | float
Item no. | ArtNr | ztString | 30 |  | varchar
Auto receiving type | AutInlevTyp | ztInteger | 5 |  | smallint
Autom mtrl.uttag | AutMtrlUttag | ztBoolean |  |  | char
Auto mtrl issue type | AutMtrlUttagTyp | ztInteger | 5 |  | smallint
Workload factor | BelaggningsFaktor | ztFloat | 15 | 2 | float
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
PDM | ExistsPdm | ztBoolean |  |  | char
PDM (order) | ExistsPdmPO | ztBoolean |  |  | char
PDM (MO) | ExistsPdmWO | ztBoolean |  |  | char
Extra overhead cost | ExtraOmk | ZtCost | 16 | 6 | float
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Calculation date | KalkBerDatum | ztDate |  |  | datetime
Scrap degree/op | KassOp | ztFloat | 5 | 2 | float
Inspection instruction | KontrollInstruktion | ztBlob | 1 |  | varchar
Queue time | KoTid | ztFloat | 15 | 2 | float
Lead time material | LeadTimeMtrlOnOp | ztInteger | 5 |  | smallint
Subcontract overhead cost | LegoBiKost | ZtCost | 16 | 6 | float
Subcontract cost | LegoKost | ZtCost | 16 | 6 | float
Subcontract price/unit | LegoPris | ZtBaseCurrAmount | 14 | 2 | money
Subcontract setup price | LegoPrisStall | ZtBaseCurrAmount | 14 | 2 | money
Subcontract start price | LegoPrisStart | ZtBaseCurrAmount | 14 | 2 | money
Subcontract flag | MarkLego | ztBoolean |  |  | char
Personnel/operation | OpBemanning | ztFloat | 6 | 3 | float
Personnel/operation, setup | OpBemanningStall | ztFloat | 6 | 3 | float
Personnel/operation, ext setup | OpBemanningYttreStall | ztFloat | 6 | 3 | float
Operation | OpBen | ztString | 30 |  | varchar
Operation | OpBeskr | ztBlob | 1 |  | varchar
End of parallel workload | OpEndParallelWorkload | ztInteger | 5 |  | smallint
Operation text ID | OperationsTextNr | ztInteger | 4 |  | smallint
Fixed quantity/operation | OpFastAntal | ZtQty | 14 | 2 | decimal
Description, subcontract | OpLegoBen | ztString | 30 |  | varchar
Fixed quantity operation | OpMarkFastAntal | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Operation sort | OpSorteringsNr | ZtLong | 4 |  | int
Operation split | OpSplitt | ztFloat | 15 | 2 | float
Start parallel workload | OpStartParallelWorkload | ztBoolean |  |  | char
OpStartsMinutesAfterMO | OpStartsMinutesAfterMO | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Fix operation time | OrderUniktFixProdTid | ztOpTime | 9 | 4 | float
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Overlapping after quantity | OverLappEfterAntal | ZtQty | 14 | 2 | decimal
Overlapping after time | OverLappEfterTid | ztOpTime | 9 | 4 | float
Pay-Roll Type | PayRollType | ztString | 8 |  | varchar
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Mfg grp deprec. | PgAvskrKost | ZtCost | 16 | 6 | float
Mfg grp fixed cost | PgFastKost | ZtCost | 16 | 6 | float
Mfg grp var cost | PgRorlKost | ZtCost | 16 | 6 | float
Mfg grp setup cost | PgStallKost | ZtCost | 16 | 6 | float
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Spare part order | ReservdelsOrder | ztBoolean |  |  | char
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Unit time B | StyckTidB | ztFloat | 8 | 4 | float
Unit time C | StyckTidC | ztFloat | 8 | 4 | float
Technical OH cost | TeknikOmk | ZtCost | 16 | 6 | float
In-house or subcontract | TillvPriorEgenLego | ztInteger | 5 |  | smallint
TimeGapInDaysAfterPrevOp | TimeGapInDaysAfterPrevOp | ztInteger | 5 |  | smallint
TimeGapInDaysTonextOp | TimeGapInDaysToNextOp | ztInteger | 5 |  | smallint
Start cost/MO | ToStartKost | ZtCost | 16 | 6 | float
Trång sektor | TrangSektor | ztBoolean |  |  | char
Update all op | UpDatAvvik | ztBoolean |  |  | char
Incl scrapped mtrl | UpDatAvvikMru | ztBoolean |  |  | char
Development cost | UtvKost | ZtCost | 16 | 6 | float
Development OH cost | UtvOmk | ZtCost | 16 | 6 | float
Item group | VaruGruppKod | ztString | 8 |  | varchar
Shop price | VerkstadPris | ZtBaseCurrAmount | 14 | 2 | money
Tools | Verktyg | ztString | 16 |  | varchar
List of tools | VerktygsLista | ztString | 35 |  | varchar
Tool deprec | VyAvskrKost | ZtCost | 16 | 6 | float
Fixed tool cost | VyFastKost | ZtCost | 16 | 6 | float
Var tool cost | VyRorlKost | ZtCost | 16 | 6 | float
Tool setup cost | VySTallKost | ZtCost | 16 | 6 | float
Tool unit cost | VyStyckKost | ZtCost | 16 | 6 | float

    This table is the main table in the following programs:

    Program: orpa Ord specific ops for a cust ord row


Order-specific texts (xotx)

Table with order-specific standard texts for copying to the field "Enter text on the order" header.
Printing is then performed on various documents in the system, e.g. order confirmation, delivery slip, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Add any cust-spec. text | AddToKundSpecText | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Text on PO | KundSpecTextBe | ztBoolean |  |  | char
Text on invoice | KundSpecTextFa | ztBoolean |  |  | char
Text on delivery note | KundSpecTextFs | ztBoolean |  |  | char
Text on order acknowledgement | KundSpecTextOe | ztBoolean |  |  | char
Text on quotation | KundSpecTextOff | ztBoolean |  |  | char
Text on picking list | KundSpecTextPl | ztBoolean |  |  | char
Text on mfg/works order | KundSpecTextTo | ztBoolean |  |  | char
Order spec text | OrderTextKod | ztString | 4 |  | varchar
Order spec text | OrderTextKodBeskr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Text after document rows | TextEfterDokRader | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xotx Order-specific texts


Order-specific texts, lang. (xotxs)

Table with order-specific standard texts by language for copying to the field "Enter text on the order" header.
Printing is then performed on various documents in the system, e.g. order confirmation, delivery slip, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order spec text | OrderTextKod | ztString | 4 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint


Orders by dispatch time, header (olh)

Table of data in dispatch order header. This is same information as in the order header, but created for each dispatch time in the order rows.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Adresslappnummer | AdressLappNr | ztString | 15 |  | varchar
Address label type | AdressLappTyp | ztInteger | 2 |  | smallint
Label print date | AdresslappUtskrDat | ztDateTime |  |  | datetime
Active | Aktiv | ztInteger | 1 |  | smallint
No. of EUR pallets | AntalEURPall | ztInteger | 5 |  | smallint
No. of packages | AntalKolli | ztInteger | 5 |  | smallint
No. of other pallets | AntalOvrPall | ztInteger | 5 |  | smallint
No. of rows | AntalRader | ZtLong | 10 |  | int
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Volume m3 | ArtVolym | ztFloat | 15 | 4 | float
Request disp date | BestBegLevDat | ztDate |  |  | datetime
Promised disp date | BestLovLevDat | ztDate |  |  | datetime
Booked net weight | BookedNetWeight | ZtDecimal73 | 14 | 3 | decimal
Booked volume | BookedVolume | ZtDecimal73 | 14 | 3 | decimal
Booked gross weight | BookedWeight | ZtDecimal73 | 14 | 3 | decimal
Not booked on picking list | BookQtyNotOnPickListFlag | ztBoolean |  |  | char
Availability check date | BristKontrolleradDatum | ztDate |  |  | datetime
Avail check status code | BristKontrolleradStatus | ztInteger | 5 |  | smallint
Specified gross wght | BruttoVikt | ztFloat | 10 | 3 | float
Code fixed departure | CodeFixedDeparture | ztBoolean |  |  | char
Shipment plan alpha ID | ConnToShipmPlanAlphaId | ztString | 30 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Partial booking allowed | DelBokningTillaten | ztInteger | 5 |  | smallint
Part delivery allowed | DelLevTillaten | ztInteger | 5 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Packaging BCU | EmballageKostnad | ZtBaseCurrAmount | 14 | 2 | money
Packaging inland, BCU | EmballageKostnInland | ZtBaseCurrAmount | 14 | 2 | money
One-package delivery | EnKolliSendNummer | ztBoolean |  |  | char
Handling charge | ExpAvgKd | ztBoolean |  |  | char
Handling charge BCU | ExpeditionKostnad | ZtBaseCurrAmount | 14 | 2 | money
Express shipment | ExpressKod | ztBoolean |  |  | char
Invoiced by | FaktAvPersSign | ztString | 6 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice date/time | FaktDateTime | ztDateTime |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoiced by | FakturerareKod | ztInteger | 2 |  | smallint
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Insurance BCU | ForsakringsKostnad | ZtBaseCurrAmount | 14 | 2 | money
Insurance inland, BCU | ForsakrKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Freight documents | FrakthandlKod | ztBoolean |  |  | char
Auto calc freight BCU | FraktKostnBer | ZtBaseCurrAmount | 14 | 2 | money
Total freight BCU | FraktKostnDeb | ZtBaseCurrAmount | 14 | 2 | money
Freight inland, BCU | FraktKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Man calc freight BCU | FraktKostnMan | ZtBaseCurrAmount | 14 | 2 | money
Freight bill no. | FraktsedelNr | ztString | 30 |  | varchar
Freight bill no., auto | FraktsedelNrAuto | ztBoolean |  |  | char
Freight bill type | FraktSedelTyp | ztInteger | 2 |  | smallint
Freight bill print date | FraktsedelUtskrDat | ztDateTime |  |  | datetime
Dispatch no. | FraktSendNummer | ztString | 15 |  | varchar
Bulk taxation | FraktSkrymmeKod | ztBoolean |  |  | char
Gross frght weight kg | FraktVikt | ztFloat | 10 | 3 | float
Del note print date | FsUtskrDat | ztDateTime |  |  | datetime
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Goods label row 1 | GodsMarke1 | ztString | 40 |  | varchar
Goods label row 2 | GodsMarke2 | ztString | 40 |  | varchar
Goods label row 3 | GodsMarke3 | ztString | 40 |  | varchar
Goods label row 4 | GodsMarke4 | ztString | 40 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location WMS | InventoryLocWMS | ztBoolean |  |  | char
No invoicing | KodEjFakturera | ztBoolean |  |  | char
Credit block status | KreditSparrStatus | ztInteger | 2 |  | smallint
Plocklista (j/n) | Kund_PlKod | ztString | 1 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Freight payer | KundFraktBetalareNr | ztCompanyNo | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Lagerst för lev.order | LagStalleLevOrder | ztString | 2 |  | varchar
Gross weight, kg, deliv | LevArtBtotVikt | ztFloat | 10 | 3 | float
Net weight , deliv | LevArtVikt | ztFloat | 10 | 3 | float
Volume, m³, deliv | LevArtVolym | ztFloat | 15 | 2 | float
Dispatch notice | LevAviseringKod | ztBoolean |  |  | char
Before 12 deliv | LevForeTolv | ztBoolean |  |  | char
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Pick flag date | OkAttPlockaSattDatum | ztDate |  |  | datetime
Pick status | OkAttPlockaStatus | ztInteger | 5 |  | smallint
Preparation day | OrdBerednDat | ztDate |  |  | datetime
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Est disp time | OrdBerLevTid | ztTime | 6 |  | datetime
Booking status | OrdBokningsStatus | ztInteger | 5 |  | smallint
Order split type | OrderdelningsTyp | ztInteger | 2 |  | smallint
Orderavslut | OrderEnding | ztBoolean |  |  | char
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Delivery note no. | OrdFoljesedelsNr | ZtLong | 10 |  | int
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Destination, country | OrdLevAdrLandsKod | ztString | 3 |  | varchar
Delivery notice 1 | OrdLevAnvisnRad1 | ztString | 30 |  | varchar
Delivery notice 2 | OrdLevAnvisnRad2 | ztString | 30 |  | varchar
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Order status | OrdStat | ztInteger | 2 |  | smallint
Est.order value | OrdSumFraktBer | ZtBaseCurrAmount | 14 | 2 | money
Order type | OrdTyp | ztInteger | 3 |  | smallint
Other inv. cost-1 BCU | OvrFaktAvgift1 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-10 BCU | OvrFaktAvgift10 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-2 BCU | OvrFaktAvgift2 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-3 BCU | OvrFaktAvgift3 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-4 BCU | OvrFaktAvgift4 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-5 BCU | OvrFaktAvgift5 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-6 BCU | OvrFaktAvgift6 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-7 BCU | OvrFaktAvgift7 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-8 BCU | OvrFaktAvgift8 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-9 BCU | OvrFaktAvgift9 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-1 BCU | OvrFaktKostnad1 | ZtBaseCurrAmount | 14 | 2 | money
Other inv. cost-2 BCU | OvrFaktKostnad2 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-1 inland, BCU | OvrFaktKostnInland1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 inland, BCU | OvrFaktKostnInland2 | ZtBaseCurrAmount | 14 | 2 | money
Packer | PackareKod | ztInteger | 2 |  | smallint
Packing slip printed | PackSedelUtskrDat | ztDateTime |  |  | datetime
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Picking index for order | PlockIndexOrder | ZtLong | 10 |  | int
Picking list no. | plockjnrorder | ZtLong | 10 |  | int
Picking list date | PLUtskrDat | ztDateTime |  |  | datetime
Entry date | RegDat | ztDate |  |  | datetime
Gross weight, kg, remain value | RestArtBtotVikt | ztFloat | 10 | 3 | float
Net weight, kg, remain value | RestArtVikt | ztFloat | 10 | 3 | float
Volume, remain value | RestArtVolym | ztFloat | 15 | 2 | float
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Joint pick | SamPlockas | ztBoolean |  |  | char
Joint pick list No. | SamPlockListeNr | ZtLong | 6 |  | int
Joint picking, running no | SamPlockLopNr | ztInteger | 5 |  | int
Shipment plan alpha ID | ShipmPlanAlphaId | ztString | 30 |  | varchar
Language | SprakKod | ztInteger | 3 |  | smallint
COD/adv amt | TA_AmtCOD | ztMoney | 14 | 2 | money
Freight bill number | TA_ConsNo | ztString | 20 |  | varchar
CMR document message | TA_CustomerMessage | ztString | 40 |  | varchar
From TA | TA_edit | ztBlob | 1 |  | varchar
Fax notification number | TA_FaxNotifiedNo | ztString | 40 |  | varchar
GAN no | TA_GANno | ztString | 20 |  | varchar
Pallet meterage | TA_Loadmeter | ztFloat | 8 | 2 | float
Email address notification | TA_MailNotified | ztString | 60 |  | varchar
Phone notification number | TA_PhonNotifiedNo | ztString | 40 |  | varchar
AffectTemplCode | TA_TemplKompCd | ztString | 1 |  | varchar
Text after document rows | TextEfterDokRader | ztBoolean |  |  | char
General/fixed text | TextKod | ztString | 4 |  | varchar
Carrier code | TransportorsKod | ztString | 17 |  | varchar
Update from order (OH) | UpdatedFromOh | ztBoolean |  |  | char
Packaging, curr | vb_EmballageKostnad | ztMoney | 14 | 2 | money
Packaging inland, curr | vb_EmballageKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Handling charge curr | vb_ExpeditionKostnad | ztMoney | 14 | 2 | money
Insurance, curr | vb_ForsakringsKostnad | ztMoney | 14 | 2 | money
Insurance inland, curr | vb_ForsakrKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Auto calc freight, curr | vb_FraktKostnBer | ztMoney | 14 | 2 | money
Total freight, curr | vb_FraktKostnDeb | ztMoney | 14 | 2 | money
Freight inland, curr | vb_FraktKostnInland | ZtBaseCurrAmount | 14 | 2 | money
Man calc freight, curr | vb_FraktKostnMan | ztMoney | 14 | 2 | money
Other invc cost-1, curr | vb_OvrFaktAvgift1 | ztMoney | 14 | 2 | money
Other invc cost-10, curr | vb_OvrFaktAvgift10 | ztMoney | 14 | 2 | money
Other invc cost-2, curr | vb_OvrFaktAvgift2 | ztMoney | 14 | 2 | money
Other invc cost-3, curr | vb_OvrFaktAvgift3 | ztMoney | 14 | 2 | money
Other invc cost-4, curr | vb_OvrFaktAvgift4 | ztMoney | 14 | 2 | money
Other invc cost-5, curr | vb_OvrFaktAvgift5 | ztMoney | 14 | 2 | money
Other invc cost-6, curr | vb_OvrFaktAvgift6 | ztMoney | 14 | 2 | money
Other invc cost-7, curr | vb_OvrFaktAvgift7 | ztMoney | 14 | 2 | money
Other invc cost-8, curr | vb_OvrFaktAvgift8 | ztMoney | 14 | 2 | money
Other invc cost-9, curr | vb_OvrFaktAvgift9 | ztMoney | 14 | 2 | money
Other invc cost-1, curr | vb_OvrFaktKostnad1 | ztMoney | 14 | 2 | money
Other invc cost-2, curr | vb_OvrFaktKostnad2 | ztMoney | 14 | 2 | money
Extra cost-1 inland, curr | vb_OvrFaktKostnInland1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 inland, curr | vb_OvrFaktKostnInland2 | ZtBaseCurrAmount | 14 | 2 | money
Weight/volume automatic | ViktSumOrder | ztBoolean |  |  | char
Height | VolHeight | ztInteger | 4 |  | smallint
Length | VolLength | ztInteger | 4 |  | smallint
Volume | Volume | ztFloat | 10 | 3 | float
Width | VolWidth | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: FraktFkt Freight documents, invoiced disp order

    Program: FraktLev Freight documents, released

    Program: FraktOrd Freight documents, dispatch order

    Program: olh Dispatch order processing

    Program: OlhAvsl Close dispatch order

    Program: OlhFrakt Freight handling

    Program: olhFU Reprint invoice (dispatch orders)

    Program: OlhJkpl Create part pick list for dispatch order

    Program: olhp Packing, package contents

    Program: OlhPack Packing, dispatch order

    Program: OlhPackF Packing, invoiced dispatch order

    Program: OlhSam Joint picking list

    Program: OlhUCorl Dispatch order picking, booking etc

    Program: OlhUsam Joint picking, create list

    Program: OlhUtPl Dispatch order picking

    Program: XOlhUsam Joint picking, create list


Original codes for claim (ClaimSrcCd)

Definition of origin for customer claim, supplier claim, or internal claim, for example Customer, Goods control, Inventory.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Claim origination | ClaimSrcCd | ztInteger | 5 |  | smallint
Claim origination | ClaimSrcDescr | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ClaimSrcCd Origin codes for claims


Our contact per company (prk)

Definition of own contact persons for companies in the company table, i.e. own salesperson, project manager or other person responsible for contacts with each company (customer, prospective customer, supplier, etc.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: prk Our contact per company


Outbox eBrev (ebub)

Table where records to be sent via Posten's eBrev are added.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Unique ID logical page | eb_logsida_id | ztInteger | 5 |  | smallint
eBrev sent | eBFilSent | ztBoolean |  |  | char
eBrev file sent date | ebFilSentDt | ztDateTime |  |  | datetime
eBrev created | ebFilSkapad | ztBoolean |  |  | char
File created | ebFilSkapadDt | ztDateTime |  |  | datetime
Receipt | ebKvitterad | ztBoolean |  |  | char
Receipt, date | ebKvitteradDt | ztDateTime |  |  | datetime
Delivery ID | ebLeveransId | ztInteger | 5 |  | smallint
Invoice no. | faktnr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
ZIP/Post code | ftgpostnr | ztString | 10 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Reminder journal batch no. | jfhknr | ztInteger | 4 |  | smallint
Note | KortNotering | ztString | 255 |  | varchar
Payer, company ID | kundbetalarenr | ztCompanyNo | 20 |  | varchar
Country | landskod | ztString | 3 |  | varchar
Order no. | ordernr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLidentity | ZtLong | 10 |  | int
Currency | valkod | ztString | 3 |  | varchar
Report program | yndreport | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: xebub Outbox, eBrev

    Program: xebubs Sent rows, eBrev


Outgoing payment journal (ju)

Outgoing payment journal with data on outgoing payments that are planned or have been made. Each payment in a journal that is planned or has been made is stored in the LRU table.

The outgoing payment journal is created by reconciling and entering an number of unpaid invoices in a "planned outgoing payment" The planned outgoing payment receives an outgoing payment journal number.

Changes to the actual outgoing payment field can be made in the outgoing payment journal The status of the outgoing payment is then changed from planned to made.

Supplier debts are unbooked against a clearing account which is counter-booked when the outgoing payment is flagged as ready.

A voucher to the General Ledger is created.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Bankfil/utskr skapad | BankFilSkapadDt | ztDate |  |  | datetime
Bankfil/utskr skapad av | BankFilSkapadSign | ztDate |  |  | datetime
Bank | BankId | ztString | 10 |  | varchar
Account at bank | BankKonto | ztString | 40 |  | varchar
Bank charge | BankKost | ZtBaseCurrAmount | 9 | 2 | money
Transmit to bank date | BankSandDat | ztDate |  |  | datetime
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Reserved in journal | BilagsMark | ztBoolean |  |  | char
BOE ledger | Boe_Code | ztBoolean |  |  | char
Accounting date | BokfDat | ztDate |  |  | datetime
Cash/Bank ID | CashOrBankBookid | ztString | 15 |  | varchar
Currency bank account | CuCdBankAccount | ztString | 3 |  | varchar
Currency type bank acct Deb | CuCdBankAccountAmount | ztMoney | 14 | 2 | money
Exchange rate, bank account | CuCdBankAccountRate | ZtCurrencyRate | 15 | 7 | decimal
Currency pocket | Curr_P | ztString | 1 |  | varchar
Currency, decimal places | CurrencyDecimals | ztInteger | 5 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Reported end time | EventRpTime | ztTime | 5 |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Currency contract no. | KursAvtalsId | ztString | 20 |  | varchar
Actual pmt date | LevFaktBetDat | ztDate |  |  | datetime
Planned pmt date | LrFaktPlanBetDat | ztDate |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
PG manufacturing date | PostGiroProdDat | ztDate |  |  | datetime
PG manufacturing no. | PostGiroProdNr | ztInteger | 1 |  | smallint
Priority | Prioritet | ztInteger | 2 |  | smallint
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Sekvensnummer | SekvensNr | ZtLong | 6 |  | int
SekvNr | SekvNr | ztInteger | 4 |  | smallint
Forward rate | TerminsKurs | ZtCurrencyRate | 11 | 6 | decimal
Plan/paid amt, BCU | UtbBel | ZtBaseCurrAmount | 14 | 2 | money
Payment route | UtbetalningsVag | ztString | 6 |  | varchar
Pmt file created | UtbFileCreated | ztBoolean |  |  | char
Pmt file created by | UtbFileCreatedBy | ztString | 6 |  | varchar
Pmt file created date | UtbFileCreatedDt | ztDateTime |  |  | datetime
Period for prel pmt | UtbFilePeriod | ztInteger | 4 |  | smallint
Fiscal year | UtbFileRedovisnAr | ztInteger | 4 |  | smallint
AP payment file sent | UtbFileSend | ztBoolean |  |  | char
Expedited by | UtbFileSendBy | ztString | 6 |  | varchar
Sent date/time | UtbFileSendDt | ztDateTime |  |  | datetime
Voucher no. | UtbFileVerNr | Jeeves_VchrNo | 9 |  | bigint
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int
Payment journal status | UtbJournStatusKod | ztInteger | 1 |  | smallint
Journaltyp | UtbJournTyp | ztInteger | 2 |  | smallint
Pmt service journal no. | UtbServJournNr | ZtLong | 6 |  | int
This field is used in the table as follows: |
Payment methods | UtbSlag | ztString | 3 |  | varchar
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate | ValKursGrund | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate, operand | ValKursOp | ztInteger | 5 |  | smallint
Exchange rate unit | ValKursPer | ZtDecimal73 | 8 | 3 | decimal
Bank cost, currency | VbBankAmt | ztMoney | 14 | 2 | money
Plan/paid amt, curr | VbUtbBel | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: nxju Outg. pmt journal, final approv

    Program: nxjux Outg. pmt journal, final approv

    Program: Xju Outgoing payment journal

    Program: xJuFbs Invoice matching, invoice payment service

    Program: xJuFbsY Invoice pmt service journal

    Program: xJuUt Create BG file

    Program: xJuUtPg Create PG file


Outgoing payment methods (x2c)

Definition of payment methods that can apply when entering outgoing payments.

The following payment methods can be provided as proposals (determined by an option during installation) but can be changed and added to:
Avd = Deductions
BG = Bank Giro
Ch = Check
Cr = Counter claim
KNB = Customer number change
kon = Cash
KTL = Customer invoice to supplier invoice
Mak = Canceled
PG = Plus Giro
Ta = Payment stub
Ub = International payment
VAL = Currency revaluation

These definitions are then used when entering posting templates for outgoing payments.

You enter the outgoing payment method when entering payments in one of the outgoing payment programs (program Xju or Xjfbs), in the journal entry and in the BOE ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Bank | BankId | ztString | 10 |  | varchar
Account at bank | BankKonto | ztString | 40 |  | varchar
Bank acct check type | BankKontoTyp | ztString | 4 |  | varchar
Payment reason | BetUppdragsTyp | ztString | 4 |  | varchar
Cancel bill of exchange | BoE_Cancel | ztBoolean |  |  | char
BOE ledger | BoE_Code | ztBoolean |  |  | char
Check form, lines per stub | CheckForm_LinesPerStub | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
From check no. | FromCheckNo | ZtLong | 9 |  | int
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Journal group | JourGrupp | ZtLong | 9 |  | int
Account | ktonr | ztString | 8 |  | varchar
Check invoice reference | MarkChkSuppInvNo | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Payment method int'l | PgUtlBetalningsSatt | ztchar | 1 |  | char
Recip code int'l | PgUtlMottagarkod | ztchar | 1 |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Exch same day | Same_Day_Exec | ztBoolean |  |  | char
Language | Sprakkod | ztInteger | 3 |  | smallint
To check no. | ToCheckNo | ZtLong | 9 |  | int
Payment route | UtbetalningsVag | ztString | 6 |  | varchar
Payment methods | UtbSlag | ztString | 3 |  | varchar
Payment method | UtbSlagBeskr | ztString | 50 |  | varchar
Currency revaluation | ValutaOmrakning | ztBoolean |  |  | char
Voucher no. group | VerNrGrupp | ztString | 6 |  | varchar

    This table is the main table in the following programs:

    Program: vX2c Outgoing payment methods

    Program: Xx2c Outgoing payment methods


Outgoing payment status (x2a)

The table contains the different approval statuses that a supplier invoice can be given.

The following standard records exist. Do not alter/delete:

AP payment status (UtbKod) | Description (Beskrivning)
0 | Planned
1 | Approved
3 | Loaded BG/PG
4 | Paid

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
AP payment status | UtbKod | ztString | 1 |  | varchar

    This table is the main table in the following programs:

    Program: Xx2a Outgoing payment status


Outgoing payment types (x2b)

The table contains payment methods that are used for free classification of outgoing payments other than existing payment methods, payment routes, etc.

The following standard records exist. Do not alter/delete:

Adjustment type (UtbTyp) | AP payment method (UtbTypBeskr) | Description
0 | Förvald typ | As a default payment type 0 is suggested on the invoice on payment. Therefore the record must always exist in the table. Otherwise, you can enter payment types as you wish.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Adjustment type | UtbTyp | ztString | 1 |  | varchar
AP payment method | UtbTypBeskr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: Xx2b Outgoing payment types


Outgoing payment, receipt status (xlrk)

Definition of the status codes automatically set for the receipt journal upon loading of paid supplier invoices from bank file via the program "Import conversion" (sthi). The status code shows the result of loading for the journal.

The following standard records exist. Do not alter/delete:

Receipt status (KvittensStatus) | Receipt status (KvittensStatusBeskr)
0 | Created
10 | Payment journal created
99 | Incorrect total
100 | Closed, transferred
200 | Canceled

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Receipt status | KvittensStatus | ztInteger | 5 |  | smallint
Receipt status | KvittensStatusBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xlrk Status codes, outg. pmt receipt heads


Outgoing pmt details->GL (juvt)

Detailed information per transaction of how outgoing payments are posted when integrated with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Bank | BankId | ztString | 10 |  | varchar
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Bill of exchange no. | BoE_No | ZtLong | 9 |  | int
Check number | CheckNo | ZtLong | 9 |  | int
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
IntField in template | IntFieldTempl | ztInteger | 5 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Supplier category | levkategori | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Reference number | ReferensNr | ZtLong | 10 |  | int
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: vJuVt Show outgoing payment journal posting


Outgoing pmt journal status (x2d)

The table contains the different statuses that an outgoing payment journal can be given.

The following standard records exist. Do not alter/delete:

Payment journal status (UtbJournStatusKod) | AP pmt journ status (UtbJournStatusBeskr)
0 | Preliminary
1 | Registered, sent
5 | Closed, paid

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
AP pmt journ status | UtbJournStatusBeskr | ztString | 50 |  | varchar
Payment journal status | UtbJournStatusKod | ztInteger | 1 |  | smallint

    This table is the main table in the following programs:

    Program: Xx2d Outgoing pmt journal status


Outgoing pmt journal VIEW (vju)

View of the ju table (Outgoing pmt journal).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Bank charge | BankKost | ZtBaseCurrAmount | 9 | 2 | money
Accounting date | BokfDat | ztDate |  |  | datetime
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Actual pmt date | LevFaktBetDat | ztDate |  |  | datetime
Planned pmt date | LrFaktPlanBetDat | ztDate |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Priority | Prioritet | ztInteger | 2 |  | smallint
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Plan/paid amt, BCU | UtbBel | ZtBaseCurrAmount | 14 | 2 | money
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int
Payment journal status | UtbJournStatusKod | ztInteger | 1 |  | smallint
Pmt service journal no. | UtbServJournNr | ZtLong | 6 |  | int
Payment methods | UtbSlag | ztString | 3 |  | varchar
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Plan/paid amt, curr | VbUtbBel | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint


Overhead allocation types (xbpv)

Table for defining how costs are to be allocated from an invoice to received purchase order rows The codes in this table may not be changed, but the designations can be changed.

The following standard records exist. Do not alter/delete:

Allocation purch OH (InkOmkFord) | Allocation purch OH (InkOmkFordBeskr)
0 | 0 - Manual
1 | 1 - Weight
2 | 2 - Volume
3 | 3 - Value

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Allocation purch OH | InkOmkFord | ztInteger | 5 |  | smallint
Allocation purch OH | InkOmkFordBeskr | ztString | 50 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xbpv Overhead allocation types


Overhead cost types (xohc)

Definition of different types of costs, for example (fixed) overhead costs that are used in the detailed calculation, (custom-defined) customs duties that are used in customs documents, etc.

Please note that own-defined cost types should be entered with number 100 and upwards in order to leave room for additional fixed cost types.

The following standard records exist. Do not alter/delete:

OH cost type (OhKostTyp) | OH cost description (OhKostBeskr)
1 | Administration overhead cost
2 | Manufacturing overhead cost
3 | Sales overhead cost.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
OH cost description | OhKostBeskr | ztString | 80 |  | varchar
OH cost type | OhKostTyp | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xohc Other cost types


Own calculated columns (terms) (UsrDefCompCols)

The customer’s customized “computed columns”.
These are columns that are created on other columns in the same table in the database.
For example, there are fields on the item balance record for inventory balance and order point.
You can create your own column which is inventory balance – order point and then obtain a calculated value (computed column) which you can display or use when searching.
Your own column can consist of merged texts (e.g. ZIP/Post code and postal address) or date calculations (e.g. number of calendar days before the order will be delivered).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Calculated column Sql AS | JvsSiteComputedColumnAS | ztString | 255 |  | varchar
Decimals | JvsSiteTermDecimals | ztInteger | 5 |  | smallint
Column header | JvsSiteTermHeader | ztString | 60 |  | varchar
Length | JvsSiteTermLength | ztInteger | 4 |  | smallint
Data type | JvsSiteTermLogDataType | ztString | 30 |  | varchar
Term | JvsSiteTermName | ztString | 40 |  | varchar
Prompt | JvsSiteTermPrompt | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Development project | UsrDefDevProj | ztString | 10 |  | varchar

    This table is the main table in the following programs:

    Program: UsrDefCompCols Own calculated columns (terms)


Own class of accounts (ekok)

Account classification that can be defined by the customer alone.
Can be used when searching for accounts or defining reports.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Customer's own account class | EgenKontoKlass | ztString | 8 |  | varchar
Customer's own account class | EgenKontoKlassBeskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ekok Customer's own account types


Own class of accounts 2 (eko2)

Account classification that can be defined by the customer alone.
Can be used when searching for accounts or defining reports.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Customer's own account class 2 | EgenKontoKlass2 | ztString | 8 |  | varchar
Customer's own account class 2 | EgenKontoKlass2Beskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: eko2 Customer's own account types 2


Own input/output (x255)

Interim table for uploading data to or downloading data from the database. There is no logic in Jeeves standard for this table; it is intended for own development.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: x255 Own input/output


Own input/output (x256)

Interim table for uploading data to or downloading data from the database. There is no logic in Jeeves standard for this table; it is intended for own development.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: x256 Own input/output


Own input/output (x257)

Interim table for uploading data to or downloading data from the database. There is no logic in Jeeves standard for this table; it is intended for own development.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: x257 Own input/output


Own input/output (x258)

Interim table for uploading data to or downloading data from the database. There is no logic in Jeeves standard for this table; it is intended for own development.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: x258 Own input/output


Own links/relationships between tables (UsrDefConstraints)

Definition of relationships between tables/windows in customized programs. Relationships must be defined in your own programs with underlying program nodes.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Constraint | JvsConstraintName | ztString | 80 |  | varchar
Constraint on table | JvsConstraintOnTable | ztString | 40 |  | varchar
Right-click to program | JvsConstraintRefProgram | ztString | 40 |  | varchar
Relation to table | JvsConstraintRefTable | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Development project | UsrDefDevProj | ztString | 10 |  | varchar
Drop-down value column | UsrDefDropDownValueColumn | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: UsrDefConstraints Own links/relationships between tables


Own links/relationships between tables, columns (UsrDefConstraintColumns)

Definition of key columns in related tables/windows in customized programs.

Foreign key column and references key column must be defined for each table/window. They can be different columns.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Foreign key column | JvsConstraintFKeyColumn | ztString | 40 |  | varchar
Constraint | JvsConstraintName | ztString | 80 |  | varchar
References key column | JvsConstraintRefColumn | ztString | 40 |  | varchar
Sequence no. | JvsSeqNo | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Development project | UsrDefDevProj | ztString | 10 |  | varchar


Own nodes in own programs (UsrDefProgramNodes)

Definition of own nodes in own programs which you have added and are not included in Jeeves standard.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Embedded list window | JvsMarkEmbeddedListWindow | ztBoolean |  |  | char
Program name in Jeeves | JvsProgramName | ztString | 40 |  | varchar
Node descr in Jeeves | JvsProgramNodeDescription | ztString | 80 |  | varchar
Link program | JvsProgramNodeInclPgm | ztString | 40 |  | varchar
Connection->linked pgm | JvsProgramNodeInclPgmConn | ztString | 100 |  | varchar
Internal pgm node ID | JvsProgramNodeIntrnId | ztInteger | 5 |  | smallint
Program node in Jeeves | JvsProgramNodeName | ztString | 25 |  | varchar
Program node (owner) | JvsProgramNodeUpperName | ztString | 25 |  | varchar
Window name in Jeeves | JvsWindowName | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Development project | UsrDefDevProj | ztString | 10 |  | varchar
Program node type | UsrDefProgramNodeType | ztInteger | 5 |  | smallint


Own program nodes, connections (UsrDefProgramNodeConnections)

Definition of own nodes in own programs which you have added and are not included in Jeeves standard.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Link from column | JvsConnectionFromColumn | ztString | 40 |  | varchar
Link from table | JvsConnectionFromTable | ztString | 40 |  | varchar
Link to column | JvsConnectionToColumn | ztString | 40 |  | varchar
Link to table | JvsConnectionToTable | ztString | 40 |  | varchar
Program name in Jeeves | JvsProgramName | ztString | 40 |  | varchar
Program node in Jeeves | JvsProgramNodeName | ztString | 25 |  | varchar
Sequence no. | JvsSeqNo | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Development project | UsrDefDevProj | ztString | 10 |  | varchar


Own programs (UsrDefPrograms)

Definition of own programs which you have added and which are not included in Jeeves standard.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Program descr in Jeeves | JvsProgramDescription | ztString | 100 |  | varchar
Program name in Jeeves | JvsProgramName | ztString | 40 |  | varchar
Internal pgm node ID | JvsProgramNodeIntrnId | ztInteger | 5 |  | smallint
Window name in Jeeves | JvsWindowName | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Development project | UsrDefDevProj | ztString | 10 |  | varchar

    This table is the main table in the following programs:

    Program: UsrDefProgram Own programs

    Program: UsrDefProgramNode Own program nodes


Own programs as nodes (UsrDefAddedNodes)

Definition of programs added as nodes in an existing program.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Embedded list window | JvsMarkEmbeddedListWindow | ztBoolean |  |  | char
Program name in Jeeves | JvsProgramName | ztString | 40 |  | varchar
Node descr in Jeeves | JvsProgramNodeDescription | ztString | 80 |  | varchar
Link program | JvsProgramNodeInclPgm | ztString | 40 |  | varchar
Connection->linked pgm | JvsProgramNodeInclPgmConn | ztString | 100 |  | varchar
Internal pgm node ID | JvsProgramNodeIntrnId | ztInteger | 5 |  | smallint
Program node (owner) | JvsProgramNodeUpperName | ztString | 25 |  | varchar
Underlying node | JvsProgramSubNodeCode | ztString | 1 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Development project | UsrDefDevProj | ztString | 10 |  | varchar

    This table is the main table in the following programs:

    Program: UsrDefAddedNodes Link programs as nodes


Own role menus (Usrdefmenus)

User defined menus.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Icon | Icon | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Unique ID | JvsSiteUniqueId | ztString | 40 |  | varchar
Menu key | MenuKey | ZtLong | 8 |  | int
Parent | MenuParent | ZtLong | 8 |  | int
Sort order | MenuSort | ztString | 60 |  | varchar
Menu text | menutext | ztString | 60 |  | varchar
Menu unique id | MenuUnitid | ztString | 30 |  | varchar
Own description | OwnDescr | ztBoolean |  |  | char
Own icon | OwnIcon | ztBoolean |  |  | char
Own pgm | OwnPgm | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Program | pgm | ztString | 40 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
OK to remove | RemoveAllowed | ztBoolean |  |  | char
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Menu ID | UsrDefMenuid | ztString | 20 |  | varchar
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: rUsrDefMenus Menu report

    Program: rUsrDefMenusRole Menu report role

    Program: UsrDefMenus Own role menus


Own tables (UsrDefTables)

Definition of own tables that you have created in the database which Jeeves will access.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Alias on base table | JvsTableAliasOnTable | ztString | 40 |  | varchar
Table description | JvsTableDescription | ztString | 80 |  | varchar
Table name | JvsTableName | ztString | 128 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Development project | UsrDefDevProj | ztString | 10 |  | varchar

    This table is the main table in the following programs:

    Program: UsrDefTable Own tables


Own texts in macros (UsrDefLangText)

Sequence number.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Development project | UsrDefDevProj | ztString | 10 |  | varchar
Text/info | x255 | ztString | 255 |  | varchar


Own windows (UsrDefWindows)

Definition of tables which own windows will use. These can be Jeeves tables, but normally this refers your own tables which do not exist in Jeeves standard.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Form window procedure | JvsFormWindowProcedure | ztString | 120 |  | varchar
List window procedure | JvsListWindowProcedure | ztString | 120 |  | varchar
Table name | JvsTableName | ztString | 128 |  | varchar
Window descr in Jeeves | JvsWindowDescription | ztString | 80 |  | varchar
Window name in Jeeves | JvsWindowName | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Development project | UsrDefDevProj | ztString | 10 |  | varchar
Delete allowed | UsrDefWindowDeleteAllowed | ztBoolean |  |  | char
Def, show all form-filelds | UsrDefWindowFormShowAll | ztBoolean |  |  | char
Insert allowed | UsrDefWindowInsertAllowed | ztBoolean |  |  | char
Def, show all list-filelds | UsrDefWindowListShowAll | ztBoolean |  |  | char
Update allowed | UsrDefWindowUpdateAllowed | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: UsrDefWindow Own windows


P D M (view) (vpdm)

View of the PDM table.
This is used for example when a PDM document (PDM row) refers to another PDM document.

This could be an inspection instruction used by several items. First an independent PDM row must be created (not linked to an item) and then a PDM row that refers to this general PDM row must be entered under the items.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Consists of, no. of items | AntBestarAvSr | ZtLong | 5 |  | int
ComponentQty | AntIngarisr | ZtLong | 5 |  | int
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Item description | artbeskr | ztString | 30 |  | varchar
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
Ny beräkning av nivåkod | ArtNiva_Dirty | ztBoolean |  |  | char
Item no. | ArtNr | ztString | 30 |  | varchar
Release | artrelease | ztString | 6 |  | nvarchar
Release Date | Artreleasedat | ztDate |  |  | datetime
Release index | Artrelindex | ztInteger | 4 |  | smallint
Release sign | Artrelsign | ztString | 6 |  | varchar
Release valid from | ArtRelValidFrDt | ztDate |  |  | datetime
Release valid to | ArtRelValidToDt | ztDate |  |  | datetime
Revision date | ArtRevDat | ztDate |  |  | datetime
Revision no. | ArtRevID | ztString | 10 |  | varchar
Revision | Artrevindex | ztInteger | 4 |  | smallint
Revision signature | ArtRevSign | ztString | 6 |  | varchar
Revision valid from | ArtRevValidFrDt | ztDate |  |  | datetime
Revision Valid to | ArtRevValidToDt | ztDate |  |  | datetime
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
PO no. | bestnr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | bestrkgnr | ztString | 25 |  | varchar
Connected to PDM ... | ConnPdmDummyUniqueID | ztUniqueIdentifier | 100 |  | varchar
Document description | docdescr | ztString | 50 |  | varchar
Document ID | docid | ztString | 50 |  | varchar
Documentation | Documentation | ztBlob | 1 |  | varchar
File extension | DocumentExt | ztString | 30 |  | varchar
Document type no. | DocumentType | ZtLong | 5 |  | int
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
File/dir | DokDir | ztString | 255 |  | varchar
Author | dokforfattare | ztString | 30 |  | varchar
Doc header/directory | DokMapp | ztBoolean |  |  | char
Document structure template | DokStruktMall | ztBoolean |  |  | char
Row no. | ecorow | ztInteger | 5 |  | smallint
Change order ID | ecouniqueid | ztString | 40 |  | varchar
File name | filename | ztString | 255 |  | varchar
File status | filstatus | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | ftgkontaktnr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Campaign | kampnr | ZtLong | 4 |  | int
Complete doc structure | Komplettdokstr | ztBoolean |  |  | char
Note | KortNotering | ztString | 255 |  | varchar
Locked by change order | lockedbyeco | ztString | 40 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Quote/agreement no. | offnr | ztString | 10 |  | varchar
PDM (previous ID) | oldPDMDummyuniqueId | ztUniqueIdentifier | 100 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
PDM (origin) | originpdmdummyuniqueid | ztUniqueIdentifier | 100 |  | varchar
Normally on purchase order | Pdm2PO | ztBoolean |  |  | char
Normally on work order | Pdm2WO | ztBoolean |  |  | char
PDM quantity 1 | PdmAntal1 | ZtLong | 10 |  | int
PDM quantity 1 | PdmAntal2 | ZtLong | 10 |  | int
PDM (Unique ID) | PdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
Document file path | pdmfilename | ztString | 250 |  | varchar
PDM ref 1 | PdmRef1 | ztString | 40 |  | varchar
PDM ref 2 | PdmRef2 | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Pos in figure | posalfa | ztString | 12 |  | varchar
Project ID | projcode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Serv.order no | servordernr | Jeeves_SONo | 9 |  | bigint
Order row, service | servordradnr | ztInteger | 5 |  | int
Checked out | utcheckad | ztBoolean |  |  | char
Checkout date | utcheckdat | ztDateTime |  |  | datetime
Checked out File | utcheckpath | ztString | 255 |  | varchar
Checked out sign | utchecksign | ztString | 6 |  | varchar
Valid version | validpdm | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: vPdm Product Document (PDM)

    Program: vyPdmn View PDMN


P D M (view) (vpdm2)

View of the PDM table.
This is used for example when a PDM document (PDM row) refers to another PDM document.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Consists of, no. of items | AntBestarAvSr |  |  |  | @DataType=NULL
ComponentQty | AntIngarisr |  |  |  | @DataType=NULL
Mfg/Works order no. | AoNr |  |  |  | @DataType=NULL
Item description | artbeskr |  |  |  | @DataType=NULL
Lowest level f item | ArtNiva |  |  |  | @DataType=NULL
Ny beräkning av nivåkod | ArtNiva_Dirty |  |  |  | @DataType=NULL
Item no. | ArtNr |  |  |  | @DataType=NULL
Release | artrelease |  |  |  | @DataType=NULL
Release Date | Artreleasedat |  |  |  | @DataType=NULL
Release index | Artrelindex |  |  |  | @DataType=NULL
Release sign | Artrelsign |  |  |  | @DataType=NULL
Release valid from | ArtRelValidFrDt |  |  |  | @DataType=NULL
Release valid to | ArtRelValidToDt |  |  |  | @DataType=NULL
Revision date | ArtRevDat |  |  |  | @DataType=NULL
Revision no. | ArtRevID |  |  |  | @DataType=NULL
Revision | Artrevindex |  |  |  | @DataType=NULL
Revision signature | ArtRevSign |  |  |  | @DataType=NULL
Revision valid from | ArtRevValidFrDt |  |  |  | @DataType=NULL
Revision Valid to | ArtRevValidToDt |  |  |  | @DataType=NULL
Item serial no. | ArtSerieNr |  |  |  | @DataType=NULL
PO no. | bestnr |  |  |  | @DataType=NULL
Supplier invoice no. | bestrkgnr |  |  |  | @DataType=NULL
Connected to PDM ... | ConnPdmDummyUniqueID |  |  |  | @DataType=NULL
Document description | docdescr |  |  |  | @DataType=NULL
Document ID | docid |  |  |  | @DataType=NULL
Documentation | Documentation |  |  |  | @DataType=NULL
File extension | DocumentExt |  |  |  | @DataType=NULL
Document type no. | DocumentType |  |  |  | @DataType=NULL
@zPrompt=null | DoIndirectUpdate |  |  |  | @DataType=NULL
File/dir | DokDir |  |  |  | @DataType=NULL
Author | dokforfattare |  |  |  | @DataType=NULL
Doc header/directory | DokMapp |  |  |  | @DataType=NULL
Document structure template | DokStruktMall |  |  |  | @DataType=NULL
Row no. | ecorow |  |  |  | @DataType=NULL
Change order ID | ecouniqueid |  |  |  | @DataType=NULL
File name | filename |  |  |  | @DataType=NULL
File status | filstatus |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Contact no. | ftgkontaktnr |  |  |  | @DataType=NULL
Company ID | FtgNr |  |  |  | @DataType=NULL
Campaign | kampnr |  |  |  | @DataType=NULL
Complete doc structure | Komplettdokstr |  |  |  | @DataType=NULL
Note | KortNotering |  |  |  | @DataType=NULL
Locked by change order | lockedbyeco |  |  |  | @DataType=NULL
Sequence no. | LopNr |  |  |  | @DataType=NULL
Quote/agreement no. | offnr |  |  |  | @DataType=NULL
PDM (previous ID) | oldPDMDummyuniqueId |  |  |  | @DataType=NULL
Operation no. | OpNr |  |  |  | @DataType=NULL
Order no. | OrderNr |  |  |  | @DataType=NULL
PDM (origin) | originpdmdummyuniqueid |  |  |  | @DataType=NULL
Normally on purchase order | Pdm2PO |  |  |  | @DataType=NULL
Normally on work order | Pdm2WO |  |  |  | @DataType=NULL
PDM quantity 1 | PdmAntal1 |  |  |  | @DataType=NULL
PDM quantity 1 | PdmAntal2 |  |  |  | @DataType=NULL
PDM (Unique ID) | PdmDummyUniqueId |  |  |  | @DataType=NULL
Document file path | pdmfilename |  |  |  | @DataType=NULL
PDM ref 1 | PdmRef1 |  |  |  | @DataType=NULL
PDM ref 2 | PdmRef2 |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Pos in figure | posalfa |  |  |  | @DataType=NULL
Project ID | projcode |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL
Serv.order no | servordernr |  |  |  | @DataType=NULL
Order row, service | servordradnr |  |  |  | @DataType=NULL
Checked out | utcheckad |  |  |  | @DataType=NULL
Checkout date | utcheckdat |  |  |  | @DataType=NULL
Checked out File | utcheckpath |  |  |  | @DataType=NULL
Checked out sign | utchecksign |  |  |  | @DataType=NULL
Valid version | validpdm |  |  |  | @DataType=NULL


Package dispatch order from FFH (TA_PackDispFFH)

Package dispatch order from FFH.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Specified gross wght | Bruttovikt | ztFloat | 10 | 3 | float
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Goods label row 1 | GodsMarke1 | ztString | 40 |  | varchar
Goods type ID | GoodsTypeid | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Pallet meterage | TA_Loadmeter | ztFloat | 8 | 2 | float
Package type | TA_PackType | ztString | 4 |  | varchar
Volume | TA_Volume | ztFloat | 15 | 2 | float


Package dispatch order from OH (TA_PackDispOH)

Package dispatch order from OH.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Specified gross wght | Bruttovikt | ztFloat | 10 | 3 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Goods label row 1 | GodsMarke1 | ztString | 40 |  | varchar
Goods type ID | GoodsTypeid | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Pallet meterage | TA_Loadmeter | ztFloat | 8 | 2 | float
Package type | TA_PackType | ztString | 4 |  | varchar
Volume | TA_Volume | ztFloat | 15 | 2 | float


Package dispatch order from OLH (TA_PackDispOLH)

Package dispatch order from OLH.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Specified gross wght | Bruttovikt | ztFloat | 10 | 3 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Goods label row 1 | GodsMarke1 | ztString | 40 |  | varchar
Goods type ID | GoodsTypeid | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Pallet meterage | TA_Loadmeter | ztFloat | 8 | 2 | float
Package type | TA_PackType | ztString | 4 |  | varchar
Volume | TA_Volume | ztFloat | 15 | 2 | float


Package groups (old) (JvsSitePackage)

Definition of members of packages to which settings can be linked. In this table, information is stored about which users and/or user groups are included in packages. Information about packagages is stored in the overlying table User groups (jvssitegroups).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allow settings | JvsSiteAllowChange | ztBoolean |  |  | char
Group ID | JvsSiteGroupId | ZtLong | 6 |  | int
Group ID (orig) | JvsSiteGroupId_orig | ZtLong | 6 |  | int
Group No (packaging) | JvsSiteGroupIdPackage | ZtLong | 6 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Package solution import result (JvsPackageImportRes)

Log information for a packae solution import, including time stamps for import start and end, SQL erorrs and SQL warnings.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Error code | ErrCode | ZtLong | 10 |  | int
@zPrompt=null | error_msg | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence | Sequence | ztInteger | 3 |  | smallint
Solution ID | SolutionID | ZtLong | 10 |  | int
Version Major | SolutionVerMajor | ztInteger | 5 |  | smallint
Version Minor | SolutionVerMinor | ztInteger | 5 |  | smallint
Error text, update | UpdateError | ztBlob | 1 |  | varchar


Package solution script execution types (JvsPackageScriptExec)

Codes defining when a package solution script should be executed at package import.

The following standard records exist. Do not alter/delete:

Execution Point (ExecPoint) | Description (Description)
0 | PrePackageInstall
1 | PostPackageInstall

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Description | ztString | 255 |  | varchar
Execution Point | ExecPoint | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsPackageScriptExec Package solution script execution


Package solution table columns (JvsPackageColumns)

Single table columns to be included in a package solution. If one or many column rows exists, only these columns will be exported, else the complete table will be exported.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allow update | AllowUpdate | ztBoolean |  |  | char
Exclude Column | ExcludeColumn | ztBoolean |  |  | char
Name of column | JvsColumnName | ztString | 128 |  | varchar
Table name | JvsTableName | ztString | 128 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Solution ID | SolutionID | ZtLong | 10 |  | int


Package solution table import types (JvsPackageImportTypes)

Definition of how table rows should be handled for a given table in a package solution.

The following standard records exist. Do not alter/delete:

Import type (ImportType) | Import type (ImportDesc)
0 | New rows only
1 | New and Updated rows
2 | Replace existing rows
3 | Data model only
4 | Exclude table
5 | Replace with condition
6 | Replace with condition

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Import type | ImportDesc | ztString | 40 |  | varchar
Import type | ImportType | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsPackageImportTypes Package solution import types


Package solutions (JvsPackageSolutions)

Package solution header, including an unique ID (GUID) enabling identification of a package solution in any Jeeves installation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Solution GUID | SolutionGUID | ztString | 40 |  | varchar
Solution ID | SolutionID | ZtLong | 10 |  | int
Information | SolutionInfo | ztBlob | 1 |  | varchar
Solution Name | SolutionName | ztString | 32 |  | varchar
Description | SolutionsDescription | ztString | 255 |  | varchar
Version Major | SolutionVerMajor | ztInteger | 5 |  | smallint
Version Minor | SolutionVerMinor | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: JvsPackageSolutions Package solution definitions


Package types (koli)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Package type | KolliTyp | ztString | 4 |  | varchar
Package type | KolliTypBeskr | ztString | 40 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: Koli Package types


Packages (JvsSitePackageId)

Table/program for viewing and managing package IDs. These are displayed in a drop-down list in the programs for creating and connecting groups of users and settings.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Unique package ID | JvsSitePackageUniqueId | ztString | 40 |  | nvarchar
Package name | JvsSitePackageUniqueId_Lang | ztString | 40 |  | nvarchar
Version | JvsSitePackageVersion | ztString | 40 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSitePackageId Package IDs


Packaging types (xemb)

Definition of the company's packaging types.
All types of packaging that can be used when packing items for dispatch to customers are stored here.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
This field is used in the table as follows: |
Packaging code EDI | EdiEmbKod | ztString | 17 |  | varchar
DepostCode EDI | EdiPantKod | ztString | 13 |  | varchar
Packaging type | Emballagetyp | ztString | 4 |  | varchar
Packaging type | EmballageTypBeskr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Package instr | PackInstrKod | ztString | 35 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xemb Packaging types


Packaging types, language (xems)

Definition of the company's packaging types in foreign languages.
Used when printing packing slips to show the packaging description according to the customers' current language codes.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Packaging type | Emballagetyp | ztString | 4 |  | varchar
Packaging type | EmballageTypBeskr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint

    This table is the main table in the following programs:

    Program: Xems Packaging types, language


Packer (x1pk)

Definition of packer within the company. The information is used to allocate orders to packers, for example for joint picking and to specify who has packed an order after picking reporting and release of orders for invoicing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Packer | PackareBeskr | ztString | 30 |  | varchar
Packer | PackareKod | ztInteger | 2 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: Xx1pk Packer


Packing instr details (afpl)

This table is used to enter packing instruction details.
A packing instruction describes how an item should be packaged. I.e. what packaging is included and how many items can be packed in the different packaging.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Qty per package | AntalEmb | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Rounding | AvrundnEmb | ztInteger | 5 |  | smallint
Packaging type | EmballageTyp | ztString | 4 |  | varchar
Pkg label | EmbEtikett | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Package instr | PackInstrKod | ztString | 35 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Packing instr header (afph)

This table is used to enter packing instruction headers.
A packing instruction describes how an item should be packaged. I.e. what packaging is included and how many items can be packed in the different packaging.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Description | Beskrivning | ztString | 50 |  | varchar
For package items | Embkod | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Pkging descr | ForpackningsEditText | ztBlob | 1 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Package instr | PackInstrKod | ztString | 35 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Packed together | SamPackas | ztBoolean |  |  | char
Standard | StandardInstr | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: afph Package instruction


Pallet (WMS_V_Pallet)

Pkg identity.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod |  |  |  | @DataType=NULL
Inventory location | LagStalle |  |  |  | @DataType=NULL
X Pos. | LocXPos |  |  |  | @DataType=NULL
Y Pos. | LocYPos |  |  |  | @DataType=NULL
MHA | Mha |  |  |  | @DataType=NULL
ID | PalletId |  |  |  | @DataType=NULL
Type | PalletTypeCode |  |  |  | @DataType=NULL
Parent ID | ParentPalletId |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Rack | Rack |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL


Pallet (WMS_Pallet)

Pkg identity.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
X Pos. | LocXPos | ztString | 5 |  | varchar
Y Pos. | LocYPos | ztString | 5 |  | varchar
MHA | Mha | ztString | 5 |  | varchar
Availability | PalletAvailCode | ztInteger | 3 |  | smallint
Created | PalletCreateDateTime | ztDateTime |  |  | datetime
ID | PalletId | ztString | 35 |  | varchar
Reason code | PalletSKUCreateReasonCode | ztInteger | 3 |  | smallint
Status, SKU | PalletSKUStatusCode | ztInteger | 3 |  | smallint
Status | PalletStatusCode | ztInteger | 3 |  | smallint
Create reason code, TU | PalletTUCreateReasonCode | ztInteger | 3 |  | smallint
Status, TU | PalletTUStatusCode | ztInteger | 3 |  | smallint
Type | PalletTypeCode | ztInteger | 3 |  | smallint
Pallet unit type | PalletUnitType | ztString | 5 |  | varchar
Parent ID | ParentPalletId | ztString | 35 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Rack | Rack | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Shipment plan alpha ID | ShipmPlanAlphaId | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_MU_LoadPallet Load

    Program: WMS_Pallet Pallet

    Program: WMS_TU TU


Pallet availability code (WMS_PalletAvailCode)

Numeric code which specifies the availability of the package.

The following standard records exist. Do not alter/delete:

Availability (PalletAvailCode) | Description (PalletAvailDesc) | Description
1 | Available | Pallet available
10 | Blocked | Pallet blocked

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Availability | PalletAvailCode | ztInteger | 3 |  | smallint
Description | PalletAvailDesc | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_PalletAvailCode Pallet availability code


Pallet content (WMS_PalletContent)

Sequence number for package contents.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Use/Best before | bastforedatum | ztDate |  |  | datetime
Batch no. | BatchId | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
FIFO date | FifoDateTime | ztDateTime |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Sequence number | PalletContSeq | ztInteger | 3 |  | smallint
Status, TU content | PalletContTUStatusCode | ztInteger | 3 |  | smallint
ID | PalletId | ztString | 35 |  | varchar
Type | PalletTypeCode | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Pick before date | PickBeforeDateTime | ztDate |  |  | datetime
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Shipment plan row no | ShipmPlanRowNo | ZtLong | 9 |  | int
Cycle count date | SKUCycleCountDateTime | ztDateTime |  |  | datetime
Delivered qty, SKU | SKUDelQty | ZtQty | 14 | 2 | decimal
Qty, SKU | SKUQty | ZtQty | 14 | 2 | decimal
Date/time | StrDateTime | ztString | 28 |  | varchar
Qty, TU | TUQty | ZtQty | 14 | 2 | decimal
Unit code | UOM | ztString | 10 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_MU_LoadPalletContent Pallet content

    Program: WMS_PalletContent Pallet content

    Program: WMS_TUContent TU content

    Program: WMS_TUContentRec Picked TU content receive into inventory


Pallet discounts (rorp)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | Artnr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price list as of | PrisFomDat | ztDate |  |  | datetime
Price valid until date | PrislGiltigDat | ztDate |  |  | datetime
Discount % | rabatt | ZtDecimal73 | 6 | 2 | decimal
Discount curr | RabattVal | ztMoney | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Currency | valkod | ztString | 3 |  | varchar

    This table is the main table in the following programs:

    Program: Prorp Pallet discounts


Pallet status code (WMS_PalletStatusCode)

Code for package status. Specifies status for package.

The following standard records exist. Do not alter/delete:

Status (PalletStatusCode) | Description (PalletStatusDesc) | Description
1 | Stored | Pallet is stored
2 | Mobile | Pallet is on a mobile unit
50 | Delete | Pallet is marked for deletion

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Status | PalletStatusCode | ztInteger | 3 |  | smallint
Description | PalletStatusDesc | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_PalletStatusCode Pallet status code


Pallet type code (WMS_PalletTypeCode)

Code for package type. Specifies type of package.

The following standard records exist. Do not alter/delete:

Type (PalletTypeCode) | Description (PalletTypeDesc) | Description
1 | SKU | Pallet is a stock keeping unit
2 | TU | Pallet is a transport unit

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Type | PalletTypeCode | ztInteger | 3 |  | smallint
Description | PalletTypeDesc | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_PalletTypeCode Pallet type code


Pallet unit type (WMS_PalletUnitType)

Definition of applicable pallet unit types. Pallet unit types are not inventory location specific.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Number of labels | NumberOfLabels | ztInteger | 5 |  | smallint
Description | PalletUnitDesc | ztString | 50 |  | varchar
Pallet unit type | PalletUnitType | ztString | 5 |  | varchar
Handling | PalletUnitUsageCode | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_PalletUnitType Pallet unit type


Pallet unit type, location types (WMS_PalletUnitLoc)

Definition of which location types a pallet unit type fits, per inventory location and MHA. When the system tries to find a suitable location for a SKU it looks at which location types the SKU fits into according to this definition.

If a pallet unit type fits into more than one location type in a MHA it can be useful to define where it fits best. A lower value in the Sequence number field indicates a better fit than a higher value.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Location type | LocType | ztString | 5 |  | varchar
MHA | Mha | ztString | 5 |  | varchar
Sequence number | PalletUnitLocSeq | ztInteger | 2 |  | smallint
Pallet unit type | PalletUnitType | ztString | 5 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_PalletUnitLoc Pallet unit type, location types


Pallet unit usage code (WMS_PalletUnitUsageCode)

Definition of applicable pallet unit usage codes. Defines for which type of pallet each pallet unit type can be used; for SKUs, for TUs or both.

The following standard records exist. Do not alter/delete:

Handling (PalletUnitUsageCode) | Description (PalletUnitUsageDesc) | Description
1 | SKU | This pallet unit type can only be used for SKUs
2 | TU | This pallet unit type can only be used for TUs
3 | Pallet | This pallet unit type can be used for both SKUs and TUs

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Handling | PalletUnitUsageCode | ztInteger | 3 |  | smallint
Description | PalletUnitUsageDesc | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_PalletUnitUsageCode Pallet unit usage code


Part delivery codes (xdl)

Table of partial delivery codes that are used to specify if an order may be partially delivered.

The following standard records exist. Do not alter/delete:

Part delivery allowed (DelLevTillaten) | Part delivery allowed (DelLevTillatenBeskr)
0 | Part delivery allowed
10 | Part delivery NOT allowed

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Part delivery allowed | DelLevTillaten | ztInteger | 5 |  | smallint
Part delivery allowed | DelLevTillatenBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xdl Part delivery codes


Partial bookings allowed (xdb)

Internal definition of the code indicating whether partial booking is allowed or not within an order.

The following standard records exist. Do not alter/delete:

Partial booking allowed (DelBokningTillaten) | Partial booking allowed (DelBokningTillatenBeskr)
0 | Partial bookings allowed
10 | Partial bookings NOT allowed

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Partial booking allowed | DelBokningTillaten | ztInteger | 5 |  | smallint
Partial booking allowed | DelBokningTillatenBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xdb Partial bookings allowed


PartnerShortToLong (vzpi)

Table for storing file extensions of compression programs.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod |  |  |  | @DataType=NULL
Partner ID | YndPartner | ztString | 20 |  | nvarchar
Partner long ID | YndPartnerLong | ztString | 32 |  | nvarchar

    This table is the main table in the following programs:

    Program: vzpi EDI-partner Long ID->Short ID


Parts from configurator (TactonPart)

Parts from the Sales configurator.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Key part 1 | Key1 | ztString | 50 |  | varchar
Key part 2 | Key2 | ztString | 50 |  | varchar
Key part 3 | Key3 | ztString | 50 |  | varchar
Key part 4 | Key4 | ztString | 50 |  | varchar
Key part 5 | Key5 | ztString | 50 |  | varchar
Configurator model ID | ModelId | ztString | 60 |  | varchar
Index to parent part | ParentPartIndex | ztInteger | 5 |  | smallint
Index of part | PartIndex | ztInteger | 5 |  | smallint
Name of part | PartName | ztString | 255 |  | varchar
Part sequence | PartSeqNo | ztString | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Realizing part name | RealizedName | ztString | 128 |  | varchar
Value of realizing part name | RealizedValue | ztString | 255 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Payment discount handling (PayD)

Definition of applicable alternatives for handling payment discounts at lump sum payment.

The following standard records exist. Do not alter/delete:

Discount priority (DiscountPrio) | Discount management (PayDDescr) | Description
1 | Never early settlement discount |
2 | Early settlmt discnt acc to dates and discnt days | Do not suggest invoices for payment if payment date is greater than discount date, and discount date is greater than today's date
3 | Always early settlmt discnt independent of dates |

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Discount priority | DiscountPrio | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Default | MarkAsDefault | ztBoolean |  |  | char
Discount management | PayDDescr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PayD Payment discount handling


Payment files (lrut)

A help table, used when creating outgoing payment files to a bank.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Row | RadPos | ZtLong | 10 |  | int
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Payment route | UtbetalningsVag | ztString | 6 |  | varchar
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int
Text/info | x255 | ztString | 255 |  | varchar
Text/info | x255_2 | ztString | 255 |  | varchar
Text 3 | x255_3 | ztString | 255 |  | varchar
Text 4 | x255_4 | ztString | 255 |  | varchar


Payment methods (x1c)

Definition of payment methods that can apply when entering incoming payments.

The following payment methods can be provided as proposals (determined by an option during installation) but can be changed and added to:
BG = Bank Giro
PG = Plus Giro
kon = Cash
ch = Cheque
KNB = Customer number change
KTL = Customer invoice to suppl invoice
VAL = Currency revaluation
FSK/ADV = Settlement advance (for new installations we recommend the ADV code be used)

These definitions are then used when entering posting templates for incoming payments.

You specify the payment method when entering incoming payments in one of the incoming payment programs (program Inb or Inbkund), also in journal entry and in the BOE ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Bank | BankId | ztString | 10 |  | varchar
Description | Beskrivning | ztString | 50 |  | varchar
Cancel bill of exchange | BoE_Cancel | ztBoolean |  |  | char
BOE ledger | BoE_Code | ztBoolean |  |  | char
Cancel check | Check_Cancel | ztBoolean |  |  | char
Collection with voucher | Check_Coll_Voucher | ztBoolean |  |  | char
Check ledger | Check_Ledger | ztBoolean |  |  | char
Check form, lines per stub | CheckForm_LinesPerStub | ztInteger | 5 |  | smallint
Document no. series | docnoserie | ztString | 3 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Advance pmt deduction | ForskottAvrakning | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment route | InbetalningsVag | ztString | 6 |  | varchar
Payment method | InbSlag | ztString | 3 |  | varchar
Payment method | InbSlagBeskr | ztString | 50 |  | varchar
Receipt to account | InbTillKontoNr | ztString | 20 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Journal group | JourGrupp | ZtLong | 9 |  | int
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency revaluation | ValutaOmrakning | ztBoolean |  |  | char
Voucher no. group | vernrgrupp | ztString | 6 |  | varchar

    This table is the main table in the following programs:

    Program: xx1c Payment methods


Payment per supplier, journal and currency (vlelru)

Alphanumeric designation for the company.

When you enter a company for the first time, this number is not automatically set by the system. You must enter it manually.

This is the unique ID for the company and cannot be changed, which means that if you base it on the company name, e.g. the first letters of the company name, you will not be able to change the ID if the company changes name. It is therefore best to construct the ID a different way or just use sequence numbers. You can search for the company using different terms, e.g. its name.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Plan/paid amt, BCU | UtbBel | ZtBaseCurrAmount | 14 | 2 | money
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int
Currency | ValKod | ztString | 3 |  | varchar
Plan/paid amt, curr | VbUtbBel | ztMoney | 14 | 2 | money


Payment priority handling (PayP)

Definition of applicable alternatives for payment priority, i.e. in which order open customer invoices are to be payed at lump sum payment.

The following standard records exist. Do not alter/delete:

Payment priority (PaymentPrio) | Payment priority (PayPDescr)
1 | Due date
2 | Invoice date
3 | Invoice amount

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Default | MarkAsDefault | ztBoolean |  |  | char
Payment priority | PaymentPrio | ztInteger | 5 |  | smallint
Payment priority | PayPDescr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PayP Payment priority handling


Payment reminder and interest invc rules (xrav)

Definition of payment reminders and interest invoice rules. The rules specify whether payment reminders and/or interest invoices will be printed and on what terms, e.g. minimum amount for payment reminder or interest invoice, payment terms for interest invoices, number of tolerance days, etc. A valid set of rules is then linked to each customer.

Much of the information which you can enter here, can also be entered in the program 'AR system data' (sy1kr). The information in the payment reminder/interest invoicing rules applies first.

No standard records exist for dispatch.

In underlying program nodes the rules are linked to interest rates for debit or credit invoices. You only specify interest for credit invoices if you run the balance method for interest calculation.

There is also a program node for specifying reminder charges which can be included in demand letters.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Days demand 1 | AntDgr1Krav | ztInteger | 2 |  | smallint
Days demand 2 | AntDgr2Krav | ztInteger | 2 |  | smallint
Days demand 3 | AntDgr3Krav | ztInteger | 2 |  | smallint
Days demand 4 | AntDgr4Krav | ztInteger | 2 |  | smallint
Days to collection | AntDgrInkasso | ztInteger | 2 |  | smallint
Max demand letters | AntKrav | ztInteger | 1 |  | smallint
Payment terms | BetKod | ztString | 2 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Min demand amt | KravBrevMinBel | ZtBaseCurrAmount | 14 | 2 | money
Collections | KravEjInkasso | ztBoolean |  |  | char
Credit on demand | KravKredit | ztBoolean |  |  | char
Print-out demand for credit | KravKreditUtskrift | ztBoolean |  |  | char
Auto pmt reminder block | KSparr_Kund | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Only w pmt rmdr counter | RemindOnlyDue | ztBoolean |  |  | char
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Interest, deposits/credit | RtaInProcent | ZtDecimal73 | 6 | 2 | decimal
30 days/month | RtaManad30Dgr | ztBoolean |  |  | char
Interest, loans/debit | RtaUtProcent | ZtDecimal73 | 6 | 2 | decimal
Tolerance days | RteBerTolDgr | ztInteger | 5 |  | smallint
Spec per invoice | RteDetSaldo | ztBoolean |  |  | char
Pmt rmdr/intrst invc rule | RteFaktAvtal | ztInteger | 2 |  | smallint
Pmt rmdr/intrst invc rule | RteFaktAvtalBeskr | ztString | 50 |  | varchar
Interest invoice | RteFaktKd | ztBoolean |  |  | char
Max days save interest | RteFaktMaxSparDagar | ztInteger | 3 |  | smallint
Min interest inv amt: | RteFaktMinBelDeb | ZtBaseCurrAmount | 14 | 2 | money
Min interest cred amt: | RteFaktMinBelKre | ZtBaseCurrAmount | 14 | 2 | money
Min interest amt, spec | RteMinBelDet | ZtBaseCurrAmount | 14 | 2 | money
Balance method credit | RteSaldoKredBegr | ztBoolean |  |  | char
Balance method | RteSaldoMetoden | ztBoolean |  |  | char
Calc excl tol days | RteTolTillDat | ztBoolean |  |  | char
Print reminder | UtskrKravBrev | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xrav Payment reminder and interest invc rules


Payment service journal (jfbs)

Invoice payment service journal.
The journal contains data on which invoices have been sent for monitoring.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Account at bank | BankKonto | ztString | 40 |  | varchar
Transmit to bank date | BankSandDat | ztDate |  |  | datetime
Currency pocket | Curr_P | ztString | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
No. of invoices | JfbsAntalFakturor | ZtLong | 4 |  | int
Payment amount | JfbsFaktBel | ZtBaseCurrAmount | 14 | 2 | money
Journal closed | JfbsLocked | ztBoolean |  |  | char
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Planned pmt date | LrFaktPlanBetDat | ztDate |  |  | datetime
This field is used in the table as follows: |
Utb skapad från FBS | Mark_If_Lru_Created | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
PG manufacturing date | PostGiroProdDat | ztDate |  |  | datetime
PG manufacturing no. | PostGiroProdNr | ztInteger | 1 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sekvensnummer | SekvensNr | ZtLong | 6 |  | int
SekvNr | SekvNr | ztInteger | 4 |  | smallint
Plan/paid amt, BCU | UtbBel | ZtBaseCurrAmount | 14 | 2 | money
Payment route | Utbetalningsvag | ztString | 6 |  | varchar
Pmt file created | UtbFileCreated | ztBoolean |  |  | char
Pmt file created by | UtbFileCreatedBy | ztString | 6 |  | varchar
Pmt file created date | UtbFileCreatedDt | ztDateTime |  |  | datetime
Pmt service journal no. | UtbServJournNr | ZtLong | 6 |  | int
Payment methods | UtbSlag | ztString | 3 |  | varchar
To due date | UtbTomFfDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar

    This table is the main table in the following programs:

    Program: Nxjfbs Invoice payment service with posting

    Program: xJfbs Invoice payment service


Payment service journal header (jbs)

Data in the journal header about payment service assignments containing one or more invoices. A journal must be created for each payment method/payment route.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Transmit to bank date | BankSandDat | ztDate |  |  | datetime
Antal fakturor | BsAntalFakturor | ZtLong | 4 |  | int
Journal/körning | BsJournNr | ZtLong | 6 |  | int
T.o.m. förfallodatum | BsTomFfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Plan/paid amt, BCU | UtbBel | ZtBaseCurrAmount | 14 | 2 | money
Pmt file created | UtbFileCreated | ztBoolean |  |  | char
Pmt file created by | UtbFileCreatedBy | ztString | 6 |  | varchar
Pmt file created date | UtbFileCreatedDt | ztDateTime |  |  | datetime
Payment methods | UtbSlag | ztString | 3 |  | varchar


Payment service payment files (lrpu)

Created invoice payment service files.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
100 chars fixed | char100 | ztchar | 100 |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Row | RadPos | ZtLong | 10 |  | int
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Pmt service journal no. | UtbServJournNr | ZtLong | 6 |  | int


Payment suggestion (PaySugg)

Payment suggestion in for customer invoices.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Journal no. | BilagsNr | Jeeves_VchrNo | 9 |  | bigint
Invoice date | FaktDat | ztDate |  |  | datetime
Due date | FaktFfDat | ztDate |  |  | datetime
Paid amount BCU | FaktInbBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment date | InbDat | ztDate |  |  | datetime
Early settlmt discnt BCU | InbKassaRab | ZtBaseCurrAmount | 14 | 2 | money
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Urspr valutakurs | OldValKurs | ZtCurrencyRate | 15 | 7 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Amount paid, curr | VbFaktInbBel | ztMoney | 14 | 2 | money
Paid amount, curr | VbInbBel | ztMoney | 14 | 2 | money
Early settlmt discnt, curr | VbKassaRab | ztMoney | 14 | 2 | money


Payment surplus handling (PayS)

Definition of applicable alternatives for handling surplus payments, i.e when a paid lump sum exceeds the sum of open invoices for the customer.

The following standard records exist. Do not alter/delete:

Payment surplus (PaymentSurplus) | Payment surplus (PaySDescr)
1 | No advance invoice
2 | Create advance invoice

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Default | MarkAsDefault | ztBoolean |  |  | char
Payment surplus | PaymentSurplus | ztInteger | 5 |  | smallint
Payment surplus | PaySDescr | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PayS Payment surplus handling


Payment terms, advance (view) (vwx2)

Definition of payment terms for customer invoices with information on credit times, any early settlement discounts, payment type, payment route, etc.

If a posting template is specified for payment terms
------------------------------------------------------------------
- The posting rule specified for the cash payment term is ALWAYS used for cash invoices (invoice total, tax and rounding).

- The posting rule is always retrieved from the invoice type for advance invoices.

- If the invoice is not an advance invoice or a cash invoice, the payment term's posting rule is used for posting the invoice total if there is no posting rule on the invoice header. (The invoice header receives the posting rule from the order header, but can be reset at the modification point found during invoice creation.) This can be used when you want different payment terms to be sent to different accounts in the General Ledger, e.g. Visa, Eurocard, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Credit months fr delivery | AntFriLevM | ztInteger | 2 |  | smallint
Posting template | AutoRegel | ztString | 4 |  | varchar
Payment type | BetalningsTyp | ztInteger | 5 |  | smallint
Payment terms | BetKod | ztString | 2 |  | varchar
Payment terms | BetVillBeskr | ztString | 50 |  | varchar
Spec payment terms | BetVillBeskr255 | ztString | 255 |  | varchar
Check, card data | CheckCardDataEnter | ztBoolean |  |  | char
Payment credit card | CreditCardPayment | ztBoolean |  |  | char
Cash on del code | EfterKravsKod | ztBoolean |  |  | char
Handling charge | ExpAvgKd | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Month following deliv | FriLevM | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment route | InbetalningsVag | ztString | 6 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Early settlmt discnt % | KassaRab | ztFloat | 6 | 2 | float
Early settlmt discnt days | KassaRabDag | ztInteger | 3 |  | smallint
Cash invoice | KontantFaktura | ztBoolean |  |  | char
Credit period days | KreditTid | ztInteger | 3 |  | smallint
Credit period months | KreditTidMan | ztInteger | 3 |  | smallint
Receipt printout | KvittoUtskrift | ztBoolean |  |  | char
Max. amount back | MaxTillbakaBelopp | ZtBaseCurrAmount | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Early settlmt discnt terms | RabKod | ztString | 3 |  | varchar
This field is used in the table as follows: |
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
TextID | TextID | ZtLong | 10 |  | int
Payment route | UtbetalningsVag | ztString | 6 |  | varchar


Payment terms, purchasing, lang. (xbvs)

Language translations of descriptions for delivery terms regarding purchases.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Dispatch terms | BestLevVilkKd | ztInteger | 2 |  | smallint
Dispatch terms | BestLevVillkBskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint


Payment terms, purchasing, language (xlbs)

Language translations of descriptions for payment terms regarding purchases.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Payment terms | LevBetvkBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint


Payment terms, purchasing/AP (xlb)

Definition of payment terms for supplier invoices and purchase orders, with information credit periods, early settlement discounts, etc.

You can specify a default payment term in the System file, own co. program (Sy) and/or for the supplier, but you can change the information on the purchase order/invoice.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Days credit | AntDag | ztInteger | 3 |  | smallint
Credit months fr delivery | AntFriLevM | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Month following deliv | FriLevM | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Early settlmt discnt % | Kassarab | ztFloat | 6 | 2 | float
Early settlmt discnt days | KassarabDag | ztInteger | 3 |  | smallint
Early stlmt dsct dt->due dt | KassaRabDatFFDat | ztBoolean |  |  | char
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Payment terms | LevBetvkBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Early settlmt discnt terms | RabKod | ztString | 3 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxlb Payment terms, purchasing/AP


Payment terms, sales (X2)

Definition of payment terms for customer invoices with information on credit times, any early settlement discounts, payment type, payment route, etc.

If a posting template is specified for payment terms
------------------------------------------------------------------
- The posting rule specified for the cash payment term is ALWAYS used for cash invoices (invoice total, tax and rounding).

- The posting rule is always retrieved from the invoice type for advance invoices.

- If the invoice is not an advance invoice or a cash invoice, the payment term's posting rule is used for posting the invoice total if there is no posting rule on the invoice header. (The invoice header receives the posting rule from the order header, but can be reset at the modification point found during invoice creation.) This can be used when you want different payment terms to be sent to different accounts in the General Ledger, e.g. Visa, Eurocard, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Credit months fr delivery | AntFriLevM | ztInteger | 2 |  | smallint
Posting template | AutoRegel | ztString | 4 |  | varchar
Payment type | BetalningsTyp | ztInteger | 5 |  | smallint
Payment terms | BetKod | ztString | 2 |  | varchar
Payment terms | BetVillBeskr | ztString | 50 |  | varchar
Spec payment terms | BetVillBeskr255 | ztString | 255 |  | varchar
Credit days acceptance | BOE_AcceptDays | ztInteger | 2 |  | smallint
Early settlmt discnt goods | CashDiscount | ztBoolean |  |  | char
Check, card data | CheckCardDataEnter | ztBoolean |  |  | char
Payment credit card | CreditCardPayment | ztBoolean |  |  | char
Cash on del code | EfterKravsKod | ztBoolean |  |  | char
Credit end of month | EndOfMonth | ztBoolean |  |  | char
Handling charge | ExpAvgKd | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Advance payment applies | ForskottBetalning | ztBoolean |  |  | char
Adv paid on delivery | ForskottSlutBetVidLev | ztBoolean |  |  | char
Month following deliv | FriLevM | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment route | InbetalningsVag | ztString | 6 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Due date 10th/20th/last | InvDueDtDecade | ztBoolean |  |  | char
Early settlmt discnt % | KassaRab | ztFloat | 6 | 2 | float
Early settlmt discnt days | KassaRabDag | ztInteger | 3 |  | smallint
Cash invoice | KontantFaktura | ztBoolean |  |  | char
Credit period days | KreditTid | ztInteger | 3 |  | smallint
Credit period months | KreditTidMan | ztInteger | 3 |  | smallint
Receipt printout | KvittoUtskrift | ztBoolean |  |  | char
Max. amount back | MaxTillbakaBelopp | ZtBaseCurrAmount | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Early settlmt discnt terms | RabKod | ztString | 3 |  | varchar
This field is used in the table as follows: |
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
TextID | TextID | ZtLong | 10 |  | int
Payment route | UtbetalningsVag | ztString | 6 |  | varchar

    This table is the main table in the following programs:

    Program: XX2 Payment terms, sales/AR


Payments (lru)

Outgoing payments from the accounts payable ledger.
Outgoing payments are preliminary from when the outgoing payment journal is created until integration with the General Ledger is run.
When invoices are entered NO planned outgoing payment is created.
This is done later in another program when the invoice receives final approval.
On the supplier invoice are the fields 'Left to pay' (invoice amount - booked outgoing payments) and 'Left to plan for payment' (invoice amount - booked outgoing payments - planned payments).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Deduction text | AvdragText | ztString | 30 |  | varchar
Deducted amt curr | AvdrVal | ztMoney | 14 | 2 | money
Bank | BankId | ztString | 10 |  | varchar
Account at bank | BankKonto | ztString | 40 |  | varchar
Description | Beskrivning | ztString | 50 |  | varchar
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Advance, linked invoice no. | BestRkgNrForskott | ztString | 25 |  | varchar
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Payment reason | BetUppdragsTyp | ztString | 4 |  | varchar
Reserved in journal | BilagsMark | ztBoolean |  |  | char
Individual bill of exchnge | BoE_Ind | ztBoolean |  |  | char
Bill of exchange no. | BoE_No | ZtLong | 9 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
Separate check | CheckInd | ztBoolean |  |  | char
Check number | Checkno | ZtLong | 9 |  | int
Check sequence number | CheckSequence | ZtLong | 10 |  | int
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Currency pocket | Curr_P | ztString | 1 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Reported end time | EventRpTime | ztTime | 5 |  | datetime
Start time | EventStartTime | ztTime | 5 |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Guarantee account | G_BankAccount | ztString | 40 |  | varchar
Guarantee payment | G_Paym | ztBoolean |  |  | char
Guarantee % | G_Percentage | ZtDecimal73 | 5 | 2 | decimal
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S-4 f ledg.balance | K4ReskSaldo | ztString | 8 |  | varchar
S5 f ledg.balance | K5ReskSaldo | ztString | 8 |  | varchar
S6 f ledg.Bal | K6ReskSaldo | ztString | 8 |  | varchar
S7 f ledg.balance | K7ReskSaldo | ztString | 8 |  | varchar
Early settlmt discnt % | Kassarab | ztFloat | 6 | 2 | float
Early settlmt discnt BCU | KassaRabBas | ZtBaseCurrAmount | 14 | 2 | money
Cost unit f ledg.balance | KBarReskSaldo | ztString | 8 |  | varchar
Pmt to acct | KontoIns | ztInteger | 1 |  | smallint
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Balance sheet CC | KstReskSaldo | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Ledger acct | KtoNrReskSaldo | ztString | 8 |  | varchar
Actual pmt date | LevFaktBetDat | ztDate |  |  | datetime
Invoice date | LevFaktDat | ztDate |  |  | datetime
Due date | LrFaktFFDat | ztDate |  |  | datetime
Early settlmt discnt dt | LrfaktKrabdat | ztDate |  |  | datetime
Planned pmt date | LrFaktPlanBetDat | ztDate |  |  | datetime
Header check number | MCheckno | ZtLong | 9 |  | int
Urspr valutakurs | oldValKurs | ZtCurrencyRate | 15 | 7 | decimal
Orig exchange rate | OldValKursGrund | ZtCurrencyRate | 15 | 7 | decimal
Orig exchange rate, operand | OldValKursOp | ztInteger | 5 |  | smallint
Orig exchange rate per | OldValKursPer | ZtDecimal73 | 8 | 3 | decimal
Preliminary voucher | OldVerNr | Jeeves_VchrNo | 9 |  | bigint
Paid amount BCU | PaidAmountBCU | ztMoney | 14 | 2 | money
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Priority | Prioritet | ztInteger | 2 |  | smallint
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Deducted amount in BCU | utbavdrbas | ZtBaseCurrAmount | 14 | 2 | money
Plan/paid amt, BCU | UtbBel | ZtBaseCurrAmount | 14 | 2 | money
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int
AP payment status | UtbKod | ztString | 1 |  | varchar
Pmt service journal no. | UtbservJournNr | ZtLong | 6 |  | int
Payment methods | UtbSlag | ztString | 3 |  | varchar
AP payment notif text | UtbText | ztString | 60 |  | varchar
Adjustment type | UtbTyp | ztString | 1 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate | ValKursGrund | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate, operand | ValKursOp | ztInteger | 5 |  | smallint
Exchange rate unit | ValKursPer | ZtDecimal73 | 8 | 3 | decimal
Currency revaluation | ValutaOmrakning | ztBoolean |  |  | char
Early settlmt discnt, curr | VbKassaRab | ztMoney | 14 | 2 | money
Plan/paid amt, curr | VbUtbBel | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: Xlru Show payments


PDM (BOM...) (srpd)

Which PDM documents are to be used/printed for a bill of materials.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Item no. (BOM) | BArtNrStrukt | ztString | 30 |  | varchar
Connected to PDM ... | ConnPdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
Document type no. | DocumentType | ZtLong | 5 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Configuration item no. | KonfigArtNr | ztString | 30 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Print date | p_Utskr_Dat | ztDate |  |  | datetime
PDM (Unique ID) | PdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


PDM (manufacturing order) (thpd)

The PDM documents to be used/printed for a manufacturing order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Revision date | ArtRevDat | ztDate |  |  | datetime
Revision no. | ArtRevId | ztString | 10 |  | varchar
Revision signature | ArtRevSign | ztString | 6 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Connected to PDM ... | ConnPdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Document type no. | DocumentType | ZtLong | 5 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Deliv to supplier | LevMedBestTillLev | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Print date | p_Utskr_Dat | ztDate |  |  | datetime
Normally on purchase order | Pdm2PO | ztBoolean |  |  | char
Normally on work order | Pdm2WO | ztBoolean |  |  | char
PDM quantity 1 | PdmAntal1 | ZtLong | 10 |  | int
PDM quantity 1 | PdmAntal2 | ZtLong | 10 |  | int
PDM (Unique ID) | PdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
PDM ref 1 | PdmRef1 | ztString | 40 |  | varchar
PDM ref 2 | PdmRef2 | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
BOM for item | StycklistaTillArtNr | ztString | 30 |  | varchar
ID for connection | Ti_LopNr_Ned | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: Thpd PDM manufacturing order


PDM (PO/purchasing...) (bhpd)

The PDM documents to be used/printed for a purchase order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
Connected to PDM ... | ConnPdmDummyUniqueID | ztUniqueIdentifier | 100 |  | varchar
Document type no. | DocumentType | ZtLong | 5 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Print date | p_Utskr_Dat | ztDate |  |  | datetime
PDM (Unique ID) | PdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: Bhpd PDM order


PDM (view BOM) (srpv)

View to obtain proposals of documents for components on a bill of materials.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Lowest level f item | ArtNiva | ztInteger | 2 |  | smallint
BOM level | ArtNivaBeskr | ztString | 20 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Item no. (BOM) | BArtNrStrukt | ztString | 30 |  | varchar
Connected to PDM ... | ConnPdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
Documentation | Documentation | ztBlob | 1 |  | varchar
Document type no. | DocumentType | ZtLong | 5 |  | int
File/dir | DokDir | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Configuration item no. | KonfigArtNr | ztString | 30 |  | varchar
Note | KortNotering | ztString | 255 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Normally on purchase order | Pdm2PO | ztBoolean |  |  | char
Normally on work order | Pdm2WO | ztBoolean |  |  | char
PDM (Unique ID) | PdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


PDM (view MO) (thpv)

View to obtain proposals of documents for items on a manufacturing order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Connected to PDM ... | ConnPdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
Documentation | Documentation | ztBlob | 1 |  | varchar
Document type no. | DocumentType | ZtLong | 5 |  | int
File/dir | DokDir | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Note | KortNotering | ztString | 255 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Normally on purchase order | Pdm2PO | ztBoolean |  |  | char
Normally on work order | Pdm2WO | ztBoolean |  |  | char
PDM quantity 1 | PdmAntal1 | ZtLong | 10 |  | int
PDM quantity 1 | PdmAntal2 | ZtLong | 10 |  | int
PDM (Unique ID) | PdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
PDM ref 1 | PdmRef1 | ztString | 40 |  | varchar
PDM ref 2 | PdmRef2 | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


PDM (view order) (bhpv)

View to obtain proposals of documents for items on a purchase order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Connected to PDM ... | ConnPdmDummyUniqueID | ztUniqueIdentifier | 100 |  | varchar
Documentation | Documentation | ztBlob | 1 |  | varchar
Document type no. | DocumentType | ZtLong | 5 |  | int
File/dir | DokDir | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Note | KortNotering | ztString | 255 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Normally on purchase order | Pdm2PO | ztBoolean |  |  | char
Normally on work order | Pdm2WO | ztBoolean |  |  | char
PDM quantity 1 | PdmAntal1 | ZtLong | 10 |  | int
PDM quantity 1 | PdmAntal2 | ZtLong | 10 |  | int
PDM (Unique ID) | PdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
PDM ref 1 | PdmRef1 | ztString | 40 |  | varchar
PDM ref 2 | PdmRef2 | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


PDM access (pdma)

Table showing access logs for a particular document. Logging takes place against the PDM (origin) field, so it takes account of all revisions and versions of the document.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
PDM (origin) | originPDMDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
EDM activity ID | pdmaccid | ZtLong | 10 |  | int
EDM activity type | pdmacctype | ztInteger | 5 |  | smallint
PDM (Unique ID) | pdmdummyuniqueid | ztUniqueIdentifier | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


PDM document types (xpdm)

Table of the different document types according to which a document is defined and classified. The document has a logical significance in classifying documents of a certain type, for example change requisition, and also a significance in defining file types on the basis of the file extension, program and browser.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Will be approved | Attesteras | ztBoolean |  |  | char
Approval chain | attkedja | ztInteger | 5 |  | smallint
Autoexec create doc | AutoCreateDoc | ztBoolean |  |  | char
Auto-create new file | AutoSkapaNyFil | ztBoolean |  |  | char
Auto-display new file | AutoVisaNyFil | ztBoolean |  |  | char
Business document | BusinessDocType | ztInteger | 5 |  | smallint
Command row, param | Commandlinepar | ztString | 255 |  | varchar
Sequence no counter | CountLopNr | ztBoolean |  |  | char
Crystal report file | CrystalReportFile | ztString | 100 |  | varchar
Crystal report (id) | CrystalReportId | ztInteger | 100 |  | smallint
DDE call, open | DDEcall | ztString | 255 |  | varchar
This field is used in the table as follows: |
DDE call open | DDEcallnew | ztBlob | 255 |  | varchar
Default document type | DefDokTyp | ztBoolean |  |  | char
Archive directory | DocDirArchive | ztString | 255 |  | varchar
Document template | DocTemplate | ztString | 255 |  | varchar
File extension | DocumentExt | ztString | 30 |  | varchar
Document type no. | DocumentType | ZtLong | 5 |  | int
Document type | DocumentTypeDescr | ztString | 40 |  | varchar
Program (edit file) | DocumentTypeProgram | ztString | 100 |  | varchar
Program (view file) | DocumentTypeViewer | ztString | 100 |  | varchar
File/dir | DokDir | ztString | 255 |  | varchar
Check-out directory | DokDirCheckOut | ztString | 255 |  | varchar
File/dir Web server | DokDirWeb | ztString | 255 |  | varchar
Doc header/directory | DokMapp | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
Only open with Viewer | EjWinOppnas | ztBoolean |  |  | char
E-mail document type | EmailDokTyp | ztBoolean |  |  | char
New file for new revision | EndastNyFilVidNyRev | ztBoolean |  |  | char
New file for new edition | EndastNyFilVidNyUtg | ztBoolean |  |  | char
File extension fr doc | ExtensionFrDok | ztBoolean |  |  | char
Filepointer terms | FilePointerTerms | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Program clone | klon | ztString | 20 |  | varchar
Supplier invoice | LevFaktDokTyp | ztBoolean |  |  | char
Log | Loggas | ztBoolean |  |  | char
Sequence no. | LopNr | ZtLong | 10 |  | int
Consist of muliple files | MultipleFiles | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Replace file | replacefile | ztBoolean |  |  | char
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Show in SFC | SFRShowInSFC | ztBoolean |  |  | char
Use streaming | Streamas | ztBoolean |  |  | char
Used for unknown file type | UnknownExtDokTyp | ztBoolean |  |  | char
Visible in Office | VisibleInOffice | ztBoolean |  |  | char
Wildchar positions | WildCharPositions | ztInteger | 5 |  | smallint
Param | zParams | ztBlob | 255 |  | varchar

    This table is the main table in the following programs:

    Program: Xpdm Document types


PDM revisions (pdmr)

Table of revision indexes linked to a specific revision to facilitate serial sorting.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Revision no. | ArtRevId | ztString | 10 |  | varchar
Revision | ArtRevIndex | ztInteger | 4 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Variant (ECO) | Variant | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: pdmr Document revisions


PDM versions (PDML)

Unique key term for a document.
If nothing is entered, a unique ID/sequence number is created based on:
number of days since 940101
number of seconds since 00.00
process ID in the database
counter

Own specified IDs must not contain Windows reserved characters.

On computers with fast processors, it is possible that this ID term will not be unique for mass insert batches. For example, upon procedural generation of new document records or upon importing document records from another system. In such cases it is better for the unique ID to be generated by the procedure that loads the document records.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Item no. | ArtNr | ztString | 30 |  | varchar
Revision date | ArtRevDat | ztDate |  |  | datetime
Revision no. | ArtRevID | ztString | 10 |  | varchar
Revision signature | ArtRevSign | ztString | 6 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Connected to PDM ... | ConnPdmDummyUniqueID | ztUniqueIdentifier | 100 |  | varchar
Documentation | Documentation | ztBlob | 1 |  | varchar
Document type no. | DocumentType | ZtLong | 5 |  | int
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
File/dir | DokDir | ztString | 255 |  | varchar
File name | FileName | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | KortNotering | ztString | 255 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Normally on purchase order | Pdm2PO | ztBoolean |  |  | char
Normally on work order | Pdm2WO | ztBoolean |  |  | char
PDM quantity 1 | PdmAntal1 | ZtLong | 10 |  | int
PDM quantity 1 | PdmAntal2 | ZtLong | 10 |  | int
PDM (Unique ID) | PdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
PDM ref 1 | PdmRef1 | ztString | 40 |  | varchar
PDM ref 2 | PdmRef2 | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Peer To Peer Community (PTPCommunity)

Numerical ID for the community.

Note that the community ID should not be filled in in the member form.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Community ID | PComId | ztInteger | 4 |  | smallint
Community name | PComName | ztString | 128 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Peer To Peer Conversations (PTPConversation)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Conversation Description | PConvDesc | ztString | 250 |  | varchar
Conversation ended | PConvEnded | ztBoolean |  |  | char
Conversation ID | PConvId | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Peer To Peer Groups (PTPGroups)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Group ID | PGroupId | ztInteger | 4 |  | smallint
Group Name | PGroupName | ztString | 128 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PTPGroups Community Groups


Peer To Peer Member (PTPMember)

Numerical ID for a member of a conversation group, used in the Collaboration function.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | ftgkontaktnr | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Member ID | MemberId | ZtLong | 6 |  | int
Member name | MemberName | ztString | 64 |  | varchar
Database name | PDBName | ztString | 128 |  | varchar
Server | PDBServer | ztString | 128 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Member standing | PMemberState | ztInteger | 2 |  | smallint
Skype name | PSkypeName | ztString | 128 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PTPMember Community Members


Peer To Peer Sessions (PTPSessions)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Member standing | PMemberState | ztInteger | 2 |  | smallint
Session ID | PSessionId | ZtLong | 6 |  | int
Structure ID | PStructId | ZtLong | 6 |  | int
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Peer To Peer User Structure (PTPUserStruct)

Definition of conversation groups and group members, used in the Collaboration function.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Member ID | MemberId | ZtLong | 6 |  | int
Community ID | pComID | ztInteger | 4 |  | smallint
Group ID | PGroupId | ztInteger | 4 |  | smallint
Structure ID | PStructId | ZtLong | 6 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PTPCommunity Communities


People/resource type (pres)

Table of resource types/roles that users or employees belong to. You can link a role to several users and one user can have several roles.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Grouping | gruppering | ztInteger | 5 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Mail per day | mailperdag | ztBoolean |  |  | char
NextResourceGrp | NastaResursGrp | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Reserve | PersSignMailReserv | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Resource group | ResursGrp | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: pres Resource type, human


Percentage of completion accounting, details (Psvd)

Journal details for percentage of completion accounting on projects. One detail row is created for each project processed in the percentage of completion accounting journal. Each detail is linked to a journal record (table Psvj) with a journal number.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Services account | TjansteKonto | ztString | 8 |  | varchar
Voucher no. | Vernr | Jeeves_VchrNo | 9 |  | bigint
Journal no. | VinstAvrakningJournal | ZtLong | 10 |  | int


Percentage of completion accounting->GL (Psvt)

Detailed information of how percentage of completion accounting has been posted when integrated with the General Ledger.
This table is the basis for the creation of vouchers.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
ProjectTransType | ProjTransTyp | ztInteger | 2 |  | smallint
This field is used in the table as follows: |
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Services account | TjansteKonto | ztString | 8 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Journal no. | VinstAvrakningJournal | ZtLong | 10 |  | int
Row status | VrStatus | ztInteger | 4 |  | smallint


Period fixed posting (pfk)

Definition of periods in templates for fixed periodic vouchers.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Period for voucher details (xepv)

Internal definitions which control whether a period can be specified on voucher rows or not.

The following standard records exist. Do not alter/delete:

Voucher per desc (PerVer) | Voucher per desc (PerVerBeskr)
0 | Cannot enter period
1 | Can enter period

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Voucher per desc | PerVer | ztInteger | 1 |  | smallint
Voucher per desc | PerVerBeskr | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xXepv Voucher per desc


Period log (perl)

Log of changes in period data, for example, when a period is opened or closed, selected or deselected as a closing period and when a period's closing date is changed. The information can be opened in an underlying program node of Fiscal year and periods (program redar).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Closing period | BokslutsPeriod | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Closing period bef chg | OldBokslutsPeriod | ztBoolean |  |  | char
Period closed bef chg | OldPeriodClosed | ztBoolean |  |  | char
Last day bef chg | OldPeriodEnd | ztDate |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Period closed | PeriodClosed | ztBoolean |  |  | char
Last day of period | PeriodEnd | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Date/time | StrDateTime | ztString | 28 |  | varchar


Period sales statistics (sper)

Period statistics of order entry, invoicing and incoming payments.

The statistics are generated by running report c, "Create statistics, customer + period".

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Budgeted amount | BudgBelopp | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Per invoiced amt | PerFaktBel | ZtBaseCurrAmount | 14 | 2 | money
CSG | PerFaktRadKost | ZtBaseCurrAmount | 14 | 2 | money
Paid/period | PerInbBel | ZtBaseCurrAmount | 14 | 2 | money
Period | Period | ztInteger | 4 |  | smallint
Orders/period value | PerOrderIngBel | ZtBaseCurrAmount | 14 | 2 | money
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Remaining to pay | RestBelFakt | ZtBaseCurrAmount | 14 | 2 | money
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Statistical item value | StatistikRadVarde | ZtBaseCurrAmount | 14 | 2 | money
Period invc amt, curr | VbPerFaktBel | ztMoney | 14 | 2 | money
Period pmt amt, curr | VbPerInbBel | ztMoney | 14 | 2 | money
Outstanding amt, curr | VbRestBelFakt | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: xSper Period statistics


Period weeks (perv)

Weeks and their distribution in a certain period.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allocation percent | FordProc | ZtDecimal73 | 6 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Week number | KalenderVecka | ztInteger | 2 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Forecast version | PrognosVer | ZtLong | 4 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: perv Weeks per period


Period's auto postings/allocations (pero)

Executed auto posting and allocation batches for the period in question.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Batch no. | AutKontNr | ztInteger | 4 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Interim vouch no. | MVerNr | Jeeves_VchrNo | 9 |  | bigint
Batch number | OmgangsNr | ztInteger | 3 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Cancel | PeroMakKod | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Date/time | StrDateTime | ztString | 28 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint


Period, closed for integration source (peri)

Definition of periods within a given fiscal year per integration source saved for posting at the period close. The purpose of this is to be able to enter certain given voucher types while not being able to invoice or perform similar measures on a closed period, for example.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Period closed | PeriodClosed | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Period, unlocked for user (peru)

Definition of the users who are allowed to post in closed accounting periods. Definitions are made per period and user.

The flag for closed period in the period table applies to all other users, i.e. not defined in this table.

Note that the unlocking only applies to manual vouchers, supplier invoices, but may apply to other integration sources in the future. Unlocking can be prevented by entering a record in the Period, closed for integration source table (peri).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Period closed | PeriodClosed | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Periodic vch.basis, details (remd)

Table of details in the periodic vouchers that are stored in an interim table to be read in at a later date.

The data concerns planned events that have been created based on an existing voucher (allocation of costs or the like) or based on a fixed posting done periodically over several months.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Debit/credit | DebKre | ztchar | 1 |  | char
Text | Edit | ztBlob | 1 |  | varchar
Amount | FordBel | ZtBaseCurrAmount | 14 | 2 | money
Allocation percent | FordProc | ZtDecimal73 | 6 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
From account no. | FromKtoNr | ztString | 8 |  | varchar
From position | FromRadPos | ztInteger | 4 |  | int
From fiscal year | FromRedovisnar | ztInteger | 4 |  | smallint
From voucher no. | FromVerNr | Jeeves_VchrNo | 9 |  | bigint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Voucher text | remdVerText | ztString | 40 |  | varchar
Fördelningstyp | RemFordTyp | ztInteger | 2 |  | smallint
Periodic vch. no | RemNr | ZtLong | 6 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Uppd år | Updar | ztInteger | 4 |  | smallint
Uppdaterad per nr | UpdPeriod | ztInteger | 4 |  | smallint
Valid to use | ValidToUse | ztBoolean |  |  | char
Currency | ValKod | ztString | 3 |  | varchar
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: vRemd Show periodic vouchers and basis


Periodic vch.basis, header (remh)

Main table for the periodic vouchers that are stored in an interim table to be read in at a later date.

The data concerns planned events that have been created based on an existing voucher (allocation of costs or the like) or based on a fixed posting done periodically over several months.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
From account no. | FromKtoNr | ztString | 8 |  | varchar
From position | FromRadPos | ztInteger | 4 |  | int
From voucher no. | FromVerNr | Jeeves_VchrNo | 9 |  | bigint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Credit amount | krebel | ZtBaseCurrAmount | 14 | 2 | money
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Copy to new fiscal year | Over2NextYear | ztBoolean |  |  | char
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Periodic vch. no | RemNr | ZtLong | 6 |  | int
Periodic vch.type | RemTyp | ztInteger | 2 |  | smallint
Replaced by | ReplaceByAccNo | ztString | 8 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Valid to use | ValidToUse | ztBoolean |  |  | char
Currency | ValKod | ztString | 3 |  | varchar
Voucher text | vertext | ztString | 60 |  | varchar
Deleted | zDeleted | ztInteger | 1 |  | smallint

    This table is the main table in the following programs:

    Program: remf Create fixed periodic voucher basis

    Program: remh Create periodic interim voucher basis


Periodic voucher types (xrt)

Internal definition of types of periodic vouchers found.

The following standard records exist. Do not alter/delete:

Periodic vch.type (RemTyp) | Periodic vch.type (RemTypBeskr)
1 | Allocation of voucher
2 | Allocation of period balance
3 | Allocation of balance
4 | Fixed amount

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Entry inventory, Proj | lager1 | ztInteger | 1 |  | smallint
@zPrompt=null | RemLayer | ztInteger | 2 |  | smallint
Periodic vch.type | RemTyp | ztInteger | 2 |  | smallint
Periodic vch.type | RemTypBeskr | ztString | 50 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: rxrt Periodic voucher types


Periodicity (xpe)

Table of depreciation periods that can be applied.

The following standard records exist. Do not alter/delete:

Depreciation periodicity (Periodicitet) | Periodicity descr (Periodicitetsbeskrivning) | Description
1 | Annually | If annually, depreciation can only be done in period 12.
2 | Biannually | If biannually, depreciation can only be done in periods 6 and 12.
3 | Every four months | If every four months, depreciation can be done in periods 4, 8 and 12.
4 | Quarterly | If quarterly, depreciation can be done in periods 3, 6, 9 and 12.
12 | Monthly | If monthly, depreciation can be done in period 1 to 12.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Depreciation periodicity | Periodicitet | ztInteger | 2 |  | smallint
Periodicity descr | Periodicitetsbeskrivning | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xpe Periodicity


Periods (per)

Periods within a certain fiscal year.
Define the accounting periods in a fiscal year in this table.
There are normally 12 periods (period 1 to 12) and a period for the opening balance (period 0) and one or more balancing periods (period 13 ...).
Specify an end date is for each period.
Ascending period numbers must be given ascending end dates (e.g. period 4 CANNOT have an end date that precedes that of period 3).
The end date of balancing periods (the opening balance counts as a balancing period and must be flagged as such) can come after the subsequent period.
There is a flag in the period table if it is open for the creation of vouchers.
Users authorized to make entries in closed periods must be listed in a special table containing the users and periods.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Closing period | Bokslutsperiod | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Posting date | HbUpDat | ztDate |  |  | datetime
Huvudboksdatum | HbUpDatTid | ztDateTime |  |  | datetime
Last locking balance reg | OmgangDateTime | ztDateTime |  |  | datetime
Batch done by | OmgangPersSign | ztString | 6 |  | varchar
Batch number | OmgangsNr | ztInteger | 3 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Period designation | PeriodBeskr | ztString | 60 |  | varchar
Period closed | PeriodClosed | ztBoolean |  |  | char
Last day of period | PeriodEnd | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax index | VATindex | ztFloat | 10 | 6 | float
Tax period | VATPeriod | ztString | 8 |  | varchar
Last day VAT/tax period | VATPeriodEnd | ztDate |  |  | datetime
VAT/tax stmt status | VATStatus | ztString | 1 |  | varchar
Tax period | VATTaxPeriod | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: bAkSal Run auto posting and allocation

    Program: bAvstKr Print reconciliation AR - GL

    Program: bAvstLr Print reconciliation AP - GL

    Program: bhbrb Print income statement and balance sheet

    Program: bVrChk Run check of incorrect vouchers

    Program: bVrRemh Posting periodic vouchers

    Program: Per Periods

    Program: PerBE VAT/tax reporting periods

    Program: rCKusPer Create statistics, customer + period

    Program: tPer Tax reporting


Permission status (xmed)

Table of the different permission statuses defined in the customer table (Kus) and used when permission files for direct debit payments are created.

The following standard records exist. Do not alter/delete:

Permission status (MedgivStatus) | Description (Beskrivning)
0 | 0 - No permission
1 | 1 - Permission
2 | 2 - Canceled permission

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Permission status | MedgivStatus | ztInteger | 1 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xXmed Permission status


Person's group (prg)

Table that shows of which group(s) a person is a member .

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Dept/grp | avdgrupp | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: prg Person's dept/group


Personal characteristic 1 (xpp1)

Definition of personal characteristics for grouping/classification of external contact persons. You can make up to 3 similar groupings/classifications (there are 3 tables for this purpose). Example of usage: information on what mailings the person is included in, personal interests, etc. You can change field prompts and titles to describe the current characteristic.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Contact characteristic 1 | Persegd1 | ztString | 30 |  | varchar
Contact characteristic 1 | Persegk1 | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xpp1 Personal characteristic 1


Personal characteristic 2 (xpp2)

Definition of personal characteristics for grouping/classification of external contact persons. You can make up to 3 similar groupings/classifications (there are 3 tables for this purpose). Example of usage: information on what mailings the person is included in, personal interests, etc. You can change field prompts and list headings to describe the current characteristic.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Contact characteristic 2 | Persegd2 | ztString | 30 |  | varchar
Contact characteristic 2 | Persegk2 | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xpp2 Personal characteristic 2


Personal characteristic 3 (xpp3)

Definition of personal characteristics for grouping/classification of external contacts. You can make up to 3 similar groupings/classifications (there are 3 tables for this purpose). Example of usage: information on what mailings the person is included in, personal interests, etc. You can change field prompts and list headings to describe the current characteristic.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Contact characteristic 3 | Persegd3 | ztString | 30 |  | varchar
Contact characteristic 3 | Persegk3 | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xpp3 Personal characteristic 3


Personnel categories (xtp)

Table in which all personnel categories are stored that are used for reporting events. The service price list can be activated by category.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Personnel category | Perskatbeskr | ztString | 30 |  | varchar
Personnel category | Perskategori | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xtp Personnel categories


Personnel categories language (xtps)

Language translations of descriptions of personnel categories.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Personnel category | Perskatbeskr | ztString | 30 |  | varchar
Personnel category | Perskategori | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint


PG payee codes (xpgm)

Definition of payee codes that can be used for outgoing payments via plus giro.

Specify the payee code for the supplier in the Supplier table, Foreign payments node.

The following standard records exist. Do not alter/delete:

Recip code int'l (PgUtlMottagarkod) | Recip code int'l (PgUtlMottagarkodBeskr)
1 | Normal
2 | Express (Swift)
5 | Express (giro)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Recip code int'l | PgUtlMottagarkod | ztchar | 1 |  | char
Recip code int'l | PgUtlMottagarkodBeskr | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xpgm PG payee code


PG payment methods (xpgb)

Definition of outgoing payment methods that can be used for outgoing payments via postal giro.

Enter a payment method for foreign payments for the supplier in the supplier table, "Foreign payments" node.

The following standard records exist. Do not alter/delete:

Payment method int'l (PgUtlBetalningsSatt) | Payment method int'l (PgUtlBetalningsSattBeskr)
0 | Swift (to bank account)
4 | Giro (to Postal Giro account)
9 | Check

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Payment method int'l | PgUtlBetalningsSatt | ztchar | 1 |  | char
Payment method int'l | PgUtlBetalningsSattBeskr | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xpgb Payment methods, localized payments


Physical inventory history (invh)

History table for all inventory transactions regardless of status, i.e. unupdated, balance updated and transferred to General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Quantity | Antal | ZtQty | 14 | 2 | decimal
No. of rows | AntalRader | ZtLong | 10 |  | int
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Purchase price | BestInPris | ZtBaseCurrAmount | 14 | 2 | money
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Physical inventory | InvAntal | ZtQty | 14 | 2 | decimal
Physical invtry date | InventeringsDatum | ztDate |  |  | datetime
Phys invtry journ no. | InvJournal | ZtLong | 5 |  | int
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Balance updated | LagerUppdatering | ztBoolean |  |  | char
Inv diff amount | LagInvDiffVarde | ZtBaseCurrAmount | 14 | 2 | money
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Invtry balance, alt unit | LagsaldoAltEnh | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Quantity, alt unit (+/-) | LagtransAntAltEnh | ZtQty | 14 | 2 | decimal
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Error msg from matrix | PvmErrMessage | ztBlob | 2000 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: Invh Physical invtry hist/bin


Physical inventory journal header (invj)

Data in the physical inventory journal header.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Physical invtry date | InventeringsDatum | ztDate |  |  | datetime
Phys invtry journ no. | InvJournal | ZtLong | 5 |  | int
Journal closed | InvJournLocked | ztBoolean |  |  | char
Invtry trans date | LagerDatum | ztDate |  |  | datetime
Balance updated | LagerUppdatering | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Transaction date | LagTransDatum | ztDate |  |  | datetime
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: xInvj Physical inventory journal

    Program: xInvjR Enter physical inventory result


Physical inventory->GL (livt)

Detailed information per item of how physical inventories are posted when integrated to the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Phys invtry journ no. | InvJournal | ZtLong | 5 |  | int
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: livt Show physical inventory posting


Physical inventory/bin/batch/SN (invr)

Physical inventory result with information about in which bin an item is located, inventory balance, batch number (lots) and serial number.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Physical inventory | InvAntal | ZtQty | 14 | 2 | decimal
Phys invtry journ no. | InvJournal | ZtLong | 5 |  | int
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Quantity, alt unit (+/-) | LagtransAntAltEnh | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar

    This table is the main table in the following programs:

    Program: Invr Physical inventory history/details


Pick, task (WMS_V_MU_PallPickLine)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
X pos, from | AssFromLocXPos | ztString | 5 |  | varchar
Y pos, from | AssFromLocYPos | ztString | 5 |  | varchar
MHA, from | AssFromMha | ztString | 5 |  | varchar
Rack, from | AssFromRack | ztString | 5 |  | varchar
ID | AssId | ZtLong | 9 |  | int
Batch no. | BatchId | ztString | 30 |  | varchar
Check digits | CheckSum | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Location search no. | LocSortKey | ZtLong | 10 |  | int
Sequence | MhaPickQueueSeq | ztInteger | 3 |  | smallint
Mobile unit | MobileUnit | ztString | 5 |  | varchar
Picked qty | PickedQty | ZtQty | 14 | 2 | decimal
Verify TU | PickedTUPalletId | ztString | 35 |  | varchar
Remaining qty, SKU | RemainingQty | ZtQty | 14 | 2 | decimal
SKU ID | SKUPalletId | ztString | 35 |  | varchar
Qty, SKU | SKUQty | ZtQty | 14 | 2 | decimal
ID | TaskIId | ZtLong | 9 |  | int
TU ID | TUPalletId | ztString | 35 |  | varchar
Pallet unit type | TUPalletUnitType | ztString | 5 |  | varchar
Qty, TU | TUQty | ZtQty | 14 | 2 | decimal
Unit code | UOM | ztString | 10 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_MU_PallPickLine Pick, task


Picked order details (Oru)

Picking/inventory issue for a customer order.
If several bins per item or serial number, batch number/lots are processed, several records are created per inventory issue.
Picking transactions update, among other things:
- the order row (reserved quantity, picked value)
- item balance (inventory balance, total field for reservations, latest picking date, number of picking transactions)
- batch (inventory balance)
- batch/bin (inventory balance)
- bin (bin balance)
- inventory transaction history The picking is posted via a program for the posting of picking.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting complete | AccountingDone | ztBoolean |  |  | char
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Bin | ars_LagPlats | ztBinLocation | 20 |  | varchar
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtkalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Calc cost price | ArtKalkPris | ZtBaseCurrAmount | 14 | 2 | money
Cost price at order | ArtKalkPrisO | ZtBaseCurrAmount | 14 | 2 | money
This field is used in the table as follows: |
Cost at order (mtrl) | ArtKalkPrisOMtrl | ZtBaseCurrAmount | 14 | 2 | money
Value acc to calculated cost | ArtKalkPrisVarde | ZtBaseCurrAmount | 14 | 2 | money
Average cost price | ArtKalkSnitt | ZtBaseCurrAmount | 14 | 2 | money
Value acc to average cost | ArtKalkSnittVarde | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Aut inlev av TO vid utplock | AutDelivOU_MO | ztInteger | 5 |  | smallint
Use/Best before | BastForeDatum | ztDate |  |  | datetime
Batch no. required | BatchBokas | ztBoolean |  |  | char
Batch no. | BatchId | ztString | 30 |  | varchar
Batch no. (multi fifo) | BatchId_Multi_Str | ztString | 255 |  | varchar
Purchase price | BestInPris | ZtBaseCurrAmount | 14 | 2 | money
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
Booked qty pick in WMS | BookedQtyToPickInWMS | ZtQty | 14 | 2 | decimal
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Overhead cost. | CMF_Palagg | ZtBaseCurrAmount | 14 | 2 | money
CO return from WMS | CodeRestoredFromWMS | ztBoolean |  |  | char
Restored ORU trans | CodeRestoredORU | ztBoolean |  |  | char
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Delivery from business unit ICT | DelivFromBusinessUnit | ztString | 8 |  | varchar
Delivery to business unit | DelivToBusinessUnit | ztString | 8 |  | varchar
Direct issue | DirektUttag | ztBoolean |  |  | char
Document ID | docnumid | ztString | 30 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
RowNo. | FaktRadNr | ztInteger | 4 |  | int
Delivery note/disp no. | FfhNr | ZtLong | 10 |  | int
RowNo | FfhRadNr | ztInteger | 5 |  | int
Consumables | ForbrukningsMaterial | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Delivery note no. | FsNr | ZtLong | 10 |  | int
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Base value markup | GO_Palagg | ZtBaseCurrAmount | 14 | 2 | money
From backorder no. ICT | ICTDelivFromBackOrderNo | ztInteger | 5 |  | smallint
From order no. ICT | ICTDelivFromOrderNo | ZtLong | 10 |  | int
From order row no. ICT | ICTDelivFromOrdLnNo | ztInteger | 5 |  | smallint
From order row no. for pkg ICT | ICTDelivFromOrdSubLnNo | ztInteger | 5 |  | smallint
Backorder.no. ICT | ICTDelivToPOBackOrderNo | ztInteger | 5 |  | smallint
Purchase order row no. ICT | ICTDelivToPOLnNo | ztInteger | 5 |  | smallint
Purchase order no. ICT | ICTDelivToPONo | ZtLong | 10 |  | int
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location WMS | InventoryLocWMS | ztBoolean |  |  | char
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
To be posted | Konteras | ztBoolean |  |  | char
Corr reserv qty | KorrAntalUt | ZtQty | 14 | 2 | decimal
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
To disp alt unit, blocked | LevAntalAltEnhSparrat | ZtQty | 14 | 2 | decimal
To dispatch, blocked | LevAntalSparrat | ZtQty | 14 | 2 | decimal
Dispatch notice | LevAviNr | ztString | 35 |  | varchar
Dispatch notice row | LevAviRadNr | ztInteger | 5 |  | int
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Invtry trans journal no. | LthJournNr | ZtLong | 6 |  | int
Cancel remain qty | MakuleraRestAntal | ztBoolean |  |  | char
Slutleverans | MarkOmSlutleverans | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Actual material cost | MtrlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (refinement) | MtrlVerklKostForadling | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (adjust) | MtrlVerklKostJustering | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (mtrl) | MtrlVerklKostMtrl | ZtBaseCurrAmount | 14 | 2 | money
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Order row qty, alt unit | OrdAntalAltEnh | ZtQty | 14 | 2 | decimal
Request disp date | OrdBegLevDat | ztDate |  |  | datetime
Preparation day | OrdBerednDat | ztDate |  |  | datetime
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order no. (alpha) | OrderNrAlfa | ztString | 50 |  | varchar
Delivery note no. | OrdFoljesedelsNr | ZtLong | 10 |  | int
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Dispatch qty alt unit | OrdLevAntalAltEnh | ZtQty | 14 | 2 | decimal
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Picking journal no. | OruJournNr | ZtLong | 10 |  | int
Excess delivery>customer | OverDelivToCustomer | ztBoolean |  |  | char
Package item | PaketArtikel | ztBoolean |  |  | char
Packing credit | PaketKreditering | ztBoolean |  |  | char
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Picking index for order | PlockIndexOrder | ZtLong | 10 |  | int
Picking list no. | PlockJnrOrder | ZtLong | 10 |  | int
Preliminary revenue at dsptch | PrelFaktVardeUtlev | ZtBaseCurrAmount | 14 | 2 | money
Doc. printed | printed | ztBoolean |  |  | char
Project ID | ProjCode | ztString | 10 |  | varchar
Product variant management Row | PvmRowIsPvm | ztInteger | 3 |  | smallint
Extra overhead cost | q_ALFA_EO_Palagg | ZtBaseCurrAmount | 14 | 2 | money
Extra overhead cost | q_ALFA_EO2_Palagg | ZtBaseCurrAmount | 14 | 2 | money
Base value markup 2 | q_ALFA_GO2_Palagg | ZtBaseCurrAmount | 14 | 2 | money
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Registr.datum | RegDatInt | ZtLong | 8 |  | int
Entry time | RegTime | ztTime | 5 |  | datetime
Reg Tid | RegTimeInt | ZtLong | 8 |  | int
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Joint pick list No. | SamplocklisteNr | ZtLong | 6 |  | int
Joint picking, running no | SamplockLopNr | ztInteger | 5 |  | int
Shipment plan alpha ID | ShipmPlanAlphaid | ztString | 30 |  | varchar
Create delivery note | SkapaFoljesedel | ztBoolean |  |  | char
Skrivskydd | SkrivUtskSk | ztBoolean |  |  | char
SO item overhead cost | SOItemOverheadCost | ZtBaseCurrAmount | 14 | 2 | money
Time sqlcmd->trg start | SQLCmd2EnterTrg | ZtLong | 10 |  | int
Start av updatering/insert | SqlStmtStartedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Transferred to TA | TA_Transf | ztBoolean |  |  | char
To bin no. | TillLagPlats | ztBinLocation | 20 |  | varchar
Print on delivery note | UtskrFoljeSedel | ztBoolean |  |  | char
Currency | ValKod | ztString | 3 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Price, curr | Vb_Pris | ZtSalesPrice | 12 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: oru Show picked orders

    Program: Oru2GL Picked orders->GL


Picking list, order rows (kplo)

Picking list row for a picking list journal.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Quantity on picking list | AntalPaPlocklista | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Picked quantity | FfhLevAntal | ZtQty | 14 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Cancel remain qty | MakuleraRestAntal | ztBoolean |  |  | char
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Picking list no. | PlockJnrOrder | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Item group | VaruGruppKod | ztString | 8 |  | varchar


Picking queue (WMS_V_PickQueue)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Assignments | Assignments | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Queue | Queue | ztString | 5 |  | varchar
Description | QueueDesc | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Picking transaction journal header (joru)

Data in the journal header of inventory transactions from the order routine, i.e. issues for customer orders.
A journal only includes data of picking for one day, which is why one journal a day is normally created (several journals a day can however be created).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Picking journal no. | OruJournNr | ZtLong | 10 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: xJoru Picking journal, orders


Placement information for fixed assets (view) (vintPlacering)

Alphanumerical code for location of fixed asset.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Location | intPlaceringBeskr | ztString | 60 |  | varchar
Location | intPlaceringKod | ztString | 10 |  | varchar

    This table is the main table in the following programs:

    Program: vintPlacering View placement info


Planned activities (hr)

Table of planned activities. This table is used differently in different modules in Jeeves, e.g. in the project module for storing planned project activities, in the marketing module for storing planned marketing activities and also messages.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Subproject | Aktivitet | ztInteger | 4 |  | smallint
Activity status | Aktstatus | ztInteger | 5 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Work group | ArbetsLag | ztString | 6 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Auto connect | AutoConnect | ztBoolean |  |  | char
Interruption status | Avbcode | ztString | 3 |  | varchar
Belong sign | BelongSign | ztBoolean |  |  | char
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Activity must be closed | EventAvslutsKrav | ztBoolean |  |  | char
Planned activity | EventKod1 | ztInteger | 3 |  | smallint
Planned activity descr | EventNote | ztString | 60 |  | varchar
Activity no. | EventNr | ZtLong | 8 |  | int
Planned date | EventPlDat | ztDate |  |  | datetime
Planned time | EventPlTime | ztTime | 5 |  | datetime
Start date | EventStartDat | ztDate |  |  | datetime
Start time | EventSTartTime | ztTime | 5 |  | datetime
Hours | EventTimant2 | ztHourWithDecimals | 8 | 2 | decimal
To be invoiced | Faktureras | ztBoolean |  |  | char
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Grafiskt tecken | Hrblock | ztchar | 1 |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Est hourly cost | kalkkostMantim | ZtBaseCurrAmount | 14 | 2 | money
Campaign | kampnr | ZtLong | 4 |  | int
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Receipt date | KvittDatum | ztDate |  |  | datetime
Sequence no. | LopNr | ZtLong | 10 |  | int
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Personal no. | PersSignNr | ztInteger | 3 |  | smallint
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Planning ID | PlanId | ztString | 10 |  | varchar
Est finish date | PlannedEndDate | ztDate |  |  | datetime
Planned final time | PlannedEndTime | ztTime | 5 |  | datetime
Activity finished | PlanUtford | ztBoolean |  |  | char
Promised date | PrjLovLevDat | ztDate |  |  | datetime
Project ID | ProjCode | ztString | 10 |  | varchar
Project priority | ProjectPriority | ZtLong | 10 |  | int
Remaining time | projkvartid | ztFloat | 10 | 2 | float
Time accrued | projnerltid | ztFloat | 10 | 2 | float
Revised end date | Projrevenddat | ztDate |  |  | datetime
Revised start date | Projrevstartdat | ztDate |  |  | datetime
Business opportunity ID | ProspektId | ZtLong | 10 |  | int
Row | RadPos | ZtLong | 10 |  | int
Row | radpos2 | ztInteger | 4 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Entry time | regtime | ztTime | 5 |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sender | Sender | ztString | 4 |  | varchar
Exported to Outlook | sent_2_Outl_cal | ztBoolean |  |  | char
Date/time | StrDateTime | ztString | 28 |  | varchar
Time type | TidKod | ztInteger | 5 |  | smallint
Service | TjKod | ztInteger | 4 |  | smallint
Sector | verksamhet | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: FMail Received messages

    Program: hr Planned activities (to do)

    Program: HrAll Planned activities (all)

    Program: Mail Create message

    Program: mhr To do, CRM

    Program: THr Own To-do list

    Program: ToDo To-do list (not time planned)


Planned activities for claim (ClaimPlannedActivities)

Planned activities for claim.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Final report by | ClaimActEndBy | ztString | 30 |  | varchar
Actual finish date | ClaimActEndDt | ztDate |  |  | datetime
Activity description | ClaimActivityDescr | ztString | 255 |  | varchar
Activity status | ClaimActivityStatus | ztInteger | 4 |  | smallint
Auto-update status when finished | ClaimAutoUpdStatWhenFinished | ztBoolean |  |  | char
Dummy activity | ClaimDummyActivity | ztBoolean |  |  | char
Claim | ClaimNo | ZtLong | 10 |  | int
Planned finish date | ClaimPlEndDt | ztDate |  |  | datetime
Previous finished at rep | ClaimPrevLineChkFinished | ztBoolean |  |  | char
Claim manager | ClaimResp | ztString | 8 |  | varchar
Claim type | ClaimSrcType | ztInteger | 5 |  | smallint
Ready after number of days | ClaimStepNoDays | ztInteger | 5 |  | smallint
Activity order | ClaimWFSeqNo | ztInteger | 5 |  | smallint
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Poka Yoke | PokaYoke | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ClaimPlannedActivities Planned activities for claim


Planned activities per status (xg1hr)

Table of planned activities that can be auto-created for different statuses for business opportunities.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Activity must be closed | EventAvslutsKrav | ztBoolean |  |  | char
Planned activity | eventkod1 | ztInteger | 3 |  | smallint
Planned activity descr | eventnote | ztString | 60 |  | varchar
Number of days until start | EventPlanStartFrIdag | ztInteger | 5 |  | smallint
Hours | eventtimant2 | ztHourWithDecimals | 8 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Jvs_Internal_LDDL_ID | Jvs_Internal_LDDL_ID | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Status code | ProspStatKod | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | sqlidentity | ZtLong | 10 |  | int
Identity | SQLIDENTITY_orig | ZtLong | 10 |  | int


Planned service activities (xas)

Definition of activities that can be planned on service orders. Only types of events are entered here. You can further specify each activity during planning in the field for notes or the ‘Edit’ field.

No standard records exist in the table. Planned events must be defined by the user.

NOTE. If you intend to invoice via the assignment routine, the codes for planned service activities must conform with corresponding codes in the assignment routine (program ‘Definition of planned activities’ (xxa)).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Planned activity | EventBeskr | ztString | 50 |  | varchar
Planned activity | EventKod1 | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xas Planned service activities


PLANNING door area (warehouse area) (pytp)

Planning of gate space or area in an inventory location belonging to a "gate".
The times planned for deliveries to/from a gate are specified here.
*** NOT IN USE ***

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Delivery note/disp no. | FfhNr | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Gate | Port | ztString | 6 |  | varchar
Gate area | PortYta | ztString | 6 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
ID number | X_IdNr | ZtLong | 10 |  | int


Planning manager (pans)

Planning manager.
Items can be linked to the planning manager.
Acquisition proposals and manufacturing orders can be selected under the planning manager.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Planning manager | PlanAnsvBeskr | ztString | 40 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Update status | Upd_amasestatus | ztBoolean |  |  | char
Update order point | Upd_Bestp | ztBoolean |  |  | char
Update EOQ | Upd_EOK | ztBoolean |  |  | char
Update forecast model | Upd_fcmodel | ztBoolean |  |  | char
Update lead time | Upd_LedTid | ztBoolean |  |  | char
Update phase | Upd_phase | ztBoolean |  |  | char
Update safety level | Upd_SecLag | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: Arsu Planning manager update EOQ, OP, SS, Lead time->item

    Program: pans Plan.responsible, assignment req->PO


Pmt reminder batch/cust (kfhk)

Data on completed reminder batches per customer.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Average credit time | AvgCreditDays | ZtLong | 10 |  | int
Rest to pay collection | BasFaktRestInkasso | ZtBaseCurrAmount | 14 | 2 | money
Rest to pay claim 1 | BasFaktRestK1 | ZtBaseCurrAmount | 14 | 2 | money
Rest to pay claim 2 | BasFaktRestK2 | ZtBaseCurrAmount | 14 | 2 | money
Rest to pay claim 3 | BasFaktRestK3 | ZtBaseCurrAmount | 14 | 2 | money
Rest to pay claim 4 | BasFaktRestK4 | ZtBaseCurrAmount | 14 | 2 | money
Due % | DueAmountPerc | ZtDecimal73 | 8 | 2 | decimal
eBrev sent | ebFilSent | ztBoolean |  |  | char
eBrev file sent date | ebFilSentDt | ztDateTime |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Reminder journal batch no. | JFhkNr | ztInteger | 4 |  | smallint
No. of reminders | KravAnt | ztInteger | 1 |  | smallint
Reminder text | KravText | ztBlob | 1 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Amount not due | KundEjForfBel | ztMoney | 14 | 2 | money
Amount due | KundForfBel | ztMoney | 14 | 2 | money
Under inquiry | KundUtredBel | ztMoney | 14 | 2 | money
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
demand 1 - % of SupLdgrBal | ReminderPerc1 | ZtDecimal73 | 8 | 2 | decimal
demand 2 - % of SupLdgrBal | ReminderPerc2 | ZtDecimal73 | 8 | 2 | decimal
demand 3 - % of SupLdgrBal | ReminderPerc3 | ZtDecimal73 | 8 | 2 | decimal
demand 4 - % of SupLdgrBal | ReminderPerc4 | ZtDecimal73 | 8 | 2 | decimal
Remaining to pay | RestBelFakt | ZtBaseCurrAmount | 14 | 2 | money
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Interest amount | RtaBelopp | ZtBaseCurrAmount | 14 | 2 | money
Language | SprakKod | ztInteger | 3 |  | smallint
Print payment reminder | UtskrInkasso | ztBoolean |  |  | char
Print account statement | UtskrKontoUtdrag | ztBoolean |  |  | char
Print reminder | UtskrKravBrev | ztBoolean |  |  | char
Currency | ValKod | ztString | 3 |  | varchar
Interest amount curr | ValRtaBelopp | ztMoney | 14 | 2 | money
Outst invc amt, curr | VbFaktRest | ztMoney | 14 | 2 | money
Rest to pay claim 1 | VbFaktRestK1 | ztMoney | 14 | 2 | money
Rest to pay claim 2 | VbFaktRestK2 | ztMoney | 14 | 2 | money
Rest to pay claim 3 | VbFaktRestK3 | ztMoney | 14 | 2 | money
Rest to pay claim 4 | VbFaktRestK4 | ztMoney | 14 | 2 | money
Remaining for collection | VbFaktRestKI | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: xKfhk Payment reminders by customer


PO status (xl)

Table of different purchase order statuses used to determine the stage of processing of a purchase order.

The following standard records exist. Do not alter/delete:

PO status (BestStatKod) | PO status (BestStatBeskr)
0 | RFQ
10 | Approved
20 | Ordered
22 | Pending
23 | Sent to Astro
25 | Order acknowledged
30 | Goods in transit
33 | Goods received
40 | Partially delivered
70 | Delivered
75 | Delivered, inv. match, not posted
80 | Delivered, inv.match, posted
90 | Cancelled

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
PO status | BestStatBeskr | ztString | 50 |  | varchar
PO status | BestStatKod | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxl PO status


PO types (xbb)

Definition of purchase order types that control how purchase orders is to be processed in Jeeves. Please note that the codes of order types that come with Jeeves must not be changed, while the texts, however, may be changed.

Customer-specific purchase order types
----------------------------
In addition to the standard order types supplied with Jeeves, you can also define your own purchase order types based on the existing ones. When creating your own purchase order types, these should be entered at a higher number, suitably at numbers 90-99.

The following standard records exist. Do not alter/delete:

PO type (BestTyp) | PO type (BestTypBeskr) | Description
0 | Inventory order | Inventory order means purchasing items to your own inventory, i.e. the inventory balance, etc., is updated. The type is also used to order goods that are not stocked, e.g. items with the consumables inventory stock type.
10 | Drop shipment (to customer) | You use the order type when goods are sold but NOT from own inventory without a purchase order being created for a supplier who sends the goods directly to the customer. Inventory balances are not affected. Purchase orders that are created automatically from customer orders with the 'Drop ship' order type are given this PO type.
11 | Transit (via inventory) | A variant of drop shipment in which the items are always purchased from a supplier for a customer order, but the goods are shipped through our own inventory. Processing is then more like normal orders except that picking never needs to be done. Delivery automatically generates a dispatch on the customer order.
15 | Order-specific inventory | Upon dispatch the goods are placed in an inventory linked to a customer/manufacturing order (order-specific inventory). From this order-specific inventory, items can be picked for the customer/manufacturing order. For customer orders, if any non-picked goods remain in the order-specific inventory when the order is released, they are automatically picked (from version 6 you can decide whether this is done via a control code in the system table). An order-specific inventory is useful when the goods have a high value and remain in stock a while before being shipped to the customer. There are programs and lists that show the value of the order unique stock.
20 | Forecast purchase order | A preliminary purchase order that is sent to the supplier but refers to deliveries farther into the future (beyond suborder date, suborder...)
33 | Subcontract flag | Refers to purchasing of labour for an operation in a manufacturing order. Instead of performing the labour in own shop, the labour is purchased.
40 | Advance purchase, MO | A purchase order type used when you know in advance that a certain material with a long delivery time must be used in a manufacturing order. Preparation/design may not be ready, but you know that certain critical material/components will be used (order-specific). The purchase order row or rows that are entered must be flagged with manufacturing order number so that a link can later be made (suborder number and operation number are left blank, but are reset to 0 when the purchase order row is saved). When you later create a manufacturing order with corresponding material reservations and press the function button to create order-specific purchase orders, the material is primarily linked to advance purchase. If no such purchase exists, purchase orders or purchase requisitions are created.
60 | Transfer between inventory loc |
70 | Stock replenishment ICT | Purchase order type is used for internal stock replenishment to the own business unit from another supplying business unit (internal company/inventory location) by using the functionality for Inter Company Transactions (ICT). This means that a purchase order is entered at the business unit where the stock is to be replenished, and a customer order is automatically created from the purchase order at the business unit to supply the goods for replenishment. Customer/purchase orders of this type require a company ID that is flagged as an internal company, when you enter the supplier ID on the replenishment purchase order at the own business unit, and also for the customer ID used on the customer order that is automatically created at the supplying business unit.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
PO type | BestTyp | ztInteger | 3 |  | smallint
PO type | BestTypBeskr | ztString | 50 |  | varchar
Drop ship | DirektLeverans | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Förköp till kundorder | ForKop_Oh | ztBoolean |  |  | char
Advance booking | ForKop_Th | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase forecast (suborder) | InkopsPrognos | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Intrastat trans type | IntStatTransTyp | ztInteger | 2 |  | smallint
Posting per invtry location | KonterasEnlLagStalle | ztString | 2 |  | varchar
Inventory transfer | LagerFlyttning | ztBoolean |  |  | char
Value to price | LagerVardeEnlInPris | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Cancel remain qty | MakuleraRestAntal | ztBoolean |  |  | char
Manual order entry | ManRegBestKod | ztBoolean |  |  | char
Manual purch order no. | ManRegBestNr | ztBoolean |  |  | char
Subcontract flag | MarkLego | ztBoolean |  |  | char
Dispatch plan | MarkLevPlanUt | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Excess delivery>customer | OverDelivToCustomer | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Entry inventory, CC | RegLager | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Stock replenishment ICT | StockReplenishment | ztBoolean |  |  | char
Transit delivery | TransitLeverans | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xXbb PO types


PO types, number series (xbbn)

Purchase order number series for purchase order types.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
PO type | BestTyp | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
From our PO no. | FromBestNr | ZtLong | 6 |  | int
From disp. plan no. | FromLevPlanNr | ZtLong | 6 |  | int
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Disp.plan number | LevPlanNr | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
To our PO no. | TomBestNr | ZtLong | 6 |  | int
To disp plan no. | TomLevPlanNr | ZtLong | 6 |  | int


PO/receiving journal header (jbpi)

Data in the header of the integration batch of received deliveries from purchase orders for inventory.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Delivery received date | BestLevDat | ztDate |  |  | datetime
Accounting date | BokfDat | ztDate |  |  | datetime
PO/receiving journal no. | BpiJournNr | ZtLong | 10 |  | int
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Receiving value | InlevKalkVarde | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Cost | RedovisnRadKostnad | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Transfer date | VtVrUpDat | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: xJbpi Receiving journal POs


Point of delivery, view (vlp)

Definition of different points of delivery for a customer. This can be used for delivery addresses, end-customers, or the like.

First, enter general company data for points of delivery in the company table. Then connect these to customers in this program/table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Point of delivery, name | OrdLevPlBeskr | ztString | 36 |  | varchar


Pointage rows (vxpd)

Table of flagged voucher rows. See the description of the Flag voucher rows (Vxpo) program for more information.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Note date | Date_of_bank_notification | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Journal# | Point_JournNo | ZtLong | 9 |  | int
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Flag text | vr_Pointage | ztString | 255 |  | varchar


Positions (X5)

Definition of positions you can use for grouping/querying contacts at suppliers, customers, companies in the marketing module, etc. according to your own wishes.

Special function in the Purchasing module: Position code "x" refers to the document recipient shown as the supplier's reference on the purchase order form.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Position | BefattBeskr | ztString | 50 |  | varchar
Position | BefattKod | ztString | 2 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: XX5 Positions


Post delivery between units (frkl)

Post delivery between units.
In this table you define the posting rules when transferring items between own units.
Each unit can have its own database with basic data and an individual chart of accounts. This can be used in Jeeves when items are manufactured in one unit and sold by a different unit where no invoicing is done, i.e. only journal vouchers are made.

The company number is registered on the manufacturing order for the unit that will receive the delivery. The received delivery from the manufacturing order is then posted to the account for the receiving unit.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Integration detail | AccountDelivCode | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: frkl Post delivery between units


Postal Giro payment files (lrpg)

Created postal giro payment files.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
100 chars fixed | char100 | ztchar | 100 |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Row | RadPos | ZtLong | 10 |  | int
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int


Posting journal (fvtj)

Journal for the transfer of appendices to the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
JournalNo. | BilagJournNr | ZtLong | 7 |  | int
Transferred | BilagsJournStat | ztBoolean |  |  | char
Journal text | BilagsText | ztString | 255 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: fvtj Posting journal


Posting journal/incoming journal (fvtr)

Appendix included in the journal when transferring to the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
JournalNo. | BilagJournNr | ZtLong | 7 |  | int
Journal no. | BilagsNr | Jeeves_VchrNo | 9 |  | bigint
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Posting method, supplier invoices (xra)

Definition of posting methods for supplier invoices. The posting method controls whether invoices will automatically be posted on receipt according to a posting template for the signature concerned and whether balance updating will be done online.

The following standard records exist. Do not alter/delete:

Posting method (KontRegKod) | Posting method (KontRegBeskr) | Description
0 | Manual posting | A new form opens for posting of the voucher rows. Using the "Automatic save" (Autospar) flag for the details in the posting template, you can govern whether the whole posting proposal will be created in one step or whether you want to approve the postings row by row.
1 | Automatic posting | The voucher is created in the background.
2 | Batch automatic posting | Posting is NOT performed on entry but in batches by running the "Automatic approval on entry" report.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Posting method | KontRegBeskr | ztString | 50 |  | varchar
Posting method | KontRegKod | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Auto balance update | SaldoOnLine | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: Xxra Posting method, supplier invoices


Posting of order (work table) (vo2p)

Table (work table) for analysis of all postings per customer order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
PO/receiving journal no. | BpiJournNr | ZtLong | 10 |  | int
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Posting date | HbUpDat | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration detail | IntFieldBeskr | ztString | 100 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Account type | KtoTyp | ztInteger | 3 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Preliminary voucher | OldVerNr | Jeeves_VchrNo | 9 |  | bigint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Picking journal no. | OruJournNr | ZtLong | 10 |  | int
Ord-spec jrnl no. | OulJournNr | ZtLong | 6 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Reference number | ReferensNr | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Closing balance | UtgSaldo | ZtBaseCurrAmount | 14 | 2 | money
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Voucher row text | VrVerText | ztString | 60 |  | varchar

    This table is the main table in the following programs:

    Program: vo2p Analysis of order posting


Posting payment routes (akuv)

Definition of the accounts in the General Ledger to be used for different AP payment routes, e.g. 1010 for Cash, 1020 for PG and 1040 for BG.
If no specification is given, the rules for the posting of payment method are used.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Integration detail | AkuTyp | ztInteger | 2 |  | smallint
Betalningsslag | BetSlag | ztString | 3 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Payment route | UtbetalningsVag | ztString | 6 |  | varchar


Posting rule on intsource (koxa6)

Dependending on intsource to decide where amount on voucher normaly is to be placed.(debbel or krebel).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Debit/credit | DebKre | ztchar | 1 |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Posting templates tax depreciations (inskAvsTK)

Definition of posting templates for tax depreciations, regarding over and under depreciations. One template must be defined per tax depreciation type..

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Tax depreciation type | inskAvsTypid | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S4 contra acct | K4Mot | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S5 contra acct | K5Mot | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S6 contra acct | K6Mot | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S7 contra acct | K7Mot | ztString | 8 |  | varchar
S3 contra acct | KBarMot | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
CC contra account | KstMot | ztString | 8 |  | varchar
Contra account | KtoMot | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Contra proj | ProjMot | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: inskAvsTK Posting templates, tax depreciations


Posting templates, GL revaluation (vwak02)

Definition of posting templates, headers (details/posting rows are in the AKD table) which are used to control posting of GL revaluation. The postings entered in the templates are proposed as default postings.

No standard records exist in this table. Fill in as needed.

If you add a posting template to this table using a program where you do not specify the customer/supplier category or equivalent, Jeeves fills in the category code 0 and tax code 0 automatically. These two codes must therefore be added to their respective tables.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval status | AttestKod1 | ztInteger | 1 |  | smallint
Posting template | AutoRegBeskr | ztString | 50 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Supplier category | levkategori | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Voucher text | VerText | ztString | 60 |  | varchar

    This table is the main table in the following programs:

    Program: vwak02 Posting templates, GL revaluation


Posting templates, head (vwak)

A view over (ak) posting templates, headers (details/posting rows are in the AKD table) which are used to control posting of incoming and outgoing payments. The postings entered in the templates are proposed as default postings during payment entry.

This table contains no standard records. Fill in as needed.

If you add a posting template to this table using a program where you do not specify the customer/supplier category or equivalent, Jeeves fills in the category code 0 and tax code 0 automatically. These two codes must therefore be added to their respective tables.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval status | AttestKod1 | ztInteger | 1 |  | smallint
Posting template | AutoRegBeskr | ztString | 50 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Supplier category | levkategori | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher text | VerText | ztString | 60 |  | varchar

    This table is the main table in the following programs:

    Program: vwakfd Distribution template/Interims

    Program: w


Posting templates, in/out pymt, header (vwak01)

(This is a view of the posting templates for incoming payments.)

Definition of posting templates, headers (details/posting rows are in the AKD table) which are used to control posting of supplier invoices, incoming and outgoing payments, etc. The postings entered in the templates are proposed as default postings.

No standard records exist in this table. Fill in as needed.

If you add a posting template to this table using a program where you do not specify the customer/supplier category or equivalent, Jeeves fills in the category code 0 and tax code 0 automatically. These two codes must therefore be added to their respective tables.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval status | AttestKod1 | ztInteger | 1 |  | smallint
Posting template | AutoRegBeskr | ztString | 50 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Supplier category | levkategori | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Voucher text | VerText | ztString | 60 |  | varchar

    This table is the main table in the following programs:

    Program: vwak01 Posting templates, incoming payments


Posting templates, in/out pymt, header (ak)

Definition of posting templates, headers (details/posting rows are in the AKD table) which are used to control posting of supplier invoices, incoming and outgoing payments, etc. The postings entered in the templates are proposed as default postings.

No standard records exist in this table. Fill in as needed.

If you add a posting template to this table using a program where you do not specify the customer/supplier category or equivalent, Jeeves fills in the category code 0 and tax code 0 automatically. These two codes must therefore be added to their respective tables.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval status | AttestKod1 | ztInteger | 1 |  | smallint
Posting template | AutoRegBeskr | ztString | 50 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Jvs_Internal_LDDL_ID | Jvs_Internal_LDDL_ID | ztString | 30 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Supplier category | levkategori | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Voucher text | VerText | ztString | 60 |  | varchar

    This table is the main table in the following programs:

    Program: akap Posting templates, AP revaluation

    Program: akar Posting templates, AR revaluation

    Program: akfd Allocation templates, interim posting

    Program: AkFromLr Posting templates, supplier invoices

    Program: akLr Posting templates, supplier invoices

    Program: aklru Posting templates, outgoing payments

    Program: Akont Posting templates, voucher entry

    Program: AKSB Allocation templates, fixed postings

    Program: alinb Posting templates, incoming payments


Posting templates, in/outg. pmts (aku)

Table of posting templates for incoming and outgoing payments, per fiscal year and incoming/outgoing payment methods.

Posting templates for incoming/outgoing payments can be set up in this table and/or in the table "Posting templates, incoming/outgoing payment details" (Akd). The way the postings are retrieved from these tables depends on the posting type (integration detail). This is described in detail in a separate chapter on posting of incoming and outgoing payments.

No templates are defined on delivery.

NOTE
---------------
For preliminary payments to be posted, this must be requested/selected in the AP system data.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Integration detail | AkuTyp | ztInteger | 2 |  | smallint
Betalningsslag | BetSlag | ztString | 3 |  | varchar
Amt not incl bank charge | EjMotBokBank | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Payment methods | UtbSlag | ztString | 3 |  | varchar
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: xAki Posting templates, incoming payment methods

    Program: xAku Posting templates, outgoing payment methods


Posting templates, inventory (aklt)

Definition of templates for posting of stock transactions, i.e. appropriate inventory issue account(s), CGS account(s), WIP account(s), account(s) for purchase costs and price differences, account(s) for manufacturing costs and overheads with any internal posting terms, per fiscal year and integration source.

If you do not need to allocate the inventory postings per transaction type, you use the default inventory transaction types 0, Default posting inventory or 180, Manual transactions (default). 180, Manual transactions (default).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Supplier category | levkategori | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowupdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
UniqueIDInAKLT | UniqueIDInAKLT | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: xAklt Posting templates, inventory


Posting templates, invoice details (AkFt)

Definition of templates for posting customer invoice rows, i.e. appropriate
- revenue account(s) on which the gross sales value is booked,
- account(s) for cost of sold items according to the item's cost price, except for drop ship when the purchase price applies,
- inventory issue account(s) for contra booking of CSG,
- order discount account(s) if a separate account is used, otherwise the order discount is booked on the revenue account.
and any internal posting terms, per fiscal year and integration source.

The accounts are obtained via the templates in the following order:
Product account	Customer category	Tax code	Posting template	Inventory location
(artprodkonto)	(kundkategorikod) 	(momskod)	(autoregel)		(lagstalle)
Filled in 	Filled in 		Filled in 	Filled in 		Filled in
Filled in 	Filled in 		Blank 		Filled in 		Filled in
Filled in 	Blank 			Filled in 	Filled in 		Filled in
Filled in 	Blank 			Blank 		Filled in 		Filled in
Filled in 	Filled in 		Filled in 	Filled in 		Blank
Filled in 	Filled in 		Blank 		Filled in 		Blank
Filled in 	Blank 			Filled in 	Filled in 		Blank
Filled in 	Blank 			Blank 		Filled in 		Blank
Blank		Filled in		Filled in	Filled in 		Filled in
Blank		Filled in		Blank		Filled in 		Filled in
Blank		Blank			Filled in	Filled in 		Filled in
Blank		Blank			Blank		Filled in 		Filled in
Blank		Filled in		Filled in	Filled in 		Blank
Blank		Filled in		Blank		Filled in 		Blank
Blank		Blank			Filled in	Filled in 		Blank
Blank		Blank			Blank		Filled in 		Blank
Filled in	Filled in		Filled in	Blank			Filled in
Filled in	Filled in		Blank		Blank			Filled in
Filled in	Blank			Filled in	Blank			Filled in
Filled in	Blank			Blank		Blank			Filled in
Filled in	Filled in		Filled in	Blank			Blank
Filled in	Filled in		Blank		Blank			Blank
Filled in	Blank			Filled in	Blank			Blank
Filled in	Blank			Blank		Blank			Blank
Blank		Filled in		Filled in	Blank			Filled in
Blank		Filled in		Blank		Blank			Filled in
Blank		Blank			Filled in	Blank			Filled in
Blank		Blank			Blank		Blank			Filled in
Blank		Filled in		Filled in	Blank			Blank
Blank		Filled in		Blank		Blank			Blank
Blank		Blank			Filled in	Blank			Blank
Blank		Blank			Blank		Blank			Blank
If there is no posting template, the inventory will be posted according to the items product account, the order rows inventory location and stock transaction type withdrawal customer order (see further Posting inventory transactions).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
UniqueIDInAKFT | UniqueIDInAKFT | ZtLong | 10 |  | int
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: xAkFt Posting templates, invoice details


Posting templates, invoice totals (AkFh)

Definition of templates for posting customer invoice totals, i.e. existing accounts receivable account(s), cash account(s), account(s) for output tax, rounding off-account, and any internal posting terms, per fiscal year and integration source.

In templates intended for use for cash sales, you specify a designation in the field 'Posting template' (auto-rule). You then specify the same designation for payment terms of the Cash type.

The accounts are obtained via the templates in the following order:
 Posting template	Customer category		Tax code
 (autoregel)		(kundkategorikod)		(momskod)
 Filled in		Filled in			Filled in
 Filled in		Filled in			Blank
 Filled in		Blank				Filled in
 Filled in		Blank				Blank
 Blank			Filled in			Filled in
 Blank			Filled in			Blank
 Blank			Blank				Filled in
 Blank			Blank				Blank
If you only use one accounts receivables account and one tax account, you can leave this field blank in the relevant template.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xAkFh Posting templates, invoice totals


Posting tmplts inv/inpt/outpt, details (akd)

Table of details in posting templates (the template headers are in the AK table) which are used to control posting of supplier invoices and incoming and outgoing payments. The postings entered in the templates are proposed as default postings during invoice and payment entry.

No standard records exist in this table. Fill in as needed.

If you add a posting template to this table using a program where you do not specify the customer/supplier category or equivalent, Jeeves fills in the category code 0 and tax code 0 automatically. These two codes must therefore be added to their respective tables.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval status | AttestKod1 | ztInteger | 1 |  | smallint
Posting template | AutoRegel | ztString | 4 |  | varchar
Automatic save | autospar | ztBoolean |  |  | char
Debit/credit | DebKre | ztchar | 1 |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Amount | FordBel | ZtBaseCurrAmount | 14 | 2 | money
Allocation percent | FordProc | ZtDecimal73 | 6 | 2 | decimal
Allocation rule | FordRegel | ztString | 3 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Transaction type | Foringskod | ztInteger | 3 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
S4 from invoice posting | KontK4 | ztBoolean |  |  | char
S5 from invoice posting | KontK5 | ztBoolean |  |  | char
S6 from invoice posting | KontK6 | ztBoolean |  |  | char
S7 from invoice posting | KontK7 | ztBoolean |  |  | char
S3 from invoice posting | KontKb | ztBoolean |  |  | char
S2 from invoice posting | KontKst | ztBoolean |  |  | char
Acct no from invoice posting | KontKtoNr | ztBoolean |  |  | char
Proj from invoice posting | KontPrj | ztBoolean |  |  | char
Note | KortNotering | ztString | 255 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Tax deduct acct | KtoNrAvrMoms | ztString | 8 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Supplier category | levkategori | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Tax code 0/4 | MomsKod0_4 | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Period/relative | PeriodRelativ | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
Voucher amount | VerBel | ZtBaseCurrAmount | 14 | 2 | money


PR companies (pubr)

Definition of PR company with contacts and planned and reported PR activities. The program/table is currently used only if there is a need to group/classify companies according to different PR types.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Form of PR | Pubreltype | ztInteger | 3 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: Pubr PR companies


PR types (pubK)

Definition of existing types of PR activities, e.g. Telemarketing, Advertising etc.

You add PR types only if there is a need to group/classify companies according to different PR types in the PR company (Pubr) program.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Form of PR | PubrelTBeskr | ztString | 50 |  | varchar
Form of PR | Pubreltype | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: pubK PR types


Predefined filter for MRP run (nefw)

Pre-settings for which items are to be processed in MRP are stored in this table.
Different pre-settings can be made for querying of:
- item number
- item group
- planning manager
- purchasing manager Searches in this field can be done with a wildcard or the like according to SQL standard.
There is also a field where you can freely enter queries according to SQL standard.
This table is used when MRP is started from the pre-settings program.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
MRP filter description | NE_Fw_Beskr | ztString | 60 |  | varchar
MRP filter ID | NE_Fw_Id | ztInteger | 5 |  | smallint
Where | NE_Where | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: nefw Predefined filter for MRP run


Prel labour operations (aorf)

Used to automatically adjust labour operations with regard to time.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Report auto setup time | AoRappStallTid_Aut | ztOpTime | 9 | 4 | float
Report man. setup time | AoRappStallTid_Man | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Rep auto run time | AoRappStyckTid_Aut | ztOpTime | 9 | 4 | float
Rep manual run time | AoRappStyckTid_Man | ztOpTime | 9 | 4 | float
Remaining to report | AoRestInnanRapp | ZtQty | 14 | 2 | decimal
Mfg journal no. | AorJournNr | ZtLong | 6 |  | int
Actual labour cost | ArbVerklArbKost | ZtBaseCurrAmount | 14 | 2 | money
Actual setup cost | ArbVerklStallKost | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
Subcontract price/unit | LegoPris | ZtBaseCurrAmount | 14 | 2 | money
Personnel/operation | OpBemanning | ztFloat | 6 | 3 | float
Operation no. | OpNr | ztInteger | 3 |  | int
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Activity finished | PlanUtford | ztBoolean |  |  | char
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Update all op | UpdatAvvik | ztBoolean |  |  | char
Shop price | VerkstadPris | ZtBaseCurrAmount | 14 | 2 | money
Tools | Verktyg | ztString | 16 |  | varchar
List of tools | Verktygslista | ztString | 35 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint


Prel/external budget items (brhp)

Preliminary budget transactions, normally loaded from an external system.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Budget batch no. | BudgetOmg | ZtLong | 10 |  | int
Budgettyp | Budgettabell | ztInteger | 3 |  | smallint
Budget text | budgettext | ztString | 60 |  | varchar
Budget item status | budgstat | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
Amount | FordBel | ZtBaseCurrAmount | 14 | 2 | money
Allocation curve | FordKurva | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | k4 | ztString | 8 |  | varchar
S5 | k5 | ztString | 8 |  | varchar
S6 | k6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
Shortcut | KortKodVerRad | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Sequence no. | LopNr | ZtLong | 10 |  | int
Not shown in list Window | NotShowninListWin | ztBoolean |  |  | char
OLE-1 | ole1 | ztString | 255 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Revision | Revision | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: brhp Preliminary budget


Prelim invc row template (muft)

Rows in the template for periodic invoicing of assignments (portrait invoice). This template specifies what will be invoiced. Another template specifies in which periods the periodic invoicing will be performed.

See the chapter on periodic invoicing and on posting of assignment invoices for more information.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Add on date | AddOnDate | ztDate |  |  | datetime
Add on invoice | AddOnInvoice | ztBoolean |  |  | char
Part to invoice | AddOnPart | ztInteger | 5 |  | smallint
Active | Aktiv | ztInteger | 1 |  | smallint
Item no. | artnr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Item serial no. | artserienr | ztString | 30 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Posting template per cost | AutoRegelK | ztString | 4 |  | varchar
District | DistrKod | ztString | 4 |  | varchar
Division code | Diviskod | ztString | 3 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Shipped invc qty | FaktLevAnt | ZtQty | 14 | 2 | decimal
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
CSG invc row | FaktRadKost | ZtBaseCurrAmount | 14 | 2 | money
Kost (budg) varor | FaktRadKostBudg | ZtBaseCurrAmount | 14 | 2 | money
RowNo. | FaktRadnr | ztInteger | 4 |  | int
Invc row discount % | FaktRadRab | ztFloat | 8 | 2 | float
Invc row discount | FaktRadRabSumma | ZtBaseCurrAmount | 14 | 2 | money
Invc row amount | FaktRadSumma | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, BCU | FPris | ZtBaseCurrAmount | 14 | 2 | money
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit percentage | KreditProcent | ztFloat | 15 | 2 | float
Account | Ktonr | ztString | 8 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Inventory location | LagStalle | ztString | 2 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Markup % | Palagg | ztFloat | 5 | 2 | float
Period | period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Pricing type | PrisHantTyp | ztInteger | 3 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Language | Sprakkod | ztInteger | 3 |  | smallint
Text on invoice row | UftRadText | ztString | 255 |  | varchar
Prel invc journal no. | UppdJournNr | ZtLong | 4 |  | int
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Row amt, curr | vb_FaktRadSumma | ztMoney | 14 | 2 | money
Gross invoice row amt, curr | vb_FaktRadSumma_Brutto | ztMoney | 14 | 2 | money
Price, curr | vb_pris | ZtSalesPrice | 12 | 2 | money
Price acc to rule | VbPrisER | ZtSalesPrice | 12 | 2 | money
Voucher no. | vernr | Jeeves_VchrNo | 9 |  | bigint
Volume disc % | VolymRabatt | ZtDecimal73 | 10 | 2 | decimal
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: muft Template rows for per invoice


Preliminary imported/loaded del invoice rows (PrelimPvLrd)

Details of imported but non-reviewed supplier invoices, details for correcting/supplementing before they can be transferred to the Supplier invoices (lrd) tables.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Alternative item | ArtNrAltArt | ztString | 30 |  | varchar
Supplier item no. | ArtnrLev | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
PO no. | PrelimPvLrBestNr | ztString | 30 |  | varchar
Received qty invtry unit | PrelimPvLrdBestLevAnt | ztString | 30 |  | varchar
Received qty (suppl's unit) | PrelimPvLrdBestLevAntExtQty | ztString | 30 |  | varchar
Invc match value | PrelimPvLrdFaktAvprVarde | ztString | 30 |  | varchar
Delivery note/disp no. | PrelimPvLrdFfhNr | ztString | 30 |  | varchar
Price conv factor | PrelimPvLrdInkArtOmvFaktor | ztString | 30 |  | varchar
Price unit factor | PrelimPvLrdinkprisper | ztString | 30 |  | varchar
Discount 1 % | PrelimPvLrdRabatt1 | ztString | 30 |  | varchar
Discount 2 % | PrelimPvLrdRabatt2 | ztString | 30 |  | varchar
Discount 3 % | PrelimPvLrdRabatt3 | ztString | 30 |  | varchar
Gross purch price, curr | PrelimPvLrdVB_inpris | ztString | 30 |  | varchar
Gross setup price, curr | PrelimPvLrdVB_inpris_stall | ztString | 30 |  | varchar
Gross start purch prc, curr | PrelimPvLrdVB_inpris_start | ztString | 30 |  | varchar
SeqNo. | PrelimPvLrid | ZtLong | 10 |  | int
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Text/info | x255_2 | ztString | 255 |  | varchar


Preliminary imported/loaded del.invoice (PrelimPvLr)

Data on supplier invoices that have undergone preliminary importation/loading, and interpretation.

Interpreted data is loaded into this preliminary table without controls. The purpose of this is to be able to import interpreted invoice data without controls in order to find any deviations in the imported data.

When loading to the preliminary table is done, row-by-row transfer is made to Review imported supplier invoices (xpvlr), and controls are performed here. If a row can be loaded, it is deleted from the preliminary table; otherwise the row remains.

The information is accessed via a node in Review imported supplier invoices, where there is also an underlying node for interpreted invoice rows.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Account at bank | BankKonto | ztString | 40 |  | varchar
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Reviewed | CheckPvlr | ztBoolean |  |  | char
Document ID | DocId | ztString | 50 |  | varchar
Document type no. | Documenttype | ZtLong | 5 |  | int
Invoice reference no. | FaktNr_Ocr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Receipt date | KvittensFvDatum | ztString | 25 |  | varchar
Receipt created | KvittensSkapad | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Approval reference | PrelimPvLrAttRef | ztString | 60 |  | varchar
PO no. | PrelimPvLrBestNr | ztString | 30 |  | varchar
Supplier invoice no. | PrelimPvLrBestRkgNr | ztString | 30 |  | varchar
Bank Giro | PrelimPvLrBg | ztString | 30 |  | varchar
&Delete | PrelimPvLrDelete | ztBoolean |  |  | char
EU VAT/tax reg no. | PrelimPvLrEuMomsNr | ztString | 30 |  | varchar
Invoice date | PrelimPvLrFaktDat | ztString | 30 |  | varchar
Due date | PrelimPvLrFaktFfDat | ztString | 30 |  | varchar
SeqNo. | Prelimpvlrid | ZtLong | 10 |  | int
S4 | PrelimPvLrK4 | ztString | 30 |  | varchar
Acc Seg 5 | PrelimPvLrK5 | ztString | 30 |  | varchar
S6 | PrelimPvLrK6 | ztString | 30 |  | varchar
Acc Seg 7 | PrelimPvLrK7 | ztString | 30 |  | varchar
S8 | PrelimPvLrK8 | ztString | 30 |  | varchar
Cost unit | PrelimPvLrKbrNr | ztString | 30 |  | varchar
Cost centre | PrelimPvLrKstNr | ztString | 30 |  | varchar
Account | PrelimPvLrKtoNr | ztString | 30 |  | varchar
Customer | PrelimPvLrKundNr | ztString | 30 |  | varchar
Organization no. | PrelimPvLrOrgNr | ztString | 30 |  | varchar
Plus giro no. | PrelimPvLrPg | ztString | 30 |  | varchar
Project | PrelimPvLrProjCode | ztString | 30 |  | varchar
Packaging, curr | PrelimPvLrVb_Emballagekostnad | ztString | 30 |  | varchar
Handling charge curr | PrelimPvLrVb_ExpeditionKostnad | ztString | 30 |  | varchar
Invoice amount, curr | PrelimPvLrVb_faktsum | ztString | 30 |  | varchar
Insurance, curr | PrelimPvLrVb_ForsakringsKostnad | ztString | 30 |  | varchar
Total freight, curr | PrelimPvLrVb_fraktkostndeb | ztString | 30 |  | varchar
VAT/tax, curr | PrelimPvLrVbfaktmoms | ztString | 30 |  | varchar
Transferred | PvlrStatus | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date created | SkapadDatum | ztString | 25 |  | varchar
Txt file created | TxtFileSkapad | ztBoolean |  |  | char
Currency | ValKod | ztString | 3 |  | varchar
Text/info | x255_2 | ztString | 255 |  | varchar
Text 3 | x255_3 | ztString | 255 |  | varchar
Info/Text | x8000 | ztString | 4000 |  | varchar
x8001 | x8001 | ztString | 4000 |  | varchar


Preliminary invoice header (uoh)

Data in the header of the preliminary invoice for an assignment.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Deducted invoice | AcDrawn | ztBoolean |  |  | char
Add on invoice | AddOnInvoice | ztBoolean |  |  | char
Active | Aktiv | ztInteger | 1 |  | smallint
Aut created credit invoice | AutKreditSkapad | ztBoolean |  |  | char
Posting template | AutoRegel | ztString | 4 |  | varchar
Est invoice date | BerFaktDat | ztDate |  |  | datetime
Payment terms | BetKod | ztString | 2 |  | varchar
VAT/tax GL date | DateOfTaxSupply | ztDate |  |  | datetime
Detail posting | Detaljkontering | ztBoolean |  |  | char
District | DistrKod | ztString | 4 |  | varchar
Division code | DivisKod | ztString | 3 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Handling charge | ExpAvgKd | ztBoolean |  |  | char
Handling charge BCU | ExpeditionKostnad | ZtBaseCurrAmount | 14 | 2 | money
Invoice date | FaktDat | ztDate |  |  | datetime
Due date | FaktFfDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice reference no. | FaktNr_OCR | ztString | 40 |  | varchar
Invoice no., original | FaktNrOrg | Jeeves_InvNo | 9 |  | bigint
VAT/tax original invc | FaktNrOrg_Moms | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax curr orig invc | FaktNrOrg_VbMoms | ztMoney | 14 | 2 | money
Invoice to date | FaktTomDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment method | InbSlag | ztString | 3 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit order | KreditOrder | ztBoolean |  |  | char
Customer order date | KundBestDat | ztDate |  |  | datetime
Ordering dept | KundBestNamn | ztString | 36 |  | varchar
Customer order no. | KundBestNr | ztString | 30 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Invoicing address | KundFaktAdr | ztString | 36 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Customer reference | KundRef2 | ztString | 30 |  | varchar
Text on invoice | KundSpecTextFa | ztBoolean |  |  | char
Country | LandsKod | ztString | 3 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Allocation template | MallFaktPeriod | ztInteger | 3 |  | smallint
Period No. | MallFaktPeriodNr | ztInteger | 4 |  | smallint
Manuellt fakt.datum | ManFaktDat | ztDate |  |  | datetime
Manual due.date | ManFaktFfDat | ztDate |  |  | datetime
Manuellt faktnr | ManFaktNr | Jeeves_InvNo | 20 |  | bigint
Tax code acc to customer | MarkKundsMomsStyr | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Not credit invoice | NoCreditInvoice | ztBoolean |  |  | char
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Assignm no. from invoice | OffNr_PAF | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Order description | OrdBeskr | ztString | 40 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order cost | OrdKostnad | ZtBaseCurrAmount | 14 | 2 | money
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Order status | OrdStat | ztInteger | 2 |  | smallint
Order value | OrdSum | ZtBaseCurrAmount | 14 | 2 | money
Order type | OrdTyp | ztInteger | 3 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Last day of period | PeriodEnd | ztDate |  |  | datetime
First day of period. | PeriodStart | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Picking list date | PLUtskrDat | ztDateTime |  |  | datetime
Invoice type, descr | PrelfaktTyp | ztInteger | 5 |  | smallint
Price adjustment | PrisJustOrder | ztBoolean |  |  | char
Price list | PrisLista | ztInteger | 5 |  | smallint
Percent of invoice | ProcentavFaktura | ztFloat | 7 | 2 | float
Project ID | ProjCode | ztString | 10 |  | varchar
Project invoice | ProjFakt | ztBoolean |  |  | char
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Collective invoicing ID | SamFaktOffNr | ztString | 30 |  | varchar
Collective invoicing | SamFaktUtskr | ztBoolean |  |  | char
Service invoice | ServiceInvoice | ztBoolean |  |  | char
Serv.order no | ServOrderNr | Jeeves_SONo | 9 |  | bigint
Credit | SingleCreditMark | ztBoolean |  |  | char
Skrivskydd | SkrivUtskSk | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Sum items on invoice | SumitemOnInvoice | ztBoolean |  |  | char
Covered | TerminsSakradOrder | ztBoolean |  |  | char
Invoicing type | UFakttyp | ztInteger | 3 |  | smallint
Prel invc status | UohStatus | ztInteger | 2 |  | smallint
Prel invc journal no. | UppdJournNr | ZtLong | 4 |  | int
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
Handling charge curr | vb_ExpeditionKostnad | ztMoney | 14 | 2 | money
Order amount, curr | VbOrdSum | ztMoney | 14 | 2 | money
Our reference | VRef | ztString | 30 |  | varchar
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: uoh Invoicing assignments


Preliminary invoice rows (uft)

Invoice rows of a preliminary invoice for an assignment.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Deducted invoice | AcDrawn | ztBoolean |  |  | char
Item no. | artnr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Posting template per cost | AutoRegelK | ztString | 4 |  | varchar
District | DistrKod | ztString | 4 |  | varchar
Division code | Diviskod | ztString | 3 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Planned activity | EventKod1 | ztInteger | 3 |  | smallint
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Print invc row Y/N | FaktKostnskrivkod | ztBoolean |  |  | char
Shipped invc qty | FaktLevAnt | ZtQty | 14 | 2 | decimal
Sales tax | FaktMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
CSG invc row | FaktRadKost | ZtBaseCurrAmount | 14 | 2 | money
Kost (budg) varor | FaktRadKostBudg | ZtBaseCurrAmount | 14 | 2 | money
RowNo. | FaktRadnr | ztInteger | 4 |  | int
Invc row discount % | FaktRadRab | ztFloat | 8 | 2 | float
Invc row discount | FaktRadRabSumma | ZtBaseCurrAmount | 14 | 2 | money
Invc row amount | FaktRadSumma | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, BCU | FPris | ZtBaseCurrAmount | 14 | 2 | money
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | Ktonr | ztString | 8 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Inventory location | LagStalle | ztString | 2 |  | varchar
Origin template | MarkFromMuft | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Markup % | Palagg | ztFloat | 5 | 2 | float
Period | period | ztInteger | 4 |  | smallint
Personnel category | PersKategori | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Pricing type | PrisHantTyp | ztInteger | 3 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Serv.order no | ServOrderNr | Jeeves_SONo | 9 |  | bigint
Order row, service | ServOrdRadNr | ztInteger | 5 |  | int
Credit | SingleCreditMark | ztBoolean |  |  | char
Language | Sprakkod | ztInteger | 3 |  | smallint
Connection->planned activities | StrDateTimeHr | ztString | 28 |  | varchar
Time type | TidKod | ztInteger | 5 |  | smallint
Text on invoice row | UftRadText | ztString | 255 |  | varchar
Prel invc status | UohStatus | ztInteger | 2 |  | smallint
Prel invc journal no. | UppdJournNr | ZtLong | 4 |  | int
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Row amt, curr | vb_FaktRadSumma | ztMoney | 14 | 2 | money
Gross invoice row amt, curr | vb_FaktRadSumma_Brutto | ztMoney | 14 | 2 | money
Price, curr | vb_pris | ZtSalesPrice | 12 | 2 | money
VAT/tax, curr | VbFaktMoms | ztMoney | 14 | 2 | money
Price acc to rule | VbPrisER | ZtSalesPrice | 12 | 2 | money
Sector | Verksamhet | ztInteger | 5 |  | smallint
Voucher no. | vernr | Jeeves_VchrNo | 9 |  | bigint
Volume disc % | VolymRabatt | ZtDecimal73 | 10 | 2 | decimal
Row status | VrStatus | ztInteger | 4 |  | smallint
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: uft Preliminary invoice rows


Preliminary invoice rows (mutf)

Rows in the preliminary invoice in the assignment ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | artnr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
District | DistrKod | ztString | 4 |  | varchar
Division code | Diviskod | ztString | 3 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Shipped invc qty | FaktLevAnt | ZtQty | 14 | 2 | decimal
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
CSG invc row | FaktRadKost | ZtBaseCurrAmount | 14 | 2 | money
Kost (budg) varor | FaktRadKostBudg | ZtBaseCurrAmount | 14 | 2 | money
RowNo. | FaktRadnr | ztInteger | 4 |  | int
Invc row discount % | FaktRadRab | ztFloat | 8 | 2 | float
Invc row discount | FaktRadRabSumma | ZtBaseCurrAmount | 14 | 2 | money
Invc row amount | FaktRadSumma | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, BCU | FPris | ZtBaseCurrAmount | 14 | 2 | money
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | Ktonr | ztString | 8 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Period | period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | Sprakkod | ztInteger | 3 |  | smallint
Text on invoice row | UftRadText | ztString | 255 |  | varchar
Prel invc journal no. | UppdJournNr | ZtLong | 4 |  | int
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Row amt, curr | vb_FaktRadSumma | ztMoney | 14 | 2 | money
Price, curr | vb_pris | ZtSalesPrice | 12 | 2 | money
Voucher no. | vernr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint


Preliminary invoice status (xuoh)

Table of status of preliminary invoices in the assignment routine. To create an invoice, the status must be Ready for invoicing (50).

The following standard records exist. Do not alter/delete:

Prel invc status (UohStatus) | Prel invc status (UohStatusBeskr) | Description
9 | Entry in progress | Flagging of the preliminary invoice to differentiate it from others with preliminary status. For example, if you want to omit certain preliminary invoices from the usual invoicing routine.
10 | Preliminary | A preliminary invoice is created and you can change delete and add rows to this before printing the correct invoice.
50 | Ready for invoicing | You can now create an invoice based on the preliminary invoice.
70 | Invoiced | An invoice is created from the preliminary invoice.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Prel invc status | UohStatus | ztInteger | 2 |  | smallint
Prel invc status | UohStatusBeskr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: xuoh Assignmt invoice status


Preliminary posting (vrpvlr)

Node and table for entering preliminary posting proposals on imported supplier invoices.

The interim posting is transferred to the voucher row table (vr) when the invoices are transferred from the review program to the accounts payable ledger.

The behaviour is similar to that of normal voucher row entry as regards which account segments are shown and the relationship checks that are performed.

If an account number or other account segment is entered in the program's main form (pvlr) it is transferred to this node/table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Approved by | AttestSign | ztString | 6 |  | varchar
Orderer approval | Attestsign2 | ztString | 6 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Avräkningskonto | AvrKtoKod | ztBoolean |  |  | char
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
VAT/tax GL date | DateOfTaxSupply | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Dispatch date | Deliverydate | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
From template | FromAutoPostTempl | ztBoolean |  |  | char
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Company text | Ftgtext | ztString | 40 |  | varchar
Posting date | HbUpDat | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Fixed asset no | Inventarie | ZtLong | 10 |  | int
Component fixed asset | InventariePos | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Shortcut | KortKodVerRad | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Account type | KtoTyp | ztInteger | 3 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Tax date | MomsDatum | ztDate |  |  | datetime
Tax base amount | MomsGrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
SeqNo. | pvlrid | ZtLong | 10 |  | int
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
VAT/tax type | VAt_Type | ztInteger | 4 |  | smallint
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money
Voucher reference number | VoucherRefNo | ztInteger | 5 |  | smallint
Voucher row text | VrVerText | ztString | 60 |  | varchar


Preliminary supplier invoices (PrelimLr)

Table of preliminary supplier invoices. A row is created for each invoice.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Days fr due dt to pmt | AntDgrSedanFfDat | ZtLong | 7 |  | int
Approval status | AttestKod1 | ztInteger | 1 |  | smallint
This field is used in the table as follows: |
Approved by | AttestSign | ztString | 6 |  | varchar
AttUtbetalasStatusNummer | AttUtbetStatusNr | ZtLong | 10 |  | int
Posting template | AutoRegel | ztString | 4 |  | varchar
This field is used in the table as follows: |
Posting tmplt, final approval | AutoRegelS | ztString | 4 |  | varchar
Deducted amt curr | AvdrVal | ztMoney | 14 | 2 | money
Account at bank | BankKonto | ztString | 40 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Payment reason | BetUppdragsTyp | ztString | 4 |  | varchar
Reserved in journal | BilagsMark | ztBoolean |  |  | char
Bild Exp Date | BildfilExpDate | ztDate |  |  | datetime
Accounting date | BokfDat | ztDate |  |  | datetime
Currency pocket | Curr_P | ztString | 1 |  | varchar
Reference ID document | DocRefNr | ZtLong | 10 |  | int
Text | Edit | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Invoice match method | FaktAvprTypBest | ztInteger | 3 |  | smallint
Invc match value | FaktAvprVarde | ztMoney | 14 | 2 | money
Invoice reference no. | FaktNr_OCR | ztString | 40 |  | varchar
Remaining to pay BCU | FaktRestBel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Total freight BCU | FraktKostnDeb | ZtBaseCurrAmount | 14 | 2 | money
Freight cost, avg cost | FraktKostSnittBer | ZtBaseCurrAmount | 14 | 2 | money
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Allocation purch OH | InkOmkFord | ztInteger | 5 |  | smallint
Purch OH type | InkOmkTyp | ztInteger | 5 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Import date | IntullningsDatum | ztDate |  |  | datetime
S4 | k4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Early settlmt discnt % | Kassarab | ztFloat | 6 | 2 | float
Early settlmt discnt BCU | KassaRabBas | ZtBaseCurrAmount | 14 | 2 | money
Early stlmt dsct dt->due dt | KassaRabDatFFDat | ztBoolean |  |  | char
Posting slip date | KontLappUtskr | ztDate |  |  | datetime
Kont Momsbelopp 0 | KontMomsBelopp0 | ZtBaseCurrAmount | 14 | 2 | money
Pmt to acct | KontoIns | ztInteger | 1 |  | smallint
Posting method | KontRegKod | ztString | 2 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | koststallekod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Currency contract no. | KursAvtalsId | ztString | 20 |  | varchar
Bank Giro | LevBankGiro | ztBgNr | 11 |  | varchar
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Actual pmt date | LevFaktBetDat | ztDate |  |  | datetime
Invoice date | LevFaktDat | ztDate |  |  | datetime
Factoring | LevFaktFact | ztchar | 1 |  | char
Supplier invoice journal | LevFaktJourn | ztInteger | 4 |  | smallint
Cancel | LevFaktMakKod | ztBoolean |  |  | char
Supplier invoice status | LevFaktStatKod | ztString | 1 |  | varchar
Invoice Type | LevFaktTyp | ztInteger | 3 |  | smallint
Sales tax | LevIngMoms | ZtBaseCurrAmount | 14 | 2 | money
Supplier category | levkategori | ztInteger | 2 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Plus giro no. | LevPostGiro | ztPgNr | 11 |  | varchar
Supplier reference | LevRef2 | ztString | 50 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Amt in interim acct | LrAvrKtoBel | ZtBaseCurrAmount | 14 | 2 | money
Arrival date | LrFaktAnkDat | ztDate |  |  | datetime
Invoice amount BCU | LrFaktBelBas | ZtBaseCurrAmount | 14 | 2 | money
Due date | LrFaktFFDat | ztDate |  |  | datetime
Early settlmt discnt dt | LrfaktKrabdat | ztDate |  |  | datetime
Utbetalninsattest | LrUtbAttest | ztInteger | 5 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Urspr valutakurs | OldValKurs | ZtCurrencyRate | 15 | 7 | decimal
Orig exchange rate | OldValKursGrund | ZtCurrencyRate | 15 | 7 | decimal
Orig exchange rate, operand | OldValKursOp | ztInteger | 5 |  | smallint
Orig exchange rate per | OldValKursPer | ZtDecimal73 | 8 | 3 | decimal
Preliminary voucher | OldVerNr | Jeeves_VchrNo | 9 |  | bigint
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Markup-1, avg cost | Palagg1KostSnittBer | ZtBaseCurrAmount | 14 | 2 | money
Markup-2, avg cost | Palagg2KostSnittBer | ZtBaseCurrAmount | 14 | 2 | money
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Spec of central bank code | PgSkrivrad | ztString | 75 |  | varchar
SeqNo. | PrelimLrid | ZtLong | 10 |  | int
Transferred | PrelimLrStatus | ztBoolean |  |  | char
Priority | Prioritet | ztInteger | 2 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Reference number | ReferensNr | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Entry method | RegKod | ztInteger | 1 |  | smallint
Centr bank issue no. | RiksBanksArendeNr | ztString | 4 |  | varchar
Ctrl bank code | RiksBanksKod | ztString | 3 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
sen ändr kontering/attest | SenAttAndrDat | ztDate |  |  | datetime
Forward rate | TerminsKurs | ZtCurrencyRate | 11 | 6 | decimal
Forward contract | TerminsNr | ZtLong | 10 |  | int
Pmt for final approval | UtbAnkKontFakt | ztBoolean |  |  | char
Deducted amount in BCU | utbavdrbas | ZtBaseCurrAmount | 14 | 2 | money
AP payment status | UtbKod | ztString | 1 |  | varchar
Pmt service journal no. | UtbServJournNr | ZtLong | 6 |  | int
Payment methods | UtbSlag | ztString | 3 |  | varchar
Payment blocked | UtbSparr | ztBoolean |  |  | char
Adjustment type | UtbTyp | ztString | 1 |  | varchar
Non-financial account | UtlBetDebKonto | ztString | 10 |  | varchar
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate | ValKursGrund | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate, operand | ValKursOp | ztInteger | 5 |  | smallint
Exchange rate unit | ValKursPer | ZtDecimal73 | 8 | 3 | decimal
Invoice amount, curr | vb_faktsum | ztMoney | 14 | 2 | money
Total freight, curr | vb_FraktKostnDeb | ztMoney | 14 | 2 | money
Paid on invc, curr | VbFaktBet | ztMoney | 14 | 2 | money
VAT/tax, curr | VbFaktMoms | ztMoney | 14 | 2 | money
Outst invc amt, curr | VbFaktRest | ztMoney | 14 | 2 | money
Pmt amt, curr (pmt srvc) | VbFbsBelopp | ztMoney | 14 | 2 | money
Early settlmt discnt, curr | VbKassaRab | ztMoney | 14 | 2 | money
Outst plan amt, curr | VbRestAttPlanera | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Voucher no. group | VerNrGrupp | ztString | 6 |  | varchar
Prel voucher no. | VerNrp | Jeeves_VchrNo | 9 |  | bigint
Fiscal Year | VerRedAr | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: PrelimLr Preliminary supplier invoice with matching


Preliminary work reports, flow group (tfao)

Preliminary labour reports of flow groups.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Remaining to report | AoRestInnanRapp | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
Personnel/operation | OpBemanning | ztFloat | 6 | 3 | float
Operation no. | OpNr | ztInteger | 3 |  | int
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Reported finish date | RappSlutDatum | ztDate |  |  | datetime
Reported finish time | RappSlutTid | ztTime | 5 |  | datetime
Start date | RappStartDatum | ztDate |  |  | datetime
Reported start time | RappStartTid | ztTime | 5 |  | datetime
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Tools | Verktyg | ztString | 16 |  | varchar


Presentation texts (txt)

Numeric language code according to Jeeves'internal standard. The language code is used throughout the entire system to identify the language in which texts, e.g. item descriptions, are to be printed/displayed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Text | LangTxt | ztString | 8000 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Language | Sprakkod | ztInteger | 3 |  | smallint
TextID | TextID | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: txt Presentation texts


Presentation texts (vtxt)

Numeric language code according to Jeeves'internal standard. The language code is used throughout the entire system to identify the language in which texts, e.g. item descriptions, are to be printed/displayed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | langtxt |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Language | sprakkod |  |  |  | @DataType=NULL
TextID | TextID |  |  |  | @DataType=NULL


Preset values for MRP runs (nefi)

Pre-settings for different types of MRP can be saved in this table.
For example, different pre-settings can be made for:
- number of days forward in time that are to be processed starting order row status to be processed (forecast, entry in progress, entered....)
- end order code etc.
See the column descriptions included in the table.
At the start of MRP, you are first asked which pre-setting is to be used.
If 0 (zero) is entered, no pre-setting is used. You must instead manually answer certain start questions.
During manual start, however, not all of the selections that can be specified in the pre-setting table are available.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Process (No. days) | NE_Beh_Antal_Dgr | ztInteger | 5 |  | smallint
Delete earlier proposals | NE_Del_Bia_Pans | ztBoolean |  |  | char
Delete purch prognosis | NE_Del_Bp_Prognos | ztBoolean |  |  | char
MRP template description | NE_Fi_Beskr | ztString | 60 |  | varchar
MRP template ID | NE_Fi_Id | ztInteger | 5 |  | smallint
Proposal No. days | NE_Forsl_Antal_Dgr | ztInteger | 5 |  | smallint
From order row status | NE_From_OrdRadSt | ztInteger | 5 |  | smallint
MRP batch -> Sign/mgr | NE_PlanAnsv | ztString | 8 |  | varchar
Invtry bal acc to inv grp | NE_Saldo_LstGrupp | ztBoolean |  |  | char
Balance type at MRP | NE_SaldoTyp | ztInteger | 5 |  | smallint
Excess inventory test | NE_TestaOverLager | ztBoolean |  |  | char
To order code | NE_Tom_OrderKod | ztInteger | 5 |  | smallint
Using limited capacity MRP | NRP_UseFiniteCapacity | ztBoolean |  |  | char
Use forecast in MRP | NRP_UseForecast | ztBoolean |  |  | char
Use security layer in MRP | NRP_UseSafetyLevel | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: nefi Pre-settings, net requirements (MRP)


Price calc, purch/inventory, header (kh)

Table of main records from cost calculations made when purchasing goods for inventory or transferring goods between inventories.

Each calculation header (kh) can have an unlimited number of detail rows (khl).
These can be entered manually or be created automatically in accordance with a table definition for calculation details (xkd), which must be done in the system.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Costing complete | EfterKalkKod | ztBoolean |  |  | char
Costing, unit cost | EfterKalkKostnad | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Estimate finished | ForKalkKod | ztBoolean |  |  | char
Estimate, cost/unit | ForKalkKostnad | ZtBaseCurrAmount | 14 | 2 | money
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Purchase calc | KodInkopKalkyl | ztBoolean |  |  | char
Inventory calculation | KodLagerKalkyl | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans qty (+/-) | LagTransAntal | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Entered values apply | RegValuesKalkyl | ztBoolean |  |  | char
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Gross purch price, curr | vb_InPris | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: kh Cost calculation, purchase/inventory


Price calc, purch/inventory, rows (khl)

Table of detail rows from cost calculations made when purchasing goods for inventory or transferring goods between inventories.

Each calculation header (kh) can have an unlimited number of detail rows.
These can be entered manually or be created automatically in accordance with a table definition for calculation details (xkd), which must be done in the system.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Actual cost | EfterKalkBelopp | ZtBaseCurrAmount | 14 | 2 | money
Costing, unit cost | EfterKalkKostnad | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Work order estimate | ForKalkBelopp | ZtBaseCurrAmount | 14 | 2 | money
Estimate, cost/unit | ForKalkKostnad | ZtBaseCurrAmount | 14 | 2 | money
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
For purchase calc | KalkDetInkopKalkyl | ztBoolean |  |  | char
Calc detail type | KalkDetKod | ztInteger | 2 |  | smallint
For inventory calc | KalkDetLagerKalkyl | ztBoolean |  |  | char
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint


Price calculation methods at order (xxpo)

Definition of price calculation methods at order that can be specified on price lists to achieve automatic price calculation at order entry.

The following standard records exist. Do not alter/delete:

Price calc method, order (PrisVidOrderTyp) | Price calc method, order (PrisVidOrderTypBeskr)
1 | Markup cost price, all Items
2 | Markup average price, all Items
3 | Markup list price, all Items
4 | Markup cost price, Items in list
5 | Markup average price, Items in list
6 | Markup list price, Items in list

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price calc method, order | PrisVidOrderTyp | ztInteger | 2 |  | smallint
Price calc method, order | PrisVidOrderTypBeskr | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xxpo Price calculation methods at order


Price calculation methods, sales (xxpt)

Definition of price calculation methods that can be used when creating price lists using the function buttons in the Price lists program (Prh).

The following standard records exist. Do not alter/delete:

Price calculation method (PrisSattnTyp) | Price calculation method (PrisSattnTypBeskr) | Description
0 | No price calculation | Calculation of sales prices is not automatic for items that are included in the current price list.
1 | Markup on cost price | Automatic calculation of sales prices based on the cost price of the items included in the current price list, with markups according to the following data specified in the price list. header or retail rows for the items: - Price factor in % (MarkUP) - Price factor in amount (MarkUpBelopp) - Price factor table (PrisFaktTabKod) in the price list header, where Price factor in % (PrisFaktTabMarkUp)and Price factor by amount (PrisFaktTabMarkUpBelopp) may also be given based on the size of the calculation price If Price factor in % (MarkUp) and/or Price factor by amount (MarkUpBelopp) are given on retail rows for items in the price list, they have priority over information specified in the price list header for cost. You may specify which factors, % or amounts, should first be added to the cost price when calculating the sales price.
2 | Reduction on list price | Automatic calculation of sales prices is based on the list price for items included in the current price list, with a discount according to the following data specified on the price list's main or retail rows for items: - Price factor in % (MarkUP) - Price factor in amount (MarkUpBelopp) - Price factor table (PrisFaktTabKod) in the price list header, where Price factor in % (PrisFaktTabMarkUp)and Price factor by amount (PrisFaktTabMarkUpBelopp) may also be given based on the size of the list price If Price factor in % (MarkUp) and/or Price factor by amount (MarkUpBelopp) are given on retail rows for items in the price list, they have priority over information specified in the price list header for calculation. You can specify which factor, % or amount, should be deducted from the list price first when calculating the sales price.
3 | Markup on list price | Automatic calculation of sales prices is based on the list price for items included in the current price list, with a markup according to the following data specified on the price list's header or retail rows for items: - Price factor in % (MarkUP) - Price factor in amount (MarkUpBelopp) - Price factor table (PrisFaktTabKod) in the price list header, where Price factor in % (PrisFaktTabMarkUp) and Price factor by amount (PrisFaktTabMarkUpBelopp) may also be given based on the size of the list price If Price factor in % (MarkUp) and/or Price factor by amount (MarkUpBelopp) are given on retail rows for items in the price list, they have priority over information specified in the price list header for calculation. You may specify which of the factors, % or amounts, is to be added to the list price first when calculating the sales price.
4 | Markup on cost price (main+detail) | Automatic calculation of sales prices based on cost price for items included in the current price list, with markup according to the following data specified on the price list's main and/or retail rows for items: - Price factor in % (MarkUP) - Price factor in amount (MarkUpBelopp) - Price factor table (PrisFaktTabKod) in the price list header, where Price factor in % (PrisFaktTabMarkUp)and Price factor by amount (PrisFaktTabMarkUpBelopp) may also be given based on the size of the cost price When calculating using this pricing method, additional details specified in both the price list header and retail rows for the items should be taken into consideration. . You may specify which factors, % or amounts, should first be added to the cost price when calculating the sales price.
5 | Reduction on list price (main+detail) | Automatic calculation of sales prices based on the list price for items included in the current price list, with a discount according to the following data specified on the price list's header and/or retail rows for items: - Price factor in % (MarkUP) - Price factor in amount (MarkUpBelopp) - Price factor table(PrisFaktTabKod) in the price list header, where also Price factor in % (PrisFaktTabMarkUp) and based on the size of the list price When calculating using this pricing method, additional details specified in both the price list header and retail rows for the items should be taken into consideration. You may specify which of the factors, % or amounts, is to be deducted first from the list price when calculating the sales price.
6 | Markup on list price (main+detail) | Automatic calculation of sales prices based on cost price for items included in the current price list, with markup according to the following data specified on the price list's header and/or retail rows for items: - Price factor in % (MarkUP) - Price factor in amount (MarkUpBelopp) - Price factor table (PrisFaktTabKod) in the price list header, where Price factor in % (PrisFaktTabMarkUp)and Price factor by amount (PrisFaktTabMarkUpBelopp) may also be given based on the size of the list price When calculating using this pricing method, additional details specified in both the price list header and retail rows for the items should be taken into consideration. . You may specify which of the factors, % or amounts, is to be added to the list price first when calculating the sales price.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price calculation method | PrisSattnTyp | ztInteger | 2 |  | smallint
Price calculation method | PrisSattnTypBeskr | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xxpt Price calculation methods, sales


Price calculation types, package items (xo2)

Table indicating different alternatives that can be used to control price calculation of packages. For example, the price can be calculated from either the package header down to details or totaled from details to the package header.

When you enter packages, the parameter for price calculation is retrieved firstly from the item and secondly from the system table for your own company.

The following standard records exist. Do not alter/delete:

Price calc method, pkg (OrpStrPrisBer) | Price calc type, pkg (OrpStrPrisBerBeskr) | Description
0 | Price->details, post det (sales price) | Means that the price is calculated and set for the components based on current quantity and sales price for components and sales price for the package header. The calculation of current sales price for the components is based on the relationship between the components’ quantity and sales price and the sum of all components’ sales value multiplied by the current sales price on the package header. i.e. if the package header’s sales price is 100 BCU and it contains 2 components, A and B with 2 pieces of each, where A has sales price = 50 and B = 75, the components’ sales price will be calculated as follows: Components’ sales value = 2*50 + 2*75 = 250. Sales price for component A = (2*50 / 250) * 100 = 40 / 2 = 20. Sales price for component B = (2*75 / 250) * 100 = 60 / 2 = 30. Posting of revenue and cost in connection with invoicing is performed based on the components’ respective product accounts.
1 | Price->details, post pkg (sales price) | The function for price calculation for details is the same as for Price calc meth, pkg = 0, i.e. Price->Details, det post (FsgPris). The difference is that posting of revenue and cost in connection with invoicing is done based on the package item’s product account.
2 | Price->details, post det (cost price) | Means that the price is calculated and set for the components based on current quantity and cost price for components and sales price for the package header. The calculation of current sales price for the components is based on the relationship between the components' quantity and cost price and the sum of all components' calculated value multiplied by the current sales price on the package header. i.e. if the package header's sales price is 100 BCU and it contains 2 components, A and B with 2 pieces of each, where A has cost price = 14 and B = 21, the components' sales price will be calculated as follows: Components' calculated value = 2*14 + 2*21 = 70. Sales price for component A = (2*14 / 70) * 100 = 40 / 2 = 20. Sales price for component B = (2*21 / 70) * 100 = 60 / 2 = 30. Posting of revenue and cost in connection with invoicing is performed based on the components' respective product accounts. (Introduced in version 8.5.)
3 | Price->details, post pkg (cost price) | The function for price calculation for details is the same as for Price calc meth, pkg = 2, i.e. Price->Details, det post (KalkPris). The difference is that posting of revenue and cost in connection with invoicing is done based on the package item’s product account. (Introduced in version 8.5.)
5 | Price=details, post details | Means that sale price of the package item is calculated and set through summary of the sale price of the included details. In other words, a package item that contains 2 details, A and B with 2 pieces of each, where A has sales price = 50 and B = 75, the package item’s sales price will be calculated as follows: Sales value of included details = 2*50 + 2*75 = 250. Posting of revenue and cost in connection with invoicing is performed based on the respective product accounts for included detail articles.
6 | Price=details, post package | The function for price calculation for package item is the same as for Price calc meth, pkg = 5, i.e. Price->Components, det post (KalkPris). The difference is that posting of revenue and cost in connection with invoicing is done based on the package item’s product account. (Introduced in version 8.5.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Price calc method, pkg | OrpStrPrisBer | ztInteger | 2 |  | smallint
Price calc type, pkg | OrpStrPrisBerBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xo2 Price calculation types, package items


Price change, service option (shoropt)

Definition of applicable service options on service items that affect the price.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Component item no. | ArtNrSerieIng | ztString | 30 |  | varchar
Price change | ChangeOfAmount | ztMoney | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Discount % | Rabatt | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Reparation type | RepNr | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Price change, curr | Vb_ChangeOfAmount | ztMoney | 14 | 2 | money


Price changes, alt supplier (alhi)

A history table showing the changes of gross purchase price (in currency) and lead time for alternative suppliers.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Main agreement | ArtHuvudAvt | ztBoolean |  |  | char
Net purchase price | ArtInPris | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Price conv factor | InkArtOmvFaktor | ztFloat | 14 | 4 | float
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Gross purch price, curr | Vb_Inpris | ztMoney | 14 | 2 | money
Gross purch price, curr | Vb_InPris_Brutto | ztMoney | 14 | 2 | money
Gross purch prc, excl alloy | Vb_InprisBas | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: alhi Price changes purchase agreement


Price factor table header (xpb)

Definition of price factors that can be used to calculate sales prices in the Price list program (Prh). Based on the tiering of the calculation data (cost price or list price), different price factors can be applied for calculating sales price.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price factor table | PrisFaktTabBeskr | ztString | 30 |  | varchar
Price factor table | PrisFaktTabKod | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxpb Price factor table


Price factor table rows (xpbl)

Detail row in the price factor table for calculating sales prices based on markup %, depending on the size of the calculation data (e.g. cost price).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Calc.ord amount + % | PrisFaktTabBerOrdnBelProc | ztBoolean |  |  | char
Price factor table | PrisFaktTabKod | ztString | 6 |  | varchar
Price factor limit | PrisFaktTabLimit | ZtSalesPrice | 12 | 2 | money
Price factor % | PrisFaktTabMarkup | ztFloat | 14 | 4 | float
Price factor amount | PrisFaktTabMarkUpBelopp | ztMoney | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Price handling types (xtz)

Definition of price management types that show how prices and discounts are set for order rows, purchase order rows, template rows in assignments and preliminary invoice rows. Jeeves automatically sets the price management type.

The following standard records exist. Do not alter/delete:

Pricing type (PrisHantTyp) | Pricing type (PrisHantBeskr)
0 | Automatic (price and discount)
1 | Price, manual
2 | Discount, manual
3 | Manually (price and discount)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Pricing type | PrisHantBeskr | ztString | 50 |  | varchar
Pricing type | PrisHantTyp | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xtz Price handling types


Price handling types, internal sales (xtzi)

Definition of price management types for internal sales that show how Sales prices, internal (FPrisInternt) are set for customer order rows. Jeeves automatically sets the price management type.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Pricing type, intrn sales | PrisHantBeskrIntFsg | ztString | 50 |  | varchar
Pricing type, intrn sales | PrisHantTypIntFsg | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xtzi Price handling types, internal sales


Price list details, discount handling (PrlArtv)

In Jeeves, you can enter an unlimited number of optional items for an item. Optional items are used in the order routine to present possible options for an item. For example with a sale of a laser printer you could also offer an extra paper tray, color cartridges, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Optional item | ArtNrTillValArt | ztString | 30 |  | varchar
Discounting method | DiscountMethod | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Price 0 applies | KodNollPris | ztBoolean |  |  | char
No customer disc | KundEjRabKod | ztBoolean |  |  | char
Quantity limit >= | Limitlowant | ztFloat | 10 | 2 | float
Discount fr matrix, add | MatrisRabAddKod | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Gross margin | Proc1 | ztFloat | 6 | 2 | float
% on main item order value | ProcBerOrdVarde | ztFloat | 14 | 4 | float
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Active disc matrix | RabattAktivKod | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Quantity | TillValArtAntal | ZtQty | 14 | 2 | decimal
Multiply quantity | TillValArtAntalMultKod | ztBoolean |  |  | char
Priority code | TillValArtPrior | ZtDecimal73 | 18 |  | decimal
Valid to date | TomDatum | ztDate |  |  | datetime
Price, curr | vb_Pris | ZtSalesPrice | 12 | 2 | money
Volume disc %, add | VolymRabAddKod | ztBoolean |  |  | char


Price list, measures (prlz)

A price list that is linked to the normal price list but is priced by repair type (for service purposes).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, BCU | FPris | ZtBaseCurrAmount | 14 | 2 | money
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quantity limit >= | LimitLowAnt | ztFloat | 10 | 2 | float
Est time in hours | PBeranttim | ztFloat | 10 | 2 | float
Price per piece. | PricePerItem | ztBoolean |  |  | char
Price list | PrisLista | ztInteger | 5 |  | smallint
Reparation type | RepNr | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: prhy Measure price list


Price rounding interval (xavp)

Definition of price rounding per price interval used:
- for calculating sales and list prices
- for calculating new purchase prices from previous purchase prices.

The definition is based on linking a rounding level according to the static system table 'Price rounding types' (xavr) to a price interval. Example: prices < 100 are rounded to the nearest 50 decimals, prices < 1000 are rounded to SEK 1.00, and so on.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Limit price rounding <= | LimitPrisAvrund | ZtSalesPrice | 12 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Rounding type | PrisAvrundKod | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xxavp Price rounding table


Pricing methods, sales (xty)

Definition of pricing methods that shows how the price was created for each order row.

The following standard records exist. Do not alter/delete:

Pricing method (PrisTypP) | Pricing method (PrisTypBeskrP)
0 | According to quote/agreemt
1 | According to price list
2 | According to calc, item
4 | According to calc, prod class
5 | According to price, prod class
6 | According to list price, item
7 | According to campaign price list
8 | According to supplier's price
9 | Manually
10 | According to order type
11 | According to supplementary price list
12 | According to markup price list
13 | According to cust spec price list

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Pricing method | PrisTypBeskrP | ztString | 50 |  | varchar
Pricing method | PrisTypP | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xty Pricing methods, sales


Pricing per product class (pip)

Table with information about prices or percentages for use when pricing per product class.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Product class | ArtProdKlass | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quantity limit >= | Limitlowant | ztFloat | 10 | 2 | float
Gross margin | Proc1 | ztFloat | 6 | 2 | float
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Price, curr | vb_pris | ZtSalesPrice | 12 | 2 | money


Primary keys in own tables (UsrDefTablesPKColumns)

Definition of primary keys in own tables and views that you have created in the database.

Own tables and views must have a primary key. The key is used during import to the form window and for sorting rows in the list window.

Note that the Company ID column (foretagkod) must be included in the primary key if you have a multicompany database.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Name of column | JvsColumnName | ztString | 128 |  | varchar
Sequence no. | JvsSeqNo | ZtLong | 10 |  | int
Table name | JvsTableName | ztString | 128 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Development project | UsrDefDevProj | ztString | 10 |  | varchar


Print record, eBrev (ebup)

Print record, eBrev.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Term | ColumnName | ztString | 40 |  | varchar
Data type | datatype | ztString | 30 |  | varchar
Date record | datumpost | ztBoolean |  |  | char
Only out on page | eb_endastutsida | ztInteger | 5 |  | smallint
Unique ID logical page | eb_logsida_id | ztInteger | 5 |  | smallint
Page number entry | eb_sidnummer | ztBoolean |  |  | char
Show unique rows only | eb_unikarader | ztBoolean |  |  | char
Unique ID Print row | eb_utskrrad | ztInteger | 5 |  | smallint
Rows before new page | ebAntalradPerSida | ztInteger | 5 |  | smallint
Selective appendix | ebBilaga | ztInteger | 2 |  | smallint
Form call | ebBlankett | ztString | 4 |  | varchar
Font control code | ebFont | ztchar | 1 |  | char
No. of copies | ebKopia | ztInteger | 2 |  | smallint
Horizontal position logo | ebLogoHP | ztInteger | 4 |  | smallint
Logo type | ebLogotyp | ztString | 6 |  | varchar
Vertical position Logo | ebLogoVP | ztInteger | 4 |  | smallint
Text if value = 0 | ebOmNoll | ztString | 146 |  | varchar
Refers to table column | ebOmNollAvserKolumn | ztBoolean |  |  | char
Row control code | ebRad | ztchar | 1 |  | char
Report object | ebRptObjekt | ztInteger | 5 |  | smallint
Temp column | ebTempKolumn | ztString | 40 |  | varchar
Temp Table | ebTempTabell | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Right alignment | hjust | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Table name | JvsTableName | ztString | 128 |  | varchar
Concatenate | Konkat | ztBoolean |  |  | char
Number of characters | LengdTerm | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row break text field | radbryt | ztBoolean |  |  | char
Row | radpos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Start position on row | StartPosRad | ztInteger | 5 |  | smallint
Prompt | termprompt | ztString | 30 |  | varchar
Suppress | undertryck | ztBoolean |  |  | char
Currency record | valutapost | ztBoolean |  |  | char
Left alignment | vjust | ztBoolean |  |  | char
Text/info | x255 | ztString | 255 |  | varchar
Report program | YndReport | ztString | 40 |  | varchar


Printer (WMS_Printer)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Printer | Printer | ztString | 20 |  | varchar
Description | PrinterDesc | ztString | 50 |  | varchar
Printer is mobile | PrinterIsMobile | ztBoolean |  |  | char
Printer queue | PrinterQueue | ztString | 255 |  | varchar
Printer type | PrinterType | ztString | 20 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_Printer Printer


Printer type (WMS_PrinterType)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Printer type | PrinterType | ztString | 20 |  | varchar
Description | PrinterTypeDesc | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_PrinterType Printer type


Processed XML data from Jeeves (header) (XmlDataOutTranHist)

Xmldata out from Jeeves.
A historical table where data gets moved after it's processed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Configurator model ID | ModelId | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Transaction Id | TranId | ZtHugeInt | 20 |  | bigint
Unique ID (1) | Uid1 | ztString | 50 |  | varchar
Unique ID (2) | Uid2 | ztString | 50 |  | varchar
Unique ID (3) | Uid3 | ztString | 50 |  | varchar
Unique ID (4) | Uid4 | ztString | 50 |  | varchar
Unique ID (5) | Uid5 | ztString | 50 |  | varchar
Unique ID (6) | Uid6 | ztString | 50 |  | varchar
Error text | ValidationError | ztBlob | 1024 |  | varchar
Xml data status | XmlDataStatus | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: XmlDataOutTranHist Processed XML data from Jeeves (header)


Processed XML data from Jeeves (rows) (XmlDataOutHist)

Xmldata out from Jeeves.
A historical table where the data gets moved when it is processed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Insert Order | InsertOrder | ztInteger | 1000 |  | smallint
Key part 1 | Key1 | ztString | 50 |  | varchar
Key part 2 | Key2 | ztString | 50 |  | varchar
Key part 3 | Key3 | ztString | 50 |  | varchar
Key part 4 | Key4 | ztString | 50 |  | varchar
Key part 5 | Key5 | ztString | 50 |  | varchar
Configurator model ID | ModelId | ztString | 60 |  | varchar
Order of Grouping | OrdOfGroup1 | ZtDecimal73 | 16 | 9 | decimal
Order of Grouping | OrdOfGroup2 | ZtDecimal73 | 16 | 9 | decimal
Order of Grouping | OrdOfGroup3 | ZtDecimal73 | 16 | 9 | decimal
Order of Grouping | OrdOfGroup4 | ZtDecimal73 | 16 | 9 | decimal
Order of Grouping | OrdOfGroup5 | ZtDecimal73 | 16 | 9 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sort order | SortOrder | ztInteger | 5 |  | smallint
Table grouping | TableGroupOrder | ztInteger | 5 |  | smallint
Transaction Id | TranId | ZtHugeInt | 20 |  | int
Xml data status | XmlDataStatus | ztInteger | 5 |  | smallint
Nodeindex | XmlNodeIndex | ztInteger | 5 |  | smallint
Nodename | XmlNodeName | ztString | 128 |  | varchar
Nodetype | XmlNodeType | ztInteger | 5 |  | smallint
Nodevalue | XmlNodeValue | ztString | 1600 |  | varchar
Parent nodeindex | XmlParentNodeIndex | ztInteger | 5 |  | smallint
Top parent nodeindex | XmlTopParentNodeIndex | ztInteger | 5 |  | smallint
XPath | XmlXPath | ztString | 1024 |  | varchar
XPath in Jeeves | XmlXPathJvs | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: XmlDataOutHist Processed XML data from Jeeves (rows)


Processed XML data to Jeeves (header) (XmlDataInTranHist)

Xmldata in to Jeeves.
A historical table where the data gets moved when it is processed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Transaction Id | TranId | ZtHugeInt | 20 |  | bigint
Xml data status | XmlDataStatus | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: XmlDataInTranHist Processed XML data to Jeeves (header)


Processed XML data to Jeeves (rows) (XmlDataInHist)

Xml data to Jeeves.
That has been processed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Insert Order | InsertOrder | ztInteger | 1000 |  | smallint
Key part 1 | Key1 | ztString | 50 |  | varchar
Key part 2 | Key2 | ztString | 50 |  | varchar
Key part 3 | Key3 | ztString | 50 |  | varchar
Key part 4 | Key4 | ztString | 50 |  | varchar
Key part 5 | Key5 | ztString | 50 |  | varchar
Configurator model ID | ModelId | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sort order | SortOrder | ztInteger | 5 |  | smallint
Table grouping | TableGroupOrder | ztInteger | 5 |  | smallint
Transaction Id | TranId | ZtHugeInt | 20 |  | bigint
Xml data status | XmlDataStatus | ztInteger | 5 |  | smallint
Nodeindex | XmlNodeIndex | ztInteger | 5 |  | smallint
Nodename | XmlNodeName | ztString | 128 |  | varchar
Nodetype | XmlNodeType | ztInteger | 5 |  | smallint
Nodevalue | XmlNodeValue | ztString | 1600 |  | varchar
Parent nodeindex | XmlParentNodeIndex | ztInteger | 5 |  | smallint
Top parent nodeindex | XmlTopParentNodeIndex | ztInteger | 5 |  | smallint
XPath | XmlXPath | ztString | 1024 |  | varchar
XPath in Jeeves | XmlXPathJvs | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: XmlDataInHist Processed xml indata to Jeeves (rows)


Product area (pomr)

Definition of the different product areas in your own workshop. The shop floor can be subdivided into different areas, in which different types of products are manufactured. The information is used, for example, in the workload analyses and planning.

Jeeves has the following levels for workload analysis:
- Total
- Product area
- Foreman area
- Work group
- Manufacturing group

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Calc wage for subcontract | KalkylLonVidLego | ZtBaseCurrAmount | 14 | 2 | money
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Product area | ProduktOmrade | ztString | 6 |  | varchar
Product area | ProduktOmradeB | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: pomr Product area


Product Attribute (PVMAttr)

This table contains attributes, used as an umbrella term for variants. Examples of attributes are color or size.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Attribute | PVMAttributeDescr | ztString | 50 |  | varchar
Attribute | PVMAttributeId | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PVMAttr Product attributes


Product classes (xp)

Definition of product classes that can for example be used for price/discount grouping of items.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Calculation markup code | ArkPalKod | ztInteger | 5 |  | smallint
This field is used in the table as follows: |
Product class | ArtProdKlass | ztString | 4 |  | varchar
Product class | ArtProdklBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Delivery cost % | Hemtkostnproc | ZtDecimal73 | 7 | 2 | decimal
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Purch price curr | InValuta | ztString | 3 |  | varchar
Markup calculation | KodBeraknPalagg | ztBoolean |  |  | char
Antgräns1 | Limit1 | ztFloat | 4 | 2 | float
Antgräns2 | Limit2 | ztFloat | 4 | 2 | float
Antgräns3 | Limit3 | ztFloat | 4 | 2 | float
Antgräns4 | Limit4 | ztFloat | 4 | 2 | float
Antgräns5 | Limit5 | ztFloat | 4 | 2 | float
Mtrl overhead % | MtrlMoKostProc | ZtDecimal73 | 7 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Gross margin | proc1 | ztFloat | 6 | 2 | float
% | proc2 | ztFloat | 4 | 2 | float
% | proc3 | ztFloat | 4 | 2 | float
% | proc4 | ztFloat | 4 | 2 | float
% | proc5 | ztFloat | 4 | 2 | float
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Gross purch price, curr | vb_InPris | ztMoney | 14 | 2 | money
Cost price, curr | vbKalkPris | ztMoney | 14 | 2 | money
Web description | webBeskr | ztString | 60 |  | varchar
Publish on Web | webPublish | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: Xxp Product classes


Product codes for logtrade (LogtradeProductCode)

Definition of product codes in Logtrade.

The following standard records exist. Do not alter/delete:

Logtrade forwarder (LogTradeForwarderCode) | Logtrade product descr (LogtradeProductDescr)
DhlSweden | Euroconnect
DhlSweden | DHL Pall
DhlSweden | DHL Parti
DhlSweden | DHL Stycke
DhlSweden | Euroconnect
DhlSweden | DHL_Europack
DhlSweden | DHL_Europlus
DhlSweden | Europremium
DhlSweden | ServicePoint B2C
DhlSweden | DHL_Swednet
DhlSweden | DHL_Swednet_Partigods
DsvRoadSweden | e-Pallet
DsvRoadSweden | e-Parcel
DsvRoadSweden | Inrikes Partigods
DsvRoadSweden | Inrikes Styckegods
DsvRoadSweden | Tempererad Transport
DsvRoadSweden | Utrikes Partigods
DsvRoadSweden | Utrikes Styckegods
OnRoadSweden | OnRoad Ila
OnRoadSweden | OnRoad Skicka
OnRoadSweden | OnRoad Skynda
PnlSweden | CarryOn Business BulkSplit [332] (Description of transport label for PNL ver 20080101)
PnlSweden | CarryOn Budget [359] (Description of transport label for PNL ver 20080101)
PnlSweden | CarryOn Business [330] (Description of transport label for PNL ver 20080101)
PnlSweden | CarryOn Business 09:00 Limited Use [335] (Description of transport label for PNL ver 20080101)
PnlSweden | CarryOn Business BulkReturn [333] (Description of transport label for PNL ver 20080101)
PnlSweden | CarryOn Business BulkSplit 09:00 [334] (Description of transport label for PNL ver 20080101)
PnlSweden | CarryOn Business Pallet [336] (Description of transport label for PNL ver 20080101)
PnlSweden | CarryOn Business Pallet 09:00 [339] (Description of transport label for PNL ver 20080101)
PnlSweden | CarryOn Business Pallet Return [337] (Description of transport label for PNL ver 20080101)
PnlSweden | CarryOn Business Return [331] (Description of transport label for PNL ver 20080101)
PnlSweden | CarryOn Home Shopping [340] (Description of transport label for PNL ver 20080101)
PnlSweden | CarryOn Home Shopping BulkReturn [343] (Description of transport label for PNL ver 20080101)
PnlSweden | CarryOn Home Shopping BulkSplit [342] (Description of transport label for PNL ver 20080101)
PnlSweden | CarryOn Home Shopping Return [341] (Description of transport label for PNL ver 20080101)
PostenSweden | Avtalsbrev (Produkt RV)
PostenSweden | Brev
PostenSweden | BrevpostFörskott (Produkt AF)
PostenSweden | Comeback (Produkt 51) *Nycklad*
PostenSweden | Företagspaket 9:00 (Produkt 13)
PostenSweden | Företagspaket 12:00 (Produkt 14)
PostenSweden | Företagspaket 16:00 (Produkt 15)
PostenSweden | Företagspaket Lokalt (Produkt 57 *Nycklad*)
PostenSweden | DPD Företagspaket Special (Produkt 57) *Nycklad*
PostenSweden | DPD Utrikes (Produkt 88)
PostenSweden | Express 0700 (Produkt 42)
PostenSweden | Expressbrev (Produkt LX)
PostenSweden | Express Global (Produkt 47)
PostenSweden | Färdskrivarkort brev (Produkt RT, kundunik)
PostenSweden | Frimärksleverans (Produkt RF, kundunik)
PostenSweden | Hem Paket (Produkt 32)
PostenSweden | HemPaket (Postorder) (Produkt 41) *Nycklad*
PostenSweden | HemPC (Produkt 12) *Nycklad*
PostenSweden | Körkortsbrev (Produkt RS, kundunik)
PostenSweden | MyPack (Produkt 19, särskilt avtal)
PostenSweden | MyPack (Produkt 24, särskilt avtal)
PostenSweden | Paket utan kvittens (Produkt 26) *Nycklad*
PostenSweden | PALL.ETT (Produkt 52)
PostenSweden | PALL.ETT + (Produkt 54) *Nycklad*
PostenSweden | PALL.ETT Special (Produkt 53) *Nycklad*
PostenSweden | Postorderpaket (Produkt 13) *Nycklad*
PostenSweden | Post Paket (Produkt 25)
PostenSweden | Postpaket Utrikes (Produkt 91)
PostenSweden | Rekommenderat brev (Produkt RR)
PostenSweden | RetailDelivery (Produkt 59, särskilt avtal)
PostenSweden | Brev, värde (Produkt VV)
SchenkerSweden | Coldsped
SchenkerSweden | Comfort
SchenkerSweden | Direct
SchenkerSweden | SCHENKERflow (Schenker AGI 4.2)
SchenkerSweden | Parcel

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Logtrade forwarder | LogTradeForwarderCode | ztString | 30 |  | varchar
Product code | LogtradeProductCode | ztString | 60 |  | varchar
Logtrade product descr | LogtradeProductDescr | ztString | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: LogtradeProductCode Product codes for LogTrade


Product Variants (PVMVrt)

Table for variants. Variants are used to characterise an item, for example with the color blue.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Attribute | PVMAttributeId | ztString | 10 |  | varchar
Variant | PVMVariantDescr | ztString | 50 |  | varchar
Variant | PVMVariantId | ztString | 10 |  | varchar
Sort order | PvmVrtSortOrder | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PVMVrt Product variants


Production group history (pghis)

Contains history of the accumulators in the tool record. In this table, a record is created per tool each time resetting of the accumulators in the tool is performed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Acc start date | AckFromDatum | ztDate |  |  | datetime
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Production time calulations (SFR_calctmp)

Temporary table for production time calculations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Interruption code | aoavbrottskod | ztInteger | 5 |  | smallint
Mfg/Works order no. | aonr | Jeeves_MONo | 7 |  | bigint
Row | aopos | ztInteger | 4 |  | int
Manufactured qty/op | aorappant | ZtQty | 14 | 2 | decimal
Scrapped qty | aorappkassant | ZtQty | 14 | 2 | decimal
Reported time per unit | aorappstycktid | ztOpTime | 9 | 4 | float
Work group | arbetslag | ztString | 6 |  | varchar
Item no. | artnr | ztString | 30 |  | varchar
Reason | attrreason | ztString | 6 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Flow group | flodesgrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Return/scrap reason | kassorsakskod | ztInteger | 2 |  | smallint
Personnel/operation | opbemanning | ztFloat | 6 | 3 | float
Personnel/operation, setup | opbemanningstall | ztFloat | 6 | 3 | float
Operation no. | opnr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | perssign2 | ztString | 6 |  | varchar
Manufacturing group | prodgr | ztString | 5 |  | varchar
Rep manhours manufacturing | rappmantidtillverkning | ztOpTime | 9 | 4 | float
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Connecting unique ID | sfrconnuniqueid | ztUniqueIdentifier | 38 |  | varchar
Origin stamp time | sfroriginworepdat | ztDateTime |  |  | datetime
Production | sfrprodinfo | ztBoolean |  |  | char
Reportingtype SFR | SFRReptype | ztInteger | 5 |  | smallint
Row | sfrrow | ztInteger | 5 |  | smallint
Spid | sfrspid | ztInteger | 5 |  | smallint
Status | sfrstatusbit | ztInteger | 5 |  | smallint
Total time | sfrtotaltime | ztFloat | 15 | 2 | float
Unique ID | SFRUniqueid | ztUniqueIdentifier | 38 |  | varchar
Stamp time | sfrworepdat | ztDateTime |  |  | datetime
Status | sfrwostatus | ztInteger | 5 |  | smallint
Indirect job/labour | veovrigtjobb | ztInteger | 5 |  | smallint


Program clones (ycl)

Program/table for viewing, and for editing the names of cloned programs.

This program/table can be accessed through an embedded window in the program Setting dimensions/keys (jvssitenodewin) or from Jeeves' menu.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Clone name | clone | ztString | 40 |  | nvarchar
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Program | pgm | ztString | 40 |  | nvarchar

    This table is the main table in the following programs:

    Program: ycl Program clones


Program menus (menu)

Table of entered program menus.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
External description | ExtBeskriv | ztBlob | 1 |  | varchar
Menu ID | MenuId | ZtLong | 5 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: menu Menus


Proj invoicing agreemt hdr (view) (vufa)

Data in the header of the agreement to invoice for an assignment.
The view covers assignments for periodic invoicing where the period is controlled by a table containing the periods for invoicing (monthly, quarterly, etc.).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Agreement type | AvtalsKod | ztInteger | 3 |  | smallint
Payment terms | BetKod | ztString | 2 |  | varchar
District | DistrKod | ztString | 4 |  | varchar
Division code | DivisKod | ztString | 3 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Handling charge | ExpAvgKd | ztBoolean |  |  | char
Invoice to date | FaktTomDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight charge code | FraktAvgKd | ztBoolean |  |  | char
Delivery note Y/N | FsKd | ztBoolean |  |  | char
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Customer order date | KundBestDat | ztDate |  |  | datetime
Ordering dept | KundBestNamn | ztString | 36 |  | varchar
Customer order no. | KundBestNr | ztString | 30 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Invoicing address | KundFaktAdr | ztString | 36 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Customer reference | KundRef2 | ztString | 30 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Ship documents | LevHandlKod | ztBoolean |  |  | char
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Allocation template | MallFaktPeriod | ztInteger | 3 |  | smallint
Master project no. | MasterProjCode | ztString | 10 |  | varchar
Max date not invoiced | MaxEjFaktDat | ztDate |  |  | datetime
Min date not invoiced | MinEjFaktDat | ztDate |  |  | datetime
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Quotation/agreement | OffBeskr | ztString | 40 |  | varchar
Quote/Agreemt date | OffertDat | ztDate |  |  | datetime
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Quote/assignment status | OffStatus | ztString | 1 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order date | OrdDatum | ztDate |  |  | datetime
Order cost | OrdKostnad | ZtBaseCurrAmount | 14 | 2 | money
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Order value | OrdSum | ZtBaseCurrAmount | 14 | 2 | money
Order type | OrdTyp | ztInteger | 3 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Service price list | PrislistaT | ztInteger | 6 |  | smallint
Pricing method | PrisTyp | ztInteger | 3 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Collective invoicing ID | SamFaktOffNr | ztString | 30 |  | varchar
Last invoice date | SerSenFakt | ztDate |  |  | datetime
End date invc period | SersSlutFakt | ztDate |  |  | datetime
Start date invc period | SerStartFakt | ztDate |  |  | datetime
Skrivskydd | SkrivUtskSk | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Price ceiling | TakPrisAvt | ZtBaseCurrAmount | 12 | 2 | money
Price ceiling expense | TakPrisEx | ZtBaseCurrAmount | 12 | 2 | money
Invoicing type | UFakttyp | ztInteger | 3 |  | smallint
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Order amount, curr | VbOrdSum | ztMoney | 14 | 2 | money
Our reference | VRef | ztString | 30 |  | varchar


Project (vprj)

Data in the project header.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Confirmed date | BestOEDatum | ztDate |  |  | datetime
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
PO order value | BestValue | ZtBaseCurrAmount | 14 | 2 | money
Text | Edit | ztBlob | 1 |  | varchar
Extern T Inköp | EditInkExt | ztBlob | 1 |  | varchar
Paid amount BCU | FaktInbBel | ZtBaseCurrAmount | 14 | 2 | money
Remaining to pay BCU | FaktRestBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice total incl tax | FaktTotMMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice total excl tax | FaktTotUMoms | ZtBaseCurrAmount | 14 | 2 | money
Est % complete | FardigGrad | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Buyer | InkAnsv | ztString | 4 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Invoice amount BCU | LrFaktBelBas | ZtBaseCurrAmount | 14 | 2 | money
Master project no. | MasterProjCode | ztString | 10 |  | varchar
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Order value | OrdSum | ZtBaseCurrAmount | 14 | 2 | money
Est time in hours | PBeranttim | ztFloat | 10 | 2 | float
Estimated cost | PBerKostnad | ZtBaseCurrAmount | 14 | 2 | money
Est finish date | PBerSlutdat | ztDate |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project mgr | ProjAnsv | ztString | 6 |  | varchar
Grafiskt tecken | ProjBlock | ztchar | 1 |  | char
Project ID | ProjCode | ztString | 10 |  | varchar
Project name | ProjDescr | ztString | 40 |  | varchar
Finished on | ProjEndDat | ztDate |  |  | datetime
Accrued project cost | ProjKost | ZtBaseCurrAmount | 10 | 2 | money
Remaining time | ProjKvarTid | ztFloat | 10 | 2 | float
Time accrued | ProjNerlTid | ztFloat | 10 | 2 | float
Project start date | ProjStartDat | ztDate |  |  | datetime
Project status | ProjStatKod | ztInteger | 2 |  | smallint
Project type | ProjType | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal

    This table is the main table in the following programs:

    Program: Vprj Projects (view)


Project (prj)

Information in customer projects.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity to manufacture | AntalAttTillverka | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
This field is used in the table as follows: |
Agreement type | Avtalskod | ztInteger | 3 |  | smallint
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Confirmed date | BestOEDatum | ztDate |  |  | datetime
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
PO order value | BestValue | ZtBaseCurrAmount | 14 | 2 | money
Sequence no. type | CompanyType | ztInteger | 4 |  | smallint
As of date | DatPrjFom | ztDate |  |  | datetime
End date | DatPrjTom | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Extern T Inköp | EditInkExt | ztBlob | 1 |  | varchar
Paid amount BCU | FaktInbBel | ZtBaseCurrAmount | 14 | 2 | money
Remaining to pay BCU | FaktRestBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice total incl tax | FaktTotMMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice total excl tax | FaktTotUMoms | ZtBaseCurrAmount | 14 | 2 | money
Est % complete | FardigGrad | ztInteger | 3 |  | smallint
Manual posting OK | FarKonterasManuellt | ztBoolean |  |  | char
Posting allowed | FarKonterasPa | ztBoolean |  |  | char
Fixed price write off | FastprisKost | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Buyer | InkAnsv | ztString | 4 |  | varchar
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Invoicing start date | InvFromDate | ztDate |  |  | datetime
To be invoiced to date | InvToDate | ztDate |  |  | datetime
S4 | K4 | ztString | 8 |  | varchar
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Appr/ctrl grp, S7 | K7Grupp | ztString | 6 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Approval control group | KstGrupp | ztString | 6 |  | varchar
Appr/ctrl grp, account | KtoGrupp | ztString | 6 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Delivery approval status | LevPlanStatus | ztInteger | 2 |  | smallint
Invoice amount BCU | LrFaktBelBas | ZtBaseCurrAmount | 14 | 2 | money
Master project no. | MasterProjCode | ztString | 10 |  | varchar
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OK to invoice | OKtoInvoice | ztBoolean |  |  | char
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Order value | OrdSum | ZtBaseCurrAmount | 14 | 2 | money
Markup % | Palagg | ztFloat | 5 | 2 | float
This field is used in the table as follows: |
Markup amount | PalaggBelopp | ZtBaseCurrAmount | 14 | 2 | money
This field is used in the table as follows: |
Est time in hours | PBeranttim | ztFloat | 10 | 2 | float
Estimated revenue | PBerIntakt | ZtBaseCurrAmount | 14 | 2 | money
Estimated cost | PBerKostnad | ZtBaseCurrAmount | 14 | 2 | money
Est finish date | PBerSlutdat | ztDate |  |  | datetime
Booked revenue | PBokfIntakt | ZtBaseCurrAmount | 14 | 2 | money
Booked cost | PBokfKostnad | ZtBaseCurrAmount | 14 | 2 | money
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Posted loss risk reserve | PForlustriskAvsattning | ZtBaseCurrAmount | 14 | 2 | money
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Planned project | PlannedProject | ztBoolean |  |  | char
Posting check | PrjAccountCheck | ztBoolean |  |  | char
Account segments for voucher | PrjAccountPart | ztBoolean |  |  | char
Project coding | PrjLittera | ztString | 1 |  | varchar
Balans/resultatföres | Proj_Resultat_Balans | ztInteger | 5 |  | smallint
Project mgr | ProjAnsv | ztString | 6 |  | varchar
Grafiskt tecken | ProjBlock | ztchar | 1 |  | char
Project ID | ProjCode | ztString | 10 |  | varchar
Project name | ProjDescr | ztString | 40 |  | varchar
Project priority | ProjectPriority | ZtLong | 10 |  | int
Finished on | ProjEndDat | ztDate |  |  | datetime
Project source | ProjInit | ztInteger | 2 |  | smallint
Accrued project cost | ProjKost | ZtBaseCurrAmount | 10 | 2 | money
This field is used in the table as follows: |
Remaining time | ProjKvarTid | ztFloat | 10 | 2 | float
Time accrued | ProjNerlTid | ztFloat | 10 | 2 | float
Invoicing start date | ProjNextInvDate | ztDate |  |  | datetime
Revised end date | Projrevenddat | ztDate |  |  | datetime
Revised start date | Projrevstartdat | ztDate |  |  | datetime
Project start date | ProjStartDat | ztDate |  |  | datetime
Project status | ProjStatKod | ztInteger | 2 |  | smallint
Translation -> balance acct | ProjTran2BalansId | ztString | 8 |  | varchar
Project type | ProjType | ztInteger | 2 |  | smallint
Accumulated revenue | PUpparbIntakt | ZtBaseCurrAmount | 14 | 2 | money
Accumulated cost | PUpparbKostnad | ZtBaseCurrAmount | 14 | 2 | money
Orig est revenue | PUrspIntakt | ZtBaseCurrAmount | 14 | 2 | money
Orig est cost | PUrspKostnad | ZtBaseCurrAmount | 14 | 2 | money
Curr profit recognition | PVinstavraknat | ZtBaseCurrAmount | 14 | 2 | money
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Remaining to pay | RestBelFakt | ZtBaseCurrAmount | 14 | 2 | money
Proj result date | ResultatBokatDatum | ztDate |  |  | datetime
Bal->Inc year | ResultatBokatRedovisnAr | ztInteger | 5 |  | smallint
Bal->Inc voucher | ResultatBokatVerNr | Jeeves_VchrNo | 20 |  | bigint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Last profit recognition yr | SenVinstAvraknAr | ztInteger | 5 |  | smallint
Last profit recognition dt | SenVinstAvraknDat | ztDate |  |  | datetime
Last profit recognition per | SenVinstAvraknPer | ztInteger | 5 |  | smallint
Services account | TjansteKonto | ztString | 8 |  | varchar
This field is used in the table as follows: |
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Voucher no. | Vernr | Jeeves_VchrNo | 9 |  | bigint
This field is used in the table as follows: |
Display on web | WebAccountMark | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: prj Projects

    Program: PrjRE Project

    Program: PrjUnd Invoicing basis, project

    Program: Proj_MO Project, MPC


Project accounts journal (pkkj)

Journal information relating to posting of internal costs from time reporting, internal debiting and percentage of completion accounting on projects. Postings are done on each time row.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Journal no. | ProjKonterJournal | ZtLong | 10 |  | int
Journal status | ProjKonterStatus | ztInteger | 2 |  | smallint
ProjectTransType | ProjTransTyp | ztInteger | 2 |  | smallint
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | Vernr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: pkkj Internal costs, journal

    Program: pkkj2 Internal debiting, journal


Project accounts, details (pkkd)

Alphanumeric ID of project according to own definition in the Projects program (prj).

If you will need to follow up all or a group of projects linked to a certain assignment, you should build up your project IDs in a way that makes this possible.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Reported activity | EventRpKod | ztInteger | 3 |  | smallint
Hours | EventTimant2 | ztHourWithDecimals | 8 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
In-house price | Internpris | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Est hourly cost | KalkKostManTim | ZtBaseCurrAmount | 14 | 2 | money
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Time accrued | Nedlagdtid | ztHourWithDecimals | 8 | 2 | decimal
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Cost unit person | prKostBar | ztString | 8 |  | varchar
Cost centre person | PrKostStalleKod | ztString | 8 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Journal no. | ProjKonterJournal | ZtLong | 10 |  | int
ProjectTransType | ProjTransTyp | ztInteger | 2 |  | smallint
Row | RadPos2 | ztInteger | 4 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Services account | TjansteKonto | ztString | 8 |  | varchar
Voucher no. | Vernr | Jeeves_VchrNo | 9 |  | bigint


Project coding (pjli)

Definition of applicable project codes, used to automatically change the cost unit when using certain combinations of account and project numbers.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Project coding | PrjLittera | ztString | 1 |  | varchar
Project coding | PrjLitteraBeskr | ztString | 40 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: pjli Project coding


Project costs->GL (pkvt)

Detailed information per transaction of how project costs are posted when integrated with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Reported activity | EventRpKod | ztInteger | 3 |  | smallint
Hours | EventTimant2 | ztHourWithDecimals | 8 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Est hourly cost | KalkKostManTim | ZtBaseCurrAmount | 14 | 2 | money
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Journal no. | ProjKonterJournal | ZtLong | 10 |  | int
ProjectTransType | ProjTransTyp | ztInteger | 2 |  | smallint
This field is used in the table as follows: |
Row | RadPos2 | ztInteger | 4 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Services account | TjansteKonto | ztString | 8 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint


Project groups, details (kprj)

Table of control groups for a project.
The control groups can then be linked to other account segments.
Therefore you can control things so only certain projects can be used by certain accounts or segment 2 or ...

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
From Proj | PrjFrom | ztString | 30 |  | varchar
Control group project | PrjGrupp | ztString | 6 |  | varchar
ToPrj | PrjTom | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Project log (prjl)

Includes all projects at the company.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Confirmed date | BestOEDatum | ztDate |  |  | datetime
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
PO order value | BestValue | ZtBaseCurrAmount | 14 | 2 | money
Text | Edit | ztBlob | 1 |  | varchar
Extern T Inköp | EditInkExt | ztBlob | 1 |  | varchar
Paid amount BCU | FaktInbBel | ZtBaseCurrAmount | 14 | 2 | money
Remaining to pay BCU | FaktRestBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice total incl tax | FaktTotMMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice total excl tax | FaktTotUMoms | ZtBaseCurrAmount | 14 | 2 | money
Est % complete | FardigGrad | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Buyer | InkAnsv | ztString | 4 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Invoice amount BCU | LrFaktBelBas | ZtBaseCurrAmount | 14 | 2 | money
Master project no. | MasterProjCode | ztString | 10 |  | varchar
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Order value | OrdSum | ZtBaseCurrAmount | 14 | 2 | money
Est time in hours | PBeranttim | ztFloat | 10 | 2 | float
Estimated cost | PBerKostnad | ZtBaseCurrAmount | 14 | 2 | money
Est finish date | PBerSlutdat | ztDate |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project coding | PrjLittera | ztString | 1 |  | varchar
Project mgr | ProjAnsv | ztString | 6 |  | varchar
Grafiskt tecken | ProjBlock | ztchar | 1 |  | char
Project ID | ProjCode | ztString | 10 |  | varchar
Project name | ProjDescr | ztString | 40 |  | varchar
Finished on | ProjEndDat | ztDate |  |  | datetime
Accrued project cost | ProjKost | ZtBaseCurrAmount | 10 | 2 | money
Remaining time | ProjKvarTid | ztFloat | 10 | 2 | float
Time accrued | ProjNerlTid | ztFloat | 10 | 2 | float
Project start date | ProjStartDat | ztDate |  |  | datetime
Project status | ProjStatKod | ztInteger | 2 |  | smallint
Translation -> balance acct | ProjTran2BalansId | ztString | 8 |  | varchar
Project type | ProjType | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Proj result date | ResultatBokatDatum | ztDate |  |  | datetime
Bal->Inc year | ResultatBokatRedovisnAr | ztInteger | 5 |  | smallint
Bal->Inc voucher | ResultatBokatVerNr | Jeeves_VchrNo | 20 |  | bigint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal


Project posting journal status (xPks)

Numeric code which specifies the status for the project posting journal.

The journal must have the status 20 'Ready for posting' for a journal and posting to be created. The status is then changed to 30 [Posted]. The status can be changed to 90 [Canceled] as long as the journal has not been given a voucher number.

The following standard records exist. Do not alter/delete:

Journal status (ProjKonterStatus) | Description (ProjKonterStatusBeskr)
0 | Entry in progress
20 | Ready for posting
30 | Posted
90 | Canceled

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Journal status | ProjKonterStatus | ztInteger | 2 |  | smallint
Description | ProjKonterStatusBeskr | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xpks Project posting journal status


Project posting rule (xl2)

Internal definitions which are used to determine whether a project can/will be specified for a specific account.

The following standard records exist. Do not alter/delete:

Proj posting rule (regel2) | Proj posting rule (regelbeskr2)
1 | Does not exist
2 | Optional
3 | Mandatory

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Entry inventory, Proj | lager1 | ztInteger | 1 |  | smallint
Mandatory, Proj | oblig1 | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Proj posting rule | regel2 | ztInteger | 1 |  | smallint
Proj posting rule | regelbeskr2 | ztString | 50 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xl2 Posting rule/projects


Project sources (xf)

Definition of contact/project source types, i.e. how contacts/projects arise, e.g. Bid procedure, Advertisement, Reference, according to internal need.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Project source | ProjInit | ztInteger | 2 |  | smallint
Project source | ProjInitBeskr | ztString | 20 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxf Project sources


Project status (xe)

Definition of existing project status codes and descriptions. These are used to specify/follow a project in the work flow.

The following standard records exist. Do not alter/delete:

Project status (ProjStatKod) | Project status (ProjStatBeskr) | Description
0 | Under entry | This status should be used to flag that the project has not been properly completed, e.g. that there is not enough information to be able to report and invoice hours and expenses on the project. If invoicing and posting are performed despite this status, an error message displays on the voucher row.
1 | Decided | Used to flag that the project has been decided but is not yet active. This status is only for information, there is no logic linked to the status.
2 | Planned | Used to flag that the project has been planned but is not yet active. This status is only for information, there is no logic linked to the status.
3 | Active | There is a control parameter (in the program Jvsp) where you can specify that only projects with ‘Active’ status can be invoiced.
4 | Under guarantee | Used to flag that the project is being carried out on guarantee, i.e. will not be invoiced. This status is only for information, i.e. no logic is linked to the status.
7 | Close in progress | Used for final posting of projects with percentage of completion accounting using the Cancel profit recognition button (PB_Prj_Avboka_Psvt) and when posting fixed cost projects using the Fix cost proj chrgd to expnses function button (PB_Prj_Fastpris_Kontering) in the project form.
8 | Closed | Used to flag that the project is closed, i.e. that you can no longer report and invoice times and expenses on the project. If invoicing and posting are done despite this status, an error message displays on the voucher row.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project status | ProjStatBeskr | ztString | 50 |  | varchar
Project status | ProjStatKod | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxe Project status


Project trans->GL (Pkrl)

Detailed information per transaction of how project transactions are posted when integrated with the General Ledger.
Log of all changes!!! The log record shows what the record looked like before changes/deletion.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
ProjectTransType | ProjTransTyp | ztInteger | 2 |  | smallint
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Services account | Tjanstekonto | ztString | 8 |  | varchar


Project transaction types (xPtt)

Definition of existing project transaction types, i.e. different types of integration with the General Ledger for project movements.

The following standard records exist. Do not alter/delete:

ProjectTransType (ProjTransTyp) | ProjectTransType (ProjTransBeskr) | Description
0 | Cost posting | Posting of the project's costs. Created via the program 'Cost accts for Time/Proj/Assmnts' (pkkj).
1 | Percentage of completion accg | Posting created in the Project program (prj) by running a report for percentage of completion accounting.
2 | Internal debiting | Posting of the project's internal debiting. Created via the program 'Internal invoice journal' (pkkj2).
3 | Cost accounts fixed cost project | Posting of fixed price projects. Created in the program 'Project' (prj) using the button 'Fixed cost proj chrgd to expnses'. The project must be a fixed price project with the status 'Close in progress', and 'Fixed price write off' must be filled in with an amount.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
ProjectTransType | ProjTransBeskr | ztString | 50 |  | varchar
ProjectTransType | ProjTransTyp | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xPtt Project transaction types


Project transactions->GL (Pkr)

Table of project posting rules with detailed information on how project transactions are to be posted when integrated with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
ProjectTransType | ProjTransTyp | ztInteger | 2 |  | smallint
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Services account | TjansteKonto | ztString | 8 |  | varchar


Project translation header (pjbh)

Main table for definition of templates for translation of the income accounts to the balance accounts when balancing a project.

The main table contains the identification and a brief description of each definition.

There is an underlying table (pjbd) for the details where you define intervals of income accounts and to which balance accounts these will be translated.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Translation -> balance acct | ProjTran2BalansId | ztString | 8 |  | varchar
Translation -> balance acct | ProjTran2BalansIdBeskr | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Pjbh Project costs to balance acct


Project translation, details (pjbd)

Details in definition of templates for translation of the income accounts to the balance accounts when balancing a project. Here you define the intervals of income accounts and to which balance accounts these will be translated.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
From account no. | FirstKtoNr | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
To account | LastKtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Translation -> balance acct | ProjTran2BalansId | ztString | 8 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Project types (xtd)

Numeric ID for project type.

The classification has no controling function. The purpose is only to make it easy to group and search for projects of different types, e.g. Marketing projects/Product development projects or Installation/Test/Training, and so on.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Project type | ProjType | ztInteger | 2 |  | smallint
Project type | ProjTypeD | ztString | 40 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xtd Project types


Project voucher rows (pjvr)

Project voucher rows.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approved by | AttestSign | ztString | 6 |  | varchar
Avräkningskonto | AvrKtoKod | ztBoolean |  |  | char
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Bundle no. | BuntNr | ZtLong | 9 |  | int
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Text | Edit | ztBlob | 1 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Posting date | HbUpDat | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Shortcut | KortKodVerRad | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Account type | KtoTyp | ztInteger | 3 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Preliminary voucher | OldVerNr | Jeeves_VchrNo | 9 |  | bigint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Bal->Inc year | ResultatBokatRedovisnAr | ztInteger | 5 |  | smallint
Bal->Inc voucher | ResultatBokatVerNr | Jeeves_VchrNo | 20 |  | bigint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Orig account no. | UrsprungsKtoNr | ztString | 8 |  | varchar
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint
Statuskod på rad | VrStMark | ztInteger | 2 |  | smallint
Uppdateringskod | VrUpdateCode | ztInteger | 1 |  | smallint
Voucher row text | VrVerText | ztString | 60 |  | varchar

    This table is the main table in the following programs:

    Program: Pjvr Project voucher rows


Project, to be invoiced, header (view) (vupj)

The view includes projects for continuous invoicing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Deducted invoice | AcDrawn | ztBoolean |  |  | char
Posting template | AutoRegel | ztString | 4 |  | varchar
Agreement type | AvtalsKod | ztInteger | 3 |  | smallint
Payment terms | BetKod | ztString | 2 |  | varchar
Detail posting | DetaljKontering | ztBoolean |  |  | char
District | DistrKod | ztString | 4 |  | varchar
Division code | DivisKod | ztString | 3 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Handling charge | ExpAvgKd | ztBoolean |  |  | char
Invoice to date | FaktTomDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight charge code | FraktAvgKd | ztBoolean |  |  | char
Delivery note Y/N | FsKd | ztBoolean |  |  | char
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Customer order date | KundBestDat | ztDate |  |  | datetime
Ordering dept | KundBestNamn | ztString | 36 |  | varchar
Customer order no. | KundBestNr | ztString | 30 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Invoicing address | KundFaktAdr | ztString | 36 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Customer reference | KundRef2 | ztString | 30 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Ship documents | LevHandlKod | ztBoolean |  |  | char
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Allocation template | MallFaktPeriod | ztInteger | 3 |  | smallint
Master project no. | MasterProjCode | ztString | 10 |  | varchar
Max date not invoiced | MaxEjFaktDat | ztDate |  |  | datetime
Min date not invoiced | MinEjFaktDat | ztDate |  |  | datetime
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Quotation/agreement | OffBeskr | ztString | 40 |  | varchar
Quote/Agreemt date | OffertDat | ztDate |  |  | datetime
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Quote/assignment status | OffStatus | ztString | 1 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order date | OrdDatum | ztDate |  |  | datetime
Order cost | OrdKostnad | ZtBaseCurrAmount | 14 | 2 | money
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Order value | OrdSum | ZtBaseCurrAmount | 14 | 2 | money
Order type | OrdTyp | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Service price list | PrislistaT | ztInteger | 6 |  | smallint
Pricing method | PrisTyp | ztInteger | 3 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Collective invoicing ID | SamFaktOffNr | ztString | 30 |  | varchar
Last invoice date | SerSenFakt | ztDate |  |  | datetime
End date invc period | SersSlutFakt | ztDate |  |  | datetime
Start date invc period | SerStartFakt | ztDate |  |  | datetime
Skrivskydd | SkrivUtskSk | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Sum items on invoice | SumitemOnInvoice | ztBoolean |  |  | char
Price ceiling | TakPrisAvt | ZtBaseCurrAmount | 12 | 2 | money
Price ceiling expense | TakPrisEx | ZtBaseCurrAmount | 12 | 2 | money
Invoicing type | UFakttyp | ztInteger | 3 |  | smallint
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Order amount, curr | VbOrdSum | ztMoney | 14 | 2 | money
Our reference | VRef | ztString | 30 |  | varchar


Properties, serial no. items (xik)

Definition of properties for serial no. items, as required.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Property | Indkod | ztInteger | 3 |  | smallint
Property | Indkoddescr | ztString | 30 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xik Properties, serial no. items


Purch overhead types (xbpo)

Table containing the overhead types to which supplier invoices can be connected. A default posting for a overhead can be defined for each overhead type. Overhead types can be freight, insurance, etc.

The following standard records exist. Do not alter/delete:

Purch OH type (InkOmkTyp) | Purch OH type (InkOmkTypBeskr)
1 | Freight
2 | Insurance
3 | Packaging
4 | Other expense-1
5 | Other expense-2

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Allocation purch OH | InkOmkFord | ztInteger | 5 |  | smallint
Purch OH type | InkOmkTyp | ztInteger | 5 |  | smallint
Purch OH type | InkOmkTypBeskr | ztString | 50 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Intrastat, allocation type | IntStatKostFordTyp | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xbpo Purch OH type


Purch overhead types, posting (xbok)

Table containing default posting by purchasing overhead type.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purch OH type | InkOmkTyp | ztInteger | 5 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Purch requisition, header (biah)

Data in the purchase order header.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
No. of rows (unproc.) | AntalRaderEjBeh | ZtLong | 5 |  | int
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Work group | ArbetsLag | ztString | 6 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Request disp date | BestBegLevDat | ztDate |  |  | datetime
Est disp date | BestBerLevDat | ztDate |  |  | datetime
Delivery date supplier quay | BestLevDatFranLevsKaj | ztDate |  |  | datetime
Dispatch method | BestLevsattKod | ztInteger | 2 |  | smallint
Dispatch terms | BestLevVilkKd | ztInteger | 2 |  | smallint
Promised disp date | BestLovLevDat | ztDate |  |  | datetime
PO type | BestTyp | ztInteger | 3 |  | smallint
PO order value | BestValue | ZtBaseCurrAmount | 14 | 2 | money
Purch requisition no. | BiaNr | ZtLong | 10 |  | int
Requisition status | biaStatus | ztInteger | 1 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
EditTmp | EditTmp | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Grouped by item | GrupperasPaartNr | ztString | 30 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Purchase forecast (suborder) | InkopsPrognos | ztBoolean |  |  | char
Purchasing role | inkopsroll | ztInteger | 4 |  | smallint
Internal company | InterntFtg | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Order for no. days | LevBestDagar | ztInteger | 3 |  | smallint
Days +/- on purch ord | LevBestSimDagar | ztInteger | 3 |  | smallint
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Er ref | LevRef1 | ztInteger | 6 |  | smallint
Supplier reference | LevRef2 | ztString | 50 |  | varchar
Text on PO | LevSpecTextBe | ztBoolean |  |  | char
Supplier specific text | LevTextKod | ztString | 4 |  | varchar
Subcontract flag | MarkLego | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Do not delete inc.req header | NoAutoDeleteBiah | ztBoolean |  |  | char
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Delivery addr, company | OrdLevAdr1 | ztString | 36 |  | varchar
Delivery address 1 | OrdLevAdr2 | ztString | 36 |  | varchar
Delivery address 2 | OrdLevAdr3 | ztString | 36 |  | varchar
Delivery address 3 | OrdLevAdr4 | ztString | 36 |  | varchar
A n v ä n d s e j !! | OrdLevAdr5 | ztString | 1 |  | varchar
Destination, district | OrdLevAdrBstOrt | ztString | 36 |  | varchar
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Quantity PDM | pdmcount | ZtLong | 10 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | regdat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Joint purchase days | SamInKopDagar | ztInteger | 5 |  | smallint
Joint prchs lead time in days | SamInKopHorisontDgr | ztInteger | 5 |  | smallint
Joint purchase (allowed) | SamInKopMark | ztBoolean |  |  | char
Joint purchase weeks | SamInKopVeckor | ztInteger | 5 |  | smallint
Skrivskydd | SkrivUtskSk | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Transport days | TransportTid | ztInteger | 3 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Purchase amt, curr | vb_levvarde | ztMoney | 14 | 2 | money
Purch value, curr | VbBestValue | ztMoney | 14 | 2 | money
Our reference | VRef | ztString | 30 |  | varchar
Unique ID link | wfrowuniqueid | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: biah Requisition

    Program: BiahAlla Req.


Purchase agreement header (bha)

Definition of purchase agreement with agreement designation (agreement header) drawn up with suppliers. You can also create/enter RFQs to suppliers here.

Details, possibly per inventory location, such as price, validity period, currency, quantities, etc., are stored under the purchase agreement header (in a separate table ‘Alternative suppliers’)).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Posting template | AutoRegel | ztString | 4 |  | varchar
New to PO date | AvtTomBestDat_Nytt | ztDate |  |  | datetime
New to disp date | AvtTomLevDat_Nytt | ztDate |  |  | datetime
Order text | BestEditExt | ztBlob | 1 |  | varchar
Dispatch method | BestLevsattKod | ztInteger | 2 |  | smallint
Dispatch terms | BestLevVilkKd | ztInteger | 2 |  | smallint
Agreed rate at order | BestToAvtalValKurs | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
No rounding | EjPrisAvrunda | ztBoolean |  |  | char
External purch agreem no. | ExtInkAvt | ztString | 20 |  | varchar
New ext agreem no. | ExtInkAvt_nytt | ztString | 20 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Valid to date | GiltigTomDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purchase agreement | InkAvtalBeskr | ztString | 25 |  | varchar
PO agreement date | InkAvtDat | ztDate |  |  | datetime
Purch agree type | InkAvtKod | ztInteger | 2 |  | smallint
Conversion % | InkAvtOmrProc | ztFloat | 6 | 2 | float
Purch agree status | InkAvtStatKod | ztInteger | 2 |  | smallint
Agreement to disp date | InkAvtTomDat | ztDate |  |  | datetime
Agreement to PO date | InkAvtTomDatBestH | ztDate |  |  | datetime
Print date | InkAvtUtskrDat | ztDateTime |  |  | datetime
Purch agree total amt | InkAvtValue | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Campaign | KampNr | ZtLong | 4 |  | int
Block purchase | KodBlockInkop | ztBoolean |  |  | char
External text -> PO | KodExtTextToBest | ztBoolean |  |  | char
Customer | KundNr | ztCompanyNo | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Adm lead time | LedTidAdm | ztInteger | 3 |  | smallint
Lead time from suppl | LedTidEnlLev | ztInteger | 3 |  | smallint
Lead time extra demand | LedTidExtra1 | ztInteger | 3 |  | smallint
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Er ref | LevRef1 | ztInteger | 6 |  | smallint
Supplier reference | LevRef2 | ztString | 50 |  | varchar
Supplier specific text | LevTextKod | ztString | 4 |  | varchar
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Delivery addr, company | OrdLevAdr1 | ztString | 36 |  | varchar
Delivery address 1 | OrdLevAdr2 | ztString | 36 |  | varchar
Delivery address 2 | OrdLevAdr3 | ztString | 36 |  | varchar
Delivery address 3 | OrdLevAdr4 | ztString | 36 |  | varchar
Destination, district | OrdLevAdrBstOrt | ztString | 36 |  | varchar
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Skrivskydd | SkrivUtskSk | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Transport days | TransportTid | ztInteger | 3 |  | smallint
Exchg rate date | ValDat | ztDate |  |  | datetime
Exchange rate, calc | ValKalkKurs | ZtCurrencyRate | 10 | 5 | decimal
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Purch value, curr | VbBestValue | ztMoney | 14 | 2 | money
Our reference | VRef | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: bha Purchase agreement/RFQ, supplier

    Program: BhaBia RFQ from requisition


Purchase agreement status (xa9)

Table giving different statuses where a purchase agreement can be given. This data is used to follow a purchase agreement through processing.

The following standard records exist. Do not alter/delete:

Purch agree status (InkAvtStatKod) | Purch agree status (InkAvtStBeskr) | Description
0 | Forecast |
1 | Request for quotation |
2 | Quotation |
3 | Agreement | This status is set manually at manual entry of purchase agreements drawn up. It is also set automatically on purchase agreements created based on customer quotations/agreements.
9 | Canceled | Note that it is not enough to change the status in the agreement header to ‘Canceled’. On requisitions and purchase orders, prices can be retrieved from the agreement as long as there are agreement rows, i.e. you must delete the rows in question for the cancellation to take effect.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purch agree status | InkAvtStatKod | ztInteger | 2 |  | smallint
Purch agree status | InkAvtStBeskr | ztString | 50 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Reg PO from agreement | KodBestFranAvtal | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxa9 Purch agree status


Purchase agreement types (xa8)

Table of different purchase agreement types that can be used when purchasing goods and services.

The following standard records exist. Do not alter/delete:

Purch agree type (InkAvtKod) | Purch agree type (InkAvtTybBeskr)
0 | Prel RFQ
1 | EDI order

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purch agree type | InkAvtKod | ztInteger | 2 |  | smallint
Purch agree type | InkAvtTybBeskr | ztString | 50 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxa8 Purch agree type


Purchase claims (irk)

Claims, e.g. protests and opinions about purchases.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Revision date | ArtRevDat | ztDate |  |  | datetime
Revision no. | ArtRevId | ztString | 10 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Department | AvdelningsBeskr | ztString | 50 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Order qty (invtry unit) | BestAnt | ZtQty | 14 | 2 | decimal
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
Delivery received date | BestLevDat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Actual finish date | ClaimActEndDt | ztDate |  |  | datetime
Activity status | ClaimActivityStatus | ztInteger | 4 |  | smallint
Claimed actual qty | ClaimActQty | ZtQty | 14 | 2 | decimal
Claim expense | ClaimCostTotal | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 1 | ClaimCostType1 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 2 | ClaimCostType2 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 3 | ClaimCostType3 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 4 | ClaimCostType4 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 5 | ClaimCostType5 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 6 | ClaimCostType6 | ZtBaseCurrAmount | 14 | 2 | money
Claim expense 7 | ClaimCostType7 | ZtBaseCurrAmount | 14 | 2 | money
Claim | ClaimNo | ZtLong | 10 |  | int
Counterpart claim number | ClaimNoCounterPart | ztString | 30 |  | varchar
Planned finish date | ClaimPlEndDt | ztDate |  |  | datetime
Claimed quantity | ClaimQty | ZtQty | 14 | 2 | decimal
Revised quantity | ClaimRepairQty | ZtQty | 14 | 2 | decimal
Claim manager | ClaimResp | ztString | 8 |  | varchar
Scrapped qty | ClaimScrapQty | ZtQty | 14 | 2 | decimal
Claim origination | ClaimSrcCd | ztInteger | 5 |  | smallint
Claim origination | ClaimSrcDescr | ztString | 60 |  | varchar
Activity order | ClaimWFSeqNo | ztInteger | 5 |  | smallint
Claim flow | ClaimWorkFlow | ZtLong | 10 |  | int
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Planned activity descr | EventNote | ztString | 60 |  | varchar
Report date | EventRpDat | ztDate |  |  | datetime
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Purchasing manager | InkHandlBeskr | ztString | 40 |  | varchar
Purchase claim reason | InkopReklamationOrsak | ztInteger | 5 |  | smallint
Purchase claim reason group | InkopReklamationOrsakGrp | ztInteger | 5 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Price | Pris | ZtBaseCurrAmount | 14 | 2 | money
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Quality Categori (MO/PO/SO) | Qkategori | ztInteger | 5 |  | smallint
Quality to do no. | QualityCheckToDo_No | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
RMA number | RMAnr | ztString | 30 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: irk Purchase claims

    Program: rIrkAr Claims, item, date

    Program: rIrkArO Claims, item, reason

    Program: rIrkLev Claims, suppliers


Purchase cost per batch, detail row (khlb)

Detail row for purchase costs on batch record.

A number of detail rows can be entered for each batch record (bat) for additional purchase costs (e.g. freight, insurance) above the actual purchase price of the batch.
The additional purchase costs that are entered as calculation details affect the purchase cost for the batch item.

The possible purchase costs are defined in a table for calculation details (xkd) in the system.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calc detail type | KalkDetKod | ztInteger | 2 |  | smallint
Cost, amount | KostnadBelopp | ZtBaseCurrAmount | 14 | 2 | money
Cost per unit | KostnadEnhet | ZtBaseCurrAmount | 14 | 2 | money
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: khlb Calculation batch


Purchase order arrival (WMS) (WMS_V_EXT_POLineRec)

Purchase order number.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Arrival entered | AnkomstRapporterad | ztBoolean |  |  | char
Item description | ArtBeskr | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | nvarchar
Order qty (invtry unit) | BestAnt | ZtQty | 14 | 2 | decimal
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
PO status | BestStatKod | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Cancel remain qty | MakuleraRestAntal | ztBoolean |  |  | nvarchar
MHA | Mha | ztString | 5 |  | nvarchar
Number of SKU | NumberOfSKU | ztInteger | 5 |  | decimal
Pallet unit type | PalletUnitType | ztString | 5 |  | varchar
Full pallet quantity | PartDefFullUnitQty | ZtQty | 14 | 2 | decimal
Pallet unit type | PartDefFullUnitType | ztString | 5 |  | varchar
Qty / SKU | QtyPerSKU | ZtQty | 14 | 2 | decimal
Qty to receive | QtyToReceive | ZtQty | 14 | 2 | decimal

    This table is the main table in the following programs:

    Program: WMS_EXT_POLineRec Purchase order arrival WMS


Purchase order details for season (PVMSeasonDetailPur)

Definition of seasons for purchase orders. For more information see the example in the help for the Seasons program (PVMSeason).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
PO type | BestTyp | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Allow | PvmSeasonAllow | ztBoolean |  |  | char
Season end | PVMSeasonEnd | ztDate |  |  | datetime
Season | PVMSeasonId | ztString | 15 |  | varchar
Season start | PVMSeasonStart | ztDate |  |  | datetime
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Purchase order header (bh)

Data in the purchase order header.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Arrival entered | AnkomstRapporterad | ztBoolean |  |  | char
Arrival text | AnkomstText | ztBlob | 1 |  | varchar
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Approved by | AttestSign | ztString | 6 |  | varchar
Approval chain | AttKedja | ztInteger | 5 |  | smallint
Posting template | AutoRegel | ztString | 4 |  | varchar
Lead time from | BasDatLedTid | ztDate |  |  | datetime
Request disp date | BestBegLevDat | ztDate |  |  | datetime
Est disp date | BestBerLevDat | ztDate |  |  | datetime
Upd agrmt fr invoice | BestFaktPris2Avtal | ztBoolean |  |  | char
Delivery note date, rcv | BestFoljesedelsDat | ztDate |  |  | datetime
Delivery note no., rcv | BestFoljesedelsNr | ztString | 30 |  | varchar
Upd agrmt fr purch order | BestInpris2Avtal | ztBoolean |  |  | char
Delivery received date | BestLevDat | ztDate |  |  | datetime
Delivery date supplier quay | BestLevDatFranLevsKaj | ztDate |  |  | datetime
Dispatch method | BestLevsattKod | ztInteger | 2 |  | smallint
PO value | BestLevValue | ZtBaseCurrAmount | 14 | 2 | money
Dispatch terms | BestLevVilkKd | ztInteger | 2 |  | smallint
Promised disp date | BestLovLevDat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Purch order no. (alpha) | BestNrAlfa | ztString | 50 |  | varchar
Confirmed date | BestOEDatum | ztDate |  |  | datetime
Confirmed by | BestOESign | ztString | 6 |  | varchar
Entry date | BestRegDat | ztDate |  |  | datetime
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Amount excl. tax | BestRkgValue | ZtBaseCurrAmount | 14 | 2 | money
PO status | BestStatKod | ztInteger | 2 |  | smallint
PO type | BestTyp | ztInteger | 3 |  | smallint
PO order value | BestValue | ZtBaseCurrAmount | 14 | 2 | money
PO print date | BHUtskrDat | ztDateTime |  |  | datetime
Purch requisition no. | BiaNr | ZtLong | 10 |  | int
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Print date | D | ztDate |  |  | datetime
Delivery from business unit ICT | DelivFromBusinessUnit | ztString | 8 |  | varchar
Dispatch from order | DelivFromOrderNo | ZtLong | 10 |  | int
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Own invoice no. | Egen_FaktNr | Jeeves_InvNo | 9 |  | bigint
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Ext Bestnr | ExtBestNr | ztString | 17 |  | varchar
Invc match value | FaktAvprVarde | ztMoney | 14 | 2 | money
Due date | FaktFfDat | ztDate |  |  | datetime
Invoice from company | FaktFranFtgNr | ztCompanyNo | 20 |  | varchar
Change calc price/item | FaktInpris2Artikel | ztBoolean |  |  | char
Overhead/PO | FaktOmkVarde | ZtBaseCurrAmount | 14 | 2 | money
RFQ printed | FfUtskrDat | ztDateTime |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Förkop till kundorder | Forkop_Oh_OrderNr | Jeeves_SONo | 20 |  | bigint
Months +/- on sales agreemt | FsgTidSimManad | ztInteger | 3 |  | smallint
Reason code | FsOrsakKod | ztInteger | 5 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Joint purchase date limit | HorisontDatum | ztDate |  |  | datetime
From order no. ICT | ICTDelivFromOrderNo | ZtLong | 10 |  | int
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Purchase forecast (suborder) | InkopsPrognos | ztBoolean |  |  | char
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Internal company | InterntFtg | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Intrastat trans type | IntStatTransTyp | ztInteger | 2 |  | smallint
Inventory location WMS | InventoryLocWMS | ztBoolean |  |  | char
Orderspec rcv CC | KstOULager | ztString | 8 |  | varchar
Orderspec rcv account | KtoNrOULager | ztString | 8 |  | varchar
Customer | KundNr | ztCompanyNo | 20 |  | varchar
Inventory transfer | LagerFlyttning | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Joint prch suitable send date | LampligtSandDatum | ztDate |  |  | datetime
Order for no. days | LevBestDagar | ztInteger | 3 |  | smallint
Days +/- on purch ord | LevBestSimDagar | ztInteger | 3 |  | smallint
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Invoice Type | LevFaktTyp | ztInteger | 3 |  | smallint
Supplier confirm date | levOrderdat | ztDate |  |  | datetime
Supplier order number | levordernr | ztString | 30 |  | varchar
Disp.plan number | LevPlanNr | ZtLong | 10 |  | int
Er ref | LevRef1 | ztInteger | 6 |  | smallint
Supplier reference | LevRef2 | ztString | 50 |  | varchar
Text on PO | LevSpecTextBe | ztBoolean |  |  | char
Supplier specific text | LevTextKod | ztString | 4 |  | varchar
Delivery time acc to PO header | LevTidEnlBestHuvud | ztBoolean |  |  | char
Man reconc, change date | ManReAvstDT | ztDateTime |  |  | datetime
Man reconc, date | ManReAvstPerDen | ztDate |  |  | datetime
Man reconc, sign | ManReAvstPersSign | ztString | 6 |  | varchar
Subcontract flag | MarkLego | ztBoolean |  |  | char
Dispatch plan | MarkLevPlanUt | ztBoolean |  |  | char
New OA printed | MarkNyttBestOEUtskr | ztBoolean |  |  | char
Tax date | MomsDatum | ztDate |  |  | datetime
Invoice date | MomsFaktDatum | ztDate |  |  | datetime
VAT/tax invc created | MomsFaktStatus | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
OLE-1 | ole1 | ztString | 255 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Delivery addr, company | OrdLevAdr1 | ztString | 36 |  | varchar
Delivery address 1 | OrdLevAdr2 | ztString | 36 |  | varchar
Delivery address 2 | OrdLevAdr3 | ztString | 36 |  | varchar
Delivery address 3 | OrdLevAdr4 | ztString | 36 |  | varchar
A n v ä n d s e j !! | OrdLevAdr5 | ztString | 1 |  | varchar
Destination, district | OrdLevAdrBstOrt | ztString | 36 |  | varchar
Destination, country | OrdLevAdrLandsKod | ztString | 3 |  | varchar
State code | OrdLevAdrProvinceCode | ztString | 5 |  | varchar
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Purchase agreem designation | PInkAvt | ZtLong | 6 |  | int
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Season | PVMSeasonId | ztString | 15 |  | varchar
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Klar för trans från lev | RappKlarForTransp | ztDate |  |  | datetime
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | regdat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Joint purchase days | SamInKopDagar | ztInteger | 5 |  | smallint
Joint prchs lead time in days | SamInKopHorisontDgr | ztInteger | 5 |  | smallint
Joint purchase (allowed) | SamInKopMark | ztBoolean |  |  | char
Joint purchase weeks | SamInKopVeckor | ztInteger | 5 |  | smallint
Send EDI | SendEdi | ztBoolean |  |  | char
Sent EDI | SendEdiDT | ztDateTime |  |  | datetime
Serv.order no | ServOrderNr | Jeeves_SONo | 9 |  | bigint
Fabriksid | SiteId | ztInteger | 4 |  | smallint
Skrivskydd | SkrivUtskSk | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Time sqlcmd->trg start | SQLCmd2EnterTrg | ZtLong | 10 |  | int
Start av updatering/insert | SqlStmtStartedDT | ztDateTime |  |  | datetime
Stock replenishment ICT | StockReplenishment | ztBoolean |  |  | char
Requisition | StrDateTimeBIA | ztString | 28 |  | varchar
Forward contract | TerminsNr | ZtLong | 10 |  | int
Covered | TerminsSakrad | ztBoolean |  |  | char
Text after document rows | TextEfterDokRader | ztBoolean |  |  | char
Transport days | TransportTid | ztInteger | 3 |  | smallint
Payment methods | UtbSlag | ztString | 3 |  | varchar
Print PO order acknowl | UtskrBestDokLovSkaGoras | ztBoolean |  |  | char
Print date new OA | UtskrBestDokLovUtskrDT | ztDateTime |  |  | datetime
Reprint purch order | UtskrBestDokSkaGoras | ztBoolean |  |  | char
New PO print date | UtskrBestDokUtskrDT | ztDateTime |  |  | datetime
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax deductible | VAT_Type1 | ztInteger | 4 |  | smallint
VAT/tax invoice, reprint | VATinvRecreated | ztBoolean |  |  | char
Purchase amt, curr | vb_levvarde | ztMoney | 14 | 2 | money
Purch value, curr | VbBestValue | ztMoney | 14 | 2 | money
Invoice amount, curr | VbFaktValue | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Our reference | VRef | ztString | 30 |  | varchar
Unique ID link | WfRowUniqueID | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: Be Purchase orders

    Program: BeAnk Arrival reports (old)

    Program: BeAnk2 Arrival entry

    Program: BeAo PO from MPC operation (all MOs)

    Program: BeAoT PO from MPC operation per order

    Program: BeArt PO from item

    Program: bebha PO from agreement

    Program: BeFakt1 Invoice matching

    Program: beia PO from requisition

    Program: BeInlev Receive deliveries

    Program: BeInlevX Received delivery -> picking

    Program: BeMr PO from material reservation

    Program: beoh PO from customer order

    Program: bepal Create PO from quotation

    Program: Bepbha PO from item

    Program: BeSRapp1 Manually close purchase orders in GL


Purchase order rows (bp)

All purchase order rows with links to deliveries and invoice matching.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Booking of purchase order | AllowBookingPO | ztBoolean |  |  | char
Replan in net req | AllowReplanInNetReq | ztBoolean |  |  | char
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Arrival qty invtry unit | AnkomstLevAnt | ZtQty | 14 | 2 | decimal
Arrival qty (suppl unit) | AnkomstLevAntExtQty | ZtQty | 14 | 2 | decimal
Arrival entered | AnkomstRapporterad | ztBoolean |  |  | char
To receive | AntalAttInLev | ZtQty | 14 | 2 | decimal
Decimal places | AntDec | ztInteger | 1 |  | smallint
Number of decs (ext) | AntDecExtQty | ztInteger | 1 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Work group | ArbetsLag | ztString | 6 |  | varchar
Bin | ars_LagPlats | ztBinLocation | 20 |  | varchar
Item description | ArtBeskr | ztString | 30 |  | varchar
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Cost price at order | ArtKalkPrisO | ZtBaseCurrAmount | 14 | 2 | money
This field is used in the table as follows: |
Cost at order (mtrl) | ArtKalkPrisOMtrl | ZtBaseCurrAmount | 14 | 2 | money
Item class | ArtKod | ztInteger | 3 |  | smallint
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Revision no. | ArtRevId | ztString | 10 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Uppdat kalk.pris | ArtUppdatera | ztString | 1 |  | varchar
Volume m3 | ArtVolym | ztFloat | 15 | 4 | float
Degree of commitment | AtagandeGrad | ztInteger | 2 |  | smallint
Repurchase, serial no | AterKopArtSerieNr | ztBoolean |  |  | char
Auto created PO row | AutoBestLine | ztInteger | 5 |  | smallint
Posting template | AutoRegel | ztString | 4 |  | varchar
Notified qty (invtry unit) | AviseratAntalLagerFlyttning | ZtQty | 14 | 2 | decimal
Pieces | BAntalStyck | ZtQty | 14 | 2 | decimal
Lead time from | BasDatLedTid | ztDate |  |  | datetime
Base(prefix) for batch | BaseBatId | ztString | 30 |  | varchar
Sequence number for batch | BaseBatIdInc | ZtLong | 10 |  | int
Batch no. required | BatchBokas | ztBoolean |  |  | char
Order qty (invtry unit) | BestAnt | ZtQty | 14 | 2 | decimal
Ordered qty, alt unit | BestAntAltEnh | ZtQty | 14 | 2 | decimal
Order qty (suppl unit) | BestAntExtQty | ZtQty | 14 | 2 | decimal
Request disp date | BestBegLevDat | ztDate |  |  | datetime
Req to date (int) | BestBehovDat | ztDate |  |  | datetime
Req to date ext | BestBehovLevDat | ztDate |  |  | datetime
Est disp date | BestBerLevDat | ztDate |  |  | datetime
Order date acc. lead time | BestDatEnlLedTid | ztDate |  |  | datetime
No disp. check statistics | BestEjMed | ztBoolean |  |  | char
Upd agrmt fr invoice | BestFaktPris2Avtal | ztBoolean |  |  | char
Purchase price | BestInpris | ZtBaseCurrAmount | 14 | 2 | money
Upd agrmt fr purch order | BestInpris2Avtal | ztBoolean |  |  | char
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
Received qty, alt unit | BestLevAntAltEnh | ZtQty | 14 | 2 | decimal
Received qty (suppl unit) | BestLevAntExtQty | ZtQty | 14 | 2 | decimal
Delivery received date | BestLevDat | ztDate |  |  | datetime
Delivery date supplier quay | BestLevDatFranLevsKaj | ztDate |  |  | datetime
Delivery date to quay | BestLevDatTillKaj | ztDate |  |  | datetime
Promised disp date | BestLovLevDat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Purch order no. (alpha) | BestNrAlfa | ztString | 50 |  | varchar
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
Orig row no in order | BestRadNrUrspr | ztInteger | 4 |  | smallint
Code row split, PO | BestRadSplitKod | ztInteger | 5 |  | smallint
Entry date | BestRegDat | ztDate |  |  | datetime
Remaining qty invtry unit | BestRestAnt | ZtQty | 14 | 2 | decimal
Remaining qty, alt unit | BestRestAntAltEnh | ZtQty | 14 | 2 | decimal
Remaining qty (suppl unit) | BestRestAntExtQty | ZtQty | 14 | 2 | decimal
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
PO status | BestStatKod | ztInteger | 2 |  | smallint
Upd BestStat | BestStatUpdKod | ztBoolean |  |  | char
PO type | BestTyp | ztInteger | 3 |  | smallint
PO order value | BestValue | ZtBaseCurrAmount | 14 | 2 | money
Prel purchase price | BestWinPris | ztMoney | 14 | 2 | money
Figure no. | BFigNr | ztString | 6 |  | varchar
Purch requisition no. | BiaNr | ZtLong | 10 |  | int
Quantity per piece | BKvantPerStyck | ztFloat | 12 | 4 | float
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Accounting date | BokfDat | ztDate |  |  | datetime
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Model | BVariant | ztInteger | 4 |  | smallint
Certifikat | Certifikat | ztString | 30 |  | varchar
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Dispatch from order | DelivFromBackorderNo | ztInteger | 5 |  | smallint
Delivery from business unit ICT | DelivFromBusinessUnit | ztString | 8 |  | varchar
Dispatch from order | DelivFromOrderNo | ZtLong | 10 |  | int
Dispatch from order | DelivFromOrdLnNo | ztInteger | 5 |  | smallint
Dispatch from order | DelivFromOrdSubLnNo | ztInteger | 5 |  | smallint
Diff picked and received | DiffPickedAmtRecAmt | ZtBaseCurrAmount | 14 | 2 | money
Diff picked and received | DiffPickedQtyRecQty | ZtQty | 14 | 2 | decimal
Dimension 1 | Dimension1 | ztFloat | 15 | 2 | float
Dimension 2 | Dimension2 | ztFloat | 15 | 2 | float
Dimension 3 | Dimension3 | ztFloat | 15 | 2 | float
Drop ship | DirektLeverans | ztBoolean |  |  | char
Avail | Dispens | ztBoolean |  |  | char
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Ext Bestnr | ExtBestNr | ztString | 17 |  | varchar
ExtBestradnr | ExtBestRadNr | ztInteger | 4 |  | smallint
ExtBestrestnr | ExtBestRestNr | ztInteger | 2 |  | smallint
Ext Best subradnr | ExtBestSubRadNr | ztInteger | 4 |  | smallint
External purch agreem no. | ExtInkAvt | ztString | 20 |  | varchar
Invc checked qty | FaktAvprAntal | ZtQty | 14 | 2 | decimal
InvcCheckQtyExt | FaktAvprAntalExtQty | ZtQty | 14 | 2 | decimal
Fakt avpr försl enl | FaktAvprForslEnl | ztInteger | 5 |  | smallint
Invc match value | FaktAvprVarde | ztMoney | 14 | 2 | money
Change calc price/item | FaktInpris2Artikel | ztBoolean |  |  | char
Overhead/qty | FaktOmkKvantitet | ztFloat | 15 | 2 | float
Overhead/PO | FaktOmkVarde | ZtBaseCurrAmount | 14 | 2 | money
Previous dispatch plan | FLevPlanNr | ztString | 17 |  | varchar
Prev Del.plan row no. | FLevPlanRadNr | ZtLong | 10 |  | int
Consumables | ForbrukningsMaterial | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Förköp till kundorder | ForKop_Oh | ztBoolean |  |  | char
Förkop till kundorder | Forkop_Oh_OrderNr | Jeeves_SONo | 20 |  | bigint
Advance booking | ForKop_Th | ztBoolean |  |  | char
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Grouped by item | GrupperasPaartNr | ztString | 30 |  | varchar
From backorder no. ICT | ICTDelivFromBackorderNo | ztInteger | 5 |  | smallint
From order no. ICT | ICTDelivFromOrderNo | ZtLong | 10 |  | int
From order row no. ICT | ICTDelivFromOrdLnNo | ztInteger | 5 |  | smallint
From order row no. for pkg ICT | ICTDelivFromOrdSubLnNo | ztInteger | 5 |  | smallint
Order row status ICT | ICTOrdLnStatus | ztInteger | 5 |  | smallint
Booking status ICT | ICTOrdResrvStat | ztInteger | 5 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Price conv factor | InkArtOmvFaktor | ztFloat | 14 | 4 | float
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Suborder purchase | InkopsAvropsBestNr | ZtLong | 10 |  | int
InköpsPrognos Rad | InkopsAvropsRadNr | ZtLong | 10 |  | int
Purchase forecast (suborder) | InkopsPrognos | ztBoolean |  |  | char
Purch value to invc match | InkopsVardeAttFaktAvpr | ZtBaseCurrAmount | 14 | 2 | money
Price unit factor | InkPrisPer | ZtDecimal73 | 8 | 3 | decimal
To receive, blocked inventory | InLevAntalSparrat | ZtQty | 14 | 2 | decimal
Receive directly | InlevDirekt | ztBoolean |  |  | char
Inlev enl dagskurs | InlevEnlAktValKurs | ztBoolean |  |  | char
Receiving value | InlevKalkVarde | ZtBaseCurrAmount | 14 | 2 | money
Calc delivery value (adjustm) | InlevKalkVardeJustering | ZtBaseCurrAmount | 14 | 2 | money
Calc val rcvd mtrl | InlevKalkVardeMtrl | ZtBaseCurrAmount | 14 | 2 | money
Upd InlevStat | InlevStatUpdKod | ztBoolean |  |  | char
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Intrastat trans type | IntStatTransTyp | ztInteger | 2 |  | smallint
Inventory location WMS | InventoryLocWMS | ztBoolean |  |  | char
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Calendar, fix disp dates | KalFastLevDagNr | ztInteger | 2 |  | smallint
Allocated time, subcontr cap | KapLegoAnslagenTid | ztOpTime | 9 | 4 | float
External text -> PO | KodExtTextToBest | ztBoolean |  |  | char
Checked qty | KontrolleratAntal | ZtQty | 14 | 2 | decimal
Checked qty (suppl's unit) | KontrolleratAntalExtQty | ZtQty | 14 | 2 | decimal
Purchase of item | KopAvArtikel | ztBoolean |  |  | char
Buy manuf of item | KopTillvAvArtikel | ztBoolean |  |  | char
KörID | KorId | ZtLong | 10 |  | int
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
Corr plan qty (suppl unit) | KorrAntalInExtQty | ZtQty | 14 | 2 | decimal
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Quantity to match | LagerAntalAttFaktAvpr | ZtQty | 14 | 2 | decimal
Antal att fakt.avpr | LagerAntalAttFaktAvprEQ | ZtQty | 14 | 2 | decimal
Stocked | LagerBokas | ztBoolean |  |  | char
Inventory transfer | LagerFlyttning | ztBoolean |  |  | char
Amount to match | LagerVardeAttFaktAvpr | ZtBaseCurrAmount | 14 | 2 | money
Value to price | LagerVardeEnlInPris | ztBoolean |  |  | char
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Lagerst för OU-lager | LagStalleOULager | ztString | 2 |  | varchar
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Adm lead time | LedTidAdm | ztInteger | 3 |  | smallint
Lead time from suppl | LedTidEnlLev | ztInteger | 3 |  | smallint
Lead time extra demand | LedTidExtra1 | ztInteger | 3 |  | smallint
Surcharge, alloying | LegeringsTillaggId | ZtLong | 10 |  | int
Surcharge, alloying | LegeringsTillaggKost | ZtBaseCurrAmount | 14 | 2 | money
Surcharge, alloying (%) | LegeringsTillaggProc | ZtDecimal73 | 8 | 3 | decimal
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Del.plan, no replanning | LevPlanEjOmPlan | ztBoolean |  |  | char
Disp.plan number | LevPlanNr | ZtLong | 10 |  | int
Dispatch plan row no. | LevPlanRadNr | ZtLong | 10 |  | int
Supplier item descr | LevsArtBeskr | ztString | 255 |  | varchar
Cancel remain qty | MakuleraRestAntal | ztBoolean |  |  | char
Manual date handling | ManDateHandlingPO | ztBoolean |  |  | char
Man reconc, change date | ManReAvstDT | ztDateTime |  |  | datetime
Man reconc, date | ManReAvstPerDen | ztDate |  |  | datetime
Man reconc, sign | ManReAvstPersSign | ztString | 6 |  | varchar
No purchase agreement | MarkInkAvtSaknas | ztBoolean |  |  | char
Subcontract flag | MarkLego | ztBoolean |  |  | char
Dispatch plan | MarkLevPlanUt | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Min order qty | MinAntalBest | ZtQty | 14 | 2 | decimal
Min order qty (ext) | MinAntalBestExtQty | ZtQty | 14 | 2 | decimal
Supplier invoice no. | MomsFaktBestRkgNr | ztString | 25 |  | varchar
Invoiced error | MomsFaktFel | ztBoolean |  |  | char
Supplier | MomsFaktLevNr | ztCompanyNo | 20 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Deliv. invoice date | MomsLevfaktdat | ztDate |  |  | datetime
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
B quantity | OrdAntalB | ztFloat | 15 | 2 | float
C quantity | OrdAntalC | ztFloat | 15 | 2 | float
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Preparation day | OrdBerednDat | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Order spec text | OrpRadText | ztString | 255 |  | varchar
Excess delivery>customer | OverDelivToCustomer | ztBoolean |  |  | char
Package item | PaketArtikel | ztBoolean |  |  | char
Quantity PDM | PdmCount | ZtLong | 10 |  | int
PDM (Unique ID) | PdmDummyUniqueId | ztUniqueIdentifier | 100 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Prel post tax amount | PrelKonteradMomsBelopp | ZtBaseCurrAmount | 14 | 2 | money
Pricing type | PrisHantTyp | ztInteger | 3 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Error msg from matrix | PvmErrMessage | ztBlob | 2000 |  | varchar
@zPrompt=null | PvmGridNo | ztInteger | 3 |  | smallint
Pick prop inventory | PvmPickPropInv | ZtQty | 14 | 2 | decimal
Picking proposal qty | PvmPickPropQty | ZtQty | 14 | 2 | decimal
Product variant management Row | PvmRowIsPvm | ztInteger | 3 |  | smallint
Warning (on variant) | PvmWarningMessage | ztBlob | 2000 |  | varchar
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Klar för trans från lev | RappKlarForTransp | ztDate |  |  | datetime
Entry date | RegDat | ztDate |  |  | datetime
Returned qty invtry unit | ReturAnt | ZtQty | 14 | 2 | decimal
Returned qty (suppl unit) | ReturAntExtQty | ZtQty | 14 | 2 | decimal
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Serial no. required | SerieNrBokas | ztBoolean |  |  | char
Serv.order no | ServOrderNr | Jeeves_SONo | 9 |  | bigint
Order row, service | ServOrdRadNr | ztInteger | 5 |  | int
Fabriksid | SiteId | ztInteger | 4 |  | smallint
Check | SkaKontrolleras | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Time sqlcmd->trg start | SQLCmd2EnterTrg | ZtLong | 10 |  | int
Start av updatering/insert | SqlStmtStartedDT | ztDateTime |  |  | datetime
Change type new OA | StatusKodNyttOE | ztInteger | 5 |  | smallint
Invtry unit->Purch unit | StockQty2SuppQty | ztFloat | 12 | 6 | float
Stock replenishment ICT | StockReplenishment | ztBoolean |  |  | char
Requisition | StrDateTimeBia | ztString | 28 |  | varchar
Inköpsanmodan | StrDateTimepal | ztString | 28 |  | varchar
BOM for item | StycklistaTillArtNr | ztString | 30 |  | varchar
Forward contract | TerminsNr | ZtLong | 10 |  | int
Covered | TerminsSakrad | ztBoolean |  |  | char
ID for connection | Ti_LopNr_Ned | ZtLong | 10 |  | int
No. of times to Astro | TimesToAstro | ztInteger | 5 |  | smallint
Transit delivery | TransitLeverans | ztBoolean |  |  | char
Transport days | TransportTid | ztInteger | 3 |  | smallint
Orig PO (invtry) | UrsprBestAnt | ZtQty | 14 | 2 | decimal
Orig PO (suppl's unit) | UrsprBestAntExtQty | ZtQty | 14 | 2 | decimal
Print PO qty | UtskrBestDokAntal | ZtQty | 14 | 2 | decimal
Print disp date | UtskrBestDokLevDat | ztDate |  |  | datetime
Print PO order acknowl | UtskrBestDokLovSkaGoras | ztBoolean |  |  | char
Print date new OA | UtskrBestDokLovUtskrDT | ztDateTime |  |  | datetime
Print req price | UtskrBestDokPris | ZtPurPrice | 12 | 2 | money
Reprint purch order | UtskrBestDokSkaGoras | ztBoolean |  |  | char
New PO print date | UtskrBestDokUtskrDT | ztDateTime |  |  | datetime
Deliv from MO | UttagFranAoNr | Jeeves_MONo | 7 |  | bigint
Deliv from MO Pos | UttagFranAoPos | ztInteger | 5 |  | int
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Gross purch price, curr (mtrl) | vb_inpris_mtrl | ztMoney | 14 | 2 | money
Gross setup price, curr | Vb_InPris_Stall | ztMoney | 14 | 2 | money
Gross start purch price, curr | Vb_InPris_Start | ztMoney | 14 | 2 | money
Gross purch prc, excl alloy | Vb_InPrisBas | ztMoney | 14 | 2 | money
Purchase price incl tax | Vb_InPrisInklMoms | ztMoney | 14 | 2 | money
Purch value, curr | VbBestValue | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: BeSRapp2 Manually close purchase order rows in GL

    Program: bp Purchase order rows

    Program: bp_a Purchase order rows

    Program: BpqQdin Q - data (purchase order)

    Program: DiffSO2POTransfer Purchase order rows, transfers

    Program: POLinesStockTransfer PO rows, inventory transfer


Purchase price list, header (bprh)

Table of data in the price list header of the purchase price list (price/discounts).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
No rounding | EjPrisAvrunda | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Campaign start date | KampanjFromDat | ztDate |  |  | datetime
Campaign price list | KampanjPrisLista | ztInteger | 6 |  | smallint
Campaign end date | KampanjTomDat | ztDate |  |  | datetime
Supplementary price list | KomplPrisLista | ztInteger | 6 |  | smallint
Markup/reduction % | markup | ztFloat | 14 | 4 | float
Net, no discount | NettoEjRabKod | ztBoolean |  |  | char
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Price valid until date | PrislGiltigDat | ztDate |  |  | datetime
Price valid as of date | PrislGiltigFromDat | ztDate |  |  | datetime
Price list | PrisLista | ztInteger | 5 |  | smallint
Price list | PrisListaBeskr | ztString | 30 |  | varchar
Price calculation method | PrisSattnTyp | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal

    This table is the main table in the following programs:

    Program: bprh Purchase price lists


Purchase price list, header (view) (vbprh)

Data in the price list header of the purchase price list (price/discounts).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
No rounding | EjPrisAvrunda | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Campaign start date | KampanjFromDat | ztDate |  |  | datetime
Campaign price list | KampanjPrisLista | ztInteger | 6 |  | smallint
Campaign end date | KampanjTomDat | ztDate |  |  | datetime
Supplementary price list | KomplPrisLista | ztInteger | 6 |  | smallint
Markup/reduction % | markup | ztFloat | 14 | 4 | float
Net, no discount | NettoEjRabKod | ztBoolean |  |  | char
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Price valid until date | PrislGiltigDat | ztDate |  |  | datetime
Price valid as of date | PrislGiltigFromDat | ztDate |  |  | datetime
Price list | PrisLista | ztInteger | 5 |  | smallint
Price list | PrisListaBeskr | ztString | 30 |  | varchar
Price calculation method | PrisSattnTyp | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal


Purchase price lists, items (bprl)

Rows in purchase agreements for tiered prices and discounts on products. Different prices and discounts can be entered here for an agreement row depending on quantity.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quantity limit >= | LimitLowAnt | ztFloat | 10 | 2 | float
Net, no discount | NettoEjRabKod | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Price valid until date | PrislGiltigDat | ztDate |  |  | datetime
Price valid as of date | PrislGiltigFromDat | ztDate |  |  | datetime
Price list | Prislista | ztInteger | 5 |  | smallint
Gross margin | Proc1 | ztFloat | 6 | 2 | float
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | vb_InPris | ztMoney | 14 | 2 | money
Price, curr | vb_Pris | ZtSalesPrice | 12 | 2 | money

    This table is the main table in the following programs:

    Program: BprlSel Purchase price list details


Purchase price lists, product class (bprp)

Price details by product class in the purchasing price list (bprh).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Product class | ArtProdKlass | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quantity limit >= | LimitLowAnt | ztFloat | 10 | 2 | float
Net, no discount | NettoEjRabKod | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Price valid until date | PrislGiltigDat | ztDate |  |  | datetime
Price valid as of date | PrislGiltigFromDat | ztDate |  |  | datetime
Price list | Prislista | ztInteger | 5 |  | smallint
Gross margin | Proc1 | ztFloat | 6 | 2 | float
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Gross purch price, curr | vb_Inpris | ztMoney | 14 | 2 | money
Price, curr | vb_Pris | ZtSalesPrice | 12 | 2 | money


Purchase qty according to rule (xari)

Table for rules that can be used to control how purchase quantity is to be calculated.

The following standard records exist. Do not alter/delete:

Purch qty according to rule (InkKvantEnlRegel) | Purch qty according to rule (InkKvantEnlRegelBeskr) | Description
0 | EOQ | Calculate the purchase quantity based on economic order quantity for the item.
1 | Max inventory | Calculate purchase/manufacturing quantity to fill up the inventory balance to the defined maximum level.
2 | EPL days | Calculate the purchase quantity based on economic planning in days (i.e. corresponding EOQ but where the economically most advantageous purchase quantity is calculated in number of days).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purch qty according to rule | InkKvantEnlRegel | ztInteger | 5 |  | smallint
Purch qty according to rule | InkKvantEnlRegelBeskr | ztString | 50 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xari Purchase qty according to rule


Purchase request, header (pbha)

Main table for information in an external system for purchasing.

The information is created by EDI orders, for example. It can also be manually entered information in RFQs. (See separate documentation on RFQs to a group of suppliers.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Posting template | AutoRegel | ztString | 4 |  | varchar
New to PO date | AvtTomBestDat_Nytt | ztDate |  |  | datetime
New to disp date | AvtTomLevDat_Nytt | ztDate |  |  | datetime
Order text | BestEditExt | ztBlob | 1 |  | varchar
Dispatch method | BestLevsattKod | ztInteger | 2 |  | smallint
Dispatch terms | BestLevVilkKd | ztInteger | 2 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
No rounding | EjPrisAvrunda | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase agreement | InkAvtalBeskr | ztString | 25 |  | varchar
PO agreement date | InkAvtDat | ztDate |  |  | datetime
Purch agree type | InkAvtKod | ztInteger | 2 |  | smallint
Conversion % | InkAvtOmrProc | ztFloat | 6 | 2 | float
Purch agree status | InkAvtStatKod | ztInteger | 2 |  | smallint
Agreement to disp date | InkAvtTomDat | ztDate |  |  | datetime
Agreement to PO date | InkAvtTomDatBestH | ztDate |  |  | datetime
Print date | InkAvtUtskrDat | ztDateTime |  |  | datetime
Purch agree total amt | InkAvtValue | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Campaign | KampNr | ZtLong | 4 |  | int
Block purchase | KodBlockInkop | ztBoolean |  |  | char
External text -> PO | KodExtTextToBest | ztBoolean |  |  | char
Customer | KundNr | ztCompanyNo | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Adm lead time | LedTidAdm | ztInteger | 3 |  | smallint
Lead time from suppl | LedTidEnlLev | ztInteger | 3 |  | smallint
Lead time extra demand | LedTidExtra1 | ztInteger | 3 |  | smallint
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Er ref | LevRef1 | ztInteger | 6 |  | smallint
Supplier reference | LevRef2 | ztString | 50 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Delivery addr, company | OrdLevAdr1 | ztString | 36 |  | varchar
Delivery address 1 | OrdLevAdr2 | ztString | 36 |  | varchar
Delivery address 2 | OrdLevAdr3 | ztString | 36 |  | varchar
Delivery address 3 | OrdLevAdr4 | ztString | 36 |  | varchar
Destination, district | OrdLevAdrBstOrt | ztString | 36 |  | varchar
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Purchase agreem designation | PInkAvt | ZtLong | 6 |  | int
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Skrivskydd | SkrivUtskSk | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Transport days | TransportTid | ztInteger | 3 |  | smallint
Exchg rate date | ValDat | ztDate |  |  | datetime
Exchange rate, calc | ValKalkKurs | ZtCurrencyRate | 10 | 5 | decimal
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Purch value, curr | VbBestValue | ztMoney | 14 | 2 | money
Our reference | VRef | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: pbha Enter response to RFQ

    Program: PbhaAr Request for quotation from item

    Program: PbhaArla Request for quotation from item balance

    Program: pbhaia RFQ from requisition

    Program: PbhaPbia RFQ from requisition


Purchase requisition source (xiau)

Internal definitions which describe purchase requisition sources.

The following standard records exist. Do not alter/delete:

Requisition source (BiaUrsprKod) | Requisition source (BiaUrsprKodBeskr)
0 | Manually entered
10 | Shortage compared to OP
12 | Shortage planning
20 | Customer orders
30 | Mtrl for manufacturing order
80 | Net requirement
90 | Service orders
95 | Adjusted order point

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Requisition source | BiaUrsprKod | ztInteger | 2 |  | smallint
Requisition source | BiaUrsprKodBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xiau Purchase requisition source

    Program: xXiau Purchase requisition source


Purchase requisition status (xias)

Internal definitions which govern the statuses that can be set for requisitions.

The following standard records exist. Do not alter/delete:

Requisition status (BiaStatus) | Requisition status (BiaStatusBeskr) | Description
0 | Created | Set automatically for a completed requisition regardless of whether they are entered in Jeeves or in Jeeves e-Purchasing.
1 | Request not approved | Applied only if you are using Jeeves e-Purchasing. Can be used to mark individual rows not been approved for a purchase order. (If a requisition is approved in the form header, the rows are automatically given an Approved status.)
2 | Returned to orderer |
4 | Requisition approved | Applied only if you are using Jeeves e-Purchasing. Set by parent or corresponding requisition header or individual rows approved for a purchase order. If a requisition is approved in the form header, the rows are automatically given an Approved status.
5 | Order entered | Set automatically in requisition rows converted to purchase orders regardless of whether done in Jeeves or via Jeeves e-Purchasing.
7 | Canceled | Set manually in a requisition header or individual rows for cancellation.
8 | Processing complete |
9 | Entry in progress | Applied only if you are using Jeeves e-Purchasing. Set automatically for a requisition under ongoing entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Requisition status | BiaStatus | ztInteger | 1 |  | smallint
Requisition status | BiaStatusBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xias Purchase requisition status


Purchased items (biar)

Items which are to be ordered from a supplier.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Purchased | AnskaffningKop | ztBoolean |  |  | char
Manufactured | AnskaffningTillv | ztBoolean |  |  | char
Decimal places | AntDec | ztInteger | 1 |  | smallint
Number of decs (ext) | AntDecExtQty | ztInteger | 1 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Unit code | ar_EnhetsKod | ztString | 4 |  | varchar
Bin | ars_LagPlats | ztBinLocation | 20 |  | varchar
Item description | ArtBeskr | ztString | 30 |  | varchar
Specification | ArtBeskrSpec | ztString | 30 |  | varchar
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Main agreement | ArtHuvudAvt | ztBoolean |  |  | char
Net purchase price | ArtInPris | ZtBaseCurrAmount | 14 | 2 | money
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Max stock level | ArtMaxLager | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Revision no. | ArtRevId | ztString | 10 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Volume m3 | ArtVolym | ztFloat | 15 | 4 | float
Approved by | AttestSign | ztString | 6 |  | varchar
Req qty, supplier's unit | BegAntal | ZtQty | 14 | 2 | decimal
Required quantity | BehovAntal | ZtQty | 14 | 2 | decimal
Max inventory level | BerArtMaxLager | ZtQty | 14 | 2 | decimal
Calc order point | BerLagBestPkt | ZtQty | 14 | 2 | decimal
Order qty (invtry unit) | BestAnt | ZtQty | 14 | 2 | decimal
Order qty (suppl unit) | BestAntExtQty | ZtQty | 14 | 2 | decimal
Request disp date | BestBegLevDat | ztDate |  |  | datetime
Req to date (int) | BestBehovDat | ztDate |  |  | datetime
Req to date ext | BestBehovLevDat | ztDate |  |  | datetime
Est disp date | BestBerLevDat | ztDate |  |  | datetime
Order text | BestEditExt | ztBlob | 1 |  | varchar
Promised disp date | BestLovLevDat | ztDate |  |  | datetime
PO no. | Bestnr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
PO type | BestTyp | ztInteger | 3 |  | smallint
Prel purchase price | BestWinPris | ztMoney | 14 | 2 | money
Requisition status | BiaStatus | ztInteger | 1 |  | smallint
Requisition source | BiaUrsprKod | ztInteger | 2 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Qty sold prev yr | FsgAntalFar | ZtQty | 14 | 2 | decimal
Fsg antal f år (Gross) | FsgAntalGrossFar | ZtQty | 14 | 2 | decimal
Gross qty sold YTD | FsgAntalGrossIar | ZtQty | 14 | 2 | decimal
Qty sold YTD | FsgAntalIar | ZtQty | 14 | 2 | decimal
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Price conv factor | InkArtOmvFaktor | ztFloat | 14 | 4 | float
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Price unit factor | InkPrisPer | ZtDecimal73 | 8 | 3 | decimal
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
External text -> PO | KodExtTextToBest | ztBoolean |  |  | char
Ordered quantity | LagBestAnt | ZtQty | 14 | 2 | decimal
Order point | LagBestPkt | ZtQty | 14 | 2 | decimal
Reserved quantity | LagResAnt | ZtQty | 14 | 2 | decimal
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Supplier item descr | LevsArtBeskr | ztString | 255 |  | varchar
Min order qty | MinAntalBest | ZtQty | 14 | 2 | decimal
Min order qty (ext) | MinAntalBestExtQty | ZtQty | 14 | 2 | decimal
Pkg size purchase | Multipel | ZtQty | 14 | 2 | decimal
Package size | MultipelExtQty | ZtQty | 14 | 2 | decimal
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Invtry unit->Purch unit | StockQty2SuppQty | ztFloat | 12 | 6 | float
Requisition | StrDateTimeBia | ztString | 28 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar


Purchasing manager (ihdl)

Definition of signatures and names of the company’s purchasing managers.

Items can be linked to a purchasing manager. Acquisition proposals can be selected under a purchasing manager.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Purchasing manager | InkHandlBeskr | ztString | 40 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ihdl Purchasing manager


Purchasing manager, MO (thih)

Purchasing manager for manufacturing orders.

There are different purchasing managers for different item types on manufacturing orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Item class | ArtKod | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Purchasing role (ikr)

Definition of purchasing roles used for e-purchasing.

A purchasing role indicates from which item groups (item group role) items may be purchased and to which cost centres (delivery role). In addition, other cost centres allowed beyond those specified in the users in Accounting users are highlighted.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval chain | attkedja | ztInteger | 5 |  | smallint
Description | beskrivning | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Appr/ctrl grp, CC | gk2beskr | ztString | 30 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchasing role | inkopsroll | ztInteger | 4 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Approval control group | KstGrupp | ztString | 6 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ikr Purchasing roles


Purchasing role - Delivery role (ikrL)

Purchasing role

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchasing role | inkopsroll | ztInteger | 4 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Dispatch role | leveransroll | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Purchasing role - Item group role (ikrV)

Purchasing role - item group role

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchasing role | inkopsroll | ztInteger | 4 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group roles | Varugrupproll | ztInteger | 4 |  | smallint


Quality parameters on bills of materials. (srqp)

Quality parameters on bills of materials.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Item no. (BOM) | BArtNrStrukt | ztString | 30 |  | varchar
Dummy id (copy from) | CopiedFromDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Item Revision | ItemRevision | ZtLong | 3 |  | int
Copy from item revision | ItemRevision_CopyOfRevision | ZtLong | 3 |  | int
Item rev OK to use? | ItemRevOkToUse | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Quality Categori (MO/PO/SO) | Qkategori | ztInteger | 5 |  | smallint
Quality parameters (group) | QParamGrupp | ZtLong | 10 |  | int
Quality parameter | QParamID | ZtLong | 10 |  | int
Får anges manuellt | QParamManuellt | ztBoolean |  |  | char
Obligatoriskt | QParamOblig | ztBoolean |  |  | char
Max.värde | QVardeMax | ztFloat | 15 | 2 | float
Min.värde | QVardeMin | ztFloat | 15 | 2 | float
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar

    This table is the main table in the following programs:

    Program: srq_2 Quality parameters for bills of materials


Quality parameters on item (revision diff) (arqp_ItemRevDiff)

Alphanumeric code for the item, BOM, fixed asset, or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Dummy id (copy from) | CopiedFromDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Item Revision | ItemRevision | ZtLong | 3 |  | int
Copy from item revision | ItemRevision_CopyOfRevision | ZtLong | 3 |  | int
Item revision diff flag | ItemRevisionDiffFlag | ztString | 4 |  | nvarchar
Item rev OK to use? | ItemRevOkToUse | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Quality Categori (MO/PO/SO) | Qkategori | ztInteger | 5 |  | smallint
Quality parameter | QParamId | ztInteger | 5 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar


Quality system (kvsy)

Definition of existing quality system types , according to need.

There is currently no logical link connected to this but the data can be used as needed for information, search and selection of suppliers.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quality system | KvalitetsSystemBeskr | ztString | 50 |  | varchar
Quality system | KvalitetsSystemKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: kvsy Quality system


Quantity posting rule (xl3)

Internal definitions which are used to determine whether a quantity can/will be specified for a specific account.

The following standard records exist. Do not alter/delete:

Qty posting rule (regel3) | Qty posting rule (regelbeskr3)
1 | Does not exist
2 | Optional
3 | Mandatory

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Entry inventory, Quant | lager2 | ztInteger | 1 |  | smallint
Mandatory, Quant | oblig2 | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Qty posting rule | regel3 | ztInteger | 1 |  | smallint
Qty posting rule | regelbeskr3 | ztString | 50 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xl3 Posting rule/quantity


Quantity rule for last proposal (xne1)

Table with rules for the quantity of the last proposal for an item from material requirement planning.
Using this code you can ensure that the theoretical inventory balance for an item after material requirement planning will be zero or safety stock.
This can be used for items that will be discontinued or which you will not need any more time according to a forecast made.
Acquisition proposals are normally obtained according to economic order quantity (and multiples) but the acquisition will then perhaps be too big.
This code is on the inventory balance record and the inventory location record of the item.
If the code is not specified for the item (ARS), it is retrieved from the inventory location (XB).

The following standard records exist. Do not alter/delete:

Rule for last NE proposal (NE_RegelSistaForslag) | Rule for last NE proposal (NE_RegelSistaForslagBeskr)
0 | Normal (EOQ....)
1 | Safety stock
2 | Zero inventory

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Rule for last NE proposal | NE_RegelSistaForslag | ztInteger | 5 |  | smallint
Rule for last NE proposal | NE_RegelSistaForslagBeskr | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xne1 Net requirement last quantity proposal


Quarter (xkv)

Quarter codes (1-4).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quarter | Kvartal | ztInteger | 1 |  | smallint
Quarter | KvartalBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Queue (WMS_Queue)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Max cont, asgmt | MaxContentsInAssignment | ztInteger | 5 |  | smallint
Max vol, asgmt | MaxVolumeInAssignment | ztFloat | 15 | 2 | float
Max net w asgmt | MaxWeightNetInAssignment | ztFloat | 10 | 3 | float
Signature | PersSign | ztString | 30 |  | varchar
Queue | Queue | ztString | 5 |  | varchar
Description | QueueDesc | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_MU_AssMovingByQueue Queue, transfer assignments

    Program: WMS_MU_AssPickByQueue Queue, picking assignments

    Program: WMS_MU_AssReplByQueue Queue, replenishment assignments

    Program: WMS_MU_AssReplPickByQueue Queue, replenishment pick assignments

    Program: WMS_Queue Queue


Queue matrix (WMS_QueueMatrix)

Definition of which queue different assignments will be placed in when they are created according to their:

- assignment type
- assignment sub type
- unit of measure
- from MHA
- to MHA

It is optional to enter assignment sub type, unit of measure, from MHA and to MHA but assignment type is mandatory.

This means that it is possible to define that for example all assignments of type Replenishment are be placed in the same queue.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
MHA, from | AssFromMha | ztString | 5 |  | varchar
Sub type | AssSubTypeCode | ztInteger | 3 |  | smallint
MHA, to | AssToMha | ztString | 5 |  | varchar
Type | AssTypeCode | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Order type | OrdTyp | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Queue | Queue | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Unit code | UOM | ztString | 10 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_QueueMatrix Queue matrix


Quotation status (xa7)

Table of different statuses that can be set on quotations and assignments, e.g. active or closed, to follow the quotation/assignment through processing.

The following standard records exist. Do not alter/delete:

Quote/assignment status (OffStatus) | Order status (OrdStatBeskr) | Description
0 | Price information | Can be used to flag that relevant products, services, prices, etc., are only for price information to a customer, i.e. are not a quotation. Records with the status cannot be invoiced.
1 | Quotation | Can be used to flag that relevant products, services, prices, etc., are quoted to a customer. Records with the status cannot be invoiced.
2 | Budget | Can be used to flag that relevant products, services, prices, etc., refer to a budget. Records with the status cannot be invoiced.
3 | Active | Used to flag that the record refers to an active customer assignment. You can only invoice assignments with ‘Active’ status.
5 | Customer request | Can be used to flag that relevant products, services, prices, etc., are only an RFQ from a customer. Records with the status cannot be invoiced.
8 | Lost | Can be used to “cancel” the quotation/customer assignment. No logic is linked to the status except that records with this status cannot be invoiced.
9 | Closed | Used to flag that the assignment is closed, i.e. that you can no longer report and invoice hours and expenses on projects included in the assignment.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Reg order from quote | KodOrderFranOffert | ztBoolean |  |  | char
Quote/assignment status | OffStatus | ztString | 1 |  | varchar
Order status | OrdStatBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Price valid at order entry | PriceValidAtOrderEntry | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxa7 Quotation status


Quotation/agreement header (ofh)

Data in the quotation/agreement/assignment header.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
One invoice | AccountsOn1Invoic | ztBoolean |  |  | char
Deducted invoice | AcDrawn | ztBoolean |  |  | char
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Days commitmt 1 | AtagandeGrad1 | ztInteger | 3 |  | smallint
Days commitmt 2 | AtagandeGrad2 | ztInteger | 3 |  | smallint
Days commitmt 3 | AtagandeGrad3 | ztInteger | 3 |  | smallint
Days commitmt 4 | AtagandeGrad4 | ztInteger | 3 |  | smallint
Automatically created | AutomatSkapad | ztBoolean |  |  | char
Posting template | AutoRegel | ztString | 4 |  | varchar
Agreement type | AvtalsKod | ztInteger | 3 |  | smallint
Payment terms | BetKod | ztString | 2 |  | varchar
Invoicing start date | CheckDagPerAvtal | ztBoolean |  |  | char
Sequence no. type | CompanyType | ztInteger | 4 |  | smallint
Detail posting | Detaljkontering | ztBoolean |  |  | char
District | DistrKod | ztString | 4 |  | varchar
Division code | DivisKod | ztString | 3 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Replaces QuoteNo | ErsattOffNr | ztString | 10 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Handling charge | ExpAvgKd | ztBoolean |  |  | char
Invoice to date | FaktTomDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Storage code | Forradskod | ztString | 17 |  | varchar
Freight charge code | FraktAvgKd | ztBoolean |  |  | char
Frozen up to commitment | FrystAtagande | ztInteger | 5 |  | smallint
Delivery note Y/N | FsKd | ztBoolean |  |  | char
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Valid to date | GiltigTomDatum | ztDate |  |  | datetime
Goods label row 1 | GodsMarke1 | ztString | 40 |  | varchar
Goods label row 2 | GodsMarke2 | ztString | 40 |  | varchar
Goods label row 3 | GodsMarke3 | ztString | 40 |  | varchar
Goods label row 4 | GodsMarke4 | ztString | 40 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Est hourly cost | KalkKostManTim | ZtBaseCurrAmount | 14 | 2 | money
Campaign | KampNr | ZtLong | 4 |  | int
Block order | KodBlockOrder | ztBoolean |  |  | char
External text -> order | KodExtTextToOrder | ztBoolean |  |  | char
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit percentage | KreditProcent | ztFloat | 15 | 2 | float
Customer order date | KundBestDat | ztDate |  |  | datetime
Ordering dept | KundBestNamn | ztString | 36 |  | varchar
Customer order no. | KundBestNr | ztString | 30 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Invoicing address | KundFaktAdr | ztString | 36 |  | varchar
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Sales price incl VAT/tax | KundPrisInklMoms | ztBoolean |  |  | char
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Customer reference | KundRef2 | ztString | 30 |  | varchar
Customer specific text | KundTextKod | ztString | 4 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Ship documents | LevHandlKod | ztBoolean |  |  | char
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Dispatch plan group | LevPlanGrupp | ztString | 35 |  | varchar
Update method | LevPlanUpdMetod | ztInteger | 1 |  | smallint
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Allocation template | MallFaktPeriod | ztInteger | 3 |  | smallint
Tax code acc to customer | MarkKundsMomsStyr | ztBoolean |  |  | char
Master project no. | MasterProjCode | ztString | 10 |  | varchar
Max date not invoiced | MaxEjFaktDat | ztDate |  |  | datetime
Min date not invoiced | MinEjFaktDat | ztDate |  |  | datetime
Min invoice amt | MinInvoiceAmount | ztMoney | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Recipient code | MottagarKod | ztString | 17 |  | varchar
Not credit invoice | NoCreditInvoice | ztBoolean |  |  | char
Quotation/agreement | OffBeskr | ztString | 40 |  | varchar
Quoted amt, intrn sales | OffertBeloppIntFsg | ZtBaseCurrAmount | 14 | 2 | money
Quoted amt, intrn prch | OffertBeloppIntKop | ZtBaseCurrAmount | 14 | 2 | money
Quote/Agreemt date | OffertDat | ztDate |  |  | datetime
Quoted cost, intrn sales | OffertKostnadIntFsg | ZtBaseCurrAmount | 14 | 2 | money
Quoted cost, intrn purch | OffertKostnadIntKop | ZtBaseCurrAmount | 14 | 2 | money
Quote row no. -> Order row no. | OffertRadNrToOrdRadNr | ztBoolean |  |  | char
Margin, intarnal sales | OffertTBIntFsg | ZtBaseCurrAmount | 14 | 2 | money
Margin, internal purch | OffertTBIntKop | ZtBaseCurrAmount | 14 | 2 | money
Margin, internal sales | OffertTGIntFsg | ZtDecimal73 | 8 | 3 | decimal
Margin degree, intrn prch | OffertTGIntKop | ZtDecimal73 | 8 | 3 | decimal
Quote cost | OffKostnad | ZtBaseCurrAmount | 14 | 2 | money
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Offert/avtal nr | OffNrNum | ZtLong | 10 |  | int
Quote/assignment status | OffStatus | ztString | 1 |  | varchar
Quotation value, BCU | OffSum | ZtBaseCurrAmount | 14 | 2 | money
Quote amt incl VAT, BCU | OffSumInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Margin | OffTB | ZtBaseCurrAmount | 14 | 2 | money
Quotation printed | OffUtskrDat | ztDateTime |  |  | datetime
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order date | OrdDatum | ztDate |  |  | datetime
Order text | OrdEditext | ztBlob | 1 |  | varchar
Order up to oblig. | OrderAtagande | ztInteger | 3 |  | smallint
Order cost | OrdKostnad | ZtBaseCurrAmount | 14 | 2 | money
Delivery addr, company | OrdLevAdr1 | ztString | 36 |  | varchar
Delivery address 1 | OrdLevAdr2 | ztString | 36 |  | varchar
Delivery address 2 | OrdLevAdr3 | ztString | 36 |  | varchar
Delivery address 3 | OrdLevAdr4 | ztString | 36 |  | varchar
Destination, district | OrdLevAdrBstOrt | ztString | 36 |  | varchar
Destination, country | OrdLevAdrLandsKod | ztString | 3 |  | varchar
Point of delivery, co. ID | ordlevplats1 | ztCompanyNo | 20 |  | varchar
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Order value | OrdSum | ZtBaseCurrAmount | 14 | 2 | money
Order type | OrdTyp | ztInteger | 3 |  | smallint
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Gate description | PortBeskrivning | ztString | 35 |  | varchar
Gate code | PortKod | ztString | 17 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Service price list | PrislistaT | ztInteger | 6 |  | smallint
Pricing method | PrisTyp | ztInteger | 3 |  | smallint
Percent of invoice | ProcentavFaktura | ztFloat | 7 | 2 | float
Project ID | ProjCode | ztString | 10 |  | varchar
Finished on | ProjEndDat | ztDate |  |  | datetime
Revised end date | Projrevenddat | ztDate |  |  | datetime
Revised start date | Projrevstartdat | ztDate |  |  | datetime
Project start date | ProjStartDat | ztDate |  |  | datetime
Business opportunity ID | prospektid | ZtLong | 10 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Collective invoicing ID | SamFaktOffNr | ztString | 30 |  | varchar
Collective invoicing | SamFaktUtskr | ztBoolean |  |  | char
Last invoice date | SerSenFakt | ztDate |  |  | datetime
End date invc period | SersSlutFakt | ztDate |  |  | datetime
Start date invc period | SerStartFakt | ztDate |  |  | datetime
Service agreement | ServiceAssignment | ztBoolean |  |  | char
Create purchase agreement | SkapaInkAvt | ztBoolean |  |  | char
Create forecast rows | SkapaPrognos | ztBoolean |  |  | char
Skrivskydd | SkrivUtskSk | ztBoolean |  |  | char
Block check | SparrAvtal | ztBoolean |  |  | char
Blocked | SparrAvtal_C | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Tiering code | StafflKodOffert | ztBoolean |  |  | char
Sum items on invoice | SumitemOnInvoice | ztBoolean |  |  | char
Price ceiling | TakPrisAvt | ZtBaseCurrAmount | 12 | 2 | money
Price ceiling expense | TakPrisEx | ZtBaseCurrAmount | 12 | 2 | money
Asgmt controls VAT/tax | TaxByAssignmentFlag | ztBoolean |  |  | char
Use cust discount | TillatKundRabatt | ztBoolean |  |  | char
Invoicing type | UFakttyp | ztInteger | 3 |  | smallint
Assignment class | Uppdragsklass | ztInteger | 5 |  | smallint
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Quotation value, curr | VbOffSum | ztMoney | 14 | 2 | money
Quote amt incl VAT, curr | VbOffSumInklMoms | ztMoney | 14 | 2 | money
Order amount, curr | VbOrdSum | ztMoney | 14 | 2 | money
Our reference | VRef | ztString | 30 |  | varchar
Publish on Web | webpublish | ztBoolean |  |  | char
Unique ID link | WfRowUniqueID | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: aofh Assignments

    Program: ofh Quotation/agreement

    Program: pofh Assignments, periodical

    Program: sht8 Service agreements and discounts

    Program: uofh Assignments

    Program: uofhT Service assignments/agreements


Quotation/agreement rows (view) (vofp)

View of rows in a quotation/agreement for products.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item description | ArtBeskr |  |  |  | @DataType=NULL
Specification | ArtBeskrSpec |  |  |  | @DataType=NULL
Recommended price | ArtCirkaPris |  |  |  | @DataType=NULL
Customer discnt allowed | ArtKundRabKod |  |  |  | @DataType=NULL
Item no. | ArtNr |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Sales price, BCU | FPris |  |  |  | @DataType=NULL
Price conv factor | FsgArtOmvFaktor |  |  |  | @DataType=NULL
Price unit factor | FsgPrisPer |  |  |  | @DataType=NULL
Company ID | FtgNr |  |  |  | @DataType=NULL
Price 0 applies | KodNollPris |  |  |  | @DataType=NULL
Discount % | KundRabatt |  |  |  | @DataType=NULL
Discount fr matrix, add | MatrisRabAddKod |  |  |  | @DataType=NULL
Net, no discount | NettoEjRabKod |  |  |  | @DataType=NULL
Net price in BCU | NettoPris |  |  |  | @DataType=NULL
Quote/agreement no. | OffNr |  |  |  | @DataType=NULL
Order row qty | OrdAntal |  |  |  | @DataType=NULL
Est disp date | OrdBerLevDat |  |  |  | @DataType=NULL
Order date | OrdDatum |  |  |  | @DataType=NULL
Order row no. | OrdRadnr |  |  |  | @DataType=NULL
Subrow no. | OrdRadNrStrPos |  |  |  | @DataType=NULL
Total row discount % | OrdRadRab |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Pricing type | PrisHantTyp |  |  |  | @DataType=NULL
Price list | PrisLista |  |  |  | @DataType=NULL
Price list | PrisListaBeskr |  |  |  | @DataType=NULL
Pricing method | PrisTypP |  |  |  | @DataType=NULL
Discount 1 % | rabatt1 |  |  |  | @DataType=NULL
Discount 2 % | rabatt2 |  |  |  | @DataType=NULL
Discount 3 % | rabatt3 |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL
Currency | ValKod |  |  |  | @DataType=NULL
Exchange rate | ValKurs |  |  |  | @DataType=NULL
Net price, curr | vb_NettoPris |  |  |  | @DataType=NULL
Price, curr | vb_pris |  |  |  | @DataType=NULL
Price incl tax, curr | vb_PrisInklMoms |  |  |  | @DataType=NULL
Price acc to rule | vbPrisER |  |  |  | @DataType=NULL
Volume disc % | VolymRabatt |  |  |  | @DataType=NULL


Quotation/agreement rows, products (ofp)

Rows in a quotation/agreement for products.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Qty on CO | AntalIOrder | ZtQty | 14 | 2 | decimal
Item description | ArtBeskr | ztString | 30 |  | varchar
Recommended price | ArtCirkaPris | ZtSalesPrice | 12 | 2 | money
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Calc cost price | ArtKalkPris | ZtBaseCurrAmount | 14 | 2 | money
Cost price (actual) | ArtKalkprisE | ZtBaseCurrAmount | 14 | 2 | money
Cost price at order | ArtKalkPrisO | ZtBaseCurrAmount | 14 | 2 | money
Fixed cost price for order | ArtKalkPrisOFast | ZtBaseCurrAmount | 14 | 2 | money
Item class | ArtKod | ztInteger | 3 |  | smallint
Customer discnt allowed | ArtKundRabKod | ztBoolean |  |  | char
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Customer item no. | ArtNrKund | ztString | 30 |  | varchar
Automatically created | AutomatSkapad | ztBoolean |  |  | char
Autoskapad orderrad | AutoOrderLine | ztInteger | 5 |  | smallint
Posting template | AutoRegel | ztString | 4 |  | varchar
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Text | Edit | ztBlob | 1 |  | varchar
External text | editExt | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, BCU | FPris | ZtBaseCurrAmount | 14 | 2 | money
Fixed sales price, BCU | FPrisFast | ZtBaseCurrAmount | 14 | 2 | money
Sales price, internal | FPrisInternt | ZtBaseCurrAmount | 14 | 2 | money
Sales price, intrn by rule | FPrisInterntEnlregel | ZtBaseCurrAmount | 14 | 2 | money
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Exg rate on order date | InValKurs | ZtCurrencyRate | 15 | 7 | decimal
Purch price curr | InValuta | ztString | 3 |  | varchar
Campaign | kampnr | ZtLong | 4 |  | int
External text -> order | KodExtTextToOrder | ztBoolean |  |  | char
Price 0 applies | KodNollPris | ztBoolean |  |  | char
Configuration item no. | KonfigArtNr | ztString | 30 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Cost centre, intrn sales | KostStalleKodIntFsg | ztString | 8 |  | varchar
Sales price incl VAT/tax | KundPrisInklMoms | ztBoolean |  |  | char
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Disp.days at order | LevAntDgrOrder | ztInteger | 5 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Discount fr matrix, add | MatrisRabAddKod | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Net, no discount | NettoEjRabKod | ztBoolean |  |  | char
Net price in BCU | NettoPris | ZtSalesPrice | 12 | 2 | money
Quoted amt, intrn sales | OffertBeloppIntFsg | ZtBaseCurrAmount | 14 | 2 | money
Quoted amt, intrn prch | OffertBeloppIntKop | ZtBaseCurrAmount | 14 | 2 | money
Quoted cost, intrn sales | OffertKostnadIntFsg | ZtBaseCurrAmount | 14 | 2 | money
Quoted cost, intrn purch | OffertKostnadIntKop | ZtBaseCurrAmount | 14 | 2 | money
Margin, intarnal sales | OffertTBIntFsg | ZtBaseCurrAmount | 14 | 2 | money
Margin, internal purch | OffertTBIntKop | ZtBaseCurrAmount | 14 | 2 | money
Margin, internal sales | OffertTGIntFsg | ZtDecimal73 | 8 | 3 | decimal
Margin degree, intrn prch | OffertTGIntKop | ZtDecimal73 | 8 | 3 | decimal
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Quote row cost | OffRadKostnad | ZtBaseCurrAmount | 14 | 2 | money
Quote row amount BCU | OffRadSum | ZtBaseCurrAmount | 14 | 2 | money
Quote amt incl VAT, BCU | OffRadSumInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Margin | OffRadTB | ZtBaseCurrAmount | 14 | 2 | money
Quote/assignment status | OffStatus | ztString | 1 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Order row qty, alt unit | OrdAntalAltEnh | ZtQty | 14 | 2 | decimal
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order date | OrdDatum | ztDate |  |  | datetime
Order text | OrdEditExt | ztBlob | 1 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Total row discount % | OrdRadRab | ZtDecimal73 | 8 | 2 | decimal
Order row status | OrdRadSt | ztInteger | 2 |  | smallint
Std order qty | OrdStdAntal | ZtQty | 14 | 2 | decimal
Std qty, alternative | OrdStdAntalAltEnh | ZtQty | 14 | 2 | decimal
Order type | OrdTyp | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Pricing type | PrisHantTyp | ztInteger | 3 |  | smallint
Pricing type, intrn sales | PrisHantTypIntFsg | ztInteger | 3 |  | smallint
Price list | PrisLista | ztInteger | 5 |  | smallint
Pricing method | PrisTypP | ztInteger | 3 |  | smallint
Business opportunity ID | ProspektId | ZtLong | 10 |  | int
Discount 1 % | rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Backorder handling | RestBehKod | ztInteger | 1 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Price ceiling per pos | TakPrisDat | ZtBaseCurrAmount | 12 | 2 | money
Optional item created | TillValArtikelSkapad | ztBoolean |  |  | char
Optional for item | TillValArtToArtNr | ztString | 30 |  | varchar
Optional item for order row no. | TillValArtToOrdRadNr | ztInteger | 4 |  | smallint
Currency clause | ValKlausul | ztInteger | 5 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | vb_InPris | ztMoney | 14 | 2 | money
Net price, curr | vb_NettoPris | ZtSalesPrice | 12 | 2 | money
Price, curr | vb_pris | ZtSalesPrice | 12 | 2 | money
Fixed price, currency | vb_PrisFast | ZtSalesPrice | 12 | 2 | money
Price incl tax, curr | vb_PrisInklMoms | ZtSalesPrice | 12 | 2 | money
Cost price, curr | vbKalkPris | ztMoney | 14 | 2 | money
Quote row amount, curr | VbOffRadSum | ztMoney | 14 | 2 | money
Quote amt incl VAT, curr | VbOffRadSumInklMoms | ztMoney | 14 | 2 | money
Order row amt, curr | VbOrdRadSum | ztMoney | 14 | 2 | money
Net Order row amt, curr | vbOrdRadSumNetto | ztMoney | 14 | 2 | money
Price acc to rule | vbPrisER | ZtSalesPrice | 12 | 2 | money
Volume disc % | VolymRabatt | ZtDecimal73 | 10 | 2 | decimal

    This table is the main table in the following programs:

    Program: ofp Open quotation analysis/item

    Program: rOfpOS Open quotations


Quotation/agreement rows, tiered prices (ofps)

Rows in quotation/agreement for tiered prices and discounts on products. Different prices and discounts can be entered here for a quotation/agreement row depending on quantity or dispatch time.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Recommended price | ArtCirkaPris | ZtSalesPrice | 12 | 2 | money
Customer discnt allowed | ArtKundRabKod | ztBoolean |  |  | char
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, BCU | FPris | ZtBaseCurrAmount | 14 | 2 | money
Sales price, internal | FPrisInternt | ZtBaseCurrAmount | 14 | 2 | money
Sales price, intrn by rule | FPrisInterntEnlRegel | ZtBaseCurrAmount | 14 | 2 | money
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Price 0 applies | KodNollPris | ztBoolean |  |  | char
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Discount fr matrix, add | MatrisRabAddKod | ztBoolean |  |  | char
Net, no discount | NettoEjRabKod | ztBoolean |  |  | char
Net price in BCU | NettoPris | ZtSalesPrice | 12 | 2 | money
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order date | OrdDatum | ztDate |  |  | datetime
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Total row discount % | OrdRadRab | ZtDecimal73 | 8 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Pricing type | PrisHantTyp | ztInteger | 3 |  | smallint
Pricing type, intrn sales | PrisHantTypIntFsg | ztInteger | 3 |  | smallint
Price list | PrisLista | ztInteger | 5 |  | smallint
Pricing method | PrisTypP | ztInteger | 3 |  | smallint
Discount 1 % | rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Net price, curr | vb_NettoPris | ZtSalesPrice | 12 | 2 | money
Price, curr | vb_pris | ZtSalesPrice | 12 | 2 | money
Price incl tax, curr | vb_PrisInklMoms | ZtSalesPrice | 12 | 2 | money
Price acc to rule | vbPrisER | ZtSalesPrice | 12 | 2 | money
Volume disc % | VolymRabatt | ZtDecimal73 | 10 | 2 | decimal


Quote Q&A class 1 (xq1)

Table 1 of 3 that can be used for free classification of questions in the quotation system.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quotation class 1 Q&A | offklass | ztInteger | 5 |  | smallint
Quotation class 1 Q&A | OffklassB | ztString | 40 |  | varchar
Signature | perssign | ztString | 30 |  | varchar
Entry date | regdat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xq1 Q&A classification 1, quotation


Quote Q&A class 2 (xq2)

Table 2 of 3 that can be used for free classification of questions in the quotation system.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quotation class 2 Q&A | offklass2 | ztInteger | 5 |  | smallint
Quotation class 2 Q&A | OffklassB2 | ztString | 30 |  | varchar
Signature | perssign | ztString | 30 |  | varchar
Entry date | regdat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xq2 Q&A classification 2, quotation


Quote Q&A class 3 (xq3)

Table 3 of 3 that can be used for free classification of questions in the quotation system.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quotation class 3 Q&A | offklass3 | ztInteger | 5 |  | smallint
Quotation class 3 Q&A | OffklassB3 | ztString | 30 |  | varchar
Signature | perssign | ztString | 30 |  | varchar
Entry date | regdat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xq3 Q&A classification 3, quotation


Rack (WMS_Rack)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
MHA | Mha | ztString | 5 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Rack | Rack | ztString | 5 |  | varchar
Availability | RackAvailCode | ztInteger | 3 |  | smallint
Description | RackDesc | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_Rack Rack


Rack/Location availability code (WMS_LocAvailCode)

Numeric code that specifies the availability of the inventory location.

If the availability of the rack is changed, the availability of all locations on the rack is also changed. You can, however, make changes if you want to assign a different availability to a particular location.

The following standard records exist. Do not alter/delete:

Availability (LocAvailCode) | Description (LocAvailDesc) | Description
1 | Available | The rack/location is available for receiving and picking.
10 | Blocked | The rack/location is blocked from receiving and picking.
20 | Blocked in | The rack/location is blocked from receiving. This can be used when a rack/location is to be emptied.
30 | Blocked out | The rack/location is blocked from picking.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Availability | LocAvailCode | ztInteger | 3 |  | smallint
Description | LocAvailDesc | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_LocAvailCode Rack/Location availability code


Rate conversion operations (xx3)

Internal definitions controlling exchange rate calculations from the base currency amount to the amount in currency.

The following standard records exist. Do not alter/delete:

Exchange rate, operand (ValKursOp) | Exchange rate, operand (ValKursOpBeskr)
1 | Direct (Multiplication)
2 | Indirect (division)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Exchange rate, operand | ValKursOp | ztInteger | 5 |  | smallint
Exchange rate, operand | ValKursOpBeskr | ztString | 60 |  | varchar

    This table is the main table in the following programs:

    Program: xx3 Rate conversion operations


Rates for VAT/tax invoice (Bhm)

The VAT/tax rates and VAT/tax amounts calculated on VAT/tax invoices.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sales tax | FaktMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice total incl tax | FaktTotMMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice total excl tax | FaktTotUMoms | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Invoice amount, curr | Vb_FaktSum | ztMoney | 14 | 2 | money
VAT/tax, curr | VbFaktMoms | ztMoney | 14 | 2 | money
Invoice total excl tax | VbFaktTotUMoms | ztMoney | 14 | 2 | money


Rcvd delivery journal, calc value (jth)

Data in the journal header of labour reports for manufacturing orders.
A journal only includes data of labour for one day, which is why one journal a day is normally created (several journals a day can however be created).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Final report date | AoSlutMarkDat | ztDate |  |  | datetime
Accounting date | BokfDat | ztDate |  |  | datetime
Reported end time | EventRpTime | ztTime | 5 |  | datetime
Time | EventTime | ztTime | 4 |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Manufacturing journal | ThJournNr | ZtLong | 6 |  | int
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: Jth Mfg costing journal


Realizing parts from configurator (TactonRealized)

Realizing parts from the Sales configurator.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Key part 1 | Key1 | ztString | 50 |  | varchar
Key part 2 | Key2 | ztString | 50 |  | varchar
Key part 3 | Key3 | ztString | 50 |  | varchar
Key part 4 | Key4 | ztString | 50 |  | varchar
Key part 5 | Key5 | ztString | 50 |  | varchar
Configurator model ID | ModelId | ztString | 60 |  | varchar
Index of part | PartIndex | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Realizing part name | RealizedName | ztString | 128 |  | varchar
Value of realizing part name | RealizedValue | ztString | 255 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Reason (AttR_reason)

Reason table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active to stamp | AttRActiveToStamp | ztBoolean |  |  | char
Extra | AttRExtra | ztBoolean |  |  | char
Reason | AttRReason | ztString | 6 |  | varchar
Reason description | AttRReasonDescr | ztString | 50 |  | varchar
Time type | AttRTimeType | ztString | 6 |  | varchar
Work schedule only | AttRWSOnly | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_reason Reasons


Reason (view 1) (vAttr_Reason)

Alphanumeric code for reason. Should be numbers to enable fast reporting.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Reason | attrreason | ztString | 6 |  | varchar
Reason description | AttrReasondescr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: vAttr_Reason Reason (view 1)


Reason code (WMS_V_EXT_ReasonCode)

Numeric code for inventory transaction type, linked to a description of the type.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Invtry trans. type | LagTransBeskr | ztString | 50 |  | varchar
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint


Reason group, customer claims (orkg)

Definition of overlying classifications or groupings of claim reasons regarding customer claims, for example error source Customer error, Supplier error, internal error. The definition, which is mandatory if you intend to use the customer claim routine, is done as required and can then be used for searching, selecting, and as headings in reports. The definition, which is mandatory if you intend to use the customer claim routine, is made as required and can then be used for searching, selecting and as headings in reports.

Please note that when you then define claim reasons, a reason must not occur in more than one group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cust claim reason group | KundReklamationGrpBeskr | ztString | 60 |  | varchar
Cust claim reason group | KundReklamationOrsakGrp | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price | Pris | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: orkg Reason group, customer claims


Reason group, manuf.claims (torg)

Definition of overlying classifications or groupings of reasons for manufacturing claims. The definition, which is mandatory if you intend to use the manufacturing claim routine, is performed as required and can then be used for searching, selecting and as headings in reports.

Note that when you define claim reasons, a reason must not occur in more than one group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price | Pris | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Manuf.claim reason group | TillvReklamationGrpBeskr | ztString | 60 |  | varchar
Manuf.claim reason group | TillvReklamationOrsakGrp | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: torg Reason group, manuf.claims


Reason group, purchase claims (irkg)

Definition of overlying classifications or groupings of reasons for purchase claims. The definition, which is mandatory if you intend to use the purchase claim routines, is performed as required and can then be used for searching, selecting and as headings in reports.

Note that when you define claim reasons, a reason must not occur in more than one group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase claim reason group | InkopReklamationGrpBeskr | ztString | 40 |  | varchar
Purchase claim reason group | InkopReklamationOrsakGrp | ztInteger | 5 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price | Pris | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: irkg Reason group, purchase claims


Reason types, delivery note (xfso)

Table of reason types (source) for delivery notes, showing the reason for dispatch or receipt of material to/from the company, e.g. Subcontract, Repairing, Sample to customer, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
External qty | FsExternQty | ztBoolean |  |  | char
Received deliv | FsInleverans | ztBoolean |  |  | char
Mark rec del from MO (120) | FsMark120 | ztBoolean |  |  | char
Reason description | FsOrsakBeskr | ztString | 40 |  | varchar
Reason code | FsOrsakKod | ztInteger | 5 |  | smallint
Dispatch | FsUtleverans | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Print on delivery note | UtskrFoljeSedel | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xxfso Reason types, delivery note


Reason/agreement (Attr_agrreason)

In this table you connect reason codes to an agreement.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Agreement ID | attragreement | ztString | 6 |  | varchar
Reason | attrreason | ztString | 6 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Attr_agrreason Resaon / agreement


Reasons, customer claims (orkk)

Definition of existing reasons for customer claims, for example Error in customer order, Error in internal order, Transport damage. The definition, which is mandatory if you intend to use the customer claim routine, is done according to need and can then be used for searching, selecting, and as headings in reports.

You must specify a reason group for every reason, which means that you must define the reason groups first in the program Reason group, claim, customers (Orkg). A group may consist of several claim reasons, but a reason must not occur in more than one group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Department | AvdelningsBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cust claim reason | KundReklamationBeskr | ztString | 40 |  | varchar
Cust claim reason | KundReklamationOrsak | ztInteger | 5 |  | smallint
Cust claim reason group | KundReklamationOrsakGrp | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price | Pris | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: orkk Reasons, customer claims


Reasons, manuf.claims (toro)

Definition of existing reasons for manufacturing claims. The definition, which is mandatory if you intend to use the manufacturing claim routine, is performed as required and can then be used for searching, selecting and as headings in reports.

You must specify a reason group for every reason, which means that you must define the reason groups first in the program "Manufacturing claim reason group" (Torg). A group can comprise of several claim reasons, but a reason must not occur in more than one group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Department | AvdelningsBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price | Pris | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Manuf.claim reason | TillvReklamationBeskr | ztString | 60 |  | varchar
Manuf.claim reason | TillvReklamationOrsak | ztInteger | 5 |  | smallint
Manuf.claim reason group | TillvReklamationOrsakGrp | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: toro Reasons, manuf.claims


Reasons, purchase claims (irkk)

Definition of existing reasons for purchase claims. The definition, which is mandatory if you intend to use the purchase claim routine, is performed as required and can then be used for searching, selecting and as headings in reports.

You must specify a reason group for every reason, which means that you must define the reason groups first in the program "Reason group, purchase claims" (Irkg). A group can comprise of several claim reasons, but a reason must not occur in more than one group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Department | AvdelningsBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase claim reason | InkopReklamationBeskr | ztString | 40 |  | varchar
Purchase claim reason | InkopReklamationOrsak | ztInteger | 5 |  | smallint
Purchase claim reason group | InkopReklamationOrsakGrp | ztInteger | 5 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price | Pris | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: irkk Reasons, purchase claims


Receipts & issues for assembly (iult)

Journal with data on receipts and deliveries of items for assembly.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Batch no. required | BatchBokas | ztBoolean |  |  | char
Batch no. | BatchId | ztString | 30 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Assembly journ no. | JournNrIULT | ZtLong | 5 |  | int
Stocked | LagerBokas | ztBoolean |  |  | char
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Transaction date | LagTransDatum | ztDate |  |  | datetime
Picked quantity | MrRappAnt | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Serial no. required | SerieNrBokas | ztBoolean |  |  | char
Reported mfg qty | TiRappAnt | ZtQty | 14 | 2 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: InvAssemblyBOM Inventory issues, assembly/BOM

    Program: xIult Inventory issues, assembly/BOM


Received deliveries, MO (WMS) (WMS_V_EXT_MSORec)

Manufacturing order number/work order number based on an automatically assigned sequence number.
Your own alphanumeric order numbers can be entered in another field on the manufacturing order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
MO/Works order status | AoStatKod | ztInteger | 1 |  | smallint
Item description | ArtBeskr | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Use/Best before | BastForeDatum | ztDate |  |  | datetime
Batch no. | BatchId | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Cancel remain qty | MakuleraRestAntal | ztBoolean |  |  | nvarchar
MHA | Mha | ztString | 5 |  | nvarchar
Number of SKU | NumberOfSKU | ztInteger | 5 |  | decimal
Pallet unit type | PalletUnitType | ztString | 5 |  | varchar
Full pallet quantity | PartDefFullUnitQty | ZtQty | 14 | 2 | decimal
Pallet unit type | PartDefFullUnitType | ztString | 5 |  | varchar
Qty / SKU | QtyPerSKU | ZtQty | 14 | 2 | decimal
Reported mfg qty | TiRappAnt | ZtQty | 14 | 2 | decimal
Remaining qty to manuf | TiRestAnt | ZtQty | 14 | 2 | decimal

    This table is the main table in the following programs:

    Program: WMS_EXT_MSORec Received deliveries, MO WMS


Received deliveries, PO row (bpi)

Received deliveries per PO row.
A row is created in this table each time a received delivery is matched with a purchase order.
At reconciliation the inventory balance is updated and an inventory transaction showing the event is created.
If the received item is flagged for batch processing with a LOT or receiving number, this must be entered.
The item can also be flagged for serial number processing on delivery, in which case the serial number must be entered.
Received deliveries can be posted in two ways. Received delivery journals can be created in which deliveries are posted in the inventory account and counter-booked in an account for "delivered, not invoice matched inventory value". The second method is to post the supplier invoice before the received delivery journal is created, in which case the inventory is posted on the supplier invoice voucher.
(If inventory posting is done through the received delivery journal, the supplier invoice voucher will post in the account for "delivered, not invoice matched inventory value".)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Arrival checked | AnkomstKontrollerad | ztBoolean |  |  | char
To receive | AntalAttInLev | ZtQty | 14 | 2 | decimal
Decimal places | AntDec | ztInteger | 1 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, refinement | ArtKalkBerForadling | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
New cost price | ArtKalkBerNytt | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Average cost price | ArtKalkSnitt | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Repurchase, serial no | AterKopArtSerieNr | ztBoolean |  |  | char
Posting template | AutoRegel | ztString | 4 |  | varchar
Lead time from | BasDatLedTid | ztDate |  |  | datetime
Use/Best before | BastForeDatum | ztDate |  |  | datetime
Batch no. required | BatchBokas | ztBoolean |  |  | char
Batch description | BatchDescr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Delivery note date, rcv | BestFoljesedelsDat | ztDate |  |  | datetime
Delivery note no., rcv | BestFoljesedelsNr | ztString | 30 |  | varchar
Intern del note seq no. | BestFsLopNr | ztInteger | 5 |  | smallint
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
Received qty, alt unit | BestLevAntAltEnh | ZtQty | 14 | 2 | decimal
Received qty (suppl unit) | BestLevAntExtQty | ZtQty | 14 | 2 | decimal
Delivery received date | bestlevdat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Purch order no. (alpha) | BestNrAlfa | ztString | 50 |  | varchar
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
Remaining qty invtry unit | BestRestAnt | ZtQty | 14 | 2 | decimal
This field is used in the table as follows: |
Remaining qty, alt unit | BestRestAntAltEnh | ZtQty | 14 | 2 | decimal
Remaining qty (suppl unit) | BestRestAntExtQty | ZtQty | 14 | 2 | decimal
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
PO order value | BestValue | ZtBaseCurrAmount | 14 | 2 | money
Accounting date | BokfDat | ztDate |  |  | datetime
PO/receiving journal no. | BpiJournNr | ZtLong | 10 |  | int
Rec delivery sources | BpiUrsprKod | ztInteger | 5 |  | smallint
** From purchase order ** | Bpl_Bpi_2_BpArt | ztString | 20 |  | varchar
Purchase price budget | BudgInPris | ZtBaseCurrAmount | 14 | 2 | money
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
CalcAvgCostPriceAtFinalApproval | CalcAvgCostPriceAtFinalApproval | ztInteger | 5 |  | smallint
Calculated customs duties | CalcRecvValueDutyCost | ZtBaseCurrAmount | 14 | 2 | money
Calculated freight charge | CalcRecvValueFreightCost | ZtBaseCurrAmount | 14 | 2 | money
Calculated handling charge | CalcRecvValueHandleCost | ZtBaseCurrAmount | 14 | 2 | money
Calculated remaining cost | CalcRecvValueRemainingCost | ZtBaseCurrAmount | 14 | 2 | money
Restored BPI trans | CodeRestoredBPI | ztBoolean |  |  | char
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Delivery from business unit ICT | DelivFromBusinessUnit | ztString | 8 |  | varchar
Diff delivery/planned | Diff_LevDat_2_LovDat | ztInteger | 5 |  | smallint
Changed inventory value | DiffLagVarde | ZtBaseCurrAmount | 14 | 2 | money
Avail | Dispens | ztBoolean |  |  | char
Document ID | docnumid | ztString | 30 |  | varchar
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Invc checked qty | FaktAvprAntal | ZtQty | 14 | 2 | decimal
InvcCheckQtyExt | FaktAvprAntalExtQty | ZtQty | 14 | 2 | decimal
Inv.check no., av. price calc. | FaktAvprAntalSnittPrisBer | ZtQty | 14 | 2 | decimal
Invc match value | FaktAvprVarde | ztMoney | 14 | 2 | money
Inv.check value, av. price calc. | FaktAvprVardeSnittPrisBer | ZtBaseCurrAmount | 14 | 2 | money
Adj fifo val rcvd mtrl | FifoAdjRecDelValue | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Reason code | FsOrsakKod | ztInteger | 5 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
From backorder no. ICT | ICTDelivFromBackOrderNo | ztInteger | 5 |  | smallint
From order no. ICT | ICTDelivFromOrderNo | ZtLong | 10 |  | int
From order row no. ICT | ICTDelivFromOrdLnNo | ztInteger | 5 |  | smallint
From order row no. for pkg ICT | ICTDelivFromOrdSubLnNo | ztInteger | 5 |  | smallint
Price conv factor | InkArtOmvFaktor | ztFloat | 14 | 4 | float
Purch value to invc match | InkopsVardeAttFaktAvpr | ZtBaseCurrAmount | 14 | 2 | money
Price unit factor | InkPrisPer | ZtDecimal73 | 8 | 3 | decimal
To receive, blocked inventory | InLevAntalSparrat | ZtQty | 14 | 2 | decimal
Receiving value | InlevKalkVarde | ZtBaseCurrAmount | 14 | 2 | money
Calc val rcvd mtrl refinement | InlevKalkVardeForadling | ZtBaseCurrAmount | 14 | 2 | money
Calc delivery value (adjustm) | InlevKalkVardeJustering | ZtBaseCurrAmount | 14 | 2 | money
Calc val rcvd mtrl | InlevKalkVardeMtrl | ZtBaseCurrAmount | 14 | 2 | money
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Inventory location WMS | InventoryLocWMS | ztBoolean |  |  | char
EDI rcving journ no. | JibpJournal | ZtLong | 10 |  | int
Adj value for new avg price | JustKalkVardeSnittPrisBer | ZtBaseCurrAmount | 14 | 2 | money
Adjustment value average price | JustVardeSnittPrisBer | ZtBaseCurrAmount | 14 | 2 | money
Settlement adjust value average price | JustVardeSnittPrisBerAvrkn | ZtBaseCurrAmount | 14 | 2 | money
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
To be posted | Konteras | ztBoolean |  |  | char
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
Corr plan qty (suppl unit) | KorrAntalInExtQty | ZtQty | 14 | 2 | decimal
Stocked | LagerBokas | ztBoolean |  |  | char
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Type of bin | LagPlatsTyp | ztString | 6 |  | varchar
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Dispatch notice | LevAviNr | ztString | 35 |  | varchar
Dispatch notice row | LevAviRadNr | ztInteger | 5 |  | int
Disp.plan number | LevPlanNr | ZtLong | 10 |  | int
Dispatch plan row no. | LevPlanRadNr | ZtLong | 10 |  | int
Invtry trans journal no. | LthJournNr | ZtLong | 6 |  | int
Cancel remain qty | MakuleraRestAntal | ztBoolean |  |  | char
Cancel remain qty, order | MakuleraRestAntalOrder | ztBoolean |  |  | char
MO issue purch mtrl (AC) | MarkInlevAvprickad | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Prev cost price BCU | OldArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Previous average cost | OldArtKalkSnitt | ZtBaseCurrAmount | 14 | 2 | money
Urspr valutakurs | OldValKurs | ZtCurrencyRate | 15 | 7 | decimal
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Excess delivery>customer | OverDelivToCustomer | ztBoolean |  |  | char
Package item | PaketArtikel | ztBoolean |  |  | char
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Prel post tax amount | PrelKonteradMomsBelopp | ZtBaseCurrAmount | 14 | 2 | money
Doc. printed | printed | ztBoolean |  |  | char
Project ID | projcode | ztString | 10 |  | varchar
@zPrompt=null | PvmGridNo | ztInteger | 3 |  | smallint
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Rec delivery from WMS | RecDelivFromWMS | ztBoolean |  |  | char
Calc rec value (added costs) | RecDelValueAddedCosts | ZtBaseCurrAmount | 14 | 2 | money
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Cost | RedovisnRadKostnad | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Returned qty invtry unit | ReturAnt | ZtQty | 14 | 2 | decimal
Returned qty (suppl unit) | ReturAntExtQty | ZtQty | 14 | 2 | decimal
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Serial no. at receiving | serialnoilev | ztBoolean |  |  | char
Serial no., quantity=1.0 | SerialNoItemOne | ztBoolean |  |  | char
Serial no., unique | SerialNoUnique | ztBoolean |  |  | char
Serial no. required | SerieNrBokas | ztBoolean |  |  | char
Shipment identity | ShipmentId | ZtLong | 10 |  | int
Time sqlcmd->trg start | SQLCmd2EnterTrg | ZtLong | 10 |  | int
Start av updatering/insert | SqlStmtStartedDT | ztDateTime |  |  | datetime
Invtry unit->Purch unit | StockQty2SuppQty | ztFloat | 12 | 6 | float
Date/time | StrDateTime | ztString | 28 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Gross purch price, curr (mtrl) | vb_inpris_mtrl | ztMoney | 14 | 2 | money
Gross setup price, curr | Vb_InPris_Stall | ztMoney | 14 | 2 | money
Gross start purch price, curr | Vb_InPris_Start | ztMoney | 14 | 2 | money
Purchase price incl tax | Vb_InPrisInklMoms | ztMoney | 14 | 2 | money
Purch value, curr | VbBestValue | ztMoney | 14 | 2 | money
Actual lead time | VerklLedTid | ztInteger | 5 |  | smallint
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Transfer date | VtVrUpDat | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: Bpi Show rec deliveries, not invoice matched

    Program: Bpi2GL Inventory posting, received deliveries->GL

    Program: xBpi Show received deliveries


Received delivery messages (EDI) (bpl)

Message regarding purchase order/purchase order row.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Decimal places | AntDec | ztInteger | 1 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Use/Best before | BastForeDatum | ztDate |  |  | datetime
Batch no. required | BatchBokas | ztBoolean |  |  | char
Batch no. | BatchId | ztString | 30 |  | varchar
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
Received qty (suppl unit) | BestLevAntExtQty | ZtQty | 14 | 2 | decimal
Delivery received date | bestlevdat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
Remaining qty invtry unit | BestRestAnt | ZtQty | 14 | 2 | decimal
This field is used in the table as follows: |
Remaining qty (suppl unit) | BestRestAntExtQty | ZtQty | 14 | 2 | decimal
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
PO order value | BestValue | ZtBaseCurrAmount | 14 | 2 | money
Accounting date | BokfDat | ztDate |  |  | datetime
PO/receiving journal no. | BpiJournNr | ZtLong | 10 |  | int
** From purchase order ** | Bpl_Bpi_2_BpArt | ztString | 20 |  | varchar
Receiving status (EDI) | BplStatus | ztInteger | 5 |  | smallint
Message type | BplTyp | ztInteger | 3 |  | smallint
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Invc checked qty | FaktAvprAntal | ZtQty | 14 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Receiving value | InlevKalkVarde | ZtBaseCurrAmount | 14 | 2 | money
Calc val rcvd mtrl | InlevKalkVardeMtrl | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
EDI rcving journ no. | JibpJournal | ZtLong | 10 |  | int
S4 | K4 | ztString | 8 |  | varchar
To be posted | Konteras | ztBoolean |  |  | char
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
Corr plan qty (suppl unit) | KorrAntalInExtQty | ZtQty | 14 | 2 | decimal
Corr purch value, curr | KorrVbBestValue | ztMoney | 14 | 2 | money
Note | KortNotering | ztString | 255 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Stocked | LagerBokas | ztBoolean |  |  | char
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Supplier item descr | LevsArtBeskr | ztString | 255 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Cancel remain qty | MakuleraRestAntal | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
EDI input only | OnlyCreateBplRec | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | projcode | ztString | 10 |  | varchar
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Cost | RedovisnRadKostnad | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Serial no. required | SerieNrBokas | ztBoolean |  |  | char
Date/time | StrDateTime | ztString | 28 |  | varchar
Original item no. | UrsprArtNr | ztString | 30 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Gross purch price, curr (mtrl) | vb_inpris_mtrl | ztMoney | 14 | 2 | money
Gross setup price, curr | Vb_InPris_Stall | ztMoney | 14 | 2 | money
Gross start purch price, curr | Vb_InPris_Start | ztMoney | 14 | 2 | money
Purch value, curr | VbBestValue | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint
Transfer date | VtVrUpDat | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: Bpl1 Incorrect rcvd ext deliveries

    Program: Bpl2 External receipts - history


Received delivery notes EDI (ofd)

1. For the Odette delivery plan this table is used for received delivery notes according to the customer. This information is used at the reconciliation of delivery plans to know the delivered quantity since the latest received delivery note according to the customer.

2. This table is used when receiving order acknowledgements from a supplier for the possible division of the delivery.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
External order number | ExtOrderNr | ztString | 17 |  | varchar
External order status | ExtOrdSta | ztInteger | 2 |  | smallint
Delivery note/disp no. | FfhNr | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Delivery note quantity | FsAntal | ZtQty | 14 | 2 | decimal
Delivery note date | FsDatum | ztDate |  |  | datetime
Delivery note no. | FsNr | ZtLong | 10 |  | int
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Delivery note | MottFoljesedel | ztString | 17 |  | varchar
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Received delivery notifications (xbpt)

Delivery row message type, for example order acknowledgement, order change, dispatch or delivery message.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Message type | BplTyp | ztInteger | 3 |  | smallint
Message type | BplTypBeskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xbpt Received delivery notifications


Received EDI delivery status (xbpl)

Definition of status codes that are found during deliveries from external systems. These received delivery status codes refer to simplified EDI processing that can be used between different units (databases) within the same company.

The following standard records exist. Do not alter/delete:

Receiving status (EDI) (BplStatus) | Receiving status (EDI) (BplStatusBeskr)
0 | Not tested (only created)
10 | PO missing
20 | Wrong status on order
22 | Wrong item on order row
30 | Order row not found
32 | Wrong status on order row
41 | Wrong price on standard item
42 | Earlier delivery at diff price - MPC
43 | Material (MPC) issued at different price
44 | Earlier delivery at diff price - custome
45 | Customer order issued at diff price
48 | Posting does not match the order
510 | Delivery adjustment created
520 | Delivery created

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Receiving status (EDI) | BplStatus | ztInteger | 5 |  | smallint
Receiving status (EDI) | BplStatusBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xbpl Received EDI delivery status codes


Received POs->GL (bpiv)

Detailed data by transaction of how received deliveries of purchase orders are posted when integrated with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
PO/receiving journal no. | BpiJournNr | ZtLong | 10 |  | int
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Document ID | docnumid | ztString | 30 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Inventory location | LagStalle | ztString | 2 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
UniqueIDInAKLT | UniqueIDInAKLT | ZtLong | 10 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: Bpiv Show received delivery posting


Received prod trans -> GL (tivt)

Detailed data by transaction of how received deliveries for manufacturing orders are posted when integrated with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Document ID | docnumid | ztString | 30 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Manufacturing journal | TiiJournNr | ZtLong | 6 |  | int
UniqueIDInAKLT | UniqueIDInAKLT | ZtLong | 10 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: xTivt Posting, received MO deliveries


Receiving tables/target table (BTran2GLDefTargetTable)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Receiving table | BTran2GLDefTargetTable | ztString | 40 |  | varchar
Transfer of transaction type | BTran2GLDefTargetTableDescr | ztString | 100 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
LayerCode | LayerCode | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: BTran2GLDefTargetTable Receiving tables/target tables


Reconciliation AR/GL, header (wfha)

Data in the work table header, used for printing the results of the reconciliation of accounts receivable ledgers with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice book date | FaktDat2BokfDat | ztDate |  |  | datetime
Paid amount BCU | FaktInbBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice total incl tax | FaktTotMMoms | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S-4 f ledg.balance | K4ReskSaldo | ztString | 8 |  | varchar
S5 f ledg.balance | K5ReskSaldo | ztString | 8 |  | varchar
S6 f ledg.Bal | K6ReskSaldo | ztString | 8 |  | varchar
S7 f ledg.balance | K7ReskSaldo | ztString | 8 |  | varchar
Cost unit f ledg.balance | KBarReskSaldo | ztString | 8 |  | varchar
Balance sheet CC | KstReskSaldo | ztString | 8 |  | varchar
Ledger acct | KtoNrReskSaldo | ztString | 8 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Customer category | KundkategoriKod | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Remaining to pay | RestBelFakt | ZtBaseCurrAmount | 14 | 2 | money
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar


Reconciliation balance/result project (Wprj)

Reconciliation table containing detailed information of how the project has been posted upon balance and cost accounting.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Net | DebCreSumAmt | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Reconciliation date | ReconDate | ztDate |  |  | datetime
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SqlIdentity | ZtLong | 10 |  | int
Orig account no. | UrsprungsKtoNr | ztString | 8 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: wprj Reconciliation balance/result project


Reconciliation delivered not invoice matched (wbpa)

Reconciliation table containing detailed information of how a PO has been posted upon delivery and invoicing matching to the general ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Net | DebCreSumAmt | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Reconciliation date | Recondate | ztDate |  |  | datetime
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Cost | RedovisnRadKostnad | ZtBaseCurrAmount | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Process ID | spid | ZtLong | 5 |  | int
Identity | SQLidentity | ZtLong | 10 |  | int
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: wbpa Reconciliation received, not invoice matched


Reconciliation delivered not invoice matched (wbpa_q)

Reconciliation table containing detailed information of how a PO has been posted upon delivery and invoicing matching to the general ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Est disp date | BestBerLevDat | ztDate |  |  | datetime
Delivery received date | BestLevDat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
PO status | BestStatKod | ztInteger | 2 |  | smallint
Accounting date | BokfDat | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Net | DebCreSumAmt | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Reconciliation date | ReconDate | ztDate |  |  | datetime
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint


Reconciliation delivered not invoice matched (wbpa_qq)

Reconciliation table containing detailed information of how a PO has been posted upon delivery and invoicing matching to the general ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Reconciliation dispatched, not invoiced (woha)

Alphanumeric code for the item, BOM, fixed asset, or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
CSG | DelNotInvoice | ZtBaseCurrAmount | 14 | 2 | money
Not deliv inv qty | DelNotInvoiceQty | ZtQty | 14 | 2 | decimal
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice book date | FaktDat2BokfDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
RowNo. | FaktRadNr | ztInteger | 4 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Fiscal year invoice | InvoiceFiscalYr | ztInteger | 4 |  | smallint
Fisc period invoice | InvoiceFiscalYrPeriod | ztInteger | 4 |  | smallint
Invoice voucher no. | InvoiceVchrNo | Jeeves_VchrNo | 7 |  | bigint
To be posted | Konteras | ztBoolean |  |  | char
Account | KtoNr | ztString | 8 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | ordradnrstrpos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Picking journal no. | orujournnr | ZtLong | 10 |  | int
Period | period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Reconciliation date | ReconDate | ztDate |  |  | datetime
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | rowno | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SqlIdentity | ZtLong | 10 |  | int
Date/time | StrDateTime | ztString | 28 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: woha Reconciliation dispatched, not invoiced


Reconciliation fixed asset (winvt)

Reconciliation table containing information per fixed assets of how depreciations of fixed assets have been posted when integrating to the general ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Fixed assets group | Anlgrp | ztString | 10 |  | varchar
Reconciliation date | FAcheckDate | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Fixed asset no | Inventarie | ZtLong | 10 |  | int
Component fixed asset | InventariePos | ztInteger | 5 |  | smallint
Calc acquisition amount | PerDenAnskBelopp | ZtBaseCurrAmount | 14 | 2 | money
Curr acquisition amount | PerDenAnskBeloppAkt | ZtBaseCurrAmount | 14 | 2 | money
GL acquisition amount | PerDenAnskBeloppRE | ZtBaseCurrAmount | 14 | 2 | money
Calc depreciated amount | PerDenAvskrBelopp | ZtBaseCurrAmount | 14 | 2 | money
Curr depreciated amount | PerDenAvskrBeloppAkt | ZtBaseCurrAmount | 14 | 2 | money
GL depreciated amount | PerDenAvskrBeloppRE | ZtBaseCurrAmount | 14 | 2 | money
Calc residual value | PerDenInvRest | ZtBaseCurrAmount | 14 | 2 | money
Curr residual value | PerDenInvRestAkt | ZtBaseCurrAmount | 14 | 2 | money
GL residual value | PerDenInvRestRE | ZtBaseCurrAmount | 14 | 2 | money
GL net amount | PerDenNettobeloppRE | ZtBaseCurrAmount | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Avstwinv Reconciliation FA - GL


Reconciliation fixed assets ->general ledger details (winv)

Reconciliation table containing detailed information per transaction of how depreciations of fixed assets have been posted when integrating to the general ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Fixed assets group | Anlgrp | ztString | 10 |  | varchar
Depreciation journal | AvskrJournal | ZtLong | 5 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Fixed asset no | Inventarie | ZtLong | 10 |  | int
Component fixed asset | InventariePos | ztInteger | 5 |  | smallint
Fixed asset journal | InvJournNr | ZtLong | 6 |  | int
Transaction type | InvTransTyp | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: Avstwdet Reconciliation details fixed asset


Reconciliation GL-AP/AR (reav)

This table is for storing reconciliation data prior to printing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Paid amount BCU | FaktInbBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Remaining to pay BCU | FaktRestBel | ZtBaseCurrAmount | 14 | 2 | money
Invoice total incl tax | FaktTotMMoms | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S-4 f ledg.balance | K4ReskSaldo | ztString | 8 |  | varchar
S5 f ledg.balance | K5ReskSaldo | ztString | 8 |  | varchar
S6 f ledg.Bal | K6ReskSaldo | ztString | 8 |  | varchar
S7 f ledg.balance | K7ReskSaldo | ztString | 8 |  | varchar
Cost unit f ledg.balance | KBarReskSaldo | ztString | 8 |  | varchar
Acc rec/Acc pay | KRorLR | ztInteger | 5 |  | smallint
Balance sheet CC | KstReskSaldo | ztString | 8 |  | varchar
Ledger acct | KtoNrReskSaldo | ztString | 8 |  | varchar
Invoice amount BCU | LrFaktBelBas | ZtBaseCurrAmount | 14 | 2 | money
Preliminarily booked payment | OutGoingPayment | ztBoolean |  |  | char
Prel pmt in bas | OutGoingPaymentAmount | ZtBaseCurrAmount | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Remaining to pay | Restbelfakt | ZtBaseCurrAmount | 14 | 2 | money
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Invoice amount, curr | vb_faktsum | ztMoney | 14 | 2 | money
Amount paid, curr | VbFaktInbBel | ztMoney | 14 | 2 | money
Outst invc amt, curr | VbFaktRest | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: reavKR Reconciliation AR - GL

    Program: reavLR Reconciliation AP - GL


Reconciliation inventory (Wlth)

Table for inventory reconciliation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Innev Redov.period | ActPeriod | ztInteger | 4 |  | smallint
Amount GL | BalanceGL | ZtBaseCurrAmount | 14 | 2 | money
Amount inventory | BalanceStock | ZtBaseCurrAmount | 14 | 2 | money
Accounting date | BokfDat | ztDate |  |  | datetime
Period diff | DiffinPeriod | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Diff inventory - GL | InvtValDiff | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Reconciliation date | ReconDate | ztDate |  |  | datetime
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Voucher text | VerText | ztString | 60 |  | varchar

    This table is the main table in the following programs:

    Program: wlth Reconciliation inventory


Reconciliation manufacturing - general ledger (wth)

Help table for reconciliation between manufacturing and the general ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Mfg journal no. | AorJournNr | ZtLong | 6 |  | int
Product acct, labour | ArbProdKonto | ztString | 8 |  | varchar
Integration detail | ArbTransTyp | ztInteger | 3 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Inventory location | LagStalle | ztString | 2 |  | varchar
Material journal no. | MruJournNr | ZtLong | 6 |  | int
Operation no. | OpNr | ztInteger | 3 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Manufacturing journal | TiiJournNr | ZtLong | 6 |  | int
Item group | VaruGruppKod | ztString | 8 |  | varchar
Tools | Verktyg | ztString | 16 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint


Reconciliation manufacturing order->general ledger details (wtha)

Reconciliation table containing detailed information per transaction of how manufacturing orders have been posted upon integration to the general ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AOPos | ztInteger | 4 |  | int
Mfg journal no. | AorJournNr | ZtLong | 6 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Net | DebCreSumAmt | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Integration detail | IntField | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | k7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Material journal no. | MruJournNr | ZtLong | 6 |  | int
Operation no. | OpNr | ztInteger | 3 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Reconciliation date | Recondate | ztDate |  |  | datetime
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLidentity | ZtLong | 10 |  | int
Manufacturing journal | TiiJournNr | ZtLong | 6 |  | int
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: wtha Reconciliation manufacturing orders


Reconciliation OU inventory (wou)

Table for reconciliation of Order-Specific inventory as of current date.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
CSG | DelNotInvoice | ZtBaseCurrAmount | 14 | 2 | money
Not deliv inv qty | DelNotInvoiceQty | ZtQty | 14 | 2 | decimal
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Shipped invc qty | FaktLevAnt | ZtQty | 14 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Receiving value | InlevKalkVarde | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans qty (+/-) | LagTransAntal | ZtQty | 14 | 2 | decimal
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Dispatch value | OutDelValueAtitemCost | ZtBaseCurrAmount | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Reconciliation date | ReconDate | ztDate |  |  | datetime
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Value remaining to deliver | RestDelValueAtitemCost | ZtBaseCurrAmount | 14 | 2 | money
Quantity remaining to deliver | RestQtyToDeli | ZtQty | 14 | 2 | decimal
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLidentity | ZtLong | 10 |  | int
Historical cost invc row | StatistikRadKostnad | ZtBaseCurrAmount | 14 | 2 | money
Deliv from MO | UttagFranAoNr | Jeeves_MONo | 7 |  | bigint
Deliv from MO Pos | UttagFranAoPos | ztInteger | 5 |  | int

    This table is the main table in the following programs:

    Program: wou Reconciliation order-specific inventory


Reconciliation/link orp<->bp (qo2p)

Table (work table) for reconciliation between orders and purchase orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Invc checked qty | FaktAvprAntal | ZtQty | 14 | 2 | decimal
Shipped invc qty | FaktLevAnt | ZtQty | 14 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: qo2p Reconcile CO <-> PO, qty


Reconciliation/link orp<->bp (ao2p)

Table (work table) for reconciliation between orders and purchase orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Accounting date | BokfDat | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Closing balance | UtgSaldo | ZtBaseCurrAmount | 14 | 2 | money

    This table is the main table in the following programs:

    Program: ao2p Reconcile order <-> PO, amount


Record types, interest invoice (xrst)

Different record types of interest details are created in the kusr table during interest invoice calculation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Record type | UkrtTyp | ztInteger | 1 |  | smallint
Record type | UkrtTypBeskr | ztString | 40 |  | varchar


Ref between records in Jeeves & Wflw (wfxt)

Table of references between "triggered" records in Jeeves and Workflow instances.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
File name | FileName | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Flow number | Processidentifier | ZtLong | 9 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
WorkflActInst | wflActInstance | ztString | 50 |  | varchar
Top level for instance | wflinstance_toplevel | ztString | 50 |  | varchar
Unique ID link | WfRowUniqueID | ztString | 50 |  | varchar
Base/value table | ztable | ztString | 255 |  | varchar


Reference table for TA- transportation administration (TA_Referens)

Reference table for TA- transport administration- this is where exported rows are saved.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Delivery note/disp no. | FfhNr | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date created | SkapadDatum | ztString | 25 |  | varchar
AssignNo. | TA_AssignmentNo | ztInteger | 5 |  | smallint
Base table | TA_BaseTable | ztString | 20 |  | varchar
Freight bill number | TA_ConsNo | ztString | 20 |  | varchar
Reference number | TA_RefNo | ztString | 40 |  | varchar
Status | TA_RefStatus | ztInteger | 5 |  | smallint
String | xString | ztString | 4000 |  | varchar


Regions (xn2)

Definition of geographical regions as per individual need for grouping/searching of companies in the company table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Region | BlockRegion | ztString | 3 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Region | Regionbeskr | ztString | 30 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xn2 Region


Reject cause inv match (ubpic)

Reject cause at supplier invoice match.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
RejectCause | RejectCause | ztInteger | 4 |  | smallint
Description | RejectCauseDescr | ztString | 80 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ubpic Reject cause inv match


Release PDM (pdmu)

Table of edition indexes linked to a specific edition to facilitate serial sorting.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Release | ArtRelease | ztString | 6 |  | varchar
Release index | ArtRelIndex | ztInteger | 4 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Variant (ECO) | Variant | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: pdmu Document versions


Reminder charges (xkav)

You can enter reminder charges per currency and a reminder level for the reminder and interest rule in question. This is done in an underlying program node for Reminder and interest invoice.rules (Program: xrav), i.e. there is no dedicated program for reminder charges.
The reminder charges are included in reminder letters but are not processed as a claim and also do not update the General Ledger.
The charge can be changed/removed for individual reminder letters in the program Payment reminder journal (xjfhk) or Payment reminder by customer (xkfhk) in the program node Show reminders.

The customer is not obliged to pay the reminder charge. If the customer pays it, you can process it as a negative deduction on the payment or with a booking order.

No reminder charges are entered in the table on delivery.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
No. of reminders | KravAnt | ztInteger | 1 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Pmt rmdr/intrst invc rule | RteFaktAvtal | ztInteger | 2 |  | smallint
Currency | Valkod | ztString | 3 |  | varchar
Reminder charge | Vb_KravAvgift | ztMoney | 14 | 2 | money


Reminder journal header (jfhk)

Data in the journal header regarding reminder batches.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Reminder journal batch no. | JfhkNr | ztInteger | 4 |  | smallint
Pmt reminder mgr | KravAnsvPersSign | ztString | 6 |  | varchar
Date last reminder | KravSenUtskr | ztDate |  |  | datetime
Legal entity | LegalEntity | ztString | 10 |  | varchar
Print date | p_utskr_dat | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xJfhk Payment reminder journal


Repair types (sht0)

Definition of IRIS repair codes. This is used when reporting against service orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Repairing IRIS | Repair | ztString | 30 |  | varchar
Repairing IRIS | RepairCode | ztString | 3 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: sht0 Reparation types IRIS


Reparation types (sht7)

Definition of existing reparation types. These can be used to specify different prices for different types of reparation on service items. You can also set up discount rates per reparation type in service agreements.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Reparation type | RepNr | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: sht7 Reparation types


Replaced By Item (ReplacedByItem)

Alphanumeric code for the item, BOM, fixed asset, or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item description | ArtBeskr |  |  |  | @DataType=NULL
Item no. | ArtNr |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL


Replanning or new proposal (xne2)

A table containing codes to determine whether a proposal for a quantity increase (after the system has tried to cover the need by moving other orders within tolerance days) should produce a proposal to re-plan an existing order or whether a new order should be planned in. This code is on the inventory balance record and the inventory location record of the item.
If the code is not specified for the item (ARS), it is retrieved from the inventory location (XB).

The following standard records exist. Do not alter/delete:

Re-plan or new order (NE_OmplanEllerNyOrder) | Re-plan or new order (NE_OmplanEllerNyOrderB) | Description
0 | Quantity change allowed | Quantity change allowed.
1 | No quantity change | Quantity change NOT allowed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Re-plan or new order | NE_OmplanEllerNyOrder | ztInteger | 5 |  | smallint
Re-plan or new order | NE_OmplanEllerNyOrderB | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xne2 Net requirement replan or new proposal


Replanning types (it2x)

Different types of (re-)planning proposals that can be made by item and order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Type of plan | It2pType | ztInteger | 5 |  | smallint
Type of plan | It2pTypeDescr | ztString | 80 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: it2x (Re)planning types


Replenishment queue (WMS_V_ReplenishmentQueue)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Assignments | Assignments | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Queue | Queue | ztString | 5 |  | varchar
Description | QueueDesc | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Replication definition (repd)

Table of different replication definitions.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | DivBeskr | ztString | 30 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Replication definition | ReplDefKod | ZtLong | 10 |  | int
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: RepDef Replication definitioner


Replication job (RepJ)

Table for creating different replication jobs. A link is then made to a replication definition (repd).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mail address if error | alarmmailadress | ztString | 100 |  | varchar
Description | divbeskr | ztString | 30 |  | varchar
Companies only | EndastFtgkod | ztInteger | 5 |  | smallint
Command after conv | execbefore | ztString | 255 |  | varchar
This field is used in the table as follows: |
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Active | jobactive | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Replication flow | RepDirection | ztchar | 1 |  | char
Replication definition | repldefkod | ZtLong | 10 |  | int
Job number | repljob | ZtLong | 10 |  | int
Replication type | repltype | ztInteger | 5 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Start date/time | StartDateTime | ztDateTime |  |  | datetime
This field is used in the table as follows: |
Interval | workinterval | ZtLong | 10 |  | int
Nest Level | zNestLevel | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: RepJob Replication job


Replication user (Repu)

Table of individuals who are authorized to use a replication job.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Signature | Perssign5 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Job number | repljob | ZtLong | 10 |  | int
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Reply option, electronic approval (xwst)

Definition of occurring reply options that an approver can select when making an electronic approval in Jeeves e-applications. Different reply options (status) determine how the document will be distributed in the workflow flow.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Height | Height | ZtLong | 9 |  | int
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Stamp group | StampGroup | ztInteger | 5 |  | smallint
Reply code | StampNo | ztInteger | 5 |  | smallint
Selected stamp | StampStatus | ztInteger | 5 |  | smallint
Reply code | StampText | ztString | 50 |  | varchar
Width | Width | ZtLong | 9 |  | int
x position | XPos | ZtLong | 9 |  | int
y position | YPos | ZtLong | 9 |  | int

    This table is the main table in the following programs:

    Program: xwst Reply option, electronic approval


Report columns (rk)

Definitions of columns included in column combinations in reports.

The first column only contains texts and is created "automatically" based on the row texts you write for the row definitions, and in specifications based on the descriptions of the included values which are retrieved from the database.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
DB-term/-expression 1 | DbTermname1 | ztString | 120 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Drill down with program | MatrixDrillDownPgm | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Edit exponent | RedExp | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Max column width | RpBredd | ztInteger | 2 |  | smallint
Decimal places | RpDecAnt | ztInteger | 2 |  | smallint
Don't print | RpEjUt | ztBoolean |  |  | char
Column title | RpKolNamn | ztString | 60 |  | varchar
Column no. | RpKolNr | ztInteger | 4 |  | smallint
Column type | RpKolTyp | ztInteger | 2 |  | smallint
Print zero rows | RpNollUtskr | ztBoolean |  |  | char
Column combination | RpTypKod | ztInteger | 4 |  | smallint
Save result in column | SaveMatrixResultInColumn | ztString | 120 |  | varchar
Value term table | VardeTabId1 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: rk Column definitions


Report columns/rows (CELL) (rkt)

Data defining a cell in a column definition.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
DB-term/-expression 1 | DbTermname1 | ztString | 120 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Edit exponent | RedExp | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Max column width | RpBredd | ztInteger | 2 |  | smallint
Decimal places | RpDecAnt | ztInteger | 2 |  | smallint
Don't print | RpEjUt | ztBoolean |  |  | char
Column title | RpKolNamn | ztString | 60 |  | varchar
Column no. | RpKolNr | ztInteger | 4 |  | smallint
Column type | RpKolTyp | ztInteger | 2 |  | smallint
Print zero rows | RpNollUtskr | ztBoolean |  |  | char
Column combination | RpTypKod | ztInteger | 4 |  | smallint
Value term table | VardeTabId1 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xrkt Cells, columns


Report definitions (rd)

Identification and data on report row and column combinations.
A report definition normally contains several row and column combinations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Report title from procedure | ReportTitleFromProcedure | ztString | 255 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Report date | RpDat | ztDate |  |  | datetime
Report name | RpNamn | ztString | 60 |  | varchar
Report no. | RpNr | ZtLong | 5 |  | int
Row combination | RpRaddefID | ztInteger | 4 |  | smallint
Report title | RpRubrik | ztString | 255 |  | varchar
Column combination | RpTypKod | ztInteger | 4 |  | smallint
Spara resultat i DB | SaveMatrixResultInDatabase | ztString | 120 |  | varchar
Spara resultat i Table | SaveMatrixResultInTable | ztString | 120 |  | varchar
Template | YndMall | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: rd Report definitions


Report distribution (rpdi)

Information for report distribution.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Value subreport 1 | DecTerm1Value | ztString | 30 |  | varchar
Value subreport 2 | DecTerm2Value | ztString | 30 |  | varchar
Value subreport 3 | DecTerm3Value | ztString | 30 |  | varchar
Value subreport 4 | DecTerm4Value | ztString | 30 |  | varchar
Value subreport 5 | DecTerm5Value | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Value report structure | RbStrBVarde | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Report request | RpBegNr | ZtLong | 6 |  | int
Report recipient | RpMottagare | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: xRpdi Definition report distribution


Report group details (rpgd)

Details in definition of report groups that can be used to make report generation more efficient.

A report group consists of several report requests that will be generated at the same time.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Report group | RapportGrupp | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Report request | RpBegNr | ZtLong | 6 |  | int
Report no. | RpNr | ZtLong | 5 |  | int


Report groups, header (rpg)

Main table in definition of report groups that can be used to make report generation more efficient.

A report group consists of several report requests that will be generated at the same time.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Report group | RapportGrupp | ztString | 6 |  | varchar
Report group | RapportGruppBeskr | ztString | 40 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xRpg Report groups


Report request (rb)

Report request information.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Specification/sub-report | DecDefId | ztString | 6 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Save result in own table | FlagSaveMatrixResultInOwnTable | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Procedure, after | MatrixPostExecProc | ztString | 255 |  | varchar
Procedure, before | MatrixPreExecProc | ztString | 255 |  | varchar
Procedure, before load def | MatrixPreLoadExecProc | ztString | 255 |  | varchar
@zPrompt=null | matrixsaveindb | ztString | 120 |  | varchar
@zPrompt=null | matrixsaveintable | ztString | 120 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Pos | radpos1 | ztInteger | 4 |  | int
Rapport på företag | RapportPaForetagKod | ztInteger | 5 |  | smallint
Structure ID | RbStrId | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Report request | RpBegBeskr | ztString | 45 |  | varchar
Report request | RpBegNr | ZtLong | 6 |  | int
Report req struct | RpBegstr | ztInteger | 5 |  | smallint
Report date | RpDat | ztDate |  |  | datetime
Från Rapppbeg Nr | RpFrbegnr | ZtLong | 6 |  | int
Report name | RpNamn | ztString | 60 |  | varchar
Report no. | RpNr | ZtLong | 5 |  | int
Status | RpStatus | ztInteger | 1 |  | smallint
Spara resultat i DB | SaveMatrixResultInDatabase | ztString | 120 |  | varchar
Spara resultat i Table | SaveMatrixResultInTable | ztString | 120 |  | varchar
Specification | SpecDefId | ztString | 6 |  | varchar
Print BO page (1st page) | UtskrAvRbSida | ztBoolean |  |  | char
Template | YndMall | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: Xrb Report request


Report row/column cells (rtk)

Data defining a cell in a row definition.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Decimal places | AntDec | ztInteger | 1 |  | smallint
DB-term/-expression 1 | DbTermname1 | ztString | 120 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Edit exponent | RedExp | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Don't print | RpEjUt | ztBoolean |  |  | char
Column no. | RpKolNr | ztInteger | 4 |  | smallint
Print zero rows | RpNollUtskr | ztBoolean |  |  | char
Reverse sign | RpOmvTkn | ztBoolean |  |  | char
Row combination | RpRaddefID | ztInteger | 4 |  | smallint
Row text | RpRadText | ztString | 40 |  | varchar
Row type | RpRadTypKod | ztInteger | 2 |  | smallint
Specification | SpecDefId | ztString | 6 |  | varchar

    This table is the main table in the following programs:

    Program: rtk Cells, rows


Report rows (rt)

Definitions of rows included in row combinations in reports.

Tip
To create a space between the column headings and the first row in the report, enter a blank text row as the first row in the row combination.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Blank rows current row | AntalBlankrader | ztInteger | 5 |  | smallint
Decimal places | AntDec | ztInteger | 1 |  | smallint
DB-term/-expression 1 | DbTermname1 | ztString | 120 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Edit exponent | RedExp | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Don't print | RpEjUt | ztBoolean |  |  | char
Print zero rows | RpNollUtskr | ztBoolean |  |  | char
Reverse sign | RpOmvTkn | ztBoolean |  |  | char
Row combination | RpRaddefID | ztInteger | 4 |  | smallint
Row text | RpRadText | ztString | 40 |  | varchar
Row type | RpRadTypKod | ztInteger | 2 |  | smallint
Specification | SpecDefId | ztString | 6 |  | varchar
Layout per template window | UseReportWindowNo | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: rt Row definition


Report structure details (rbsd)

Report structure details.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Internal text | EditInt | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Structure description | RbStrBBeskr | ztString | 60 |  | varchar
Value report structure | RbStrBVarde | ztString | 30 |  | varchar
Structure ID | RbStrId | ztString | 6 |  | varchar
Strukturtyp | RbStrTyp | ztInteger | 1 |  | smallint
Value | RbStrVarde | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Report structure header (rbsh)

Data in the header of the report structure definition.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
DB-term/-expression 1 | DbTermname1 | ztString | 120 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Structure | RbStrBeskr | ztString | 60 |  | varchar
Structure ID | RbStrId | ztString | 6 |  | varchar
Structure term | RbStrTerm | ztString | 60 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Value term table | VardeTabId1 | ztString | 255 |  | varchar
Value type | VardeTermT | ztInteger | 3 |  | smallint

    This table is the main table in the following programs:

    Program: xRbsh Report structures


Report template (site repository) (vrpx)

View in the database for table for report templates.
This view is used to find report templates and for copying report templates.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | int
Template company | MallForetagKod | ztInteger | 5 |  | smallint
Report | ReportProgram | ztString | 255 |  | nvarchar
Report template | ReportTemplate | ztString | 255 |  | nvarchar
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Report templates (vRtpl)

Program/table for viewing, editing and copying report templates, for the current company, that have been created in Jeeves' template editor.

Choice of personal/global: No
Per company: Yes

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKodA |  |  |  | @DataType=NULL
Name | Name |  |  |  | @DataType=NULL
Program | pgm |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL
Language | SprakKod |  |  |  | @DataType=NULL
Template | Template |  |  |  | @DataType=NULL

    This table is the main table in the following programs:

    Program: rtpl2 Report templates


Report templates (rtpl)

Program/table for viewing, editing and copying report templates, for the current company, that have been created in Jeeves' template editor.

Choice of personal/global: No
Per company: Yes

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | int
Name | Name | ztString | 60 |  | nvarchar
Program | pgm | ztString | 40 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Template | Template | ztBlob | 1 |  | text

    This table is the main table in the following programs:

    Program: rtpl Report templates


Report templates (Site repository) (vrtp)

View in the database for table for report templates.
This view is used to find report templates and for copying report templates.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Template company | MallForetagKod | ztInteger | 5 |  | int
Report | ReportProgram | ztString | 255 |  | nvarchar
Report template | ReportTemplate | ztString | 255 |  | nvarchar
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Report, eBrev (ebRp)

Table for definition of tables included in eBrev report.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Main table | basTabell | ztBoolean |  |  | char
Link | connection | ztBlob | 1 |  | varchar
Report object | ebRptObjBeskr | ztString | 40 |  | varchar
Report object | ebRptObjekt | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Type of join | jointyp | ztString | 40 |  | varchar
Table name | JvsTableName | ztString | 128 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Primary key | PKey | ztString | 255 |  | varchar
Row table | radtabell | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Report program | yndreport | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: xebrp Report definition, eBrev


Reported activities (hrp)

This table contains reported activities, e.g. service activities, project activities, marketing activities, etc.

Log records are also stored in the table, for example conversion of data in Jeeves General Ledger module. These log records are only intended for system consultants or equivalent for troubleshooting in the event of interruptions during conversion.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Subproj closed | Aktavsl | ztBoolean |  |  | char
Subproject | Aktivitet | ztInteger | 4 |  | smallint
Quantity | Antal | ZtQty | 14 | 2 | decimal
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Charge | DebKod | ztInteger | 1 |  | smallint
File/dir | dokdir | ztString | 255 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | editext | ztBlob | 1 |  | varchar
Planned activity descr | EventNote | ztString | 60 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Reported activity | EventRpKod | ztInteger | 3 |  | smallint
Reported end time | EventRpTime | ztTime | 5 |  | datetime
Hours | EventTimant2 | ztHourWithDecimals | 8 | 2 | decimal
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
External order number | ExtOrderNr | ztString | 17 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no., original | FaktNrOrg | Jeeves_InvNo | 9 |  | bigint
RowNo. | FaktRadnr | ztInteger | 4 |  | int
Invoice row no., original | FaktRadNrOrg | ZtLong | 9 |  | int
To be invoiced | Faktureras | ztBoolean |  |  | char
Est % complete | FardigGrad | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Grafiskt tecken | Hrpblock | ztchar | 1 |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Intern inv journal | InterndebJournal | ZtLong | 10 |  | int
In-house price | Internpris | ZtBaseCurrAmount | 14 | 2 | money
This field is used in the table as follows: |
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Invoice row no | InvRowNo | ZtLong | 5 |  | int
Jeeves_Init_Insert_Enter | Jeeves_Init_Insert_Enter | ztDateTime |  |  | datetime
Jeeves_Init_Insert_PreIns | Jeeves_Init_Insert_PreIns | ztDateTime |  |  | datetime
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Est hourly cost | KalkKostManTim | ZtBaseCurrAmount | 14 | 2 | money
Campaign | KampNr | ZtLong | 4 |  | int
Close follow up | KampResponsKlar | ztBoolean |  |  | char
Responses | KampSvarsKod | ztInteger | 5 |  | smallint
Note | KortNotering | ztString | 255 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Wage type | Loneart | ztString | 6 |  | varchar
This field is used in the table as follows: |
Sequence no. | LopNr | ZtLong | 10 |  | int
Master project no. | MasterProjCode | ztString | 10 |  | varchar
Time accrued | NedlagdTid | ztHourWithDecimals | 8 | 2 | decimal
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OK to invoice | OKtoInvoice | ztBoolean |  |  | char
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Print date | p_utskr_dat | ztDate |  |  | datetime
Quantity PDM | PdmCount | ZtLong | 10 |  | int
PDM (Unique ID) | pdmdummyuniqueid | ztUniqueIdentifier | 100 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Personnel category | perskategori | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Personal no. | PersSignNr | ztInteger | 3 |  | smallint
Planning ID | PlanId | ztString | 10 |  | varchar
Activity finished | PlanUtford | ztBoolean |  |  | char
Price | pris | ZtBaseCurrAmount | 14 | 2 | money
Cost unit person | PrKostBar | ztString | 8 |  | varchar
Cost centre person | PrKostStalleKod | ztString | 8 |  | varchar
This field is used in the table as follows: |
Project ID | ProjCode | ztString | 10 |  | varchar
Journal no. | ProjKonterJournal | ZtLong | 10 |  | int
This field is used in the table as follows: |
Remaining time | ProjKvarTid | ztFloat | 10 | 2 | float
Business opportunity ID | ProspektId | ZtLong | 10 |  | int
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Row | RadPos | ZtLong | 10 |  | int
Row | radpos2 | ztInteger | 4 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Entry time | regtime | ztTime | 5 |  | datetime
Return receipt created | ReturSedelSkapad | ztBoolean |  |  | char
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Cost posting blocked | SparrKostnadskontering | ztInteger | 5 |  | smallint
Date/time | StrDateTime | ztString | 28 |  | varchar
Connection->planned activities | StrDateTimehr | ztString | 28 |  | varchar
Time type | tidkod | ztInteger | 5 |  | smallint
Time report no. | TidrapportNr | ZtLong | 10 |  | int
This field is used in the table as follows: |
Approved status | TimeApprovedStatus | ztInteger | 2 |  | smallint
Services account | TjansteKonto | ztString | 8 |  | varchar
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Price, curr | vb_pris | ZtSalesPrice | 12 | 2 | money
Week no | Veckonr | ztInteger | 6 |  | smallint
Sector | verksamhet | ztInteger | 5 |  | smallint
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint
Prel invoice no. org | WorkFaktNrOrg | Jeeves_InvNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: hrp Reported activities


Reported service activities (xhs)

Definition of activities that you will be able to report on service orders.

NOTE. If you intend to invoice via the assignment routine, the codes for reported service activities must conform with corresponding codes in the assignment routine (program ‘Definition of planned activities’ (xxa)).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Reported activity | EventRpBeskr | ztString | 50 |  | varchar
Reported activity | EventRpKod | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xhs Reported service activities


Reporting manufacturing groups (tpg)

Manufacturing group time report header.
In the header, specify the manufacturing group and the end date of the time report.
A default time can also be entered, which is then copied to those working in the manufacturing group for the calendar period that the report covers.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rep date/labour | AoRappDat | ztDate |  |  | datetime
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Worked hours, mfg grp | ArbTidProdGr | ztHourWithDecimals | 8 | 4 | decimal
Worked hrs/person | ArbTimPerPers | ztHourWithDecimals | 8 | 2 | decimal
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Activity finished | PlanUtford | ztBoolean |  |  | char
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: tpg Reporting manufacturing groups


Reporting Types attendance (AttR_reptp)

Holds report types and descriptions of those.

The following standard records exist. Do not alter/delete:

Report type (AttRRepType) | Report type descr (AttRRepTypeDescr) | Description
1 | In | Code for clocking in, in attendance reporting.
2 | New type | Code for change of attendance reporting type.
3 | Out | Code for clocking out, in attendance reporting.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Report type | AttRRepType | ztInteger | 5 |  | smallint
Report type descr | AttRRepTypeDescr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_reptp Attendance reporting types


Reporting types SFR (SFR_reptp)

Definition of reporting types that is used in shop floor control.

The following standard records exist. Do not alter/delete:

Reportingtype SFR (SFRReptype) | Description (SFRREpTypeDescr) | Description
10 | Start Setup | Code for reporting start of setup.
20 | Start Production | Code for reporting start of production.
30 | Start indirect labour | Code for reporting start of indirect labour that should not affect a "real" manufacturing order.
35 | Start indirect labour (charge) | Code for reporting start of indirect labour that should affect a "real" manufacturing order.
38 | Start indirect labour (temp) | Code for reporting start of indirect labour that should be activated when an employee does not have any other work in progress. If used, this is started automatically.
40 | Interrupt Setup | Code for reporting interruption in setup. This does not interrupt the operation, only the setup.
50 | Interrupt production | Code for reporting interruption in production.
60 | Finish Setup | Code for reporting end of setup. This also reports the labour operation as Finished.
70 | Finish Production | Code for reporting end of production. This also reports the labour operation as Finished, irrespective of any remaining work.
80 | Finish indirect labour | Code for reporting end of indirect labour (irrespective of whether it was started with type 30 or 35).
85 | Partial rep prod, ongoing | Code for partial reporting of production for a job to be continued.
90 | Partial rep production | Code for partial reporting of production for a job to be stopped.
95 | Finish other work (Temp) | Code for reporting end of indirect labour (temp), i.e. a job that is activated when an employee does not have any other work in progress. If used, this is started automatically.
100 | Not active shopfloor op | Code for reporting that a job is in progress but there are currently no employees connected to the job. Example: at the end of the working day, the status of the job can be set to Inactive. This is used to obtain the correct status on labour operations. You can not choose this code when clocking in/out.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Reportingtype SFR | SFRRepType | ztInteger | 5 |  | smallint
Description | SFRRepTypedescr | ztString | 40 |  | varchar
SFR operation status | SFRRepTypeStatusdescr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: SFR_reptp Shop floor reporting types


Reporting types SFR (vSFR_reptp_cdd)

Definition of reporting types that is used in shop floor control.

The following standard records exist. Do not alter/delete:

Reportingtype SFR (SFRReptype) | SFR operation status (SFRRepTypeStatusdescr) | Description
10 | Setup in process |
20 | Production in process |
30 | Indirect labour in process |
35 | Indirect labour in process (charge) |
38 | Indirect labour in process (temp) |
40 | Standstill, interrupt setup |
50 | Standstill, interrupt production |
60 | Finished, setup |
70 | Finished, production |
80 | Finish indirect labour | Code for reporting end of indirect labour (irrespective of whether it was started with type 30 or 35).
85 | Standstill |
90 | Standstill |
95 | Finish other work (Temp) | Code for reporting end of indirect labour (temp), i.e. a job that is activated when an employee does not have any other work in progress. If used, this is started automatically.
100 | Standstill |

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 4 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Reportingtype SFR | SFRRepType | ztInteger | 5 |  | smallint
Description | SFRRepTypedescr | ztString | 40 |  | varchar
SFR operation status | SFRRepTypeStatusdescr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: SFR_reptp2 Reporting types SFR


Reports to be printed (rpmu)

Information in respect of generated reports for printing per recipient according to a distribution list set up.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Value subreport 1 | DecTerm1Value | ztString | 30 |  | varchar
Value subreport 2 | DecTerm2Value | ztString | 30 |  | varchar
Value subreport 3 | DecTerm3Value | ztString | 30 |  | varchar
Value subreport 4 | DecTerm4Value | ztString | 30 |  | varchar
Value subreport 5 | DecTerm5Value | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
OLE-1 | Ole1 | ztString | 255 |  | varchar
OLE-2 | Ole2 | ztString | 255 |  | varchar
Print date | p_utskr_dat | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Value report structure | RbStrBVarde | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Report request | RpBegNr | ZtLong | 6 |  | int
Column no. | RpKolNr | ztInteger | 4 |  | smallint
Batch no. | RpKorNr | ZtLong | 5 |  | int
Report recipient | RpMottagare | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: xRpmu Reports to print


Reports with rules for printout (xffr)

Table of the reports in Jeeves that can have different templates for different customers/suppliers, etc.

The following standard records exist. Do not alter/delete:

Report program (YndReport) | Report name (YndReportDescription)
pUohF | Preview invoice
pUohFD | Preview invoice detail posting
pUohFP | Preview invoice, PG pmt slip
pUohSF1 | Preview collective invoice
pUohSFD | Preview collective inv detail posting
rArlaDA | Reprint purchase order (rArlaDA)
rArlaDe | PO, from requisition, not printed (rArlaDe)
rAviexpU | Odette delivery notice
rBha | Purchase agreements
rBhaA | Reprint purchase agreement
rBhaE | Purchase agreement (not printed)
rBhAoA | Purchase order subcontract, reprint
rBhAoE | Purchase order subcontract (not printed)
rBhBiaDA | Reprint purchase order (rBhBiaDA)
rBhBiaDE | PO from requisition, not printed (rBhBiaDE)
rBhBiaPA | Reprint purchase order (rBhBiaPA)
rBhBiaPE | PO from requisition, not printed (rBhBiaPE)
rBhBiXDA | Reprint purchase order (rBhBiXDA)
rBhBiXDE | PO from requisition, not printed (rBhBiXDE)
rBhDok | Purchase order
rBhDokA | Reprint purchase order (rBhDokA)
rBhDokE | Purchase order, not printed
rBhDokF | Purchase order, RFQ
rBhDokH | Purchase order history
rBhOEC | NEW PO acknowledgement, all rows
rBiahDA | Reprint purchase order (rBiahDA)
rBiahDE | PO from requisition, not printed (rBiahDE)
rDelfor | EDI dispatch plan
rEdiPri1 | Price list EDI complete
rEdiPri2 | Price list EDI changes
rFakt | rfakt sv
rFaktEb | Invoicing eBrev
rFaktFfh | Invoicing of delivery note
rFaktFri | Print invoices by release time
rFaktfu | Invoice, reprint
rFaktFUL | Reprint invoices (disp order)
rFaktKus | Invoicing by cust no.
rFaktP | Print amendment invoice
rFaktPFU | Reprint amendment invoice
rfaktseb | Collective invoicing eBrev
rFaktSF1 | Collective invoicing per delivery customer
rFaktSF2 | Collective invoicing per payment customer
rFaktSFOU1 | Coll.invoicing order+assignment per deliv.cust
rFaktSFOU2 | Coll.invoicing order+assignment per pay.cust
rFfhFs | ... (Delivery note) ...
rFfhFsA | Delivery note (reprint)
rFfhFsE | Delivery note (not printed)
rFfhPl | ... (Picking list, delivery note)...
rFfhPlA | Picking list, deliv note (reprint)
rFfhPlE | Picking list, deliv note (not printed)
rFhUtskr | Reprint invoice
rFktAFfh | Reprint invoicing of delivery note
rFktF | Invoice, print preview
rFktFfhF | Invoice deliv note, print preview
rFktFsk | Print Advance invoice
rFktFskA | Reprint advance invoice (rFktFskA)
rFktKusF | Invoicing, cust no seq, print preview
rFktPF | Amendment invoice, print preview
rFktSF1F | Coll Inv per dest (cust), print preview
rFktSF2F | Coll Inv per pay (cust), print preview
rInvjIL_variant | Physical inventory list - variant
rInvjIR_variant | Physical inventory results - variant
rInvoicU | Invoice message INVOIC
rJkplPL | Picking list, picking journal
rJkplPLA | Picking list, picking journal (reprint)
rJkplPLE | Picking list, picking journal (not printed)
rJkplPlk | Picking list
rKravKpr | Print/reprint individual reminders
rKravPrt | Demand letter
rKuKrvSP | Create and print reminders
rkukrvspeb | Create and print reminders (eBrev)
rKusKU | Account statement
rKusKUbr | Account statement in currency
rKusKUx | Acct stmnt in base cncy (prev version)
rKusRtaS | Calc/print interest invoices
rLevResU | Supplier invoice EDI
rOeAlfa | Order acknowledgement Alpha
rOfh2 | ... Quotation
rOfh2A | Quotation (reprint)
rOfh2E | Quotation (not printed)
rOfhKr | ... ( Quotation, campaign ) ... (rOfhKr)
rOfhKrA | Quotation, campaign (reprint)
rOfhKrE | Quotation, campaign (not printed)
rOfhP2 | ... (Quotation, pos order) ...
rOfhP2A | Quotation, pos order (reprint)
rOfhP2E | Quotation, pos order (not printed)
rOhBPlE | Bkng+pckng list, OK status (not printed)
rOhFs | ... (Delivery note, order) ...
rOhFsA | Delivery note, order (reprint)
rOhFsE | Delivery note, order (not printed)
rOhFSF | ... (Deliv note, invoiced orders) ...
rOhFsFA | Deliv note, invoiced orders (reprint)
rOhFsFE | Deliv note, invcd orders (not printed)
rOhFskA | Reprinting Advance invoice (rOhFskA)
rOhOe | Order acknowledgement
rOhOea | Reprint order acknowledgement
rOhOEC | NEW Order acknowledgement, all rows
rOhOEC1 | NEW Order acknowledgement, changed rows
rOhOeE | Order acknowledgement (not printed)
rOhOeEb | Order acknowledging eBrev
rOhOEH | Order acknowledgement history
rOhOff | Quotation
rOhPL | ... (Picking list) ...
rOhPL1 | ... (Picking list, customer no.) ...
rOhPl1A | Picking list, customer no. (reprint)
rOhPl1E | Picking list, cust no. (not printed)
rOhPlA | Reprint picking list
rOhPlC | ... (Picking list, OK status) ...
rOhPlCA | Reprint picking list w OK status
rOhPlCE | Picking list, OK status (not printed)
rOhPlE | Picking lists (not printed)
rOhPlKC | ... (Pick. list cust. no., OK status)...
rOhPlKCA | Reprint pick. list cust. no., OK status
rOhPlKCE | Picking list cust. no., OK (not printed)
rOhPrf | Pro Forma, order
rOhPsK | ... ( Compressed packing slip order) ...
rOhPsKA | Reprint compressed packing slip order
rOhPsKE | Compressed pack slip order (not printed)
rOkrdOf | ... ( Quotation, campaign ) ... (rOkrdOf)
rOlhBPOK | Bkng+pckng list, OK status
rOlhFs | Delivery note, dispatch order
rOlhFSA | Reprint delivery note, disp order
rOlhFSE | Delivery note, disp ord (not printed)
rOlhFsF | ... (Del note invcd disp orders)
rOlhFsFA | Reprint deliv note/invcd dispatch order
rOlhFsFE | Deliv note invcd disp ord (not printed)
rOlhPKC | ... (Dsp ord pick lst cst no. OK sts)...
rOlhPKCA | Reprt disp. order cust no. pick list, OK status
rOlhPKCE | Disp ord pick list cust no., OK status (nt prt)
rOlhPl | ... (Disp order picking list) ...
rOlhPl1 | ... (Pick list disp order, cust no.) ..
rOlhPl1A | Reprint disp order pick list, cust no.
rOlhPl1E | Disp ord pick list, cust no., (not pr)
rOlhPlA | Reprint disp order picking list
rOlhPlC | ... (Disp order pick list, OK status)...
rOlhPlCA | Reprint disp order picking list, OK status
rOlhPlCE | Disp order picking list, OK status (not print)
rOlhPlE | Disp ord picking list (not printed)
rOlhPrf | Proforma, dispatch order
rOlhPsK | ... (Compr packing slip disp order) ...
rOlhPsKA | Reprint disp order compr packing slip
rOlhPsKE | Compr pack slip disp order (not printed)
rOrdersU | Order message ORDERS
rPOLineS | Purchase order rows, supplier (rPOLineS)
rPOLineSuppExtDoc | Purchase order rows, supplier (rPOLineSuppExtDoc)
rPricatU | Price list EDI
rPrtRtaA | Print/reprint interest invoice
rPrtRtaQ | Print/reprint interest invoice with mode
rPrtRtaS | Interest invoice
rprtrteb | (Re)print interest invoice eBrev
rSamFaktFfh | Collective invoicing of delivery note
rSFFfheb | Collective invoice, delivery note (eBrev)
rUohF | Assignment invoice
rUohFD | Create and print invoice detail posting
rUohFDU | Reprint invoice detail posting
ruohfeb | Create/print invoices (eBrev)
rUohFP | Create and print invoice w PG pmt
rUohFU | Assignment invoice, reprint
rUohFUP | Reprint invoice w PG pmt
rUohSF1 | Collective invoice Assignments
rUohSFD | Collective invc Assignment det posting
rUohSFDU | Reprint collective invoice, detail
rUohSFU | Reprint collective invoice, assignments

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Report, eBrev | eBrevrapport | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Matrix printout only | PVMReportOnly | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Report program | YndReport | ztString | 40 |  | varchar
Report name | YndReportDescription | ztString | 80 |  | varchar

    This table is the main table in the following programs:

    Program: xffr Reports with rules for printout


Requisition (wbia)

Table containing preliminary requisitions.
This can be items that should be put out to tender before placing an order.
New rows are NOT created in the table in Jeeves standard but are intended to be able for customers to use with their own macros/procedures.
The table can be used in Jeeves standard to create requisitions for suppliers and indirectly to create purchase agreements.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Purchased | AnskaffningKop | ztBoolean |  |  | char
Manufactured | AnskaffningTillv | ztBoolean |  |  | char
Number of decs (ext) | AntDecExtQty | ztInteger | 1 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Work group | ArbetsLag | ztString | 6 |  | varchar
Item description | ArtBeskr | ztString | 30 |  | varchar
Main agreement | ArtHuvudAvt | ztBoolean |  |  | char
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Revision no. | ArtRevId | ztString | 10 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Approved by | AttestSign | ztString | 6 |  | varchar
Pieces | BAntalStyck | ZtQty | 14 | 2 | decimal
Req qty, supplier's unit | BegAntal | ZtQty | 14 | 2 | decimal
Required quantity | BehovAntal | ZtQty | 14 | 2 | decimal
Start purch/mfg | BehovStartDat | ztDate |  |  | datetime
Order qty (invtry unit) | BestAnt | ZtQty | 14 | 2 | decimal
Order qty (suppl unit) | BestAntExtQty | ZtQty | 14 | 2 | decimal
Request disp date | BestBegLevDat | ztDate |  |  | datetime
Req to date (int) | BestBehovDat | ztDate |  |  | datetime
Req to date ext | BestBehovLevDat | ztDate |  |  | datetime
Est disp date | BestBerLevDat | ztDate |  |  | datetime
Order date acc. lead time | BestDatEnlLedTid | ztDate |  |  | datetime
Delivery date supplier quay | BestLevDatFranLevsKaj | ztDate |  |  | datetime
Delivery date to quay | BestLevDatTillKaj | ztDate |  |  | datetime
Promised disp date | BestLovLevDat | ztDate |  |  | datetime
PO no. | Bestnr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Prel purchase price | BestWinPris | ztMoney | 14 | 2 | money
Preliminary price (setup) | BestWinPrisStall | ztMoney | 14 | 2 | money
Prel purchase price (start) | BestWinPrisStart | ztMoney | 14 | 2 | money
Figure no. | BFigNr | ztString | 6 |  | varchar
Purch requisition no. | BiaNr | ZtLong | 10 |  | int
Requisition status | BiaStatus | ztInteger | 1 |  | smallint
Requisition source | BiaUrsprKod | ztInteger | 2 |  | smallint
Quantity per piece | BKvantPerStyck | ztFloat | 12 | 4 | float
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Dimension 1 | Dimension1 | ztFloat | 15 | 2 | float
Dimension 2 | Dimension2 | ztFloat | 15 | 2 | float
Dimension 3 | Dimension3 | ztFloat | 15 | 2 | float
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
External purch agreem no. | ExtInkAvt | ztString | 20 |  | varchar
Finns arbetsbeskr | FinnsArbetsBeskr | ztBoolean |  |  | char
Finns op.lista | FinnsOperationsLista | ztBoolean |  |  | char
Finns verktygslista | FinnsVerktygsLista | ztBoolean |  |  | char
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Advance booking | ForKop_Th | ztBoolean |  |  | char
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Grouped by item | GrupperasPaartNr | ztString | 30 |  | varchar
Ext doc purch req | IA_ExtDok | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Suborder item (purchase) | InkopsAvropsArtikel | ztBoolean |  |  | char
Suborder purchase | InkopsAvropsBestNr | ZtLong | 10 |  | int
Purchase forecast (suborder) | InkopsPrognos | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Allocated time, subcontr cap | KapLegoAnslagenTid | ztOpTime | 9 | 4 | float
Purchase of item | KopAvArtikel | ztBoolean |  |  | char
Buy manuf of item | KopTillvAvArtikel | ztBoolean |  |  | char
Note | KortNotering | ztString | 255 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry loc group | LagStalleGrupp | ztString | 8 |  | varchar
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Adm lead time | LedTidAdm | ztInteger | 3 |  | smallint
Lead time from suppl | LedTidEnlLev | ztInteger | 3 |  | smallint
Lead time extra demand | LedTidExtra1 | ztInteger | 3 |  | smallint
Disp.plan number | LevPlanNr | ZtLong | 10 |  | int
Dispatch plan row no. | LevPlanRadNr | ZtLong | 10 |  | int
Supplier item descr | LevsArtBeskr | ztString | 255 |  | varchar
Subcontract flag | MarkLego | ztBoolean |  |  | char
MRP batch -> Sign/mgr | NE_PlanAnsv | ztString | 8 |  | varchar
Search if agree > net req | NewSearchWhenCreatePur | ztBoolean |  |  | char
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Replan | Omplaneras | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Order spec text | OrpRadText | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Invtry unit->Purch unit | StockQty2SuppQty | ztFloat | 12 | 6 | float
Requisition | StrDateTimeBia | ztString | 28 |  | varchar
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
ID for connection | Ti_LopNr_Ned | ZtLong | 10 |  | int
Start date | TiStartDat | ztDate |  |  | datetime
OK to use tool | ToolOkToUse | ztBoolean |  |  | char
Transport days | TransportTid | ztInteger | 3 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross setup price, curr | Vb_InPris_Stall | ztMoney | 14 | 2 | money
Gross start purch price, curr | Vb_InPris_Start | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: Pbia Requisition


Requisition (bia)

Details on purchase requisition.
This table can be seen as a mailbox to the purchaser.
At demand runs, shortage runs, etc., a row is created for each item and purchase need in this table.
It is also possible to enter purchase proposals manually.
Purchase requisitions can then be used to generate purchase orders for suppliers or manufacturing orders for the workshop.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Purchased | AnskaffningKop | ztBoolean |  |  | char
Manufactured | AnskaffningTillv | ztBoolean |  |  | char
Number of decs (ext) | AntDecExtQty | ztInteger | 1 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
MRP Manufacturing order no | AoNrNE | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
MRP Pos | AoPosNE | ztInteger | 4 |  | smallint
Work group | ArbetsLag | ztString | 6 |  | varchar
Item description | ArtBeskr | ztString | 30 |  | varchar
Main agreement | ArtHuvudAvt | ztBoolean |  |  | char
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Revision no. | ArtRevId | ztString | 10 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Approved by | AttestSign | ztString | 6 |  | varchar
Pieces | BAntalStyck | ZtQty | 14 | 2 | decimal
Req qty, supplier's unit | BegAntal | ZtQty | 14 | 2 | decimal
Required quantity | BehovAntal | ZtQty | 14 | 2 | decimal
Start purch/mfg | BehovStartDat | ztDate |  |  | datetime
Order qty (invtry unit) | BestAnt | ZtQty | 14 | 2 | decimal
Order qty (suppl unit) | BestAntExtQty | ZtQty | 14 | 2 | decimal
Request disp date | BestBegLevDat | ztDate |  |  | datetime
Req to date (int) | BestBehovDat | ztDate |  |  | datetime
Req to date ext | BestBehovLevDat | ztDate |  |  | datetime
Est disp date | BestBerLevDat | ztDate |  |  | datetime
Order date acc. lead time | BestDatEnlLedTid | ztDate |  |  | datetime
Delivery date supplier quay | BestLevDatFranLevsKaj | ztDate |  |  | datetime
Delivery date to quay | BestLevDatTillKaj | ztDate |  |  | datetime
Promised disp date | BestLovLevDat | ztDate |  |  | datetime
PO no. | Bestnr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Prel purchase price | BestWinPris | ztMoney | 14 | 2 | money
Preliminary price (setup) | BestWinPrisStall | ztMoney | 14 | 2 | money
Prel purchase price (start) | BestWinPrisStart | ztMoney | 14 | 2 | money
Figure no. | BFigNr | ztString | 6 |  | varchar
Purch requisition no. | BiaNr | ZtLong | 10 |  | int
Requisition status | BiaStatus | ztInteger | 1 |  | smallint
Requisition source | BiaUrsprKod | ztInteger | 2 |  | smallint
Quantity per piece | BKvantPerStyck | ztFloat | 12 | 4 | float
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Dimension 1 | Dimension1 | ztFloat | 15 | 2 | float
Dimension 2 | Dimension2 | ztFloat | 15 | 2 | float
Dimension 3 | Dimension3 | ztFloat | 15 | 2 | float
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
External purch agreem no. | ExtInkAvt | ztString | 20 |  | varchar
Finns arbetsbeskr | FinnsArbetsBeskr | ztBoolean |  |  | char
Finns op.lista | FinnsOperationsLista | ztBoolean |  |  | char
Finns verktygslista | FinnsVerktygsLista | ztBoolean |  |  | char
Previous dispatch plan | FLevPlanNr | ztString | 17 |  | varchar
Prev Del.plan row no. | FLevPlanRadNr | ZtLong | 10 |  | int
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Advance booking | ForKop_Th | ztBoolean |  |  | char
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Grouped by item | GrupperasPaartNr | ztString | 30 |  | varchar
Ext doc purch req | IA_ExtDok | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Suborder item (purchase) | InkopsAvropsArtikel | ztBoolean |  |  | char
Suborder purchase | InkopsAvropsBestNr | ZtLong | 10 |  | int
Purchase forecast (suborder) | InkopsPrognos | ztBoolean |  |  | char
Purchasing role | inkopsroll | ztInteger | 4 |  | smallint
Receive to MO | InlevTillAoNr | Jeeves_MONo | 7 |  | bigint
Receive to MO Pos | InlevTillAoPos | ztInteger | 4 |  | int
Receive to MO Op | InlevTillOpNr | ztInteger | 3 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar, fix disp dates | KalFastLevDagNr | ztInteger | 2 |  | smallint
Allocated time, subcontr cap | KapLegoAnslagenTid | ztOpTime | 9 | 4 | float
Purchase of item | KopAvArtikel | ztBoolean |  |  | char
Buy manuf of item | KopTillvAvArtikel | ztBoolean |  |  | char
Note | KortNotering | ztString | 255 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry loc group | LagStalleGrupp | ztString | 8 |  | varchar
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Adm lead time | LedTidAdm | ztInteger | 3 |  | smallint
Lead time from suppl | LedTidEnlLev | ztInteger | 3 |  | smallint
Lead time extra demand | LedTidExtra1 | ztInteger | 3 |  | smallint
Disp.plan number | LevPlanNr | ZtLong | 10 |  | int
Dispatch plan row no. | LevPlanRadNr | ZtLong | 10 |  | int
Supplier item descr | LevsArtBeskr | ztString | 255 |  | varchar
Subcontract flag | MarkLego | ztBoolean |  |  | char
Dispatch plan item | MarkLevPlanArtikel | ztBoolean |  |  | char
MO replanned in MRP calc | MRP_RePlannedFlag | ztBoolean |  |  | char
MRP batch -> Sign/mgr | NE_PlanAnsv | ztString | 8 |  | varchar
Search if agree > net req | NewSearchWhenCreatePur | ztBoolean |  |  | char
MRP change type | NRP_Action | ztInteger | 5 |  | smallint
Change from date | NRP_FromDate | ztDate |  |  | datetime
Change from quantity | NRP_FromQty | ZtQty | 14 | 2 | decimal
Change proposal | NRP_Note | ztString | 255 |  | varchar
Change to date | NRP_ToDate | ztDate |  |  | datetime
Change to quantity | NRP_ToQty | ZtQty | 14 | 2 | decimal
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Replan | Omplaneras | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Order spec text | OrpRadText | ztString | 255 |  | varchar
Quantity PDM | pdmcount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Pricing type | PrisHantTyp | ztInteger | 3 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Build-up of safety stock | SakLagUppByggnad | ZtQty | 14 | 2 | decimal
Serv.order no | ServOrderNr | Jeeves_SONo | 9 |  | bigint
Order row, service | ServOrdRadNr | ztInteger | 5 |  | int
Language | SprakKod | ztInteger | 3 |  | smallint
Invtry unit->Purch unit | StockQty2SuppQty | ztFloat | 12 | 6 | float
Requisition | StrDateTimeBia | ztString | 28 |  | varchar
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
BOM for item | StycklistaTillArtNr | ztString | 30 |  | varchar
ID for connection | Ti_LopNr_Ned | ZtLong | 10 |  | int
Start date | TiStartDat | ztDate |  |  | datetime
OK to use tool | ToolOkToUse | ztBoolean |  |  | char
Transport days | TransportTid | ztInteger | 3 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Gross setup price, curr | Vb_InPris_Stall | ztMoney | 14 | 2 | money
Gross start purch price, curr | Vb_InPris_Start | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: BiaAn1 Requisition - assembly analysis

    Program: BiaMaReP Replanning, manufacturing

    Program: BiaPuReP Replanning, purch

    Program: SrLa2 Assembly analysis, requisition

    Program: xBia Requisition, details

    Program: xBiaAll Purchase requisitions (also ordered)

    Program: xBiapr Forecast order from requisition

    Program: xBiaprb PO from forecast order

    Program: xBiaTa Requisitions (purch + mfg)


Resource groups (xrg)

A table for resource groups/roles to which users and activities in the Workflow flows are linked.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Resource group (descr) | ResGrpBeskr1 | ztString | 50 |  | varchar
Resource group | ResursGrp | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xrg Workflow resource groups


Resource groups (view) (vxrg)

Numeric code for group of resources/roles. The information is used to group personnel resources/users and to link activities to resources and roles.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Resource group (descr) | resgrpbeskr1 | ztString | 50 |  | varchar
Resource group | ResursGrp | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Resource reserves (prrs)

Resource reserves

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
From date | fromdatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Reserve | PerssignMailReserv | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Valid to date | tomdatum | ztDate |  |  | datetime


Responsible - main (pra)

Main table of supervisors.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Sequence no. | LopNr | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Project manager | PersSign1 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PrA Manager


Restriction types (ret)

Definition of restriction types used for limiting report production in the report generator.

As well as standard records, you can also set up your own restriction types.

The following standard records exist. Do not alter/delete:

Restriction type (RestrType) | Restriction type (RestrTBeskr) | Description
1 | Equals (=) | Used to restrict a report column/row or a conversion to an individual record, e.g. to an individual account or a specific fiscal year or a period. You specify which record in the 'From value' field.
2 | WildCard (%) | Used to restrict a report column/row or a conversion using a Wildcard, e.g. only to accounts whose number starts with 3, in which case you enter 3% in the 'From value' field.
3 | Interval (from-to) | Used to restrict a report column/row or a conversion to an interval of records, e.g. to an interval of accounts or fiscal periods. You enter the interval in the 'From value' or 'To value' field.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Restriction type | RestrTBeskr | ztString | 50 |  | varchar
Restriction type | RestrType | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: reta Column restriction


Restrictions (rest)

Definition of restrictions in report definitions, i.e. conditions/restrictions for which records will be covered by the report.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
DB-term/-expression 1 | DbTermname1 | ztString | 120 |  | varchar
From value | Firstvarde | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
To value | Lastvarde | ztString | 255 |  | varchar
And/Or | ocheller | ztInteger | 3 |  | smallint
Operand | Operator | ztString | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Entry time | RegTime | ztTime | 5 |  | datetime
Restriction type | RestrType | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Column no. | RpKolNr | ztInteger | 4 |  | smallint
Row combination | RpRaddefID | ztInteger | 4 |  | smallint
Column combination | RpTypKod | ztInteger | 4 |  | smallint
Sequence | Sequence | ztInteger | 3 |  | smallint
Date/time | StrDateTime | ztString | 28 |  | varchar
Value term table | VardeTabId1 | ztString | 255 |  | varchar
Negation | WhereNot | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: rest Row restriction


Restrictive views (sy3)

Table of restrictive views, i.e. views can be used to limit the rows in a database that are accessible to a user group.

Note that these restrictions are at row level. Column restrictions can be created by using the SQL Security functions.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Group | grupp | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Base/value table | ztable | ztString | 255 |  | varchar
View | zview | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: xSy3 Restrictive views, table


Restrictive views, node, wcd (sy3p)

Table of restrictive views, i.e. views can be used to limit the rows in a database that are displayed in a certain program node.

These views can be used, for example, to decrease the result of a search for orders to those with a specific status.
You can see all orders in Jeeves order program. If a specific group always wants to see orders with planned status up to released status, you can create a view on the order table which only shows orders with the correct status and specify in the table in question which group(s) and program is referred to.
If you want to have the order program for search on all orders, you can create a clone of the order program and link the restrictive views into the clone.
You can link the restrictive views to a program and node or to a form.

This view can be based on another view that restricts the rows in a database to which a user group has access.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Group | Grupp | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Program node | node | ztString | 35 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Program | pgm | ztString | 40 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Window context (site rep) | wctxt | ztString | 40 |  | varchar
Base/value table | zTable | ztString | 255 |  | varchar
View | zview | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: sy3p Restrictive views, program node, forms


Retail discount matrix (pria)

Matrix for the calculation of discounts, based on discount classes defined for customers and items.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item discount class | ArtRabKlass | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quantity limit >= | Limitlowant | ztFloat | 10 | 2 | float
Signature | PersSign | ztString | 30 |  | varchar
Price list as of | prisfomdat | ztDate |  |  | datetime
Price valid until date | prislgiltigdat | ztDate |  |  | datetime
Discount 1 % | rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Discount curr 1 | RabattVal1 | ztMoney | 14 | 2 | money
Discount curr 2 | rabattval2 | ztMoney | 14 | 2 | money
Discount curr 3 | Rabattval3 | ztMoney | 14 | 2 | money
Cust discount class | RabKlass | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Currency | valkod | ztString | 3 |  | varchar

    This table is the main table in the following programs:

    Program: pria Retail discount matrix


Return/scrap reasons (bpik)

Definition of reasons for returns and/or according to scrapping which can be used for arrival entry and receipt of purchased or manufactured items.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
Return/scrap reason | KassOrsaksKodBeskr | ztString | 50 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: bpik Return/scrap reasons


Returns/scrapping, PO row (bpr)

Returns/scrap, PO row.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Decimal places | AntDec | ztInteger | 1 |  | smallint
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Use/Best before | BastForeDatum | ztDate |  |  | datetime
Batch no. required | BatchBokas | ztBoolean |  |  | char
Batch no. | BatchId | ztString | 30 |  | varchar
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
Received qty (suppl unit) | BestLevAntExtQty | ZtQty | 14 | 2 | decimal
Delivery received date | bestlevdat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
Remaining qty invtry unit | BestRestAnt | ZtQty | 14 | 2 | decimal
This field is used in the table as follows: |
Remaining qty (suppl unit) | BestRestAntExtQty | ZtQty | 14 | 2 | decimal
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Cancel remain qty | MakuleraRestAntal | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | projcode | ztString | 10 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Returned qty invtry unit | ReturAnt | ZtQty | 14 | 2 | decimal
Returned qty (suppl unit) | ReturAntExtQty | ZtQty | 14 | 2 | decimal
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Serial no. required | SerieNrBokas | ztBoolean |  |  | char
Create delivery note | SkapaFoljesedel | ztBoolean |  |  | char
Create freight bill | SkapaFraktsedel | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Invtry unit->Purch unit | StockQty2SuppQty | ztFloat | 12 | 6 | float
Date/time | StrDateTime | ztString | 28 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: bpr Returns


Review of imported supp.invoice (pvlr)

Details of imported but unreviewed supplier invoices for correcting/supplementing before they can be transferred to the Supplier invoices (lr) and Document (pdm) tables.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule match inv/PO | ap2pomatchingrule | ztInteger | 5 |  | smallint
Approval status | Attestkod1 | ztInteger | 1 |  | smallint
Approved by | AttestSign | ztString | 6 |  | varchar
Approval chain | attkedja | ztInteger | 5 |  | smallint
Posting template | autoregel | ztString | 4 |  | varchar
Posting tmplt, final approval | AutoRegels | ztString | 4 |  | varchar
Bank Giro | Bankgiro | ztBgNr | 11 |  | varchar
Account at bank | BankKonto | ztString | 40 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Purch order no. (alpha) | BestNrAlfa | ztString | 50 |  | varchar
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Reviewed | CheckPvlr | ztBoolean |  |  | char
Document ID | DocId | ztString | 50 |  | varchar
Document type no. | Documenttype | ZtLong | 5 |  | int
Internal text | EditInt | ztBlob | 1 |  | varchar
EU VAT/tax registration no. | EUmomsNR | ztString | 20 |  | varchar
Invoice date | FaktDat | ztDate |  |  | datetime
Due date | FaktFfDat | ztDate |  |  | datetime
Invoice reference no. | FaktNr_ocr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Accruals | InterimsKontering | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | k5 | ztString | 8 |  | varchar
S6 | k6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Customer order no. | KundBestNr | ztString | 30 |  | varchar
Customer | KundNr | ztCompanyNo | 20 |  | varchar
Receipt date | KvittensFvDatum | ztString | 25 |  | varchar
Receipt created | KvittensSkapad | ztBoolean |  |  | char
Payment terms | LevBetvillk | ztString | 2 |  | varchar
Invoice Type | LevfaktTyp | ztInteger | 3 |  | smallint
Supplier category | levkategori | ztInteger | 2 |  | smallint
Supplier reference | LevRef2 | ztString | 50 |  | varchar
Arrival date | lrfaktankdat | ztDate |  |  | datetime
Tax amount 0 | MomsBelopp0 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 1 | MomsBelopp1 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 2 | MomsBelopp2 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 3 | MomsBelopp3 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 4 | MomsBelopp4 | ZtBaseCurrAmount | 14 | 2 | money
Tax date | MomsDatum | ztDate |  |  | datetime
Tax basis 0 | MomsGrundBelopp0 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 1 | MomsGrundBelopp1 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 2 | MomsGrundBelopp2 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 3 | MomsGrundBelopp3 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 4 | MomsGrundBelopp4 | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax 0 | MomsKod0 | ztInteger | 5 |  | smallint
VAT/tax 1 | MomsKod1 | ztInteger | 5 |  | smallint
VAT/tax 2 | MomsKod2 | ztInteger | 5 |  | smallint
VAT/tax 3 | MomsKod3 | ztInteger | 5 |  | smallint
VAT/tax 4 | MomsKod4 | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Organization no. | OrgNr | ztString | 18 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Plus giro no. | Postgiro | ztPgNr | 11 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Date/time resend | Pvlr_Resend_Dt | ztDateTime |  |  | datetime
Supplier invoice rows? | PvLrdRowsExist | ztBoolean |  |  | char
SeqNo. | pvlrid | ZtLong | 10 |  | int
Collective Invoice | PvLrSamFakt | ztInteger | 5 |  | smallint
Transferred | PvlrStatus | ztBoolean |  |  | char
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Signature | ReviewedByPersSign | ztString | 6 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date created | SkapadDatum | ztString | 25 |  | varchar
Txt file created | TxtFileSkapad | ztBoolean |  |  | char
Upd charge basis | upddeb | ztBoolean |  |  | char
Payment methods | UtbSlag | ztString | 3 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax type 0 | VAT_Type_0 | ztInteger | 4 |  | smallint
VAT/tax type 1 | VAT_Type_1 | ztInteger | 4 |  | smallint
VAT/tax type 2 | VAT_Type_2 | ztInteger | 4 |  | smallint
VAT/tax type 3 | VAT_Type_3 | ztInteger | 4 |  | smallint
VAT/tax type 4 | VAT_Type_4 | ztInteger | 4 |  | smallint
VAT/tax type purchase | VAT_Type_Purchase | ztInteger | 4 |  | smallint
VAT/tax type sales | VAT_Type_Sales | ztInteger | 4 |  | smallint
VAT/tax exchange rate | VATExchRate | ZtCurrencyRate | 15 | 7 | decimal
Packaging, curr | Vb_Emballagekostnad | ztMoney | 14 | 2 | money
Handling charge curr | Vb_Expeditionkostnad | ztMoney | 14 | 2 | money
Invoice amount, curr | vb_faktsum | ztMoney | 14 | 2 | money
Insurance, curr | Vb_ForsakringsKostnad | ztMoney | 14 | 2 | money
Total freight, curr | Vb_Fraktkostndeb | ztMoney | 14 | 2 | money
VAT/tax, curr | vbFaktMoms | ztMoney | 14 | 2 | money
Verified date | VerifieradDatum | ztString | 25 |  | varchar
Text/info | x255_2 | ztString | 255 |  | varchar
Text 3 | x255_3 | ztString | 255 |  | varchar
Text 4 | x255_4 | ztString | 255 |  | varchar
Info/Text | x8000 | ztString | 4000 |  | varchar
x8001 | x8001 | ztString | 4000 |  | varchar

    This table is the main table in the following programs:

    Program: xPvlr Review imported supplier invoices


Review of imported supp.invoice rows (PvLrd)

Details of imported but non reviewed supplier invoices, details for correcting/supplementing before they can be transferred to the Supplier invoices (lrd).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Alternative item | ArtNrAltArt | ztString | 30 |  | varchar
Supplier item no. | ArtnrLev | ztString | 30 |  | varchar
Delivery note no., rcv | BestFoljesedelsNr | ztString | 30 |  | varchar
Received qty invtry unit | bestlevant | ZtQty | 14 | 2 | decimal
Received qty (suppl unit) | bestlevantextqty | ZtQty | 14 | 2 | decimal
PO no. | bestnr | Jeeves_PONo | 6 |  | bigint
Purch order no. (alpha) | BestNrAlfa | ztString | 50 |  | varchar
Invc match value | FaktAvprVarde | ztMoney | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Price conv factor | inkartomvfaktor | ztFloat | 14 | 4 | float
Price unit factor | inkprisper | ZtDecimal73 | 8 | 3 | decimal
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Customer order no. | kundbestnr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
SeqNo. | PvLrid | ZtLong | 10 |  | int
Discount 1 % | rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Gross purch price, curr | vb_inpris | ztMoney | 14 | 2 | money
Gross setup price, curr | vb_inpris_stall | ztMoney | 14 | 2 | money
Gross start purch price, curr | vb_inpris_start | ztMoney | 14 | 2 | money
Text/info | x255_2 | ztString | 255 |  | varchar


Revisions view (vpdmr)

Revision index linked to an alphanumeric revision designation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Revision no. | artrevid | ztString | 10 |  | varchar
Revision | artrevindex | ztInteger | 4 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


RFQ Q&A (oqa)

Questions and answers in an RFQ.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | edit | ztBlob | 1 |  | varchar
External text | editext | ztBlob | 1 |  | varchar
Internal text | editint | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quotation class 1 Q&A | offklass | ztInteger | 5 |  | smallint
Quotation class 2 Q&A | offklass2 | ztInteger | 5 |  | smallint
Quotation class 3 Q&A | offklass3 | ztInteger | 5 |  | smallint
Signature | Perssign | ztString | 30 |  | varchar
Entry date | Regdat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Date/time | strdatetime | ztString | 28 |  | varchar

    This table is the main table in the following programs:

    Program: oqa Quotation Q&A


Right-click to program (JvsSiteExpandPgm)

Program/table for viewing and editing settings regarding right-clicks to other programs. Here, you can specify a program that should be replaced with another program when right-clicking (or using Ctrl E).

Note!
Both programs must have the same main table. If you are going to replace one program that has the item table (ar) as its main table, the new program must also have the item table as its main table.

In Jeeves there can be several programs that share the same main table but have different designs for different needs. For example, for items there is a program that is more suited for use in the inventory module (program Artikel) and another that is more suited to production/design (program Arprod). You can use this function to replace the program Artikel with the program Arprod for certain users. You can also used cloned programs when right-clicking.

The setting can apply to an individual user, a user group or for all users. Note, however, that the setting applies to all programs, i.e. if you change the program Artikel to the program Arprod this will affect all right-clicks to the item program.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Right-click from program | JvsSiteExpandFromPgm | ztString | 40 |  | nvarchar
Right-click to program | JvsSiteExpandToPgm | ztString | 40 |  | nvarchar
Group | JvsSiteForGrp | ZtLong | 6 |  | int
Signature | JvsSiteForUser | ztString | 6 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIdentity | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: JvsSiteExpandPgm Right-click to program


Roles in menu (RoToMe)

Roles in menu.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Unique ID | JvsSiteUniqueId | ztString | 40 |  | varchar
Menu key | MenuKey | ZtLong | 8 |  | int
Parent | MenuParent | ZtLong | 8 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Menu ID | UsrDefMenuid | ztString | 20 |  | varchar


Rounding types (xavr)

Definition of rounding types for use
- for calculating sales and list prices,
- in the invoicing for rounding the invoice total via the currency code,
- for calculating new purchase prices from previous purchase prices and
- entering and allocating a budget

The following standard records exist. Do not alter/delete:

Rounding type (PrisAvrundKod) | Rounding type (PrisAvrundBeskr) | Description
0 | No rounding | No rounding.
1 | To 0.05 | To the nearest 5 hundredths (0.05).
2 | To 0.10 | To the nearest 10 hundredths (0.10).
3 | To 0.25 | To the nearest 25 hundredths (0.25).
4 | To 0.50 | To the nearest 50 hundredths (0.50).
5 | To 1.00 | To the nearest whole number (1.00).
6 | To 5.00 | To the nearest 5 whole numbers (5.00).
7 | To 10.00 | To the nearest 10 whole numbers (10.00).
8 | To 100.00 | To the nearest 100 whole numbers (100.00).
9 | To 50.00 | To the nearest 50 whole numbers (50.00).
10 | To 1000.00 | To the nearest thousand (1000.00).
11 | To 10000.00 | To the nearest ten thousand (10000.00).
12 | To 100000.00 | To the nearest hundred thousand (100000.00).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Rounding type | PrisAvrundBeskr | ztString | 50 |  | varchar
Rounding factor | PrisAvrundFaktor | ztFloat | 12 | 6 | float
Rounding type | PrisAvrundKod | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xxavr Rounding types


Row (spec) info, matrix output (MatrixResultSpecRows)

Row number in the relevant table, an automatically generated running number. The purpose is to create unique ids for storing information in different tables.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
WHERE | MatrixCalcWhereStmt | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Batch no. | RpKorNr | ZtLong | 5 |  | int
Row type | RpRadTypKod | ztInteger | 2 |  | smallint
Internal ID on specification | SpecDefIntrnNo | ztInteger | 5 |  | smallint
Partial report no | SubRepNo | ztInteger | 5 |  | smallint


Row combinations (rrdf)

Definition of row combinations in reports. A row combination, which normally contains several report rows, can be included in several report definitions.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Row combination | RpRaddefBeskr | ztString | 40 |  | varchar
Row combination | RpRaddefID | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: rrdf Row combinations


Row control code, eBrev (ebrs)

Row control code, eBrev

The following standard records exist. Do not alter/delete:

Row control code (ebrad) | Row position description (ebRadBeskr)
 | Write on next row
 | Write on next row
 | Write on next row
 | Write on next row
+ | Write on same row
+ | Write on same row
+ | Write on same row
+ | Write on same row
- | Print after 2 blank rows
- | Print after 2 blank rows
- | Print after 2 blank rows
- | Print after 2 blank rows
0 | Print after blank row
0 | Print after blank row
0 | Print after blank row
0 | Print after blank row
1 | Go to top of new page
1 | Go to top of new page
1 | Go to top of new page
1 | Go to top of new page
2 | Channel 2 - Invoice address
2 | Channel 2 - Invoice address
2 | Channel 2 - Invoice address
2 | Channel 2 - Invoice address
3 | Channel 3 - Purchaser
3 | Channel 3 - Purchaser
3 | Channel 3 - Purchaser
3 | Channel 3 - Purchaser
4 | Channel 4 - Our reference
4 | Channel 4 - Our reference
4 | Channel 4 - Our reference
4 | Channel 4 - Our reference
5 | Channel 5 - Delivery address
5 | Channel 5 - Delivery address
5 | Channel 5 - Delivery address
5 | Channel 5 - Delivery address
6 | Channel 6 - Order rows
6 | Channel 6 - Order rows
6 | Channel 6 - Order rows
6 | Channel 6 - Order rows
7 | Channel 7 - Total
7 | Channel 7 - Total
7 | Channel 7 - Total
7 | Channel 7 - Total
8 | Channel 8 - Footer, Company address
8 | Channel 8 - Footer, Company address
8 | Channel 8 - Footer, Company address
8 | Channel 8 - Footer, Company address
9 | Jump to position 9
9 | Jump to position 9
9 | Jump to position 9
9 | Jump to position 9
A | Jump to position 10
A | Jump to position 10
A | Jump to position 10
A | Jump to position 10
B | Jump to position 11
B | Jump to position 11
B | Jump to position 11
B | Jump to position 11
C | Jump to position 12
C | Jump to position 12
C | Jump to position 12
C | Jump to position 12

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Form call | ebBlankett | ztString | 4 |  | varchar
Row control code | ebRad | ztchar | 1 |  | char
Row position description | ebRadBeskr | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xebrs Row control code, eBrev


Row info, matrix output (MatrixResultRows)

Row number in the relevant table, an automatically generated running number. The purpose is to create unique ids for storing information in different tables.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Blank rows current row | AntalBlankrader | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
WHERE | MatrixCalcWhereStmt | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Batch no. | RpKorNr | ZtLong | 5 |  | int
Row text | RpRadText | ztString | 40 |  | varchar
Row type | RpRadTypKod | ztInteger | 2 |  | smallint
Layout per template window | UseReportWindowNo | ztInteger | 5 |  | smallint


Row types (xr2)

Table of the different row types that can be used when creating reports using the report generator.

The following standard records exist. Do not alter/delete:

Row type (RpRadTypKod) | Row type (RpRadTypBeskr) | Description
0 | Value from database | Values that are retrieved from the database.
1 | Calculate using formula | The value is calculated from the values in the report. E.g. r10+r20 gives the sum of rows 10 and 20. sum (r10,r30) totals all rows between 10 and 30.
9 | Text only | Rows that contain text only. Also used to define blank rows.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Row type | RpRadTypBeskr | ztString | 50 |  | varchar
Row type | RpRadTypKod | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: Xxr2 Report row type


Row types, planning list (xo4)

Table of the row types that may be found on the item planning list.

The following standard records exist. Do not alter/delete:

Row type plan list (PlanLstRadTyp) | Row type plan list (PlanLstRadTypBeskr) | Description
- | Batch record, NOT used |
B | Order/purchase | Ordering rows are added to the planning list upon entry/create of an order and are removed when the entire number of rows has been delivered (or upon cancellation of the row or any remainder).
I | Requisition (purchase + mfg) | Purchasing or manufacturing request rows are added to the planning list upon entry/creation of the request and are removed when the request for the order/manufacturing order is changed (or when the request is deleted).
K | Customer orders | Inventory reservations from the customer order rows are added to the planning list upon entry (at status During entry) and are removed when the entire number of rows has been pulled from inventory (or upon cancellation of the rows or any remainder).
M | Mtrl reserv., MO | Material reservation rows for items that are included in the item that will be manufactured, are added to the planning list upon breakdown/entry of the manufacturing order and are removed when the entire number of rows has been pulled (or upon cancellation of the rows or any remainder).
N | Mtrl reserv. MRP order | Material reservation rows from the net requirement order for items that are included in the item that will be manufactured, are added to the planning list upon net requirement scheduling and are removed when the entire number of rows has been pulled (or upon cancellation of the rows or any remainder).
P | Forecast demand | Forecast requirement rows are added to the planning list upon entry/creation of item forecasts and removed when the forecast is collected (or manually deleted in the item forecast program).
R | Repair, service | Material reservation rows for material needed for the item to be repaired are added to the planning list when status is changed to Planned or Ongoing and are removed when you change status to Complete.
S | Balance record, batch |
T | MO, rec delivery | Manufacturing order rows for items that will be manufactured are added to the planning list upon entry and are removed upon delivery from manufacture (or upon cancellation of the rows or remainder).
U | MO, MRP rec delivery | Net requirement order rows for items that will be manufactured are added to the planning list upon net requirement scheduling and are removed upon delivery from manufacture (or upon cancellation of the rows or any remainder).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row type plan list | PlanLstRadTyp | ztString | 2 |  | varchar
Row type plan list | PlanLstRadTypBeskr | ztString | 50 |  | varchar
Sort order | PlanLstRadTypSort | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xo4 Planning list row type


Rules for matching supp.inv. and order (AP2POMatchingRule)

Rules for matching supplier invoice and order.
Matching can be performed at the component level/row level or total level.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule match inv/PO | AP2POMatchingRule | ztInteger | 5 |  | smallint
Matching rule del.inv./order | AP2POMatchingRuleDescr | ztString | 80 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xap2po Matching rules


Rules for printout (ffld)

Definition of printing rules. Printing rules are created in part to specify alternative templates to be used for printing "external" documents, i.e. documents sent out to customers, suppliers, etc. and in part to control the print processing in EDI, eBrev and the fax connection.

The reports for which printing rules can be created are defined in the program Reports editable in Template editor (xffr).

You specify alternative templates if you wish to vary the appearance of documents for different types of customers (one template per country code, language code, etc.) or requiring a special design for a specific customer (primarily when using EDI or eBrev).

The conditions are processed as follows (for each report):
Primarily: If a template has been defined for a company, it is selected.
Secondarily: If a template has been defined for a country code, it is selected.
Thirdly: If a template has been defined for a language code, it is selected.
Fourthly: If a template has been defined for a customer category, it is selected.

If you wish to apply a combination of the above, you must fill in all fields (exact matching).

If you wish to have your own priority, an adaptation must be made (by using the procedure JEEVES_New_Doc).

Note:
- When making a screen print no check of Print rules is performed.

- If you have, in the print rules, directed different templates to different printers this setting will be ignored if you use the (Jini) parameter SameTemplateSamePrintJob, to bundle several printouts.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Auto create out box | AutoCreIOBoxEdi | ztBoolean |  |  | char
Program ID (data name) | DbProgramName | ztString | 60 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Unique ID logical page | eb_logsida_Id | ztInteger | 5 |  | smallint
EDI partner profile | EdiId | ZtLong | 6 |  | int
Email, address | EmailAddress | ztString | 255 |  | varchar
Email, subject template | EmailSubjectTemplate | ztString | 255 |  | varchar
Fax no./e-mail address | FaxNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | KortNotering | ztString | 255 |  | varchar
Customer category | kundkategorikod | ztInteger | 2 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
No of rows | NoOfRepRows | ztInteger | 4 |  | smallint
This field is used in the table as follows: |
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Rapporttyp | Reporttype | ztInteger | 2 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Contract | YndKontrakt | ztString | 20 |  | varchar
Template | Yndmall | ztString | 40 |  | varchar
Report program | YndReport | ztString | 40 |  | varchar
Parameters | Yparams | ztBlob | 255 |  | varchar

    This table is the main table in the following programs:

    Program: Ffld Rules for printout


Rules, historically weighted forecast (phfd)

Rules for weighting history when creating a forecast.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
This field is used in the table as follows: |
Signature | PersSign | ztString | 30 |  | varchar
Weight period | PhfPeriod | ztInteger | 3 |  | smallint
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
This field is used in the table as follows: |
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Weighting factor | ViktningsFaktor | ztFloat | 6 | 2 | float
Weighting rule | ViktningsRegel | ztString | 4 |  | varchar


S3 appr/ctrl grps (kk3)

Table of approval control groups for account segment 3.
The control groups can then be linked to other account segments.
In this way you can control things so that only certain S3 can be used by certain accounts or segment 2 or ...

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
From CU | KBarFrom | ztString | 8 |  | varchar
Appr/ctrl grp, S3 | KBarGrupp | ztString | 6 |  | varchar
To S3 | KBarTom | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


S3 posting rule (xl4)

Internal definitions which are used to determine whether account segment 3 (cost unit) can/will be specified for a specific account.

The following standard records exist. Do not alter/delete:

S3 posting rule (regel4) | S3 posting rule (regelbeskr4)
1 | Does not exist
2 | Optional
3 | Mandatory

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Entry inventory, CU | lager3 | ztInteger | 1 |  | smallint
Obligatory, CU | oblig3 | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
S3 posting rule | regel4 | ztInteger | 1 |  | smallint
S3 posting rule | regelbeskr4 | ztString | 50 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xl4 Posting rule/S3


S3 translation (kbt)

Translation table of segment 3 (cost units) at auto posting and auto allocation in the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allocate to S3 | FordTillKBar | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost unit | Kostbar | ztString | 8 |  | varchar
Translation group | OversattnGrp | ztString | 8 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xKbt Translate S3


S4 appr/ctrl grps, details (kk4)

Table of approval control groups for account segment 4.
The control groups can then be linked to other account segments.
In this way you can control things so that only certain S4 can be used by certain accounts or segment 2 or ...

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
From S4 | K4From | ztString | 8 |  | varchar
Appr/ctrl grp, S4 | k4grupp | ztString | 6 |  | varchar
To S4 | K4Tom | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


S4 posting rule (xl5)

Internal definitions which are used to determine whether account segment 4 can/will be specified for a specific account.

The following standard records exist. Do not alter/delete:

S4 posting rule (regel5) | S4 posting rule (regelbeskr5)
1 | Does not exist
2 | Optional
3 | Mandatory

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Entry inventory, S4 | lager4 | ztInteger | 1 |  | smallint
Mandatory, S4 | oblig4 | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
S4 posting rule | regel5 | ztInteger | 1 |  | smallint
S4 posting rule | regelbeskr5 | ztString | 50 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xl5 Posting rule/S4


S4 translation (k4t)

Translation table of segment 3 at auto posting and auto allocation in the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allocate to S4 | FordTillK4 | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
Translation group | OversattnGrp | ztString | 8 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xK4t Translate S4


S5 appr/ctrl grps (kk5)

Table of approval control groups for account segment 5.
The control groups can then be linked to other account segments.
In this way you can control things so that only certain S5 can be used by certain accounts or segment 2 or ...

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
From S5 | K5From | ztString | 8 |  | varchar
Appr/ctrl grp, S5 | K5Grupp | ztString | 6 |  | varchar
To S5 | K5Tom | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


S5 posting rule (xl6)

Internal definitions which are used to determine whether account segment 5 can/will be specified for a specific account.

The following standard records exist. Do not alter/delete:

S5 posting rule (regel6) | S5 posting rule (regelbeskr6)
1 | Does not exist
2 | Optional
3 | Mandatory

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Entry inventory, S5 | lager5 | ztInteger | 5 |  | smallint
Mandatory, S5 | oblig5 | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
S5 posting rule | regel6 | ztInteger | 1 |  | smallint
S5 posting rule | regelbeskr6 | ztString | 50 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xl6 Posting rule/S5


S5 translation (k5t)

Translation table of segment 5 at auto posting and auto allocation in the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allocate to S5 | FordTillK5 | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S5 | K5 | ztString | 8 |  | varchar
Translation group | OversattnGrp | ztString | 8 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xK5t Translate S5


S6 appr/ctrl grps (kk6)

Table of approval control groups for account segment 6.
The control groups can then be linked to other account segments.
In this way you can control things so that only certain S6 can be used by certain accounts or segment 2 or ...

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
From S6 | K6From | ztString | 8 |  | varchar
Appr/ctrl grp, S6 | K6Grupp | ztString | 6 |  | varchar
To S6 | K6Tom | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


S6 posting rule (xl7)

Internal definitions which are used to determine whether account segment 6 can/will be specified for a specific account.

The following standard records exist. Do not alter/delete:

S6 posting rule (regel7) | S6 posting rule (regelbeskr7)
1 | Does not exist
2 | Optional
3 | Mandatory

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Entry inventory, S6 | lager6 | ztInteger | 5 |  | smallint
Mandatory, S6 | oblig6 | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
S6 posting rule | regel7 | ztInteger | 1 |  | smallint
S6 posting rule | regelbeskr7 | ztString | 50 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xl7 Posting rule/S6


S6 translation (k6t)

Translation table of segment 6 at auto posting and auto allocation in the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allocate to S6 | FordTillK6 | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S6 | K6 | ztString | 8 |  | varchar
Translation group | OversattnGrp | ztString | 8 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xK6t Translate S6


S7 appr/ctrl grps (kk7)

Table of approval control groups for account segment 7.
The control groups can then be linked to other account segments.
In this way you can control things so that only certain S7 can be used by certain accounts or segment 2 or ...

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
From S7 | K7From | ztString | 8 |  | varchar
Appr/ctrl grp, S7 | K7grupp | ztString | 6 |  | varchar
To S7 | K7Tom | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


S7 posting rule (xl8)

Internal definitions which are used to determine whether account segment 7 can/will be specified for a specific account.

The following standard records exist. Do not alter/delete:

S7 posting rule (regel8) | S7 posting rule (regelbeskr8)
1 | Does not exist
2 | Optional
3 | Mandatory

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Entry inventory, S7 | lager7 | ztInteger | 5 |  | smallint
Mandatory, S7 | oblig7 | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
S7 posting rule | regel8 | ztInteger | 1 |  | smallint
S7 posting rule | regelbeskr8 | ztString | 50 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xl8 Posting rule/S7


S7 translation (k7t)

Translation table of segment 7 at auto posting and auto allocation in the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allocate to S7 | FordTillK7 | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S7 | K7 | ztString | 8 |  | varchar
Translation group | OversattnGrp | ztString | 8 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xK7t Translate S7


S8 appr/ctrl grps (kk8)

Table of approval control groups for account segment 8.
The control groups can then be linked to other account segments.
In this way you can control things so that only certain S8 can be used by certain accounts or segment 2 or ...
**** NOT USED ****

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Fr o m K8 | K8From | ztString | 8 |  | varchar
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
To S8 | K8Tom | ztString | 8 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


S8 appr/ctrl grps (gk8)

This table contains any approval control groups for segment 8. It is copied from one year to the next.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Beskr ktrl.grp K8 | Gk8Beskr | ztString | 30 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Kontrollgrupp K8 | K8Grupp | ztString | 6 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


S8 translation (k8t)

Translation table of segment 8 at auto posting and auto allocation in the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Fördelas till K8 | FordTillK8 | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S8 | K8 | ztString | 8 |  | varchar
Translation group | OversattnGrp | ztString | 8 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Safety stock calculation rules (xast)

Definition of calculation method for calculating safety stock.

The following standard records exist. Do not alter/delete:

Safety stock calc (ArtSecBerTyp) | Safety stock calc (ArtSecBerBeskr) | Description
0 | Days from ABC rule | Calculated - according to the number of days plus percentage of lead time specified on the safety stock type. In this way you can control a group of items (for example, manufactured items with high volume weight) so that the safety stock is calculated to a certain level of the usage forecast. For items with this calculation method, the safety stock days are calculated using the formula below and the result is updated to the inventory balance record: Safety stock days according to safety stock type + (% of lead time according to safety stock group * lead time according to inventory balance record / 100) Note that this alternative requires an ABC-class on the items.
1 | Manually entered days | Calculated – according to the number of days specified on the item’s inventory balance record. In this way, for the item, you can specify that the safety stock will refer, for example, to 5 extra days of consumption and the safety stock level is then calculated from number of days and the usage forecast.
2 | Manually entered inventory | Not calculated - specified value applies and does not change automatically. You use this calculation method for items that require special processing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Safety stock calc | ArtSecBerBeskr | ztString | 50 |  | varchar
Safety stock calc | ArtSecBerTyp | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xast Safety stock calc. rules


Safety stock types (arps)

Definition of safety stock types for automatic calculation of safety stock based on the number of safety stock days plus a specified percentage of the item’s lead time.

Safety stock types are built up of combinations of item types and ABC codes, which means that these must be defined first.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item type EOQ/SS | ArpsTyp | ztInteger | 5 |  | smallint
ABC code | ArtABC | ztchar | 1 |  | char
Safety lead time % | ArtSakLagProcLed | ztFloat | 15 | 2 | float
Safety stock days | ArtSecDagar | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: arps Safety stock types


Salary Code (for printing and exporting) (AttR_salcd)

Salary Codes used for printing and exporting to other systems.

The following standard records exist. Do not alter/delete:

Salary code (AttRSalaryCode) | Salary code description (AttRSalaryCodeDescr)
AGDAPS_1 | Salary transactions
AGDAPS_10 | Schedule time
AGDAPS_3 | Absence transactions
Client_1 | Salary transactions
Client_10 | Schedule time
Client_3 | Absence transactions
Hogia_1 | Salary transactions
Hogia_10 | Schedule time
Hogia_3 | Absence transactions
Kontek_1 | Salary transaction
Kontek_10 | Schedule time
Kontek_3 | Absence transactions
SPCSLON_1 | Salary transactions
SPCSLON_10 | Schedule time
SPCSLON_3 | Absence transactions
tidkort_1 | schedule time
tidkort_2 | Worked time
tidkort_3 | Flex plus
tidkort_4 | Flex minus
tidkort_5 | Absence
tidkort_6 | Over time
tidkort_7 | Other
tidkort_8 | Diff
V_SPCS_1 | Salary transactions
V_SPCS_10 | Schedule time
V_SPCS_3 | Absence transactions
Visma_1 | Salary transactions
Visma_10 | Schedule time
Visma_3 | Absence transactions

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Salary code | AttRSalaryCode | ztString | 10 |  | varchar
Salary code description | AttRSalaryCodeDescr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_salcd Salary codes


Salary Code and Type (AttR_salcdtp)

Connects salary code to salary type.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Code 1 | AttRCode1 | ztString | 10 |  | varchar
Code 2 | AttRCode2 | ztString | 10 |  | varchar
Salary code | AttRSalaryCode | ztString | 10 |  | varchar
Salary type | AttRSalaryType | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_salcdtp Salary code and type


Salary Type (AttR_saltp)

Salary types and description.

The following standard records exist. Do not alter/delete:

Salary type (AttRSalaryType) | Salary type description (AttRSalaryTypeDescr)
-2 | Error
-1 | Schedule time

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Salary type | AttRSalaryType | ZtLong | 10 |  | int
Salary type description | AttRSalaryTypeDescr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_saltp Salary types


Salary Type per Agreement (AttR_authacc)

Salary type (used as accumulator) per Agreement.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Agreement ID | AttrAgreement | ztString | 6 |  | varchar
Salary type | AttRSalaryType | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_authacc Accumulator per agreement


Sales discounting methods (xrab)

Definition of sales discounting methods in the customer order routine.

Examples of a sales discounting methods:
- Price deduction
- Buy X and get Y for free

The following standard records exist. Do not alter/delete:

Discounting method
(DiscountMethod) 		Discounting method
(DiscountMethodDescr)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Discounting method | DiscountMethod | ztInteger | 2 |  | smallint
Discounting method | DiscountMethodDescr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xrab Sales discounting methods


Sales forecast per sales group (prgfpr)

Sales forecast per sales group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Forecast group, sales | FsgPrgGrp | ztString | 8 |  | varchar
Main period | HuvudPeriod | ztString | 25 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Keep year forecast | KeepYearValue | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Period forecast | PrognosAntalPeriod | ZtQty | 14 | 2 | decimal
Forecast family | PrognosFamilj | ztString | 4 |  | varchar
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Forecast key | PrognosNyckel | ztString | 25 |  | varchar
Forecast period | PrognosPeriod | ztString | 25 |  | varchar
Forecast version | PrognosVer | ZtLong | 4 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Sales order returns (WMS) (WMS_V_EXT_SOLineRec)

Order numbers in numeric format. There is also a field for alphanumeric order numbers.

When defining the company's order types, it is possible to set different number series for each order type. The orders whose order types do not have order number series, receive their order numbers from the highest number series.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item description | ArtBeskr | ztString | 30 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Number of SKU | NumberOfSKU | ztInteger | 5 |  | decimal
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Order row status | OrdRadSt | ztInteger | 2 |  | smallint
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Pallet unit type | PalletUnitType | ztString | 5 |  | varchar
Full pallet quantity | PartDefFullUnitQty | ZtQty | 14 | 2 | decimal
Pallet unit type | PartDefFullUnitType | ztString | 5 |  | varchar
Qty / SKU | QtyPerSKU | ZtQty | 14 | 2 | decimal
Qty to receive | QtyToReceive | ZtQty | 14 | 2 | decimal

    This table is the main table in the following programs:

    Program: WMS_EXT_SOLineRec Sales order returns (WMS)


Sales phases (prof)

Definition of different steps in the sales phase.

From version 9, there is certain logic for automatically changing the sales phase when changing a business opportunity's status, which is why there are records that can be loaded into the table upon installation (so-called Proposals).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sales phase | saljfasbeskr | ztString | 80 |  | varchar
Sales phase | saljfasid | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: prof Sales phases


Sales price list details, item groups (prlv)

Table of price list date for each item group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Recommended price | ArtCirkaPris | ZtSalesPrice | 12 | 2 | money
Calc.ord amount + % | BerOrdnBelAddProc | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, BCU | FPris | ZtBaseCurrAmount | 14 | 2 | money
Sales price, internal | FPrisInternt | ZtBaseCurrAmount | 14 | 2 | money
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
No customer disc | KundEjRabKod | ztBoolean |  |  | char
Discount code, item grp | LevVgrpRabGrupp | ztInteger | 4 |  | smallint
Quantity limit >= | LimitLowAnt | ztFloat | 10 | 2 | float
Markup/reduction % | markup | ztFloat | 14 | 4 | float
Price factor amount | MarkUpBelopp | ztMoney | 14 | 2 | money
Discount fr matrix, add | MatrisRabAddKod | ztBoolean |  |  | char
Disc code order value | OrdvRabKod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price factor table | PrisFaktTabKod | ztString | 6 |  | varchar
Price valid until date | PrisLGiltigDat | ztDate |  |  | datetime
Price valid as of date | PrisLGiltigFromDat | ztDate |  |  | datetime
Price valid as of disp date | PrisLGiltigFromLevDat | ztDate |  |  | datetime
Price valid until disp date | PrisLGiltigTomLevDat | ztDate |  |  | datetime
Price list | PrisLista | ztInteger | 5 |  | smallint
Price calc method, order | PrisVidOrderTyp | ztInteger | 2 |  | smallint
Gross margin | Proc1 | ztFloat | 6 | 2 | float
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Price, curr | vb_pris | ZtSalesPrice | 12 | 2 | money
New price, curr | vb_PrisNytt | ZtSalesPrice | 12 | 2 | money
New price, curr fr date | vb_PrisNyttDatum | ztDate |  |  | datetime
Volume disc %, add | VolymRabAddKod | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: PrlSelV Sales price list details, item groups


Sales price list details, items (prl)

Table of price list details per product.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Recommended price | ArtCirkaPris | ZtSalesPrice | 12 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Calc.ord amount + % | BerOrdnBelAddProc | ztBoolean |  |  | char
Text | edit | ztBlob | 1 |  | varchar
Packaging type | EmballageTyp | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, BCU | FPris | ZtBaseCurrAmount | 14 | 2 | money
Sales price, internal | FPrisInternt | ZtBaseCurrAmount | 14 | 2 | money
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Price 0 applies | KodNollPris | ztBoolean |  |  | char
No customer disc | KundEjRabKod | ztBoolean |  |  | char
Quantity limit >= | LimitLowAnt | ztFloat | 10 | 2 | float
Markup/reduction % | markup | ztFloat | 14 | 4 | float
Price factor amount | MarkUpBelopp | ztMoney | 14 | 2 | money
Discount fr matrix, add | MatrisRabAddKod | ztBoolean |  |  | char
Net, no discount | NettoEjRabKod | ztBoolean |  |  | char
Price factor 0 | NollFaktor | ztBoolean |  |  | char
Disc code order value | OrdvRabKod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price calc basis | PrisBerUnderlag | ZtBaseCurrAmount | 14 | 2 | money
Price valid until date | PrisLGiltigDat | ztDate |  |  | datetime
Price valid as of date | PrisLGiltigFromDat | ztDate |  |  | datetime
Price valid as of disp date | PrisLGiltigFromLevDat | ztDate |  |  | datetime
Price valid until disp date | PrisLGiltigTomLevDat | ztDate |  |  | datetime
Price list | PrisLista | ztInteger | 5 |  | smallint
Sel price list | PrlFtgSpec1 | ztString | 10 |  | varchar
Gross margin | Proc1 | ztFloat | 6 | 2 | float
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Price, curr | vb_pris | ZtSalesPrice | 12 | 2 | money
New price, curr | vb_PrisNytt | ZtSalesPrice | 12 | 2 | money
New price, curr fr date | vb_PrisNyttDatum | ztDate |  |  | datetime
Volume disc %, add | VolymRabAddKod | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: prl Sales price list details

    Program: Prlsel Sales price list details, items


Sales price list header, campaign (view) (vprh)

Data in the price list header.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Campaign start date | KampanjFromDat | ztDate |  |  | datetime
Campaign price list | KampanjPrisLista | ztInteger | 6 |  | smallint
Campaign end date | KampanjTomDat | ztDate |  |  | datetime
Supplementary price list | KomplPrisLista | ztInteger | 6 |  | smallint
Markup/reduction % | markup | ztFloat | 14 | 4 | float
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Price list | PrisListaBeskr | ztString | 30 |  | varchar
Price calculation method | PrisSattnTyp | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal


Sales price list header, campaign (view) (vprs)

Data in the price list header.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Campaign start date | KampanjFromDat | ztDate |  |  | datetime
Campaign price list | KampanjPrisLista | ztInteger | 6 |  | smallint
Campaign end date | KampanjTomDat | ztDate |  |  | datetime
Supplementary price list | KomplPrisLista | ztInteger | 6 |  | smallint
Markup/reduction % | markup | ztFloat | 14 | 4 | float
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Price list | PrisListaBeskr | ztString | 30 |  | varchar
Price calculation method | PrisSattnTyp | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal


Sales price list header, complement (view) (vprk)

Data in the price list header.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Campaign start date | KampanjFromDat | ztDate |  |  | datetime
Campaign price list | KampanjPrisLista | ztInteger | 6 |  | smallint
Campaign end date | KampanjTomDat | ztDate |  |  | datetime
Supplementary price list | KomplPrisLista | ztInteger | 6 |  | smallint
Markup/reduction % | markup | ztFloat | 14 | 4 | float
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Price list | PrisListaBeskr | ztString | 30 |  | varchar
Price calculation method | PrisSattnTyp | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal


Sales price list per customer (kprh)

Table of price lists per customer. An unlimited number of price lists can be entered per customer.

A priority code must be specified for each price list and is then used when price data is retrieved for the customer in the order routine.

The price list specified in the customer table (kus) really has priority 1 because it has priority over the price lists specified in this table. If no price list is specified here for the customer, only price list data on the customer record applies.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Priority code | PrisListaPrior | ztInteger | 3 |  | smallint
Campaign price list | prompricelist | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Valid to date | TomDatum | ztDate |  |  | datetime
Publish on Web | webpublish | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: kprh Sales price list per customer


Sales price list, header (prh)

Definition of price lists per item, service or equivalent in the item table, or per item group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Calc.ord amount + % | BerOrdnBelAddProc | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
No rounding | EjPrisAvrunda | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Campaign start date | KampanjFromDat | ztDate |  |  | datetime
Campaign price list | KampanjPrisLista | ztInteger | 6 |  | smallint
Campaign end date | KampanjTomDat | ztDate |  |  | datetime
Price adjustment (%) | KodPrisJustering | ztBoolean |  |  | char
This field is used in the table as follows: |
Supplementary price list | KomplPrisLista | ztInteger | 6 |  | smallint
No customer disc | KundEjRabKod | ztBoolean |  |  | char
Markup/reduction % | markup | ztFloat | 14 | 4 | float
Price factor amount | MarkUpBelopp | ztMoney | 14 | 2 | money
Discount fr matrix, add | MatrisRabAddKod | ztBoolean |  |  | char
Net, no discount | NettoEjRabKod | ztBoolean |  |  | char
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Prices incl VAT/tax | PrisEnlListaInklMoms | ztBoolean |  |  | char
Price factor table | PrisFaktTabKod | ztString | 6 |  | varchar
Price adjustment fact% | PrisJustFaktor | ztFloat | 14 | 4 | float
Price valid until date | PrislGiltigDat | ztDate |  |  | datetime
Price valid as of date | PrislGiltigFromDat | ztDate |  |  | datetime
Price valid as of disp date | PrisLGiltigFromLevDat | ztDate |  |  | datetime
Price valid until disp date | PrisLGiltigTomLevDat | ztDate |  |  | datetime
Price list | PrisLista | ztInteger | 5 |  | smallint
Price list | PrisListaBeskr | ztString | 30 |  | varchar
Price calculation method | PrisSattnTyp | ztInteger | 2 |  | smallint
Price calc method, order | PrisVidOrderTyp | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Search type, campaign | SokTypKampPrisLista | ztInteger | 1 |  | smallint
Search type, supp price list | SokTypKomplPrisLista | ztInteger | 1 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Volume disc %, add | VolymRabAddKod | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: prh Sales price lists

    Program: prhz Sales price lists

    Program: prlsar Select items for sales price list

    Program: prlsarfr Select items for sales price list


Sales price list, header EDI (eprh)

The table contains the price list headers for the price lists that will be, or are, sent via EDI.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Prev. price list EDI | ForegPrislistaEDI | ztString | 35 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Campaign start date | KampanjFromDat | ztDate |  |  | datetime
Campaign price list | KampanjPrisLista | ztInteger | 6 |  | smallint
Campaign end date | KampanjTomDat | ztDate |  |  | datetime
Price adjustment (%) | KodPrisJustering | ztBoolean |  |  | char
This field is used in the table as follows: |
Supplementary price list | KomplPrisLista | ztInteger | 6 |  | smallint
Discount fr matrix, add | MatrisRabAddKod | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Price valid until date | PrislGiltigDat | ztDate |  |  | datetime
Price valid as of date | PrislGiltigFromDat | ztDate |  |  | datetime
Price list | PrisLista | ztInteger | 5 |  | smallint
Price list | PrisListaBeskr | ztString | 30 |  | varchar
Price list EDI | PrisListaEdi | ztString | 35 |  | varchar
Price list status | PrislisteStatusEdi | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Send EDI | SendEdi | ztBoolean |  |  | char
Sent EDI | SendEdiDT | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal

    This table is the main table in the following programs:

    Program: EdiPris Sales price lists EDI


Sales price list, item details (view) (vprl)

View of price list details per product.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternative unit | AltEnhetKod |  |  |  | @DataType=NULL
Recommended price | ArtCirkaPris |  |  |  | @DataType=NULL
Item no. | ArtNr |  |  |  | @DataType=NULL
Calc.ord amount + % | BerOrdnBelAddProc |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Sales price, BCU | FPris |  |  |  | @DataType=NULL
Price conv factor | FsgArtOmvFaktor |  |  |  | @DataType=NULL
Price unit factor | FsgPrisPer |  |  |  | @DataType=NULL
Company ID | FtgNr |  |  |  | @DataType=NULL
Price 0 applies | KodNollPris |  |  |  | @DataType=NULL
No customer disc | KundEjRabKod |  |  |  | @DataType=NULL
Discount % | KundRabatt |  |  |  | @DataType=NULL
Quantity limit >= | LimitLowAnt |  |  |  | @DataType=NULL
Markup/reduction % | markup |  |  |  | @DataType=NULL
Price factor amount | MarkUpBelopp |  |  |  | @DataType=NULL
Discount fr matrix, add | MatrisRabAddKod |  |  |  | @DataType=NULL
Net, no discount | NettoEjRabKod |  |  |  | @DataType=NULL
Price factor 0 | NollFaktor |  |  |  | @DataType=NULL
Quote/agreement no. | OffNr |  |  |  | @DataType=NULL
Disc code order value | OrdvRabKod |  |  |  | @DataType=NULL
Price calc method, pkg | OrpStrPrisBer |  |  |  | @DataType=NULL
Package item | PaketArtikel |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Price calc basis | PrisBerUnderlag |  |  |  | @DataType=NULL
Price valid until date | PrisLGiltigDat |  |  |  | @DataType=NULL
Price valid as of date | PrisLGiltigFromDat |  |  |  | @DataType=NULL
Price list | PrisLista |  |  |  | @DataType=NULL
Price list | PrisListaBeskr |  |  |  | @DataType=NULL
Sel price list | PrlFtgSpec1 |  |  |  | @DataType=NULL
Gross margin | Proc1 |  |  |  | @DataType=NULL
Discount 1 % | Rabatt1 |  |  |  | @DataType=NULL
Discount 2 % | Rabatt2 |  |  |  | @DataType=NULL
Discount 3 % | Rabatt3 |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL
Currency | ValKod |  |  |  | @DataType=NULL
Exchange rate | ValKurs |  |  |  | @DataType=NULL
Item group | VaruGruppKod |  |  |  | @DataType=NULL
Price, curr | vb_pris |  |  |  | @DataType=NULL
New price, curr | vb_PrisNytt |  |  |  | @DataType=NULL
New price, curr fr date | vb_PrisNyttDatum |  |  |  | @DataType=NULL
Volume disc %, add | VolymRabAddKod |  |  |  | @DataType=NULL

    This table is the main table in the following programs:

    Program: VPrlsel Sales price list/selected details


Sales price list, item details EDI (eprl)

Table of price list details per product.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Recommended price | ArtCirkaPris | ZtSalesPrice | 12 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Text | edit | ztBlob | 1 |  | varchar
Packaging type | EmballageTyp | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, BCU | FPris | ZtBaseCurrAmount | 14 | 2 | money
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Price 0 applies | KodNollPris | ztBoolean |  |  | char
Quantity limit >= | LimitLowAnt | ztFloat | 10 | 2 | float
Quantity limit <= | LimitMaxAnt | ztFloat | 10 | 2 | float
Discount fr matrix, add | MatrisRabAddKod | ztBoolean |  |  | char
Net, no discount | NettoEjRabKod | ztBoolean |  |  | char
Price factor 0 | NollFaktor | ztBoolean |  |  | char
Disc code order value | OrdvRabKod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Step code | PrisAtgard | ztString | 3 |  | varchar
Price valid until date | PrisLGiltigDat | ztDate |  |  | datetime
Price valid as of date | PrisLGiltigFromDat | ztDate |  |  | datetime
Price list | PrisLista | ztInteger | 5 |  | smallint
Price list EDI | PrislistaEDI | ztString | 35 |  | varchar
Sel price list | PrlFtgSpec1 | ztString | 10 |  | varchar
Gross margin | Proc1 | ztFloat | 6 | 2 | float
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Price, curr | vb_pris | ZtSalesPrice | 12 | 2 | money
Volume disc %, add | VolymRabAddKod | ztBoolean |  |  | char


Sales teams (saljteam)

Definition of sales teams. The salespersons to be included in the sales team is specified in the Salespersons program.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sales team | saljteambeskr | ztString | 80 |  | varchar
Sales team | saljteamkod | ztString | 8 |  | varchar
Team manager | teamchef | ztString | 1 |  | varchar

    This table is the main table in the following programs:

    Program: xsteam Sales teams


Sales types (xsal)

Definition of occurring sales types to be able to internally divide orders e.g. New sales, Additional sales, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sales type | SalesType | ztString | 3 |  | varchar
Sales type | SalesTypeDescr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: xsal Sales types


Salespersons (salj)

Definition of own company's Salespersons, with posting information if applicable. The internal accounts segment 2 and 3 (cost centre and cost unit) can be retrieved from the Salesperson.

In the underlying nodes you can also see orders entered for the relevant Salesperson and you can specify information for the EPOS system.

There are also fields for linking Salespersons to a sales team and manager, information which is used in the marketing module.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Product acct | ArtProdKonto | ztString | 8 |  | varchar
This field is used in the table as follows: |
Posting template, advance | AutoRegelForskott | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Forecast group, sales | FsgPrgGrp | ztString | 8 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
OrderSpec S4 (rcv cost centre) | K4OuLager | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
OS-S5 (rcv deliveries) | K5OuLager | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
OrderSpec S6 (rcv deliveries) | K6OuLager | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
OrderSpec S7 (rcv deliveries) | K7OuLager | ztString | 8 |  | varchar
Sent from dept/S3 | KBarAvsandandeEnhet | ztString | 8 |  | varchar
CO specific CC (rec) | KBarOuLager | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Cost centre (elim) | KostStalleKodEliminera | ztString | 8 |  | varchar
CC dispatched unit | KstAvsandandeEnhet | ztString | 8 |  | varchar
Orderspec rcv CC | KstOULager | ztString | 8 |  | varchar
WIP CC | KstPIA | ztString | 8 |  | varchar
CC manufacturing diff | KstTillvDiff | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Orderspec rcv account | KtoNrOULager | ztString | 8 |  | varchar
WIP account | KtoNrPIA | ztString | 8 |  | varchar
Acct manufacturing diff | KtoNrTillvDiff | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Salesperson, dummy code | SaljareDummyKod | ztBoolean |  |  | char
Salesperson name | SaljareNamn | ztString | 40 |  | varchar
Sales manager | saljchef | ztBoolean |  |  | char
Sales team | saljteamkod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: xSalj Salespersons


Saved dynamic reports (JvsSiteDynReports)

Program/table for viewing settings regarding saved dynamic reports.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | DivBeskr | ztString | 30 |  | nvarchar
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIdentity | ZtLong | 10 |  | int
Window context (site rep) | wctxt | ztString | 40 |  | nvarchar

    This table is the main table in the following programs:

    Program: JvsSiteDynReports Saved dynamic reports (old)


Saved search filters (cnd)

Search filters for any of the options under ‘Find’ on the menu bar are saved here.

Choose from personal/global: Yes
Per company: No

(This table replaces table Vcnd.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Terms | Cond |  |  |  | @DataType=NULL
Group | Grupp |  |  |  | @DataType=NULL
Name | Name |  |  |  | @DataType=NULL
Program node | Node |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Program | Pgm |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL

    This table is the main table in the following programs:

    Program: cnd Saved search filters


Scheduler job details (bsched_jvs_job_details)

Table containing job details for batch scheduler.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Is durable | bsched_is_durable | ztBoolean |  |  | char
Is stateful | bsched_is_stateful | ztBoolean |  |  | char
Is volatile | bsched_is_volatile | ztBoolean |  |  | char
Job data | bsched_job_data | ztBlob | 1 |  | varchar
Description | bsched_job_description | ztString | 120 |  | varchar
Job group | bsched_job_group | ztString | 80 |  | varchar
Job name | bsched_job_name | ztString | 80 |  | varchar
Job type | bsched_job_type | ztString | 50 |  | varchar
Job type ID | bsched_job_type_key | ztInteger | 2 |  | smallint
Request recovery | bsched_request_recovery | ztBoolean |  |  | char
Scheduler version | bsched_version | ztString | 10 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Path | Path | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Report parameters | ReportParam | ztString | 255 |  | varchar
Report | ReportProgram | ztString | 255 |  | varchar
Report template | ReportTemplate | ztString | 255 |  | varchar
Where condition | ReportWhere | ztString | 255 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: bsched_jvs_job_details Scheduler job details


Scheduler job states (bsched_job_state)

Batch job state.

The following standard records exist. Do not alter/delete:

Job state (bsched_job_state) | Job state description (bsched_job_state_descr) | Description
0 | 0: Inactive | The initial state of a job in the job scheduler. Jobs should remain inactive until definition or redefinition is complete.
1 | 1: Scheduling | When the job definition or redefinition is complete, i.e. ready to be fed to the job scheduler, change its status to Scheduling.
2 | 2: Scheduled | The job scheduler has a sleep interval so it may take a moment before a job is scheduled. When the job has been successfully scheduled its status is automatically changed to Scheduled.
3 | 3: Rescheduling | You can change the schedule of a scheduled job by unscheduling it, clearing the current trigger name, right-clicking and selecting a new trigger (make sure to set a valid start date and time etc.), transferring it back to the job definition and changing its status to Rescheduling. If the rescheduling is successful, the job's status is set back to Scheduled. The trigger group on the job definition is updated as well as the fields for previous trigger group and name.
4 | 4: Unscheduling | If you need to redefine or reschedule a scheduled job you must first unschedule it by manually changing its status from Scheduled to Unscheduling. After a moment its status is automatically set to Inactive, after which you can change the job and/or trigger definition.
5 | 5: Finishing | When job execution is complete according to its current trigger, the job's status is automatically set to Finishing then Finished. You can manually change the status to Inactive if you want to prolong the execution of a job.
6 | 6: Finished | When job execution is complete according to its current trigger, the job's status is automatically set to Finishing then Finished.
-1 | -1: Error | If a job can not be executed, for example due to incorrect definition or due to the scheduler or another required application not being installed or running, its status is automatically set to Error. You can manually change it to Inactive in order to correct the problem before re-attempting to schedule the job.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Job state | bsched_job_state | ztInteger | 5 |  | smallint
Job state description | bsched_job_state_descr | ztString | 80 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: bsched_job_state Scheduler job states


Scheduler job types (bsched_job_type)

Schedular job types.

The following standard records exist. Do not alter/delete:

Job type ID (bsched_job_type_key) | Job type (bsched_job_type) | Description
0 | JvsProgramJob | Job type in Job scheduler to run a normal Jeeves program, i.e. not a report program. This job type is not implemented in the first version of Job scheduler.
1 | JvsReportJob | Job type in Job scheduler to run a Jeeves report program.
2 | ExeProgramJob | Job type in Job scheduler to run any exe-program.
3 | SqlScriptJob | Job type in Job scheduler to execute an SQL script.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Job type | bsched_job_type | ztString | 50 |  | varchar
Job type ID | bsched_job_type_key | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: bsched_job_type Scheduler job types


Scheduler jobs (bsched_jvs_jobs)

Table containing jobs entered to be processed by the batch scheduler.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Job group | bsched_job_group | ztString | 80 |  | varchar
Job name | bsched_job_name | ztString | 80 |  | varchar
Job state | bsched_job_state | ztInteger | 5 |  | smallint
Trigger group | bsched_trigger_group | ztString | 80 |  | varchar
Trigger group, previous | bsched_trigger_group_original | ztString | 80 |  | varchar
Trigger name | bsched_trigger_name | ztString | 80 |  | varchar
Trigger name, previous | bsched_trigger_name_original | ztString | 80 |  | varchar
Trigger type | bsched_trigger_type | ztString | 40 |  | varchar
Scheduler version | bsched_version | ztString | 10 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: bsched_jvs_jobs Scheduler jobs


Scheduler log (bsched_jvs_job_log)

Log for bsheduler.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Job data | bsched_job_data | ztBlob | 1 |  | varchar
Job group | bsched_job_group | ztString | 80 |  | varchar
Job name | bsched_job_name | ztString | 80 |  | varchar
Misfire descr | bsched_misfire_descr | ztString | 80 |  | varchar
Misfire instruction | bsched_missfire_instr | ztInteger | 5 |  | smallint
Start time | bsched_start_time | ztString | 21 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Success | Jobexec | ztBoolean |  |  | char
Sequence no. | LopNr | ZtLong | 10 |  | int
Message info | MessageInfo | ztBlob | 1 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: bsched_jvs_job_log Scheduler log


Scheduler misfire instructions (bsched_misfire)

Misfire instructions

The following standard records exist. Do not alter/delete:

Misfire instruction (bsched_missfire_instr) | Misfire descr (bsched_misfire_descr) | Description
0 | 0:TRIGGER_MISFIRE_INSTRUCTION_SMART_POLICY | Instructs the scheduler that upon a mis-fire situation, when the scheduler is restarted, the updateAfterMisfire() method will be called on the Trigger to determine the mis-fire instruction.
1 | 1:SIMPLE_MISFIRE_INSTRUCTION_FIRE_NOW | Instructs the scheduler that upon a mis-fire situation, when the scheduler is restarted, the Simple trigger wants to be fired now by the scheduler and execute the remaining jobs. Any jobs that should have been executed while the scheduler was down are skipped.
2 | 2:SIMPLE_MISFIRE_INSTRUCTION_RESCHEDULE_NOW_WITH_EXISTING_REPEAT_COUNT | Instructs the scheduler that upon a mis-fire situation, when the scheduler is restarted, the Simple trigger wants to be re-scheduled to 'now' and execute all jobs according to the repeat count. If 'now' is after the end-time the trigger will not fire again.
3 | 3:SIMPLE_MISFIRE_INSTRUCTION_RESCHEDULE_NOW_WITH_REMAINING_REPEAT_COUNT | Instructs the scheduler that upon a mis-fire situation, when the scheduler is restarted, the Simple trigger wants to be re-scheduled to 'now' and execute the remaining jobs. Any jobs that should have been executed while the scheduler was down are skipped. If 'now' is after the end-time the trigger will not fire again.
4 | 4:SIMPLE_MISFIRE_INSTRUCTION_RESCHEDULE_NEXT_WITH_REMAINING_COUNT | Instructs the scheduler that upon a mis-fire situation, when the scheduler is restarted, the Simple trigger wants to be re-scheduled to the next scheduled time after 'now'. Any jobs that should have been executed while the scheduler was down are skipped.
5 | 5:SIMPLE_MISFIRE_INSTRUCTION_RESCHEDULE_NEXT_WITH_EXISTING_COUNT | Instructs the scheduler that upon a mis-fire situation, when the scheduler is restarted, the Simple trigger wants to be re-scheduled to the next scheduled time after 'now' and execute all jobs according to the repeat count.
6 | 1:CRON_MISFIRE_INSTRUCTION_FIRE_ONCE_NOW | Instructs the scheduler that upon a mis-fire situation, when the scheduler is restarted, the Cron trigger wants to be fired now by the scheduler.
7 | 2:CRON_MISFIRE_INSTRUCTION_DO_NOTHING | Instructs the scheduler that upon a mis-fire situation, when the scheduler is restarted, the Cron trigger wants to have its next-fire-time updated to the next time in the schedule after the current time, but it does not want to be fired now.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Misfire descr | bsched_misfire_descr | ztString | 80 |  | varchar
Misfire instruction | bsched_missfire_instr | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: bsched_misfire Scheduler misfire instructions


Scheduler properties (bsched_jvs_properties)

Properties scheduler. Only on record for each Database.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Scheduler sleep interval | jobmonitor_sleep | ZtLong | 9 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Scheduler sleep | scheduler_sleep | ZtLong | 8 |  | int
Scheduler state | scheduler_state | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: bsched_jvs_properties System data, job scheduler


Scheduler states (bsched_sched_state)

Schedular state.

The following standard records exist. Do not alter/delete:

Scheduler state (scheduler_state) | State description (schedular_state_desc) | Description
1 | Started | When you have started the Job scheduler service the scheduler's status is automatically set to Started in Jeeves.
2 | Standing by | You can set the job scheduler service in Stand by mode from Jeeves, if required, by manually changing the status from Started to Standing by.
3 | Standby | The job scheduler displays this state in Jeeves when set in Stand by mode. This means Quartz' motor is shut down and that any new scheduling information detected during this time will not be fed into Quartz' table. The job scheduler service continues to check for any changes in status in the database. If, for any reason, you want to shut down all activity you will need to shut down the background service too.
4 | Starting | The job scheduler displays this state in Jeeves when in the process of starting. You can not start the job scheduler service from Jeeves. It must be started by running the exe file.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
State description | schedular_state_desc | ztString | 80 |  | varchar
Scheduler state | scheduler_state | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: bsched_sched_state Scheduler states


Scheduler trigger types (bsched_trigger_type)

Trigger types in schedular.
Only 2 types.
SimpleTrigger CronTrigger

The following standard records exist. Do not alter/delete:

Trigger type (bsched_trigger_type) | Trigger type descr (bsched_trigger_type_desc) | Description
CronTrigger | Cron trigger | Job scheduler trigger type. CronTriggers are used for jobs that should recur at irregular or more complexely defined time intervals. When this trigger type is selected the form is expanded with fields for entering the cron expressions for the trigger. For detailed information about cron expressions please refer to Quartz' documentation (e.g. through www.opensymphony.com/quartz).
SimpleTrigger | Simple trigger | Job scheduler trigger type. Simple triggers are used for jobs that should recur at regular time intervals expressed in milliseconds, a given number of times or within a given date and time interval.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Layer | bsched_layer | ztInteger | 5 |  | smallint
Trigger type | bsched_trigger_type | ztString | 40 |  | varchar
Trigger type descr | bsched_trigger_type_desc | ztString | 80 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: bsched_trigger_type Scheduler trigger types


Scheduler triggers (bsched_jvs_triggers)

Definition of applicable Job scheduler triggers, i.e. intervals of recurrence for scheduled jobs, as well as which misfire instruction is to be used for each trigger. The form adapts to the selected type of trigger.

Note that if you define a job via the Print settings dialogue, basic information for a simple trigger is automatically entered. For these jobs you only need to add data in the repeat, start and, if applicable, end data fields in the trigger definition, or alternatively choose another trigger.

Also note that you can only redefine or delete a trigger if it is not connected to a job or only connected to inactive jobs.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Cron expression | bsched_cron_expression | ztString | 80 |  | varchar
Day of Month | bsched_DayOfM | ztString | 10 |  | varchar
Day in week (1=Sun) | bsched_DayOfW | ztString | 10 |  | varchar
End time | bsched_end_time | ztString | 21 |  | varchar
Hours | Bsched_Hours | ztString | 10 |  | varchar
Minutes | bsched_Minutes | ztString | 10 |  | varchar
Misfire instruction | bsched_missfire_instr | ztInteger | 5 |  | smallint
Month | bsched_Month | ztString | 10 |  | varchar
Priority | bsched_priority | ztInteger | 5 |  | smallint
Rept count, NULL=indef | bsched_repeat_count | ZtHugeInt | 20 |  | bigint
Repeat interval ms | bsched_repeat_interval | ZtHugeInt | 20 |  | bigint
Seconds | bsched_Seconds | ztString | 10 |  | varchar
Start time | bsched_start_time | ztString | 21 |  | varchar
Time zone ID | bsched_time_zone_id | ztString | 80 |  | varchar
Description | bsched_trigger_description | ztString | 120 |  | varchar
Trigger group | bsched_trigger_group | ztString | 80 |  | varchar
Trigger name | bsched_trigger_name | ztString | 80 |  | varchar
Trigger type | bsched_trigger_type | ztString | 40 |  | varchar
Year | bsched_Year | ztString | 10 |  | varchar
End date | EventEndDat | ztDate |  |  | datetime
End time | EventEndTime | ztTime | 5 |  | datetime
Start date | EventStartDat | ztDate |  |  | datetime
Start time | EventStartTime | ztTime | 5 |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: bsched_jvs_triggers Scheduler triggers


Schedules for EDI traffic (edik)

Contains the different schedules used for EDI traffic. A schedule can be linked to a method of communication or a partner profile.

Linking a schedule to a method of communication means that the command sequence linked to the method of communication will be run according to the schedule.

Linking a schedule to a partner profile means that a record is created in the EDI messages table (edih). This message is in turn placed in the outbox for EDI messages. The command sequences, linked to the partner profile in the form of message type and method of communication, are run. If the Grouped field is checked, a record is only created in EDI messages (edih) if there are unsent items in the outbox for that particular partner profile.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Schedule | EdiSched | ztInteger | 5 |  | smallint
SchName | EdiSchedDescr | ztString | 30 |  | varchar
Friday | EdiSchedFri | ztBoolean |  |  | char
Interval (min) | EdiSchedInterval | ztInteger | 5 |  | smallint
Monday | EdiSchedMon | ztBoolean |  |  | char
Saturday | EdiSchedSat | ztBoolean |  |  | char
Starting time | EdiSchedStart | ztTime | 5 |  | datetime
Ending time | EdiSchedStop | ztTime | 5 |  | datetime
Sunday | EdiSchedSun | ztBoolean |  |  | char
Thursday | EdiSchedThu | ztBoolean |  |  | char
Tuesday | EdiSchedTue | ztBoolean |  |  | char
Wednesday | EdiSchedWed | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: edik Schedules for EDI traffic


Scrap reasons (aok)

Table of scrap reasons for labour operations. The scrap quantity and reason can be entered when reporting labour operations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
Return/scrap reason | KassOrsaksKodBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: aok Scrap reasons, labour operations


Scrap reasons (tiik)

Scrap reasons.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
Return/scrap reason | KassOrsaksKodBeskr | ztString | 50 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Tiik Scrap reasons, material


Scrap reasons, material (mruk)

Scrap reasons for material issue.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
Return/scrap reason | KassOrsaksKodBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: mruk Scrap reasons


Season definition (PVMSeason)

Definition of season. A season is used to specify that an item only can be sold or purchased during an limited time.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Season | PVMSeasonDescr | ztString | 50 |  | varchar
Season | PVMSeasonId | ztString | 15 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PVMSeason Seasons


Seasons for items (PvmSeasonAr)

Table for seasons connected to items.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Season | PVMSeasonId | ztString | 15 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Section types (sht4)

Definition of IRIS faulty parts codes. This is used when reporting against service orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Section IRIS | Section | ztString | 30 |  | varchar
Section IRIS | SectionCode | ztString | 3 |  | varchar

    This table is the main table in the following programs:

    Program: sht4 Section codes IRIS


Sectors (xbr)

Definition of industries or equivalent, as per internal need for grouping/searching of companies in the company table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
SIC code | Branschbeskr | ztString | 50 |  | varchar
SIC code | Branschkod | ztString | 15 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: pXBR Sectors


Sectors (xhv)

Table containing the company sectors, used for planning and reporting time. Pricing and posting can also be based on the type of sector.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sector | verksamhet | ztInteger | 5 |  | smallint
Sector | verksbeskr | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: xhv Sectors


Sectors (frb)

Table of branches to which you can tie the company in the company file.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
SIC code | Branschkod | ztString | 15 |  | varchar
Industry solution | branschlosning | ztBoolean |  |  | char
Message | budskap | ztBlob | 1 |  | varchar
Text | edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Customers | kunder | ztBlob | 1 |  | varchar
Partner | partner | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sales argument | usp | ztBlob | 1 |  | varchar


Sectors, language (xhvs)

Language translations of descriptions of activities.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | Sprakkod | ztInteger | 3 |  | smallint
Sector | verksamhet | ztInteger | 5 |  | smallint
Sector | verksbeskr | ztString | 30 |  | varchar


Security manager, dimensions (sec_dimension)

Dimension Id from table sec_dimension in security management module.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company code | ForetagKodAll | ztInteger | 5 |  | smallint
Company group No. | JvsSiteCmpGroup | ztInteger | 4 |  | smallint
Group ID | JvsSiteGroupId | ZtLong | 6 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Dimension Id | SecDimId | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: sec_dimension Security manager, dimensions


Security manager, permissions (sec_permission)

Each time a permission setting is saved in the Security manager a record is saved here. If a setting is deleted, the record here is deleted.

The program/table may be of use for searching/troubleshooting permission settings.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Deny permission | SecDenyPerm | ztInteger | 4 |  | smallint
Dimension Id | SecDimId | ZtLong | 10 |  | int
Grant permission | SecGrantPerm | ztInteger | 4 |  | smallint
Id1 | SecId1 | ztString | 255 |  | varchar
Id2 | SecId2 | ztString | 255 |  | varchar
Id3 | SecId3 | ztString | 255 |  | varchar
Id4 | SecId4 | ztString | 255 |  | varchar
Id5 | SecId5 | ztString | 255 |  | varchar
Inherited | SecInherited | ztBoolean |  |  | char
Tree Id | SecTreeId | ZtLong | 10 |  | int
Type | SecType | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: sec_permission Security manager, permissions


Security manager, tree (sec_tree)

Each time an object is added to the tree structure in the Security manager a record is saved here. If an object is deleted, the record here is deleted.

The program/table may be of use for searching/troubleshooting permission settings.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Data | SecData | ztString | 255 |  | nvarchar
Description | SecDescription | ztString | 255 |  | nvarchar
Expanded | SecExpanded | ztBoolean |  |  | char
Name | SecName | ztString | 255 |  | nvarchar
Parent Id | SecParentId | ZtLong | 10 |  | int
Tree Id | SecTreeId | ZtLong | 10 |  | int
Type | SecType | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: sec_tree Security manager, tree


Security type (sec_type)

Security management type.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Type | SecType | ztInteger | 4 |  | smallint
Type Description | SecTypeDescription | ztString | 255 |  | nvarchar


Segment 2, PO (bekt)

The cost centres that can be entered manually on purchase orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
As of date | DatKstFom | ztDate |  |  | datetime
End date | DatKstTom | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Cost centre | KstBeskr | ztString | 25 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: bekt Segment 2 on purchase order


Segment 3 on purchase order (bekb)

The account segments 3 that can be entered manually on purchase orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
As of date | DatKBarFom | ztDate |  |  | datetime
End date | DatKBarTom | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost unit | KostBar | ztString | 8 |  | varchar
Cost unit | KostBarBeskr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: bekb Segment 3 on purchase order


Segment 4, PO (bek4)

The account segments 4 that can be entered manually on purchase orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S4 | K4Beskr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: bek4 Segment 4 on purchase order


Segmenting 1 (konks1)

Segmenting of competition.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Segmenting 1 ID | ksegment1 | ztInteger | 5 |  | smallint
Segmenting 1 | ksegment1beskr | ztString | 80 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: konks1 Segmenting category 1


Segmenting 2 (konks2)

Table of segmenting categories for competitors.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Segmenting 2 ID | ksegment2 | ztInteger | 5 |  | smallint
Segmenting 2 | ksegment2beskr | ztString | 80 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: konks2 Segmenting category 2


Selected calculation components (ohcs)

This table contains calculation components to be included in certain overhead expense.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Calculation markup code | ArkPalKod | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calculation component | KalkylKompTyp | ztInteger | 2 |  | smallint
OH cost type | OhKostTyp | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Selection in reports (JvsSiteRepWhere)

Program/table for viewing and editing settings regarding selections in reports.

Selection is specified per report program and main table.

The terms found in print templates (frames and windows) do not correspond to retrieval of data from the database and therefore these cannot be used. However, there are "nodes" in the reports and there is a main table in every such node.

Example:

Order acknowledgement has a node for order headers where the main table is the order header table (oh) and another for the order rows where the main table is the order row table (orp).

By specifying a selection on the order header table, the order acknowledgement is printed in the customized selection.

By specifying a selection on the order row table, the order rows within an order acknowledgement are printed according to the customized selection.

The selection setting can be applied globally for all users (group 9999 and user *), applied to an individual group (specified group and user *) or applied to an individual user (specified signature and group 9999).

You can link the custom defined selection to a specific print template and in this way get different selections depending on which template is used.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Group | JvsSiteForGrp | ZtLong | 6 |  | int
Signature | JvsSiteForUser | ztString | 6 |  | nvarchar
Settings for report | JvsSiteReportName | ztString | 40 |  | nvarchar
Report template | JvsSiteReportTemplate | ztString | 60 |  | nvarchar
Table | JvsSiteTableName | ztString | 40 |  | nvarchar
Settings, where | JvsSiteWhereStmt | ztString | 255 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteRepWhere Selection in reports


Selection types (xrc)

Typ av selektering för rapporter t ex Intervall, och Wildcard.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Layer | SelLayer | ztInteger | 2 |  | smallint
Selekteringstypbeskr | VardSelBeskr | ztString | 30 |  | varchar
Selekterigstyp | VardSeltyp | ztInteger | 2 |  | smallint


Seller (view) (vsalj)

View against the seller table. Used to specify assistant or in-house sales agents on the company level.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Product acct | ArtProdKonto | ztString | 8 |  | varchar
This field is used in the table as follows: |
Posting template, advance | AutoRegelForskott | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Forecast group, sales | FsgPrgGrp | ztString | 8 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
OrderSpec S4 (rcv cost centre) | K4OuLager | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
OS-S5 (rcv deliveries) | K5OuLager | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
OrderSpec S6 (rcv deliveries) | K6OuLager | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
OrderSpec S7 (rcv deliveries) | K7OuLager | ztString | 8 |  | varchar
Sent from dept/S3 | KBarAvsandandeEnhet | ztString | 8 |  | varchar
CO specific CC (rec) | KBarOuLager | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
CC dispatched unit | KstAvsandandeEnhet | ztString | 8 |  | varchar
Orderspec rcv CC | KstOULager | ztString | 8 |  | varchar
WIP CC | KstPIA | ztString | 8 |  | varchar
CC manufacturing diff | KstTillvDiff | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Orderspec rcv account | KtoNrOULager | ztString | 8 |  | varchar
WIP account | KtoNrPIA | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Salesperson, dummy code | SaljareDummyKod | ztBoolean |  |  | char
Salesperson name | SaljareNamn | ztString | 40 |  | varchar
Sales manager | saljchef | ztBoolean |  |  | char
Sales team | saljteamkod | ztString | 8 |  | varchar


Seller log (sall)

Our sellers.
This table contains a log of all changes made to the seller table.
User-added fields are however not logged.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Product acct | ArtProdKonto | ztString | 8 |  | varchar
This field is used in the table as follows: |
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Orderspec rcv CC | KstOULager | ztString | 8 |  | varchar
WIP CC | KstPIA | ztString | 8 |  | varchar
CC manufacturing diff | KstTillvDiff | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Orderspec rcv account | KtoNrOULager | ztString | 8 |  | varchar
WIP account | KtoNrPIA | ztString | 8 |  | varchar
Acct manufacturing diff | KtoNrTillvDiff | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Salesperson name | SaljareNamn | ztString | 40 |  | varchar
Date/time | StrDateTime | ztString | 28 |  | varchar

    This table is the main table in the following programs:

    Program: xSall Seller log


Seller receipt, customer order (x3sk)

Table defining the seller's personal receipt code which s/he MUST enter when closing an order and how many attempts the seller can make to enter the correct code before the receipt block is set.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Receipt blocked | KvittensSparrKod | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Receipt code, attempt | SaljKvittensAntForsok | ztInteger | 5 |  | smallint
Receipt code, order | SaljKvittensKod | ztString | 20 |  | varchar


Sellers per group signature (x3gs)

Table with definitions of which group signature(s) a seller can belong to. Used for logging into the client with a group signature to give access during order processing to only one seller who belongs to the relevant group signature.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Group signature | GruppPersSign | ztString | 6 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Our reference on order | OurRefOnOrder | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar

    This table is the main table in the following programs:

    Program: x3gs Sellers per group signature


Sellers per order (ohs)

A table of which salespersons share an order.
This is defined for the entire order and applies for all order rows.
This table is not actively used in Jeeves, but it can be used to produce reports or to create or your own statistic tables.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allocation percent | FordProc | ZtDecimal73 | 6 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar

    This table is the main table in the following programs:

    Program: ohs Sellers per order


Serial no. items (ari)

Table for details about serial no. items. For further information see the program help.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Component item no. | ArtNrSerieIng | ztString | 30 |  | varchar
Component serial no. | ArtSerieing | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Serial no. item status | ArtSerst | ztInteger | 5 |  | smallint
Batch no. | BatchId | ztString | 30 |  | varchar
Description | Beskrivning | ztString | 50 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
Condition code (IRIS) | ConditionCode | ztString | 3 |  | varchar
Charge | debkod | ztInteger | 1 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Transaction date | EventDat | ztDate |  |  | datetime
Time | EventTime | ztTime | 4 |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Guarantee to | garanti | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Property | Indkod | ztInteger | 3 |  | smallint
Own specification 1 | Indstr1 | ztString | 200 |  | varchar
Own specification 2 | Indstr2 | ztString | 200 |  | varchar
Own specification 3 | Indstr3 | ztString | 200 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Customer reference | KundRef2 | ztString | 30 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Meter reading | Matarstallning | ZtLong | 10 |  | int
Last meter reading | matdat | ztDate |  |  | datetime
Service planned up to | NextServiceDate | ztDate |  |  | datetime
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Delivery addr, company | OrdLevAdr1 | ztString | 36 |  | varchar
Delivery address 1 | OrdLevAdr2 | ztString | 36 |  | varchar
Delivery address 2 | OrdLevAdr3 | ztString | 36 |  | varchar
Delivery address 3 | OrdLevAdr4 | ztString | 36 |  | varchar
Destination, district | OrdLevAdrBstOrt | ztString | 36 |  | varchar
Destination, country | OrdLevAdrLandsKod | ztString | 3 |  | varchar
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Point of delivery, co. ID | ordlevplats1 | ztCompanyNo | 20 |  | varchar
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Project manager | perssign1 | ztString | 6 |  | varchar
Employee ID | perssign2 | ztString | 6 |  | varchar
Project ID | projcode | ztString | 10 |  | varchar
Entry date | regdat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Service flow | ServFlow | ZtLong | 10 |  | int
Service code -3 | ServKod3 | ztInteger | 3 |  | smallint
Service interval, months | ServNoMonth | ztInteger | 5 |  | smallint
Service interval, weeks | ServNoWeeks | ztInteger | 5 |  | smallint
Source | Source | ztString | 6 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: ari Serial no. items


Serial no. items/agreement (view) (vshtaari)

View of entered serial no. items linked to service agreements.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Assignment in Agreement | AgrNoInclude | ztString | 10 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Customer | KundNr | ztCompanyNo | 20 |  | varchar
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Server paths (sPth)

Table showing which server path can be used by the macro commands FileStreamToClient and FileStreamToServer.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Path | path | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Signature | Perssign5 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: sPth Applicable server paths


Service codes 2 (xya)

Definition of service codes (2 of 3) as required which will be specified during service order reporting.

Example
-------------
Service code 1: Service type; Workshop/field service, and so on
Service code 2: Service level; Within x hours, No agreement and so on
Service code 3: Item/spare part type; Stocked item/purchase order item, Original spare part/normal, and so on

Every service order can be divided into three different service codes. The information can then be used when searching for service orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Service code -2 | servkod2 | ztInteger | 3 |  | smallint
Service code -2 | servkodB2 | ztString | 30 |  | varchar
TextID | TextID | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: xya Service code 2


Service codes 3 (xyb)

Definition of service codes (3 of 3) as required which will be specified during service order reporting.

Example
-------------
Service code 1: Service type; Workshop/field service, and so on
Service code 2: Service level; Within x hours, No agreement and so on
Service code 3: Item/spare part type; Stocked item/purchase order item, Original spare part/normal, and so on

Every service order can be divided into three different service codes. The information can then be used when searching for service orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Service code -3 | servkod3 | ztInteger | 3 |  | smallint
Service code -3 | servkodB3 | ztString | 30 |  | varchar
TextID | TextID | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: xyb Service code 3


Service codes-1 (xy8)

Definition of service codes (1 of 3) as required which will be specified during service order reporting.

Example
-------------
Service code 1: Service type; Workshop/field service, and so on
Service code 2: Service level; Within x hours, No agreement and so on
Service code 3: Item/spare part type; Stocked item/purchase order item, Original spare part/normal, and so on

Every service order can be divided into three different service codes. The information can then be used when searching for service orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Service code -1 | servkod1 | ztInteger | 3 |  | smallint
Service code -1 | servkodB1 | ztString | 50 |  | varchar
TextID | TextID | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: xy8 Service code 1


Service flow details (sfld)

Measures in a standard service flow.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Subproj closed | Aktavsl | ztBoolean |  |  | char
Quantity | antal | ZtQty | 14 | 2 | decimal
Incl. item no. | ArtMed | ztBoolean |  |  | char
Item no. | Artnr | ztString | 30 |  | varchar
Charge | debkod | ztInteger | 1 |  | smallint
Planned activity | EventKod1 | ztInteger | 3 |  | smallint
Reported activity | EventRpKod | ztInteger | 3 |  | smallint
Hours | EventTimant2 | ztHourWithDecimals | 8 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Est time in hours | PBeranttim | ztFloat | 10 | 2 | float
Signature | perssign | ztString | 30 |  | varchar
Project manager | Perssign1 | ztString | 6 |  | varchar
Employee ID | Perssign2 | ztString | 6 |  | varchar
Activity finished | Planutford | ztBoolean |  |  | char
Price | pris | ZtBaseCurrAmount | 14 | 2 | money
Entry date | regdat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence | sequence | ztInteger | 3 |  | smallint
Service flow | ServFlow | ZtLong | 10 |  | int
Status code, Service | servstatus | ztInteger | 2 |  | smallint
Step | Step | ztInteger | 3 |  | smallint
Sector | verksamhet | ztInteger | 5 |  | smallint


Service flows (sflw)

Definition of service flows, templates for what is normally included in different types of service works. These can be used upon arrival entry of a service order to speed up the entry of corresponding service order rows.

In the service flow, you can also add default values for price, technician, sector, etc., which are suggested on the service order row but which you can change. The defaults you enter in the service flow have a higher priority than corresponding assignments that are entered during service order header entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | perssign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Service flow | ServFlow | ZtLong | 10 |  | int
Service flow descr | ServFlowb | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: sflw Service flows


Service item rows (shor)

Rows in service item price lists. In this table, you can store prices per service item and reparation type.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Reparation type | RepNr | ztInteger | 3 |  | smallint
Repair price | RepPris | ZtBaseCurrAmount | 14 | 2 | money
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Price, curr | Vb_Pris | ZtSalesPrice | 12 | 2 | money


Service items (shro)

Definition of service items that can be included in service orders. The service items must exist in the item table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight price | FraktPris | ZtBaseCurrAmount | 14 | 2 | money
Guarantee time supplier | GarantiLev | ztInteger | 2 |  | smallint
Guarantor | GarantiLevNr | ztCompanyNo | 10 |  | varchar
Guarantee from retailer | GarantiOem | ztInteger | 2 |  | smallint
Warranty period (mon) | GarantiTid | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost proposal price | KostFPris | ZtBaseCurrAmount | 14 | 2 | money
Service option | OptCalc | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Repair time | TurnAround | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: shro Service items


Service keywords (shn)

Table of keywords for service reports. Keywords are retrieved from the table/program (xp2).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Keyword | ProSpegId | ztInteger | 3 |  | smallint
Row | RadPos2 | ztInteger | 4 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: shn Keywords per service order


Service keywords (xp2)

Definition of keyword, specific to the service module, that you can use to create profiles for service reports.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Keywords | ProspegBeskr | ztString | 30 |  | varchar
Keyword | ProspegID | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xp2 Service keywords


Service managers (stk)

Definition of service managers/areas of responsibility as required. This can involve a department, a local office, a director, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project manager | PersSign1 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Description | ServManDescr | ztString | 80 |  | varchar

    This table is the main table in the following programs:

    Program: stk Service managers


Service managers (view) (vstk)

Service managers are entered in this table. A service manager can be a department, local office, director, etc. A manager can be entered on each service order and service order row. This can then be used to query service orders for each manager.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project manager | PersSign1 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Name | RespNamn | ztString | 50 |  | nvarchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Service options, service items (ariopt)

Definition of applicable service options on serial no. items (service items with serial numbers) that affect the price and/or agreement discount.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Quantity | Antal | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Component item no. | ArtNrSerieIng | ztString | 30 |  | varchar
Component serial no. | ArtSerieIng | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Service order header (sh)

Planned service activities based on reports.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Reporting method | anmalantyp | ztInteger | 3 |  | smallint
No. of labels | AntalEtikett | ztInteger | 3 |  | smallint
Sum calc value | ArtKalkBerSum | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Delay no. days | AutoDelayDays | ztInteger | 5 |  | smallint
Interruption | AvbNr | ztInteger | 3 |  | smallint
Condition code (IRIS) | ConditionCode | ztString | 3 |  | varchar
Charge | debkod | ztInteger | 1 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
Planned activity | EventKod1 | ztInteger | 3 |  | smallint
Service report type | EventKod2 | ztInteger | 5 |  | smallint
Planned activity descr | EventNote | ztString | 60 |  | varchar
Activity no. | EventNr | ZtLong | 8 |  | int
Planned date | EventPlDat | ztDate |  |  | datetime
Planned time | EventPlTime | ztTime | 5 |  | datetime
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Reported end time | eventrptime | ztTime | 5 |  | datetime
Hours | EventTimant2 | ztHourWithDecimals | 8 | 2 | decimal
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
External description | ExtBeskriv | ztBlob | 1 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Error type | FelNr | ztString | 3 |  | varchar
Error description | feltext | ztBlob | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Free field 1 | frifalt1 | ztString | 40 |  | varchar
Free field 2 | frifalt2 | ztString | 40 |  | varchar
Free field 3 | frifalt3 | ztString | 40 |  | varchar
Free field 4 | frifalt4 | ztString | 40 |  | varchar
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
ZIP/Post code | FtgPostNr | ztString | 10 |  | varchar
Guarantee to | garanti | ztDate |  |  | datetime
Internal guarantee | GarantiInt | ztBoolean |  |  | char
Grafiskt tecken | Hrblock | ztchar | 1 |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Inlämningsdatum | InlDat | ztDate |  |  | datetime
Inlämnat kl | InlDatTime | ztDateTime |  |  | datetime
Internal description | IntBeskriv | ztBlob | 1 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost proposal | KostFRuta | ztBoolean |  |  | char
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | Ktonr | ztString | 8 |  | varchar
Customer order no. | KundBestNr | ztString | 30 |  | varchar
Customer reference | KundRef2 | ztString | 30 |  | varchar
Text on PO | KundSpecTextBe | ztBoolean |  |  | char
Receipt date | KvittDatum | ztDate |  |  | datetime
Sen anv ordernr | LastUsedOrdNo | ZtLong | 10 |  | int
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Lovad LevDat | LovLevDat | ztDate |  |  | datetime
Lovad Klockan | LovLevDatTime | ztDateTime |  |  | datetime
Header service order | MainOrderNr | Jeeves_SONo | 8 |  | bigint
Quote/agreement no. | offnr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order number 1 | OrderNr1 | ztString | 20 |  | varchar
Order number 2 | OrderNr2 | ztString | 20 |  | varchar
Order no. | OrderNrServ | Jeeves_SONo | 9 |  | bigint
Delivery addr, company | OrdLevAdr1 | ztString | 36 |  | varchar
Delivery address 1 | OrdLevAdr2 | ztString | 36 |  | varchar
Delivery address 2 | OrdLevAdr3 | ztString | 36 |  | varchar
Delivery address 3 | OrdLevAdr4 | ztString | 36 |  | varchar
LevFtgNr | OrdLevFtgNr | ztCompanyNo | 20 |  | varchar
Point of delivery, co. ID | ordlevplats1 | ztCompanyNo | 20 |  | varchar
Order value | OrdSum | ZtBaseCurrAmount | 14 | 2 | money
Order type | OrdTyp | ztInteger | 3 |  | smallint
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Project manager | perssign1 | ztString | 6 |  | varchar
Employee ID | perssign2 | ztString | 6 |  | varchar
Personal no. | PersSignNr | ztInteger | 3 |  | smallint
Activity finished | PlanUtford | ztBoolean |  |  | char
Position | Position | ztString | 10 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Keyword | ProSpegId | ztInteger | 3 |  | smallint
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Row | radpos2 | ztInteger | 4 |  | int
Action description | rapporttext | ztBlob | 1 |  | varchar
Fiscal year | redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Entry time | regtime | ztTime | 5 |  | datetime
Revision status | RevStatus | ztString | 10 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Service alternative | Saltartnr | ztString | 15 |  | varchar
Sender | Sender | ztString | 4 |  | varchar
Service center | ServCenter | ztString | 10 |  | varchar
Create order | ServCreOrd | ztBoolean |  |  | char
Service flow | servflow | ZtLong | 10 |  | int
Service code -1 | servkod1 | ztInteger | 3 |  | smallint
Service code -2 | servkod2 | ztInteger | 3 |  | smallint
Service code -3 | servkod3 | ztInteger | 3 |  | smallint
Priority, SO | ServPrioritet | ztInteger | 2 |  | smallint
Service item's serial no. | ServSerieNr | ztString | 30 |  | varchar
Status code, Service | servstatus | ztInteger | 2 |  | smallint
This field is used in the table as follows: |
Date/time | StrDateTime | ztString | 28 |  | varchar
Symptom IRIS | SymptomCode | ztString | 3 |  | varchar
Service | TjKod | ztInteger | 4 |  | smallint
Repair time | TurnAround | ztInteger | 2 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Item group | VaruGruppKod | ztString | 8 |  | varchar
Order amount, curr | VbOrdSum | ztMoney | 14 | 2 | money
Publish on Web | webpublish | ztBoolean |  |  | char
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: rshetik Label/service

    Program: shte Service order entry

    Program: shtg Complete service order reporting


Service order rows (shp)

Reported service activities.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Add existing fs | Add2DelNote | ztBoolean |  |  | char
Subproj closed | Aktavsl | ztBoolean |  |  | char
Subproject | Aktivitet | ztInteger | 4 |  | smallint
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Quantity | antal | ZtQty | 14 | 2 | decimal
No. of labels | AntalEtikett | ztInteger | 3 |  | smallint
Bin | Ars_LagPlats | ztBinLocation | 20 |  | varchar
Item description | ArtBeskr | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
Sum calc value | ArtKalkBerSum | ZtBaseCurrAmount | 14 | 2 | money
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Item no. | Artnr | ztString | 30 |  | varchar
Component serial no. | ArtSerieing | ztString | 30 |  | varchar
Item serial no. | Artserienr | ztString | 30 |  | varchar
Interruption | AvbNr | ztInteger | 3 |  | smallint
Item no. (BOM) | BArtnrStrukt | ztString | 30 |  | varchar
Batch no. required | BatchBokas | ztBoolean |  |  | char
Batch no. | BatchId | ztString | 30 |  | varchar
Ordered | Bestallas | ztBoolean |  |  | char
Delivery received date | BestLevDat | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Condition code (IRIS) | ConditionCode | ztString | 3 |  | varchar
Charge | debkod | ztInteger | 1 |  | smallint
Defect IRIS | DefectCode | ztString | 3 |  | varchar
File/dir | DokDir | ztString | 255 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | editext | ztBlob | 1 |  | varchar
Internal text | editint | ztBlob | 1 |  | varchar
@zPrompt=null | EjUpdShOh | ztInteger | 5 |  | smallint
Planned activity | eventkod1 | ztInteger | 3 |  | smallint
Planned activity descr | EventNote | ztString | 60 |  | varchar
Planned date | EventPlDat | ztDate |  |  | datetime
Planned time | EventPlTime | ztTime | 5 |  | datetime
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Reported activity | EventRpKod | ztInteger | 3 |  | smallint
Reported end time | EventRpTime | ztTime | 5 |  | datetime
Hours | EventTimant2 | ztHourWithDecimals | 8 | 2 | decimal
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Text on invoice row | exradtext | ztString | 255 |  | varchar
External description | ExtBeskriv | ztBlob | 1 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
RowNo. | FaktRadnr | ztInteger | 4 |  | int
Error type | FelNr | ztString | 3 |  | varchar
Delivery note/disp no. | FFhNr | ZtLong | 10 |  | int
RowNo | FFhRadNr | ztInteger | 5 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Free field 1 | frifalt1 | ztString | 40 |  | varchar
Free field 2 | frifalt2 | ztString | 40 |  | varchar
Free field 3 | frifalt3 | ztString | 40 |  | varchar
Free field 4 | frifalt4 | ztString | 40 |  | varchar
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Guarantee to | garanti | ztDate |  |  | datetime
Internal guarantee | GarantiInt | ztBoolean |  |  | char
Grafiskt tecken | Hrpblock | ztchar | 1 |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Internal description | IntBeskriv | ztBlob | 1 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Incl man entered del adr | K_Check_Adr | ztBoolean |  |  | char
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Est hourly cost | KalkKostManTim | ZtBaseCurrAmount | 14 | 2 | money
Cost unit | KostBar | ztString | 8 |  | varchar
Cost proposal | KostFRuta | ztBoolean |  |  | char
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Stocked | LagerBokas | ztBoolean |  |  | char
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Suppl discount-1 in % | LevRabattProc1 | ZtDecimal73 | 6 | 2 | decimal
Meter reading | Matarstallning | ZtLong | 10 |  | int
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Time accrued | NedLagdTid | ztHourWithDecimals | 8 | 2 | decimal
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Item descr (order) | ordartbeskr | ztString | 255 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order number 1 | OrderNr1 | ztString | 20 |  | varchar
Order number 2 | OrderNr2 | ztString | 20 |  | varchar
Order no. | OrderNrServ | Jeeves_SONo | 9 |  | bigint
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Order row sales | OrdRadNrServ | ztInteger | 5 |  | int
Row value, BCU | OrdRadSum | ZtBaseCurrAmount | 14 | 2 | money
Order spec text | OrpRadText | ztString | 255 |  | varchar
Print date | p_utskr_dat | ztDate |  |  | datetime
Est time in hours | PBeranttim | ztFloat | 10 | 2 | float
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project manager | PersSign1 | ztString | 6 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Signature | PersSign3 | ztString | 6 |  | varchar
Final inspection | PersSign4 | ztString | 6 |  | varchar
Personal no. | PersSignNr | ztInteger | 3 |  | smallint
Activity finished | PlanUtford | ztBoolean |  |  | char
Position | Position | ztString | 10 |  | varchar
Prel inv row no | PrelinvRowNo | ZtLong | 5 |  | int
Price | pris | ZtBaseCurrAmount | 14 | 2 | money
Price list | PrisLista | ztInteger | 5 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Discount % | Rabatt | ZtDecimal73 | 6 | 2 | decimal
Row | radpos2 | ztInteger | 4 |  | int
Action description | rapporttext | ztBlob | 1 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Reference pos IRIS | RefPosNr | ztString | 7 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Entry time | regtime | ztTime | 5 |  | datetime
Repairing IRIS | RepairCode | ztString | 3 |  | varchar
Reparation type | RepNr | ztInteger | 3 |  | smallint
Revision status | RevStatus | ztString | 10 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Joint purchase (allowed) | SamInKopMark | ztBoolean |  |  | char
Section IRIS | SectionCode | ztString | 3 |  | varchar
Sequence | Sequence | ztInteger | 3 |  | smallint
Service center | ServCenter | ztString | 10 |  | varchar
Create order | ServCreOrd | ztBoolean |  |  | char
Service flow | ServFlow | ZtLong | 10 |  | int
Service code -1 | servkod1 | ztInteger | 3 |  | smallint
Service code -2 | servkod2 | ztInteger | 3 |  | smallint
Service code -3 | servkod3 | ztInteger | 3 |  | smallint
Service item's serial no. | ServSerieNr | ztString | 30 |  | varchar
Status code, Service | servstatus | ztInteger | 2 |  | smallint
Print doc | SkapaUtDok | ztBoolean |  |  | char
Step | STEP | ztInteger | 3 |  | smallint
Date/time | StrDateTime | ztString | 28 |  | varchar
Requisition | StrDateTimeBIA | ztString | 28 |  | varchar
Symptom IRIS | SymptomCode | ztString | 3 |  | varchar
Time type | tidkod | ztInteger | 5 |  | smallint
Repair time | TurnAround | ztInteger | 2 |  | smallint
Update Q&A | UpdateQA | ztBoolean |  |  | char
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Price, curr | Vb_Pris | ZtSalesPrice | 12 | 2 | money
Order row amt, curr | VbOrdRadSum | ztMoney | 14 | 2 | money
Sector | verksamhet | ztInteger | 5 |  | smallint
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: shtf Service order reporting


Service order rows from structure (shsr)

Table of items included in service order rows created based on a package in the item register.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Component serial no. | ArtSerieIng | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Interruption | AvbNr | ztInteger | 3 |  | smallint
Condition code (IRIS) | ConditionCode | ztString | 3 |  | varchar
Charge | DebKod | ztInteger | 1 |  | smallint
Text | Edit | ztBlob | 1 |  | varchar
Planned activity descr | EventNote | ztString | 60 |  | varchar
Planned date | EventPlDat | ztDate |  |  | datetime
Planned time | EventPlTime | ztTime | 5 |  | datetime
External description | Extbeskriv | ztBlob | 1 |  | varchar
Error type | FelNr | ztString | 3 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Free field 1 | FriFalt1 | ztString | 40 |  | varchar
Free field 2 | FriFalt2 | ztString | 40 |  | varchar
Free field 3 | FriFalt3 | ztString | 40 |  | varchar
Free field 4 | FriFalt4 | ztString | 40 |  | varchar
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Guarantee to | Garanti | ztDate |  |  | datetime
Internal guarantee | GarantiInt | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Internal description | IntBeskriv | ztBlob | 1 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost proposal | KostFRuta | ztBoolean |  |  | char
Cost centre | KoststalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order number 1 | OrderNr1 | ztString | 20 |  | varchar
Order number 2 | OrderNr2 | ztString | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project manager | Perssign1 | ztString | 6 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Position | Position | ztString | 10 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Action description | RapportText | ztBlob | 1 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Revision status | RevStatus | ztString | 10 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Service code -1 | ServKod1 | ztInteger | 3 |  | smallint
Service code -2 | ServKod2 | ztInteger | 3 |  | smallint
Service code -3 | ServKod3 | ztInteger | 3 |  | smallint
Service item's serial no. | ServSerieNr | ztString | 30 |  | varchar
Status code, Service | ServStatus | ztInteger | 2 |  | smallint
Date/time | StrDateTime | ztString | 28 |  | varchar
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
Symptom IRIS | SymptomCode | ztString | 3 |  | varchar
Repair time | TurnAround | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: shsr Enter service order rows from BOM


Service order status (xy6)

Definition of existing status codes that are used in the Service module to follow service report processing.

Each service order has a status code showing the current stage of the service order. The status code is copied to the service order rows at the time of entry, but the status code can then differ between the service header and the rows. Different rows can have a different status.

If you work with the service flow you can specify which status will be assigned to each row when entering a service order based on the service flow in the program Entering a Service Order (Shte).

A great deal of logic is built into the status code, as shown by the compilation below. For every status code you can also choose whether you want status changes for service orders/rows to be logged in the service log.

The following standard records exist. Do not alter/delete:

Status code, Service (servstatus) | Status, Service (servstatusB) | Description
0 | Entered | Status 0, Entered is set automatically on the service order header when the record is saved. No reservation of inventory items is done for status code 0 (to and including 9 for own status codes).
10 | Planned | Status 10, Planned is set manually to show that the service order/row has been planned, usually at the same time that the signature is specified for the individual who will perform the work indicated in the plan. Reservation of inventory items is done for status code 10 (to and including 29 for own status codes).
20 | Ongoing | Status 20, Ongoing is set manually to show that work on the service order/row has begun. Reservation of inventory items is done for status code 20 (to and including 29 for own status codes).
30 | Closed | Status 30, Completed is set manually to show that work on the service order/row has been completed or reported as finished. Status means that the service order row is transferred to either the order or assignment routine, depending on what is specified in the system data, and on control parameters and billing codes. See the chapter on invoicing in the Service module for more details.
50 | Invoiced | You can use this status code for information (set manually in this case), i.e. no logic is built into the code.
90 | Canceled | You can use this status code for information (set manually in this case), i.e. no logic is built into the code.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Log changes | Servlog | ztBoolean |  |  | char
Status code, Service | servstatus | ztInteger | 2 |  | smallint
Status, Service | servstatusB | ztString | 50 |  | varchar
TextID | TextID | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: xy6 Service order status


Service order types (xy4)

Definition of the order types that can be used in the Service module. You specify a number series that will be used for each service order type in the embedded window. You can add your own types as required.

For entry of service orders via Jeeves e-Service, the order type is governed by the control parameter WEBAPP009, Web service order type.

The following standard records exist. Do not alter/delete:

Order type (OrdTyp) | Order type (OrdTypBeskr)
20 | Internet

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Order type | OrdTypBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowupdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xy4 Service order types


Service order types, no. series (xy44)

Table for entering number series linked to a service order type.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
From our order no. | FromOrderNr | Jeeves_SONo | 8 |  | bigint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowupdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
To our order no. | TomOrderNr | Jeeves_SONo | 8 |  | bigint


Service pricing methods (xtt)

Table of pricing methods that are used to define how prices are set on services.

The following standard records exist. Do not alter/delete:

Pricing method (PrisTyp) | Pricing method (PrisTypBeskr)
0 | Sector
1 | Category
2 | Contact

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Pricing method | PrisTyp | ztInteger | 3 |  | smallint
Pricing method | PrisTypBeskr | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xtt Pricing methods, assignment


Service priority codes (xy7)

Definition of existing priority codes as required.

No logic is built into the priority coding, it is used for manual searching/sorting of service orders by priority.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Priority, SO | ServPrioritet | ztInteger | 2 |  | smallint
Priority serv. order | ServPrioritetB | ztString | 30 |  | varchar
TextID | TextID | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: xy7 Service priority


Service report types, service (xap)

Definition of occurring service report types which will be specified when reporting service orders.

Every service order can be divided into different service report types (for example installation, repairing, etc.). The information can then be used when searching for service orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Service report type | EventBeskr1 | ztString | 50 |  | varchar
Service report type | EventKod2 | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Log changes | ServLog | ztBoolean |  |  | char
TextID | TextID | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: xap Service report types, service


Service reporting methods (xsa)

Definition of methods for reporting service orders, e.g. Letter, Internet, Fax and so on.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Reporting method | anmalantyp | ztInteger | 3 |  | smallint
Reporting method | anmalantypD | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xsa Report meth, service


Service status log (shlg)

Status changes on service headers and service order rows are stored in this table. The status code determines whether status changes are to be logged.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | artnr | ztString | 30 |  | varchar
Item serial no. | artserienr | ztString | 30 |  | varchar
Service report type | EventKod2 | ztInteger | 5 |  | smallint
Reported end date | eventrpEndDat | ztDate |  |  | datetime
Reported end time | eventrptime | ztTime | 5 |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quote/agreement no. | offnr | ztString | 10 |  | varchar
Order no. | ordernr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Project manager | PersSign1 | ztString | 6 |  | varchar
Row | RadPos2 | ztInteger | 4 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Entry time | regtime | ztTime | 5 |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Service item's serial no. | ServSerieNr | ztString | 30 |  | varchar
Status code, Service | servstatus | ztInteger | 2 |  | smallint
Date/time | StrDateTime | ztString | 28 |  | varchar

    This table is the main table in the following programs:

    Program: shlg Status log, service order


Service technicians (stt)

Definition of the company’s service technician or equivalent. Service engineers must be entered in the ‘Accounting users’ (pr) table before you can enter them here.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar number | kalendernr | ztInteger | 2 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project manager | perssign1 | ztString | 6 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: stt Service technicians


Service techs/view (vstt)

The vstt table is a view of the stt table.
The service technicians used in the service module are entered in this table. Before they can be entered as service technicians, they must be entered in the pr table (Personnel).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Calendar number | kalendernr | ztInteger | 2 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Project manager | perssign1 | ztString | 6 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Name | RespNamn | ztString | 50 |  | nvarchar


Service techs/view (vst1)

The vst1 table is a view of the stt table. The service technicians used in the service module are entered in this table. Before they can be entered as service technicians, they must be entered in the pr table (Personnel).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Calendar number | kalendernr | ztInteger | 2 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Project manager | perssign1 | ztString | 6 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar


Services accounts, projects (Ptko)

Definition of the services accounts used to control postings from projects in respect of cost postings from time rows, internal debiting and percentage of completion accounting. The services account works almost in the same way as the product account. It has a sub-table where posting rules are defined for fiscal years.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invoice segment 4 | FaktK4 | ztString | 8 |  | varchar
Invoice segment 5 | Faktk5 | ztString | 8 |  | varchar
Invoice segment 6 | FaktK6 | ztString | 8 |  | varchar
Invoice segment 7 | FaktK7 | ztString | 8 |  | varchar
Invoice cost unit | FaktKostBar | ztString | 8 |  | varchar
Invoice cost centre | FaktKostStalleKod | ztString | 8 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Services account | TjansteKonto | ztString | 8 |  | varchar
Services account | TjansteKontoBeskr | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: Ptko Services accounts, projects


Services price list, details (prlt)

Details in price lists for services.

This can be assignment-specific price details which are entered in the program ‘Assignments’ (uofh) in the right-hand embedded list window.

This can also be prices per business area, personnel category or accounting user which are entered in the program ‘Service price lists’ (prht).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item class | ArtKod | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
In-house price | Internpris | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Markup % | Palagg | ztFloat | 5 | 2 | float
Personnel category | Perskategori | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project manager | perssign1 | ztString | 6 |  | varchar
Price | pris | ZtBaseCurrAmount | 14 | 2 | money
Price list | PrisLista | ztInteger | 5 |  | smallint
Service price list | PrislistaT | ztInteger | 6 |  | smallint
Pricing method | PrisTyp | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Time type | tidkod | ztInteger | 5 |  | smallint
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Price, curr | Vb_Pris | ZtSalesPrice | 12 | 2 | money
Sector | verksamhet | ztInteger | 5 |  | smallint


Services price list, header (prht)

Data in the price list header for services.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Price list | PrisListaBeskr | ztString | 30 |  | varchar
Service price list | PrislistaT | ztInteger | 6 |  | smallint
Pricing method | PrisTyp | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal

    This table is the main table in the following programs:

    Program: prht Services price lists


Session log setup (WMS_Tool_SessionLog)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Log To File | LogStatus | ztBoolean |  |  | char
Log User | LogUser | ztString | 6 |  | varchar
Path | Path | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Log to window | PrintStatus | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_Tool_SessionLog Session log setup


Setting (AstroName)

Subsetting table in the Astro installation program.

The following standard records exist. Do not alter/delete:

Id (AstroNameId) | Description (AstroNameDescr)
30 | DirectoryIn
40 | DictoryOut
50 | ExceptionHandler
80 | SrcEndpoint
90 | DestEndpoint
110 | Transformer
120 | Extractor
130 | MessageProcessor
140 | Persign
150 | FTPAddressIn
160 | FTPAddressOut
170 | UsernameIn
180 | UsernameOut
190 | PasswordIn
200 | PasswordOut
210 | ConnectionString
220 | ServerName
230 | DataBasename
240 | PollingIntervall
250 | XSDValidationDirectory
260 | CompanyCode
270 | Disable
280 | Log
290 | Debug
300 | Port
310 | Host
320 | From
330 | To
340 | Subject
350 | EnableTransaction
360 | FileFilter
370 | Encoder
380 | Decoder
390 | ResendAfter
400 | CleanupAfter
410 | MoveTo
420 | NumberOfResends
430 | SQLExceptionHandlers
440 | FileName
450 | ValidationDoesNotThroughException
460 | RoutingValueXPath
470 | JustToXML
480 | JustToPipe
490 | Timeout

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | AstroNameDescr | ztString | 50 |  | varchar
Id | AstroNameId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AstroName Astro setting


Setting dimensions/keys (JvsSiteNodeWin)

The main program/table for viewing and editing own settings. All settings in the current site structure are assigned a setting ID that is stored here, together with the selected setting dimensions. The settings themselves are stored in separate programs/tables most of which can be viewed and accessed through embedded windows in this program or from Jeeves' menu.

Note that one record is stored here per setting where the key is identical, i.e. with the same user (signature/group/all), the same company (company ID/group/all) and the same object (program node/window context/global). This means that if you make several settings on different occasions but for exactly the same key, they are added to the same record.

Also note that the fields in the header show the program/node/window in which the setting applies, e.g. if a program is named in the Program field, the setting only applies if that program is open. For settings that apply to programs, but do not require the program in question to be open, the program name is stored in the Edit field in the relevant setting table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company code | ForetagKodAll | ztInteger | 5 |  | smallint
Company group No. | JvsSiteCmpGroup | ztInteger | 4 |  | smallint
All users | JvsSiteForGlobal | ztBoolean |  |  | char
Group | JvsSiteForGrp | ZtLong | 6 |  | int
Signature | JvsSiteForUser | ztString | 6 |  | nvarchar
Group name (lang) | JvsSiteGroupName_Lang | ztString | 6 |  | nvarchar
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Setting ID (orig) | JvsSiteNodeWinSettingsID_orig | ZtLong | 10 |  | int
Program | JvsSiteProgramName | ztString | 40 |  | nvarchar
Node | JvsSiteProgramNode | ztString | 35 |  | nvarchar
Active | jvssitesettingactive | ztBoolean |  |  | char
Unique ID | JvsSiteUniqueId | ztString | 40 |  | nvarchar
Window context | JvsSiteWindowName | ztString | 40 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteNodeWin Setting dimensions/keys


Setting name (AstroSettingName)

Subsetting table in the Astro installation program.

The following standard records exist. Do not alter/delete:

Id (AstroSettingNameId) | Description (AstroSettingNameDescr)
10 | FileEndPoint
20 | TactonTransformer
30 | TransformerMessageProcessor
40 | FileExceptionHandler
50 | AstroToJeevesExtractor
60 | MessageNode
70 | Global
80 | Jeeves endpoint
90 | MailExceptionHandler

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | AstroSettingNameDescr | ztString | 50 |  | varchar
Id | AstroSettingNameId | ztInteger | 5 |  | smallint
System Type | AstroSettingNameText | ztString | 50 |  | varchar
Id | AstroSystemTypeId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AstroSettingName Astro setting name


Setting templates (JvsSitePropertyGroup)

Program/table for viewing and editing setting templates. Instead of making multiple settings you can group a number of settings into a template.

You can for example create a template that includes font settings such as Arial, 10, Bold, Red and there by you have made a style. This style you can then reuse on different text settings.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Data | JvsSitePropertyData | ztString | 7500 |  | nvarchar
Template name | JvsSitePropertyGroupName | ztString | 40 |  | nvarchar
Index | JvsSitePropertyIndex | ztInteger | 4 |  | int
Type | JvsSitePropertyName | ztString | 64 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSitePropertyGroup Setting templates


Setting type (AstroSettingType)

Subsetting table in the program astroinstallation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Id | AstroSettingNameId | ztInteger | 5 |  | smallint
Entity | AstroSettingTypeDescr | ztString | 50 |  | varchar
Type Id | AstroSettingTypeId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AstroSettingType Astro setting Types


Settings (AstroSettings)

Subsetting table in the program astroinstallation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Id | AstroNameId | ztInteger | 5 |  | smallint
Setting Id | AstroSettingsId | ztInteger | 5 |  | smallint
Setting | AstroSettingText | ztString | 255 |  | varchar
Type Id | AstroSettingTypeId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AstroSettings Astro settings


Settings for maintenance, attendance reports (sy2_Attr)

This table is for entering user that shall be allowed to perform maintenance on the time reports (attestation).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
From approval code | AttRFromAttRAuthorizeCode | ztString | 6 |  | varchar
From date | AttRFromDat | ztDate |  |  | datetime
From day | AttrFromDay | ztInteger | 5 |  | smallint
From employee | AttRfromPerssign2 | ztString | 6 |  | varchar
Only approved | AttrOnlyAuthorized | ztBoolean |  |  | char
Show invalid reports | AttrOnlyInvalid | ztBoolean |  |  | char
Summary type | AttrSummaryType | ztInteger | 5 |  | smallint
To approval group | AttRToAttRAuthorizeCode | ztString | 6 |  | varchar
To date | AttrToDat | ztDate |  |  | datetime
To day | AttrToDay | ztInteger | 5 |  | smallint
To employee | AttRToPerssign2 | ztString | 6 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | Perssign2 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sort order | SFROrderBy | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: Attr_Maint Maintenance, attendance reports

    Program: sy2_Attr Settings for maintenance, attendance reports


Settings for shopfloor reporting (sy2_sfr)

In this table each user (terminal) is linked to a manufacturing group or flow group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Flow group | Flodesgrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Job card | kortnrao | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | Perssign2 | ztString | 6 |  | varchar
Manufacturing group | Prodgr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Days ahead | SFRDayForward | ztInteger | 5 |  | smallint
From date | SFRFromDat | ztDate |  |  | datetime
Sort order | SFROrderBy | ztInteger | 5 |  | smallint
Show finished WO | SFRShowFinished | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: ShopFloor Shopfloor

    Program: sy2_sfr Settings for shop floor reporting


Settings nodes/windows (JvsPreSiteHideND)

Table to flag which fields will be invisible in a program node.
Loaded before settings in site repository.
The table lies in the customer’s production database and NOT in the site repository database.
The table is intended to supply certain simple default settings for customers.
The default settings can be grouped on an ID so that there can be several different versions for different types of customers and users.
You can specify an ID in the JINI table for which rows will be included from the table in question.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Site pre setting ID | JvsPreSiteEditionId | ztString | 20 |  | nvarchar
Hidden | JvsSiteMakeInvisible | ztBoolean |  |  | nvarchar
Program | JvsSiteProgramName | ztString | 40 |  | nvarchar
Node | JvsSiteProgramNode | ztString | 35 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Settings nodes/windows (JvsPreSiteNode)

Table to flag which fields will be invisible in a program node.
Loaded before settings in site repository.
The table lies in the customer’s production database and NOT in the site repository database.
The table is intended to supply certain simple default settings for customers.
The default settings can be grouped on an ID so that there can be several different versions for different types of customers and users.
You can specify an ID in the JINI table for which rows will be included from the table in question.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Site pre setting ID | JvsPreSiteEditionId | ztString | 20 |  | nvarchar
Term | JvsSiteColumnName | ztString | 40 |  | nvarchar
Hidden | JvsSiteMakeInvisible | ztBoolean |  |  | nvarchar
Program | JvsSiteProgramName | ztString | 40 |  | nvarchar
Node | JvsSiteProgramNode | ztString | 35 |  | nvarchar
Table | JvsSiteTableName | ztString | 40 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Settings nodes/windows (JvsPreSiteTerm)

Table to flag which terms will be invisible.
Loaded before settings in site repository.
The table lies in the customer’s production database and NOT in the site repository database.
The table is intended to supply certain simple default settings for customers.
The default settings can be grouped on an ID so that there can be several different versions for different types of customers and users.
You can specify an ID in the JINI table for which rows will be included from the table in question.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Site pre setting ID | JvsPreSiteEditionId | ztString | 20 |  | nvarchar
Hidden | JvsSiteMakeInvisible | ztBoolean |  |  | char
Term | JvsSiteTermName | ztString | 40 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsPreSiteTerm Settings nodes/windows


Settings nodes/windows (JvsPreSiteWin)

Table to flag which fields will be invisible in a program node.
Loaded before settings in site repository.
The table lies in the customer’s production database and NOT in the site repository database.
The table is intended to supply certain simple default settings for customers.
The default settings can be grouped on an ID so that there can be several different versions for different types of customers and users.
You can specify an ID in the JINI table for which rows will be included from the table in question.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Site pre setting ID | JvsPreSiteEditionId | ztString | 20 |  | nvarchar
Term | JvsSiteColumnName | ztString | 40 |  | nvarchar
Hidden | JvsSiteMakeInvisible | ztBoolean |  |  | char
Table | JvsSiteTableName | ztString | 40 |  | nvarchar
Window context | JvsSiteWindowName | ztString | 40 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Shipment plan, header (ShipmPlanH)

Table of details in shipment plans.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Booked net weight | BookedNetWeight | ZtDecimal73 | 14 | 3 | decimal
Booked volume | BookedVolume | ZtDecimal73 | 14 | 3 | decimal
Booked gross weight | BookedWeight | ZtDecimal73 | 14 | 3 | decimal
Departure unique ID | DepartureUniqueId | ztInteger | 5 |  | smallint
Start day of the week | FastLevVeckoDag | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Load before, date | LoadBeforeDate | ztDate |  |  | datetime
Load before, time | LoadBeforeTime | ztTime | 5 |  | datetime
Loading gate WMS | LoadingGateWMS | ztString | 10 |  | varchar
Load location WMS | LoadLocationWMS | ztString | 10 |  | varchar
No of booked Disp orders | NoOfBookedDispOrders | ZtLong | 10 |  | int
Rows released to WMS | NoOfRowsRelToWMS | ZtLong | 10 |  | int
Rows in Shipment plan | NoOfRowsShipmPlan | ZtLong | 10 |  | int
Order gate, date | OrderGateDate | ztDate |  |  | datetime
Order gate, time | OrderGateTime | ztTime | 5 |  | datetime
Pack before, date | PackBeforeDate | ztDate |  |  | datetime
Pack before, time | PackBeforeTime | ztTime | 5 |  | datetime
Pack location WMS | PackLocationWMS | ztString | 10 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Pick before, date | PickBeforeDate | ztDate |  |  | datetime
Pick before, time | PickBeforeTime | ztTime | 5 |  | datetime
Pick release before, date | PickReleaseDate | ztDate |  |  | datetime
Pick release before, time | PickReleaseTime | ztTime | 5 |  | datetime
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Ship lock before, date | ShipLockBeforeDate | ztDate |  |  | datetime
Ship lock before, time | ShipLockBeforeTime | ztTime | 5 |  | datetime
Shipment status | ShipmentStatus | ztInteger | 5 |  | smallint
Shipment load status | ShipmLoadStatus | ztInteger | 2 |  | smallint
Shipment plan alpha ID | ShipmPlanAlphaId | ztString | 30 |  | varchar
Shipment plan date | ShipmPlanDate | ztDate |  |  | datetime
Planned net weight | ShipmPlanNetWeight | ZtDecimal73 | 14 | 3 | decimal
Shipment plan no | ShipmPlanNo | ZtLong | 9 |  | int
Shipment plan status | ShipmPlanStatus | ztInteger | 2 |  | smallint
Shipment plan time | ShipmPlanTime | ztTime | 5 |  | datetime
Planned volume | ShipmPlanVolume | ZtDecimal73 | 14 | 3 | decimal
Planned gross weight | ShipmPlanWeight | ZtDecimal73 | 14 | 3 | decimal
Max net weight | TranspResrcNetWeight | ZtDecimal73 | 14 | 3 | decimal
Transport resource | TranspResrcType | ztInteger | 4 |  | smallint
Max volume | TranspResrcVolume | ZtDecimal73 | 14 | 3 | decimal
Max gross weight | TranspResrcWeight | ZtDecimal73 | 14 | 3 | decimal
Day of week | VeckoDag | ztInteger | 1 |  | smallint
WMS released flag | WMSReleasedFlag | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: ShipmentPlan Shipment planning

    Program: ShipmentPlanHist Shipment planning, history


Shipment plan, lines of detail (ShipmPlanR)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Booked net weight | BookedNetWeight | ZtDecimal73 | 14 | 3 | decimal
Booked volume | BookedVolume | ZtDecimal73 | 14 | 3 | decimal
Booked gross weight | BookedWeight | ZtDecimal73 | 14 | 3 | decimal
Delivery note/disp no. | FfhNr | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Est disp time | OrdBerLevTid | ztTime | 6 |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Released to WMS | ReleasedToWMS | ztDateTime |  |  | datetime
Gross weight, kg, remain value | RestArtBtotVikt | ztFloat | 10 | 3 | float
Net weight, kg, remain value | RestArtVikt | ztFloat | 10 | 3 | float
Volume, remain value | RestArtVolym | ztFloat | 15 | 2 | float
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Shipment plan alpha ID | ShipmPlanAlphaId | ztString | 30 |  | varchar
Shipment plan no | ShipmPlanNo | ZtLong | 9 |  | int
Shipment plan row no | ShipmPlanRowNo | ZtLong | 9 |  | int


Shipment status of shipment plans (ShipmentStatus)

Definition of shipment status codes for shipment plans for the WMS module. Information about the current shipment status is shown on the shipment plan.

The following standard records exist. Do not alter/delete:

Shipment status (ShipmentStatus) | Shipment status (ShipmentStatusDescr)
0 | Created
10 | Transport quote requested
20 | Transport booked

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Shipment status | ShipmentStatus | ztInteger | 5 |  | smallint
Shipment status | ShipmentStatusDescr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: ShipmentStatus Shipment status of shipment plans


Shop ... other work (veoj)

Id of indirect labour that the team/work group on the shop floor performs.

This is shown as default for the team members when they do not have an ongoing job.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Indirect job/labour | VeOvrigtJobb | ztInteger | 5 |  | smallint
Indirect job/labour | VeOvrigtJobbBeskr | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: veoj Shop floor, misc. reason codes


Shop floor report log (SFR_StartSfr_Ao_Log)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | smallint
Work group | ArbetsLag | ztString | 6 |  | nvarchar
Identitetskolumn | ConnToSQLIDENTITY | ZtLong | 10 |  | int
Created by object | CreatedByDBObject | ztString | 60 |  | nvarchar
Flow group | FlodesGrupp | ztString | 5 |  | nvarchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Note | KortNotering | ztString | 255 |  | nvarchar
Operation no. | OpNr | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | nvarchar
Employee ID | PersSign2 | ztString | 6 |  | nvarchar
Manufacturing group | ProdGr | ztString | 5 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Reportingtype SFR | SFRRepType | ztInteger | 5 |  | smallint
Start Stamptime | SFRWORepStartDt | ztDateTime |  |  | datetime
Process ID | spid | ZtLong | 5 |  | int
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Procedure | StoredProcedure | ztString | 120 |  | nvarchar
Date/time | StrDateTime | ztString | 28 |  | nvarchar
Indirect job/labour | VeOvrigtJobb | ztInteger | 5 |  | smallint
Language code | zlanguage | ztInteger | 4 |  | smallint
Nest Level | ZNestLevel | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: SFR_StartSfr_Ao_Log Shop floor report log


Shop floor report log (SFR_StopSfr_Ao_Log)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Interruption code | AoAvbrottsKod | ztInteger | 5 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | smallint
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Work group | ArbetsLag | ztString | 6 |  | nvarchar
Item serial no. | ArtSerieNr | ztString | 30 |  | nvarchar
Batch no. | BatchId | ztString | 30 |  | nvarchar
Identitetskolumn | ConnToSQLIDENTITY | ZtLong | 10 |  | int
Created by object | CreatedByDBObject | ztString | 60 |  | nvarchar
Identitetskolumn | DummySQLIdentity | ZtLong | 10 |  | int
Flow group | FlodesGrupp | ztString | 5 |  | nvarchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
Note | KortNotering | ztString | 255 |  | nvarchar
Inventory supervisor | LagerAnsvPersSign | ztString | 6 |  | nvarchar
Bin | LagPlats | ztBinLocation | 20 |  | nvarchar
Operation no. | OpNr | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | nvarchar
Employee ID | PersSign2 | ztString | 6 |  | nvarchar
Manufacturing group | ProdGr | ztString | 5 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Reportingtype SFR | SFRRepType | ztInteger | 5 |  | smallint
Stamp time | SFRWORepDat | ztDateTime |  |  | datetime
Start Stamptime | SFRWORepStartDt | ztDateTime |  |  | datetime
Process ID | spid | ZtLong | 5 |  | int
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Procedure | StoredProcedure | ztString | 120 |  | nvarchar
Date/time | StrDateTime | ztString | 28 |  | nvarchar
Indirect job/labour | VeOvrigtJobb | ztInteger | 5 |  | smallint
Language code | zlanguage | ztInteger | 4 |  | smallint
Nest Level | ZNestLevel | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: SFR_StopSfr_Ao_Log Shop floor report log


Shop personnel (prv)

In this table, you define the shop personnel or the persons that have the right to both "stamp" that they are on site and perform labour in the program for shop floor reporting.

You can tie personnel to flow groups, manufacturing groups, monetary factors, and group schedules.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active from | AttrActiveFrom | ztDate |  |  | datetime
Active to | AttrActiveTo | ztDate |  |  | datetime
Authorization group ID | AttRAuthorizeCode | ztString | 6 |  | varchar
Blocked | AttrBlocked | ztBoolean |  |  | char
Card code | AttrCardCode | ztString | 40 |  | varchar
Change schedule | attrChangeSchedule | ztBoolean |  |  | char
Department | attrdepartment | ztString | 6 |  | varchar
Time type, work metrics | AttRExpwtTimeType | ztString | 6 |  | varchar
Not active | AttrNotActive | ztBoolean |  |  | char
Password | attrpassword | ztString | 10 |  | varchar
Terminal | AttRPerssign2Term | ztString | 6 |  | varchar
Time type scrap time | AttRScrapTimeType | ztString | 6 |  | varchar
Schedule group | AttRWorkScheduleGrp | ztString | 6 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Foreman area | FormansOmrade | ztString | 6 |  | varchar
Last clock out date | GickDatum | ztDate |  |  | datetime
Last clock out time | GickTid | ztTime | 5 |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Last clock in date | KomDatum | ztDate |  |  | datetime
Last clock in date | KomTid | ztTime | 5 |  | datetime
Note | KortNotering | ztString | 255 |  | varchar
Interim cost centre | KstInterimsBokning | ztString | 8 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Personal no. | PersSignNr | ztInteger | 3 |  | smallint
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Days ahead | QCheckShowDaysForward | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Entry time | RegTime | ztTime | 5 |  | datetime
Name | RespNamn | ztString | 50 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Orig end date | UrsprSlutDatum | ztDate |  |  | datetime
Orig end time | UrsprSlutTid | ztTime | 5 |  | datetime
Orig start date | UrsprStartDatum | ztDate |  |  | datetime
Orig start time | UrsprStartTid | ztTime | 5 |  | datetime
Group schedule | VeGruppSchema | ztInteger | 5 |  | smallint
Visa historik antal dgr | VisaPrvtAntDagar | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: Attendance Attendance reporting

    Program: attr_prv Personnel

    Program: prv Shop floor personnel

    Program: Prv_1 Time reporting, personnel

    Program: PrvGK1 Attendance/labour reporting

    Program: Qprv Quality, to do

    Program: Qprv_1 Quality, to do


Shop time reports (prvt)

Time reports completed by shop personnel are stored in this table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of minutes | AntalMinuter | ZtLong | 10 |  | int
Interruption code | AoAvbrottsKod | ztInteger | 5 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Status reported labour | AoruStatus | ztInteger | 5 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Sequence number | ConnDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar
@zPrompt=null | DoIndirectUpdate | ztBoolean |  |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Reported end time | EventRpTime | ztTime | 5 |  | datetime
Hours | EventTimAnt2 | ztHourWithDecimals | 8 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Last clock out date | GickDatum | ztDate |  |  | datetime
Last clock out time | GickTid | ztTime | 5 |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Last clock in date | KomDatum | ztDate |  |  | datetime
Last clock in date | KomTid | ztTime | 5 |  | datetime
Note | KortNotering | ztString | 255 |  | varchar
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Operation no. | OpNr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Activity finished | PlanUtford | ztBoolean |  |  | char
Error code factory rep | PRVT_Felkod | ztInteger | 5 |  | smallint
Time report type | PrvtTyp | ztInteger | 3 |  | smallint
Rep no. minutes | RappAntalMinuter | ZtLong | 10 |  | int
Reported finish date | RappSlutDatum | ztDate |  |  | datetime
Reported finish time | RappSlutTid | ztTime | 5 |  | datetime
Start date | RappStartDatum | ztDate |  |  | datetime
Reported start time | RappStartTid | ztTime | 5 |  | datetime
Entry date | RegDat | ztDate |  |  | datetime
Entry time | RegTime | ztTime | 5 |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Original minutes | UrsprAntalMinuter | ZtLong | 10 |  | int
Orig end date | UrsprSlutDatum | ztDate |  |  | datetime
Orig end time | UrsprSlutTid | ztTime | 5 |  | datetime
Orig start date | UrsprStartDatum | ztDate |  |  | datetime
Orig start time | UrsprStartTid | ztTime | 5 |  | datetime
Performed time | UtfordTid_TTMM | ztTime | 5 |  | datetime
Indirect job/labour | VeOvrigtJobb | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: prvt Completed shop reports

    Program: prvt_atg Time reports, shop personnel

    Program: prvt0 Today's time reports, shop personnel


Shortcuts, voucher row entry (kvr)

Shortcut codes that can be used to facilitate manual entry of voucher rows when the posting contains many account segments, or when the voucher basis does not contain the correct account segments but other information for the posting.

If when entering a voucher row you specify a shortcut code, the account segments that are defined for the shortcut code are retrieved as default on the voucher row.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Shortcut | KortKodVerRad | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Voucher row text | VrVerText | ztString | 60 |  | varchar

    This table is the main table in the following programs:

    Program: xKvr Shortcut codes, voucher entry


SIE Export (Sie)

Help table for SIE export (Standardized Import and Export) of data to external systems.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
ID | sieid | ZtLong | 8 |  | int
Text/info | x255 | ztString | 255 |  | nvarchar


Sign conversion from->to (x2cr)

For control of which characters are converted when creating outgoing payment files.
There is a link via the outgoing payment route.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sign conversion | CharConvertType | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
From | FromChar | ztInteger | 5 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
To | ToChar | ztInteger | 5 |  | smallint


Sign conversion, outgoing payments, etc. (x2ct)

Definitions for controlling which characters are converted when creating outgoing payment files, etc.

This is specified when defining outgoing payment routes, for example.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sign conversion | CharConvertType | ztInteger | 5 |  | smallint
Sign conversion | CharConvertTypeDescr | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: x2ct Conversion rules/signs, pmt


Signatures per purchasing role (ikrp)

Definition of the persons included in the respective purchase role.

If a person is included in several purchase roles, you can mark that person as a default purchase role for the signature. If a person is allowed to purchase for several inventory locations, you can specify the default inventory location for the signature.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Default purchasing role | definkopsroll | ztBoolean |  |  | char
Default point of delivery | DefLevPlats | ztString | 2 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchasing role | inkopsroll | ztInteger | 4 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Single settings (JvsSiteNodeWinProperty)

Program/table for viewing and editing single settings, i.e. settings of which there can only be one instance for the same key and setting dimensions. Example of settings stored here are hidden buttons, nodes and tabs etc., changes in node order, entry mode settings, background color settings and many more.

The program/table can be accessed through an embedded window in the program Setting dimensions/keys (jvssitenodewin) or from Jeeves' menu.

For settings involving own texts there is also an embedded window for translating these texts to other languages in which the system is run.

Note that the fields in the header show the program/node/window in which the setting applies, e.g. if a program is named in the Program field, the setting only applies if that program is open. For settings that apply to programs, but do not require the program in question to be open, the program name is stored in the Edit field.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Code | JvsSiteMacroCode_sub |  |  |  | @DataType=NULL
Conn to setting ID | JvsSiteMacroConn2Setting_sub2 |  |  |  | @DataType=NULL
Setting name | JvsSiteMacroName_sub1 |  |  |  | @DataType=NULL
Id | JvsSiteMacroUniqueId_sub2 |  |  |  | @DataType=NULL
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Setting ID (orig) | JvsSiteNodeWinSettingsID_orig | ZtLong | 10 |  | int
Data | JvsSitePropertyData | ztString | 7500 |  | varchar
Type | JvsSitePropertyName | ztString | 64 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteNodeWinProperty Single settings


Site distance per inventory loc (xavs)

Alphanumeric designation for the company.

When you enter a company for the first time, this number is not automatically set by the system. You must enter it manually.

This is the unique ID for the company and cannot be changed, which means that if you base it on the company name, e.g. the first letters of the company name, you will not be able to change the ID if the company changes name. It is therefore best to construct the ID a different way or just use sequence numbers. You can search for the company using different terms, e.g. its name.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Distance | FtgAvstand | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xxavs Site distance per inventory loc


Site groups in package solution (JvsPackageSiteGroups)

Site groups included in a package solution.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allow settings/subgroups | JvsSiteAllowChangeSubGroups | ztBoolean |  |  | char
Group ID | JvsSiteGroupId | ZtLong | 6 |  | int
ID of SiteRepository | JvsSiteID | ZtLong | 10 |  | int
Unique package ID | JvsSitePackageUniqueId | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Solution ID | SolutionID | ZtLong | 10 |  | int


Site Language VIEW (vJvsSiteLang)

Language code.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Language | JvsSiteLangID | ztInteger | 5 |  | int
Text | JvsSiteLangString | ztString | 7500 |  | nvarchar
TextID | JvsSiteTextID | ztString | 40 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Site repository databases (vsrd)

If there is more than one company in the same directory, you can have a number of site repositories in different databases.
A site repository contains settings/adaptations of windows and reports.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Replication from DB | MarkIfReplFromSiteRep |  |  |  | @DataType=NULL
Replication to DB | MarkIfReplToSiteRep |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL
Site repository database | SiteRepDataBase |  |  |  | @DataType=NULL


Site repository import log (JvsSite_Import_Log)

SIte repository import log header, including a row for each site repository import attempt.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
JvsSite Import LogId | JvsSiteImportLogId | ZtLong | 10 |  | int
Unique ID | JvsSiteUniqueID | ztString | 40 |  | nvarchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SQL statement | SQLStmtStr | ztBlob | 1 |  | varchar


Site repository import, deleted rows (JvsSite_chk_import_deleted_rows)

Name of database object as defined in the Added/modified objects program (usrdefmodsqlobject).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Object name | DB_Object_Name |  |  |  | @DataType=NULL
No of rows | NoOfRows |  |  |  | @DataType=NULL


Site repository import, inserted rows (JvsSite_chk_import_inserted_rows)

Name of database object as defined in the Added/modified objects program (usrdefmodsqlobject).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Object name | DB_Object_Name |  |  |  | @DataType=NULL
No of rows | NoOfRows |  |  |  | @DataType=NULL


Siterepository replication (srdb)

Multi-companies with different site repository databases.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Replication from DB | MarkIfReplFromSiterep | ztBoolean |  |  | varchar
Replication to DB | MarkIfReplToSiterep | ztBoolean |  |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Site repository database | SiterepDatabase | ztString | 120 |  | varchar

    This table is the main table in the following programs:

    Program: srdb Site repository replication

    Program: xsrdb Site repository replication


Sites in package solution (JvsPackageSites)

Sites included in a package solution.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
ID of SiteRepository | JvsSiteID | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Database of Site | SiteDB | ztString | 60 |  | varchar
Password in Site | SitePwd | ztString | 60 |  | varchar
Server of Site | SiteServer | ztString | 60 |  | varchar
User in Site | SiteUser | ztString | 60 |  | varchar
Solution ID | SolutionID | ZtLong | 10 |  | int


SKU (WMS_V_EXT_SKU)

Pkg identity.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
FIFO date | FifoDateTime | ztDateTime |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
X Pos. | LocXPos | ztString | 5 |  | varchar
Y Pos. | LocYPos | ztString | 5 |  | varchar
MHA | Mha | ztString | 5 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Sequence number | PalletContSeq | ztInteger | 3 |  | smallint
ID | PalletId | ztString | 35 |  | varchar
Type | PalletTypeCode | ztInteger | 3 |  | smallint
Parent ID | ParentPalletId | ztString | 35 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Rack | Rack | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Qty, SKU | SKUQty | ZtQty | 14 | 2 | decimal
Date/time | StrDateTime | ztString | 28 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_EXT_SKU SKU


SKU (WMS_V_SKU)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Use/Best before | bastforedatum | ztDate |  |  | datetime
Batch no. | BatchId | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
FIFO date | FifoDateTime | ztDateTime |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
X Pos. | LocXPos | ztString | 5 |  | varchar
Y Pos. | LocYPos | ztString | 5 |  | varchar
MHA | Mha | ztString | 5 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Availability | PalletAvailCode | ztInteger | 3 |  | smallint
Sequence number | PalletContSeq | ztInteger | 3 |  | smallint
Created | PalletCreateDateTime | ztDateTime |  |  | datetime
ID | PalletId | ztString | 35 |  | varchar
Reason code | PalletSKUCreateReasonCode | ztInteger | 3 |  | smallint
Status, SKU | PalletSKUStatusCode | ztInteger | 3 |  | smallint
Type | PalletTypeCode | ztInteger | 3 |  | smallint
Pallet unit type | PalletUnitType | ztString | 5 |  | varchar
Parent ID | ParentPalletId | ztString | 35 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Pick before date | PickBeforeDateTime | ztDate |  |  | datetime
Rack | Rack | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Cycle count date | SKUCycleCountDateTime | ztDateTime |  |  | datetime
Delivered qty, SKU | SKUDelQty | ZtQty | 14 | 2 | decimal
Qty, SKU | SKUQty | ZtQty | 14 | 2 | decimal
Date/time | StrDateTime | ztString | 28 |  | varchar
Unit code | UOM | ztString | 10 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_SKU SKU


SKU create reason code (WMS_PalletSKUCreateReasonCode)

NULL

The following standard records exist. Do not alter/delete:

Reason code (PalletSKUCreateReasonCode) | PalletCreateReasonDesc (PalletCreateReasonDesc)
100 | Receiving
101 | Manually
102 | Split

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Description | PalletCreateReasonDesc | ztString | 50 |  | varchar
Reason code | PalletSKUCreateReasonCode | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_PalletSKUCreateReasonCode SKU create reason code


SKU status code (WMS_PalletSkuStatusCode)

Code for package status. Specifies status for package.

The following standard records exist. Do not alter/delete:

Status (PalletStatusCode) | Description (PalletStatusDesc) | Description
100 | Stored | SKU is stored
120 | Empty | SKU is empty

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Status | PalletStatusCode | ztInteger | 3 |  | smallint
Description | PalletStatusDesc | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_PalletSKUStatusCode SKU status code


Sort order for maintance attendance (AttR_SortOrder)

Here you define the sort order in the program where you maintenance your time reports. The field names must be in the table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sort order | SFRORderby | ztInteger | 5 |  | smallint
Order by definition | SFRORderByDef | ztString | 1000 |  | varchar
Order by description | SFROrderbydescr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: AttR_SortOrder Sort order, attendance reporting


Sort order in Shop floor reporting (SFR_SortOrder)

Sort order for the operation queue in Shop floor control. The field names must be in the table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sort order | SFROrderBy | ztInteger | 5 |  | smallint
Order by definition | sfrorderbydef | ztString | 1000 |  | varchar
Order by description | SFROrderByDescr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: SFR_SortOrder Sort order, shop floor reporting


Sorting in reports (JvsSiteRepSort)

Program/table for viewing and editing settings regarding sorting in reports. Please note that this does not function for reports based on results from database procedures, e.g. interest batches, but there are only a few reports like this. It is also not suitable for reports which create groupings and subtotals. Example: if a report is normally sorted and subtotaled per customer number, the result will be incorrect if you choose a different sorting for the report.

Sorting is specified per report program and main table.

The terms found in print templates (frames and windows) do not correspond to retrieval of data from the database and therefore these cannot be used. However, there are "nodes" in the reports and there is a main table in every such node.

Example:

Order acknowledgement has a node for order headers where the main table is the order header table (oh) and another for the order rows where the main table is the order row table (orp).

By specifying a sort order on the order header table, the order acknowledgement is printed in the customized sort order.

By specifying a sort order on the order row table, the order rows within an order acknowledgement are printed in the customized sort order.

The sorting setting can be applied globally for all users (group 9999 and user *), applied to an individual group (specified group and user *) or applied to an individual user (specified signature and group 9999).

You can link the in-house defined sorting to a specific print template and in this way get different sortings depending on the template used.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Group | JvsSiteForGrp | ZtLong | 6 |  | int
Signature | JvsSiteForUser | ztString | 6 |  | nvarchar
Setting, order by | JvsSiteOrderByStmt | ztString | 255 |  | nvarchar
Settings for report | JvsSiteReportName | ztString | 40 |  | nvarchar
Report template | JvsSiteReportTemplate | ztString | 60 |  | nvarchar
Table | JvsSiteTableName | ztString | 40 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteRepSort Sorting in reports


Source table, details (std)

Definition of the source table's (external system file) appearance on conversion of external data to Jeeves record standard.

Here you define the terms, term parts, term combinations and/or term combinations that will form fields in the Jeeves record, or are necessary to describe the conditions for if a record will be created or not. You enter the term's name and value type, e.g. digit or character field.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
DB-term/-expression 2 | DbTermname2 | ztString | 255 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Definition | kdefine | ztString | 60 |  | varchar
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Value term table | VardeTabId1 | ztString | 255 |  | varchar
Value type | VardeTermT | ztInteger | 3 |  | smallint


Source table, header (sth)

In the table the name of the conversion description and which database it applies to are stored.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Value term table | VardeTabId1 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: sth Definition conversion

    Program: sthv Display definition conversion


Source table, parameters (sthp)

The last specified values for variables (batch parameters) during a conversion batch which are suggested as default values at the next conversion batch are stored here.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
DB-term/-expression 1 | DbTermName1 | ztString | 120 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Default | KonvDefault | ztString | 60 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Value term table | VardeTabId1 | ztString | 255 |  | varchar


Source to target table, details (BTran2GLDefStepDetail)

Definition of columns in the target table in conversion and definition of rules for how the columns are created.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
ID | BTran2GLDefId | ztString | 10 |  | varchar
Source, column | BTran2GLDefSourceColumn | ztString | 40 |  | varchar
Sent column | BTran2GLDefSourceColumnDescr | ztString | 40 |  | varchar
Source, column | BTran2GLDefSourceColumnWrk | ztString | 40 |  | varchar
Step in conversion | BTran2GLDefStepNo | ZtLong | 10 |  | int
Receiving column | BTran2GLDefTargetColumn | ztString | 40 |  | varchar
SQL expression sender | BTran2GLSourceExpr | ztString | 255 |  | varchar
Default value | BTran2GLTargetDefault | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Translation table | KTabell | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence | Sequence | ztInteger | 3 |  | smallint


Source VAT/tax declaration details (BE_Vat_Amt)

Results of calculations for VAT/tax declarations produced in the Periods (perbe) program using the Create VAT/tax declaration basis button.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Amount excl VAT/tax | AmountExclVAT | ZtBaseCurrAmount | 14 | 2 | money
Amount incl VAT/tax | AmountinclVAT | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax amount | AmountVAT | ZtBaseCurrAmount | 14 | 2 | money
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
Customer category | KundKategorikod | ztInteger | 2 |  | smallint
Supplier category | LevKategori | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax box | VATBox | ztString | 5 |  | varchar
Box sign | VATBoxSign | ztString | 5 |  | varchar
Amount | VATReportAmount | ztMoney | 14 | 2 | money
VAT/tax report number | VATReportNo | ZtLong | 9 |  | int
VAT/tax stmt status | VATStatus | ztString | 1 |  | varchar
Tax period | VATTaxPeriod | ztInteger | 2 |  | smallint
VAT/tax trans type | VATTransactionType | ztString | 5 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: BE_VAT_Amt Source VAT/tax declaration details


Source VAT/tax declaration totals (BE_VAT_Total)

Results of calculations for VAT/tax declarations produced in the Periods (perbe) program using the Create VAT/tax declaration basis button.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Amount excl VAT/tax | AmountExclVAT | ZtBaseCurrAmount | 14 | 2 | money
Amount incl VAT/tax | AmountInclVAT | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax amount | AmountVAT | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
VAT/tax box | VATBox | ztString | 5 |  | varchar
Amount | VATReportAmount | ztMoney | 14 | 2 | money
VAT/tax report number | VATReportNo | ZtLong | 9 |  | int
VAT/tax stmt status | VATStatus | ztString | 1 |  | varchar
Tax period | VATTaxPeriod | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: BE_VAT_Total Source VAT/tax declaration totals


Sources, fixed assets (xak)

Table of possible fixed assets sources.

The following standard records exist. Do not alter/delete:

Fixed asset source (invsource) | invsourceB (invsourceB)
0 | Manual entry
10 | Purchasing routine

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Fixed asset source | invsource | ztInteger | 2 |  | smallint
Anl. ursprung | invsourceB | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: Pxak Sources, fixed assets


Special interest rate, interest invoicing (xrsi)

Interest rates that apply instead of the usual interest rates in interest invoicing after the number of days specified with the parameter ACCREC017. If ACCREC017 is set to 0 then only the usual interest rate is used.

The function CANNOT be used if interest calculation is performed according to the balance method. No interest rates are defined on delivery.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Interest rate chg date | RtaDatum | ztDate |  |  | datetime
Interest, loans/debit | RtaUtProcent | ZtDecimal73 | 6 | 2 | decimal

    This table is the main table in the following programs:

    Program: xrsi Special interest rate, interest invoicing


Specifications, details (rbbd)

Table of details in respect of specifications in reports.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Specification/sub-report | DecDefId | ztString | 6 |  | varchar
Sub-term | DecTerm | ztString | 32 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Number of characters | LengdTerm | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Specification | SpecDefId | ztString | 6 |  | varchar
Start position | StartPosTerm | ztInteger | 4 |  | smallint


Specifications, header (rbbh)

Main table for specifications in reports.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Specification/sub-report | DecDefBeskr | ztString | 60 |  | varchar
Specification/sub-report | DecDefId | ztString | 6 |  | varchar
Value table, sub-report | DecDefTable | ztString | 40 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Print sum row after | PrintSpecRowPost | ztInteger | 5 |  | smallint
Print sum row before | PrintSpecRowPre | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Specification | SpecDefId | ztString | 6 |  | varchar

    This table is the main table in the following programs:

    Program: xRbbh Specifications


Specifications, sum row after (xrso)

Edit sum row after Table of printout alternatives for a sum row that lies after (below) the records contained in a specification.

The following standard records exist. Do not alter/delete:

Print sum row after (PrintSpecRowPost) | Print sum row after (PrintSpecRowPostBeskr) | Description
0 | Text and total | Both the name of the main term that the specification refers to and its subtotal will be printed on a row after the specification.
1 | Text only | Only the name of the main term that the specification refers to will be printed on a row after the specification.
2 | No text or total | No total row will be printed after the specification.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Print sum row after | PrintSpecRowPost | ztInteger | 5 |  | smallint
Print sum row after | PrintSpecRowPostBeskr | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xrso Sum row after specification


Specifications, sum row before (xrsp)

Edit sum row after Table of printout alternatives for a sum row that lies before (above) the records contained in a specification.

The following standard records exist. Do not alter/delete:

Print sum row before (PrintSpecRowPre) | Print sum row before (PrintSpecRowPreBeskr) | Description
0 | Text and total | Both the name of the main term that the specification refers to and its subtotal will be printed on a row before the specification.
1 | Text only | Only the name of the main term that the specification refers to will be printed on a row before the specification.
2 | No text or total | No total row will be printed before the specification.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Print sum row before | PrintSpecRowPre | ztInteger | 5 |  | smallint
Print sum row before | PrintSpecRowPreBeskr | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xrsp Sum row before specification


SQL scripts in package solution (JvsPackageScripts)

Scripts that are executed at package import. The scripts can either be executed before or after the import of a package and are mainly used by the Jeeves installation program.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Description | ztString | 255 |  | varchar
Execution Point | ExecPoint | ztInteger | 5 |  | smallint
@zPrompt=null | idno | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Solution ID | SolutionID | ZtLong | 10 |  | int
SQL statement | SQLStmtStr | ztBlob | 1 |  | varchar
Use in Site | UseInSite | ztBoolean |  |  | char


SRU codes, details (srud)

Details, i.e. account interval(s) in the SRU code (Standardized accounts extract). See under the program Help/dedicated chapter for more information.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Version | accountversion | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
From account no. | FromKtoNr | ztString | 8 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SRU 1 | Sru1Nr | ztString | 6 |  | varchar
SRU 2 | Sru2Nr | ztString | 6 |  | varchar
To account no. | TomKtoNr | ztString | 8 |  | varchar


SRU codes, headers (sruh)

Table header indicating the group in the SRU code (Standardized accounts extract). See under the program Help/dedicated chapter for more information.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Version | accountversion | ztString | 50 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SRU 1 | Sru1Nr | ztString | 6 |  | varchar
SRU 2 | Sru2Nr | ztString | 6 |  | varchar
SRU 3 | Sru3Nr | ztString | 6 |  | varchar
Description | SruBeskrivning | ztString | 60 |  | varchar

    This table is the main table in the following programs:

    Program: Sru SRU codes


Standard price, header (xcp)

Data in the standard price header.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
List price table | CaPrisTabBeskr | ztString | 30 |  | varchar
List price table | CaPrisTabKod | ztString | 6 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxcp List price table


Standard responses, campaigns (Krs)

Definition of standardized response choices to make the entry of responses and following up more structured and easier to do.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Responses | KampSvarsBeskr | ztString | 60 |  | varchar
Responses | KampSvarsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xkrs Standard responses, campaigns


Start record, eBrev (ebsp)

Start record eBrev with communication information.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
File/dir | DokDir | ztString | 255 |  | varchar
Run procedure | eb_execprocedur | ztBoolean |  |  | char
Write to table | eb_jeevesfilexport | ztBoolean |  |  | char
Unique ID eBrev | eb_komm_id | ztInteger | 5 |  | smallint
Delivery node | ebAvlNod | ztString | 10 |  | varchar
External reference | ebExtRef | ztString | 7 |  | varchar
File type eBrev | ebFilTyp | ztString | 3 |  | varchar
Password eBrev | ebLosenOrd | ztString | 6 |  | varchar
Final record, eBrev | ebSLutPost | ztString | 4 |  | varchar
Start record eBrev | ebStartPost | ztString | 4 |  | varchar
Dispatch via entrance | ebViaEntren | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
FTP profile | FTPprofil | ztInteger | 5 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Create file | skapafil | ztBoolean |  |  | char
Send file by ftp | skickafil | ztBoolean |  |  | char
Value term table | vardetabid1 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xebsp Create and send eBrev


State / Province (Province)

Definition of states/provinces existing in some contries.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Country | landskod | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
State code | ProvinceCode | ztString | 5 |  | varchar
State description | ProvinceDescr | ztString | 50 |  | varchar
Short description | ProvinceShortDescr | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Province State / Province


Statistics item class period (sxmp)

Statistics for item class per year and period.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item class | ArtKod | ztInteger | 3 |  | smallint
Budgeted amount | Budgbelopp | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Per invoiced amt | PerFaktBel | ZtBaseCurrAmount | 14 | 2 | money
CSG | PerFaktRadKost | ZtBaseCurrAmount | 14 | 2 | money
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: sxmp Item class statistics


Status BOE (vxst)

Internal definitions of the statuses that can be given to a bill of exchange.

The following standard records exist. Do not alter/delete:

BOE status (BOE_Status) | Description (BoE_Status_Desc) | Description
0 | 0. Entered | Refers to BOE to suppliers only. The BOE has this preliminary status when the BOE is printed from the outgoing payment program but is not yet updated to the General Ledger.
2 | 2. Prel. paid | Refers to both BOE from customers and BOE to suppliers. The BOE is updated in the BOE ledger in connection with creating the ingoing/outgoing payment journal and integrating with the general ledger.
3 | 3. Collected | Refers to BOE from customers only. The BOE is given this status when a collection journal has been run, implying that the BOE has been sent for encashment or discounting.
4 | 4. Paid | Refers to both BOE from customers and BOE to suppliers. The BOE is considered as paid. The bank account has been posted.
9 | 9. Canceled | Refers to both BOE from customers and BOE to suppliers. The BOE is canceled with reversal of posting against a BOE.
-1 | To be accepted | Refers to BOE from customers only. The BOE is included in a BOE acceptance journal, but acceptance has not yet been received/entered.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
BOE status | BOE_Status | ztInteger | 5 |  | smallint
Description | BoE_Status_Desc | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: vxst Bill of exchange status codes


Status change log of item group for item (arvls)

Code to mark update status.
0 = update to be done later
1 = during updating
5 = update completed
9 = update canceled (need not be done)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Update status | UpdateStatus | ztInteger | 5 |  | smallint
Update status | UpdateStatusDescr | ztString | 80 |  | varchar

    This table is the main table in the following programs:

    Program: arvls Status change/log item group for item


Status codes calculating SFR (SFR_statuscd)

Used internal for time calculation of production reports.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Status code | sfrstatuscode | ztInteger | 5 |  | smallint
Description | SFRStatuscodedescr | ztString | 30 |  | varchar


Status codes for EDI job queue (xed6)

This system table contains descriptions of different status codes that may be applied to records in the job queue.

The following standard records exist. Do not alter/delete:

Status (EdiJobStatus) | Job status (EdiJobStatDescr)
0 | Placed in a queue Not started
10 | Sent to EDI-server
20 | Started by EDI server
30 | Performed by EDI server
40 | Canceled by EDI server
99 | Error occurred while running

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Job status | EdiJobStatDescr | ztString | 50 |  | varchar
Status | EdiJobStatus | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xed6 Status codes, EDI job queue


Status codes for packages (details) (xkos)

This system table contains descriptions of different status codes that may be on package records in the job queue.

The following standard records exist. Do not alter/delete:

Package status (KolliStatus) | Package status (KolliStatusDescr)
10 | Unpacked
20 | Packing in progress
30 | Packed
40 | Left factory

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Package status | KolliStatus | ztInteger | 2 |  | smallint
Package status | KolliStatusDescr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xkos Status codes for packages (details)


Status codes for picking list (xpjs)

Internal definitions of the statuses that can be set for picking lists.

The following standard records exist. Do not alter/delete:

Picking list status (plockjnrstat) | Picking list status (plockjnrstatbeskr)
0 | Created
10 | Transferred to external system
20 | Reporting in progress
70 | Closed
90 | Canceled

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Picking list status | plockjnrstat | ztInteger | 5 |  | smallint
Picking list status | plockjnrstatbeskr | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xpjs Status codes for picking list


Status codes, avail check of cust order (xbsl)

A table containing the status codes which a customer order row can receive for availability check against physical balance (warehouse - dispatches) on delivery day.

The following standard records exist. Do not alter/delete:

Avail status (invtry-out) (BristStatusLagerUtlev) | Avail status (invtry-out) (BristStatusLagerUtlevBeskr)
0 | Not checked
40 | Shortage in inventory
100 | OK

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Avail status (invtry-out) | BristStatusLagerUtlev | ztInteger | 5 |  | smallint
Avail status (invtry-out) | BristStatusLagerUtlevBeskr | ztString | 80 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xbsl Status codes, avail check of cust order


Status codes, batches (xba)

Definition of the status codes that can be allocated to batches, i.e. individual received deliveries to the inventory.

You use the status to determine whether it is permitted to book and/or use (pick) the items within each batch. When taking Jeeves into operation, you can change the default descriptions and settings and you can enter new status codes for required combinations of ‘Booking allowed’ and ‘Picking allowed’.

The following standard records exist. Do not alter/delete:

Batch status (BatchStatusKod) | Batch status (BatchStatusBeskr) | Description
0 | Checked, OK to use | As a default setting in Jeeves, this status means that you can book and pick the batch.
5 | Not OK | As a default setting in Jeeves, this status means that you can NOT book or pick the batch.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Booking allowed | BatchOkToBook | ztBoolean |  |  | char
Picking allowed | BatchOkToUse | ztBoolean |  |  | char
Batch status | BatchStatusBeskr | ztString | 50 |  | varchar
Batch status | BatchStatusKod | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Included in available balance | InclInAvailInvtBal | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xXba Status codes, batches


Status codes, inc pmt receipt details (xKrd)

Definition of the status codes automatically set on invoices during import of paid customer invoices from the bank giro and plus giro via the Import external data->work table program (vsthi). The status code shows the result during import on each individual invoice.

The following standard records exist. Do not alter/delete:

Status code pmt detail (KrkdStatus) | Status code pmt detail (KrkdStatusBeskr)
0 | Loaded
10 | Customer not found
20 | Invoice not found
25 | Invoice in progress
30 | Wrong customer on invoice
35 | Invoice date > Payment date
36 | Incorrect incoming payment date
40 | Already paid
70 | Invoice not posted
81 | No coverage
82 | AutoGiro connection not found
84 | Not used, admission missing
85 | Not used, bank account nr. missing in BG
86 | Not used, bank account nr. unreg in Hreg
87 | The sum exceeds max limit
88 | Denied, still not chargeable
89 | New coverage
100 | Wrong amount
110 | Already paid/On account invoice created
120 | Payment against credit invoice
130 | Reference code 1. Ref. field is empty
140 | Bank costs
150 | Payed with no/err reference
160 | OK with another integration source
170 | Zero amount
180 | Paid in another currency
190 | Reference code 5. Ref.field not valid
200 | Payment surplus
900 | Transferred

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Status code pmt detail | KrkdStatus | ztInteger | 5 |  | smallint
Status code pmt detail | KrkdStatusBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xkrd Status codes, inc pmt receipt details


Status codes, outg pmt receipt details (xlrd)

Definition of the status codes automatically set on invoices during import of paid supplier invoices from the bank giro and plus giro via the Import external data->work table program (vsthi). The status code shows the result during import on each individual invoice.

The following standard records exist. Do not alter/delete:

Receipt status (LrkdStatus) | Receipt status (LrkdStatusBeskr)
0 | Created
10 | Supplier not found
20 | Invoice not found
30 | Wrong supplier for invoice
40 | Already paid
50 | Already loaded
100 | Amount not correct
160 | OK med annan integrationskälla
900 | OK

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Receipt status | LrkdStatus | ztInteger | 5 |  | smallint
Receipt status | LrkdStatusBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xlrd Status codes, outg pmt receipt details


Status codes, serial no. items (xst)

Definition of status codes and descriptions to specify the status of serial no. items, as required.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Serial no. item status | ArtSerst | ztInteger | 5 |  | smallint
Serial no. item status | ArtSerStatbeskr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xst Status codes, serial no. items


Status for variant order rows (PvmStatus)

Numerical code for status of variant order row. Can be manually changed if you need to cancel a row.

The following standard records exist. Do not alter/delete:

Status (PvmStatus) | Status (PvmStatusDescr)
1 | Active
2 | Cancelled

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Status | PvmStatus | ztInteger | 3 |  | smallint
Status | PvmStatusDescr | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: PvmStatus Status for variant order rows


Status input table #1 (xin1)

Status code on rows in a "dummy input table".
The WIN1 table is a dummy input table and has no function in Jeeves. The customer may use the table as they wish.
The idea is however that the table should be used for loading orders, invoices, etc. from other systems.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Input status | Xin1Status | ztInteger | 5 |  | smallint
Input status | Xin1StatusBeskr | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: xin1 External input, status


Status of shipment plans (ShipmPlanStatus)

Definition of status codes for shipment plans for the WMS module. Information about the current status is shown on the shipment plan.

The following standard records exist. Do not alter/delete:

Shipment plan status (ShipmPlanStatus) | Shipment plan status (ShipmPlanStatusDescr)
0 | No orders connected
10 | Orders connected
20 | Released for picking
30 | Picked
40 | Packed
90 | Closed

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Shipment plan status | ShipmPlanStatus | ztInteger | 2 |  | smallint
Shipment plan status | ShipmPlanStatusDescr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: ShipmentPlanStatus Status of shipment plans


Status of tranfer to Logtrade (LogtradeStatus)

Status of transfer to Logtrade.

The following standard records exist. Do not alter/delete:

Status (LogtradeStatus) | Status descr (LogtradeStatusDescr)
10 | New
20 | Transfer in progress
30 | Transfer complete
99 | Transfer failed
-1 | Error. No contact with Logtrade

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Status | LogtradeStatus | ztInteger | 5 |  | smallint
Status descr | LogtradeStatusDescr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: LogtradeStatus Status of tranfer to LogTrade


Status reported labour (xars)

Status codes that can be set on reported labour per person.

The following standard records exist. Do not alter/delete:

Status reported labour (AoruStatus) | Status reported labour (AoruStatusBeskr)
0 | OK
200 | Could not calculate time

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Status reported labour | AoruStatus | ztInteger | 5 |  | smallint
Status reported labour | AoruStatusBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xars Status reported labour


Status time report (tids)

Status code on time report.

0 - Active
5 - Ready 10 = Approved

If the time report (tidr) is marked with a status code, the time row will not be able to be invoiced variable status code=10 (Approved).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Status | Tidrappstatkd | ztInteger | 2 |  | smallint
Status description | Tidrappstatkdbeskr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: tids Status codes, time report


Status, entry journal (x2j)

Definition of the different statuses that an entry journal can be given.

The following standard records exist. Do not alter/delete:

Journal status (JournalStatusKod) | Journal status (JournalStatusBeskr) | Description
0 | Entry in progress | Transactions can only be entered if the journal’s status is Entry in progress.
3 | Can be flagged Ready | For entry journals in the inventory module this status is set manually when needed. For entry journals in the fixed assets module this status is set automatically when printing transactions.
5 | Ready | Journal can only be integrated with the general ledger if its status is flagged ready.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Journal status | JournalStatusBeskr | ztString | 50 |  | varchar
Journal status | JournalStatusKod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: x2j Status, entry journal


Storage location (WMS_V_LocStore)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod |  |  |  | @DataType=NULL
Frequency | Frequence |  |  |  | @DataType=NULL
Inventory location | LagStalle |  |  |  | @DataType=NULL
Max no. pallets | LocPallMax |  |  |  | @DataType=NULL
Assignment qty | LocStoreAssQty |  |  |  | @DataType=NULL
Pallet qty | LocStorePallQty |  |  |  | @DataType=NULL
Location type | LocType |  |  |  | @DataType=NULL
X Pos. | LocXPos |  |  |  | @DataType=NULL
Y Pos. | LocYPos |  |  |  | @DataType=NULL
MHA | Mha |  |  |  | @DataType=NULL
Rack | Rack |  |  |  | @DataType=NULL


Storage type code (WMS_StorageTypeCode)

The type of MHA in which this unit of measure is stored.

The following standard records exist. Do not alter/delete:

Storage type (StorageTypeCode) | Description (StorageTypeDesc) | Description
10 | Pick | Defines where the unit of measure of the item in question is picked. Pick assignments are only generated for storage types Pick and Pick/Buffer.
20 | Buffer | Defines the buffer area for the unit of measure of the item in question.
30 | Pick/Buffer | Defines the buffer area and where the unit of measure of the item in question is picked. Pick assignments are only generated for storage types Pick and Pick/Buffer.
100 | External | Defines where the unit of measure of the item in question is stored externally.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Storage type | StorageTypeCode | ztInteger | 3 |  | smallint
Description | StorageTypeDesc | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_StorageTypeCode Storage type code


Storage type code (WMS_V_StorageTypeCode)

The type of MHA in which this unit of measure is stored.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Storage type | StorageTypeCode | ztInteger | 3 |  | smallint
Description | StorageTypeDesc | ztString | 50 |  | varchar


Stored procedure log (espl)

Log of internal system data.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cancel | Makulerad | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Procedure | StoredProcedure | ztString | 120 |  | varchar
Date/time | StrDateTime | ztString | 28 |  | varchar


Structures price calculation package (help table) (srps)

A help table for price calculation of package configuration.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
BOM level | ArtNivaBeskr | ztString | 20 |  | varchar
Item no. | ArtNr | ztString | 30 |  | varchar
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Item no. (BOM) | BArtnrStrukt | ztString | 30 |  | varchar
Figure no. | BFigNr | ztString | 6 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Sequence no. | LopNr | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence number | SrDummyUniqueID | ztUniqueIdentifier | 38 |  | varchar


Sts codes for plan short. plan. del. dte (xpsp)

Table containing the status codes which a customer order row can receive for planning check against a theoretical balance (warehouse - dispatches + confirmed deliveries) on the planned dispatch day.

The following standard records exist. Do not alter/delete:

Availability status (plan/req) (BristStatusPlaneringBerLevDat) | Availability status (plan/req) (BristStatusPlaneringBerLevDatBeskr)
0 | Not checked
40 | Shortage in planned balance on planned delivery date
100 | OK

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Availability status (plan/req) | BristStatusPlaneringBerLevDat | ztInteger | 5 |  | smallint
Availability status (plan/req) | BristStatusPlaneringBerLevDatBeskr | ztString | 80 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xpsp Status codes, plan. check of cust. order


Sts codes for plan short. req. del. date (xpso)

Table containing the status codes which a customer order row can receive for planning check against a theoretical balance (warehouse - dispatches + confirmed deliveries) on the dispatch day requested by the customer.

The following standard records exist. Do not alter/delete:

Availability status (plan/req) (BristStatusPlaneringBegLevDat) | Availability status (plan/req) (BristStatusPlaneringBegLevDatBeskr)
0 | Not checked
40 | Shortage in planned balance on requested delivery date
100 | OK

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Availability status (plan/req) | BristStatusPlaneringBegLevDat | ztInteger | 5 |  | smallint
Availability status (plan/req) | BristStatusPlaneringBegLevDatBeskr | ztString | 80 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xpso Status codes, plan. check of cust. order


Sub rows from bank file (krkb)

Contains loaded bank file row for row.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Pmt receipt journal no. | InbKvittensJournNr | ZtLong | 10 |  | int
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Löpnummer | RadNummer | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Text/info | x255 | ztString | 255 |  | varchar


Sub tags in package solution (JvsPackageSubTags)

Sub tags included in a package solution, identifying package solution specific modifications to triggers and procedures.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Name of Sub Tag | DB_Sub_TagName | ztString | 128 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Solution ID | SolutionID | ZtLong | 10 |  | int


Sub-categories, campaign type (xgk1)

Definition of own sub-categories for campaigns.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Campaign category | KampKatBeskr1 | ztString | 60 |  | varchar
Campaign category | KampKatKod1 | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xxgk1 Campaign categories


Sub-document rows (vpdw)

View applicable to document structures constructed according to the following principles:
document header without file link but with business data link & document rows with file link without business data link

Each row in the view shows file pointers from document rows and business data from the document header.
In this way, document rows are obtained with complete information about the document header.
Used for viewing scanned supplier invoices in Jeeves Viewer.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | aonr | Jeeves_MONo | 7 |  | bigint
Item no. | artnr | ztString | 30 |  | varchar
Supplier invoice no. | bestrkgnr | ztString | 25 |  | varchar
P D M consists of | bpdmdummy | ztString | 100 |  | varchar
Document type no. | documenttype | ZtLong | 5 |  | int
File/dir | dokdir | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | ftgkontaktnr | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Campaign | kampnr | ZtLong | 4 |  | int
Operation no. | opnr | ztInteger | 3 |  | int
Order no. | ordernr | Jeeves_SONo | 8 |  | bigint
PDM (Unique ID) | pdmdummyuniqueid | ztUniqueIdentifier | 100 |  | varchar
Document file path | pdmfilename | ztString | 250 |  | varchar
Sequence number | srdummyuniqueid | ztUniqueIdentifier | 38 |  | varchar
Checked out | utcheckad | ztBoolean |  |  | char


Suborder, mfg, BOM list (tis)

Bill of material on a manufacturing order.
Each suborder has a bill of materials. However, if fictitious items are included or items that are "dragged", a record is also created in this table for the item to which the bill of material belongs.
((Customer-specific function for revisions and blueprint changes by BOM)).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
MO/Works order status | AoStatKod | ztInteger | 1 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Revision date | ArtRevDat | ztDate |  |  | datetime
Revision no. | ArtRevId | ztString | 10 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Figure no. | BFigNr | ztString | 6 |  | varchar
BOM sequence number | BOMItemSeqNo | ZtLong | 10 |  | int
BOM sequence number (next) | BOMItemSeqNo_next | ZtLong | 10 |  | int
BOM sequence number (prev) | BOMItemSeqNo_prev | ZtLong | 10 |  | int
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Fictitious item | FiktivArtikel | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Sequence no. | LopNr | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos2 | ztInteger | 4 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
BOM for item | StycklistaTillArtNr | ztString | 30 |  | varchar
TimeGapInDaysToCurrItem | TimeGapInDaysToCurrItem | ztInteger | 5 |  | smallint
Ready date | TiSlutDat | ztDate |  |  | datetime
Start date | TiStartDat | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: tis Fictitious items, MO


Suborder, mfg, net requirements (tin)

A manufacturing order (header) can contain several suborders (this table) for the manufacturing of entirely different items or items with different delivery dates.
If there are 'logical/non stocked' items in a bill of materials, these are broken down one level further and create a new suborder.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Quantity | Antal | ZtQty | 14 | 2 | decimal
Quantity to manufacture | AntalAttTillverka | ZtQty | 14 | 2 | decimal
Decimal places | AntDec | ztInteger | 1 |  | smallint
MO type | AoKod | ztInteger | 2 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Final report date | AoSlutMarkDat | ztDate |  |  | datetime
MO/Works order status | AoStatKod | ztInteger | 1 |  | smallint
Original ops end date | AoUrsprSlutDat | ztDate |  |  | datetime
CalcCost labour/op | ArbKalkArbKost | ZtBaseCurrAmount | 14 | 2 | money
Calc setup cost | ArbKalkStallKost | ZtBaseCurrAmount | 14 | 2 | money
Actual labour cost | ArbVerklArbKost | ZtBaseCurrAmount | 14 | 2 | money
Actual setup cost | ArbVerklStallKost | ZtBaseCurrAmount | 14 | 2 | money
Item description | ArtBeskr | ztString | 30 |  | varchar
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
B-kostnad | ArtKalkBerB | ZtBaseCurrAmount | 14 | 2 | money
C-kostnad | ArtKalkBerC | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Cost price (actual) | ArtKalkprisE | ZtBaseCurrAmount | 14 | 2 | money
Cost price at order | ArtKalkprisO | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Revision date | ArtRevDat | ztDate |  |  | datetime
Revision no. | ArtRevId | ztString | 10 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Workload type | BelaggningsKod | ztInteger | 2 |  | smallint
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Purch order no. (alpha) | BestNrAlfa | ztString | 50 |  | varchar
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Accounting date | BokfDat | ztDate |  |  | datetime
Availability check date | BristKontrolleradDatum | ztDate |  |  | datetime
Avail check status code | BristKontrolleradStatus | ztInteger | 5 |  | smallint
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Körtid, skapa arbetsorder | ExecutionTimeCreateWO | ztFloat | 15 | 2 | float
Qty includes safety level | ExistsNeed4StockSafetyLevel | ztBoolean |  |  | char
Qty includes forecast | ExistsNeedFromPNEForcst | ztBoolean |  |  | char
Qty includes SO forecast | ExistsNeedFromSOForcst | ztBoolean |  |  | char
Qty includes SO and MO | ExistsNeedFromSOMO | ztBoolean |  |  | char
Actual fixed cost | FastVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Est delivery value | FkalkInlevVarde | ZtBaseCurrAmount | 14 | 2 | money
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Throughput time | GenomLoppsTid | ztFloat | 8 | 2 | float
Throughput time adj | GenomLoppsTidJust | ztFloat | 8 | 2 | float
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Receiving value | InlevKalkVarde | ZtBaseCurrAmount | 14 | 2 | money
Receive to MO | InlevTillAoNr | Jeeves_MONo | 7 |  | bigint
Receive to MO Pos | InlevTillAoPos | ztInteger | 4 |  | int
Receive to MO Op | InlevTillOpNr | ztInteger | 3 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
Calculation date | KalkBerDatum | ztDate |  |  | datetime
Buy manuf of item | KopTillvAvArtikel | ztBoolean |  |  | char
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
Note | KortNotering | ztString | 255 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Queue time | KoTid | ztFloat | 15 | 2 | float
Orderspec rcv CC | KstOULager | ztString | 8 |  | varchar
WIP CC | KstPIA | ztString | 8 |  | varchar
CC manufacturing diff | KstTillvDiff | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Orderspec rcv account | KtoNrOULager | ztString | 8 |  | varchar
WIP account | KtoNrPIA | ztString | 8 |  | varchar
Acct manufacturing diff | KtoNrTillvDiff | ztString | 8 |  | varchar
Stocked | LagerBokas | ztBoolean |  |  | char
Value to price | LagerVardeEnlInPris | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Lagerst för OU-lager | LagStalleOULager | ztString | 2 |  | varchar
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Manuf yield % | ManufYieldPercent | ZtDecimal73 | 8 | 3 | decimal
Ord spec cost price | MarkOrderUniktKalkP | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
MO qty pre yield calc | MOQtyPreYieldCalc | ZtQty | 14 | 2 | decimal
Calc mtrl cost | MtrlKalkKost | ZtBaseCurrAmount | 14 | 2 | money
Actual material cost | MtrlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
MRP batch -> Sign/mgr | NE_PlanAnsv | ztString | 8 |  | varchar
MRP change type | NRP_Action | ztInteger | 5 |  | smallint
Change from date | NRP_FromDate | ztDate |  |  | datetime
Change from quantity | NRP_FromQty | ZtQty | 14 | 2 | decimal
Change proposal | NRP_Note | ztString | 255 |  | varchar
Change to date | NRP_ToDate | ztDate |  |  | datetime
Change to quantity | NRP_ToQty | ZtQty | 14 | 2 | decimal
Pick status | OkAttPlockaStatus | ztInteger | 5 |  | smallint
B quantity | OrdAntalB | ztFloat | 15 | 2 | float
C quantity | OrdAntalC | ztFloat | 15 | 2 | float
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Qty includes safety level | PercentNeed4StockSafetyLevel | ZtDecimal73 | 8 | 3 | decimal
Qty includes forecast | PercentNeedFromPNEForcst | ZtDecimal73 | 8 | 3 | decimal
Qty includes forecast | PercentNeedFromSOForcst | ZtDecimal73 | 8 | 3 | decimal
Qty includes forecast | PercentNeedFromSOMO | ZtDecimal73 | 8 | 3 | decimal
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project manager | PersSign1 | ztString | 6 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Pick order | PlockOrder | ztBoolean |  |  | char
Project ID | ProjCode | ztString | 10 |  | varchar
Qty for safety stock level | QtyNeed4StockSafetyLevel | ZtQty | 14 | 2 | decimal
Qty from forecast | QtyNeedFromPNEForcst | ZtQty | 14 | 2 | decimal
Qty from SO forecast | QtyNeedFromSOForcst | ZtQty | 14 | 2 | decimal
Qty existing needs | QtyNeedFromSOMO | ZtQty | 14 | 2 | decimal
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Act variable cost | RorlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Build-up of safety stock | SakLagUppByggnad | ZtQty | 14 | 2 | decimal
Joint purchase (allowed) | SamInKopMark | ztBoolean |  |  | char
Send: Delivered | SendDeliv | ztBoolean |  |  | char
Deliv notification date | SendDelivDoneDT | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Requisition | StrDateTimeBia | ztString | 28 |  | varchar
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Manufacturing journal | ThJournNr | ZtLong | 6 |  | int
Mfg cost diff | TillvVinst | ZtBaseCurrAmount | 14 | 2 | money
Start date before adjustment | TiMinStartDatOrig | ztDateTime |  |  | datetime
Mtrl/op created on | TiNedbrutenDatum | ztDateTime |  |  | datetime
Reported mfg qty | TiRappAnt | ZtQty | 14 | 2 | decimal
MO entry date | TiRegDat | ztDate |  |  | datetime
Remaining qty to manuf | TiRestAnt | ZtQty | 14 | 2 | decimal
Ready date | TiSlutDat | ztDate |  |  | datetime
Start date | TiStartDat | ztDate |  |  | datetime
Tillverkningstatus | TiStatKod | ztInteger | 1 |  | smallint
Reprint purch order | UtskrBestDokSkaGoras | ztBoolean |  |  | char
New PO print date | UtskrBestDokUtskrDT | ztDateTime |  |  | datetime
Print promised qty | UtskrDokLovAntal | ZtQty | 14 | 2 | decimal
Print promised disp date | UtskrDokLovLevDat | ztDate |  |  | datetime
Print promised price | UtskrDokLovPris | ZtSalesPrice | 12 | 2 | money
Print order acknowl | UtskrDokLovSkaGoras | ztBoolean |  |  | char
Print date new OA | UtskrDokLovUtskrDT | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar
Price, curr | Vb_Pris | ZtSalesPrice | 12 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: SrLa4 Assembly analysis, MRP proposal

    Program: xTin Manufacturing order, net requirements


Suborder, mfg, net requirements (view on table tin) (vtin)

A manufacturing order (header) can contain several suborders (this table) for the manufacturing of entirely different items or items with different delivery dates.
If there are 'logical/non stocked' items in a bill of materials, these are broken down one level further and create a new suborder.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Quantity | Antal | ZtQty | 14 | 2 | decimal
Quantity to manufacture | AntalAttTillverka | ZtQty | 14 | 2 | decimal
Decimal places | AntDec | ztInteger | 1 |  | smallint
MO type | AoKod | ztInteger | 2 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Final report date | AoSlutMarkDat | ztDate |  |  | datetime
MO/Works order status | AoStatKod | ztInteger | 1 |  | smallint
Original ops end date | AoUrsprSlutDat | ztDate |  |  | datetime
CalcCost labour/op | ArbKalkArbKost | ZtBaseCurrAmount | 14 | 2 | money
Calc setup cost | ArbKalkStallKost | ZtBaseCurrAmount | 14 | 2 | money
Actual labour cost | ArbVerklArbKost | ZtBaseCurrAmount | 14 | 2 | money
Actual setup cost | ArbVerklStallKost | ZtBaseCurrAmount | 14 | 2 | money
Item description | ArtBeskr | ztString | 30 |  | varchar
Gross weight kg | ArtBtotVikt | ZtDecimal73 | 15 | 4 | decimal
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
B-kostnad | ArtKalkBerB | ZtBaseCurrAmount | 14 | 2 | money
C-kostnad | ArtKalkBerC | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Cost price (actual) | ArtKalkprisE | ZtBaseCurrAmount | 14 | 2 | money
Cost price at order | ArtKalkprisO | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Revision date | ArtRevDat | ztDate |  |  | datetime
Revision no. | ArtRevId | ztString | 10 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Net weight kg | ArtVikt | ZtDecimal73 | 15 | 4 | decimal
Workload type | BelaggningsKod | ztInteger | 2 |  | smallint
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Purch order no. (alpha) | BestNrAlfa | ztString | 50 |  | varchar
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Accounting date | BokfDat | ztDate |  |  | datetime
Availability check date | BristKontrolleradDatum | ztDate |  |  | datetime
Avail check status code | BristKontrolleradStatus | ztInteger | 5 |  | smallint
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
Körtid, skapa arbetsorder | ExecutionTimeCreateWO | ztFloat | 15 | 2 | float
Actual fixed cost | FastVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Est delivery value | FkalkInlevVarde | ZtBaseCurrAmount | 14 | 2 | money
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Throughput time | GenomLoppsTid | ztFloat | 8 | 2 | float
Throughput time adj | GenomLoppsTidJust | ztFloat | 8 | 2 | float
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Receiving value | InlevKalkVarde | ZtBaseCurrAmount | 14 | 2 | money
Receive to MO | InlevTillAoNr | Jeeves_MONo | 7 |  | bigint
Receive to MO Pos | InlevTillAoPos | ztInteger | 4 |  | int
Receive to MO Op | InlevTillOpNr | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
Calculation date | KalkBerDatum | ztDate |  |  | datetime
Buy manuf of item | KopTillvAvArtikel | ztBoolean |  |  | char
Corr plan qty invtry unit | KorrAntalIn | ZtQty | 14 | 2 | decimal
Note | KortNotering | ztString | 255 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Queue time | KoTid | ztFloat | 15 | 2 | float
Orderspec rcv CC | KstOULager | ztString | 8 |  | varchar
WIP CC | KstPIA | ztString | 8 |  | varchar
CC manufacturing diff | KstTillvDiff | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Orderspec rcv account | KtoNrOULager | ztString | 8 |  | varchar
WIP account | KtoNrPIA | ztString | 8 |  | varchar
Acct manufacturing diff | KtoNrTillvDiff | ztString | 8 |  | varchar
Stocked | LagerBokas | ztBoolean |  |  | char
Value to price | LagerVardeEnlInPris | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Lagerst för OU-lager | LagStalleOULager | ztString | 2 |  | varchar
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Ord spec cost price | MarkOrderUniktKalkP | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
Calc mtrl cost | MtrlKalkKost | ZtBaseCurrAmount | 14 | 2 | money
Actual material cost | MtrlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
MRP batch -> Sign/mgr | NE_PlanAnsv | ztString | 8 |  | varchar
MRP change type | NRP_Action | ztInteger | 5 |  | smallint
Change from date | NRP_FromDate | ztDate |  |  | datetime
Change from quantity | NRP_FromQty | ZtQty | 14 | 2 | decimal
Change proposal | NRP_Note | ztString | 255 |  | varchar
Change to date | NRP_ToDate | ztDate |  |  | datetime
Change to quantity | NRP_ToQty | ZtQty | 14 | 2 | decimal
Pick status | OkAttPlockaStatus | ztInteger | 5 |  | smallint
B quantity | OrdAntalB | ztFloat | 15 | 2 | float
C quantity | OrdAntalC | ztFloat | 15 | 2 | float
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project manager | PersSign1 | ztString | 6 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Pick order | PlockOrder | ztBoolean |  |  | char
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Act variable cost | RorlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Build-up of safety stock | SakLagUppByggnad | ZtQty | 14 | 2 | decimal
Joint purchase (allowed) | SamInKopMark | ztBoolean |  |  | char
Send: Delivered | SendDeliv | ztBoolean |  |  | char
Deliv notification date | SendDelivDoneDT | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Requisition | StrDateTimeBia | ztString | 28 |  | varchar
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Manufacturing journal | ThJournNr | ZtLong | 6 |  | int
Mfg cost diff | TillvVinst | ZtBaseCurrAmount | 14 | 2 | money
Start date before adjustment | TiMinStartDatOrig | ztDateTime |  |  | datetime
Mtrl/op created on | TiNedbrutenDatum | ztDateTime |  |  | datetime
Reported mfg qty | TiRappAnt | ZtQty | 14 | 2 | decimal
MO entry date | TiRegDat | ztDate |  |  | datetime
Remaining qty to manuf | TiRestAnt | ZtQty | 14 | 2 | decimal
Ready date | TiSlutDat | ztDate |  |  | datetime
Start date | TiStartDat | ztDate |  |  | datetime
Tillverkningstatus | TiStatKod | ztInteger | 1 |  | smallint
Reprint purch order | UtskrBestDokSkaGoras | ztBoolean |  |  | char
New PO print date | UtskrBestDokUtskrDT | ztDateTime |  |  | datetime
Print promised qty | UtskrDokLovAntal | ZtQty | 14 | 2 | decimal
Print promised disp date | UtskrDokLovLevDat | ztDate |  |  | datetime
Print promised price | UtskrDokLovPris | ZtSalesPrice | 12 | 2 | money
Print order acknowl | UtskrDokLovSkaGoras | ztBoolean |  |  | char
Print date new OA | UtskrDokLovUtskrDT | ztDateTime |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar
Price, curr | Vb_Pris | ZtSalesPrice | 12 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: vtin Manufacturing order, net requirements


Subordinate (PraD)

Sequence number.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Sequence no. | LopNr | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Project manager | PersSign1 | ztString | 6 |  | varchar
Subordinate | PersSign6 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Subreport info, matrix output (MatrixResultSubReports)

Batch number in the report generator.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
WHERE | MatrixCalcWhereStmt | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Column no. | RpKolNr | ztInteger | 4 |  | smallint
Batch no. | RpKorNr | ZtLong | 5 |  | int
Partial report no | SubRepNo | ztInteger | 5 |  | smallint


Subreport, details (rbdd)

Details in respect of subreports in reports.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Specification/sub-report | DecDefId | ztString | 6 |  | varchar
Sub-term | DecTerm | ztString | 32 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Number of characters | LengdTerm | ztInteger | 4 |  | smallint
Row | RadPos | ZtLong | 10 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Start position | StartPosTerm | ztInteger | 4 |  | smallint


Subreports, header (rbdh)

Main table for subreports in reports.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Specification/sub-report | DecDefBeskr | ztString | 60 |  | varchar
Specification/sub-report | DecDefId | ztString | 6 |  | varchar
Value table, sub-report | DecDefTable | ztString | 40 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xRbdh Subreports


Subsystem codes, delivery notes (x1x)

Table of subsystem codes. This is used to identify in which subsystem a delivery note was created.

The following standard records exist. Do not alter/delete:

Subsystem (FfhInt) | Description (Beskrivning)
0 | Direct entry
1 | Purchasing
2 | MPC
3 | Service
4 | Orders
5 | MPC, subcontract

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
Subsystem | FfhInt | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xx1x Subsystem codes, delivery notes


Summary of salary types (UAttr_Sal)

View that is used for maintenance the time reports in the Attendance sub module.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Summary column1 | attrcol1 |  |  |  | @DataType=NULL
Summary column10 | attrcol10 |  |  |  | @DataType=NULL
Summary column11 | attrcol11 |  |  |  | @DataType=NULL
Summary column12 | attrcol12 |  |  |  | @DataType=NULL
Summary column13 | attrcol13 |  |  |  | @DataType=NULL
Summary column14 | attrcol14 |  |  |  | @DataType=NULL
Summary column15 | attrcol15 |  |  |  | @DataType=NULL
Summary column16 | attrcol16 |  |  |  | @DataType=NULL
Summary column17 | attrcol17 |  |  |  | @DataType=NULL
Summary column18 | attrcol18 |  |  |  | @DataType=NULL
Summary column19 | attrcol19 |  |  |  | @DataType=NULL
Summary column2 | attrcol2 |  |  |  | @DataType=NULL
Summary column20 | attrcol20 |  |  |  | @DataType=NULL
Summary column3 | attrcol3 |  |  |  | @DataType=NULL
Summary column4 | attrcol4 |  |  |  | @DataType=NULL
Summary column5 | attrcol5 |  |  |  | @DataType=NULL
Summary column6 | attrcol6 |  |  |  | @DataType=NULL
Summary column7 | attrcol7 |  |  |  | @DataType=NULL
Summary column8 | attrcol8 |  |  |  | @DataType=NULL
Summary column9 | attrcol9 |  |  |  | @DataType=NULL
No clocked time | AttrColNoTime |  |  |  | @DataType=NULL
Schedule time | attrcolscheduletime |  |  |  | @DataType=NULL
Day schedule | AttrDayschedule |  |  |  | @DataType=NULL
Schedule description | AttrDayscheduledescr |  |  |  | @DataType=NULL
Authorizied | AttrSalaryAuthorized |  |  |  | @DataType=NULL
Reporting changed | AttrSalaryChanged |  |  |  | @DataType=NULL
Salary date | AttrSalaryDat |  |  |  | @DataType=NULL
Reason text | AttrSalaryReasonText |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Employee ID | perssign2 |  |  |  | @DataType=NULL
Name | respnamn |  |  |  | @DataType=NULL


Summary records per tax depreciation types (inskAvsTypSum)

Summary records per tax depreciation types.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Year opening balance | AretsIngBalans | ZtBaseCurrAmount | 14 | 2 | money
Autocreated | AutoCreatedinskAvsTypSum | ztBoolean |  |  | char
Deprn journal status | avskjstatus | ztInteger | 2 |  | smallint
Depreciation journal | Avskrjournal | ZtLong | 5 |  | int
Tot recorded deprn YTD | AvSkrTotAr | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Year's acquisitions | inskAr | ZtBaseCurrAmount | 14 | 2 | money
Acq value tax year | inskar1 | ZtBaseCurrAmount | 14 | 2 | money
80% thereof = | InskAr1Ber | ZtBaseCurrAmount | 14 | 2 | money
Acq value prev year | inskar2 | ZtBaseCurrAmount | 14 | 2 | money
60% thereof = | InskAr2Ber | ZtBaseCurrAmount | 14 | 2 | money
Acq value prev year 2 | inskar3 | ZtBaseCurrAmount | 14 | 2 | money
40% thereof = | InskAr3Ber | ZtBaseCurrAmount | 14 | 2 | money
Acq value prev year 3 | inskar4 | ZtBaseCurrAmount | 14 | 2 | money
20% thereof = | InskAr4Ber | ZtBaseCurrAmount | 14 | 2 | money
Tax depreciation type | inskAvsTypid | ztInteger | 2 |  | smallint
New tax deprn | insknyh | ZtBaseCurrAmount | 14 | 2 | money
New tax deprn | insknyk | ZtBaseCurrAmount | 14 | 2 | money
70% of outst amount | InskSaH | ZtBaseCurrAmount | 14 | 2 | money
Remuneration received | insksald | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Max allowed deprn | maxavsh | ZtBaseCurrAmount | 14 | 2 | money
Max allowed deprn | maxavsk | ZtBaseCurrAmount | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax depreciation amount | TaxDeprAmount | ZtBaseCurrAmount | 14 | 2 | money
Tax depreciation amount | TaxDeprAmountK | ZtBaseCurrAmount | 14 | 2 | money


Summary report VAT/tax header (VATRepH)

Summary report VAT/tax header.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Report period | VATReportPeriod | ztString | 8 |  | varchar
Report status | VATReportStatus | ztString | 1 |  | varchar


Summary report VAT/tax rows (VATRepL)

Summary report VAT/tax rows.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
EU VAT/tax registration no. | EUMomsNr | ztString | 20 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S7 | K7 | ztString | 8 |  | varchar
Tax base amount | MomsGrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
VAT/tax code | VAtCode | ztString | 1 |  | varchar
Tax period | VATPeriod | ztString | 8 |  | varchar
Report period | VATReportPeriod | ztString | 8 |  | varchar
Report status | VATReportStatus | ztString | 1 |  | varchar
VAT/tax row | VATRow | ztInteger | 4 |  | smallint
VAT/tax used | VATUsed | ztString | 1 |  | varchar
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint


Supplier calc cost-% per Inventory loc (lecc)

Definition of cost percentages per Inventory location to be used when calculating standard/average cost price for a specific Supplier (table le), when functionality for cost price per Inventory location is active in the system.
Percentages can be definied for the following costs:
- Delivery cost (HemtKostnProc)
- Freight cost (FraktKostnProc) If a record is entered for an Inventory location in this table, the percentages defined will have priority over any percentages defined on the Supplier record (table le) itself.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight cost % | FraktKostnProc | ZtDecimal73 | 7 | 2 | decimal
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Delivery cost % | HemtKostnProc | ZtDecimal73 | 7 | 2 | decimal
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Lecc Supplier calc cost-% per inventory loc


Supplier categories (xlk)

Definition of supplier categories that can be used to group/classify suppliers. Using the supplier category you govern which approval status will be given to invoices from relevant suppliers - "Arrival entered" or "Final approval" - other status codes are set automatically by the system.

For suppliers with agreements, final posting can be done during arrival entry. A supplier category with approval status "Final approval" is then entered for these suppliers. Alternatively, you can specify the approval status "Final approval" for the supplier and specify a posting template.

Note that supplier categories are also used to manage posting of supplier invoices via posting templates. If a posting template is entered without a supplier category specified, category 0 is automatically used, which is why it must be entered in the table.

The following standard records exist. Do not alter/delete:

Supplier category (levkategori) | Supplier category (LevKatBeskr1)
0 | Domestic suppliers

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval status | AttestKod1 | ztInteger | 1 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Supplier category | LevKatBeskr1 | ztString | 50 |  | varchar
Supplier category | levkategori | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: xlk Supplier categories


Supplier delivery terms (xbv)

Definition of the dispatch terms that can be applied for purchase/order.

You can specify a default dispatch term in the program 'System file, own co.' (Sy) and/or for the supplier, but you can change the information on the purchase order/invoice.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Dispatch terms | BestLevVilkKd | ztInteger | 2 |  | smallint
Dispatch terms | BestlevVillkBskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Delivery cost % | Hemtkostnproc | ZtDecimal73 | 7 | 2 | decimal
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Intrastat, excl costs | IntStatKostExklKod | ztBoolean |  |  | char
Intrastat, delivery terms | IntStatLevVillkor | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xbv Delivery terms, purchases


Supplier evaluation (view) (vle9)

Here you can look at a supplier evaluation carried out and print the result.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Company name | FtgNamn | ztString | 36 |  | varchar
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Quality group | Kvalitetsklass | ztString | 20 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Revision date | RevDatum | ztDateTime |  |  | datetime
Value | TypVarde | ztFloat | 7 | 2 | float
Group value 1 | TypVarde1 | ztFloat | 7 | 2 | float
Group value 2 | TypVarde2 | ztFloat | 7 | 2 | float
Subtotal | TypVarde21 | ztFloat | 7 | 2 | int
Group value 3 | TypVarde3 | ztFloat | 7 | 2 | float
Group value > 3 | TypVardeGt3 | ztFloat | 7 | 2 | float

    This table is the main table in the following programs:

    Program: vle9 View supplier evaluation


Supplier evaluation groups (lebk)

Definition of desired groups for supplier evaluation with descriptions and limit values. Depending on the sum of the value of all group types included, the supplier is allocated one of these groups after a supplier evaluation is performed.

No records are defined on delivery.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quality group | KlassVarde | ztString | 20 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
To value | TomBed | ztFloat | 9 | 2 | float

    This table is the main table in the following programs:

    Program: lebk Supplier evaluation groups


Supplier evaluation history (lekh)

The history of completed quality classifications per supplier is created here.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Group type | KlassTyp | ztInteger | 3 |  | smallint
Quality group | KvalitetsKlass | ztString | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Revision date | RevDatum | ztDateTime |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Value | TypVarde | ztFloat | 7 | 2 | float
Text/info | x255 | ztString | 255 |  | varchar


Supplier invc hdr reconciliation (wlrw)

Work table for printing the results of the reconciliation of accounts receivable ledgers with the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Remaining to pay BCU | FaktRestBel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Interim cost centre | KstInterimsBokning | ztString | 8 |  | varchar
Balance sheet CC | KstReskSaldo | ztString | 8 |  | varchar
Clearing account | KtoNrInterimsBokning | ztString | 8 |  | varchar
Ledger acct | KtoNrReskSaldo | ztString | 8 |  | varchar
Invoice date | LevFaktDat | ztDate |  |  | datetime
Supplier category | LevKategori | ztInteger | 2 |  | smallint
Amt in interim acct | LrAvrKtoBel | ZtBaseCurrAmount | 14 | 2 | money
Arrival date | LrFaktAnkDat | ztDate |  |  | datetime
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar


Supplier invoice approval (vatt)

Supplier invoice approval.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval date | AttestDat | ztDate |  |  | datetime
Approval status | AttestKod1 | ztInteger | 1 |  | smallint
Approved by | AttestSign | ztString | 6 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Preliminary voucher | OldVerNr | Jeeves_VchrNo | 9 |  | bigint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint


Supplier invoice approval (Att)

Approvals (arrival and final approval) of supplier invoice.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval date | AttestDat | ztDate |  |  | datetime
Approval status | AttestKod1 | ztInteger | 1 |  | smallint
Approved by | AttestSign | ztString | 6 |  | varchar
VchrTxt/Appr | AttVerText | ztString | 60 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Journal date | bilagsdato | ztDate |  |  | datetime
Reserved in journal | BilagsMark | ztBoolean |  |  | char
Accounting date | BokfDat | ztDate |  |  | datetime
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Posting slip date | KontLappUtskr | ztDate |  |  | datetime
Supplier category | levkategori | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Preliminary voucher | OldVerNr | Jeeves_VchrNo | 9 |  | bigint
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Prel posting | PrelKonteras | ztBoolean |  |  | char
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Prel voucher no. | vernrp | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: att Final approval

    Program: FinalApproval Final approval

    Program: natt Final approval without posting


Supplier invoice status (xla)

Table of supplier invoice statuses that can be used to show if the invoice has been finally approved, paid or canceled.

The following standard records exist. Do not alter/delete:

Supplier invoice status (LevFaktStatKod) | Supplier invoice status (LevFaktStatBeskr)
0 | Received
1 | Received, arrival approved
2 | Received, arrival posted
4 | Final approval
5 | Final approval/posting
6 | Being paid
7 | Paid, not posted
8 | Paid
9 | Canceled

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Supplier invoice status | LevFaktStatBeskr | ztString | 50 |  | varchar
Supplier invoice status | LevFaktStatKod | ztString | 1 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxla Supplier invoice status


Supplier invoice types (xlft)

This table contains permitted supplier invoice types.

The following standard records exist. Do not alter/delete:

Invoice Type (LevFaktTyp) | Invoice type, descr (LevFaktTypBeskr) | Description
0 | Normal |
1 | Advance invoice debit | (Tax deduction is done upon final payment)
2 | Advance invoice credit (on account) | Upon payment the advance invoice is automatically changed into a credit invoice. This means that you enter a normal supplier invoice and pay it as an advance. At the time of updating the payment to the General Ledger the invoice is remade into a credit invoice which can later be used to credit the real invoice when it comes. This type of invoice is not included when converting currency for supplier ledgers.
3 | VAT/tax invoice |
4 | Own invoice |

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Invoice Type | LevFaktTyp | ztInteger | 3 |  | smallint
Invoice type, descr | LevFaktTypBeskr | ztString | 50 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Payment methods | UtbSlag | ztString | 3 |  | varchar

    This table is the main table in the following programs:

    Program: xlft Supplier invoice types


Supplier invoices (vlr)

Supplier invoices. A row is created for each invoice.
Outgoing payments and other data are stored in the underlying tables.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Days fr due dt to pmt | AntDgrSedanFfDat | ZtLong | 7 |  | int
Approval status | AttestKod1 | ztInteger | 1 |  | smallint
This field is used in the table as follows: |
Approved by | AttestSign | ztString | 6 |  | varchar
AttUtbetalasStatusNummer | AttUtbetStatusNr | ZtLong | 10 |  | int
Posting template | AutoRegel | ztString | 4 |  | varchar
This field is used in the table as follows: |
Deducted amt curr | AvdrVal | ztMoney | 14 | 2 | money
Account at bank | BankKonto | ztString | 40 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Payment reason | BetUppdragsTyp | ztString | 4 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Early stlmt dsct basis curr | CashDiscBaseFCU | ztMoney | 14 | 2 | money
Text | Edit | ztBlob | 1 |  | varchar
Packaging BCU | EmballageKostnad | ZtBaseCurrAmount | 14 | 2 | money
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Handling charge BCU | ExpeditionKostnad | ZtBaseCurrAmount | 14 | 2 | money
Invc match value | FaktAvprVarde | ztMoney | 14 | 2 | money
Remaining to pay BCU | FaktRestBel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Insurance BCU | ForsakringsKostnad | ZtBaseCurrAmount | 14 | 2 | money
Total freight BCU | FraktKostnDeb | ZtBaseCurrAmount | 14 | 2 | money
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Import date | IntullningsDatum | ztDate |  |  | datetime
Early settlmt discnt % | Kassarab | ztFloat | 6 | 2 | float
Posting slip date | KontLappUtskr | ztDate |  |  | datetime
Posting method | KontRegKod | ztString | 2 |  | varchar
Cost centre | koststallekod | ztString | 8 |  | varchar
Interim cost centre | KstInterimsBokning | ztString | 8 |  | varchar
Balance sheet CC | KstReskSaldo | ztString | 8 |  | varchar
Clearing account | KtoNrInterimsBokning | ztString | 8 |  | varchar
Ledger acct | KtoNrReskSaldo | ztString | 8 |  | varchar
Currency contract no. | KursAvtalsId | ztString | 20 |  | varchar
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Actual pmt date | LevFaktBetDat | ztDate |  |  | datetime
Invoice date | LevFaktDat | ztDate |  |  | datetime
Factoring | LevFaktFact | ztchar | 1 |  | char
Supplier invoice journal | LevFaktJourn | ztInteger | 4 |  | smallint
Cancel | LevFaktMakKod | ztBoolean |  |  | char
Supplier invoice status | LevFaktStatKod | ztString | 1 |  | varchar
Invoice Type | LevFaktTyp | ztInteger | 3 |  | smallint
Sales tax | LevIngMoms | ZtBaseCurrAmount | 14 | 2 | money
Supplier category | levkategori | ztInteger | 2 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Supplier reference | LevRef2 | ztString | 50 |  | varchar
Amt in interim acct | LrAvrKtoBel | ZtBaseCurrAmount | 14 | 2 | money
Arrival date | LrFaktAnkDat | ztDate |  |  | datetime
Invoice amount BCU | LrFaktBelBas | ZtBaseCurrAmount | 14 | 2 | money
Due date | LrFaktFFDat | ztDate |  |  | datetime
Early settlmt discnt dt | LrfaktKrabdat | ztDate |  |  | datetime
Utbetalninsattest | LrUtbAttest | ztInteger | 5 |  | smallint
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Tax amount 0 | MomsBelopp0 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 1 | MomsBelopp1 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 2 | MomsBelopp2 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 3 | MomsBelopp3 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 4 | MomsBelopp4 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 0 | MomsGrundBelopp0 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 1 | MomsGrundBelopp1 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 2 | MomsGrundBelopp2 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 3 | MomsGrundBelopp3 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 4 | MomsGrundBelopp4 | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Urspr valutakurs | OldValKurs | ZtCurrencyRate | 15 | 7 | decimal
Preliminary voucher | OldVerNr | Jeeves_VchrNo | 9 |  | bigint
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Priority | Prioritet | ztInteger | 2 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Centr bank issue no. | RiksBanksArendeNr | ztString | 4 |  | varchar
Ctrl bank code | RiksBanksKod | ztString | 3 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Forward rate | TerminsKurs | ZtCurrencyRate | 11 | 6 | decimal
Forward contract | TerminsNr | ZtLong | 10 |  | int
Pmt for final approval | UtbAnkKontFakt | ztBoolean |  |  | char
Deducted amount in BCU | utbavdrbas | ZtBaseCurrAmount | 14 | 2 | money
AP payment status | UtbKod | ztString | 1 |  | varchar
Pmt service journal no. | UtbServJournNr | ZtLong | 6 |  | int
Payment methods | UtbSlag | ztString | 3 |  | varchar
Payment blocked | UtbSparr | ztBoolean |  |  | char
Adjustment type | UtbTyp | ztString | 1 |  | varchar
Non-financial account | UtlBetDebKonto | ztString | 10 |  | varchar
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Invoice amount, curr | vb_faktsum | ztMoney | 14 | 2 | money
Paid on invc, curr | VbFaktBet | ztMoney | 14 | 2 | money
VAT/tax, curr | VbFaktMoms | ztMoney | 14 | 2 | money
Outst invc amt, curr | VbFaktRest | ztMoney | 14 | 2 | money
Pmt amt, curr (pmt srvc) | VbFbsBelopp | ztMoney | 14 | 2 | money
Early settlmt discnt, curr | VbKassaRab | ztMoney | 14 | 2 | money
Outst plan amt, curr | VbRestAttPlanera | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Voucher no. group | VerNrGrupp | ztString | 6 |  | varchar
Prel voucher no. | VerNrp | Jeeves_VchrNo | 9 |  | bigint


Supplier invoices (lr)

Table of supplier invoices. A row is created for each invoice.
Outgoing payments and other data are stored in the underlying tables.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Days fr due dt to pmt | AntDgrSedanFfDat | ZtLong | 7 |  | int
AP revaluation date | APRevaluationDate | ztDateTime |  |  | datetime
Approval status | AttestKod1 | ztInteger | 1 |  | smallint
This field is used in the table as follows: |
Approved by | AttestSign | ztString | 6 |  | varchar
Approval chain | Attkedja | ztInteger | 5 |  | smallint
AttUtbetalasStatusNummer | AttUtbetStatusNr | ZtLong | 10 |  | int
Posting template | AutoRegel | ztString | 4 |  | varchar
This field is used in the table as follows: |
Posting tmplt, final approval | AutoRegelS | ztString | 4 |  | varchar
Deducted amt curr | AvdrVal | ztMoney | 14 | 2 | money
Account at bank | BankKonto | ztString | 40 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Payment reason | BetUppdragsTyp | ztString | 4 |  | varchar
Reserved in journal | BilagsMark | ztBoolean |  |  | char
Bild Exp Date | BildfilExpDate | ztDate |  |  | datetime
BOE ledger | BoE_Code | ztBoolean |  |  | char
BOE status | BoE_Status | ztInteger | 5 |  | smallint
Accounting date | BokfDat | ztDate |  |  | datetime
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Early stlmt dsct basis curr | CashDiscBaseFCU | ztMoney | 14 | 2 | money
VAT bas early settlmt discnt curr | CashDiscBaseFCU_VAT | ztMoney | 14 | 2 | money
Separate check | checkind | ztBoolean |  |  | char
Currency pocket | Curr_P | ztString | 1 |  | varchar
VAT/tax GL date | DateOfTaxSupply | ztDate |  |  | datetime
Delivery from business unit ICT | DelivFromBusinessUnit | ztString | 8 |  | varchar
Deliv from invoice | DelivFromInvoiceNo | Jeeves_InvNo | 20 |  | bigint
Reference ID document | DocRefNr | ZtLong | 10 |  | int
Text | Edit | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Packaging BCU | EmballageKostnad | ZtBaseCurrAmount | 14 | 2 | money
Packaging overs, BCU | EmballageKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Packaging import, BCU | EmbKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Exported date | expdatum | ztDateTime |  |  | datetime
Handling charge BCU | ExpeditionKostnad | ZtBaseCurrAmount | 14 | 2 | money
Exported | expstatus | ztBoolean |  |  | char
To text file | ExpTillText | ztBoolean |  |  | char
Invoice match method | FaktAvprTypBest | ztInteger | 3 |  | smallint
Invc match value | FaktAvprVarde | ztMoney | 14 | 2 | money
Invc match value BCU | FaktAvprVardeBas | ZtBaseCurrAmount | 14 | 2 | money
Invoice reference no. | FaktNr_OCR | ztString | 40 |  | varchar
Remaining to pay BCU | FaktRestBel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Insurance BCU | ForsakringsKostnad | ZtBaseCurrAmount | 14 | 2 | money
Insurance import, BCU | ForsakrKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Insurance overs, BCU | ForsakrKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Total freight BCU | FraktKostnDeb | ZtBaseCurrAmount | 14 | 2 | money
Freight import, BCU | FraktKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Insurance overs, BCU | FraktKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Freight cost, avg cost | FraktKostSnittBer | ZtBaseCurrAmount | 14 | 2 | money
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Guarantee account | G_BankAccount | ztString | 40 |  | varchar
Guarantee fulfilled | G_FulFilled | ztBoolean |  |  | char
Paid guarantee account | G_PaidAmountFCU | ztMoney | 14 | 2 | money
Guarantee payment | G_Paym | ztBoolean |  |  | char
Guarantee % | G_Percentage | ZtDecimal73 | 5 | 2 | decimal
Third party trade | Handel3Part | ztBoolean |  |  | char
Delivery cost, avg cost | HemtagnKostSnittBer | ZtBaseCurrAmount | 14 | 2 | money
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Allocation purch OH | InkOmkFord | ztInteger | 5 |  | smallint
Purch OH type | InkOmkTyp | ztInteger | 5 |  | smallint
Accruals | InterimsKontering | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Import date | IntullningsDatum | ztDate |  |  | datetime
Fixed asset no | inventarie | ZtLong | 10 |  | int
S4 | k4 | ztString | 8 |  | varchar
Clearing acc 4 | K4InterimsBokning | ztString | 8 |  | varchar
S-4 f ledg.balance | K4ReskSaldo | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
Clearing acc 5 | K5InterimsBokning | ztString | 8 |  | varchar
S5 f ledg.balance | K5ReskSaldo | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
Clearing acc 6 | K6InterimsBokning | ztString | 8 |  | varchar
S6 f ledg.Bal | K6ReskSaldo | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Clearing acc 7 | K7InterimsBokning | ztString | 8 |  | varchar
S7 f ledg.balance | K7ReskSaldo | ztString | 8 |  | varchar
Early settlmt discnt % | Kassarab | ztFloat | 6 | 2 | float
Early settlmt discnt BCU | KassaRabBas | ZtBaseCurrAmount | 14 | 2 | money
Early stlmt dsct dt->due dt | KassaRabDatFFDat | ztBoolean |  |  | char
Clearing acc bearer | KBarInterimsBokning | ztString | 8 |  | varchar
Cost unit f ledg.balance | KBarReskSaldo | ztString | 8 |  | varchar
Posting slip date | KontLappUtskr | ztDate |  |  | datetime
Kont Momsbelopp 0 | KontMomsBelopp0 | ZtBaseCurrAmount | 14 | 2 | money
Kont Momsbelopp 1 | KontMomsBelopp1 | ZtBaseCurrAmount | 14 | 2 | money
Kont Momsbelopp 2 | KontMomsBelopp2 | ZtBaseCurrAmount | 14 | 2 | money
Kont Momsbelopp 3 | KontMomsBelopp3 | ZtBaseCurrAmount | 14 | 2 | money
Kont Momsbelopp 4 | KontMomsBelopp4 | ZtBaseCurrAmount | 14 | 2 | money
Pmt to acct | KontoIns | ztInteger | 1 |  | smallint
Posting method | KontRegKod | ztString | 2 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | koststallekod | ztString | 8 |  | varchar
Interim cost centre | KstInterimsBokning | ztString | 8 |  | varchar
Balance sheet CC | KstReskSaldo | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Clearing account | KtoNrInterimsBokning | ztString | 8 |  | varchar
Ledger acct | KtoNrReskSaldo | ztString | 8 |  | varchar
Customer order no. | kundbestnr | ztString | 30 |  | varchar
Currency contract no. | KursAvtalsId | ztString | 20 |  | varchar
Bank Giro | LevBankGiro | ztBgNr | 11 |  | varchar
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Sale/delivery date | LevDatBest | ztDate |  |  | datetime
Actual pmt date | LevFaktBetDat | ztDate |  |  | datetime
Invoice date | LevFaktDat | ztDate |  |  | datetime
Factoring | LevFaktFact | ztchar | 1 |  | char
Supplier invoice journal | LevFaktJourn | ztInteger | 4 |  | smallint
Cancel | LevFaktMakKod | ztBoolean |  |  | char
Supplier invoice status | LevFaktStatKod | ztString | 1 |  | varchar
Invoice Type | LevFaktTyp | ztInteger | 3 |  | smallint
Sales tax | LevIngMoms | ZtBaseCurrAmount | 14 | 2 | money
Supplier category | levkategori | ztInteger | 2 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Plus giro no. | LevPostGiro | ztPgNr | 11 |  | varchar
Supplier reference | LevRef2 | ztString | 50 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Amt in interim acct | LrAvrKtoBel | ZtBaseCurrAmount | 14 | 2 | money
Arrival date | LrFaktAnkDat | ztDate |  |  | datetime
Invoice amount BCU | LrFaktBelBas | ZtBaseCurrAmount | 14 | 2 | money
Invoice amt adv, BCU | lrfaktbelbasforskott | ZtBaseCurrAmount | 14 | 2 | money
Due date | LrFaktFFDat | ztDate |  |  | datetime
Early settlmt discnt dt | LrfaktKrabdat | ztDate |  |  | datetime
Utbetalninsattest | LrUtbAttest | ztInteger | 5 |  | smallint
Mail to buyer | MailToBuyer | ztBoolean |  |  | char
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Tax amount 0 | MomsBelopp0 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 1 | MomsBelopp1 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 2 | MomsBelopp2 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 3 | MomsBelopp3 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 4 | MomsBelopp4 | ZtBaseCurrAmount | 14 | 2 | money
PO no. | MomsBestNr | ZtLong | 6 |  | int
Tax date | MomsDatum | ztDate |  |  | datetime
VAT/tax invc basis | MomsFaktUnderlag | ztBoolean |  |  | char
Tax basis 0 | MomsGrundBelopp0 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 1 | MomsGrundBelopp1 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 2 | MomsGrundBelopp2 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 3 | MomsGrundBelopp3 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 4 | MomsGrundBelopp4 | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax 0 | Momskod0 | ztInteger | 5 |  | smallint
VAT/tax 1 | Momskod1 | ztInteger | 5 |  | smallint
VAT/tax 2 | Momskod2 | ztInteger | 5 |  | smallint
VAT/tax 3 | Momskod3 | ztInteger | 5 |  | smallint
VAT/tax 4 | Momskod4 | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Urspr valutakurs | OldValKurs | ZtCurrencyRate | 15 | 7 | decimal
Orig exchange rate | OldValKursGrund | ZtCurrencyRate | 15 | 7 | decimal
Orig exchange rate, operand | OldValKursOp | ztInteger | 5 |  | smallint
Orig exchange rate per | OldValKursPer | ZtDecimal73 | 8 | 3 | decimal
Preliminary voucher | OldVerNr | Jeeves_VchrNo | 9 |  | bigint
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Extra cost-1 overs, BCU | OvrFaktKostnUtland1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 overs, BCU | OvrFaktKostnUtland2 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-1 import, BCU | OvrKostnImport1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 import, BCU | OvrKostnImport2 | ZtBaseCurrAmount | 14 | 2 | money
Markup-1, avg cost | Palagg1KostSnittBer | ZtBaseCurrAmount | 14 | 2 | money
Markup-2, avg cost | Palagg2KostSnittBer | ZtBaseCurrAmount | 14 | 2 | money
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Spec of central bank code | PgSkrivrad | ztString | 75 |  | varchar
Priority | Prioritet | ztInteger | 2 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Supplier invoice rows? | PvLrdRowsExist | ztBoolean |  |  | char
Collective Invoice | PvLrSamFakt | ztInteger | 5 |  | smallint
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Reference number | ReferensNr | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Entry method | RegKod | ztInteger | 1 |  | smallint
RejectCause | RejectCause | ztInteger | 4 |  | smallint
Signature | ReviewedByPersSign | ztString | 6 |  | varchar
Centr bank issue no. | RiksBanksArendeNr | ztString | 4 |  | varchar
Ctrl bank code | RiksBanksKod | ztString | 3 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
sen ändr kontering/attest | SenAttAndrDat | ztDate |  |  | datetime
Send EDI | SendEdi | ztBoolean |  |  | char
Sent EDI | SendEdiDT | ztDateTime |  |  | datetime
Forward rate | TerminsKurs | ZtCurrencyRate | 11 | 6 | decimal
Forward contract | TerminsNr | ZtLong | 10 |  | int
Upd charge basis | UpdDeb | ztBoolean |  |  | char
Date upd chrg basis | UpdDebDatum | ztDate |  |  | datetime
Pmt for final approval | UtbAnkKontFakt | ztBoolean |  |  | char
Deducted amount in BCU | utbavdrbas | ZtBaseCurrAmount | 14 | 2 | money
AP payment status | UtbKod | ztString | 1 |  | varchar
Pmt service journal no. | UtbServJournNr | ZtLong | 6 |  | int
Payment methods | UtbSlag | ztString | 3 |  | varchar
Payment blocked | UtbSparr | ztBoolean |  |  | char
Adjustment type | UtbTyp | ztString | 1 |  | varchar
Non-financial account | UtlBetDebKonto | ztString | 10 |  | varchar
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate | ValKursGrund | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate, operand | ValKursOp | ztInteger | 5 |  | smallint
Exchange rate unit | ValKursPer | ZtDecimal73 | 8 | 3 | decimal
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax type 0 | VAT_Type_0 | ztInteger | 4 |  | smallint
VAT/tax type 1 | VAT_Type_1 | ztInteger | 4 |  | smallint
VAT/tax type 2 | VAT_Type_2 | ztInteger | 4 |  | smallint
VAT/tax type 3 | VAT_Type_3 | ztInteger | 4 |  | smallint
VAT/tax type 4 | VAT_Type_4 | ztInteger | 4 |  | smallint
VAT/tax type purchase | VAT_Type_Purchase | ztInteger | 4 |  | smallint
VAT/tax type sales | VAT_Type_Sales | ztInteger | 4 |  | smallint
VAT/tax exchange rate | VATExchRate | ZtCurrencyRate | 15 | 7 | decimal
Packaging, curr | vb_EmballageKostnad | ztMoney | 14 | 2 | money
Packaging overs, curr | vb_EmballageKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Packaging import, curr | vb_EmbKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Handling charge curr | vb_ExpeditionKostnad | ztMoney | 14 | 2 | money
Invoice amount, curr | vb_faktsum | ztMoney | 14 | 2 | money
Invoice amt adv, curr | vb_faktsumforskott | ztMoney | 14 | 2 | money
Insurance, curr | vb_ForsakringsKostnad | ztMoney | 14 | 2 | money
Insurance import, curr | vb_ForsakrKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Insurance overs, curr | vb_ForsakrKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Total freight, curr | vb_FraktKostnDeb | ztMoney | 14 | 2 | money
Freight import, curr | vb_FraktKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Freight overseas, curr | vb_FraktKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-1 overs, curr | vb_OvrFaktKostnUtland1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 overs, curr | vb_OvrFaktKostnUtland2 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-1 import, curr | vb_OvrKostnImport1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 import, curr | vb_OvrKostnImport2 | ZtBaseCurrAmount | 14 | 2 | money
Paid on invc, curr | VbFaktBet | ztMoney | 14 | 2 | money
VAT/tax, curr | VbFaktMoms | ztMoney | 14 | 2 | money
Outst invc amt, curr | VbFaktRest | ztMoney | 14 | 2 | money
Pmt amt, curr (pmt srvc) | VbFbsBelopp | ztMoney | 14 | 2 | money
Early settlmt discnt, curr | VbKassaRab | ztMoney | 14 | 2 | money
Outst plan amt, curr | VbRestAttPlanera | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Voucher no. group | VerNrGrupp | ztString | 6 |  | varchar
Prel voucher no. | VerNrp | Jeeves_VchrNo | 9 |  | bigint
Fiscal Year | VerRedAr | ztInteger | 4 |  | smallint
Updated from the web | webupd | ztBoolean |  |  | char
Unique ID link | wfrowuniqueid | ztString | 50 |  | varchar
Zero invoice | ZeroAmount | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: bLr Print AP as of

    Program: Nxlr Supplier invoices, direct posting

    Program: Supplinvcs Supplier invoices

    Program: Xlr Supplier invoices

    Program: xLrAvr Show invoices in clearing account

    Program: xlrq Supplier invoices, automatic posting


Supplier invoices (view) (vlr9)

Supplier invoices. A row is created for each invoice.
Outgoing payments and other data are stored in the underlying tables.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Days fr due dt to pmt | AntDgrSedanFfDat | ZtLong | 7 |  | int
Approval status | AttestKod1 | ztInteger | 1 |  | smallint
This field is used in the table as follows: |
Approved by | AttestSign | ztString | 6 |  | varchar
AttUtbetalasStatusNummer | AttUtbetStatusNr | ZtLong | 10 |  | int
Posting template | AutoRegel | ztString | 4 |  | varchar
This field is used in the table as follows: |
Deducted amt curr | AvdrVal | ztMoney | 14 | 2 | money
Deduction curr | AvdrVal_Fbs | ztMoney | 14 | 2 | money
Account at bank | BankKonto | ztString | 40 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Payment reason | BetUppdragsTyp | ztString | 4 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Text | Edit | ztBlob | 1 |  | varchar
Packaging BCU | EmballageKostnad | ZtBaseCurrAmount | 14 | 2 | money
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Handling charge BCU | ExpeditionKostnad | ZtBaseCurrAmount | 14 | 2 | money
Invc match value | FaktAvprVarde | ztMoney | 14 | 2 | money
Invoice reference no. | fAKTnR_ocr | ztString | 40 |  | varchar
Remaining to pay BCU | FaktRestBel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Insurance BCU | ForsakringsKostnad | ZtBaseCurrAmount | 14 | 2 | money
Total freight BCU | FraktKostnDeb | ZtBaseCurrAmount | 14 | 2 | money
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Bank account | G_BankAccount_lrfb | ztString | 40 |  | varchar
Guarantee payment | G_Paym_lrfb | ztBoolean |  |  | char
Guarantee % | G_Percentage_lrfb | ZtDecimal73 | 5 | 2 | decimal
Import date | IntullningsDatum | ztDate |  |  | datetime
Early settlmt discnt % | Kassarab | ztFloat | 6 | 2 | float
Posting slip date | KontLappUtskr | ztDate |  |  | datetime
Pmt to acct | KontoIns | ztInteger | 1 |  | smallint
Posting method | KontRegKod | ztString | 2 |  | varchar
Cost centre | koststallekod | ztString | 8 |  | varchar
Interim cost centre | KstInterimsBokning | ztString | 8 |  | varchar
Balance sheet CC | KstReskSaldo | ztString | 8 |  | varchar
Clearing account | KtoNrInterimsBokning | ztString | 8 |  | varchar
Ledger acct | KtoNrReskSaldo | ztString | 8 |  | varchar
Currency contract no. | KursAvtalsId | ztString | 20 |  | varchar
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Actual pmt date | LevFaktBetDat | ztDate |  |  | datetime
Invoice date | LevFaktDat | ztDate |  |  | datetime
Factoring | LevFaktFact | ztchar | 1 |  | char
Supplier invoice journal | LevFaktJourn | ztInteger | 4 |  | smallint
Cancel | LevFaktMakKod | ztBoolean |  |  | char
Supplier invoice status | LevFaktStatKod | ztString | 1 |  | varchar
Sales tax | LevIngMoms | ZtBaseCurrAmount | 14 | 2 | money
Supplier category | levkategori | ztInteger | 2 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Supplier reference | LevRef2 | ztString | 50 |  | varchar
Amt in interim acct | LrAvrKtoBel | ZtBaseCurrAmount | 14 | 2 | money
Arrival date | LrFaktAnkDat | ztDate |  |  | datetime
Invoice amount BCU | LrFaktBelBas | ZtBaseCurrAmount | 14 | 2 | money
Due date | LrFaktFFDat | ztDate |  |  | datetime
Early settlmt discnt dt | LrfaktKrabdat | ztDate |  |  | datetime
Utbetalninsattest | LrUtbAttest | ztInteger | 5 |  | smallint
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Tax amount 0 | MomsBelopp0 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 1 | MomsBelopp1 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 2 | MomsBelopp2 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 3 | MomsBelopp3 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 4 | MomsBelopp4 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 0 | MomsGrundBelopp0 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 1 | MomsGrundBelopp1 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 2 | MomsGrundBelopp2 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 3 | MomsGrundBelopp3 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 4 | MomsGrundBelopp4 | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
New due date | NewLrFaktFFDat | ztDate |  |  | datetime
Urspr valutakurs | OldValKurs | ZtCurrencyRate | 15 | 7 | decimal
Preliminary voucher | OldVerNr | Jeeves_VchrNo | 9 |  | bigint
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Priority | Prioritet | ztInteger | 2 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Centr bank issue no. | RiksBanksArendeNr | ztString | 4 |  | varchar
Ctrl bank code | RiksBanksKod | ztString | 3 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Forward rate | TerminsKurs | ZtCurrencyRate | 11 | 6 | decimal
Forward contract | TerminsNr | ZtLong | 10 |  | int
PaymentJournalNo | UniqueJoNo | ZtLong | 10 |  | int
Pmt for final approval | UtbAnkKontFakt | ztBoolean |  |  | char
Deducted amount in BCU | utbavdrbas | ZtBaseCurrAmount | 14 | 2 | money
AP payment status | UtbKod | ztString | 1 |  | varchar
Pmt service journal no. | UtbServJournNr | ZtLong | 6 |  | int
Payment methods | UtbSlag | ztString | 3 |  | varchar
Payment blocked | UtbSparr | ztBoolean |  |  | char
Adjustment type | UtbTyp | ztString | 1 |  | varchar
Non-financial account | UtlBetDebKonto | ztString | 10 |  | varchar
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Invoice amount, curr | vb_faktsum | ztMoney | 14 | 2 | money
Paid on invc, curr | VbFaktBet | ztMoney | 14 | 2 | money
VAT/tax, curr | VbFaktMoms | ztMoney | 14 | 2 | money
Outst invc amt, curr | VbFaktRest | ztMoney | 14 | 2 | money
Pmt amt, curr (pmt srvc) | VbFbsBelopp | ztMoney | 14 | 2 | money
Amount (Invc pmt srvc) | VbFbsUtbBel | ztMoney | 14 | 2 | money
Early settlmt discnt, curr | VbKassaRab | ztMoney | 14 | 2 | money
Early settlmt discnt, curr | VbKassaRab_Fbs | ztMoney | 14 | 2 | money
Outst plan amt, curr | VbRestAttPlanera | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Voucher no. group | VerNrGrupp | ztString | 6 |  | varchar
Prel voucher no. | VerNrp | Jeeves_VchrNo | 9 |  | bigint


Supplier invoices (view) with G_Bankaccount (vlrG)

View over table of supplier invoices which has a G_BankAccount.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Days fr due dt to pmt | AntDgrSedanFfDat | ZtLong | 7 |  | int
Approval status | AttestKod1 | ztInteger | 1 |  | smallint
This field is used in the table as follows: |
Approved by | AttestSign | ztString | 6 |  | varchar
Approval chain | Attkedja | ztInteger | 5 |  | smallint
AttUtbetalasStatusNummer | AttUtbetStatusNr | ZtLong | 10 |  | int
Posting template | AutoRegel | ztString | 4 |  | varchar
This field is used in the table as follows: |
Posting tmplt, final approval | AutoRegelS | ztString | 4 |  | varchar
Deducted amt curr | AvdrVal | ztMoney | 14 | 2 | money
Account at bank | BankKonto | ztString | 40 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Payment reason | BetUppdragsTyp | ztString | 4 |  | varchar
Reserved in journal | BilagsMark | ztBoolean |  |  | char
Bild Exp Date | BildfilExpDate | ztDate |  |  | datetime
BOE ledger | BoE_Code | ztBoolean |  |  | char
BOE status | BoE_Status | ztInteger | 5 |  | smallint
Accounting date | BokfDat | ztDate |  |  | datetime
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Early stlmt dsct basis curr | CashDiscBaseFCU | ztMoney | 14 | 2 | money
VAT bas early settlmt discnt curr | CashDiscBaseFCU_VAT | ztMoney | 14 | 2 | money
Separate check | checkind | ztBoolean |  |  | char
Currency pocket | Curr_P | ztString | 1 |  | varchar
VAT/tax GL date | DateOfTaxSupply | ztDate |  |  | datetime
Delivery from business unit ICT | DelivFromBusinessUnit | ztString | 8 |  | varchar
Deliv from invoice | DelivFromInvoiceNo | Jeeves_InvNo | 20 |  | bigint
Reference ID document | DocRefNr | ZtLong | 10 |  | int
Text | Edit | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Packaging BCU | EmballageKostnad | ZtBaseCurrAmount | 14 | 2 | money
Packaging overs, BCU | EmballageKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Packaging import, BCU | EmbKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Exported date | expdatum | ztDateTime |  |  | datetime
Handling charge BCU | ExpeditionKostnad | ZtBaseCurrAmount | 14 | 2 | money
Exported | expstatus | ztBoolean |  |  | char
To text file | ExpTillText | ztBoolean |  |  | char
Invoice match method | FaktAvprTypBest | ztInteger | 3 |  | smallint
Invc match value | FaktAvprVarde | ztMoney | 14 | 2 | money
Invc match value BCU | FaktAvprVardeBas | ZtBaseCurrAmount | 14 | 2 | money
Invoice reference no. | FaktNr_OCR | ztString | 40 |  | varchar
Remaining to pay BCU | FaktRestBel | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Insurance BCU | ForsakringsKostnad | ZtBaseCurrAmount | 14 | 2 | money
Insurance import, BCU | ForsakrKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Insurance overs, BCU | ForsakrKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Total freight BCU | FraktKostnDeb | ZtBaseCurrAmount | 14 | 2 | money
Freight import, BCU | FraktKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Insurance overs, BCU | FraktKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Freight cost, avg cost | FraktKostSnittBer | ZtBaseCurrAmount | 14 | 2 | money
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Guarantee account | G_BankAccount | ztString | 40 |  | varchar
Bank account | g_BankAccount_lrfb | ztString | 40 |  | varchar
Guarantee fulfilled | G_FulFilled | ztBoolean |  |  | char
Guarantee payment | G_Paym | ztBoolean |  |  | char
Guarantee % | G_Percentage | ZtDecimal73 | 5 | 2 | decimal
Third party trade | Handel3Part | ztBoolean |  |  | char
Delivery cost, avg cost | HemtagnKostSnittBer | ZtBaseCurrAmount | 14 | 2 | money
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Allocation purch OH | InkOmkFord | ztInteger | 5 |  | smallint
Purch OH type | InkOmkTyp | ztInteger | 5 |  | smallint
Accruals | InterimsKontering | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Import date | IntullningsDatum | ztDate |  |  | datetime
Fixed asset no | inventarie | ZtLong | 10 |  | int
S4 | k4 | ztString | 8 |  | varchar
Clearing acc 4 | K4InterimsBokning | ztString | 8 |  | varchar
S-4 f ledg.balance | K4ReskSaldo | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
Clearing acc 5 | K5InterimsBokning | ztString | 8 |  | varchar
S5 f ledg.balance | K5ReskSaldo | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
Clearing acc 6 | K6InterimsBokning | ztString | 8 |  | varchar
S6 f ledg.Bal | K6ReskSaldo | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Clearing acc 7 | K7InterimsBokning | ztString | 8 |  | varchar
S7 f ledg.balance | K7ReskSaldo | ztString | 8 |  | varchar
Early settlmt discnt % | Kassarab | ztFloat | 6 | 2 | float
Early settlmt discnt BCU | KassaRabBas | ZtBaseCurrAmount | 14 | 2 | money
Early stlmt dsct dt->due dt | KassaRabDatFFDat | ztBoolean |  |  | char
Clearing acc bearer | KBarInterimsBokning | ztString | 8 |  | varchar
Cost unit f ledg.balance | KBarReskSaldo | ztString | 8 |  | varchar
Posting slip date | KontLappUtskr | ztDate |  |  | datetime
Kont Momsbelopp 0 | KontMomsBelopp0 | ZtBaseCurrAmount | 14 | 2 | money
Kont Momsbelopp 1 | KontMomsBelopp1 | ZtBaseCurrAmount | 14 | 2 | money
Kont Momsbelopp 2 | KontMomsBelopp2 | ZtBaseCurrAmount | 14 | 2 | money
Kont Momsbelopp 3 | KontMomsBelopp3 | ZtBaseCurrAmount | 14 | 2 | money
Kont Momsbelopp 4 | KontMomsBelopp4 | ZtBaseCurrAmount | 14 | 2 | money
Pmt to acct | KontoIns | ztInteger | 1 |  | smallint
Posting method | KontRegKod | ztString | 2 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | koststallekod | ztString | 8 |  | varchar
Interim cost centre | KstInterimsBokning | ztString | 8 |  | varchar
Balance sheet CC | KstReskSaldo | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Clearing account | KtoNrInterimsBokning | ztString | 8 |  | varchar
Ledger acct | KtoNrReskSaldo | ztString | 8 |  | varchar
Customer order no. | kundbestnr | ztString | 30 |  | varchar
Currency contract no. | KursAvtalsId | ztString | 20 |  | varchar
Bank Giro | LevBankGiro | ztBgNr | 11 |  | varchar
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Sale/delivery date | LevDatBest | ztDate |  |  | datetime
Actual pmt date | LevFaktBetDat | ztDate |  |  | datetime
Invoice date | LevFaktDat | ztDate |  |  | datetime
Factoring | LevFaktFact | ztchar | 1 |  | char
Supplier invoice journal | LevFaktJourn | ztInteger | 4 |  | smallint
Cancel | LevFaktMakKod | ztBoolean |  |  | char
Supplier invoice status | LevFaktStatKod | ztString | 1 |  | varchar
Invoice Type | LevFaktTyp | ztInteger | 3 |  | smallint
Sales tax | LevIngMoms | ZtBaseCurrAmount | 14 | 2 | money
Supplier category | levkategori | ztInteger | 2 |  | smallint
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Plus giro no. | LevPostGiro | ztPgNr | 11 |  | varchar
Supplier reference | LevRef2 | ztString | 50 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Amt in interim acct | LrAvrKtoBel | ZtBaseCurrAmount | 14 | 2 | money
Arrival date | LrFaktAnkDat | ztDate |  |  | datetime
Invoice amount BCU | LrFaktBelBas | ZtBaseCurrAmount | 14 | 2 | money
Invoice amt adv, BCU | lrfaktbelbasforskott | ZtBaseCurrAmount | 14 | 2 | money
Due date | LrFaktFFDat | ztDate |  |  | datetime
Early settlmt discnt dt | LrfaktKrabdat | ztDate |  |  | datetime
Utbetalninsattest | LrUtbAttest | ztInteger | 5 |  | smallint
Mail to buyer | MailToBuyer | ztBoolean |  |  | char
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Tax amount 0 | MomsBelopp0 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 1 | MomsBelopp1 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 2 | MomsBelopp2 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 3 | MomsBelopp3 | ZtBaseCurrAmount | 14 | 2 | money
Tax amount 4 | MomsBelopp4 | ZtBaseCurrAmount | 14 | 2 | money
PO no. | MomsBestNr | ZtLong | 6 |  | int
Tax date | MomsDatum | ztDate |  |  | datetime
VAT/tax invc basis | MomsFaktUnderlag | ztBoolean |  |  | char
Tax basis 0 | MomsGrundBelopp0 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 1 | MomsGrundBelopp1 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 2 | MomsGrundBelopp2 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 3 | MomsGrundBelopp3 | ZtBaseCurrAmount | 14 | 2 | money
Tax basis 4 | MomsGrundBelopp4 | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax 0 | Momskod0 | ztInteger | 5 |  | smallint
VAT/tax 1 | Momskod1 | ztInteger | 5 |  | smallint
VAT/tax 2 | Momskod2 | ztInteger | 5 |  | smallint
VAT/tax 3 | Momskod3 | ztInteger | 5 |  | smallint
VAT/tax 4 | Momskod4 | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Urspr valutakurs | OldValKurs | ZtCurrencyRate | 15 | 7 | decimal
Orig exchange rate | OldValKursGrund | ZtCurrencyRate | 15 | 7 | decimal
Orig exchange rate, operand | OldValKursOp | ztInteger | 5 |  | smallint
Orig exchange rate per | OldValKursPer | ZtDecimal73 | 8 | 3 | decimal
Preliminary voucher | OldVerNr | Jeeves_VchrNo | 9 |  | bigint
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Extra cost-1 overs, BCU | OvrFaktKostnUtland1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 overs, BCU | OvrFaktKostnUtland2 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-1 import, BCU | OvrKostnImport1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 import, BCU | OvrKostnImport2 | ZtBaseCurrAmount | 14 | 2 | money
Markup-1, avg cost | Palagg1KostSnittBer | ZtBaseCurrAmount | 14 | 2 | money
Markup-2, avg cost | Palagg2KostSnittBer | ZtBaseCurrAmount | 14 | 2 | money
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Spec of central bank code | PgSkrivrad | ztString | 75 |  | varchar
Priority | Prioritet | ztInteger | 2 |  | smallint
Project ID | ProjCode | ztString | 10 |  | varchar
Supplier invoice rows? | PvLrdRowsExist | ztBoolean |  |  | char
Collective Invoice | PvLrSamFakt | ztInteger | 5 |  | smallint
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Reference number | ReferensNr | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Entry method | RegKod | ztInteger | 1 |  | smallint
Signature | ReviewedByPersSign | ztString | 6 |  | varchar
Centr bank issue no. | RiksBanksArendeNr | ztString | 4 |  | varchar
Ctrl bank code | RiksBanksKod | ztString | 3 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
sen ändr kontering/attest | SenAttAndrDat | ztDate |  |  | datetime
Send EDI | SendEdi | ztBoolean |  |  | char
Sent EDI | SendEdiDT | ztDateTime |  |  | datetime
Forward rate | TerminsKurs | ZtCurrencyRate | 11 | 6 | decimal
Forward contract | TerminsNr | ZtLong | 10 |  | int
Upd charge basis | UpdDeb | ztBoolean |  |  | char
Date upd chrg basis | UpdDebDatum | ztDate |  |  | datetime
Pmt for final approval | UtbAnkKontFakt | ztBoolean |  |  | char
Deducted amount in BCU | utbavdrbas | ZtBaseCurrAmount | 14 | 2 | money
AP payment status | UtbKod | ztString | 1 |  | varchar
Pmt service journal no. | UtbServJournNr | ZtLong | 6 |  | int
Payment methods | UtbSlag | ztString | 3 |  | varchar
Payment blocked | UtbSparr | ztBoolean |  |  | char
Adjustment type | UtbTyp | ztString | 1 |  | varchar
Non-financial account | UtlBetDebKonto | ztString | 10 |  | varchar
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate | ValKursGrund | ZtCurrencyRate | 15 | 7 | decimal
Exchange rate, operand | ValKursOp | ztInteger | 5 |  | smallint
Exchange rate unit | ValKursPer | ZtDecimal73 | 8 | 3 | decimal
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax type 0 | VAT_Type_0 | ztInteger | 4 |  | smallint
VAT/tax type 1 | VAT_Type_1 | ztInteger | 4 |  | smallint
VAT/tax type 2 | VAT_Type_2 | ztInteger | 4 |  | smallint
VAT/tax type 3 | VAT_Type_3 | ztInteger | 4 |  | smallint
VAT/tax type 4 | VAT_Type_4 | ztInteger | 4 |  | smallint
VAT/tax type purchase | VAT_Type_Purchase | ztInteger | 4 |  | smallint
VAT/tax type sales | VAT_Type_Sales | ztInteger | 4 |  | smallint
VAT/tax exchange rate | VATExchRate | ZtCurrencyRate | 15 | 7 | decimal
Packaging, curr | vb_EmballageKostnad | ztMoney | 14 | 2 | money
Packaging overs, curr | vb_EmballageKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Packaging import, curr | vb_EmbKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Handling charge curr | vb_ExpeditionKostnad | ztMoney | 14 | 2 | money
Invoice amount, curr | vb_faktsum | ztMoney | 14 | 2 | money
Invoice amt adv, curr | vb_faktsumforskott | ztMoney | 14 | 2 | money
Insurance, curr | vb_ForsakringsKostnad | ztMoney | 14 | 2 | money
Insurance import, curr | vb_ForsakrKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Insurance overs, curr | vb_ForsakrKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Total freight, curr | vb_FraktKostnDeb | ztMoney | 14 | 2 | money
Freight import, curr | vb_FraktKostnImport | ZtBaseCurrAmount | 14 | 2 | money
Freight overseas, curr | vb_FraktKostnUtland | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-1 overs, curr | vb_OvrFaktKostnUtland1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 overs, curr | vb_OvrFaktKostnUtland2 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-1 import, curr | vb_OvrKostnImport1 | ZtBaseCurrAmount | 14 | 2 | money
Extra cost-2 import, curr | vb_OvrKostnImport2 | ZtBaseCurrAmount | 14 | 2 | money
Paid on invc, curr | VbFaktBet | ztMoney | 14 | 2 | money
VAT/tax, curr | VbFaktMoms | ztMoney | 14 | 2 | money
Outst invc amt, curr | VbFaktRest | ztMoney | 14 | 2 | money
Pmt amt, curr (pmt srvc) | VbFbsBelopp | ztMoney | 14 | 2 | money
Early settlmt discnt, curr | VbKassaRab | ztMoney | 14 | 2 | money
Outst plan amt, curr | VbRestAttPlanera | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Voucher no. group | VerNrGrupp | ztString | 6 |  | varchar
Prel voucher no. | VerNrp | Jeeves_VchrNo | 9 |  | bigint
Fiscal Year | VerRedAr | ztInteger | 4 |  | smallint
Updated from the web | webupd | ztBoolean |  |  | char
Unique ID link | wfrowuniqueid | ztString | 50 |  | varchar
Zero invoice | ZeroAmount | ztBoolean |  |  | char


Supplier point of delivery (vlp1)

Definition of different points of delivery for a supplier. This can be used for delivery addresses or the like.

First, enter general company data for points of delivery in the company table. Then connect these to suppliers in this program/table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv |  |  |  | @DataType=NULL
Created by object | CreatedByDBObject |  |  |  | @DataType=NULL
Text | Edit |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Storage code | ForradsKod |  |  |  | @DataType=NULL
Company ID | FtgNr |  |  |  | @DataType=NULL
Print point of delivery | KOdUtskrLevPlats |  |  |  | @DataType=NULL
Recipient code | MottagarKod |  |  |  | @DataType=NULL
OLE-1 | ole1 |  |  |  | @DataType=NULL
OLE-2 | ole2 |  |  |  | @DataType=NULL
Point of delivery, co. ID | OrdLevPlats1 |  |  |  | @DataType=NULL
Point of delivery, name | OrdLevPlBeskr |  |  |  | @DataType=NULL
Quantity PDM | PdmCount |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Gate description | PortBeskrivning |  |  |  | @DataType=NULL
Gate code | PortKod |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Columns updated | RowUpdatedCols |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL

    This table is the main table in the following programs:

    Program: vlp1 Supplier point of delivery


Supplier statistics (sle)

Statistics per supplier and period.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Amount excl. tax | BestRkgValue | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
AP ledger balance | LevReskSaldo | ZtBaseCurrAmount | 14 | 2 | money
Ej förf saldo g1 | LevReskSaldoE1 | ZtBaseCurrAmount | 14 | 2 | money
Ej förf saldo g2 | LevReskSaldoE2 | ZtBaseCurrAmount | 14 | 2 | money
Ej förf saldo g3 | LevReskSaldoE3 | ZtBaseCurrAmount | 14 | 2 | money
Ej förf saldo g4 | LevReskSaldoE4 | ZtBaseCurrAmount | 14 | 2 | money
Ej förf saldo g--- | LevReskSaldoEx | ZtBaseCurrAmount | 14 | 2 | money
Förf saldo g1 | LevReskSaldoF1 | ZtBaseCurrAmount | 14 | 2 | money
Förf saldo g2 | LevReskSaldoF2 | ZtBaseCurrAmount | 14 | 2 | money
Förf saldo g3 | LevReskSaldoF3 | ZtBaseCurrAmount | 14 | 2 | money
Förf saldo g4 | LevReskSaldoF4 | ZtBaseCurrAmount | 14 | 2 | money
Förf saldo g-- | LevReskSaldoFx | ZtBaseCurrAmount | 14 | 2 | money
Per invoiced amt | PerFaktBel | ZtBaseCurrAmount | 14 | 2 | money
Period | Period | ztInteger | 4 |  | smallint
Period amount paid | PerUtbBel | ZtBaseCurrAmount | 14 | 2 | money
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xSle Supplier statistics


Supplier statistics/item (slea)

The table contains the delivery receipt statistics by item for a supplier.
It is updated when the final delivery of the purchase order row is made.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of exemptions | AntalDispens | ZtLong | 10 |  | int
AntDgrFöre | AntalForeDgr | ZtLong | 10 |  | int
Qty early | AntalForeTid | ZtLong | 10 |  | int
Qty rcvd deliv | AntalInlev | ZtLong | 10 |  | int
No. of returns | AntalReturer | ZtLong | 10 |  | int
AntDgrFörsent | AntalSenDgr | ZtLong | 10 |  | int
No. delayed | AntalSenTid | ZtLong | 10 |  | int
No. of purch orders | AntBest | ZtLong | 10 |  | int
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Order qty (invtry unit) | BestAnt | ZtQty | 14 | 2 | decimal
Ordered amount | BestBelopp | ZtBaseCurrAmount | 14 | 2 | money
Received qty invtry unit | BestLevAnt | ZtQty | 14 | 2 | decimal
Delivery received date | BestLevDat | ztDate |  |  | datetime
Entry date | BestRegDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Received amount | InlevBelopp | ZtBaseCurrAmount | 14 | 2 | money
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Returned qty invtry unit | ReturAnt | ZtQty | 14 | 2 | decimal
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Supplier types (lety)

Definition of supplier types that can be used to divide the suppliers into different groups according to requirements, e.g. for supplier evaluation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Type of supplier | LeverantorsTyp | ztInteger | 5 |  | smallint
Type of supplier | LeverantorsTypBeskr | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Lety Supplier types


Supplier view (vle2)

Supplier-specific information, as an extension of the basic information in the company file.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Approval status | AttestKod1 | ztInteger | 1 |  | smallint
This field is used in the table as follows: |
Posting template | AutoRegel | ztString | 4 |  | varchar
This field is used in the table as follows: |
Account at bank | BankKonto | ztString | 40 |  | varchar
Bank acct check type | BankKontoTyp | ztString | 4 |  | varchar
Upd agrmt fr invoice | BestFaktPris2Avtal | ztBoolean |  |  | char
Upd agrmt fr purch order | BestInpris2Avtal | ztBoolean |  |  | char
Dispatch method | BestLevsattKod | ztInteger | 2 |  | smallint
Dispatch terms | BestLevVilkKd | ztInteger | 2 |  | smallint
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Bank charge | BgUtlBankKost | ztString | 1 |  | varchar
Charge account | BgUtlBelKto | ztString | 1 |  | varchar
Payment method | BgUtlBetForm | ztString | 1 |  | varchar
Priority | BgUtlPrio | ztString | 1 |  | varchar
Separate check | checkind | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Change calc price/item | FaktInpris2Artikel | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight cost % | FraktKostnProc | ZtDecimal73 | 7 | 2 | decimal
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Delivery cost % | HemtKostnProc | ZtDecimal73 | 7 | 2 | decimal
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Purchase blocked | InkopsSparr | ztBoolean |  |  | char
Cust no. at supplier | KundNrHosLev | ztString | 15 |  | varchar
Quality system | KvalitetsSystemKod | ztInteger | 5 |  | smallint
Adm lead time | LedTidAdm | ztInteger | 3 |  | smallint
Lead time from suppl | LedTidEnlLev | ztInteger | 3 |  | smallint
This field is used in the table as follows: |
Lead time extra demand | LedTidExtra1 | ztInteger | 3 |  | smallint
Bank Giro | LevBankgiro | ztBgNr | 11 |  | varchar
Order for no. days | LevBestDagar | ztInteger | 3 |  | smallint
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Type of supplier | LeverantorsTyp | ztInteger | 5 |  | smallint
Total invcd prev yr | LevFaktPreYr | ZtBaseCurrAmount | 14 | 2 | money
Total invc YTD | LevFaktThYr | ZtBaseCurrAmount | 14 | 2 | money
Supplier category | levkategori | ztInteger | 2 |  | smallint
Credit limit | LevKredLim | ZtBaseCurrAmount | 14 | 2 | money
Turnover previous year | LevOmsPreYr | ZtBaseCurrAmount | 14 | 2 | money
Turnover YTD | LevOmsThYr | ZtBaseCurrAmount | 14 | 2 | money
Plus giro no. | LevPostgiro | ztPgNr | 11 |  | varchar
Supplier disc % | LevRabProc | ZtDecimal73 | 6 | 2 | decimal
AP ledger balance | LevReskSaldo | ZtBaseCurrAmount | 14 | 2 | money
Supplier specific text | LevTextKod | ztString | 4 |  | varchar
Subcontract flag | MarkLego | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Mot.bank förbindelse | MotBankForbindelse | ztString | 30 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Joint sorting | PgSamSort | ztString | 1 |  | varchar
Payment method int'l | PgUtlBetalningsSatt | ztchar | 1 |  | char
Recip code int'l | PgUtlMottagarKod | ztchar | 1 |  | char
Priority | Prioritet | ztInteger | 2 |  | smallint
Manufacturing group | ProdGr | ztString | 5 |  | varchar
This field is used in the table as follows: |
Entry date | RegDat | ztDate |  |  | datetime
Centr bank issue no. | RiksBanksArendeNr | ztString | 4 |  | varchar
Ctrl bank code | RiksBanksKod | ztString | 3 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Joint purchase days | SamInKopDagar | ztInteger | 5 |  | smallint
Joint prchs lead time in days | SamInKopHorisontDgr | ztInteger | 5 |  | smallint
Joint purchase (allowed) | SamInKopMark | ztBoolean |  |  | char
Joint purchase weeks | SamInKopVeckor | ztInteger | 5 |  | smallint
Language | SprakKod | ztInteger | 3 |  | smallint
BIC/SWIFTaddress | SwiftMotBankAdress | ztString | 33 |  | varchar
IBAN/SWIFT account | SwiftMotBankKonto | ztString | 40 |  | varchar
SWIFT receiving bank name | SwiftMotBankNamn | ztString | 33 |  | varchar
SWIFT bank location | SwiftMotBankOrt | ztString | 22 |  | varchar
Forward contract | TerminsNr | ZtLong | 10 |  | int
Transport days | TransportTid | ztInteger | 3 |  | smallint
Pmt for final approval | UtbAnkKontFakt | ztBoolean |  |  | char
Payment methods | UtbSlag | ztString | 3 |  | varchar
Payment blocked | UtbSparr | ztBoolean |  |  | char
Non-financial account | UtlBetDebKonto | ztString | 10 |  | varchar
Foreign ZIP/Post code | UtlBetPostNummer | ztString | 10 |  | varchar
International PG no. | UtlPostgiroKontoNummer | ztString | 15 |  | varchar
Foreign PG office | UtlPostgiroKontor | ztString | 5 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar

    This table is the main table in the following programs:

    Program: vle2 Supplier view


Supplier-specific texts (xltx)

Table of supplier-specific texts to print on various documents in the system, such as purchase orders, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Default text | KodDefaultText | ztBoolean |  |  | char
Copyable text | KodFastText | ztBoolean |  |  | char
Choice at copy | KodValCopyText | ztBoolean |  |  | char
Text on PO | LevSpecTextBe | ztBoolean |  |  | char
Text on purchase agreement | LevSpecTextInkAvt | ztBoolean |  |  | char
Supplier specific text | LevTextKod | ztString | 4 |  | varchar
Supplier specific text | LevTextKodBeskr | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Text after document rows | TextEfterDokRader | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xltx Supplier-specific texts


Suppliers (le)

Supplier-specific information, as an extension of the basic information in the company file.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No surcharges | AddArtEjAktiv | ztBoolean |  |  | char
Allow invc qty > disp qty | AllowInvQtyGTDelivQty | ztBoolean |  |  | char
Alt. supplier | Altlevnr | ztCompanyNo | 20 |  | varchar
Arrival handling | AnkomstKod | ztInteger | 5 |  | smallint
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Avg days fr inv dte to pmt | AntInbDgrSnitt | ZtLong | 10 |  | int
Rule match inv/PO | AP2POMatchingRule | ztInteger | 5 |  | smallint
Approval status | AttestKod1 | ztInteger | 1 |  | smallint
This field is used in the table as follows: |
Approved by | attestsign | ztString | 6 |  | varchar
Approval chain | attkedja | ztInteger | 5 |  | smallint
Posting template | AutoRegel | ztString | 4 |  | varchar
This field is used in the table as follows: |
Posting tmplt, final approval | AutoRegelS | ztString | 4 |  | varchar
Round EOQ down to pkg. | AvrEokNerTillForp | ZtDecimal73 | 8 | 3 | decimal
Round EOQ up to pkg. | AvrEokUppTillForp | ZtDecimal73 | 8 | 3 | decimal
Account at bank | BankKonto | ztString | 40 |  | varchar
Bank acct check type | BankKontoTyp | ztString | 4 |  | varchar
Upd agrmt fr invoice | BestFaktPris2Avtal | ztBoolean |  |  | char
Upd agrmt fr purch order | BestInpris2Avtal | ztBoolean |  |  | char
Dispatch method | BestLevsattKod | ztInteger | 2 |  | smallint
Dispatch terms | BestLevVilkKd | ztInteger | 2 |  | smallint
PO type | BestTyp | ztInteger | 3 |  | smallint
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Bank charge | BgUtlBankKost | ztString | 1 |  | varchar
Charge account | BgUtlBelKto | ztString | 1 |  | varchar
Payment method | BgUtlBetForm | ztString | 1 |  | varchar
Priority | BgUtlPrio | ztString | 1 |  | varchar
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Separate check | checkind | ztBoolean |  |  | char
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Currency pocket | Curr_P | ztString | 1 |  | varchar
Delivery from business unit ICT | DelivFromBusinessUnit | ztString | 8 |  | varchar
Dispatch plan->subcontr | DispatchPlanToSubcontractor | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Extra1 | Extra1 | ztString | 30 |  | varchar
Extra2 | Extra2 | ztString | 30 |  | varchar
Extra3 | Extra3 | ztString | 30 |  | varchar
Extra4 | Extra4 | ztFloat | 10 | 2 | float
Invoice match method | FaktAvprTypBest | ztInteger | 3 |  | smallint
Change calc price/item | FaktInpris2Artikel | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Freight cost % | FraktKostnProc | ZtDecimal73 | 7 | 2 | decimal
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Guarantee account | G_BankAccount | ztString | 40 |  | varchar
Guarantee % | G_Percentage | ZtDecimal73 | 5 | 2 | decimal
Third party trade | Handel3Part | ztBoolean |  |  | char
Delivery cost % | HemtKostnProc | ZtDecimal73 | 7 | 2 | decimal
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Allocation purch OH | InkOmkFord | ztInteger | 5 |  | smallint
Purch OH type | InkOmkTyp | ztInteger | 5 |  | smallint
Purchase blocked | InkopsSparr | ztBoolean |  |  | char
Accruals | InterimsKontering | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar, fix disp dates | KalFastLevDagNr | ztInteger | 2 |  | smallint
Calendar, create deliv.plan | KalFastLevPlanDag | ztInteger | 2 |  | smallint
Pmt to acct | KontoIns | ztInteger | 1 |  | smallint
Cust no. at supplier | KundNrHosLev | ztString | 15 |  | varchar
Quality system | KvalitetsSystemKod | ztInteger | 5 |  | smallint
Adm lead time | LedTidAdm | ztInteger | 3 |  | smallint
Lead time from suppl | LedTidEnlLev | ztInteger | 3 |  | smallint
This field is used in the table as follows: |
Lead time extra demand | LedTidExtra1 | ztInteger | 3 |  | smallint
Bank Giro | LevBankgiro | ztBgNr | 11 |  | varchar
Order for no. days | LevBestDagar | ztInteger | 3 |  | smallint
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Type of supplier | LeverantorsTyp | ztInteger | 5 |  | smallint
Total invcd prev yr | LevFaktPreYr | ZtBaseCurrAmount | 14 | 2 | money
Total invc YTD | LevFaktThYr | ZtBaseCurrAmount | 14 | 2 | money
Invoice Type | LevfaktTyp | ztInteger | 3 |  | smallint
Supplier category | levkategori | ztInteger | 2 |  | smallint
Credit limit | LevKredLim | ZtBaseCurrAmount | 14 | 2 | money
Turnover previous year | LevOmsPreYr | ZtBaseCurrAmount | 14 | 2 | money
Turnover YTD | LevOmsThYr | ZtBaseCurrAmount | 14 | 2 | money
Plus giro no. | LevPostgiro | ztPgNr | 11 |  | varchar
Supplier disc % | LevRabProc | ZtDecimal73 | 6 | 2 | decimal
AP ledger balance | LevReskSaldo | ZtBaseCurrAmount | 14 | 2 | money
Supplier specific text | LevTextKod | ztString | 4 |  | varchar
Discount code, item grp | LevVgrpRabGrupp | ztInteger | 4 |  | smallint
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Subcontract flag | MarkLego | ztBoolean |  |  | char
Max add handl chrg invc | MaxAddedDispatchFee | ZtBaseCurrAmount | 14 | 2 | money
Max add handl chrg% invc | MaxAddedDispatchFeePerc | ZtDecimal73 | 8 | 3 | decimal
Max add frght chrg invc | MaxAddedFrghtCost | ZtBaseCurrAmount | 14 | 2 | money
Max add frght chrg% invc | MaxAddedFrghtCostPerc | ZtDecimal73 | 8 | 3 | decimal
Max add insur chrg invc | MaxAddedInsurCost | ZtBaseCurrAmount | 14 | 2 | money
Max add insur chrg% invc | MaxAddedInsurPerc | ZtDecimal73 | 8 | 3 | decimal
Max add pkgng chrg invc | MaxAddedPackagingCost | ZtBaseCurrAmount | 14 | 2 | money
Max add pkgng chrg% invc | MaxAddedPackagingCostPerc | ZtDecimal73 | 8 | 3 | decimal
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Mot.bank förbindelse | MotBankForbindelse | ztString | 30 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Joint sorting | PgSamSort | ztString | 1 |  | varchar
Payment method int'l | PgUtlBetalningsSatt | ztchar | 1 |  | char
Recip code int'l | PgUtlMottagarKod | ztchar | 1 |  | char
Priority | Prioritet | ztInteger | 2 |  | smallint
Manufacturing group | ProdGr | ztString | 5 |  | varchar
This field is used in the table as follows: |
Entry date | RegDat | ztDate |  |  | datetime
Centr bank issue no. | RiksBanksArendeNr | ztString | 4 |  | varchar
Ctrl bank code | RiksBanksKod | ztString | 3 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Exch same day | Same_Day_Exec | ztBoolean |  |  | char
Joint purchase days | SamInKopDagar | ztInteger | 5 |  | smallint
Joint prchs lead time in days | SamInKopHorisontDgr | ztInteger | 5 |  | smallint
Joint purchase (allowed) | SamInKopMark | ztBoolean |  |  | char
Joint purchase weeks | SamInKopVeckor | ztInteger | 5 |  | smallint
Language | SprakKod | ztInteger | 3 |  | smallint
BIC/SWIFTaddress | SwiftMotBankAdress | ztString | 33 |  | varchar
IBAN/SWIFT account | SwiftMotBankKonto | ztString | 40 |  | varchar
SWIFT receiving bank name | SwiftMotBankNamn | ztString | 33 |  | varchar
SWIFT bank location | SwiftMotBankOrt | ztString | 22 |  | varchar
Forward contract | TerminsNr | ZtLong | 10 |  | int
Transport days | TransportTid | ztInteger | 3 |  | smallint
Pmt for final approval | UtbAnkKontFakt | ztBoolean |  |  | char
Payment methods | UtbSlag | ztString | 3 |  | varchar
Payment blocked | UtbSparr | ztBoolean |  |  | char
Non-financial account | UtlBetDebKonto | ztString | 10 |  | varchar
Foreign ZIP/Post code | UtlBetPostNummer | ztString | 10 |  | varchar
International PG no. | UtlPostgiroKontoNummer | ztString | 15 |  | varchar
Foreign PG office | UtlPostgiroKontor | ztString | 5 |  | varchar
Currency | ValKod | ztString | 3 |  | varchar
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax type purchase | VAT_Type_Purchase | ztInteger | 4 |  | smallint
VAT/tax type sales | VAT_Type_Sales | ztInteger | 4 |  | smallint
Voucher no. group | VerNrGrupp | ztString | 6 |  | varchar
ID number | X_IdNr | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: bLe Print AP, all suppliers

    Program: Le Suppliers

    Program: LrLE AP information


Suppliers in RFQ (pkrd)

Suppliers in an RFQ.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Campaign | KampNr | ZtLong | 4 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Purchase agreem designation | pinkavt | ZtLong | 6 |  | int
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Suppliers' bank accounts (lek)

Definition of bank accounts for suppliers (or companies). The accounts are used for outgoing payments.

Code key calculated automatic if jeeves parameter ACCPAY005 activated.

For further information about these bank accounts, please refer to the field help for Account at bank (BankKonto).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Bank | BankId | ztString | 10 |  | varchar
Account at bank | BankKonto | ztString | 40 |  | varchar
Bank acct check type | BankKontoTyp | ztString | 4 |  | varchar
Local bank code | FilialKod | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Guarantee account | G_BankAccount | ztString | 40 |  | varchar
Bank, guarantee acct | G_BankId | ztCompanyNo | 20 |  | varchar
Default bank account | G_Def_Acc | ztBoolean |  |  | char
Guarantee payment | G_Paym | ztBoolean |  |  | char
Guarantee % | G_Percentage | ZtDecimal73 | 5 | 2 | decimal
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Code key | KodNyckel | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SWIFT code | SwiftKod | ztString | 15 |  | varchar
Payment route | UtbetalningsVag | ztString | 6 |  | varchar
Payment methods | UtbSlag | ztString | 3 |  | varchar

    This table is the main table in the following programs:

    Program: Lek Suppliers' bank accounts


Suppliers, KLAS table (vle1)

The table is a mirror of the supplier table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Dispatch method | BestLevsattKod | ztInteger | 2 |  | smallint
Dispatch terms | BestLevVilkKd | ztInteger | 2 |  | smallint
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Cust no. at supplier | KundNrHosLev | ztString | 15 |  | varchar
Bank Giro | LevBankgiro | ztBgNr | 11 |  | varchar
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Supplier category | levkategori | ztInteger | 2 |  | smallint
Turnover previous year | LevOmsPreYr | ZtBaseCurrAmount | 14 | 2 | money
Turnover YTD | LevOmsThYr | ZtBaseCurrAmount | 14 | 2 | money
Plus giro no. | LevPostgiro | ztPgNr | 11 |  | varchar
AP ledger balance | LevReskSaldo | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Priority | Prioritet | ztInteger | 2 |  | smallint
Language | SprakKod | ztInteger | 3 |  | smallint
Pmt for final approval | UtbAnkKontFakt | ztBoolean |  |  | char
Payment methods | UtbSlag | ztString | 3 |  | varchar
Payment blocked | UtbSparr | ztBoolean |  |  | char
Currency | ValKod | ztString | 3 |  | varchar


Suppliers, proposal, invoice matching (PrelimLrFtg)

Alphanumeric designation for the company.

When you enter a company for the first time, this number is not automatically set by the system. You must enter it manually.

This is the unique ID for the company and cannot be changed, which means that if you base it on the company name, e.g. the first letters of the company name, you will not be able to change the ID if the company changes name. It is therefore best to construct the ID a different way or just use sequence numbers. You can search for the company using different terms, e.g. its name.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
SeqNo. | PrelimLrid | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Surcharge, alloying (allt)

Definition of different surcharges per kilo specified in a purchase agreement (item). A surcharge can occur when purchasing plate material as an addition to the base price.

Note! Purchase price lists based on the purchase quantity do not have any support for surcharges.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Surcharge, alloying | LegeringsTillaggBeskr | ztString | 60 |  | varchar
Surcharge, alloying | LegeringsTillaggId | ZtLong | 10 |  | int
Surcharge, alloying | LegeringsTillaggKost | ZtBaseCurrAmount | 14 | 2 | money
New surcharge, alloying | LegeringsTillaggKostNytt | ZtBaseCurrAmount | 14 | 2 | money
Surcharge, alloying (%) | LegeringsTillaggProc | ZtDecimal73 | 8 | 3 | decimal
New surch, alloying (%) | LegeringsTillaggProcNytt | ZtDecimal73 | 8 | 3 | decimal
New surcharge from date | NewAlloySurFromDate | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: allt Surcharge, alloying


SWOT analysis (swot)

Table for setting up SWOT analysis rows.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Obsolete | inaktuell | ztBoolean |  |  | char
Source | infosource | ztString | 80 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | KortNotering | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | sqlidentity | ZtLong | 10 |  | int
SWOT category | swotkat | ztInteger | 5 |  | smallint
SWOT code | swotkod | ztchar | 1 |  | char
SWOT description | swottext | ztBlob | 255 |  | varchar

    This table is the main table in the following programs:

    Program: swot SWOT rows


SWOT category (swotk)

Categorization of SWOT analysis rows.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SWOT category | SWOTkat | ztInteger | 5 |  | smallint
SWOT category | SWOTkatbeskr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: swotk SWOT categories


Symptom types (sht2)

Definition of IRIS symptom codes. This is used when entering service orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Symptom IRIS | Symptom | ztString | 30 |  | varchar
Symptom IRIS | SymptomCode | ztString | 3 |  | varchar

    This table is the main table in the following programs:

    Program: sht2 Symptom codes IRIS


Syntax converter (edic)

Contains the different syntax converters that are to be used when converting EDI messages.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Backup directory | EdiBackupDir | ztString | 255 |  | varchar
In-box directory | EdiInBoxDir | ztString | 255 |  | varchar
In directory | EdiInDir | ztString | 255 |  | varchar
Out box directory | EdiOutBoxDir | ztString | 255 |  | varchar
Out directory | EdiOutDir | ztString | 255 |  | varchar
EDI server no | EdiServerNo | ztInteger | 5 |  | smallint
Syntax converter | EdiSyntaxConvDescr | ztString | 50 |  | varchar
Syntax converter | EdiSyntaxConvNo | ztInteger | 5 |  | smallint
Syntax path | EdiSyntaxConvPath | ztString | 255 |  | varchar
Syntax conv program | EdiSyntaxConvPgm | ztString | 255 |  | varchar
WorkDir | EdiWorkDir | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: edic Syntax converter for EDI


System file, own co. (sy1)

Default values for your own company. Much of the data that is entered here will be given as proposals when working with Jeeves but can be changed.

One record is entered for each company that is to be run in the same database, i.e. if you have a multi company database, you fill in one record for each company and template company. If you use multi company handling, company code 0 should not be used. If there is just one company, the company code should be 0. This makes it easier to identify if it is a single or multi company installation when trouble-shooting in the SQL code for instance.

Note! When entering a new company record, error messages may be displayed regarding missing information in related tables, for example if you accidentally tab to certain drop-down-list fields. If this happens you must empty the form and re-enter the record. (At this stage, all tables in the company being created are empty so the messages can be disregarded.)

You switch company from the drop-down list or the company code field on the toolbar.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
IFNS code | _company_ifns | ztString | 6 |  | varchar
INFS name | _company_ifns_name | ztString | 250 |  | varchar
KPP code | _company_kpp | ztString | 15 |  | varchar
Full company name | _company_namelong_ | ztString | 250 |  | varchar
OGRN code | _company_ogrn_ | ztString | 15 |  | varchar
OKATO code | _company_okato | ztString | 12 |  | varchar
OKFS code | _company_okfs | ztString | 2 |  | varchar
Main OKONH code | _company_okonh_ | ztString | 4 |  | varchar
OKOPF code | _company_okopf | ztString | 2 |  | varchar
Company registration number | _company_okpo_ | ztString | 20 |  | varchar
OKVED code | _company_okved | ztString | 8 |  | varchar
Company registration date | _company_regdate | ztDate |  |  | datetime
Vat reg. date | _company_VAT_date | ztDate |  |  | datetime
VAT reg. serie | _company_vat_serie | ztString | 100 |  | varchar
VAT authority code | _company_vatauth_code | ztString | 4 |  | varchar
VAT authority name | _company_vatauth_name | ztString | 250 |  | varchar
Innev Redov.period | ActPeriod | ztInteger | 4 |  | smallint
Sista dag i period | ActPeriodEnd | ztDate |  |  | datetime
Innev Redov.år | ActRedovisnAr | ztInteger | 4 |  | smallint
Antal period | ActRedovisnArAntPer | ztInteger | 4 |  | smallint
Adjustment for local time | AdjustMinutes2GetLocalTime | ztInteger | 5 |  | smallint
DB owner | Ag | ztString | 32 |  | varchar
DB owner password | AgP | ztString | 60 |  | varchar
Activity type layer | AktTypLayer | ztInteger | 3 |  | smallint
Aging -1 | Alder1 | ztInteger | 3 |  | smallint
Aging -2 | Alder2 | ztInteger | 3 |  | smallint
Aging 3 | Alder3 | ztInteger | 3 |  | smallint
Aging -4 | Alder4 | ztInteger | 3 |  | smallint
Alla fakturor på krav | AllaFaktPaKrav | ztBoolean |  |  | char
Alternative inventory items | AlternativaArtiklar | ztInteger | 5 |  | smallint
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Acquisition method | Anskaffningssatt | ztInteger | 2 |  | smallint
Decimal places | AntDec | ztInteger | 1 |  | smallint
Days demand 1 | AntDgr1Krav | ztInteger | 2 |  | smallint
Days demand 2 | AntDgr2Krav | ztInteger | 2 |  | smallint
Days demand 3 | AntDgr3Krav | ztInteger | 2 |  | smallint
Days demand 4 | AntDgr4Krav | ztInteger | 2 |  | smallint
No. days, due | AntDgrForfallet | ztInteger | 5 |  | smallint
Days to collection | AntDgrInkasso | ztInteger | 2 |  | smallint
Deliv days in time | AntDgriTid | ztInteger | 5 |  | smallint
Max demand letters | AntKrav | ztInteger | 1 |  | smallint
Aut. reported | AoDummyRapp | ztBoolean |  |  | char
Show operation | AoVisas | ztBoolean |  |  | char
Item descr to order row | ArtBeskr_2_Orp | ztBoolean |  |  | char
Markup template | ArtKalkPalKod | ztString | 4 |  | varchar
Item discount class | ArtRabKlass | ztInteger | 3 |  | smallint
Auto avslutsmarkera ver | AutoAvslutAvVer | ztBoolean |  |  | char
Auto generate new year | AutoCreateNY | ztBoolean |  |  | char
Auto create OB | AutoCreateOB | ztBoolean |  |  | char
Auto freight calc | AutoFraktBer | ztBoolean |  |  | char
Auto, credit function | AutoKreditKontrollKod | ztBoolean |  |  | char
Auto order value discount | AutoOrderRabatt | ztInteger | 2 |  | smallint
Auto refresh order | AutoRefreshOnOrder | ztBoolean |  |  | char
Auto booking rule | AutStockBookingRule | ztInteger | 5 |  | smallint
Dispatch point | AvsOrtStation | ztString | 20 |  | varchar
Bank Giro | Bankgiro | ztBgNr | 11 |  | varchar
Customer invoice BG | BankGiroKrFakt | ztBgNr | 11 |  | varchar
Bank Giro OCR | BankGiroOCR | ztBgNr | 11 |  | varchar
Bank | BankId | ztString | 10 |  | varchar
Account at bank | BankKonto | ztString | 40 |  | varchar
Account at bank | BankKonto2 | ztString | 40 |  | varchar
Base currency mask | BaseCurrencyMask | ztString | 30 |  | varchar
Requisition, batch status | BatchConditionAtPlan | ztInteger | 5 |  | smallint
Batch or bin | BatchEllerHylla | ztInteger | 5 |  | smallint
Workload type | BelaggningsKod | ztInteger | 2 |  | smallint
Calc order value | BerOrderVarde | ztBoolean |  |  | char
PO from order, agreement | BestFromOrderAvtKrav | ztInteger | 5 |  | smallint
Dispatch method | BestLevsattKod | ztInteger | 2 |  | smallint
Dispatch terms | BestLevVilkKd | ztInteger | 2 |  | smallint
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Payment terms | BetKod | ztString | 2 |  | varchar
Journal entry type | Bilaga | ztInteger | 5 |  | smallint
Bin=CustNo | BokaHyllaKund | ztBoolean |  |  | char
Booking sequence | BokningsSekvens | ztInteger | 5 |  | smallint
Ange 0 !!!!! | BooleanFalse | ztchar | 1 |  | char
Ange 1 !!!!! | BooleanTrue | ztchar | 1 |  | char
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Bolla & ContoLavoro | CodeBollaContoLavoro | ztBoolean |  |  | char
Contact details | ComNr | ztString | 200 |  | varchar
Create KLAS table | Create_Item_Cus_Supp | ztBoolean |  |  | char
Create order entry statistics | Create_SO_Hist_Stat | ztBoolean |  |  | char
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Currency, decimal places | CurrencyDecimals | ztInteger | 5 |  | smallint
Date mask | datemask | ztString | 30 |  | varchar
Database | DbNameWho | ztString | 30 |  | varchar
Date final approv | Deftoday | ztBoolean |  |  | char
Partial booking allowed | DelBokningTillaten | ztInteger | 5 |  | smallint
Dispatch Qty<=Balance | DeliverAtOrder | ztBoolean |  |  | char
Part delivery allowed | DelLevTillaten | ztInteger | 5 |  | smallint
Availability check | DispCheckAtOrder | ztInteger | 5 |  | smallint
District | Distrikt | ztString | 50 |  | varchar
Penalty interest % | DrRtaProc | ZtDecimal73 | 5 | 2 | decimal
Non-stocked item | DummyArtNrEjLager | ztString | 30 |  | varchar
@zPrompt=null | DummyNull | ztDate |  |  | datetime
EAN location code | EAN_Loc_Code | ztString | 30 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
New MO/flow grp on explosion | EgenThFlgVidVidareNedbr | ztBoolean |  |  | char
Own company no./ ID | EgetFtgNr | ztCompanyNo | 20 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
EU VAT/tax registration no. | EUMomsNr | ztString | 20 |  | varchar
Different invoice booking date | FaktDat_and_BokfDat | ztBoolean |  |  | char
Invoice journal no. | FaktJournal | ZtLong | 6 |  | int
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no. -> voucher | FaktNr_2_vr | ztBoolean |  |  | char
S/N on invoice | Faktura_SerieNr | ztBoolean |  |  | char
Check fixed price | FastPrisKontroll | ztBoolean |  |  | char
Fax no./e-mail address | FaxNr | ztString | 30 |  | varchar
From period | FirstPer | ztInteger | 4 |  | smallint
From period prev yr | FirstPerPrevYr | ztInteger | 4 |  | smallint
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Foreign currency mask | ForeignCurrencyMask | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company rep templates (Matrix) | ForetagKodMatrixMallar | ztInteger | 5 |  | smallint
Auto transport | ForwarderHandling | ztBoolean |  |  | char
Pkg type 1 f SIS | FraktSKollislag1 | ztString | 5 |  | varchar
Pkg type 2 f SIS | FraktSKollislag2 | ztString | 5 |  | varchar
Goods type on DN | FraktSVaruslag | ztString | 30 |  | varchar
Contact->your ref | FtgKontaktToErRef | ztBoolean |  |  | char
Company name | FtgNamn | ztString | 36 |  | varchar
c/o address | FtgPostAdr1 | ztString | 36 |  | varchar
Street addr/box | FtgPostAdr2 | ztString | 36 |  | varchar
Town/City/State | FtgPostAdr3 | ztString | 36 |  | varchar
Visiting address | FtgPostAdr4 | ztString | 36 |  | varchar
ZIP/Post code | FtgPostnr | ztString | 10 |  | varchar
Ledger company | genledcompany | ztBoolean |  |  | char
From category/wholesaler | GrossFromKatKod | ztInteger | 2 |  | smallint
To category/wholesaler | GrossTomKatKod | ztInteger | 2 |  | smallint
Trading area | HandelsOmrKod | ztInteger | 2 |  | smallint
Max margin % | HighBidrProc | ZtDecimal73 | 6 | 2 | decimal
Building number | HusNummer | ztString | 10 |  | varchar
Payment tolerance days | InBetTolDgr | ztInteger | 5 |  | smallint
Payment journal no. | InbJournNr | ZtLong | 6 |  | int
Requisition, agreement claim | InkAnmEnlAvtal | ztInteger | 5 |  | smallint
Collection procedure | inkassoProcedure | ztString | 255 |  | varchar
Intrastat statistics no. | IntStatIdNummer | ztString | 20 |  | varchar
Intrastat, customs identity | IntStatTullId | ztString | 10 |  | varchar
OrderSpec S4 (rcv cost centre) | K4OULager | ztString | 8 |  | varchar
OS-S5 (rcv deliveries) | K5OULager | ztString | 8 |  | varchar
OrderSpec S6 (rcv deliveries) | K6OULager | ztString | 8 |  | varchar
OrderSpec S7 (rcv deliveries) | K7OULager | ztString | 8 |  | varchar
Est hourly cost | KalkKostManTim | ZtBaseCurrAmount | 14 | 2 | money
Calculation process, purchase | KalkylBehandling | ztInteger | 5 |  | smallint
Actual cost from accounting | KalkylIntegrRedov | ztBoolean |  |  | char
Early settlmt discnt aff tax | KassaRab_2_Moms | ztBoolean |  |  | char
CO specific CC (rec) | KBarOULager | ztString | 8 |  | varchar
Alternative units | KodAlternativEnhet | ztInteger | 5 |  | smallint
Customer addr order doc | KodKundAdrBestDok | ztBoolean |  |  | char
Invtry transfer, rebook | KodLagerOmBokning | ztBoolean |  |  | char
Subcontr del note | KodLegoUttag | ztBoolean |  |  | char
Package no. (alpha), prefix | KolliNrAlfaPrefix | ztString | 30 |  | varchar
Municipality | KommunNamn | ztString | 50 |  | varchar
Office number | KontorsNummer | ztString | 10 |  | varchar
Posting method | KontRegKod | ztString | 2 |  | varchar
Reminder code | KravKd | ztBoolean |  |  | char
Show all invoices not due | KravVisaEjForf | ztBoolean |  |  | char
Credit status type | KreditStatusTyp | ztInteger | 2 |  | smallint
Orderspec rcv CC | KstOULager | ztString | 8 |  | varchar
This field is used in the table as follows: |
Orderspec rcv account | KtoNrOULager | ztString | 8 |  | varchar
This field is used in the table as follows: |
Customer no. direct debit | KundNrHosAutogirot | ztString | 6 |  | varchar
Our cust no. at PG | KundNrHosPostgirot | ztString | 5 |  | varchar
County | LaenNamn | ztString | 50 |  | varchar
Layer | laglayer | ztInteger | 2 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Inventory stock type | LagTyp | ztInteger | 2 |  | smallint
Country | LandsKod | ztString | 3 |  | varchar
To period | LastPer | ztInteger | 4 |  | smallint
To period prev yr | LastPerPreYr | ztInteger | 4 |  | smallint
Requisition, lead time req | LedtidInkAnm | ztInteger | 3 |  | smallint
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Supplier invoice journal | LevFaktJourn | ztInteger | 4 |  | smallint
Supplier invoice status | LevFaktStatKod | ztString | 1 |  | varchar
Ship documents | LevHandlKod | ztBoolean |  |  | char
Freight fr point of del | LevKundStyrOrder | ztBoolean |  |  | char
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Log list price change | LoggListPrisAndr | ztInteger | 2 |  | smallint
Min margin % | LowBidrProc | ZtDecimal73 | 7 | 2 | decimal
Increment by 10 | LrAnkVerNr10 | ztBoolean |  |  | char
Show arr vouch no. | LrAnkVerNrVisaDef | ztBoolean |  |  | char
Credit to invoice pmt serv | LrKred_Chk | ztBoolean |  |  | char
Template company | MallForetagKod | ztInteger | 5 |  | smallint
Update template | MallPrisListeUppdat | ztBoolean |  |  | char
Voucher no. type | manver | ztInteger | 2 |  | smallint
All positions same date | MarkIfAllTi2ThStartDate | ztBoolean |  |  | char
Multiple flow groups | MarkIfMultiFlowGroups | ztBoolean |  |  | char
Tot pos lead time->MO | MarkIfTi2ThLedTid | ztBoolean |  |  | char
Unique batch numbers | MarkIfUniqueBatchId | ztBoolean |  |  | char
Ord spec cost price | MarkOrderUniktKalkP | ztBoolean |  |  | char
This field is used in the table as follows: |
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
This field is used in the table as follows: |
Report gen., several companies | MatrixRapportFlerFtg | ztBoolean |  |  | char
Max. amount due | MaxBelForfallet | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax reg no. | MomsRegNr | ztString | 20 |  | varchar
Book multiple batches | MultiBatchBokning | ztBoolean |  |  | char
Print order acknowl. | OeKod | ztBoolean |  |  | char
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Invoice in ONE trans. | Oh_2_Fh_1_Transaction | ztBoolean |  |  | char
CO->MO | Oh_2_Th_Rules | ztInteger | 5 |  | smallint
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Replan requsition | OmplanInkAnm | ztInteger | 5 |  | smallint
Cost | OrderCostCurrency | ztBoolean |  |  | char
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Automatic order packing | OrderPackAuto | ztBoolean |  |  | char
Order packing | OrderPackStatus | ztInteger | 5 |  | smallint
Order spec text | OrderTextKod | ztString | 4 |  | varchar
Delivery note no. | OrdFoljesedelsNr | ZtLong | 10 |  | int
Orderpunkt Beräkning | OrdPktBer | ztInteger | 5 |  | smallint
Disc code order value | OrdvRabKod | ztInteger | 2 |  | smallint
Organization no. | OrgNr | ztString | 18 |  | varchar
Package details on inv | OrpPktDetFa | ztBoolean |  |  | char
Package details on DN | OrpPktDetFs | ztBoolean |  |  | char
Package details on OA | OrpPktDetOe | ztBoolean |  |  | char
Package details on PL | OrpPktDetPs | ztBoolean |  |  | char
Utskriftstyp, paket | OrpStrDetUt | ztInteger | 1 |  | smallint
Price calc method, pkg | OrpStrPrisBer | ztInteger | 2 |  | smallint
Markup% on order spec cost prc | OU_Kalk_Palagg | ztBoolean |  |  | char
Auto pick ord-spec items | OULager_Auto_Utplock | ztBoolean |  |  | char
Order specific; only complete | OULager_Leverera_Allt | ztBoolean |  |  | char
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
This field is used in the table as follows: |
Periodise agreement | PerAvtal_re | ztBoolean |  |  | char
Period | Period | ztInteger | 4 |  | smallint
Period type | PeriodTyp | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Voucher per desc | PerVer | ztInteger | 1 |  | smallint
Show order spec invtry on plan | Planing_Show_OUS | ztBoolean |  |  | char
Picking list range | PlocklistaHyllaBestRes | ztInteger | 5 |  | smallint
Picking list sorting | PlocklistaSorteradPa | ztInteger | 5 |  | smallint
Plus giro no. | Postgiro | ztPgNr | 11 |  | varchar
Pg Rubrik 1 | PostGiroAvsRubrik1 | ztString | 27 |  | varchar
Pg Rubrik 1 (utl) | PostGiroAvsRubrik1Utl | ztString | 27 |  | varchar
Pg Rubrik 2 | PostGiroAvsRubrik2 | ztString | 27 |  | varchar
Pg Rubrik 1 (utl) | PostGiroAvsRubrik2Utl | ztString | 27 |  | varchar
Pg Rubrik 1 (utl) | PostGiroAvsRubrik3Utl | ztString | 15 |  | varchar
Customer invoice PG | PostGiroKrFakt | ztPgNr | 11 |  | varchar
Plus giro OCR | PostGiroOCR | ztPgNr | 11 |  | varchar
Post office | PostKontor | ztString | 50 |  | varchar
Föreg års Red.period | PrevYearLastPeriod | ztInteger | 4 |  | smallint
Föreg Redov.år | PrevYearRedovisnAr | ztInteger | 4 |  | smallint
Pricing method | Prisadaco | ztInteger | 3 |  | smallint
Price list | PrisLista | ztInteger | 5 |  | smallint
Prices incl VAT/tax | PrisListaInklMoms | ztchar | 1 |  | char
Price list, tiered | PrisListaStaffling | ztInteger | 6 |  | smallint
Manufacturing group | ProdGr | ztString | 5 |  | varchar
This field is used in the table as follows: |
Forecast days/yr | PrognosDagar | ztInteger | 3 |  | smallint
Project no. from batch | ProjCodeFromBatch | ztBoolean |  |  | char
State code | provinceCode | ztString | 5 |  | varchar
Calc disp date | PurOrdCalcDelivDate | ztInteger | 2 |  | smallint
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Customer discount handling | RegKundRabatt | ztInteger | 5 |  | smallint
Backorder handling | RestBehKod | ztInteger | 1 |  | smallint
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Interest invoice | RteFaktKd | ztBoolean |  |  | char
INN | RU_INN | ztString | 15 |  | varchar
KPP | RU_KPP | ztString | 10 |  | varchar
OGRN | RU_OGRN | ztString | 15 |  | varchar
OKONH | RU_OKONH | ztString | 30 |  | varchar
OKPO | RU_OKPO | ztString | 20 |  | varchar
Auto balance update | Saldoonline | ztBoolean |  |  | char
Uppd lager vid ankomst | SaldoUpdAnkomst | ztBoolean |  |  | char
Update inventory at inspection | SaldoUpdKontrollAntal | ztBoolean |  |  | char
Salesperson | Saljare | ztString | 6 |  | varchar
Collective invoicing | SamFaktUtskr | ztBoolean |  |  | char
Joint purchase (allowed) | SamInkopMark | ztBoolean |  |  | char
@zPrompt=null | SammaSomArtNrHantering | ztBoolean |  |  | char
Srvc assign start date | SerStartDat | ztDate |  |  | datetime
This field is used in the table as follows: |
Create order | ServCreOrd | ztBoolean |  |  | char
From order no, SO | ServFromNr | ZtLong | 9 |  | int
ServiceOrderNrSerie | ServOrdNrSerie | ztInteger | 3 |  | smallint
This field is used in the table as follows: |
Order type service | ServOrdTyp | ztInteger | 3 |  | smallint
To order no, SO | ServTomNr | ZtLong | 9 |  | int
Show batches balance=0 | ShowBatchSaldoZero | ztBoolean |  |  | char
Phone, show/advise | ShowComKod1 | ztString | 2 |  | varchar
Fax, show/advise | ShowComKod2 | ztString | 2 |  | varchar
Home phone, show/advise | ShowComKod3 | ztString | 2 |  | varchar
No order row history | ShowOrderRadHistorik | ztBoolean |  |  | char
Show row status | ShowOrderRadStatus | ztInteger | 2 |  | smallint
Change sign rev voucher | SignRevVoucher | ztBoolean |  |  | char
Latest pkg sequence no. | SistaKolliLopNr | ZtLong | 10 |  | int
Tax office | SkatteKontor | ztString | 50 |  | varchar
Tax office, address 1 | SkatteKontorAdr1 | ztString | 50 |  | varchar
Tax office, address 2 | SkatteKontorAdr2 | ztString | 50 |  | varchar
Tax office, address 3 | SkatteKontorAdr3 | ztString | 50 |  | varchar
Final appr vouch #-series | SlutAttestNrSerie | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
This field is used in the table as follows: |
Dispatch status per day | StockPlanPerDate | ztBoolean |  |  | char
Streckkod kundfaktura | StreckKodKFakt | ztInteger | 5 |  | smallint
Unit time | StyckTid | ztOpTime | 9 | 4 | float
This field is used in the table as follows: |
SWIFT code | SwiftKod | ztString | 15 |  | varchar
IBAN/SWIFT account | SwiftMotBankKonto | ztString | 40 |  | varchar
Orderv.disc/customer | sy1_kora | ztBoolean |  |  | char
Cost calc at order | sy1_kpb | ztBoolean |  |  | char
Cust disc code | sy1_krbk | ztBoolean |  |  | char
Ord value disc/code | sy1_orbk | ztBoolean |  |  | char
Auto pricing/prod class | sy1_pip | ztBoolean |  |  | char
Active disc matrix | sy1_pri | ztBoolean |  |  | char
Price lists act items | sy1_prl | ztBoolean |  |  | char
Price lists act item grp | sy1_prlv | ztBoolean |  |  | char
Gross ord value/disc | sy1_rbn | ztBoolean |  |  | char
Orderv.disc/cust disc.class | sy1_rora | ztBoolean |  |  | char
Orderv.disc, general | sy1_xorb | ztBoolean |  |  | char
Price/act prod class | sy1_xp | ztBoolean |  |  | char
Check if BOM items OK to use | Ti2MrCheckOkToUse | ztInteger | 5 |  | smallint
Time zone code | TimeZoneCode | ztInteger | 4 |  | smallint
Final record 29 | TK_29 | ztBoolean |  |  | char
Trading, sales price % | TradeFsgMarkup | ztFloat | 7 | 2 | float
Trading, cost price % | TradeKalkMarkup | ztFloat | 7 | 2 | float
Trade reg number | TradeRegNr | ztString | 20 |  | varchar
Trading-processing | TradingAtOrder | ztBoolean |  |  | char
Password UC | UCpassword | ztString | 30 |  | varchar
User name UC | UCusername | ztString | 50 |  | varchar
Fil/dir for AP pmt files | UtbDir | ztString | 60 |  | varchar
AP pmt file NAME ... | UtbFileNameType | ztInteger | 2 |  | smallint
Payment journal no. | UtbJournNr | ZtLong | 6 |  | int
Create vch/pmt file | UtbSkapaPrelVer | ztBoolean |  |  | char
Payment methods | UtbSlag | ztString | 3 |  | varchar
Adjustment type | UtbTyp | ztString | 1 |  | varchar
Valid to use | ValidToUse | ztBoolean |  |  | char
Currency clause | ValKlausul | ztInteger | 5 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Difference to be rounded | verregdiff | ZtBaseCurrAmount | 14 | 2 | money
Weight/volume automatic | ViktSumOrder | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: AccountsPayable_PO_2_GL_Rep Log of invoice matching against PO

    Program: AccountsPayable_PO_2_GL_Rep_GL Log of invoice checking against order (year/per/voucher no.)

    Program: Bia2Th Multiple MOs from requisition

    Program: CompanyAccess User access to companies

    Program: ItemRevision_r01 Item revisions

    Program: ItemRevision_r02 Item revision, changes

    Program: JvsSiteLangImport Difference in language import

    Program: JvsSiteRepSort_1 Sort settings, program name

    Program: KLopNr Latest package sequence no.

    Program: PalletHead_Tripasin_Rep Packing info concerning pallet

    Program: PlRp Copy planned to reported activities

    Program: pUohF Preview invoice

    Program: pUohFD Preview invoice detail posting

    Program: pUohFP Preview invoice, PG pmt slip

    Program: pUohSF1 Preview collective invoice

    Program: pUohSFD Preview collective inv detail posting

    Program: rAcO On account not invoiced

    Program: rAcOUoh Create on account invoice

    Program: rAgMedGi Direct debit permission

    Program: rAk Print auto posting template

    Program: rAkfd Batch auto posting and allocation

    Program: rAkfdEx Close auto posting and allocation

    Program: RakfdL Log auto posting and allocation

    Program: rAkfh Print definitions

    Program: rAkft Print integration type definitions

    Program: rAkftP Print product acct definitions

    Program: rAklt Print definitions

    Program: rakon Print auto posting/allocation rules

    Program: rAkop Print labour posting rules

    Program: rAku Print templ, pmts/pmt type/bank accts

    Program: rAkvt Print auto posting/allocation details

    Program: rAlag Work group

    Program: rAlInb Print posting templ, incoming pmts

    Program: rAo_b1 Availability check, planned balance

    Program: rAo_b2 Availability check, invtry reservations

    Program: rAo1 Labour operations by mfg group

    Program: rAo15 Op list, job ticket

    Program: rAo15_SFR Op list, job ticket

    Program: rAo16 Op list, job ticket + mtrl list

    Program: rAo16_SFR Op list, job ticket + mtrl list

    Program: rAo1a Labour operations by mfg group

    Program: rAo2 Labour operations by flow grp

    Program: rAo2p Reconciling amount differences

    Program: rAo2pD Account differences

    Program: rAo2pD2 Account differences

    Program: rAo2Workload Links planned work - det.workload

    Program: rAo2Workload_wo Links planned work - det.workload, order by mo

    Program: rAo4a Reprint job ticket

    Program: rAo4a_SFR Reprint job ticket

    Program: rAo4e Job tickets (not printed)

    Program: rAo5 Job tickets + address labels

    Program: rAo5_SFR Job tickets + address labels

    Program: rAo6 Job tickets + material list

    Program: rAo6_SFR Job tickets + material list

    Program: rAo6A Reprint job ticket + material list

    Program: rAo6A_SFR Reprint job ticket + material list

    Program: rAo6E Job tickets + material list (not printed)

    Program: rAo6E_SFR Job tickets + material list (not printed)

    Program: rAoh1 Invtry per order

    Program: rAok1 Scrap reason codes

    Program: rAor Completed labour reports

    Program: rAorAr Labour reports per item

    Program: rAorFlg Labour reports per flow group

    Program: rAorPg Labour reports per mfg group

    Program: rAorS21 Labour reports per person

    Program: rAorTh1 Labour reports per order

    Program: rAorVtC Labour journal and voucher, detailed

    Program: rAorVtCq Labour journal and voucher, summary

    Program: rAr Item list

    Program: rArAl Item/supplier

    Program: rArat Item types

    Program: rAratABC Item types, calculate ABC codes

    Program: rAratPs Item types, safety stock grps

    Program: rArData Print item data

    Program: rAri1 Serial no. items

    Program: rAri2 Serial no. items with components

    Program: rArk Print item PYR ....

    Program: rArkh Calculation header, item

    Program: rArkh2 Item calc, detailed

    Program: rArkhC1 Detailed calculations

    Program: rArkhC1Inv Detailed cost calculations, inventory location

    Program: rArkl Cost price changes

    Program: rArkv Calculation versions

    Program: rArkvD1 Item calculation

    Program: rArkvK Cost price calc (pyramidic)

    Program: rArkvK2 Cost price calc (pyramidic) + upd

    Program: rArla1 Item/inventory loc data

    Program: rArlaABC Print ABC analysis

    Program: rArlaBB Purch/mfg requisition (OP)

    Program: rArlaBBl Purch/mfg requisition (OP)) disp ord

    Program: rArlaBP Purch/mfg requisition (planning)

    Program: rArlaBx Requisition (plan by item)

    Program: rArlaDA Reprint purchase order

    Program: rArlaDe PO from requisition, not printed

    Program: rArlaLe Balance/main supplier

    Program: rArlaLv Current inventory value

    Program: rArlaLv2 Inventory value, item group

    Program: rArlaQ Update forecast, OP, SS, EOQ ...

    Program: rArlgB1 Item -> purchase requisition

    Program: rArlgB2 Purch requisition (available balance)

    Program: rArlgB3 Purch requisition (phys balance)

    Program: rArOpSr Item/operation/BOM

    Program: rArpk Print product accounts

    Program: rArpl List price changes

    Program: rArPlan Item planning list

    Program: rArsf Inventory loc transfers, date

    Program: rArsh Printout bins

    Program: rArsi Item, serial no., bin

    Program: rArsiNeg Negative invtry bal for bins

    Program: rArsk Inventory value/cost prc change

    Program: rArskAr Inventory value/item cost prc change

    Program: rArskPer Inventory value/period cost prc change

    Program: rArskVtC Cost price change journal and voucher

    Program: rArsm Manual inventory transactions

    Program: rArsmAr Inventory transactions per item

    Program: rArsmH Inventory transactions per entry journal

    Program: rArsmHVtC Inventory journal and voucher

    Program: rArsmKo Inventory transactions per account

    Program: rArsmVtC Inventory journal and voucher

    Program: rArsp Order-specific items

    Program: rArspA Order-specific items, ALL

    Program: rArspksA Order-spec inventory, cost centre, ALL

    Program: rArspKst Order-spec inventory, cost centre, CO

    Program: rArspkzA Order-spec inventory, cost centre, ALL

    Program: rArspKzt Order-specific stock, cost centre

    Program: rArspOh Order-spec inventory, cust order

    Program: rArspOhA Order-spec inventory, cust order, ALL

    Program: rArspTh Order-specific inventory, MO

    Program: rArspThA Order-spec inventory, cust order, ALL

    Program: rArsq1 Order-specific transaction date

    Program: rArsq5 Order-spec transactions, CO

    Program: rArsqVtC Inventory journal and voucher

    Program: rArsx1 Item forecast

    Program: rArtKalkBer Calculation of cost prices

    Program: rArvl Print log of item group change for item

    Program: rArvl_upd Updating item's item group in all tables

    Program: rAtkh Approval chain

    Program: ratkr Approval chain

    Program: rAtt Approvals

    Program: rAttr_agr Print agreements

    Program: rAttr_agr2 Print agreements salarytype

    Program: rAttr_agr3 Print agreement reason

    Program: rAttr_Auth Print authorization group

    Program: rAttr_daysched Print dayschedule

    Program: rAttr_daysched2 Print compensation schedule

    Program: rAttr_Dep Print departments

    Program: rAttr_prv01 Print personalinformation

    Program: rAttr_prv02 Print accumulator

    Program: rAttr_prv03 Print personal / auth.group

    Program: rAttr_Reason Print reasoncodes

    Program: rAttr_salcd Print salarycodes

    Program: rAttr_saltp Print salarytypes

    Program: rAttr_Schgrp Print schedule group

    Program: rAttR_schtempl Print dayschedule

    Program: rAttr_tc Print timecolumns

    Program: rAttr_tt Print timetypes

    Program: rAttr_tt2 Print timetypes - classes

    Program: rAttr_ttcl Print timetypeclasses

    Program: rAviexpU Create dispatch notice (EDI/Odette)

    Program: rAvstKr Reconciliation AR - GL

    Program: rAvstKrD Reconciliation AR - GL, invoices

    Program: rAvstLR Reconciliation AP - GL, balance

    Program: rAvstLrA Reconciliation AP - GL, clearing acct

    Program: rBat Printout batches

    Program: rBatBokning Batch booking

    Program: rBatLag Item, batch, balance

    Program: rBatOverBokning Overbooked batches

    Program: rBE_VAT_Total VAT/tax report

    Program: rBE_VAT_Total_Det VAT/tax report with details

    Program: rBE_VAT_Total_pre Preliminary VAT/tax report

    Program: rBE_VAT_Total_Re Reprint VAT/tax report

    Program: rbeank2_invdoc Inventory document

    Program: rBerRtaNi Interest calculation interest spec

    Program: rBerRtaS Calculate interest

    Program: rBha Purchase agreement

    Program: rBhaA Reprint purchase agreement

    Program: rBhaE Purchase agreement (not printed)

    Program: rBhaKr Purchase agreement, campaign

    Program: rBhAoA PO subcontract, reprint

    Program: rBhAoE PO, subcontract (not printed)

    Program: rBhBiaDA Reprint purchase order

    Program: rBhBiaDE PO from requisition, not printed

    Program: rBhBiaPA Reprint purchase order

    Program: rBhBiaPE PO from requisition, not printed

    Program: rBhBiXDA Reprint purchase order

    Program: rBhBiXDE PO from requisition, not printed

    Program: rBhDok Purchase order

    Program: rBhDokA Reprint purchase order

    Program: rBhDokE Purchase order, not printed

    Program: rBhDokF Purchase order, RFQ

    Program: rBhDokH Purchase order history

    Program: rBhOEC NEW PO acknowledgement, all rows

    Program: rBhOEC1 NEW PO acknowledgement, changed rows

    Program: rBhPdm1 Purchase order, PDM info

    Program: rBhRestD Purchase order, backorder

    Program: rBhSelfinvA Company invoice, reprint

    Program: rBhSelfinvE Company invoice, not printed

    Program: rBhSRap1 Manually reconciled POs

    Program: rBhVatinvA VAT/tax invoice, reprint

    Program: rBhVatinvE VAT/tax invoice, not printed

    Program: rBia Purch requisitions chronological order

    Program: rBiaa1 Print closed requisitions

    Program: rBiaa2 Print closed requisitions (supplier)

    Program: rBiaa3 Print closed requisitions (item)

    Program: rBiah1 Requisition

    Program: rBiahDA Reprint purchase order

    Program: rBiahDE PO from requisition, not printed

    Program: rBiaLe Requisitions/supplier

    Program: rBiaLeX Requisitions/supplier

    Program: rBiaMRP1 Replanning requisitions chronological order

    Program: rBiaPla Requisitions/purchasing manager

    Program: rBiaPlaX Requisitions/purchasing manager

    Program: rBiaPRP1 Replanning requisitions chronological order

    Program: rBiaX Purch requisitions chronological order

    Program: rBOE_Jrnl_discount Bills of exchange for discounting

    Program: rBOE_Jrnl_encashment Bills of exchange for encashment

    Program: rBp PO rows, in order of PO number

    Program: rBpa Printout of arrival reports

    Program: rBpaBh Arrivals, PO

    Program: rbpak For arrival inspection

    Program: rBpakBh Received, not inspected

    Program: RBpakPF PALLET FLAG

    Program: rBpAr PO rows per item

    Program: rBpBh Purchase order rows

    Program: rBpBhL Purchase order rows, received

    Program: rBpBhLPF PO rows, received, PALLET FLAG

    Program: rBpBhR PO rows, not received

    Program: rBpf Print invoice matching

    Program: rBpfAr Print invoice matching/item

    Program: rBpfLe Invoice matching/suppliers

    Program: rBpi Print received deliv

    Program: rBpiAr Print received deliv, item

    Program: rBpiBh Received deliveries, purchase orders

    Program: rBpiBh2 Received deliveries, value, POs (0)

    Program: rBpiBh3 Received deliveries, value, POs (?)

    Program: rBpiBh4 Received deliveries, value, POs (*)

    Program: rBpiLe Print received deliveries/supplier

    Program: rBpiVtC Receiving journal POs and voucher

    Program: rBpl1 EDI receipts, incorrect

    Program: rBpl2 EDI receipts

    Program: rBpLD PO rows, date

    Program: rBpLe PO rows, supplier

    Program: rBpReAr Check invoice matching, items

    Program: rBpReLe Check invoice matching, suppliers

    Program: rBprh Purchase price lists

    Program: rBpSR2 Manually reconciled PO rows

    Program: rBrd Print budget details

    Program: rBrdKt Print budget details/cost centre

    Program: rBrdKtKo Print CC/acct/budget details

    Program: rBrhp Prel/ext budget transactions

    Program: rCashbook Cash book list

    Program: rCashbookPeriod Cash book list period

    Program: rCashbookSaldo Cash book list balance

    Program: rCashReceipt Cash receipt

    Program: rCheckBankReport Checks for collection

    Program: rChkbrec Reconciliation list check

    Program: rChkTkt Verify balances (vr-tkt)

    Program: rCKapl1 Create op join list

    Program: rCreSolh Joint picking, create list

    Program: rCrMemoK Credit memo, copy

    Program: rCrMemoO Credit memo, original

    Program: rCrMemoP Credit memo, preview

    Program: rCSkus Create statistics, customer + period

    Program: rCSle Create supplier history

    Program: rCSvgp Create statistics, item groups

    Program: rCustcard Customer card

    Program: rDelfor EDI dispatch plan

    Program: rEdfSbi SBI report

    Program: rEdiPri1 Sales price lists EDI complete

    Program: rEdiPri2 Sales price lists EDI, changes

    Program: rEspr Execute stored procedure

    Program: rEUPerA EU-quarterly report (reprint)

    Program: rEUPerE EU quarterly report (not printed)

    Program: rEx1 Expense and material issue

    Program: rExExt External costs

    Program: rFakt Invoicing

    Program: rFakteB Printout of Invoice eBrev

    Program: rFaktFfh Invoicing of delivery note

    Program: rFaktFri Print invoices by release time

    Program: rFaktFU Reprint invoice

    Program: rFaktFUL Reprint invoices (disp order)

    Program: rFaktK Invoicing (Receipt)

    Program: rFaktKFU Re-invoicing (Receipt)

    Program: rFaktKus Invoicing by cust no.

    Program: rFaktP Print amendment invoice

    Program: rFaktPFU Reprint amendment invoice

    Program: rFaktSeb Collective invoicing per customer eBrev

    Program: rFaktSF1 Collective invoicing per deliv.customer

    Program: rFaktSF2 Collective invoicing per pay.customer

    Program: rFaktSFOU1 Coll.invoicing order+assignment per deliv.cust

    Program: rFaktSFOU2 Coll.invoicing order+assignment per pay.cust

    Program: rFaTransJ1 Fixed assets transactions journal

    Program: rFaTransJ2 Fixed assets trans jrnl with GL postings

    Program: rFbsBgF Create BG payment file

    Program: rFbsNVS1 Post to journal as paid

    Program: rFbsPGf Create PG payment file

    Program: rFbsX2uv Create payment file

    Program: rFFhA1L ... (Address label 151.4/single) ...

    Program: rFFhA1LA Address label (151.4)/single (reprint)

    Program: rFFhA1LE Addr label (151.4)/single (not printed)

    Program: rFFhA2L ... (Address label 151.4/double) ...

    Program: rFFhA2LA Address label (151.4)/double (reprint)

    Program: rFFhA2LE Addr label (151.4)/double (not printed)

    Program: rFFhBgL ... (Goods address label) ...

    Program: rFFhBgLA Goods address label (reprint)

    Program: rFFhBgLE Goods address label (not printed)

    Program: rFFhBpL ... (Package address label)...

    Program: rFFhBpLA Package address label (reprint)

    Program: rFFhBpLE Package address label (not printed)

    Program: rFFhFpl ... (Postal label) ...

    Program: rFFhFplA Postal label (reprint)

    Program: rFFhFplE Postal label (not printed)

    Program: rFFhFS ... (Delivery note) ...

    Program: rFFhFSA Delivery note (reprint)

    Program: rFFhFSE Delivery note (not printed)

    Program: rFFhFSF ... (Delivery note, invoiced)...

    Program: rFFhFSFA Delivery note, invoiced (reprint)

    Program: rFFhFSFE Delivery note, invoiced (not printed)

    Program: rFFhFSK ... (Delivery note, customer) ...

    Program: rFFhFSKA Delivery note, cust (reprint)

    Program: rFFhFSKE Delivery note, cust (not printed)

    Program: rFFhFSL ... (Delivery note, subcontr) ...

    Program: rFFhFSLA Delivery note, subcontr (reprint)

    Program: rFFhFSLE Delivery note, subcontr (not printed)

    Program: rFFhFvL ... (SIS freight bill) ...

    Program: rFFhFvLA SIS freight bill (reprint)

    Program: rFFhFvLE SIS freight bill (not printed)

    Program: rFfhPL ... (Picking list, delivery note)...

    Program: rFfhPLA Picking list, deliv note (reprint)

    Program: rFfhPLE Picking list, deliv note (not printed)

    Program: rFfhPs ... (Packing slip) ...

    Program: rFfhPsA Reprint packing slip

    Program: rFfhPsE Packing slip (not printed)

    Program: rFfhPsK ... (Compressed packing slip) ...

    Program: rFfhPsKA Compressed packing slip (reprint)

    Program: rFfhPsKE Compressed packing slip (not printed)

    Program: rFh Cust invoices by invc number

    Program: rFhAdv AR advance invoices as of (invc no.)

    Program: rFhFfDt Cust invoices by due date

    Program: rFhFhP AR as of (invc no.)

    Program: rFhFhvt Posting details, customer invoice

    Program: rFhInb Cust open invoices & pmts

    Program: rFhInbKo Cust open invc, pmt and posting

    Program: rFhJ Invoicing journal

    Program: rFhKAvst Customer invoice, cash reconciliation

    Program: rFhKreK Customer invoice credit check

    Program: rFhKstP AR, as of (CC)

    Program: rFhKus Cust invoices by payer no.

    Program: rFhKusP AR as of (customer)

    Program: rFhKusPVal AR as of (Currency)

    Program: rFhKusV AR, as of voucher date

    Program: rFhPer Invoicing/period

    Program: rFhPerK Invoicing by period/account

    Program: rFhSFfDt Invoices by due date and seller

    Program: rFhUtskr Reprint invoice

    Program: rFhVtC Invoicing journal and voucher

    Program: rFhVtCNr Invoicing journal and voucher per invoice

    Program: rFhVtCX Invoice journal and voucher per invoice

    Program: rFktAFfh Reprint invoicing of delivery note

    Program: rFktF Invoice, print preview

    Program: rFktFfhF Invoice deliv note, print preview

    Program: rFktFsk Print advance invoice

    Program: rFktFskA Reprint Advance invoice

    Program: rFktKusF Invoicing, cust no seq, print preview

    Program: rFktPF Amendment invoice, print preview

    Program: rFktSF1F Coll Inv per dest (cust), print preview

    Program: rFktSF2F Col Inv per pay (cust), print preview

    Program: rFlg Flow groups

    Program: rFlgBaoD Workload, day

    Program: rFlgBaoP Workload, period

    Program: rFlgBaoW Workload, week

    Program: rFlgPia Open orders, WIP

    Program: rFlgResAck Reset accumulators on flow group

    Program: rFlgTh Flow groups, main orders

    Program: rFlgTi Flow groups, suborders

    Program: rFlgTiF Flow groups, suborder due date

    Program: rFlgTiS Flow group, suborder start date

    Program: rFMail Print messages

    Program: rFnk Print cust no. changes

    Program: rFomr Foreman area

    Program: rFomr2 Foreman area, work group

    Program: rFrkl Post deliveries between units

    Program: rFt Detailed invoicing statistics

    Program: rFtA Item invoicing history

    Program: rFtF Customer invoicing history

    Program: rFtg1 Companies & contacts

    Program: rFtg2 Companies & contacts (new page per co.)

    Program: rFtgKr Create campaign

    Program: rFtS Invoicing stats, seller

    Program: rFtV Invoicing year, period, item group

    Program: rFtV2 Invoicing item grp, item, year, period

    Program: rFtV3 Invoicing item group, year, period

    Program: rFvr2Vr Transfer journal

    Program: rFvr2VrK Printout, transferred journal(s)

    Program: rFvtCash Cashbook

    Program: rFvtj2Vr Transfer journal

    Program: rFvtjKop Reprint, transfer journal

    Program: rFvtPay Cash payment in/out

    Program: rGLAPReprint Reprint AP revaluation voucher

    Program: rGLARReprint Reprint AR revaluation voucher

    Program: rGlAs GL account specification

    Program: rGlReprint Reprint revaluation voucher

    Program: rhb General ledger

    Program: rHbK3 General ledger by acc seg 3

    Program: rhbkst General ledger by cost centre

    Program: rhbv General ledger by voucher no.

    Program: rHMvt Print interim vouchers

    Program: rHMvtH Print totals per voucher header

    Program: rHr Planned activities (not finished), sign, dates

    Program: rHr1A Planned activities, sign, dates

    Program: rHr2 Planned activities (not finished), assignments, dates

    Program: rHr2A Planned activities, assignments, dates

    Program: rHrp Print reported activities

    Program: rHrPersPrj Planned activities, person, project

    Program: rHrpHrp Reported activities/project

    Program: rHrpHrpQ Log reported activities

    Program: rHrpPe Reported activities/person

    Program: rHrT Planned activities (to do)

    Program: rInb1 Payments per customer

    Program: rInbD Pmts/cust and other invoices

    Program: rInbDet Incoming pmts by period

    Program: rInbDKo Incoming pmts by period, claim acct

    Program: rInbDKo2 Incoming pmts by period/cash account

    Program: rInsk Tax depreciation journal

    Program: rinsk01 Tax depreciation with posting

    Program: rInt1 List fixed assets

    Program: rInt2 List fixed assets per group

    Program: rInt3 List fixed assets per cost centre

    Program: rInt4 List fixed assets, clear sold/scrapped

    Program: rInt5 List preliminary fixed assets

    Program: rInt6 List fixed assets, sold/discarded

    Program: rinttDocA Fixed assets transactions, reprint

    Program: rinttDocAB Fixed assets transactions sums, reprint

    Program: rinttDocE Fixed assets transactions, not printed

    Program: rinttDocEB Fixed assets transactions sums, not printed

    Program: rInttInt Fixed assets transactions, history

    Program: rInttVtC Fixed assets journal and voucher

    Program: rInva2 Depreciation journal

    Program: rInva3 Depreciation journal with GL postings

    Program: rInvjIL Physical inventory list

    Program: rInvjIL_variant Physical inventory list - variant

    Program: rInvjIR Physical inventory results

    Program: rInvjIR_variant Physical inventory results - variant

    Program: rInvjRE Create voucher from phys inventory

    Program: rInvjRH Physical inventory results/bin

    Program: rInvLocSTock Stock quantity on inventory location

    Program: rInvoic Supplier invoices EDI

    Program: rInvoicU Create invoice (EDI/Odette)

    Program: rIt2p1 (Re)planning ... (item)

    Program: rIt2p2 (Re)planning ... (planning mgr)

    Program: rIult Print invtry/assembly

    Program: rJag Print direct debit journal header

    Program: rJagFh Print direct debit journal details

    Program: rJagX2iv Create direct debit file acc/pmt route

    Program: rJaor Labour journal header

    Program: rJaorAor Labour reporting

    Program: rJaorVtC Labour journal, integration

    Program: rJaorVtX Show labour journal posting

    Program: rJark Cost change journal header

    Program: rJarkArk Cost change per journal

    Program: rJarkVtA Cost price change journal, integration

    Program: rJbpi Receiving journal POs, header

    Program: rJbpi1 Receiving journal POs, details

    Program: rJbpi2 Receiving journal POs, details w posting

    Program: rJbpi3 Receiving journal POs, integration

    Program: rJder Error messages in triggers/procedures

    Program: rJf Invoicing journal header

    Program: rJfbs Payment service journal

    Program: rJfbsFb Outgoing payments per journal

    Program: rjFbsFFdt Payments (due date)

    Program: rjFbsLev Payments (supplier)

    Program: rjFbsVal Payments (currency)

    Program: rJfFh Invoicing journal w invoices

    Program: rJfhk Payment reminder log

    Program: rJfhkDet Reminder batch, cust details

    Program: rJfhkInk Basis for collection

    Program: rJfhkKus Reminder batch/customer totals

    Program: rJfVt Invoicing journal, integration

    Program: rJi Incoming pmt journals

    Program: rJibp Journal

    Program: rJibp2 Journals rcvd deliv, bin

    Program: rJibp3 Journals rcvd deliv, trans time

    Program: rJiInb Incoming payment journal

    Program: rJiKv Reciept

    Program: rJiKvA Reprint receipt

    Program: rJiKvK Ready flag & receipt

    Program: rJint2 Fixed assets transactions journal

    Program: rJint3 Fixed assets trans jrnl with GL postings

    Program: rJiUtch Print check

    Program: rJivt Create voucher fr incoming pmt

    Program: rJiVtP Reprint vouchers

    Program: rJkm Print company consol. log

    Program: rJkplFS ... (Delivery note) ...

    Program: rJkplFSA Delivery note, reprint

    Program: rJkplFSE Delivery note, not printed

    Program: rJkplPL ... (Picking list) ...

    Program: rJkplPLA Picking list (reprint)

    Program: rJkplPLE Picking lists (not printed)

    Program: rJkplPlk Picking list

    Program: rJks Print company consol. log

    Program: rJksOut Create transfer to company

    Program: rJKur Print interest calc batches

    Program: rJKurKdt Print interest calculation, cust details

    Program: rJKurKus Print interest calc, cust totals

    Program: rJl Print inventory journal hdr

    Program: rJlth Print inventory journal hdr

    Program: rJlthLth Print inventory trans

    Program: rJmru1 Material journal header

    Program: rJmru2 Material journal

    Program: rJmru3 Material journal, integration

    Program: rJmsg Log/error messages

    Program: rJoru2 Picked orders

    Program: rJoru3 Picking journal, integration

    Program: rJoul Print inventory journal hdr

    Program: rJoulTR1 Order-specific trans

    Program: rJoulVt Print inventory/accounting

    Program: rJth1 Mfg receiving journal header

    Program: rJth2 Print calc/accounting

    Program: rJtii1 Receiving journal mfg header

    Program: rJtii2 Received deliveries mfg

    Program: rJtii3 Receiving journal mfg, integration

    Program: rJtkk Cost postings journal, manufacturing

    Program: rJu Planned/actual supplier pmts

    Program: rJuP Print pmt jrnl header

    Program: rJuPol Payment note

    Program: rJuUtBg Create BG payment file

    Program: rJuUtch Print check

    Program: rJuUtPg Create PG payment file

    Program: rJuVt Create payment voucher

    Program: rJuvtP Reprint payment voucher

    Program: rJuX2uv Create payment file

    Program: rJvsd5 Print report

    Program: rJvsd6 Print report and specs

    Program: rJvsk Open reports

    Program: rK4 Print acct segment 4

    Program: rK4X Print acct segment 4

    Program: rK5 Print acct segment 5

    Program: rK5X Print acct segment 5

    Program: rK6 Print acct segment 6

    Program: rK6X Print acct segment 6

    Program: rK7 Print acct segment 7

    Program: rK7X Print acct segment 7

    Program: rKalkPrisPerLgr Calculated cost prices

    Program: rKapl1 Op join lists

    Program: rKapl2 Op join lists and their operations

    Program: rKapl4 Op join lists, their operations and mtrl

    Program: rKb Print acct segment 3

    Program: rKbX Print acct segment 3

    Program: rKlapNv Posting slips for PO

    Program: rKlapNva Posting slips, PO copy

    Program: rKlapslo Posting slips incl. outgoing payment Copy

    Program: rKlpslo Posting slips incl. outgoing payments

    Program: rKo Chart of accounts

    Program: rKoAll Account definition detail 1

    Program: rKoAllX Account definition detail 2

    Program: rKoDag1 Daily reconciliation, account

    Program: rKoDag2 Daily reconciliation, account per date

    Program: rKodcag1 Daily reconciliation, account, currency

    Program: rKodcag2 Daily reconciliation, account, currency per date

    Program: rKoLap Posting slips w final approval

    Program: rKoLapA Reprint posting slips w final approval

    Program: rKontLaA Reprint posting slips

    Program: rKontLap Posting slips

    Program: rKora Order discounts by customer

    Program: rKoSal Balance by account

    Program: rKoX Chart of accounts

    Program: rKoXAll Account definition detail 1

    Program: rKoxAllX Account definition detail 2

    Program: rKp1 Companies and contacts

    Program: rKp2 Contacts

    Program: rKpKr Create campaign

    Program: rKravKpr Print/reprint reminder

    Program: rKravOM Print/reprint reminders with specific text

    Program: rKravOMk Print/reprint reminders (special)

    Program: rKravPrt Print/reprint reminders

    Program: rKrd1 Campaigns per campaign, company and contact

    Program: rKrd2 Campaigns per company, contact and campaign

    Program: rKrFtg1 Company & contact (within campaign)

    Program: rKrKrd1 Campaigns incl. contacts

    Program: rKrLikv Customer balance as of (Liq Prog)

    Program: rKrSal Customer balance list, current

    Program: rKrSalP Customer balance list, as of

    Program: rKrSalPD Customer balance list as of with details

    Program: rKrSalVa Customer balance as of (ccy sum)

    Program: rKrSalVd AR as of (Forecast, Currency tot, Det)

    Program: rKrVal Currency summary AR

    Program: rKt Print cost centre

    Program: rKtl Transfer customer invoice to AP

    Program: rKtX Print cost centre

    Program: rKuar Customer-specific item data

    Program: rKuKrav Create payment reminder

    Program: rKuKrvSP Create and print reminders

    Program: rKuKrvSPEb Create and print reminders (eBrev)

    Program: RKus AR ledger, current

    Program: rKus1 Companies & contacts

    Program: rKusb Print payment injunctions

    Program: rKusbDet Print pmt injunction details

    Program: rKusBKF Reminder block removal proposal

    Program: rKusBKU Remove reminder block

    Program: rKusData Customer data

    Program: rKusFfhC Create delivery notes

    Program: rKusFh Cust invoices by invc number

    Program: rKusHrp Print reported activities

    Program: rKusi Print collection batches

    Program: rKusiaDet Print collection details

    Program: rKusiDet Print collection details

    Program: rKusKreK Customers, credit check

    Program: rKusKreL Credit limit exceeded

    Program: rKusKU Account statement BCU

    Program: rKusKUbr Account statement in currency

    Program: rKusL Customer listing

    Program: rKusO Turnover per customer

    Program: rKusP AR, as of

    Program: rKusPVAV AR, as of voucher date reconc

    Program: rKusPVer AR, as of voucher date

    Program: rKusRtaNi Calc/print interest spec

    Program: rKusRtaS Calc/print interest invoices

    Program: rKusSol Customer solvency

    Program: rkusSpec AR customer specification, as of

    Program: rKusverF AR, as per voucher date Company name

    Program: rKvr Shortcut codes, voucher entry

    Program: rLaborOpJoinPickingList_1 Op join lists, their operations and mtrl

    Program: rLagSal Print inventory bal

    Program: rlagst Invtry loc listing

    Program: rLagV Current inventory value

    Program: rLagVPer Inventory value/item, as of

    Program: rLagVPk Curr invtry value/prod acct

    Program: rLagVVg Curr inventory value/item grp

    Program: rLavt Inventory journal, integration

    Program: rLbSPhase Lost business opportunities per sales phase

    Program: rLBstatus Lost business opportunities per status

    Program: rLe Supplier listing

    Program: rLeAttP Accounts Payable

    Program: rLeBed Supplier evaluation (New)

    Program: rLeData Supplier data

    Program: rLeOms Balance & turnover/supplier

    Program: rLeResk Accounts Payable, current

    Program: rLeReskV AP by voucher no.

    Program: rleSpec2 AP supplier specification, as of

    Program: rLevBed Update supplier evaluation

    Program: rLevKva Supplier evaluation list

    Program: rLevResU Create supplier invoice EDI

    Program: rLipt Printout liquidity forecast

    Program: rLPBerLO Calc item statistics, ivtry turnover/per

    Program: rLPBerLV Calculate inventory value

    Program: rLPBerPG Forecast from history

    Program: rLper Inventory locs, periods

    Program: rLperS1 Item statistics->Item group

    Program: rLperS1x Item statistics->Own def statistics

    Program: rLr Accounts Payable as of

    Program: rLrAttP Invoices supplier no. order with posting

    Program: rLrAttPV Invoices voucher no. order with posting

    Program: rLrAutAt Automatic approval on entry

    Program: rLrAvrA Clearing account, approvals

    Program: rLrAvrAU Clear account, no pg break for approvals

    Program: rLrD Supplier invoices/period

    Program: rLrFfDt Supplier invoices per due date

    Program: rLrLikv Supplier balance list as of (Liq Prog)

    Program: rLrLogg1 Supplier invoices per invc no.

    Program: rLrLogg2 Supplier invoices per arriv. voucher no.

    Program: rLrMak Canceled supplier invoices

    Program: rLrPerVal Accounts payable, as of (Currency)

    Program: rLrSal Balance list AP, as of

    Program: rLrSalD Balance list AP, as of with invoices

    Program: rLrSalF Bal list forecast/AP as of

    Program: rLrSalVa Balance list/AP as of (currency)

    Program: rLrSalVd AP as of (Forecast, Currency tot, Det)

    Program: rLrSalVF Forecast/AP as of (currency)

    Program: rLru Outgoing pmts/period

    Program: rLrV AP by voucher no.

    Program: rLrVal Currency summary AP

    Program: rLrVerD AP, as of (voucher date)

    Program: rLrVerDA AP, as of (vouch date) Ftgnamn (CoName)

    Program: rLrVerDFD Accounts payable as of (voucher dt)/due dt

    Program: rLrVerDK AP, as of (voucher date) CC

    Program: rLs Dispatch method/customer

    Program: rLth Print inventory trans

    Program: rLthAr Inventory transaction/item

    Program: rLthKo Inventory trans/account/item

    Program: rLthVtC Inventory journal and voucher

    Program: rLtvt Inventory transaction journal, integration

    Program: rMatrix6 Reports

    Program: rMatrix7 Report with specifications

    Program: rMatrix8 Report, partial report 1+2

    Program: rMatrix9 Report, partial report 1+2 with spec

    Program: rMatrixE Matrix log

    Program: rMatrixL Matrix log

    Program: rMLBook Book material for suborder

    Program: rMOBook Book material for manufacturing order

    Program: rMr1 Material reservations

    Program: rMr2 Mtrl reservations + bins

    Program: rMRP_InvLocGrp MRP, item, inventory location group

    Program: rmru2_invdoc Inventory document

    Program: rMruAr Material issue per item

    Program: rMruTh Material issue per order

    Program: rMruVtC Material journal and voucher, detailed

    Program: rMruVtCq Material journal and voucher, summary

    Program: rMvt Interim vouchers

    Program: rMvt2KM Flag as finished

    Program: rMvt2KMu Flag as finished without list

    Program: rMvt2Vt Transfer to general ledger

    Program: rMvt2VtA Print/reprint voucher

    Program: rMvt2VtE Transfer to GL, no journal

    Program: rMvtE Incorrect interim voucher rows

    Program: rMvtH Voucher summary

    Program: rMvtTx Interim voucher in alphabetical ord

    Program: rNeABBK MRP, item

    Program: rNeABBKK MRP, purchase items

    Program: rNefr MRP - Batches, preset values

    Program: rNefrNE1 MRP

    Program: rOeAlfa Order acknowledgement (alpha)

    Program: rOfh1 Print agreement

    Program: rOfh2 ... Quotation

    Program: rOfh2A Quotation (reprint)

    Program: rOfh2E Quotation (not printed)

    Program: rOfhKr ... ( Quotations per campaign ) ...

    Program: rOfhKrA Quotations per campaign (reprint)

    Program: rOfhKrE Quotations per campaign (not printed)

    Program: rOfhP2 ... (Quotation, pos order) ...

    Program: rOfhP2A Quotation, pos order (reprint)

    Program: rOfhP2E Quotation, pos order (not printed)

    Program: rOhAvstK Cash reconciliation

    Program: rOhBok1 Order booking (sorted by no)

    Program: rOhBok1L Order booking (sorted by disp date)

    Program: rOhBok2 Order booking (sorted by no.)

    Program: rOhBok2L Order booking + log (disp date)

    Program: rOhBPlE Bkng+pckng list, OK status (not printed)

    Program: rOhd1 Create order from external invoice

    Program: rOhd2 Create order external backorder

    Program: rOhd4 Create restocking order

    Program: rOhdEdi2 Create order from EDI

    Program: rOhdo4 Create order from ODETTE

    Program: rOhdV Validate new/corrected orders

    Program: rOhFS ... (Delivery note, order) ...

    Program: rOhFsA Delivery note, order (reprint)

    Program: rOhFsE Delivery note, order (not printed)

    Program: rOhFSF ... (Deliv note, invoiced orders) ...

    Program: rOhFsFA Deliv note, invoiced orders (reprint)

    Program: rOhFsFE Deliv note, invcd orders (not printed)

    Program: rOhFskA Reprint Advance invoice

    Program: rOhFt Invoice transactions, order

    Program: rOhOE ... ( Order acknowledgement) ...

    Program: rOhOeA Order acknowledgement (reprint)

    Program: rOhOEC NEW Order acknowledgement, all rows

    Program: rOhOEC1 NEW Order acknowledgement, changed rows

    Program: rOhOeE Order acknowledgement (not printed)

    Program: rOhOeEb Order acknowledging eBrev

    Program: rOhOEH Order acknowledgement history

    Program: rOhOEH1 Order acknowledge, planned/released/invoiced (not printed)

    Program: rOhOEH1A Order acknowledgem, planned/released/invoiced (reprint)

    Program: rOhOeI1 Order analysis, internal

    Program: rOhOff Quotation

    Program: rOhOrpo Order entry transaction list

    Program: rOhOru Picked per order

    Program: rOhPL ... (Picking list) ...

    Program: rOhPL1 ... (Picking list, customer no.) ...

    Program: rOhPl1A Picking list, customer no. (reprint)

    Program: rOhPl1E Picking list, cust no. (not printed)

    Program: rOhPlA Picking list (reprint)

    Program: rOhPlC ... (Picking list, OK status) ...

    Program: rOhPlCA Reprint picking list w OK status

    Program: rOhPlCE Picking list, OK status (not printed)

    Program: rOhPlE Picking list (not printed)

    Program: rOhPlKC ...(Pick. list cust. no., OK status)...

    Program: rOhPlKCA Reprint pick. list cust. no., OK status

    Program: rOhPlKCE Picking list cust. no., OK (not printed)

    Program: rOhPrf Proforma

    Program: rOhPs ... (Packing slip) ...

    Program: rOhPsA Reprint packing slip

    Program: rOhPsE Packing slip (not printed)

    Program: rOhPsK ... ( Compressed packing slip order) ...

    Program: rOhPsKA Reprint compressed packing slip order

    Program: rOhPsKE Compressed pack slip order (not printed)

    Program: rOhsf1 Printout of collective invoice log

    Program: rOhSR1 Manually reconciled orders

    Program: rOhSTE ... (STE-label) ...

    Program: rOks Print company codes

    Program: rOksKS Company consolidation

    Program: rOlhA1FA Address label (151.4)/single (reprint)

    Program: rOlhA1FE Addr label (151.4)/single (not printed)

    Program: rOlhA1L ... (Address label 151.4/single) ...

    Program: rOlhA1LA Address label (151.4)/single (reprint)

    Program: rOlhA1LE Addr label (151.4)/single (not printed)

    Program: rOlhA2FA Address label (151.4)/double (reprint)

    Program: rOlhA2FE Addr label (151.4)/double (not printed)

    Program: rOlhA2L ... (Address label 151.4/double) ...

    Program: rOlhA2LA Address label (151.4)/double (reprint)

    Program: rOlhA2LE Addr label (151.4)/double (not printed)

    Program: rOlhBgFA Goods address label (reprint)

    Program: rOlhBgFE Goods address label (not printed)

    Program: rOlhBgL ... (Goods address label) ...

    Program: rOlhBgLA Goods address label (reprint)

    Program: rOlhBgLE Goods address label (not printed)

    Program: rOlhBok1 Dispatch order booking

    Program: rOlhBokL Disp order booking (sorted by disp date)

    Program: rOlhBpFA Package address label (reprint)

    Program: rOlhBpFE Package address label (not printed)

    Program: rOlhBpL ... (Package address label)...

    Program: rOlhBpLA Package address label (reprint)

    Program: rOlhBpLE Package address label (not printed)

    Program: rOlhBPOK Bkng+pckng list, OK status

    Program: rOlhFfFA SIS freight/dangerous goods (reprint)

    Program: rOlhFfFE SIS frght/dangerous goods (not printed)

    Program: rOlhFfL ... (SIS frght bill/dangerous goods)...

    Program: rOlhFfLA SIS freight/dangerous goods (reprint)

    Program: rOlhFfLE SIS frght/dangerous goods (not printed)

    Program: rOlhFpFA Postal label (reprint)

    Program: rOlhFpFE Postal label (not printed)

    Program: rOlhFpL ... (Postal label) ...

    Program: rOlhFpLA Postal label (reprint)

    Program: rOlhFpLE Postal label (not printed)

    Program: rOlhFrS SIS freight bill

    Program: rOlhFrSA SIS freight bill (reprint)

    Program: rOlhFrSE SIS freight bill (not printed)

    Program: rOlhFS ... (Delivery note, disp order) ...

    Program: rOlhFSA Reprint delivery note, disp order

    Program: rOlhFSE Delivery note, disp ord (not printed)

    Program: rOlhFsF ... (Del note invcd disp orders)

    Program: rOlhFsFA Reprint deliv note/dispatch order

    Program: rOlhFsFE Deliv note invcd disp ord (not printed)

    Program: rOlhFvFA SIS freight bill (reprint)

    Program: rOlhFvFE SIS freight bill (not printed)

    Program: rOlhFvL ... (SIS freight bill) ...

    Program: rOlhFvLA SIS freight bill (reprint)

    Program: rOlhFvLE SIS freight bill (not printed)

    Program: rOlhJkplE Create and print part picking list for dispatch order

    Program: rOlhJkplX Create part picking list for dispatch order

    Program: rOlhOru Picked for dispatch orders

    Program: rOlhPKC ...(Dsp ord pick lst cst no. OK sts)...

    Program: rOlhPKCA Reprt disp. order cust no. pick list, OK

    Program: rOlhPKCE Disp ord pick list cust no., OK (nt prt)

    Program: rOlhPl ... (Disp order picking list) ...

    Program: rOlhPl1 ... (Pick list disp order, cust no.) ..

    Program: rOlhPl1A Reprint disp order pick list, cust no.

    Program: rOlhPl1E Disp ord pick list, cust no., (not pr)

    Program: rOlhPlA Reprint disp order picking list

    Program: rOlhPlC ...(Disp order pick list, OK status)...

    Program: rOlhPlCA Reprint disp order picking list, OK

    Program: rOlhPlCE Disp order picking list, OK (not print)

    Program: rOlhPlE Disp ord picking list (not printed)

    Program: rOlhPrf Proforma dispatch order

    Program: rOlhPs ... (Packing slip disp order) ...

    Program: rOlhPsA Reprint disp order packing slip

    Program: rOlhPsE Disp order packing slip (not printed)

    Program: rOlhPsK ... (Compr packing slip disp order) ...

    Program: rOlhPsKA Reprint disp order compr packing slip

    Program: rOlhPsKE Compr pack slip disp order (not printed)

    Program: rOlhSTE ... (STE-label disp order) ...

    Program: rOlhSTEA STE-Label disp order (reprints)

    Program: rOlhSTEE STE-Label disp order (not printed)

    Program: rOmplanBp Replanning purchase order

    Program: rOmplanTi Replanning manufacturing order

    Program: rOMPRta Print/reprint interest invoice

    Program: rOMPrtaA Print/reprint interest invoice

    Program: rOp1 Operation list

    Program: rOp2 Operation list

    Program: rOpt Operation texts

    Program: rOrdersU Create EDI order message

    Program: rOrdrsp2 Update order from EDI

    Program: rOrpBok1 Perform booking

    Program: rOrpoAP Order intake/item, period

    Program: rOrpOff Open quotations (orders)

    Program: rOrpoOh Order intake/period, order

    Program: rOrpoPer Order intake/period, district

    Program: rOrpOS Open orders

    Program: rOrpOSA1 Open orders/item

    Program: rOrpOSF1 Open orders/customer

    Program: rOrpOSL1 Open orders/est dispatch

    Program: rOrpoSP Order intake/seller, period

    Program: rOrpPlanBeg Prt cust, req del, ord per curr status

    Program: rOrpPlanBegUpd Avail chk (upd) + prt cust, req del, ord

    Program: rOrpPlanBer Prt cust, pln del, order per curr status

    Program: rOrpPlanBerUpd Avl chk (upd) + prt cust, plan del, ord

    Program: rOrpPlanUpd Avail check (status update), no printout

    Program: rOrpSR2 Manually reconciled order rows

    Program: rOrpSSF1 Open orders, seller, cust

    Program: rOrpUOS Picked order value, order, date

    Program: rOrpUOSa Picked value, order, current

    Program: rOru Picked orders

    Program: rOruVtC Picking journal and voucher

    Program: rPal Item-Supplier list

    Program: rPBhaKr Print RFQs per supplier

    Program: rPBhaKr1 Print quotation request, replied

    Program: rPdm PDM

    Program: rPdms1 PDM Consists of

    Program: rPdms1v PDM Consists of

    Program: rPdms2 PDM Consists of / Included in

    Program: rPdms2v PDM Consists of / Included in

    Program: rPerLagAr Periodic inventory report per item/inventory location

    Program: rPf Print monetary factors

    Program: rPg Print manufacturing groups

    Program: rPgAo Labour operations

    Program: rPgBaoD Workload, day

    Program: rPgBaoP Workload, period

    Program: rPgBaoW Workload, week

    Program: rPgBlts Workload

    Program: rPgResAck Reset accumulators on production group

    Program: rPhf Weighting rules

    Program: rPiaExt WIP list, external material

    Program: rPjbh Project -> balance account

    Program: rPkkj Internal costs, journal and voucher

    Program: rPkkj2 Print internal costs, journal

    Program: rPkkj21 Internal debiting, journal and voucher

    Program: rPkkj21A Reprint internal debiting, journal

    Program: rPkkj22 Internal debiting, journal

    Program: rPkkjA Reprint internal costs, journal

    Program: rPODelivFromSO PO rows, in order of PO number

    Program: rPODelivFromSODt PO rows, date

    Program: rPODelivFromSOItem PO rows per item

    Program: rPODelivFromSOSup PO rows, supplier

    Program: rPolen Poland totals

    Program: rPOLineSuppExtDoc PO rows, Supplier, (one doc/supplier)

    Program: rPomr Product areas

    Program: rPomr2 Product - foreman areas

    Program: rPomr3 Product - foreman areas, work groups

    Program: rPrh Sales price list

    Program: rPri Discount matrix

    Program: rPricatU Sales price lists EDI direct

    Program: rPrj Projects+details

    Program: rPrjBia Requisition

    Program: RprjD Projects+subprojects

    Program: rPrjDH Projects+subprojects+activities

    Program: rPrjHr Projects+planned activities/person

    Program: rPrjHrpHr Projects+reported activities/pers+planned act

    Program: rPrjNetD MRP run, project

    Program: rPrjVr GL list, project

    Program: rPrlsel Sales price list/selected details

    Program: rPro Business opportunities

    Program: rProHrHrp Bus. opportunities, reported acts per pers+planned

    Program: rPrtRtaA Print/reprint interest invoice

    Program: rPrtRtaNi Print/reprint interest spec

    Program: rPrtRtaQ Print/reprint interest invc, modifyable

    Program: rPrtRtaS Print/reprint interest invoice

    Program: rPrtRteb (Re)print interest invoice eBrev

    Program: rPrvt1 Time reports

    Program: rPrvt2 Time reports, person

    Program: rPrvtN2 Hrs on site, person

    Program: rPsvj Perc of completion acct, jrnl + voucher

    Program: rPsvj2 Perc of completion acct, jrnl + posting

    Program: rPtko Print service accts

    Program: rPurAgmt_Item Purchase agreement lines order by item

    Program: rPurAgmt_Sup Purchase agreement lines order by supplier

    Program: rQo2p Reconciling quantity differences

    Program: rRb Print report request

    Program: rRbbh Append/spec definition

    Program: rRbdH Subreport definition

    Program: rRbSh Print BOMs

    Program: rrd Print report definition

    Program: RrdX Print report def/header

    Program: rReavKR1 Reconciliation AR - GL

    Program: rReavLR1 Reconciliation AP - GL

    Program: rReBal Balance sheet

    Program: rRemh Periodic interim vouchers

    Program: rRemJrnl Bills of exchange to customers

    Program: rRemJrnlRe Reprint bills of exchange to customers

    Program: rReRes Income statement

    Program: rRora Discount order value/cust grp

    Program: rRpdi1 Distribution lists, signature

    Program: rRpdi2 Distribution lists, report request

    Program: rRpg Report groups

    Program: rRpgD Report groups w details

    Program: rRpmu Print report info

    Program: rRpmuM6 Reports

    Program: rRpmuM7 Report result w specs

    Program: rRtaF Preliminary interest calc

    Program: rRtaFSta Special (date-sensitive) interest

    Program: rRxa6 Voucher number series, fiscal year

    Program: rSADtax Tax statement, customs document

    Program: rSalj Seller listing

    Program: rSamFaktFfh Coll invoicing of delivery note per Del customer

    Program: rSamFaktFfhP Coll invoicing of delivery note per Pay customer

    Program: rSars Item statistics

    Program: rSars1 Item statistics

    Program: rSars2 Item stats/prod acct, item grp

    Program: rSars22 Item stats/prod acct, item grp

    Program: rSarsVg Item statistics->Item group

    Program: rSFFfheb Collective invoicing of delivery note (eBrev)

    Program: rsh Service order header

    Program: rsh1 Service order report

    Program: rSh1P2 Service orders/technician

    Program: rSh2 Service orders/customer, order

    Program: rshav Report interruption

    Program: rshdok Service order report

    Program: rShipmentPlan Shipment planning

    Program: rshp Print service order rows

    Program: rShp2 Service orders/mgr

    Program: rShp3 Service orders/technician

    Program: rshpDA Service order report

    Program: rSkus Customer statistics

    Program: rSkus2 Cust statistics, subtotals

    Program: rSle Supplier statistics

    Program: rSolhPl ... (Joint picking list disp order) ...

    Program: rSolhPlA Reprint joint picking list, disp orders

    Program: rsOlhPlE Joint pick list, disp ord (not printed)

    Program: rSper Period statistics

    Program: rSper2 Period statistics, subtotals

    Program: rSr BOM records

    Program: rSran1 Explosion

    Program: rSran2 Explosion with operations

    Program: rSrLa1 Assembly analysis

    Program: rSrLa2 Assembly analysis, requisition

    Program: rSrLa3 Assembly analysis, MO

    Program: rSrLa4 Assembly analysis, MRP proposal

    Program: rSt1Kxxx Company consolidation

    Program: rSth Print conversion definition

    Program: rSthi Import conversion definitions

    Program: rSthiC Import conversion

    Program: rSthu Jeeves -> Export, definitions

    Program: rSthuC Jeeves -> Export

    Program: rSu1 BOM list

    Program: rSu2 BOM document

    Program: rSy1Ar2 Cost calc (pyramidic) + update

    Program: rSy1Ar3 Prel cost price -> current on item

    Program: rSy1Kus1 Create reminders/all customers

    Program: rSy1Kus2 Create interest invoice/all customers

    Program: rSycg Print syst log by date, time

    Program: rSycgP Print system log, signature

    Program: rSycgT Print syst log per table

    Program: rSyse Disrupted Jeeves processes

    Program: rSysp Jeeves processes

    Program: rTax Tax statement

    Program: rtaxhpre Slovakian tax statement

    Program: rTaxt Basis of tax statement

    Program: rTh Manufacturing order

    Program: rTh_b1 Availability check, planned balance

    Program: rTh_b2 Availability check, invtry reservations

    Program: rTh_Bx1 Shortages according to prev check

    Program: rTh_PIC_1 MO, suborder (not printed)

    Program: rTh_PIC_1a MO, suborder (reprint)

    Program: rTh20 Manufacturing order costs (detailed)

    Program: rThA Reprint manufacturing order

    Program: rThAlfa Manufacturing order (alpha)

    Program: rThAlfaO Manufacturing order (alpha) ackn.

    Program: rThBIA Purchase requisition, MO

    Program: rThFAS MO, suborder

    Program: rThFASa Reprint manufacturing order, suborder

    Program: rThHuv Open orders

    Program: rThLogg Manufacturing order log

    Program: rThPDenD WIP as of per account

    Program: rThPdm1 MO, PDM info

    Program: rThPeDen WIP as of

    Program: rThPia WIP list, MO

    Program: rThPiaP WIP list, suborders

    Program: rThPiaPD WIP list, suborder details

    Program: rThPl1 MO, picking list

    Program: rThRapp Completed reports

    Program: rThRapp2 Actual cost, summary

    Program: rThRapp4 Actual cost, transactions

    Program: rThSund1 MO + suborders (explosion)

    Program: rThSund2 MO + mtrl + suborders (explosion)

    Program: rthtii_invdoc Inventory document

    Program: rThToDo1 Orders by flow group

    Program: rThVtC Mfg costing journal and voucher

    Program: rThVtCA Mfg costing journal, integration

    Program: rTi_b1 Availability check, planned balance

    Program: rTi_b2 Availability check, invtry reservations

    Program: rTi_Bx1 Shortages according to prev check

    Program: rTiChgAoMr Incorporate drawing changes on MO

    Program: rTidr Time report

    Program: rTiiAr Received deliveries mfg by item

    Program: rTiiTh Received deliveries mfg by order

    Program: rTiiVtC Receiving journal mfg and voucher

    Program: rTiLogg Suborder log & report

    Program: rTiNed MO explosion

    Program: rTiNedTD MO explosion

    Program: rTiNedTh MO explosion

    Program: rTiNedTP MO explosion

    Program: rTiPia Open orders, WIP

    Program: rTiPiaD Open orders/WIP details

    Program: rTiPl1 MO, picking list

    Program: rTiPl1_SFR MO, picking list

    Program: rTiRapp Completed reports

    Program: rTiTh Manufacturing order

    Program: rTiTh_SFR Manufacturing order

    Program: rTiThA Reprint manufacturing order

    Program: rTiThA_SFR Reprint manufacturing order

    Program: rTiThF Suborders, due date

    Program: rTiThHuv Open orders

    Program: rTiThS Suborders, start date

    Program: rTko Balance, account

    Program: rTko_Query Balance per account

    Program: rTkt_QueryKoD Balance per account, account segment (vouchers)

    Program: rTkt_QueryKoL Balance per account, account segment

    Program: rTktc0_Query Balance per account, account segment, currency

    Program: rTktc1_Query Balance per account, currency

    Program: rTktKo2D Balance (acct/CC/detail)

    Program: rTktKoD Balance, acct/details

    Program: rTktKtD Balance CC/detail

    Program: rTktPjTK Balance proj/CC/detail

    Program: rToDo Print unplanned activities

    Program: rUfo1 Invoicing batches

    Program: rUofh1 Assignments

    Program: rUofh1A Assignments

    Program: rUofh2 Assignments w details

    Program: rUofh3 Asignments w uninvoiced details

    Program: rUofh3T Assignment not invcd det/person

    Program: rUofh5 Assignment plan, person, date

    Program: rUofh6 Assignment plan, date

    Program: rUofh9 Assignments with counter entry

    Program: rUoh Preliminary invoices

    Program: rUohF Create/print invoices

    Program: rUohFD Create/print invoice detail posting

    Program: rUohFDU Reprint invoice detail posting

    Program: rUohFEb Create/print invoices (eBrev)

    Program: rUohFP Create/print invoice w PG

    Program: rUohFU Reprint invoice

    Program: rUohFUP Reprint invoice w PG

    Program: rUohSF1 Collective invoice Assignments

    Program: rUohSFD Collective invc Assignment det posting

    Program: rUohSFDU Reprint collective invc Assignments det

    Program: rUohSFU Reprint collective invoice Assignments

    Program: rUohT Preliminary invoices assignment

    Program: rUtpl_invdoc Inventory document

    Program: rVak Print exchange rates

    Program: rVakk Print currency calc rates

    Program: rVatAR VAT/tax report AR

    Program: rVatFh VAT/tax report AR

    Program: rVcnd Print personal settings

    Program: rVg Print item groups

    Program: rvle9kva Supplier evaluation list

    Program: rVmcr Macros by name

    Program: rVmcr2 Macros by program

    Program: rVo2p Posting analysis

    Program: rVpgc Print program connections

    Program: rVr Voucher rows

    Program: rVrChk Status check incorrect vouchers

    Program: rVrEjFi Print incomplete vouchers

    Program: rVrEjOK Print incorrect vouchers

    Program: rVrEntryNo Voucher rows, chronological

    Program: rVrHBok GL voucher rows

    Program: rVrKST Voucher rows, cost centre

    Program: rVrpm Print report templates

    Program: rVrRemh Posting periodic vouchers

    Program: rVrRemhA Print reconc periodic vouchers

    Program: rVrRemhE Print periodic voucher basis

    Program: rVrRemhR Print periodic voucher incl basis

    Program: rVrRemhV Print periodic vouchers

    Program: rVrTHBok GL voucher rows by cost centre

    Program: rVsdp Print dependencies

    Program: rVsix Tables, indexes...

    Program: rVsob Print objects & dependencies

    Program: rVsr21 Explosion

    Program: rVswh WHO; Jeeves sysprocesses

    Program: rVsyl Print definitions

    Program: rVtBfdFD Journal not printed

    Program: rVtChk1 Status check incorrect vouchers

    Program: rVtDag List of unprinted vouchers

    Program: rvtinv Internal invoice

    Program: rvxrbvt Journal and voucher paid customer BOE

    Program: rvxrbvt1 Journal and voucher paid supplier BOE

    Program: rVxreUt Print bills of exchange

    Program: rVxreUtA Reprint bills of exchange

    Program: rVxriVt Create voucher, BOE paid

    Program: rVxrjVt Create voucher, BOE paid

    Program: rVxrjVtA Reprint voucher, BOE for payment

    Program: rVxrkVt Create voucher, BOE for payment

    Program: rVy Tools

    Program: rVyKus Tools per customer

    Program: rVyl Tool lists

    Program: rVyLe Tools per supplier

    Program: rVynd Print personal settings

    Program: rVyOp Tools, operations

    Program: rVyResAck Reset accumulators on tool

    Program: rwbpa Reconciliation invoice matching

    Program: rWinvRE Reconciliation FA - GL

    Program: rWinvRE2 Reconciliation FA - GL per account

    Program: rWitb1 Book customer order rows by item

    Program: rwlth Reconciliation inventory

    Program: rWOBook Book material for labour operation

    Program: rwoha Reconciliation dispatched, not invoiced

    Program: rwou Reconciliation OU inventory

    Program: rwprj Print reconciliation balance/result project

    Program: rwtha Reconciliation manufacturing orders

    Program: rX1s Print voucher status

    Program: rX1t Print voucher row status

    Program: rX1u Print interim voucher status

    Program: rX255 Dummy input/output

    Program: rX256 Dummy input/output

    Program: rX257 Dummy input/output

    Program: rX258 Dummy input/output

    Program: rX6 Order types

    Program: rXa6 Print integr sources

    Program: rXa6Ak1 Print integr sources w details

    Program: rXa6Rxa6 Print integr sources w voucher series

    Program: rXarlaBerAB Calculate ABC code

    Program: rXarlaBerEK Calc EOQ/OP/safety stock

    Program: rxArsx1 Item forecast

    Program: rXbBerAB Calculate ABC code

    Program: rXbBerEK Calc EOQ/OP/safety stock

    Program: rXbBerLed Est. lead time for manufacturing items

    Program: rXbBerLO Calc item statistics, inventory turnover

    Program: rXbBerLV Calculate inventory value per period

    Program: rXbBerPG Forecast from history

    Program: rXbBia Requisition (planned by item)

    Program: rXbBiaBP Requisition (order point)

    Program: rXbBiaPL Requisition (planning)

    Program: rXbNb1 MRP

    Program: rXbUtsAB Print ABC analysis

    Program: rXen Print unit codes

    Program: rXlt Print invtry trans types

    Program: rxlth_invdoc Inventory document

    Program: rXm Print item types

    Program: rXnel Log MRP

    Program: rXo1 Show order structure

    Program: rXopa Labour codes/types

    Program: rXr7 Value table, terms

    Program: rXrar Print fiscal year

    Program: rXrin Print interest on deposits

    Program: rXrut Print interest rates (lending)

    Program: rXx Print currencies

    Program: rXxAPrev AP currency revaluation with reversal voucher

    Program: rXxARrev AR currency revaluation with reversal voucher

    Program: rXxGl GL currency revaluation

    Program: rXxGlrev GL currency revaluation with reversal voucher

    Program: rXxKr AR currency revaluation

    Program: rXxLr AP currency revaluation

    Program: rXz Print inventory stocking types

    Program: rXz2 Invoice types

    Program: rZipLrVr Zip IR files

    Program: shsy System data, service

    Program: Sie SIE import/export

    Program: Srpd1 PDM

    Program: sy System file, own co.

    Program: Sy1_Mask Masks for date and currency

    Program: Sy1Ar1 Functions for all items

    Program: Sy1Ar2 Reconstructions, year and purge routines

    Program: Sy1Kr AR system data

    Program: Sy1Lager System data order, purchase, inventory

    Program: Sy1MPS System data, MPC

    Program: Sy1Red Copy tables to new company

    Program: Sy1Rtpl Copying of print templates

    Program: Sy1Utb AP system data

    Program: sye System data/accounting

    Program: vhb GL list (no details)

    Program: WLReplan Reconstruction of details workload

    Program: xAgIdSy1 Startup/login

    Program: xJkmX Company consolidation

    Program: xSy1Kus Batches, all customers

    Program: yJvsCnv1 Conversion

    Program: yJvsCnv2 Conversion (DB_procedure)

    Program: yMatrix1 Report definitions, MATRIX calc

    Program: yMatrix2 Report requests, MATRIX calc

    Program: yMatrix3 Report groups, MATRIX calc


System indexes (vsix)

Name on database object.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Object name | ObjectName | ztString | 128 |  | nvarchar
Row | RadPos | ZtLong | 10 |  | smallint
Base/value table | ztable | ztString | 255 |  | nvarchar

    This table is the main table in the following programs:

    Program: xVsix Index, tables...


System settings for EDI server (edis)

Settings affecting the EDI server are entered here. Several EDI servers can be configured if needed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Error sequence | EdiAlertCommandSeqNo | ztInteger | 5 |  | smallint
E-mail Error Report | EdiAlertMail | ztString | 255 |  | varchar
Err Rep E-mail Active | EdiAlertMailActive | ztBoolean |  |  | char
No. Err Rep E-mails | EdiAlertMailCount | ZtLong | 6 |  | int
Max No. Err Rep E-mails | EdiAlertMailMax | ZtLong | 6 |  | int
Backup directory | EdiBackupDir | ztString | 255 |  | varchar
Data source | EdiDsn | ztString | 80 |  | varchar
Password | EdiDsnPwd | ztString | 30 |  | varchar
User | EdiDsnUser | ztString | 6 |  | varchar
In-box directory | EdiInBoxDir | ztString | 255 |  | varchar
In directory | EdiInDir | ztString | 255 |  | varchar
Job history | EdiJobHistory | ztInteger | 5 |  | smallint
Internal loop (sec) | EdiJobInterval | ztInteger | 5 |  | smallint
Job timeout | EdiJobTimeOut | ztInteger | 5 |  | smallint
E-mail, incoming | EdiNotifyMail | ztString | 255 |  | varchar
In-mail active | EdiNotifyMailActive | ztBoolean |  |  | char
No.IncMail | EdiNotifyMailCount | ZtLong | 6 |  | int
Max No. incoming mail | EdiNotifyMailMax | ZtLong | 6 |  | int
Out box directory | EdiOutBoxDir | ztString | 255 |  | varchar
Out directory | EdiOutDir | ztString | 255 |  | varchar
Load EDI files | EdiReadFile | ztBoolean |  |  | char
External loop (sec) | EdiScanInterval | ztInteger | 5 |  | smallint
EDI server name | EdiServerName | ztString | 40 |  | varchar
EDI server no | EdiServerNo | ztInteger | 5 |  | smallint
WorkDir | EdiWorkDir | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: edis System settings for EDI server

    Program: EdiSrv EDI server


System type (AstroSystemType)

Subsetting table in the Astro installation program.

The following standard records exist. Do not alter/delete:

Id (AstroSystemTypeId) | Description (AstroSystemTypeDescr)
10 | EndPoint
20 | ExceptionHandler
30 | Node
40 | MessageProcessor
50 | Transformer
60 | Extractor
70 | Global

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | AstroSystemTypeDescr | ztString | 50 |  | varchar
Id | AstroSystemTypeId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AstroSystemType Astro system type


System view sysmail_allitems (VSysMail_AllItems)

Identifier of the mail item in the mail queue.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Send if error | DBM_append_query_error | ztInteger | 1 |  | bit
Query result to file | DBM_attach_query_result_as_file | ztInteger | 1 |  | bit
Attachment type | DBM_attachment_encoding | ztString | 20 |  | varchar
Email for blind copys | DBM_blind_copy_recipients | ztBlob | 1 |  | varchar
Mail body | DBM_body | ztBlob | 1 |  | nvarchar
Mail body format | DBM_body_format | ztString | 20 |  | varchar
Email addresses for copy | DBM_copy_recipients | ztBlob | 1 |  | varchar
Exclude query output | DBM_exclude_query_output | ztInteger | 1 |  | bit
Mail query database | DBM_execute_query_database | ztString | 255 |  | nvarchar
File attachments | DBM_file_attachments | ztBlob | 1 |  | nvarchar
Mail importance | DBM_importance | ztString | 6 |  | varchar
Mail id | DBM_mailitem_id | ZtHugeInt | 20 |  | int
Mail profile id | DBM_profile_id | ztInteger | 5 |  | int
Mail query | DBM_query | ztBlob | 1 |  | nvarchar
Query result header | DBM_query_result_header | ztInteger | 1 |  | bit
Query result separator | DBM_query_result_separator | ztchar | 1 |  | char
Query result width | DBM_query_result_width | ztInteger | 5 |  | int
Email addresses | DBM_recipients | ztBlob | 1 |  | varchar
Send request date | DBM_send_request_date | ztDateTime |  |  | datetime
Send request user | DBM_send_request_user | ztString | 255 |  | nvarchar
Mail sensitivity | DBM_sensitivity | ztString | 12 |  | varchar
Send account id | DBM_sent_account_id | ztInteger | 5 |  | int
Send date | DBM_sent_date | ztDateTime |  |  | datetime
Send status | DBM_sent_status | ztString | 8 |  | varchar
Mail subject | DBM_subject | ztBlob | 1 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: DbMailLog Database mail log


System view sysmail_mailattachments (VSysMail_MailAttachments)

Contains one row for each attachment submitted to Database Mail.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
File content | DBM_attachment | ztBlob | 1 |  | nvarchar
Attachment id | DBM_attachment_id | ztInteger | 5 |  | int
Filename | DBM_filename | ztString | 250 |  | nvarchar
Filesize | DBM_filesize | ZtHugeInt | 20 |  | int
Mail id | DBM_mailitem_id | ZtHugeInt | 20 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


TA control parameters (TA_SysP)

Setup of control parameters for integration with the Transport administration system (TA). From version 9.2.1 the integration also includes LogTrade.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Add country code for record number | TA_Add_iso_postnr | ztBoolean |  |  | char
Incl payer | TA_AddBuyer | ztBoolean |  |  | char
Alt. send date | TA_alt_Desp_Date | ztInteger | 5 |  | smallint
Always incl item | TA_AlwaysItemlines | ztBoolean |  |  | char
Calc avg gross weight/item | TA_AvgItemGrossWght | ztBoolean |  |  | char
Calc avg net weight/item | TA_AvgItemNetWght | ztBoolean |  |  | char
Backup TA trans | TA_Backuptrans | ztBoolean |  |  | char
Base country code | TA_BaseCountryCD | ztString | 15 |  | varchar
Business parcel t private | TA_CoPkg2Priv | ztString | 50 |  | varchar
Freight bill date | TA_Def_DelNoteCreatedDt | ztString | 20 |  | varchar
Dangerous alt unit | TA_DGDunit | ztBoolean |  |  | char
TA-path | TA_Export_Path | ztString | 150 |  | varchar
No row linking FFH | TA_Ffh_itemline | ztBoolean |  |  | char
Trade area code | TA_ForceTradeAreaCd | ztString | 30 |  | varchar
Free text on freight bill | TA_FreeTextFile | ztString | 250 |  | varchar
GAN from customer | TA_GanFromCustom | ztBoolean |  |  | char
Goods line handle code | TA_godslinehandlecode | ztInteger | 5 |  | smallint
Which goods label field | TA_GoodsMark | ztString | 50 |  | varchar
Order row reading | TA_itemLines | ztBoolean |  |  | char
Invoice level | TA_IvnoLevel | ztBoolean |  |  | char
Logging definition | TA_Loggmode | ztString | 255 |  | varchar
GANNo. as palletentno. | TA_ManGanAsPallReg | ztBoolean |  |  | char
Path to master | TA_Master_Path | ztString | 150 |  | varchar
Adaptation Procedure | TA_ModProcedureName | ztString | 150 |  | varchar
Include discounts | TA_NoDiscntCd | ztBoolean |  |  | char
NoGanNoEUR | TA_NoGanNoEUR | ztBoolean |  |  | char
NoGodslineByEur | TA_NoGodslineByEur | ztBoolean |  |  | char
Path to package | TA_Pkg_Path | ztString | 150 |  | varchar
Post no. limiter | TA_PostNoDelim | ztString | 5 |  | varchar
PreAssigNo | TA_PreAssigNo | ztString | 1 |  | varchar
ProjNoField | TA_ProjNoField | ztString | 30 |  | varchar
Recipient template against TA | TA_RefCnTemplate | ztBoolean |  |  | char
Reference | TA_RefNoText | ztString | 60 |  | varchar
Shift CO adr | TA_Shift_CO_adr | ztString | 30 |  | varchar
Fixed TARIC code | TA_StatNo | ztString | 30 |  | varchar
Fixed TARIC code pos 4 | TA_statNo4 | ztString | 15 |  | varchar
Description | TA_SyspDescr | ztString | 50 |  | varchar
TA-system parameters | TA_Syspid | ztInteger | 5 |  | smallint
Incl invoice number | TA_TrueInvoiceNo | ztBoolean |  |  | char
Notification/additional claim | TA_Use5Trptype | ztBoolean |  |  | char
Text/info | x255 | ztString | 255 |  | varchar
Text/info | x255_2 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: TA_SysP TA control parameters


TA international package types (TA_PackType)

Definition of package types according to international standard used in the transport administration system (TA).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Package type | TA_PAckType | ztString | 4 |  | varchar
Pack type | TA_PackTypeDesc | ztString | 80 |  | varchar

    This table is the main table in the following programs:

    Program: TA_PackType TA international package types


Table column change rules (ICTtccr)

Definition of rules for how replicated table columns can be used in replicated companies.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Active | Aktiv | ztInteger | 1 |  | smallint
Term | ColumnName | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Property | ICTColumnProperty | ztInteger | 2 |  | smallint
ICT conn business unit | ictconbusinessunit | ztString | 8 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Table name | TableName | ztString | 255 |  | varchar
To company | ToCompanyNo | ztInteger | 5 |  | smallint


Table for locking access to workload during update (WorkLoad_Lock)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Object name | ObjectName | ztString | 128 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Process ID | spid | ZtLong | 5 |  | int


Table replication (tcc)

Definition specifying which tables and fields are to be replicated, between which companies/units, any conditions for replication as well as any data to be converted.

Replication must be set up by persons with technical knowledge of Jeeves' database structure and any tables interdependencies. For example, in order to replicate the customer table you will also need to replicate the company table.

The definition is used in Jeeves ICT but can also be used in Jeeves multi-company management.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Only Update | ConvertNoInsert | ztBoolean |  |  | char
Only Insert | ConvertNoUpdate | ztBoolean |  |  | char
Insert on update | ConvUpd2Insert | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
ICT conn business unit | ictconbusinessunit | ztString | 8 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Procedure | StoredProcedure | ztString | 120 |  | varchar
From view | TableCopyUsingView | ztString | 255 |  | varchar
Table name | TableName | ztString | 255 |  | varchar
Update using view | TableUpdUsingView | ztString | 255 |  | varchar
To company | ToCompanyNo | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: tcc Table replication


Tables for replication (RepT)

Definition of the tables to be replicated in the web server, i.e. making up the minimized Jeeves database.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Change key procedure | ChngKeyProc | ztString | 30 |  | varchar
External table name | ExtTableName | ztString | 30 |  | varchar
Change procedure (Insert) | insmodproc | ztString | 30 |  | varchar
Key generating proc | KeyCreateProc | ztString | 30 |  | varchar
Replication conditions | NotReplicated | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Replication flow | RepDirection | ztchar | 1 |  | char
Replication definition | repldefkod | ZtLong | 10 |  | int
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence | Sequence | ztInteger | 3 |  | smallint
Table name | tablename | ztString | 255 |  | varchar
Change procedure (Update) | UpdModProc | ztString | 30 |  | varchar
Use insert proc | useinsproc | ztBoolean |  |  | char


Tables in database (Jeeves_View_UserTables)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
@zPrompt=null | table_name | ztString | 255 |  | nvarchar


Tables in package solution (JvsPackageTables)

Tables included in a package solution. The complete table is exported unless one or many columns are specified in the Package solution table columns table. How the table should be handled when importing and exporting is defined in the Package solution table import types table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Terms | Cond | ztBlob | 1 |  | varchar
Import type | ImportType | ztInteger | 5 |  | smallint
Table name | JvsTableName | ztString | 128 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Priority | Priority | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Solution ID | SolutionID | ZtLong | 10 |  | int


Tables to copy (xfil)

Definition of tables to be copied to newly created companies. In other words, the function is only relevant for multi-company processing.

Note!
--------------
- This table is common to all companies.

- From Jeeves version 10 pre-release almost all tables in the database are represented here, which means that additions are only necessary for own developed tables, which can only have number 10000 or higher. The only standard tables not included are:
System file, own co. (sy1) - can be copied anyway, see chapter about copying system data
User file (sy2)
Jeeves system process (sysp)

- All these standard tables must be copied when creating new companies. Instead of flagging certain tables for copying, as in earlier versions, you should create different types of template companies with the data needed to create different types of companies. For example you may have one template company for production companies, containing only the chart of accounts, posting templates etc., and another template company for test or education companies containing much more data for test and training purposes.

All tables defined here are by default flagged for copying, including own developed tables, and this is only editable for own tables.

Here there is also a checkbox for flagging tables that CAN be replicated when entering, changing and deleting data in the template company. Specify which of these SHALL be replicated in the Common tables/companies program (xfif).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Sequence no. | LopNr | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Table name | TabellBeskr | ztString | 100 |  | varchar
Can be replicated | TabellGemensam | ztBoolean |  |  | char
Copy/replicate | TabellKopiera | ztBoolean |  |  | char
Table | TabellNamn | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: xfil Tables to copy


Tabs (JvsSiteWinTabs)

Program/table for viewing and editing settings regarding the order and name of tabs.

The program/table can be accessed through an embedded window in the program Setting dimensions/keys (jvssitenodewin) or from Jeeves' menu.

There is also an embedded window for translating tab names to other languages in which the system is run.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Setting ID (orig) | JvsSiteNodeWinSettingsID_orig | ZtLong | 10 |  | int
Name | JvsSiteTabDescription | ztString | 80 |  | nvarchar
Tab ID | JvsSiteTabID | ZtLong | 10 |  | int
Tab ID (orig) | JvsSiteTabID_orig | ZtLong | 10 |  | int
Sequence no. | JvsSiteTabSeq | ztInteger | 5 |  | smallint
ID on window setting | JvsSiteWindowSettingsID | ZtLong | 10 |  | int
ID on window setting (orig) | JvsSiteWindowSettingsID_orig | ZtLong | 10 |  | int
Window type | JvsSiteWindowType | ztString | 2 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteWinTabs Tabs


Tacton Component Class (TactonComponentClass)

Name/identity of Tacton model class.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Tacton Component Class Description | ClassDescr | ztString | 255 |  | varchar
Tacton component class ID | ClassId | ztString | 100 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Configurator model ID | ModelId | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Tacton Component Feature (TactonComponentFeature)

Name/identity of Tacton model class.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Tacton component class ID | ClassId | ztString | 100 |  | varchar
Domain ID | DomainId | ztString | 60 |  | varchar
Feature Name | FeatureName | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Configurator model ID | ModelId | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


TactonNamedDomain (TactonNamedDomain)

Tacton Name of element in domain

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Elemend description | DomainElementDesc | ztString | 255 |  | varchar
Element ID | DomainElementId | ztString | 100 |  | varchar
Elemend value | DomainElementValue | ztString | 255 |  | varchar
Domain ID | DomainId | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Configurator model ID | ModelId | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Tags in added/modified objects (UsrDefModSQLObject_Tag)

User/ISV own modification of databas object containing SQL code.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Object name | DB_Object_Name | ztString | 128 |  | varchar
Tag in DB object | DB_Object_TagName | ztString | 128 |  | varchar
Tag seq in DB object | DB_Object_TagSequence | ztInteger | 5 |  | smallint
SQL code | DB_SQLCode | ztBlob | 1 |  | varchar
Name of Sub Tag | DB_Sub_TagName | ztString | 128 |  | varchar
Sub tag priority in tag | DB_Sub_TagPriority | ZtLong | 6 |  | int
Sub tag seq in tag | DB_Sub_TagSequence | ztInteger | 5 |  | smallint
Documentation | Documentation | ztBlob | 1 |  | varchar
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Development project | UsrDefDevProj | ztString | 10 |  | varchar

    This table is the main table in the following programs:

    Program: UsrDefModSQLObject_Tag Tags in added/modified objects


Tags in added/modified objects, history (UsrDefModSQLObject_Tag_CodeHistory)

User/ISV own modification of databas object containing SQL code.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Object name | DB_Object_Name | ztString | 128 |  | varchar
Tag in DB object | DB_Object_TagName | ztString | 128 |  | varchar
SQL code | DB_SQLCode | ztBlob | 1 |  | varchar
Name of Sub Tag | DB_Sub_TagName | ztString | 128 |  | varchar
Unique ID of text (GUID) | GUID_Str | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Development project | UsrDefDevProj | ztString | 10 |  | varchar

    This table is the main table in the following programs:

    Program: UsrDefModSQLObject_Tag_CodeHistory Tags in added/modified objects, history


Target table, details (sctd)

Definition of columns in the target table at conversion and of rules for how the columns are created.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
DB-term/-expression 2 | DbTermname2 | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Definition | kdefine | ztString | 60 |  | varchar
Default | Konvdefault | ztString | 60 |  | varchar
Translation table | KTabell | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Sequence | Sequence | ztInteger | 3 |  | smallint
Value term table | VardeTabId1 | ztString | 255 |  | varchar


Target table, details (stgd)

This table shows what a Jeeves standard record looks like, i.e. the standard columns that can be used in the definition of the target table when converting data to Jeeves records.

The following standard records exist. Do not alter/delete:

Sequence (Sequence) | DB-term/-expression 2 (Dbtermname2)
5 | foretagkod
10 | bokfdat
20 | KtoNr
30 | Koststallekod
40 | kostbar
50 | projcode
60 | k4
70 | k5
80 | k6
90 | k7
100 | debkre
110 | debbel
120 | krebel
122 | Belopp
125 | Kvantitet
130 | regdat
140 | lopnr
150 | redovisnar
160 | period
200 | perssign
220 | IntSource
230 | VrVerText
240 | Markkomp
340 | VerNr
410 | KonvTillForetagKod
450 | AutoRegel

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
DB-term/-expression 2 | DbTermname2 | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Sequence | Sequence | ztInteger | 3 |  | smallint
Value type | VardeTermT | ztInteger | 3 |  | smallint


TARIC codes (arsn)

Definition of TARIC codes, which are 8 digit numbers used for classifying goods in trade statistics and also for handling customs duties etc.

The number determines which customs duty percentage applies and whether or not an import license is required. It is thus important that you know and use the right TARIC codes for the goods you import. The correct TARIC codes can be obtained through your customs authority or EU's web sites.

Note that, if you want the calculation of cost prices (standard and average) to take duty costs into consideration, you must connect the companies in question to the relevant trading areas (fr.handelsomrkod) and set up the trading areas for duty calculation (xn5.tullkostnkod etc.).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
TARIC code descr | ArtStatBeskr | ztString | 50 |  | varchar
TARIC code, full descr | ArtStatBeskr2 | ztString | 255 |  | varchar
TARIC code | ArtStatNr | ztString | 20 |  | varchar
Duty/ton fixed | AvgiftTonFast | ztFloat | 10 | 2 | float
Duty/ton floating | AvgiftTonFlyt | ztFloat | 10 | 2 | float
Intrastat, unit code | EnhetsKodIntraStat | ztString | 10 |  | varchar
Dangerous goods | FarligtGods | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Intrastat, conv.factor | OmvFaktorIntraStat | ZtDecimal73 | 14 | 5 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Customs duties % | TullKostnProc | ZtDecimal73 | 6 | 2 | decimal
Currency | ValKod | ztString | 3 |  | varchar

    This table is the main table in the following programs:

    Program: arsn TARIC codes


Task (WMS_Task)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
ID | AssId | ZtLong | 9 |  | int
Qty | AssQty | ZtQty | 14 | 2 | decimal
Batch no. | BatchId | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
X Pos. | LocXPos | ztString | 5 |  | varchar
Y Pos. | LocYPos | ztString | 5 |  | varchar
MHA | Mha | ztString | 5 |  | varchar
Mobile unit | MobileUnit | ztString | 5 |  | varchar
Parent ID | ParentPalletId | ztString | 35 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Rack | Rack | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SKU ID | SKUPalletId | ztString | 35 |  | varchar
Storage type | StorageTypeCode | ztInteger | 3 |  | smallint
ID | TaskIId | ZtLong | 9 |  | int
Status | TaskStatusCode | ztInteger | 3 |  | smallint
Type | TaskTypeCode | ztInteger | 3 |  | smallint
Sequence number, TU | TUPalletContSeq | ztInteger | 3 |  | smallint
TU ID | TUPalletId | ztString | 35 |  | varchar
Unit code | UOM | ztString | 10 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_MU_FetchPalletLine Fetch, task

    Program: WMS_MU_ReplenPickLine Replenishment pick, task

    Program: WMS_Task Task


Task status code (WMS_TaskStatusCode)

Code for information status. Specifies status for assignment.

The following standard records exist. Do not alter/delete:

Status (TaskStatusCode) | Description (TaskStatusDesc)
1 | To be performed
2 | In progress
9 | Error
99 | Finished

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Status | TaskStatusCode | ztInteger | 3 |  | smallint
Description | TaskStatusDesc | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_TaskStatusCode Task status code


Task supervisor (agre)

Task supervisors on an assignment.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Task supervisor | AgrResponsible | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: agre Task supervisors


Task type code (WMS_TaskTypeCode)

Code for information type. Specifies type of information.

The following standard records exist. Do not alter/delete:

Type (TaskTypeCode) | Description (TaskTypeDesc)
5 | Load pallet
10 | Unload pallet
20 | Pick
100 | Receiving
101 | Manually
102 | Split
103 | Merge
104 | Cycle count
202 | Row pick
203 | Zero pick

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Type | TaskTypeCode | ztInteger | 3 |  | smallint
Description | TaskTypeDesc | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_TaskTypeCode Task type code


Tax Area Level 1 (TaxAreaLevel1)

Table that contains definitions of Tax Areas for level 1.

The following standard records exist. Do not alter/delete:

Tax area level 1
(TaxAreaCode1) 		Tax area level 1
(TaxAreaDescr1)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
New tax area rate 1 | NewTaxAreaRate1 | ZtDecimal73 | 10 | 4 | decimal
New tax valid from date 1 | NewTaxFromDate1 | ztDate |  |  | datetime
New tax valid to date 1 | NewTaxToDate1 | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax area level 1 | TaxAreaCode1 | ztString | 10 |  | varchar
Tax area level 1 | TaxAreaDescr1 | ztString | 60 |  | varchar
Tax area rate 1 | TaxAreaRate1 | ZtDecimal73 | 10 | 4 | decimal
Tax chain calculation 1 | TaxChainCalc1 | ztBoolean |  |  | char
Tax jurisdiction | TaxJurCode | ztInteger | 2 |  | smallint
Tax limit amount 1 | TaxLimitAmount1 | ZtBaseCurrAmount | 14 | 2 | money

    This table is the main table in the following programs:

    Program: TaxAreaLevel1 Tax area level 1

    Program: TaxAreaLevels Tax area levels 1-5


Tax Area Level 2 (TaxAreaLevel2)

Table that contains definitions of Tax Areas for level 2.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
New tax area rate 2 | NewTaxAreaRate2 | ZtDecimal73 | 10 | 4 | decimal
New tax valid from date 2 | NewTaxFromDate2 | ztDate |  |  | datetime
New tax valid to date 2 | NewTaxToDate2 | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax area level 1 | TaxAreaCode1 | ztString | 10 |  | varchar
Tax area level 2 | TaxAreaCode2 | ztString | 10 |  | varchar
Tax area level 2 | TaxAreaDescr2 | ztString | 60 |  | varchar
Tax area rate 2 | TaxAreaRate2 | ZtDecimal73 | 10 | 4 | decimal
Tax chain calculation 2 | TaxChainCalc2 | ztBoolean |  |  | char
Tax jurisdiction | TaxJurCode | ztInteger | 2 |  | smallint
Tax limit amount 2 | TaxLimitAmount2 | ZtBaseCurrAmount | 14 | 2 | money

    This table is the main table in the following programs:

    Program: TaxAreaLevel2 Tax area level 2


Tax Area Level 3 (TaxAreaLevel3)

Table that contains definitions of Tax Areas for level 3.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
New tax area rate 3 | NewTaxAreaRate3 | ZtDecimal73 | 10 | 4 | decimal
New tax valid from date 3 | NewTaxFromDate3 | ztDate |  |  | datetime
New tax valid to date 3 | NewTaxToDate3 | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax area level 1 | TaxAreaCode1 | ztString | 10 |  | varchar
Tax area level 2 | TaxAreaCode2 | ztString | 10 |  | varchar
Tax area level 3 | TaxAreaCode3 | ztString | 10 |  | varchar
Tax area level 3 | TaxAreaDescr3 | ztString | 60 |  | varchar
Tax area rate 3 | TaxAreaRate3 | ZtDecimal73 | 10 | 4 | decimal
Tax chain calculation 3 | TaxChainCalc3 | ztBoolean |  |  | char
Tax jurisdiction | TaxJurCode | ztInteger | 2 |  | smallint
Tax limit amount 3 | TaxLimitAmount3 | ZtBaseCurrAmount | 14 | 2 | money

    This table is the main table in the following programs:

    Program: TaxAreaLevel3 Tax area level 3


Tax Area Level 4 (TaxAreaLevel4)

Table that contains definitions of Tax Areas for level 4.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
New tax area rate 4 | NewTaxAreaRate4 | ZtDecimal73 | 10 | 4 | decimal
New tax valid from date 4 | NewTaxFromDate4 | ztDate |  |  | datetime
New tax valid to date 4 | NewTaxToDate4 | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax area level 1 | TaxAreaCode1 | ztString | 10 |  | varchar
Tax area level 2 | TaxAreaCode2 | ztString | 10 |  | varchar
Tax area level 3 | TaxAreaCode3 | ztString | 10 |  | varchar
Tax area level 4 | TaxAreaCode4 | ztString | 10 |  | varchar
Tax area level 4 | TaxAreaDescr4 | ztString | 60 |  | varchar
Tax area rate 4 | TaxAreaRate4 | ZtDecimal73 | 10 | 4 | decimal
Tax chain calculation 4 | TaxChainCalc4 | ztBoolean |  |  | char
Tax jurisdiction | TaxJurCode | ztInteger | 2 |  | smallint
Tax limit amount 4 | TaxLimitAmount4 | ZtBaseCurrAmount | 14 | 2 | money

    This table is the main table in the following programs:

    Program: TaxAreaLevel4 Tax area level 4


Tax Area Level 5 (TaxAreaLevel5)

Table that contains definitions of Tax Areas for level 5.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
New tax area rate 5 | NewTaxAreaRate5 | ZtDecimal73 | 10 | 4 | decimal
New tax valid from date 5 | NewTaxFromDate5 | ztDate |  |  | datetime
New tax valid to date 5 | NewTaxToDate5 | ztDate |  |  | datetime
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax area level 1 | TaxAreaCode1 | ztString | 10 |  | varchar
Tax area level 2 | TaxAreaCode2 | ztString | 10 |  | varchar
Tax area level 3 | TaxAreaCode3 | ztString | 10 |  | varchar
Tax area level 4 | TaxAreaCode4 | ztString | 10 |  | varchar
Tax area level 5 | TaxAreaCode5 | ztString | 10 |  | varchar
Tax area level 5 | TaxAreaDescr5 | ztString | 60 |  | varchar
Tax area rate 5 | TaxAreaRate5 | ZtDecimal73 | 10 | 4 | decimal
Tax chain calculation 5 | TaxChainCalc5 | ztBoolean |  |  | char
Tax jurisdiction | TaxJurCode | ztInteger | 2 |  | smallint
Tax limit amount 5 | TaxLimitAmount5 | ZtBaseCurrAmount | 14 | 2 | money

    This table is the main table in the following programs:

    Program: TaxAreaLevel5 Tax area level 5


Tax Codes (TaxCode)

Table that contains definitions of Tax Areas for level 1.

The following standard records exist. Do not alter/delete:

Sales tax code (TaxCode) | Sales tax code (TaxCodeDescr) | Description
0 | Tax exempt | The customer is exempt from sales tax in this state, county or city.
1 | Normal tax | Sales tax is collected for the customer according to the rates defined per state, county and/or city.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sales tax code | TaxCode | ztInteger | 2 |  | smallint
Sales tax code | TaxCodeDescr | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: TaxCode Tax codes


Tax depreciation - Invent detail (insh)

Fixed assets that are included in tax depreciation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Acquisition amount | Anskbelopp | ZtBaseCurrAmount | 14 | 2 | money
Acquisition date | AnskDat | ztDate |  |  | datetime
Quantity | Antal | ZtQty | 14 | 2 | decimal
Deprn journal status | avskjstatus | ztInteger | 2 |  | smallint
Depreciated amount | AvskrBelopp | ZtBaseCurrAmount | 14 | 2 | money
Depreciation journal | Avskrjournal | ZtLong | 5 |  | int
Discard amount | DiscardAmount | ztMoney | 14 | 2 | money
Discard date | DiscardDate | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Tax depreciation type | inskAvsTypid | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Fixed asset no | inventarie | ZtLong | 10 |  | int
Component fixed asset | InventariePos | ztInteger | 5 |  | smallint
Residual value | InvRest | ZtBaseCurrAmount | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Discard/sale amount | UtrangBelopp | ZtBaseCurrAmount | 14 | 2 | money
Discard/sale date | UtrangDat | ztDate |  |  | datetime


Tax depreciation types (inskAvsTyp)

Definition of applicable tax depreciation types for fixed assets.

The following standard records exist. Do not alter/delete:

Tax depreciation type (inskAvsTypid) | Tax depreciation type (inskAvsTypDesc)
1 | Intangible fixed assets
2 | Buildings and land improvements
3 | Machinery and equipment
10 | Intangible fixed assets (man adjmt)
20 | Buildings and land improvements (man adjmt)
30 | Machinery and equipment (man adjmt)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Connected to FA group | ConnFAgrp | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Tax depreciation type | inskAvsTypDesc | ztString | 100 |  | varchar
Tax depreciation type | inskAvsTypid | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: inskAvsTyp Tax depreciation types


Tax Exempt certificates (TaxExemptCert)

Table that contains definitions of Tax Areas for level 1.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax area level 1 | TaxAreaCode1 | ztString | 10 |  | varchar
Tax area level 2 | TaxAreaCode2 | ztString | 10 |  | varchar
Tax area level 3 | TaxAreaCode3 | ztString | 10 |  | varchar
Tax area level 4 | TaxAreaCode4 | ztString | 10 |  | varchar
Tax area level 5 | TaxAreaCode5 | ztString | 10 |  | varchar
Expiration date | TaxExemptExpDate | ztDate |  |  | datetime
Tax Exempt Id | TaxExemptId | ztInteger | 5 |  | smallint
Resale Certificate No | TaxExemptNo | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: TaxExemptCert Tax exemption certificates


Tax exemptions per Item (TaxExemptAr)

Table that contains definitions of Sales Tax exemptions per Items.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax area level 1 | TaxAreaCode1 | ztString | 10 |  | varchar
Tax area level 2 | TaxAreaCode2 | ztString | 10 |  | varchar
Tax area level 3 | TaxAreaCode3 | ztString | 10 |  | varchar
Tax area level 4 | TaxAreaCode4 | ztString | 10 |  | varchar
Tax area level 5 | TaxAreaCode5 | ztString | 10 |  | varchar
Tax area rate 1 | TaxAreaRate1 | ZtDecimal73 | 10 | 4 | decimal
Tax area rate 2 | TaxAreaRate2 | ZtDecimal73 | 10 | 4 | decimal
Tax area rate 3 | TaxAreaRate3 | ZtDecimal73 | 10 | 4 | decimal
Tax area rate 4 | TaxAreaRate4 | ZtDecimal73 | 10 | 4 | decimal
Tax area rate 5 | TaxAreaRate5 | ZtDecimal73 | 10 | 4 | decimal
Tax limit amount 1 | TaxLimitAmount1 | ZtBaseCurrAmount | 14 | 2 | money
Tax limit amount 2 | TaxLimitAmount2 | ZtBaseCurrAmount | 14 | 2 | money
Tax limit amount 3 | TaxLimitAmount3 | ZtBaseCurrAmount | 14 | 2 | money
Tax limit amount 4 | TaxLimitAmount4 | ZtBaseCurrAmount | 14 | 2 | money
Tax limit amount 5 | TaxLimitAmount5 | ZtBaseCurrAmount | 14 | 2 | money
Tax method area 1 | TaxMethodArea1 | ztInteger | 2 |  | smallint
Tax method area 2 | TaxMethodArea2 | ztInteger | 2 |  | smallint
Tax method area 3 | TaxMethodArea3 | ztInteger | 2 |  | smallint
Tax method area 4 | TaxMethodArea4 | ztInteger | 2 |  | smallint
Tax method area 5 | TaxMethodArea5 | ztInteger | 2 |  | smallint
Tax rate status area 1 | TaxRateStatusArea1 | ztInteger | 2 |  | smallint
Tax rate status area 2 | TaxRateStatusArea2 | ztInteger | 2 |  | smallint
Tax rate status area 3 | TaxRateStatusArea3 | ztInteger | 2 |  | smallint
Tax rate status area 4 | TaxRateStatusArea4 | ztInteger | 2 |  | smallint
Tax rate status area 5 | TaxRateStatusArea5 | ztInteger | 2 |  | smallint
Tax valid from date 1 | TaxValidFromDate1 | ztDate |  |  | datetime
Tax valid from date 2 | TaxValidFromDate2 | ztDate |  |  | datetime
Tax valid from date 3 | TaxValidFromDate3 | ztDate |  |  | datetime
Tax valid from date 4 | TaxValidFromDate4 | ztDate |  |  | datetime
Tax valid from date 5 | TaxValidFromDate5 | ztDate |  |  | datetime
Tax valid to date 1 | TaxValidToDate1 | ztDate |  |  | datetime
Tax valid to date 2 | TaxValidToDate2 | ztDate |  |  | datetime
Tax valid to date 3 | TaxValidToDate3 | ztDate |  |  | datetime
Tax valid to date 4 | TaxValidToDate4 | ztDate |  |  | datetime
Tax valid to date 5 | TaxValidToDate5 | ztDate |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: TaxExemptAr Sales tax exemptions, Item


Tax exemptions per Item group (TaxExemptVg)

Table that contains definitions of Sales Tax exemptions per Item groups.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax area level 1 | TaxAreaCode1 | ztString | 10 |  | varchar
Tax area level 2 | TaxAreaCode2 | ztString | 10 |  | varchar
Tax area level 3 | TaxAreaCode3 | ztString | 10 |  | varchar
Tax area level 4 | TaxAreaCode4 | ztString | 10 |  | varchar
Tax area level 5 | TaxAreaCode5 | ztString | 10 |  | varchar
Tax area rate 1 | TaxAreaRate1 | ZtDecimal73 | 10 | 4 | decimal
Tax area rate 2 | TaxAreaRate2 | ZtDecimal73 | 10 | 4 | decimal
Tax area rate 3 | TaxAreaRate3 | ZtDecimal73 | 10 | 4 | decimal
Tax area rate 4 | TaxAreaRate4 | ZtDecimal73 | 10 | 4 | decimal
Tax area rate 5 | TaxAreaRate5 | ZtDecimal73 | 10 | 4 | decimal
Tax limit amount 1 | TaxLimitAmount1 | ZtBaseCurrAmount | 14 | 2 | money
Tax limit amount 2 | TaxLimitAmount2 | ZtBaseCurrAmount | 14 | 2 | money
Tax limit amount 3 | TaxLimitAmount3 | ZtBaseCurrAmount | 14 | 2 | money
Tax limit amount 4 | TaxLimitAmount4 | ZtBaseCurrAmount | 14 | 2 | money
Tax limit amount 5 | TaxLimitAmount5 | ZtBaseCurrAmount | 14 | 2 | money
Tax method area 1 | TaxMethodArea1 | ztInteger | 2 |  | smallint
Tax method area 2 | TaxMethodArea2 | ztInteger | 2 |  | smallint
Tax method area 3 | TaxMethodArea3 | ztInteger | 2 |  | smallint
Tax method area 4 | TaxMethodArea4 | ztInteger | 2 |  | smallint
Tax method area 5 | TaxMethodArea5 | ztInteger | 2 |  | smallint
Tax rate status area 1 | TaxRateStatusArea1 | ztInteger | 2 |  | smallint
Tax rate status area 2 | TaxRateStatusArea2 | ztInteger | 2 |  | smallint
Tax rate status area 3 | TaxRateStatusArea3 | ztInteger | 2 |  | smallint
Tax rate status area 4 | TaxRateStatusArea4 | ztInteger | 2 |  | smallint
Tax rate status area 5 | TaxRateStatusArea5 | ztInteger | 2 |  | smallint
Tax valid from date 1 | TaxValidFromDate1 | ztDate |  |  | datetime
Tax valid from date 2 | TaxValidFromDate2 | ztDate |  |  | datetime
Tax valid from date 3 | TaxValidFromDate3 | ztDate |  |  | datetime
Tax valid from date 4 | TaxValidFromDate4 | ztDate |  |  | datetime
Tax valid from date 5 | TaxValidFromDate5 | ztDate |  |  | datetime
Tax valid to date 1 | TaxValidToDate1 | ztDate |  |  | datetime
Tax valid to date 2 | TaxValidToDate2 | ztDate |  |  | datetime
Tax valid to date 3 | TaxValidToDate3 | ztDate |  |  | datetime
Tax valid to date 4 | TaxValidToDate4 | ztDate |  |  | datetime
Tax valid to date 5 | TaxValidToDate5 | ztDate |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: TaxExemptVg Sales tax exemptions, Item group


Tax Jurisdiction (TaxJurisdiction)

Table that contains definitions of Tax Jurisdictions.

The following standard records exist. Do not alter/delete:

Tax jurisdiction (TaxJurCode) | Tax jurisdiction (TaxJurDescr) | Description
1 | State | The description can be changed to PST for Canada.
2 | County | The description can be changed to GST for Canada.
3 | City | The description can be changed to HST for Canada.
4 | Local county |
5 | Local city |

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax jurisdiction | TaxJurCode | ztInteger | 2 |  | smallint
Tax jurisdiction | TaxJurDescr | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: TaxJurisdiction Tax jurisdictions


Tax Methods (TaxMethod)

Table that contains definitions of Tax Areas for level 1.

The following standard records exist. Do not alter/delete:

Tax method (TaxMethod) | Tax method (TaxMethodDescr) | Description
1 | Always applicable | Sales tax applies generally, irrespective of order value.
2 | Applicable BELOW spec limit | Sales tax only applies below a certain order value. ***NOT YET IMPLEMENTED***
3 | Applicable ABOVE spec limit | Sales tax only applies above a certain order value. ***NOT YET IMPLEMENTED***

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax method | TaxMethod | ztInteger | 2 |  | smallint
Tax method | TaxMethodDescr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: TaxMethod Tax methods


Tax on customer invoice (fhm)

The tax rates and tax amounts on customer invoices.
Created by the invoicing program

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Early stlmt dsct basis curr | CashDiscBaseFCU | ztMoney | 14 | 2 | money
VAT bas early settlmt discnt curr | CashDiscBaseFCU_VAT | ztMoney | 14 | 2 | money
Sales tax | FaktMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice total incl tax | FaktTotMMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice total excl tax | FaktTotUMoms | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Invoice amount, curr | Vb_FaktSum | ztMoney | 14 | 2 | money
VAT/tax, curr | VbFaktMoms | ztMoney | 14 | 2 | money
Invoice total excl tax | VbFaktTotUMoms | ztMoney | 14 | 2 | money

    This table is the main table in the following programs:

    Program: fhm Customer invoice VAT/tax


Tax Rate status (TaxRateStatus)

Table that contains definitions of Tax Areas for level 1.

The following standard records exist. Do not alter/delete:

Tax rate status (TaxRateStatus) | Tax rate status (TaxRateStatusDescr) | Description
1 | Preliminary | You can use this status when setting up tax rates, if a tax rate should not yet be applied. There is no other logic connected to the status code.
2 | Active | Only tax rates with this status are applied.
9 | Expired | You can use this status if a tax rate should no longer be applied, but you want to keep the specified tax rate for a certain reason. There is no other logic connected to the status code.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax rate status | TaxRateStatus | ztInteger | 2 |  | smallint
Tax rate status | TaxRateStatusDescr | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: TaxRateStatus Tax rate status


Tax rates (View) (vxm0)

Definition of the tax types used for sales and purchasing, with associated tax rates. The tax codes can also be used to control sales postings via posting templates.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
VAT/tax (description) | MomsBeskrivning | ztString | 50 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
New rate from date | NyMomsFromDatum | ztDate |  |  | datetime
New VAT/tax rate | NyMomsSats | ZtDecimal73 | 5 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Tax rates (View) (vxm1)

Definition of the tax types used for sales and purchasing, with associated tax rates. The tax codes can also be used to control sales postings via posting templates.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
VAT/tax (description) | MomsBeskrivning | ztString | 50 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
New rate from date | NyMomsFromDatum | ztDate |  |  | datetime
New VAT/tax rate | NyMomsSats | ZtDecimal73 | 5 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Tax rates (View) (vxm2)

Definition of the tax types used for sales and purchasing, with associated tax rates. The tax codes can also be used to control sales postings via posting templates.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
VAT/tax (description) | MomsBeskrivning | ztString | 50 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
New rate from date | NyMomsFromDatum | ztDate |  |  | datetime
New VAT/tax rate | NyMomsSats | ZtDecimal73 | 5 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Tax rates (View) (vxm3)

Definition of the tax types used for sales and purchasing, with associated tax rates. The tax codes can also be used to control sales postings via posting templates.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
VAT/tax (description) | MomsBeskrivning | ztString | 50 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
New rate from date | NyMomsFromDatum | ztDate |  |  | datetime
New VAT/tax rate | NyMomsSats | ZtDecimal73 | 5 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Tax rates (View) (vxm4)

Definition of the tax types used for sales and purchasing, with associated tax rates. The tax codes can also be used to control sales postings via posting templates.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
VAT/tax (description) | MomsBeskrivning | ztString | 50 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
New rate from date | NyMomsFromDatum | ztDate |  |  | datetime
New VAT/tax rate | NyMomsSats | ZtDecimal73 | 5 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Tax statement - history (taxh)

Tax statement's rows. (Slovakian adaptation).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Round sum | AvrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
Net amount | Belopp | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Tax amount | MomsBelopp | ZtBaseCurrAmount | 14 | 2 | money
Tax base amount | MomsGrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Auto created | VATautocreated | ztBoolean |  |  | char
Cell description | VATcelldescr | ztString | 80 |  | varchar
Cell no. | VATcellno | ztInteger | 5 |  | smallint
Corrected amount | VATcorrectionamount | ZtBaseCurrAmount | 14 | 2 | money
Incl corrected amount | VATinclcorramount | ZtBaseCurrAmount | 14 | 2 | money
Tax period | VATPeriod | ztString | 8 |  | varchar
Recreate | VATrecreate | ztBoolean |  |  | char
VAT/tax stmt status | VATStatus | ztString | 1 |  | varchar
Correction no. | VATtaxcorrectionno | ztInteger | 2 |  | smallint
Tax period | VATtaxperiod | ztInteger | 2 |  | smallint
Tax year | VATtaxyear | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: Taxh Tax statement rows


Tax statement row description (taxc)

Definition of descriptive texts for each cell in the tax statement (country specific adaptation).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Debit/credit | DebKre | ztchar | 1 |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Cell description | VATcelldescr | ztString | 80 |  | varchar
Cell no. | VATcellno | ztInteger | 5 |  | smallint
Tax period | VATPeriod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: taxc Tax statement row description


Tax statement status (taxs)

Definition of relevant status codes that can occur on the tax statement rows. (Country specific adaptation).

The following standard records exist. Do not alter/delete:

VAT/tax stmt status (VATStatus) | VAT/tax stmt status (VatStatusBeskr)
D | Correction
N | Not included
V | Complete
Y | Preliminary
Z | Discarded

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
VAT/tax stmt status | VATStatus | ztString | 1 |  | varchar
VAT/tax stmt status | VATStatusBeskr | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: taxs Tax statement status description


Tax statement status (BE_VAT_Status)

Definition of relevant status codes that can occur on the tax statement rows.

The following standard records exist. Do not alter/delete:

VAT/tax stmt status (VATStatus) | VAT/tax stmt status (VATStatusBeskr)
D | Definitive
P | Preliminary
R | Removed from report

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
VAT/tax stmt status | VATStatus | ztString | 1 |  | varchar
VAT/tax stmt status | VATStatusBeskr | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: BE_VAT_Status VAT/tax statement status


Telecom types, view 1 (vx41)

Definition of the phone type that is to be used to show or advise of the telephone numbers of customers and suppliers (on freight documents to the customer).

An alternative to this function is to specify for the company's (customer's/supplier's) telephone records a dispatch notify method according to the definition in the program 'dispatch notify method (xx1g) with the following coding:
1 = Phone
2 = Fax
3 = Home phone

In the order/purchase routine certain programs have preprogrammed buttons allowing you to quickly access three phone numbers for the customer/supplier. If this function is only used to display customer/supplier phone numbers it does not matter which phone type is specified here.

If the function is also used for notification on freight documents to customers, a phone type must be defined referring to customer phone numbers, since this number is printed under the heading 'Telephone notification' on freight documents.

TIP!
-------
If you want to create your own buttons in other programs than those that have pre-programmed buttons to display phone numbers for customers/suppliers, here is an example of the macro code that you can use in programs where the customer table is the main table:

function @KusTfnNr:boolean;
var FtgNr:string;
     FtgKod:integer;
begin

   FtgKod:='';
   if TermExists('kus','foretagkod') then FtgKod:=kus.ForetagKod;

   if TermExists('kus','ftgnr') then
      begin
         FtgNr:=kus.FtgNr;
         UF_Show_TfnNr(FtgNr,FtgKod);
      end;

   @KusTfnNr:=true;

end;
You can modify the macro code to use it for all tables which include the term FtgNr.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Contact method | ComBeskr | ztString | 50 |  | varchar
Contact method | ComKort | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Phone, show/advise | ShowComKod1 | ztString | 2 |  | varchar


Temp table for labour rep (SFR_Ao)

Temporary table for labour reporting.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Interruption code | aoavbrottskod | ztInteger | 5 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | aopos | ztInteger | 4 |  | int
Manufactured qty/op | aorappant | ZtQty | 14 | 2 | decimal
Scrapped qty | aorappkassant | ZtQty | 14 | 2 | decimal
Reported time per unit | aorappstycktid | ztOpTime | 9 | 4 | float
Work group | arbetslag | ztString | 6 |  | varchar
Item description | ArtBeskr | ztString | 6 |  | varchar
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Flow group | flodesgrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Return/scrap reason | kassorsakskod | ztInteger | 2 |  | smallint
Operation no. | opnr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | perssign2 | ztString | 6 |  | varchar
Manufacturing group | prodgr | ztString | 5 |  | varchar
Rep no. minutes | RappAntalMinuter | ZtLong | 10 |  | int
Rep manhours manufacturing | RappManTidTillverkning | ztOpTime | 9 | 4 | float
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Aop records | SFRAoPCount | ztInteger | 5 |  | smallint
Calculation priority | SFRCalcPrio | ztInteger | 5 |  | smallint
Manually created | SFRManCreated | ztBoolean |  |  | char
Reportingtype SFR | SFRRepType | ztInteger | 5 |  | smallint
Stamp time | SFRWORepDat | ztDateTime |  |  | datetime
End stamp time | SFRWORepEndDt | ztDateTime |  |  | datetime
Start Stamptime | SFRWORepStartDt | ztDateTime |  |  | datetime
Status | sfrwostatus | ztInteger | 5 |  | smallint
Identity | SQLIdentity | ZtLong | 10 |  | int
Indirect job/labour | veovrigtjobb | ztInteger | 5 |  | smallint
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: SFR_Ao Adjustment shop floor reports


Template companies in package solution (JvsPackageTemplateCompanies)

Template company included in a package solution. Only tables with the Company code column (foretagkod) are included.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Add Missing Columns | AddMissingColumns | ztBoolean |  |  | char
Add Missing Tables | AddMissingTables | ztBoolean |  |  | char
Company Code | CompanyCode | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Solution ID | SolutionID | ZtLong | 10 |  | int


Temporary assembly reporting table (head) (SFR_KapH)

Identification on an op join list.
Normally, a sequence number.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Interruption code | AoAvbrottsKod | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Op join list No. | kaplista | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | perssign2 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Interrupt | SFRInterrupt | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: SFR_KapH Temporary assembly reporting table (head)


Temporary assembly reporting table (line) (SFR_KapL)

Manufacturing order number/work order number based on an automatically assigned sequence number.
Your own alphanumeric order numbers can be entered in another field on the manufacturing order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Interruption code | aoavbrottskod | ztInteger | 5 |  | smallint
Mfg/Works order no. | aonr | Jeeves_MONo | 7 |  | bigint
Row | aopos | ztInteger | 4 |  | int
Manufactured qty/op | aorappant | ZtQty | 14 | 2 | decimal
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Item no. | artnr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Op join list No. | Kaplista | ZtLong | 10 |  | int
Return/scrap reason | kassorsakskod | ztInteger | 2 |  | smallint
Operation no. | opnr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Interrupt | SFRInterrupt | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: SFR_KapL Temporary assembly reporting table (line)


Temporary mru reporting table (head) (SFR_mruh)

Temporary table for material reporting in shop floor control.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Qty parent BOM/pkg level | bantalavi | ztFloat | 12 | 4 | float
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Item no. required | mrArtNr | ztString | 30 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Planned quantity | PlaneratAntal | ZtQty | 14 | 2 | decimal
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Ref to table SFRAo | SFRConnAoId | ZtLong | 10 |  | int
Identity | SQLIdentity | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: SFR_mruh Mru reporting table (head)


Temporary mru reporting table (rows) (SFR_mrul)

Temporary table for material reporting in shop floor control.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Batch no. | BatchId | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Return/scrap reason | KassOrsaksKod | ztInteger | 2 |  | smallint
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory balance | lagsaldo | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Item no. required | mrArtNr | ztString | 30 |  | varchar
Picked quantity | MrRappAnt | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Ref to parent table | SFRConnSqlIdentity | ZtLong | 10 |  | int
Identity | SQLIdentity | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: SFR_mrul Temporary mru reporting table (rows)


Temporary table for EDI-mail (edit)

This table is used to build the mail generated by the EDI server. The table contains temporary characters and is automatically cleared when the mail in question is sent.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Process ID | spid | ZtLong | 5 |  | int
Prompt | TermPrompt | ztString | 30 |  | varchar
Value | TermValue | ztString | 255 |  | varchar


Term keys (WMS_TermKey)

Definition of term keys for the different labels, buttons, menus and other controls in the mobile clients for WMS.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Prog translation | ProgTranslation | ztString | 255 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Term key | TermKey | ztString | 128 |  | varchar
Term type | TermType | ztString | 128 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_TermKey Term keys


Term types (xrb)

Internal definition of types of terms/columns that can be used when converting external (or internal) data to the General Ledger.

The following standard records exist. Do not alter/delete:

Value type (VardeTermT) | Value type (VardeTermTB) | Description
0 | Numerical field | Numeric (digits)
1 | Sign | Alphanumeric (text / string / characters)
2 | Y/N | Boolean (yes/no, i.e. true/false)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Value type | VardeTermT | ztInteger | 3 |  | smallint
Value type | VardeTermTB | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: Yrb Term type


Terms (JvsSiteTerms)

Program/table for viewing and editing settings regarding edited term prompts, column headers, term lengths, number of decimal points and/or masks, as well as hidden terms.

The program/table can be accessed through an embedded window in the program Setting dimensions/keys (jvssitenodewin) or from Jeeves' menu.

For settings involving own texts there are also embedded windows for translating these texts to other languages in which the system is run.

Note that the fields in the header show the program/node/window in which the setting applies, e.g. if a program is named in the Program field, the setting only applies if that program is open.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mask | Editmask | ztString | 30 |  | nvarchar
Calculated column Sql AS | JvsSiteComputedColumnAS | ztString | 255 |  | nvarchar
Macro | JvsSiteMacroName | ztString | 40 |  | nvarchar
Hidden | JvsSiteMakeInvisible | ztBoolean |  |  | char
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Setting ID (orig) | JvsSiteNodeWinSettingsID_orig | ZtLong | 10 |  | int
Decimals | JvsSiteTermDecimals | ztInteger | 5 |  | smallint
Column header | JvsSiteTermHeader | ztString | 60 |  | nvarchar
Max no of char | JvsSiteTermInpLength | ztInteger | 4 |  | smallint
Length | JvsSiteTermLength | ztInteger | 4 |  | smallint
Data type | JvsSiteTermLogDataType | ztString | 30 |  | nvarchar
Term | JvsSiteTermName | ztString | 40 |  | nvarchar
Prompt | JvsSiteTermPrompt | ztString | 60 |  | nvarchar
User-defined | JvsSiteUserAdded | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteTerms Terms


Terms added to table (JvsSiteTableColumns)

Program/table for viewing user-defined terms that have been added to tables.

The program/table can be accessed through an embedded window in the program Setting dimensions/keys (jvssitenodewin) or from Jeeves' menu.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Term | JvsSiteColumnName | ztString | 40 |  | nvarchar
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Setting ID (orig) | JvsSiteNodeWinSettingsID_orig | ZtLong | 10 |  | int
Table | JvsSiteTableName | ztString | 40 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteTableColumns Terms added to table


Terms, and/or (xand)

Condition for governing, for example, how a split will function in a work flow.

The following standard records exist. Do not alter/delete:

Condition AND, OR (andor) | And/Or (andordescr) | Description
0 | and | (Default) Condition means that all activities in a split must be completed before the work in the flow can progress. This record must exist in the database to be able to run Jeeves Workflow.
1 | or | Condition means that it is sufficient that one activity in a split is completed before the work in the flow can progress. This record must exist in the database to be able to run Jeeves Workflow.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Condition AND, OR | andor | ztInteger | 1 |  | smallint
And/Or | andordescr | ztString | 20 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xand Terms, and/or


Texts work flow(SupplTxt) (wtxt)

Numeric language code according to Jeeves'internal standard. The language code is used throughout the entire system to identify the language in which texts, e.g. item descriptions, are to be printed/displayed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | sprakkod | ztInteger | 3 |  | smallint
TextID | textid | ZtLong | 10 |  | int
Text/info | x255 | ztString | 255 |  | varchar


Time columns (AttR_tc)

Group salary types.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Column | AttRColumn | ztInteger | 4 |  | smallint
Salary type | AttRSalaryType | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_tc Time columns


Time report (Tidr)

Time report header. Summary record to group all time rows that have been entered for a person a certain week.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Hours | EventTimAnt2 | ztHourWithDecimals | 8 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Time accrued | NedLagdTid | ztHourWithDecimals | 8 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Time report no. | TidrapportNr | ZtLong | 10 |  | int
Status | Tidrappstatkd | ztInteger | 2 |  | smallint
Week no | Veckonr | ztInteger | 6 |  | smallint

    This table is the main table in the following programs:

    Program: Tidr Time reporting per week


Time report approval (TidrAttest)

Time report header for approval. Summary record to group all time rows that have been entered for a person a certain month.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval chain time | AppChainTime | ztInteger | 5 |  | smallint
Approved by | AttestSign | ztString | 6 |  | varchar
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Hours | EventTimAnt2 | ztHourWithDecimals | 8 | 2 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calendar year | KalenderAr | ztInteger | 4 |  | smallint
Kalendermånad | KalenderManad | ztInteger | 2 |  | smallint
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Time accrued | NedLagdTid | ztHourWithDecimals | 8 | 2 | decimal
Total working time calendar | PeriodArbTid | ztHourWithDecimals | 8 | 2 | decimal
Period time correction | PeriodKorrTid | ztHourWithDecimals | 8 | 2 | decimal
Total period time | PeriodNedlagdTid | ztHourWithDecimals | 8 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Status | Tidrappstatkd | ztInteger | 2 |  | smallint
Unique ID link | wfrowuniqueid | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: TidrAttest Time report approval


Time report template (tidm)

Table for time report templates. Used by the Web application.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Subproject | Aktivitet | ztInteger | 4 |  | smallint
Reported activity | EventRpKod | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Template company | MallForetagKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Status | TidmStatus | ztchar | 1 |  | char
Sector | verksamhet | ztInteger | 5 |  | smallint


Time report types (xo6)

Table of time reports types for attendance reporting which are used to show arrival etc.
Examples of use:

0-99 are for messages to foreman
100-199 are for arrivals
200-299 are for end of day

The following standard records exist. Do not alter/delete:

Time report type (PrvtTyp) | Time report type (PrvtTypBeskr)
0 | Message
100 | Arrival
200 | End of workday
210 | Left 1
220 | Left 2
230 | End of workday without arrival report
240 | End of workday without arrival (same day
310 | Finished labour reporting
320 | Unfinished labour reporting
330 | Interruption due to end of workday
410 | Interruption
900 | Remove ongoing work transaction

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Time report type | PrvtTyp | ztInteger | 3 |  | smallint
Time report type | PrvtTypBeskr | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xo6 Report types, workshop


Time Type Classes (AttR_ttcl)

Holds time type classes and descriptions of those.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Time type class | AttRTimeTypeClass | ztInteger | 5 |  | smallint
Time type class descr | AttRTimeTypeClassDescr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_ttcl Time type classes


Time Types (AttR_tt)

Time types and their characteristics.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Attendance | AttRAttendance | ztBoolean |  |  | char
No schedule limit | AttRNoSchedLimit | ztBoolean |  |  | char
Part of work metrics | AttRPartOfHrs | ztBoolean |  |  | char
Time type | AttRTimeType | ztString | 6 |  | varchar
Class Mask | AttRTimeTypeClassMask | ZtLong | 10 |  | int
Time type descr | AttRTimeTypeDescr | ztString | 50 |  | varchar
Time type prio | AttRTimeTypePriority | ztInteger | 1 |  | smallint
Work hours | AttRWorkHrs | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Production | SFRProdInfo | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: AttR_tt Time types


Time Types view (1) (vAttR_tt)

Alphanumerical code for the time type. Time types can for example be Normal hours, Overtime, Flexi hours etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Time type | AttRTimeType | ztString | 6 |  | varchar
Time type descr | AttRTimeTypedescr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: vAttR_tt Time Types view (1)


Time types, services language (xtcs)

Language translations of descriptions of time types.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Time type | Tidkod | ztInteger | 5 |  | smallint
Time type | Tidkodbeskr | ztString | 50 |  | varchar


Time units, forecasts (Pren)

Definition of desired time units for building up item forecasts, e.g. year, Month, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Forecast unit | PrognosEnhet | ztInteger | 4 |  | smallint
Forecast unit name | PrognosEnhetNamn | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Pren Time units, forecasts


Time zone areas (TimeZones)

A time zone is an area on earth with the same standard time, so-called "ZONE TIME". The universal time, UTC (Coordinated Universal Time), is used as a reference when defining time zones.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Created UTC date/time | RowCreatedUTCDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Updated date/time | RowUpdatedUTCDT | ztDateTime |  |  | datetime
Time zone code | TimeZoneCode | ztInteger | 4 |  | smallint
Time zone name | TimeZoneName | ztString | 40 |  | nvarchar
Time zone UTC offset | TimeZoneUTCOffset | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: TimeZones Time zone areas


Time-controlled job details (view) (msjs)

sysjobsteps Contains the information for each step in a job to be executed by SQL Server Enterprise Manager. This table is stored in the msdb database.

---
A database view to the SQL Server table of job steps that make up a job.
---

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
msdb_additional_params | msdb_additional_params | ztBlob | 1 |  | varchar
Spec of work stage | msdb_Command | ztBlob | 1 |  | varchar
Job ID | msdb_job_id | ztUniqueIdentifier | 38 |  | varchar
File name | msdb_OutputFileName | ztString | 255 |  | nvarchar
Work stage ID | msdb_Step_ID | ZtLong | 10 |  | int
Work stage name | msdb_Step_Name | ztString | 255 |  | nvarchar


Time-controlled job history (view) (msjh)

sysjobhistory Contains information about the execution of scheduled jobs by SQL Server Enterprise Manager. This table is stored in the msdb database.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Unique row ID | msdb_Instance_ID | ZtLong | 10 |  | int
Job ID | msdb_job_id | ztUniqueIdentifier | 38 |  | varchar
Error message | msdb_message | ztBlob | 1 |  | varchar
Batch date | msdb_run_date | ZtLong | 10 |  | int
Work stage ID | msdb_Step_ID | ZtLong | 10 |  | int
Work stage name | msdb_Step_Name | ztString | 255 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime


Time-controlled jobs (scheduled) (view) (msjb)

sysjobs Stores the information for each scheduled job to be executed by SQL Server Enterprise Manager. This table is stored in the msdb database.

---
A database view to the SQL Server table of jobs that can be controlled time-wise.
The header information of a job is stored in this table.
The job itself (job step) is defined in an underlying table. Several steps can be defined per job.
When the job in question is to be done is defined (time controlled) in another table.
---

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | msdb_Description |  |  |  | @DataType=NULL
Job ID | msdb_job_id |  |  |  | @DataType=NULL
Name | msdb_Name |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL

    This table is the main table in the following programs:

    Program: msjb Time-cntrlld jobs (scheduled) in MSDB


Tolerance lev. for order ackowledgement (edif)

Contains the tolerance levels that will apply for receiving order acknowledgements via EDI. You can also specify whether you want to transfer information from the order acknowledgement to the purchase order.

You can have different tolerance levels for different suppliers, item groups or items.

When the validation is run, a search is done in this tolerance table in the following sequence. As soon as the system has a hit for a record, the search is canceled and the values from the record found apply

1. Company number, item number
2. Item number
3. Company number, item group
4. Item group
5. Company number
6. System level. (No key fields are filled in)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Tolerance quantity - | AntalDiffNeg | ztFloat | 15 | 2 | float
Tolerance quantity + | AntalDiffPos | ztFloat | 15 | 2 | float
Quantity tolerance in percent | AntalDiffProc | ztBoolean |  |  | char
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Tolerance disp. day - | LevDagDiffNeg | ztInteger | 5 |  | smallint
Tolerance disp. day + | LevDagDiffPos | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price tolerance - | PrisDiffNeg | ztFloat | 15 | 2 | float
Price tolerance - | PrisDiffPos | ztFloat | 15 | 2 | float
Price tolerance in percent | PrisDiffProc | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Update quantity | UppdateraAntal | ztBoolean |  |  | char
Update dispatch day | UppdateraLevDag | ztBoolean |  |  | char
Update price | UppdateraPris | ztBoolean |  |  | char
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: edif Tolerance lev. for order ackowledgement


Tool history (vyhis)

Contains history of the accumulators in the tool record. In this table, a record is created per tool each time resetting of the accumulators in the tool is performed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Acc start date | AckFromDatum | ztDate |  |  | datetime
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tools | Verktyg | ztString | 16 |  | varchar


Tool list, tools/details (vyld)

List of tools.
Contains a list of tools for one or several operations depending on how many operations use a tool list.
The list of tools contains a table where the tools included in the tool list are specified.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Number of tools | AntalVerktygVidTillv | ZtDecimal73 | 8 | 3 | float
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Deliv to supplier | LevMedBestTillLev | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Quality parameter | QParamId | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tools | Verktyg | ztString | 16 |  | varchar
List of tools | Verktygslista | ztString | 35 |  | varchar
Sequence in list of tools | VerktygslistaSekvNr | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: vyld Tool lists, details


Tool status (xvys)

Definition of the various statuses the tool can have, e.g. OK/In service/Defect.

This table does not contain standard records. You complete it in according to your own needs. Status can be specified as information on each individual tool.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
OK to use tool | ToolOkToUse | ztBoolean |  |  | char
Tool status | ToolStatusCode | ztInteger | 5 |  | smallint
Tool status | ToolStatusCodeDescr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: xvys Tool status


Tool types (xvyt)

Definition of existing tool types as required. The information can be used, for example, to divide tools into groups and for searching for tools by type.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tool type | VerktygsTyp | ztInteger | 5 |  | smallint
Tool type descr | VerktygsTypBeskr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: xvyt Tool types


Tools (vy)

Tools with data on costs. A tool is linked to one or several operations.

A tool can also be linked to a tool list which in turn can be linked to operations. A tool list is used when several tools are used for the same operation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Acc start date | AckFromDatum | ztDate |  |  | datetime
Antal verktyg | AntalVerktyg | ztFloat | 15 | 2 | float
Manufactured qty/op | AoRappAnt | ZtQty | 14 | 2 | decimal
This field is used in the table as follows: |
Scrapped qty | AoRappKassAnt | ZtQty | 14 | 2 | decimal
This field is used in the table as follows: |
Reported setup time | AoRappStallTid | ztOpTime | 9 | 4 | float
This field is used in the table as follows: |
Reported time per unit | AoRappStyckTid | ztOpTime | 9 | 4 | float
This field is used in the table as follows: |
Product acct, labour | ArbProdKonto | ztString | 8 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Replaced by tool | ErsattsAvVerktyg | ztString | 16 |  | varchar
Finish date, maintenance | FardDatUnderhall | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Valid to date | GiltigTomDatum | ztDate |  |  | datetime
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Deliv to supplier | LevMedBestTillLev | ztBoolean |  |  | char
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
Quantity PDM | pdmcount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
OK to use tool | ToolOkToUse | ztBoolean |  |  | char
Tool status | ToolStatusCode | ztInteger | 5 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Tools | Verktyg | ztString | 16 |  | varchar
Deprec tool cost | VerktygAvskrKost | ZtBaseCurrAmount | 14 | 2 | money
Tool description | VerktygBen | ztString | 30 |  | varchar
Fixed tool cost | VerktygFastKost | ZtBaseCurrAmount | 14 | 2 | money
Variable tool cost | VerktygRorlKost | ZtBaseCurrAmount | 14 | 2 | money
Tool revision | VerktygsRevision | ztString | 6 |  | varchar
Blueprint | VerktygsRitningsNr | ztString | 40 |  | varchar
Tool unit cost | VerktygStyckKost | ZtBaseCurrAmount | 14 | 2 | money
Tool type | VerktygsTyp | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: vy Tools


Tools - search - work table (vyw)

Work table for use when searching for where a tool is used.
This can be:
- for an item (tool for a purchased item)
- on the tool list of an item (tool for a purchased item)
- for an operation
- on the tool list of an operation

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Sequence no. | LopNr | ZtLong | 10 |  | int
Operation no. | OpNr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Tools | Verktyg | ztString | 16 |  | varchar
List of tools | VerktygsLista | ztString | 35 |  | varchar


Tools included in calculation (opkv)

Used in the detailed calculation for reporting the various tools involved in an operation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Number of tools | AntalVerktygVidTillv | ZtDecimal73 | 8 | 3 | float
Calculation version no. | ArkVersion | ZtLong | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calculation item | KalkArtNr | ztString | 30 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tools | Verktyg | ztString | 16 |  | varchar
Sequence in list of tools | VerktygslistaSekvNr | ztInteger | 5 |  | smallint
Tool deprec | VyAvskrKost | ZtCost | 16 | 6 | float
Fixed tool cost | VyFastKost | ZtCost | 16 | 6 | float
Var tool cost | VyRorlKost | ZtCost | 16 | 6 | float
Tool setup cost | VyStallKost | ZtCost | 16 | 6 | float
Tool unit cost | VyStyckKost | ZtCost | 16 | 6 | float


Tools, calculation (vyk)

Tools.
Calculations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Calculation version no. | ArkVersion | ZtLong | 4 |  | int
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Sequence number | ConnDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calculation item | KalkArtNr | ztString | 30 |  | varchar
Calculation on quantity | KalkylPaAntal | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Total tool depr | TotVyAvskrKost | ZtCost | 16 | 6 | float
Total tool fix cost | TotVyFastKost | ZtCost | 16 | 6 | float
Total tool var cost | TotVyRorlKost | ZtCost | 16 | 6 | float
Total tool setup cost | TotVyStallKost | ZtCost | 16 | 6 | float
Total tool unit cost | TotVySTyckKost | ZtCost | 16 | 6 | float
Tools | Verktyg | ztString | 16 |  | varchar


Trading areas (xn5)

Definition of trading areas for grouping/classifying companies in the company table.

The sales module determines the trading area for each company:
- customs duty for calculating item prices,
- duty/ton for calculating item prices,
- check against item source EU.

Export and import within the trade area EU are included in the Intrastat reports.

The following standard records exist. Do not alter/delete:

Trading area (HandelsOmrkod) | Trading area (HandelsOmrBeskr)
1 | EU
2 | EEA
3 | ASIA
99 | Miscellaneous

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Duty/ton | AvgiftTonKod | ztBoolean |  |  | char
Item origin | CheckArtUrsprung | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Trading area | HandelsOmrBeskr | ztString | 50 |  | varchar
Trading area | HandelsOmrkod | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Calculate customs duties | TullKostnKod | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xn5 Trading areas


Transaction log for replication (RepL)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Change column | chngcol | ztString | 7000 |  | varchar
Database | DbNameWho | ztString | 30 |  | varchar
This field is used in the table as follows: |
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Primary key | pkey | ztString | 255 |  | varchar
Replikeringsdata | repdata | ztBlob | 1 |  | varchar
Job number | repljob | ZtLong | 10 |  | int
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Identity | sqlidentity | ZtLong | 10 |  | int
Table name | tablename | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: Repl Replication log


Transaction types, journal entry (xfk)

Definition of the transaction types that can occur in journal entry.

The following standard records exist. Do not alter/delete:

Transaction type (Foringskod) | Transaction type (ForKBeskr) | Description
1 | General ledger | Can be used to create a voucher in the general ledger.
2 | Customer invoice | Can be used to create a debit invoice for a customer.
3 | Supplier invoice | Can be used to create an invoice from a supplier.
4 | Incoming customer payment | Can be used to create an incoming payments journal.
5 | Payment of supplier invoice | Can be used to create an outgoing payments journal.
6 | Advance from customer | Can be used to create a credit invoice for a customer with an on-account invoice type.
7 | Advance to supplier | Can be used to create a credit invoice from a supplier.
8 | Difference posting AR | This is used internally by Jeeves for posting deductions and early settlement discounts in the accounts receivable.
9 | Difference posting AP | This is used internally by Jeeves for posting deductions and early settlement discounts in the accounts payable.
10 | Cash transactions | Can be used to create a cash transaction in the function for cash book processing.
11 | Advance invoice | Can be used to create a debit invoice to a customer using invoice type On-account invoice.
12 | Cash-/bankbook | Can be used to create a cash or bank book transaction in the function for cash book processing.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Transaction type | Foringskod | ztInteger | 3 |  | smallint
Transaction type | ForKBeskr | ztString | 50 |  | varchar
Entry layer | Forlayer | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xfk Transaction types, journal entry


Transactions for replication (RepS)

Table of transactions that will be replicated in the web server (called the "Jeeves Light" database).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Change column | chngcol | ztString | 7000 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Innehåller textfält | isblob | ztchar | 1 |  | char
Signature | PersSign | ztString | 30 |  | varchar
Primary key | pkey | ztString | 255 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Replikeringsdata | repdata | ztBlob | 1 |  | varchar
Replication status | replicatestatus | ztString | 1 |  | varchar
Job number | repljob | ZtLong | 10 |  | int
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Table name | tablename | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: Reps Replication data


Transfer matrix (WMS_TransitMatrix)

Definition of if an assignment will be rerouted to a transfer MHA on the way to its final destination according to their:

- inventory location
- assignment type
- assignment sub type
- from MHA
- to MHA

It is optional to enter assingment type, assignment sub type, from MHA and to MHA but inventory location and transfer MHA is mandatory.

An example:

A SKU is received into inventory and a transfer assignment is created. During the creation of the assignment the system checks if the assignment parameters matches a record in this program. In this case we can say that the SKU was created in the MHA Rec01 which is a goods receiving area. The received item is stored in the MHA Pick01 and this will be the final destination of the assignment.

If a matching record is found in this program the to MHA of the assignment will be set to the transfer MHA from this program (for example Tr01). Otherwise the to MHA will be the same as the final destination (Pick01).

All assignments will have a final destination and when the final step in each assignment is performed (a SKU or TU is unloaded at an area or location) the system will check if the unloading location is the final destination of the assignment. If this is the case the assignment is finished and we are done. If this is not the case the assignment is finished but a new transfer assignment is created from the current location to the final destination and in this process the system checks this program for transfer MHAs. Therefore it is possible to define several transfer MHAs between two locations in an inventory location.

When the system checks if a transfer MHA should be used it checks the matrix in the following order:

Order Assignment type Assignment sub type From MHA To MHA

1 X X X X 2 X X X NULL 3 X X NULL X 4 X X NULL NULL 5 X NULL X X 6 X NULL X NULL 7 X NULL NULL X 8 X NULL NULL NULL 9 NULL NULL X X 10 NULL NULL X NULL 11 NULL NULL NULL X 12 NULL NULL NULL NULL

X means that a value is entered for the term in the matrix and the value matches the value of the current assignment.
NULL means that a value for the term in the matrix is not entered and then no check is done against the corresponding term of the current assignment.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
MHA, from | AssFromMha | ztString | 5 |  | varchar
Sub type | AssSubTypeCode | ztInteger | 3 |  | smallint
MHA, to | AssToMHA | ztString | 5 |  | varchar
MHA, transfer | AssTransitMHA | ztString | 5 |  | varchar
Type | AssTypeCode | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_TransitMatrix Transfer matrix


Transfer sales forecast per sales group -> item forecast (FsgPrgGrp2Arpr)

Table for defining which sales forecast groups will be transferred to the item forecast.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Desc sales prg for item | DefineringFsgPrgTillArtikelBeskr | ztString | 80 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Forecast version | PrognosVer | ZtLong | 4 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int

    This table is the main table in the following programs:

    Program: FsgPrgGrp2Arpr Sales group forecast -> item forecast


Transfer sales forecast per sales group -> item forecast (FsgPrgGrp2Arpr_FsgPrgGrp)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Identitetskolumn | ConnToSQLIDENTITY | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Forecast group, sales | FsgPrgGrp | ztString | 8 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int


Transfer status logtrade (LogtradeTransferStatus)

Table for status for transfer to lograde. As long as the logtrade transfer service is running the date is updated every fifth minute. The date is to check if the service is running when starting transfer to logtrade from Jeeves.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Status Date | LogTradeDate | ztDateTime |  |  | datetime
TransferId | LogtradeTransferId | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Transition kind (xwtk)

In this table Jeeves Information Systems sets up the types of transitions that can occur in the workflows in Workflow.

The following standard records exist. Do not alter/delete:

Transition condition (transitionkind) | Transition condition (transitionkindd) | Description
0 | No | A flow route has no condition as default, which means that the flow route will ALWAYS be used.
1 | Accept | Choose condition type Accept for flow routes that will only be used if a prior activity is APPROVED by the user.
2 | Reject | Choose condition type Reject for flow routes that will only be used if a prior activity is REJECTED by the user.
3 | SQL Server condition | Choose condition type SQL Server condition for flow routes that will only be used when a specified condition is fulfilled. You specify the condition in the field 'Condition' (TransitCondition).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Transition condition | TransitionKind | ztInteger | 5 |  | smallint
Transition condition | TransitionKindD | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: xwtk Transition kind


Translation table details (str)

Definition of translations that can be used on conversion of, for example, external accounting material for Jeeves records...

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Translate from | Ksource | ztString | 30 |  | varchar
Translation table | KTabell | ztString | 30 |  | varchar
Translate to | KTarget | ztString | 30 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar


Translations for mobile clients (WMS_Translation)

Definition of translations for the different labels, buttons, menus and other controls in the mobile clients for WMS.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
@zPrompt=null | Term | ztNString | 256 |  | varchar
Term key | TermKey | ztString | 128 |  | varchar
Translation | TermTranslation | ztString | 255 |  | varchar
Language code | zlanguage | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: WMS_Translation Translations for mobile clients


Translations in menu (lmenus)

Language DB file of pmu's.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Menu key | MenuKey | ZtLong | 8 |  | int
Parent | MenuParent | ZtLong | 8 |  | int
Menu text | menutext | ztString | 60 |  | varchar
Menu unique id | MenuUnitid | ztString | 30 |  | varchar
Own description | OwnDescr | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Menu ID | UsrDefMenuid | ztString | 20 |  | varchar
Language code | zlanguage | ztInteger | 4 |  | smallint


Translations project (prjt)

Translation table of project at auto posting and auto allocation in the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allocate to project | FordTillPrj | ztString | 10 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Translation group | OversattnGrp | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xPrjt Translation, project


Transport ID types, EDIFACT (x2h)

Table of transport types in accordance with the EDIFACT standard.

The following standard records exist. Do not alter/delete:

Transport ID code EDIFACT (TransportIdKod) | Transp ID EDIFACT (TransportIdBeskr)
CC | Container
RR | Train car
SW | Swap body
TE | Trailer
ZZ | Truck

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Transp ID EDIFACT | TransportIdBeskr | ztString | 50 |  | varchar
Transport ID code EDIFACT | TransportIdKod | ztString | 3 |  | varchar

    This table is the main table in the following programs:

    Program: x2h Transport ID types, EDIFACT


Transport methods, Intrastat (x2g)

Table for transport methods in accordance with Intrastat terminology.

The following standard records exist. Do not alter/delete:

Intrastat, transport method (TranspSattKod) | Transp method, Intrastat (TranspSattBeskr)
1 | Sea transport
2 | Rail transport
3 | Road transport
4 | Air transport
5 | By post
7 | Fixed transport installations
8 | Transport on domestic waterway
9 | Own transport

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Transp method, Intrastat | TranspSattBeskr | ztString | 50 |  | varchar
Intrastat, transport method | TranspSattKod | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: Xx2g Transport methods, Intrastat


Transport resources (xtrr)

Definition of the company's transport resource types, such as lorries, containers etc., with capacity information, used when creating shipment plans for the WMS-module.

There is no automation in the capacity fields; they only serve as input for the shipment planner(s).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Transport resource | TranspResrcDescr | ztString | 50 |  | varchar
Height | TranspResrcHeight | ZtDecimal73 | 8 |  | decimal
Length | TranspResrcLength | ZtDecimal73 | 8 |  | decimal
Max net weight | TranspResrcNetWeight | ZtDecimal73 | 14 | 3 | decimal
Transport resource | TranspResrcType | ztInteger | 4 |  | smallint
Max volume | TranspResrcVolume | ZtDecimal73 | 14 | 3 | decimal
Max gross weight | TranspResrcWeight | ZtDecimal73 | 14 | 3 | decimal
Width | TranspResrcWidth | ZtDecimal73 | 8 |  | decimal

    This table is the main table in the following programs:

    Program: xtrr Transport resources


Transport resources, language (xtrrs)

Language translations of descriptions of the company's transport resource types.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint
Transport resource | TranspResrcDescr | ztString | 50 |  | varchar
Transport resource | TranspResrcType | ztInteger | 4 |  | smallint


Transport route (xtr)

Definition of the transport routes used by the company for dispatches to customers.

A transport route comprises the following terms:
- Country
- Dispatch method
- Carrier

You can also specify information about weight and volume and fixed dispatch dates for every transport route. If this data is common for several transport routes when a certain carrier is used, the equivalent data can be specified in and retrieved from the program 'Carrier' (x2t).

The country code and dispatch method for the customer order are checked against this information and Jeeves automatically works out which carrier will be hired for the dispatch and retrieves the carrier in question to the order header. If there is a choice of several carriers, this must be made by the user.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Specified gross wght | BruttoVikt | ztFloat | 10 | 3 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
From date | FromDatum | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Internal lead time days | InternLedTid | ztInteger | 3 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Calender created | KalenderCreatedDt | ztDateTime |  |  | datetime
Calendar number | KalenderNr | ztInteger | 2 |  | smallint
Default transport | KodDefaultTransport | ztBoolean |  |  | char
Country | LandsKod | ztString | 3 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Time limit, dispatch | TimeLimit | ztTime | 5 |  | datetime
Valid to date | TomDatum | ztDate |  |  | datetime
Carrier code | TransportorsKod | ztString | 17 |  | varchar
Carrier name | TransportorsNamn | ztString | 35 |  | varchar
Height | VolHeight | ztInteger | 4 |  | smallint
Length | VolLength | ztInteger | 4 |  | smallint
Volume | Volume | ztFloat | 10 | 3 | float
Width | VolWidth | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: xxtr Transport route


TU content pick data (WMS_TUContentPickData)

TU (transport unit) identity.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Use/Best before | BastForeDatum | ztDate |  |  | datetime
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
FIFO date | FifoDateTime | ztDateTime |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Reason code | PalletSKUCreateReasonCode | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Pick before date | PickBeforeDateTime | ztDate |  |  | datetime
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sequence number | SKUPalletContSeq | ztInteger | 3 |  | smallint
SKU ID | SKUPalletId | ztString | 35 |  | varchar
Sequence number, TU | TUPalletContSeq | ztInteger | 3 |  | smallint
TU ID | TUPalletId | ztString | 35 |  | varchar


TU content status code (WMS_PalletContTUStatusCode)

Code for transport package content status. Specifies status for contents in transport package.

The following standard records exist. Do not alter/delete:

Status, TU content (PalletContTUStatusCode) | Description (PalletContStatusDesc) | Description
200 | Created | TU content created
210 | Picking in progress | Picking of TU content in progress
220 | Picked | TU content have been picked

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Description | PalletContStatusDesc | ztString | 50 |  | varchar
Status, TU content | PalletContTUStatusCode | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_PalletContTUStatusCode TU content status code


TU create reason code (WMS_PalletTUCreateReasonCode)

NULL

The following standard records exist. Do not alter/delete:

PalletTUCreateReasonCode (PalletTUCreateReasonCode) | PalletCreateReasonDesc (PalletCreateReasonDesc)
200 | Order
201 | Split
210 | Manufacturing order

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Description | PalletCreateReasonDesc | ztString | 50 |  | varchar
Create reason code, TU | PalletTUCreateReasonCode | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_PalletTUCreateReasonCode TU create reason code


TU status code (WMS_PalletTuStatusCode)

Code for package status. Specifies status for package.

The following standard records exist. Do not alter/delete:

Status (PalletStatusCode) | Description (PalletStatusDesc) | Description
200 | Created | TU is created
210 | Picking in progress | TU is being picked
220 | Picked | TU is picked
230 | Cancelled | TU is cancelled
299 | Dispatched | TU is dispatched

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Status | PalletStatusCode | ztInteger | 3 |  | smallint
Description | PalletStatusDesc | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_PalletTUStatusCode TU status code


Type of bin (xhyt)

Definition of types of bins found.

No bin types are defined on delivery. You fill in the table yourself if your company applies bin management for received deliveries. The type can be an item type or size code which is also specified for the items and which can be used for automatic bin location to find suitable bins for items. The type can also be a customer number if customer specific bins are applied, or another suitable bin coding.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Type of bin | LagPlatsTyp | ztString | 6 |  | varchar
Type of bin | LagPlatsTypBeskr | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xhyt Bin types


Type of log of final posting PO (AccountsPayable_PO_2_GL_TranType)

Type of transaction during final posting of supplier invoice with linked order.
When closing the invoice, extra rows for purchase variances, rounding variances and inventory adjustments using FIFO are created automatically.

The following standard records exist. Do not alter/delete:

Invc match, trans type GL (AP_PO_2_GL_TranType) | Invc match, trans type GL (AP_PO_2_GL_TranTypeDescr)
120 | Counter-booking interim account, arrival->final approval
160 | Difference between invoice and checked value (rounding etc.)
210 | Inventory, received deliv
230 | Invtry adjustment, average cost
240 | Counter-booking of inventory adjustment, average cost
260 | Inventory adjustment of received deliv (FIFO)
310 | Purchase price differences
320 | Material overhead cost
810 | Adjustment of previously picked customer order
812 | Counter-booking adjustment of previously picked customer order
910 | Inventory value adjustment for earlier transaction
920 | Counter-booking of inventory value adjustment on earlier transaction

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Invc match, trans type GL | AP_PO_2_GL_TranType | ztInteger | 5 |  | smallint
Invc match, trans type GL | AP_PO_2_GL_TranTypeDescr | ztString | 100 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Type of treatment for excess invtry (xovl)

Definition of alternatives for handling excess inventory. An alternative can be chosen for each item/inventory location (table ARS).

The following standard records exist. Do not alter/delete:

Excess invtry ctrl (AnmodanOverLagerEnl) | Excess invtry ctrl (AnmodanOverLagerEnlBeskr) | Description
1 | Excess inventory, SS | Excess inventory is tested against safety stock (as requisitions against demand).
2 | Excess invtry, SS+EOQ | Excess inventory is tested against safety stock + economic order quantity.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Excess invtry ctrl | AnmodanOverLagerEnl | ztInteger | 5 |  | smallint
Excess invtry ctrl | AnmodanOverLagerEnlBeskr | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xovl Type of treatment for excess invtry


Unique ID and Spid (SFR_afftmp)

Temporary table for calculations.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Spid | SFRSpid | ztInteger | 5 |  | smallint
Unique ID | SFRUniqueId | ztUniqueIdentifier | 38 |  | varchar


Unit codes (xen)

Definition of the units used to specify per item in which unit it is stocked and/or purchased.

You can also fill in the desired translation of each unit description in the embedded window 'Unit codes, language' (table xenb).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Unit code time | DefaultTimeUnit | ztBoolean |  |  | char
EDI unit | EdiEnhet | ztString | 3 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Unit descr | EnhetsKodBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: Xxen Unit codes


Unit codes (WMS_V_UOM)

Alphanumeric code for unit of measure, e.g. Pc for Piece, Doz for Dozen, 144P for 144-pack and FP or 1440P for Full pallet of 1440 peices.

Note! The box calculation that creates picking assignments only considers a unit of measure as pickable if it is the base unit of the current item or if its conversion factor is greater than 1 and multiply quantity is checked.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Decimal places | AltEnhetAntDec | ztInteger | 2 |  | smallint
Multiply quantity | AltEnhetMultKod | ztBoolean |  |  | char
Conversion factor | AltEnhetOmrFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Unit code | UOM | ztString | 10 |  | nvarchar
Unit descr | UOMDesc | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_UOM Unit codes


Unit codes (WMS_V2_UOM)

Alphanumeric code for unit of measure, e.g. Pc for Piece, Doz for Dozen, 144P for 144-pack and FP or 1440P for Full pallet of 1440 peices.

Note! The box calculation that creates picking assignments only considers a unit of measure as pickable if it is the base unit of the current item or if its conversion factor is greater than 1 and multiply quantity is checked.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Decimal places | AltEnhetAntDec | ztInteger | 2 |  | smallint
Multiply quantity | AltEnhetMultKod | ztBoolean |  |  | char
Conversion factor | AltEnhetOmrFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Unit code | UOM | ztString | 10 |  | nvarchar
Unit descr | UOMDesc | ztString | 50 |  | varchar


Unit codes (WMS_V3_UOM)

Alphanumeric code for unit of measure, e.g. Pc for Piece, Doz for Dozen, 144P for 144-pack and FP or 1440P for Full pallet of 1440 peices.

Note! The box calculation that creates picking assignments only considers a unit of measure as pickable if it is the base unit of the current item or if its conversion factor is greater than 1 and multiply quantity is checked.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Decimal places | AltEnhetAntDec | ztInteger | 2 |  | smallint
Multiply quantity | AltEnhetMultKod | ztBoolean |  |  | char
Conversion factor | AltEnhetOmrFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Company | ForetagKod | ztInteger | 4 |  | smallint
Unit code | UOM | ztString | 10 |  | nvarchar
Unit descr | UOMDesc | ztString | 50 |  | varchar


Unit codes, language (xenb)

Translations of the unit descriptions used to specify per item in which unit it is stocked and/or purchased.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Unit code | EnhetsKod | ztString | 4 |  | varchar
Unit descr | EnhetsKodBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language | SprakKod | ztInteger | 3 |  | smallint


Units per item (WMS_V2_ItemUOM)

Alphanumeric code for the item, BOM, fixed asset, or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Decimal places | AltEnhetAntDec | ztInteger | 2 |  | smallint
Multiply quantity | AltEnhetMultKod | ztBoolean |  |  | char
Conversion factor | AltEnhetOmrFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Stock unit | StockUnit | ztBoolean |  |  | nvarchar
Unit code | UOM | ztString | 10 |  | nvarchar
Unit descr | UOMDesc | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_ItemUOM2 Units per item


Units per item (WMS_V_ItemUOM)

Alphanumeric code for the item, BOM, fixed asset, or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Decimal places | AltEnhetAntDec | ztInteger | 2 |  | smallint
Multiply quantity | AltEnhetMultKod | ztBoolean |  |  | char
Conversion factor | AltEnhetOmrFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Stock unit | StockUnit | ztBoolean |  |  | nvarchar
Unit code | UOM | ztString | 10 |  | nvarchar
Unit descr | UOMDesc | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: WMS_ItemUOM Units per item


Unload, task (WMS_V_MU_UnLoadPalletLine)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
ID | AssId | ZtLong | 9 |  | int
X pos, to | AssToLocXPos | ztString | 5 |  | varchar
Y pos, to | AssToLocYPos | ztString | 5 |  | varchar
MHA, to | AssToMha | ztString | 5 |  | varchar
Rack, to | AssToRack | ztString | 5 |  | varchar
Type | AssTypeCode | ztInteger | 3 |  | smallint
Check digits | CheckSum | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
X Pos. | LocXPos | ztString | 5 |  | varchar
Y Pos. | LocYPos | ztString | 5 |  | varchar
MHA | Mha | ztString | 5 |  | varchar
Mobile unit | MobileUnit | ztString | 5 |  | varchar
ID | PalletId | ztString | 35 |  | varchar
Type | PalletTypeCode | ztInteger | 3 |  | int
Pallet unit type | PalletUnitType | ztString | 5 |  | varchar
Rack | Rack | ztString | 5 |  | varchar
ID | TaskIId | ZtLong | 9 |  | int

    This table is the main table in the following programs:

    Program: WMS_MU_UnLoadPalletLine Unload, task


User Access to companies (view) (vCompanyAccess)

This table is used to enter user access to companies when using multi companies.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagkodA | ztInteger | 4 |  | smallint
Group | Grupp | ztInteger | 4 |  | smallint
Group ID | jvsSiteGroupId | ZtLong | 6 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: CompanyAccess2 View user access to companies


User acess to companies (CompanyAccess)

This table is used to enter user access to companies when using multi companies.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Group | grupp | ztInteger | 4 |  | smallint
Group ID | jvssitegroupid | ZtLong | 6 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


User defined program links (pgc)

Program links from a specific program or generally from all programs that are created using the option ‘Programs/Create link…’

Choose from personal/global: Yes
Per company: No

(This table replaces table Vpgc.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Link | Connection |  |  |  | @DataType=NULL
Global settings | Global |  |  |  | @DataType=NULL
This field is used in the table as follows: |
Group | Grupp |  |  |  | @DataType=NULL
Name | Name |  |  |  | @DataType=NULL
Program node | Node |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Program | Pgm |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL


User defined programs in package solution (JvsPackageCustomPrograms)

Customers own programs that are included in a package solution. The tables on which the programs are based must be added as database tables in the package solution.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Program name in Jeeves | JvsProgramName | ztString | 40 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Solution ID | SolutionID | ZtLong | 10 |  | int


User file (sy2)

System data for each logged-in user, for personnel within your own company.
There must be one record in this table for each licensed Jeeves user.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Adjustment for local time | AdjustMinutes2GetLocalTime | ztInteger | 5 |  | smallint
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Acquisition method | AnskaffningsSatt | ztInteger | 2 |  | smallint
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Approval limit | attestlimit | ZtBaseCurrAmount | 18 | 2 | money
Access level | authorizecode | ztString | 4 |  | varchar
Status at order close | AutoOrderEnding | ztString | 1 |  | varchar
Automatic pricing | autopris | ztBoolean |  |  | char
Posting template | AutoRegel | ztString | 4 |  | varchar
This field is used in the table as follows: |
Posting tmplt, final approval | AutoRegelS | ztString | 4 |  | varchar
Workload type | Belaggningskod | ztInteger | 2 |  | smallint
Bundle no. | Buntnr | ZtLong | 9 |  | int
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Print templ, cash rec | CashBalanceTemplate | ztString | 30 |  | varchar
Cash configuration | CashConfigCode | ztInteger | 5 |  | smallint
CCU | CCU | ztBoolean |  |  | char
CDD_From_Lang | CDD_From_Lang | ztInteger | 5 |  | smallint
Test, create PO/MO | CheckBestGen | ztInteger | 5 |  | smallint
CRM user | CRM | ztBoolean |  |  | char
CTI user | CTI | ztBoolean |  |  | char
Login ID/name | DbLoginId | ztString | 128 |  | varchar
Mobile Database server | dbserver | ztString | 40 |  | varchar
@zPrompt=null | DebugMsg | ztBoolean |  |  | char
Default vouch row 0-amount | DefAnswer | ztBoolean |  |  | char
Default company | DefForetagKod | ztInteger | 4 |  | smallint
Today's date counterpost | DefVerRevDate | ztBoolean |  |  | char
Availab chk, Order store | DispCheckInOrderStore | ztBoolean |  |  | char
File/dir | DokDir | ztString | 255 |  | varchar
Check-out directory | DokDirCheckOut | ztString | 255 |  | varchar
EDM user | EDM | ztBoolean |  |  | char
Invoice no. series group | FakturaNrGrupp | ztInteger | 3 |  | smallint
Invoiced by | FakturerareKod | ztInteger | 2 |  | smallint
This field is used in the table as follows: |
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Close order, CO entry | GoToOrderEnding1 | ztInteger | 1 |  | smallint
Close order, picking | GoToOrderEnding2 | ztInteger | 1 |  | smallint
Close order, release | GoToOrderEnding3 | ztInteger | 1 |  | smallint
Group | grupp | ztInteger | 4 |  | smallint
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Invoicing allowed | InvoiceAllowed | ztBoolean |  |  | char
Group signature | KodGruppSignatur | ztBoolean |  |  | char
Package no. (alpha), prefix | KolliNrAlfaPrefix | ztString | 30 |  | varchar
Posting method | KontRegKod | ztString | 2 |  | varchar
Credit memo, issuer | KreditMemoUtfardare | ztBoolean |  |  | char
Interim cost centre | KstInterimsBokning | ztString | 8 |  | varchar
Balance sheet CC | KstReskSaldo | ztString | 8 |  | varchar
Cust no, cash | KundNrKontant | ztCompanyNo | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Last bundle number | LastBuntnr | ZtLong | 10 |  | int
Voucher no. type | manver | ztInteger | 2 |  | smallint
Max bundle no. | Maxbuntnr | ZtLong | 10 |  | int
MRP batch -> Sign/mgr | NE_PlanAnsv | ztString | 8 |  | varchar
Open a closed claim | OpenClosedClaim | ztBoolean |  |  | char
Optional items, Order store | OptItemsInOrderStore | ztBoolean |  |  | char
Order status | OrdStat | ztInteger | 2 |  | smallint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Cash terminal user | POS | ztBoolean |  |  | char
Reporter | Rapportor | ztBoolean |  |  | char
Read user | ReadOnly | ztBoolean |  |  | char
Print template, receipt | ReceiptTemplate | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Name | RespNamn | ztString | 50 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Auto balance update | SaldoOnLine | ztBoolean |  |  | char
Salesperson | Saljare | ztString | 6 |  | varchar
Joint purchase (allowed) | SamInkopMark | ztBoolean |  |  | char
Show forecast in the planning list | ShowFrcstInPlan | ztBoolean |  |  | char
No order row history | ShowOrderRadHistorik | ztBoolean |  |  | char
Show row status | ShowOrderRadStatus | ztInteger | 2 |  | smallint
Language | SprakKod | ztInteger | 3 |  | smallint
Start invoice print | StartInvoicePgm | ztInteger | 5 |  | smallint
System administrator | SysAdmAllowed | ztBoolean |  |  | char
Permitted TA-transport | TA_allowed | ztBoolean |  |  | char
TA suffix | TA_FileSuffix | ztString | 3 |  | varchar
TA-system parameters | Ta_SysPid | ztInteger | 5 |  | smallint
Time zone code | TimeZoneCode | ztInteger | 5 |  | smallint
Manuf.order on-line | TiOnLine | ztBoolean |  |  | char
Print block ext doc | UtskrDokSparr | ztBoolean |  |  | char
Valid to use | ValidToUse | ztBoolean |  |  | char
Voucher no. group | VerNrGrupp | ztString | 6 |  | varchar
As of fiscal year | VisaFromRedovisnAr | ztInteger | 5 |  | smallint
Show from ord status | VisaOStockFromOrdStat | ztInteger | 5 |  | smallint
Show to ord status | VisaOStockTomOrdStat | ztInteger | 5 |  | smallint
Up to fiscal year | VisaTomRedovisnAr | ztInteger | 5 |  | smallint
Visible in Office | VisibleInOffice | ztBoolean |  |  | char
Warning! excess delivery | WarningAtDeliver | ztBoolean |  |  | char
Workflow user | Wflw | ztBoolean |  |  | char
WMS | WMS | ztBoolean |  |  | char
E-mail address | YndEmailAddr | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: Sy2_1 Time reporting

    Program: Xsy2 System data person, own company


User file per company (sy2m)

User file per signature and company

In this table you can enter any deviating system data per signature and company if there are several companies in the same database.

Information entered in this table takes priority over the information entered in the table ‘System data for each logged-in user’ (Sy2).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Acquisition method | AnskaffningsSatt | ztInteger | 2 |  | smallint
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Approval limit | attestlimit | ZtBaseCurrAmount | 18 | 2 | money
Access level | authorizecode | ztString | 4 |  | varchar
Status at order close | AutoOrderEnding | ztString | 1 |  | varchar
Automatic pricing | autopris | ztBoolean |  |  | char
Posting template | AutoRegel | ztString | 4 |  | varchar
This field is used in the table as follows: |
Posting tmplt, final approval | AutoRegelS | ztString | 4 |  | varchar
Workload type | Belaggningskod | ztInteger | 2 |  | smallint
Bundle no. | Buntnr | ZtLong | 9 |  | int
Business unit ICT | BusinessUnit | ztString | 8 |  | varchar
Print templ, cash rec | CashBalanceTemplate | ztString | 30 |  | varchar
Cash configuration | CashConfigCode | ztInteger | 5 |  | smallint
Test, create PO/MO | CheckBestGen | ztInteger | 5 |  | smallint
Default vouch row 0-amount | DefAnswer | ztBoolean |  |  | char
Today's date counterpost | DefVerRevDate | ztBoolean |  |  | char
Availab chk, Order store | DispCheckInOrderStore | ztBoolean |  |  | char
File/dir | DokDir | ztString | 255 |  | varchar
Check-out directory | DokDirCheckOut | ztString | 255 |  | varchar
Invoice no. series group | FakturaNrGrupp | ztInteger | 3 |  | smallint
Invoiced by | FakturerareKod | ztInteger | 2 |  | smallint
This field is used in the table as follows: |
Company | ForetagKodSy2M | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Close order, CO entry | GoToOrderEnding1 | ztInteger | 1 |  | smallint
Close order, picking | GoToOrderEnding2 | ztInteger | 1 |  | smallint
Close order, release | GoToOrderEnding3 | ztInteger | 1 |  | smallint
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Invoicing allowed | InvoiceAllowed | ztBoolean |  |  | char
Group signature | KodGruppSignatur | ztBoolean |  |  | char
Package no. (alpha), prefix | KolliNrAlfaPrefix | ztString | 30 |  | varchar
Posting method | KontRegKod | ztString | 2 |  | varchar
Credit memo, issuer | KreditMemoUtfardare | ztBoolean |  |  | char
Interim cost centre | KstInterimsBokning | ztString | 8 |  | varchar
Balance sheet CC | KstReskSaldo | ztString | 8 |  | varchar
Cust no, cash | KundNrKontant | ztCompanyNo | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Last bundle number | LastBuntnr | ZtLong | 10 |  | int
Voucher no. type | manver | ztInteger | 2 |  | smallint
Max bundle no. | Maxbuntnr | ZtLong | 10 |  | int
MRP batch -> Sign/mgr | NE_PlanAnsv | ztString | 8 |  | varchar
Optional items, Order store | OptItemsInOrderStore | ztBoolean |  |  | char
Order status | OrdStat | ztInteger | 2 |  | smallint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Print template, receipt | ReceiptTemplate | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Name | RespNamn | ztString | 50 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Auto balance update | SaldoOnLine | ztBoolean |  |  | char
Salesperson | Saljare | ztString | 6 |  | varchar
Joint purchase (allowed) | SamInkopMark | ztBoolean |  |  | char
Show forecast in the planning list | ShowFrcstInPlan | ztBoolean |  |  | char
No order row history | ShowOrderRadHistorik | ztBoolean |  |  | char
Show row status | ShowOrderRadStatus | ztInteger | 2 |  | smallint
Language | SprakKod | ztInteger | 3 |  | smallint
Start invoice print | StartInvoicePgm | ztInteger | 5 |  | smallint
Manuf.order on-line | TiOnLine | ztBoolean |  |  | char
Print block ext doc | UtskrDokSparr | ztBoolean |  |  | char
Voucher no. group | VerNrGrupp | ztString | 6 |  | varchar
As of fiscal year | VisaFromRedovisnAr | ztInteger | 5 |  | smallint
Show from ord status | VisaOStockFromOrdStat | ztInteger | 5 |  | smallint
Show to ord status | VisaOStockTomOrdStat | ztInteger | 5 |  | smallint
Up to fiscal year | VisaTomRedovisnAr | ztInteger | 5 |  | smallint
Warning! excess delivery | WarningAtDeliver | ztBoolean |  |  | char
E-mail address | YndEmailAddr | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: Xsy2m System data person per company


User file, approval sign (view) (vwsy2)

NULL

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Posting tmplt, final approval | AutoRegelS | ztString | 4 |  | varchar
Login ID/name | DbLoginId | ztString | 128 |  | varchar
Group | grupp | ztInteger | 4 |  | smallint
Group signature | KodGruppSignatur | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Voucher no. type | manver | ztInteger | 2 |  | smallint
Order status | OrdStat | ztInteger | 2 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Name | RespNamn | ztString | 50 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Layer | SelLayer | ztInteger | 2 |  | int
Voucher no. group | VerNrGrupp | ztString | 6 |  | varchar


User functions (zufu)

Functions such as those linked to the function buttons in Jeeves, User functions (which you will also find in the file Appl.ufu).

Choose from personal/global: No
Per company: No

(This table replaces table Vzuf.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Code | Code | ztBlob | 1 |  | text
Data type | DataType | ztString | 30 |  | varchar
Function name | FuncName | ztString | 25 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Settings | Props | ztBlob | 1 |  | text
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xzufu User functions


User groups (JvsSiteGroups_Tmp)

Temporary working table for JvsSiteGroups

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Integer 1 | dataint1 | ztInteger | 5 |  | smallint
Integer 2 | dataint2 | ztInteger | 5 |  | smallint
Command | datavarchar1 | ztString | 255 |  | nvarchar
Activity | datavarchar2 | ztString | 255 |  | nvarchar
Level | GroupLevel | ztInteger | 5 |  | smallint
Allow settings | JvsSiteAllowChange | ztBoolean |  |  | char
Group ID | JvsSiteGroupId | ZtLong | 6 |  | int
Group name | JvsSiteGroupName | ztString | 128 |  | nvarchar
Group name (lang) | jvssitegroupname_lang | ztString | 128 |  | nvarchar
Group type | JvsSiteGroupType | ztInteger | 5 |  | smallint
Unique package ID | JvsSitePackageUniqueId | ztString | 40 |  | nvarchar
Parent group | JvsSiteParentId | ZtLong | 6 |  | int
Priority | JvsSitePriority | ztInteger | 4 |  | smallint
Unique ID | JvsSiteUniqueId | ztString | 40 |  | nvarchar
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Unique ID | TmpUniqueId | ztString | 50 |  | nvarchar


User groups (grp)

Definition of groups of users in Jeeves. This is primarily used for setting database restrictions for user groups. For other group settings, use the Groups program (jvssitegroups).

If you create a new user in this program the user will be connected to the group. If you want to connect an existing user to the group you have to use the System data person, own company program (Xsy2) and assign the group id to the user.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Group | grupp | ztInteger | 4 |  | smallint
Group | gruppbeskr | ztString | 35 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: grp Groups, authorization


User groups (view) (vJvsSiteGroups)

Numeric ID of group (role, user group, setting group etc.) to which settings can be connected.

Note that the following group numbers have a special, built in meaning:
- Group 0 refers to personal settings
- Group 9999 refers to global settings for all users

Besides these, groups can be created and numbered according to your own needs.

This number works as a primary key to identify the group in a specific site database. In order to be able to export and import packages of groups between different environments, this number is re-generated on records to be imported that have an id that is already in use.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Group ID | JvsSiteGroupId | ZtLong | 6 |  | int
Group name | JvsSiteGroupName | ztString | 128 |  | nvarchar


User-defined buttons (JvsSiteUserButtons)

Program/table for viewing and editing settings regarding user-defined buttons, created to launch printouts, searches, or the like.

The program/table can be accessed through an embedded window in the program Setting dimensions/keys (jvssitenodewin) or from Jeeves' menu.

There is also an embedded window for translating button texts and tooltips to other languages in which the system is run.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Tooltip text | JvsSiteHintsDocumentation | ztString | 8000 |  | nvarchar
Code | JvsSiteMacroCode_sub | ztString | 8000 |  | nvarchar
Conn to setting ID | JvsSiteMacroConn2Setting_sub2 | ztString | 8000 |  | nvarchar
Setting name | JvsSiteMacroName_sub1 | ztString | 8000 |  | nvarchar
Id | JvsSiteMacroUniqueId_sub2 | ztString | 8000 |  | nvarchar
Setting ID | JvsSiteNodeWinSettingsID | ZtLong | 10 |  | int
Setting ID (orig) | JvsSiteNodeWinSettingsID_orig | ZtLong | 10 |  | int
Data | JvsSitePropertyData | ztString | 7500 |  | nvarchar
Type | JvsSitePropertyName | ztString | 64 |  | nvarchar
File ID | JvsSiteResID | ztString | 60 |  | nvarchar
Tab ID | JvsSiteTabID | ZtLong | 10 |  | int
Tab ID (orig) | JvsSiteTabID_orig | ZtLong | 10 |  | int
Sequence no. | JvsSiteTabSeq | ztInteger | 5 |  | smallint
Prompt | JvsSiteTermPrompt | ztString | 60 |  | nvarchar
Unique ID | JvsSiteUniqueId | ztString | 40 |  | nvarchar
Name on button | JvsSiteUserButtonName_Lang | ztString | 40 |  | nvarchar
Field ID | JvsSiteWindowFieldID | ZtLong | 11 |  | int
Field ID (orig) | JvsSiteWindowFieldID_orig | ZtLong | 11 |  | int
Startpos X axis | JvsSiteXPos | ZtLong | 10 |  | int
Width | JvsSiteXSize | ZtLong | 10 |  | int
Startpos Y axis | JvsSiteYPos | ZtLong | 10 |  | int
Height | JvsSiteYSize | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | nvarchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | nvarchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | nvarchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: JvsSiteUserButtons User-defined buttons


Users (incl All users group) (UsrAndGlobalView)

Database view containing all groups from the group table (grp) and an extra row for group 9999, All users.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Signature | JvsSiteForUser | ztString | 6 |  | nvarchar
Name | RespNamn | ztString | 50 |  | nvarchar


Validation rules (SFR_rules)

Table for maintenance of the rules in Shop floor control.

You can add records on different levels; company, flow group, manufacturing group and employee. Observe that not all keys are applicable on all levels. Company is the highest level, and there must be a record for each company. When a key value is requested, Jeeves first searches at employee, then manufacturing group, flow group and finally at company level.

If no value has been entered (NULL) the key is not applicable and the system goes up one level to retreive the key.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Bin | Lagplats | ztBinLocation | 20 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | PersSign2 | ztString | 6 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Time report at qty report | SFRAutoCreateAopFromAoq | ztBoolean |  |  | char
Divide machine time | SFRRDivideLabourTime | ztInteger | 5 |  | smallint
Divide man hours | SFRRDivideManhours | ztInteger | 5 |  | smallint
Mtrl rep only current op | SFRRmruOnlyCurrent | ztBoolean |  |  | char
Mtrl rep manually | SFRRmruReporting | ztBoolean |  |  | char
Scrap rep manually | SFRRmruScrapReporting | ztBoolean |  |  | char
Not adjust mtrl issue | SFRRNotAdjustMtrl | ztBoolean |  |  | char
Do not calc breaktime | SFRRNotCalcBreak | ztBoolean |  |  | char
Do not start indirect job | SFRRNotStartOtherWork | ztBoolean |  |  | char
Limit op crew | SFRROpCrewlimit | ztFloat | 15 | 2 | float
Indirect job | SFRROtherWork | ztInteger | 5 |  | smallint
Indirect job time limit | SFRROtherWorkLimit | ztInteger | 5 |  | smallint
Park all active op - indir | SFRRParkJobStartOther | ztBoolean |  |  | char
Report finished op | SFRRReportFinishedOp | ztInteger | 5 |  | smallint
Report only printed WO | SFRRReportOnlyPrinted | ztInteger | 5 |  | smallint
Report previous finished | SFRRReportPrevFinished | ztInteger | 5 |  | smallint
Show WO rem 0 qty | SFRRShowNotRemZero | ztInteger | 5 |  | smallint
Show only printed WO | SFRRShowOnlyPrinted | ztBoolean |  |  | char
Report absolute qty | SFRVabsoluteqty | ztInteger | 5 |  | smallint
Avail check | SFRVAvailCheck | ztInteger | 5 |  | smallint
Change mfgrp at start | SFRVchangepg | ztInteger | 5 |  | smallint
Check if not presence | SFRVcheckattr | ztInteger | 5 |  | smallint
Check if not presence Wrk grp | SFRVcheckattrWrkGrp | ztInteger | 5 |  | smallint
Check reporting if no team | SFRVchecklag | ztInteger | 5 |  | smallint
Active job mfgrp | SFRVcheckworunning | ztInteger | 5 |  | smallint
Active job employee | SFRVcheckworunningperssign2 | ztInteger | 5 |  | smallint
Enter bin at delivery | SFRVEnterBin | ztInteger | 5 |  | smallint
Report ongoing op | SFRVFinishInProcessOp | ztInteger | 5 |  | smallint
Report finish 0 qty | SFRVFinishZeroQty | ztInteger | 5 |  | smallint
Report greater qty | SFRVGreaterqty | ztInteger | 5 |  | smallint
Report interrupt 0 qty | SFRVInterruptZeroQty | ztInteger | 5 |  | smallint
Enter time manual | SFRVManualTime | ztInteger | 5 |  | smallint
Propose BatchNo | SFRVProposeBatchNo | ztInteger | 5 |  | smallint
Propose remaining qty | SFRVProposeRemqty | ztInteger | 5 |  | smallint
Report only qty/pallet | SFRVQtyPerPallet | ztInteger | 5 |  | smallint
Report quantity 0 qty | SFRVQuantityZeroQty | ztInteger | 5 |  | smallint
Question at finish setup | SFRVQuestFinishSetup | ztInteger | 5 |  | smallint
Report finish mtrl not OK | SFRVReportFinishedMtrlNotOk | ztInteger | 5 |  | smallint
Report op mtrl not OK | SFRVReportMtrlNotOk | ztInteger | 5 |  | smallint
Report op tolerance | SFRVReportOpTolLimit | ztInteger | 5 |  | smallint
Report over mtrl issue | SFRVReportOverMtrlIssue | ztInteger | 5 |  | smallint
Report without start | SFRVReportwithoutStart | ztInteger | 5 |  | smallint
Def restart qty report | SFRVRestartQtyReport | ztInteger | 5 |  | smallint
Mtrl issue when 0 scrap | SFRVShowMtrlIssue | ztInteger | 5 |  | smallint
Report with tolerance | SFRVTolLimit | ztInteger | 5 |  | smallint
Tolerance limit high | SFRVTolLimitHigh | ztInteger | 5 |  | smallint
Tolerance limit low | SFRVTolLimitLow | ztInteger | 5 |  | smallint
Update all op | updatavvik | ztBoolean |  |  | char
Incl scrapped mtrl | updatavvikmru | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: SFR_rules Validation rules


Value tables (xr7)

A value table containing a selection of the columns that are part of a database table with the same identity. In addition, further terms can be defined based on the terms that exist in the database table. This is done via a standard SQL statement, e.g. you can define the difference between Debit and Credit as a value term.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Value term table | VardeTabId1 | ztString | 255 |  | varchar
Ägare | Vowner | ztString | 1 |  | varchar
Value term table | VTabell | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: xr7 Value tables


Value terms (xr9)

Definition of value terms, i.e. columns in tables in the database that contains values. The information is used, for example, in Jeeves report generator. See the 'Value tables' program (xr7) for further information.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
DB-term/-expression 1 | DbTermname1 | ztString | 120 |  | varchar
Alias for term | DbTermNameAlias | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Part of primary key | PrimaryKeyTerm | ztBoolean |  |  | char
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Value term table | VardeTabId1 | ztString | 255 |  | varchar
Value type | VardeTermT | ztInteger | 3 |  | smallint

    This table is the main table in the following programs:

    Program: xr9 Value terms


Value terms (vxr9)

Data name for the term, i.e. the column in a given database table which contains a value you want to retrieve, or an expression. The information is used on conversion, when entering definitions for import/export/logging of data and when defining reports in the report generator.

Example in column in database table
--------------------------------------
'AcctNo' is the column for account number
'DebAmt' is the column for debit amount
'CredAmt' is the column for credit amount

Example of expression to retrieve (and possibly convert) values
---------------------------------------------------------------
substring (Acct no, 1,2)+substring(Dept code, 3,2)
convert (datetime,convert(char(8),getdate(),112))
'Text'

Example of an expression for calculations in the report generator
----------------------------------------------------------
debbel-krebel (calculates the difference between Debit and Credit)
c20+c30+c40 (totals the values in column 20, 30 and 40 and enters the result in the relevant column)
r100+r300 (totals the values on row 100 and 300 and enters the result on the relevant row)
SUM(r100,r800) (totals the values from row 100 to and including 800 and enters the result on the relevant row)

From version 126 of Net Kernel you can also type in if-clauses in the expression using the following syntax: if xx then res:=xx else res:=xx;

Example:
if c20 <> 0 then res:=c30 else res:=c50;
if r143 <> 0 then res:=r450 else res:=5555;
if c10 <> 0 then res:=c20/c10 else res:= -123;

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
DB-term/-expression 1 | DbTermname1 | ztString | 120 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: vxr9 Database term


Value type, system parameter (qity)

Value types for terms/columns that can be used when defining system parameters in the JVSP table, JEEVES parameters.

The following standard records exist. Do not alter/delete:

Value type (VardeTermT) | Value type (VardeTermTB)
1 | String
2 | Checkbox, logical
3 | Numeric

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Value type | VardeTermT | ztInteger | 3 |  | smallint
Value type | VardeTermTB | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: qity Value types, system parameters


Value type, system parameter (xrbp)

Value types for terms/columns that can be used when defining system parameters in the JVSP table, JEEVES parameters.

The following standard records exist. Do not alter/delete:

Value type (VardeTermT) | Value type (VardeTermTB)
1 | Alphanumeric value
2 | Boolean (True/False)
3 | Numeric, whole numbers

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Value type | VardeTermT | ztInteger | 3 |  | smallint
Value type | VardeTermTB | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: Xrbp Value types, system parameters


Variant Levels (PVMVrtLev)

Table to connect variants to a master item. The table is used when creating variant items.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | artnr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Attribute | PVMAttributeId | ztString | 10 |  | varchar
Attribute level | PVMLevel | ztInteger | 4 |  | smallint
Variant | PVMVariantId | ztString | 10 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
@zPrompt=null | xbUpdFlag | ztBoolean |  |  | char


Variant order rows (OrpPvm)

Order numbers in numeric format. There is also a field for alphanumeric order numbers.

When defining the company's order types, it is possible to set different number series for each order type. The orders whose order types do not have order number series, receive their order numbers from the highest number series.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Error msg from matrix | PvmErrMessage | ztBlob | 2000 |  | varchar
@zPrompt=null | PvmGridNo | ztInteger | 3 |  | smallint
@zPrompt=null | PvmInProcess | ztInteger | 3 |  | smallint
Status | PvmStatus | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Language code | zlanguage | ztInteger | 4 |  | smallint


VAT/tax accounting (Wx1)

Auxiliary table for VAT/tax report. Summary per VAT/tax code.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sales tax | FaktMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice total incl tax | FaktTotMMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice total excl tax | FaktTotUMoms | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Customs document ID | Tulldokid | ztString | 20 |  | varchar


VAT/tax accounting (Wx1SAD)

Auxiliary table for VAT/tax report. Summary per VAT/tax code.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sales tax | FaktMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice total incl tax | FaktTotMMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice total excl tax | FaktTotUMoms | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Customs document ID | Tulldokid | ztString | 20 |  | varchar


VAT/tax accounts parameters (VATAccPar)

VAT/tax accounts parameters.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
VAT/tax parameter ID | VATParameterId | ztInteger | 5 |  | smallint
Validity ID | VATValidityId | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: VATAccPar VAT/tax accounts parameter


VAT/tax box descriptions (BE_VAT_Box)

VAT/tax box description.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
VAT/tax box | VATBox | ztString | 5 |  | varchar
VAT/tax box | VATBoxDescr | ztString | 100 |  | varchar

    This table is the main table in the following programs:

    Program: BE_VAT_Box VAT/tax box descriptions


VAT/tax declaration grid (BE_Vat_Grid)

Definition of the VAT/tax declaration grid.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
Customer category | KundKategorikod | ztInteger | 2 |  | smallint
Supplier category | LevKategori | ztInteger | 2 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Pay or receive | VAT_PayedOrReceive | ztBoolean |  |  | char
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax box | VATBox | ztString | 5 |  | varchar
Box sign | VATBoxSign | ztString | 5 |  | varchar
Grid ID | VATGridid | ZtLong | 10 |  | int
VAT/tax trans type | VATTransactionType | ztString | 5 |  | varchar

    This table is the main table in the following programs:

    Program: BE_Vat_Grid VAT/tax declaration grid


VAT/tax groups (VATGroup)

Definition of VAT/tax Groups.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
VAT/tax group ID | VATGroupId | ztInteger | 4 |  | smallint
VAT/tax group name | VATGroupName | ztString | 32 |  | varchar

    This table is the main table in the following programs:

    Program: VATGroup VAT/tax groups


VAT/tax parameters (VATParam)

VAT/tax parameters.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
VAT/tax group ID | VATGroupId | ztInteger | 4 |  | smallint
VAT/tax parameter descr | VATParameterDescr | ztString | 255 |  | varchar
VAT/tax parameter ID | VATParameterId | ztInteger | 5 |  | smallint
VAT/tax parameter name | VATParameterName | ztString | 64 |  | varchar
Validity ID | VATValidityId | ztInteger | 4 |  | smallint

    This table is the main table in the following programs:

    Program: VATParam VAT/tax parameters


VAT/tax rates (X1)

Definition of the VAT/tax types used for sales and purchasing, with associated VAT/tax rates according to legislation. The VAT/tax codes can also be used to control sales postings via posting templates.

The following standard records exist. Do not alter/delete:

VAT/tax code (MomsKod) | VAT/tax (description) (MomsBeskrivning) | Description
0 | 0% (domestic) | Note that VAT/tax code 0 must exist because Jeeves performs certain internal checks using this code.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
VAT/tax code mapping | FiscalPrinterMomsKod | ztString | 3 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Mixed VAT/tax | KodVidBlandadMoms | ztBoolean |  |  | char
VAT/tax (description) | MomsBeskrivning | ztString | 50 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
New rate from date | NyMomsFromDatum | ztDate |  |  | datetime
New VAT/tax rate | NyMomsSats | ZtDecimal73 | 5 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Rounding type | PrisAvrundKod | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sales tax handling | SalesTaxHandling | ztBoolean |  |  | char
Sales tax code | TaxCode | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: XX1 VAT/tax rates


VAT/tax rates on account (kox1)

VAT/tax rates that can be used on account.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Account | KtoNr | ztString | 8 |  | varchar
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


VAT/tax register (tax)

VAT/tax transactions from different modules with the option of viewng the VAT/tax base transactions (customer invoices, supplier invoices, customs invoices, etc.)

The program/table constitutes a part of a country-specific function for VAT/tax reporting.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Amount excl VAT/tax | AmountExclVAT | ZtBaseCurrAmount | 14 | 2 | money
Amount incl VAT/tax | AmountInclVAT | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax amount | AmountVAT | ZtBaseCurrAmount | 14 | 2 | money
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Dispatch date | DeliveryDate | ztDate |  |  | datetime
Own invoice no. | egen_faktnr | Jeeves_InvNo | 9 |  | bigint
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Tax date | MomsDatum | ztDate |  |  | datetime
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Upd VAT/tax register | MomsPlikt | ztBoolean |  |  | char
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLidentity | ZtLong | 10 |  | int
Customs document ID | TullDokId | ztString | 20 |  | varchar
Customs duties | TullkostTyp | ztInteger | 5 |  | smallint
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: tax VAT/tax transactions


VAT/tax transaction types (x1dt)

Definition of applicable VAT/tax transaction types that can be used in the VAT/tax grid.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
VAT/tax trans type | VATTransactionType | ztString | 5 |  | varchar
VAT/tax trans type | VATTransactionTypeDescr | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: x1dt VAT/tax transaction types


VAT/tax types (x1d)

Own definition of existing VAT/tax types, for example VAT on domestic sales, VAT EU export, VAT EU import, etc.

This constitutes a part of a country-specific function for VAT/tax reporting and is obligatory if the function is to be applied.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Collective invoicing | SamlingsFaktura | ztBoolean |  |  | char
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax type | VAT_Type_Descr | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: x1d VAT/tax types


VAT/tax types (vx1d)

View of own definition of existing VAT/tax types, for example VAT on domestic sales, VAT EU export, VAT EU import, etc.

This constitutes a part of a country-specific function for VAT/tax reporting and is obligatory if the function is to be applied.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Collective invoicing | SamlingsFaktura | ztBoolean |  |  | char
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax type | VAT_Type_Descr | ztString | 40 |  | varchar


VAT/tax types (vx1d1)

View of own definition of existing VAT/tax types, for example VAT on domestic sales, VAT EU export, VAT EU import, etc.

This constitutes a part of a country-specific function for VAT/tax reporting and is obligatory if the function is to be applied.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Collective invoicing | SamlingsFaktura | ztBoolean |  |  | char
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax type | VAT_Type_Descr | ztString | 40 |  | varchar


VAT/tax types (vx1dv0)

View of own definition of existing VAT/tax types, for example VAT on domestic sales, VAT EU export, VAT EU import, etc.

This constitutes a part of a country-specific function for VAT/tax reporting and is obligatory if the function is to be applied.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Collective invoicing | SamlingsFaktura | ztBoolean |  |  | char
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax type | VAT_Type_Descr | ztString | 40 |  | varchar


VAT/tax types (vx1dv1)

View of own definition of existing VAT/tax types, for example VAT on domestic sales, VAT EU export, VAT EU import, etc.

This constitutes a part of a country-specific function for VAT/tax reporting and is obligatory if the function is to be applied.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Collective invoicing | SamlingsFaktura | ztBoolean |  |  | char
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax type | VAT_Type_Descr | ztString | 40 |  | varchar


VAT/tax types (vx1dv2)

View of own definition of existing VAT/tax types, for example VAT on domestic sales, VAT EU export, VAT EU import, etc.

This constitutes a part of a country-specific function for VAT/tax reporting and is obligatory if the function is to be applied.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Collective invoicing | SamlingsFaktura | ztBoolean |  |  | char
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax type | VAT_Type_Descr | ztString | 40 |  | varchar


VAT/tax types (vx1dv3)

View of own definition of existing VAT/tax types, for example VAT on domestic sales, VAT EU export, VAT EU import, etc.

This constitutes a part of a country-specific function for VAT/tax reporting and is obligatory if the function is to be applied.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Collective invoicing | SamlingsFaktura | ztBoolean |  |  | char
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax type | VAT_Type_Descr | ztString | 40 |  | varchar


VAT/tax types (vx1dv4)

View of own definition of existing VAT/tax types, for example VAT on domestic sales, VAT EU export, VAT EU import, etc.

This constitutes a part of a country-specific function for VAT/tax reporting and is obligatory if the function is to be applied.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Collective invoicing | SamlingsFaktura | ztBoolean |  |  | char
VAT/tax type | VAT_Type | ztInteger | 4 |  | smallint
VAT/tax type | VAT_Type_Descr | ztString | 40 |  | varchar


VAT/tax validity (VATValid)

VAT/tax validity.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
VAT/tax valid fr period | VATValidFromPer | ztInteger | 2 |  | smallint
Validity ID | VATValidityId | ztInteger | 4 |  | smallint
VAT/tax valid to period | VATValidToPer | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: VATValid VAT/tax validity


vFrOrp (view) (vFrOrp)

View of purchased items.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item class | Artkod | ztInteger | 3 |  | smallint
Item no. | artnr | ztString | 30 |  | varchar
Product class | artprodklass | ztString | 4 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Item type 1 | itemtypecd1 | ztInteger | 5 |  | smallint
Item type 2 | itemtypecd2 | ztInteger | 5 |  | smallint
Order row qty | ordantal | ZtQty | 14 | 2 | decimal
Order date | orddatum | ztDate |  |  | datetime
Order no. | ordernr | Jeeves_SONo | 8 |  | bigint
Order row no. | ordradnr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Backorder no. | ordrestnr | ztInteger | 2 |  | smallint
Item group | varugruppkod | ztString | 8 |  | varchar
Row value, curr (+tax) | vb_radvardeinklmoms | ztMoney | 14 | 2 | money
Order row amt, curr | vbordradsum | ztMoney | 14 | 2 | money
Setting type | ztype | ztInteger | 5 |  | int


View Change order row (vEcoh)

View against a change order row.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Change order status | ecostatuscode |  |  |  | @DataType=NULL
Change order ID | ecouniqueid |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL


View Company category level 2 (vfrekd2)

Internal categorization at the company level 2 (CRM) that is included in level 1

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Comp.category level 1 | ekd1 | ztInteger | 15 |  | smallint
Comp.category level 2 | ekd2 | ztInteger | 15 |  | int
Description level 2 | Ekd2Beskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint


View competitor items (varkonk)

View of base table with competitor items.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Unique drop-down record | ddlstring | ztString | 18 |  | nvarchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Competitor item part | konkartdel | ztInteger | 5 |  | smallint
Competitor item part | KonkArtDelBeskr | ztString | 50 |  | varchar
Competitor item type | konkarttyp | ztInteger | 5 |  | smallint
Competitor item type | KonkArtTypBeskr | ztInteger | 5 |  | smallint


View contact pers. category level 2 (vKpEkd2)

Internal categorization level 2 at contact pers. Level (KP)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Comp.category level 1 | ekd1 | ztInteger | 15 |  | smallint
Comp.category level 2 | Ekd2 | ztInteger | 15 |  | int
Description level 2 | Ekd2Beskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint


View customers, payer (vkus)

Definition of deviating payer that can be linked to a customer or be specified on the customer order when creating follow-up invoices, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. days, due | AntDgrForFallet | ztInteger | 5 |  | smallint
Direct debit BG/acct no | AutoGiroBetKtoNr | ztString | 20 |  | varchar
Auto, credit function | AutoKreditKontrollKod | ztBoolean |  |  | char
Payment terms | BetKod | ztString | 2 |  | varchar
Payment terms, advance | BetKodForskott | ztString | 2 |  | varchar
Discount priority | DiscountPrio | ztInteger | 5 |  | smallint
District | DistrKod | ztString | 4 |  | varchar
Text | edit | ztBlob | 1 |  | varchar
Handling charge | expavgkd | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Delivery note Y/N | fskd | ztBoolean |  |  | char
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Payment method | InbSlag | ztString | 3 |  | varchar
Reminder code | kravkd | ztBoolean |  |  | char
Reminders blocked | KravSparr | ztBoolean |  |  | char
Block reminders until | KravSparrTomDat | ztDate |  |  | datetime
Credit limit check type | KreditCheckTyp | ztInteger | 2 |  | smallint
Credit exclude order value | KreditExklOrdSaldo | ztBoolean |  |  | char
Credit block | kreditsparr | ztBoolean |  |  | char
Credit block type | KreditSparrTyp | ztInteger | 2 |  | smallint
Credit status type | KreditStatusTyp | ztInteger | 2 |  | smallint
Credit warning | KreditVarning | ztBoolean |  |  | char
Payer, company ID | kundbetalarenr | ztCompanyNo | 20 |  | varchar
Customer balance, adv | KundForskottSaldo | ZtBaseCurrAmount | 14 | 2 | money
Customer balance, paid adv | KundInbetForskottSaldo | ZtBaseCurrAmount | 14 | 2 | money
Customer category | kundkategorikod | ztInteger | 2 |  | smallint
Average days credit | kundkreddag | ztInteger | 3 |  | smallint
Credit limit | kundkredlim | ZtBaseCurrAmount | 14 | 2 | money
Turnover YTD | kundoms | ZtBaseCurrAmount | 14 | 2 | money
Turnover previous year | kundomsfa | ZtBaseCurrAmount | 14 | 2 | money
T-ov prev yr incl VAT/tax | KundOmsFaInklMoms | ZtBaseCurrAmount | 14 | 2 | money
T-ov curr yr incl VAT/tax | KundOmsInklMoms | ZtBaseCurrAmount | 14 | 2 | money
AR ledger balance | kundsaldo | ZtBaseCurrAmount | 14 | 2 | money
Unused credit | KusKvarPaKredit | ZtBaseCurrAmount | 14 | 2 | decimal
Country | LandsKod | ztString | 3 |  | varchar
Ship documents | levhandlkod | ztBoolean |  |  | char
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Date/time canceled | MakdateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Max. amount due | MaxBelForFallet | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Order date | OrdDatum | ztDate |  |  | datetime
Order value | ordsum | ZtBaseCurrAmount | 14 | 2 | money
Order value (incl tax) | OrdSumInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Payment priority | PaymentPrio | ztInteger | 5 |  | smallint
Payment surplus | PaymentSurplus | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Cust discount class | RabKlass | ztInteger | 3 |  | smallint
Interest amt calc to date | rtasaldobertomdat | ztDate |  |  | datetime
Pmt rmdr/intrst invc rule | RteFaktAvtal | ztInteger | 2 |  | smallint
Interest invoice | RteFaktKd | ztBoolean |  |  | char
Salesperson | Saljare | ztString | 6 |  | varchar
Collective invoicing | SamFaktUtskr | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Total assignments invoice | SumUppDrag | ztBoolean |  |  | char
Currency | ValKod | ztString | 3 |  | varchar

    This table is the main table in the following programs:

    Program: vkus View customers, payer


View EDM user (vpredm)

View of EDM users.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Name | respnamn | ztString | 50 |  | varchar


View for calc components not selected (vxcc)

Contains calculation components that are not yet included in a calculation markup code.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Calculation markup code | ArkPalKod | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Calculation component descr | KalkylKompBeskr | ztString | 80 |  | varchar
Calculation component | KalkylKompTyp | ztInteger | 2 |  | smallint
OH cost type | OhKostTyp | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


View of cust+company+contact (Customer_Company_Contact_view)

Alphanumeric designation for the company.

When you enter a company for the first time, this number is not automatically set by the system. You must enter it manually.

This is the unique ID for the company and cannot be changed, which means that if you base it on the company name, e.g. the first letters of the company name, you will not be able to change the ID if the company changes name. It is therefore best to construct the ID a different way or just use sequence numbers. You can search for the company using different terms, e.g. its name.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Max amt for direct debit | AgPayLimit | ZtLong | 5 |  | int
Restricted equity | Aktiekap | ZtBaseCurrAmount | 14 | 2 | money
No. of times ordered | antalkop | ztInteger | 5 |  | smallint
No. days, due | AntDgrForfallet | ztInteger | 5 |  | smallint
Direct debit BG/acct no | AutoGiroBetKtoNr | ztString | 20 |  | varchar
Auto, credit function | AutoKreditKontrollKod | ztBoolean |  |  | char
Auto booking rule | AutStockBookingRule | ztInteger | 5 |  | smallint
Department | avd | ztString | 30 |  | varchar
Position | BefattKod | ztString | 2 |  | varchar
Req cust | BehovsKund | ztCompanyNo | 20 |  | varchar
This field is used in the table as follows: |
Payment terms | BetKod | ztString | 2 |  | varchar
Region | BlockRegion | ztString | 3 |  | varchar
Contact details | ComNr | ztString | 200 |  | varchar
This field is used in the table as follows: |
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Part delivery allowed | DelLevTillaten | ztInteger | 5 |  | smallint
This field is used in the table as follows: |
District | DistrKod | ztString | 4 |  | varchar
EAN location code | EAN_Loc_Code | ztString | 30 |  | varchar
Text | edit | ztBlob | 1 |  | varchar
External text | EditExt | ztBlob | 1 |  | varchar
Charge packaging cost | EmballageFakt | ztBoolean |  |  | char
Ship method, EU | EULevSattKod | ztInteger | 2 |  | smallint
EU VAT/tax registration no. | EUMomsNr | ztString | 20 |  | varchar
Handling charge | expavgkd | ztBoolean |  |  | char
Del Note, inv per order | FFhNr_Separata_Fakturor | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Insurance cost % | ForsakrKostnProc | ZtDecimal73 | 6 | 2 | decimal
Delivery note Y/N | fskd | ztBoolean |  |  | char
Distance | FtgAvstand | ztInteger | 4 |  | smallint
ZIP/Post code, visiting addr | FtgBesPostNr | ztString | 10 |  | varchar
Destination | FtgBestOrt | ztString | 25 |  | varchar
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Ship to->Visit addr | FtgLevAdressKod | ztBoolean |  |  | char
ZIP/Post code, del address | FtgLevPostNr | ztString | 10 |  | varchar
Company name | FtgNamn | ztString | 36 |  | varchar
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Business hours | FtgOpenHrs | ztString | 20 |  | varchar
Contact name | FtgPerson | ztString | 60 |  | varchar
c/o address | FtgPostAdr1 | ztString | 36 |  | varchar
Street addr/box | FtgPostAdr2 | ztString | 36 |  | varchar
Town/City/State | FtgPostAdr3 | ztString | 36 |  | varchar
Visiting address | FtgPostadr4 | ztString | 36 |  | varchar
Delivery address | FtgPostadr5 | ztString | 36 |  | varchar
Town/City/State, visiting address | FtgPostBesAdr3 | ztString | 36 |  | varchar
Town/City/State, del address | FtgPostLevAdr3 | ztString | 36 |  | varchar
ZIP/Post code | FtgPostnr | ztString | 10 |  | varchar
Visiting address | FtgVisAdr | ztString | 36 |  | varchar
Besöksadress | FtgVisAdr1 | ztString | 36 |  | varchar
Besöksadress | FtgVisAdr2 | ztString | 36 |  | varchar
Besöksadress | FtgVisAdr3 | ztString | 36 |  | varchar
Företagsnamn | FtgVisName | ztString | 36 |  | varchar
Goods label row 1 | GodsMarke1 | ztString | 40 |  | varchar
Goods label row 2 | GodsMarke2 | ztString | 40 |  | varchar
Goods terminal | GodsTerminalKod | ztString | 17 |  | varchar
Trading area | HandelsOmrKod | ztInteger | 2 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 2 |  | smallint
Payment method | InbSlag | ztString | 3 |  | varchar
Internal company | InterntFtg | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztBoolean |  |  | char
Municipality | kommun | ztString | 5 |  | varchar
Anst kont | Kontanst | ZtLong | 6 |  | int
Reminder code | kravkd | ztBoolean |  |  | char
Reminders blocked | KravSparr | ztBoolean |  |  | char
Block reminders until | KravSparrTomDat | ztDate |  |  | datetime
Credit limit check type | KreditCheckTyp | ztInteger | 2 |  | smallint
Credit exclude order value | KreditExklOrdSaldo | ztBoolean |  |  | char
Credit block | kreditsparr | ztBoolean |  |  | char
Credit block type | KreditSparrTyp | ztInteger | 2 |  | smallint
Credit status type | KreditStatusTyp | ztInteger | 2 |  | smallint
Credit warning | KreditVarning | ztBoolean |  |  | char
Plocklista (j/n) | Kund_PlKod | ztString | 1 |  | varchar
Alternative items | KundAltArtiklar | ztBoolean |  |  | char
Payer, company ID | kundbetalarenr | ztCompanyNo | 20 |  | varchar
Freight payer | KundFraktBetalareNr | ztCompanyNo | 20 |  | varchar
Charge freight cost | KundFraktDeb | ztBoolean |  |  | char
Paid-in previous year | KundInbPreYr | ZtBaseCurrAmount | 14 | 2 | money
Paid-in this year | KundInbThYr | ZtBaseCurrAmount | 14 | 2 | money
Customer category | kundkategorikod | ztInteger | 2 |  | smallint
Average days credit | kundkreddag | ztInteger | 3 |  | smallint
Credit limit | kundkredlim | ZtBaseCurrAmount | 14 | 2 | money
Turnover YTD | kundoms | ZtBaseCurrAmount | 14 | 2 | money
Turnover previous year | kundomsfa | ZtBaseCurrAmount | 14 | 2 | money
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Rabatt ej rab.gr art | KundRabattKod | ztBoolean |  |  | char
Discountable item | KundRabattKod0 | ztBoolean |  |  | char
Discounted item | KundRabattKod1 | ztBoolean |  |  | char
Non discountable item | KundRabattKod2 | ztBoolean |  |  | char
Max order disc % | KundRabattMax | ztFloat | 6 | 2 | float
Min order disc % | KundRabattMin | ztFloat | 6 | 2 | float
Customer reference | kundref2 | ztString | 30 |  | varchar
AR ledger balance | kundsaldo | ZtBaseCurrAmount | 14 | 2 | money
Tier qty + order value | KundStafflKod | ztBoolean |  |  | char
Customer specific text | KundTextKod | ztString | 4 |  | varchar
Unused credit | KusKvarPaKredit | ztString | 4 |  | varchar
County | laen | ztString | 5 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Country | LandsKod | ztString | 3 |  | varchar
Ship documents | levhandlkod | ztBoolean |  |  | char
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch terms | LevVillkKod | ztInteger | 2 |  | smallint
Date/time canceled | MakDateTime | ztDateTime |  |  | datetime
Canceled by | MakPersSign | ztString | 6 |  | varchar
Cancel | Makulerad | ztBoolean |  |  | char
Payment terms acc to payer | MarkBetBetVillkStyr | ztBoolean |  |  | char
Tax code acc to customer | MarkKundsMomsStyr | ztBoolean |  |  | char
Max. amount due | MaxBelForfallet | ZtBaseCurrAmount | 14 | 2 | money
Delivery note rows/page | MaxFsRaderPerSida | ztInteger | 5 |  | smallint
Send permission | medgivSendDt | ztDate |  |  | datetime
Permission status | medgivstatus | ztInteger | 1 |  | smallint
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Counterpart entry | MotPart | ztString | 30 |  | varchar
Goods label layout | OdetteFlaggLayout | ztString | 1 |  | varchar
Print order acknowl. | OeKod | ztBoolean |  |  | char
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Turnover | Omsattning | ZtBaseCurrAmount | 14 | 2 | money
Order date | OrdDatum | ztDate |  |  | datetime
Order link | OrderKoppling | ztBoolean |  |  | char
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Order value | ordsum | ZtBaseCurrAmount | 14 | 2 | money
Order value (incl tax) | OrdSumInklMoms | ZtBaseCurrAmount | 14 | 2 | money
Order type | OrdTyp | ztInteger | 3 |  | smallint
Organization no. | OrgNr | ztString | 18 |  | varchar
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Contact characteristic 1 | Persegk1 | ztInteger | 4 |  | smallint
Contact characteristic 2 | Persegk2 | ztInteger | 4 |  | smallint
Contact characteristic 3 | Persegk3 | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Price list | PrisLista | ztInteger | 5 |  | smallint
Company characteristic | ProspEgK1 | ztInteger | 3 |  | smallint
Company characteristic | ProspEgK2 | ztInteger | 3 |  | smallint
Company characteristic | ProspEgK3 | ztInteger | 3 |  | smallint
Company characteristic | ProspEgK4 | ztInteger | 3 |  | smallint
Company characteristic | ProspEgK5 | ztInteger | 3 |  | smallint
Cust discount class | RabKlass | ztInteger | 3 |  | smallint
Alt Kundrabklass | RabKlass1 | ztInteger | 3 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Backorder handling | RestBehKod | ztInteger | 1 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Interest amt calc to date | rtasaldobertomdat | ztDate |  |  | datetime
Pmt rmdr/intrst invc rule | RteFaktAvtal | ztInteger | 2 |  | smallint
Interest invoice | RteFaktKd | ztBoolean |  |  | char
Salesperson | Saljare | ztString | 6 |  | varchar
Collective invoicing | SamFaktUtskr | ztBoolean |  |  | char
SNI code | SNIKod | ztString | 8 |  | varchar
Language | SprakKod | ztInteger | 3 |  | smallint
Total assignments invoice | SumUppdrag | ztBoolean |  |  | char
Antal ans totalt | Totanst | ZtLong | 5 |  | int
Trading, sales price % | TradeFsgMarkup | ztFloat | 7 | 2 | float
Trading, cost price % | TradeKalkMarkup | ztFloat | 7 | 2 | float
Carrier code | TransportorsKod | ztString | 17 |  | varchar
Choice of carrier | TransportorsVal | ztBoolean |  |  | char
Currency | ValKod | ztString | 3 |  | varchar
Show Edit at order | VisaEditVidOrder | ztBoolean |  |  | char
Our supplier no. | VLevNr | ztString | 17 |  | varchar
Web address | webadress | ztString | 100 |  | varchar
Last login | WebLastLogin | ztDate |  |  | datetime
NoLogins | WebLoginCount | ZtLong | 6 |  | int
Entry date | WebRegDate | ztDate |  |  | datetime
Web remote address | WebRemoteAddr | ztString | 30 |  | varchar
E-mail | wEmailAddress | ztString | 100 |  | varchar
User Id | wPassword | ztString | 50 |  | varchar
Web user ID | wUserId | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: Customer_Company_Contact_view Customers


View on Mapping configurator from Jeeves, details (vXmlOutMappingRows)

Unique id of the installation.

Note: In the first version of the Astro integration, there is a one-to-one relationship between this definition and inventory locations in Jeeves, i.e. only one installation ID can exist per inventory location.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Table name | JvsTableName |  |  |  | @DataType=NULL
Configurator model ID | ModelId |  |  |  | @DataType=NULL
Signature | PersSign |  |  |  | @DataType=NULL
Entry date | RegDat |  |  |  | @DataType=NULL
Created by | RowCreatedBy |  |  |  | @DataType=NULL
Created date/time | RowCreatedDt |  |  |  | @DataType=NULL
Updated by | RowUpdatedBy |  |  |  | @DataType=NULL
Updated date/time | RowUpdatedDt |  |  |  | @DataType=NULL
Table grouping | TableGroupOrder |  |  |  | @DataType=NULL
Tag name | TactonTagName |  |  |  | @DataType=NULL
Only update | UpdateNoInsert |  |  |  | @DataType=NULL
Nodetype | XmlNodeType |  |  |  | @DataType=NULL
XPath | XmlXPath |  |  |  | @DataType=NULL


View operations, item (vop)

View of the op table (Operations per item in manufacturing).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Alternativ op | AltOpKod | ztString | 2 |  | varchar
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
Quantity per hour | AntalPerTimme | ztFloat | 15 | 6 | float
Aut. reported | AoDummyRapp | ztBoolean |  |  | char
Show operation | AoVisas | ztBoolean |  |  | char
Fixed labour OH | ArbOmkFast | ZtCost | 16 | 6 | float
Tot labour OH/op | ArbOmkOp | ZtCost | 16 | 6 | float
Variable labour OH | ArbOmkRorl | ZtCost | 16 | 6 | float
Setup labour OH/unit | ArbOmkStall | ZtCost | 16 | 6 | float
Setup overhead, labour | ArbStallBiKost | ZtCost | 16 | 6 | float
Setup cost labour | ArbStallKost | ZtCost | 16 | 6 | float
Labour overhead/unit | ArbStyckBiKost | ZtCost | 16 | 6 | float
Labour cost/unit | ArbStyckKost | ZtCost | 16 | 6 | float
Item no. | ArtNr | ztString | 30 |  | varchar
Auto receiving type | AutInlevTyp | ztInteger | 5 |  | smallint
Autom mtrl.uttag | AutMtrlUttag | ztBoolean |  |  | char
Auto mtrl issue type | AutMtrlUttagTyp | ztInteger | 5 |  | smallint
Workload factor | BelaggningsFaktor | ztFloat | 15 | 2 | float
PDM | ExistsPdm | ztBoolean |  |  | char
PDM (order) | ExistsPdmPO | ztBoolean |  |  | char
PDM (MO) | ExistsPdmWO | ztBoolean |  |  | char
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Calculation date | KalkBerDatum | ztDate |  |  | datetime
Scrap degree/op | KassOp | ztFloat | 5 | 2 | float
Inspection instruction | KontrollInstruktion | ztBlob | 1 |  | varchar
Queue time | KoTid | ztFloat | 15 | 2 | float
Subcontract overhead cost | LegoBiKost | ZtCost | 16 | 6 | float
Subcontract cost | LegoKost | ZtCost | 16 | 6 | float
Subcontract price/unit | LegoPris | ZtBaseCurrAmount | 14 | 2 | money
Subcontract setup price | LegoPrisStall | ZtBaseCurrAmount | 14 | 2 | money
Subcontract start price | LegoPrisStart | ZtBaseCurrAmount | 14 | 2 | money
Subcontract flag | MarkLego | ztBoolean |  |  | char
OLE-1 | Ole1 | ztString | 255 |  | varchar
OLE-2 | Ole2 | ztString | 255 |  | varchar
Personnel/operation | OpBemanning | ztFloat | 6 | 3 | float
Personnel/operation, setup | OpBemanningStall | ztFloat | 6 | 3 | float
Operation | OpBen | ztString | 30 |  | varchar
Operation | OpBeskr | ztBlob | 1 |  | varchar
Operation text ID | OperationsTextNr | ztInteger | 4 |  | smallint
Description, subcontract | OpLegoBen | ztString | 30 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Operation sort | OpSorteringsNr | ZtLong | 4 |  | int
Operation split | OpSplitt | ztFloat | 15 | 2 | float
Overlapping after quantity | OverLappEfterAntal | ZtQty | 14 | 2 | decimal
Overlapping after time | OverLappEfterTid | ztOpTime | 9 | 4 | float
Monetary factor | PenningFaktor | ztString | 3 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Mfg grp deprec. | PgAvskrKost | ZtCost | 16 | 6 | float
Mfg grp fixed cost | PgFastKost | ZtCost | 16 | 6 | float
Mfg grp var cost | PgRorlKost | ZtCost | 16 | 6 | float
Mfg grp setup cost | PgStallKost | ZtCost | 16 | 6 | float
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Spare part order | ReservdelsOrder | ztBoolean |  |  | char
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Unit time B | StyckTidB | ztFloat | 8 | 4 | float
Unit time C | StyckTidC | ztFloat | 8 | 4 | float
In-house or subcontract | TillvPriorEgenLego | ztInteger | 5 |  | smallint
Trång sektor | TrangSektor | ztBoolean |  |  | char
Item group | VaruGruppKod | ztString | 8 |  | varchar
Shop price | VerkstadPris | ZtBaseCurrAmount | 14 | 2 | money
Tools | Verktyg | ztString | 16 |  | varchar
List of tools | VerktygsLista | ztString | 35 |  | varchar
Tool deprec | VyAvskrKost | ZtCost | 16 | 6 | float
Fixed tool cost | VyFastKost | ZtCost | 16 | 6 | float
Var tool cost | VyRorlKost | ZtCost | 16 | 6 | float
Tool setup cost | VySTallKost | ZtCost | 16 | 6 | float
Tool unit cost | VyStyckKost | ZtCost | 16 | 6 | float


View order connection type (vxz3)

Definition of codes for controlling the function for automatic order link (order on hold).
The code can be entered on the order type and then automatically linked to the order header or it can be entered manually.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Order link type | OrderKopplBeskr | ztString | 50 |  | varchar
Order link type | OrderKopplKod | ztInteger | 2 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


View order rows, EDI (vord)

Alphanumeric code for the item, BOM, fixed asset, or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
External order number | ExtOrderNr | ztString | 17 |  | varchar
External order type | ExtOrdTyp | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar


View release (vpdmu)

Release index linked to an alphanumeric release designation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Release | artrelease | ztString | 6 |  | varchar
Release index | artrelindex | ztInteger | 4 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


View sales price list, header (prhv)

Definition of price lists per item, service or equivalent in the item table, or per item group. The price lists are normally linked to a customer.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Calc.ord amount + % | BerOrdnBelAddProc | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
No rounding | EjPrisAvrunda | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Campaign start date | KampanjFromDat | ztDate |  |  | datetime
Campaign price list | KampanjPrisLista | ztInteger | 6 |  | smallint
Campaign end date | KampanjTomDat | ztDate |  |  | datetime
Price adjustment (%) | KodPrisJustering | ztBoolean |  |  | char
This field is used in the table as follows: |
Supplementary price list | KomplPrisLista | ztInteger | 6 |  | smallint
No customer disc | KundEjRabKod | ztBoolean |  |  | char
Markup/reduction % | markup | ztFloat | 14 | 4 | float
Price factor amount | MarkUpBelopp | ztMoney | 14 | 2 | money
Discount fr matrix, add | MatrisRabAddKod | ztBoolean |  |  | char
Net, no discount | NettoEjRabKod | ztBoolean |  |  | char
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Price factor table | PrisFaktTabKod | ztString | 6 |  | varchar
Price adjustment fact% | PrisJustFaktor | ztFloat | 14 | 4 | float
Price valid until date | PrislGiltigDat | ztDate |  |  | datetime
Price valid as of date | PrislGiltigFromDat | ztDate |  |  | datetime
Price list | PrisLista | ztInteger | 5 |  | smallint
Price list | PrisListaBeskr | ztString | 30 |  | varchar
Price calculation method | PrisSattnTyp | ztInteger | 2 |  | smallint
Price calc method, order | PrisVidOrderTyp | ztInteger | 2 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Volume disc %, add | VolymRabAddKod | ztBoolean |  |  | char


View suppliers, payment recipients (vle)

Definition of deviating payment recipient that can be linked to a supplier or be specified on the supplier invoice, e.g. Factoring company, etc.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Account at bank | BankKonto | ztString | 40 |  | varchar
Dispatch method | BestLevsattKod | ztInteger | 2 |  | smallint
Dispatch terms | BestLevVilkKd | ztInteger | 2 |  | smallint
Payee company no. | BetalasTillNr | ztCompanyNo | 20 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Pmt to acct | KontoIns | ztInteger | 1 |  | smallint
Cust no. at supplier | KundNrHosLev | ztString | 15 |  | varchar
Bank Giro | LevBankgiro | ztBgNr | 11 |  | varchar
Payment terms | LevBetVillk | ztString | 2 |  | varchar
Supplier category | levkategori | ztInteger | 2 |  | smallint
Turnover previous year | LevOmsPreYr | ZtBaseCurrAmount | 14 | 2 | money
Turnover YTD | LevOmsThYr | ZtBaseCurrAmount | 14 | 2 | money
Plus giro no. | LevPostgiro | ztPgNr | 11 |  | varchar
AP ledger balance | LevReskSaldo | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Priority | Prioritet | ztInteger | 2 |  | smallint
Language | SprakKod | ztInteger | 3 |  | smallint
Pmt for final approval | UtbAnkKontFakt | ztBoolean |  |  | char
Payment methods | UtbSlag | ztString | 3 |  | varchar
Payment blocked | UtbSparr | ztBoolean |  |  | char
Currency | ValKod | ztString | 3 |  | varchar

    This table is the main table in the following programs:

    Program: vle View suppliers, payment recipients


View, alternative items (vara)

Table for entering an unlimited number of alternative items for an item. Priority can be specified for the alternative items.
This is used in the order routine to present possible alternatives for an item that at the time of the order does not have any available inventory for the dispatch date in question.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item description | ArtBeskr | ztString | 30 |  | varchar
Recommended price | ArtCirkaPris | ZtSalesPrice | 12 | 2 | money
List price | ArtListPris | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Alternative item | ArtNrAltArt | ztString | 30 |  | varchar
Priority code | ArtNrAltArtPrior | ztInteger | 3 |  | smallint
Total inventory balance | BerSaldo | ZtQty | 14 | 2 | decimal
Available invtry balance | DispSaldo | ZtQty | 14 | 2 | decimal
EDI alternative | EdiAlternativ | ztInteger | 2 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Ordered quantity | LagBestAnt | ZtQty | 14 | 2 | decimal
Qty on order/prod | LagOrdrAnt | ZtQty | 14 | 2 | decimal
Reserved quantity | LagResAnt | ZtQty | 14 | 2 | decimal
Inventory balance | LagSaldo | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Valid to date | TomDatum | ztDate |  |  | datetime
Item group | VaruGruppKod | ztString | 8 |  | varchar

    This table is the main table in the following programs:

    Program: vara Alternative items


View, External business units ICT (vICTConBusUnit)

Definition of the external business units or equivalent, i.e. units within other companies with which the home company has business relations. The term “business unit” shows the unit that owns an order, purchase order, invoice etc, as well as the unit to which the order, purchase order, or invoice is directed.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
ICT conn business unit | ICTConBusinessUnit | ztString | 8 |  | varchar
ICT conn business unit | ICTConBusinessUnitDescr | ztString | 50 |  | varchar
Database connection ICT | ICTDataBase | ztString | 120 |  | varchar
Database schema ICT | ICTDataBaseSchema | ztString | 120 |  | varchar
External company ICT | ICTExtrnCoNo | ztInteger | 4 |  | smallint
Internal company ICT | ICTIntrnCoNo | ztInteger | 5 |  | smallint
Inventory location ICT | ICTInvLocation | ztString | 16 |  | varchar
Linked server ICT | ICTLinkedServer | ztString | 120 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Connection type ICT | ICTType | ztInteger | 2 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: vICTConBusUnit View, External business units ICT


View, forecast levels (vprn)

Definition of forecast levels for building up item forecasts. A forecast level consists of a specific number of forecast periods and therefore always represents a time period.

If there are several forecast periods, they normally have a relationship with each other which is defined in the field 'Main level', e.g.:
- Three year forecast is a superior level to Year forecast.
- Year forecast is a superior level to Quarterly forecast.
- Quarterly forecast is a superior level to Month forecast, and so on.

It is also here, in the embedded list window 'Forecast periods' (program Prpe), that you define a start date, end date and order for each period within the forecast level.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Number of forecast units | AntalEnheter | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Main level | HuvudNiva | ztInteger | 4 |  | smallint
Net requirement level | NettoNiva | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Forecast unit | PrognosEnhet | ztInteger | 4 |  | smallint
Forecast level | PrognosNiva | ztInteger | 5 |  | smallint
Forecast level | PrognosNivaNamn | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Year forecast | YearPrognos | ztBoolean |  |  | char


View, forecast versions (vprv)

Forecast versions according to own definition, e.g. to mirror revisions, division into different markets, for example, and so on.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Forecast version | PrognosNamn | ztString | 60 |  | varchar
Forecast version | PrognosVer | ZtLong | 4 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


View, item -> price-/invntry information (bars)

This view is intended as a search program for items, including price and inventory information.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
ComponentQty | AntIngarISr | ZtLong | 5 |  | int
Item description | ArtBeskr | ztString | 30 |  | varchar
Specification | ArtBeskrSpec | ztString | 30 |  | varchar
Item category | ArtKat | ztString | 10 |  | varchar
Item class | ArtKod | ztInteger | 3 |  | smallint
Customer discnt allowed | ArtKundRabKod | ztBoolean |  |  | char
List price | ArtListPris | ZtBaseCurrAmount | 14 | 2 | money
Item no. | ArtNr | ztString | 30 |  | varchar
Item no. EAN | ArtNrEAN | ztString | 30 |  | varchar
Product class | ArtProdKlass | ztString | 4 |  | varchar
Item discount class | ArtRabKlass | ztInteger | 3 |  | smallint
Total inventory balance | BerSaldo | ZtQty | 14 | 2 | float
Available invtry balance | DispSaldo | ZtQty | 14 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, BCU | FPris | ZtBaseCurrAmount | 14 | 2 | money
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | float
Ordered quantity | LagBestAnt | ZtQty | 14 | 2 | float
Qty on order/prod | LagOrdrAnt | ZtQty | 14 | 2 | float
Reserved quantity | LagResAnt | ZtQty | 14 | 2 | float
Inventory balance | LagSaldo | ZtQty | 14 | 2 | float
Inventory location | LagStalle | ztString | 2 |  | varchar
Net price in BCU | NettoPris | ZtSalesPrice | 12 | 2 | money
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | float
Disc code order value | OrdVRabKod | ztInteger | 2 |  | smallint
Price calc method, pkg | OrpStrPrisBer | ztInteger | 2 |  | smallint
Package item | PaketArtikel | ztBoolean |  |  | char
Price list | PrisLista | ztInteger | 5 |  | smallint
Pricing method | PrisTypP | ztInteger | 3 |  | smallint
Discount 1 % | Rabatt1 | ZtDecimal73 | 6 | 2 | float
Discount 2 % | Rabatt2 | ZtDecimal73 | 6 | 2 | float
Discount 3 % | Rabatt3 | ZtDecimal73 | 6 | 2 | float
Item group | VaruGruppKod | ztString | 8 |  | varchar
Volume disc % | VolymRabatt | ZtDecimal73 | 10 | 2 | float

    This table is the main table in the following programs:

    Program: artsok Search item

    Program: artsok1 Search item, complete


View, Language (xwvw)

Internal definition of languages according to Jeeves' own standard. Language codes cannot be changed.

The information is used to manage the language for some external texts depending on the external company's language.

The following standard records exist. Do not alter/delete:

Language
(SprakKod) 		Language
(Sprak)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Coll.invoice text-1 | SamlFaktText1 | ztString | 20 |  | varchar
Coll.invoice text-2 | SamlFaktText2 | ztString | 20 |  | varchar
Coll.invoice text-3 | SamlFaktText3 | ztString | 20 |  | varchar
Coll.invoice text-4 | SamlFaktText4 | ztString | 20 |  | varchar
Coll.invoice text-5 | SamlFaktText5 | ztString | 20 |  | varchar
Language | Sprak | ztString | 50 |  | varchar
Language | SprakKod | ztInteger | 3 |  | smallint


View, outgoing pmts and vouchers (ulrv)

Combination of outgoing payment details and corresponding postings (General Ledger vouchers) concerning supplier invoices.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr |  |  |  | @DataType=NULL
Approved by | AttestSign |  |  |  | @DataType=NULL
Supplier invoice no. | BestRkgNr |  |  |  | @DataType=NULL
VAT/tax GL date | DateOfTaxSupply |  |  |  | @DataType=NULL
Debit amount | DebBel |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Company ID | FtgNr |  |  |  | @DataType=NULL
Integration detail | IntField |  |  |  | @DataType=NULL
Integration source | IntSource |  |  |  | @DataType=NULL
S4 | K4 |  |  |  | @DataType=NULL
S5 | K5 |  |  |  | @DataType=NULL
S6 | K6 |  |  |  | @DataType=NULL
S7 | K7 |  |  |  | @DataType=NULL
Cost unit | Kostbar |  |  |  | @DataType=NULL
Cost centre | KostStalleKod |  |  |  | @DataType=NULL
Credit amount | KreBel |  |  |  | @DataType=NULL
Account | KtoNr |  |  |  | @DataType=NULL
Tax base amount | MomsGrundBelopp |  |  |  | @DataType=NULL
VAT/tax code | MomsKod |  |  |  | @DataType=NULL
Project ID | ProjCode |  |  |  | @DataType=NULL
Row | RadPos |  |  |  | @DataType=NULL
Fiscal year | Redovisnar |  |  |  | @DataType=NULL
Payment journal no. | UtbJournNr |  |  |  | @DataType=NULL
Voucher no. | VerNr |  |  |  | @DataType=NULL


View, reports, eBrev (vebr)

View of report definition, eBrev.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Report object | ebRptObjBeskr | ztString | 40 |  | varchar
Report object | ebRptObjekt | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Report program | YndReport | ztString | 40 |  | varchar


View, Tax Methods area level 1 (VTaxMethod1)

Table that contains definitions of Tax Areas for level 1.

The following standard records exist. Do not alter/delete:

Tax method (TaxMethod) | Tax method (TaxMethodDescr)
1 | Always applicable
2 | Applicable BELOW spec limit
3 | Applicable ABOVE spec limit

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax method | TaxMethod | ztInteger | 2 |  | smallint
Tax method | TaxMethodDescr | ztString | 50 |  | varchar


View, Tax Methods area level 2 (VTaxMethod2)

Table that contains definitions of Tax Areas for level 1.

The following standard records exist. Do not alter/delete:

Tax method (TaxMethod) | Tax method (TaxMethodDescr)
1 | Always applicable
2 | Applicable BELOW spec limit
3 | Applicable ABOVE spec limit

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax method | TaxMethod | ztInteger | 2 |  | smallint
Tax method | TaxMethodDescr | ztString | 50 |  | varchar


View, Tax Methods area level 3 (VTaxMethod3)

Table that contains definitions of Tax Areas for level 1.

The following standard records exist. Do not alter/delete:

Tax method (TaxMethod) | Tax method (TaxMethodDescr)
1 | Always applicable
2 | Applicable BELOW spec limit
3 | Applicable ABOVE spec limit

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax method | TaxMethod | ztInteger | 2 |  | smallint
Tax method | TaxMethodDescr | ztString | 50 |  | varchar


View, Tax Methods area level 4 (VTaxMethod4)

Table that contains definitions of Tax Areas for level 1.

The following standard records exist. Do not alter/delete:

Tax method (TaxMethod) | Tax method (TaxMethodDescr)
1 | Always applicable
2 | Applicable BELOW spec limit
3 | Applicable ABOVE spec limit

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax method | TaxMethod | ztInteger | 2 |  | smallint
Tax method | TaxMethodDescr | ztString | 50 |  | varchar


View, Tax Methods area level 5 (VTaxMethod5)

Table that contains definitions of Tax Areas for level 1.

The following standard records exist. Do not alter/delete:

Tax method (TaxMethod) | Tax method (TaxMethodDescr)
1 | Always applicable
2 | Applicable BELOW spec limit
3 | Applicable ABOVE spec limit

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax method | TaxMethod | ztInteger | 2 |  | smallint
Tax method | TaxMethodDescr | ztString | 50 |  | varchar


View, Tax Rate status area level 1 (VTaxRateStatus1)

Table that contains definitions of Tax Areas for level 1.

The following standard records exist. Do not alter/delete:

Tax rate status (TaxRateStatus) | Tax rate status (TaxRateStatusDescr)
1 | Preliminary
2 | Active
9 | Expired

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax rate status | TaxRateStatus | ztInteger | 2 |  | smallint
Tax rate status | TaxRateStatusDescr | ztString | 30 |  | varchar


View, Tax Rate status area level 2 (VTaxRateStatus2)

Table that contains definitions of Tax Areas for level 1.

The following standard records exist. Do not alter/delete:

Tax rate status (TaxRateStatus) | Tax rate status (TaxRateStatusDescr)
1 | Preliminary
2 | Active
9 | Expired

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax rate status | TaxRateStatus | ztInteger | 2 |  | smallint
Tax rate status | TaxRateStatusDescr | ztString | 30 |  | varchar


View, Tax Rate status area level 3 (VTaxRateStatus3)

Table that contains definitions of Tax Areas for level 1.

The following standard records exist. Do not alter/delete:

Tax rate status (TaxRateStatus) | Tax rate status (TaxRateStatusDescr)
1 | Preliminary
2 | Active
9 | Expired

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax rate status | TaxRateStatus | ztInteger | 2 |  | smallint
Tax rate status | TaxRateStatusDescr | ztString | 30 |  | varchar


View, Tax Rate status area level 4 (VTaxRateStatus4)

Table that contains definitions of Tax Areas for level 1.

The following standard records exist. Do not alter/delete:

Tax rate status (TaxRateStatus) | Tax rate status (TaxRateStatusDescr) | Description
1 | Always applicable |
2 | Applicable BELOW spec limit |
3 | Applicable ABOVE spec limit | Sales tax only applies above a certain order value. ***NOT YET IMPLEMENTED***
9 | Expired |

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax rate status | TaxRateStatus | ztInteger | 2 |  | smallint
Tax rate status | TaxRateStatusDescr | ztString | 30 |  | varchar


View, Tax Rate status area level 5 (VTaxRateStatus5)

Table that contains definitions of Tax Areas for level 1.

The following standard records exist. Do not alter/delete:

Tax rate status (TaxRateStatus) | Tax rate status (TaxRateStatusDescr) | Description
1 | Always applicable |
2 | Applicable BELOW spec limit |
3 | Applicable ABOVE spec limit | Sales tax only applies above a certain order value. ***NOT YET IMPLEMENTED***
9 | Expired |

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Tax rate status | TaxRateStatus | ztInteger | 2 |  | smallint
Tax rate status | TaxRateStatusDescr | ztString | 30 |  | varchar


View, time rep. details->int. accs. (vHrp)

View from the table of reported events, for example project activities, used for internal debiting.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Subproj closed | Aktavsl | ztBoolean |  |  | char
Subproject | Aktivitet | ztInteger | 4 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Charge | DebKod | ztInteger | 1 |  | smallint
File/dir | dokdir | ztString | 255 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
External text | editext | ztBlob | 1 |  | varchar
Planned activity descr | EventNote | ztString | 60 |  | varchar
Reported end date | EventRpEndDat | ztDate |  |  | datetime
Reported activity | EventRpKod | ztInteger | 3 |  | smallint
Reported end time | EventRpTime | ztTime | 5 |  | datetime
Hours | EventTimant2 | ztHourWithDecimals | 8 | 2 | decimal
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
RowNo. | FaktRadnr | ztInteger | 4 |  | int
To be invoiced | Faktureras | ztBoolean |  |  | char
Est % complete | FardigGrad | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Grafiskt tecken | Hrpblock | ztchar | 1 |  | char
Intern inv journal | InterndebJournal | ZtLong | 10 |  | int
In-house price | Internpris | ZtBaseCurrAmount | 14 | 2 | money
This field is used in the table as follows: |
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
Est hourly cost | KalkKostManTim | ZtBaseCurrAmount | 14 | 2 | money
Campaign | KampNr | ZtLong | 4 |  | int
Note | KortNotering | ztString | 255 |  | varchar
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Wage type | Loneart | ztString | 6 |  | varchar
This field is used in the table as follows: |
Sequence no. | LopNr | ZtLong | 10 |  | int
Master project no. | MasterProjCode | ztString | 10 |  | varchar
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Operation no. | OpNr | ztInteger | 3 |  | int
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order row no. | OrdRadNr | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Print date | p_utskr_dat | ztDate |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Personnel category | perskategori | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Personal no. | PersSignNr | ztInteger | 3 |  | smallint
Planning ID | PlanId | ztString | 10 |  | varchar
Activity finished | PlanUtford | ztBoolean |  |  | char
Price | pris | ZtBaseCurrAmount | 14 | 2 | money
Cost unit person | PrKostBar | ztString | 8 |  | varchar
Cost centre person | PrKostStalleKod | ztString | 8 |  | varchar
This field is used in the table as follows: |
Project ID | ProjCode | ztString | 10 |  | varchar
Journal no. | ProjKonterJournal | ZtLong | 10 |  | int
This field is used in the table as follows: |
Remaining time | ProjKvarTid | ztFloat | 10 | 2 | float
Row | RadPos | ZtLong | 10 |  | int
Row | radpos2 | ztInteger | 4 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Entry time | regtime | ztTime | 5 |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Connection->planned activities | StrDateTimehr | ztString | 28 |  | varchar
Time type | tidkod | ztInteger | 5 |  | smallint
Time report no. | TidrapportNr | ZtLong | 10 |  | int
This field is used in the table as follows: |
Services account | TjansteKonto | ztString | 8 |  | varchar
Currency | valkod | ztString | 3 |  | varchar
Price, curr | vb_pris | ZtSalesPrice | 12 | 2 | money
Week no | Veckonr | ztInteger | 6 |  | smallint
Sector | verksamhet | ztInteger | 5 |  | smallint
Prel invoice no. | WorkFaktNr | Jeeves_InvNo | 9 |  | bigint


View, users (vpr)

Database view of the Contacts table (PR).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Name | RespNamn | ztString | 50 |  | varchar
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: vpr View, users


View, zctrrel (vzfc)

Name of an EDI link.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod |  |  |  | @DataType=NULL
Contract | YndConnection | ztString | 32 |  | nvarchar
Connection name | YndInConnName | ztString | 20 |  | nvarchar
OutConnName | YndOutConnName | ztString | 20 |  | nvarchar

    This table is the main table in the following programs:

    Program: xVzfc EDI contracts/connections


View, zpvar (vzfp)

View, zpvar.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod |  |  |  | @DataType=NULL
Contract | YndConnection | ztString | 32 |  | nvarchar
Header extension | YndHdrExt | ztString | 8 |  | nvarchar
Mail type | YndKindOfMail | ztString | 20 |  | nvarchar
Pack extension | YndPackExt | ztString | 8 |  | nvarchar
Partner ID | YndPartner | ztString | 20 |  | nvarchar
Programs | YndPgm | ztString | 32 |  | nvarchar
Unit extension | YndUnitExt | ztString | 8 |  | nvarchar
Auto receiving | YndzAutoRecv | ztBoolean |  |  | char
Auto transmission | YndzAutoSend | ztBoolean |  |  | char
Delete at new loading | YndzDeleteRecv | ztBoolean |  |  | char
Delete at sending | YndzDeleteSend | ztBoolean |  |  | char
OK to receive | YndzRecv | ztBoolean |  |  | char
OK to send | YndzSend | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: xVzfp EDI partners (contracts)


VIEW; Order rows, items (products) (SOStockTransfer)

Order rows for items (products).
These order rows always have an item number that must be in the item table.
Such items are normally flagged as stocked, but can also be flagged as non-stocked (services, freight, fees, ....) The order row always belongs to an order header (OH) and a dispatch order header (OLH).
If the order row is released and noted for backorder, it is flagged as backorder (OrdRestNr > 0) and a new row is created (OrdRestNr = 0) with the backorder noted quantity.
Active order rows always have backorder number zero (OrdRestNr=0) and a remaining quantity (OrdRestAnt <> 0).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Add to MO row | AddToMO | Jeeves_MONo | 20 |  | bigint
Add to purchase order | AddToPO | Jeeves_PONo | 20 |  | bigint
Active | Aktiv | ztInteger | 1 |  | smallint
Alternative unit | AltEnhetKod | ztString | 10 |  | varchar
Alternative routing | AltOpPrior | ztInteger | 2 |  | smallint
This field is used in the table as follows: |
Requisition (not purch) | AnmodanMark | ztBoolean |  |  | char
Purchased | AnskaffningKop | ztBoolean |  |  | char
Acq to requirement | AnskaffningMotBehov | ztBoolean |  |  | char
Manufactured | AnskaffningTillv | ztBoolean |  |  | char
To dispatch | AntalAttLev | ZtQty | 14 | 2 | decimal
To disp, alt unit | AntalAttLevAltEnh | ZtQty | 14 | 2 | decimal
Quantity on picking list | AntalPaPlocklista | ZtQty | 14 | 2 | decimal
Qty being picked | AntalUnderPlock | ZtQty | 14 | 2 | decimal
Decimal places | AntDec | ztInteger | 1 |  | smallint
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Mfg/Works order no. (alpha) | AoNrAlfa | ztString | 30 |  | varchar
Row | AoPos | ztInteger | 4 |  | int
Operations start date | AoStartDat | ztDate |  |  | datetime
Bin | ars_LagPlats | ztBinLocation | 20 |  | varchar
Item description | Artbeskr | ztString | 30 |  | varchar
Recommended price | ArtCirkaPris | ZtSalesPrice | 12 | 2 | money
Item variant | ArtikelVariant | ztString | 30 |  | varchar
Current cost price | ArtKalkBer | ZtBaseCurrAmount | 14 | 2 | money
A-kostnad | ArtKalkBerA | ZtBaseCurrAmount | 14 | 2 | money
B-kostnad | ArtKalkBerB | ZtBaseCurrAmount | 14 | 2 | money
C-kostnad | ArtKalkBerC | ZtBaseCurrAmount | 14 | 2 | money
Cost price, material | ArtKalkBerMtrl | ZtBaseCurrAmount | 14 | 2 | money
Startkostnad | ArtKalkBerStart | ZtBaseCurrAmount | 14 | 2 | money
Budgeted cost | ArtKalkBudg | ZtBaseCurrAmount | 14 | 2 | money
Cost price unit | ArtKalkPer | ztInteger | 1 |  | smallint
Cost price (actual) | ArtKalkprisE | ZtBaseCurrAmount | 14 | 2 | money
Cost price at order | ArtKalkprisO | ZtBaseCurrAmount | 14 | 2 | money
Fixed cost price for order | ArtKalkprisOFast | ZtBaseCurrAmount | 14 | 2 | money
Cost at order (mtrl) | ArtKalkprisOMtrl | ZtBaseCurrAmount | 14 | 2 | money
Item class | ArtKod | ztInteger | 3 |  | smallint
Customer discnt allowed | ArtKundRabKod | ztBoolean |  |  | char
Priority | ArtLevPrior | ztInteger | 2 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Alternative item | ArtNrAltArt | ztString | 30 |  | varchar
Item no. EAN | ArtNrEAN | ztString | 30 |  | varchar
Customer item no. | ArtNrKund | ztString | 30 |  | varchar
Supplier item no. | ArtNrLev | ztString | 30 |  | varchar
Reg.template item | ArtNrRegMall | ztString | 30 |  | varchar
Unit conv factor | ArtOmvFaktor | ZtPurQty2Stock | 12 | 6 | decimal
Pack separately | ArtPackSeparat | ztBoolean |  |  | char
Product class | ArtProdKlass | ztString | 4 |  | varchar
Product acct | ArtProdKonto | ztString | 8 |  | varchar
Revision no. | ArtRevId | ztString | 10 |  | varchar
Blueprint | ArtRitnNr | ztString | 30 |  | varchar
Item serial no. | ArtSerieNr | ztString | 30 |  | varchar
Serienr from | ArtSerieNrFrom | ztString | 30 |  | varchar
T.o.m. serienr | ArtSerieNrTom | ztString | 30 |  | varchar
Degree of commitment | AtagandeGrad | ztInteger | 2 |  | smallint
Aut inlev av TO vid utplock | AutDelivOU_MO | ztInteger | 5 |  | smallint
Automatskapad | AutoCreated | ztBoolean |  |  | char
Automatic release | AutoFrislappas | ztBoolean |  |  | char
Autoskapad orderrad | AutoOrderLine | ztInteger | 5 |  | smallint
Posting template | AutoRegel | ztString | 4 |  | varchar
Auto booking rule | AutStockBookingRule | ztInteger | 5 |  | smallint
Qty parent BOM/pkg level | BAntalAvi | ztFloat | 12 | 4 | float
Batch no. required | BatchBokas | ztBoolean |  |  | char
Batch no. | BatchId | ztString | 30 |  | varchar
Ordered | Bestallas | ztBoolean |  |  | char
Order qty (invtry unit) | BestAnt | ZtQty | 14 | 2 | decimal
Order qty (suppl unit) | BestAntExtQty | ZtQty | 14 | 2 | decimal
Purchase price | BestInPris | ZtBaseCurrAmount | 14 | 2 | money
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Figure no. | BFigNr | ztString | 6 |  | varchar
Quantity booked | BokatAntal | ZtQty | 14 | 2 | decimal
Booked Qty (MO) | BookQtyMO | ZtQty | 14 | 2 | decimal
Booked Qty (PO) | BookQtyPO | ZtQty | 14 | 2 | decimal
Avail check status code | BristKontrolleradStatus | ztInteger | 5 |  | smallint
Avail status (invtry-out) | BristStatusLagerUtlev | ztInteger | 5 |  | smallint
Availability status (plan/req) | BristStatusPlaneringBegLevDat | ztInteger | 5 |  | smallint
Availability status (plan/req) | BristStatusPlaneringBerLevDat | ztInteger | 5 |  | smallint
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
Partial booking allowed | DelBokningTillaten | ztInteger | 5 |  | smallint
This field is used in the table as follows: |
Dispatch to PO | DelivToPOBackorderNo | ztInteger | 5 |  | smallint
Dispatch to PO | DelivToPOLnNo | ztInteger | 5 |  | smallint
Dispatch to PO | DelivToPONo | ZtLong | 10 |  | int
Part delivery allowed | DelLevTillaten | ztInteger | 5 |  | smallint
This field is used in the table as follows: |
Drop ship | DirektLeverans | ztBoolean |  |  | char
Direct issue | DirektUttag | ztBoolean |  |  | char
Text | Edit | ztBlob | 1 |  | varchar
External text | Editext | ztBlob | 1 |  | varchar
Unit code | EnhetsKod | ztString | 4 |  | varchar
Log | Exec_Time_Log_String | ztString | 255 |  | varchar
Processing time | ExecutionTime | ztFloat | 15 | 2 | float
External qty | ExternQty | ZtQty | 14 | 2 | decimal
External order type | ExtOrdTyp | ztInteger | 3 |  | smallint
Invoice date | FaktDat | ztDate |  |  | datetime
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no., change | FaktNrKorr | Jeeves_InvNo | 9 |  | bigint
Invoice no., original | FaktNrOrg | Jeeves_InvNo | 9 |  | bigint
Delivery note/disp no. | FfhNr | ZtLong | 10 |  | int
RowNo | FfhRadNr | ztInteger | 5 |  | int
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Delivery note reference | FoljesedelsRef | ztString | 17 |  | varchar
Consumables | ForbrukningsMaterial | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Sales price, BCU | FPris | ZtBaseCurrAmount | 14 | 2 | money
Fixed sales price, BCU | FPrisFast | ZtBaseCurrAmount | 14 | 2 | money
Price conv factor | FsgArtOmvFaktor | ztFloat | 14 | 4 | float
Price unit factor | FsgPrisPer | ztFloat | 14 | 4 | float
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Godsmärke | GodsMarke | ztString | 40 |  | varchar
Group acquisition by ...... | GroupPoWoOn | ztString | 10 |  | varchar
Item individual reference | IndividRef | ztString | 35 |  | varchar
Purchase agreement no. | InkAvt | ZtLong | 6 |  | int
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Exg rate on order date | InValKurs | ZtCurrencyRate | 15 | 7 | decimal
Purch price curr | InValuta | ztString | 3 |  | varchar
Jeeves_Init_Insert_Enter | Jeeves_Init_Insert_Enter | ztDateTime |  |  | datetime
Jeeves_Init_Insert_PreIns | Jeeves_Init_Insert_PreIns | ztDateTime |  |  | datetime
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
At cost | KalkylPrisFaktura | ztString | 1 |  | varchar
Sent from dept/S3 | KBarAvsandandeEnhet | ztString | 8 |  | varchar
Do not print invoice | KodEJUtskrFA | ztBoolean |  |  | char
Do not print DN | KodEJUtskrFS | ztBoolean |  |  | char
Do not print OA | KodEJUtskrOE | ztBoolean |  |  | char
External text -> order | KodExtTextToOrder | ztBoolean |  |  | char
Invtry transfer, rebook | KodLagerOmBokning | ztBoolean |  |  | char
Configuration item no. | KonfigArtNr | ztString | 30 |  | varchar
Copied from invoice | KopieradFranFaktNr | Jeeves_InvNo | 20 |  | bigint
Copied from order | KopieradFranOrderNr | Jeeves_SONo | 8 |  | bigint
Copied to order | KopieradTillOrderNr | Jeeves_SONo | 8 |  | bigint
KörID | KorId | ZtLong | 10 |  | int
Cost unit | KostBar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit order | KreditOrder | ztBoolean |  |  | char
CC dispatched unit | KstAvsandandeEnhet | ztString | 8 |  | varchar
Customer's intrn order no | KundIntOrderNr | ztString | 35 |  | varchar
Customer's order row | KundIntOrdRadNr | ZtLong | 6 |  | int
Customer category | KundKategoriKod | ztInteger | 2 |  | smallint
Discount % | KundRabatt | ZtDecimal73 | 6 | 2 | decimal
Stocked | LagerBokas | ztBoolean |  |  | char
Inventory transfer | LagerFlyttning | ztBoolean |  |  | char
Inventory mgmt type | LagerHanteringTyp | ztInteger | 2 |  | smallint
Bin | LagPlats | ztBinLocation | 20 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Lagerst för lev.order | LagStalleLevOrder | ztString | 2 |  | varchar
Lagerst för OU-lager | LagStalleOULager | ztString | 2 |  | varchar
Lead time to PO/MO | LedTid_orp_2_bp_ti | ztInteger | 5 |  | smallint
To disp alt unit, blocked | LevAntalAltEnhSparrat | ZtQty | 14 | 2 | decimal
To dispatch, blocked | LevAntalSparrat | ZtQty | 14 | 2 | decimal
Supplier number | LevNr | ztCompanyNo | 20 |  | varchar
Suppl discount-1 in % | LevRabattProc1 | ZtDecimal73 | 6 | 2 | decimal
Supplier item descr | LevsArtBeskr | ztString | 255 |  | varchar
Dispatch method | LevSattKod | ztInteger | 2 |  | smallint
Dispatch time | LevTid | ztTime | 5 |  | datetime
Man reconc, change date | ManReAvstDT | ztDateTime |  |  | datetime
Man reconc, date | ManReAvstPerDen | ztDate |  |  | datetime
Man reconc, sign | ManReAvstPersSign | ztString | 6 |  | varchar
Partially shipped package | MarkDelLevPkt | ztBoolean |  |  | char
Ord spec cost price | MarkOrderUniktKalkP | ztBoolean |  |  | char
Order-specific inventory | MarkOrderUniktLager | ztBoolean |  |  | char
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Actual material cost | MtrlVerklKost | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (adjust) | MtrlVerklKostJustering | ZtBaseCurrAmount | 14 | 2 | money
Actual mtrl cost (mtrl) | MtrlVerklKostMtrl | ZtBaseCurrAmount | 14 | 2 | money
Net, no discount | NettoEjRabKod | ztBoolean |  |  | char
Net price in BCU | NettoPris | ZtSalesPrice | 12 | 2 | money
Quote/agreement no. | OffNr | ztString | 10 |  | varchar
Quote/agreement row no | OffRadNr | ztInteger | 5 |  | int
Orderingång skapad | OingSkapad | ztBoolean |  |  | char
Pick flag date | OkAttPlockaSattDatum | ztDate |  |  | datetime
Pick status | OkAttPlockaStatus | ztInteger | 5 |  | smallint
OLE-1 | ole1 | ztString | 255 |  | varchar
OLE-2 | ole2 | ztString | 255 |  | varchar
Order row qty | OrdAntal | ZtQty | 14 | 2 | decimal
Order row qty, alt unit | OrdAntalAltEnh | ZtQty | 14 | 2 | decimal
B quantity | OrdAntalB | ztFloat | 15 | 2 | float
C quantity | OrdAntalC | ztFloat | 15 | 2 | float
Item descr (order) | OrdArtBeskr | ztString | 255 |  | varchar
Request disp date | OrdBegLevDat | ztDate |  |  | datetime
Preparation day | OrdBerednDat | ztDate |  |  | datetime
Est disp date | OrdBerLevDat | ztDate |  |  | datetime
Booking status | OrdBokningsStatus | ztInteger | 5 |  | smallint
This field is used in the table as follows: |
Order date | OrdDatum | ztDate |  |  | datetime
Order row from quote | OrderFranOffert | ztBoolean |  |  | char
Order code | OrderKod | ztInteger | 5 |  | smallint
Qty from linked orders | OrderKopplAntal | ZtQty | 14 | 2 | decimal
Order link type | OrderKopplKod | ztInteger | 2 |  | smallint
Order no. | OrderNr | Jeeves_SONo | 8 |  | bigint
Order no. (alpha) | OrderNrAlfa | ztString | 50 |  | varchar
Link order No. | OrderNrKoppl | Jeeves_SONo | 9 |  | bigint
Order No., change | OrderNrKorr | Jeeves_SONo | 8 |  | bigint
Order No., original | OrderNrOrg | Jeeves_SONo | 8 |  | bigint
Order no. | OrderNrServ | Jeeves_SONo | 9 |  | bigint
Ord-spec invtry bal | OrderUniktLager | ZtQty | 14 | 2 | decimal
Delivery note no. | OrdFoljesedelsNr | ZtLong | 10 |  | int
Order DN no. | OrdFsNr | ztInteger | 5 |  | int
Dispatched quantity | OrdLevAntal | ZtQty | 14 | 2 | decimal
Dispatch qty alt unit | OrdLevAntalAltEnh | ZtQty | 14 | 2 | decimal
Dispatch date | OrdLevDat | ztDate |  |  | datetime
Dispatch type | OrdLevNr | ztInteger | 5 |  | int
Point of delivery, co. ID | OrdLevPlats1 | ztCompanyNo | 20 |  | varchar
Promised disp date | OrdLovLevDat | ztDate |  |  | datetime
Order discount % | OrdRabatt | ZtDecimal73 | 6 | 2 | decimal
Order row no. | OrdRadnr | ztInteger | 5 |  | int
Link row No. | OrdRadNrKoppl | ztInteger | 5 |  | int
Order row no, template | OrdRadNrMall | ztInteger | 4 |  | int
Order row no, original | OrdRadNrOrg | ztInteger | 4 |  | smallint
Order row sales | OrdRadNrServ | ztInteger | 5 |  | int
Subrow no. | OrdRadNrStrPos | ztInteger | 5 |  | int
Ord.row no f package, original | OrdRadNrStrPosOrg | ztInteger | 4 |  | smallint
Orig row no in order | OrdRadnrUrspr | ztInteger | 5 |  | smallint
Total row discount % | OrdRadRab | ZtDecimal73 | 8 | 2 | decimal
Code row split, cust orders | OrdRadSplitKod | ztInteger | 5 |  | smallint
Order row status | OrdRadSt | ztInteger | 2 |  | smallint
Remaining qty | OrdRestAnt | ZtQty | 14 | 2 | decimal
Remaining qty, alt unit | OrdRestAntAltEnh | ZtQty | 14 | 2 | decimal
Remaining to pack | OrdRestAntPack | ZtQty | 14 | 2 | decimal
Backorder | OrdRestNot | ztBoolean |  |  | char
Backorder no. | OrdRestNr | ztInteger | 2 |  | smallint
Order type | OrdTyp | ztInteger | 3 |  | smallint
Disc code order value | OrdvRabKod | ztInteger | 2 |  | smallint
Order spec text | OrpRadText | ztString | 255 |  | varchar
Ord.spec text -> PO | OrpRadTextBe | ztBoolean |  |  | char
Order spec text/inv | OrpRadTextFa | ztBoolean |  |  | char
Order spec text/DN | OrpRadTextFs | ztBoolean |  |  | char
Order spec text OA | OrpRadTextOe | ztBoolean |  |  | char
Order spec text/PL | OrpRadTextPl | ztBoolean |  |  | char
Order spec text->MO | OrpRadTextTo | ztBoolean |  |  | char
Utskriftstyp, paket | OrpStrDetUt | ztInteger | 1 |  | smallint
Price calc method, pkg | OrpStrPrisBer | ztInteger | 2 |  | smallint
Package on picking list | PackageItemOnPickList | ztBoolean |  |  | char
Change package qty->det | PackageItemQty2Det | ztBoolean |  |  | char
Package, create 0 details | PackageItemZero | ztBoolean |  |  | char
Package date | PackagingDate | ztDateTime |  |  | datetime
Package item | PaketArtikel | ztBoolean |  |  | char
Paketartikel (klar?) | PaketUnderArbete | ztBoolean |  |  | char
Quantity PDM | pdmcount | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Picking list no. | PlockJnrOrder | ZtLong | 10 |  | int
Preliminary revenue at dsptch | PrelFaktVardeUtlev | ZtBaseCurrAmount | 14 | 2 | money
Date of price chg | PrisAndrDatum | ztDate |  |  | datetime
Pricing type | PrisHantTyp | ztInteger | 3 |  | smallint
Price adjustment | PrisJustOrder | ztBoolean |  |  | char
CSG on price adjustment | PrisJustOrderKost | ztBoolean |  |  | char
Price list | PrisLista | ztInteger | 5 |  | smallint
Pricing method | PrisTypP | ztInteger | 3 |  | smallint
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Discount % | rabatt | ZtDecimal73 | 6 | 2 | decimal
Discount 1 % | rabatt1 | ZtDecimal73 | 6 | 2 | decimal
Discount 2 % | rabatt2 | ZtDecimal73 | 6 | 2 | decimal
Discount 3 % | rabatt3 | ZtDecimal73 | 6 | 2 | decimal
Qty discount basis | RabattGrundAntal | ZtQty | 14 | 2 | decimal
Discount curr | rabattval | ztMoney | 14 | 2 | money
Discount curr 1 | rabattval1 | ztMoney | 14 | 2 | money
Discount curr 2 | rabattval2 | ztMoney | 14 | 2 | money
Discount curr 3 | rabattval3 | ztMoney | 14 | 2 | money
Entry date | RegDat | ztDate |  |  | datetime
Spare part order | ReservdelsOrder | ztBoolean |  |  | char
Backorder handling | RestBehKod | ztInteger | 1 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | Saljare | ztString | 6 |  | varchar
Joint purchase (allowed) | SamInKopMark | ztBoolean |  |  | char
Joint delivery code | SamLevKod | ztString | 4 |  | varchar
Joint pick | SamPlockas | ztBoolean |  |  | char
Joint pick list No. | SamPlockListeNr | ZtLong | 6 |  | int
Joint picking, running no | SamPlockLopNr | ztInteger | 5 |  | int
Serial no. required | SerieNrBokas | ztBoolean |  |  | char
Language | SprakKod | ztInteger | 3 |  | smallint
Start av updatering/insert | SqlStmtStartedDT | ztDateTime |  |  | datetime
Sequence number | SrDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Tiering code | StafflingsKod | ztBoolean |  |  | char
Change type new OA | StatusKodNyttOE | ztInteger | 5 |  | smallint
Requisition | StrDateTimeBIA | ztString | 28 |  | varchar
Order intake statistics | StrDateTimeOrpo | ztString | 28 |  | varchar
BOM rev. | StrukturRevision | ztString | 10 |  | varchar
This field is used in the table as follows: |
Component cost | SumKalkVardeIngDet | ZtBaseCurrAmount | 14 | 2 | money
Component cost (mtrl) | SumKalkVardeIngDetMtrl | ZtBaseCurrAmount | 14 | 2 | money
Component value, BCU | SumVardeIngDet | ZtBaseCurrAmount | 14 | 2 | money
Tot pkg detail value, curr | SumVbVardeIngDet | ztMoney | 14 | 2 | money
To bin no. | TillLagPlats | ztBinLocation | 20 |  | varchar
Optional for item | TillValArtToArtNr | ztString | 30 |  | varchar
Total deliv quantity | TotOrdLevAntal | ZtQty | 14 | 2 | decimal
Transit delivery | TransitLeverans | ztBoolean |  |  | char
Print order, alpha | Turordning | ztString | 20 |  | varchar
Orig order qty | UrsprOrderAntal | ZtQty | 14 | 2 | decimal
Pick code | UtplocksKod | ztBoolean |  |  | char
Print promised qty | UtskrDokLovAntal | ZtQty | 14 | 2 | decimal
Print promised disp date | UtskrDokLovLevDat | ztDate |  |  | datetime
Print promised price | UtskrDokLovPris | ZtSalesPrice | 12 | 2 | money
Print order acknowl | UtskrDokLovSkaGoras | ztBoolean |  |  | char
Print date new OA | UtskrDokLovUtskrDT | ztDateTime |  |  | datetime
Print on delivery note | UtskrFoljesedel | ztBoolean |  |  | char
Print on picking list | UtskrPlocklista | ztBoolean |  |  | char
Currency clause | ValKlausul | ztInteger | 5 |  | smallint
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Variant gruppH | VariantGruppH | ztString | 30 |  | varchar
Variant gruppT | VariantGruppT | ztString | 30 |  | varchar
Variant gruppV | VariantGruppV | ztString | 30 |  | varchar
Variant gruppX | VariantGruppX | ztString | 30 |  | varchar
Item group | VaruGruppKod | ztString | 8 |  | varchar
Invoice 0-price | VaruProv | ztString | 1 |  | varchar
Skattekod 2 | VATCode2 | ztInteger | 5 |  | smallint
Skattekod 3 | VATCode3 | ztInteger | 5 |  | smallint
Gross purch price, curr | Vb_InPris | ztMoney | 14 | 2 | money
Gross purch price, curr (mtrl) | Vb_InPris_Mtrl | ztMoney | 14 | 2 | money
Net price, curr | vb_NettoPris | ZtSalesPrice | 12 | 2 | money
Price, curr | vb_pris | ZtSalesPrice | 12 | 2 | money
Fixed price, currency | vb_PrisFast | ZtSalesPrice | 12 | 2 | money
Price incl tax, curr | Vb_PrisInklMoms | ZtSalesPrice | 12 | 2 | money
Row value, curr (+tax) | Vb_RadVardeInklMoms | ztMoney | 14 | 2 | money
Cost price, curr | vbKalkPris | ztMoney | 14 | 2 | money
Discount | VbOrdRabattSum | ztMoney | 14 | 2 | money
Order row amt, curr | VbOrdRadSum | ztMoney | 14 | 2 | money
Net Order row amt, curr | VbOrdRadSumNetto | ztMoney | 14 | 2 | money
Price acc to rule | VbPrisER | ZtSalesPrice | 12 | 2 | money
Volume disc % | VolymRabatt | ZtDecimal73 | 10 | 2 | decimal


Voucher header (vt)

Data in the voucher header.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Reversal period | AterBokasPeriod | ztInteger | 4 |  | smallint
Per bok.ver s/t | AterBokasST | ztInteger | 1 |  | smallint
Reversal voucher no. | AterBokasVerNr | Jeeves_VchrNo | 9 |  | bigint
Reversal date | AterBokfDat | ztDate |  |  | datetime
Reversal fiscal year | AterRedovisnar | ztInteger | 4 |  | smallint
Approved by | AttestSign | ztString | 6 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Base fiscal year | BasRedAr | ztInteger | 4 |  | smallint
Base voucher no. | Basvernr | Jeeves_VchrNo | 9 |  | bigint
Base voucher row no. | BasVerRadpos | ztInteger | 4 |  | smallint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Journal no | DagBoksNr | ZtLong | 9 |  | int
Debit amount | debbel | ZtBaseCurrAmount | 14 | 2 | money
Text | Edit | ztBlob | 1 |  | varchar
Chronological vouch no. | EntryNo_GL | ZtLong | 9 |  | int
Exported date | ExpDatum | ztDateTime |  |  | datetime
Exported | ExpStatus | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Company text | FtgText | ztString | 40 |  | varchar
Posting date | HbUpDat | ztDate |  |  | datetime
Prev posting date | HbUpDat_OLD | ztDate |  |  | datetime
Huvudboksdatum | HbUpDatTid | ztDateTime |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Journal group | JourGrupp | ZtLong | 9 |  | int
Jnr konc.sammanst | JournNrKoncSam | ZtLong | 5 |  | int
Credit amount | krebel | ZtBaseCurrAmount | 14 | 2 | money
Voucher no. type | ManVer | ztInteger | 2 |  | smallint
Preliminary voucher | OldVerNr | Jeeves_VchrNo | 9 |  | bigint
OLE-1 | ole1 | ztString | 255 |  | varchar
Print date | p_utskr_dat | ztDate |  |  | datetime
Quantity PDM | PdmCount | ZtLong | 10 |  | int
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Prel posting | PrelKonteras | ztBoolean |  |  | char
Translation -> balance acct | ProjTran2BalansId | ztString | 8 |  | varchar
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Time sqlcmd->trg start | SQLCmd2EnterTrg | ZtLong | 10 |  | int
Exchg rate date | valdat | ztDate |  |  | datetime
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
VAT/tax mark | VATMark | ztBoolean |  |  | char
Voucher amount | VerBel | ZtBaseCurrAmount | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Voucher no. group | VerNrGrupp | ztString | 6 |  | varchar
Voucher text | VerText | ztString | 60 |  | varchar
Voucher status | VtStatus | ztInteger | 2 |  | smallint
Deleted | zDeleted | ztInteger | 1 |  | smallint

    This table is the main table in the following programs:

    Program: bVt Print ledger/journal

    Program: IntInv Entry internal VAT/tax invoice, Sales

    Program: rvt Voucher list by number

    Program: rvtbfd Voucher list/accounting date

    Program: rVtBfdF Journal

    Program: rVtK Voucher list, acct

    Program: rvts Voucher list simple

    Program: rVtT Voucher list, voucher, text

    Program: Vchr Voucher entry

    Program: vt Voucher entry


Voucher header log (vtl)

Log of changes to the voucher header.
Data in the voucher header.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Reversal period | AterBokasPeriod | ztInteger | 4 |  | smallint
Per bok.ver s/t | AterBokasST | ztInteger | 1 |  | smallint
Reversal voucher no. | AterBokasVerNr | Jeeves_VchrNo | 9 |  | bigint
Approved by | AttestSign | ztString | 6 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Debit amount | debbel | ZtBaseCurrAmount | 14 | 2 | money
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Posting date | HbUpDat | ztDate |  |  | datetime
Prev posting date | HbUpDat_OLD | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Jnr konc.sammanst | JournNrKoncSam | ZtLong | 5 |  | int
Credit amount | krebel | ZtBaseCurrAmount | 14 | 2 | money
Voucher no. type | ManVer | ztInteger | 2 |  | smallint
Preliminary voucher | OldVerNr | Jeeves_VchrNo | 9 |  | bigint
OLE-1 | ole1 | ztString | 255 |  | varchar
Print date | p_utskr_dat | ztDate |  |  | datetime
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Date/time | StrDateTime | ztString | 28 |  | varchar
Exchg rate date | valdat | ztDate |  |  | datetime
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Voucher amount | VerBel | ZtBaseCurrAmount | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Voucher no. group | VerNrGrupp | ztString | 6 |  | varchar
Voucher text | VerText | ztString | 60 |  | varchar
Voucher status | VtStatus | ztInteger | 2 |  | smallint
Deleted | zDeleted | ztInteger | 1 |  | smallint


Voucher header VIEW (vvt)

View of the vt table (Voucher header).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Posting template | AutoRegel | ztString | 4 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Posting date | HbUpDat | ztDate |  |  | datetime
Integration source | IntSource | ztInteger | 3 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Voucher amount | VerBel | ZtBaseCurrAmount | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Voucher text | VerText | ztString | 60 |  | varchar
Deleted | zDeleted | ztInteger | 1 |  | smallint


Voucher no. group (grpv)

Definition of existing groups for voucher numbering.

Use this function if you want to retrieve voucher numbers from different intervals depending on the login ID (sy2) or attest ID (pr). Starting with version 9, this can also be done by supplier and supplier invoice.

If the field is omitted, the voucher number interval that is defined for the voucher type is used (integration source).

For more information see Help for program/table Voucher number series/group (program Nrxa7/tabell Rxa7).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approval limit | Attestlimit | ZtBaseCurrAmount | 18 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Vchrnogrp | VernrgrpBeskr | ztString | 35 |  | varchar
Voucher no. group | vernrgrupp | ztString | 6 |  | varchar

    This table is the main table in the following programs:

    Program: grpv Voucher number groups


Voucher number series (rxa7)

Voucher number series per group, which can be used for different purposes (different integration sources). These number series must lie within the number interval of the integration source in question, and only work when voucher numbers are retrieved automatically. When voucher numbers are entered manually they are only checked against the number series for the integration source, not for the group.

If you use voucher number series per group, all users should be part of a group. This is because the system always searches for the highest number used for an integration source for users not part of a group. This could, for example, mean that the number for a user not belonging to a group is taken from group A that has a number series in the upper range.

A user can belong to one group (specified in the program System data person (xsy2) and Accounting users (pr)).

In Jeeves there are pre-defined integration sources for the different sub-systems. See Help for the program Integration sources (xxa6) for information about these.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Max vouch no | MaxVerNr | Jeeves_VchrNo | 9 |  | bigint
Min. vouch.no | MinVerNr | Jeeves_VchrNo | 9 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Voucher no. group | VerNrGrupp | ztString | 6 |  | varchar

    This table is the main table in the following programs:

    Program: nrxa7 Voucher number series/group


Voucher numbering types (xmv)

Internal definitions specifying a type of numbering for vouchers. (Voucher number is set automatically if no number is entered manually.)

The following standard records exist. Do not alter/delete:

Voucher no. type (manver) | Voucher no. type (manvertext)
1 | Manual
2 | Automatic

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Voucher no. type | manver | ztInteger | 2 |  | smallint
Voucher no. type | manvertext | ztString | 50 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xmv Voucher numbering


Voucher posting type (xkkt)

Definition of posting types that are used to specify how vouchers are to be posted.

The following standard records exist. Do not alter/delete:

Posting type (verkonttyp) | Posting type (verkonttypB) | Description
0 | Supplement | Means that the specified posting is supplemented with new account segments.
1 | Supplement and post | Means that the specified posting must be supplemented with new account, segments and new posting is done that is counter-booked against the voucher source.
2 | Allocate voucher row | Means that the specified posting is allocated without recording the source posting, i.e. two new voucher rows are created, each with their share of the source posting.
3 | Rebook debit amount | Means that for a debit amount on a specified posting, the original posting is canceled and a new voucher row is created with the debit amount and a new account. The posting type is used, for example, to post exchange rate differences when you want to use a separate account for losses on exchange. (Introduced in version 8.5.)
4 | Rebook credit amount | Means that for a credit amount on a specified posting, the original posting is canceled and a new voucher row is created with the credit amount and a new account. The posting type is used, for example, to post exchange rate differences when you want to use a separate account for gains on exchange. (Introduced in version 8.5.)
5 | Allocation of revenues, customer invoice | This means that when coding customer invoices, the revenue posting is already allocated when data for the vouchers is being created. Basic data for the vouchers is stored in the FHVT table. The basic coding of the revenue is performed based on the coding definitions of the invoice details but the row can be allocated based on specified percentages to specified accounts, cost centres etc. Any amount not allocated will remain with the basic coding.
10 | VAT/tax definition |
11 | Fictitious row for VAT/tax report |

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Posting type | verkonttyp | ztInteger | 5 |  | smallint
Posting type | verkonttypB | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: xkkt Auto posting types, vouchers


Voucher row status (x1t)

Internal definitions of status codes which describe the status of voucher rows, i.e. whether everything is OK or something has gone wrong on creating postings.

The following standard records exist. Do not alter/delete:

Row status (VrStatus) | Row status (VrStatusBeskrivning)
0 | Everything OK!!
1 | Invalid approval signature
2 | Wrong segment 2 according to approval si
10 | 10: Zero row (Debit=0 and Credit=0)
41 | You must enter segment 1
42 | You must enter segment 2
43 | You must enter segment 3
44 | You must enter segment 4
45 | You must enter segment 5
46 | You must enter segment 6
47 | You must enter segment 7
48 | You must enter segment 8
56 | You must enter a project
59 | You must enter a quantity
62 | You cannot enter segment 2
63 | You cannot enter segment 3
64 | You cannot enter segment 4
65 | You cannot enter segment 5
66 | You cannot enter segment 6
67 | You cannot enter segment 7
68 | You cannot enter segment 8
76 | You cannot enter a project
79 | You cannot enter a quantity
81 | Segment 1 cannot be posted
82 | Segment 2 cannot be posted
83 | Segment 3 cannot be posted
84 | Segment 4 cannot be posted
85 | Segment 5 cannot be posted
86 | Segment 6 cannot be posted
87 | Segment 7 cannot be posted
88 | Segment 8 cannot be posted
89 | Cannot post project/incorrect project
90 | Account segment 1 not within date interv
91 | Account segment 2 not within date interv
92 | Account segment 3 not within date interv
97 | Account segment 7 not within date interv
101 | No account entered
102 | Wrong segment 2 according to account 1
103 | Wrong segment 3 according to account 1
104 | Wrong segment 4 according to account 1
105 | Wrong segment 5 according to account 1
106 | Wrong segment 6 according to account 1
107 | Wrong segment 7 according to account 1
109 | Incorrect project according to Acct 1
111 | GO markup or material posting not posted
201 | Wrong segment 1 according to account 2
202 | Segment 2 not found
203 | Wrong segment 3 according to account 2
204 | Wrong segment 4 according to account 2
205 | Wrong segment 5 according to account 2
206 | Wrong segment 6 according to account 2
207 | Wrong segment 7 according to account 2
209 | Incorrect project according to Acct 2
301 | Wrong segment 1 according to account 3
302 | Wrong segment 2 according to account 3
303 | Segment 3 not found
304 | Wrong segment 4 according to account 3
305 | Wrong segment 5 according to account 3
306 | Wrong segment 6 according to account 3
307 | Wrong segment 7 according to account 3
309 | Incorrect project according to Acct 3
401 | Wrong segment 1 according to account 4
402 | Wrong segment 2 according to account 4
403 | Wrong segment 3 according to account 4
404 | Segment 4 not found
405 | Wrong segment 5 according to account 4
406 | Wrong segment 6 according to account 4
407 | Wrong segment 7 according to account 4
409 | Incorrect project according to Acct 4
501 | Wrong segment 1 according to account 5
502 | Wrong segment 2 according to account 5
503 | Wrong segment 3 according to account 5
504 | Wrong segment 4 according to account 5
505 | Segment 5 not found
506 | Wrong segment 6 according to account 5
507 | Wrong segment 7 according to account 5
509 | Incorrect project according to Acct 5
601 | Wrong segment 1 according to account 6
602 | Wrong segment 2 according to account 6
603 | Wrong segment 3 according to account 6
604 | Wrong segment 4 according to account 6
605 | Wrong segment 5 according to account 6
606 | Segment 6 not found
607 | Wrong segment 7 according to account 6
609 | Incorrect project according to Acct 6
701 | Wrong segment 1 according to account 7
702 | Wrong segment 2 according to account 7
703 | Wrong segment 3 according to account 7
704 | Wrong segment 4 according to account 7
705 | Wrong segment 5 according to account 7
706 | Wrong segment 6 according to account 7
707 | Segment 7 not found
709 | Incorrect project according to Acct 7
800 | Tax code on account not correct
811 | Incorrect acct no according to approval
812 | Incorrect acct 2 according to approval s
813 | Incorrect acct 3 according to approval s
814 | Incorrect acct 4 according to approval s
815 | Incorrect acct 5 according to approval s
816 | Incorrect acct 6 according to approval s
817 | Incorrect acct 7 according to approval s
819 | Incorrect project according to approval
901 | Cost centre elimination missing
909 | No project entered
910 | Account type=92 but no item specified
911 | VAT/tax code not allowed on account

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Row status | VrStatus | ztInteger | 4 |  | smallint
Row status | VrStatusBeskrivning | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: xX1t Voucher row status


Voucher rows (vr)

Voucher rows in the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Approved by | AttestSign | ztString | 6 |  | varchar
Orderer approval | Attestsign2 | ztString | 6 |  | varchar
Posting template | AutoRegel | ztString | 4 |  | varchar
Avräkningskonto | AvrKtoKod | ztBoolean |  |  | char
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
JournalNo. | BilagJournNr | ZtLong | 7 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
Bundle no. | BuntNr | ZtLong | 9 |  | int
Created by object | CreatedByDbObject | ztString | 60 |  | varchar
VAT/tax GL date | DateOfTaxSupply | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Dispatch date | Deliverydate | ztDate |  |  | datetime
Document ID | docnumid | ztString | 30 |  | varchar
Document | DocPicture | ztString | 40 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
EMU conv date | EMU_Convert_DateAndTime | ztDate |  |  | datetime
Chronological vouch no. | EntryNo_GL | ZtLong | 9 |  | int
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no., advance | FaktNrForskott | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Transaction type | Foringskod | ztInteger | 3 |  | smallint
From template | FromAutoPostTempl | ztBoolean |  |  | char
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Company text | Ftgtext | ztString | 40 |  | varchar
GL revaluation date | GLRevaluationDate | ztDateTime |  |  | datetime
Posting date | HbUpDat | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Start trigger | Ins_DT_MilliSecond | ztDateTime |  |  | datetime
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Fixed asset no | Inventarie | ZtLong | 10 |  | int
Component fixed asset | InventariePos | ztInteger | 5 |  | smallint
Fixed asset type | inventarietyp | ztInteger | 5 |  | smallint
Journal group | JourGrupp | ZtLong | 9 |  | int
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Shortcut | KortKodVerRad | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Cost centre (elim) | KostStalleKodEliminera | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Account type | KtoTyp | ztInteger | 3 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Seq no. for VR split | LopNrSplittVr | ztInteger | 5 |  | smallint
Tax date | MomsDatum | ztDate |  |  | datetime
Tax base amount | MomsGrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
VAT/tax rate | MomsSats | ZtDecimal73 | 6 | 2 | decimal
Contra account | MotKtoNr | ztString | 8 |  | varchar
Preliminary voucher | OldVerNr | Jeeves_VchrNo | 9 |  | bigint
@zPrompt=null | origin | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Start trigger | QQ_Ins_Trg_Start | ztDateTime |  |  | datetime
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Reference number | ReferensNr | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Time sqlcmd->trg start | SQLCmd2EnterTrg | ZtLong | 10 |  | int
Upd charge basis | UpdDeb | ztBoolean |  |  | char
Date upd chrg basis | UpdDebDatum | ztDate |  |  | datetime
Orig account no. | UrsprungsKtoNr | ztString | 8 |  | varchar
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
VAT/tax type | VAt_Type | ztInteger | 4 |  | smallint
Affect Tax calculation | VATCalcCheck | ztBoolean |  |  | char
VAT/tax grid box | VATgrating | ztString | 20 |  | varchar
Tax period | VATperiod | ztString | 8 |  | varchar
VAT/tax stmt status | VATStatus | ztString | 1 |  | varchar
VAT/tax trans type | VATtransactionType | ztString | 5 |  | varchar
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Voucher reference number | VoucherRefNo | ztInteger | 5 |  | smallint
Flag text | vr_Pointage | ztString | 255 |  | varchar
Row status | VrStatus | ztInteger | 4 |  | smallint
Statuskod på rad | VrStMark | ztInteger | 2 |  | smallint
Uppdateringskod | VrUpdateCode | ztInteger | 1 |  | smallint
Voucher row text | VrVerText | ztString | 60 |  | varchar

    This table is the main table in the following programs:

    Program: vAllaVr Show all voucher rows

    Program: vejupdvr Show non-updated vouchers

    Program: ViewUpdRows Show updated vouchers

    Program: vvr Show updated vouchers

    Program: vvr_sy2 Show balance updated voucher rows


Voucher rows, LOG (vrl)

LOG OF CHANGES OF OPENED VOUCHERS.
Voucher rows in the General Ledger.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approved by | AttestSign | ztString | 6 |  | varchar
Avräkningskonto | AvrKtoKod | ztBoolean |  |  | char
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
Bundle no. | BuntNr | ZtLong | 9 |  | int
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Text | Edit | ztBlob | 1 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Posting date | HbUpDat | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Shortcut | KortKodVerRad | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Account type | KtoTyp | ztInteger | 3 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Preliminary voucher | OldVerNr | Jeeves_VchrNo | 9 |  | bigint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Reference number | ReferensNr | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Type of changes | TypeOfChange | ztString | 1 |  | varchar
Orig account no. | UrsprungsKtoNr | ztString | 8 |  | varchar
Exchg rate date | ValDat | ztDate |  |  | datetime
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint
Statuskod på rad | VrStMark | ztInteger | 2 |  | smallint
Uppdateringskod | VrUpdateCode | ztInteger | 1 |  | smallint
Voucher row text | VrVerText | ztString | 60 |  | varchar


Voucher rows, tax statement (taxt)

Tax statement's voucher rows. (Slovakian adaptation).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approved by | AttestSign | ztString | 6 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
VAT/tax GL date | DateOfTaxSupply | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Text | Edit | ztBlob | 1 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Posting date | HbUpDat | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Fixed asset no | Inventarie | ZtLong | 10 |  | int
Component fixed asset | InventariePos | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Account type | KtoTyp | ztInteger | 3 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Tax amount | MomsBelopp | ZtBaseCurrAmount | 14 | 2 | money
Tax base amount | MomsGrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Affect Tax calculation | VATCalcCheck | ztBoolean |  |  | char
Cell no. | VATcellno | ztInteger | 5 |  | smallint
Cell no., base | VATcellno_basis | ztInteger | 5 |  | smallint
VAT/tax parameter | VATParameter | ztInteger | 4 |  | smallint
Tax period | VATPeriod | ztString | 8 |  | varchar
Report EU period | VATReportEUPeriod | ztString | 8 |  | varchar
VAT/tax stmt status | VATStatus | ztString | 1 |  | varchar
Correction no. | VATtaxcorrectionno | ztInteger | 2 |  | smallint
Tax period | VATtaxperiod | ztInteger | 2 |  | smallint
Tax year | VATtaxyear | ztInteger | 5 |  | smallint
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint
Statuskod på rad | VrStMark | ztInteger | 2 |  | smallint
Uppdateringskod | VrUpdateCode | ztInteger | 1 |  | smallint
Voucher row text | VrVerText | ztString | 60 |  | varchar

    This table is the main table in the following programs:

    Program: Taxt Tax statement basis


Voucher rows, tax statement history (taxthist)

History tax statement's voucher rows. (Slovakian adaptation).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Approved by | AttestSign | ztString | 6 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Supplier invoice no. | BestRkgNr | ztString | 25 |  | varchar
Accounting date | BokfDat | ztDate |  |  | datetime
VAT/tax GL date | DateOfTaxSupply | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Text | Edit | ztBlob | 1 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Posting date | HbUpDat | ztDate |  |  | datetime
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Fixed asset no | Inventarie | ZtLong | 10 |  | int
Component fixed asset | InventariePos | ztInteger | 5 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
S8 | K8 | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
Account | KtoNr | ztString | 8 |  | varchar
Account type | KtoTyp | ztInteger | 3 |  | smallint
Payer, company ID | KundBetalareNr | ztCompanyNo | 20 |  | varchar
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Tax amount | MomsBelopp | ZtBaseCurrAmount | 14 | 2 | money
Tax base amount | MomsGrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Sequence no. | RowNo | ZtLong | 6 |  | int
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Affect Tax calculation | VATCalcCheck | ztBoolean |  |  | char
Cell no. | VATcellno | ztInteger | 5 |  | smallint
Cell no., base | VATcellno_basis | ztInteger | 5 |  | smallint
VAT/tax parameter | VATParameter | ztInteger | 4 |  | smallint
Tax period | VATPeriod | ztString | 8 |  | varchar
Report EU period | VATReportEUPeriod | ztString | 8 |  | varchar
VAT/tax stmt status | VATStatus | ztString | 1 |  | varchar
Correction no. | VATtaxcorrectionno | ztInteger | 2 |  | smallint
Tax period | VATtaxperiod | ztInteger | 2 |  | smallint
Tax year | VATtaxyear | ztInteger | 5 |  | smallint
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Row status | VrStatus | ztInteger | 4 |  | smallint
Statuskod på rad | VrStMark | ztInteger | 2 |  | smallint
Uppdateringskod | VrUpdateCode | ztInteger | 1 |  | smallint
Voucher row text | VrVerText | ztString | 60 |  | varchar


Voucher series per period integration sources (rxa6p)

Definition of desired voucher number series per fiscal year and period for integration source 199.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Max vouch no | MaxVerNr | Jeeves_VchrNo | 9 |  | bigint
Min. vouch.no | MinVerNr | Jeeves_VchrNo | 9 |  | bigint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint


Voucher series/integration source (rxa6)

Definition of desired voucher number series per fiscal year and voucher type (i.e. integration source which describes the source for the voucher). Voucher numbers are allocated from the number series with the highest number for the integration sources which do not have a specified number series.

Make sure that number series do not overlap when you enter them.

You can divide a voucher number series into underlying number series for different user groups. You do this in the program node 'Voucher no. series/group'. Read more in the help for 'Group voucher no. series/integr srce' (program Nrxa7 or table Rxa7) about the what is needed for this to function.

Whether the voucher numbering will be done automatically or manually is determined by the value in the field 'Voucher no. type' (manver) which is defined for the whole company and/or per user. The value for the user has the highest priority. If you choose manual numbering, the numbering is still done automatically if you do not specify a voucher number.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Integration source | IntSource | ztInteger | 3 |  | smallint
Max vouch no | MaxVerNr | Jeeves_VchrNo | 9 |  | bigint
Min. vouch.no | MinVerNr | Jeeves_VchrNo | 9 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint

    This table is the main table in the following programs:

    Program: xRxa6 Voucher number series


Voucher status (x1s)

Table of different statuses that a voucher header can be given.

The following standard records exist. Do not alter/delete:

Voucher status (VtStatus) | Voucher status (VtBeskrivning)
0 | Entry in progress
1 | Entry complete
2 | Balance locked, auto posting
8 | Balance update complete
10 | Diff debit-credit
11 | Other error, account terms
51 | Incorrect fiscal year
52 | Incorrect period
53 | Incorrect entry date
56 | Incorrect approval signature

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Description | Beskrivning | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Voucher status | VtBeskrivning | ztString | 50 |  | varchar
Voucher status | VtStatus | ztInteger | 2 |  | smallint

    This table is the main table in the following programs:

    Program: xX1s Voucher status


Vouchers VIEW (vvr)

View of the vr table (Voucher rows).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Reversal period | AterBokasPeriod | ztInteger | 4 |  | smallint
JournalNo. | BilagJournNr | ZtLong | 7 |  | int
Accounting date | BokfDat | ztDate |  |  | datetime
Bundle no. | BuntNr | ZtLong | 9 |  | int
VAT/tax GL date | DateOfTaxSupply | ztDate |  |  | datetime
Debit amount | DebBel | ZtBaseCurrAmount | 14 | 2 | money
Debit/credit | DebKre | ztchar | 1 |  | char
Text | Edit | ztBlob | 1 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Posting date | HbUpDat | ztDate |  |  | datetime
Integration source | IntSource | ztInteger | 3 |  | smallint
S4 | K4 | ztString | 8 |  | varchar
From S4 | K4From | ztString | 8 |  | varchar
To S4 | K4Tom | ztString | 8 |  | varchar
S5 | K5 | ztString | 8 |  | varchar
From S5 | K5From | ztString | 8 |  | varchar
To S5 | K5Tom | ztString | 8 |  | varchar
S6 | K6 | ztString | 8 |  | varchar
From S6 | K6From | ztString | 8 |  | varchar
To S6 | K6Tom | ztString | 8 |  | varchar
S7 | K7 | ztString | 8 |  | varchar
From S7 | K7From | ztString | 8 |  | varchar
To S7 | K7Tom | ztString | 8 |  | varchar
Fr o m K8 | K8From | ztString | 8 |  | varchar
To S8 | K8Tom | ztString | 8 |  | varchar
From CU | KbarFrom | ztString | 8 |  | varchar
To S3 | KbarTom | ztString | 8 |  | varchar
Cost unit | Kostbar | ztString | 8 |  | varchar
Cost centre | KostStalleKod | ztString | 8 |  | varchar
Credit amount | KreBel | ZtBaseCurrAmount | 14 | 2 | money
From CC | KstFrom | ztString | 8 |  | varchar
To CC | KstTom | ztString | 8 |  | varchar
From account | KtoFrom | ztString | 8 |  | varchar
Account | KtoNr | ztString | 8 |  | varchar
To account | KtoTom | ztString | 8 |  | varchar
Account type | ktotyp | ztInteger | 3 |  | smallint
Quantity | Kvantitet | ztFloat | 9 | 2 | float
Tax base amount | MomsGrundBelopp | ZtBaseCurrAmount | 14 | 2 | money
VAT/tax code | MomsKod | ztInteger | 5 |  | smallint
Preliminary voucher | OldVerNr | Jeeves_VchrNo | 9 |  | bigint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
From Proj | PrjFrom | ztString | 30 |  | varchar
ToPrj | PrjTom | ztString | 30 |  | varchar
Project ID | ProjCode | ztString | 10 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Fiscal year | Redovisnar | ztInteger | 4 |  | smallint
Reference number | Referensnr | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDT | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDT | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Affect Tax calculation | VATCalcCheck | ztBoolean |  |  | char
Amount, curr | VbBelopp | ztMoney | 14 | 2 | money
Voucher no. | VerNr | Jeeves_VchrNo | 9 |  | bigint
Uppdateringskod | VrUpdateCode | ztInteger | 1 |  | smallint
Voucher row text | VrVerText | ztString | 60 |  | varchar


Wage cost/activity (pk)

Calculated costs by employee and activity.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Unit code | EnhetsKod | ztString | 4 |  | varchar
Reported activity | EventRpKod | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Est hourly cost | KalkKostManTim | ZtBaseCurrAmount | 14 | 2 | money
Signature | PersSign | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar


Warehouse door (port)

Gate to inventory.
Gates to inventory are defined in this table.
Bins can be linked to a gate (or door area, see another table).
Planned events (deliveries) can be planned to a gate (or door area).
***** Not used in Jeeves standard *****

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Gate | Port | ztString | 6 |  | varchar
Gate descr | PortBeskr | ztString | 50 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: port Warehouse door


Web document structure (webd)

Code for web structure record.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Icon (Closed) | IkonClosed | ztString | 25 |  | varchar
Icon (open) | IkonOpen | ztString | 25 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Web structure | WebDocCode | ztInteger | 5 |  | smallint
Web structure | WebDocDescr | ztString | 50 |  | varchar


Web log (WEBL)

Table showing all logins in Jeeves E-commerce system, including unsuccessful attempts.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
ID | ConnSQLIDkpw | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | ftgkontaktnr | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Login time | logindt | ztDateTime |  |  | datetime
Logoff time | logoutdt | ztDateTime |  |  | datetime
Order no. | ordernr | Jeeves_SONo | 8 |  | bigint
This field is used in the table as follows: |
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Session ID | sessionid | ztString | 35 |  | varchar
Web remote address | webremoteaddr | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: webl Web log


Web login profile (WEBP)

Table of login profiles for web users.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allow posting, inquiry | AllowPostOnInquiry | ztBoolean |  |  | char
Allow purchase | allowpurchase | ztBoolean |  |  | char
Allow view price | allowviewprice | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | lagstalle | ztString | 2 |  | varchar
This field is used in the table as follows: |
Block posting | NoSaveVrWithError | ztBoolean |  |  | char
Only prch from prclist | onlyfrompl | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Profile description | ProfilBeskr | ztString | 30 |  | varchar
Login profile | ProfilKod | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Active from date | ValidFromDate | ztDate |  |  | datetime
This field is used in the table as follows: |
Active to date | ValidToDate | ztDate |  |  | datetime
This field is used in the table as follows: |
Warning, posting diff | warnvrdiff | ztBoolean |  |  | char
Allow addn point of deliv | WebAddDeliveryAddress | ztBoolean |  |  | char
Allow addn subsidiary | webaddsubsidiary | ztBoolean |  |  | char
Allow addn users | WebAddUser | ztBoolean |  |  | char
Web tree ID | WebTreeID | ztString | 25 |  | varchar

    This table is the main table in the following programs:

    Program: webp Login profiles


Web messages (webn)

Numeric identity for current record in the database. (Field obtains its value automatically via SQL server's IDENTITY function.)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Header ID | CaptionID | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | sqlidentity | ZtLong | 10 |  | int
TextID | TextID | ZtLong | 10 |  | int
Active from date | ValidFromDate | ztDate |  |  | datetime
Active to date | ValidToDate | ztDate |  |  | datetime

    This table is the main table in the following programs:

    Program: webn Web document


Web order (WEBO)

This table contains all customer and service orders that have been received via the web.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order no. | Ordernr | Jeeves_SONo | 8 |  | bigint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Serv.order no | Servordernr | Jeeves_SONo | 9 |  | bigint
Session ID | sessionid | ztString | 35 |  | varchar


Web sessions (WEBS)

Table of logged-in web users.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Purch requisition no. | bianr | ZtLong | 10 |  | int
ID | ConnSQLIDKpw | ZtLong | 10 |  | int
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | ftgkontaktnr | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Subsidiary | FtgNrDtr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchasing role | inkopsroll | ztInteger | 4 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
JeevesParamString | JeevesParamString | ztString | 255 |  | varchar
Inventory location | LagStalle | ztString | 2 |  | varchar
Template company | MallForetagKod | ztInteger | 5 |  | smallint
This field is used in the table as follows: |
Order no. | ordernr | Jeeves_SONo | 8 |  | bigint
This field is used in the table as follows: |
Signature | PersSign | ztString | 30 |  | varchar
Signature | PersSign5 | ztString | 6 |  | varchar
This field is used in the table as follows: |
Price list | prislista | ztInteger | 5 |  | smallint
Login profile | ProfilKod | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Salesperson | saljare | ztString | 6 |  | varchar
Serv.order no | ServOrderNr | Jeeves_SONo | 9 |  | bigint
This field is used in the table as follows: |
Session ID | SessionID | ztString | 35 |  | varchar
Language | sprakkod | ztInteger | 3 |  | smallint
Currency | valkod | ztString | 3 |  | varchar
Exchange rate | valkurs | ZtCurrencyRate | 15 | 7 | decimal
Web remote address | webremoteaddr | ztString | 30 |  | varchar

    This table is the main table in the following programs:

    Program: webs Web sessions


Web users (kpw)

Table of web users tied to contacts and companies. This can be used to store user-specific information.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Login ID/name | DbLoginId | ztString | 128 |  | varchar
This field is used in the table as follows: |
Company | ForetagKod | ztInteger | 4 |  | smallint
Contact no. | FtgKontaktNr | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
This field is used in the table as follows: |
Log-in attempt | LoginAttempts | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Signature | Perssign5 | ztString | 6 |  | varchar
This field is used in the table as follows: |
Login profile | ProfilKod | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Valid to use | ValidToUse | ztBoolean |  |  | char
This field is used in the table as follows: |
Allow addn point of deliv | WebAddDeliveryAddress | ztBoolean |  |  | char
Allow addn subsidiary | webaddsubsidiary | ztBoolean |  |  | char
Allow addn users | WebAddUser | ztBoolean |  |  | char
NoLogins | weblogincount | ZtLong | 6 |  | int
Web remote address | WebRemoteAddr | ztString | 30 |  | varchar
Security level | WebSecurityLevel | ZtLong | 10 |  | int
Web tree ID | WebTreeID | ztString | 25 |  | varchar
User name | WebUserName | ztString | 50 |  | varchar
Password | WebUserPwd | ztString | 20 |  | varchar

    This table is the main table in the following programs:

    Program: kpw Web users


Who, DB process (vswh)

Process ID in SQL Server. ((SQL Server Books On Line master SysProcesses))

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Command | DbCmd | ztString | 16 |  | varchar
HostName | DbHostName | ztString | 10 |  | varchar
DB login sign | DBLogInSign | ztString | 8 |  | varchar
Database | DbNameWho | ztString | 30 |  | varchar
Program ID (data name) | DbProgramName | ztString | 60 |  | varchar
User name | DbUserName | ztString | 30 |  | varchar
Program ID | JeevesPgmId | ztString | 8 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
DB lib process ID | ProcIdDBLib | ZtLong | 10 |  | int
DB lib proc ID 1:a | ProcIdDBLibPgmId | ZtLong | 10 |  | int
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Process ID | spid | ZtLong | 5 |  | smallint
Waiting for process | SpidBlocked | ZtLong | 4 |  | smallint
Process ID, pgm | spidpgm | ZtLong | 5 |  | int
Process status | SpidStatus | ztString | 30 |  | varchar
WaitTime | SQLServ_spid_WaitTime | ZtLong | 10 |  | bigint
Text/info | x255 | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xVswh DB processes (sp_who)


WMS User (WMS_User)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Default inv.location | DefaultLagStalle | ztBoolean |  |  | char
Default printer | DefaultPrinter | ztString | 20 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Mobile unit user | IsMobileUnitUser | ztBoolean |  |  | char
Inventory location | LagStalle | ztString | 2 |  | varchar
Number of labels | NumberOfLabels | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Printer | Printer | ztString | 20 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: WMS_User WMS User


Work assignment (WMS_MU_CurrTask)

Alphanumeric code for inventory location. An inventory location can be a part of a warehouse or an entire warehouse.

Stock balances, reservation totals, usage, forecasts, ABC codes, order points, etc., are stored per inventory location.

From version 10 pre-release, cost price data and cost prices can be defined/stored per inventory location. If this field shows an asterisk (*) it implies that the record in question, for example a cost price calculation record (arkh), applies to a group of inventory locations.

Default inventory location can be specified for the whole company in the System file, own co, program (sy), per user in the System data person, own company program (Xsy2) or per customer or item. Normally, the latter have higher priority. If, however, you use Jeeves Product Variants, the user (Xsy2) controls the default inventory location. A default value is suggested at customer order entry and purchase order/agreement entry.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Check digits | CheckSum | ztInteger | 3 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Inventory location | LagStalle | ztString | 2 |  | varchar
Invtry trans. type | LagTransTyp | ztInteger | 3 |  | smallint
Mobile unit | MobileUnit | ztString | 5 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Picked qty | PickedQty | ZtQty | 14 | 2 | decimal
Verify TU | PickedTUPalletId | ztString | 35 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Remaining qty, SKU | RemainingQty | ZtQty | 14 | 2 | decimal
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
ID | TaskIId | ZtLong | 9 |  | int


Work group (alag)

Definition of the different work methods in your own workshop. The information is used, for example, in the workload analyses and planning.

Jeeves has the following levels for workload analysis:
- Total
- Product area
- Foreman area
- Work group
- Manufacturing group

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Staffing quantity | antbemanning | ztFloat | 6 | 2 | float
Work group | ArbetsLag | ztString | 6 |  | varchar
Work group designation | ArbetsLagB | ztString | 40 |  | varchar
Workload against ceiling | BelaggningMotTak | ztBoolean |  |  | char
One requisition within order | EnIAperALagInomTH | ztBoolean |  |  | char
Company | ForetagKod | ztInteger | 4 |  | smallint
Foreman area | FormansOmrade | ztString | 6 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Manufacturing resource ID | ManufRes_Id | ZtLong | 10 |  | int
Signature | PersSign | ztString | 30 |  | varchar
Product area | ProduktOmrade | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Indirect job/labour | veOvrigtjobb | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: alag Shopfloor work group


Work order number series (thnr)

Number series for work/manufacturing orders.
The number series to be used can be specified on the manufacturing order.
The number series can also be entered in the manufacturing order type, in which case it becomes the default on the manufacturing order.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
MO number series | AoNrSerie | ztInteger | 5 |  | smallint
MO number series | AoNrSerieBeskr | ztString | 40 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
From manuf.order no. | FromAoNr | Jeeves_MONo | 7 |  | bigint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
To manuf.order no. | TomAoNr | Jeeves_MONo | 7 |  | bigint

    This table is the main table in the following programs:

    Program: ThNr Manufacturing order number series


Work Schedule (AttR_schtempl)

Holds work schedules and descriptions.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Work schedule template | AttRWorkScheduleTemplate | ztString | 6 |  | varchar
Template description | AttRWorkScheduleTemplateDescr | ztString | 100 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_schtempl Work schedule templates


Work Schedule Group (AttR_schgrp)

Work schedule groups (with descriptions).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Schedule group | AttRWorkScheduleGrp | ztString | 6 |  | varchar
Work schedule descr | AttRWorkScheduleGrpDescr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_schgrp Work schedule groups


Work Schedule Rows (AttR_schtemplrow)

Rows in work schedule.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Day schedule | AttRDaySchedule | ztString | 6 |  | varchar
From weekday | AttRFromWeekday | ztInteger | 5 |  | smallint
Work schedule template | AttRWorkScheduleTemplate | ztString | 6 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | rowupdatedcols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_schtemplrow Work schedule template rows


Work Schedules (AttR_ws)

Holds records generated per employee and/or schedule group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Day schedule | AttRDaySchedule | ztString | 6 |  | varchar
Deviant day schedule | AttRDevDaySchedule | ztString | 6 |  | varchar
Work schedule date | AttRWorkScheduleDat | ztDate |  |  | datetime
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | Perssign2 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: AttR_ws Work schedules


Work table -> File (sthu)

Export definitions for Jeeves' general import/export function.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Command shell post | CmdShellPost | ztString | 255 |  | varchar
Command shell pre | CmdShellPre | ztString | 255 |  | varchar
Database (SQL) ID | DataBas | ztString | 30 |  | varchar
DB-term/-expression 2 | DbTermname2 | ztString | 255 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Payment route | InbetalningsVag | ztString | 6 |  | varchar
Name of input/output data file | InputFileName | ztString | 255 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Note | KortNotering | ztString | 255 |  | varchar
Procedure, after | MatrixPostExecProc | ztString | 255 |  | varchar
Procedure, before | MatrixPreExecProc | ztString | 255 |  | varchar
Sorting/weighting by | OrderByColumns | ztString | 255 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Payment route | UtbetalningsVag | ztString | 6 |  | varchar
Value term table | VardeTabId1 | ztString | 255 |  | varchar
Text/info | x255 | ztString | 255 |  | varchar
Where | YndWhere | ztString | 255 |  | varchar
Delete at new loading | YndzDeleteRecv | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: sthu Export Jeeves data -> file


Work table for changed BOMs (wbpc)

Work table for items whose BOM or operation list has been changed that affect manufacturing orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
PO no. | BestNr | Jeeves_PONo | 6 |  | bigint
Row no. in PO | BestRadNr | ztInteger | 5 |  | int
PO backorder no. | BestRestNr | ztInteger | 4 |  | int
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar


Work table for changed BOMs (wsrc)

Work table for items whose BOM or operation list has been changed that affect manufacturing orders.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Mfg/Works order no. | AoNr | Jeeves_MONo | 7 |  | bigint
Row | AoPos | ztInteger | 4 |  | int
Item no. | ArtNr | ztString | 30 |  | varchar
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
BOM for item | StycklistaTillArtNr | ztString | 30 |  | varchar


Work table for loading scanned supplier invoices (Pvlrin)

A help table used when loading scanned supp.invoice via the program Import conversion (sthi)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Reference text | ReferensText | ztString | 255 |  | varchar
This field is used in the table as follows: |
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Text/info | x255 | ztString | 255 |  | varchar
Text/info | x255_2 | ztString | 255 |  | varchar
Text 3 | x255_3 | ztString | 255 |  | varchar
Text 4 | x255_4 | ztString | 255 |  | varchar
String | xString | ztString | 4000 |  | varchar


Work table for updating ars (Ars1)

Work table used for updating the ars table in the Arsu program. The records that shall update ars are copied to the table ars2.
The table Ars1 is created/updated when you run "Calculate EOQ/OP/safety stock", if the term Upd_Ars is set as 'No' in the xb table (inventory location).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Status | AmaseStatus | ztInteger | 5 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Safety stock days | ArtSecDagar | ztInteger | 5 |  | smallint
Safety stock level | ArtSecLager | ZtQty | 14 | 2 | decimal
Econ order quantity | Eoq | ZtQty | 14 | 2 | decimal
Estimated EOQ | EoqBer | ZtQty | 14 | 2 | decimal
Forecast model | ForecastModel | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order point | LagBestPkt | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Phase | Phase | ztInteger | 5 |  | smallint
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Work table for updating ars (Ars2)

Work table used for updating the ars table in the Arsu program. The records that shall update ars are copied to the table ars2.
The table Ars1 is created/updated when you run "Calculate EOQ/OP/safety stock", if the term Upd_Ars is set as 'No' in ars and sy1.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Status | AmaseStatus | ztInteger | 5 |  | smallint
Item no. | ArtNr | ztString | 30 |  | varchar
Safety stock days | ArtSecDagar | ztInteger | 5 |  | smallint
Safety stock level | ArtSecLager | ZtQty | 14 | 2 | decimal
Econ order quantity | Eoq | ZtQty | 14 | 2 | decimal
Forecast model | ForecastModel | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Order point | LagBestPkt | ZtQty | 14 | 2 | decimal
Inventory location | LagStalle | ztString | 2 |  | varchar
Lead time in days | LedTid | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Phase | Phase | ztInteger | 5 |  | smallint
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Work time types (xtc)

Definition of work time types that can occur when reporting activities on projects, e.g. normal time, overtime, etc. You can use the work time types for pricing against a customer and when calculating internal costs.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Text | Edit | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Cost price factor | KalkylPrisFaktor | ztFloat | 4 | 2 | float
This field is used in the table as follows: |
Wage type | Loneart | ztString | 6 |  | varchar
This field is used in the table as follows: |
Övertid | overtid | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Time type | Tidkod | ztInteger | 5 |  | smallint
Time type | Tidkodbeskr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: xtc Work time types


Work week schedule/shop reporting (vevc)

Use this table to define the weekly schedule, i.e. normal work hours for the different days of the week. If the given working hours include breaks, the breaks will automatically be excluded from reported time (needn't be stamped).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Week schedule | VeVeckoSchema | ztInteger | 5 |  | smallint
Week schedule | VeVeckoSchemaBeskr | ztString | 40 |  | varchar

    This table is the main table in the following programs:

    Program: vevc Work week schedule/shop reporting


Workflow activity instance (wpia)

The individual instances of an activity, e.g. the instance of the Enter order for customer order 1001 activity, are stored in this table. You cannot access the table from the standard menu. The information is used by the Workflow administrator for analysis and simulation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Order sequence | AcceptStatusNo | ztInteger | 3 |  | smallint
Grouping ID | AcSetId | ztString | 50 |  | varchar
Activated, date | ActiveDateTime | ztDateTime |  |  | datetime
Activity description | ActivityDescription | ztString | 255 |  | varchar
Activity number | ActivityIdentifier | ztString | 50 |  | varchar
Activity type | ActivityKind | ztInteger | 5 |  | smallint
Activity name | ActivityName | ztString | 35 |  | varchar
Activity status | ActivityStatus | ztInteger | 3 |  | smallint
Condition AND, OR | AndOr | ztInteger | 1 |  | smallint
Approval chain | AttKedja | ztInteger | 5 |  | smallint
Automation modes | AutomationMode | ztInteger | 5 |  | smallint
Cancel | ButtonReject | ztBoolean |  |  | char
Skip | ButtonSuspend | ztBoolean |  |  | char
Optional date | DataDate1 | ztDateTime |  |  | datetime
Integer 1 | DataInt1 | ztInteger | 5 |  | smallint
Integer 2 | DataInt2 | ztInteger | 5 |  | smallint
Integer 3 | DataInt3 | ztInteger | 5 |  | smallint
Command | DataVarchar1 | ztString | 255 |  | varchar
Activity | DataVarchar2 | ztString | 255 |  | varchar
Role | DataVarchar3 | ztString | 255 |  | varchar
Varchar 4 | DataVarchar4 | ztString | 255 |  | varchar
Program ID (data name) | DbProgramName | ztString | 60 |  | varchar
Activity period | Duration | ztHourWithDecimals | 10 | 4 | decimal
Activity period | DurationInSec | ZtLong | 10 |  | int
Date for escalation | EscalationDateTime | ztDateTime |  |  | datetime
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Copy activity | InstanceCopy | ztBoolean |  |  | char
No. of copies | InstanceCopyNo | ztInteger | 5 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Loop Number | LoopCount | ztInteger | 5 |  | smallint
End of loop | LoopEnd | ztBoolean |  |  | char
Start of loop | LoopStart | ztBoolean |  |  | char
Auto mail dispatch | MailAuto | ztBoolean |  |  | char
Max no. mail | MailMaxNo | ztInteger | 5 |  | smallint
Send new mail after | MailResend | ztInteger | 5 |  | smallint
Last sent | MailSendTime | ztDateTime |  |  | datetime
No. sent mail | MailSentNo | ztInteger | 5 |  | smallint
Deactivate accept button | NoAcceptButton | ztBoolean |  |  | char
Deactivate delegation button | NoDelegateButton | ztBoolean |  |  | char
Deactivate pause button | NoPauseButton | ztBoolean |  |  | char
Deactivate start button | NoStartButton | ztBoolean |  |  | char
Generate status change trigger | OnInsertAccept | ztBoolean |  |  | char
Signature | PersSign | ztString | 30 |  | varchar
E-mail signature | perssignEmail | ztString | 30 |  | varchar
E-mail signature | perssignEmail2 | ztString | 30 |  | varchar
Level approval chain | posattkedja | ztInteger | 5 |  | smallint
PreSetSign | PreSetSign | ztString | 255 |  | varchar
Priority | priority | ZtLong | 10 |  | int
Flow number | ProcessIdentifier | ZtLong | 9 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Report | ReportProgram | ztString | 255 |  | varchar
Report template | ReportTemplate | ztString | 255 |  | varchar
Alarm group | ResourceGrpTo | ztInteger | 5 |  | smallint
Resource group | ResursGrp | ztInteger | 3 |  | smallint
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Start date/time | StartDateTime | ztDateTime |  |  | datetime
No. starts | StartedNo | ztInteger | 5 |  | smallint
Pause date/time | StartWaitingTime | ztDateTime |  |  | datetime
End date/time | StopDateTime | ztDateTime |  |  | datetime
Flow number, underlying | subprocessidentifier | ZtLong | 9 |  | int
Update expression | UpdateExpression | ztString | 255 |  | varchar
Upd charge basis | UpdDeb | ztBoolean |  |  | char
Date upd chrg basis | UpdDebDatum | ztDate |  |  | datetime
Wait time in seconds | WaitedTime | ZtLong | 10 |  | int
Wait time | WaitingTime | ztHourWithDecimals | 10 | 4 | decimal
Execute | WfExecute | ztBlob | 1 |  | varchar
Control procedure | WfExecuteAfter | ztString | 8000 |  | varchar
Activity information | WfInfo | ztString | 255 |  | varchar
Activity information 2 | Wfinfo2 | ztString | 255 |  | varchar
Activity information 3 | Wfinfo3 | ztString | 255 |  | varchar
Workflow instance | wflinstance | ztString | 50 |  | varchar
Main instance | wflInstance_master | ztUniqueIdentifier | 38 |  | varchar
Top level for instance | wflinstance_TopLevel | ztString | 50 |  | varchar
Message | WfMessage | ztBlob | 1 |  | varchar
Unique ID activity instance | wpiadummyuniqueid | ztUniqueIdentifier | 50 |  | varchar
Main instance, activity | wpiadummyuniqueid_master | ztString | 50 |  | varchar
Back to activity | wpiadummyuniqueid_return | ztString | 50 |  | varchar
Unique ID activity def | wpraDummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Resource | WResourceID | ztInteger | 5 |  | smallint
x position | XPos | ZtLong | 9 |  | int
y position | YPos | ZtLong | 9 |  | int
Base/value table | ztable | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: ToDoList1 Workflow to-do list

    Program: wpia Workflow activity instance


Workflow classification (xwcl)

In this table you register the process groups/types you want in Workflow's process list.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Process group | Classification | ztInteger | 3 |  | smallint
Process group | classificationD | ztString | 35 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: xwcl Workflow classification


Workflow for claim (ClaimWorkFlow)

Voucher flow (header).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Allow adjustment of flow | ClaimChangeFlowFlag | ztBoolean |  |  | char
Internal claim | ClaimMO | ztBoolean |  |  | char
Supplier claim | ClaimPO | ztBoolean |  |  | char
Customer claim | ClaimSO | ztBoolean |  |  | char
Claim flow | ClaimWorkFlow | ZtLong | 10 |  | int
Claim flow | ClaimWorkFlowDescr | ztString | 80 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ClaimWorkFlow Workflow for claim


Workflow for claim, rows (ClaimWorkFlowLines)

Voucher flow (activities).

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Activity description | ClaimActivityDescr | ztString | 255 |  | varchar
Auto-update status when finished | ClaimAutoUpdStatWhenFinished | ztBoolean |  |  | char
Dummy activity | ClaimDummyActivity | ztBoolean |  |  | char
Previous finished at rep | ClaimPrevLineChkFinished | ztBoolean |  |  | char
Claim manager | ClaimResp | ztString | 8 |  | varchar
Ready after number of days | ClaimStepNoDays | ztInteger | 5 |  | smallint
Activity order | ClaimWFSeqNo | ztInteger | 5 |  | smallint
Claim flow | ClaimWorkFlow | ZtLong | 10 |  | int
External text | EditExt | ztBlob | 1 |  | varchar
Internal text | EditInt | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ClaimWorkFlowLines Workflow for claim, rows


Workflow installation table (wfinst)

Workflow installation log table

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Basic data installed | WfInstBasicData | ztBoolean |  |  | char
Static data installed | WfInstData | ztBoolean |  |  | char
eApproval installed | WfInsteApproval | ztBoolean |  |  | char
Log | WfInstLog | ztBlob | 1 |  | varchar
SqlAgent installed | WfInstSqlAgent | ztBoolean |  |  | char
Template installed | WfInstTemplate | ztBoolean |  |  | char
Text installed | WfInstText | ztBoolean |  |  | char

    This table is the main table in the following programs:

    Program: WorkFlowInstall Workflow installation


Workflow log instances (wpil)

Unique identity for activity log in a flow. The information is used internally by Jeeves Workflow.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Activity status | activitystatus | ztInteger | 3 |  | smallint
Approval chain | attkedja | ztInteger | 5 |  | smallint
Integer 1 | DataInt1 | ztInteger | 5 |  | smallint
Integer 2 | DataInt2 | ztInteger | 5 |  | smallint
Integer 3 | dataint3 | ztInteger | 5 |  | smallint
Command | DataVarchar1 | ztString | 255 |  | varchar
Activity | DataVarchar2 | ztString | 255 |  | varchar
Role | datavarchar3 | ztString | 255 |  | varchar
Varchar 4 | datavarchar4 | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | ftgnr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
E-mail signature | perssignemail | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Activity information | wfinfo | ztString | 255 |  | varchar
Column to log | WfLogColumnName | ztString | 100 |  | varchar
Log time | WfLogTime | ztDateTime |  |  | datetime
Unique ID activity instance | wpiadummyuniqueid | ztUniqueIdentifier | 50 |  | varchar
Unique ID activity instance | wpildummyuniqueid | ztUniqueIdentifier | 50 |  | varchar
Resource | wresourceid | ztInteger | 5 |  | smallint


Workflow process activity (wpra)

Information about the activities in the workflows you create in Jeeves Workflow is stored in this table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Limit data | AccessRestriction | ZtLong | 20 |  | int
Grouping ID | AcSetId | ztString | 50 |  | varchar
Activity description | ActivityDescription | ztString | 255 |  | varchar
Activity number | ActivityIdentifier | ztString | 50 |  | varchar
Activity type | ActivityKind | ztInteger | 5 |  | smallint
Activity name | ActivityName | ztString | 35 |  | varchar
Condition AND, OR | AndOr | ztInteger | 1 |  | smallint
Automation modes | AutomationMode | ztInteger | 5 |  | smallint
Cancel | ButtonReject | ztBoolean |  |  | char
Skip | ButtonSuspend | ztBoolean |  |  | char
Estimated cost | Cost | ZtCost | 16 | 6 | float
Current Wflw | CurrentWflw | ztBoolean |  |  | char
Program ID (data name) | DbProgramName | ztString | 60 |  | varchar
Documentation | Documentation | ztBlob | 1 |  | varchar
Activity period | Duration | ztHourWithDecimals | 10 | 4 | decimal
File name | FileName | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
ImplChoice | ImplemantationAlternative | ztInteger | 5 |  | smallint
Copy activity | InstanceCopy | ztBoolean |  |  | char
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
End of loop | LoopEnd | ztBoolean |  |  | char
Start of loop | LoopStart | ztBoolean |  |  | char
Auto mail dispatch | MailAuto | ztBoolean |  |  | char
Max no. mail | MailMaxNo | ztInteger | 5 |  | smallint
Mail Recipients | MailRecipients | ztString | 255 |  | varchar
Copy to Recipients(cc:) | MailRecipientsCopy | ztString | 255 |  | varchar
Send new mail after | MailResend | ztInteger | 5 |  | smallint
Deactivate accept button | NoAcceptButton | ztBoolean |  |  | char
Deactivate delegation button | NoDelegateButton | ztBoolean |  |  | char
Deactivate pause button | NoPauseButton | ztBoolean |  |  | char
Deactivate start button | NoStartButton | ztBoolean |  |  | char
Start at deletion | OnDelete | ztBoolean |  |  | char
Start new entry | OnInsert | ztBoolean |  |  | char
Generate status change trigger | OnInsertAccept | ztBoolean |  |  | char
Start at update | OnUpdate | ztBoolean |  |  | char
Participant | ParticipantAssignment | ztString | 35 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Priority | Priority | ZtLong | 10 |  | int
Flow number | ProcessIdentifier | ZtLong | 9 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Report | ReportProgram | ztString | 255 |  | varchar
This field is used in the table as follows: |
Report template | ReportTemplate | ztString | 255 |  | varchar
Alarm group | ResourceGrpTo | ztInteger | 5 |  | smallint
Resource group | ResursGrp | ztInteger | 3 |  | smallint
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Search filter | SearchCond | ztString | 2000 |  | varchar
Flow number, underlying | SubProcessIdentifier | ZtLong | 9 |  | int
Terms | TransitCondition | ztBlob | 35 |  | varchar
@zPrompt=null | TransitionRestrictions | ztInteger | 5 |  | smallint
Update expression | UpdateExpression | ztString | 255 |  | varchar
Wait time | WaitingTime | ztHourWithDecimals | 10 | 4 | decimal
This field is used in the table as follows: |
Execute | WfExecute | ztBlob | 1 |  | varchar
Control procedure | WfExecuteAfter | ztString | 8000 |  | varchar
Wizard ID | WizID | ztString | 40 |  | varchar
Resource | WResourceID | ztInteger | 5 |  | smallint
x position | XPos | ZtLong | 9 |  | int
y position | YPos | ZtLong | 9 |  | int
Related tables | zSubTable | ztString | 12 |  | varchar
Base/value table | ztable | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: wpra Workflow process activity


Workflow process definition (wprd)

Information about the workflows you create in Jeeves Workflow is stored in this table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Limit data | AccessRestriction | ZtLong | 20 |  | int
Backup directory | BackupFolder | ztString | 255 |  | varchar
Process group | Classification | ztInteger | 3 |  | smallint
Document type no. | DocumentType | ZtLong | 5 |  | int
File name | FileName | ztString | 255 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Time before escalation | Limit | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Priority | Priority | ZtLong | 10 |  | int
Flow description | ProcessDescription | ztString | 2000 |  | varchar
Flow number | ProcessIdentifier | ZtLong | 9 |  | int
Flow | ProcessName | ztString | 35 |  | varchar
Edition status | PublicationStatus | ztInteger | 5 |  | smallint
Entry date | RegDat | ztDate |  |  | datetime
Project manager | Responsible | ztString | 20 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Scan directory | ScanFolder | ztString | 255 |  | varchar
Sql trigger | TriggerSql | ztBlob | 1 |  | varchar
Active from date | ValidFromDate | ztDate |  |  | datetime
Active to date | ValidToDate | ztDate |  |  | datetime
Version | Version | ztString | 15 |  | varchar
Workflow directory | WfFolder | ztString | 255 |  | varchar
Wizard ID | WizID | ztString | 40 |  | varchar
Activity XML | XmlDocActivity | ztBlob | 1 |  | varchar
Process XML | XmlDocProcess | ztBlob | 1 |  | varchar
Transition XML | XmlDocTransition | ztBlob | 1 |  | varchar

    This table is the main table in the following programs:

    Program: wprd Workflow process definition


Workflow process instance (wpid)

The individual instances of a flow, e.g. the Order receipt for customer order 1001 flow, are stored in this table. You cannot access the table from the standard menu. The information is used by the Workflow administrator for analysis and simulation.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Activity status | activitystatus | ztInteger | 3 |  | smallint
Integer 1 | dataint1 | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Flow number | ProcessIdentifier | ZtLong | 9 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Workflow instance | wflinstance | ztString | 50 |  | varchar
Unique ID link | wfrowuniqueid | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: wpid Workflow process instance


Workflow resources (xwfr)

In this table, Jeeves Information Systems sets up the types of data resources used in the workflows in Workflow. You link activities to these, e.g. the Scanning supplier invoice type activity is linked to the Trigger action data resource type.

The Help for the Activity type table (xwac) describes the data resources that can be connected to the particular activity type.

The following standard records exist. Do not alter/delete:

Resource (WResourceID) | Resource (WResource) | Description
9 | Trigger action | This resource type can only be set for start activities. The resource type means that the flow will be initiated automatically by an event, e.g. when the user enters a new record or updates an existing record in a specified table (for the activity). The trigger is defined in detail for the activity definition, see example in a separate chapter.
10 | Jeeves application | This resource type is used for activities of the Run Jeeves type. You specify for the activity definition which Jeeves program is referred to.
20 | Jeeves Document | You only use this resource type for the activity type Jeeves Document, i.e. when a document in Jeeves PDM will be displayed in Jeeves Viewer.
30 | Database procedure | NOT USED!
40 | Exe program | This resource type is only used for activities of the Run Exe.pgm type, i.e. when you will use an external program like Notepad or MS Word.
50 | Run SQL Script | This resource type is used for activities of the Run SQL Script type. For these activities you enter the SQL code that will be run for the activity definition.
60 | Scan Folder | NOT USED!
70 | Accept/Reject | This resource type is used for activities of the Split type, i.e. splits where terms automatically control which route will be taken in the work flow, and for the Approve activity type when the user approves an activity manually.
80 | Send mail | This resource type is only used for activities of the Run SQL Script type and means that SQL Mail will be run. For these activities you enter the SQL code for the activity definition that specifies what will be mailed. See example in separate chapter.
85 | Macro/Record | This resource type is only used for activities of the Run Jeeves type and means that Workflow's Recorder will be used to record and then play a sequence in Jeeves. This can be used for testing, demonstration and training. See separate chapter.
90 | Dummy | This resource type is set for activities where no task or processing will be done, i.e. for activities which are entered in the work flow for design technical reasons such as start activities, split and join and subprocesses.
95 | Run Jeeves report | This resource type is only used for activities of the Report type and specifies that it is a Jeeves report that will be run. The report program and template must then be specified for the activity definition.
97 | Run Crystal | This resource type is only used for activities of the Report type and specifies that it is a Crystal Reports document that will be run.
100 | Connect tables | This resource type refers to Workflow activities for defining related tables. You do this to define the relationship between a main record and details (e.g. order rows which belong to an order header) or between two or more main records (e.g. customer order and customer invoice). See example in separate chapter.
110 | Hours |

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Activity type | activitykind | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Layer | LagLayer | ztInteger | 2 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Resource | WResource | ztString | 50 |  | varchar
Resource | WResourceID | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: xwfr Workflow resources


Workflow sql template (wftp)

Workflow SQL templates for generating SQL, the table can only be changed by Jeeves.

The following standard records exist. Do not alter/delete:

() 		Columns updated
(RowUpdatedCols)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Body | body | ztBlob | 1 |  | varchar
Foot | footer | ztBlob | 1 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Main | header | ztBlob | 1 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Initiation | prebatch | ztBlob | 1 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SQL type | sqltype | ztInteger | 5 |  | smallint


Workflow transition information (wtri)

Information about the transitions in the workflows you create in Jeeves Workflow is stored in this table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Activity number | ActivityIdentifier | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
And/Or | ocheller | ztInteger | 3 |  | smallint
Flow number | ProcessIdentifier | ZtLong | 9 |  | int
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Terms | TransitCondition | ztBlob | 35 |  | varchar
Workflow desc. | TransitDescr | ztString | 50 |  | varchar
Transition condition | TransitionKind | ztInteger | 5 |  | smallint
From | wFromActivity | ztString | 50 |  | varchar
@zPrompt=null | wIdentifier | ztString | 36 |  | varchar
Wizard ID | WizID | ztString | 40 |  | varchar
@zPrompt=null | wName | ztString | 1 |  | varchar
Sequence number | WSequence | ZtLong | 4 |  | int
To | wToActivity | ztString | 50 |  | varchar
Unique ID workflow def | wtriDummyUniqueId | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: wtri Workflow transition information


Workflow transitions, instances (wtia)

The individual instances of a flow route are stored in this table. You cannot access the table from the standard menu.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Activity number | ActivityIdentifier | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Loop Number | loopcount | ztInteger | 5 |  | smallint
And/Or | ocheller | ztInteger | 3 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Flow number | ProcessIdentifier | ZtLong | 9 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Terms | TransitCondition | ztBlob | 35 |  | varchar
Workflow desc. | TransitDescr | ztString | 50 |  | varchar
Transition condition | TransitionKind | ztInteger | 5 |  | smallint
Workflow instance | wflinstance | ztString | 50 |  | varchar
From | wFromActivity | ztString | 50 |  | varchar
@zPrompt=null | wIdentifier | ztString | 36 |  | varchar
@zPrompt=null | wName | ztString | 1 |  | varchar
Sequence number | WSequence | ZtLong | 4 |  | int
Unique ID workflow instance | wtiaDummyUniqueId | ztString | 50 |  | varchar
To | wToActivity | ztString | 50 |  | varchar
Unique ID workflow def | wtriDummyUniqueId | ztString | 50 |  | varchar


Workflow variable def. (wfdf)

Table for variable templates wf, the table can only be changed by Jeeves.

The following standard records exist. Do not alter/delete:

() 		Variable name
(variablename)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
SQL code/Variable | sqltext | ztBlob | 1 |  | varchar
SQL type | sqltype | ztInteger | 5 |  | smallint
Variable name | variablename | ztString | 50 |  | varchar


Workgroup for Person (SFR_wgrpsfp)

Contains which employees the team consists of. When a person leaves the team or change team, the record is removed from the table.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Work group | arbetslag | ztString | 6 |  | varchar
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Employee ID | perssign2 | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Status | SFRStatus | ZtLong | 10 |  | int
Clock In | SFRWorkGrpInDat | ztDateTime |  |  | datetime
Clock Out | SFRWorkGrpOutDat | ztDateTime |  |  | datetime
Indirect job/labour | veovrigtjobb | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: SFR_wgrpsfp Workgroup for Person


Workgroup for workorder (SFR_AoWgrp)

This table contains which operations that are linked to a specific team.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Work group | arbetslag | ztString | 6 |  | varchar
Created by object | CreatedByDBObject | ztString | 60 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Ref to table SFRAo | sfrconnaoid | ZtLong | 10 |  | int
Start Stamptime | SFRWORepStartDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: SFR_AoWgrp Workgroup for workorder


Workload codes (x1b)

Table of the different workload codes that can be used in the manufacturing module to control expenses of operations, for example.

The following standard records exist. Do not alter/delete:

Workload type (BelaggningsKod) | Workload type (BelaggningsKodBeskr) | Description
10 | Ready date | Originates from a specified completion date for the production order and sets a date for the order and associated operations based on information about operations, resources and capacity. The completion date refers to the date when the item is ready for shipping, i.e. at midnight on the completion date, production should be complete.
20 | Start date | Originates from a specified start date and calculates a completion date based on the information about operations, resources and capacity.
30 | Continuous allocation | This means that the system sets dates for operations based on the specified start and completion dates specified. This is also based on information about operations, resources and capacity. Should the specified date interval be too short, a new completion date will be calculated as if only a start date has been specified with planning according to this.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Workload type | BelaggningsKod | ztInteger | 2 |  | smallint
Workload type | BelaggningsKodBeskr | ztString | 50 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: xX1b Workload types


Workload/day, flow group (bao2)

Data about the workload (by day) of the flow group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader |  |  |  | @DataType=NULL
Operations start date | AoStartDat |  |  |  | @DataType=NULL
Capacity | ArbKapacitet |  |  |  | @DataType=NULL
Available time | BelaggningLedig |  |  |  | @DataType=NULL
Avail accum time | BelaggningLedigAck |  |  |  | @DataType=NULL
Flow group | FlodesGrupp |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Week number | KalenderVecka |  |  |  | @DataType=NULL
Period | Period |  |  |  | @DataType=NULL
Fiscal year | RedovisnAr |  |  |  | @DataType=NULL
Setup time for op | StallTid |  |  |  | @DataType=NULL
Unit time | StyckTid |  |  |  | @DataType=NULL
Source | UlbpTyp |  |  |  | @DataType=NULL


Workload/day, flow group (baof)

Data about the workload (by day) of the flow group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Operations start date | AoStartDat | ztDate |  |  | datetime
Capacity | ArbKapacitet | ztFloat | 15 | 2 | float
Available time | BelaggningLedig | ztFloat | 15 | 2 | float
Avail accum time | BelaggningLedigAck | ztFloat | 15 | 2 | float
Flow group | FlodesGrupp | ztString | 5 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Week number | KalenderVecka | ztInteger | 2 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Source | UlbpTyp | ztString | 2 |  | varchar


Workload/day, manufacturing group (bao1)

Data about the workload (by day) of the manufacturing group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader |  |  |  | @DataType=NULL
Operations start date | AoStartDat |  |  |  | @DataType=NULL
Capacity | ArbKapacitet |  |  |  | @DataType=NULL
Available time | BelaggningLedig |  |  |  | @DataType=NULL
Avail accum time | BelaggningLedigAck |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Week number | KalenderVecka |  |  |  | @DataType=NULL
Period | Period |  |  |  | @DataType=NULL
Manufacturing group | ProdGr |  |  |  | @DataType=NULL
Fiscal year | RedovisnAr |  |  |  | @DataType=NULL
Setup time for op | StallTid |  |  |  | @DataType=NULL
Unit time | StyckTid |  |  |  | @DataType=NULL
Source | UlbpTyp |  |  |  | @DataType=NULL


Workload/day, week, period manufacturing group (baop)

Data about the workload (by day) of the manufacturing group.
*** Under construction ***

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader | ZtLong | 10 |  | int
Operations start date | AoStartDat | ztDate |  |  | datetime
Capacity | ArbKapacitet | ztFloat | 15 | 2 | float
Available time | BelaggningLedig | ztFloat | 15 | 2 | float
Avail accum time | BelaggningLedigAck | ztFloat | 15 | 2 | float
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Week number | KalenderVecka | ztInteger | 2 |  | smallint
Period | Period | ztInteger | 4 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Manufacturing group | ProdGr | ztString | 5 |  | varchar
Fiscal year | RedovisnAr | ztInteger | 4 |  | smallint
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Setup time for op | StallTid | ztOpTime | 9 | 4 | float
Unit time | StyckTid | ztOpTime | 9 | 4 | float
Source | UlbpTyp | ztString | 2 |  | varchar


Workload/day, work team (bao3)

Data about the workload (by day) of the work group.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
No. of rows | AntalRader |  |  |  | @DataType=NULL
Operations start date | AoStartDat |  |  |  | @DataType=NULL
Work group | ArbetsLag |  |  |  | @DataType=NULL
Capacity | ArbKapacitet |  |  |  | @DataType=NULL
Available time | BelaggningLedig |  |  |  | @DataType=NULL
Avail accum time | BelaggningLedigAck |  |  |  | @DataType=NULL
Company | ForetagKod |  |  |  | @DataType=NULL
Week number | KalenderVecka |  |  |  | @DataType=NULL
Period | Period |  |  |  | @DataType=NULL
Fiscal year | RedovisnAr |  |  |  | @DataType=NULL
Setup time for op | StallTid |  |  |  | @DataType=NULL
Unit time | StyckTid |  |  |  | @DataType=NULL
Source | UlbpTyp |  |  |  | @DataType=NULL


Worktable LPlanUt (Items without demand) (wlpl)

Alphanumeric code for the item, BOM, fixed asset, or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Purchasing manager | InkHandl | ztString | 6 |  | varchar
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Ord. no., del.plan out | LevPlanBestNr | ZtLong | 6 |  | int
Ord. row no., del.plan out | LevPlanBestRadNr | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Planning manager | PlanAnsv | ztString | 6 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime


Worktable Payment against advance (winb)

Customer invoice number.

The number is retrieved from the number series for the invoice type in question which is entered in one of the following programs.

For invoices created in the order routine:
- Order types (xx6) or
- Invoice types (xxz2) or
- if applied, from the number series for the invoice number series group and invoice type in question in Invoice No. Series Group (xz2g)

For invoices manually entered in the accounts receivable:
- Invoice types (xxz2) or
- if applied, from the number series for the invoice number series group and invoice type in question in Invoice No. Series Group (xz2g)

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Sequence number | DummyUniqueId | ztUniqueIdentifier | 38 |  | varchar
Invoice no. | FaktNr | Jeeves_InvNo | 9 |  | bigint
Invoice no., advance | FaktNrForskott | Jeeves_InvNo | 9 |  | bigint
Invoice total incl tax | FaktTotMMoms | ZtBaseCurrAmount | 14 | 2 | money
Invoice total excl tax | FaktTotUMoms | ZtBaseCurrAmount | 14 | 2 | money
Company | ForetagKod | ztInteger | 4 |  | smallint
Company ID | FtgNr | ztCompanyNo | 20 |  | varchar
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Urspr valutakurs | OldValKurs | ZtCurrencyRate | 15 | 7 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Row | RadPos | ZtLong | 10 |  | int
Entry date | RegDat | ztDate |  |  | datetime
Remaining to pay | RestBelFakt | ZtBaseCurrAmount | 14 | 2 | money
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Currency | ValKod | ztString | 3 |  | varchar
Exchange rate | ValKurs | ZtCurrencyRate | 15 | 7 | decimal
Outst invc amt, curr | vbFaktRest | ztMoney | 14 | 2 | money


Worktable PrlSar (Items -> Price list) (warl)

Alphanumeric code for the item, BOM, fixed asset, or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar


XML data from Jeeves (header) (XmlDataOutTran)

Xmldataout from Jeeves.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Configurator model ID | ModelId | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Transaction Id | TranId | ZtHugeInt | 20 |  | bigint
Unique ID (1) | Uid1 | ztString | 50 |  | varchar
Unique ID (2) | Uid2 | ztString | 50 |  | varchar
Unique ID (3) | Uid3 | ztString | 50 |  | varchar
Unique ID (4) | Uid4 | ztString | 50 |  | varchar
Unique ID (5) | Uid5 | ztString | 50 |  | varchar
Unique ID (6) | Uid6 | ztString | 50 |  | varchar
Error text | ValidationError | ztBlob | 1024 |  | varchar
Xml data status | XmlDataStatus | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: XmlDataOutTran XML data from Jeeves (header)


XML data from Jeeves (rows) (XmlDataOut)

Xmldataout from Jeeves.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Insert Order | InsertOrder | ztInteger | 1000 |  | smallint
Key part 1 | Key1 | ztString | 50 |  | varchar
Key part 2 | Key2 | ztString | 50 |  | varchar
Key part 3 | Key3 | ztString | 50 |  | varchar
Key part 4 | Key4 | ztString | 50 |  | varchar
Key part 5 | Key5 | ztString | 50 |  | varchar
Configurator model ID | ModelId | ztString | 60 |  | varchar
Order of Grouping | OrdOfGroup1 | ZtDecimal73 | 16 | 9 | decimal
Order of Grouping | OrdOfGroup2 | ZtDecimal73 | 16 | 9 | decimal
Order of Grouping | OrdOfGroup3 | ZtDecimal73 | 16 | 9 | decimal
Order of Grouping | OrdOfGroup4 | ZtDecimal73 | 16 | 9 | decimal
Order of Grouping | OrdOfGroup5 | ZtDecimal73 | 16 | 9 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sort order | SortOrder | ztInteger | 5 |  | smallint
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Table grouping | TableGroupOrder | ztInteger | 5 |  | smallint
Transaction Id | TranId | ZtHugeInt | 20 |  | int
Xml data status | XmlDataStatus | ztInteger | 5 |  | smallint
Nodeindex | XmlNodeIndex | ztInteger | 5 |  | smallint
Nodename | XmlNodeName | ztString | 128 |  | varchar
Nodetype | XmlNodeType | ztInteger | 5 |  | smallint
Nodevalue | XmlNodeValue | ztString | 1600 |  | varchar
Parent nodeindex | XmlParentNodeIndex | ztInteger | 5 |  | smallint
Top parent nodeindex | XmlTopParentNodeIndex | ztInteger | 5 |  | smallint
XPath | XmlXPath | ztString | 1024 |  | varchar
XPath in Jeeves | XmlXPathJvs | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: XmlDataOut XML data from Jeeves (rows)


XML data to Jeeves (header) (XmlDataInTran)

Xml data in to Jeeves.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Transaction Id | TranId | ZtHugeInt | 20 |  | bigint
Xml data status | XmlDataStatus | ztInteger | 5 |  | smallint

    This table is the main table in the following programs:

    Program: XmlDataInTran XML data to Jeeves (header)


XML data to Jeeves (rows) (XmlDataIn)

Xml data to Jeeves

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Company | ForetagKod | ztInteger | 4 |  | smallint
Insert Order | InsertOrder | ztInteger | 1000 |  | smallint
Key part 1 | Key1 | ztString | 50 |  | varchar
Key part 2 | Key2 | ztString | 50 |  | varchar
Key part 3 | Key3 | ztString | 50 |  | varchar
Key part 4 | Key4 | ztString | 50 |  | varchar
Key part 5 | Key5 | ztString | 50 |  | varchar
Configurator model ID | ModelId | ztString | 60 |  | varchar
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Sort order | SortOrder | ztInteger | 5 |  | smallint
Identity | SQLIDENTITY | ZtLong | 10 |  | int
Table grouping | TableGroupOrder | ztInteger | 5 |  | smallint
Transaction Id | TranId | ZtHugeInt | 20 |  | bigint
Xml data status | XmlDataStatus | ztInteger | 5 |  | smallint
Nodeindex | XmlNodeIndex | ztInteger | 5 |  | smallint
Nodename | XmlNodeName | ztString | 128 |  | varchar
Nodetype | XmlNodeType | ztInteger | 5 |  | smallint
Nodevalue | XmlNodeValue | ztString | 1600 |  | varchar
Parent nodeindex | XmlParentNodeIndex | ztInteger | 5 |  | smallint
Top parent nodeindex | XmlTopParentNodeIndex | ztInteger | 5 |  | smallint
XPath | XmlXPath | ztString | 1024 |  | varchar
XPath in Jeeves | XmlXPathJvs | ztString | 255 |  | varchar

    This table is the main table in the following programs:

    Program: XmlDataIn XML data to Jeeves (rows)


XML definition for XML parser (XmlType)

Definitiontable for xml-settings.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Company | ForetagKod | ztInteger | 4 |  | smallint
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Close Tacton and save | TactonAutoSave | ztBoolean |  |  | char
Dump data to modelfile | TactonDumpData | ztBoolean |  |  | char
Save button first step | TactonSaveButton | ztBoolean |  |  | char
Save xml to log | XmlDocSave | ztBoolean |  |  | char
Type of xml | XmlFileType | ztInteger | 5 |  | smallint
Xml parser mode | XmlParserMode | ztInteger | 5 |  | smallint
Special parsing | XmlPreParse | ztInteger | 5 |  | smallint
Top node index created from | XmlTopNodeIndex | ztInteger | 5 |  | smallint
XML Type | XmlType | ztInteger | 5 |  | smallint
Description | XmlTypeDescr | ztString | 50 |  | varchar

    This table is the main table in the following programs:

    Program: XmlType Xml definition for the xml parser.


Xml messages (XmlConfirmTran)

Program/table for storage of confirmations regarding the transmission of XML files between Jeeves and Astro warehouse management.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Installation Id, Astro | AstroInstallationId | ztInteger | 5 |  | smallint
Description | Description | ztString | 255 |  | varchar
Detailed description | DetDescription | ztBlob | 1600 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
From Astro | FromAstro | ztBoolean |  |  | char
Rule no | ICTRuleNumber | ztInteger | 6 |  | smallint
Original company | IntrnCoNoOrigin | ztInteger | 5 |  | smallint
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime
Severity | SeverityCode | ztchar | 1 |  | char
Success | SuccessCode | ztBoolean |  |  | char
Transaction Id | TranId | ZtHugeInt | 20 |  | bigint

    This table is the main table in the following programs:

    Program: XmlConfirmTran Xml messages


Yield when manufacturing the item (ItemManufYield)

Alphanumeric code for the item, BOM, fixed asset, or the like.

The table consists of the following fields:

Prompt | Data name | Jeeves data type | Number of characters | Decimal places | SQL data type
Item no. | ArtNr | ztString | 30 |  | varchar
Company | ForetagKod | ztInteger | 4 |  | smallint
Manuf yield % | ManufYieldPercent | ZtDecimal73 | 8 | 3 | decimal
Quantity limit | ManufYieldQtyLimit | ZtQty | 14 | 2 | decimal
Signature | PersSign | ztString | 30 |  | varchar
Entry date | RegDat | ztDate |  |  | datetime
Created by | RowCreatedBy | ztString | 30 |  | varchar
Created date/time | RowCreatedDt | ztDateTime |  |  | datetime
Updated by | RowUpdatedBy | ztString | 30 |  | varchar
Columns updated | RowUpdatedCols | ztString | 255 |  | varchar
Updated date/time | RowUpdatedDt | ztDateTime |  |  | datetime

    This table is the main table in the following programs:

    Program: ItemManufYield ItemManufYield